AT.MIN Namespace

[image]

One of William Foster's Class Libraries
AT.MIN Namespace
Send Feedback

[Missing <summary> documentation for "N:AT.MIN"]

Classes

 | Class | Description
Public class | Tools |

Send comments on this topic to bill@software-imagination.com

(C) 2011 by William P. Foster, all rights reserved.


Tools Class

[image]

One of William Foster's Class Libraries
Tools Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:AT.MIN.Tools"]

Namespace: AT.MIN
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static class Tools
Visual Basic
Public NotInheritable Class Tools
Visual C++
public ref class Tools abstract sealed

Inheritance Hierarchy

System..::..Object
AT.MIN..::..Tools

See Also

Tools Members
AT.MIN Namespace


Tools Members

[image] [image]

One of William Foster's Class Libraries
Tools Members
Tools Class Methods See Also Send Feedback

The Tools type exposes the following members.

Methods

Name | Description
fprintf |
IsNumericType | Determines whether the specified value is of numeric type.
IsPositive | Determines whether the specified value is positive.
printf |
ReplaceMetaChars | Replaces the string representations of meta chars with their corresponding character values.
sprintf |
ToInteger | Converts the specified values boxed type to its correpsonding integer type.
ToUnsigned | Converts the specified values boxed type to its correpsonding unsigned type.
UnboxToLong |

See Also

Tools Class
AT.MIN Namespace


Tools Methods

[image] [image]

One of William Foster's Class Libraries
Tools Methods
Tools Class See Also Send Feedback

The Tools type exposes the following members.

Methods

Name | Description
fprintf |
IsNumericType | Determines whether the specified value is of numeric type.
IsPositive | Determines whether the specified value is positive.
printf |
ReplaceMetaChars | Replaces the string representations of meta chars with their corresponding character values.
sprintf |
ToInteger | Converts the specified values boxed type to its correpsonding integer type.
ToUnsigned | Converts the specified values boxed type to its correpsonding unsigned type.
UnboxToLong |

See Also

Tools Class
AT.MIN Namespace


fprintf Method

[image]

One of William Foster's Class Libraries
Tools..::..fprintf Method
Tools Class See Also Send Feedback

[Missing <summary> documentation for "M:AT.MIN.Tools.fprintf(System.IO.TextWriter,System.String,System.Object[])"]

Namespace: AT.MIN
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void fprintf(
    TextWriter Destination,
    string Format,
    params Object[] Parameters
)
Visual Basic
Public Shared Sub fprintf ( _
    Destination As TextWriter, _
    Format As String, _
    ParamArray Parameters As Object() _
)
Visual C++
public:
static void fprintf(
    TextWriter^ Destination,
    String^ Format,
    ... array<Object^>^ Parameters
)

Parameters

Destination
Type: System.IO..::..TextWriter

[Missing <param name="Destination"/> documentation for "M:AT.MIN.Tools.fprintf(System.IO.TextWriter,System.String,System.Object[])"]

Format
Type: System..::..String

[Missing <param name="Format"/> documentation for "M:AT.MIN.Tools.fprintf(System.IO.TextWriter,System.String,System.Object[])"]

Parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="Parameters"/> documentation for "M:AT.MIN.Tools.fprintf(System.IO.TextWriter,System.String,System.Object[])"]

See Also

Tools Class
AT.MIN Namespace


IsNumericType Method

[image]

One of William Foster's Class Libraries
Tools..::..IsNumericType Method
Tools Class See Also Send Feedback
Determines whether the specified value is of numeric type.

Namespace: AT.MIN
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool IsNumericType(
    Object o
)
Visual Basic
Public Shared Function IsNumericType ( _
    o As Object _
) As Boolean
Visual C++
public:
static bool IsNumericType(
    Object^ o
)

Parameters

o
Type: System..::..Object
The object to check.

Return Value

true if o is a numeric type; otherwise, false.

See Also

Tools Class
AT.MIN Namespace


IsPositive Method

[image]

One of William Foster's Class Libraries
Tools..::..IsPositive Method
Tools Class See Also Send Feedback
Determines whether the specified value is positive.

Namespace: AT.MIN
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool IsPositive(
    Object Value,
    bool ZeroIsPositive
)
Visual Basic
Public Shared Function IsPositive ( _
    Value As Object, _
    ZeroIsPositive As Boolean _
) As Boolean
Visual C++
public:
static bool IsPositive(
    Object^ Value,
    bool ZeroIsPositive
)

Parameters

Value
Type: System..::..Object
The value.
ZeroIsPositive
Type: System..::..Boolean
if set to true treats 0 as positive.

Return Value

true if the specified value is positive; otherwise, false.

See Also

Tools Class
AT.MIN Namespace


printf Method

[image]

One of William Foster's Class Libraries
Tools..::..printf Method
Tools Class See Also Send Feedback

[Missing <summary> documentation for "M:AT.MIN.Tools.printf(System.String,System.Object[])"]

Namespace: AT.MIN
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void printf(
    string Format,
    params Object[] Parameters
)
Visual Basic
Public Shared Sub printf ( _
    Format As String, _
    ParamArray Parameters As Object() _
)
Visual C++
public:
static void printf(
    String^ Format,
    ... array<Object^>^ Parameters
)

Parameters

Format
Type: System..::..String

[Missing <param name="Format"/> documentation for "M:AT.MIN.Tools.printf(System.String,System.Object[])"]

Parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="Parameters"/> documentation for "M:AT.MIN.Tools.printf(System.String,System.Object[])"]

See Also

Tools Class
AT.MIN Namespace


ReplaceMetaChars Method

[image]

One of William Foster's Class Libraries
Tools..::..ReplaceMetaChars Method
Tools Class See Also Send Feedback
Replaces the string representations of meta chars with their corresponding character values.

Namespace: AT.MIN
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static string ReplaceMetaChars(
    string input
)
Visual Basic
Public Shared Function ReplaceMetaChars ( _
    input As String _
) As String
Visual C++
public:
static String^ ReplaceMetaChars(
    String^ input
)

Parameters

input
Type: System..::..String
The input.

Return Value

A string with all string meta chars are replaced

See Also

Tools Class
AT.MIN Namespace


sprintf Method

[image]

One of William Foster's Class Libraries
Tools..::..sprintf Method
Tools Class See Also Send Feedback

[Missing <summary> documentation for "M:AT.MIN.Tools.sprintf(System.String,System.Object[])"]

Namespace: AT.MIN
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static string sprintf(
    string Format,
    params Object[] Parameters
)
Visual Basic
Public Shared Function sprintf ( _
    Format As String, _
    ParamArray Parameters As Object() _
) As String
Visual C++
public:
static String^ sprintf(
    String^ Format,
    ... array<Object^>^ Parameters
)

Parameters

Format
Type: System..::..String

[Missing <param name="Format"/> documentation for "M:AT.MIN.Tools.sprintf(System.String,System.Object[])"]

Parameters
Type: array< System..::..Object >[]()[][]

[Missing <param name="Parameters"/> documentation for "M:AT.MIN.Tools.sprintf(System.String,System.Object[])"]

Return Value

[Missing <returns> documentation for "M:AT.MIN.Tools.sprintf(System.String,System.Object[])"]

See Also

Tools Class
AT.MIN Namespace


ToInteger Method

[image]

One of William Foster's Class Libraries
Tools..::..ToInteger Method
Tools Class See Also Send Feedback
Converts the specified values boxed type to its correpsonding integer type.

Namespace: AT.MIN
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Object ToInteger(
    Object Value,
    bool Round
)
Visual Basic
Public Shared Function ToInteger ( _
    Value As Object, _
    Round As Boolean _
) As Object
Visual C++
public:
static Object^ ToInteger(
    Object^ Value,
    bool Round
)

Parameters

Value
Type: System..::..Object
The value.
Round
Type: System..::..Boolean

[Missing <param name="Round"/> documentation for "M:AT.MIN.Tools.ToInteger(System.Object,System.Boolean)"]

Return Value

A boxed numeric object whos type is an integer type.

See Also

Tools Class
AT.MIN Namespace


ToUnsigned Method

[image]

One of William Foster's Class Libraries
Tools..::..ToUnsigned Method
Tools Class See Also Send Feedback
Converts the specified values boxed type to its correpsonding unsigned type.

Namespace: AT.MIN
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Object ToUnsigned(
    Object Value
)
Visual Basic
Public Shared Function ToUnsigned ( _
    Value As Object _
) As Object
Visual C++
public:
static Object^ ToUnsigned(
    Object^ Value
)

Parameters

Value
Type: System..::..Object
The value.

Return Value

A boxed numeric object whos type is unsigned.

See Also

Tools Class
AT.MIN Namespace


UnboxToLong Method

[image]

One of William Foster's Class Libraries
Tools..::..UnboxToLong Method
Tools Class See Also Send Feedback

[Missing <summary> documentation for "M:AT.MIN.Tools.UnboxToLong(System.Object,System.Boolean)"]

Namespace: AT.MIN
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static long UnboxToLong(
    Object Value,
    bool Round
)
Visual Basic
Public Shared Function UnboxToLong ( _
    Value As Object, _
    Round As Boolean _
) As Long
Visual C++
public:
static long long UnboxToLong(
    Object^ Value,
    bool Round
)

Parameters

Value
Type: System..::..Object

[Missing <param name="Value"/> documentation for "M:AT.MIN.Tools.UnboxToLong(System.Object,System.Boolean)"]

Round
Type: System..::..Boolean

[Missing <param name="Round"/> documentation for "M:AT.MIN.Tools.UnboxToLong(System.Object,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:AT.MIN.Tools.UnboxToLong(System.Object,System.Boolean)"]

See Also

Tools Class
AT.MIN Namespace


El Namespace

[image]

One of William Foster's Class Libraries
El Namespace
Send Feedback

[Missing <summary> documentation for "N:El"]

Classes

 | Class | Description
Public class | Allocation |
Public class | ApplicationBase |
Public class | Array<(Of <(<'baseClass>)>)> |
Public class | Assert |
Public class | Assert..::..FailedException |
Public class | CBfc_Angle |
Public class | CBfc_File |
Public class | Distance |
Public class | Exception |
Public class | Filename |
Public class | Generic |
Public class | LinkedList |
Public class | LinkedObject |
Public class | MemPtr |
Public class | PointSpaceTime |
Public class | PointTime |
Public class | Position3d |
Public class | Range2d |
Public class | Range2dU |
Public class | Rect2d |
Public class | Rect2dU |
Public class | Registry |
Public class | SEl_Character |
Public class | Size2d |
Public class | Size2dU |
Public class | Stream |
Public class | StreamSource |
Public class | StreamSource_File |
Public class | StreamSource_Memory |
Public class | StreamThreadInfo |
Public class | STRING |
Public class | StringBuffer |
Public class | STRINGEnumerator |
Public class | STRINGEX |
Public class | StringExtension |
Public class | StringMap2d |
Public class | Value |

Enumerations

 | Enumeration | Description
Public enumeration | E_DistanceUnits |
Public enumeration | E_RangeType |
Public enumeration | Exception..::..EBFC_Exception |
Public enumeration | Generic..::..OSType |
Public enumeration | Stream..::..EAccessMode |
Public enumeration | StreamSource..::..EBFC_StreamSource |


Allocation Class

[image]

One of William Foster's Class Libraries
Allocation Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Allocation"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Allocation : MemPtr
Visual Basic
Public Class Allocation _
    Inherits MemPtr
Visual C++
public ref class Allocation : public MemPtr

Inheritance Hierarchy

System..::..Object
El..::..MemPtr
El..::..Allocation

See Also

Allocation Members
El Namespace


Allocation Members

[image] [image]

One of William Foster's Class Libraries
Allocation Members
Allocation Class Constructors Methods Fields See Also Send Feedback

The Allocation type exposes the following members.

Constructors

 | Name | Description
Public method | Allocation()()()() | Initializes a new instance of the Allocation class
Public method | Allocation(array<Byte>[]()[][]) | Initializes a new instance of the Allocation class
Public method | Allocation(Allocation) | Initializes a new instance of the Allocation class

Methods

 | Name | Description
Public method | Delete | (Overrides MemPtr..::..Delete()()()().)
Public method | Dup |
Public method | EnsureBytesAllocated |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | Free |
Public method | GetBytesAllocated |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadBytes |
Public method | ReleaseMemoryAssignment |
Public method | SetBytesAllocated |
Public method | SetToData |
Public method | SetToMemory |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_array | (Inherited from MemPtr.)
Public field | m_index | (Inherited from MemPtr.)

See Also

Allocation Class


Allocation Constructor

[image] [image]

One of William Foster's Class Libraries
Allocation Constructor
Allocation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Allocation()()()() | Initializes a new instance of the Allocation class
Public method | Allocation(array<Byte>[]()[][]) | Initializes a new instance of the Allocation class
Public method | Allocation(Allocation) | Initializes a new instance of the Allocation class

See Also

Allocation Class
Allocation Members


Allocation Constructor

[image]

One of William Foster's Class Libraries
Allocation Constructor
Allocation Class See Also Send Feedback
Initializes a new instance of the Allocation class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Allocation()
Visual Basic
Public Sub New
Visual C++
public:
Allocation()

See Also

Allocation Class
Allocation Overload


Allocation Constructor (Byte[])

[image]

One of William Foster's Class Libraries
Allocation Constructor (array<Byte>[]()[][])
Allocation Class See Also Send Feedback
Initializes a new instance of the Allocation class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Allocation(
    byte[] bytes
)
Visual Basic
Public Sub New ( _
    bytes As Byte() _
)
Visual C++
public:
Allocation(
    array<unsigned char>^ bytes
)

Parameters

bytes
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bytes"/> documentation for "M:El.Allocation.#ctor(System.Byte[])"]

See Also

Allocation Class
Allocation Overload


Allocation Constructor (Allocation)

[image]

One of William Foster's Class Libraries
Allocation Constructor (Allocation)
Allocation Class See Also Send Feedback
Initializes a new instance of the Allocation class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Allocation(
    Allocation reference
)
Visual Basic
Public Sub New ( _
    reference As Allocation _
)
Visual C++
public:
Allocation(
    Allocation^ reference
)

Parameters

reference
Type: El..::..Allocation

[Missing <param name="reference"/> documentation for "M:El.Allocation.#ctor(El.Allocation)"]

See Also

Allocation Class
Allocation Overload


Allocation Fields

[image] [image]

One of William Foster's Class Libraries
Allocation Fields
Allocation Class See Also Send Feedback

The Allocation type exposes the following members.

Fields

 | Name | Description
Public field | m_array | (Inherited from MemPtr.)
Public field | m_index | (Inherited from MemPtr.)

See Also

Allocation Class


Allocation Methods

[image] [image]

One of William Foster's Class Libraries
Allocation Methods
Allocation Class See Also Send Feedback

The Allocation type exposes the following members.

Methods

 | Name | Description
Public method | Delete | (Overrides MemPtr..::..Delete()()()().)
Public method | Dup |
Public method | EnsureBytesAllocated |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | Free |
Public method | GetBytesAllocated |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadBytes |
Public method | ReleaseMemoryAssignment |
Public method | SetBytesAllocated |
Public method | SetToData |
Public method | SetToMemory |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Allocation Class


Delete Method

[image]

One of William Foster's Class Libraries
Allocation..::..Delete Method
Allocation Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Allocation.Delete"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override void Delete()
Visual Basic
Public Overrides Sub Delete
Visual C++
public:
virtual void Delete() override

See Also

Allocation Class


Dup Method

[image]

One of William Foster's Class Libraries
Allocation..::..Dup Method
Allocation Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Allocation.Dup"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual Allocation Dup()
Visual Basic
Public Overridable Function Dup As Allocation
Visual C++
public:
virtual Allocation^ Dup()

Return Value

[Missing <returns> documentation for "M:El.Allocation.Dup"]

See Also

Allocation Class


EnsureBytesAllocated Method

[image]

One of William Foster's Class Libraries
Allocation..::..EnsureBytesAllocated Method
Allocation Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Allocation.EnsureBytesAllocated(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool EnsureBytesAllocated(
    uint u_byteLength
)
Visual Basic
Public Function EnsureBytesAllocated ( _
    u_byteLength As UInteger _
) As Boolean
Visual C++
public:
bool EnsureBytesAllocated(
    unsigned int u_byteLength
)

Parameters

u_byteLength
Type: System..::..UInt32

[Missing <param name="u_byteLength"/> documentation for "M:El.Allocation.EnsureBytesAllocated(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.Allocation.EnsureBytesAllocated(System.UInt32)"]

See Also

Allocation Class


Finalize Method

[image]

One of William Foster's Class Libraries
Allocation..::..Finalize Method
Allocation Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Allocation.Finalize"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Allocation Class


Free Method

[image]

One of William Foster's Class Libraries
Allocation..::..Free Method
Allocation Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Allocation.Free"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual void Free()
Visual Basic
Public Overridable Sub Free
Visual C++
public:
virtual void Free()

See Also

Allocation Class


GetBytesAllocated Method

[image]

One of William Foster's Class Libraries
Allocation..::..GetBytesAllocated Method
Allocation Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Allocation.GetBytesAllocated"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public ulong GetBytesAllocated()
Visual Basic
Public Function GetBytesAllocated As ULong
Visual C++
public:
unsigned long long GetBytesAllocated()

Return Value

[Missing <returns> documentation for "M:El.Allocation.GetBytesAllocated"]

See Also

Allocation Class


ReadBytes Method

[image]

One of William Foster's Class Libraries
Allocation..::..ReadBytes Method
Allocation Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Allocation.ReadBytes(El.MemPtr,System.UInt32,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool ReadBytes(
    MemPtr dstMem,
    uint uCount,
    out uint o_uBytesRead
)
Visual Basic
Public Function ReadBytes ( _
    dstMem As MemPtr, _
    uCount As UInteger, _
    <OutAttribute> ByRef o_uBytesRead As UInteger _
) As Boolean
Visual C++
public:
bool ReadBytes(
    MemPtr^ dstMem,
    unsigned int uCount,
    [OutAttribute] unsigned int% o_uBytesRead
)

Parameters

dstMem
Type: El..::..MemPtr

[Missing <param name="dstMem"/> documentation for "M:El.Allocation.ReadBytes(El.MemPtr,System.UInt32,System.UInt32@)"]

uCount
Type: System..::..UInt32

[Missing <param name="uCount"/> documentation for "M:El.Allocation.ReadBytes(El.MemPtr,System.UInt32,System.UInt32@)"]

o_uBytesRead
Type: System..::..UInt32 %

[Missing <param name="o_uBytesRead"/> documentation for "M:El.Allocation.ReadBytes(El.MemPtr,System.UInt32,System.UInt32@)"]

Return Value

[Missing <returns> documentation for "M:El.Allocation.ReadBytes(El.MemPtr,System.UInt32,System.UInt32@)"]

See Also

Allocation Class


ReleaseMemoryAssignment Method

[image]

One of William Foster's Class Libraries
Allocation..::..ReleaseMemoryAssignment Method
Allocation Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Allocation.ReleaseMemoryAssignment"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void ReleaseMemoryAssignment()
Visual Basic
Public Sub ReleaseMemoryAssignment
Visual C++
public:
void ReleaseMemoryAssignment()

See Also

Allocation Class


SetBytesAllocated Method

[image]

One of William Foster's Class Libraries
Allocation..::..SetBytesAllocated Method
Allocation Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Allocation.SetBytesAllocated(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool SetBytesAllocated(
    uint u_byteLength
)
Visual Basic
Public Function SetBytesAllocated ( _
    u_byteLength As UInteger _
) As Boolean
Visual C++
public:
bool SetBytesAllocated(
    unsigned int u_byteLength
)

Parameters

u_byteLength
Type: System..::..UInt32

[Missing <param name="u_byteLength"/> documentation for "M:El.Allocation.SetBytesAllocated(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.Allocation.SetBytesAllocated(System.UInt32)"]

See Also

Allocation Class


SetToData Method

[image]

One of William Foster's Class Libraries
Allocation..::..SetToData Method
Allocation Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Allocation.SetToData(System.Byte[],System.UInt64)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool SetToData(
    byte[] p_data,
    ulong ul_memoryByteLength
)
Visual Basic
Public Function SetToData ( _
    p_data As Byte(), _
    ul_memoryByteLength As ULong _
) As Boolean
Visual C++
public:
bool SetToData(
    array<unsigned char>^ p_data,
    unsigned long long ul_memoryByteLength
)

Parameters

p_data
Type: array< System..::..Byte >[]()[][]

[Missing <param name="p_data"/> documentation for "M:El.Allocation.SetToData(System.Byte[],System.UInt64)"]

ul_memoryByteLength
Type: System..::..UInt64

[Missing <param name="ul_memoryByteLength"/> documentation for "M:El.Allocation.SetToData(System.Byte[],System.UInt64)"]

Return Value

[Missing <returns> documentation for "M:El.Allocation.SetToData(System.Byte[],System.UInt64)"]

See Also

Allocation Class


SetToMemory Method

[image]

One of William Foster's Class Libraries
Allocation..::..SetToMemory Method
Allocation Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Allocation.SetToMemory(System.Byte[],System.UInt64)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool SetToMemory(
    byte[] p_memory,
    ulong ul_memoryByteLength
)
Visual Basic
Public Function SetToMemory ( _
    p_memory As Byte(), _
    ul_memoryByteLength As ULong _
) As Boolean
Visual C++
public:
bool SetToMemory(
    array<unsigned char>^ p_memory,
    unsigned long long ul_memoryByteLength
)

Parameters

p_memory
Type: array< System..::..Byte >[]()[][]

[Missing <param name="p_memory"/> documentation for "M:El.Allocation.SetToMemory(System.Byte[],System.UInt64)"]

ul_memoryByteLength
Type: System..::..UInt64

[Missing <param name="ul_memoryByteLength"/> documentation for "M:El.Allocation.SetToMemory(System.Byte[],System.UInt64)"]

Return Value

[Missing <returns> documentation for "M:El.Allocation.SetToMemory(System.Byte[],System.UInt64)"]

See Also

Allocation Class


ApplicationBase Class

[image]

One of William Foster's Class Libraries
ApplicationBase Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.ApplicationBase"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class ApplicationBase
Visual Basic
Public Class ApplicationBase
Visual C++
public ref class ApplicationBase

Inheritance Hierarchy

System..::..Object
El..::..ApplicationBase

See Also

ApplicationBase Members


ApplicationBase Members

[image] [image]

One of William Foster's Class Libraries
ApplicationBase Members
ApplicationBase Class Constructors Methods Fields See Also Send Feedback

The ApplicationBase type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationBase | Initializes a new instance of the ApplicationBase class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResourceFolder |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_args |
Protected field | m_BaseFolder |
Protected field | m_ResourceFolder |

See Also

ApplicationBase Class


ApplicationBase Constructor

[image]

One of William Foster's Class Libraries
ApplicationBase Constructor
ApplicationBase Class See Also Send Feedback
Initializes a new instance of the ApplicationBase class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public ApplicationBase()
Visual Basic
Public Sub New
Visual C++
public:
ApplicationBase()

See Also

ApplicationBase Class


ApplicationBase Fields

[image] [image]

One of William Foster's Class Libraries
ApplicationBase Fields
ApplicationBase Class See Also Send Feedback

The ApplicationBase type exposes the following members.

Fields

 | Name | Description
Protected field | m_args |
Protected field | m_BaseFolder |
Protected field | m_ResourceFolder |

See Also

ApplicationBase Class


m_args Field

[image]

One of William Foster's Class Libraries
ApplicationBase..::..m_args Field
ApplicationBase Class See Also Send Feedback

[Missing <summary> documentation for "F:El.ApplicationBase.m_args"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected string[] m_args
Visual Basic
Protected m_args As String()
Visual C++
protected:
array<String^>^ m_args

See Also

ApplicationBase Class


m_BaseFolder Field

[image]

One of William Foster's Class Libraries
ApplicationBase..::..m_BaseFolder Field
ApplicationBase Class See Also Send Feedback

[Missing <summary> documentation for "F:El.ApplicationBase.m_BaseFolder"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected Filename m_BaseFolder
Visual Basic
Protected m_BaseFolder As Filename
Visual C++
protected:
Filename^ m_BaseFolder

See Also

ApplicationBase Class


m_ResourceFolder Field

[image]

One of William Foster's Class Libraries
ApplicationBase..::..m_ResourceFolder Field
ApplicationBase Class See Also Send Feedback

[Missing <summary> documentation for "F:El.ApplicationBase.m_ResourceFolder"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected Filename m_ResourceFolder
Visual Basic
Protected m_ResourceFolder As Filename
Visual C++
protected:
Filename^ m_ResourceFolder

See Also

ApplicationBase Class


ApplicationBase Methods

[image] [image]

One of William Foster's Class Libraries
ApplicationBase Methods
ApplicationBase Class See Also Send Feedback

The ApplicationBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResourceFolder |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ApplicationBase Class


GetResourceFolder Method

[image]

One of William Foster's Class Libraries
ApplicationBase..::..GetResourceFolder Method
ApplicationBase Class See Also Send Feedback

[Missing <summary> documentation for "M:El.ApplicationBase.GetResourceFolder(El.Filename@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void GetResourceFolder(
    out Filename resfolder
)
Visual Basic
Public Sub GetResourceFolder ( _
    <OutAttribute> ByRef resfolder As Filename _
)
Visual C++
public:
void GetResourceFolder(
    [OutAttribute] Filename^% resfolder
)

Parameters

resfolder
Type: El..::..Filename %

[Missing <param name="resfolder"/> documentation for "M:El.ApplicationBase.GetResourceFolder(El.Filename@)"]

See Also

ApplicationBase Class


Initialize Method

[image]

One of William Foster's Class Libraries
ApplicationBase..::..Initialize Method
ApplicationBase Class See Also Send Feedback

[Missing <summary> documentation for "M:El.ApplicationBase.Initialize(System.String[],El.Filename)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Initialize(
    string[] args,
    Filename csResourcePath
)
Visual Basic
Public Sub Initialize ( _
    args As String(), _
    csResourcePath As Filename _
)
Visual C++
public:
void Initialize(
    array<String^>^ args,
    Filename^ csResourcePath
)

Parameters

args
Type: array< System..::..String >[]()[][]

[Missing <param name="args"/> documentation for "M:El.ApplicationBase.Initialize(System.String[],El.Filename)"]

csResourcePath
Type: El..::..Filename

[Missing <param name="csResourcePath"/> documentation for "M:El.ApplicationBase.Initialize(System.String[],El.Filename)"]

See Also

ApplicationBase Class


Array(baseClass) Class

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)> Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Array`1"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Array<baseClass> : ArrayList
Visual Basic
Public Class Array(Of baseClass) _
    Inherits ArrayList
Visual C++
generic<typename baseClass>
public ref class Array : public ArrayList

Type Parameters

baseClass

[Missing <typeparam name="baseClass"/> documentation for "T:El.Array`1"]

Inheritance Hierarchy

System..::..Object
System.Collections..::..ArrayList
El..::..Array<(Of <(<'baseClass>)>)>

See Also

Array<(Of <(<'baseClass>)>)> Members


Array(baseClass) Members

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)> Members
Array<(Of <(<'baseClass>)>)> Class Constructors Methods Properties See Also Send Feedback

The Array<(Of <(<'baseClass>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Array<(Of <(<'baseClass>)>)> | Initializes a new instance of the Array<(Of <(<'baseClass>)>)> class

Methods

 | Name | Description
Public method | Add()()()() |
Public method | Add(Object) | Adds an object to the end of the ArrayList. (Inherited from ArrayList.)
Public method | Add(baseClass) |
Public method | AddIfNotPresent |
Public method | AddRange | Adds the elements of an ICollection to the end of the ArrayList. (Inherited from ArrayList.)
Public method | BinarySearch(Object) | Searches the entire sorted ArrayList for an element using the default comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | BinarySearch(Object, IComparer) | Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | BinarySearch(Int32, Int32, Object, IComparer) | Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | Clear | Removes all elements from the ArrayList. (Inherited from ArrayList.)
Public method | Clone | Creates a shallow copy of the ArrayList. (Inherited from ArrayList.)
Public method | Contains | Determines whether an element is in the ArrayList. (Inherited from ArrayList.)
Public method | CopyTo(Array) | Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array. (Inherited from ArrayList.)
Public method | CopyTo(Array, Int32) | Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ArrayList.)
Public method | CopyTo(Int32, Array, Int32, Int32) | Copies a range of elements from the ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ArrayList.)
Public method | Empty |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | Find |
Public method | GetAt(Int32) |
Public method | GetAt(UInt32) |
Public method | GetAt(UInt64) |
Public method | GetCount |
Public method | GetCountAsULONG |
Public method | GetEnumerator()()()() | Returns an enumerator for the entire ArrayList. (Inherited from ArrayList.)
Public method | GetEnumerator(Int32, Int32) | Returns an enumerator for a range of elements in the ArrayList. (Inherited from ArrayList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLast |
Public method | GetNext |
Public method | GetRange | Returns an ArrayList which represents a subset of the elements in the source ArrayList. (Inherited from ArrayList.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(Object) | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList. (Inherited from ArrayList.)
Public method | IndexOf(Object, Int32) | Searches for the specified Object and returns the zero-based index of the first occurrence within the range of elements in the ArrayList that extends from the specified index to the last element. (Inherited from ArrayList.)
Public method | IndexOf(Object, Int32, Int32) | Searches for the specified Object and returns the zero-based index of the first occurrence within the range of elements in the ArrayList that starts at the specified index and contains the specified number of elements. (Inherited from ArrayList.)
Public method | Insert | Inserts an element into the ArrayList at the specified index. (Inherited from ArrayList.)
Public method | InsertAt |
Public method | InsertRange | Inserts the elements of a collection into the ArrayList at the specified index. (Inherited from ArrayList.)
Public method | IsEmpty |
Public method | LastIndexOf(Object) | Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList. (Inherited from ArrayList.)
Public method | LastIndexOf(Object, Int32) | Searches for the specified Object and returns the zero-based index of the last occurrence within the range of elements in the ArrayList that extends from the first element to the specified index. (Inherited from ArrayList.)
Public method | LastIndexOf(Object, Int32, Int32) | Searches for the specified Object and returns the zero-based index of the last occurrence within the range of elements in the ArrayList that contains the specified number of elements and ends at the specified index. (Inherited from ArrayList.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ArrayList. (Inherited from ArrayList.)
Public method | RemoveAt |
Public method | RemoveLast |
Public method | RemoveRange | Removes a range of elements from the ArrayList. (Inherited from ArrayList.)
Public method | Replace |
Public method | Reverse()()()() | Reverses the order of the elements in the entire ArrayList. (Inherited from ArrayList.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ArrayList.)
Public method | SetRange | Copies the elements of a collection over a range of elements in the ArrayList. (Inherited from ArrayList.)
Public method | Sort()()()() | Sorts the elements in the entire ArrayList using the IComparable implementation of each element. (Inherited from ArrayList.)
Public method | Sort(IComparer) | Sorts the elements in the entire ArrayList using the specified comparer. (Inherited from ArrayList.)
Public method | Sort(Int32, Int32, IComparer) | Sorts the elements in a range of elements in ArrayList using the specified comparer. (Inherited from ArrayList.)
Public method | StartIteration |
Public method | ToArray()()()() | Copies the elements of the ArrayList to a new Object array. (Inherited from ArrayList.)
Public method | ToArray(Type) | Copies the elements of the ArrayList to a new array of the specified element type. (Inherited from ArrayList.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements in the ArrayList. (Inherited from ArrayList.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the ArrayList can contain. (Inherited from ArrayList.)
Public property | Count | Gets the number of elements actually contained in the ArrayList. (Inherited from ArrayList.)
Public property | IsFixedSize | Gets a value indicating whether the ArrayList has a fixed size. (Inherited from ArrayList.)
Public property | IsReadOnly | Gets a value indicating whether the ArrayList is read-only. (Inherited from ArrayList.)
Public property | IsSynchronized | Gets a value indicating whether access to the ArrayList is synchronized (thread safe). (Inherited from ArrayList.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from ArrayList.)
Public property | Item[([( UInt32])]) |
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ArrayList. (Inherited from ArrayList.)

See Also

Array<(Of <(<'baseClass>)>)> Class


Array(baseClass) Constructor

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)> Constructor
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback
Initializes a new instance of the Array<(Of <(<'baseClass>)>)> class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Array()
Visual Basic
Public Sub New
Visual C++
public:
Array()

See Also

Array<(Of <(<'baseClass>)>)> Class


Array(baseClass) Methods

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)> Methods
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

The Array<(Of <(<'baseClass>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add()()()() |
Public method | Add(Object) | Adds an object to the end of the ArrayList. (Inherited from ArrayList.)
Public method | Add(baseClass) |
Public method | AddIfNotPresent |
Public method | AddRange | Adds the elements of an ICollection to the end of the ArrayList. (Inherited from ArrayList.)
Public method | BinarySearch(Object) | Searches the entire sorted ArrayList for an element using the default comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | BinarySearch(Object, IComparer) | Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | BinarySearch(Int32, Int32, Object, IComparer) | Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | Clear | Removes all elements from the ArrayList. (Inherited from ArrayList.)
Public method | Clone | Creates a shallow copy of the ArrayList. (Inherited from ArrayList.)
Public method | Contains | Determines whether an element is in the ArrayList. (Inherited from ArrayList.)
Public method | CopyTo(Array) | Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array. (Inherited from ArrayList.)
Public method | CopyTo(Array, Int32) | Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ArrayList.)
Public method | CopyTo(Int32, Array, Int32, Int32) | Copies a range of elements from the ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ArrayList.)
Public method | Empty |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | Find |
Public method | GetAt(Int32) |
Public method | GetAt(UInt32) |
Public method | GetAt(UInt64) |
Public method | GetCount |
Public method | GetCountAsULONG |
Public method | GetEnumerator()()()() | Returns an enumerator for the entire ArrayList. (Inherited from ArrayList.)
Public method | GetEnumerator(Int32, Int32) | Returns an enumerator for a range of elements in the ArrayList. (Inherited from ArrayList.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLast |
Public method | GetNext |
Public method | GetRange | Returns an ArrayList which represents a subset of the elements in the source ArrayList. (Inherited from ArrayList.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(Object) | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList. (Inherited from ArrayList.)
Public method | IndexOf(Object, Int32) | Searches for the specified Object and returns the zero-based index of the first occurrence within the range of elements in the ArrayList that extends from the specified index to the last element. (Inherited from ArrayList.)
Public method | IndexOf(Object, Int32, Int32) | Searches for the specified Object and returns the zero-based index of the first occurrence within the range of elements in the ArrayList that starts at the specified index and contains the specified number of elements. (Inherited from ArrayList.)
Public method | Insert | Inserts an element into the ArrayList at the specified index. (Inherited from ArrayList.)
Public method | InsertAt |
Public method | InsertRange | Inserts the elements of a collection into the ArrayList at the specified index. (Inherited from ArrayList.)
Public method | IsEmpty |
Public method | LastIndexOf(Object) | Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList. (Inherited from ArrayList.)
Public method | LastIndexOf(Object, Int32) | Searches for the specified Object and returns the zero-based index of the last occurrence within the range of elements in the ArrayList that extends from the first element to the specified index. (Inherited from ArrayList.)
Public method | LastIndexOf(Object, Int32, Int32) | Searches for the specified Object and returns the zero-based index of the last occurrence within the range of elements in the ArrayList that contains the specified number of elements and ends at the specified index. (Inherited from ArrayList.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ArrayList. (Inherited from ArrayList.)
Public method | RemoveAt |
Public method | RemoveLast |
Public method | RemoveRange | Removes a range of elements from the ArrayList. (Inherited from ArrayList.)
Public method | Replace |
Public method | Reverse()()()() | Reverses the order of the elements in the entire ArrayList. (Inherited from ArrayList.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ArrayList.)
Public method | SetRange | Copies the elements of a collection over a range of elements in the ArrayList. (Inherited from ArrayList.)
Public method | Sort()()()() | Sorts the elements in the entire ArrayList using the IComparable implementation of each element. (Inherited from ArrayList.)
Public method | Sort(IComparer) | Sorts the elements in the entire ArrayList using the specified comparer. (Inherited from ArrayList.)
Public method | Sort(Int32, Int32, IComparer) | Sorts the elements in a range of elements in ArrayList using the specified comparer. (Inherited from ArrayList.)
Public method | StartIteration |
Public method | ToArray()()()() | Copies the elements of the ArrayList to a new Object array. (Inherited from ArrayList.)
Public method | ToArray(Type) | Copies the elements of the ArrayList to a new array of the specified element type. (Inherited from ArrayList.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimToSize | Sets the capacity to the actual number of elements in the ArrayList. (Inherited from ArrayList.)

See Also

Array<(Of <(<'baseClass>)>)> Class


Add Method

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..Add Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add()()()() |
Public method | Add(Object) | Adds an object to the end of the ArrayList. (Inherited from ArrayList.)
Public method | Add(baseClass) |

See Also

Array<(Of <(<'baseClass>)>)> Class
Array<(Of <(<'baseClass>)>)> Members


Add Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..Add Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.Add"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Add()
Visual Basic
Public Function Add As Boolean
Visual C++
public:
bool Add()

Return Value

[Missing <returns> documentation for "M:El.Array`1.Add"]

See Also

Array<(Of <(<'baseClass>)>)> Class
Add Overload


Add Method (baseClass)

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..Add Method (baseClass)
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.Add(`0)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Add(
    baseClass Item
)
Visual Basic
Public Function Add ( _
    Item As baseClass _
) As Boolean
Visual C++
public:
bool Add(
    baseClass Item
)

Parameters

Item
Type: baseClass

[Missing <param name="Item"/> documentation for "M:El.Array`1.Add(`0)"]

Return Value

[Missing <returns> documentation for "M:El.Array`1.Add(`0)"]

See Also

Array<(Of <(<'baseClass>)>)> Class
Add Overload


AddIfNotPresent Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..AddIfNotPresent Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.AddIfNotPresent(`0)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void AddIfNotPresent(
    baseClass Item
)
Visual Basic
Public Sub AddIfNotPresent ( _
    Item As baseClass _
)
Visual C++
public:
void AddIfNotPresent(
    baseClass Item
)

Parameters

Item
Type: baseClass

[Missing <param name="Item"/> documentation for "M:El.Array`1.AddIfNotPresent(`0)"]

See Also

Array<(Of <(<'baseClass>)>)> Class


BinarySearch Method

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..BinarySearch Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(Object) | Searches the entire sorted ArrayList for an element using the default comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | BinarySearch(Object, IComparer) | Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ArrayList.)
Public method | BinarySearch(Int32, Int32, Object, IComparer) | Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from ArrayList.)

See Also

Array<(Of <(<'baseClass>)>)> Class
Array<(Of <(<'baseClass>)>)> Members


CopyTo Method

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..CopyTo Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(Array) | Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array. (Inherited from ArrayList.)
Public method | CopyTo(Array, Int32) | Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ArrayList.)
Public method | CopyTo(Int32, Array, Int32, Int32) | Copies a range of elements from the ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ArrayList.)

See Also

Array<(Of <(<'baseClass>)>)> Class
Array<(Of <(<'baseClass>)>)> Members


Empty Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..Empty Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.Empty"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Empty()
Visual Basic
Public Function Empty As Boolean
Visual C++
public:
bool Empty()

Return Value

[Missing <returns> documentation for "M:El.Array`1.Empty"]

See Also

Array<(Of <(<'baseClass>)>)> Class


Finalize Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..Finalize Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.Finalize"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Array<(Of <(<'baseClass>)>)> Class


Find Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..Find Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.Find(`0)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public long Find(
    baseClass cmp
)
Visual Basic
Public Function Find ( _
    cmp As baseClass _
) As Long
Visual C++
public:
long long Find(
    baseClass cmp
)

Parameters

cmp
Type: baseClass

[Missing <param name="cmp"/> documentation for "M:El.Array`1.Find(`0)"]

Return Value

[Missing <returns> documentation for "M:El.Array`1.Find(`0)"]

See Also

Array<(Of <(<'baseClass>)>)> Class


GetAt Method

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..GetAt Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAt(Int32) |
Public method | GetAt(UInt32) |
Public method | GetAt(UInt64) |

See Also

Array<(Of <(<'baseClass>)>)> Class
Array<(Of <(<'baseClass>)>)> Members


GetAt Method (Int32)

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..GetAt Method (Int32)
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.GetAt(System.Int32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public baseClass GetAt(
    int iIndex
)
Visual Basic
Public Function GetAt ( _
    iIndex As Integer _
) As baseClass
Visual C++
public:
baseClass GetAt(
    int iIndex
)

Parameters

iIndex
Type: System..::..Int32

[Missing <param name="iIndex"/> documentation for "M:El.Array`1.GetAt(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:El.Array`1.GetAt(System.Int32)"]

See Also

Array<(Of <(<'baseClass>)>)> Class
GetAt Overload


GetAt Method (UInt32)

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..GetAt Method (UInt32)
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.GetAt(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public baseClass GetAt(
    uint uIndex
)
Visual Basic
Public Function GetAt ( _
    uIndex As UInteger _
) As baseClass
Visual C++
public:
baseClass GetAt(
    unsigned int uIndex
)

Parameters

uIndex
Type: System..::..UInt32

[Missing <param name="uIndex"/> documentation for "M:El.Array`1.GetAt(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.Array`1.GetAt(System.UInt32)"]

See Also

Array<(Of <(<'baseClass>)>)> Class
GetAt Overload


GetAt Method (UInt64)

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..GetAt Method (UInt64)
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.GetAt(System.UInt64)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public baseClass GetAt(
    ulong ulIndex
)
Visual Basic
Public Function GetAt ( _
    ulIndex As ULong _
) As baseClass
Visual C++
public:
baseClass GetAt(
    unsigned long long ulIndex
)

Parameters

ulIndex
Type: System..::..UInt64

[Missing <param name="ulIndex"/> documentation for "M:El.Array`1.GetAt(System.UInt64)"]

Return Value

[Missing <returns> documentation for "M:El.Array`1.GetAt(System.UInt64)"]

See Also

Array<(Of <(<'baseClass>)>)> Class
GetAt Overload


GetCount Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..GetCount Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.GetCount"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint GetCount()
Visual Basic
Public Function GetCount As UInteger
Visual C++
public:
unsigned int GetCount()

Return Value

[Missing <returns> documentation for "M:El.Array`1.GetCount"]

See Also

Array<(Of <(<'baseClass>)>)> Class


GetCountAsULONG Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..GetCountAsULONG Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.GetCountAsULONG"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public ulong GetCountAsULONG()
Visual Basic
Public Function GetCountAsULONG As ULong
Visual C++
public:
unsigned long long GetCountAsULONG()

Return Value

[Missing <returns> documentation for "M:El.Array`1.GetCountAsULONG"]

See Also

Array<(Of <(<'baseClass>)>)> Class


GetEnumerator Method

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..GetEnumerator Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEnumerator()()()() | Returns an enumerator for the entire ArrayList. (Inherited from ArrayList.)
Public method | GetEnumerator(Int32, Int32) | Returns an enumerator for a range of elements in the ArrayList. (Inherited from ArrayList.)

See Also

Array<(Of <(<'baseClass>)>)> Class
Array<(Of <(<'baseClass>)>)> Members


GetLast Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..GetLast Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.GetLast"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public baseClass GetLast()
Visual Basic
Public Function GetLast As baseClass
Visual C++
public:
baseClass GetLast()

Return Value

[Missing <returns> documentation for "M:El.Array`1.GetLast"]

See Also

Array<(Of <(<'baseClass>)>)> Class


GetNext Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..GetNext Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.GetNext(System.UInt64@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public baseClass GetNext(
    ref ulong uIterationIndex
)
Visual Basic
Public Function GetNext ( _
    ByRef uIterationIndex As ULong _
) As baseClass
Visual C++
public:
baseClass GetNext(
    unsigned long long% uIterationIndex
)

Parameters

uIterationIndex
Type: System..::..UInt64 %

[Missing <param name="uIterationIndex"/> documentation for "M:El.Array`1.GetNext(System.UInt64@)"]

Return Value

[Missing <returns> documentation for "M:El.Array`1.GetNext(System.UInt64@)"]

See Also

Array<(Of <(<'baseClass>)>)> Class


IndexOf Method

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..IndexOf Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(Object) | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList. (Inherited from ArrayList.)
Public method | IndexOf(Object, Int32) | Searches for the specified Object and returns the zero-based index of the first occurrence within the range of elements in the ArrayList that extends from the specified index to the last element. (Inherited from ArrayList.)
Public method | IndexOf(Object, Int32, Int32) | Searches for the specified Object and returns the zero-based index of the first occurrence within the range of elements in the ArrayList that starts at the specified index and contains the specified number of elements. (Inherited from ArrayList.)

See Also

Array<(Of <(<'baseClass>)>)> Class
Array<(Of <(<'baseClass>)>)> Members


InsertAt Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..InsertAt Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.InsertAt(System.Int32,`0)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool InsertAt(
    int iIndex,
    baseClass Item
)
Visual Basic
Public Function InsertAt ( _
    iIndex As Integer, _
    Item As baseClass _
) As Boolean
Visual C++
public:
bool InsertAt(
    int iIndex,
    baseClass Item
)

Parameters

iIndex
Type: System..::..Int32

[Missing <param name="iIndex"/> documentation for "M:El.Array`1.InsertAt(System.Int32,`0)"]

Item
Type: baseClass

[Missing <param name="Item"/> documentation for "M:El.Array`1.InsertAt(System.Int32,`0)"]

Return Value

[Missing <returns> documentation for "M:El.Array`1.InsertAt(System.Int32,`0)"]

See Also

Array<(Of <(<'baseClass>)>)> Class


IsEmpty Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..IsEmpty Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.IsEmpty"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool IsEmpty()
Visual Basic
Public Function IsEmpty As Boolean
Visual C++
public:
bool IsEmpty()

Return Value

[Missing <returns> documentation for "M:El.Array`1.IsEmpty"]

See Also

Array<(Of <(<'baseClass>)>)> Class


LastIndexOf Method

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..LastIndexOf Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(Object) | Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList. (Inherited from ArrayList.)
Public method | LastIndexOf(Object, Int32) | Searches for the specified Object and returns the zero-based index of the last occurrence within the range of elements in the ArrayList that extends from the first element to the specified index. (Inherited from ArrayList.)
Public method | LastIndexOf(Object, Int32, Int32) | Searches for the specified Object and returns the zero-based index of the last occurrence within the range of elements in the ArrayList that contains the specified number of elements and ends at the specified index. (Inherited from ArrayList.)

See Also

Array<(Of <(<'baseClass>)>)> Class
Array<(Of <(<'baseClass>)>)> Members


RemoveAt Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..RemoveAt Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.RemoveAt(System.Int32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool RemoveAt(
    int iIndex
)
Visual Basic
Public Function RemoveAt ( _
    iIndex As Integer _
) As Boolean
Visual C++
public:
bool RemoveAt(
    int iIndex
)

Parameters

iIndex
Type: System..::..Int32

[Missing <param name="iIndex"/> documentation for "M:El.Array`1.RemoveAt(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:El.Array`1.RemoveAt(System.Int32)"]

See Also

Array<(Of <(<'baseClass>)>)> Class


RemoveLast Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..RemoveLast Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.RemoveLast"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void RemoveLast()
Visual Basic
Public Sub RemoveLast
Visual C++
public:
void RemoveLast()

See Also

Array<(Of <(<'baseClass>)>)> Class


Replace Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..Replace Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.Replace(System.Int32,`0)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Replace(
    int index,
    baseClass Item
)
Visual Basic
Public Sub Replace ( _
    index As Integer, _
    Item As baseClass _
)
Visual C++
public:
void Replace(
    int index,
    baseClass Item
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:El.Array`1.Replace(System.Int32,`0)"]

Item
Type: baseClass

[Missing <param name="Item"/> documentation for "M:El.Array`1.Replace(System.Int32,`0)"]

See Also

Array<(Of <(<'baseClass>)>)> Class


Reverse Method

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..Reverse Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire ArrayList. (Inherited from ArrayList.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ArrayList.)

See Also

Array<(Of <(<'baseClass>)>)> Class
Array<(Of <(<'baseClass>)>)> Members


Sort Method

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..Sort Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire ArrayList using the IComparable implementation of each element. (Inherited from ArrayList.)
Public method | Sort(IComparer) | Sorts the elements in the entire ArrayList using the specified comparer. (Inherited from ArrayList.)
Public method | Sort(Int32, Int32, IComparer) | Sorts the elements in a range of elements in ArrayList using the specified comparer. (Inherited from ArrayList.)

See Also

Array<(Of <(<'baseClass>)>)> Class
Array<(Of <(<'baseClass>)>)> Members


StartIteration Method

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..StartIteration Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Array`1.StartIteration"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public ulong StartIteration()
Visual Basic
Public Function StartIteration As ULong
Visual C++
public:
unsigned long long StartIteration()

Return Value

[Missing <returns> documentation for "M:El.Array`1.StartIteration"]

See Also

Array<(Of <(<'baseClass>)>)> Class


ToArray Method

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..ToArray Method
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToArray()()()() | Copies the elements of the ArrayList to a new Object array. (Inherited from ArrayList.)
Public method | ToArray(Type) | Copies the elements of the ArrayList to a new array of the specified element type. (Inherited from ArrayList.)

See Also

Array<(Of <(<'baseClass>)>)> Class
Array<(Of <(<'baseClass>)>)> Members


Array(baseClass) Properties

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)> Properties
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

The Array<(Of <(<'baseClass>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the ArrayList can contain. (Inherited from ArrayList.)
Public property | Count | Gets the number of elements actually contained in the ArrayList. (Inherited from ArrayList.)
Public property | IsFixedSize | Gets a value indicating whether the ArrayList has a fixed size. (Inherited from ArrayList.)
Public property | IsReadOnly | Gets a value indicating whether the ArrayList is read-only. (Inherited from ArrayList.)
Public property | IsSynchronized | Gets a value indicating whether access to the ArrayList is synchronized (thread safe). (Inherited from ArrayList.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from ArrayList.)
Public property | Item[([( UInt32])]) |
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ArrayList. (Inherited from ArrayList.)

See Also

Array<(Of <(<'baseClass>)>)> Class


Item Property

[image] [image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..Item Property
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from ArrayList.)
Public property | Item[([( UInt32])]) |

See Also

Array<(Of <(<'baseClass>)>)> Class
Array<(Of <(<'baseClass>)>)> Members


Item Property (UInt32)

[image]

One of William Foster's Class Libraries
Array<(Of <(<'baseClass>)>)>..::..Item Property (UInt32)
Array<(Of <(<'baseClass>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "P:El.Array`1.Item(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public baseClass this[
    uint uIndex
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    uIndex As UInteger _
) As baseClass
    Get
Visual C++
public:
property baseClass default[unsigned int uIndex] {
    baseClass get (unsigned int uIndex);
}

Parameters

uIndex
Type: System..::..UInt32

See Also

Array<(Of <(<'baseClass>)>)> Class
Item Overload


Assert Class

[image]

One of William Foster's Class Libraries
Assert Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Assert"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Assert
Visual Basic
Public Class Assert
Visual C++
public ref class Assert

Inheritance Hierarchy

System..::..Object
El..::..Assert

See Also

Assert Members


Assert Members

[image] [image]

One of William Foster's Class Libraries
Assert Members
Assert Class Constructors Methods See Also Send Feedback

The Assert type exposes the following members.

Constructors

 | Name | Description
Public method | Assert | Initializes a new instance of the Assert class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Test(Boolean) |
 | Test(Boolean, String) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Assert Class


Assert Constructor

[image]

One of William Foster's Class Libraries
Assert Constructor
Assert Class See Also Send Feedback
Initializes a new instance of the Assert class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Assert()
Visual Basic
Public Sub New
Visual C++
public:
Assert()

See Also

Assert Class


Assert Methods

[image] [image]

One of William Foster's Class Libraries
Assert Methods
Assert Class See Also Send Feedback

The Assert type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Test(Boolean) |
 | Test(Boolean, String) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Assert Class


Test Method

[image] [image]

One of William Foster's Class Libraries
Assert..::..Test Method
Assert Class See Also Send Feedback

Overload List

Name | Description
Test(Boolean) |
Test(Boolean, String) |

See Also

Assert Class
Assert Members


Test Method (Boolean)

[image]

One of William Foster's Class Libraries
Assert..::..Test Method (Boolean)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Assert.Test(System.Boolean)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void Test(
    bool condition
)
Visual Basic
Public Shared Sub Test ( _
    condition As Boolean _
)
Visual C++
public:
static void Test(
    bool condition
)

Parameters

condition
Type: System..::..Boolean

[Missing <param name="condition"/> documentation for "M:El.Assert.Test(System.Boolean)"]

See Also

Assert Class
Test Overload


Test Method (Boolean, String)

[image]

One of William Foster's Class Libraries
Assert..::..Test Method (Boolean, String)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Assert.Test(System.Boolean,System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void Test(
    bool condition,
    string message
)
Visual Basic
Public Shared Sub Test ( _
    condition As Boolean, _
    message As String _
)
Visual C++
public:
static void Test(
    bool condition,
    String^ message
)

Parameters

condition
Type: System..::..Boolean

[Missing <param name="condition"/> documentation for "M:El.Assert.Test(System.Boolean,System.String)"]

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:El.Assert.Test(System.Boolean,System.String)"]

See Also

Assert Class
Test Overload


Assert.FailedException Class

[image]

One of William Foster's Class Libraries
Assert..::..FailedException Class
Assert Class Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Assert.FailedException"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class FailedException : ApplicationException
Visual Basic
Public Class FailedException _
    Inherits ApplicationException
Visual C++
public ref class FailedException : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
El..::..Assert..::..FailedException

See Also

Assert..::..FailedException Members


Assert.FailedException Members

[image] [image]

One of William Foster's Class Libraries
Assert..::..FailedException Members
Assert..::..FailedException Class Constructors Methods Properties Events See Also Send Feedback

The Assert..::..FailedException type exposes the following members.

Constructors

 | Name | Description
Public method | Assert..::..FailedException | Initializes a new instance of the Assert..::..FailedException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

Assert..::..FailedException Class


Assert.FailedException Constructor

[image]

One of William Foster's Class Libraries
Assert..::..FailedException Constructor
Assert..::..FailedException Class See Also Send Feedback
Initializes a new instance of the Assert..::..FailedException class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public FailedException(
    string s
)
Visual Basic
Public Sub New ( _
    s As String _
)
Visual C++
public:
FailedException(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:El.Assert.FailedException.#ctor(System.String)"]

See Also

Assert..::..FailedException Class


Assert.FailedException Methods

[image] [image]

One of William Foster's Class Libraries
Assert..::..FailedException Methods
Assert..::..FailedException Class See Also Send Feedback

The Assert..::..FailedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

Assert..::..FailedException Class


Assert.FailedException Properties

[image] [image]

One of William Foster's Class Libraries
Assert..::..FailedException Properties
Assert..::..FailedException Class See Also Send Feedback

The Assert..::..FailedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

Assert..::..FailedException Class


Assert.FailedException Events

[image] [image]

One of William Foster's Class Libraries
Assert..::..FailedException Events
Assert..::..FailedException Class See Also Send Feedback

The Assert..::..FailedException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

Assert..::..FailedException Class


CBfc_Angle Class

[image]

One of William Foster's Class Libraries
CBfc_Angle Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.CBfc_Angle"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class CBfc_Angle : Value
Visual Basic
Public Class CBfc_Angle _
    Inherits Value
Visual C++
public ref class CBfc_Angle : public Value

Inheritance Hierarchy

System..::..Object
El..::..Value
El..::..CBfc_Angle

See Also

CBfc_Angle Members


CBfc_Angle Members

[image] [image]

One of William Foster's Class Libraries
CBfc_Angle Members
CBfc_Angle Class Methods Fields See Also Send Feedback

The CBfc_Angle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInDegrees(CBfc_Angle%) |
Public method | GetInDegrees(Value%) |
Public method | GetInRadians(CBfc_Angle%) |
Public method | GetInRadians(Value%) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue_double | (Inherited from Value.)
Public method | GetValue_int | (Inherited from Value.)
Public method | GetValue_uint | (Inherited from Value.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToString | (Inherited from Value.)
Public method | SetFromString | (Inherited from Value.)
Public method | SetInDegrees |
Public method | SetInRadians |
Public method | SetValue(Double) | (Inherited from Value.)
Public method | SetValue(Int32) | (Inherited from Value.)
Public method | SetValue(UInt32) | (Inherited from Value.)
Public method | SetValue(Value) | (Inherited from Value.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_d_value | (Inherited from Value.)

See Also

CBfc_Angle Class


CBfc_Angle Fields

[image] [image]

One of William Foster's Class Libraries
CBfc_Angle Fields
CBfc_Angle Class See Also Send Feedback

The CBfc_Angle type exposes the following members.

Fields

 | Name | Description
Public field | m_d_value | (Inherited from Value.)

See Also

CBfc_Angle Class


CBfc_Angle Methods

[image] [image]

One of William Foster's Class Libraries
CBfc_Angle Methods
CBfc_Angle Class See Also Send Feedback

The CBfc_Angle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInDegrees(CBfc_Angle%) |
Public method | GetInDegrees(Value%) |
Public method | GetInRadians(CBfc_Angle%) |
Public method | GetInRadians(Value%) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue_double | (Inherited from Value.)
Public method | GetValue_int | (Inherited from Value.)
Public method | GetValue_uint | (Inherited from Value.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToString | (Inherited from Value.)
Public method | SetFromString | (Inherited from Value.)
Public method | SetInDegrees |
Public method | SetInRadians |
Public method | SetValue(Double) | (Inherited from Value.)
Public method | SetValue(Int32) | (Inherited from Value.)
Public method | SetValue(UInt32) | (Inherited from Value.)
Public method | SetValue(Value) | (Inherited from Value.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CBfc_Angle Class


GetInDegrees Method

[image] [image]

One of William Foster's Class Libraries
CBfc_Angle..::..GetInDegrees Method
CBfc_Angle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInDegrees(CBfc_Angle%) |
Public method | GetInDegrees(Value%) |

See Also

CBfc_Angle Class
CBfc_Angle Members


GetInDegrees Method (CBfc_Angle)

[image]

One of William Foster's Class Libraries
CBfc_Angle..::..GetInDegrees Method (CBfc_Angle%)
CBfc_Angle Class See Also Send Feedback

[Missing <summary> documentation for "M:El.CBfc_Angle.GetInDegrees(El.CBfc_Angle@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void GetInDegrees(
    ref CBfc_Angle DestAngle
)
Visual Basic
Public Sub GetInDegrees ( _
    ByRef DestAngle As CBfc_Angle _
)
Visual C++
public:
void GetInDegrees(
    CBfc_Angle^% DestAngle
)

Parameters

DestAngle
Type: El..::..CBfc_Angle %

[Missing <param name="DestAngle"/> documentation for "M:El.CBfc_Angle.GetInDegrees(El.CBfc_Angle@)"]

See Also

CBfc_Angle Class
GetInDegrees Overload


GetInDegrees Method (Value)

[image]

One of William Foster's Class Libraries
CBfc_Angle..::..GetInDegrees Method (Value%)
CBfc_Angle Class See Also Send Feedback

[Missing <summary> documentation for "M:El.CBfc_Angle.GetInDegrees(El.Value@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void GetInDegrees(
    ref Value DestValue
)
Visual Basic
Public Sub GetInDegrees ( _
    ByRef DestValue As Value _
)
Visual C++
public:
void GetInDegrees(
    Value^% DestValue
)

Parameters

DestValue
Type: El..::..Value %

[Missing <param name="DestValue"/> documentation for "M:El.CBfc_Angle.GetInDegrees(El.Value@)"]

See Also

CBfc_Angle Class
GetInDegrees Overload


GetInRadians Method

[image] [image]

One of William Foster's Class Libraries
CBfc_Angle..::..GetInRadians Method
CBfc_Angle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInRadians(CBfc_Angle%) |
Public method | GetInRadians(Value%) |

See Also

CBfc_Angle Class
CBfc_Angle Members


GetInRadians Method (CBfc_Angle)

[image]

One of William Foster's Class Libraries
CBfc_Angle..::..GetInRadians Method (CBfc_Angle%)
CBfc_Angle Class See Also Send Feedback

[Missing <summary> documentation for "M:El.CBfc_Angle.GetInRadians(El.CBfc_Angle@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void GetInRadians(
    ref CBfc_Angle DestAngle
)
Visual Basic
Public Sub GetInRadians ( _
    ByRef DestAngle As CBfc_Angle _
)
Visual C++
public:
void GetInRadians(
    CBfc_Angle^% DestAngle
)

Parameters

DestAngle
Type: El..::..CBfc_Angle %

[Missing <param name="DestAngle"/> documentation for "M:El.CBfc_Angle.GetInRadians(El.CBfc_Angle@)"]

See Also

CBfc_Angle Class
GetInRadians Overload


GetInRadians Method (Value)

[image]

One of William Foster's Class Libraries
CBfc_Angle..::..GetInRadians Method (Value%)
CBfc_Angle Class See Also Send Feedback

[Missing <summary> documentation for "M:El.CBfc_Angle.GetInRadians(El.Value@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void GetInRadians(
    ref Value DestValue
)
Visual Basic
Public Sub GetInRadians ( _
    ByRef DestValue As Value _
)
Visual C++
public:
void GetInRadians(
    Value^% DestValue
)

Parameters

DestValue
Type: El..::..Value %

[Missing <param name="DestValue"/> documentation for "M:El.CBfc_Angle.GetInRadians(El.Value@)"]

See Also

CBfc_Angle Class
GetInRadians Overload


SetInDegrees Method

[image]

One of William Foster's Class Libraries
CBfc_Angle..::..SetInDegrees Method
CBfc_Angle Class See Also Send Feedback

[Missing <summary> documentation for "M:El.CBfc_Angle.SetInDegrees(El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetInDegrees(
    Value NewValue
)
Visual Basic
Public Sub SetInDegrees ( _
    NewValue As Value _
)
Visual C++
public:
void SetInDegrees(
    Value^ NewValue
)

Parameters

NewValue
Type: El..::..Value

[Missing <param name="NewValue"/> documentation for "M:El.CBfc_Angle.SetInDegrees(El.Value)"]

See Also

CBfc_Angle Class


SetInRadians Method

[image]

One of William Foster's Class Libraries
CBfc_Angle..::..SetInRadians Method
CBfc_Angle Class See Also Send Feedback

[Missing <summary> documentation for "M:El.CBfc_Angle.SetInRadians(El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetInRadians(
    Value NewValue
)
Visual Basic
Public Sub SetInRadians ( _
    NewValue As Value _
)
Visual C++
public:
void SetInRadians(
    Value^ NewValue
)

Parameters

NewValue
Type: El..::..Value

[Missing <param name="NewValue"/> documentation for "M:El.CBfc_Angle.SetInRadians(El.Value)"]

See Also

CBfc_Angle Class


SetValue Method

[image] [image]

One of William Foster's Class Libraries
CBfc_Angle..::..SetValue Method
CBfc_Angle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(Double) | (Inherited from Value.)
Public method | SetValue(Int32) | (Inherited from Value.)
Public method | SetValue(UInt32) | (Inherited from Value.)
Public method | SetValue(Value) | (Inherited from Value.)

See Also

CBfc_Angle Class
CBfc_Angle Members


CBfc_File Class

[image]

One of William Foster's Class Libraries
CBfc_File Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.CBfc_File"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class CBfc_File : Stream
Visual Basic
Public Class CBfc_File _
    Inherits Stream
Visual C++
public ref class CBfc_File : public Stream

Inheritance Hierarchy

System..::..Object
El..::..Stream
El..::..CBfc_File

See Also

CBfc_File Members


CBfc_File Members

[image] [image]

One of William Foster's Class Libraries
CBfc_File Members
CBfc_File Class Methods Fields Properties See Also Send Feedback

The CBfc_File type exposes the following members.

Methods

 | Name | Description
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AttachFile(Filename, Stream..::..EAccessMode) | (Inherited from Stream.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | Close | (Inherited from Stream.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Stream..::..Finalize()()()().)
Public method | Flush | (Inherited from Stream.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttach | (Inherited from Stream.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | Rewind | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Stream.)
Public method | Set | (Inherited from Stream.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | Tell | (Inherited from Stream.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write(STRING) | (Inherited from Stream.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

Fields

 | Name | Description
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

CBfc_File Class


CBfc_File Fields

[image] [image]

One of William Foster's Class Libraries
CBfc_File Fields
CBfc_File Class See Also Send Feedback

The CBfc_File type exposes the following members.

Fields

 | Name | Description
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)

See Also

CBfc_File Class


CBfc_File Methods

[image] [image]

One of William Foster's Class Libraries
CBfc_File Methods
CBfc_File Class See Also Send Feedback

The CBfc_File type exposes the following members.

Methods

 | Name | Description
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AttachFile(Filename, Stream..::..EAccessMode) | (Inherited from Stream.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | Close | (Inherited from Stream.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Stream..::..Finalize()()()().)
Public method | Flush | (Inherited from Stream.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttach | (Inherited from Stream.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | Rewind | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Stream.)
Public method | Set | (Inherited from Stream.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | Tell | (Inherited from Stream.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write(STRING) | (Inherited from Stream.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

CBfc_File Class


AttachFile Method

[image] [image]

One of William Foster's Class Libraries
CBfc_File..::..AttachFile Method
CBfc_File Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachFile(Filename, Stream..::..EAccessMode) | (Inherited from Stream.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)

See Also

CBfc_File Class
CBfc_File Members


AttachMemory Method

[image] [image]

One of William Foster's Class Libraries
CBfc_File..::..AttachMemory Method
CBfc_File Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)

See Also

CBfc_File Class
CBfc_File Members


Finalize Method

[image]

One of William Foster's Class Libraries
CBfc_File..::..Finalize Method
CBfc_File Class See Also Send Feedback

[Missing <summary> documentation for "M:El.CBfc_File.Finalize"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

CBfc_File Class


Seek Method

[image] [image]

One of William Foster's Class Libraries
CBfc_File..::..Seek Method
CBfc_File Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Stream.)

See Also

CBfc_File Class
CBfc_File Members


Write Method

[image] [image]

One of William Foster's Class Libraries
CBfc_File..::..Write Method
CBfc_File Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(STRING) | (Inherited from Stream.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

CBfc_File Class
CBfc_File Members


CBfc_File Properties

[image] [image]

One of William Foster's Class Libraries
CBfc_File Properties
CBfc_File Class See Also Send Feedback

The CBfc_File type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

CBfc_File Class


Distance Class

[image]

One of William Foster's Class Libraries
Distance Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Distance"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Distance : Value
Visual Basic
Public Class Distance _
    Inherits Value
Visual C++
public ref class Distance : public Value

Inheritance Hierarchy

System..::..Object
El..::..Value
El..::..Distance

See Also

Distance Members


Distance Members

[image] [image]

One of William Foster's Class Libraries
Distance Members
Distance Class Constructors Methods Fields See Also Send Feedback

The Distance type exposes the following members.

Constructors

 | Name | Description
Public method | Distance()()()() | Initializes a new instance of the Distance class
Public method | Distance(Distance) | Initializes a new instance of the Distance class
Public method | Distance(Value, E_DistanceUnits) | Initializes a new instance of the Distance class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAsString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnits |
Public method | GetValue_double | (Inherited from Value.)
Public method | GetValue_int | (Inherited from Value.)
Public method | GetValue_uint | (Inherited from Value.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToString | (Inherited from Value.)
Public method | Set |
Public method | SetFromString |
Public method | SetValue(Double) | (Inherited from Value.)
Public method | SetValue(Int32) | (Inherited from Value.)
Public method | SetValue(UInt32) | (Inherited from Value.)
Public method | SetValue(Value) | (Inherited from Value.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_d_value | (Inherited from Value.)

See Also

Distance Class


Distance Constructor

[image] [image]

One of William Foster's Class Libraries
Distance Constructor
Distance Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Distance()()()() | Initializes a new instance of the Distance class
Public method | Distance(Distance) | Initializes a new instance of the Distance class
Public method | Distance(Value, E_DistanceUnits) | Initializes a new instance of the Distance class

See Also

Distance Class
Distance Members


Distance Constructor

[image]

One of William Foster's Class Libraries
Distance Constructor
Distance Class See Also Send Feedback
Initializes a new instance of the Distance class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Distance()
Visual Basic
Public Sub New
Visual C++
public:
Distance()

See Also

Distance Class
Distance Overload


Distance Constructor (Distance)

[image]

One of William Foster's Class Libraries
Distance Constructor (Distance)
Distance Class See Also Send Feedback
Initializes a new instance of the Distance class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Distance(
    Distance duper
)
Visual Basic
Public Sub New ( _
    duper As Distance _
)
Visual C++
public:
Distance(
    Distance^ duper
)

Parameters

duper
Type: El..::..Distance

[Missing <param name="duper"/> documentation for "M:El.Distance.#ctor(El.Distance)"]

See Also

Distance Class
Distance Overload


Distance Constructor (Value, E_DistanceUnits)

[image]

One of William Foster's Class Libraries
Distance Constructor (Value, E_DistanceUnits)
Distance Class See Also Send Feedback
Initializes a new instance of the Distance class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Distance(
    Value value,
    E_DistanceUnits units
)
Visual Basic
Public Sub New ( _
    value As Value, _
    units As E_DistanceUnits _
)
Visual C++
public:
Distance(
    Value^ value,
    E_DistanceUnits units
)

Parameters

value
Type: El..::..Value

[Missing <param name="value"/> documentation for "M:El.Distance.#ctor(El.Value,El.E_DistanceUnits)"]

units
Type: El..::..E_DistanceUnits

[Missing <param name="units"/> documentation for "M:El.Distance.#ctor(El.Value,El.E_DistanceUnits)"]

See Also

Distance Class
Distance Overload


Distance Fields

[image] [image]

One of William Foster's Class Libraries
Distance Fields
Distance Class See Also Send Feedback

The Distance type exposes the following members.

Fields

 | Name | Description
Public field | m_d_value | (Inherited from Value.)

See Also

Distance Class


Distance Methods

[image] [image]

One of William Foster's Class Libraries
Distance Methods
Distance Class See Also Send Feedback

The Distance type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAsString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnits |
Public method | GetValue_double | (Inherited from Value.)
Public method | GetValue_int | (Inherited from Value.)
Public method | GetValue_uint | (Inherited from Value.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToString | (Inherited from Value.)
Public method | Set |
Public method | SetFromString |
Public method | SetValue(Double) | (Inherited from Value.)
Public method | SetValue(Int32) | (Inherited from Value.)
Public method | SetValue(UInt32) | (Inherited from Value.)
Public method | SetValue(Value) | (Inherited from Value.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distance Class


GetAsString Method

[image]

One of William Foster's Class Libraries
Distance..::..GetAsString Method
Distance Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Distance.GetAsString(El.STRING@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void GetAsString(
    out STRING sDesc
)
Visual Basic
Public Sub GetAsString ( _
    <OutAttribute> ByRef sDesc As STRING _
)
Visual C++
public:
void GetAsString(
    [OutAttribute] STRING^% sDesc
)

Parameters

sDesc
Type: El..::..STRING %

[Missing <param name="sDesc"/> documentation for "M:El.Distance.GetAsString(El.STRING@)"]

See Also

Distance Class


GetUnits Method

[image]

One of William Foster's Class Libraries
Distance..::..GetUnits Method
Distance Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Distance.GetUnits"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public E_DistanceUnits GetUnits()
Visual Basic
Public Function GetUnits As E_DistanceUnits
Visual C++
public:
E_DistanceUnits GetUnits()

Return Value

[Missing <returns> documentation for "M:El.Distance.GetUnits"]

See Also

Distance Class


Set Method

[image]

One of William Foster's Class Libraries
Distance..::..Set Method
Distance Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Distance.Set(El.Value,El.E_DistanceUnits)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Set(
    Value value,
    E_DistanceUnits units
)
Visual Basic
Public Function Set ( _
    value As Value, _
    units As E_DistanceUnits _
) As Boolean
Visual C++
public:
bool Set(
    Value^ value,
    E_DistanceUnits units
)

Parameters

value
Type: El..::..Value

[Missing <param name="value"/> documentation for "M:El.Distance.Set(El.Value,El.E_DistanceUnits)"]

units
Type: El..::..E_DistanceUnits

[Missing <param name="units"/> documentation for "M:El.Distance.Set(El.Value,El.E_DistanceUnits)"]

Return Value

[Missing <returns> documentation for "M:El.Distance.Set(El.Value,El.E_DistanceUnits)"]

See Also

Distance Class


SetFromString Method

[image]

One of William Foster's Class Libraries
Distance..::..SetFromString Method
Distance Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Distance.SetFromString(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool SetFromString(
    STRING sDesc
)
Visual Basic
Public Function SetFromString ( _
    sDesc As STRING _
) As Boolean
Visual C++
public:
bool SetFromString(
    STRING^ sDesc
)

Parameters

sDesc
Type: El..::..STRING

[Missing <param name="sDesc"/> documentation for "M:El.Distance.SetFromString(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.Distance.SetFromString(El.STRING)"]

See Also

Distance Class


SetValue Method

[image] [image]

One of William Foster's Class Libraries
Distance..::..SetValue Method
Distance Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(Double) | (Inherited from Value.)
Public method | SetValue(Int32) | (Inherited from Value.)
Public method | SetValue(UInt32) | (Inherited from Value.)
Public method | SetValue(Value) | (Inherited from Value.)

See Also

Distance Class
Distance Members


E_DistanceUnits Enumeration

[image]

One of William Foster's Class Libraries
E_DistanceUnits Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:El.E_DistanceUnits"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public enum E_DistanceUnits
Visual Basic
Public Enumeration E_DistanceUnits
Visual C++
public enum class E_DistanceUnits

Members

Member name | Value | Description
UNIT | 0 |
POINT | 1 |
INCH | 2 |
FOOT | 3 |
YARD | 4 |
MILE | 5 |
MICRON | 6 |
MILLIMETER | 7 |
CENTIMETER | 8 |
DECIMETER | 9 |
METER | 10 |
KILOMETER | 11 |
LIGHTYEAR | 12 |

See Also

El Namespace

Send comments on this topic to bill@software-imagination.com

(C) 2011 by William P. Foster, all rights reserved.


E_RangeType Enumeration

[image]

One of William Foster's Class Libraries
E_RangeType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:El.E_RangeType"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public enum E_RangeType
Visual Basic
Public Enumeration E_RangeType
Visual C++
public enum class E_RangeType

Members

Member name | Value | Description
RANGE_NONE | 0 |
RANGE_RANGE | 1 |
RANGE_COLUMNS | 2 |
RANGE_ROWS | 3 |

See Also

El Namespace

Send comments on this topic to bill@software-imagination.com

(C) 2011 by William P. Foster, all rights reserved.


Exception Class

[image]

One of William Foster's Class Libraries
Exception Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Exception"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Exception : Exception
Visual Basic
Public Class Exception _
    Inherits Exception
Visual C++
public ref class Exception : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
El..::..Exception

See Also

Exception Members


Exception Members

[image] [image]

One of William Foster's Class Libraries
Exception Members
Exception Class Constructors Methods Fields Properties Events See Also Send Feedback

The Exception type exposes the following members.

Constructors

 | Name | Description
Public method | Exception()()()() | Initializes a new instance of the Exception class
Public method | Exception(Exception..::..EBFC_Exception) | Initializes a new instance of the Exception class
Public method | Exception(Exception..::..EBFC_Exception, STRING) | Initializes a new instance of the Exception class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType |
Public method | Log |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

 | Name | Description
Public field | m_cs_additionalInfo |
Public field | m_e_exception |

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

Exception Class


Exception Constructor

[image] [image]

One of William Foster's Class Libraries
Exception Constructor
Exception Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Exception()()()() | Initializes a new instance of the Exception class
Public method | Exception(Exception..::..EBFC_Exception) | Initializes a new instance of the Exception class
Public method | Exception(Exception..::..EBFC_Exception, STRING) | Initializes a new instance of the Exception class

See Also

Exception Class
Exception Members


Exception Constructor

[image]

One of William Foster's Class Libraries
Exception Constructor
Exception Class See Also Send Feedback
Initializes a new instance of the Exception class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Exception()
Visual Basic
Public Sub New
Visual C++
public:
Exception()

See Also

Exception Class
Exception Overload


Exception Constructor (Exception.EBFC_Exception)

[image]

One of William Foster's Class Libraries
Exception Constructor (Exception..::..EBFC_Exception)
Exception Class See Also Send Feedback
Initializes a new instance of the Exception class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Exception(
    Exception..::..EBFC_Exception exception
)
Visual Basic
Public Sub New ( _
    exception As Exception..::..EBFC_Exception _
)
Visual C++
public:
Exception(
    Exception..::..EBFC_Exception exception
)

Parameters

exception
Type: El..::..Exception..::..EBFC_Exception

[Missing <param name="exception"/> documentation for "M:El.Exception.#ctor(El.Exception.EBFC_Exception)"]

See Also

Exception Class
Exception Overload


Exception Constructor (Exception.EBFC_Exception, STRING)

[image]

One of William Foster's Class Libraries
Exception Constructor (Exception..::..EBFC_Exception, STRING)
Exception Class See Also Send Feedback
Initializes a new instance of the Exception class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Exception(
    Exception..::..EBFC_Exception exception,
    STRING cs_additionalInfo
)
Visual Basic
Public Sub New ( _
    exception As Exception..::..EBFC_Exception, _
    cs_additionalInfo As STRING _
)
Visual C++
public:
Exception(
    Exception..::..EBFC_Exception exception,
    STRING^ cs_additionalInfo
)

Parameters

exception
Type: El..::..Exception..::..EBFC_Exception

[Missing <param name="exception"/> documentation for "M:El.Exception.#ctor(El.Exception.EBFC_Exception,El.STRING)"]

cs_additionalInfo
Type: El..::..STRING

[Missing <param name="cs_additionalInfo"/> documentation for "M:El.Exception.#ctor(El.Exception.EBFC_Exception,El.STRING)"]

See Also

Exception Class
Exception Overload


Exception Fields

[image] [image]

One of William Foster's Class Libraries
Exception Fields
Exception Class See Also Send Feedback

The Exception type exposes the following members.

Fields

 | Name | Description
Public field | m_cs_additionalInfo |
Public field | m_e_exception |

See Also

Exception Class


m_cs_additionalInfo Field

[image]

One of William Foster's Class Libraries
Exception..::..m_cs_additionalInfo Field
Exception Class See Also Send Feedback

[Missing <summary> documentation for "F:El.Exception.m_cs_additionalInfo"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public STRING m_cs_additionalInfo
Visual Basic
Public m_cs_additionalInfo As STRING
Visual C++
public:
STRING^ m_cs_additionalInfo

See Also

Exception Class


m_e_exception Field

[image]

One of William Foster's Class Libraries
Exception..::..m_e_exception Field
Exception Class See Also Send Feedback

[Missing <summary> documentation for "F:El.Exception.m_e_exception"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Exception..::..EBFC_Exception m_e_exception
Visual Basic
Public m_e_exception As Exception..::..EBFC_Exception
Visual C++
public:
Exception..::..EBFC_Exception m_e_exception

See Also

Exception Class


Exception Methods

[image] [image]

One of William Foster's Class Libraries
Exception Methods
Exception Class See Also Send Feedback

The Exception type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType |
Public method | Log |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

Exception Class


Finalize Method

[image]

One of William Foster's Class Libraries
Exception..::..Finalize Method
Exception Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Exception.Finalize"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Exception Class


GetDescription Method

[image]

One of William Foster's Class Libraries
Exception..::..GetDescription Method
Exception Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Exception.GetDescription"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual string GetDescription()
Visual Basic
Public Overridable Function GetDescription As String
Visual C++
public:
virtual String^ GetDescription()

Return Value

[Missing <returns> documentation for "M:El.Exception.GetDescription"]

See Also

Exception Class


GetType Method

[image]

One of William Foster's Class Libraries
Exception..::..GetType Method
Exception Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Exception.GetType"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Exception..::..EBFC_Exception GetType()
Visual Basic
Public Function GetType As Exception..::..EBFC_Exception
Visual C++
public:
Exception..::..EBFC_Exception GetType()

Return Value

[Missing <returns> documentation for "M:El.Exception.GetType"]

See Also

Exception Class


Log Method

[image]

One of William Foster's Class Libraries
Exception..::..Log Method
Exception Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Exception.Log(System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Log(
    string szDescription
)
Visual Basic
Public Function Log ( _
    szDescription As String _
) As Boolean
Visual C++
public:
bool Log(
    String^ szDescription
)

Parameters

szDescription
Type: System..::..String

[Missing <param name="szDescription"/> documentation for "M:El.Exception.Log(System.String)"]

Return Value

[Missing <returns> documentation for "M:El.Exception.Log(System.String)"]

See Also

Exception Class


Exception Properties

[image] [image]

One of William Foster's Class Libraries
Exception Properties
Exception Class See Also Send Feedback

The Exception type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

Exception Class


Exception Events

[image] [image]

One of William Foster's Class Libraries
Exception Events
Exception Class See Also Send Feedback

The Exception type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

Exception Class


Exception.EBFC_Exception Enumeration

[image]

One of William Foster's Class Libraries
Exception..::..EBFC_Exception Enumeration
Exception Class See Also Send Feedback

[Missing <summary> documentation for "T:El.Exception.EBFC_Exception"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public enum EBFC_Exception
Visual Basic
Public Enumeration EBFC_Exception
Visual C++
public enum class EBFC_Exception

Members

Member name | Value | Description
EBFC_EXC_UNKNOWN | 0 |
EBFC_EXC_COMPOUND | 1 |
EBFC_EXC_FILEOPEN | 2 |
EBFC_EXC_OUTOFMEMORY | 3 |
EBFC_EXC_UNEVEN_REFERENCECOUNT | 4 |
EBFC_EXC_CANT_DELETE_DUETO_REFERENCECOUNT | 5 |
EBFC_EXC_STRING_LIMITATION | 6 |
EBFC_EXC_OUT_OF_RANGE | 7 |
EBFC_EXC_ILLEGAL_ACCESS_UNLOCKED_CONSTANT | 8 |
EBFC_EXC_ILLEGAL_ACCESS_ALREADYLOCKED | 9 |
EBFC_EXC_END_OF_FILE | 10 |

See Also

El Namespace

Send comments on this topic to bill@software-imagination.com

(C) 2011 by William P. Foster, all rights reserved.


Filename Class

[image]

One of William Foster's Class Libraries
Filename Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Filename"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Filename : STRING
Visual Basic
Public Class Filename _
    Inherits STRING
Visual C++
public ref class Filename : public STRING

Inheritance Hierarchy

System..::..Object
El..::..STRING
El..::..Filename

See Also

Filename Members


Filename Members

[image] [image]

One of William Foster's Class Libraries
Filename Members
Filename Class Constructors Methods Operators Fields Properties See Also Send Feedback

The Filename type exposes the following members.

Constructors

 | Name | Description
Public method | Filename()()()() | Initializes a new instance of the Filename class
Public method | Filename(String) | Initializes a new instance of the Filename class
Public method | Filename(Filename) | Initializes a new instance of the Filename class
Public method | Filename(STRING) | Initializes a new instance of the Filename class

Methods

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | DeleteFilespec |
Public method | Empty | (Inherited from STRING.)
Public method | EnsureTrailingSlash |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)
Public method | FindOneOf | (Inherited from STRING.)
Public method | FormatV | (Inherited from STRING.)
Public method | GetAsString | (Inherited from STRING.)
Public method | GetAt | (Inherited from STRING.)
Public method | GetBytePtr | (Inherited from STRING.)
Public method | GetComponents |
Public method | GetEnumerator | (Inherited from STRING.)
Public method | GetExtension |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | (Inherited from STRING.)
Public method | GetLengthBytes | (Inherited from STRING.)
Public method | GetName |
Public method | GetNameExtension |
Public method | GetNextSubdir |
Public method | GetPath |
Public method | GetPtr | (Inherited from STRING.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAt | (Inherited from STRING.)
Public method | IsEmpty | (Inherited from STRING.)
Public method | Left | (Inherited from STRING.)
Public method | LeftEquals | (Inherited from STRING.)
Public method | LeftFrom | (Inherited from STRING.)
Public method | MatchesWildcard |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid | (Inherited from STRING.)
Public method | ParseLines | (Inherited from STRING.)
Public method | PrependPath |
Public method | RemoveAt | (Inherited from STRING.)
Public method | RemoveQuotes | (Inherited from STRING.)
Public method | RemoveTrailingSlash |
Public method | RemoveWhitespace | (Inherited from STRING.)
 | Rename |
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)
Public method | ReverseFind | (Inherited from STRING.)
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)
Public method | RightFrom | (Inherited from STRING.)
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)
Public method | SetAt | (Inherited from STRING.)
Public method | SetComponents |
Public method | SetExtention |
Public method | SetLength | (Inherited from STRING.)
Public method | SetName |
Public method | SetPath |
Public method | SpanExcluding | (Inherited from STRING.)
Public method | Substitute | (Inherited from STRING.)
Public method | Terminate | (Inherited from STRING.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase | (Inherited from STRING.)
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)
Public method | UnLink |

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(String to Filename) |
ImplicitWideningImplicitImplicitImplicit(Filename to String) |

Extension Methods

 | Name | Description
Public Extension Method | LeftWord | (Defined by StringExtension.)

Fields

 | Name | Description
 | ALL_WILD |
 | FOLDER_CHAR |
Protected field | m_cs | (Inherited from STRING.)

Properties

 | Name | Description
Public property | Item[([( Int32])]) | (Inherited from STRING.)
Public property | Item[([( UInt32])]) | (Inherited from STRING.)
Public property | Length | (Inherited from STRING.)

See Also

Filename Class


Filename Constructor

[image] [image]

One of William Foster's Class Libraries
Filename Constructor
Filename Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Filename()()()() | Initializes a new instance of the Filename class
Public method | Filename(String) | Initializes a new instance of the Filename class
Public method | Filename(Filename) | Initializes a new instance of the Filename class
Public method | Filename(STRING) | Initializes a new instance of the Filename class

See Also

Filename Class
Filename Members


Filename Constructor

[image]

One of William Foster's Class Libraries
Filename Constructor
Filename Class See Also Send Feedback
Initializes a new instance of the Filename class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Filename()
Visual Basic
Public Sub New
Visual C++
public:
Filename()

See Also

Filename Class
Filename Overload


Filename Constructor (String)

[image]

One of William Foster's Class Libraries
Filename Constructor (String)
Filename Class See Also Send Feedback
Initializes a new instance of the Filename class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Filename(
    string s
)
Visual Basic
Public Sub New ( _
    s As String _
)
Visual C++
public:
Filename(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:El.Filename.#ctor(System.String)"]

See Also

Filename Class
Filename Overload


Filename Constructor (Filename)

[image]

One of William Foster's Class Libraries
Filename Constructor (Filename)
Filename Class See Also Send Feedback
Initializes a new instance of the Filename class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Filename(
    Filename fn
)
Visual Basic
Public Sub New ( _
    fn As Filename _
)
Visual C++
public:
Filename(
    Filename^ fn
)

Parameters

fn
Type: El..::..Filename

[Missing <param name="fn"/> documentation for "M:El.Filename.#ctor(El.Filename)"]

See Also

Filename Class
Filename Overload


Filename Constructor (STRING)

[image]

One of William Foster's Class Libraries
Filename Constructor (STRING)
Filename Class See Also Send Feedback
Initializes a new instance of the Filename class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Filename(
    STRING srcString
)
Visual Basic
Public Sub New ( _
    srcString As STRING _
)
Visual C++
public:
Filename(
    STRING^ srcString
)

Parameters

srcString
Type: El..::..STRING

[Missing <param name="srcString"/> documentation for "M:El.Filename.#ctor(El.STRING)"]

See Also

Filename Class
Filename Overload


Filename Fields

[image] [image]

One of William Foster's Class Libraries
Filename Fields
Filename Class See Also Send Feedback

The Filename type exposes the following members.

Fields

 | Name | Description
 | ALL_WILD |
 | FOLDER_CHAR |
Protected field | m_cs | (Inherited from STRING.)

See Also

Filename Class


ALL_WILD Field

[image]

One of William Foster's Class Libraries
Filename..::..ALL_WILD Field
Filename Class See Also Send Feedback

[Missing <summary> documentation for "F:El.Filename.ALL_WILD"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static string ALL_WILD
Visual Basic
Public Shared ALL_WILD As String
Visual C++
public:
static String^ ALL_WILD

See Also

Filename Class


FOLDER_CHAR Field

[image]

One of William Foster's Class Libraries
Filename..::..FOLDER_CHAR Field
Filename Class See Also Send Feedback

[Missing <summary> documentation for "F:El.Filename.FOLDER_CHAR"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static char FOLDER_CHAR
Visual Basic
Public Shared FOLDER_CHAR As Char
Visual C++
public:
static wchar_t FOLDER_CHAR

See Also

Filename Class


Filename Methods

[image] [image]

One of William Foster's Class Libraries
Filename Methods
Filename Class See Also Send Feedback

The Filename type exposes the following members.

Methods

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | DeleteFilespec |
Public method | Empty | (Inherited from STRING.)
Public method | EnsureTrailingSlash |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)
Public method | FindOneOf | (Inherited from STRING.)
Public method | FormatV | (Inherited from STRING.)
Public method | GetAsString | (Inherited from STRING.)
Public method | GetAt | (Inherited from STRING.)
Public method | GetBytePtr | (Inherited from STRING.)
Public method | GetComponents |
Public method | GetEnumerator | (Inherited from STRING.)
Public method | GetExtension |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | (Inherited from STRING.)
Public method | GetLengthBytes | (Inherited from STRING.)
Public method | GetName |
Public method | GetNameExtension |
Public method | GetNextSubdir |
Public method | GetPath |
Public method | GetPtr | (Inherited from STRING.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAt | (Inherited from STRING.)
Public method | IsEmpty | (Inherited from STRING.)
Public method | Left | (Inherited from STRING.)
Public method | LeftEquals | (Inherited from STRING.)
Public method | LeftFrom | (Inherited from STRING.)
Public method | MatchesWildcard |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid | (Inherited from STRING.)
Public method | ParseLines | (Inherited from STRING.)
Public method | PrependPath |
Public method | RemoveAt | (Inherited from STRING.)
Public method | RemoveQuotes | (Inherited from STRING.)
Public method | RemoveTrailingSlash |
Public method | RemoveWhitespace | (Inherited from STRING.)
 | Rename |
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)
Public method | ReverseFind | (Inherited from STRING.)
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)
Public method | RightFrom | (Inherited from STRING.)
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)
Public method | SetAt | (Inherited from STRING.)
Public method | SetComponents |
Public method | SetExtention |
Public method | SetLength | (Inherited from STRING.)
Public method | SetName |
Public method | SetPath |
Public method | SpanExcluding | (Inherited from STRING.)
Public method | Substitute | (Inherited from STRING.)
Public method | Terminate | (Inherited from STRING.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase | (Inherited from STRING.)
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)
Public method | UnLink |

Extension Methods

 | Name | Description
Public Extension Method | LeftWord | (Defined by StringExtension.)

See Also

Filename Class


Append Method

[image] [image]

One of William Foster's Class Libraries
Filename..::..Append Method
Filename Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)

See Also

Filename Class
Filename Members


Compare Method

[image] [image]

One of William Foster's Class Libraries
Filename..::..Compare Method
Filename Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)

See Also

Filename Class
Filename Members


CompareNoCase Method

[image] [image]

One of William Foster's Class Libraries
Filename..::..CompareNoCase Method
Filename Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)

See Also

Filename Class
Filename Members


DeleteFilespec Method

[image]

One of William Foster's Class Libraries
Filename..::..DeleteFilespec Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.DeleteFilespec(System.Boolean)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool DeleteFilespec(
    bool bKill
)
Visual Basic
Public Function DeleteFilespec ( _
    bKill As Boolean _
) As Boolean
Visual C++
public:
bool DeleteFilespec(
    bool bKill
)

Parameters

bKill
Type: System..::..Boolean

[Missing <param name="bKill"/> documentation for "M:El.Filename.DeleteFilespec(System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:El.Filename.DeleteFilespec(System.Boolean)"]

See Also

Filename Class


EnsureTrailingSlash Method

[image]

One of William Foster's Class Libraries
Filename..::..EnsureTrailingSlash Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.EnsureTrailingSlash"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void EnsureTrailingSlash()
Visual Basic
Public Sub EnsureTrailingSlash
Visual C++
public:
void EnsureTrailingSlash()

See Also

Filename Class


FileExists Method

[image]

One of William Foster's Class Libraries
Filename..::..FileExists Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.FileExists"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool FileExists()
Visual Basic
Public Function FileExists As Boolean
Visual C++
public:
bool FileExists()

Return Value

[Missing <returns> documentation for "M:El.Filename.FileExists"]

See Also

Filename Class


Find Method

[image] [image]

One of William Foster's Class Libraries
Filename..::..Find Method
Filename Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)

See Also

Filename Class
Filename Members


GetComponents Method

[image]

One of William Foster's Class Libraries
Filename..::..GetComponents Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.GetComponents(El.STRING@,El.STRING@,El.STRING@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void GetComponents(
    out STRING cs_path,
    out STRING cs_name,
    out STRING cs_ext
)
Visual Basic
Public Sub GetComponents ( _
    <OutAttribute> ByRef cs_path As STRING, _
    <OutAttribute> ByRef cs_name As STRING, _
    <OutAttribute> ByRef cs_ext As STRING _
)
Visual C++
public:
void GetComponents(
    [OutAttribute] STRING^% cs_path,
    [OutAttribute] STRING^% cs_name,
    [OutAttribute] STRING^% cs_ext
)

Parameters

cs_path
Type: El..::..STRING %

[Missing <param name="cs_path"/> documentation for "M:El.Filename.GetComponents(El.STRING@,El.STRING@,El.STRING@)"]

cs_name
Type: El..::..STRING %

[Missing <param name="cs_name"/> documentation for "M:El.Filename.GetComponents(El.STRING@,El.STRING@,El.STRING@)"]

cs_ext
Type: El..::..STRING %

[Missing <param name="cs_ext"/> documentation for "M:El.Filename.GetComponents(El.STRING@,El.STRING@,El.STRING@)"]

See Also

Filename Class


GetExtension Method

[image]

One of William Foster's Class Libraries
Filename..::..GetExtension Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.GetExtension"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Filename GetExtension()
Visual Basic
Public Function GetExtension As Filename
Visual C++
public:
Filename^ GetExtension()

Return Value

[Missing <returns> documentation for "M:El.Filename.GetExtension"]

See Also

Filename Class


GetName Method

[image]

One of William Foster's Class Libraries
Filename..::..GetName Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.GetName"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Filename GetName()
Visual Basic
Public Function GetName As Filename
Visual C++
public:
Filename^ GetName()

Return Value

[Missing <returns> documentation for "M:El.Filename.GetName"]

See Also

Filename Class


GetNameExtension Method

[image]

One of William Foster's Class Libraries
Filename..::..GetNameExtension Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.GetNameExtension"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Filename GetNameExtension()
Visual Basic
Public Function GetNameExtension As Filename
Visual C++
public:
Filename^ GetNameExtension()

Return Value

[Missing <returns> documentation for "M:El.Filename.GetNameExtension"]

See Also

Filename Class


GetNextSubdir Method

[image]

One of William Foster's Class Libraries
Filename..::..GetNextSubdir Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.GetNextSubdir(El.Filename@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool GetNextSubdir(
    out Filename next
)
Visual Basic
Public Function GetNextSubdir ( _
    <OutAttribute> ByRef next As Filename _
) As Boolean
Visual C++
public:
bool GetNextSubdir(
    [OutAttribute] Filename^% next
)

Parameters

next
Type: El..::..Filename %

[Missing <param name="next"/> documentation for "M:El.Filename.GetNextSubdir(El.Filename@)"]

Return Value

[Missing <returns> documentation for "M:El.Filename.GetNextSubdir(El.Filename@)"]

See Also

Filename Class


GetPath Method

[image]

One of William Foster's Class Libraries
Filename..::..GetPath Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.GetPath"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Filename GetPath()
Visual Basic
Public Function GetPath As Filename
Visual C++
public:
Filename^ GetPath()

Return Value

[Missing <returns> documentation for "M:El.Filename.GetPath"]

See Also

Filename Class


MatchesWildcard Method

[image]

One of William Foster's Class Libraries
Filename..::..MatchesWildcard Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.MatchesWildcard(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool MatchesWildcard(
    STRING cs_wildcard
)
Visual Basic
Public Function MatchesWildcard ( _
    cs_wildcard As STRING _
) As Boolean
Visual C++
public:
bool MatchesWildcard(
    STRING^ cs_wildcard
)

Parameters

cs_wildcard
Type: El..::..STRING

[Missing <param name="cs_wildcard"/> documentation for "M:El.Filename.MatchesWildcard(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.Filename.MatchesWildcard(El.STRING)"]

See Also

Filename Class


PrependPath Method

[image]

One of William Foster's Class Libraries
Filename..::..PrependPath Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.PrependPath(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void PrependPath(
    STRING cs_path
)
Visual Basic
Public Sub PrependPath ( _
    cs_path As STRING _
)
Visual C++
public:
void PrependPath(
    STRING^ cs_path
)

Parameters

cs_path
Type: El..::..STRING

[Missing <param name="cs_path"/> documentation for "M:El.Filename.PrependPath(El.STRING)"]

See Also

Filename Class


RemoveTrailingSlash Method

[image]

One of William Foster's Class Libraries
Filename..::..RemoveTrailingSlash Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.RemoveTrailingSlash"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void RemoveTrailingSlash()
Visual Basic
Public Sub RemoveTrailingSlash
Visual C++
public:
void RemoveTrailingSlash()

See Also

Filename Class


Rename Method

[image]

One of William Foster's Class Libraries
Filename..::..Rename Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.Rename(El.STRING,El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool Rename(
    STRING cs_source,
    STRING cs_dest
)
Visual Basic
Public Shared Function Rename ( _
    cs_source As STRING, _
    cs_dest As STRING _
) As Boolean
Visual C++
public:
static bool Rename(
    STRING^ cs_source,
    STRING^ cs_dest
)

Parameters

cs_source
Type: El..::..STRING

[Missing <param name="cs_source"/> documentation for "M:El.Filename.Rename(El.STRING,El.STRING)"]

cs_dest
Type: El..::..STRING

[Missing <param name="cs_dest"/> documentation for "M:El.Filename.Rename(El.STRING,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.Filename.Rename(El.STRING,El.STRING)"]

See Also

Filename Class


Replace Method

[image] [image]

One of William Foster's Class Libraries
Filename..::..Replace Method
Filename Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)

See Also

Filename Class
Filename Members


Right Method

[image] [image]

One of William Foster's Class Libraries
Filename..::..Right Method
Filename Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)

See Also

Filename Class
Filename Members


Set Method

[image] [image]

One of William Foster's Class Libraries
Filename..::..Set Method
Filename Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)

See Also

Filename Class
Filename Members


SetComponents Method

[image]

One of William Foster's Class Libraries
Filename..::..SetComponents Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.SetComponents(System.String,System.String,System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetComponents(
    string spath,
    string sname,
    string sext
)
Visual Basic
Public Sub SetComponents ( _
    spath As String, _
    sname As String, _
    sext As String _
)
Visual C++
public:
void SetComponents(
    String^ spath,
    String^ sname,
    String^ sext
)

Parameters

spath
Type: System..::..String

[Missing <param name="spath"/> documentation for "M:El.Filename.SetComponents(System.String,System.String,System.String)"]

sname
Type: System..::..String

[Missing <param name="sname"/> documentation for "M:El.Filename.SetComponents(System.String,System.String,System.String)"]

sext
Type: System..::..String

[Missing <param name="sext"/> documentation for "M:El.Filename.SetComponents(System.String,System.String,System.String)"]

See Also

Filename Class


SetExtention Method

[image]

One of William Foster's Class Libraries
Filename..::..SetExtention Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.SetExtention(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetExtention(
    STRING cs_ext
)
Visual Basic
Public Sub SetExtention ( _
    cs_ext As STRING _
)
Visual C++
public:
void SetExtention(
    STRING^ cs_ext
)

Parameters

cs_ext
Type: El..::..STRING

[Missing <param name="cs_ext"/> documentation for "M:El.Filename.SetExtention(El.STRING)"]

See Also

Filename Class


SetName Method

[image]

One of William Foster's Class Libraries
Filename..::..SetName Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.SetName(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetName(
    STRING cs_name
)
Visual Basic
Public Sub SetName ( _
    cs_name As STRING _
)
Visual C++
public:
void SetName(
    STRING^ cs_name
)

Parameters

cs_name
Type: El..::..STRING

[Missing <param name="cs_name"/> documentation for "M:El.Filename.SetName(El.STRING)"]

See Also

Filename Class


SetPath Method

[image]

One of William Foster's Class Libraries
Filename..::..SetPath Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.SetPath(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetPath(
    STRING cs_path
)
Visual Basic
Public Sub SetPath ( _
    cs_path As STRING _
)
Visual C++
public:
void SetPath(
    STRING^ cs_path
)

Parameters

cs_path
Type: El..::..STRING

[Missing <param name="cs_path"/> documentation for "M:El.Filename.SetPath(El.STRING)"]

See Also

Filename Class


Trim Method

[image] [image]

One of William Foster's Class Libraries
Filename..::..Trim Method
Filename Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)

See Also

Filename Class
Filename Members


TrimLeft Method

[image] [image]

One of William Foster's Class Libraries
Filename..::..TrimLeft Method
Filename Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)

See Also

Filename Class
Filename Members


TrimRight Method

[image] [image]

One of William Foster's Class Libraries
Filename..::..TrimRight Method
Filename Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

See Also

Filename Class
Filename Members


UnLink Method

[image]

One of William Foster's Class Libraries
Filename..::..UnLink Method
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.UnLink"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool UnLink()
Visual Basic
Public Function UnLink As Boolean
Visual C++
public:
bool UnLink()

Return Value

[Missing <returns> documentation for "M:El.Filename.UnLink"]

See Also

Filename Class


Filename Type Conversions

[image] [image]

One of William Foster's Class Libraries
Filename Type Conversions
Filename Class See Also Send Feedback

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(String to Filename) |
ImplicitWideningImplicitImplicitImplicit(Filename to String) |

See Also

Filename Class


Implicit Conversion Operators

[image] [image]

One of William Foster's Class Libraries
Filename ImplicitWideningImplicitImplicitImplicit Conversion Operators
Filename Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(String to Filename) |
ImplicitWideningImplicitImplicitImplicit(Filename to String) |

See Also

Filename Class
Filename Members


Implicit Conversion (String to Filename)

[image]

One of William Foster's Class Libraries
Filename ImplicitWideningImplicitImplicitImplicit Conversion (String to Filename)
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.op_Implicit(System.String)~El.Filename"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator Filename (
    string s
)
Visual Basic
Public Shared Widening Operator CType ( _
    s As String _
) As Filename
Visual C++
static implicit operator Filename^ (
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:El.Filename.op_Implicit(System.String)~El.Filename"]

Return Value

[Missing <returns> documentation for "M:El.Filename.op_Implicit(System.String)~El.Filename"]

See Also

Filename Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (Filename to String)

[image]

One of William Foster's Class Libraries
Filename ImplicitWideningImplicitImplicitImplicit Conversion (Filename to String)
Filename Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Filename.op_Implicit(El.Filename)~System.String"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator string (
    Filename s
)
Visual Basic
Public Shared Widening Operator CType ( _
    s As Filename _
) As String
Visual C++
static implicit operator String^ (
    Filename^ s
)

Parameters

s
Type: El..::..Filename

[Missing <param name="s"/> documentation for "M:El.Filename.op_Implicit(El.Filename)~System.String"]

Return Value

[Missing <returns> documentation for "M:El.Filename.op_Implicit(El.Filename)~System.String"]

See Also

Filename Class
ImplicitWideningImplicitImplicitImplicit Overload


Filename Properties

[image] [image]

One of William Foster's Class Libraries
Filename Properties
Filename Class See Also Send Feedback

The Filename type exposes the following members.

Properties

 | Name | Description
Public property | Item[([( Int32])]) | (Inherited from STRING.)
Public property | Item[([( UInt32])]) | (Inherited from STRING.)
Public property | Length | (Inherited from STRING.)

See Also

Filename Class


Item Property

[image] [image]

One of William Foster's Class Libraries
Filename..::..Item Property
Filename Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | (Inherited from STRING.)
Public property | Item[([( UInt32])]) | (Inherited from STRING.)

See Also

Filename Class
Filename Members


Generic Class

[image]

One of William Foster's Class Libraries
Generic Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Generic"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Generic
Visual Basic
Public Class Generic
Visual C++
public ref class Generic

Inheritance Hierarchy

System..::..Object
El..::..Generic

See Also

Generic Members


Generic Members

[image] [image]

One of William Foster's Class Libraries
Generic Members
Generic Class Constructors Methods See Also Send Feedback

The Generic type exposes the following members.

Constructors

 | Name | Description
Public method | Generic | Initializes a new instance of the Generic class

Methods

 | Name | Description
 | DetectOS |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | WITHIN(Int16, Int16, Int16) |
 | WITHIN(UInt16, UInt16, UInt16) |

See Also

Generic Class


Generic Constructor

[image]

One of William Foster's Class Libraries
Generic Constructor
Generic Class See Also Send Feedback
Initializes a new instance of the Generic class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Generic()
Visual Basic
Public Sub New
Visual C++
public:
Generic()

See Also

Generic Class


Generic Methods

[image] [image]

One of William Foster's Class Libraries
Generic Methods
Generic Class See Also Send Feedback

The Generic type exposes the following members.

Methods

 | Name | Description
 | DetectOS |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | WITHIN(Int16, Int16, Int16) |
 | WITHIN(UInt16, UInt16, UInt16) |

See Also

Generic Class


DetectOS Method

[image]

One of William Foster's Class Libraries
Generic..::..DetectOS Method
Generic Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Generic.DetectOS"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Generic..::..OSType DetectOS()
Visual Basic
Public Shared Function DetectOS As Generic..::..OSType
Visual C++
public:
static Generic..::..OSType DetectOS()

Return Value

[Missing <returns> documentation for "M:El.Generic.DetectOS"]

See Also

Generic Class


WITHIN Method

[image] [image]

One of William Foster's Class Libraries
Generic..::..WITHIN Method
Generic Class See Also Send Feedback

Overload List

Name | Description
WITHIN(Int16, Int16, Int16) |
WITHIN(UInt16, UInt16, UInt16) |

See Also

Generic Class
Generic Members


WITHIN Method (Int16, Int16, Int16)

[image]

One of William Foster's Class Libraries
Generic..::..WITHIN Method (Int16, Int16, Int16)
Generic Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Generic.WITHIN(System.Int16,System.Int16,System.Int16)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static short WITHIN(
    short value,
    short low,
    short high
)
Visual Basic
Public Shared Function WITHIN ( _
    value As Short, _
    low As Short, _
    high As Short _
) As Short
Visual C++
public:
static short WITHIN(
    short value,
    short low,
    short high
)

Parameters

value
Type: System..::..Int16

[Missing <param name="value"/> documentation for "M:El.Generic.WITHIN(System.Int16,System.Int16,System.Int16)"]

low
Type: System..::..Int16

[Missing <param name="low"/> documentation for "M:El.Generic.WITHIN(System.Int16,System.Int16,System.Int16)"]

high
Type: System..::..Int16

[Missing <param name="high"/> documentation for "M:El.Generic.WITHIN(System.Int16,System.Int16,System.Int16)"]

Return Value

[Missing <returns> documentation for "M:El.Generic.WITHIN(System.Int16,System.Int16,System.Int16)"]

See Also

Generic Class
WITHIN Overload


WITHIN Method (UInt16, UInt16, UInt16)

[image]

One of William Foster's Class Libraries
Generic..::..WITHIN Method (UInt16, UInt16, UInt16)
Generic Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Generic.WITHIN(System.UInt16,System.UInt16,System.UInt16)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static ushort WITHIN(
    ushort value,
    ushort low,
    ushort high
)
Visual Basic
Public Shared Function WITHIN ( _
    value As UShort, _
    low As UShort, _
    high As UShort _
) As UShort
Visual C++
public:
static unsigned short WITHIN(
    unsigned short value,
    unsigned short low,
    unsigned short high
)

Parameters

value
Type: System..::..UInt16

[Missing <param name="value"/> documentation for "M:El.Generic.WITHIN(System.UInt16,System.UInt16,System.UInt16)"]

low
Type: System..::..UInt16

[Missing <param name="low"/> documentation for "M:El.Generic.WITHIN(System.UInt16,System.UInt16,System.UInt16)"]

high
Type: System..::..UInt16

[Missing <param name="high"/> documentation for "M:El.Generic.WITHIN(System.UInt16,System.UInt16,System.UInt16)"]

Return Value

[Missing <returns> documentation for "M:El.Generic.WITHIN(System.UInt16,System.UInt16,System.UInt16)"]

See Also

Generic Class
WITHIN Overload


Generic.OSType Enumeration

[image]

One of William Foster's Class Libraries
Generic..::..OSType Enumeration
Generic Class See Also Send Feedback

[Missing <summary> documentation for "T:El.Generic.OSType"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public enum OSType
Visual Basic
Public Enumeration OSType
Visual C++
public enum class OSType

Members

Member name | Value | Description
WINDOWS | 0 |
LINUX | 1 |

See Also

El Namespace

Send comments on this topic to bill@software-imagination.com

(C) 2011 by William P. Foster, all rights reserved.


LinkedList Class

[image]

One of William Foster's Class Libraries
LinkedList Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.LinkedList"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class LinkedList
Visual Basic
Public Class LinkedList
Visual C++
public ref class LinkedList

Inheritance Hierarchy

System..::..Object
El..::..LinkedList

See Also

LinkedList Members


LinkedList Members

[image] [image]

One of William Foster's Class Libraries
LinkedList Members
LinkedList Class Methods See Also Send Feedback

The LinkedList type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkedList Class


LinkedList Methods

[image] [image]

One of William Foster's Class Libraries
LinkedList Methods
LinkedList Class See Also Send Feedback

The LinkedList type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkedList Class


Finalize Method

[image]

One of William Foster's Class Libraries
LinkedList..::..Finalize Method
LinkedList Class See Also Send Feedback

[Missing <summary> documentation for "M:El.LinkedList.Finalize"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

LinkedList Class


LinkedObject Class

[image]

One of William Foster's Class Libraries
LinkedObject Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.LinkedObject"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class LinkedObject
Visual Basic
Public Class LinkedObject
Visual C++
public ref class LinkedObject

Inheritance Hierarchy

System..::..Object
El..::..LinkedObject

See Also

LinkedObject Members


LinkedObject Members

[image] [image]

One of William Foster's Class Libraries
LinkedObject Members
LinkedObject Class Methods See Also Send Feedback

The LinkedObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetChild |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext |
Public method | GetPrevious |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkedObject Class


LinkedObject Methods

[image] [image]

One of William Foster's Class Libraries
LinkedObject Methods
LinkedObject Class See Also Send Feedback

The LinkedObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetChild |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext |
Public method | GetPrevious |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkedObject Class


Finalize Method

[image]

One of William Foster's Class Libraries
LinkedObject..::..Finalize Method
LinkedObject Class See Also Send Feedback

[Missing <summary> documentation for "M:El.LinkedObject.Finalize"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

LinkedObject Class


GetChild Method

[image]

One of William Foster's Class Libraries
LinkedObject..::..GetChild Method
LinkedObject Class See Also Send Feedback

[Missing <summary> documentation for "M:El.LinkedObject.GetChild"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public LinkedObject GetChild()
Visual Basic
Public Function GetChild As LinkedObject
Visual C++
public:
LinkedObject^ GetChild()

Return Value

[Missing <returns> documentation for "M:El.LinkedObject.GetChild"]

See Also

LinkedObject Class


GetNext Method

[image]

One of William Foster's Class Libraries
LinkedObject..::..GetNext Method
LinkedObject Class See Also Send Feedback

[Missing <summary> documentation for "M:El.LinkedObject.GetNext"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public LinkedObject GetNext()
Visual Basic
Public Function GetNext As LinkedObject
Visual C++
public:
LinkedObject^ GetNext()

Return Value

[Missing <returns> documentation for "M:El.LinkedObject.GetNext"]

See Also

LinkedObject Class


GetPrevious Method

[image]

One of William Foster's Class Libraries
LinkedObject..::..GetPrevious Method
LinkedObject Class See Also Send Feedback

[Missing <summary> documentation for "M:El.LinkedObject.GetPrevious"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public LinkedObject GetPrevious()
Visual Basic
Public Function GetPrevious As LinkedObject
Visual C++
public:
LinkedObject^ GetPrevious()

Return Value

[Missing <returns> documentation for "M:El.LinkedObject.GetPrevious"]

See Also

LinkedObject Class


MemPtr Class

[image]

One of William Foster's Class Libraries
MemPtr Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.MemPtr"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class MemPtr
Visual Basic
Public Class MemPtr
Visual C++
public ref class MemPtr

Inheritance Hierarchy

System..::..Object
El..::..MemPtr
El..::..Allocation

See Also

MemPtr Members


MemPtr Members

[image] [image]

One of William Foster's Class Libraries
MemPtr Members
MemPtr Class Constructors Methods Operators Fields See Also Send Feedback

The MemPtr type exposes the following members.

Constructors

 | Name | Description
Public method | MemPtr()()()() | Initializes a new instance of the MemPtr class
Public method | MemPtr(array<Byte>[]()[][]) | Initializes a new instance of the MemPtr class

Methods

 | Name | Description
Public method | Delete |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(array<Byte>[]()[][] to MemPtr) |
ImplicitWideningImplicitImplicitImplicit(MemPtr to array<Byte>[]()[][]) |

Fields

 | Name | Description
Public field | m_array |
Public field | m_index |

See Also

MemPtr Class


MemPtr Constructor

[image] [image]

One of William Foster's Class Libraries
MemPtr Constructor
MemPtr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MemPtr()()()() | Initializes a new instance of the MemPtr class
Public method | MemPtr(array<Byte>[]()[][]) | Initializes a new instance of the MemPtr class

See Also

MemPtr Class
MemPtr Members


MemPtr Constructor

[image]

One of William Foster's Class Libraries
MemPtr Constructor
MemPtr Class See Also Send Feedback
Initializes a new instance of the MemPtr class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public MemPtr()
Visual Basic
Public Sub New
Visual C++
public:
MemPtr()

See Also

MemPtr Class
MemPtr Overload


MemPtr Constructor (Byte[])

[image]

One of William Foster's Class Libraries
MemPtr Constructor (array<Byte>[]()[][])
MemPtr Class See Also Send Feedback
Initializes a new instance of the MemPtr class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public MemPtr(
    byte[] bp
)
Visual Basic
Public Sub New ( _
    bp As Byte() _
)
Visual C++
public:
MemPtr(
    array<unsigned char>^ bp
)

Parameters

bp
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bp"/> documentation for "M:El.MemPtr.#ctor(System.Byte[])"]

See Also

MemPtr Class
MemPtr Overload


MemPtr Fields

[image] [image]

One of William Foster's Class Libraries
MemPtr Fields
MemPtr Class See Also Send Feedback

The MemPtr type exposes the following members.

Fields

 | Name | Description
Public field | m_array |
Public field | m_index |

See Also

MemPtr Class


m_array Field

[image]

One of William Foster's Class Libraries
MemPtr..::..m_array Field
MemPtr Class See Also Send Feedback

[Missing <summary> documentation for "F:El.MemPtr.m_array"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public byte[] m_array
Visual Basic
Public m_array As Byte()
Visual C++
public:
array<unsigned char>^ m_array

See Also

MemPtr Class


m_index Field

[image]

One of William Foster's Class Libraries
MemPtr..::..m_index Field
MemPtr Class See Also Send Feedback

[Missing <summary> documentation for "F:El.MemPtr.m_index"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint m_index
Visual Basic
Public m_index As UInteger
Visual C++
public:
unsigned int m_index

See Also

MemPtr Class


MemPtr Methods

[image] [image]

One of William Foster's Class Libraries
MemPtr Methods
MemPtr Class See Also Send Feedback

The MemPtr type exposes the following members.

Methods

 | Name | Description
Public method | Delete |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemPtr Class


Delete Method

[image]

One of William Foster's Class Libraries
MemPtr..::..Delete Method
MemPtr Class See Also Send Feedback

[Missing <summary> documentation for "M:El.MemPtr.Delete"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual void Delete()
Visual Basic
Public Overridable Sub Delete
Visual C++
public:
virtual void Delete()

See Also

MemPtr Class


MemPtr Type Conversions

[image] [image]

One of William Foster's Class Libraries
MemPtr Type Conversions
MemPtr Class See Also Send Feedback

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(array<Byte>[]()[][] to MemPtr) |
ImplicitWideningImplicitImplicitImplicit(MemPtr to array<Byte>[]()[][]) |

See Also

MemPtr Class


Implicit Conversion Operators

[image] [image]

One of William Foster's Class Libraries
MemPtr ImplicitWideningImplicitImplicitImplicit Conversion Operators
MemPtr Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(array<Byte>[]()[][] to MemPtr) |
ImplicitWideningImplicitImplicitImplicit(MemPtr to array<Byte>[]()[][]) |

See Also

MemPtr Class
MemPtr Members


Implicit Conversion (Byte[] to MemPtr)

[image]

One of William Foster's Class Libraries
MemPtr ImplicitWideningImplicitImplicitImplicit Conversion (array<Byte>[]()[][] to MemPtr)
MemPtr Class See Also Send Feedback

[Missing <summary> documentation for "M:El.MemPtr.op_Implicit(System.Byte[])~El.MemPtr"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator MemPtr (
    byte[] bp
)
Visual Basic
Public Shared Widening Operator CType ( _
    bp As Byte() _
) As MemPtr
Visual C++
static implicit operator MemPtr^ (
    array<unsigned char>^ bp
)

Parameters

bp
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bp"/> documentation for "M:El.MemPtr.op_Implicit(System.Byte[])~El.MemPtr"]

Return Value

[Missing <returns> documentation for "M:El.MemPtr.op_Implicit(System.Byte[])~El.MemPtr"]

See Also

MemPtr Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (MemPtr to Byte[])

[image]

One of William Foster's Class Libraries
MemPtr ImplicitWideningImplicitImplicitImplicit Conversion (MemPtr to array<Byte>[]()[][])
MemPtr Class See Also Send Feedback

[Missing <summary> documentation for "M:El.MemPtr.op_Implicit(El.MemPtr)~System.Byte[]"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator byte[] (
    MemPtr bp
)
Visual Basic
Public Shared Widening Operator CType ( _
    bp As MemPtr _
) As Byte()
Visual C++
static implicit operator array<unsigned char>^ (
    MemPtr^ bp
)

Parameters

bp
Type: El..::..MemPtr

[Missing <param name="bp"/> documentation for "M:El.MemPtr.op_Implicit(El.MemPtr)~System.Byte[]"]

Return Value

[Missing <returns> documentation for "M:El.MemPtr.op_Implicit(El.MemPtr)~System.Byte[]"]

See Also

MemPtr Class
ImplicitWideningImplicitImplicitImplicit Overload


PointSpaceTime Class

[image]

One of William Foster's Class Libraries
PointSpaceTime Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.PointSpaceTime"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class PointSpaceTime : Position3d
Visual Basic
Public Class PointSpaceTime _
    Inherits Position3d
Visual C++
public ref class PointSpaceTime : public Position3d

Inheritance Hierarchy

System..::..Object
El..::..Position3d
El..::..PointSpaceTime

See Also

PointSpaceTime Members


PointSpaceTime Members

[image] [image]

One of William Foster's Class Libraries
PointSpaceTime Members
PointSpaceTime Class Constructors Methods See Also Send Feedback

The PointSpaceTime type exposes the following members.

Constructors

 | Name | Description
Public method | PointSpaceTime | Initializes a new instance of the PointSpaceTime class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(UInt32%, UInt32%, UInt32%) | (Inherited from Position3d.)
Public method | Get(Value%, Value%, Value%) | (Inherited from Position3d.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetX | (Inherited from Position3d.)
Public method | GetY | (Inherited from Position3d.)
Public method | GetZ | (Inherited from Position3d.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset |
Public method | Set(Position3d) | (Inherited from Position3d.)
Public method | Set(Value, Value, Value) | (Inherited from Position3d.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointSpaceTime Class


PointSpaceTime Constructor

[image]

One of William Foster's Class Libraries
PointSpaceTime Constructor
PointSpaceTime Class See Also Send Feedback
Initializes a new instance of the PointSpaceTime class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public PointSpaceTime()
Visual Basic
Public Sub New
Visual C++
public:
PointSpaceTime()

See Also

PointSpaceTime Class


PointSpaceTime Methods

[image] [image]

One of William Foster's Class Libraries
PointSpaceTime Methods
PointSpaceTime Class See Also Send Feedback

The PointSpaceTime type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(UInt32%, UInt32%, UInt32%) | (Inherited from Position3d.)
Public method | Get(Value%, Value%, Value%) | (Inherited from Position3d.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetX | (Inherited from Position3d.)
Public method | GetY | (Inherited from Position3d.)
Public method | GetZ | (Inherited from Position3d.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset |
Public method | Set(Position3d) | (Inherited from Position3d.)
Public method | Set(Value, Value, Value) | (Inherited from Position3d.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointSpaceTime Class


Get Method

[image] [image]

One of William Foster's Class Libraries
PointSpaceTime..::..Get Method
PointSpaceTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(UInt32%, UInt32%, UInt32%) | (Inherited from Position3d.)
Public method | Get(Value%, Value%, Value%) | (Inherited from Position3d.)

See Also

PointSpaceTime Class
PointSpaceTime Members


Reset Method

[image]

One of William Foster's Class Libraries
PointSpaceTime..::..Reset Method
PointSpaceTime Class See Also Send Feedback

[Missing <summary> documentation for "M:El.PointSpaceTime.Reset"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

PointSpaceTime Class


Set Method

[image] [image]

One of William Foster's Class Libraries
PointSpaceTime..::..Set Method
PointSpaceTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Position3d) | (Inherited from Position3d.)
Public method | Set(Value, Value, Value) | (Inherited from Position3d.)

See Also

PointSpaceTime Class
PointSpaceTime Members


PointTime Class

[image]

One of William Foster's Class Libraries
PointTime Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.PointTime"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class PointTime
Visual Basic
Public Class PointTime
Visual C++
public ref class PointTime

Inheritance Hierarchy

System..::..Object
El..::..PointTime

See Also

PointTime Members


PointTime Members

[image] [image]

One of William Foster's Class Libraries
PointTime Members
PointTime Class Constructors Methods See Also Send Feedback

The PointTime type exposes the following members.

Constructors

 | Name | Description
Public method | PointTime | Initializes a new instance of the PointTime class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetYear |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDate |
Public method | SetTime |
Public method | SetToLocalTime |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointTime Class


PointTime Constructor

[image]

One of William Foster's Class Libraries
PointTime Constructor
PointTime Class See Also Send Feedback
Initializes a new instance of the PointTime class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public PointTime()
Visual Basic
Public Sub New
Visual C++
public:
PointTime()

See Also

PointTime Class


PointTime Methods

[image] [image]

One of William Foster's Class Libraries
PointTime Methods
PointTime Class See Also Send Feedback

The PointTime type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetYear |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDate |
Public method | SetTime |
Public method | SetToLocalTime |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointTime Class


GetYear Method

[image]

One of William Foster's Class Libraries
PointTime..::..GetYear Method
PointTime Class See Also Send Feedback

[Missing <summary> documentation for "M:El.PointTime.GetYear"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint GetYear()
Visual Basic
Public Function GetYear As UInteger
Visual C++
public:
unsigned int GetYear()

Return Value

[Missing <returns> documentation for "M:El.PointTime.GetYear"]

See Also

PointTime Class


SetDate Method

[image]

One of William Foster's Class Libraries
PointTime..::..SetDate Method
PointTime Class See Also Send Feedback

[Missing <summary> documentation for "M:El.PointTime.SetDate(System.UInt16,System.UInt16,System.UInt16)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool SetDate(
    ushort w_Month,
    ushort w_Day,
    ushort w_Year
)
Visual Basic
Public Function SetDate ( _
    w_Month As UShort, _
    w_Day As UShort, _
    w_Year As UShort _
) As Boolean
Visual C++
public:
bool SetDate(
    unsigned short w_Month,
    unsigned short w_Day,
    unsigned short w_Year
)

Parameters

w_Month
Type: System..::..UInt16

[Missing <param name="w_Month"/> documentation for "M:El.PointTime.SetDate(System.UInt16,System.UInt16,System.UInt16)"]

w_Day
Type: System..::..UInt16

[Missing <param name="w_Day"/> documentation for "M:El.PointTime.SetDate(System.UInt16,System.UInt16,System.UInt16)"]

w_Year
Type: System..::..UInt16

[Missing <param name="w_Year"/> documentation for "M:El.PointTime.SetDate(System.UInt16,System.UInt16,System.UInt16)"]

Return Value

[Missing <returns> documentation for "M:El.PointTime.SetDate(System.UInt16,System.UInt16,System.UInt16)"]

See Also

PointTime Class


SetTime Method

[image]

One of William Foster's Class Libraries
PointTime..::..SetTime Method
PointTime Class See Also Send Feedback

[Missing <summary> documentation for "M:El.PointTime.SetTime(System.UInt16,System.UInt16,System.UInt16,System.UInt16)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool SetTime(
    ushort w_Hour,
    ushort w_Minute,
    ushort w_Second,
    ushort w_Millisecond
)
Visual Basic
Public Function SetTime ( _
    w_Hour As UShort, _
    w_Minute As UShort, _
    w_Second As UShort, _
    w_Millisecond As UShort _
) As Boolean
Visual C++
public:
bool SetTime(
    unsigned short w_Hour,
    unsigned short w_Minute,
    unsigned short w_Second,
    unsigned short w_Millisecond
)

Parameters

w_Hour
Type: System..::..UInt16

[Missing <param name="w_Hour"/> documentation for "M:El.PointTime.SetTime(System.UInt16,System.UInt16,System.UInt16,System.UInt16)"]

w_Minute
Type: System..::..UInt16

[Missing <param name="w_Minute"/> documentation for "M:El.PointTime.SetTime(System.UInt16,System.UInt16,System.UInt16,System.UInt16)"]

w_Second
Type: System..::..UInt16

[Missing <param name="w_Second"/> documentation for "M:El.PointTime.SetTime(System.UInt16,System.UInt16,System.UInt16,System.UInt16)"]

w_Millisecond
Type: System..::..UInt16

[Missing <param name="w_Millisecond"/> documentation for "M:El.PointTime.SetTime(System.UInt16,System.UInt16,System.UInt16,System.UInt16)"]

Return Value

[Missing <returns> documentation for "M:El.PointTime.SetTime(System.UInt16,System.UInt16,System.UInt16,System.UInt16)"]

See Also

PointTime Class


SetToLocalTime Method

[image]

One of William Foster's Class Libraries
PointTime..::..SetToLocalTime Method
PointTime Class See Also Send Feedback

[Missing <summary> documentation for "M:El.PointTime.SetToLocalTime"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetToLocalTime()
Visual Basic
Public Sub SetToLocalTime
Visual C++
public:
void SetToLocalTime()

See Also

PointTime Class


Position3d Class

[image]

One of William Foster's Class Libraries
Position3d Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Position3d"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Position3d
Visual Basic
Public Class Position3d
Visual C++
public ref class Position3d

Inheritance Hierarchy

System..::..Object
El..::..Position3d
El..::..PointSpaceTime

See Also

Position3d Members


Position3d Members

[image] [image]

One of William Foster's Class Libraries
Position3d Members
Position3d Class Constructors Methods Operators See Also Send Feedback

The Position3d type exposes the following members.

Constructors

 | Name | Description
Public method | Position3d()()()() | Initializes a new instance of the Position3d class
Public method | Position3d(Position3d) | Initializes a new instance of the Position3d class
Public method | Position3d(Value, Value, Value) | Initializes a new instance of the Position3d class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(UInt32%, UInt32%, UInt32%) |
Public method | Get(Value%, Value%, Value%) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetX |
Public method | GetY |
Public method | GetZ |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set(Position3d) |
Public method | Set(Value, Value, Value) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality |
Inequality |

See Also

Position3d Class


Position3d Constructor

[image] [image]

One of William Foster's Class Libraries
Position3d Constructor
Position3d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Position3d()()()() | Initializes a new instance of the Position3d class
Public method | Position3d(Position3d) | Initializes a new instance of the Position3d class
Public method | Position3d(Value, Value, Value) | Initializes a new instance of the Position3d class

See Also

Position3d Class
Position3d Members


Position3d Constructor

[image]

One of William Foster's Class Libraries
Position3d Constructor
Position3d Class See Also Send Feedback
Initializes a new instance of the Position3d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Position3d()
Visual Basic
Public Sub New
Visual C++
public:
Position3d()

See Also

Position3d Class
Position3d Overload


Position3d Constructor (Position3d)

[image]

One of William Foster's Class Libraries
Position3d Constructor (Position3d)
Position3d Class See Also Send Feedback
Initializes a new instance of the Position3d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Position3d(
    Position3d pos3d
)
Visual Basic
Public Sub New ( _
    pos3d As Position3d _
)
Visual C++
public:
Position3d(
    Position3d^ pos3d
)

Parameters

pos3d
Type: El..::..Position3d

[Missing <param name="pos3d"/> documentation for "M:El.Position3d.#ctor(El.Position3d)"]

See Also

Position3d Class
Position3d Overload


Position3d Constructor (Value, Value, Value)

[image]

One of William Foster's Class Libraries
Position3d Constructor (Value, Value, Value)
Position3d Class See Also Send Feedback
Initializes a new instance of the Position3d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Position3d(
    Value positionX,
    Value positionY,
    Value positionZ
)
Visual Basic
Public Sub New ( _
    positionX As Value, _
    positionY As Value, _
    positionZ As Value _
)
Visual C++
public:
Position3d(
    Value^ positionX,
    Value^ positionY,
    Value^ positionZ
)

Parameters

positionX
Type: El..::..Value

[Missing <param name="positionX"/> documentation for "M:El.Position3d.#ctor(El.Value,El.Value,El.Value)"]

positionY
Type: El..::..Value

[Missing <param name="positionY"/> documentation for "M:El.Position3d.#ctor(El.Value,El.Value,El.Value)"]

positionZ
Type: El..::..Value

[Missing <param name="positionZ"/> documentation for "M:El.Position3d.#ctor(El.Value,El.Value,El.Value)"]

See Also

Position3d Class
Position3d Overload


Position3d Methods

[image] [image]

One of William Foster's Class Libraries
Position3d Methods
Position3d Class See Also Send Feedback

The Position3d type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(UInt32%, UInt32%, UInt32%) |
Public method | Get(Value%, Value%, Value%) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetX |
Public method | GetY |
Public method | GetZ |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set(Position3d) |
Public method | Set(Value, Value, Value) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Position3d Class


Get Method

[image] [image]

One of William Foster's Class Libraries
Position3d..::..Get Method
Position3d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(UInt32%, UInt32%, UInt32%) |
Public method | Get(Value%, Value%, Value%) |

See Also

Position3d Class
Position3d Members


Get Method (UInt32, UInt32, UInt32)

[image]

One of William Foster's Class Libraries
Position3d..::..Get Method (UInt32%, UInt32%, UInt32%)
Position3d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Position3d.Get(System.UInt32@,System.UInt32@,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Get(
    out uint u_x,
    out uint u_y,
    out uint u_z
)
Visual Basic
Public Sub Get ( _
    <OutAttribute> ByRef u_x As UInteger, _
    <OutAttribute> ByRef u_y As UInteger, _
    <OutAttribute> ByRef u_z As UInteger _
)
Visual C++
public:
void Get(
    [OutAttribute] unsigned int% u_x,
    [OutAttribute] unsigned int% u_y,
    [OutAttribute] unsigned int% u_z
)

Parameters

u_x
Type: System..::..UInt32 %

[Missing <param name="u_x"/> documentation for "M:El.Position3d.Get(System.UInt32@,System.UInt32@,System.UInt32@)"]

u_y
Type: System..::..UInt32 %

[Missing <param name="u_y"/> documentation for "M:El.Position3d.Get(System.UInt32@,System.UInt32@,System.UInt32@)"]

u_z
Type: System..::..UInt32 %

[Missing <param name="u_z"/> documentation for "M:El.Position3d.Get(System.UInt32@,System.UInt32@,System.UInt32@)"]

See Also

Position3d Class
Get Overload


Get Method (Value, Value, Value)

[image]

One of William Foster's Class Libraries
Position3d..::..Get Method (Value%, Value%, Value%)
Position3d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Position3d.Get(El.Value@,El.Value@,El.Value@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Get(
    out Value positionX,
    out Value positionY,
    out Value positionZ
)
Visual Basic
Public Sub Get ( _
    <OutAttribute> ByRef positionX As Value, _
    <OutAttribute> ByRef positionY As Value, _
    <OutAttribute> ByRef positionZ As Value _
)
Visual C++
public:
void Get(
    [OutAttribute] Value^% positionX,
    [OutAttribute] Value^% positionY,
    [OutAttribute] Value^% positionZ
)

Parameters

positionX
Type: El..::..Value %

[Missing <param name="positionX"/> documentation for "M:El.Position3d.Get(El.Value@,El.Value@,El.Value@)"]

positionY
Type: El..::..Value %

[Missing <param name="positionY"/> documentation for "M:El.Position3d.Get(El.Value@,El.Value@,El.Value@)"]

positionZ
Type: El..::..Value %

[Missing <param name="positionZ"/> documentation for "M:El.Position3d.Get(El.Value@,El.Value@,El.Value@)"]

See Also

Position3d Class
Get Overload


GetX Method

[image]

One of William Foster's Class Libraries
Position3d..::..GetX Method
Position3d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Position3d.GetX"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Value GetX()
Visual Basic
Public Function GetX As Value
Visual C++
public:
Value^ GetX()

Return Value

[Missing <returns> documentation for "M:El.Position3d.GetX"]

See Also

Position3d Class


GetY Method

[image]

One of William Foster's Class Libraries
Position3d..::..GetY Method
Position3d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Position3d.GetY"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Value GetY()
Visual Basic
Public Function GetY As Value
Visual C++
public:
Value^ GetY()

Return Value

[Missing <returns> documentation for "M:El.Position3d.GetY"]

See Also

Position3d Class


GetZ Method

[image]

One of William Foster's Class Libraries
Position3d..::..GetZ Method
Position3d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Position3d.GetZ"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Value GetZ()
Visual Basic
Public Function GetZ As Value
Visual C++
public:
Value^ GetZ()

Return Value

[Missing <returns> documentation for "M:El.Position3d.GetZ"]

See Also

Position3d Class


Set Method

[image] [image]

One of William Foster's Class Libraries
Position3d..::..Set Method
Position3d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Position3d) |
Public method | Set(Value, Value, Value) |

See Also

Position3d Class
Position3d Members


Set Method (Position3d)

[image]

One of William Foster's Class Libraries
Position3d..::..Set Method (Position3d)
Position3d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Position3d.Set(El.Position3d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Set(
    Position3d position3d
)
Visual Basic
Public Function Set ( _
    position3d As Position3d _
) As Boolean
Visual C++
public:
bool Set(
    Position3d^ position3d
)

Parameters

position3d
Type: El..::..Position3d

[Missing <param name="position3d"/> documentation for "M:El.Position3d.Set(El.Position3d)"]

Return Value

[Missing <returns> documentation for "M:El.Position3d.Set(El.Position3d)"]

See Also

Position3d Class
Set Overload


Set Method (Value, Value, Value)

[image]

One of William Foster's Class Libraries
Position3d..::..Set Method (Value, Value, Value)
Position3d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Position3d.Set(El.Value,El.Value,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Set(
    Value positionX,
    Value positionY,
    Value positionZ
)
Visual Basic
Public Function Set ( _
    positionX As Value, _
    positionY As Value, _
    positionZ As Value _
) As Boolean
Visual C++
public:
bool Set(
    Value^ positionX,
    Value^ positionY,
    Value^ positionZ
)

Parameters

positionX
Type: El..::..Value

[Missing <param name="positionX"/> documentation for "M:El.Position3d.Set(El.Value,El.Value,El.Value)"]

positionY
Type: El..::..Value

[Missing <param name="positionY"/> documentation for "M:El.Position3d.Set(El.Value,El.Value,El.Value)"]

positionZ
Type: El..::..Value

[Missing <param name="positionZ"/> documentation for "M:El.Position3d.Set(El.Value,El.Value,El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Position3d.Set(El.Value,El.Value,El.Value)"]

See Also

Position3d Class
Set Overload


Position3d Operators

[image] [image]

One of William Foster's Class Libraries
Position3d Operators
Position3d Class See Also Send Feedback

The Position3d type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Position3d Class


Equality Operator

[image]

One of William Foster's Class Libraries
Position3d..::..Equality Operator
Position3d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Position3d.op_Equality(El.Position3d,El.Position3d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator ==(
    Position3d pos3d,
    Position3d eqeqSize3d
)
Visual Basic
Public Shared Operator = ( _
    pos3d As Position3d, _
    eqeqSize3d As Position3d _
) As Boolean
Visual C++
public:
static bool operator ==(
    Position3d^ pos3d,
    Position3d^ eqeqSize3d
)

Parameters

pos3d
Type: El..::..Position3d

[Missing <param name="pos3d"/> documentation for "M:El.Position3d.op_Equality(El.Position3d,El.Position3d)"]

eqeqSize3d
Type: El..::..Position3d

[Missing <param name="eqeqSize3d"/> documentation for "M:El.Position3d.op_Equality(El.Position3d,El.Position3d)"]

Return Value

[Missing <returns> documentation for "M:El.Position3d.op_Equality(El.Position3d,El.Position3d)"]

See Also

Position3d Class


Inequality Operator

[image]

One of William Foster's Class Libraries
Position3d..::..Inequality Operator
Position3d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Position3d.op_Inequality(El.Position3d,El.Position3d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator !=(
    Position3d pos3d,
    Position3d eqeqSize3d
)
Visual Basic
Public Shared Operator <> ( _
    pos3d As Position3d, _
    eqeqSize3d As Position3d _
) As Boolean
Visual C++
public:
static bool operator !=(
    Position3d^ pos3d,
    Position3d^ eqeqSize3d
)

Parameters

pos3d
Type: El..::..Position3d

[Missing <param name="pos3d"/> documentation for "M:El.Position3d.op_Inequality(El.Position3d,El.Position3d)"]

eqeqSize3d
Type: El..::..Position3d

[Missing <param name="eqeqSize3d"/> documentation for "M:El.Position3d.op_Inequality(El.Position3d,El.Position3d)"]

Return Value

[Missing <returns> documentation for "M:El.Position3d.op_Inequality(El.Position3d,El.Position3d)"]

See Also

Position3d Class


Range2d Class

[image]

One of William Foster's Class Libraries
Range2d Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Range2d"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Range2d
Visual Basic
Public Class Range2d
Visual C++
public ref class Range2d

Inheritance Hierarchy

System..::..Object
El..::..Range2d

See Also

Range2d Members


Range2d Members

[image] [image]

One of William Foster's Class Libraries
Range2d Members
Range2d Class Constructors Methods Fields See Also Send Feedback

The Range2d type exposes the following members.

Constructors

 | Name | Description
Public method | Range2d()()()() | Initializes a new instance of the Range2d class
Public method | Range2d(Double, Double, Double, Double) | Initializes a new instance of the Range2d class

Methods

 | Name | Description
Public method | Empty |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_rangeType |

See Also

Range2d Class


Range2d Constructor

[image] [image]

One of William Foster's Class Libraries
Range2d Constructor
Range2d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Range2d()()()() | Initializes a new instance of the Range2d class
Public method | Range2d(Double, Double, Double, Double) | Initializes a new instance of the Range2d class

See Also

Range2d Class
Range2d Members


Range2d Constructor

[image]

One of William Foster's Class Libraries
Range2d Constructor
Range2d Class See Also Send Feedback
Initializes a new instance of the Range2d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Range2d()
Visual Basic
Public Sub New
Visual C++
public:
Range2d()

See Also

Range2d Class
Range2d Overload


Range2d Constructor (Double, Double, Double, Double)

[image]

One of William Foster's Class Libraries
Range2d Constructor (Double, Double, Double, Double)
Range2d Class See Also Send Feedback
Initializes a new instance of the Range2d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Range2d(
    double x,
    double y,
    double w,
    double h
)
Visual Basic
Public Sub New ( _
    x As Double, _
    y As Double, _
    w As Double, _
    h As Double _
)
Visual C++
public:
Range2d(
    double x,
    double y,
    double w,
    double h
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:El.Range2d.#ctor(System.Double,System.Double,System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:El.Range2d.#ctor(System.Double,System.Double,System.Double,System.Double)"]

w
Type: System..::..Double

[Missing <param name="w"/> documentation for "M:El.Range2d.#ctor(System.Double,System.Double,System.Double,System.Double)"]

h
Type: System..::..Double

[Missing <param name="h"/> documentation for "M:El.Range2d.#ctor(System.Double,System.Double,System.Double,System.Double)"]

See Also

Range2d Class
Range2d Overload


Range2d Fields

[image] [image]

One of William Foster's Class Libraries
Range2d Fields
Range2d Class See Also Send Feedback

The Range2d type exposes the following members.

Fields

 | Name | Description
Public field | m_rangeType |

See Also

Range2d Class


m_rangeType Field

[image]

One of William Foster's Class Libraries
Range2d..::..m_rangeType Field
Range2d Class See Also Send Feedback

[Missing <summary> documentation for "F:El.Range2d.m_rangeType"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public E_RangeType m_rangeType
Visual Basic
Public m_rangeType As E_RangeType
Visual C++
public:
E_RangeType m_rangeType

See Also

Range2d Class


Range2d Methods

[image] [image]

One of William Foster's Class Libraries
Range2d Methods
Range2d Class See Also Send Feedback

The Range2d type exposes the following members.

Methods

 | Name | Description
Public method | Empty |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Range2d Class


Empty Method

[image]

One of William Foster's Class Libraries
Range2d..::..Empty Method
Range2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Range2d.Empty"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Empty()
Visual Basic
Public Sub Empty
Visual C++
public:
void Empty()

See Also

Range2d Class


Get Method

[image]

One of William Foster's Class Libraries
Range2d..::..Get Method
Range2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Range2d.Get(El.Rect2d@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Get(
    out Rect2d rect
)
Visual Basic
Public Sub Get ( _
    <OutAttribute> ByRef rect As Rect2d _
)
Visual C++
public:
void Get(
    [OutAttribute] Rect2d^% rect
)

Parameters

rect
Type: El..::..Rect2d %

[Missing <param name="rect"/> documentation for "M:El.Range2d.Get(El.Rect2d@)"]

See Also

Range2d Class


IsEmpty Method

[image]

One of William Foster's Class Libraries
Range2d..::..IsEmpty Method
Range2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Range2d.IsEmpty"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool IsEmpty()
Visual Basic
Public Function IsEmpty As Boolean
Visual C++
public:
bool IsEmpty()

Return Value

[Missing <returns> documentation for "M:El.Range2d.IsEmpty"]

See Also

Range2d Class


Set Method

[image]

One of William Foster's Class Libraries
Range2d..::..Set Method
Range2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Range2d.Set(System.Double,System.Double,System.Double,System.Double)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Set(
    double x,
    double y,
    double w,
    double h
)
Visual Basic
Public Sub Set ( _
    x As Double, _
    y As Double, _
    w As Double, _
    h As Double _
)
Visual C++
public:
void Set(
    double x,
    double y,
    double w,
    double h
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:El.Range2d.Set(System.Double,System.Double,System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:El.Range2d.Set(System.Double,System.Double,System.Double,System.Double)"]

w
Type: System..::..Double

[Missing <param name="w"/> documentation for "M:El.Range2d.Set(System.Double,System.Double,System.Double,System.Double)"]

h
Type: System..::..Double

[Missing <param name="h"/> documentation for "M:El.Range2d.Set(System.Double,System.Double,System.Double,System.Double)"]

See Also

Range2d Class


Range2dU Class

[image]

One of William Foster's Class Libraries
Range2dU Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Range2dU"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Range2dU
Visual Basic
Public Class Range2dU
Visual C++
public ref class Range2dU

Inheritance Hierarchy

System..::..Object
El..::..Range2dU

See Also

Range2dU Members


Range2dU Members

[image] [image]

One of William Foster's Class Libraries
Range2dU Members
Range2dU Class Constructors Methods Fields See Also Send Feedback

The Range2dU type exposes the following members.

Constructors

 | Name | Description
Public method | Range2dU()()()() | Initializes a new instance of the Range2dU class
Public method | Range2dU(Rect2dU) | Initializes a new instance of the Range2dU class
Public method | Range2dU(UInt32, UInt32, UInt32, UInt32) | Initializes a new instance of the Range2dU class

Methods

 | Name | Description
Public method | Empty |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetAbsolute |
Public method | StartIteration |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_rangeType |
Public field | m_rect |

See Also

Range2dU Class


Range2dU Constructor

[image] [image]

One of William Foster's Class Libraries
Range2dU Constructor
Range2dU Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Range2dU()()()() | Initializes a new instance of the Range2dU class
Public method | Range2dU(Rect2dU) | Initializes a new instance of the Range2dU class
Public method | Range2dU(UInt32, UInt32, UInt32, UInt32) | Initializes a new instance of the Range2dU class

See Also

Range2dU Class
Range2dU Members


Range2dU Constructor

[image]

One of William Foster's Class Libraries
Range2dU Constructor
Range2dU Class See Also Send Feedback
Initializes a new instance of the Range2dU class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Range2dU()
Visual Basic
Public Sub New
Visual C++
public:
Range2dU()

See Also

Range2dU Class
Range2dU Overload


Range2dU Constructor (Rect2dU)

[image]

One of William Foster's Class Libraries
Range2dU Constructor (Rect2dU)
Range2dU Class See Also Send Feedback
Initializes a new instance of the Range2dU class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Range2dU(
    Rect2dU r
)
Visual Basic
Public Sub New ( _
    r As Rect2dU _
)
Visual C++
public:
Range2dU(
    Rect2dU^ r
)

Parameters

r
Type: El..::..Rect2dU

[Missing <param name="r"/> documentation for "M:El.Range2dU.#ctor(El.Rect2dU)"]

See Also

Range2dU Class
Range2dU Overload


Range2dU Constructor (UInt32, UInt32, UInt32, UInt32)

[image]

One of William Foster's Class Libraries
Range2dU Constructor (UInt32, UInt32, UInt32, UInt32)
Range2dU Class See Also Send Feedback
Initializes a new instance of the Range2dU class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Range2dU(
    uint x,
    uint y,
    uint w,
    uint h
)
Visual Basic
Public Sub New ( _
    x As UInteger, _
    y As UInteger, _
    w As UInteger, _
    h As UInteger _
)
Visual C++
public:
Range2dU(
    unsigned int x,
    unsigned int y,
    unsigned int w,
    unsigned int h
)

Parameters

x
Type: System..::..UInt32

[Missing <param name="x"/> documentation for "M:El.Range2dU.#ctor(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

y
Type: System..::..UInt32

[Missing <param name="y"/> documentation for "M:El.Range2dU.#ctor(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

w
Type: System..::..UInt32

[Missing <param name="w"/> documentation for "M:El.Range2dU.#ctor(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

h
Type: System..::..UInt32

[Missing <param name="h"/> documentation for "M:El.Range2dU.#ctor(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

See Also

Range2dU Class
Range2dU Overload


Range2dU Fields

[image] [image]

One of William Foster's Class Libraries
Range2dU Fields
Range2dU Class See Also Send Feedback

The Range2dU type exposes the following members.

Fields

 | Name | Description
Public field | m_rangeType |
Public field | m_rect |

See Also

Range2dU Class


m_rangeType Field

[image]

One of William Foster's Class Libraries
Range2dU..::..m_rangeType Field
Range2dU Class See Also Send Feedback

[Missing <summary> documentation for "F:El.Range2dU.m_rangeType"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public E_RangeType m_rangeType
Visual Basic
Public m_rangeType As E_RangeType
Visual C++
public:
E_RangeType m_rangeType

See Also

Range2dU Class


m_rect Field

[image]

One of William Foster's Class Libraries
Range2dU..::..m_rect Field
Range2dU Class See Also Send Feedback

[Missing <summary> documentation for "F:El.Range2dU.m_rect"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Rect2dU m_rect
Visual Basic
Public m_rect As Rect2dU
Visual C++
public:
Rect2dU^ m_rect

See Also

Range2dU Class


Range2dU Methods

[image] [image]

One of William Foster's Class Libraries
Range2dU Methods
Range2dU Class See Also Send Feedback

The Range2dU type exposes the following members.

Methods

 | Name | Description
Public method | Empty |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetAbsolute |
Public method | StartIteration |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Range2dU Class


Empty Method

[image]

One of William Foster's Class Libraries
Range2dU..::..Empty Method
Range2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Range2dU.Empty"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Empty()
Visual Basic
Public Sub Empty
Visual C++
public:
void Empty()

See Also

Range2dU Class


Get Method

[image]

One of William Foster's Class Libraries
Range2dU..::..Get Method
Range2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Range2dU.Get(El.Rect2dU@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Get(
    out Rect2dU rect
)
Visual Basic
Public Sub Get ( _
    <OutAttribute> ByRef rect As Rect2dU _
)
Visual C++
public:
void Get(
    [OutAttribute] Rect2dU^% rect
)

Parameters

rect
Type: El..::..Rect2dU %

[Missing <param name="rect"/> documentation for "M:El.Range2dU.Get(El.Rect2dU@)"]

See Also

Range2dU Class


GetNext Method

[image]

One of William Foster's Class Libraries
Range2dU..::..GetNext Method
Range2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Range2dU.GetNext(El.Size2dU@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool GetNext(
    ref Size2dU pos
)
Visual Basic
Public Function GetNext ( _
    ByRef pos As Size2dU _
) As Boolean
Visual C++
public:
bool GetNext(
    Size2dU^% pos
)

Parameters

pos
Type: El..::..Size2dU %

[Missing <param name="pos"/> documentation for "M:El.Range2dU.GetNext(El.Size2dU@)"]

Return Value

[Missing <returns> documentation for "M:El.Range2dU.GetNext(El.Size2dU@)"]

See Also

Range2dU Class


IsEmpty Method

[image]

One of William Foster's Class Libraries
Range2dU..::..IsEmpty Method
Range2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Range2dU.IsEmpty"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool IsEmpty()
Visual Basic
Public Function IsEmpty As Boolean
Visual C++
public:
bool IsEmpty()

Return Value

[Missing <returns> documentation for "M:El.Range2dU.IsEmpty"]

See Also

Range2dU Class


Set Method

[image]

One of William Foster's Class Libraries
Range2dU..::..Set Method
Range2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Range2dU.Set(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Set(
    uint x,
    uint y,
    uint w,
    uint h
)
Visual Basic
Public Sub Set ( _
    x As UInteger, _
    y As UInteger, _
    w As UInteger, _
    h As UInteger _
)
Visual C++
public:
void Set(
    unsigned int x,
    unsigned int y,
    unsigned int w,
    unsigned int h
)

Parameters

x
Type: System..::..UInt32

[Missing <param name="x"/> documentation for "M:El.Range2dU.Set(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

y
Type: System..::..UInt32

[Missing <param name="y"/> documentation for "M:El.Range2dU.Set(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

w
Type: System..::..UInt32

[Missing <param name="w"/> documentation for "M:El.Range2dU.Set(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

h
Type: System..::..UInt32

[Missing <param name="h"/> documentation for "M:El.Range2dU.Set(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

See Also

Range2dU Class


SetAbsolute Method

[image]

One of William Foster's Class Libraries
Range2dU..::..SetAbsolute Method
Range2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Range2dU.SetAbsolute(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetAbsolute(
    uint xtop,
    uint ytop,
    uint xbot,
    uint ybot
)
Visual Basic
Public Sub SetAbsolute ( _
    xtop As UInteger, _
    ytop As UInteger, _
    xbot As UInteger, _
    ybot As UInteger _
)
Visual C++
public:
void SetAbsolute(
    unsigned int xtop,
    unsigned int ytop,
    unsigned int xbot,
    unsigned int ybot
)

Parameters

xtop
Type: System..::..UInt32

[Missing <param name="xtop"/> documentation for "M:El.Range2dU.SetAbsolute(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

ytop
Type: System..::..UInt32

[Missing <param name="ytop"/> documentation for "M:El.Range2dU.SetAbsolute(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

xbot
Type: System..::..UInt32

[Missing <param name="xbot"/> documentation for "M:El.Range2dU.SetAbsolute(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

ybot
Type: System..::..UInt32

[Missing <param name="ybot"/> documentation for "M:El.Range2dU.SetAbsolute(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

See Also

Range2dU Class


StartIteration Method

[image]

One of William Foster's Class Libraries
Range2dU..::..StartIteration Method
Range2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Range2dU.StartIteration(El.Size2dU@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool StartIteration(
    out Size2dU pos
)
Visual Basic
Public Function StartIteration ( _
    <OutAttribute> ByRef pos As Size2dU _
) As Boolean
Visual C++
public:
bool StartIteration(
    [OutAttribute] Size2dU^% pos
)

Parameters

pos
Type: El..::..Size2dU %

[Missing <param name="pos"/> documentation for "M:El.Range2dU.StartIteration(El.Size2dU@)"]

Return Value

[Missing <returns> documentation for "M:El.Range2dU.StartIteration(El.Size2dU@)"]

See Also

Range2dU Class


Rect2d Class

[image]

One of William Foster's Class Libraries
Rect2d Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Rect2d"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Rect2d
Visual Basic
Public Class Rect2d
Visual C++
public ref class Rect2d

Inheritance Hierarchy

System..::..Object
El..::..Rect2d

See Also

Rect2d Members


Rect2d Members

[image] [image]

One of William Foster's Class Libraries
Rect2d Members
Rect2d Class Constructors Methods Operators Properties See Also Send Feedback

The Rect2d type exposes the following members.

Constructors

 | Name | Description
Public method | Rect2d()()()() | Initializes a new instance of the Rect2d class
Public method | Rect2d(Rect2d) | Initializes a new instance of the Rect2d class
Public method | Rect2d(Size2d, Size2d) | Initializes a new instance of the Rect2d class
Public method | Rect2d(Value, Value, Value, Value) | Initializes a new instance of the Rect2d class

Methods

 | Name | Description
Public method | Encapsulates |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(Size2d%, Size2d%) |
Public method | Get(UInt32%, UInt32%, UInt32%, UInt32%) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Height |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set(Rect2d) |
Public method | Set(Size2d) |
Public method | Set(Size2d, Size2d) |
Public method | Set(Value, Value, Value, Value) |
Public method | SetPosition |
Public method | SetSize |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Width |

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BottomRight |
Public property | Center |
Public property | TopLeft |

See Also

Rect2d Class


Rect2d Constructor

[image] [image]

One of William Foster's Class Libraries
Rect2d Constructor
Rect2d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Rect2d()()()() | Initializes a new instance of the Rect2d class
Public method | Rect2d(Rect2d) | Initializes a new instance of the Rect2d class
Public method | Rect2d(Size2d, Size2d) | Initializes a new instance of the Rect2d class
Public method | Rect2d(Value, Value, Value, Value) | Initializes a new instance of the Rect2d class

See Also

Rect2d Class
Rect2d Members


Rect2d Constructor

[image]

One of William Foster's Class Libraries
Rect2d Constructor
Rect2d Class See Also Send Feedback
Initializes a new instance of the Rect2d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Rect2d()
Visual Basic
Public Sub New
Visual C++
public:
Rect2d()

See Also

Rect2d Class
Rect2d Overload


Rect2d Constructor (Rect2d)

[image]

One of William Foster's Class Libraries
Rect2d Constructor (Rect2d)
Rect2d Class See Also Send Feedback
Initializes a new instance of the Rect2d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Rect2d(
    Rect2d rect2d
)
Visual Basic
Public Sub New ( _
    rect2d As Rect2d _
)
Visual C++
public:
Rect2d(
    Rect2d^ rect2d
)

Parameters

rect2d
Type: El..::..Rect2d

[Missing <param name="rect2d"/> documentation for "M:El.Rect2d.#ctor(El.Rect2d)"]

See Also

Rect2d Class
Rect2d Overload


Rect2d Constructor (Size2d, Size2d)

[image]

One of William Foster's Class Libraries
Rect2d Constructor (Size2d, Size2d)
Rect2d Class See Also Send Feedback
Initializes a new instance of the Rect2d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Rect2d(
    Size2d position,
    Size2d size
)
Visual Basic
Public Sub New ( _
    position As Size2d, _
    size As Size2d _
)
Visual C++
public:
Rect2d(
    Size2d^ position,
    Size2d^ size
)

Parameters

position
Type: El..::..Size2d

[Missing <param name="position"/> documentation for "M:El.Rect2d.#ctor(El.Size2d,El.Size2d)"]

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Rect2d.#ctor(El.Size2d,El.Size2d)"]

See Also

Rect2d Class
Rect2d Overload


Rect2d Constructor (Value, Value, Value, Value)

[image]

One of William Foster's Class Libraries
Rect2d Constructor (Value, Value, Value, Value)
Rect2d Class See Also Send Feedback
Initializes a new instance of the Rect2d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Rect2d(
    Value left,
    Value top,
    Value width,
    Value height
)
Visual Basic
Public Sub New ( _
    left As Value, _
    top As Value, _
    width As Value, _
    height As Value _
)
Visual C++
public:
Rect2d(
    Value^ left,
    Value^ top,
    Value^ width,
    Value^ height
)

Parameters

left
Type: El..::..Value

[Missing <param name="left"/> documentation for "M:El.Rect2d.#ctor(El.Value,El.Value,El.Value,El.Value)"]

top
Type: El..::..Value

[Missing <param name="top"/> documentation for "M:El.Rect2d.#ctor(El.Value,El.Value,El.Value,El.Value)"]

width
Type: El..::..Value

[Missing <param name="width"/> documentation for "M:El.Rect2d.#ctor(El.Value,El.Value,El.Value,El.Value)"]

height
Type: El..::..Value

[Missing <param name="height"/> documentation for "M:El.Rect2d.#ctor(El.Value,El.Value,El.Value,El.Value)"]

See Also

Rect2d Class
Rect2d Overload


Rect2d Methods

[image] [image]

One of William Foster's Class Libraries
Rect2d Methods
Rect2d Class See Also Send Feedback

The Rect2d type exposes the following members.

Methods

 | Name | Description
Public method | Encapsulates |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(Size2d%, Size2d%) |
Public method | Get(UInt32%, UInt32%, UInt32%, UInt32%) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Height |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set(Rect2d) |
Public method | Set(Size2d) |
Public method | Set(Size2d, Size2d) |
Public method | Set(Value, Value, Value, Value) |
Public method | SetPosition |
Public method | SetSize |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Width |

See Also

Rect2d Class


Encapsulates Method

[image]

One of William Foster's Class Libraries
Rect2d..::..Encapsulates Method
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.Encapsulates(El.Rect2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Encapsulates(
    Rect2d rect2d
)
Visual Basic
Public Function Encapsulates ( _
    rect2d As Rect2d _
) As Boolean
Visual C++
public:
bool Encapsulates(
    Rect2d^ rect2d
)

Parameters

rect2d
Type: El..::..Rect2d

[Missing <param name="rect2d"/> documentation for "M:El.Rect2d.Encapsulates(El.Rect2d)"]

Return Value

[Missing <returns> documentation for "M:El.Rect2d.Encapsulates(El.Rect2d)"]

See Also

Rect2d Class


Get Method

[image] [image]

One of William Foster's Class Libraries
Rect2d..::..Get Method
Rect2d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(Size2d%, Size2d%) |
Public method | Get(UInt32%, UInt32%, UInt32%, UInt32%) |

See Also

Rect2d Class
Rect2d Members


Get Method (Size2d, Size2d)

[image]

One of William Foster's Class Libraries
Rect2d..::..Get Method (Size2d%, Size2d%)
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.Get(El.Size2d@,El.Size2d@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Get(
    out Size2d position,
    out Size2d size
)
Visual Basic
Public Sub Get ( _
    <OutAttribute> ByRef position As Size2d, _
    <OutAttribute> ByRef size As Size2d _
)
Visual C++
public:
void Get(
    [OutAttribute] Size2d^% position,
    [OutAttribute] Size2d^% size
)

Parameters

position
Type: El..::..Size2d %

[Missing <param name="position"/> documentation for "M:El.Rect2d.Get(El.Size2d@,El.Size2d@)"]

size
Type: El..::..Size2d %

[Missing <param name="size"/> documentation for "M:El.Rect2d.Get(El.Size2d@,El.Size2d@)"]

See Also

Rect2d Class
Get Overload


Get Method (UInt32, UInt32, UInt32, UInt32)

[image]

One of William Foster's Class Libraries
Rect2d..::..Get Method (UInt32%, UInt32%, UInt32%, UInt32%)
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.Get(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Get(
    ref uint u_x,
    ref uint u_y,
    ref uint u_w,
    ref uint u_h
)
Visual Basic
Public Sub Get ( _
    ByRef u_x As UInteger, _
    ByRef u_y As UInteger, _
    ByRef u_w As UInteger, _
    ByRef u_h As UInteger _
)
Visual C++
public:
void Get(
    unsigned int% u_x,
    unsigned int% u_y,
    unsigned int% u_w,
    unsigned int% u_h
)

Parameters

u_x
Type: System..::..UInt32 %

[Missing <param name="u_x"/> documentation for "M:El.Rect2d.Get(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

u_y
Type: System..::..UInt32 %

[Missing <param name="u_y"/> documentation for "M:El.Rect2d.Get(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

u_w
Type: System..::..UInt32 %

[Missing <param name="u_w"/> documentation for "M:El.Rect2d.Get(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

u_h
Type: System..::..UInt32 %

[Missing <param name="u_h"/> documentation for "M:El.Rect2d.Get(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

See Also

Rect2d Class
Get Overload


GetSize Method

[image]

One of William Foster's Class Libraries
Rect2d..::..GetSize Method
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.GetSize"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2d GetSize()
Visual Basic
Public Function GetSize As Size2d
Visual C++
public:
Size2d^ GetSize()

Return Value

[Missing <returns> documentation for "M:El.Rect2d.GetSize"]

See Also

Rect2d Class


Height Method

[image]

One of William Foster's Class Libraries
Rect2d..::..Height Method
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.Height"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Value Height()
Visual Basic
Public Function Height As Value
Visual C++
public:
Value^ Height()

Return Value

[Missing <returns> documentation for "M:El.Rect2d.Height"]

See Also

Rect2d Class


Set Method

[image] [image]

One of William Foster's Class Libraries
Rect2d..::..Set Method
Rect2d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Rect2d) |
Public method | Set(Size2d) |
Public method | Set(Size2d, Size2d) |
Public method | Set(Value, Value, Value, Value) |

See Also

Rect2d Class
Rect2d Members


Set Method (Rect2d)

[image]

One of William Foster's Class Libraries
Rect2d..::..Set Method (Rect2d)
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.Set(El.Rect2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Set(
    Rect2d rect2d
)
Visual Basic
Public Sub Set ( _
    rect2d As Rect2d _
)
Visual C++
public:
void Set(
    Rect2d^ rect2d
)

Parameters

rect2d
Type: El..::..Rect2d

[Missing <param name="rect2d"/> documentation for "M:El.Rect2d.Set(El.Rect2d)"]

See Also

Rect2d Class
Set Overload


Set Method (Size2d)

[image]

One of William Foster's Class Libraries
Rect2d..::..Set Method (Size2d)
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.Set(El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Set(
    Size2d size
)
Visual Basic
Public Sub Set ( _
    size As Size2d _
)
Visual C++
public:
void Set(
    Size2d^ size
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Rect2d.Set(El.Size2d)"]

See Also

Rect2d Class
Set Overload


Set Method (Size2d, Size2d)

[image]

One of William Foster's Class Libraries
Rect2d..::..Set Method (Size2d, Size2d)
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.Set(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Set(
    Size2d position,
    Size2d size
)
Visual Basic
Public Sub Set ( _
    position As Size2d, _
    size As Size2d _
)
Visual C++
public:
void Set(
    Size2d^ position,
    Size2d^ size
)

Parameters

position
Type: El..::..Size2d

[Missing <param name="position"/> documentation for "M:El.Rect2d.Set(El.Size2d,El.Size2d)"]

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Rect2d.Set(El.Size2d,El.Size2d)"]

See Also

Rect2d Class
Set Overload


Set Method (Value, Value, Value, Value)

[image]

One of William Foster's Class Libraries
Rect2d..::..Set Method (Value, Value, Value, Value)
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.Set(El.Value,El.Value,El.Value,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Set(
    Value left,
    Value top,
    Value width,
    Value height
)
Visual Basic
Public Sub Set ( _
    left As Value, _
    top As Value, _
    width As Value, _
    height As Value _
)
Visual C++
public:
void Set(
    Value^ left,
    Value^ top,
    Value^ width,
    Value^ height
)

Parameters

left
Type: El..::..Value

[Missing <param name="left"/> documentation for "M:El.Rect2d.Set(El.Value,El.Value,El.Value,El.Value)"]

top
Type: El..::..Value

[Missing <param name="top"/> documentation for "M:El.Rect2d.Set(El.Value,El.Value,El.Value,El.Value)"]

width
Type: El..::..Value

[Missing <param name="width"/> documentation for "M:El.Rect2d.Set(El.Value,El.Value,El.Value,El.Value)"]

height
Type: El..::..Value

[Missing <param name="height"/> documentation for "M:El.Rect2d.Set(El.Value,El.Value,El.Value,El.Value)"]

See Also

Rect2d Class
Set Overload


SetPosition Method

[image]

One of William Foster's Class Libraries
Rect2d..::..SetPosition Method
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.SetPosition(El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetPosition(
    Size2d position
)
Visual Basic
Public Sub SetPosition ( _
    position As Size2d _
)
Visual C++
public:
void SetPosition(
    Size2d^ position
)

Parameters

position
Type: El..::..Size2d

[Missing <param name="position"/> documentation for "M:El.Rect2d.SetPosition(El.Size2d)"]

See Also

Rect2d Class


SetSize Method

[image]

One of William Foster's Class Libraries
Rect2d..::..SetSize Method
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.SetSize(El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetSize(
    Size2d size
)
Visual Basic
Public Sub SetSize ( _
    size As Size2d _
)
Visual C++
public:
void SetSize(
    Size2d^ size
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Rect2d.SetSize(El.Size2d)"]

See Also

Rect2d Class


Width Method

[image]

One of William Foster's Class Libraries
Rect2d..::..Width Method
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.Width"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Value Width()
Visual Basic
Public Function Width As Value
Visual C++
public:
Value^ Width()

Return Value

[Missing <returns> documentation for "M:El.Rect2d.Width"]

See Also

Rect2d Class


Rect2d Operators

[image] [image]

One of William Foster's Class Libraries
Rect2d Operators
Rect2d Class See Also Send Feedback

The Rect2d type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Rect2d Class


Equality Operator

[image]

One of William Foster's Class Libraries
Rect2d..::..Equality Operator
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.op_Equality(El.Rect2d,El.Rect2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator ==(
    Rect2d rect2d1,
    Rect2d rect2d2
)
Visual Basic
Public Shared Operator = ( _
    rect2d1 As Rect2d, _
    rect2d2 As Rect2d _
) As Boolean
Visual C++
public:
static bool operator ==(
    Rect2d^ rect2d1,
    Rect2d^ rect2d2
)

Parameters

rect2d1
Type: El..::..Rect2d

[Missing <param name="rect2d1"/> documentation for "M:El.Rect2d.op_Equality(El.Rect2d,El.Rect2d)"]

rect2d2
Type: El..::..Rect2d

[Missing <param name="rect2d2"/> documentation for "M:El.Rect2d.op_Equality(El.Rect2d,El.Rect2d)"]

Return Value

[Missing <returns> documentation for "M:El.Rect2d.op_Equality(El.Rect2d,El.Rect2d)"]

See Also

Rect2d Class


Inequality Operator

[image]

One of William Foster's Class Libraries
Rect2d..::..Inequality Operator
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2d.op_Inequality(El.Rect2d,El.Rect2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator !=(
    Rect2d rect2d1,
    Rect2d rect2d2
)
Visual Basic
Public Shared Operator <> ( _
    rect2d1 As Rect2d, _
    rect2d2 As Rect2d _
) As Boolean
Visual C++
public:
static bool operator !=(
    Rect2d^ rect2d1,
    Rect2d^ rect2d2
)

Parameters

rect2d1
Type: El..::..Rect2d

[Missing <param name="rect2d1"/> documentation for "M:El.Rect2d.op_Inequality(El.Rect2d,El.Rect2d)"]

rect2d2
Type: El..::..Rect2d

[Missing <param name="rect2d2"/> documentation for "M:El.Rect2d.op_Inequality(El.Rect2d,El.Rect2d)"]

Return Value

[Missing <returns> documentation for "M:El.Rect2d.op_Inequality(El.Rect2d,El.Rect2d)"]

See Also

Rect2d Class


Rect2d Properties

[image] [image]

One of William Foster's Class Libraries
Rect2d Properties
Rect2d Class See Also Send Feedback

The Rect2d type exposes the following members.

Properties

 | Name | Description
Public property | BottomRight |
Public property | Center |
Public property | TopLeft |

See Also

Rect2d Class


BottomRight Property

[image]

One of William Foster's Class Libraries
Rect2d..::..BottomRight Property
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "P:El.Rect2d.BottomRight"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2d BottomRight { get; }
Visual Basic
Public ReadOnly Property BottomRight As Size2d
    Get
Visual C++
public:
property Size2d^ BottomRight {
    Size2d^ get ();
}

See Also

Rect2d Class


Center Property

[image]

One of William Foster's Class Libraries
Rect2d..::..Center Property
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "P:El.Rect2d.Center"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2d Center { get; }
Visual Basic
Public ReadOnly Property Center As Size2d
    Get
Visual C++
public:
property Size2d^ Center {
    Size2d^ get ();
}

See Also

Rect2d Class


TopLeft Property

[image]

One of William Foster's Class Libraries
Rect2d..::..TopLeft Property
Rect2d Class See Also Send Feedback

[Missing <summary> documentation for "P:El.Rect2d.TopLeft"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2d TopLeft { get; }
Visual Basic
Public ReadOnly Property TopLeft As Size2d
    Get
Visual C++
public:
property Size2d^ TopLeft {
    Size2d^ get ();
}

See Also

Rect2d Class


Rect2dU Class

[image]

One of William Foster's Class Libraries
Rect2dU Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Rect2dU"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Rect2dU
Visual Basic
Public Class Rect2dU
Visual C++
public ref class Rect2dU

Inheritance Hierarchy

System..::..Object
El..::..Rect2dU

See Also

Rect2dU Members


Rect2dU Members

[image] [image]

One of William Foster's Class Libraries
Rect2dU Members
Rect2dU Class Constructors Methods Operators Properties See Also Send Feedback

The Rect2dU type exposes the following members.

Constructors

 | Name | Description
Public method | Rect2dU()()()() | Initializes a new instance of the Rect2dU class
Public method | Rect2dU(Rect2dU) | Initializes a new instance of the Rect2dU class
Public method | Rect2dU(Size2dU, Size2dU) | Initializes a new instance of the Rect2dU class
Public method | Rect2dU(UInt32, UInt32, UInt32, UInt32) | Initializes a new instance of the Rect2dU class

Methods

 | Name | Description
Public method | Encapsulates(Rect2dU) |
Public method | Encapsulates(Size2dU) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(Size2dU%, Size2dU%) |
Public method | Get(UInt32%, UInt32%, UInt32%, UInt32%) |
Public method | GetAbsolute |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Height |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Offset |
Public method | OR |
 | RectFromPoints |
Public method | Set(Rect2dU) |
Public method | Set(Size2dU) |
Public method | Set(Size2dU, Size2dU) |
Public method | Set(UInt32, UInt32, UInt32, UInt32) |
Public method | SetHeight |
Public method | SetPosition |
Public method | SetSize |
Public method | SetWidth |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Width |

Operators

Name | Description
Addition |
Equality |
ImplicitWideningImplicitImplicitImplicit(Rect2dU to Rectangle) |
Inequality |
Multiply(Rect2dU, Double) |
Multiply(Rect2dU, UInt32) |

Properties

 | Name | Description
Public property | BottomRight |
Public property | Center |
Public property | TopLeft |

See Also

Rect2dU Class


Rect2dU Constructor

[image] [image]

One of William Foster's Class Libraries
Rect2dU Constructor
Rect2dU Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Rect2dU()()()() | Initializes a new instance of the Rect2dU class
Public method | Rect2dU(Rect2dU) | Initializes a new instance of the Rect2dU class
Public method | Rect2dU(Size2dU, Size2dU) | Initializes a new instance of the Rect2dU class
Public method | Rect2dU(UInt32, UInt32, UInt32, UInt32) | Initializes a new instance of the Rect2dU class

See Also

Rect2dU Class
Rect2dU Members


Rect2dU Constructor

[image]

One of William Foster's Class Libraries
Rect2dU Constructor
Rect2dU Class See Also Send Feedback
Initializes a new instance of the Rect2dU class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Rect2dU()
Visual Basic
Public Sub New
Visual C++
public:
Rect2dU()

See Also

Rect2dU Class
Rect2dU Overload


Rect2dU Constructor (Rect2dU)

[image]

One of William Foster's Class Libraries
Rect2dU Constructor (Rect2dU)
Rect2dU Class See Also Send Feedback
Initializes a new instance of the Rect2dU class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Rect2dU(
    Rect2dU rect2d
)
Visual Basic
Public Sub New ( _
    rect2d As Rect2dU _
)
Visual C++
public:
Rect2dU(
    Rect2dU^ rect2d
)

Parameters

rect2d
Type: El..::..Rect2dU

[Missing <param name="rect2d"/> documentation for "M:El.Rect2dU.#ctor(El.Rect2dU)"]

See Also

Rect2dU Class
Rect2dU Overload


Rect2dU Constructor (Size2dU, Size2dU)

[image]

One of William Foster's Class Libraries
Rect2dU Constructor (Size2dU, Size2dU)
Rect2dU Class See Also Send Feedback
Initializes a new instance of the Rect2dU class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Rect2dU(
    Size2dU position,
    Size2dU size
)
Visual Basic
Public Sub New ( _
    position As Size2dU, _
    size As Size2dU _
)
Visual C++
public:
Rect2dU(
    Size2dU^ position,
    Size2dU^ size
)

Parameters

position
Type: El..::..Size2dU

[Missing <param name="position"/> documentation for "M:El.Rect2dU.#ctor(El.Size2dU,El.Size2dU)"]

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Rect2dU.#ctor(El.Size2dU,El.Size2dU)"]

See Also

Rect2dU Class
Rect2dU Overload


Rect2dU Constructor (UInt32, UInt32, UInt32, UInt32)

[image]

One of William Foster's Class Libraries
Rect2dU Constructor (UInt32, UInt32, UInt32, UInt32)
Rect2dU Class See Also Send Feedback
Initializes a new instance of the Rect2dU class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Rect2dU(
    uint left,
    uint top,
    uint width,
    uint height
)
Visual Basic
Public Sub New ( _
    left As UInteger, _
    top As UInteger, _
    width As UInteger, _
    height As UInteger _
)
Visual C++
public:
Rect2dU(
    unsigned int left,
    unsigned int top,
    unsigned int width,
    unsigned int height
)

Parameters

left
Type: System..::..UInt32

[Missing <param name="left"/> documentation for "M:El.Rect2dU.#ctor(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

top
Type: System..::..UInt32

[Missing <param name="top"/> documentation for "M:El.Rect2dU.#ctor(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

width
Type: System..::..UInt32

[Missing <param name="width"/> documentation for "M:El.Rect2dU.#ctor(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

height
Type: System..::..UInt32

[Missing <param name="height"/> documentation for "M:El.Rect2dU.#ctor(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

See Also

Rect2dU Class
Rect2dU Overload


Rect2dU Methods

[image] [image]

One of William Foster's Class Libraries
Rect2dU Methods
Rect2dU Class See Also Send Feedback

The Rect2dU type exposes the following members.

Methods

 | Name | Description
Public method | Encapsulates(Rect2dU) |
Public method | Encapsulates(Size2dU) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(Size2dU%, Size2dU%) |
Public method | Get(UInt32%, UInt32%, UInt32%, UInt32%) |
Public method | GetAbsolute |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Height |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Offset |
Public method | OR |
 | RectFromPoints |
Public method | Set(Rect2dU) |
Public method | Set(Size2dU) |
Public method | Set(Size2dU, Size2dU) |
Public method | Set(UInt32, UInt32, UInt32, UInt32) |
Public method | SetHeight |
Public method | SetPosition |
Public method | SetSize |
Public method | SetWidth |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Width |

See Also

Rect2dU Class


Encapsulates Method

[image] [image]

One of William Foster's Class Libraries
Rect2dU..::..Encapsulates Method
Rect2dU Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Encapsulates(Rect2dU) |
Public method | Encapsulates(Size2dU) |

See Also

Rect2dU Class
Rect2dU Members


Encapsulates Method (Rect2dU)

[image]

One of William Foster's Class Libraries
Rect2dU..::..Encapsulates Method (Rect2dU)
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.Encapsulates(El.Rect2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Encapsulates(
    Rect2dU rect2d
)
Visual Basic
Public Function Encapsulates ( _
    rect2d As Rect2dU _
) As Boolean
Visual C++
public:
bool Encapsulates(
    Rect2dU^ rect2d
)

Parameters

rect2d
Type: El..::..Rect2dU

[Missing <param name="rect2d"/> documentation for "M:El.Rect2dU.Encapsulates(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Rect2dU.Encapsulates(El.Rect2dU)"]

See Also

Rect2dU Class
Encapsulates Overload


Encapsulates Method (Size2dU)

[image]

One of William Foster's Class Libraries
Rect2dU..::..Encapsulates Method (Size2dU)
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.Encapsulates(El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Encapsulates(
    Size2dU point2d
)
Visual Basic
Public Function Encapsulates ( _
    point2d As Size2dU _
) As Boolean
Visual C++
public:
bool Encapsulates(
    Size2dU^ point2d
)

Parameters

point2d
Type: El..::..Size2dU

[Missing <param name="point2d"/> documentation for "M:El.Rect2dU.Encapsulates(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Rect2dU.Encapsulates(El.Size2dU)"]

See Also

Rect2dU Class
Encapsulates Overload


Get Method

[image] [image]

One of William Foster's Class Libraries
Rect2dU..::..Get Method
Rect2dU Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(Size2dU%, Size2dU%) |
Public method | Get(UInt32%, UInt32%, UInt32%, UInt32%) |

See Also

Rect2dU Class
Rect2dU Members


Get Method (Size2dU, Size2dU)

[image]

One of William Foster's Class Libraries
Rect2dU..::..Get Method (Size2dU%, Size2dU%)
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.Get(El.Size2dU@,El.Size2dU@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Get(
    out Size2dU position,
    out Size2dU size
)
Visual Basic
Public Sub Get ( _
    <OutAttribute> ByRef position As Size2dU, _
    <OutAttribute> ByRef size As Size2dU _
)
Visual C++
public:
void Get(
    [OutAttribute] Size2dU^% position,
    [OutAttribute] Size2dU^% size
)

Parameters

position
Type: El..::..Size2dU %

[Missing <param name="position"/> documentation for "M:El.Rect2dU.Get(El.Size2dU@,El.Size2dU@)"]

size
Type: El..::..Size2dU %

[Missing <param name="size"/> documentation for "M:El.Rect2dU.Get(El.Size2dU@,El.Size2dU@)"]

See Also

Rect2dU Class
Get Overload


Get Method (UInt32, UInt32, UInt32, UInt32)

[image]

One of William Foster's Class Libraries
Rect2dU..::..Get Method (UInt32%, UInt32%, UInt32%, UInt32%)
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.Get(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Get(
    out uint u_x,
    out uint u_y,
    out uint u_w,
    out uint u_h
)
Visual Basic
Public Sub Get ( _
    <OutAttribute> ByRef u_x As UInteger, _
    <OutAttribute> ByRef u_y As UInteger, _
    <OutAttribute> ByRef u_w As UInteger, _
    <OutAttribute> ByRef u_h As UInteger _
)
Visual C++
public:
void Get(
    [OutAttribute] unsigned int% u_x,
    [OutAttribute] unsigned int% u_y,
    [OutAttribute] unsigned int% u_w,
    [OutAttribute] unsigned int% u_h
)

Parameters

u_x
Type: System..::..UInt32 %

[Missing <param name="u_x"/> documentation for "M:El.Rect2dU.Get(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

u_y
Type: System..::..UInt32 %

[Missing <param name="u_y"/> documentation for "M:El.Rect2dU.Get(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

u_w
Type: System..::..UInt32 %

[Missing <param name="u_w"/> documentation for "M:El.Rect2dU.Get(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

u_h
Type: System..::..UInt32 %

[Missing <param name="u_h"/> documentation for "M:El.Rect2dU.Get(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

See Also

Rect2dU Class
Get Overload


GetAbsolute Method

[image]

One of William Foster's Class Libraries
Rect2dU..::..GetAbsolute Method
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.GetAbsolute(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void GetAbsolute(
    out uint xul,
    out uint yul,
    out uint xlr,
    out uint ylr
)
Visual Basic
Public Sub GetAbsolute ( _
    <OutAttribute> ByRef xul As UInteger, _
    <OutAttribute> ByRef yul As UInteger, _
    <OutAttribute> ByRef xlr As UInteger, _
    <OutAttribute> ByRef ylr As UInteger _
)
Visual C++
public:
void GetAbsolute(
    [OutAttribute] unsigned int% xul,
    [OutAttribute] unsigned int% yul,
    [OutAttribute] unsigned int% xlr,
    [OutAttribute] unsigned int% ylr
)

Parameters

xul
Type: System..::..UInt32 %

[Missing <param name="xul"/> documentation for "M:El.Rect2dU.GetAbsolute(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

yul
Type: System..::..UInt32 %

[Missing <param name="yul"/> documentation for "M:El.Rect2dU.GetAbsolute(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

xlr
Type: System..::..UInt32 %

[Missing <param name="xlr"/> documentation for "M:El.Rect2dU.GetAbsolute(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

ylr
Type: System..::..UInt32 %

[Missing <param name="ylr"/> documentation for "M:El.Rect2dU.GetAbsolute(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

See Also

Rect2dU Class


GetSize Method

[image]

One of William Foster's Class Libraries
Rect2dU..::..GetSize Method
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.GetSize"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2dU GetSize()
Visual Basic
Public Function GetSize As Size2dU
Visual C++
public:
Size2dU^ GetSize()

Return Value

[Missing <returns> documentation for "M:El.Rect2dU.GetSize"]

See Also

Rect2dU Class


Height Method

[image]

One of William Foster's Class Libraries
Rect2dU..::..Height Method
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.Height"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint Height()
Visual Basic
Public Function Height As UInteger
Visual C++
public:
unsigned int Height()

Return Value

[Missing <returns> documentation for "M:El.Rect2dU.Height"]

See Also

Rect2dU Class


Offset Method

[image]

One of William Foster's Class Libraries
Rect2dU..::..Offset Method
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.Offset(El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Offset(
    Size2dU offset
)
Visual Basic
Public Sub Offset ( _
    offset As Size2dU _
)
Visual C++
public:
void Offset(
    Size2dU^ offset
)

Parameters

offset
Type: El..::..Size2dU

[Missing <param name="offset"/> documentation for "M:El.Rect2dU.Offset(El.Size2dU)"]

See Also

Rect2dU Class


OR Method

[image]

One of William Foster's Class Libraries
Rect2dU..::..OR Method
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.OR(El.Rect2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void OR(
    Rect2dU rect
)
Visual Basic
Public Sub OR ( _
    rect As Rect2dU _
)
Visual C++
public:
void OR(
    Rect2dU^ rect
)

Parameters

rect
Type: El..::..Rect2dU

[Missing <param name="rect"/> documentation for "M:El.Rect2dU.OR(El.Rect2dU)"]

See Also

Rect2dU Class


RectFromPoints Method

[image]

One of William Foster's Class Libraries
Rect2dU..::..RectFromPoints Method
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.RectFromPoints(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Rect2dU RectFromPoints(
    Size2dU pt1,
    Size2dU pt2
)
Visual Basic
Public Shared Function RectFromPoints ( _
    pt1 As Size2dU, _
    pt2 As Size2dU _
) As Rect2dU
Visual C++
public:
static Rect2dU^ RectFromPoints(
    Size2dU^ pt1,
    Size2dU^ pt2
)

Parameters

pt1
Type: El..::..Size2dU

[Missing <param name="pt1"/> documentation for "M:El.Rect2dU.RectFromPoints(El.Size2dU,El.Size2dU)"]

pt2
Type: El..::..Size2dU

[Missing <param name="pt2"/> documentation for "M:El.Rect2dU.RectFromPoints(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Rect2dU.RectFromPoints(El.Size2dU,El.Size2dU)"]

See Also

Rect2dU Class


Set Method

[image] [image]

One of William Foster's Class Libraries
Rect2dU..::..Set Method
Rect2dU Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Rect2dU) |
Public method | Set(Size2dU) |
Public method | Set(Size2dU, Size2dU) |
Public method | Set(UInt32, UInt32, UInt32, UInt32) |

See Also

Rect2dU Class
Rect2dU Members


Set Method (Rect2dU)

[image]

One of William Foster's Class Libraries
Rect2dU..::..Set Method (Rect2dU)
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.Set(El.Rect2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Set(
    Rect2dU rect2d
)
Visual Basic
Public Sub Set ( _
    rect2d As Rect2dU _
)
Visual C++
public:
void Set(
    Rect2dU^ rect2d
)

Parameters

rect2d
Type: El..::..Rect2dU

[Missing <param name="rect2d"/> documentation for "M:El.Rect2dU.Set(El.Rect2dU)"]

See Also

Rect2dU Class
Set Overload


Set Method (Size2dU)

[image]

One of William Foster's Class Libraries
Rect2dU..::..Set Method (Size2dU)
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.Set(El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Set(
    Size2dU size
)
Visual Basic
Public Sub Set ( _
    size As Size2dU _
)
Visual C++
public:
void Set(
    Size2dU^ size
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Rect2dU.Set(El.Size2dU)"]

See Also

Rect2dU Class
Set Overload


Set Method (Size2dU, Size2dU)

[image]

One of William Foster's Class Libraries
Rect2dU..::..Set Method (Size2dU, Size2dU)
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.Set(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Set(
    Size2dU position,
    Size2dU size
)
Visual Basic
Public Sub Set ( _
    position As Size2dU, _
    size As Size2dU _
)
Visual C++
public:
void Set(
    Size2dU^ position,
    Size2dU^ size
)

Parameters

position
Type: El..::..Size2dU

[Missing <param name="position"/> documentation for "M:El.Rect2dU.Set(El.Size2dU,El.Size2dU)"]

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Rect2dU.Set(El.Size2dU,El.Size2dU)"]

See Also

Rect2dU Class
Set Overload


Set Method (UInt32, UInt32, UInt32, UInt32)

[image]

One of William Foster's Class Libraries
Rect2dU..::..Set Method (UInt32, UInt32, UInt32, UInt32)
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.Set(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Set(
    uint left,
    uint top,
    uint width,
    uint height
)
Visual Basic
Public Sub Set ( _
    left As UInteger, _
    top As UInteger, _
    width As UInteger, _
    height As UInteger _
)
Visual C++
public:
void Set(
    unsigned int left,
    unsigned int top,
    unsigned int width,
    unsigned int height
)

Parameters

left
Type: System..::..UInt32

[Missing <param name="left"/> documentation for "M:El.Rect2dU.Set(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

top
Type: System..::..UInt32

[Missing <param name="top"/> documentation for "M:El.Rect2dU.Set(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

width
Type: System..::..UInt32

[Missing <param name="width"/> documentation for "M:El.Rect2dU.Set(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

height
Type: System..::..UInt32

[Missing <param name="height"/> documentation for "M:El.Rect2dU.Set(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

See Also

Rect2dU Class
Set Overload


SetHeight Method

[image]

One of William Foster's Class Libraries
Rect2dU..::..SetHeight Method
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.SetHeight(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetHeight(
    uint h
)
Visual Basic
Public Sub SetHeight ( _
    h As UInteger _
)
Visual C++
public:
void SetHeight(
    unsigned int h
)

Parameters

h
Type: System..::..UInt32

[Missing <param name="h"/> documentation for "M:El.Rect2dU.SetHeight(System.UInt32)"]

See Also

Rect2dU Class


SetPosition Method

[image]

One of William Foster's Class Libraries
Rect2dU..::..SetPosition Method
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.SetPosition(El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetPosition(
    Size2dU position
)
Visual Basic
Public Sub SetPosition ( _
    position As Size2dU _
)
Visual C++
public:
void SetPosition(
    Size2dU^ position
)

Parameters

position
Type: El..::..Size2dU

[Missing <param name="position"/> documentation for "M:El.Rect2dU.SetPosition(El.Size2dU)"]

See Also

Rect2dU Class


SetSize Method

[image]

One of William Foster's Class Libraries
Rect2dU..::..SetSize Method
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.SetSize(El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetSize(
    Size2dU size
)
Visual Basic
Public Sub SetSize ( _
    size As Size2dU _
)
Visual C++
public:
void SetSize(
    Size2dU^ size
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Rect2dU.SetSize(El.Size2dU)"]

See Also

Rect2dU Class


SetWidth Method

[image]

One of William Foster's Class Libraries
Rect2dU..::..SetWidth Method
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.SetWidth(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetWidth(
    uint w
)
Visual Basic
Public Sub SetWidth ( _
    w As UInteger _
)
Visual C++
public:
void SetWidth(
    unsigned int w
)

Parameters

w
Type: System..::..UInt32

[Missing <param name="w"/> documentation for "M:El.Rect2dU.SetWidth(System.UInt32)"]

See Also

Rect2dU Class


Width Method

[image]

One of William Foster's Class Libraries
Rect2dU..::..Width Method
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.Width"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint Width()
Visual Basic
Public Function Width As UInteger
Visual C++
public:
unsigned int Width()

Return Value

[Missing <returns> documentation for "M:El.Rect2dU.Width"]

See Also

Rect2dU Class


Rect2dU Operators and Type Conversions

[image] [image]

One of William Foster's Class Libraries
Rect2dU Operators and Type Conversions
Rect2dU Class See Also Send Feedback

The Rect2dU type exposes the following members.

Operators

Name | Description
Addition |
Equality |
ImplicitWideningImplicitImplicitImplicit(Rect2dU to Rectangle) |
Inequality |
Multiply(Rect2dU, Double) |
Multiply(Rect2dU, UInt32) |

See Also

Rect2dU Class


Addition Operator

[image]

One of William Foster's Class Libraries
Rect2dU..::..Addition Operator
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.op_Addition(El.Rect2dU,El.Rect2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Rect2dU operator +(
    Rect2dU r,
    Rect2dU AddRect
)
Visual Basic
Public Shared Operator + ( _
    r As Rect2dU, _
    AddRect As Rect2dU _
) As Rect2dU
Visual C++
public:
static Rect2dU^ operator +(
    Rect2dU^ r,
    Rect2dU^ AddRect
)

Parameters

r
Type: El..::..Rect2dU

[Missing <param name="r"/> documentation for "M:El.Rect2dU.op_Addition(El.Rect2dU,El.Rect2dU)"]

AddRect
Type: El..::..Rect2dU

[Missing <param name="AddRect"/> documentation for "M:El.Rect2dU.op_Addition(El.Rect2dU,El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Rect2dU.op_Addition(El.Rect2dU,El.Rect2dU)"]

See Also

Rect2dU Class


Equality Operator

[image]

One of William Foster's Class Libraries
Rect2dU..::..Equality Operator
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.op_Equality(El.Rect2dU,El.Rect2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator ==(
    Rect2dU r1,
    Rect2dU rect2d
)
Visual Basic
Public Shared Operator = ( _
    r1 As Rect2dU, _
    rect2d As Rect2dU _
) As Boolean
Visual C++
public:
static bool operator ==(
    Rect2dU^ r1,
    Rect2dU^ rect2d
)

Parameters

r1
Type: El..::..Rect2dU

[Missing <param name="r1"/> documentation for "M:El.Rect2dU.op_Equality(El.Rect2dU,El.Rect2dU)"]

rect2d
Type: El..::..Rect2dU

[Missing <param name="rect2d"/> documentation for "M:El.Rect2dU.op_Equality(El.Rect2dU,El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Rect2dU.op_Equality(El.Rect2dU,El.Rect2dU)"]

See Also

Rect2dU Class


Implicit Conversion (Rect2dU to Rectangle)

[image]

One of William Foster's Class Libraries
Rect2dU ImplicitWideningImplicitImplicitImplicit Conversion (Rect2dU to Rectangle)
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.op_Implicit(El.Rect2dU)~System.Drawing.Rectangle"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator Rectangle (
    Rect2dU r
)
Visual Basic
Public Shared Widening Operator CType ( _
    r As Rect2dU _
) As Rectangle
Visual C++
static implicit operator Rectangle (
    Rect2dU^ r
)

Parameters

r
Type: El..::..Rect2dU

[Missing <param name="r"/> documentation for "M:El.Rect2dU.op_Implicit(El.Rect2dU)~System.Drawing.Rectangle"]

Return Value

[Missing <returns> documentation for "M:El.Rect2dU.op_Implicit(El.Rect2dU)~System.Drawing.Rectangle"]

See Also

Rect2dU Class


Inequality Operator

[image]

One of William Foster's Class Libraries
Rect2dU..::..Inequality Operator
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.op_Inequality(El.Rect2dU,El.Rect2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator !=(
    Rect2dU r1,
    Rect2dU rect2d
)
Visual Basic
Public Shared Operator <> ( _
    r1 As Rect2dU, _
    rect2d As Rect2dU _
) As Boolean
Visual C++
public:
static bool operator !=(
    Rect2dU^ r1,
    Rect2dU^ rect2d
)

Parameters

r1
Type: El..::..Rect2dU

[Missing <param name="r1"/> documentation for "M:El.Rect2dU.op_Inequality(El.Rect2dU,El.Rect2dU)"]

rect2d
Type: El..::..Rect2dU

[Missing <param name="rect2d"/> documentation for "M:El.Rect2dU.op_Inequality(El.Rect2dU,El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Rect2dU.op_Inequality(El.Rect2dU,El.Rect2dU)"]

See Also

Rect2dU Class


Multiply Operator

[image] [image]

One of William Foster's Class Libraries
Rect2dU..::..Multiply Operator
Rect2dU Class See Also Send Feedback

Overload List

Name | Description
Multiply(Rect2dU, Double) |
Multiply(Rect2dU, UInt32) |

See Also

Rect2dU Class
Rect2dU Members


Multiply Operator (Rect2dU, Double)

[image]

One of William Foster's Class Libraries
Rect2dU..::..Multiply Operator (Rect2dU, Double)
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.op_Multiply(El.Rect2dU,System.Double)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Rect2dU operator *(
    Rect2dU r,
    double dmul
)
Visual Basic
Public Shared Operator * ( _
    r As Rect2dU, _
    dmul As Double _
) As Rect2dU
Visual C++
public:
static Rect2dU^ operator *(
    Rect2dU^ r,
    double dmul
)

Parameters

r
Type: El..::..Rect2dU

[Missing <param name="r"/> documentation for "M:El.Rect2dU.op_Multiply(El.Rect2dU,System.Double)"]

dmul
Type: System..::..Double

[Missing <param name="dmul"/> documentation for "M:El.Rect2dU.op_Multiply(El.Rect2dU,System.Double)"]

Return Value

[Missing <returns> documentation for "M:El.Rect2dU.op_Multiply(El.Rect2dU,System.Double)"]

See Also

Rect2dU Class
Multiply Overload


Multiply Operator (Rect2dU, UInt32)

[image]

One of William Foster's Class Libraries
Rect2dU..::..Multiply Operator (Rect2dU, UInt32)
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Rect2dU.op_Multiply(El.Rect2dU,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Rect2dU operator *(
    Rect2dU r,
    uint umul
)
Visual Basic
Public Shared Operator * ( _
    r As Rect2dU, _
    umul As UInteger _
) As Rect2dU
Visual C++
public:
static Rect2dU^ operator *(
    Rect2dU^ r,
    unsigned int umul
)

Parameters

r
Type: El..::..Rect2dU

[Missing <param name="r"/> documentation for "M:El.Rect2dU.op_Multiply(El.Rect2dU,System.UInt32)"]

umul
Type: System..::..UInt32

[Missing <param name="umul"/> documentation for "M:El.Rect2dU.op_Multiply(El.Rect2dU,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.Rect2dU.op_Multiply(El.Rect2dU,System.UInt32)"]

See Also

Rect2dU Class
Multiply Overload


Rect2dU Properties

[image] [image]

One of William Foster's Class Libraries
Rect2dU Properties
Rect2dU Class See Also Send Feedback

The Rect2dU type exposes the following members.

Properties

 | Name | Description
Public property | BottomRight |
Public property | Center |
Public property | TopLeft |

See Also

Rect2dU Class


BottomRight Property

[image]

One of William Foster's Class Libraries
Rect2dU..::..BottomRight Property
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "P:El.Rect2dU.BottomRight"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2dU BottomRight { get; }
Visual Basic
Public ReadOnly Property BottomRight As Size2dU
    Get
Visual C++
public:
property Size2dU^ BottomRight {
    Size2dU^ get ();
}

See Also

Rect2dU Class


Center Property

[image]

One of William Foster's Class Libraries
Rect2dU..::..Center Property
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "P:El.Rect2dU.Center"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2dU Center { get; }
Visual Basic
Public ReadOnly Property Center As Size2dU
    Get
Visual C++
public:
property Size2dU^ Center {
    Size2dU^ get ();
}

See Also

Rect2dU Class


TopLeft Property

[image]

One of William Foster's Class Libraries
Rect2dU..::..TopLeft Property
Rect2dU Class See Also Send Feedback

[Missing <summary> documentation for "P:El.Rect2dU.TopLeft"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2dU TopLeft { get; }
Visual Basic
Public ReadOnly Property TopLeft As Size2dU
    Get
Visual C++
public:
property Size2dU^ TopLeft {
    Size2dU^ get ();
}

See Also

Rect2dU Class


Registry Class

[image]

One of William Foster's Class Libraries
Registry Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Registry"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Registry
Visual Basic
Public Class Registry
Visual C++
public ref class Registry

Inheritance Hierarchy

System..::..Object
El..::..Registry

See Also

Registry Members


Registry Members

[image] [image]

One of William Foster's Class Libraries
Registry Members
Registry Class Constructors Methods See Also Send Feedback

The Registry type exposes the following members.

Constructors

 | Name | Description
Public method | Registry | Initializes a new instance of the Registry class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetDouble |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put |
Public method | PutDouble |
Public method | PutString |
Public method | PutValue |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Registry Class


Registry Constructor

[image]

One of William Foster's Class Libraries
Registry Constructor
Registry Class See Also Send Feedback
Initializes a new instance of the Registry class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Registry(
    STRING csRegname
)
Visual Basic
Public Sub New ( _
    csRegname As STRING _
)
Visual C++
public:
Registry(
    STRING^ csRegname
)

Parameters

csRegname
Type: El..::..STRING

[Missing <param name="csRegname"/> documentation for "M:El.Registry.#ctor(El.STRING)"]

See Also

Registry Class


Registry Methods

[image] [image]

One of William Foster's Class Libraries
Registry Methods
Registry Class See Also Send Feedback

The Registry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetDouble |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Put |
Public method | PutDouble |
Public method | PutString |
Public method | PutValue |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Registry Class


Get Method

[image]

One of William Foster's Class Libraries
Registry..::..Get Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Registry.Get(El.STRING,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Get(
    STRING csKey,
    ref uint uVal
)
Visual Basic
Public Function Get ( _
    csKey As STRING, _
    ByRef uVal As UInteger _
) As Boolean
Visual C++
public:
bool Get(
    STRING^ csKey,
    unsigned int% uVal
)

Parameters

csKey
Type: El..::..STRING

[Missing <param name="csKey"/> documentation for "M:El.Registry.Get(El.STRING,System.UInt32@)"]

uVal
Type: System..::..UInt32 %

[Missing <param name="uVal"/> documentation for "M:El.Registry.Get(El.STRING,System.UInt32@)"]

Return Value

[Missing <returns> documentation for "M:El.Registry.Get(El.STRING,System.UInt32@)"]

See Also

Registry Class


GetDouble Method

[image]

One of William Foster's Class Libraries
Registry..::..GetDouble Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Registry.GetDouble(El.STRING,System.Double@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool GetDouble(
    STRING csKey,
    ref double dVal
)
Visual Basic
Public Function GetDouble ( _
    csKey As STRING, _
    ByRef dVal As Double _
) As Boolean
Visual C++
public:
bool GetDouble(
    STRING^ csKey,
    double% dVal
)

Parameters

csKey
Type: El..::..STRING

[Missing <param name="csKey"/> documentation for "M:El.Registry.GetDouble(El.STRING,System.Double@)"]

dVal
Type: System..::..Double %

[Missing <param name="dVal"/> documentation for "M:El.Registry.GetDouble(El.STRING,System.Double@)"]

Return Value

[Missing <returns> documentation for "M:El.Registry.GetDouble(El.STRING,System.Double@)"]

See Also

Registry Class


GetString Method

[image]

One of William Foster's Class Libraries
Registry..::..GetString Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Registry.GetString(El.STRING,El.STRING@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool GetString(
    STRING csKey,
    ref STRING csVal
)
Visual Basic
Public Function GetString ( _
    csKey As STRING, _
    ByRef csVal As STRING _
) As Boolean
Visual C++
public:
bool GetString(
    STRING^ csKey,
    STRING^% csVal
)

Parameters

csKey
Type: El..::..STRING

[Missing <param name="csKey"/> documentation for "M:El.Registry.GetString(El.STRING,El.STRING@)"]

csVal
Type: El..::..STRING %

[Missing <param name="csVal"/> documentation for "M:El.Registry.GetString(El.STRING,El.STRING@)"]

Return Value

[Missing <returns> documentation for "M:El.Registry.GetString(El.STRING,El.STRING@)"]

See Also

Registry Class


GetValue Method

[image]

One of William Foster's Class Libraries
Registry..::..GetValue Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Registry.GetValue(El.STRING,El.Value@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool GetValue(
    STRING csKey,
    ref Value value
)
Visual Basic
Public Function GetValue ( _
    csKey As STRING, _
    ByRef value As Value _
) As Boolean
Visual C++
public:
bool GetValue(
    STRING^ csKey,
    Value^% value
)

Parameters

csKey
Type: El..::..STRING

[Missing <param name="csKey"/> documentation for "M:El.Registry.GetValue(El.STRING,El.Value@)"]

value
Type: El..::..Value %

[Missing <param name="value"/> documentation for "M:El.Registry.GetValue(El.STRING,El.Value@)"]

Return Value

[Missing <returns> documentation for "M:El.Registry.GetValue(El.STRING,El.Value@)"]

See Also

Registry Class


Put Method

[image]

One of William Foster's Class Libraries
Registry..::..Put Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Registry.Put(El.STRING,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Put(
    STRING csKey,
    uint uVal
)
Visual Basic
Public Function Put ( _
    csKey As STRING, _
    uVal As UInteger _
) As Boolean
Visual C++
public:
bool Put(
    STRING^ csKey,
    unsigned int uVal
)

Parameters

csKey
Type: El..::..STRING

[Missing <param name="csKey"/> documentation for "M:El.Registry.Put(El.STRING,System.UInt32)"]

uVal
Type: System..::..UInt32

[Missing <param name="uVal"/> documentation for "M:El.Registry.Put(El.STRING,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.Registry.Put(El.STRING,System.UInt32)"]

See Also

Registry Class


PutDouble Method

[image]

One of William Foster's Class Libraries
Registry..::..PutDouble Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Registry.PutDouble(El.STRING,System.Double)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool PutDouble(
    STRING csKey,
    double dVal
)
Visual Basic
Public Function PutDouble ( _
    csKey As STRING, _
    dVal As Double _
) As Boolean
Visual C++
public:
bool PutDouble(
    STRING^ csKey,
    double dVal
)

Parameters

csKey
Type: El..::..STRING

[Missing <param name="csKey"/> documentation for "M:El.Registry.PutDouble(El.STRING,System.Double)"]

dVal
Type: System..::..Double

[Missing <param name="dVal"/> documentation for "M:El.Registry.PutDouble(El.STRING,System.Double)"]

Return Value

[Missing <returns> documentation for "M:El.Registry.PutDouble(El.STRING,System.Double)"]

See Also

Registry Class


PutString Method

[image]

One of William Foster's Class Libraries
Registry..::..PutString Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Registry.PutString(El.STRING,El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool PutString(
    STRING csKey,
    STRING csVal
)
Visual Basic
Public Function PutString ( _
    csKey As STRING, _
    csVal As STRING _
) As Boolean
Visual C++
public:
bool PutString(
    STRING^ csKey,
    STRING^ csVal
)

Parameters

csKey
Type: El..::..STRING

[Missing <param name="csKey"/> documentation for "M:El.Registry.PutString(El.STRING,El.STRING)"]

csVal
Type: El..::..STRING

[Missing <param name="csVal"/> documentation for "M:El.Registry.PutString(El.STRING,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.Registry.PutString(El.STRING,El.STRING)"]

See Also

Registry Class


PutValue Method

[image]

One of William Foster's Class Libraries
Registry..::..PutValue Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Registry.PutValue(El.STRING,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool PutValue(
    STRING csKey,
    Value value
)
Visual Basic
Public Function PutValue ( _
    csKey As STRING, _
    value As Value _
) As Boolean
Visual C++
public:
bool PutValue(
    STRING^ csKey,
    Value^ value
)

Parameters

csKey
Type: El..::..STRING

[Missing <param name="csKey"/> documentation for "M:El.Registry.PutValue(El.STRING,El.Value)"]

value
Type: El..::..Value

[Missing <param name="value"/> documentation for "M:El.Registry.PutValue(El.STRING,El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Registry.PutValue(El.STRING,El.Value)"]

See Also

Registry Class


SEl_Character Class

[image]

One of William Foster's Class Libraries
SEl_Character Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.SEl_Character"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static class SEl_Character
Visual Basic
Public NotInheritable Class SEl_Character
Visual C++
public ref class SEl_Character abstract sealed

Inheritance Hierarchy

System..::..Object
El..::..SEl_Character

See Also

SEl_Character Members


SEl_Character Members

[image] [image]

One of William Foster's Class Libraries
SEl_Character Members
SEl_Character Class Methods See Also Send Feedback

The SEl_Character type exposes the following members.

Methods

Name | Description
Block_UTF16toCharacter |
Block_UTF16toUTF8 |
Block_UTF8toCharacter |
IsDigit |
isWhiteSpace |
StringCompare |
StringCompareNoCase |
StringToDouble |
StringToInteger |
toupper |
UpperCase |

See Also

SEl_Character Class


SEl_Character Methods

[image] [image]

One of William Foster's Class Libraries
SEl_Character Methods
SEl_Character Class See Also Send Feedback

The SEl_Character type exposes the following members.

Methods

Name | Description
Block_UTF16toCharacter |
Block_UTF16toUTF8 |
Block_UTF8toCharacter |
IsDigit |
isWhiteSpace |
StringCompare |
StringCompareNoCase |
StringToDouble |
StringToInteger |
toupper |
UpperCase |

See Also

SEl_Character Class


Block_UTF16toCharacter Method

[image]

One of William Foster's Class Libraries
SEl_Character..::..Block_UTF16toCharacter Method
SEl_Character Class See Also Send Feedback

[Missing <summary> documentation for "M:El.SEl_Character.Block_UTF16toCharacter(System.Byte[],System.Char[],System.UInt32,System.Boolean)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void Block_UTF16toCharacter(
    byte[] bytep_Source,
    char[] charp_dest,
    uint u_CharsInBlock,
    bool b_BigEndian
)
Visual Basic
Public Shared Sub Block_UTF16toCharacter ( _
    bytep_Source As Byte(), _
    charp_dest As Char(), _
    u_CharsInBlock As UInteger, _
    b_BigEndian As Boolean _
)
Visual C++
public:
static void Block_UTF16toCharacter(
    array<unsigned char>^ bytep_Source,
    array<wchar_t>^ charp_dest,
    unsigned int u_CharsInBlock,
    bool b_BigEndian
)

Parameters

bytep_Source
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bytep_Source"/> documentation for "M:El.SEl_Character.Block_UTF16toCharacter(System.Byte[],System.Char[],System.UInt32,System.Boolean)"]

charp_dest
Type: array< System..::..Char >[]()[][]

[Missing <param name="charp_dest"/> documentation for "M:El.SEl_Character.Block_UTF16toCharacter(System.Byte[],System.Char[],System.UInt32,System.Boolean)"]

u_CharsInBlock
Type: System..::..UInt32

[Missing <param name="u_CharsInBlock"/> documentation for "M:El.SEl_Character.Block_UTF16toCharacter(System.Byte[],System.Char[],System.UInt32,System.Boolean)"]

b_BigEndian
Type: System..::..Boolean

[Missing <param name="b_BigEndian"/> documentation for "M:El.SEl_Character.Block_UTF16toCharacter(System.Byte[],System.Char[],System.UInt32,System.Boolean)"]

See Also

SEl_Character Class


Block_UTF16toUTF8 Method

[image]

One of William Foster's Class Libraries
SEl_Character..::..Block_UTF16toUTF8 Method
SEl_Character Class See Also Send Feedback

[Missing <summary> documentation for "M:El.SEl_Character.Block_UTF16toUTF8(System.Char[],System.Byte[],System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void Block_UTF16toUTF8(
    char[] charp_source,
    byte[] bp_dest,
    uint u_CharsInBlock
)
Visual Basic
Public Shared Sub Block_UTF16toUTF8 ( _
    charp_source As Char(), _
    bp_dest As Byte(), _
    u_CharsInBlock As UInteger _
)
Visual C++
public:
static void Block_UTF16toUTF8(
    array<wchar_t>^ charp_source,
    array<unsigned char>^ bp_dest,
    unsigned int u_CharsInBlock
)

Parameters

charp_source
Type: array< System..::..Char >[]()[][]

[Missing <param name="charp_source"/> documentation for "M:El.SEl_Character.Block_UTF16toUTF8(System.Char[],System.Byte[],System.UInt32)"]

bp_dest
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bp_dest"/> documentation for "M:El.SEl_Character.Block_UTF16toUTF8(System.Char[],System.Byte[],System.UInt32)"]

u_CharsInBlock
Type: System..::..UInt32

[Missing <param name="u_CharsInBlock"/> documentation for "M:El.SEl_Character.Block_UTF16toUTF8(System.Char[],System.Byte[],System.UInt32)"]

See Also

SEl_Character Class


Block_UTF8toCharacter Method

[image]

One of William Foster's Class Libraries
SEl_Character..::..Block_UTF8toCharacter Method
SEl_Character Class See Also Send Feedback

[Missing <summary> documentation for "M:El.SEl_Character.Block_UTF8toCharacter(System.Byte[],System.Char[],System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void Block_UTF8toCharacter(
    byte[] bytep_Source,
    char[] charp_dest,
    uint u_CharsInBlock
)
Visual Basic
Public Shared Sub Block_UTF8toCharacter ( _
    bytep_Source As Byte(), _
    charp_dest As Char(), _
    u_CharsInBlock As UInteger _
)
Visual C++
public:
static void Block_UTF8toCharacter(
    array<unsigned char>^ bytep_Source,
    array<wchar_t>^ charp_dest,
    unsigned int u_CharsInBlock
)

Parameters

bytep_Source
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bytep_Source"/> documentation for "M:El.SEl_Character.Block_UTF8toCharacter(System.Byte[],System.Char[],System.UInt32)"]

charp_dest
Type: array< System..::..Char >[]()[][]

[Missing <param name="charp_dest"/> documentation for "M:El.SEl_Character.Block_UTF8toCharacter(System.Byte[],System.Char[],System.UInt32)"]

u_CharsInBlock
Type: System..::..UInt32

[Missing <param name="u_CharsInBlock"/> documentation for "M:El.SEl_Character.Block_UTF8toCharacter(System.Byte[],System.Char[],System.UInt32)"]

See Also

SEl_Character Class


IsDigit Method

[image]

One of William Foster's Class Libraries
SEl_Character..::..IsDigit Method
SEl_Character Class See Also Send Feedback

[Missing <summary> documentation for "M:El.SEl_Character.IsDigit(System.Char)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool IsDigit(
    char c
)
Visual Basic
Public Shared Function IsDigit ( _
    c As Char _
) As Boolean
Visual C++
public:
static bool IsDigit(
    wchar_t c
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:El.SEl_Character.IsDigit(System.Char)"]

Return Value

[Missing <returns> documentation for "M:El.SEl_Character.IsDigit(System.Char)"]

See Also

SEl_Character Class


isWhiteSpace Method

[image]

One of William Foster's Class Libraries
SEl_Character..::..isWhiteSpace Method
SEl_Character Class See Also Send Feedback

[Missing <summary> documentation for "M:El.SEl_Character.isWhiteSpace(System.Char)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool isWhiteSpace(
    char c
)
Visual Basic
Public Shared Function isWhiteSpace ( _
    c As Char _
) As Boolean
Visual C++
public:
static bool isWhiteSpace(
    wchar_t c
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:El.SEl_Character.isWhiteSpace(System.Char)"]

Return Value

[Missing <returns> documentation for "M:El.SEl_Character.isWhiteSpace(System.Char)"]

See Also

SEl_Character Class


StringCompare Method

[image]

One of William Foster's Class Libraries
SEl_Character..::..StringCompare Method
SEl_Character Class See Also Send Feedback

[Missing <summary> documentation for "M:El.SEl_Character.StringCompare(System.Char[],System.Int32,System.Char[],System.Int32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool StringCompare(
    char[] dst,
    int dstoff,
    char[] src,
    int srcoff
)
Visual Basic
Public Shared Function StringCompare ( _
    dst As Char(), _
    dstoff As Integer, _
    src As Char(), _
    srcoff As Integer _
) As Boolean
Visual C++
public:
static bool StringCompare(
    array<wchar_t>^ dst,
    int dstoff,
    array<wchar_t>^ src,
    int srcoff
)

Parameters

dst
Type: array< System..::..Char >[]()[][]

[Missing <param name="dst"/> documentation for "M:El.SEl_Character.StringCompare(System.Char[],System.Int32,System.Char[],System.Int32)"]

dstoff
Type: System..::..Int32

[Missing <param name="dstoff"/> documentation for "M:El.SEl_Character.StringCompare(System.Char[],System.Int32,System.Char[],System.Int32)"]

src
Type: array< System..::..Char >[]()[][]

[Missing <param name="src"/> documentation for "M:El.SEl_Character.StringCompare(System.Char[],System.Int32,System.Char[],System.Int32)"]

srcoff
Type: System..::..Int32

[Missing <param name="srcoff"/> documentation for "M:El.SEl_Character.StringCompare(System.Char[],System.Int32,System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:El.SEl_Character.StringCompare(System.Char[],System.Int32,System.Char[],System.Int32)"]

See Also

SEl_Character Class


StringCompareNoCase Method

[image]

One of William Foster's Class Libraries
SEl_Character..::..StringCompareNoCase Method
SEl_Character Class See Also Send Feedback

[Missing <summary> documentation for "M:El.SEl_Character.StringCompareNoCase(System.Char[],System.Int32,System.Char[],System.Int32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool StringCompareNoCase(
    char[] dst,
    int dstoff,
    char[] src,
    int srcoff
)
Visual Basic
Public Shared Function StringCompareNoCase ( _
    dst As Char(), _
    dstoff As Integer, _
    src As Char(), _
    srcoff As Integer _
) As Boolean
Visual C++
public:
static bool StringCompareNoCase(
    array<wchar_t>^ dst,
    int dstoff,
    array<wchar_t>^ src,
    int srcoff
)

Parameters

dst
Type: array< System..::..Char >[]()[][]

[Missing <param name="dst"/> documentation for "M:El.SEl_Character.StringCompareNoCase(System.Char[],System.Int32,System.Char[],System.Int32)"]

dstoff
Type: System..::..Int32

[Missing <param name="dstoff"/> documentation for "M:El.SEl_Character.StringCompareNoCase(System.Char[],System.Int32,System.Char[],System.Int32)"]

src
Type: array< System..::..Char >[]()[][]

[Missing <param name="src"/> documentation for "M:El.SEl_Character.StringCompareNoCase(System.Char[],System.Int32,System.Char[],System.Int32)"]

srcoff
Type: System..::..Int32

[Missing <param name="srcoff"/> documentation for "M:El.SEl_Character.StringCompareNoCase(System.Char[],System.Int32,System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:El.SEl_Character.StringCompareNoCase(System.Char[],System.Int32,System.Char[],System.Int32)"]

See Also

SEl_Character Class


StringToDouble Method

[image]

One of William Foster's Class Libraries
SEl_Character..::..StringToDouble Method
SEl_Character Class See Also Send Feedback

[Missing <summary> documentation for "M:El.SEl_Character.StringToDouble(System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static double StringToDouble(
    string ptr
)
Visual Basic
Public Shared Function StringToDouble ( _
    ptr As String _
) As Double
Visual C++
public:
static double StringToDouble(
    String^ ptr
)

Parameters

ptr
Type: System..::..String

[Missing <param name="ptr"/> documentation for "M:El.SEl_Character.StringToDouble(System.String)"]

Return Value

[Missing <returns> documentation for "M:El.SEl_Character.StringToDouble(System.String)"]

See Also

SEl_Character Class


StringToInteger Method

[image]

One of William Foster's Class Libraries
SEl_Character..::..StringToInteger Method
SEl_Character Class See Also Send Feedback

[Missing <summary> documentation for "M:El.SEl_Character.StringToInteger(System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static int StringToInteger(
    string ptr
)
Visual Basic
Public Shared Function StringToInteger ( _
    ptr As String _
) As Integer
Visual C++
public:
static int StringToInteger(
    String^ ptr
)

Parameters

ptr
Type: System..::..String

[Missing <param name="ptr"/> documentation for "M:El.SEl_Character.StringToInteger(System.String)"]

Return Value

[Missing <returns> documentation for "M:El.SEl_Character.StringToInteger(System.String)"]

See Also

SEl_Character Class


toupper Method

[image]

One of William Foster's Class Libraries
SEl_Character..::..toupper Method
SEl_Character Class See Also Send Feedback

[Missing <summary> documentation for "M:El.SEl_Character.toupper(System.Char)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static char toupper(
    char c
)
Visual Basic
Public Shared Function toupper ( _
    c As Char _
) As Char
Visual C++
public:
static wchar_t toupper(
    wchar_t c
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:El.SEl_Character.toupper(System.Char)"]

Return Value

[Missing <returns> documentation for "M:El.SEl_Character.toupper(System.Char)"]

See Also

SEl_Character Class


UpperCase Method

[image]

One of William Foster's Class Libraries
SEl_Character..::..UpperCase Method
SEl_Character Class See Also Send Feedback

[Missing <summary> documentation for "M:El.SEl_Character.UpperCase(System.Char)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static char UpperCase(
    char c
)
Visual Basic
Public Shared Function UpperCase ( _
    c As Char _
) As Char
Visual C++
public:
static wchar_t UpperCase(
    wchar_t c
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:El.SEl_Character.UpperCase(System.Char)"]

Return Value

[Missing <returns> documentation for "M:El.SEl_Character.UpperCase(System.Char)"]

See Also

SEl_Character Class


Size2d Class

[image]

One of William Foster's Class Libraries
Size2d Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Size2d"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Size2d
Visual Basic
Public Class Size2d
Visual C++
public ref class Size2d

Inheritance Hierarchy

System..::..Object
El..::..Size2d

See Also

Size2d Members


Size2d Members

[image] [image]

One of William Foster's Class Libraries
Size2d Members
Size2d Class Constructors Methods Operators See Also Send Feedback

The Size2d type exposes the following members.

Constructors

 | Name | Description
Public method | Size2d()()()() | Initializes a new instance of the Size2d class
Public method | Size2d(Size2d) | Initializes a new instance of the Size2d class
Public method | Size2d(Size2dU) | Initializes a new instance of the Size2d class
Public method | Size2d(Value, Value) | Initializes a new instance of the Size2d class

Methods

 | Name | Description
Public method | DecrementX |
Public method | DecrementY |
Public method | DistanceTo |
Public method | Encapsulates |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(UInt32%, UInt32%) |
Public method | Get(Value%, Value%) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetX |
Public method | GetY |
Public method | IncrementX |
Public method | IncrementY |
Public method | Iterate(Rect2d) |
Public method | Iterate(Size2d) |
Public method | Iterate(Size2d, Size2d) |
Public method | IterateX(Rect2d) |
Public method | IterateX(Size2d) |
Public method | IterateY(Rect2d) |
Public method | IterateY(Size2d) |
Public method | Maximum |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minimum |
Public method | Product(Double%) |
Public method | Product(UInt32%) |
Public method | Product(Value%) |
Public method | Set(Size2d) |
Public method | Set(Value, Value) |
Public method | SetX |
Public method | SetY |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Zero |

Operators

Name | Description
Addition |
Division(Size2d, Size2d) |
Division(Size2d, Double) |
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Modulus |
Multiply(Size2d, Size2d) |
Multiply(Size2d, Double) |
Subtraction |

See Also

Size2d Class


Size2d Constructor

[image] [image]

One of William Foster's Class Libraries
Size2d Constructor
Size2d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Size2d()()()() | Initializes a new instance of the Size2d class
Public method | Size2d(Size2d) | Initializes a new instance of the Size2d class
Public method | Size2d(Size2dU) | Initializes a new instance of the Size2d class
Public method | Size2d(Value, Value) | Initializes a new instance of the Size2d class

See Also

Size2d Class
Size2d Members


Size2d Constructor

[image]

One of William Foster's Class Libraries
Size2d Constructor
Size2d Class See Also Send Feedback
Initializes a new instance of the Size2d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2d()
Visual Basic
Public Sub New
Visual C++
public:
Size2d()

See Also

Size2d Class
Size2d Overload


Size2d Constructor (Size2d)

[image]

One of William Foster's Class Libraries
Size2d Constructor (Size2d)
Size2d Class See Also Send Feedback
Initializes a new instance of the Size2d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2d(
    Size2d size
)
Visual Basic
Public Sub New ( _
    size As Size2d _
)
Visual C++
public:
Size2d(
    Size2d^ size
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.#ctor(El.Size2d)"]

See Also

Size2d Class
Size2d Overload


Size2d Constructor (Size2dU)

[image]

One of William Foster's Class Libraries
Size2d Constructor (Size2dU)
Size2d Class See Also Send Feedback
Initializes a new instance of the Size2d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2d(
    Size2dU size
)
Visual Basic
Public Sub New ( _
    size As Size2dU _
)
Visual C++
public:
Size2d(
    Size2dU^ size
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2d.#ctor(El.Size2dU)"]

See Also

Size2d Class
Size2d Overload


Size2d Constructor (Value, Value)

[image]

One of William Foster's Class Libraries
Size2d Constructor (Value, Value)
Size2d Class See Also Send Feedback
Initializes a new instance of the Size2d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2d(
    Value dimensionX,
    Value dimensionY
)
Visual Basic
Public Sub New ( _
    dimensionX As Value, _
    dimensionY As Value _
)
Visual C++
public:
Size2d(
    Value^ dimensionX,
    Value^ dimensionY
)

Parameters

dimensionX
Type: El..::..Value

[Missing <param name="dimensionX"/> documentation for "M:El.Size2d.#ctor(El.Value,El.Value)"]

dimensionY
Type: El..::..Value

[Missing <param name="dimensionY"/> documentation for "M:El.Size2d.#ctor(El.Value,El.Value)"]

See Also

Size2d Class
Size2d Overload


Size2d Methods

[image] [image]

One of William Foster's Class Libraries
Size2d Methods
Size2d Class See Also Send Feedback

The Size2d type exposes the following members.

Methods

 | Name | Description
Public method | DecrementX |
Public method | DecrementY |
Public method | DistanceTo |
Public method | Encapsulates |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(UInt32%, UInt32%) |
Public method | Get(Value%, Value%) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetX |
Public method | GetY |
Public method | IncrementX |
Public method | IncrementY |
Public method | Iterate(Rect2d) |
Public method | Iterate(Size2d) |
Public method | Iterate(Size2d, Size2d) |
Public method | IterateX(Rect2d) |
Public method | IterateX(Size2d) |
Public method | IterateY(Rect2d) |
Public method | IterateY(Size2d) |
Public method | Maximum |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minimum |
Public method | Product(Double%) |
Public method | Product(UInt32%) |
Public method | Product(Value%) |
Public method | Set(Size2d) |
Public method | Set(Value, Value) |
Public method | SetX |
Public method | SetY |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Zero |

See Also

Size2d Class


DecrementX Method

[image]

One of William Foster's Class Libraries
Size2d..::..DecrementX Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.DecrementX"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void DecrementX()
Visual Basic
Public Sub DecrementX
Visual C++
public:
void DecrementX()

See Also

Size2d Class


DecrementY Method

[image]

One of William Foster's Class Libraries
Size2d..::..DecrementY Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.DecrementY"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void DecrementY()
Visual Basic
Public Sub DecrementY
Visual C++
public:
void DecrementY()

See Also

Size2d Class


DistanceTo Method

[image]

One of William Foster's Class Libraries
Size2d..::..DistanceTo Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.DistanceTo(El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public double DistanceTo(
    Size2d siz
)
Visual Basic
Public Function DistanceTo ( _
    siz As Size2d _
) As Double
Visual C++
public:
double DistanceTo(
    Size2d^ siz
)

Parameters

siz
Type: El..::..Size2d

[Missing <param name="siz"/> documentation for "M:El.Size2d.DistanceTo(El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.DistanceTo(El.Size2d)"]

See Also

Size2d Class


Encapsulates Method

[image]

One of William Foster's Class Libraries
Size2d..::..Encapsulates Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Encapsulates(El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Encapsulates(
    Size2d siz
)
Visual Basic
Public Function Encapsulates ( _
    siz As Size2d _
) As Boolean
Visual C++
public:
bool Encapsulates(
    Size2d^ siz
)

Parameters

siz
Type: El..::..Size2d

[Missing <param name="siz"/> documentation for "M:El.Size2d.Encapsulates(El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.Encapsulates(El.Size2d)"]

See Also

Size2d Class


Get Method

[image] [image]

One of William Foster's Class Libraries
Size2d..::..Get Method
Size2d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(UInt32%, UInt32%) |
Public method | Get(Value%, Value%) |

See Also

Size2d Class
Size2d Members


Get Method (UInt32, UInt32)

[image]

One of William Foster's Class Libraries
Size2d..::..Get Method (UInt32%, UInt32%)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Get(System.UInt32@,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Get(
    out uint u_x,
    out uint u_y
)
Visual Basic
Public Sub Get ( _
    <OutAttribute> ByRef u_x As UInteger, _
    <OutAttribute> ByRef u_y As UInteger _
)
Visual C++
public:
void Get(
    [OutAttribute] unsigned int% u_x,
    [OutAttribute] unsigned int% u_y
)

Parameters

u_x
Type: System..::..UInt32 %

[Missing <param name="u_x"/> documentation for "M:El.Size2d.Get(System.UInt32@,System.UInt32@)"]

u_y
Type: System..::..UInt32 %

[Missing <param name="u_y"/> documentation for "M:El.Size2d.Get(System.UInt32@,System.UInt32@)"]

See Also

Size2d Class
Get Overload


Get Method (Value, Value)

[image]

One of William Foster's Class Libraries
Size2d..::..Get Method (Value%, Value%)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Get(El.Value@,El.Value@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Get(
    out Value dimensionX,
    out Value dimensionY
)
Visual Basic
Public Sub Get ( _
    <OutAttribute> ByRef dimensionX As Value, _
    <OutAttribute> ByRef dimensionY As Value _
)
Visual C++
public:
void Get(
    [OutAttribute] Value^% dimensionX,
    [OutAttribute] Value^% dimensionY
)

Parameters

dimensionX
Type: El..::..Value %

[Missing <param name="dimensionX"/> documentation for "M:El.Size2d.Get(El.Value@,El.Value@)"]

dimensionY
Type: El..::..Value %

[Missing <param name="dimensionY"/> documentation for "M:El.Size2d.Get(El.Value@,El.Value@)"]

See Also

Size2d Class
Get Overload


GetIndex Method

[image]

One of William Foster's Class Libraries
Size2d..::..GetIndex Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.GetIndex(El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint GetIndex(
    Size2d offset
)
Visual Basic
Public Function GetIndex ( _
    offset As Size2d _
) As UInteger
Visual C++
public:
unsigned int GetIndex(
    Size2d^ offset
)

Parameters

offset
Type: El..::..Size2d

[Missing <param name="offset"/> documentation for "M:El.Size2d.GetIndex(El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.GetIndex(El.Size2d)"]

See Also

Size2d Class


GetX Method

[image]

One of William Foster's Class Libraries
Size2d..::..GetX Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.GetX"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Value GetX()
Visual Basic
Public Function GetX As Value
Visual C++
public:
Value^ GetX()

Return Value

[Missing <returns> documentation for "M:El.Size2d.GetX"]

See Also

Size2d Class


GetY Method

[image]

One of William Foster's Class Libraries
Size2d..::..GetY Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.GetY"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Value GetY()
Visual Basic
Public Function GetY As Value
Visual C++
public:
Value^ GetY()

Return Value

[Missing <returns> documentation for "M:El.Size2d.GetY"]

See Also

Size2d Class


IncrementX Method

[image]

One of William Foster's Class Libraries
Size2d..::..IncrementX Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.IncrementX"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void IncrementX()
Visual Basic
Public Sub IncrementX
Visual C++
public:
void IncrementX()

See Also

Size2d Class


IncrementY Method

[image]

One of William Foster's Class Libraries
Size2d..::..IncrementY Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.IncrementY"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void IncrementY()
Visual Basic
Public Sub IncrementY
Visual C++
public:
void IncrementY()

See Also

Size2d Class


Iterate Method

[image] [image]

One of William Foster's Class Libraries
Size2d..::..Iterate Method
Size2d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Iterate(Rect2d) |
Public method | Iterate(Size2d) |
Public method | Iterate(Size2d, Size2d) |

See Also

Size2d Class
Size2d Members


Iterate Method (Rect2d)

[image]

One of William Foster's Class Libraries
Size2d..::..Iterate Method (Rect2d)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Iterate(El.Rect2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Iterate(
    Rect2d rect
)
Visual Basic
Public Function Iterate ( _
    rect As Rect2d _
) As Boolean
Visual C++
public:
bool Iterate(
    Rect2d^ rect
)

Parameters

rect
Type: El..::..Rect2d

[Missing <param name="rect"/> documentation for "M:El.Size2d.Iterate(El.Rect2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.Iterate(El.Rect2d)"]

See Also

Size2d Class
Iterate Overload


Iterate Method (Size2d)

[image]

One of William Foster's Class Libraries
Size2d..::..Iterate Method (Size2d)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Iterate(El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Iterate(
    Size2d size
)
Visual Basic
Public Function Iterate ( _
    size As Size2d _
) As Boolean
Visual C++
public:
bool Iterate(
    Size2d^ size
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.Iterate(El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.Iterate(El.Size2d)"]

See Also

Size2d Class
Iterate Overload


Iterate Method (Size2d, Size2d)

[image]

One of William Foster's Class Libraries
Size2d..::..Iterate Method (Size2d, Size2d)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Iterate(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Iterate(
    Size2d size,
    Size2d increment
)
Visual Basic
Public Function Iterate ( _
    size As Size2d, _
    increment As Size2d _
) As Boolean
Visual C++
public:
bool Iterate(
    Size2d^ size,
    Size2d^ increment
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.Iterate(El.Size2d,El.Size2d)"]

increment
Type: El..::..Size2d

[Missing <param name="increment"/> documentation for "M:El.Size2d.Iterate(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.Iterate(El.Size2d,El.Size2d)"]

See Also

Size2d Class
Iterate Overload


IterateX Method

[image] [image]

One of William Foster's Class Libraries
Size2d..::..IterateX Method
Size2d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IterateX(Rect2d) |
Public method | IterateX(Size2d) |

See Also

Size2d Class
Size2d Members


IterateX Method (Rect2d)

[image]

One of William Foster's Class Libraries
Size2d..::..IterateX Method (Rect2d)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.IterateX(El.Rect2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool IterateX(
    Rect2d rect
)
Visual Basic
Public Function IterateX ( _
    rect As Rect2d _
) As Boolean
Visual C++
public:
bool IterateX(
    Rect2d^ rect
)

Parameters

rect
Type: El..::..Rect2d

[Missing <param name="rect"/> documentation for "M:El.Size2d.IterateX(El.Rect2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.IterateX(El.Rect2d)"]

See Also

Size2d Class
IterateX Overload


IterateX Method (Size2d)

[image]

One of William Foster's Class Libraries
Size2d..::..IterateX Method (Size2d)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.IterateX(El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool IterateX(
    Size2d size
)
Visual Basic
Public Function IterateX ( _
    size As Size2d _
) As Boolean
Visual C++
public:
bool IterateX(
    Size2d^ size
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.IterateX(El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.IterateX(El.Size2d)"]

See Also

Size2d Class
IterateX Overload


IterateY Method

[image] [image]

One of William Foster's Class Libraries
Size2d..::..IterateY Method
Size2d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IterateY(Rect2d) |
Public method | IterateY(Size2d) |

See Also

Size2d Class
Size2d Members


IterateY Method (Rect2d)

[image]

One of William Foster's Class Libraries
Size2d..::..IterateY Method (Rect2d)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.IterateY(El.Rect2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool IterateY(
    Rect2d rect
)
Visual Basic
Public Function IterateY ( _
    rect As Rect2d _
) As Boolean
Visual C++
public:
bool IterateY(
    Rect2d^ rect
)

Parameters

rect
Type: El..::..Rect2d

[Missing <param name="rect"/> documentation for "M:El.Size2d.IterateY(El.Rect2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.IterateY(El.Rect2d)"]

See Also

Size2d Class
IterateY Overload


IterateY Method (Size2d)

[image]

One of William Foster's Class Libraries
Size2d..::..IterateY Method (Size2d)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.IterateY(El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool IterateY(
    Size2d size
)
Visual Basic
Public Function IterateY ( _
    size As Size2d _
) As Boolean
Visual C++
public:
bool IterateY(
    Size2d^ size
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.IterateY(El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.IterateY(El.Size2d)"]

See Also

Size2d Class
IterateY Overload


Maximum Method

[image]

One of William Foster's Class Libraries
Size2d..::..Maximum Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Maximum(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2d Maximum(
    Size2d size1,
    Size2d size2
)
Visual Basic
Public Function Maximum ( _
    size1 As Size2d, _
    size2 As Size2d _
) As Size2d
Visual C++
public:
Size2d^ Maximum(
    Size2d^ size1,
    Size2d^ size2
)

Parameters

size1
Type: El..::..Size2d

[Missing <param name="size1"/> documentation for "M:El.Size2d.Maximum(El.Size2d,El.Size2d)"]

size2
Type: El..::..Size2d

[Missing <param name="size2"/> documentation for "M:El.Size2d.Maximum(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.Maximum(El.Size2d,El.Size2d)"]

See Also

Size2d Class


Minimum Method

[image]

One of William Foster's Class Libraries
Size2d..::..Minimum Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Minimum(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2d Minimum(
    Size2d size1,
    Size2d size2
)
Visual Basic
Public Function Minimum ( _
    size1 As Size2d, _
    size2 As Size2d _
) As Size2d
Visual C++
public:
Size2d^ Minimum(
    Size2d^ size1,
    Size2d^ size2
)

Parameters

size1
Type: El..::..Size2d

[Missing <param name="size1"/> documentation for "M:El.Size2d.Minimum(El.Size2d,El.Size2d)"]

size2
Type: El..::..Size2d

[Missing <param name="size2"/> documentation for "M:El.Size2d.Minimum(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.Minimum(El.Size2d,El.Size2d)"]

See Also

Size2d Class


Product Method

[image] [image]

One of William Foster's Class Libraries
Size2d..::..Product Method
Size2d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Product(Double%) |
Public method | Product(UInt32%) |
Public method | Product(Value%) |

See Also

Size2d Class
Size2d Members


Product Method (Double)

[image]

One of William Foster's Class Libraries
Size2d..::..Product Method (Double%)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Product(System.Double@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Product(
    out double result
)
Visual Basic
Public Function Product ( _
    <OutAttribute> ByRef result As Double _
) As Boolean
Visual C++
public:
bool Product(
    [OutAttribute] double% result
)

Parameters

result
Type: System..::..Double %

[Missing <param name="result"/> documentation for "M:El.Size2d.Product(System.Double@)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.Product(System.Double@)"]

See Also

Size2d Class
Product Overload


Product Method (UInt32)

[image]

One of William Foster's Class Libraries
Size2d..::..Product Method (UInt32%)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Product(System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Product(
    out uint result
)
Visual Basic
Public Function Product ( _
    <OutAttribute> ByRef result As UInteger _
) As Boolean
Visual C++
public:
bool Product(
    [OutAttribute] unsigned int% result
)

Parameters

result
Type: System..::..UInt32 %

[Missing <param name="result"/> documentation for "M:El.Size2d.Product(System.UInt32@)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.Product(System.UInt32@)"]

See Also

Size2d Class
Product Overload


Product Method (Value)

[image]

One of William Foster's Class Libraries
Size2d..::..Product Method (Value%)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Product(El.Value@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Product(
    out Value result
)
Visual Basic
Public Function Product ( _
    <OutAttribute> ByRef result As Value _
) As Boolean
Visual C++
public:
bool Product(
    [OutAttribute] Value^% result
)

Parameters

result
Type: El..::..Value %

[Missing <param name="result"/> documentation for "M:El.Size2d.Product(El.Value@)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.Product(El.Value@)"]

See Also

Size2d Class
Product Overload


Set Method

[image] [image]

One of William Foster's Class Libraries
Size2d..::..Set Method
Size2d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Size2d) |
Public method | Set(Value, Value) |

See Also

Size2d Class
Size2d Members


Set Method (Size2d)

[image]

One of William Foster's Class Libraries
Size2d..::..Set Method (Size2d)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Set(El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Set(
    Size2d size2d
)
Visual Basic
Public Function Set ( _
    size2d As Size2d _
) As Boolean
Visual C++
public:
bool Set(
    Size2d^ size2d
)

Parameters

size2d
Type: El..::..Size2d

[Missing <param name="size2d"/> documentation for "M:El.Size2d.Set(El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.Set(El.Size2d)"]

See Also

Size2d Class
Set Overload


Set Method (Value, Value)

[image]

One of William Foster's Class Libraries
Size2d..::..Set Method (Value, Value)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Set(El.Value,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Set(
    Value dimensionX,
    Value dimensionY
)
Visual Basic
Public Function Set ( _
    dimensionX As Value, _
    dimensionY As Value _
) As Boolean
Visual C++
public:
bool Set(
    Value^ dimensionX,
    Value^ dimensionY
)

Parameters

dimensionX
Type: El..::..Value

[Missing <param name="dimensionX"/> documentation for "M:El.Size2d.Set(El.Value,El.Value)"]

dimensionY
Type: El..::..Value

[Missing <param name="dimensionY"/> documentation for "M:El.Size2d.Set(El.Value,El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.Set(El.Value,El.Value)"]

See Also

Size2d Class
Set Overload


SetX Method

[image]

One of William Foster's Class Libraries
Size2d..::..SetX Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.SetX(El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetX(
    Value dimensionX
)
Visual Basic
Public Sub SetX ( _
    dimensionX As Value _
)
Visual C++
public:
void SetX(
    Value^ dimensionX
)

Parameters

dimensionX
Type: El..::..Value

[Missing <param name="dimensionX"/> documentation for "M:El.Size2d.SetX(El.Value)"]

See Also

Size2d Class


SetY Method

[image]

One of William Foster's Class Libraries
Size2d..::..SetY Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.SetY(El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetY(
    Value dimensionY
)
Visual Basic
Public Sub SetY ( _
    dimensionY As Value _
)
Visual C++
public:
void SetY(
    Value^ dimensionY
)

Parameters

dimensionY
Type: El..::..Value

[Missing <param name="dimensionY"/> documentation for "M:El.Size2d.SetY(El.Value)"]

See Also

Size2d Class


Zero Method

[image]

One of William Foster's Class Libraries
Size2d..::..Zero Method
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.Zero"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Zero()
Visual Basic
Public Sub Zero
Visual C++
public:
void Zero()

See Also

Size2d Class


Size2d Operators

[image] [image]

One of William Foster's Class Libraries
Size2d Operators
Size2d Class See Also Send Feedback

The Size2d type exposes the following members.

Operators

Name | Description
Addition |
Division(Size2d, Size2d) |
Division(Size2d, Double) |
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Modulus |
Multiply(Size2d, Size2d) |
Multiply(Size2d, Double) |
Subtraction |

See Also

Size2d Class


Addition Operator

[image]

One of William Foster's Class Libraries
Size2d..::..Addition Operator
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.op_Addition(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2d operator +(
    Size2d size1,
    Size2d size2
)
Visual Basic
Public Shared Operator + ( _
    size1 As Size2d, _
    size2 As Size2d _
) As Size2d
Visual C++
public:
static Size2d^ operator +(
    Size2d^ size1,
    Size2d^ size2
)

Parameters

size1
Type: El..::..Size2d

[Missing <param name="size1"/> documentation for "M:El.Size2d.op_Addition(El.Size2d,El.Size2d)"]

size2
Type: El..::..Size2d

[Missing <param name="size2"/> documentation for "M:El.Size2d.op_Addition(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.op_Addition(El.Size2d,El.Size2d)"]

See Also

Size2d Class


Division Operator

[image] [image]

One of William Foster's Class Libraries
Size2d..::..Division Operator
Size2d Class See Also Send Feedback

Overload List

Name | Description
Division(Size2d, Size2d) |
Division(Size2d, Double) |

See Also

Size2d Class
Size2d Members


Division Operator (Size2d, Size2d)

[image]

One of William Foster's Class Libraries
Size2d..::..Division Operator (Size2d, Size2d)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.op_Division(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2d operator /(
    Size2d size,
    Size2d divSize
)
Visual Basic
Public Shared Operator / ( _
    size As Size2d, _
    divSize As Size2d _
) As Size2d
Visual C++
public:
static Size2d^ operator /(
    Size2d^ size,
    Size2d^ divSize
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.op_Division(El.Size2d,El.Size2d)"]

divSize
Type: El..::..Size2d

[Missing <param name="divSize"/> documentation for "M:El.Size2d.op_Division(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.op_Division(El.Size2d,El.Size2d)"]

See Also

Size2d Class
Division Overload


Division Operator (Size2d, Double)

[image]

One of William Foster's Class Libraries
Size2d..::..Division Operator (Size2d, Double)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.op_Division(El.Size2d,System.Double)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2d operator /(
    Size2d size,
    double d_div
)
Visual Basic
Public Shared Operator / ( _
    size As Size2d, _
    d_div As Double _
) As Size2d
Visual C++
public:
static Size2d^ operator /(
    Size2d^ size,
    double d_div
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.op_Division(El.Size2d,System.Double)"]

d_div
Type: System..::..Double

[Missing <param name="d_div"/> documentation for "M:El.Size2d.op_Division(El.Size2d,System.Double)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.op_Division(El.Size2d,System.Double)"]

See Also

Size2d Class
Division Overload


Equality Operator

[image]

One of William Foster's Class Libraries
Size2d..::..Equality Operator
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.op_Equality(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator ==(
    Size2d size1,
    Size2d size2
)
Visual Basic
Public Shared Operator = ( _
    size1 As Size2d, _
    size2 As Size2d _
) As Boolean
Visual C++
public:
static bool operator ==(
    Size2d^ size1,
    Size2d^ size2
)

Parameters

size1
Type: El..::..Size2d

[Missing <param name="size1"/> documentation for "M:El.Size2d.op_Equality(El.Size2d,El.Size2d)"]

size2
Type: El..::..Size2d

[Missing <param name="size2"/> documentation for "M:El.Size2d.op_Equality(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.op_Equality(El.Size2d,El.Size2d)"]

See Also

Size2d Class


GreaterThan Operator

[image]

One of William Foster's Class Libraries
Size2d..::..GreaterThan Operator
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.op_GreaterThan(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator >(
    Size2d size,
    Size2d greaterthanSize
)
Visual Basic
Public Shared Operator > ( _
    size As Size2d, _
    greaterthanSize As Size2d _
) As Boolean
Visual C++
public:
static bool operator >(
    Size2d^ size,
    Size2d^ greaterthanSize
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.op_GreaterThan(El.Size2d,El.Size2d)"]

greaterthanSize
Type: El..::..Size2d

[Missing <param name="greaterthanSize"/> documentation for "M:El.Size2d.op_GreaterThan(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.op_GreaterThan(El.Size2d,El.Size2d)"]

See Also

Size2d Class


GreaterThanOrEqual Operator

[image]

One of William Foster's Class Libraries
Size2d..::..GreaterThanOrEqual Operator
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.op_GreaterThanOrEqual(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator >=(
    Size2d size,
    Size2d greaterthanSize
)
Visual Basic
Public Shared Operator >= ( _
    size As Size2d, _
    greaterthanSize As Size2d _
) As Boolean
Visual C++
public:
static bool operator >=(
    Size2d^ size,
    Size2d^ greaterthanSize
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.op_GreaterThanOrEqual(El.Size2d,El.Size2d)"]

greaterthanSize
Type: El..::..Size2d

[Missing <param name="greaterthanSize"/> documentation for "M:El.Size2d.op_GreaterThanOrEqual(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.op_GreaterThanOrEqual(El.Size2d,El.Size2d)"]

See Also

Size2d Class


Inequality Operator

[image]

One of William Foster's Class Libraries
Size2d..::..Inequality Operator
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.op_Inequality(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator !=(
    Size2d size1,
    Size2d size2
)
Visual Basic
Public Shared Operator <> ( _
    size1 As Size2d, _
    size2 As Size2d _
) As Boolean
Visual C++
public:
static bool operator !=(
    Size2d^ size1,
    Size2d^ size2
)

Parameters

size1
Type: El..::..Size2d

[Missing <param name="size1"/> documentation for "M:El.Size2d.op_Inequality(El.Size2d,El.Size2d)"]

size2
Type: El..::..Size2d

[Missing <param name="size2"/> documentation for "M:El.Size2d.op_Inequality(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.op_Inequality(El.Size2d,El.Size2d)"]

See Also

Size2d Class


LessThan Operator

[image]

One of William Foster's Class Libraries
Size2d..::..LessThan Operator
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.op_LessThan(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator <(
    Size2d size,
    Size2d lessthanSize
)
Visual Basic
Public Shared Operator < ( _
    size As Size2d, _
    lessthanSize As Size2d _
) As Boolean
Visual C++
public:
static bool operator <(
    Size2d^ size,
    Size2d^ lessthanSize
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.op_LessThan(El.Size2d,El.Size2d)"]

lessthanSize
Type: El..::..Size2d

[Missing <param name="lessthanSize"/> documentation for "M:El.Size2d.op_LessThan(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.op_LessThan(El.Size2d,El.Size2d)"]

See Also

Size2d Class


LessThanOrEqual Operator

[image]

One of William Foster's Class Libraries
Size2d..::..LessThanOrEqual Operator
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.op_LessThanOrEqual(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator <=(
    Size2d size,
    Size2d lessthanSize
)
Visual Basic
Public Shared Operator <= ( _
    size As Size2d, _
    lessthanSize As Size2d _
) As Boolean
Visual C++
public:
static bool operator <=(
    Size2d^ size,
    Size2d^ lessthanSize
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.op_LessThanOrEqual(El.Size2d,El.Size2d)"]

lessthanSize
Type: El..::..Size2d

[Missing <param name="lessthanSize"/> documentation for "M:El.Size2d.op_LessThanOrEqual(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.op_LessThanOrEqual(El.Size2d,El.Size2d)"]

See Also

Size2d Class


Modulus Operator

[image]

One of William Foster's Class Libraries
Size2d..::..Modulus Operator
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.op_Modulus(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2d operator %(
    Size2d size,
    Size2d modSize
)
Visual Basic
Public Shared Operator Mod ( _
    size As Size2d, _
    modSize As Size2d _
) As Size2d
Visual C++
public:
static Size2d^ operator %(
    Size2d^ size,
    Size2d^ modSize
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.op_Modulus(El.Size2d,El.Size2d)"]

modSize
Type: El..::..Size2d

[Missing <param name="modSize"/> documentation for "M:El.Size2d.op_Modulus(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.op_Modulus(El.Size2d,El.Size2d)"]

See Also

Size2d Class


Multiply Operator

[image] [image]

One of William Foster's Class Libraries
Size2d..::..Multiply Operator
Size2d Class See Also Send Feedback

Overload List

Name | Description
Multiply(Size2d, Size2d) |
Multiply(Size2d, Double) |

See Also

Size2d Class
Size2d Members


Multiply Operator (Size2d, Size2d)

[image]

One of William Foster's Class Libraries
Size2d..::..Multiply Operator (Size2d, Size2d)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.op_Multiply(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2d operator *(
    Size2d size1,
    Size2d size2
)
Visual Basic
Public Shared Operator * ( _
    size1 As Size2d, _
    size2 As Size2d _
) As Size2d
Visual C++
public:
static Size2d^ operator *(
    Size2d^ size1,
    Size2d^ size2
)

Parameters

size1
Type: El..::..Size2d

[Missing <param name="size1"/> documentation for "M:El.Size2d.op_Multiply(El.Size2d,El.Size2d)"]

size2
Type: El..::..Size2d

[Missing <param name="size2"/> documentation for "M:El.Size2d.op_Multiply(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.op_Multiply(El.Size2d,El.Size2d)"]

See Also

Size2d Class
Multiply Overload


Multiply Operator (Size2d, Double)

[image]

One of William Foster's Class Libraries
Size2d..::..Multiply Operator (Size2d, Double)
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.op_Multiply(El.Size2d,System.Double)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2d operator *(
    Size2d size,
    double d_mul
)
Visual Basic
Public Shared Operator * ( _
    size As Size2d, _
    d_mul As Double _
) As Size2d
Visual C++
public:
static Size2d^ operator *(
    Size2d^ size,
    double d_mul
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.op_Multiply(El.Size2d,System.Double)"]

d_mul
Type: System..::..Double

[Missing <param name="d_mul"/> documentation for "M:El.Size2d.op_Multiply(El.Size2d,System.Double)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.op_Multiply(El.Size2d,System.Double)"]

See Also

Size2d Class
Multiply Overload


Subtraction Operator

[image]

One of William Foster's Class Libraries
Size2d..::..Subtraction Operator
Size2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2d.op_Subtraction(El.Size2d,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2d operator -(
    Size2d size,
    Size2d subSize
)
Visual Basic
Public Shared Operator - ( _
    size As Size2d, _
    subSize As Size2d _
) As Size2d
Visual C++
public:
static Size2d^ operator -(
    Size2d^ size,
    Size2d^ subSize
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2d.op_Subtraction(El.Size2d,El.Size2d)"]

subSize
Type: El..::..Size2d

[Missing <param name="subSize"/> documentation for "M:El.Size2d.op_Subtraction(El.Size2d,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2d.op_Subtraction(El.Size2d,El.Size2d)"]

See Also

Size2d Class


Size2dU Class

[image]

One of William Foster's Class Libraries
Size2dU Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Size2dU"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Size2dU
Visual Basic
Public Class Size2dU
Visual C++
public ref class Size2dU

Inheritance Hierarchy

System..::..Object
El..::..Size2dU

See Also

Size2dU Members


Size2dU Members

[image] [image]

One of William Foster's Class Libraries
Size2dU Members
Size2dU Class Constructors Methods Operators See Also Send Feedback

The Size2dU type exposes the following members.

Constructors

 | Name | Description
Public method | Size2dU()()()() | Initializes a new instance of the Size2dU class
Public method | Size2dU(Size2d) | Initializes a new instance of the Size2dU class
Public method | Size2dU(Size2dU) | Initializes a new instance of the Size2dU class
Public method | Size2dU(Int32, Int32) | Initializes a new instance of the Size2dU class
Public method | Size2dU(UInt32, UInt32) | Initializes a new instance of the Size2dU class

Methods

 | Name | Description
Public method | DecrementX |
Public method | DecrementY |
Public method | Encapsulates |
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetX |
Public method | GetY |
 | IMaximum |
 | IMinimum |
Public method | IncrementX |
Public method | IncrementY |
Public method | Iterate(Rect2dU) |
Public method | Iterate(Size2dU) |
Public method | Iterate(Size2dU, Size2dU) |
Public method | IterateX(Rect2dU) |
Public method | IterateX(Size2dU) |
Public method | IterateY(Rect2dU) |
Public method | IterateY(Size2dU) |
 | Maximum |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Minimum |
Public method | Product()()()() |
Public method | Product(UInt32%) |
Public method | Set(Size2dU) |
Public method | Set(UInt32, UInt32) |
Public method | SetX |
Public method | SetY |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Zero |

Operators

Name | Description
Addition |
Division(Size2dU, Size2dU) |
Division(Size2dU, Double) |
Equality |
GreaterThan |
GreaterThanOrEqual |
ImplicitWideningImplicitImplicitImplicit(Size to Size2dU) |
ImplicitWideningImplicitImplicitImplicit(Size2dU to Point) |
ImplicitWideningImplicitImplicitImplicit(Size2dU to Size) |
Inequality |
LessThan |
LessThanOrEqual |
Modulus |
Multiply(Size2dU, Size2d) |
Multiply(Size2dU, Size2dU) |
Multiply(Size2dU, Double) |
Multiply(Size2dU, UInt32) |
Subtraction |

See Also

Size2dU Class


Size2dU Constructor

[image] [image]

One of William Foster's Class Libraries
Size2dU Constructor
Size2dU Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Size2dU()()()() | Initializes a new instance of the Size2dU class
Public method | Size2dU(Size2d) | Initializes a new instance of the Size2dU class
Public method | Size2dU(Size2dU) | Initializes a new instance of the Size2dU class
Public method | Size2dU(Int32, Int32) | Initializes a new instance of the Size2dU class
Public method | Size2dU(UInt32, UInt32) | Initializes a new instance of the Size2dU class

See Also

Size2dU Class
Size2dU Members


Size2dU Constructor

[image]

One of William Foster's Class Libraries
Size2dU Constructor
Size2dU Class See Also Send Feedback
Initializes a new instance of the Size2dU class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2dU()
Visual Basic
Public Sub New
Visual C++
public:
Size2dU()

See Also

Size2dU Class
Size2dU Overload


Size2dU Constructor (Size2d)

[image]

One of William Foster's Class Libraries
Size2dU Constructor (Size2d)
Size2dU Class See Also Send Feedback
Initializes a new instance of the Size2dU class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2dU(
    Size2d size
)
Visual Basic
Public Sub New ( _
    size As Size2d _
)
Visual C++
public:
Size2dU(
    Size2d^ size
)

Parameters

size
Type: El..::..Size2d

[Missing <param name="size"/> documentation for "M:El.Size2dU.#ctor(El.Size2d)"]

See Also

Size2dU Class
Size2dU Overload


Size2dU Constructor (Size2dU)

[image]

One of William Foster's Class Libraries
Size2dU Constructor (Size2dU)
Size2dU Class See Also Send Feedback
Initializes a new instance of the Size2dU class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2dU(
    Size2dU size
)
Visual Basic
Public Sub New ( _
    size As Size2dU _
)
Visual C++
public:
Size2dU(
    Size2dU^ size
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.#ctor(El.Size2dU)"]

See Also

Size2dU Class
Size2dU Overload


Size2dU Constructor (Int32, Int32)

[image]

One of William Foster's Class Libraries
Size2dU Constructor (Int32, Int32)
Size2dU Class See Also Send Feedback
Initializes a new instance of the Size2dU class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2dU(
    int dimensionX,
    int dimensionY
)
Visual Basic
Public Sub New ( _
    dimensionX As Integer, _
    dimensionY As Integer _
)
Visual C++
public:
Size2dU(
    int dimensionX,
    int dimensionY
)

Parameters

dimensionX
Type: System..::..Int32

[Missing <param name="dimensionX"/> documentation for "M:El.Size2dU.#ctor(System.Int32,System.Int32)"]

dimensionY
Type: System..::..Int32

[Missing <param name="dimensionY"/> documentation for "M:El.Size2dU.#ctor(System.Int32,System.Int32)"]

See Also

Size2dU Class
Size2dU Overload


Size2dU Constructor (UInt32, UInt32)

[image]

One of William Foster's Class Libraries
Size2dU Constructor (UInt32, UInt32)
Size2dU Class See Also Send Feedback
Initializes a new instance of the Size2dU class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Size2dU(
    uint dimensionX,
    uint dimensionY
)
Visual Basic
Public Sub New ( _
    dimensionX As UInteger, _
    dimensionY As UInteger _
)
Visual C++
public:
Size2dU(
    unsigned int dimensionX,
    unsigned int dimensionY
)

Parameters

dimensionX
Type: System..::..UInt32

[Missing <param name="dimensionX"/> documentation for "M:El.Size2dU.#ctor(System.UInt32,System.UInt32)"]

dimensionY
Type: System..::..UInt32

[Missing <param name="dimensionY"/> documentation for "M:El.Size2dU.#ctor(System.UInt32,System.UInt32)"]

See Also

Size2dU Class
Size2dU Overload


Size2dU Methods

[image] [image]

One of William Foster's Class Libraries
Size2dU Methods
Size2dU Class See Also Send Feedback

The Size2dU type exposes the following members.

Methods

 | Name | Description
Public method | DecrementX |
Public method | DecrementY |
Public method | Encapsulates |
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetX |
Public method | GetY |
 | IMaximum |
 | IMinimum |
Public method | IncrementX |
Public method | IncrementY |
Public method | Iterate(Rect2dU) |
Public method | Iterate(Size2dU) |
Public method | Iterate(Size2dU, Size2dU) |
Public method | IterateX(Rect2dU) |
Public method | IterateX(Size2dU) |
Public method | IterateY(Rect2dU) |
Public method | IterateY(Size2dU) |
 | Maximum |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Minimum |
Public method | Product()()()() |
Public method | Product(UInt32%) |
Public method | Set(Size2dU) |
Public method | Set(UInt32, UInt32) |
Public method | SetX |
Public method | SetY |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Zero |

See Also

Size2dU Class


DecrementX Method

[image]

One of William Foster's Class Libraries
Size2dU..::..DecrementX Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.DecrementX"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void DecrementX()
Visual Basic
Public Sub DecrementX
Visual C++
public:
void DecrementX()

See Also

Size2dU Class


DecrementY Method

[image]

One of William Foster's Class Libraries
Size2dU..::..DecrementY Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.DecrementY"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void DecrementY()
Visual Basic
Public Sub DecrementY
Visual C++
public:
void DecrementY()

See Also

Size2dU Class


Encapsulates Method

[image]

One of William Foster's Class Libraries
Size2dU..::..Encapsulates Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.Encapsulates(El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Encapsulates(
    Size2dU siz
)
Visual Basic
Public Function Encapsulates ( _
    siz As Size2dU _
) As Boolean
Visual C++
public:
bool Encapsulates(
    Size2dU^ siz
)

Parameters

siz
Type: El..::..Size2dU

[Missing <param name="siz"/> documentation for "M:El.Size2dU.Encapsulates(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.Encapsulates(El.Size2dU)"]

See Also

Size2dU Class


Equals Method

[image]

One of William Foster's Class Libraries
Size2dU..::..Equals Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.Equals(System.Object)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:El.Size2dU.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.Equals(System.Object)"]

See Also

Size2dU Class


Get Method

[image]

One of William Foster's Class Libraries
Size2dU..::..Get Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.Get(System.UInt32@,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Get(
    out uint u_x,
    out uint u_y
)
Visual Basic
Public Sub Get ( _
    <OutAttribute> ByRef u_x As UInteger, _
    <OutAttribute> ByRef u_y As UInteger _
)
Visual C++
public:
void Get(
    [OutAttribute] unsigned int% u_x,
    [OutAttribute] unsigned int% u_y
)

Parameters

u_x
Type: System..::..UInt32 %

[Missing <param name="u_x"/> documentation for "M:El.Size2dU.Get(System.UInt32@,System.UInt32@)"]

u_y
Type: System..::..UInt32 %

[Missing <param name="u_y"/> documentation for "M:El.Size2dU.Get(System.UInt32@,System.UInt32@)"]

See Also

Size2dU Class


GetIndex Method

[image]

One of William Foster's Class Libraries
Size2dU..::..GetIndex Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.GetIndex(El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint GetIndex(
    Size2dU offset
)
Visual Basic
Public Function GetIndex ( _
    offset As Size2dU _
) As UInteger
Visual C++
public:
unsigned int GetIndex(
    Size2dU^ offset
)

Parameters

offset
Type: El..::..Size2dU

[Missing <param name="offset"/> documentation for "M:El.Size2dU.GetIndex(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.GetIndex(El.Size2dU)"]

See Also

Size2dU Class


GetX Method

[image]

One of William Foster's Class Libraries
Size2dU..::..GetX Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.GetX"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint GetX()
Visual Basic
Public Function GetX As UInteger
Visual C++
public:
unsigned int GetX()

Return Value

[Missing <returns> documentation for "M:El.Size2dU.GetX"]

See Also

Size2dU Class


GetY Method

[image]

One of William Foster's Class Libraries
Size2dU..::..GetY Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.GetY"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint GetY()
Visual Basic
Public Function GetY As UInteger
Visual C++
public:
unsigned int GetY()

Return Value

[Missing <returns> documentation for "M:El.Size2dU.GetY"]

See Also

Size2dU Class


IMaximum Method

[image]

One of William Foster's Class Libraries
Size2dU..::..IMaximum Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.IMaximum(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2dU IMaximum(
    Size2dU size1,
    Size2dU size2
)
Visual Basic
Public Shared Function IMaximum ( _
    size1 As Size2dU, _
    size2 As Size2dU _
) As Size2dU
Visual C++
public:
static Size2dU^ IMaximum(
    Size2dU^ size1,
    Size2dU^ size2
)

Parameters

size1
Type: El..::..Size2dU

[Missing <param name="size1"/> documentation for "M:El.Size2dU.IMaximum(El.Size2dU,El.Size2dU)"]

size2
Type: El..::..Size2dU

[Missing <param name="size2"/> documentation for "M:El.Size2dU.IMaximum(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.IMaximum(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class


IMinimum Method

[image]

One of William Foster's Class Libraries
Size2dU..::..IMinimum Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.IMinimum(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2dU IMinimum(
    Size2dU size1,
    Size2dU size2
)
Visual Basic
Public Shared Function IMinimum ( _
    size1 As Size2dU, _
    size2 As Size2dU _
) As Size2dU
Visual C++
public:
static Size2dU^ IMinimum(
    Size2dU^ size1,
    Size2dU^ size2
)

Parameters

size1
Type: El..::..Size2dU

[Missing <param name="size1"/> documentation for "M:El.Size2dU.IMinimum(El.Size2dU,El.Size2dU)"]

size2
Type: El..::..Size2dU

[Missing <param name="size2"/> documentation for "M:El.Size2dU.IMinimum(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.IMinimum(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class


IncrementX Method

[image]

One of William Foster's Class Libraries
Size2dU..::..IncrementX Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.IncrementX"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void IncrementX()
Visual Basic
Public Sub IncrementX
Visual C++
public:
void IncrementX()

See Also

Size2dU Class


IncrementY Method

[image]

One of William Foster's Class Libraries
Size2dU..::..IncrementY Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.IncrementY"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void IncrementY()
Visual Basic
Public Sub IncrementY
Visual C++
public:
void IncrementY()

See Also

Size2dU Class


Iterate Method

[image] [image]

One of William Foster's Class Libraries
Size2dU..::..Iterate Method
Size2dU Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Iterate(Rect2dU) |
Public method | Iterate(Size2dU) |
Public method | Iterate(Size2dU, Size2dU) |

See Also

Size2dU Class
Size2dU Members


Iterate Method (Rect2dU)

[image]

One of William Foster's Class Libraries
Size2dU..::..Iterate Method (Rect2dU)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.Iterate(El.Rect2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Iterate(
    Rect2dU rect
)
Visual Basic
Public Function Iterate ( _
    rect As Rect2dU _
) As Boolean
Visual C++
public:
bool Iterate(
    Rect2dU^ rect
)

Parameters

rect
Type: El..::..Rect2dU

[Missing <param name="rect"/> documentation for "M:El.Size2dU.Iterate(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.Iterate(El.Rect2dU)"]

See Also

Size2dU Class
Iterate Overload


Iterate Method (Size2dU)

[image]

One of William Foster's Class Libraries
Size2dU..::..Iterate Method (Size2dU)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.Iterate(El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Iterate(
    Size2dU size
)
Visual Basic
Public Function Iterate ( _
    size As Size2dU _
) As Boolean
Visual C++
public:
bool Iterate(
    Size2dU^ size
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.Iterate(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.Iterate(El.Size2dU)"]

See Also

Size2dU Class
Iterate Overload


Iterate Method (Size2dU, Size2dU)

[image]

One of William Foster's Class Libraries
Size2dU..::..Iterate Method (Size2dU, Size2dU)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.Iterate(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Iterate(
    Size2dU size,
    Size2dU increment
)
Visual Basic
Public Function Iterate ( _
    size As Size2dU, _
    increment As Size2dU _
) As Boolean
Visual C++
public:
bool Iterate(
    Size2dU^ size,
    Size2dU^ increment
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.Iterate(El.Size2dU,El.Size2dU)"]

increment
Type: El..::..Size2dU

[Missing <param name="increment"/> documentation for "M:El.Size2dU.Iterate(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.Iterate(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class
Iterate Overload


IterateX Method

[image] [image]

One of William Foster's Class Libraries
Size2dU..::..IterateX Method
Size2dU Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IterateX(Rect2dU) |
Public method | IterateX(Size2dU) |

See Also

Size2dU Class
Size2dU Members


IterateX Method (Rect2dU)

[image]

One of William Foster's Class Libraries
Size2dU..::..IterateX Method (Rect2dU)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.IterateX(El.Rect2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool IterateX(
    Rect2dU rect
)
Visual Basic
Public Function IterateX ( _
    rect As Rect2dU _
) As Boolean
Visual C++
public:
bool IterateX(
    Rect2dU^ rect
)

Parameters

rect
Type: El..::..Rect2dU

[Missing <param name="rect"/> documentation for "M:El.Size2dU.IterateX(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.IterateX(El.Rect2dU)"]

See Also

Size2dU Class
IterateX Overload


IterateX Method (Size2dU)

[image]

One of William Foster's Class Libraries
Size2dU..::..IterateX Method (Size2dU)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.IterateX(El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool IterateX(
    Size2dU size
)
Visual Basic
Public Function IterateX ( _
    size As Size2dU _
) As Boolean
Visual C++
public:
bool IterateX(
    Size2dU^ size
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.IterateX(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.IterateX(El.Size2dU)"]

See Also

Size2dU Class
IterateX Overload


IterateY Method

[image] [image]

One of William Foster's Class Libraries
Size2dU..::..IterateY Method
Size2dU Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IterateY(Rect2dU) |
Public method | IterateY(Size2dU) |

See Also

Size2dU Class
Size2dU Members


IterateY Method (Rect2dU)

[image]

One of William Foster's Class Libraries
Size2dU..::..IterateY Method (Rect2dU)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.IterateY(El.Rect2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool IterateY(
    Rect2dU rect
)
Visual Basic
Public Function IterateY ( _
    rect As Rect2dU _
) As Boolean
Visual C++
public:
bool IterateY(
    Rect2dU^ rect
)

Parameters

rect
Type: El..::..Rect2dU

[Missing <param name="rect"/> documentation for "M:El.Size2dU.IterateY(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.IterateY(El.Rect2dU)"]

See Also

Size2dU Class
IterateY Overload


IterateY Method (Size2dU)

[image]

One of William Foster's Class Libraries
Size2dU..::..IterateY Method (Size2dU)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.IterateY(El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool IterateY(
    Size2dU size
)
Visual Basic
Public Function IterateY ( _
    size As Size2dU _
) As Boolean
Visual C++
public:
bool IterateY(
    Size2dU^ size
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.IterateY(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.IterateY(El.Size2dU)"]

See Also

Size2dU Class
IterateY Overload


Maximum Method

[image]

One of William Foster's Class Libraries
Size2dU..::..Maximum Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.Maximum(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2dU Maximum(
    Size2dU size1,
    Size2dU size2
)
Visual Basic
Public Shared Function Maximum ( _
    size1 As Size2dU, _
    size2 As Size2dU _
) As Size2dU
Visual C++
public:
static Size2dU^ Maximum(
    Size2dU^ size1,
    Size2dU^ size2
)

Parameters

size1
Type: El..::..Size2dU

[Missing <param name="size1"/> documentation for "M:El.Size2dU.Maximum(El.Size2dU,El.Size2dU)"]

size2
Type: El..::..Size2dU

[Missing <param name="size2"/> documentation for "M:El.Size2dU.Maximum(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.Maximum(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class


Minimum Method

[image]

One of William Foster's Class Libraries
Size2dU..::..Minimum Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.Minimum(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2dU Minimum(
    Size2dU size1,
    Size2dU size2
)
Visual Basic
Public Shared Function Minimum ( _
    size1 As Size2dU, _
    size2 As Size2dU _
) As Size2dU
Visual C++
public:
static Size2dU^ Minimum(
    Size2dU^ size1,
    Size2dU^ size2
)

Parameters

size1
Type: El..::..Size2dU

[Missing <param name="size1"/> documentation for "M:El.Size2dU.Minimum(El.Size2dU,El.Size2dU)"]

size2
Type: El..::..Size2dU

[Missing <param name="size2"/> documentation for "M:El.Size2dU.Minimum(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.Minimum(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class


Product Method

[image] [image]

One of William Foster's Class Libraries
Size2dU..::..Product Method
Size2dU Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Product()()()() |
Public method | Product(UInt32%) |

See Also

Size2dU Class
Size2dU Members


Product Method

[image]

One of William Foster's Class Libraries
Size2dU..::..Product Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.Product"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint Product()
Visual Basic
Public Function Product As UInteger
Visual C++
public:
unsigned int Product()

Return Value

[Missing <returns> documentation for "M:El.Size2dU.Product"]

See Also

Size2dU Class
Product Overload


Product Method (UInt32)

[image]

One of William Foster's Class Libraries
Size2dU..::..Product Method (UInt32%)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.Product(System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Product(
    out uint result
)
Visual Basic
Public Function Product ( _
    <OutAttribute> ByRef result As UInteger _
) As Boolean
Visual C++
public:
bool Product(
    [OutAttribute] unsigned int% result
)

Parameters

result
Type: System..::..UInt32 %

[Missing <param name="result"/> documentation for "M:El.Size2dU.Product(System.UInt32@)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.Product(System.UInt32@)"]

See Also

Size2dU Class
Product Overload


Set Method

[image] [image]

One of William Foster's Class Libraries
Size2dU..::..Set Method
Size2dU Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Size2dU) |
Public method | Set(UInt32, UInt32) |

See Also

Size2dU Class
Size2dU Members


Set Method (Size2dU)

[image]

One of William Foster's Class Libraries
Size2dU..::..Set Method (Size2dU)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.Set(El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Set(
    Size2dU size2d
)
Visual Basic
Public Function Set ( _
    size2d As Size2dU _
) As Boolean
Visual C++
public:
bool Set(
    Size2dU^ size2d
)

Parameters

size2d
Type: El..::..Size2dU

[Missing <param name="size2d"/> documentation for "M:El.Size2dU.Set(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.Set(El.Size2dU)"]

See Also

Size2dU Class
Set Overload


Set Method (UInt32, UInt32)

[image]

One of William Foster's Class Libraries
Size2dU..::..Set Method (UInt32, UInt32)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.Set(System.UInt32,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Set(
    uint dimensionX,
    uint dimensionY
)
Visual Basic
Public Function Set ( _
    dimensionX As UInteger, _
    dimensionY As UInteger _
) As Boolean
Visual C++
public:
bool Set(
    unsigned int dimensionX,
    unsigned int dimensionY
)

Parameters

dimensionX
Type: System..::..UInt32

[Missing <param name="dimensionX"/> documentation for "M:El.Size2dU.Set(System.UInt32,System.UInt32)"]

dimensionY
Type: System..::..UInt32

[Missing <param name="dimensionY"/> documentation for "M:El.Size2dU.Set(System.UInt32,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.Set(System.UInt32,System.UInt32)"]

See Also

Size2dU Class
Set Overload


SetX Method

[image]

One of William Foster's Class Libraries
Size2dU..::..SetX Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.SetX(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetX(
    uint dimensionX
)
Visual Basic
Public Sub SetX ( _
    dimensionX As UInteger _
)
Visual C++
public:
void SetX(
    unsigned int dimensionX
)

Parameters

dimensionX
Type: System..::..UInt32

[Missing <param name="dimensionX"/> documentation for "M:El.Size2dU.SetX(System.UInt32)"]

See Also

Size2dU Class


SetY Method

[image]

One of William Foster's Class Libraries
Size2dU..::..SetY Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.SetY(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetY(
    uint dimensionY
)
Visual Basic
Public Sub SetY ( _
    dimensionY As UInteger _
)
Visual C++
public:
void SetY(
    unsigned int dimensionY
)

Parameters

dimensionY
Type: System..::..UInt32

[Missing <param name="dimensionY"/> documentation for "M:El.Size2dU.SetY(System.UInt32)"]

See Also

Size2dU Class


Zero Method

[image]

One of William Foster's Class Libraries
Size2dU..::..Zero Method
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.Zero"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Zero()
Visual Basic
Public Sub Zero
Visual C++
public:
void Zero()

See Also

Size2dU Class


Size2dU Operators and Type Conversions

[image] [image]

One of William Foster's Class Libraries
Size2dU Operators and Type Conversions
Size2dU Class See Also Send Feedback

The Size2dU type exposes the following members.

Operators

Name | Description
Addition |
Division(Size2dU, Size2dU) |
Division(Size2dU, Double) |
Equality |
GreaterThan |
GreaterThanOrEqual |
ImplicitWideningImplicitImplicitImplicit(Size to Size2dU) |
ImplicitWideningImplicitImplicitImplicit(Size2dU to Point) |
ImplicitWideningImplicitImplicitImplicit(Size2dU to Size) |
Inequality |
LessThan |
LessThanOrEqual |
Modulus |
Multiply(Size2dU, Size2d) |
Multiply(Size2dU, Size2dU) |
Multiply(Size2dU, Double) |
Multiply(Size2dU, UInt32) |
Subtraction |

See Also

Size2dU Class


Addition Operator

[image]

One of William Foster's Class Libraries
Size2dU..::..Addition Operator
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Addition(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2dU operator +(
    Size2dU size1,
    Size2dU size2
)
Visual Basic
Public Shared Operator + ( _
    size1 As Size2dU, _
    size2 As Size2dU _
) As Size2dU
Visual C++
public:
static Size2dU^ operator +(
    Size2dU^ size1,
    Size2dU^ size2
)

Parameters

size1
Type: El..::..Size2dU

[Missing <param name="size1"/> documentation for "M:El.Size2dU.op_Addition(El.Size2dU,El.Size2dU)"]

size2
Type: El..::..Size2dU

[Missing <param name="size2"/> documentation for "M:El.Size2dU.op_Addition(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Addition(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class


Division Operator

[image] [image]

One of William Foster's Class Libraries
Size2dU..::..Division Operator
Size2dU Class See Also Send Feedback

Overload List

Name | Description
Division(Size2dU, Size2dU) |
Division(Size2dU, Double) |

See Also

Size2dU Class
Size2dU Members


Division Operator (Size2dU, Size2dU)

[image]

One of William Foster's Class Libraries
Size2dU..::..Division Operator (Size2dU, Size2dU)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Division(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2dU operator /(
    Size2dU size,
    Size2dU divSize
)
Visual Basic
Public Shared Operator / ( _
    size As Size2dU, _
    divSize As Size2dU _
) As Size2dU
Visual C++
public:
static Size2dU^ operator /(
    Size2dU^ size,
    Size2dU^ divSize
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.op_Division(El.Size2dU,El.Size2dU)"]

divSize
Type: El..::..Size2dU

[Missing <param name="divSize"/> documentation for "M:El.Size2dU.op_Division(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Division(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class
Division Overload


Division Operator (Size2dU, Double)

[image]

One of William Foster's Class Libraries
Size2dU..::..Division Operator (Size2dU, Double)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Division(El.Size2dU,System.Double)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2dU operator /(
    Size2dU size,
    double d_div
)
Visual Basic
Public Shared Operator / ( _
    size As Size2dU, _
    d_div As Double _
) As Size2dU
Visual C++
public:
static Size2dU^ operator /(
    Size2dU^ size,
    double d_div
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.op_Division(El.Size2dU,System.Double)"]

d_div
Type: System..::..Double

[Missing <param name="d_div"/> documentation for "M:El.Size2dU.op_Division(El.Size2dU,System.Double)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Division(El.Size2dU,System.Double)"]

See Also

Size2dU Class
Division Overload


Equality Operator

[image]

One of William Foster's Class Libraries
Size2dU..::..Equality Operator
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Equality(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator ==(
    Size2dU size1,
    Size2dU size2
)
Visual Basic
Public Shared Operator = ( _
    size1 As Size2dU, _
    size2 As Size2dU _
) As Boolean
Visual C++
public:
static bool operator ==(
    Size2dU^ size1,
    Size2dU^ size2
)

Parameters

size1
Type: El..::..Size2dU

[Missing <param name="size1"/> documentation for "M:El.Size2dU.op_Equality(El.Size2dU,El.Size2dU)"]

size2
Type: El..::..Size2dU

[Missing <param name="size2"/> documentation for "M:El.Size2dU.op_Equality(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Equality(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class


GreaterThan Operator

[image]

One of William Foster's Class Libraries
Size2dU..::..GreaterThan Operator
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_GreaterThan(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator >(
    Size2dU size,
    Size2dU greaterthanSize
)
Visual Basic
Public Shared Operator > ( _
    size As Size2dU, _
    greaterthanSize As Size2dU _
) As Boolean
Visual C++
public:
static bool operator >(
    Size2dU^ size,
    Size2dU^ greaterthanSize
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.op_GreaterThan(El.Size2dU,El.Size2dU)"]

greaterthanSize
Type: El..::..Size2dU

[Missing <param name="greaterthanSize"/> documentation for "M:El.Size2dU.op_GreaterThan(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_GreaterThan(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class


GreaterThanOrEqual Operator

[image]

One of William Foster's Class Libraries
Size2dU..::..GreaterThanOrEqual Operator
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_GreaterThanOrEqual(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator >=(
    Size2dU size,
    Size2dU greaterthanSize
)
Visual Basic
Public Shared Operator >= ( _
    size As Size2dU, _
    greaterthanSize As Size2dU _
) As Boolean
Visual C++
public:
static bool operator >=(
    Size2dU^ size,
    Size2dU^ greaterthanSize
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.op_GreaterThanOrEqual(El.Size2dU,El.Size2dU)"]

greaterthanSize
Type: El..::..Size2dU

[Missing <param name="greaterthanSize"/> documentation for "M:El.Size2dU.op_GreaterThanOrEqual(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_GreaterThanOrEqual(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class


Implicit Conversion Operators

[image] [image]

One of William Foster's Class Libraries
Size2dU ImplicitWideningImplicitImplicitImplicit Conversion Operators
Size2dU Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(Size to Size2dU) |
ImplicitWideningImplicitImplicitImplicit(Size2dU to Point) |
ImplicitWideningImplicitImplicitImplicit(Size2dU to Size) |

See Also

Size2dU Class
Size2dU Members


Implicit Conversion (Size to Size2dU)

[image]

One of William Foster's Class Libraries
Size2dU ImplicitWideningImplicitImplicitImplicit Conversion (Size to Size2dU)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Implicit(System.Drawing.Size)~El.Size2dU"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator Size2dU (
    Size s
)
Visual Basic
Public Shared Widening Operator CType ( _
    s As Size _
) As Size2dU
Visual C++
static implicit operator Size2dU^ (
    Size s
)

Parameters

s
Type: System.Drawing..::..Size

[Missing <param name="s"/> documentation for "M:El.Size2dU.op_Implicit(System.Drawing.Size)~El.Size2dU"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Implicit(System.Drawing.Size)~El.Size2dU"]

See Also

Size2dU Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (Size2dU to Point)

[image]

One of William Foster's Class Libraries
Size2dU ImplicitWideningImplicitImplicitImplicit Conversion (Size2dU to Point)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Implicit(El.Size2dU)~System.Drawing.Point"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator Point (
    Size2dU s
)
Visual Basic
Public Shared Widening Operator CType ( _
    s As Size2dU _
) As Point
Visual C++
static implicit operator Point (
    Size2dU^ s
)

Parameters

s
Type: El..::..Size2dU

[Missing <param name="s"/> documentation for "M:El.Size2dU.op_Implicit(El.Size2dU)~System.Drawing.Point"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Implicit(El.Size2dU)~System.Drawing.Point"]

See Also

Size2dU Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (Size2dU to Size)

[image]

One of William Foster's Class Libraries
Size2dU ImplicitWideningImplicitImplicitImplicit Conversion (Size2dU to Size)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Implicit(El.Size2dU)~System.Drawing.Size"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator Size (
    Size2dU s
)
Visual Basic
Public Shared Widening Operator CType ( _
    s As Size2dU _
) As Size
Visual C++
static implicit operator Size (
    Size2dU^ s
)

Parameters

s
Type: El..::..Size2dU

[Missing <param name="s"/> documentation for "M:El.Size2dU.op_Implicit(El.Size2dU)~System.Drawing.Size"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Implicit(El.Size2dU)~System.Drawing.Size"]

See Also

Size2dU Class
ImplicitWideningImplicitImplicitImplicit Overload


Inequality Operator

[image]

One of William Foster's Class Libraries
Size2dU..::..Inequality Operator
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Inequality(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator !=(
    Size2dU size1,
    Size2dU size2
)
Visual Basic
Public Shared Operator <> ( _
    size1 As Size2dU, _
    size2 As Size2dU _
) As Boolean
Visual C++
public:
static bool operator !=(
    Size2dU^ size1,
    Size2dU^ size2
)

Parameters

size1
Type: El..::..Size2dU

[Missing <param name="size1"/> documentation for "M:El.Size2dU.op_Inequality(El.Size2dU,El.Size2dU)"]

size2
Type: El..::..Size2dU

[Missing <param name="size2"/> documentation for "M:El.Size2dU.op_Inequality(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Inequality(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class


LessThan Operator

[image]

One of William Foster's Class Libraries
Size2dU..::..LessThan Operator
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_LessThan(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator <(
    Size2dU size,
    Size2dU lessthanSize
)
Visual Basic
Public Shared Operator < ( _
    size As Size2dU, _
    lessthanSize As Size2dU _
) As Boolean
Visual C++
public:
static bool operator <(
    Size2dU^ size,
    Size2dU^ lessthanSize
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.op_LessThan(El.Size2dU,El.Size2dU)"]

lessthanSize
Type: El..::..Size2dU

[Missing <param name="lessthanSize"/> documentation for "M:El.Size2dU.op_LessThan(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_LessThan(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class


LessThanOrEqual Operator

[image]

One of William Foster's Class Libraries
Size2dU..::..LessThanOrEqual Operator
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_LessThanOrEqual(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator <=(
    Size2dU size,
    Size2dU lessthanSize
)
Visual Basic
Public Shared Operator <= ( _
    size As Size2dU, _
    lessthanSize As Size2dU _
) As Boolean
Visual C++
public:
static bool operator <=(
    Size2dU^ size,
    Size2dU^ lessthanSize
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.op_LessThanOrEqual(El.Size2dU,El.Size2dU)"]

lessthanSize
Type: El..::..Size2dU

[Missing <param name="lessthanSize"/> documentation for "M:El.Size2dU.op_LessThanOrEqual(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_LessThanOrEqual(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class


Modulus Operator

[image]

One of William Foster's Class Libraries
Size2dU..::..Modulus Operator
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Modulus(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2dU operator %(
    Size2dU size,
    Size2dU modSize
)
Visual Basic
Public Shared Operator Mod ( _
    size As Size2dU, _
    modSize As Size2dU _
) As Size2dU
Visual C++
public:
static Size2dU^ operator %(
    Size2dU^ size,
    Size2dU^ modSize
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.op_Modulus(El.Size2dU,El.Size2dU)"]

modSize
Type: El..::..Size2dU

[Missing <param name="modSize"/> documentation for "M:El.Size2dU.op_Modulus(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Modulus(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class


Multiply Operator

[image] [image]

One of William Foster's Class Libraries
Size2dU..::..Multiply Operator
Size2dU Class See Also Send Feedback

Overload List

Name | Description
Multiply(Size2dU, Size2d) |
Multiply(Size2dU, Size2dU) |
Multiply(Size2dU, Double) |
Multiply(Size2dU, UInt32) |

See Also

Size2dU Class
Size2dU Members


Multiply Operator (Size2dU, Size2d)

[image]

One of William Foster's Class Libraries
Size2dU..::..Multiply Operator (Size2dU, Size2d)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,El.Size2d)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2dU operator *(
    Size2dU size1,
    Size2d size2
)
Visual Basic
Public Shared Operator * ( _
    size1 As Size2dU, _
    size2 As Size2d _
) As Size2dU
Visual C++
public:
static Size2dU^ operator *(
    Size2dU^ size1,
    Size2d^ size2
)

Parameters

size1
Type: El..::..Size2dU

[Missing <param name="size1"/> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,El.Size2d)"]

size2
Type: El..::..Size2d

[Missing <param name="size2"/> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,El.Size2d)"]

See Also

Size2dU Class
Multiply Overload


Multiply Operator (Size2dU, Size2dU)

[image]

One of William Foster's Class Libraries
Size2dU..::..Multiply Operator (Size2dU, Size2dU)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2dU operator *(
    Size2dU size1,
    Size2dU size2
)
Visual Basic
Public Shared Operator * ( _
    size1 As Size2dU, _
    size2 As Size2dU _
) As Size2dU
Visual C++
public:
static Size2dU^ operator *(
    Size2dU^ size1,
    Size2dU^ size2
)

Parameters

size1
Type: El..::..Size2dU

[Missing <param name="size1"/> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,El.Size2dU)"]

size2
Type: El..::..Size2dU

[Missing <param name="size2"/> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class
Multiply Overload


Multiply Operator (Size2dU, Double)

[image]

One of William Foster's Class Libraries
Size2dU..::..Multiply Operator (Size2dU, Double)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,System.Double)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2dU operator *(
    Size2dU size,
    double d_mul
)
Visual Basic
Public Shared Operator * ( _
    size As Size2dU, _
    d_mul As Double _
) As Size2dU
Visual C++
public:
static Size2dU^ operator *(
    Size2dU^ size,
    double d_mul
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,System.Double)"]

d_mul
Type: System..::..Double

[Missing <param name="d_mul"/> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,System.Double)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,System.Double)"]

See Also

Size2dU Class
Multiply Overload


Multiply Operator (Size2dU, UInt32)

[image]

One of William Foster's Class Libraries
Size2dU..::..Multiply Operator (Size2dU, UInt32)
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2dU operator *(
    Size2dU size,
    uint u_mul
)
Visual Basic
Public Shared Operator * ( _
    size As Size2dU, _
    u_mul As UInteger _
) As Size2dU
Visual C++
public:
static Size2dU^ operator *(
    Size2dU^ size,
    unsigned int u_mul
)

Parameters

size
Type: El..::..Size2dU

[Missing <param name="size"/> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,System.UInt32)"]

u_mul
Type: System..::..UInt32

[Missing <param name="u_mul"/> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Multiply(El.Size2dU,System.UInt32)"]

See Also

Size2dU Class
Multiply Overload


Subtraction Operator

[image]

One of William Foster's Class Libraries
Size2dU..::..Subtraction Operator
Size2dU Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Size2dU.op_Subtraction(El.Size2dU,El.Size2dU)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Size2dU operator -(
    Size2dU size1,
    Size2dU size2
)
Visual Basic
Public Shared Operator - ( _
    size1 As Size2dU, _
    size2 As Size2dU _
) As Size2dU
Visual C++
public:
static Size2dU^ operator -(
    Size2dU^ size1,
    Size2dU^ size2
)

Parameters

size1
Type: El..::..Size2dU

[Missing <param name="size1"/> documentation for "M:El.Size2dU.op_Subtraction(El.Size2dU,El.Size2dU)"]

size2
Type: El..::..Size2dU

[Missing <param name="size2"/> documentation for "M:El.Size2dU.op_Subtraction(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:El.Size2dU.op_Subtraction(El.Size2dU,El.Size2dU)"]

See Also

Size2dU Class


Stream Class

[image]

One of William Foster's Class Libraries
Stream Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Stream"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Stream
Visual Basic
Public Class Stream
Visual C++
public ref class Stream

Inheritance Hierarchy

System..::..Object
El..::..Stream
El..::..CBfc_File

See Also

Stream Members


Stream Members

[image] [image]

One of William Foster's Class Libraries
Stream Members
Stream Class Constructors Methods Fields Properties See Also Send Feedback

The Stream type exposes the following members.

Constructors

 | Name | Description
Public method | Stream()()()() | Initializes a new instance of the Stream class
Public method | Stream(Stream) | Initializes a new instance of the Stream class
Public method | Stream(Filename, Boolean) | Initializes a new instance of the Stream class
Public method | Stream(StreamSource, Boolean) | Initializes a new instance of the Stream class

Methods

 | Name | Description
Public method | AppendStream |
Public method | AppendToFile |
Public method | AttachFile(Filename, Stream..::..EAccessMode) |
Public method | AttachFile(Filename, Boolean) |
Public method | AttachMemory(array<Byte>[]()[][], UInt64) |
Public method | AttachMemory(array<Char>[]()[][], UInt64) |
Public method | AttachStream |
Public method | Close |
Public method | CreateFile |
Public method | Detach |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | Flush |
Public method | GetFilename |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttached |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttach |
Public method | Open |
Public method | Read |
Public method | ReadAhead |
Public method | Rewind |
Public method | Seek(UInt32, UInt64) |
Public method | Seek(UInt32, UInt64, UInt64%) |
Public method | Set |
Public method | SetThreaded |
Public method | Tell |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write(STRING) |
Public method | Write(MemPtr, UInt32, UInt32%) |

Fields

 | Name | Description
Public field | m_bReadOnly |
Protected field | m_source |
Protected field | m_ThreadInfo |

Properties

 | Name | Description
Public property | SysStream |

See Also

Stream Class


Stream Constructor

[image] [image]

One of William Foster's Class Libraries
Stream Constructor
Stream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Stream()()()() | Initializes a new instance of the Stream class
Public method | Stream(Stream) | Initializes a new instance of the Stream class
Public method | Stream(Filename, Boolean) | Initializes a new instance of the Stream class
Public method | Stream(StreamSource, Boolean) | Initializes a new instance of the Stream class

See Also

Stream Class
Stream Members


Stream Constructor

[image]

One of William Foster's Class Libraries
Stream Constructor
Stream Class See Also Send Feedback
Initializes a new instance of the Stream class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Stream()
Visual Basic
Public Sub New
Visual C++
public:
Stream()

See Also

Stream Class
Stream Overload


Stream Constructor (Stream)

[image]

One of William Foster's Class Libraries
Stream Constructor (Stream)
Stream Class See Also Send Feedback
Initializes a new instance of the Stream class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Stream(
    Stream bfc_stream
)
Visual Basic
Public Sub New ( _
    bfc_stream As Stream _
)
Visual C++
public:
Stream(
    Stream^ bfc_stream
)

Parameters

bfc_stream
Type: El..::..Stream

[Missing <param name="bfc_stream"/> documentation for "M:El.Stream.#ctor(El.Stream)"]

See Also

Stream Class
Stream Overload


Stream Constructor (Filename, Boolean)

[image]

One of William Foster's Class Libraries
Stream Constructor (Filename, Boolean)
Stream Class See Also Send Feedback
Initializes a new instance of the Stream class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Stream(
    Filename bfc_filename,
    bool b_ReadOnly
)
Visual Basic
Public Sub New ( _
    bfc_filename As Filename, _
    b_ReadOnly As Boolean _
)
Visual C++
public:
Stream(
    Filename^ bfc_filename,
    bool b_ReadOnly
)

Parameters

bfc_filename
Type: El..::..Filename

[Missing <param name="bfc_filename"/> documentation for "M:El.Stream.#ctor(El.Filename,System.Boolean)"]

b_ReadOnly
Type: System..::..Boolean

[Missing <param name="b_ReadOnly"/> documentation for "M:El.Stream.#ctor(El.Filename,System.Boolean)"]

See Also

Stream Class
Stream Overload


Stream Constructor (StreamSource, Boolean)

[image]

One of William Foster's Class Libraries
Stream Constructor (StreamSource, Boolean)
Stream Class See Also Send Feedback
Initializes a new instance of the Stream class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Stream(
    StreamSource source,
    bool b_ReadOnly
)
Visual Basic
Public Sub New ( _
    source As StreamSource, _
    b_ReadOnly As Boolean _
)
Visual C++
public:
Stream(
    StreamSource^ source,
    bool b_ReadOnly
)

Parameters

source
Type: El..::..StreamSource

[Missing <param name="source"/> documentation for "M:El.Stream.#ctor(El.StreamSource,System.Boolean)"]

b_ReadOnly
Type: System..::..Boolean

[Missing <param name="b_ReadOnly"/> documentation for "M:El.Stream.#ctor(El.StreamSource,System.Boolean)"]

See Also

Stream Class
Stream Overload


Stream Fields

[image] [image]

One of William Foster's Class Libraries
Stream Fields
Stream Class See Also Send Feedback

The Stream type exposes the following members.

Fields

 | Name | Description
Public field | m_bReadOnly |
Protected field | m_source |
Protected field | m_ThreadInfo |

See Also

Stream Class


m_bReadOnly Field

[image]

One of William Foster's Class Libraries
Stream..::..m_bReadOnly Field
Stream Class See Also Send Feedback

[Missing <summary> documentation for "F:El.Stream.m_bReadOnly"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool m_bReadOnly
Visual Basic
Public m_bReadOnly As Boolean
Visual C++
public:
bool m_bReadOnly

See Also

Stream Class


m_source Field

[image]

One of William Foster's Class Libraries
Stream..::..m_source Field
Stream Class See Also Send Feedback

[Missing <summary> documentation for "F:El.Stream.m_source"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected StreamSource m_source
Visual Basic
Protected m_source As StreamSource
Visual C++
protected:
StreamSource^ m_source

See Also

Stream Class


m_ThreadInfo Field

[image]

One of William Foster's Class Libraries
Stream..::..m_ThreadInfo Field
Stream Class See Also Send Feedback

[Missing <summary> documentation for "F:El.Stream.m_ThreadInfo"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected StreamThreadInfo m_ThreadInfo
Visual Basic
Protected m_ThreadInfo As StreamThreadInfo
Visual C++
protected:
StreamThreadInfo^ m_ThreadInfo

See Also

Stream Class


Stream Methods

[image] [image]

One of William Foster's Class Libraries
Stream Methods
Stream Class See Also Send Feedback

The Stream type exposes the following members.

Methods

 | Name | Description
Public method | AppendStream |
Public method | AppendToFile |
Public method | AttachFile(Filename, Stream..::..EAccessMode) |
Public method | AttachFile(Filename, Boolean) |
Public method | AttachMemory(array<Byte>[]()[][], UInt64) |
Public method | AttachMemory(array<Char>[]()[][], UInt64) |
Public method | AttachStream |
Public method | Close |
Public method | CreateFile |
Public method | Detach |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | Flush |
Public method | GetFilename |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttached |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttach |
Public method | Open |
Public method | Read |
Public method | ReadAhead |
Public method | Rewind |
Public method | Seek(UInt32, UInt64) |
Public method | Seek(UInt32, UInt64, UInt64%) |
Public method | Set |
Public method | SetThreaded |
Public method | Tell |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write(STRING) |
Public method | Write(MemPtr, UInt32, UInt32%) |

See Also

Stream Class


AppendStream Method

[image]

One of William Foster's Class Libraries
Stream..::..AppendStream Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.AppendStream(El.Stream)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool AppendStream(
    Stream stream
)
Visual Basic
Public Function AppendStream ( _
    stream As Stream _
) As Boolean
Visual C++
public:
bool AppendStream(
    Stream^ stream
)

Parameters

stream
Type: El..::..Stream

[Missing <param name="stream"/> documentation for "M:El.Stream.AppendStream(El.Stream)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.AppendStream(El.Stream)"]

See Also

Stream Class


AppendToFile Method

[image]

One of William Foster's Class Libraries
Stream..::..AppendToFile Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.AppendToFile(El.Filename)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool AppendToFile(
    Filename filename
)
Visual Basic
Public Function AppendToFile ( _
    filename As Filename _
) As Boolean
Visual C++
public:
bool AppendToFile(
    Filename^ filename
)

Parameters

filename
Type: El..::..Filename

[Missing <param name="filename"/> documentation for "M:El.Stream.AppendToFile(El.Filename)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.AppendToFile(El.Filename)"]

See Also

Stream Class


AttachFile Method

[image] [image]

One of William Foster's Class Libraries
Stream..::..AttachFile Method
Stream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachFile(Filename, Stream..::..EAccessMode) |
Public method | AttachFile(Filename, Boolean) |

See Also

Stream Class
Stream Members


AttachFile Method (Filename, Stream.EAccessMode)

[image]

One of William Foster's Class Libraries
Stream..::..AttachFile Method (Filename, Stream..::..EAccessMode)
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.AttachFile(El.Filename,El.Stream.EAccessMode)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool AttachFile(
    Filename filename,
    Stream..::..EAccessMode mode
)
Visual Basic
Public Function AttachFile ( _
    filename As Filename, _
    mode As Stream..::..EAccessMode _
) As Boolean
Visual C++
public:
bool AttachFile(
    Filename^ filename,
    Stream..::..EAccessMode mode
)

Parameters

filename
Type: El..::..Filename

[Missing <param name="filename"/> documentation for "M:El.Stream.AttachFile(El.Filename,El.Stream.EAccessMode)"]

mode
Type: El..::..Stream..::..EAccessMode

[Missing <param name="mode"/> documentation for "M:El.Stream.AttachFile(El.Filename,El.Stream.EAccessMode)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.AttachFile(El.Filename,El.Stream.EAccessMode)"]

See Also

Stream Class
AttachFile Overload


AttachFile Method (Filename, Boolean)

[image]

One of William Foster's Class Libraries
Stream..::..AttachFile Method (Filename, Boolean)
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.AttachFile(El.Filename,System.Boolean)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool AttachFile(
    Filename filename,
    bool b_ReadOnly
)
Visual Basic
Public Function AttachFile ( _
    filename As Filename, _
    b_ReadOnly As Boolean _
) As Boolean
Visual C++
public:
bool AttachFile(
    Filename^ filename,
    bool b_ReadOnly
)

Parameters

filename
Type: El..::..Filename

[Missing <param name="filename"/> documentation for "M:El.Stream.AttachFile(El.Filename,System.Boolean)"]

b_ReadOnly
Type: System..::..Boolean

[Missing <param name="b_ReadOnly"/> documentation for "M:El.Stream.AttachFile(El.Filename,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.AttachFile(El.Filename,System.Boolean)"]

See Also

Stream Class
AttachFile Overload


AttachMemory Method

[image] [image]

One of William Foster's Class Libraries
Stream..::..AttachMemory Method
Stream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachMemory(array<Byte>[]()[][], UInt64) |
Public method | AttachMemory(array<Char>[]()[][], UInt64) |

See Also

Stream Class
Stream Members


AttachMemory Method (Byte[], UInt64)

[image]

One of William Foster's Class Libraries
Stream..::..AttachMemory Method (array<Byte>[]()[][], UInt64)
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.AttachMemory(System.Byte[],System.UInt64)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool AttachMemory(
    byte[] p_memory,
    ulong ul_memoryByteLength
)
Visual Basic
Public Function AttachMemory ( _
    p_memory As Byte(), _
    ul_memoryByteLength As ULong _
) As Boolean
Visual C++
public:
bool AttachMemory(
    array<unsigned char>^ p_memory,
    unsigned long long ul_memoryByteLength
)

Parameters

p_memory
Type: array< System..::..Byte >[]()[][]

[Missing <param name="p_memory"/> documentation for "M:El.Stream.AttachMemory(System.Byte[],System.UInt64)"]

ul_memoryByteLength
Type: System..::..UInt64

[Missing <param name="ul_memoryByteLength"/> documentation for "M:El.Stream.AttachMemory(System.Byte[],System.UInt64)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.AttachMemory(System.Byte[],System.UInt64)"]

See Also

Stream Class
AttachMemory Overload


AttachMemory Method (Char[], UInt64)

[image]

One of William Foster's Class Libraries
Stream..::..AttachMemory Method (array<Char>[]()[][], UInt64)
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.AttachMemory(System.Char[],System.UInt64)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool AttachMemory(
    char[] p_charmemory,
    ulong ul_memoryByteLength
)
Visual Basic
Public Function AttachMemory ( _
    p_charmemory As Char(), _
    ul_memoryByteLength As ULong _
) As Boolean
Visual C++
public:
bool AttachMemory(
    array<wchar_t>^ p_charmemory,
    unsigned long long ul_memoryByteLength
)

Parameters

p_charmemory
Type: array< System..::..Char >[]()[][]

[Missing <param name="p_charmemory"/> documentation for "M:El.Stream.AttachMemory(System.Char[],System.UInt64)"]

ul_memoryByteLength
Type: System..::..UInt64

[Missing <param name="ul_memoryByteLength"/> documentation for "M:El.Stream.AttachMemory(System.Char[],System.UInt64)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.AttachMemory(System.Char[],System.UInt64)"]

See Also

Stream Class
AttachMemory Overload


AttachStream Method

[image]

One of William Foster's Class Libraries
Stream..::..AttachStream Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.AttachStream(El.Stream)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool AttachStream(
    Stream stream
)
Visual Basic
Public Function AttachStream ( _
    stream As Stream _
) As Boolean
Visual C++
public:
bool AttachStream(
    Stream^ stream
)

Parameters

stream
Type: El..::..Stream

[Missing <param name="stream"/> documentation for "M:El.Stream.AttachStream(El.Stream)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.AttachStream(El.Stream)"]

See Also

Stream Class


Close Method

[image]

One of William Foster's Class Libraries
Stream..::..Close Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.Close"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Close()
Visual Basic
Public Function Close As Boolean
Visual C++
public:
bool Close()

Return Value

[Missing <returns> documentation for "M:El.Stream.Close"]

See Also

Stream Class


CreateFile Method

[image]

One of William Foster's Class Libraries
Stream..::..CreateFile Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.CreateFile(El.Filename)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool CreateFile(
    Filename filename
)
Visual Basic
Public Function CreateFile ( _
    filename As Filename _
) As Boolean
Visual C++
public:
bool CreateFile(
    Filename^ filename
)

Parameters

filename
Type: El..::..Filename

[Missing <param name="filename"/> documentation for "M:El.Stream.CreateFile(El.Filename)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.CreateFile(El.Filename)"]

See Also

Stream Class


Detach Method

[image]

One of William Foster's Class Libraries
Stream..::..Detach Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.Detach"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool Detach()
Visual Basic
Public Overridable Function Detach As Boolean
Visual C++
public:
virtual bool Detach()

Return Value

[Missing <returns> documentation for "M:El.Stream.Detach"]

See Also

Stream Class


Finalize Method

[image]

One of William Foster's Class Libraries
Stream..::..Finalize Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.Finalize"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Stream Class


Flush Method

[image]

One of William Foster's Class Libraries
Stream..::..Flush Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.Flush"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Flush()
Visual Basic
Public Function Flush As Boolean
Visual C++
public:
bool Flush()

Return Value

[Missing <returns> documentation for "M:El.Stream.Flush"]

See Also

Stream Class


GetFilename Method

[image]

One of William Foster's Class Libraries
Stream..::..GetFilename Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.GetFilename(El.Filename@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool GetFilename(
    out Filename csFilename
)
Visual Basic
Public Function GetFilename ( _
    <OutAttribute> ByRef csFilename As Filename _
) As Boolean
Visual C++
public:
bool GetFilename(
    [OutAttribute] Filename^% csFilename
)

Parameters

csFilename
Type: El..::..Filename %

[Missing <param name="csFilename"/> documentation for "M:El.Stream.GetFilename(El.Filename@)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.GetFilename(El.Filename@)"]

See Also

Stream Class


IsAttached Method

[image]

One of William Foster's Class Libraries
Stream..::..IsAttached Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.IsAttached"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool IsAttached()
Visual Basic
Public Function IsAttached As Boolean
Visual C++
public:
bool IsAttached()

Return Value

[Missing <returns> documentation for "M:El.Stream.IsAttached"]

See Also

Stream Class


OnAttach Method

[image]

One of William Foster's Class Libraries
Stream..::..OnAttach Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.OnAttach"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected virtual bool OnAttach()
Visual Basic
Protected Overridable Function OnAttach As Boolean
Visual C++
protected:
virtual bool OnAttach()

Return Value

[Missing <returns> documentation for "M:El.Stream.OnAttach"]

See Also

Stream Class


Open Method

[image]

One of William Foster's Class Libraries
Stream..::..Open Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.Open"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Open()
Visual Basic
Public Function Open As Boolean
Visual C++
public:
bool Open()

Return Value

[Missing <returns> documentation for "M:El.Stream.Open"]

See Also

Stream Class


Read Method

[image]

One of William Foster's Class Libraries
Stream..::..Read Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Read(
    MemPtr dstMem,
    uint uCount,
    out uint uBytesRead
)
Visual Basic
Public Function Read ( _
    dstMem As MemPtr, _
    uCount As UInteger, _
    <OutAttribute> ByRef uBytesRead As UInteger _
) As Boolean
Visual C++
public:
bool Read(
    MemPtr^ dstMem,
    unsigned int uCount,
    [OutAttribute] unsigned int% uBytesRead
)

Parameters

dstMem
Type: El..::..MemPtr

[Missing <param name="dstMem"/> documentation for "M:El.Stream.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

uCount
Type: System..::..UInt32

[Missing <param name="uCount"/> documentation for "M:El.Stream.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

uBytesRead
Type: System..::..UInt32 %

[Missing <param name="uBytesRead"/> documentation for "M:El.Stream.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

See Also

Stream Class


ReadAhead Method

[image]

One of William Foster's Class Libraries
Stream..::..ReadAhead Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.ReadAhead(El.MemPtr,System.UInt32,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool ReadAhead(
    MemPtr dstMem,
    uint uCount,
    out uint uBytesRead
)
Visual Basic
Public Function ReadAhead ( _
    dstMem As MemPtr, _
    uCount As UInteger, _
    <OutAttribute> ByRef uBytesRead As UInteger _
) As Boolean
Visual C++
public:
bool ReadAhead(
    MemPtr^ dstMem,
    unsigned int uCount,
    [OutAttribute] unsigned int% uBytesRead
)

Parameters

dstMem
Type: El..::..MemPtr

[Missing <param name="dstMem"/> documentation for "M:El.Stream.ReadAhead(El.MemPtr,System.UInt32,System.UInt32@)"]

uCount
Type: System..::..UInt32

[Missing <param name="uCount"/> documentation for "M:El.Stream.ReadAhead(El.MemPtr,System.UInt32,System.UInt32@)"]

uBytesRead
Type: System..::..UInt32 %

[Missing <param name="uBytesRead"/> documentation for "M:El.Stream.ReadAhead(El.MemPtr,System.UInt32,System.UInt32@)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.ReadAhead(El.MemPtr,System.UInt32,System.UInt32@)"]

See Also

Stream Class


Rewind Method

[image]

One of William Foster's Class Libraries
Stream..::..Rewind Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.Rewind"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool Rewind()
Visual Basic
Public Overridable Function Rewind As Boolean
Visual C++
public:
virtual bool Rewind()

Return Value

[Missing <returns> documentation for "M:El.Stream.Rewind"]

See Also

Stream Class


Seek Method

[image] [image]

One of William Foster's Class Libraries
Stream..::..Seek Method
Stream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(UInt32, UInt64) |
Public method | Seek(UInt32, UInt64, UInt64%) |

See Also

Stream Class
Stream Members


Seek Method (UInt32, UInt64)

[image]

One of William Foster's Class Libraries
Stream..::..Seek Method (UInt32, UInt64)
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.Seek(System.UInt32,System.UInt64)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Seek(
    uint n64Offset,
    ulong ulOrigin
)
Visual Basic
Public Function Seek ( _
    n64Offset As UInteger, _
    ulOrigin As ULong _
) As Boolean
Visual C++
public:
bool Seek(
    unsigned int n64Offset,
    unsigned long long ulOrigin
)

Parameters

n64Offset
Type: System..::..UInt32

[Missing <param name="n64Offset"/> documentation for "M:El.Stream.Seek(System.UInt32,System.UInt64)"]

ulOrigin
Type: System..::..UInt64

[Missing <param name="ulOrigin"/> documentation for "M:El.Stream.Seek(System.UInt32,System.UInt64)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.Seek(System.UInt32,System.UInt64)"]

See Also

Stream Class
Seek Overload


Seek Method (UInt32, UInt64, UInt64)

[image]

One of William Foster's Class Libraries
Stream..::..Seek Method (UInt32, UInt64, UInt64%)
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.Seek(System.UInt32,System.UInt64,System.UInt64@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool Seek(
    uint n64Offset,
    ulong ulOrigin,
    out ulong un64NewPosition
)
Visual Basic
Public Overridable Function Seek ( _
    n64Offset As UInteger, _
    ulOrigin As ULong, _
    <OutAttribute> ByRef un64NewPosition As ULong _
) As Boolean
Visual C++
public:
virtual bool Seek(
    unsigned int n64Offset,
    unsigned long long ulOrigin,
    [OutAttribute] unsigned long long% un64NewPosition
)

Parameters

n64Offset
Type: System..::..UInt32

[Missing <param name="n64Offset"/> documentation for "M:El.Stream.Seek(System.UInt32,System.UInt64,System.UInt64@)"]

ulOrigin
Type: System..::..UInt64

[Missing <param name="ulOrigin"/> documentation for "M:El.Stream.Seek(System.UInt32,System.UInt64,System.UInt64@)"]

un64NewPosition
Type: System..::..UInt64 %

[Missing <param name="un64NewPosition"/> documentation for "M:El.Stream.Seek(System.UInt32,System.UInt64,System.UInt64@)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.Seek(System.UInt32,System.UInt64,System.UInt64@)"]

See Also

Stream Class
Seek Overload


Set Method

[image]

One of William Foster's Class Libraries
Stream..::..Set Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.Set(El.Stream)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Set(
    Stream stream
)
Visual Basic
Public Sub Set ( _
    stream As Stream _
)
Visual C++
public:
void Set(
    Stream^ stream
)

Parameters

stream
Type: El..::..Stream

[Missing <param name="stream"/> documentation for "M:El.Stream.Set(El.Stream)"]

See Also

Stream Class


SetThreaded Method

[image]

One of William Foster's Class Libraries
Stream..::..SetThreaded Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.SetThreaded(System.Boolean)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetThreaded(
    bool b_threaded
)
Visual Basic
Public Sub SetThreaded ( _
    b_threaded As Boolean _
)
Visual C++
public:
void SetThreaded(
    bool b_threaded
)

Parameters

b_threaded
Type: System..::..Boolean

[Missing <param name="b_threaded"/> documentation for "M:El.Stream.SetThreaded(System.Boolean)"]

See Also

Stream Class


Tell Method

[image]

One of William Foster's Class Libraries
Stream..::..Tell Method
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.Tell"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual uint Tell()
Visual Basic
Public Overridable Function Tell As UInteger
Visual C++
public:
virtual unsigned int Tell()

Return Value

[Missing <returns> documentation for "M:El.Stream.Tell"]

See Also

Stream Class


Write Method

[image] [image]

One of William Foster's Class Libraries
Stream..::..Write Method
Stream Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(STRING) |
Public method | Write(MemPtr, UInt32, UInt32%) |

See Also

Stream Class
Stream Members


Write Method (STRING)

[image]

One of William Foster's Class Libraries
Stream..::..Write Method (STRING)
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.Write(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool Write(
    STRING cs
)
Visual Basic
Public Overridable Function Write ( _
    cs As STRING _
) As Boolean
Visual C++
public:
virtual bool Write(
    STRING^ cs
)

Parameters

cs
Type: El..::..STRING

[Missing <param name="cs"/> documentation for "M:El.Stream.Write(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.Write(El.STRING)"]

See Also

Stream Class
Write Overload


Write Method (MemPtr, UInt32, UInt32)

[image]

One of William Foster's Class Libraries
Stream..::..Write Method (MemPtr, UInt32, UInt32%)
Stream Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Stream.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool Write(
    MemPtr srcMem,
    uint uCount,
    out uint uBytesWritten
)
Visual Basic
Public Overridable Function Write ( _
    srcMem As MemPtr, _
    uCount As UInteger, _
    <OutAttribute> ByRef uBytesWritten As UInteger _
) As Boolean
Visual C++
public:
virtual bool Write(
    MemPtr^ srcMem,
    unsigned int uCount,
    [OutAttribute] unsigned int% uBytesWritten
)

Parameters

srcMem
Type: El..::..MemPtr

[Missing <param name="srcMem"/> documentation for "M:El.Stream.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

uCount
Type: System..::..UInt32

[Missing <param name="uCount"/> documentation for "M:El.Stream.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

uBytesWritten
Type: System..::..UInt32 %

[Missing <param name="uBytesWritten"/> documentation for "M:El.Stream.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

Return Value

[Missing <returns> documentation for "M:El.Stream.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

See Also

Stream Class
Write Overload


Stream Properties

[image] [image]

One of William Foster's Class Libraries
Stream Properties
Stream Class See Also Send Feedback

The Stream type exposes the following members.

Properties

 | Name | Description
Public property | SysStream |

See Also

Stream Class


SysStream Property

[image]

One of William Foster's Class Libraries
Stream..::..SysStream Property
Stream Class See Also Send Feedback

[Missing <summary> documentation for "P:El.Stream.SysStream"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Stream SysStream { get; }
Visual Basic
Public ReadOnly Property SysStream As Stream
    Get
Visual C++
public:
property Stream^ SysStream {
    Stream^ get ();
}

See Also

Stream Class


Stream.EAccessMode Enumeration

[image]

One of William Foster's Class Libraries
Stream..::..EAccessMode Enumeration
Stream Class See Also Send Feedback

[Missing <summary> documentation for "T:El.Stream.EAccessMode"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public enum EAccessMode
Visual Basic
Public Enumeration EAccessMode
Visual C++
public enum class EAccessMode

Members

Member name | Value | Description
READ_ONLY | 0 |
READ_WRITE | 1 |
OVERWRITE | 2 |
APPEND | 3 |
CREATE | 4 |

See Also

El Namespace

Send comments on this topic to bill@software-imagination.com

(C) 2011 by William P. Foster, all rights reserved.


StreamSource Class

[image]

One of William Foster's Class Libraries
StreamSource Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.StreamSource"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public abstract class StreamSource
Visual Basic
Public MustInherit Class StreamSource
Visual C++
public ref class StreamSource abstract

Inheritance Hierarchy

System..::..Object
El..::..StreamSource
El..::..StreamSource_File
El..::..StreamSource_Memory

See Also

StreamSource Members


StreamSource Members

[image] [image]

One of William Foster's Class Libraries
StreamSource Members
StreamSource Class Constructors Methods Fields Properties See Also Send Feedback

The StreamSource type exposes the following members.

Constructors

 | Name | Description
Public method | StreamSource | Initializes a new instance of the StreamSource class

Methods

 | Name | Description
Public method | Awaken |
Public method | Close |
Public method | CloseIt |
Public method | Detach |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStreamSource |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open |
Public method | OpenIt |
Public method | Read |
Public method | Seek |
Public method | Sleep |
Public method | Tell |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write |

Fields

 | Name | Description
Protected field | m_bOpen |
Protected field | m_streamSource |

Properties

 | Name | Description
Public property | SysStream |

See Also

StreamSource Class


StreamSource Constructor

[image]

One of William Foster's Class Libraries
StreamSource Constructor
StreamSource Class See Also Send Feedback
Initializes a new instance of the StreamSource class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public StreamSource()
Visual Basic
Public Sub New
Visual C++
public:
StreamSource()

See Also

StreamSource Class


StreamSource Fields

[image] [image]

One of William Foster's Class Libraries
StreamSource Fields
StreamSource Class See Also Send Feedback

The StreamSource type exposes the following members.

Fields

 | Name | Description
Protected field | m_bOpen |
Protected field | m_streamSource |

See Also

StreamSource Class


m_bOpen Field

[image]

One of William Foster's Class Libraries
StreamSource..::..m_bOpen Field
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "F:El.StreamSource.m_bOpen"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected bool m_bOpen
Visual Basic
Protected m_bOpen As Boolean
Visual C++
protected:
bool m_bOpen

See Also

StreamSource Class


m_streamSource Field

[image]

One of William Foster's Class Libraries
StreamSource..::..m_streamSource Field
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "F:El.StreamSource.m_streamSource"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected StreamSource..::..EBFC_StreamSource m_streamSource
Visual Basic
Protected m_streamSource As StreamSource..::..EBFC_StreamSource
Visual C++
protected:
StreamSource..::..EBFC_StreamSource m_streamSource

See Also

StreamSource Class


StreamSource Methods

[image] [image]

One of William Foster's Class Libraries
StreamSource Methods
StreamSource Class See Also Send Feedback

The StreamSource type exposes the following members.

Methods

 | Name | Description
Public method | Awaken |
Public method | Close |
Public method | CloseIt |
Public method | Detach |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStreamSource |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open |
Public method | OpenIt |
Public method | Read |
Public method | Seek |
Public method | Sleep |
Public method | Tell |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write |

See Also

StreamSource Class


Awaken Method

[image]

One of William Foster's Class Libraries
StreamSource..::..Awaken Method
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource.Awaken"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool Awaken()
Visual Basic
Public Overridable Function Awaken As Boolean
Visual C++
public:
virtual bool Awaken()

Return Value

[Missing <returns> documentation for "M:El.StreamSource.Awaken"]

See Also

StreamSource Class


Close Method

[image]

One of William Foster's Class Libraries
StreamSource..::..Close Method
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource.Close"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Close()
Visual Basic
Public Function Close As Boolean
Visual C++
public:
bool Close()

Return Value

[Missing <returns> documentation for "M:El.StreamSource.Close"]

See Also

StreamSource Class


CloseIt Method

[image]

One of William Foster's Class Libraries
StreamSource..::..CloseIt Method
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource.CloseIt"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool CloseIt()
Visual Basic
Public Overridable Function CloseIt As Boolean
Visual C++
public:
virtual bool CloseIt()

Return Value

[Missing <returns> documentation for "M:El.StreamSource.CloseIt"]

See Also

StreamSource Class


Detach Method

[image]

One of William Foster's Class Libraries
StreamSource..::..Detach Method
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource.Detach"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool Detach()
Visual Basic
Public Overridable Function Detach As Boolean
Visual C++
public:
virtual bool Detach()

Return Value

[Missing <returns> documentation for "M:El.StreamSource.Detach"]

See Also

StreamSource Class


Flush Method

[image]

One of William Foster's Class Libraries
StreamSource..::..Flush Method
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource.Flush"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool Flush()
Visual Basic
Public Overridable Function Flush As Boolean
Visual C++
public:
virtual bool Flush()

Return Value

[Missing <returns> documentation for "M:El.StreamSource.Flush"]

See Also

StreamSource Class


GetStreamSource Method

[image]

One of William Foster's Class Libraries
StreamSource..::..GetStreamSource Method
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource.GetStreamSource"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public StreamSource..::..EBFC_StreamSource GetStreamSource()
Visual Basic
Public Function GetStreamSource As StreamSource..::..EBFC_StreamSource
Visual C++
public:
StreamSource..::..EBFC_StreamSource GetStreamSource()

Return Value

[Missing <returns> documentation for "M:El.StreamSource.GetStreamSource"]

See Also

StreamSource Class


Open Method

[image]

One of William Foster's Class Libraries
StreamSource..::..Open Method
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource.Open"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Open()
Visual Basic
Public Function Open As Boolean
Visual C++
public:
bool Open()

Return Value

[Missing <returns> documentation for "M:El.StreamSource.Open"]

See Also

StreamSource Class


OpenIt Method

[image]

One of William Foster's Class Libraries
StreamSource..::..OpenIt Method
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource.OpenIt"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool OpenIt()
Visual Basic
Public Overridable Function OpenIt As Boolean
Visual C++
public:
virtual bool OpenIt()

Return Value

[Missing <returns> documentation for "M:El.StreamSource.OpenIt"]

See Also

StreamSource Class


Read Method

[image]

One of William Foster's Class Libraries
StreamSource..::..Read Method
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public abstract bool Read(
    MemPtr dstMem,
    uint uCount,
    out uint o_uBytesRead
)
Visual Basic
Public MustOverride Function Read ( _
    dstMem As MemPtr, _
    uCount As UInteger, _
    <OutAttribute> ByRef o_uBytesRead As UInteger _
) As Boolean
Visual C++
public:
virtual bool Read(
    MemPtr^ dstMem,
    unsigned int uCount,
    [OutAttribute] unsigned int% o_uBytesRead
) abstract

Parameters

dstMem
Type: El..::..MemPtr

[Missing <param name="dstMem"/> documentation for "M:El.StreamSource.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

uCount
Type: System..::..UInt32

[Missing <param name="uCount"/> documentation for "M:El.StreamSource.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

o_uBytesRead
Type: System..::..UInt32 %

[Missing <param name="o_uBytesRead"/> documentation for "M:El.StreamSource.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

Return Value

[Missing <returns> documentation for "M:El.StreamSource.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

See Also

StreamSource Class


Seek Method

[image]

One of William Foster's Class Libraries
StreamSource..::..Seek Method
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public abstract bool Seek(
    ulong n64Offset,
    ulong ulOrigin,
    out ulong pun64NewPosition
)
Visual Basic
Public MustOverride Function Seek ( _
    n64Offset As ULong, _
    ulOrigin As ULong, _
    <OutAttribute> ByRef pun64NewPosition As ULong _
) As Boolean
Visual C++
public:
virtual bool Seek(
    unsigned long long n64Offset,
    unsigned long long ulOrigin,
    [OutAttribute] unsigned long long% pun64NewPosition
) abstract

Parameters

n64Offset
Type: System..::..UInt64

[Missing <param name="n64Offset"/> documentation for "M:El.StreamSource.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

ulOrigin
Type: System..::..UInt64

[Missing <param name="ulOrigin"/> documentation for "M:El.StreamSource.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

pun64NewPosition
Type: System..::..UInt64 %

[Missing <param name="pun64NewPosition"/> documentation for "M:El.StreamSource.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

Return Value

[Missing <returns> documentation for "M:El.StreamSource.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

See Also

StreamSource Class


Sleep Method

[image]

One of William Foster's Class Libraries
StreamSource..::..Sleep Method
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource.Sleep"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool Sleep()
Visual Basic
Public Overridable Function Sleep As Boolean
Visual C++
public:
virtual bool Sleep()

Return Value

[Missing <returns> documentation for "M:El.StreamSource.Sleep"]

See Also

StreamSource Class


Tell Method

[image]

One of William Foster's Class Libraries
StreamSource..::..Tell Method
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource.Tell"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public abstract uint Tell()
Visual Basic
Public MustOverride Function Tell As UInteger
Visual C++
public:
virtual unsigned int Tell() abstract

Return Value

[Missing <returns> documentation for "M:El.StreamSource.Tell"]

See Also

StreamSource Class


Write Method

[image]

One of William Foster's Class Libraries
StreamSource..::..Write Method
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public abstract bool Write(
    MemPtr srcMem,
    uint uCount,
    out uint o_uBytesWritten
)
Visual Basic
Public MustOverride Function Write ( _
    srcMem As MemPtr, _
    uCount As UInteger, _
    <OutAttribute> ByRef o_uBytesWritten As UInteger _
) As Boolean
Visual C++
public:
virtual bool Write(
    MemPtr^ srcMem,
    unsigned int uCount,
    [OutAttribute] unsigned int% o_uBytesWritten
) abstract

Parameters

srcMem
Type: El..::..MemPtr

[Missing <param name="srcMem"/> documentation for "M:El.StreamSource.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

uCount
Type: System..::..UInt32

[Missing <param name="uCount"/> documentation for "M:El.StreamSource.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

o_uBytesWritten
Type: System..::..UInt32 %

[Missing <param name="o_uBytesWritten"/> documentation for "M:El.StreamSource.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

Return Value

[Missing <returns> documentation for "M:El.StreamSource.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

See Also

StreamSource Class


StreamSource Properties

[image] [image]

One of William Foster's Class Libraries
StreamSource Properties
StreamSource Class See Also Send Feedback

The StreamSource type exposes the following members.

Properties

 | Name | Description
Public property | SysStream |

See Also

StreamSource Class


SysStream Property

[image]

One of William Foster's Class Libraries
StreamSource..::..SysStream Property
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "P:El.StreamSource.SysStream"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public abstract Stream SysStream { get; }
Visual Basic
Public MustOverride ReadOnly Property SysStream As Stream
    Get
Visual C++
public:
virtual property Stream^ SysStream {
    Stream^ get () abstract;
}

See Also

StreamSource Class


StreamSource.EBFC_StreamSource Enumeration

[image]

One of William Foster's Class Libraries
StreamSource..::..EBFC_StreamSource Enumeration
StreamSource Class See Also Send Feedback

[Missing <summary> documentation for "T:El.StreamSource.EBFC_StreamSource"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public enum EBFC_StreamSource
Visual Basic
Public Enumeration EBFC_StreamSource
Visual C++
public enum class EBFC_StreamSource

Members

Member name | Value | Description
EBFC_STREAMSOURCE_FILE | 0 |
EBFC_STREAMSOURCE_MEMORY | 1 |

See Also

El Namespace

Send comments on this topic to bill@software-imagination.com

(C) 2011 by William P. Foster, all rights reserved.


StreamSource_File Class

[image]

One of William Foster's Class Libraries
StreamSource_File Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.StreamSource_File"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class StreamSource_File : StreamSource
Visual Basic
Public Class StreamSource_File _
    Inherits StreamSource
Visual C++
public ref class StreamSource_File : public StreamSource

Inheritance Hierarchy

System..::..Object
El..::..StreamSource
El..::..StreamSource_File

See Also

StreamSource_File Members


StreamSource_File Members

[image] [image]

One of William Foster's Class Libraries
StreamSource_File Members
StreamSource_File Class Constructors Methods Fields Properties See Also Send Feedback

The StreamSource_File type exposes the following members.

Constructors

 | Name | Description
Public method | StreamSource_File(StreamSource_File) | Initializes a new instance of the StreamSource_File class
Public method | StreamSource_File(Stream, Stream..::..EAccessMode) | Initializes a new instance of the StreamSource_File class
Public method | StreamSource_File(Filename, Stream..::..EAccessMode) | Initializes a new instance of the StreamSource_File class

Methods

 | Name | Description
Public method | Awaken |
Public method | Close | (Inherited from StreamSource.)
Public method | CloseIt | (Overrides StreamSource..::..CloseIt()()()().)
Public method | Detach | (Inherited from StreamSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | Flush | (Inherited from StreamSource.)
Public method | GetFilename |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStreamSource | (Inherited from StreamSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | (Inherited from StreamSource.)
Public method | OpenIt | (Overrides StreamSource..::..OpenIt()()()().)
Public method | Read | (Overrides StreamSource..::..Read(MemPtr, UInt32, UInt32%).)
Public method | Seek | (Overrides StreamSource..::..Seek(UInt64, UInt64, UInt64%).)
Public method | Sleep |
Public method | Tell | (Overrides StreamSource..::..Tell()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | (Overrides StreamSource..::..Write(MemPtr, UInt32, UInt32%).)

Fields

 | Name | Description
Protected field | m_bOpen | (Inherited from StreamSource.)
Protected field | m_streamSource | (Inherited from StreamSource.)
Public field | m_sysStream |

Properties

 | Name | Description
Public property | SysStream | (Overrides StreamSource..::..SysStream.)

See Also

StreamSource_File Class


StreamSource_File Constructor

[image] [image]

One of William Foster's Class Libraries
StreamSource_File Constructor
StreamSource_File Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StreamSource_File(StreamSource_File) | Initializes a new instance of the StreamSource_File class
Public method | StreamSource_File(Stream, Stream..::..EAccessMode) | Initializes a new instance of the StreamSource_File class
Public method | StreamSource_File(Filename, Stream..::..EAccessMode) | Initializes a new instance of the StreamSource_File class

See Also

StreamSource_File Class
StreamSource_File Members


StreamSource_File Constructor (StreamSource_File)

[image]

One of William Foster's Class Libraries
StreamSource_File Constructor (StreamSource_File)
StreamSource_File Class See Also Send Feedback
Initializes a new instance of the StreamSource_File class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public StreamSource_File(
    StreamSource_File duper
)
Visual Basic
Public Sub New ( _
    duper As StreamSource_File _
)
Visual C++
public:
StreamSource_File(
    StreamSource_File^ duper
)

Parameters

duper
Type: El..::..StreamSource_File

[Missing <param name="duper"/> documentation for "M:El.StreamSource_File.#ctor(El.StreamSource_File)"]

See Also

StreamSource_File Class
StreamSource_File Overload


StreamSource_File Constructor (Stream, Stream.EAccessMode)

[image]

One of William Foster's Class Libraries
StreamSource_File Constructor (Stream, Stream..::..EAccessMode)
StreamSource_File Class See Also Send Feedback
Initializes a new instance of the StreamSource_File class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public StreamSource_File(
    Stream netstream,
    Stream..::..EAccessMode mode
)
Visual Basic
Public Sub New ( _
    netstream As Stream, _
    mode As Stream..::..EAccessMode _
)
Visual C++
public:
StreamSource_File(
    Stream^ netstream,
    Stream..::..EAccessMode mode
)

Parameters

netstream
Type: System.IO..::..Stream

[Missing <param name="netstream"/> documentation for "M:El.StreamSource_File.#ctor(System.IO.Stream,El.Stream.EAccessMode)"]

mode
Type: El..::..Stream..::..EAccessMode

[Missing <param name="mode"/> documentation for "M:El.StreamSource_File.#ctor(System.IO.Stream,El.Stream.EAccessMode)"]

See Also

StreamSource_File Class
StreamSource_File Overload


StreamSource_File Constructor (Filename, Stream.EAccessMode)

[image]

One of William Foster's Class Libraries
StreamSource_File Constructor (Filename, Stream..::..EAccessMode)
StreamSource_File Class See Also Send Feedback
Initializes a new instance of the StreamSource_File class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public StreamSource_File(
    Filename filename,
    Stream..::..EAccessMode mode
)
Visual Basic
Public Sub New ( _
    filename As Filename, _
    mode As Stream..::..EAccessMode _
)
Visual C++
public:
StreamSource_File(
    Filename^ filename,
    Stream..::..EAccessMode mode
)

Parameters

filename
Type: El..::..Filename

[Missing <param name="filename"/> documentation for "M:El.StreamSource_File.#ctor(El.Filename,El.Stream.EAccessMode)"]

mode
Type: El..::..Stream..::..EAccessMode

[Missing <param name="mode"/> documentation for "M:El.StreamSource_File.#ctor(El.Filename,El.Stream.EAccessMode)"]

See Also

StreamSource_File Class
StreamSource_File Overload


StreamSource_File Fields

[image] [image]

One of William Foster's Class Libraries
StreamSource_File Fields
StreamSource_File Class See Also Send Feedback

The StreamSource_File type exposes the following members.

Fields

 | Name | Description
Protected field | m_bOpen | (Inherited from StreamSource.)
Protected field | m_streamSource | (Inherited from StreamSource.)
Public field | m_sysStream |

See Also

StreamSource_File Class


m_sysStream Field

[image]

One of William Foster's Class Libraries
StreamSource_File..::..m_sysStream Field
StreamSource_File Class See Also Send Feedback

[Missing <summary> documentation for "F:El.StreamSource_File.m_sysStream"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Stream m_sysStream
Visual Basic
Public m_sysStream As Stream
Visual C++
public:
Stream^ m_sysStream

See Also

StreamSource_File Class


StreamSource_File Methods

[image] [image]

One of William Foster's Class Libraries
StreamSource_File Methods
StreamSource_File Class See Also Send Feedback

The StreamSource_File type exposes the following members.

Methods

 | Name | Description
Public method | Awaken |
Public method | Close | (Inherited from StreamSource.)
Public method | CloseIt | (Overrides StreamSource..::..CloseIt()()()().)
Public method | Detach | (Inherited from StreamSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | Flush | (Inherited from StreamSource.)
Public method | GetFilename |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStreamSource | (Inherited from StreamSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | (Inherited from StreamSource.)
Public method | OpenIt | (Overrides StreamSource..::..OpenIt()()()().)
Public method | Read | (Overrides StreamSource..::..Read(MemPtr, UInt32, UInt32%).)
Public method | Seek | (Overrides StreamSource..::..Seek(UInt64, UInt64, UInt64%).)
Public method | Sleep |
Public method | Tell | (Overrides StreamSource..::..Tell()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | (Overrides StreamSource..::..Write(MemPtr, UInt32, UInt32%).)

See Also

StreamSource_File Class


Awaken Method

[image]

One of William Foster's Class Libraries
StreamSource_File..::..Awaken Method
StreamSource_File Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_File.Awaken"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool Awaken()
Visual Basic
Public Overridable Function Awaken As Boolean
Visual C++
public:
virtual bool Awaken()

Return Value

[Missing <returns> documentation for "M:El.StreamSource_File.Awaken"]

See Also

StreamSource_File Class


CloseIt Method

[image]

One of William Foster's Class Libraries
StreamSource_File..::..CloseIt Method
StreamSource_File Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_File.CloseIt"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override bool CloseIt()
Visual Basic
Public Overrides Function CloseIt As Boolean
Visual C++
public:
virtual bool CloseIt() override

Return Value

[Missing <returns> documentation for "M:El.StreamSource_File.CloseIt"]

See Also

StreamSource_File Class


Finalize Method

[image]

One of William Foster's Class Libraries
StreamSource_File..::..Finalize Method
StreamSource_File Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_File.Finalize"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

StreamSource_File Class


GetFilename Method

[image]

One of William Foster's Class Libraries
StreamSource_File..::..GetFilename Method
StreamSource_File Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_File.GetFilename(El.Filename@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void GetFilename(
    out Filename fn
)
Visual Basic
Public Sub GetFilename ( _
    <OutAttribute> ByRef fn As Filename _
)
Visual C++
public:
void GetFilename(
    [OutAttribute] Filename^% fn
)

Parameters

fn
Type: El..::..Filename %

[Missing <param name="fn"/> documentation for "M:El.StreamSource_File.GetFilename(El.Filename@)"]

See Also

StreamSource_File Class


OpenIt Method

[image]

One of William Foster's Class Libraries
StreamSource_File..::..OpenIt Method
StreamSource_File Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_File.OpenIt"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override bool OpenIt()
Visual Basic
Public Overrides Function OpenIt As Boolean
Visual C++
public:
virtual bool OpenIt() override

Return Value

[Missing <returns> documentation for "M:El.StreamSource_File.OpenIt"]

See Also

StreamSource_File Class


Read Method

[image]

One of William Foster's Class Libraries
StreamSource_File..::..Read Method
StreamSource_File Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_File.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override bool Read(
    MemPtr dstMem,
    uint uCount,
    out uint o_uBytesRead
)
Visual Basic
Public Overrides Function Read ( _
    dstMem As MemPtr, _
    uCount As UInteger, _
    <OutAttribute> ByRef o_uBytesRead As UInteger _
) As Boolean
Visual C++
public:
virtual bool Read(
    MemPtr^ dstMem,
    unsigned int uCount,
    [OutAttribute] unsigned int% o_uBytesRead
) override

Parameters

dstMem
Type: El..::..MemPtr

[Missing <param name="dstMem"/> documentation for "M:El.StreamSource_File.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

uCount
Type: System..::..UInt32

[Missing <param name="uCount"/> documentation for "M:El.StreamSource_File.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

o_uBytesRead
Type: System..::..UInt32 %

[Missing <param name="o_uBytesRead"/> documentation for "M:El.StreamSource_File.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

Return Value

[Missing <returns> documentation for "M:El.StreamSource_File.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

See Also

StreamSource_File Class


Seek Method

[image]

One of William Foster's Class Libraries
StreamSource_File..::..Seek Method
StreamSource_File Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_File.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override bool Seek(
    ulong n64Offset,
    ulong ulOrigin,
    out ulong pun64NewPosition
)
Visual Basic
Public Overrides Function Seek ( _
    n64Offset As ULong, _
    ulOrigin As ULong, _
    <OutAttribute> ByRef pun64NewPosition As ULong _
) As Boolean
Visual C++
public:
virtual bool Seek(
    unsigned long long n64Offset,
    unsigned long long ulOrigin,
    [OutAttribute] unsigned long long% pun64NewPosition
) override

Parameters

n64Offset
Type: System..::..UInt64

[Missing <param name="n64Offset"/> documentation for "M:El.StreamSource_File.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

ulOrigin
Type: System..::..UInt64

[Missing <param name="ulOrigin"/> documentation for "M:El.StreamSource_File.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

pun64NewPosition
Type: System..::..UInt64 %

[Missing <param name="pun64NewPosition"/> documentation for "M:El.StreamSource_File.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

Return Value

[Missing <returns> documentation for "M:El.StreamSource_File.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

See Also

StreamSource_File Class


Sleep Method

[image]

One of William Foster's Class Libraries
StreamSource_File..::..Sleep Method
StreamSource_File Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_File.Sleep"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool Sleep()
Visual Basic
Public Overridable Function Sleep As Boolean
Visual C++
public:
virtual bool Sleep()

Return Value

[Missing <returns> documentation for "M:El.StreamSource_File.Sleep"]

See Also

StreamSource_File Class


Tell Method

[image]

One of William Foster's Class Libraries
StreamSource_File..::..Tell Method
StreamSource_File Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_File.Tell"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override uint Tell()
Visual Basic
Public Overrides Function Tell As UInteger
Visual C++
public:
virtual unsigned int Tell() override

Return Value

[Missing <returns> documentation for "M:El.StreamSource_File.Tell"]

See Also

StreamSource_File Class


Write Method

[image]

One of William Foster's Class Libraries
StreamSource_File..::..Write Method
StreamSource_File Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_File.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override bool Write(
    MemPtr srcMem,
    uint uCount,
    out uint o_uBytesWritten
)
Visual Basic
Public Overrides Function Write ( _
    srcMem As MemPtr, _
    uCount As UInteger, _
    <OutAttribute> ByRef o_uBytesWritten As UInteger _
) As Boolean
Visual C++
public:
virtual bool Write(
    MemPtr^ srcMem,
    unsigned int uCount,
    [OutAttribute] unsigned int% o_uBytesWritten
) override

Parameters

srcMem
Type: El..::..MemPtr

[Missing <param name="srcMem"/> documentation for "M:El.StreamSource_File.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

uCount
Type: System..::..UInt32

[Missing <param name="uCount"/> documentation for "M:El.StreamSource_File.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

o_uBytesWritten
Type: System..::..UInt32 %

[Missing <param name="o_uBytesWritten"/> documentation for "M:El.StreamSource_File.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

Return Value

[Missing <returns> documentation for "M:El.StreamSource_File.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

See Also

StreamSource_File Class


StreamSource_File Properties

[image] [image]

One of William Foster's Class Libraries
StreamSource_File Properties
StreamSource_File Class See Also Send Feedback

The StreamSource_File type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Overrides StreamSource..::..SysStream.)

See Also

StreamSource_File Class


SysStream Property

[image]

One of William Foster's Class Libraries
StreamSource_File..::..SysStream Property
StreamSource_File Class See Also Send Feedback

[Missing <summary> documentation for "P:El.StreamSource_File.SysStream"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override Stream SysStream { get; }
Visual Basic
Public Overrides ReadOnly Property SysStream As Stream
    Get
Visual C++
public:
virtual property Stream^ SysStream {
    Stream^ get () override;
}

See Also

StreamSource_File Class


StreamSource_Memory Class

[image]

One of William Foster's Class Libraries
StreamSource_Memory Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.StreamSource_Memory"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class StreamSource_Memory : StreamSource
Visual Basic
Public Class StreamSource_Memory _
    Inherits StreamSource
Visual C++
public ref class StreamSource_Memory : public StreamSource

Inheritance Hierarchy

System..::..Object
El..::..StreamSource
El..::..StreamSource_Memory

See Also

StreamSource_Memory Members


StreamSource_Memory Members

[image] [image]

One of William Foster's Class Libraries
StreamSource_Memory Members
StreamSource_Memory Class Constructors Methods Fields Properties See Also Send Feedback

The StreamSource_Memory type exposes the following members.

Constructors

 | Name | Description
Public method | StreamSource_Memory(StreamSource_Memory) | Initializes a new instance of the StreamSource_Memory class
Public method | StreamSource_Memory(STRING) | Initializes a new instance of the StreamSource_Memory class
Public method | StreamSource_Memory(MemPtr, UInt64) | Initializes a new instance of the StreamSource_Memory class

Methods

 | Name | Description
Public method | Awaken | (Inherited from StreamSource.)
Public method | Close | (Inherited from StreamSource.)
Public method | CloseIt | (Inherited from StreamSource.)
Public method | Detach |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | Flush | (Inherited from StreamSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStreamSource | (Inherited from StreamSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | (Inherited from StreamSource.)
Public method | OpenIt | (Inherited from StreamSource.)
Public method | Read | (Overrides StreamSource..::..Read(MemPtr, UInt32, UInt32%).)
Public method | Seek | (Overrides StreamSource..::..Seek(UInt64, UInt64, UInt64%).)
Public method | Sleep | (Inherited from StreamSource.)
Public method | Tell | (Overrides StreamSource..::..Tell()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | (Overrides StreamSource..::..Write(MemPtr, UInt32, UInt32%).)

Fields

 | Name | Description
Protected field | m_bOpen | (Inherited from StreamSource.)
Protected field | m_streamSource | (Inherited from StreamSource.)

Properties

 | Name | Description
Public property | SysStream | (Overrides StreamSource..::..SysStream.)

See Also

StreamSource_Memory Class


StreamSource_Memory Constructor

[image] [image]

One of William Foster's Class Libraries
StreamSource_Memory Constructor
StreamSource_Memory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StreamSource_Memory(StreamSource_Memory) | Initializes a new instance of the StreamSource_Memory class
Public method | StreamSource_Memory(STRING) | Initializes a new instance of the StreamSource_Memory class
Public method | StreamSource_Memory(MemPtr, UInt64) | Initializes a new instance of the StreamSource_Memory class

See Also

StreamSource_Memory Class
StreamSource_Memory Members


StreamSource_Memory Constructor (StreamSource_Memory)

[image]

One of William Foster's Class Libraries
StreamSource_Memory Constructor (StreamSource_Memory)
StreamSource_Memory Class See Also Send Feedback
Initializes a new instance of the StreamSource_Memory class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public StreamSource_Memory(
    StreamSource_Memory duper
)
Visual Basic
Public Sub New ( _
    duper As StreamSource_Memory _
)
Visual C++
public:
StreamSource_Memory(
    StreamSource_Memory^ duper
)

Parameters

duper
Type: El..::..StreamSource_Memory

[Missing <param name="duper"/> documentation for "M:El.StreamSource_Memory.#ctor(El.StreamSource_Memory)"]

See Also

StreamSource_Memory Class
StreamSource_Memory Overload


StreamSource_Memory Constructor (STRING)

[image]

One of William Foster's Class Libraries
StreamSource_Memory Constructor (STRING)
StreamSource_Memory Class See Also Send Feedback
Initializes a new instance of the StreamSource_Memory class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public StreamSource_Memory(
    STRING s
)
Visual Basic
Public Sub New ( _
    s As STRING _
)
Visual C++
public:
StreamSource_Memory(
    STRING^ s
)

Parameters

s
Type: El..::..STRING

[Missing <param name="s"/> documentation for "M:El.StreamSource_Memory.#ctor(El.STRING)"]

See Also

StreamSource_Memory Class
StreamSource_Memory Overload


StreamSource_Memory Constructor (MemPtr, UInt64)

[image]

One of William Foster's Class Libraries
StreamSource_Memory Constructor (MemPtr, UInt64)
StreamSource_Memory Class See Also Send Feedback
Initializes a new instance of the StreamSource_Memory class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public StreamSource_Memory(
    MemPtr p_memory,
    ulong ul_memoryByteLength
)
Visual Basic
Public Sub New ( _
    p_memory As MemPtr, _
    ul_memoryByteLength As ULong _
)
Visual C++
public:
StreamSource_Memory(
    MemPtr^ p_memory,
    unsigned long long ul_memoryByteLength
)

Parameters

p_memory
Type: El..::..MemPtr

[Missing <param name="p_memory"/> documentation for "M:El.StreamSource_Memory.#ctor(El.MemPtr,System.UInt64)"]

ul_memoryByteLength
Type: System..::..UInt64

[Missing <param name="ul_memoryByteLength"/> documentation for "M:El.StreamSource_Memory.#ctor(El.MemPtr,System.UInt64)"]

See Also

StreamSource_Memory Class
StreamSource_Memory Overload


StreamSource_Memory Fields

[image] [image]

One of William Foster's Class Libraries
StreamSource_Memory Fields
StreamSource_Memory Class See Also Send Feedback

The StreamSource_Memory type exposes the following members.

Fields

 | Name | Description
Protected field | m_bOpen | (Inherited from StreamSource.)
Protected field | m_streamSource | (Inherited from StreamSource.)

See Also

StreamSource_Memory Class


StreamSource_Memory Methods

[image] [image]

One of William Foster's Class Libraries
StreamSource_Memory Methods
StreamSource_Memory Class See Also Send Feedback

The StreamSource_Memory type exposes the following members.

Methods

 | Name | Description
Public method | Awaken | (Inherited from StreamSource.)
Public method | Close | (Inherited from StreamSource.)
Public method | CloseIt | (Inherited from StreamSource.)
Public method | Detach |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | Flush | (Inherited from StreamSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStreamSource | (Inherited from StreamSource.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | (Inherited from StreamSource.)
Public method | OpenIt | (Inherited from StreamSource.)
Public method | Read | (Overrides StreamSource..::..Read(MemPtr, UInt32, UInt32%).)
Public method | Seek | (Overrides StreamSource..::..Seek(UInt64, UInt64, UInt64%).)
Public method | Sleep | (Inherited from StreamSource.)
Public method | Tell | (Overrides StreamSource..::..Tell()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | (Overrides StreamSource..::..Write(MemPtr, UInt32, UInt32%).)

See Also

StreamSource_Memory Class


Detach Method

[image]

One of William Foster's Class Libraries
StreamSource_Memory..::..Detach Method
StreamSource_Memory Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_Memory.Detach"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool Detach()
Visual Basic
Public Overridable Function Detach As Boolean
Visual C++
public:
virtual bool Detach()

Return Value

[Missing <returns> documentation for "M:El.StreamSource_Memory.Detach"]

See Also

StreamSource_Memory Class


Finalize Method

[image]

One of William Foster's Class Libraries
StreamSource_Memory..::..Finalize Method
StreamSource_Memory Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_Memory.Finalize"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

StreamSource_Memory Class


Read Method

[image]

One of William Foster's Class Libraries
StreamSource_Memory..::..Read Method
StreamSource_Memory Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_Memory.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override bool Read(
    MemPtr dstMem,
    uint uCount,
    out uint o_uBytesRead
)
Visual Basic
Public Overrides Function Read ( _
    dstMem As MemPtr, _
    uCount As UInteger, _
    <OutAttribute> ByRef o_uBytesRead As UInteger _
) As Boolean
Visual C++
public:
virtual bool Read(
    MemPtr^ dstMem,
    unsigned int uCount,
    [OutAttribute] unsigned int% o_uBytesRead
) override

Parameters

dstMem
Type: El..::..MemPtr

[Missing <param name="dstMem"/> documentation for "M:El.StreamSource_Memory.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

uCount
Type: System..::..UInt32

[Missing <param name="uCount"/> documentation for "M:El.StreamSource_Memory.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

o_uBytesRead
Type: System..::..UInt32 %

[Missing <param name="o_uBytesRead"/> documentation for "M:El.StreamSource_Memory.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

Return Value

[Missing <returns> documentation for "M:El.StreamSource_Memory.Read(El.MemPtr,System.UInt32,System.UInt32@)"]

See Also

StreamSource_Memory Class


Seek Method

[image]

One of William Foster's Class Libraries
StreamSource_Memory..::..Seek Method
StreamSource_Memory Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_Memory.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override bool Seek(
    ulong n64Offset,
    ulong ulOrigin,
    out ulong pun64NewPosition
)
Visual Basic
Public Overrides Function Seek ( _
    n64Offset As ULong, _
    ulOrigin As ULong, _
    <OutAttribute> ByRef pun64NewPosition As ULong _
) As Boolean
Visual C++
public:
virtual bool Seek(
    unsigned long long n64Offset,
    unsigned long long ulOrigin,
    [OutAttribute] unsigned long long% pun64NewPosition
) override

Parameters

n64Offset
Type: System..::..UInt64

[Missing <param name="n64Offset"/> documentation for "M:El.StreamSource_Memory.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

ulOrigin
Type: System..::..UInt64

[Missing <param name="ulOrigin"/> documentation for "M:El.StreamSource_Memory.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

pun64NewPosition
Type: System..::..UInt64 %

[Missing <param name="pun64NewPosition"/> documentation for "M:El.StreamSource_Memory.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

Return Value

[Missing <returns> documentation for "M:El.StreamSource_Memory.Seek(System.UInt64,System.UInt64,System.UInt64@)"]

See Also

StreamSource_Memory Class


Tell Method

[image]

One of William Foster's Class Libraries
StreamSource_Memory..::..Tell Method
StreamSource_Memory Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_Memory.Tell"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override uint Tell()
Visual Basic
Public Overrides Function Tell As UInteger
Visual C++
public:
virtual unsigned int Tell() override

Return Value

[Missing <returns> documentation for "M:El.StreamSource_Memory.Tell"]

See Also

StreamSource_Memory Class


Write Method

[image]

One of William Foster's Class Libraries
StreamSource_Memory..::..Write Method
StreamSource_Memory Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StreamSource_Memory.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override bool Write(
    MemPtr srcMem,
    uint uCount,
    out uint o_uBytesWritten
)
Visual Basic
Public Overrides Function Write ( _
    srcMem As MemPtr, _
    uCount As UInteger, _
    <OutAttribute> ByRef o_uBytesWritten As UInteger _
) As Boolean
Visual C++
public:
virtual bool Write(
    MemPtr^ srcMem,
    unsigned int uCount,
    [OutAttribute] unsigned int% o_uBytesWritten
) override

Parameters

srcMem
Type: El..::..MemPtr

[Missing <param name="srcMem"/> documentation for "M:El.StreamSource_Memory.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

uCount
Type: System..::..UInt32

[Missing <param name="uCount"/> documentation for "M:El.StreamSource_Memory.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

o_uBytesWritten
Type: System..::..UInt32 %

[Missing <param name="o_uBytesWritten"/> documentation for "M:El.StreamSource_Memory.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

Return Value

[Missing <returns> documentation for "M:El.StreamSource_Memory.Write(El.MemPtr,System.UInt32,System.UInt32@)"]

See Also

StreamSource_Memory Class


StreamSource_Memory Properties

[image] [image]

One of William Foster's Class Libraries
StreamSource_Memory Properties
StreamSource_Memory Class See Also Send Feedback

The StreamSource_Memory type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Overrides StreamSource..::..SysStream.)

See Also

StreamSource_Memory Class


SysStream Property

[image]

One of William Foster's Class Libraries
StreamSource_Memory..::..SysStream Property
StreamSource_Memory Class See Also Send Feedback

[Missing <summary> documentation for "P:El.StreamSource_Memory.SysStream"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public override Stream SysStream { get; }
Visual Basic
Public Overrides ReadOnly Property SysStream As Stream
    Get
Visual C++
public:
virtual property Stream^ SysStream {
    Stream^ get () override;
}

See Also

StreamSource_Memory Class


StreamThreadInfo Class

[image]

One of William Foster's Class Libraries
StreamThreadInfo Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.StreamThreadInfo"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class StreamThreadInfo
Visual Basic
Public Class StreamThreadInfo
Visual C++
public ref class StreamThreadInfo

Inheritance Hierarchy

System..::..Object
El..::..StreamThreadInfo

See Also

StreamThreadInfo Members


StreamThreadInfo Members

[image] [image]

One of William Foster's Class Libraries
StreamThreadInfo Members
StreamThreadInfo Class Constructors Methods Fields See Also Send Feedback

The StreamThreadInfo type exposes the following members.

Constructors

 | Name | Description
Public method | StreamThreadInfo | Initializes a new instance of the StreamThreadInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_b_threaded |

See Also

StreamThreadInfo Class


StreamThreadInfo Constructor

[image]

One of William Foster's Class Libraries
StreamThreadInfo Constructor
StreamThreadInfo Class See Also Send Feedback
Initializes a new instance of the StreamThreadInfo class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public StreamThreadInfo()
Visual Basic
Public Sub New
Visual C++
public:
StreamThreadInfo()

See Also

StreamThreadInfo Class


StreamThreadInfo Fields

[image] [image]

One of William Foster's Class Libraries
StreamThreadInfo Fields
StreamThreadInfo Class See Also Send Feedback

The StreamThreadInfo type exposes the following members.

Fields

 | Name | Description
Public field | m_b_threaded |

See Also

StreamThreadInfo Class


m_b_threaded Field

[image]

One of William Foster's Class Libraries
StreamThreadInfo..::..m_b_threaded Field
StreamThreadInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:El.StreamThreadInfo.m_b_threaded"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool m_b_threaded
Visual Basic
Public m_b_threaded As Boolean
Visual C++
public:
bool m_b_threaded

See Also

StreamThreadInfo Class


StreamThreadInfo Methods

[image] [image]

One of William Foster's Class Libraries
StreamThreadInfo Methods
StreamThreadInfo Class See Also Send Feedback

The StreamThreadInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StreamThreadInfo Class


STRING Class

[image]

One of William Foster's Class Libraries
STRING Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.STRING"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class STRING : IEnumerable
Visual Basic
Public Class STRING _
    Implements IEnumerable
Visual C++
public ref class STRING : IEnumerable

Inheritance Hierarchy

System..::..Object
El..::..STRING
El..::..Filename
El..::..StringBuffer
El..::..STRINGEX

See Also

STRING Members


STRING Members

[image] [image]

One of William Foster's Class Libraries
STRING Members
STRING Class Constructors Methods Operators Fields Properties See Also Send Feedback

The STRING type exposes the following members.

Constructors

 | Name | Description
Public method | STRING()()()() | Initializes a new instance of the STRING class
Public method | STRING(String) | Initializes a new instance of the STRING class
Public method | STRING(STRING) | Initializes a new instance of the STRING class

Methods

 | Name | Description
Public method | Append(Char) |
Public method | Append(String) |
Public method | Compare(STRING) |
Public method | Compare(array<Char>[]()[][], UInt32) |
Public method | Compare(STRING, Boolean) |
Public method | CompareNoCase(STRING) |
Public method | CompareNoCase(array<Char>[]()[][], UInt32) |
Public method | Empty |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) |
Public method | Find(Char, UInt32) |
Public method | Find(STRING, UInt32) |
Public method | Find(Char, UInt32, Boolean) |
Public method | Find(STRING, UInt32, Boolean, Boolean) |
Public method | FindOneOf |
Public method | FormatV |
Public method | GetAsString |
Public method | GetAt |
Public method | GetBytePtr |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength |
Public method | GetLengthBytes |
Public method | GetPtr |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAt |
Public method | IsEmpty |
Public method | Left |
Public method | LeftEquals |
Public method | LeftFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid |
Public method | ParseLines |
Public method | RemoveAt |
Public method | RemoveQuotes |
Public method | RemoveWhitespace |
Public method | Replace(STRING, STRING) |
Public method | Replace(UInt32, STRING, STRING) |
Public method | Replace(UInt32, UInt32, STRING) |
Public method | ReverseFind |
Public method | Right()()()() |
Public method | Right(UInt32) |
Public method | RightFrom |
Public method | Set(array<Byte>[]()[][]) |
Public method | Set(String) |
Public method | SetAt |
Public method | SetLength |
Public method | SpanExcluding |
Public method | Substitute |
Public method | Terminate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase |
Public method | Trim()()()() |
Public method | Trim(UInt32, UInt32) |
Public method | TrimLeft()()()() |
Public method | TrimLeft(UInt32) |
Public method | TrimLeft(STRING) |
Public method | TrimRight()()()() |
Public method | TrimRight(UInt32) |
 | WildcardMatch |

Operators

Name | Description
Equality(STRING, STRING) |
Equality(STRING, String) |
ImplicitWideningImplicitImplicitImplicit(String to STRING) |
ImplicitWideningImplicitImplicitImplicit(STRING to String) |
Inequality(STRING, STRING) |
Inequality(STRING, String) |

Extension Methods

 | Name | Description
Public Extension Method | LeftWord | (Defined by StringExtension.)

Fields

 | Name | Description
Protected field | m_cs |

Properties

 | Name | Description
Public property | Item[([( Int32])]) |
Public property | Item[([( UInt32])]) |
Public property | Length |

See Also

STRING Class


STRING Constructor

[image] [image]

One of William Foster's Class Libraries
STRING Constructor
STRING Class See Also Send Feedback

Overload List

 | Name | Description
Public method | STRING()()()() | Initializes a new instance of the STRING class
Public method | STRING(String) | Initializes a new instance of the STRING class
Public method | STRING(STRING) | Initializes a new instance of the STRING class

See Also

STRING Class
STRING Members


STRING Constructor

[image]

One of William Foster's Class Libraries
STRING Constructor
STRING Class See Also Send Feedback
Initializes a new instance of the STRING class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public STRING()
Visual Basic
Public Sub New
Visual C++
public:
STRING()

See Also

STRING Class
STRING Overload


STRING Constructor (String)

[image]

One of William Foster's Class Libraries
STRING Constructor (String)
STRING Class See Also Send Feedback
Initializes a new instance of the STRING class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public STRING(
    string src
)
Visual Basic
Public Sub New ( _
    src As String _
)
Visual C++
public:
STRING(
    String^ src
)

Parameters

src
Type: System..::..String

[Missing <param name="src"/> documentation for "M:El.STRING.#ctor(System.String)"]

See Also

STRING Class
STRING Overload


STRING Constructor (STRING)

[image]

One of William Foster's Class Libraries
STRING Constructor (STRING)
STRING Class See Also Send Feedback
Initializes a new instance of the STRING class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public STRING(
    STRING srcString
)
Visual Basic
Public Sub New ( _
    srcString As STRING _
)
Visual C++
public:
STRING(
    STRING^ srcString
)

Parameters

srcString
Type: El..::..STRING

[Missing <param name="srcString"/> documentation for "M:El.STRING.#ctor(El.STRING)"]

See Also

STRING Class
STRING Overload


STRING Fields

[image] [image]

One of William Foster's Class Libraries
STRING Fields
STRING Class See Also Send Feedback

The STRING type exposes the following members.

Fields

 | Name | Description
Protected field | m_cs |

See Also

STRING Class


m_cs Field

[image]

One of William Foster's Class Libraries
STRING..::..m_cs Field
STRING Class See Also Send Feedback

[Missing <summary> documentation for "F:El.STRING.m_cs"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
protected string m_cs
Visual Basic
Protected m_cs As String
Visual C++
protected:
String^ m_cs

See Also

STRING Class


STRING Methods

[image] [image]

One of William Foster's Class Libraries
STRING Methods
STRING Class See Also Send Feedback

The STRING type exposes the following members.

Methods

 | Name | Description
Public method | Append(Char) |
Public method | Append(String) |
Public method | Compare(STRING) |
Public method | Compare(array<Char>[]()[][], UInt32) |
Public method | Compare(STRING, Boolean) |
Public method | CompareNoCase(STRING) |
Public method | CompareNoCase(array<Char>[]()[][], UInt32) |
Public method | Empty |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) |
Public method | Find(Char, UInt32) |
Public method | Find(STRING, UInt32) |
Public method | Find(Char, UInt32, Boolean) |
Public method | Find(STRING, UInt32, Boolean, Boolean) |
Public method | FindOneOf |
Public method | FormatV |
Public method | GetAsString |
Public method | GetAt |
Public method | GetBytePtr |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength |
Public method | GetLengthBytes |
Public method | GetPtr |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAt |
Public method | IsEmpty |
Public method | Left |
Public method | LeftEquals |
Public method | LeftFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid |
Public method | ParseLines |
Public method | RemoveAt |
Public method | RemoveQuotes |
Public method | RemoveWhitespace |
Public method | Replace(STRING, STRING) |
Public method | Replace(UInt32, STRING, STRING) |
Public method | Replace(UInt32, UInt32, STRING) |
Public method | ReverseFind |
Public method | Right()()()() |
Public method | Right(UInt32) |
Public method | RightFrom |
Public method | Set(array<Byte>[]()[][]) |
Public method | Set(String) |
Public method | SetAt |
Public method | SetLength |
Public method | SpanExcluding |
Public method | Substitute |
Public method | Terminate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase |
Public method | Trim()()()() |
Public method | Trim(UInt32, UInt32) |
Public method | TrimLeft()()()() |
Public method | TrimLeft(UInt32) |
Public method | TrimLeft(STRING) |
Public method | TrimRight()()()() |
Public method | TrimRight(UInt32) |
 | WildcardMatch |

Extension Methods

 | Name | Description
Public Extension Method | LeftWord | (Defined by StringExtension.)

See Also

STRING Class


Append Method

[image] [image]

One of William Foster's Class Libraries
STRING..::..Append Method
STRING Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Append(Char) |
Public method | Append(String) |

See Also

STRING Class
STRING Members


Append Method (Char)

[image]

One of William Foster's Class Libraries
STRING..::..Append Method (Char)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Append(System.Char)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Append(
    char c
)
Visual Basic
Public Sub Append ( _
    c As Char _
)
Visual C++
public:
void Append(
    wchar_t c
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:El.STRING.Append(System.Char)"]

See Also

STRING Class
Append Overload


Append Method (String)

[image]

One of William Foster's Class Libraries
STRING..::..Append Method (String)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Append(System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Append(
    string s
)
Visual Basic
Public Sub Append ( _
    s As String _
)
Visual C++
public:
void Append(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:El.STRING.Append(System.String)"]

See Also

STRING Class
Append Overload


Compare Method

[image] [image]

One of William Foster's Class Libraries
STRING..::..Compare Method
STRING Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Compare(STRING) |
Public method | Compare(array<Char>[]()[][], UInt32) |
Public method | Compare(STRING, Boolean) |

See Also

STRING Class
STRING Members


Compare Method (STRING)

[image]

One of William Foster's Class Libraries
STRING..::..Compare Method (STRING)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Compare(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int Compare(
    STRING csCompare
)
Visual Basic
Public Function Compare ( _
    csCompare As STRING _
) As Integer
Visual C++
public:
int Compare(
    STRING^ csCompare
)

Parameters

csCompare
Type: El..::..STRING

[Missing <param name="csCompare"/> documentation for "M:El.STRING.Compare(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.Compare(El.STRING)"]

See Also

STRING Class
Compare Overload


Compare Method (Char[], UInt32)

[image]

One of William Foster's Class Libraries
STRING..::..Compare Method (array<Char>[]()[][], UInt32)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Compare(System.Char[],System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int Compare(
    char[] lpsz_compare,
    uint u_MaxLen
)
Visual Basic
Public Function Compare ( _
    lpsz_compare As Char(), _
    u_MaxLen As UInteger _
) As Integer
Visual C++
public:
int Compare(
    array<wchar_t>^ lpsz_compare,
    unsigned int u_MaxLen
)

Parameters

lpsz_compare
Type: array< System..::..Char >[]()[][]

[Missing <param name="lpsz_compare"/> documentation for "M:El.STRING.Compare(System.Char[],System.UInt32)"]

u_MaxLen
Type: System..::..UInt32

[Missing <param name="u_MaxLen"/> documentation for "M:El.STRING.Compare(System.Char[],System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.Compare(System.Char[],System.UInt32)"]

See Also

STRING Class
Compare Overload


Compare Method (STRING, Boolean)

[image]

One of William Foster's Class Libraries
STRING..::..Compare Method (STRING, Boolean)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Compare(El.STRING,System.Boolean)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int Compare(
    STRING csCompare,
    bool b_CaseSensitive
)
Visual Basic
Public Function Compare ( _
    csCompare As STRING, _
    b_CaseSensitive As Boolean _
) As Integer
Visual C++
public:
int Compare(
    STRING^ csCompare,
    bool b_CaseSensitive
)

Parameters

csCompare
Type: El..::..STRING

[Missing <param name="csCompare"/> documentation for "M:El.STRING.Compare(El.STRING,System.Boolean)"]

b_CaseSensitive
Type: System..::..Boolean

[Missing <param name="b_CaseSensitive"/> documentation for "M:El.STRING.Compare(El.STRING,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.Compare(El.STRING,System.Boolean)"]

See Also

STRING Class
Compare Overload


CompareNoCase Method

[image] [image]

One of William Foster's Class Libraries
STRING..::..CompareNoCase Method
STRING Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareNoCase(STRING) |
Public method | CompareNoCase(array<Char>[]()[][], UInt32) |

See Also

STRING Class
STRING Members


CompareNoCase Method (STRING)

[image]

One of William Foster's Class Libraries
STRING..::..CompareNoCase Method (STRING)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.CompareNoCase(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int CompareNoCase(
    STRING csCompare
)
Visual Basic
Public Function CompareNoCase ( _
    csCompare As STRING _
) As Integer
Visual C++
public:
int CompareNoCase(
    STRING^ csCompare
)

Parameters

csCompare
Type: El..::..STRING

[Missing <param name="csCompare"/> documentation for "M:El.STRING.CompareNoCase(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.CompareNoCase(El.STRING)"]

See Also

STRING Class
CompareNoCase Overload


CompareNoCase Method (Char[], UInt32)

[image]

One of William Foster's Class Libraries
STRING..::..CompareNoCase Method (array<Char>[]()[][], UInt32)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.CompareNoCase(System.Char[],System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int CompareNoCase(
    char[] lpsz_compare,
    uint u_MaxLen
)
Visual Basic
Public Function CompareNoCase ( _
    lpsz_compare As Char(), _
    u_MaxLen As UInteger _
) As Integer
Visual C++
public:
int CompareNoCase(
    array<wchar_t>^ lpsz_compare,
    unsigned int u_MaxLen
)

Parameters

lpsz_compare
Type: array< System..::..Char >[]()[][]

[Missing <param name="lpsz_compare"/> documentation for "M:El.STRING.CompareNoCase(System.Char[],System.UInt32)"]

u_MaxLen
Type: System..::..UInt32

[Missing <param name="u_MaxLen"/> documentation for "M:El.STRING.CompareNoCase(System.Char[],System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.CompareNoCase(System.Char[],System.UInt32)"]

See Also

STRING Class
CompareNoCase Overload


Empty Method

[image]

One of William Foster's Class Libraries
STRING..::..Empty Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Empty"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual void Empty()
Visual Basic
Public Overridable Sub Empty
Visual C++
public:
virtual void Empty()

See Also

STRING Class


Find Method

[image] [image]

One of William Foster's Class Libraries
STRING..::..Find Method
STRING Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Find(Char) |
Public method | Find(Char, UInt32) |
Public method | Find(STRING, UInt32) |
Public method | Find(Char, UInt32, Boolean) |
Public method | Find(STRING, UInt32, Boolean, Boolean) |

See Also

STRING Class
STRING Members


Find Method (Char)

[image]

One of William Foster's Class Libraries
STRING..::..Find Method (Char)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Find(System.Char)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int Find(
    char c
)
Visual Basic
Public Function Find ( _
    c As Char _
) As Integer
Visual C++
public:
int Find(
    wchar_t c
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:El.STRING.Find(System.Char)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.Find(System.Char)"]

See Also

STRING Class
Find Overload


Find Method (Char, UInt32)

[image]

One of William Foster's Class Libraries
STRING..::..Find Method (Char, UInt32)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Find(System.Char,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int Find(
    char c,
    uint u_Start
)
Visual Basic
Public Function Find ( _
    c As Char, _
    u_Start As UInteger _
) As Integer
Visual C++
public:
int Find(
    wchar_t c,
    unsigned int u_Start
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:El.STRING.Find(System.Char,System.UInt32)"]

u_Start
Type: System..::..UInt32

[Missing <param name="u_Start"/> documentation for "M:El.STRING.Find(System.Char,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.Find(System.Char,System.UInt32)"]

See Also

STRING Class
Find Overload


Find Method (STRING, UInt32)

[image]

One of William Foster's Class Libraries
STRING..::..Find Method (STRING, UInt32)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Find(El.STRING,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int Find(
    STRING s,
    uint u_Start
)
Visual Basic
Public Function Find ( _
    s As STRING, _
    u_Start As UInteger _
) As Integer
Visual C++
public:
int Find(
    STRING^ s,
    unsigned int u_Start
)

Parameters

s
Type: El..::..STRING

[Missing <param name="s"/> documentation for "M:El.STRING.Find(El.STRING,System.UInt32)"]

u_Start
Type: System..::..UInt32

[Missing <param name="u_Start"/> documentation for "M:El.STRING.Find(El.STRING,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.Find(El.STRING,System.UInt32)"]

See Also

STRING Class
Find Overload


Find Method (Char, UInt32, Boolean)

[image]

One of William Foster's Class Libraries
STRING..::..Find Method (Char, UInt32, Boolean)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Find(System.Char,System.UInt32,System.Boolean)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int Find(
    char c,
    uint u_Start,
    bool b_Reverse
)
Visual Basic
Public Function Find ( _
    c As Char, _
    u_Start As UInteger, _
    b_Reverse As Boolean _
) As Integer
Visual C++
public:
int Find(
    wchar_t c,
    unsigned int u_Start,
    bool b_Reverse
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:El.STRING.Find(System.Char,System.UInt32,System.Boolean)"]

u_Start
Type: System..::..UInt32

[Missing <param name="u_Start"/> documentation for "M:El.STRING.Find(System.Char,System.UInt32,System.Boolean)"]

b_Reverse
Type: System..::..Boolean

[Missing <param name="b_Reverse"/> documentation for "M:El.STRING.Find(System.Char,System.UInt32,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.Find(System.Char,System.UInt32,System.Boolean)"]

See Also

STRING Class
Find Overload


Find Method (STRING, UInt32, Boolean, Boolean)

[image]

One of William Foster's Class Libraries
STRING..::..Find Method (STRING, UInt32, Boolean, Boolean)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Find(El.STRING,System.UInt32,System.Boolean,System.Boolean)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int Find(
    STRING s,
    uint u_Start,
    bool bWhole,
    bool bCase
)
Visual Basic
Public Function Find ( _
    s As STRING, _
    u_Start As UInteger, _
    bWhole As Boolean, _
    bCase As Boolean _
) As Integer
Visual C++
public:
int Find(
    STRING^ s,
    unsigned int u_Start,
    bool bWhole,
    bool bCase
)

Parameters

s
Type: El..::..STRING

[Missing <param name="s"/> documentation for "M:El.STRING.Find(El.STRING,System.UInt32,System.Boolean,System.Boolean)"]

u_Start
Type: System..::..UInt32

[Missing <param name="u_Start"/> documentation for "M:El.STRING.Find(El.STRING,System.UInt32,System.Boolean,System.Boolean)"]

bWhole
Type: System..::..Boolean

[Missing <param name="bWhole"/> documentation for "M:El.STRING.Find(El.STRING,System.UInt32,System.Boolean,System.Boolean)"]

bCase
Type: System..::..Boolean

[Missing <param name="bCase"/> documentation for "M:El.STRING.Find(El.STRING,System.UInt32,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.Find(El.STRING,System.UInt32,System.Boolean,System.Boolean)"]

See Also

STRING Class
Find Overload


FindOneOf Method

[image]

One of William Foster's Class Libraries
STRING..::..FindOneOf Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.FindOneOf(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int FindOneOf(
    STRING csItems
)
Visual Basic
Public Function FindOneOf ( _
    csItems As STRING _
) As Integer
Visual C++
public:
int FindOneOf(
    STRING^ csItems
)

Parameters

csItems
Type: El..::..STRING

[Missing <param name="csItems"/> documentation for "M:El.STRING.FindOneOf(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.FindOneOf(El.STRING)"]

See Also

STRING Class


FormatV Method

[image]

One of William Foster's Class Libraries
STRING..::..FormatV Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.FormatV(System.String,System.Object[])"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void FormatV(
    string csFormat,
    params Object[] argList
)
Visual Basic
Public Sub FormatV ( _
    csFormat As String, _
    ParamArray argList As Object() _
)
Visual C++
public:
void FormatV(
    String^ csFormat,
    ... array<Object^>^ argList
)

Parameters

csFormat
Type: System..::..String

[Missing <param name="csFormat"/> documentation for "M:El.STRING.FormatV(System.String,System.Object[])"]

argList
Type: array< System..::..Object >[]()[][]

[Missing <param name="argList"/> documentation for "M:El.STRING.FormatV(System.String,System.Object[])"]

See Also

STRING Class


GetAsString Method

[image]

One of William Foster's Class Libraries
STRING..::..GetAsString Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.GetAsString"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public string GetAsString()
Visual Basic
Public Function GetAsString As String
Visual C++
public:
String^ GetAsString()

Return Value

[Missing <returns> documentation for "M:El.STRING.GetAsString"]

See Also

STRING Class


GetAt Method

[image]

One of William Foster's Class Libraries
STRING..::..GetAt Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.GetAt(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public char GetAt(
    uint uIndex
)
Visual Basic
Public Function GetAt ( _
    uIndex As UInteger _
) As Char
Visual C++
public:
wchar_t GetAt(
    unsigned int uIndex
)

Parameters

uIndex
Type: System..::..UInt32

[Missing <param name="uIndex"/> documentation for "M:El.STRING.GetAt(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.GetAt(System.UInt32)"]

See Also

STRING Class


GetBytePtr Method

[image]

One of William Foster's Class Libraries
STRING..::..GetBytePtr Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.GetBytePtr"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public byte[] GetBytePtr()
Visual Basic
Public Function GetBytePtr As Byte()
Visual C++
public:
array<unsigned char>^ GetBytePtr()

Return Value

[Missing <returns> documentation for "M:El.STRING.GetBytePtr"]

See Also

STRING Class


GetEnumerator Method

[image]

One of William Foster's Class Libraries
STRING..::..GetEnumerator Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.GetEnumerator"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

[Missing <returns> documentation for "M:El.STRING.GetEnumerator"]

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

STRING Class


GetLength Method

[image]

One of William Foster's Class Libraries
STRING..::..GetLength Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.GetLength"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint GetLength()
Visual Basic
Public Function GetLength As UInteger
Visual C++
public:
unsigned int GetLength()

Return Value

[Missing <returns> documentation for "M:El.STRING.GetLength"]

See Also

STRING Class


GetLengthBytes Method

[image]

One of William Foster's Class Libraries
STRING..::..GetLengthBytes Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.GetLengthBytes"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint GetLengthBytes()
Visual Basic
Public Function GetLengthBytes As UInteger
Visual C++
public:
unsigned int GetLengthBytes()

Return Value

[Missing <returns> documentation for "M:El.STRING.GetLengthBytes"]

See Also

STRING Class


GetPtr Method

[image]

One of William Foster's Class Libraries
STRING..::..GetPtr Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.GetPtr"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public char[] GetPtr()
Visual Basic
Public Function GetPtr As Char()
Visual C++
public:
array<wchar_t>^ GetPtr()

Return Value

[Missing <returns> documentation for "M:El.STRING.GetPtr"]

See Also

STRING Class


InsertAt Method

[image]

One of William Foster's Class Libraries
STRING..::..InsertAt Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.InsertAt(El.STRING,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void InsertAt(
    STRING insertString,
    uint offset
)
Visual Basic
Public Sub InsertAt ( _
    insertString As STRING, _
    offset As UInteger _
)
Visual C++
public:
void InsertAt(
    STRING^ insertString,
    unsigned int offset
)

Parameters

insertString
Type: El..::..STRING

[Missing <param name="insertString"/> documentation for "M:El.STRING.InsertAt(El.STRING,System.UInt32)"]

offset
Type: System..::..UInt32

[Missing <param name="offset"/> documentation for "M:El.STRING.InsertAt(El.STRING,System.UInt32)"]

See Also

STRING Class


IsEmpty Method

[image]

One of William Foster's Class Libraries
STRING..::..IsEmpty Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.IsEmpty"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool IsEmpty()
Visual Basic
Public Function IsEmpty As Boolean
Visual C++
public:
bool IsEmpty()

Return Value

[Missing <returns> documentation for "M:El.STRING.IsEmpty"]

See Also

STRING Class


Left Method

[image]

One of William Foster's Class Libraries
STRING..::..Left Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Left(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public STRING Left(
    uint uCount
)
Visual Basic
Public Function Left ( _
    uCount As UInteger _
) As STRING
Visual C++
public:
STRING^ Left(
    unsigned int uCount
)

Parameters

uCount
Type: System..::..UInt32

[Missing <param name="uCount"/> documentation for "M:El.STRING.Left(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.Left(System.UInt32)"]

See Also

STRING Class


LeftEquals Method

[image]

One of William Foster's Class Libraries
STRING..::..LeftEquals Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.LeftEquals(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool LeftEquals(
    STRING match
)
Visual Basic
Public Function LeftEquals ( _
    match As STRING _
) As Boolean
Visual C++
public:
bool LeftEquals(
    STRING^ match
)

Parameters

match
Type: El..::..STRING

[Missing <param name="match"/> documentation for "M:El.STRING.LeftEquals(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.LeftEquals(El.STRING)"]

See Also

STRING Class


LeftFrom Method

[image]

One of William Foster's Class Libraries
STRING..::..LeftFrom Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.LeftFrom(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public STRING LeftFrom(
    uint uIndex
)
Visual Basic
Public Function LeftFrom ( _
    uIndex As UInteger _
) As STRING
Visual C++
public:
STRING^ LeftFrom(
    unsigned int uIndex
)

Parameters

uIndex
Type: System..::..UInt32

[Missing <param name="uIndex"/> documentation for "M:El.STRING.LeftFrom(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.LeftFrom(System.UInt32)"]

See Also

STRING Class


Mid Method

[image]

One of William Foster's Class Libraries
STRING..::..Mid Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Mid(System.UInt32,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public STRING Mid(
    uint uLeft,
    uint uRight
)
Visual Basic
Public Function Mid ( _
    uLeft As UInteger, _
    uRight As UInteger _
) As STRING
Visual C++
public:
STRING^ Mid(
    unsigned int uLeft,
    unsigned int uRight
)

Parameters

uLeft
Type: System..::..UInt32

[Missing <param name="uLeft"/> documentation for "M:El.STRING.Mid(System.UInt32,System.UInt32)"]

uRight
Type: System..::..UInt32

[Missing <param name="uRight"/> documentation for "M:El.STRING.Mid(System.UInt32,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.Mid(System.UInt32,System.UInt32)"]

See Also

STRING Class


ParseLines Method

[image]

One of William Foster's Class Libraries
STRING..::..ParseLines Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.ParseLines(System.UInt32,El.STRING@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint ParseLines(
    uint u_Start,
    out STRING csNext
)
Visual Basic
Public Function ParseLines ( _
    u_Start As UInteger, _
    <OutAttribute> ByRef csNext As STRING _
) As UInteger
Visual C++
public:
unsigned int ParseLines(
    unsigned int u_Start,
    [OutAttribute] STRING^% csNext
)

Parameters

u_Start
Type: System..::..UInt32

[Missing <param name="u_Start"/> documentation for "M:El.STRING.ParseLines(System.UInt32,El.STRING@)"]

csNext
Type: El..::..STRING %

[Missing <param name="csNext"/> documentation for "M:El.STRING.ParseLines(System.UInt32,El.STRING@)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.ParseLines(System.UInt32,El.STRING@)"]

See Also

STRING Class


RemoveAt Method

[image]

One of William Foster's Class Libraries
STRING..::..RemoveAt Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.RemoveAt(System.Int32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void RemoveAt(
    int uIndex
)
Visual Basic
Public Sub RemoveAt ( _
    uIndex As Integer _
)
Visual C++
public:
void RemoveAt(
    int uIndex
)

Parameters

uIndex
Type: System..::..Int32

[Missing <param name="uIndex"/> documentation for "M:El.STRING.RemoveAt(System.Int32)"]

See Also

STRING Class


RemoveQuotes Method

[image]

One of William Foster's Class Libraries
STRING..::..RemoveQuotes Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.RemoveQuotes"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool RemoveQuotes()
Visual Basic
Public Function RemoveQuotes As Boolean
Visual C++
public:
bool RemoveQuotes()

Return Value

[Missing <returns> documentation for "M:El.STRING.RemoveQuotes"]

See Also

STRING Class


RemoveWhitespace Method

[image]

One of William Foster's Class Libraries
STRING..::..RemoveWhitespace Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.RemoveWhitespace"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void RemoveWhitespace()
Visual Basic
Public Sub RemoveWhitespace
Visual C++
public:
void RemoveWhitespace()

See Also

STRING Class


Replace Method

[image] [image]

One of William Foster's Class Libraries
STRING..::..Replace Method
STRING Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Replace(STRING, STRING) |
Public method | Replace(UInt32, STRING, STRING) |
Public method | Replace(UInt32, UInt32, STRING) |

See Also

STRING Class
STRING Members


Replace Method (STRING, STRING)

[image]

One of William Foster's Class Libraries
STRING..::..Replace Method (STRING, STRING)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Replace(El.STRING,El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int Replace(
    STRING search,
    STRING replace
)
Visual Basic
Public Function Replace ( _
    search As STRING, _
    replace As STRING _
) As Integer
Visual C++
public:
int Replace(
    STRING^ search,
    STRING^ replace
)

Parameters

search
Type: El..::..STRING

[Missing <param name="search"/> documentation for "M:El.STRING.Replace(El.STRING,El.STRING)"]

replace
Type: El..::..STRING

[Missing <param name="replace"/> documentation for "M:El.STRING.Replace(El.STRING,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.Replace(El.STRING,El.STRING)"]

See Also

STRING Class
Replace Overload


Replace Method (UInt32, STRING, STRING)

[image]

One of William Foster's Class Libraries
STRING..::..Replace Method (UInt32, STRING, STRING)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Replace(System.UInt32,El.STRING,El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Replace(
    uint iIndex,
    STRING search,
    STRING replace
)
Visual Basic
Public Sub Replace ( _
    iIndex As UInteger, _
    search As STRING, _
    replace As STRING _
)
Visual C++
public:
void Replace(
    unsigned int iIndex,
    STRING^ search,
    STRING^ replace
)

Parameters

iIndex
Type: System..::..UInt32

[Missing <param name="iIndex"/> documentation for "M:El.STRING.Replace(System.UInt32,El.STRING,El.STRING)"]

search
Type: El..::..STRING

[Missing <param name="search"/> documentation for "M:El.STRING.Replace(System.UInt32,El.STRING,El.STRING)"]

replace
Type: El..::..STRING

[Missing <param name="replace"/> documentation for "M:El.STRING.Replace(System.UInt32,El.STRING,El.STRING)"]

See Also

STRING Class
Replace Overload


Replace Method (UInt32, UInt32, STRING)

[image]

One of William Foster's Class Libraries
STRING..::..Replace Method (UInt32, UInt32, STRING)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Replace(System.UInt32,System.UInt32,El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Replace(
    uint iIndexStart,
    uint iIndexEnd,
    STRING replace
)
Visual Basic
Public Sub Replace ( _
    iIndexStart As UInteger, _
    iIndexEnd As UInteger, _
    replace As STRING _
)
Visual C++
public:
void Replace(
    unsigned int iIndexStart,
    unsigned int iIndexEnd,
    STRING^ replace
)

Parameters

iIndexStart
Type: System..::..UInt32

[Missing <param name="iIndexStart"/> documentation for "M:El.STRING.Replace(System.UInt32,System.UInt32,El.STRING)"]

iIndexEnd
Type: System..::..UInt32

[Missing <param name="iIndexEnd"/> documentation for "M:El.STRING.Replace(System.UInt32,System.UInt32,El.STRING)"]

replace
Type: El..::..STRING

[Missing <param name="replace"/> documentation for "M:El.STRING.Replace(System.UInt32,System.UInt32,El.STRING)"]

See Also

STRING Class
Replace Overload


ReverseFind Method

[image]

One of William Foster's Class Libraries
STRING..::..ReverseFind Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.ReverseFind(System.Char,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int ReverseFind(
    char c,
    uint u_Start
)
Visual Basic
Public Function ReverseFind ( _
    c As Char, _
    u_Start As UInteger _
) As Integer
Visual C++
public:
int ReverseFind(
    wchar_t c,
    unsigned int u_Start
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:El.STRING.ReverseFind(System.Char,System.UInt32)"]

u_Start
Type: System..::..UInt32

[Missing <param name="u_Start"/> documentation for "M:El.STRING.ReverseFind(System.Char,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.ReverseFind(System.Char,System.UInt32)"]

See Also

STRING Class


Right Method

[image] [image]

One of William Foster's Class Libraries
STRING..::..Right Method
STRING Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Right()()()() |
Public method | Right(UInt32) |

See Also

STRING Class
STRING Members


Right Method

[image]

One of William Foster's Class Libraries
STRING..::..Right Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Right"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public char Right()
Visual Basic
Public Function Right As Char
Visual C++
public:
wchar_t Right()

Return Value

[Missing <returns> documentation for "M:El.STRING.Right"]

See Also

STRING Class
Right Overload


Right Method (UInt32)

[image]

One of William Foster's Class Libraries
STRING..::..Right Method (UInt32)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Right(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public STRING Right(
    uint uCount
)
Visual Basic
Public Function Right ( _
    uCount As UInteger _
) As STRING
Visual C++
public:
STRING^ Right(
    unsigned int uCount
)

Parameters

uCount
Type: System..::..UInt32

[Missing <param name="uCount"/> documentation for "M:El.STRING.Right(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.Right(System.UInt32)"]

See Also

STRING Class
Right Overload


RightFrom Method

[image]

One of William Foster's Class Libraries
STRING..::..RightFrom Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.RightFrom(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public STRING RightFrom(
    uint uIndex
)
Visual Basic
Public Function RightFrom ( _
    uIndex As UInteger _
) As STRING
Visual C++
public:
STRING^ RightFrom(
    unsigned int uIndex
)

Parameters

uIndex
Type: System..::..UInt32

[Missing <param name="uIndex"/> documentation for "M:El.STRING.RightFrom(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.RightFrom(System.UInt32)"]

See Also

STRING Class


Set Method

[image] [image]

One of William Foster's Class Libraries
STRING..::..Set Method
STRING Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(array<Byte>[]()[][]) |
Public method | Set(String) |

See Also

STRING Class
STRING Members


Set Method (Byte[])

[image]

One of William Foster's Class Libraries
STRING..::..Set Method (array<Byte>[]()[][])
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Set(System.Byte[])"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Set(
    byte[] bp
)
Visual Basic
Public Sub Set ( _
    bp As Byte() _
)
Visual C++
public:
void Set(
    array<unsigned char>^ bp
)

Parameters

bp
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bp"/> documentation for "M:El.STRING.Set(System.Byte[])"]

See Also

STRING Class
Set Overload


Set Method (String)

[image]

One of William Foster's Class Libraries
STRING..::..Set Method (String)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Set(System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Set(
    string cs
)
Visual Basic
Public Sub Set ( _
    cs As String _
)
Visual C++
public:
void Set(
    String^ cs
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.STRING.Set(System.String)"]

See Also

STRING Class
Set Overload


SetAt Method

[image]

One of William Foster's Class Libraries
STRING..::..SetAt Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.SetAt(System.Char,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetAt(
    char c,
    uint uIndex
)
Visual Basic
Public Sub SetAt ( _
    c As Char, _
    uIndex As UInteger _
)
Visual C++
public:
void SetAt(
    wchar_t c,
    unsigned int uIndex
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:El.STRING.SetAt(System.Char,System.UInt32)"]

uIndex
Type: System..::..UInt32

[Missing <param name="uIndex"/> documentation for "M:El.STRING.SetAt(System.Char,System.UInt32)"]

See Also

STRING Class


SetLength Method

[image]

One of William Foster's Class Libraries
STRING..::..SetLength Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.SetLength(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void SetLength(
    uint uLength
)
Visual Basic
Public Sub SetLength ( _
    uLength As UInteger _
)
Visual C++
public:
void SetLength(
    unsigned int uLength
)

Parameters

uLength
Type: System..::..UInt32

[Missing <param name="uLength"/> documentation for "M:El.STRING.SetLength(System.UInt32)"]

See Also

STRING Class


SpanExcluding Method

[image]

One of William Foster's Class Libraries
STRING..::..SpanExcluding Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.SpanExcluding(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public STRING SpanExcluding(
    STRING lpsz
)
Visual Basic
Public Function SpanExcluding ( _
    lpsz As STRING _
) As STRING
Visual C++
public:
STRING^ SpanExcluding(
    STRING^ lpsz
)

Parameters

lpsz
Type: El..::..STRING

[Missing <param name="lpsz"/> documentation for "M:El.STRING.SpanExcluding(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.SpanExcluding(El.STRING)"]

See Also

STRING Class


Substitute Method

[image]

One of William Foster's Class Libraries
STRING..::..Substitute Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Substitute(El.STRING[],El.STRING[])"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Substitute(
    STRING[] substitute_array,
    STRING[] replace_array
)
Visual Basic
Public Function Substitute ( _
    substitute_array As STRING(), _
    replace_array As STRING() _
) As Boolean
Visual C++
public:
bool Substitute(
    array<STRING^>^ substitute_array,
    array<STRING^>^ replace_array
)

Parameters

substitute_array
Type: array< El..::..STRING >[]()[][]

[Missing <param name="substitute_array"/> documentation for "M:El.STRING.Substitute(El.STRING[],El.STRING[])"]

replace_array
Type: array< El..::..STRING >[]()[][]

[Missing <param name="replace_array"/> documentation for "M:El.STRING.Substitute(El.STRING[],El.STRING[])"]

Return Value

[Missing <returns> documentation for "M:El.STRING.Substitute(El.STRING[],El.STRING[])"]

See Also

STRING Class


Terminate Method

[image]

One of William Foster's Class Libraries
STRING..::..Terminate Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Terminate(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Terminate(
    uint len
)
Visual Basic
Public Sub Terminate ( _
    len As UInteger _
)
Visual C++
public:
void Terminate(
    unsigned int len
)

Parameters

len
Type: System..::..UInt32

[Missing <param name="len"/> documentation for "M:El.STRING.Terminate(System.UInt32)"]

See Also

STRING Class


ToUpperCase Method

[image]

One of William Foster's Class Libraries
STRING..::..ToUpperCase Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.ToUpperCase"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void ToUpperCase()
Visual Basic
Public Sub ToUpperCase
Visual C++
public:
void ToUpperCase()

See Also

STRING Class


Trim Method

[image] [image]

One of William Foster's Class Libraries
STRING..::..Trim Method
STRING Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Trim()()()() |
Public method | Trim(UInt32, UInt32) |

See Also

STRING Class
STRING Members


Trim Method

[image]

One of William Foster's Class Libraries
STRING..::..Trim Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Trim"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Trim()
Visual Basic
Public Function Trim As Boolean
Visual C++
public:
bool Trim()

Return Value

[Missing <returns> documentation for "M:El.STRING.Trim"]

See Also

STRING Class
Trim Overload


Trim Method (UInt32, UInt32)

[image]

One of William Foster's Class Libraries
STRING..::..Trim Method (UInt32, UInt32)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.Trim(System.UInt32,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Trim(
    uint left,
    uint right
)
Visual Basic
Public Sub Trim ( _
    left As UInteger, _
    right As UInteger _
)
Visual C++
public:
void Trim(
    unsigned int left,
    unsigned int right
)

Parameters

left
Type: System..::..UInt32

[Missing <param name="left"/> documentation for "M:El.STRING.Trim(System.UInt32,System.UInt32)"]

right
Type: System..::..UInt32

[Missing <param name="right"/> documentation for "M:El.STRING.Trim(System.UInt32,System.UInt32)"]

See Also

STRING Class
Trim Overload


TrimLeft Method

[image] [image]

One of William Foster's Class Libraries
STRING..::..TrimLeft Method
STRING Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimLeft()()()() |
Public method | TrimLeft(UInt32) |
Public method | TrimLeft(STRING) |

See Also

STRING Class
STRING Members


TrimLeft Method

[image]

One of William Foster's Class Libraries
STRING..::..TrimLeft Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.TrimLeft"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool TrimLeft()
Visual Basic
Public Function TrimLeft As Boolean
Visual C++
public:
bool TrimLeft()

Return Value

[Missing <returns> documentation for "M:El.STRING.TrimLeft"]

See Also

STRING Class
TrimLeft Overload


TrimLeft Method (UInt32)

[image]

One of William Foster's Class Libraries
STRING..::..TrimLeft Method (UInt32)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.TrimLeft(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void TrimLeft(
    uint count
)
Visual Basic
Public Sub TrimLeft ( _
    count As UInteger _
)
Visual C++
public:
void TrimLeft(
    unsigned int count
)

Parameters

count
Type: System..::..UInt32

[Missing <param name="count"/> documentation for "M:El.STRING.TrimLeft(System.UInt32)"]

See Also

STRING Class
TrimLeft Overload


TrimLeft Method (STRING)

[image]

One of William Foster's Class Libraries
STRING..::..TrimLeft Method (STRING)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.TrimLeft(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool TrimLeft(
    STRING match
)
Visual Basic
Public Function TrimLeft ( _
    match As STRING _
) As Boolean
Visual C++
public:
bool TrimLeft(
    STRING^ match
)

Parameters

match
Type: El..::..STRING

[Missing <param name="match"/> documentation for "M:El.STRING.TrimLeft(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.TrimLeft(El.STRING)"]

See Also

STRING Class
TrimLeft Overload


TrimRight Method

[image] [image]

One of William Foster's Class Libraries
STRING..::..TrimRight Method
STRING Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimRight()()()() |
Public method | TrimRight(UInt32) |

See Also

STRING Class
STRING Members


TrimRight Method

[image]

One of William Foster's Class Libraries
STRING..::..TrimRight Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.TrimRight"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool TrimRight()
Visual Basic
Public Function TrimRight As Boolean
Visual C++
public:
bool TrimRight()

Return Value

[Missing <returns> documentation for "M:El.STRING.TrimRight"]

See Also

STRING Class
TrimRight Overload


TrimRight Method (UInt32)

[image]

One of William Foster's Class Libraries
STRING..::..TrimRight Method (UInt32)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.TrimRight(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void TrimRight(
    uint count
)
Visual Basic
Public Sub TrimRight ( _
    count As UInteger _
)
Visual C++
public:
void TrimRight(
    unsigned int count
)

Parameters

count
Type: System..::..UInt32

[Missing <param name="count"/> documentation for "M:El.STRING.TrimRight(System.UInt32)"]

See Also

STRING Class
TrimRight Overload


WildcardMatch Method

[image]

One of William Foster's Class Libraries
STRING..::..WildcardMatch Method
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.WildcardMatch(System.String,System.String,System.Boolean)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool WildcardMatch(
    string strCompare,
    string strWild,
    bool bIgnoreCase
)
Visual Basic
Public Shared Function WildcardMatch ( _
    strCompare As String, _
    strWild As String, _
    bIgnoreCase As Boolean _
) As Boolean
Visual C++
public:
static bool WildcardMatch(
    String^ strCompare,
    String^ strWild,
    bool bIgnoreCase
)

Parameters

strCompare
Type: System..::..String

[Missing <param name="strCompare"/> documentation for "M:El.STRING.WildcardMatch(System.String,System.String,System.Boolean)"]

strWild
Type: System..::..String

[Missing <param name="strWild"/> documentation for "M:El.STRING.WildcardMatch(System.String,System.String,System.Boolean)"]

bIgnoreCase
Type: System..::..Boolean

[Missing <param name="bIgnoreCase"/> documentation for "M:El.STRING.WildcardMatch(System.String,System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.WildcardMatch(System.String,System.String,System.Boolean)"]

See Also

STRING Class


STRING Operators and Type Conversions

[image] [image]

One of William Foster's Class Libraries
STRING Operators and Type Conversions
STRING Class See Also Send Feedback

Operators

Name | Description
Equality(STRING, STRING) |
Equality(STRING, String) |
ImplicitWideningImplicitImplicitImplicit(String to STRING) |
ImplicitWideningImplicitImplicitImplicit(STRING to String) |
Inequality(STRING, STRING) |
Inequality(STRING, String) |

See Also

STRING Class


Equality Operator

[image] [image]

One of William Foster's Class Libraries
STRING..::..Equality Operator
STRING Class See Also Send Feedback

Overload List

Name | Description
Equality(STRING, STRING) |
Equality(STRING, String) |

See Also

STRING Class
STRING Members


Equality Operator (STRING, STRING)

[image]

One of William Foster's Class Libraries
STRING..::..Equality Operator (STRING, STRING)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.op_Equality(El.STRING,El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator ==(
    STRING str,
    STRING cmpString
)
Visual Basic
Public Shared Operator = ( _
    str As STRING, _
    cmpString As STRING _
) As Boolean
Visual C++
public:
static bool operator ==(
    STRING^ str,
    STRING^ cmpString
)

Parameters

str
Type: El..::..STRING

[Missing <param name="str"/> documentation for "M:El.STRING.op_Equality(El.STRING,El.STRING)"]

cmpString
Type: El..::..STRING

[Missing <param name="cmpString"/> documentation for "M:El.STRING.op_Equality(El.STRING,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.op_Equality(El.STRING,El.STRING)"]

See Also

STRING Class
Equality Overload


Equality Operator (STRING, String)

[image]

One of William Foster's Class Libraries
STRING..::..Equality Operator (STRING, String)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.op_Equality(El.STRING,System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator ==(
    STRING str,
    string cmpString
)
Visual Basic
Public Shared Operator = ( _
    str As STRING, _
    cmpString As String _
) As Boolean
Visual C++
public:
static bool operator ==(
    STRING^ str,
    String^ cmpString
)

Parameters

str
Type: El..::..STRING

[Missing <param name="str"/> documentation for "M:El.STRING.op_Equality(El.STRING,System.String)"]

cmpString
Type: System..::..String

[Missing <param name="cmpString"/> documentation for "M:El.STRING.op_Equality(El.STRING,System.String)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.op_Equality(El.STRING,System.String)"]

See Also

STRING Class
Equality Overload


Implicit Conversion Operators

[image] [image]

One of William Foster's Class Libraries
STRING ImplicitWideningImplicitImplicitImplicit Conversion Operators
STRING Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(String to STRING) |
ImplicitWideningImplicitImplicitImplicit(STRING to String) |

See Also

STRING Class
STRING Members


Implicit Conversion (String to STRING)

[image]

One of William Foster's Class Libraries
STRING ImplicitWideningImplicitImplicitImplicit Conversion (String to STRING)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.op_Implicit(System.String)~El.STRING"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator STRING (
    string s
)
Visual Basic
Public Shared Widening Operator CType ( _
    s As String _
) As STRING
Visual C++
static implicit operator STRING^ (
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:El.STRING.op_Implicit(System.String)~El.STRING"]

Return Value

[Missing <returns> documentation for "M:El.STRING.op_Implicit(System.String)~El.STRING"]

See Also

STRING Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (STRING to String)

[image]

One of William Foster's Class Libraries
STRING ImplicitWideningImplicitImplicitImplicit Conversion (STRING to String)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.op_Implicit(El.STRING)~System.String"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator string (
    STRING s
)
Visual Basic
Public Shared Widening Operator CType ( _
    s As STRING _
) As String
Visual C++
static implicit operator String^ (
    STRING^ s
)

Parameters

s
Type: El..::..STRING

[Missing <param name="s"/> documentation for "M:El.STRING.op_Implicit(El.STRING)~System.String"]

Return Value

[Missing <returns> documentation for "M:El.STRING.op_Implicit(El.STRING)~System.String"]

See Also

STRING Class
ImplicitWideningImplicitImplicitImplicit Overload


Inequality Operator

[image] [image]

One of William Foster's Class Libraries
STRING..::..Inequality Operator
STRING Class See Also Send Feedback

Overload List

Name | Description
Inequality(STRING, STRING) |
Inequality(STRING, String) |

See Also

STRING Class
STRING Members


Inequality Operator (STRING, STRING)

[image]

One of William Foster's Class Libraries
STRING..::..Inequality Operator (STRING, STRING)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.op_Inequality(El.STRING,El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator !=(
    STRING str,
    STRING cmpString
)
Visual Basic
Public Shared Operator <> ( _
    str As STRING, _
    cmpString As STRING _
) As Boolean
Visual C++
public:
static bool operator !=(
    STRING^ str,
    STRING^ cmpString
)

Parameters

str
Type: El..::..STRING

[Missing <param name="str"/> documentation for "M:El.STRING.op_Inequality(El.STRING,El.STRING)"]

cmpString
Type: El..::..STRING

[Missing <param name="cmpString"/> documentation for "M:El.STRING.op_Inequality(El.STRING,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.op_Inequality(El.STRING,El.STRING)"]

See Also

STRING Class
Inequality Overload


Inequality Operator (STRING, String)

[image]

One of William Foster's Class Libraries
STRING..::..Inequality Operator (STRING, String)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRING.op_Inequality(El.STRING,System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator !=(
    STRING str,
    string cmpString
)
Visual Basic
Public Shared Operator <> ( _
    str As STRING, _
    cmpString As String _
) As Boolean
Visual C++
public:
static bool operator !=(
    STRING^ str,
    String^ cmpString
)

Parameters

str
Type: El..::..STRING

[Missing <param name="str"/> documentation for "M:El.STRING.op_Inequality(El.STRING,System.String)"]

cmpString
Type: System..::..String

[Missing <param name="cmpString"/> documentation for "M:El.STRING.op_Inequality(El.STRING,System.String)"]

Return Value

[Missing <returns> documentation for "M:El.STRING.op_Inequality(El.STRING,System.String)"]

See Also

STRING Class
Inequality Overload


STRING Properties

[image] [image]

One of William Foster's Class Libraries
STRING Properties
STRING Class See Also Send Feedback

The STRING type exposes the following members.

Properties

 | Name | Description
Public property | Item[([( Int32])]) |
Public property | Item[([( UInt32])]) |
Public property | Length |

See Also

STRING Class


Item Property

[image] [image]

One of William Foster's Class Libraries
STRING..::..Item Property
STRING Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) |
Public property | Item[([( UInt32])]) |

See Also

STRING Class
STRING Members


Item Property (Int32)

[image]

One of William Foster's Class Libraries
STRING..::..Item Property (Int32)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "P:El.STRING.Item(System.Int32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public char this[
    int i
] { get; set; }
Visual Basic
Public Default Property Item ( _
    i As Integer _
) As Char
    Get
    Set
Visual C++
public:
property wchar_t default[int i] {
    wchar_t get (int i);
    void set (int i, wchar_t value);
}

Parameters

i
Type: System..::..Int32

See Also

STRING Class
Item Overload


Item Property (UInt32)

[image]

One of William Foster's Class Libraries
STRING..::..Item Property (UInt32)
STRING Class See Also Send Feedback

[Missing <summary> documentation for "P:El.STRING.Item(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public char this[
    uint ui
] { get; set; }
Visual Basic
Public Default Property Item ( _
    ui As UInteger _
) As Char
    Get
    Set
Visual C++
public:
property wchar_t default[unsigned int ui] {
    wchar_t get (unsigned int ui);
    void set (unsigned int ui, wchar_t value);
}

Parameters

ui
Type: System..::..UInt32

See Also

STRING Class
Item Overload


Length Property

[image]

One of William Foster's Class Libraries
STRING..::..Length Property
STRING Class See Also Send Feedback

[Missing <summary> documentation for "P:El.STRING.Length"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint Length { get; }
Visual Basic
Public ReadOnly Property Length As UInteger
    Get
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
}

See Also

STRING Class


StringBuffer Class

[image]

One of William Foster's Class Libraries
StringBuffer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.StringBuffer"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class StringBuffer : STRING
Visual Basic
Public Class StringBuffer _
    Inherits STRING
Visual C++
public ref class StringBuffer : public STRING

Inheritance Hierarchy

System..::..Object
El..::..STRING
El..::..StringBuffer

See Also

StringBuffer Members


StringBuffer Members

[image] [image]

One of William Foster's Class Libraries
StringBuffer Members
StringBuffer Class Constructors Methods Fields Properties See Also Send Feedback

The StringBuffer type exposes the following members.

Constructors

 | Name | Description
Public method | StringBuffer()()()() | Initializes a new instance of the StringBuffer class
Public method | StringBuffer(STRING) | Initializes a new instance of the StringBuffer class

Methods

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Empty | (Inherited from STRING.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)
Public method | FindOneOf | (Inherited from STRING.)
Public method | FormatV | (Inherited from STRING.)
Public method | GetAsString | (Inherited from STRING.)
Public method | GetAt | (Inherited from STRING.)
Public method | GetBytePtr | (Inherited from STRING.)
Public method | GetEnumerator | (Inherited from STRING.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | (Inherited from STRING.)
Public method | GetLengthBytes | (Inherited from STRING.)
Public method | GetPtr | (Inherited from STRING.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAt | (Inherited from STRING.)
Public method | IsEmpty | (Inherited from STRING.)
Public method | Left | (Inherited from STRING.)
Public method | LeftEquals | (Inherited from STRING.)
Public method | LeftFrom | (Inherited from STRING.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid | (Inherited from STRING.)
Public method | ParseLines | (Inherited from STRING.)
Public method | RemoveAt | (Inherited from STRING.)
Public method | RemoveQuotes | (Inherited from STRING.)
Public method | RemoveWhitespace | (Inherited from STRING.)
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)
Public method | ReverseFind | (Inherited from STRING.)
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)
Public method | RightFrom | (Inherited from STRING.)
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)
Public method | SetAt | (Inherited from STRING.)
Public method | SetLength | (Inherited from STRING.)
Public method | SpanExcluding | (Inherited from STRING.)
Public method | Substitute | (Inherited from STRING.)
Public method | Terminate | (Inherited from STRING.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase | (Inherited from STRING.)
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

Extension Methods

 | Name | Description
Public Extension Method | LeftWord | (Defined by StringExtension.)

Fields

 | Name | Description
Protected field | m_cs | (Inherited from STRING.)

Properties

 | Name | Description
Public property | Item[([( Int32])]) | (Inherited from STRING.)
Public property | Item[([( UInt32])]) | (Inherited from STRING.)
Public property | Length | (Inherited from STRING.)

See Also

StringBuffer Class


StringBuffer Constructor

[image] [image]

One of William Foster's Class Libraries
StringBuffer Constructor
StringBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StringBuffer()()()() | Initializes a new instance of the StringBuffer class
Public method | StringBuffer(STRING) | Initializes a new instance of the StringBuffer class

See Also

StringBuffer Class
StringBuffer Members


StringBuffer Constructor

[image]

One of William Foster's Class Libraries
StringBuffer Constructor
StringBuffer Class See Also Send Feedback
Initializes a new instance of the StringBuffer class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public StringBuffer()
Visual Basic
Public Sub New
Visual C++
public:
StringBuffer()

See Also

StringBuffer Class
StringBuffer Overload


StringBuffer Constructor (STRING)

[image]

One of William Foster's Class Libraries
StringBuffer Constructor (STRING)
StringBuffer Class See Also Send Feedback
Initializes a new instance of the StringBuffer class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public StringBuffer(
    STRING cs
)
Visual Basic
Public Sub New ( _
    cs As STRING _
)
Visual C++
public:
StringBuffer(
    STRING^ cs
)

Parameters

cs
Type: El..::..STRING

[Missing <param name="cs"/> documentation for "M:El.StringBuffer.#ctor(El.STRING)"]

See Also

StringBuffer Class
StringBuffer Overload


StringBuffer Fields

[image] [image]

One of William Foster's Class Libraries
StringBuffer Fields
StringBuffer Class See Also Send Feedback

The StringBuffer type exposes the following members.

Fields

 | Name | Description
Protected field | m_cs | (Inherited from STRING.)

See Also

StringBuffer Class


StringBuffer Methods

[image] [image]

One of William Foster's Class Libraries
StringBuffer Methods
StringBuffer Class See Also Send Feedback

The StringBuffer type exposes the following members.

Methods

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Empty | (Inherited from STRING.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)
Public method | FindOneOf | (Inherited from STRING.)
Public method | FormatV | (Inherited from STRING.)
Public method | GetAsString | (Inherited from STRING.)
Public method | GetAt | (Inherited from STRING.)
Public method | GetBytePtr | (Inherited from STRING.)
Public method | GetEnumerator | (Inherited from STRING.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | (Inherited from STRING.)
Public method | GetLengthBytes | (Inherited from STRING.)
Public method | GetPtr | (Inherited from STRING.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAt | (Inherited from STRING.)
Public method | IsEmpty | (Inherited from STRING.)
Public method | Left | (Inherited from STRING.)
Public method | LeftEquals | (Inherited from STRING.)
Public method | LeftFrom | (Inherited from STRING.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid | (Inherited from STRING.)
Public method | ParseLines | (Inherited from STRING.)
Public method | RemoveAt | (Inherited from STRING.)
Public method | RemoveQuotes | (Inherited from STRING.)
Public method | RemoveWhitespace | (Inherited from STRING.)
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)
Public method | ReverseFind | (Inherited from STRING.)
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)
Public method | RightFrom | (Inherited from STRING.)
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)
Public method | SetAt | (Inherited from STRING.)
Public method | SetLength | (Inherited from STRING.)
Public method | SpanExcluding | (Inherited from STRING.)
Public method | Substitute | (Inherited from STRING.)
Public method | Terminate | (Inherited from STRING.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase | (Inherited from STRING.)
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

Extension Methods

 | Name | Description
Public Extension Method | LeftWord | (Defined by StringExtension.)

See Also

StringBuffer Class


Append Method

[image] [image]

One of William Foster's Class Libraries
StringBuffer..::..Append Method
StringBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)

See Also

StringBuffer Class
StringBuffer Members


Compare Method

[image] [image]

One of William Foster's Class Libraries
StringBuffer..::..Compare Method
StringBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)

See Also

StringBuffer Class
StringBuffer Members


CompareNoCase Method

[image] [image]

One of William Foster's Class Libraries
StringBuffer..::..CompareNoCase Method
StringBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)

See Also

StringBuffer Class
StringBuffer Members


Find Method

[image] [image]

One of William Foster's Class Libraries
StringBuffer..::..Find Method
StringBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)

See Also

StringBuffer Class
StringBuffer Members


Replace Method

[image] [image]

One of William Foster's Class Libraries
StringBuffer..::..Replace Method
StringBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)

See Also

StringBuffer Class
StringBuffer Members


Right Method

[image] [image]

One of William Foster's Class Libraries
StringBuffer..::..Right Method
StringBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)

See Also

StringBuffer Class
StringBuffer Members


Set Method

[image] [image]

One of William Foster's Class Libraries
StringBuffer..::..Set Method
StringBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)

See Also

StringBuffer Class
StringBuffer Members


Trim Method

[image] [image]

One of William Foster's Class Libraries
StringBuffer..::..Trim Method
StringBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)

See Also

StringBuffer Class
StringBuffer Members


TrimLeft Method

[image] [image]

One of William Foster's Class Libraries
StringBuffer..::..TrimLeft Method
StringBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)

See Also

StringBuffer Class
StringBuffer Members


TrimRight Method

[image] [image]

One of William Foster's Class Libraries
StringBuffer..::..TrimRight Method
StringBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

See Also

StringBuffer Class
StringBuffer Members


StringBuffer Properties

[image] [image]

One of William Foster's Class Libraries
StringBuffer Properties
StringBuffer Class See Also Send Feedback

The StringBuffer type exposes the following members.

Properties

 | Name | Description
Public property | Item[([( Int32])]) | (Inherited from STRING.)
Public property | Item[([( UInt32])]) | (Inherited from STRING.)
Public property | Length | (Inherited from STRING.)

See Also

StringBuffer Class


Item Property

[image] [image]

One of William Foster's Class Libraries
StringBuffer..::..Item Property
StringBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | (Inherited from STRING.)
Public property | Item[([( UInt32])]) | (Inherited from STRING.)

See Also

StringBuffer Class
StringBuffer Members


STRINGEnumerator Class

[image]

One of William Foster's Class Libraries
STRINGEnumerator Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.STRINGEnumerator"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class STRINGEnumerator : IEnumerator
Visual Basic
Public Class STRINGEnumerator _
    Implements IEnumerator
Visual C++
public ref class STRINGEnumerator : IEnumerator

Inheritance Hierarchy

System..::..Object
El..::..STRINGEnumerator

See Also

STRINGEnumerator Members


STRINGEnumerator Members

[image] [image]

One of William Foster's Class Libraries
STRINGEnumerator Members
STRINGEnumerator Class Constructors Methods Properties See Also Send Feedback

The STRINGEnumerator type exposes the following members.

Constructors

 | Name | Description
Public method | STRINGEnumerator | Initializes a new instance of the STRINGEnumerator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |

See Also

STRINGEnumerator Class


STRINGEnumerator Constructor

[image]

One of William Foster's Class Libraries
STRINGEnumerator Constructor
STRINGEnumerator Class See Also Send Feedback
Initializes a new instance of the STRINGEnumerator class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public STRINGEnumerator(
    string cs
)
Visual Basic
Public Sub New ( _
    cs As String _
)
Visual C++
public:
STRINGEnumerator(
    String^ cs
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.STRINGEnumerator.#ctor(System.String)"]

See Also

STRINGEnumerator Class


STRINGEnumerator Methods

[image] [image]

One of William Foster's Class Libraries
STRINGEnumerator Methods
STRINGEnumerator Class See Also Send Feedback

The STRINGEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

STRINGEnumerator Class


MoveNext Method

[image]

One of William Foster's Class Libraries
STRINGEnumerator..::..MoveNext Method
STRINGEnumerator Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRINGEnumerator.MoveNext"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool MoveNext()
Visual Basic
Public Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext() sealed

Return Value

[Missing <returns> documentation for "M:El.STRINGEnumerator.MoveNext"]

Implements

IEnumerator..::..MoveNext()()()()

See Also

STRINGEnumerator Class


Reset Method

[image]

One of William Foster's Class Libraries
STRINGEnumerator..::..Reset Method
STRINGEnumerator Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRINGEnumerator.Reset"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
virtual void Reset() sealed

Implements

IEnumerator..::..Reset()()()()

See Also

STRINGEnumerator Class


STRINGEnumerator Properties

[image] [image]

One of William Foster's Class Libraries
STRINGEnumerator Properties
STRINGEnumerator Class See Also Send Feedback

The STRINGEnumerator type exposes the following members.

Properties

 | Name | Description
Public property | Current |

See Also

STRINGEnumerator Class


Current Property

[image]

One of William Foster's Class Libraries
STRINGEnumerator..::..Current Property
STRINGEnumerator Class See Also Send Feedback

[Missing <summary> documentation for "P:El.STRINGEnumerator.Current"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Object Current { get; }
Visual Basic
Public ReadOnly Property Current As Object
    Get
Visual C++
public:
property Object^ Current {
    Object^ get ();
}

See Also

STRINGEnumerator Class


STRINGEX Class

[image]

One of William Foster's Class Libraries
STRINGEX Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.STRINGEX"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class STRINGEX : STRING
Visual Basic
Public Class STRINGEX _
    Inherits STRING
Visual C++
public ref class STRINGEX : public STRING

Inheritance Hierarchy

System..::..Object
El..::..STRING
El..::..STRINGEX

See Also

STRINGEX Members


STRINGEX Members

[image] [image]

One of William Foster's Class Libraries
STRINGEX Members
STRINGEX Class Constructors Methods Fields Properties See Also Send Feedback

The STRINGEX type exposes the following members.

Constructors

 | Name | Description
Public method | STRINGEX | Initializes a new instance of the STRINGEX class

Methods

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Empty | (Inherited from STRING.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)
Public method | FindOneOf | (Inherited from STRING.)
Public method | FormatV | (Inherited from STRING.)
Public method | GetAs |
Public method | GetAsDouble |
Public method | GetAsString | (Inherited from STRING.)
Public method | GetAt | (Inherited from STRING.)
Public method | GetBytePtr | (Inherited from STRING.)
Public method | GetEnumerator | (Inherited from STRING.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | (Inherited from STRING.)
Public method | GetLengthBytes | (Inherited from STRING.)
Public method | GetPtr | (Inherited from STRING.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAt | (Inherited from STRING.)
Public method | IsEmpty | (Inherited from STRING.)
Public method | Left | (Inherited from STRING.)
Public method | LeftEquals | (Inherited from STRING.)
Public method | LeftFrom | (Inherited from STRING.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid | (Inherited from STRING.)
Public method | ParseLines | (Inherited from STRING.)
Public method | RemoveAt | (Inherited from STRING.)
Public method | RemoveQuotes | (Inherited from STRING.)
Public method | RemoveWhitespace | (Inherited from STRING.)
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)
Public method | ReverseFind | (Inherited from STRING.)
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)
Public method | RightFrom | (Inherited from STRING.)
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)
Public method | SetAt | (Inherited from STRING.)
Public method | SetLength | (Inherited from STRING.)
Public method | SpanExcluding | (Inherited from STRING.)
Public method | Substitute | (Inherited from STRING.)
Public method | Terminate | (Inherited from STRING.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase | (Inherited from STRING.)
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

Extension Methods

 | Name | Description
Public Extension Method | LeftWord | (Defined by StringExtension.)

Fields

 | Name | Description
Protected field | m_cs | (Inherited from STRING.)

Properties

 | Name | Description
Public property | Item[([( Int32])]) | (Inherited from STRING.)
Public property | Item[([( UInt32])]) | (Inherited from STRING.)
Public property | Length | (Inherited from STRING.)

See Also

STRINGEX Class


STRINGEX Constructor

[image]

One of William Foster's Class Libraries
STRINGEX Constructor
STRINGEX Class See Also Send Feedback
Initializes a new instance of the STRINGEX class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public STRINGEX()
Visual Basic
Public Sub New
Visual C++
public:
STRINGEX()

See Also

STRINGEX Class


STRINGEX Fields

[image] [image]

One of William Foster's Class Libraries
STRINGEX Fields
STRINGEX Class See Also Send Feedback

The STRINGEX type exposes the following members.

Fields

 | Name | Description
Protected field | m_cs | (Inherited from STRING.)

See Also

STRINGEX Class


STRINGEX Methods

[image] [image]

One of William Foster's Class Libraries
STRINGEX Methods
STRINGEX Class See Also Send Feedback

The STRINGEX type exposes the following members.

Methods

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Empty | (Inherited from STRING.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)
Public method | FindOneOf | (Inherited from STRING.)
Public method | FormatV | (Inherited from STRING.)
Public method | GetAs |
Public method | GetAsDouble |
Public method | GetAsString | (Inherited from STRING.)
Public method | GetAt | (Inherited from STRING.)
Public method | GetBytePtr | (Inherited from STRING.)
Public method | GetEnumerator | (Inherited from STRING.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | (Inherited from STRING.)
Public method | GetLengthBytes | (Inherited from STRING.)
Public method | GetPtr | (Inherited from STRING.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAt | (Inherited from STRING.)
Public method | IsEmpty | (Inherited from STRING.)
Public method | Left | (Inherited from STRING.)
Public method | LeftEquals | (Inherited from STRING.)
Public method | LeftFrom | (Inherited from STRING.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid | (Inherited from STRING.)
Public method | ParseLines | (Inherited from STRING.)
Public method | RemoveAt | (Inherited from STRING.)
Public method | RemoveQuotes | (Inherited from STRING.)
Public method | RemoveWhitespace | (Inherited from STRING.)
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)
Public method | ReverseFind | (Inherited from STRING.)
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)
Public method | RightFrom | (Inherited from STRING.)
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)
Public method | SetAt | (Inherited from STRING.)
Public method | SetLength | (Inherited from STRING.)
Public method | SpanExcluding | (Inherited from STRING.)
Public method | Substitute | (Inherited from STRING.)
Public method | Terminate | (Inherited from STRING.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase | (Inherited from STRING.)
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

Extension Methods

 | Name | Description
Public Extension Method | LeftWord | (Defined by StringExtension.)

See Also

STRINGEX Class


Append Method

[image] [image]

One of William Foster's Class Libraries
STRINGEX..::..Append Method
STRINGEX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)

See Also

STRINGEX Class
STRINGEX Members


Compare Method

[image] [image]

One of William Foster's Class Libraries
STRINGEX..::..Compare Method
STRINGEX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)

See Also

STRINGEX Class
STRINGEX Members


CompareNoCase Method

[image] [image]

One of William Foster's Class Libraries
STRINGEX..::..CompareNoCase Method
STRINGEX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)

See Also

STRINGEX Class
STRINGEX Members


Find Method

[image] [image]

One of William Foster's Class Libraries
STRINGEX..::..Find Method
STRINGEX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)

See Also

STRINGEX Class
STRINGEX Members


GetAs Method

[image]

One of William Foster's Class Libraries
STRINGEX..::..GetAs Method
STRINGEX Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRINGEX.GetAs"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint GetAs()
Visual Basic
Public Function GetAs As UInteger
Visual C++
public:
unsigned int GetAs()

Return Value

[Missing <returns> documentation for "M:El.STRINGEX.GetAs"]

See Also

STRINGEX Class


GetAsDouble Method

[image]

One of William Foster's Class Libraries
STRINGEX..::..GetAsDouble Method
STRINGEX Class See Also Send Feedback

[Missing <summary> documentation for "M:El.STRINGEX.GetAsDouble"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public double GetAsDouble()
Visual Basic
Public Function GetAsDouble As Double
Visual C++
public:
double GetAsDouble()

Return Value

[Missing <returns> documentation for "M:El.STRINGEX.GetAsDouble"]

See Also

STRINGEX Class


Replace Method

[image] [image]

One of William Foster's Class Libraries
STRINGEX..::..Replace Method
STRINGEX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)

See Also

STRINGEX Class
STRINGEX Members


Right Method

[image] [image]

One of William Foster's Class Libraries
STRINGEX..::..Right Method
STRINGEX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)

See Also

STRINGEX Class
STRINGEX Members


Set Method

[image] [image]

One of William Foster's Class Libraries
STRINGEX..::..Set Method
STRINGEX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)

See Also

STRINGEX Class
STRINGEX Members


Trim Method

[image] [image]

One of William Foster's Class Libraries
STRINGEX..::..Trim Method
STRINGEX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)

See Also

STRINGEX Class
STRINGEX Members


TrimLeft Method

[image] [image]

One of William Foster's Class Libraries
STRINGEX..::..TrimLeft Method
STRINGEX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)

See Also

STRINGEX Class
STRINGEX Members


TrimRight Method

[image] [image]

One of William Foster's Class Libraries
STRINGEX..::..TrimRight Method
STRINGEX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

See Also

STRINGEX Class
STRINGEX Members


STRINGEX Properties

[image] [image]

One of William Foster's Class Libraries
STRINGEX Properties
STRINGEX Class See Also Send Feedback

The STRINGEX type exposes the following members.

Properties

 | Name | Description
Public property | Item[([( Int32])]) | (Inherited from STRING.)
Public property | Item[([( UInt32])]) | (Inherited from STRING.)
Public property | Length | (Inherited from STRING.)

See Also

STRINGEX Class


Item Property

[image] [image]

One of William Foster's Class Libraries
STRINGEX..::..Item Property
STRINGEX Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | (Inherited from STRING.)
Public property | Item[([( UInt32])]) | (Inherited from STRING.)

See Also

STRINGEX Class
STRINGEX Members


StringExtension Class

[image]

One of William Foster's Class Libraries
StringExtension Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.StringExtension"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static class StringExtension
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class StringExtension
Visual C++
[ExtensionAttribute]
public ref class StringExtension abstract sealed

Inheritance Hierarchy

System..::..Object
El..::..StringExtension

See Also

StringExtension Members


StringExtension Members

[image] [image]

One of William Foster's Class Libraries
StringExtension Members
StringExtension Class Methods See Also Send Feedback

The StringExtension type exposes the following members.

Methods

Name | Description
Empty |
FormatV |
GetBytePtr |
GetLengthBytes |
GetPtr |
IsEmpty |
Left |
LeftFrom |
LeftWord |
ParseLines |
RemoveAt |
RemoveWhitespace |
RightFrom |
Set(String, array<Byte>[]()[][]) |
Set(String, String) |
SetAt |
Substitute |
ToUpperCase |

See Also

StringExtension Class


StringExtension Methods

[image] [image]

One of William Foster's Class Libraries
StringExtension Methods
StringExtension Class See Also Send Feedback

The StringExtension type exposes the following members.

Methods

Name | Description
Empty |
FormatV |
GetBytePtr |
GetLengthBytes |
GetPtr |
IsEmpty |
Left |
LeftFrom |
LeftWord |
ParseLines |
RemoveAt |
RemoveWhitespace |
RightFrom |
Set(String, array<Byte>[]()[][]) |
Set(String, String) |
SetAt |
Substitute |
ToUpperCase |

See Also

StringExtension Class


Empty Method

[image]

One of William Foster's Class Libraries
StringExtension..::..Empty Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.Empty(System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void Empty(
    this string cs
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub Empty ( _
    cs As String _
)
Visual C++
[ExtensionAttribute]
public:
static void Empty(
    String^ cs
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.Empty(System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


FormatV Method

[image]

One of William Foster's Class Libraries
StringExtension..::..FormatV Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.FormatV(System.String,System.String,System.Object[])"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void FormatV(
    this string cs,
    string csFormat,
    params Object[] argList
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub FormatV ( _
    cs As String, _
    csFormat As String, _
    ParamArray argList As Object() _
)
Visual C++
[ExtensionAttribute]
public:
static void FormatV(
    String^ cs,
    String^ csFormat,
    ... array<Object^>^ argList
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.FormatV(System.String,System.String,System.Object[])"]

csFormat
Type: System..::..String

[Missing <param name="csFormat"/> documentation for "M:El.StringExtension.FormatV(System.String,System.String,System.Object[])"]

argList
Type: array< System..::..Object >[]()[][]

[Missing <param name="argList"/> documentation for "M:El.StringExtension.FormatV(System.String,System.String,System.Object[])"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


GetBytePtr Method

[image]

One of William Foster's Class Libraries
StringExtension..::..GetBytePtr Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.GetBytePtr(System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static byte[] GetBytePtr(
    this string cs
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetBytePtr ( _
    cs As String _
) As Byte()
Visual C++
[ExtensionAttribute]
public:
static array<unsigned char>^ GetBytePtr(
    String^ cs
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.GetBytePtr(System.String)"]

Return Value

[Missing <returns> documentation for "M:El.StringExtension.GetBytePtr(System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


GetLengthBytes Method

[image]

One of William Foster's Class Libraries
StringExtension..::..GetLengthBytes Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.GetLengthBytes(System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static uint GetLengthBytes(
    this string cs
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetLengthBytes ( _
    cs As String _
) As UInteger
Visual C++
[ExtensionAttribute]
public:
static unsigned int GetLengthBytes(
    String^ cs
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.GetLengthBytes(System.String)"]

Return Value

[Missing <returns> documentation for "M:El.StringExtension.GetLengthBytes(System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


GetPtr Method

[image]

One of William Foster's Class Libraries
StringExtension..::..GetPtr Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.GetPtr(System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static char[] GetPtr(
    this string cs
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetPtr ( _
    cs As String _
) As Char()
Visual C++
[ExtensionAttribute]
public:
static array<wchar_t>^ GetPtr(
    String^ cs
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.GetPtr(System.String)"]

Return Value

[Missing <returns> documentation for "M:El.StringExtension.GetPtr(System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


IsEmpty Method

[image]

One of William Foster's Class Libraries
StringExtension..::..IsEmpty Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.IsEmpty(System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool IsEmpty(
    this string cs
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsEmpty ( _
    cs As String _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool IsEmpty(
    String^ cs
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.IsEmpty(System.String)"]

Return Value

[Missing <returns> documentation for "M:El.StringExtension.IsEmpty(System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


Left Method

[image]

One of William Foster's Class Libraries
StringExtension..::..Left Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.Left(System.String,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static string Left(
    this string cs,
    uint uCount
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Left ( _
    cs As String, _
    uCount As UInteger _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ Left(
    String^ cs,
    unsigned int uCount
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.Left(System.String,System.UInt32)"]

uCount
Type: System..::..UInt32

[Missing <param name="uCount"/> documentation for "M:El.StringExtension.Left(System.String,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.StringExtension.Left(System.String,System.UInt32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


LeftFrom Method

[image]

One of William Foster's Class Libraries
StringExtension..::..LeftFrom Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.LeftFrom(System.String,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static string LeftFrom(
    this string cs,
    uint uIndex
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function LeftFrom ( _
    cs As String, _
    uIndex As UInteger _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ LeftFrom(
    String^ cs,
    unsigned int uIndex
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.LeftFrom(System.String,System.UInt32)"]

uIndex
Type: System..::..UInt32

[Missing <param name="uIndex"/> documentation for "M:El.StringExtension.LeftFrom(System.String,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.StringExtension.LeftFrom(System.String,System.UInt32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


LeftWord Method

[image]

One of William Foster's Class Libraries
StringExtension..::..LeftWord Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.LeftWord(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static STRING LeftWord(
    this STRING cs
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function LeftWord ( _
    cs As STRING _
) As STRING
Visual C++
[ExtensionAttribute]
public:
static STRING^ LeftWord(
    STRING^ cs
)

Parameters

cs
Type: El..::..STRING

[Missing <param name="cs"/> documentation for "M:El.StringExtension.LeftWord(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.StringExtension.LeftWord(El.STRING)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type STRING. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


ParseLines Method

[image]

One of William Foster's Class Libraries
StringExtension..::..ParseLines Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.ParseLines(System.String,System.UInt32,El.STRING@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static uint ParseLines(
    this string cs,
    uint u_Start,
    out STRING csNext
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function ParseLines ( _
    cs As String, _
    u_Start As UInteger, _
    <OutAttribute> ByRef csNext As STRING _
) As UInteger
Visual C++
[ExtensionAttribute]
public:
static unsigned int ParseLines(
    String^ cs,
    unsigned int u_Start,
    [OutAttribute] STRING^% csNext
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.ParseLines(System.String,System.UInt32,El.STRING@)"]

u_Start
Type: System..::..UInt32

[Missing <param name="u_Start"/> documentation for "M:El.StringExtension.ParseLines(System.String,System.UInt32,El.STRING@)"]

csNext
Type: El..::..STRING %

[Missing <param name="csNext"/> documentation for "M:El.StringExtension.ParseLines(System.String,System.UInt32,El.STRING@)"]

Return Value

[Missing <returns> documentation for "M:El.StringExtension.ParseLines(System.String,System.UInt32,El.STRING@)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


RemoveAt Method

[image]

One of William Foster's Class Libraries
StringExtension..::..RemoveAt Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.RemoveAt(System.String,System.Int32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void RemoveAt(
    this string cs,
    int uIndex
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub RemoveAt ( _
    cs As String, _
    uIndex As Integer _
)
Visual C++
[ExtensionAttribute]
public:
static void RemoveAt(
    String^ cs,
    int uIndex
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.RemoveAt(System.String,System.Int32)"]

uIndex
Type: System..::..Int32

[Missing <param name="uIndex"/> documentation for "M:El.StringExtension.RemoveAt(System.String,System.Int32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


RemoveWhitespace Method

[image]

One of William Foster's Class Libraries
StringExtension..::..RemoveWhitespace Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.RemoveWhitespace(System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void RemoveWhitespace(
    this string cs
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub RemoveWhitespace ( _
    cs As String _
)
Visual C++
[ExtensionAttribute]
public:
static void RemoveWhitespace(
    String^ cs
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.RemoveWhitespace(System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


RightFrom Method

[image]

One of William Foster's Class Libraries
StringExtension..::..RightFrom Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.RightFrom(System.String,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static string RightFrom(
    this string cs,
    uint uIndex
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function RightFrom ( _
    cs As String, _
    uIndex As UInteger _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ RightFrom(
    String^ cs,
    unsigned int uIndex
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.RightFrom(System.String,System.UInt32)"]

uIndex
Type: System..::..UInt32

[Missing <param name="uIndex"/> documentation for "M:El.StringExtension.RightFrom(System.String,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.StringExtension.RightFrom(System.String,System.UInt32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


Set Method

[image] [image]

One of William Foster's Class Libraries
StringExtension..::..Set Method
StringExtension Class See Also Send Feedback

Overload List

Name | Description
Set(String, array<Byte>[]()[][]) |
Set(String, String) |

See Also

StringExtension Class
StringExtension Members


Set Method (String, Byte[])

[image]

One of William Foster's Class Libraries
StringExtension..::..Set Method (String, array<Byte>[]()[][])
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.Set(System.String,System.Byte[])"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void Set(
    this string cs,
    byte[] bp
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub Set ( _
    cs As String, _
    bp As Byte() _
)
Visual C++
[ExtensionAttribute]
public:
static void Set(
    String^ cs,
    array<unsigned char>^ bp
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.Set(System.String,System.Byte[])"]

bp
Type: array< System..::..Byte >[]()[][]

[Missing <param name="bp"/> documentation for "M:El.StringExtension.Set(System.String,System.Byte[])"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class
Set Overload


Set Method (String, String)

[image]

One of William Foster's Class Libraries
StringExtension..::..Set Method (String, String)
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.Set(System.String,System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void Set(
    this string cs,
    string csnew
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub Set ( _
    cs As String, _
    csnew As String _
)
Visual C++
[ExtensionAttribute]
public:
static void Set(
    String^ cs,
    String^ csnew
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.Set(System.String,System.String)"]

csnew
Type: System..::..String

[Missing <param name="csnew"/> documentation for "M:El.StringExtension.Set(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class
Set Overload


SetAt Method

[image]

One of William Foster's Class Libraries
StringExtension..::..SetAt Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.SetAt(System.String,System.Char,System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void SetAt(
    this string cs,
    char c,
    uint uIndex
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetAt ( _
    cs As String, _
    c As Char, _
    uIndex As UInteger _
)
Visual C++
[ExtensionAttribute]
public:
static void SetAt(
    String^ cs,
    wchar_t c,
    unsigned int uIndex
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.SetAt(System.String,System.Char,System.UInt32)"]

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:El.StringExtension.SetAt(System.String,System.Char,System.UInt32)"]

uIndex
Type: System..::..UInt32

[Missing <param name="uIndex"/> documentation for "M:El.StringExtension.SetAt(System.String,System.Char,System.UInt32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


Substitute Method

[image]

One of William Foster's Class Libraries
StringExtension..::..Substitute Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.Substitute(System.String,El.STRING[],El.STRING[])"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool Substitute(
    this string cs,
    STRING[] substitute_array,
    STRING[] replace_array
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Substitute ( _
    cs As String, _
    substitute_array As STRING(), _
    replace_array As STRING() _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool Substitute(
    String^ cs,
    array<STRING^>^ substitute_array,
    array<STRING^>^ replace_array
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.Substitute(System.String,El.STRING[],El.STRING[])"]

substitute_array
Type: array< El..::..STRING >[]()[][]

[Missing <param name="substitute_array"/> documentation for "M:El.StringExtension.Substitute(System.String,El.STRING[],El.STRING[])"]

replace_array
Type: array< El..::..STRING >[]()[][]

[Missing <param name="replace_array"/> documentation for "M:El.StringExtension.Substitute(System.String,El.STRING[],El.STRING[])"]

Return Value

[Missing <returns> documentation for "M:El.StringExtension.Substitute(System.String,El.STRING[],El.STRING[])"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


ToUpperCase Method

[image]

One of William Foster's Class Libraries
StringExtension..::..ToUpperCase Method
StringExtension Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringExtension.ToUpperCase(System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static void ToUpperCase(
    this string cs
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub ToUpperCase ( _
    cs As String _
)
Visual C++
[ExtensionAttribute]
public:
static void ToUpperCase(
    String^ cs
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:El.StringExtension.ToUpperCase(System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

StringExtension Class


StringMap2d Class

[image]

One of William Foster's Class Libraries
StringMap2d Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.StringMap2d"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class StringMap2d
Visual Basic
Public Class StringMap2d
Visual C++
public ref class StringMap2d

Inheritance Hierarchy

System..::..Object
El..::..StringMap2d

See Also

StringMap2d Members


StringMap2d Members

[image] [image]

One of William Foster's Class Libraries
StringMap2d Members
StringMap2d Class Constructors Methods Fields Properties See Also Send Feedback

The StringMap2d type exposes the following members.

Constructors

 | Name | Description
Public method | StringMap2d | Initializes a new instance of the StringMap2d class

Methods

 | Name | Description
Public method | Add |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_dataArray |
Public field | m_indexArray |

Properties

 | Name | Description
Public property | Item |

See Also

StringMap2d Class


StringMap2d Constructor

[image]

One of William Foster's Class Libraries
StringMap2d Constructor
StringMap2d Class See Also Send Feedback
Initializes a new instance of the StringMap2d class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public StringMap2d()
Visual Basic
Public Sub New
Visual C++
public:
StringMap2d()

See Also

StringMap2d Class


StringMap2d Fields

[image] [image]

One of William Foster's Class Libraries
StringMap2d Fields
StringMap2d Class See Also Send Feedback

The StringMap2d type exposes the following members.

Fields

 | Name | Description
Public field | m_dataArray |
Public field | m_indexArray |

See Also

StringMap2d Class


m_dataArray Field

[image]

One of William Foster's Class Libraries
StringMap2d..::..m_dataArray Field
StringMap2d Class See Also Send Feedback

[Missing <summary> documentation for "F:El.StringMap2d.m_dataArray"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Array<string> m_dataArray
Visual Basic
Public m_dataArray As Array(Of String)
Visual C++
public:
Array<String^>^ m_dataArray

See Also

StringMap2d Class


m_indexArray Field

[image]

One of William Foster's Class Libraries
StringMap2d..::..m_indexArray Field
StringMap2d Class See Also Send Feedback

[Missing <summary> documentation for "F:El.StringMap2d.m_indexArray"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Array<string> m_indexArray
Visual Basic
Public m_indexArray As Array(Of String)
Visual C++
public:
Array<String^>^ m_indexArray

See Also

StringMap2d Class


StringMap2d Methods

[image] [image]

One of William Foster's Class Libraries
StringMap2d Methods
StringMap2d Class See Also Send Feedback

The StringMap2d type exposes the following members.

Methods

 | Name | Description
Public method | Add |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringMap2d Class


Add Method

[image]

One of William Foster's Class Libraries
StringMap2d..::..Add Method
StringMap2d Class See Also Send Feedback

[Missing <summary> documentation for "M:El.StringMap2d.Add(System.String,System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool Add(
    string key,
    string data
)
Visual Basic
Public Function Add ( _
    key As String, _
    data As String _
) As Boolean
Visual C++
public:
bool Add(
    String^ key,
    String^ data
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:El.StringMap2d.Add(System.String,System.String)"]

data
Type: System..::..String

[Missing <param name="data"/> documentation for "M:El.StringMap2d.Add(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:El.StringMap2d.Add(System.String,System.String)"]

See Also

StringMap2d Class


StringMap2d Properties

[image] [image]

One of William Foster's Class Libraries
StringMap2d Properties
StringMap2d Class See Also Send Feedback

The StringMap2d type exposes the following members.

Properties

 | Name | Description
Public property | Item |

See Also

StringMap2d Class


Item Property

[image]

One of William Foster's Class Libraries
StringMap2d..::..Item Property
StringMap2d Class See Also Send Feedback

[Missing <summary> documentation for "P:El.StringMap2d.Item(System.String)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public string this[
    string icKey
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    icKey As String _
) As String
    Get
Visual C++
public:
property String^ default[String^ icKey] {
    String^ get (String^ icKey);
}

Parameters

icKey
Type: System..::..String

See Also

StringMap2d Class


Value Class

[image]

One of William Foster's Class Libraries
Value Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:El.Value"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public class Value
Visual Basic
Public Class Value
Visual C++
public ref class Value

Inheritance Hierarchy

System..::..Object
El..::..Value
El..::..CBfc_Angle
El..::..Distance

See Also

Value Members


Value Members

[image] [image]

One of William Foster's Class Libraries
Value Members
Value Class Constructors Methods Operators Fields See Also Send Feedback

The Value type exposes the following members.

Constructors

 | Name | Description
Public method | Value()()()() | Initializes a new instance of the Value class
Public method | Value(Double) | Initializes a new instance of the Value class
Public method | Value(Int32) | Initializes a new instance of the Value class
Public method | Value(UInt32) | Initializes a new instance of the Value class
Public method | Value(Value) | Initializes a new instance of the Value class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue_double |
Public method | GetValue_int |
Public method | GetValue_uint |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToString |
Public method | SetFromString |
Public method | SetValue(Double) |
Public method | SetValue(Int32) |
Public method | SetValue(UInt32) |
Public method | SetValue(Value) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Addition |
Division |
Equality |
GreaterThan |
GreaterThanOrEqual |
ImplicitWideningImplicitImplicitImplicit(Double to Value) |
ImplicitWideningImplicitImplicitImplicit(Int32 to Value) |
ImplicitWideningImplicitImplicitImplicit(UInt32 to Value) |
ImplicitWideningImplicitImplicitImplicit(Value to UInt32) |
ImplicitWideningImplicitImplicitImplicit(Value to Double) |
Inequality |
LessThan |
LessThanOrEqual |
Multiply |
Subtraction |

Fields

 | Name | Description
Public field | m_d_value |

See Also

Value Class


Value Constructor

[image] [image]

One of William Foster's Class Libraries
Value Constructor
Value Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Value()()()() | Initializes a new instance of the Value class
Public method | Value(Double) | Initializes a new instance of the Value class
Public method | Value(Int32) | Initializes a new instance of the Value class
Public method | Value(UInt32) | Initializes a new instance of the Value class
Public method | Value(Value) | Initializes a new instance of the Value class

See Also

Value Class
Value Members


Value Constructor

[image]

One of William Foster's Class Libraries
Value Constructor
Value Class See Also Send Feedback
Initializes a new instance of the Value class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Value()
Visual Basic
Public Sub New
Visual C++
public:
Value()

See Also

Value Class
Value Overload


Value Constructor (Double)

[image]

One of William Foster's Class Libraries
Value Constructor (Double)
Value Class See Also Send Feedback
Initializes a new instance of the Value class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Value(
    double d
)
Visual Basic
Public Sub New ( _
    d As Double _
)
Visual C++
public:
Value(
    double d
)

Parameters

d
Type: System..::..Double

[Missing <param name="d"/> documentation for "M:El.Value.#ctor(System.Double)"]

See Also

Value Class
Value Overload


Value Constructor (Int32)

[image]

One of William Foster's Class Libraries
Value Constructor (Int32)
Value Class See Also Send Feedback
Initializes a new instance of the Value class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Value(
    int i
)
Visual Basic
Public Sub New ( _
    i As Integer _
)
Visual C++
public:
Value(
    int i
)

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:El.Value.#ctor(System.Int32)"]

See Also

Value Class
Value Overload


Value Constructor (UInt32)

[image]

One of William Foster's Class Libraries
Value Constructor (UInt32)
Value Class See Also Send Feedback
Initializes a new instance of the Value class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Value(
    uint u
)
Visual Basic
Public Sub New ( _
    u As UInteger _
)
Visual C++
public:
Value(
    unsigned int u
)

Parameters

u
Type: System..::..UInt32

[Missing <param name="u"/> documentation for "M:El.Value.#ctor(System.UInt32)"]

See Also

Value Class
Value Overload


Value Constructor (Value)

[image]

One of William Foster's Class Libraries
Value Constructor (Value)
Value Class See Also Send Feedback
Initializes a new instance of the Value class

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public Value(
    Value value
)
Visual Basic
Public Sub New ( _
    value As Value _
)
Visual C++
public:
Value(
    Value^ value
)

Parameters

value
Type: El..::..Value

[Missing <param name="value"/> documentation for "M:El.Value.#ctor(El.Value)"]

See Also

Value Class
Value Overload


Value Fields

[image] [image]

One of William Foster's Class Libraries
Value Fields
Value Class See Also Send Feedback

The Value type exposes the following members.

Fields

 | Name | Description
Public field | m_d_value |

See Also

Value Class


m_d_value Field

[image]

One of William Foster's Class Libraries
Value..::..m_d_value Field
Value Class See Also Send Feedback

[Missing <summary> documentation for "F:El.Value.m_d_value"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public double m_d_value
Visual Basic
Public m_d_value As Double
Visual C++
public:
double m_d_value

See Also

Value Class


Value Methods

[image] [image]

One of William Foster's Class Libraries
Value Methods
Value Class See Also Send Feedback

The Value type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue_double |
Public method | GetValue_int |
Public method | GetValue_uint |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToString |
Public method | SetFromString |
Public method | SetValue(Double) |
Public method | SetValue(Int32) |
Public method | SetValue(UInt32) |
Public method | SetValue(Value) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Value Class


GetValue_double Method

[image]

One of William Foster's Class Libraries
Value..::..GetValue_double Method
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.GetValue_double"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public double GetValue_double()
Visual Basic
Public Function GetValue_double As Double
Visual C++
public:
double GetValue_double()

Return Value

[Missing <returns> documentation for "M:El.Value.GetValue_double"]

See Also

Value Class


GetValue_int Method

[image]

One of William Foster's Class Libraries
Value..::..GetValue_int Method
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.GetValue_int"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public int GetValue_int()
Visual Basic
Public Function GetValue_int As Integer
Visual C++
public:
int GetValue_int()

Return Value

[Missing <returns> documentation for "M:El.Value.GetValue_int"]

See Also

Value Class


GetValue_uint Method

[image]

One of William Foster's Class Libraries
Value..::..GetValue_uint Method
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.GetValue_uint"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public uint GetValue_uint()
Visual Basic
Public Function GetValue_uint As UInteger
Visual C++
public:
unsigned int GetValue_uint()

Return Value

[Missing <returns> documentation for "M:El.Value.GetValue_uint"]

See Also

Value Class


RenderToString Method

[image]

One of William Foster's Class Libraries
Value..::..RenderToString Method
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.RenderToString(El.STRING@)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool RenderToString(
    out STRING str_out
)
Visual Basic
Public Function RenderToString ( _
    <OutAttribute> ByRef str_out As STRING _
) As Boolean
Visual C++
public:
bool RenderToString(
    [OutAttribute] STRING^% str_out
)

Parameters

str_out
Type: El..::..STRING %

[Missing <param name="str_out"/> documentation for "M:El.Value.RenderToString(El.STRING@)"]

Return Value

[Missing <returns> documentation for "M:El.Value.RenderToString(El.STRING@)"]

See Also

Value Class


SetFromString Method

[image]

One of William Foster's Class Libraries
Value..::..SetFromString Method
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.SetFromString(El.STRING)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool SetFromString(
    STRING s
)
Visual Basic
Public Function SetFromString ( _
    s As STRING _
) As Boolean
Visual C++
public:
bool SetFromString(
    STRING^ s
)

Parameters

s
Type: El..::..STRING

[Missing <param name="s"/> documentation for "M:El.Value.SetFromString(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:El.Value.SetFromString(El.STRING)"]

See Also

Value Class


SetValue Method

[image] [image]

One of William Foster's Class Libraries
Value..::..SetValue Method
Value Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(Double) |
Public method | SetValue(Int32) |
Public method | SetValue(UInt32) |
Public method | SetValue(Value) |

See Also

Value Class
Value Members


SetValue Method (Double)

[image]

One of William Foster's Class Libraries
Value..::..SetValue Method (Double)
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.SetValue(System.Double)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool SetValue(
    double d
)
Visual Basic
Public Function SetValue ( _
    d As Double _
) As Boolean
Visual C++
public:
bool SetValue(
    double d
)

Parameters

d
Type: System..::..Double

[Missing <param name="d"/> documentation for "M:El.Value.SetValue(System.Double)"]

Return Value

[Missing <returns> documentation for "M:El.Value.SetValue(System.Double)"]

See Also

Value Class
SetValue Overload


SetValue Method (Int32)

[image]

One of William Foster's Class Libraries
Value..::..SetValue Method (Int32)
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.SetValue(System.Int32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool SetValue(
    int i
)
Visual Basic
Public Function SetValue ( _
    i As Integer _
) As Boolean
Visual C++
public:
bool SetValue(
    int i
)

Parameters

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:El.Value.SetValue(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:El.Value.SetValue(System.Int32)"]

See Also

Value Class
SetValue Overload


SetValue Method (UInt32)

[image]

One of William Foster's Class Libraries
Value..::..SetValue Method (UInt32)
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.SetValue(System.UInt32)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool SetValue(
    uint u
)
Visual Basic
Public Function SetValue ( _
    u As UInteger _
) As Boolean
Visual C++
public:
bool SetValue(
    unsigned int u
)

Parameters

u
Type: System..::..UInt32

[Missing <param name="u"/> documentation for "M:El.Value.SetValue(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:El.Value.SetValue(System.UInt32)"]

See Also

Value Class
SetValue Overload


SetValue Method (Value)

[image]

One of William Foster's Class Libraries
Value..::..SetValue Method (Value)
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.SetValue(El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public bool SetValue(
    Value value
)
Visual Basic
Public Function SetValue ( _
    value As Value _
) As Boolean
Visual C++
public:
bool SetValue(
    Value^ value
)

Parameters

value
Type: El..::..Value

[Missing <param name="value"/> documentation for "M:El.Value.SetValue(El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Value.SetValue(El.Value)"]

See Also

Value Class
SetValue Overload


Value Operators and Type Conversions

[image] [image]

One of William Foster's Class Libraries
Value Operators and Type Conversions
Value Class See Also Send Feedback

The Value type exposes the following members.

Operators

Name | Description
Addition |
Division |
Equality |
GreaterThan |
GreaterThanOrEqual |
ImplicitWideningImplicitImplicitImplicit(Double to Value) |
ImplicitWideningImplicitImplicitImplicit(Int32 to Value) |
ImplicitWideningImplicitImplicitImplicit(UInt32 to Value) |
ImplicitWideningImplicitImplicitImplicit(Value to UInt32) |
ImplicitWideningImplicitImplicitImplicit(Value to Double) |
Inequality |
LessThan |
LessThanOrEqual |
Multiply |
Subtraction |

See Also

Value Class


Addition Operator

[image]

One of William Foster's Class Libraries
Value..::..Addition Operator
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_Addition(El.Value,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Value operator +(
    Value v,
    Value addValue
)
Visual Basic
Public Shared Operator + ( _
    v As Value, _
    addValue As Value _
) As Value
Visual C++
public:
static Value^ operator +(
    Value^ v,
    Value^ addValue
)

Parameters

v
Type: El..::..Value

[Missing <param name="v"/> documentation for "M:El.Value.op_Addition(El.Value,El.Value)"]

addValue
Type: El..::..Value

[Missing <param name="addValue"/> documentation for "M:El.Value.op_Addition(El.Value,El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_Addition(El.Value,El.Value)"]

See Also

Value Class


Division Operator

[image]

One of William Foster's Class Libraries
Value..::..Division Operator
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_Division(El.Value,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Value operator /(
    Value v,
    Value divValue
)
Visual Basic
Public Shared Operator / ( _
    v As Value, _
    divValue As Value _
) As Value
Visual C++
public:
static Value^ operator /(
    Value^ v,
    Value^ divValue
)

Parameters

v
Type: El..::..Value

[Missing <param name="v"/> documentation for "M:El.Value.op_Division(El.Value,El.Value)"]

divValue
Type: El..::..Value

[Missing <param name="divValue"/> documentation for "M:El.Value.op_Division(El.Value,El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_Division(El.Value,El.Value)"]

See Also

Value Class


Equality Operator

[image]

One of William Foster's Class Libraries
Value..::..Equality Operator
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_Equality(El.Value,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator ==(
    Value val,
    Value eqeqValue
)
Visual Basic
Public Shared Operator = ( _
    val As Value, _
    eqeqValue As Value _
) As Boolean
Visual C++
public:
static bool operator ==(
    Value^ val,
    Value^ eqeqValue
)

Parameters

val
Type: El..::..Value

[Missing <param name="val"/> documentation for "M:El.Value.op_Equality(El.Value,El.Value)"]

eqeqValue
Type: El..::..Value

[Missing <param name="eqeqValue"/> documentation for "M:El.Value.op_Equality(El.Value,El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_Equality(El.Value,El.Value)"]

See Also

Value Class


GreaterThan Operator

[image]

One of William Foster's Class Libraries
Value..::..GreaterThan Operator
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_GreaterThan(El.Value,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator >(
    Value v,
    Value greaterthanValue
)
Visual Basic
Public Shared Operator > ( _
    v As Value, _
    greaterthanValue As Value _
) As Boolean
Visual C++
public:
static bool operator >(
    Value^ v,
    Value^ greaterthanValue
)

Parameters

v
Type: El..::..Value

[Missing <param name="v"/> documentation for "M:El.Value.op_GreaterThan(El.Value,El.Value)"]

greaterthanValue
Type: El..::..Value

[Missing <param name="greaterthanValue"/> documentation for "M:El.Value.op_GreaterThan(El.Value,El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_GreaterThan(El.Value,El.Value)"]

See Also

Value Class


GreaterThanOrEqual Operator

[image]

One of William Foster's Class Libraries
Value..::..GreaterThanOrEqual Operator
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_GreaterThanOrEqual(El.Value,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator >=(
    Value v,
    Value greaterthanValue
)
Visual Basic
Public Shared Operator >= ( _
    v As Value, _
    greaterthanValue As Value _
) As Boolean
Visual C++
public:
static bool operator >=(
    Value^ v,
    Value^ greaterthanValue
)

Parameters

v
Type: El..::..Value

[Missing <param name="v"/> documentation for "M:El.Value.op_GreaterThanOrEqual(El.Value,El.Value)"]

greaterthanValue
Type: El..::..Value

[Missing <param name="greaterthanValue"/> documentation for "M:El.Value.op_GreaterThanOrEqual(El.Value,El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_GreaterThanOrEqual(El.Value,El.Value)"]

See Also

Value Class


Implicit Conversion Operators

[image] [image]

One of William Foster's Class Libraries
Value ImplicitWideningImplicitImplicitImplicit Conversion Operators
Value Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(Double to Value) |
ImplicitWideningImplicitImplicitImplicit(Int32 to Value) |
ImplicitWideningImplicitImplicitImplicit(UInt32 to Value) |
ImplicitWideningImplicitImplicitImplicit(Value to UInt32) |
ImplicitWideningImplicitImplicitImplicit(Value to Double) |

See Also

Value Class
Value Members


Implicit Conversion (Double to Value)

[image]

One of William Foster's Class Libraries
Value ImplicitWideningImplicitImplicitImplicit Conversion (Double to Value)
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_Implicit(System.Double)~El.Value"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator Value (
    double val
)
Visual Basic
Public Shared Widening Operator CType ( _
    val As Double _
) As Value
Visual C++
static implicit operator Value^ (
    double val
)

Parameters

val
Type: System..::..Double

[Missing <param name="val"/> documentation for "M:El.Value.op_Implicit(System.Double)~El.Value"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_Implicit(System.Double)~El.Value"]

See Also

Value Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (Int32 to Value)

[image]

One of William Foster's Class Libraries
Value ImplicitWideningImplicitImplicitImplicit Conversion (Int32 to Value)
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_Implicit(System.Int32)~El.Value"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator Value (
    int val
)
Visual Basic
Public Shared Widening Operator CType ( _
    val As Integer _
) As Value
Visual C++
static implicit operator Value^ (
    int val
)

Parameters

val
Type: System..::..Int32

[Missing <param name="val"/> documentation for "M:El.Value.op_Implicit(System.Int32)~El.Value"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_Implicit(System.Int32)~El.Value"]

See Also

Value Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (UInt32 to Value)

[image]

One of William Foster's Class Libraries
Value ImplicitWideningImplicitImplicitImplicit Conversion (UInt32 to Value)
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_Implicit(System.UInt32)~El.Value"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator Value (
    uint val
)
Visual Basic
Public Shared Widening Operator CType ( _
    val As UInteger _
) As Value
Visual C++
static implicit operator Value^ (
    unsigned int val
)

Parameters

val
Type: System..::..UInt32

[Missing <param name="val"/> documentation for "M:El.Value.op_Implicit(System.UInt32)~El.Value"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_Implicit(System.UInt32)~El.Value"]

See Also

Value Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (Value to UInt32)

[image]

One of William Foster's Class Libraries
Value ImplicitWideningImplicitImplicitImplicit Conversion (Value to UInt32)
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_Implicit(El.Value)~System.UInt32"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator uint (
    Value val
)
Visual Basic
Public Shared Widening Operator CType ( _
    val As Value _
) As UInteger
Visual C++
static implicit operator unsigned int (
    Value^ val
)

Parameters

val
Type: El..::..Value

[Missing <param name="val"/> documentation for "M:El.Value.op_Implicit(El.Value)~System.UInt32"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_Implicit(El.Value)~System.UInt32"]

See Also

Value Class
ImplicitWideningImplicitImplicitImplicit Overload


Implicit Conversion (Value to Double)

[image]

One of William Foster's Class Libraries
Value ImplicitWideningImplicitImplicitImplicit Conversion (Value to Double)
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_Implicit(El.Value)~System.Double"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static implicit operator double (
    Value val
)
Visual Basic
Public Shared Widening Operator CType ( _
    val As Value _
) As Double
Visual C++
static implicit operator double (
    Value^ val
)

Parameters

val
Type: El..::..Value

[Missing <param name="val"/> documentation for "M:El.Value.op_Implicit(El.Value)~System.Double"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_Implicit(El.Value)~System.Double"]

See Also

Value Class
ImplicitWideningImplicitImplicitImplicit Overload


Inequality Operator

[image]

One of William Foster's Class Libraries
Value..::..Inequality Operator
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_Inequality(El.Value,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator !=(
    Value val,
    Value eqeqValue
)
Visual Basic
Public Shared Operator <> ( _
    val As Value, _
    eqeqValue As Value _
) As Boolean
Visual C++
public:
static bool operator !=(
    Value^ val,
    Value^ eqeqValue
)

Parameters

val
Type: El..::..Value

[Missing <param name="val"/> documentation for "M:El.Value.op_Inequality(El.Value,El.Value)"]

eqeqValue
Type: El..::..Value

[Missing <param name="eqeqValue"/> documentation for "M:El.Value.op_Inequality(El.Value,El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_Inequality(El.Value,El.Value)"]

See Also

Value Class


LessThan Operator

[image]

One of William Foster's Class Libraries
Value..::..LessThan Operator
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_LessThan(El.Value,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator <(
    Value v,
    Value lessthanValue
)
Visual Basic
Public Shared Operator < ( _
    v As Value, _
    lessthanValue As Value _
) As Boolean
Visual C++
public:
static bool operator <(
    Value^ v,
    Value^ lessthanValue
)

Parameters

v
Type: El..::..Value

[Missing <param name="v"/> documentation for "M:El.Value.op_LessThan(El.Value,El.Value)"]

lessthanValue
Type: El..::..Value

[Missing <param name="lessthanValue"/> documentation for "M:El.Value.op_LessThan(El.Value,El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_LessThan(El.Value,El.Value)"]

See Also

Value Class


LessThanOrEqual Operator

[image]

One of William Foster's Class Libraries
Value..::..LessThanOrEqual Operator
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_LessThanOrEqual(El.Value,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static bool operator <=(
    Value v,
    Value lessthanValue
)
Visual Basic
Public Shared Operator <= ( _
    v As Value, _
    lessthanValue As Value _
) As Boolean
Visual C++
public:
static bool operator <=(
    Value^ v,
    Value^ lessthanValue
)

Parameters

v
Type: El..::..Value

[Missing <param name="v"/> documentation for "M:El.Value.op_LessThanOrEqual(El.Value,El.Value)"]

lessthanValue
Type: El..::..Value

[Missing <param name="lessthanValue"/> documentation for "M:El.Value.op_LessThanOrEqual(El.Value,El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_LessThanOrEqual(El.Value,El.Value)"]

See Also

Value Class


Multiply Operator

[image]

One of William Foster's Class Libraries
Value..::..Multiply Operator
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_Multiply(El.Value,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Value operator *(
    Value v,
    Value mulValue
)
Visual Basic
Public Shared Operator * ( _
    v As Value, _
    mulValue As Value _
) As Value
Visual C++
public:
static Value^ operator *(
    Value^ v,
    Value^ mulValue
)

Parameters

v
Type: El..::..Value

[Missing <param name="v"/> documentation for "M:El.Value.op_Multiply(El.Value,El.Value)"]

mulValue
Type: El..::..Value

[Missing <param name="mulValue"/> documentation for "M:El.Value.op_Multiply(El.Value,El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_Multiply(El.Value,El.Value)"]

See Also

Value Class


Subtraction Operator

[image]

One of William Foster's Class Libraries
Value..::..Subtraction Operator
Value Class See Also Send Feedback

[Missing <summary> documentation for "M:El.Value.op_Subtraction(El.Value,El.Value)"]

Namespace: El
Assembly: El (in El.dll) Version: 1.0.0.0

Syntax

C#
public static Value operator -(
    Value v,
    Value subValue
)
Visual Basic
Public Shared Operator - ( _
    v As Value, _
    subValue As Value _
) As Value
Visual C++
public:
static Value^ operator -(
    Value^ v,
    Value^ subValue
)

Parameters

v
Type: El..::..Value

[Missing <param name="v"/> documentation for "M:El.Value.op_Subtraction(El.Value,El.Value)"]

subValue
Type: El..::..Value

[Missing <param name="subValue"/> documentation for "M:El.Value.op_Subtraction(El.Value,El.Value)"]

Return Value

[Missing <returns> documentation for "M:El.Value.op_Subtraction(El.Value,El.Value)"]

See Also

Value Class