ElGUI Namespace

[image]

4 of William Foster's Class Libraries
ElGUI Namespace
Send Feedback

[Missing <summary> documentation for "N:ElGUI"]

Classes

 | Class | Description
Public class | ActionDP |
Public class | Brush |
Public class | Brush_Effect |
Public class | Brush_Image |
Public class | Brush_Solid |
Public class | Button |
Public class | CDefault_DlgDP |
Public class | ComboBox |
Public class | CSys_ButtonControl |
Public class | CSys_CheckBoxControl |
Public class | CSys_ChildWindow |
Public class | CSys_ComboControl |
Public class | CSys_ControlWindow |
Public class | CSys_DialogWindow |
Public class | CSys_LabelControl |
Public class | CSys_ListboxControl |
Public class | CSys_ListControl |
Public class | CSys_MainWindow |
Public class | CSys_RadioButtonControl |
Public class | CSys_SliderControl |
Public class | CSys_Tab |
Public class | CSys_TextboxControl |
Public class | CSys_TextControl |
Public class | CSys_Toolbar |
Public class | CSys_TopWindow |
Public class | CTerminalWindow |
Public class | CursesBox |
Public class | CursesWindow |
Public class | Data_Resource_Control |
Public class | DataSource |
Public class | DialogWindow |
Public class | DlgDP |
Public class | DP |
Public class | DX | The DX, or DataExchange Class is the baseclass for a set of data This dataset is used by both by various DS (DataSources) and also DP (DataProcessors). The DS interacts to fill in the DX with appropriate parameters, and then the DP acts using the values describes by the DX.
Public class | EditInterface |
Public class | GetcWindow |
Public class | GetlineWindow |
Public class | GUI |
Public class | Label |
Public class | ListBox |
Public class | ListControl |
Public class | ListRC |
Public class | MarchingAnts |
Public class | MarchingAnts_Rectangle |
Public class | Menu |
Public class | MenuEntry |
Public class | MenuWindow |
Public class | Message |
Public class | MessageBox |
Public class | ProgressControl |
Public class | ProgressMeter |
Public class | Registry |
Public class | Resource_Control |
Public class | ResourceAttributes |
Public class | ResourceContainer |
Public class | ResourceEntity |
Public class | ResourceEvent |
Public class | ResourceHandler |
Public class | ResourceStore |
Public class | ResourceWindow |
Public class | ScriptResource |
Public class | Slider |
Public class | TextBox |
Public class | TextData_Resource_Control |
Public class | ToolBar |
Public class | ToolbarDP | This simple DlgDP just stores the last selected button information. It is the responsibility of the application to read this data when (before) it uses the tool. Derive from this DP to make one that will feed your windows with the result.
Public class | UILayerWindow |
Public class | Window |

Structures

 | Structure | Description
Public structure | DXEntry |

Interfaces

 | Interface | Description
Public interface | ITerminalWindow |

Enumerations

 | Enumeration | Description
Public enumeration | ALIGNMENT_KEY |
Public enumeration | Brush..::..EBrushType |
Public enumeration | CURSOR |
Public enumeration | EBFC_GUIRES_ATTRIBUTE_KEY |
Public enumeration | EBFC_GUIRES_HANDLER_KEY |
Public enumeration | EBFC_GUIRES_RESOURCE_KEY |
Public enumeration | EBFC_GUIRES_RESOURCE_SHAPE_KEY |
Public enumeration | EDXFieldType |
Public enumeration | EKeyCode |
Public enumeration | EKeys |
Public enumeration | Message..::..EMessage_ID |
Public enumeration | Resource_ID |
Public enumeration | ResourceEvent..::..EVENT |
Public enumeration | WINDOW_TYPE |
Public enumeration | WM | Windows Messages Defined in winuser.h from Windows SDK v6.1 Documentation pulled from MSDN.

Send comments on this topic to bill@software-imagination.com

Copyright (C) 2011 by William P. Foster, all rights reserved.


ActionDP Class

[image]

4 of William Foster's Class Libraries
ActionDP Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ActionDP"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class ActionDP : DP
Visual Basic
Public MustInherit Class ActionDP _
    Inherits DP
Visual C++
public ref class ActionDP abstract : public DP

Inheritance Hierarchy

System..::..Object
ElGUI..::..DP
ElGUI..::..ActionDP
ElImage..::..ImageActionDP

See Also

ActionDP Members
ElGUI Namespace


ActionDP Members

[image] [image]

4 of William Foster's Class Libraries
ActionDP Members
ActionDP Class Constructors Methods Fields Properties See Also Send Feedback

The ActionDP type exposes the following members.

Constructors

 | Name | Description
Public method | ActionDP | Initializes a new instance of the ActionDP class

Methods

 | Name | Description
Public method | ApplyAction |
Public method | CombineAction |
Public method | CompletedAction |
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Dup |
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformAction |
Public method | Preview | (Inherited from DP.)
Public method | PreviewAction |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UndoAction |

Fields

 | Name | Description
Public field | m_combinable |
Public field | m_name |
Public field | m_undoable |

Properties

 | Name | Description
Public property | Name |

See Also

ActionDP Class
ElGUI Namespace


ActionDP Constructor

[image]

4 of William Foster's Class Libraries
ActionDP Constructor
ActionDP Class See Also Send Feedback
Initializes a new instance of the ActionDP class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ActionDP(
    string name,
    DX dx
)
Visual Basic
Public Sub New ( _
    name As String, _
    dx As DX _
)
Visual C++
public:
ActionDP(
    String^ name,
    DX^ dx
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ElGUI.ActionDP.#ctor(System.String,ElGUI.DX)"]

dx
Type: ElGUI..::..DX

[Missing <param name="dx"/> documentation for "M:ElGUI.ActionDP.#ctor(System.String,ElGUI.DX)"]

See Also

ActionDP Class
ElGUI Namespace


ActionDP Fields

[image] [image]

4 of William Foster's Class Libraries
ActionDP Fields
ActionDP Class See Also Send Feedback

The ActionDP type exposes the following members.

Fields

 | Name | Description
Public field | m_combinable |
Public field | m_name |
Public field | m_undoable |

See Also

ActionDP Class
ElGUI Namespace


m_combinable Field

[image]

4 of William Foster's Class Libraries
ActionDP..::..m_combinable Field
ActionDP Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ActionDP.m_combinable"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool m_combinable
Visual Basic
Public m_combinable As Boolean
Visual C++
public:
bool m_combinable

See Also

ActionDP Class
ElGUI Namespace


m_name Field

[image]

4 of William Foster's Class Libraries
ActionDP..::..m_name Field
ActionDP Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ActionDP.m_name"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_name
Visual Basic
Public m_name As String
Visual C++
public:
String^ m_name

See Also

ActionDP Class
ElGUI Namespace


m_undoable Field

[image]

4 of William Foster's Class Libraries
ActionDP..::..m_undoable Field
ActionDP Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ActionDP.m_undoable"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool m_undoable
Visual Basic
Public m_undoable As Boolean
Visual C++
public:
bool m_undoable

See Also

ActionDP Class
ElGUI Namespace


ActionDP Methods

[image] [image]

4 of William Foster's Class Libraries
ActionDP Methods
ActionDP Class See Also Send Feedback

The ActionDP type exposes the following members.

Methods

 | Name | Description
Public method | ApplyAction |
Public method | CombineAction |
Public method | CompletedAction |
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Dup |
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformAction |
Public method | Preview | (Inherited from DP.)
Public method | PreviewAction |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UndoAction |

See Also

ActionDP Class
ElGUI Namespace


ApplyAction Method

[image]

4 of William Foster's Class Libraries
ActionDP..::..ApplyAction Method
ActionDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ActionDP.ApplyAction"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ApplyAction()
Visual Basic
Public Function ApplyAction As Boolean
Visual C++
public:
bool ApplyAction()

Return Value

[Missing <returns> documentation for "M:ElGUI.ActionDP.ApplyAction"]

See Also

ActionDP Class
ElGUI Namespace


CombineAction Method

[image]

4 of William Foster's Class Libraries
ActionDP..::..CombineAction Method
ActionDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ActionDP.CombineAction(ElGUI.ActionDP,System.Boolean@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool CombineAction(
    ActionDP comb,
    out bool b_remove
)
Visual Basic
Public Overridable Function CombineAction ( _
    comb As ActionDP, _
    <OutAttribute> ByRef b_remove As Boolean _
) As Boolean
Visual C++
public:
virtual bool CombineAction(
    ActionDP^ comb,
    [OutAttribute] bool% b_remove
)

Parameters

comb
Type: ElGUI..::..ActionDP

[Missing <param name="comb"/> documentation for "M:ElGUI.ActionDP.CombineAction(ElGUI.ActionDP,System.Boolean@)"]

b_remove
Type: System..::..Boolean %

[Missing <param name="b_remove"/> documentation for "M:ElGUI.ActionDP.CombineAction(ElGUI.ActionDP,System.Boolean@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ActionDP.CombineAction(ElGUI.ActionDP,System.Boolean@)"]

See Also

ActionDP Class
ElGUI Namespace


CompletedAction Method

[image]

4 of William Foster's Class Libraries
ActionDP..::..CompletedAction Method
ActionDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ActionDP.CompletedAction(System.Boolean)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void CompletedAction(
    bool bActionTaken
)
Visual Basic
Public MustOverride Sub CompletedAction ( _
    bActionTaken As Boolean _
)
Visual C++
public:
virtual void CompletedAction(
    bool bActionTaken
) abstract

Parameters

bActionTaken
Type: System..::..Boolean

[Missing <param name="bActionTaken"/> documentation for "M:ElGUI.ActionDP.CompletedAction(System.Boolean)"]

See Also

ActionDP Class
ElGUI Namespace


Dup Method

[image]

4 of William Foster's Class Libraries
ActionDP..::..Dup Method
ActionDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ActionDP.Dup"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract ActionDP Dup()
Visual Basic
Public MustOverride Function Dup As ActionDP
Visual C++
public:
virtual ActionDP^ Dup() abstract

Return Value

[Missing <returns> documentation for "M:ElGUI.ActionDP.Dup"]

See Also

ActionDP Class
ElGUI Namespace


PerformAction Method

[image]

4 of William Foster's Class Libraries
ActionDP..::..PerformAction Method
ActionDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ActionDP.PerformAction(System.Boolean@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract bool PerformAction(
    out bool bModified
)
Visual Basic
Public MustOverride Function PerformAction ( _
    <OutAttribute> ByRef bModified As Boolean _
) As Boolean
Visual C++
public:
virtual bool PerformAction(
    [OutAttribute] bool% bModified
) abstract

Parameters

bModified
Type: System..::..Boolean %

[Missing <param name="bModified"/> documentation for "M:ElGUI.ActionDP.PerformAction(System.Boolean@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ActionDP.PerformAction(System.Boolean@)"]

See Also

ActionDP Class
ElGUI Namespace


PreviewAction Method

[image]

4 of William Foster's Class Libraries
ActionDP..::..PreviewAction Method
ActionDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ActionDP.PreviewAction"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool PreviewAction()
Visual Basic
Public Function PreviewAction As Boolean
Visual C++
public:
bool PreviewAction()

Return Value

[Missing <returns> documentation for "M:ElGUI.ActionDP.PreviewAction"]

See Also

ActionDP Class
ElGUI Namespace


UndoAction Method

[image]

4 of William Foster's Class Libraries
ActionDP..::..UndoAction Method
ActionDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ActionDP.UndoAction"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool UndoAction()
Visual Basic
Public Overridable Function UndoAction As Boolean
Visual C++
public:
virtual bool UndoAction()

Return Value

[Missing <returns> documentation for "M:ElGUI.ActionDP.UndoAction"]

See Also

ActionDP Class
ElGUI Namespace


ActionDP Properties

[image] [image]

4 of William Foster's Class Libraries
ActionDP Properties
ActionDP Class See Also Send Feedback

The ActionDP type exposes the following members.

Properties

 | Name | Description
Public property | Name |

See Also

ActionDP Class
ElGUI Namespace


Name Property

[image]

4 of William Foster's Class Libraries
ActionDP..::..Name Property
ActionDP Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.ActionDP.Name"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

See Also

ActionDP Class
ElGUI Namespace


ALIGNMENT_KEY Enumeration

[image]

4 of William Foster's Class Libraries
ALIGNMENT_KEY Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ALIGNMENT_KEY"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ALIGNMENT_KEY
Visual Basic
Public Enumeration ALIGNMENT_KEY
Visual C++
public enum class ALIGNMENT_KEY

Members

Member name | Value | Description
LEFT | 0 |
RIGHT | 1 |
CENTER | 2 |
STRETCH | 3 |

See Also

ElGUI Namespace


Brush Class

[image]

4 of William Foster's Class Libraries
Brush Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Brush"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Brush
Visual Basic
Public Class Brush
Visual C++
public ref class Brush

Inheritance Hierarchy

System..::..Object
ElGUI..::..Brush
ElGUI..::..Brush_Effect
ElGUI..::..Brush_Image
ElGUI..::..Brush_Solid

See Also

Brush Members
ElGUI Namespace


Brush Members

[image] [image]

4 of William Foster's Class Libraries
Brush Members
Brush Class Constructors Methods Operators Fields See Also Send Feedback

The Brush type exposes the following members.

Constructors

 | Name | Description
Public method | Brush | Initializes a new instance of the Brush class

Methods

 | Name | Description
Public method | BrushVirtualInternal |
Public method | DoBrush |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrushType |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Brush to Brush) |

Fields

 | Name | Description
Public field | m_SysBrush |

See Also

Brush Class
ElGUI Namespace


Brush Constructor

[image]

4 of William Foster's Class Libraries
Brush Constructor
Brush Class See Also Send Feedback
Initializes a new instance of the Brush class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush(
    Brush..::..EBrushType brushType
)
Visual Basic
Public Sub New ( _
    brushType As Brush..::..EBrushType _
)
Visual C++
public:
Brush(
    Brush..::..EBrushType brushType
)

Parameters

brushType
Type: ElGUI..::..Brush..::..EBrushType

[Missing <param name="brushType"/> documentation for "M:ElGUI.Brush.#ctor(ElGUI.Brush.EBrushType)"]

See Also

Brush Class
ElGUI Namespace


Brush Fields

[image] [image]

4 of William Foster's Class Libraries
Brush Fields
Brush Class See Also Send Feedback

The Brush type exposes the following members.

Fields

 | Name | Description
Public field | m_SysBrush |

See Also

Brush Class
ElGUI Namespace


m_SysBrush Field

[image]

4 of William Foster's Class Libraries
Brush..::..m_SysBrush Field
Brush Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.Brush.m_SysBrush"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush m_SysBrush
Visual Basic
Public m_SysBrush As Brush
Visual C++
public:
Brush^ m_SysBrush

See Also

Brush Class
ElGUI Namespace


Brush Methods

[image] [image]

4 of William Foster's Class Libraries
Brush Methods
Brush Class See Also Send Feedback

The Brush type exposes the following members.

Methods

 | Name | Description
Public method | BrushVirtualInternal |
Public method | DoBrush |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrushType |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Brush Class
ElGUI Namespace


BrushVirtualInternal Method

[image]

4 of William Foster's Class Libraries
Brush..::..BrushVirtualInternal Method
Brush Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Brush.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool BrushVirtualInternal(
    Bitmap bitmap,
    Shape2d_Rect RectDraw
)
Visual Basic
Public Overridable Function BrushVirtualInternal ( _
    bitmap As Bitmap, _
    RectDraw As Shape2d_Rect _
) As Boolean
Visual C++
public:
virtual bool BrushVirtualInternal(
    Bitmap^ bitmap,
    Shape2d_Rect^ RectDraw
)

Parameters

bitmap
Type: ElImage..::..Bitmap

[Missing <param name="bitmap"/> documentation for "M:ElGUI.Brush.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

RectDraw
Type: Shape2d_Rect

[Missing <param name="RectDraw"/> documentation for "M:ElGUI.Brush.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Brush.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

See Also

Brush Class
ElGUI Namespace


DoBrush Method

[image]

4 of William Foster's Class Libraries
Brush..::..DoBrush Method
Brush Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Brush.DoBrush(ElImage.Bitmap,ElVector.Shape2d,ElVector.Shape2d)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool DoBrush(
    Bitmap bitmap,
    Shape2d ShapeDraw,
    Shape2d ShapeClip
)
Visual Basic
Public Function DoBrush ( _
    bitmap As Bitmap, _
    ShapeDraw As Shape2d, _
    ShapeClip As Shape2d _
) As Boolean
Visual C++
public:
bool DoBrush(
    Bitmap^ bitmap,
    Shape2d^ ShapeDraw,
    Shape2d^ ShapeClip
)

Parameters

bitmap
Type: ElImage..::..Bitmap

[Missing <param name="bitmap"/> documentation for "M:ElGUI.Brush.DoBrush(ElImage.Bitmap,ElVector.Shape2d,ElVector.Shape2d)"]

ShapeDraw
Type: Shape2d

[Missing <param name="ShapeDraw"/> documentation for "M:ElGUI.Brush.DoBrush(ElImage.Bitmap,ElVector.Shape2d,ElVector.Shape2d)"]

ShapeClip
Type: Shape2d

[Missing <param name="ShapeClip"/> documentation for "M:ElGUI.Brush.DoBrush(ElImage.Bitmap,ElVector.Shape2d,ElVector.Shape2d)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Brush.DoBrush(ElImage.Bitmap,ElVector.Shape2d,ElVector.Shape2d)"]

See Also

Brush Class
ElGUI Namespace


GetBrushType Method

[image]

4 of William Foster's Class Libraries
Brush..::..GetBrushType Method
Brush Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Brush.GetBrushType"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush..::..EBrushType GetBrushType()
Visual Basic
Public Function GetBrushType As Brush..::..EBrushType
Visual C++
public:
Brush..::..EBrushType GetBrushType()

Return Value

[Missing <returns> documentation for "M:ElGUI.Brush.GetBrushType"]

See Also

Brush Class
ElGUI Namespace


Brush Type Conversions

[image] [image]

4 of William Foster's Class Libraries
Brush Type Conversions
Brush Class See Also Send Feedback

The Brush type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(Brush to Brush) |

See Also

Brush Class
ElGUI Namespace


Implicit Conversion (Brush to Brush)

[image]

4 of William Foster's Class Libraries
Brush ImplicitWideningImplicitImplicitImplicit Conversion (Brush to Brush)
Brush Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Brush.op_Implicit(ElGUI.Brush)~System.Drawing.Brush"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static implicit operator Brush (
    Brush b
)
Visual Basic
Public Shared Widening Operator CType ( _
    b As Brush _
) As Brush
Visual C++
static implicit operator Brush^ (
    Brush^ b
)

Parameters

b
Type: ElGUI..::..Brush

[Missing <param name="b"/> documentation for "M:ElGUI.Brush.op_Implicit(ElGUI.Brush)~System.Drawing.Brush"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Brush.op_Implicit(ElGUI.Brush)~System.Drawing.Brush"]

See Also

Brush Class
ElGUI Namespace


Brush.EBrushType Enumeration

[image]

4 of William Foster's Class Libraries
Brush..::..EBrushType Enumeration
Brush Class See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Brush.EBrushType"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum EBrushType
Visual Basic
Public Enumeration EBrushType
Visual C++
public enum class EBrushType

Members

Member name | Value | Description
SOLID_COLOR | 0 |
IMAGE2D | 1 |
EFFECT | 2 |

See Also

ElGUI Namespace


Brush_Effect Class

[image]

4 of William Foster's Class Libraries
Brush_Effect Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Brush_Effect"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Brush_Effect : Brush
Visual Basic
Public Class Brush_Effect _
    Inherits Brush
Visual C++
public ref class Brush_Effect : public Brush

Inheritance Hierarchy

System..::..Object
ElGUI..::..Brush
ElGUI..::..Brush_Effect

See Also

Brush_Effect Members
ElGUI Namespace


Brush_Effect Members

[image] [image]

4 of William Foster's Class Libraries
Brush_Effect Members
Brush_Effect Class Constructors Methods Fields See Also Send Feedback

The Brush_Effect type exposes the following members.

Constructors

 | Name | Description
Public method | Brush_Effect | Initializes a new instance of the Brush_Effect class

Methods

 | Name | Description
Public method | BrushVirtualInternal | (Overrides Brush..::..BrushVirtualInternal(Bitmap, Shape2d_Rect).)
Public method | DoBrush | (Inherited from Brush.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrushType | (Inherited from Brush.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_SysBrush | (Inherited from Brush.)

See Also

Brush_Effect Class
ElGUI Namespace


Brush_Effect Constructor

[image]

4 of William Foster's Class Libraries
Brush_Effect Constructor
Brush_Effect Class See Also Send Feedback
Initializes a new instance of the Brush_Effect class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush_Effect()
Visual Basic
Public Sub New
Visual C++
public:
Brush_Effect()

See Also

Brush_Effect Class
ElGUI Namespace


Brush_Effect Fields

[image] [image]

4 of William Foster's Class Libraries
Brush_Effect Fields
Brush_Effect Class See Also Send Feedback

The Brush_Effect type exposes the following members.

Fields

 | Name | Description
Public field | m_SysBrush | (Inherited from Brush.)

See Also

Brush_Effect Class
ElGUI Namespace


Brush_Effect Methods

[image] [image]

4 of William Foster's Class Libraries
Brush_Effect Methods
Brush_Effect Class See Also Send Feedback

The Brush_Effect type exposes the following members.

Methods

 | Name | Description
Public method | BrushVirtualInternal | (Overrides Brush..::..BrushVirtualInternal(Bitmap, Shape2d_Rect).)
Public method | DoBrush | (Inherited from Brush.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrushType | (Inherited from Brush.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Brush_Effect Class
ElGUI Namespace


BrushVirtualInternal Method

[image]

4 of William Foster's Class Libraries
Brush_Effect..::..BrushVirtualInternal Method
Brush_Effect Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Brush_Effect.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool BrushVirtualInternal(
    Bitmap bitmap,
    Shape2d_Rect shapeDraw
)
Visual Basic
Public Overrides Function BrushVirtualInternal ( _
    bitmap As Bitmap, _
    shapeDraw As Shape2d_Rect _
) As Boolean
Visual C++
public:
virtual bool BrushVirtualInternal(
    Bitmap^ bitmap,
    Shape2d_Rect^ shapeDraw
) override

Parameters

bitmap
Type: ElImage..::..Bitmap

[Missing <param name="bitmap"/> documentation for "M:ElGUI.Brush_Effect.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

shapeDraw
Type: Shape2d_Rect

[Missing <param name="shapeDraw"/> documentation for "M:ElGUI.Brush_Effect.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Brush_Effect.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

See Also

Brush_Effect Class
ElGUI Namespace


Brush_Image Class

[image]

4 of William Foster's Class Libraries
Brush_Image Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Brush_Image"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Brush_Image : Brush
Visual Basic
Public Class Brush_Image _
    Inherits Brush
Visual C++
public ref class Brush_Image : public Brush

Inheritance Hierarchy

System..::..Object
ElGUI..::..Brush
ElGUI..::..Brush_Image

See Also

Brush_Image Members
ElGUI Namespace


Brush_Image Members

[image] [image]

4 of William Foster's Class Libraries
Brush_Image Members
Brush_Image Class Constructors Methods Fields See Also Send Feedback

The Brush_Image type exposes the following members.

Constructors

 | Name | Description
Public method | Brush_Image | Initializes a new instance of the Brush_Image class

Methods

 | Name | Description
Public method | BrushVirtualInternal | (Overrides Brush..::..BrushVirtualInternal(Bitmap, Shape2d_Rect).)
Public method | DoBrush | (Inherited from Brush.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrushType | (Inherited from Brush.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_SysBrush | (Inherited from Brush.)

See Also

Brush_Image Class
ElGUI Namespace


Brush_Image Constructor

[image]

4 of William Foster's Class Libraries
Brush_Image Constructor
Brush_Image Class See Also Send Feedback
Initializes a new instance of the Brush_Image class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush_Image()
Visual Basic
Public Sub New
Visual C++
public:
Brush_Image()

See Also

Brush_Image Class
ElGUI Namespace


Brush_Image Fields

[image] [image]

4 of William Foster's Class Libraries
Brush_Image Fields
Brush_Image Class See Also Send Feedback

The Brush_Image type exposes the following members.

Fields

 | Name | Description
Public field | m_SysBrush | (Inherited from Brush.)

See Also

Brush_Image Class
ElGUI Namespace


Brush_Image Methods

[image] [image]

4 of William Foster's Class Libraries
Brush_Image Methods
Brush_Image Class See Also Send Feedback

The Brush_Image type exposes the following members.

Methods

 | Name | Description
Public method | BrushVirtualInternal | (Overrides Brush..::..BrushVirtualInternal(Bitmap, Shape2d_Rect).)
Public method | DoBrush | (Inherited from Brush.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrushType | (Inherited from Brush.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Brush_Image Class
ElGUI Namespace


BrushVirtualInternal Method

[image]

4 of William Foster's Class Libraries
Brush_Image..::..BrushVirtualInternal Method
Brush_Image Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Brush_Image.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool BrushVirtualInternal(
    Bitmap bitmap,
    Shape2d_Rect shapeDraw
)
Visual Basic
Public Overrides Function BrushVirtualInternal ( _
    bitmap As Bitmap, _
    shapeDraw As Shape2d_Rect _
) As Boolean
Visual C++
public:
virtual bool BrushVirtualInternal(
    Bitmap^ bitmap,
    Shape2d_Rect^ shapeDraw
) override

Parameters

bitmap
Type: ElImage..::..Bitmap

[Missing <param name="bitmap"/> documentation for "M:ElGUI.Brush_Image.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

shapeDraw
Type: Shape2d_Rect

[Missing <param name="shapeDraw"/> documentation for "M:ElGUI.Brush_Image.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Brush_Image.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

See Also

Brush_Image Class
ElGUI Namespace


Brush_Solid Class

[image]

4 of William Foster's Class Libraries
Brush_Solid Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Brush_Solid"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Brush_Solid : Brush
Visual Basic
Public Class Brush_Solid _
    Inherits Brush
Visual C++
public ref class Brush_Solid : public Brush

Inheritance Hierarchy

System..::..Object
ElGUI..::..Brush
ElGUI..::..Brush_Solid

See Also

Brush_Solid Members
ElGUI Namespace


Brush_Solid Members

[image] [image]

4 of William Foster's Class Libraries
Brush_Solid Members
Brush_Solid Class Constructors Methods Fields See Also Send Feedback

The Brush_Solid type exposes the following members.

Constructors

 | Name | Description
Public method | Brush_Solid | Initializes a new instance of the Brush_Solid class

Methods

 | Name | Description
Public method | BrushVirtualInternal | (Overrides Brush..::..BrushVirtualInternal(Bitmap, Shape2d_Rect).)
Public method | DoBrush | (Inherited from Brush.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrushType | (Inherited from Brush.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_SysBrush | (Inherited from Brush.)

See Also

Brush_Solid Class
ElGUI Namespace


Brush_Solid Constructor

[image]

4 of William Foster's Class Libraries
Brush_Solid Constructor
Brush_Solid Class See Also Send Feedback
Initializes a new instance of the Brush_Solid class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush_Solid(
    Color color
)
Visual Basic
Public Sub New ( _
    color As Color _
)
Visual C++
public:
Brush_Solid(
    Color^ color
)

Parameters

color
Type: ElImage..::..Color

[Missing <param name="color"/> documentation for "M:ElGUI.Brush_Solid.#ctor(ElImage.Color)"]

See Also

Brush_Solid Class
ElGUI Namespace


Brush_Solid Fields

[image] [image]

4 of William Foster's Class Libraries
Brush_Solid Fields
Brush_Solid Class See Also Send Feedback

The Brush_Solid type exposes the following members.

Fields

 | Name | Description
Public field | m_SysBrush | (Inherited from Brush.)

See Also

Brush_Solid Class
ElGUI Namespace


Brush_Solid Methods

[image] [image]

4 of William Foster's Class Libraries
Brush_Solid Methods
Brush_Solid Class See Also Send Feedback

The Brush_Solid type exposes the following members.

Methods

 | Name | Description
Public method | BrushVirtualInternal | (Overrides Brush..::..BrushVirtualInternal(Bitmap, Shape2d_Rect).)
Public method | DoBrush | (Inherited from Brush.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBrushType | (Inherited from Brush.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Brush_Solid Class
ElGUI Namespace


BrushVirtualInternal Method

[image]

4 of William Foster's Class Libraries
Brush_Solid..::..BrushVirtualInternal Method
Brush_Solid Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Brush_Solid.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool BrushVirtualInternal(
    Bitmap bitmap,
    Shape2d_Rect shapeDraw
)
Visual Basic
Public Overrides Function BrushVirtualInternal ( _
    bitmap As Bitmap, _
    shapeDraw As Shape2d_Rect _
) As Boolean
Visual C++
public:
virtual bool BrushVirtualInternal(
    Bitmap^ bitmap,
    Shape2d_Rect^ shapeDraw
) override

Parameters

bitmap
Type: ElImage..::..Bitmap

[Missing <param name="bitmap"/> documentation for "M:ElGUI.Brush_Solid.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

shapeDraw
Type: Shape2d_Rect

[Missing <param name="shapeDraw"/> documentation for "M:ElGUI.Brush_Solid.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Brush_Solid.BrushVirtualInternal(ElImage.Bitmap,ElVector.Shape2d_Rect)"]

See Also

Brush_Solid Class
ElGUI Namespace


Button Class

[image]

4 of William Foster's Class Libraries
Button Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Button"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Button : Resource_Control
Visual Basic
Public Class Button _
    Inherits Resource_Control
Visual C++
public ref class Button : public Resource_Control

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..Resource_Control
ElGUI..::..Button

See Also

Button Members
ElGUI Namespace


Button Members

[image] [image]

4 of William Foster's Class Libraries
Button Members
Button Class Constructors Methods Fields Properties See Also Send Feedback

The Button type exposes the following members.

Constructors

 | Name | Description
Public method | Button | Initializes a new instance of the Button class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetChecked |
Public method | GetGroup |
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Public method | LoadBitmap |
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Overrides Window..::..OnPaint(Rect2dU).)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetChecked |
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetGroup |
Public method | SetIcon |
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

Button Class
ElGUI Namespace


Button Constructor

[image]

4 of William Foster's Class Libraries
Button Constructor
Button Class See Also Send Feedback
Initializes a new instance of the Button class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Button(
    GUI gui,
    Window Parent,
    STRING csText,
    Resource_ID resourceID,
    bool bCheckbox,
    bool bRadio
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    Parent As Window, _
    csText As STRING, _
    resourceID As Resource_ID, _
    bCheckbox As Boolean, _
    bRadio As Boolean _
)
Visual C++
public:
Button(
    GUI^ gui,
    Window^ Parent,
    STRING^ csText,
    Resource_ID resourceID,
    bool bCheckbox,
    bool bRadio
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.Button.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,System.Boolean,System.Boolean)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.Button.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,System.Boolean,System.Boolean)"]

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.Button.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,System.Boolean,System.Boolean)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.Button.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,System.Boolean,System.Boolean)"]

bCheckbox
Type: System..::..Boolean

[Missing <param name="bCheckbox"/> documentation for "M:ElGUI.Button.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,System.Boolean,System.Boolean)"]

bRadio
Type: System..::..Boolean

[Missing <param name="bRadio"/> documentation for "M:ElGUI.Button.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,System.Boolean,System.Boolean)"]

See Also

Button Class
ElGUI Namespace


Button Fields

[image] [image]

4 of William Foster's Class Libraries
Button Fields
Button Class See Also Send Feedback

The Button type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

Button Class
ElGUI Namespace


Button Methods

[image] [image]

4 of William Foster's Class Libraries
Button Methods
Button Class See Also Send Feedback

The Button type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetChecked |
Public method | GetGroup |
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Public method | LoadBitmap |
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Overrides Window..::..OnPaint(Rect2dU).)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetChecked |
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetGroup |
Public method | SetIcon |
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

Button Class
ElGUI Namespace


GetChecked Method

[image]

4 of William Foster's Class Libraries
Button..::..GetChecked Method
Button Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Button.GetChecked"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GetChecked()
Visual Basic
Public Function GetChecked As Boolean
Visual C++
public:
bool GetChecked()

Return Value

[Missing <returns> documentation for "M:ElGUI.Button.GetChecked"]

See Also

Button Class
ElGUI Namespace


GetGroup Method

[image]

4 of William Foster's Class Libraries
Button..::..GetGroup Method
Button Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Button.GetGroup"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING GetGroup()
Visual Basic
Public Function GetGroup As STRING
Visual C++
public:
STRING^ GetGroup()

Return Value

[Missing <returns> documentation for "M:ElGUI.Button.GetGroup"]

See Also

Button Class
ElGUI Namespace


GetText Method

[image] [image]

4 of William Foster's Class Libraries
Button..::..GetText Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)

See Also

Button Class
Button Members
ElGUI Namespace


LoadBitmap Method

[image]

4 of William Foster's Class Libraries
Button..::..LoadBitmap Method
Button Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Button.LoadBitmap(El.Filename)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LoadBitmap(
    Filename file
)
Visual Basic
Public Function LoadBitmap ( _
    file As Filename _
) As Boolean
Visual C++
public:
bool LoadBitmap(
    Filename^ file
)

Parameters

file
Type: Filename

[Missing <param name="file"/> documentation for "M:ElGUI.Button.LoadBitmap(El.Filename)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Button.LoadBitmap(El.Filename)"]

See Also

Button Class
ElGUI Namespace


OnPaint Method

[image]

4 of William Foster's Class Libraries
Button..::..OnPaint Method
Button Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Button.OnPaint(El.Rect2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override int OnPaint(
    Rect2dU rect2d
)
Visual Basic
Protected Overrides Function OnPaint ( _
    rect2d As Rect2dU _
) As Integer
Visual C++
protected:
virtual int OnPaint(
    Rect2dU^ rect2d
) override

Parameters

rect2d
Type: Rect2dU

[Missing <param name="rect2d"/> documentation for "M:ElGUI.Button.OnPaint(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Button.OnPaint(El.Rect2dU)"]

See Also

Button Class
ElGUI Namespace


SetChecked Method

[image]

4 of William Foster's Class Libraries
Button..::..SetChecked Method
Button Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Button.SetChecked(System.Boolean)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetChecked(
    bool bChecked
)
Visual Basic
Public Sub SetChecked ( _
    bChecked As Boolean _
)
Visual C++
public:
void SetChecked(
    bool bChecked
)

Parameters

bChecked
Type: System..::..Boolean

[Missing <param name="bChecked"/> documentation for "M:ElGUI.Button.SetChecked(System.Boolean)"]

See Also

Button Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
Button..::..SetColor Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

Button Class
Button Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
Button..::..SetDefaultCursor Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

Button Class
Button Members
ElGUI Namespace


SetGroup Method

[image]

4 of William Foster's Class Libraries
Button..::..SetGroup Method
Button Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Button.SetGroup(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetGroup(
    STRING cs
)
Visual Basic
Public Sub SetGroup ( _
    cs As STRING _
)
Visual C++
public:
void SetGroup(
    STRING^ cs
)

Parameters

cs
Type: STRING

[Missing <param name="cs"/> documentation for "M:ElGUI.Button.SetGroup(El.STRING)"]

See Also

Button Class
ElGUI Namespace


SetIcon Method

[image]

4 of William Foster's Class Libraries
Button..::..SetIcon Method
Button Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Button.SetIcon(El.Filename)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetIcon(
    Filename file
)
Visual Basic
Public Function SetIcon ( _
    file As Filename _
) As Boolean
Visual C++
public:
bool SetIcon(
    Filename^ file
)

Parameters

file
Type: Filename

[Missing <param name="file"/> documentation for "M:ElGUI.Button.SetIcon(El.Filename)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Button.SetIcon(El.Filename)"]

See Also

Button Class
ElGUI Namespace


Button Properties

[image] [image]

4 of William Foster's Class Libraries
Button Properties
Button Class See Also Send Feedback

The Button type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

Button Class
ElGUI Namespace


CDefault_DlgDP Class

[image]

4 of William Foster's Class Libraries
CDefault_DlgDP Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CDefault_DlgDP"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CDefault_DlgDP : DlgDP
Visual Basic
Public Class CDefault_DlgDP _
    Inherits DlgDP
Visual C++
public ref class CDefault_DlgDP : public DlgDP

Inheritance Hierarchy

System..::..Object
ElGUI..::..DP
ElGUI..::..DlgDP
ElGUI..::..CDefault_DlgDP
ElOS..::..FileSelection_DP

See Also

CDefault_DlgDP Members
ElGUI Namespace


CDefault_DlgDP Members

[image] [image]

4 of William Foster's Class Libraries
CDefault_DlgDP Members
CDefault_DlgDP Class Constructors Methods Fields See Also Send Feedback

The CDefault_DlgDP type exposes the following members.

Constructors

 | Name | Description
Public method | CDefault_DlgDP | Initializes a new instance of the CDefault_DlgDP class

Methods

 | Name | Description
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetGUI | (Inherited from DlgDP.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadMemoryResource |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview |
Public method | ProcessInput | (Overrides DlgDP..::..ProcessInput(Resource_Control, DialogWindow).)
Public method | RunDlg(DialogWindow, DP) | (Overrides DlgDP..::..RunDlg(DialogWindow, DP).)
Public method | RunDlg(Window, STRING) | (Inherited from DlgDP.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_parent | (Inherited from DlgDP.)

See Also

CDefault_DlgDP Class
ElGUI Namespace


CDefault_DlgDP Constructor

[image]

4 of William Foster's Class Libraries
CDefault_DlgDP Constructor
CDefault_DlgDP Class See Also Send Feedback
Initializes a new instance of the CDefault_DlgDP class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CDefault_DlgDP(
    GUI gui,
    DX dx,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    dx As DX, _
    Parent As Window _
)
Visual C++
public:
CDefault_DlgDP(
    GUI^ gui,
    DX^ dx,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.CDefault_DlgDP.#ctor(ElGUI.GUI,ElGUI.DX,ElGUI.Window)"]

dx
Type: ElGUI..::..DX

[Missing <param name="dx"/> documentation for "M:ElGUI.CDefault_DlgDP.#ctor(ElGUI.GUI,ElGUI.DX,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.CDefault_DlgDP.#ctor(ElGUI.GUI,ElGUI.DX,ElGUI.Window)"]

See Also

CDefault_DlgDP Class
ElGUI Namespace


CDefault_DlgDP Fields

[image] [image]

4 of William Foster's Class Libraries
CDefault_DlgDP Fields
CDefault_DlgDP Class See Also Send Feedback

The CDefault_DlgDP type exposes the following members.

Fields

 | Name | Description
Protected field | m_parent | (Inherited from DlgDP.)

See Also

CDefault_DlgDP Class
ElGUI Namespace


CDefault_DlgDP Methods

[image] [image]

4 of William Foster's Class Libraries
CDefault_DlgDP Methods
CDefault_DlgDP Class See Also Send Feedback

The CDefault_DlgDP type exposes the following members.

Methods

 | Name | Description
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetGUI | (Inherited from DlgDP.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadMemoryResource |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview |
Public method | ProcessInput | (Overrides DlgDP..::..ProcessInput(Resource_Control, DialogWindow).)
Public method | RunDlg(DialogWindow, DP) | (Overrides DlgDP..::..RunDlg(DialogWindow, DP).)
Public method | RunDlg(Window, STRING) | (Inherited from DlgDP.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CDefault_DlgDP Class
ElGUI Namespace


LoadMemoryResource Method

[image]

4 of William Foster's Class Libraries
CDefault_DlgDP..::..LoadMemoryResource Method
CDefault_DlgDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CDefault_DlgDP.LoadMemoryResource(System.String)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceStore LoadMemoryResource(
    string csScript
)
Visual Basic
Public Function LoadMemoryResource ( _
    csScript As String _
) As ResourceStore
Visual C++
public:
ResourceStore^ LoadMemoryResource(
    String^ csScript
)

Parameters

csScript
Type: System..::..String

[Missing <param name="csScript"/> documentation for "M:ElGUI.CDefault_DlgDP.LoadMemoryResource(System.String)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CDefault_DlgDP.LoadMemoryResource(System.String)"]

See Also

CDefault_DlgDP Class
ElGUI Namespace


Preview Method

[image]

4 of William Foster's Class Libraries
CDefault_DlgDP..::..Preview Method
CDefault_DlgDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CDefault_DlgDP.Preview"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Preview()
Visual Basic
Public Sub Preview
Visual C++
public:
void Preview()

See Also

CDefault_DlgDP Class
ElGUI Namespace


ProcessInput Method

[image]

4 of William Foster's Class Libraries
CDefault_DlgDP..::..ProcessInput Method
CDefault_DlgDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CDefault_DlgDP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool ProcessInput(
    Resource_Control Ctrl,
    DialogWindow DS
)
Visual Basic
Public Overrides Function ProcessInput ( _
    Ctrl As Resource_Control, _
    DS As DialogWindow _
) As Boolean
Visual C++
public:
virtual bool ProcessInput(
    Resource_Control^ Ctrl,
    DialogWindow^ DS
) override

Parameters

Ctrl
Type: ElGUI..::..Resource_Control

[Missing <param name="Ctrl"/> documentation for "M:ElGUI.CDefault_DlgDP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

DS
Type: ElGUI..::..DialogWindow

[Missing <param name="DS"/> documentation for "M:ElGUI.CDefault_DlgDP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CDefault_DlgDP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

See Also

CDefault_DlgDP Class
ElGUI Namespace


RunDlg Method

[image] [image]

4 of William Foster's Class Libraries
CDefault_DlgDP..::..RunDlg Method
CDefault_DlgDP Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RunDlg(DialogWindow, DP) | (Overrides DlgDP..::..RunDlg(DialogWindow, DP).)
Public method | RunDlg(Window, STRING) | (Inherited from DlgDP.)

See Also

CDefault_DlgDP Class
CDefault_DlgDP Members
ElGUI Namespace


RunDlg Method (DialogWindow, DP)

[image]

4 of William Foster's Class Libraries
CDefault_DlgDP..::..RunDlg Method (DialogWindow, DP)
CDefault_DlgDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CDefault_DlgDP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int RunDlg(
    DialogWindow DlgDS,
    DP PreviewDP
)
Visual Basic
Public Overrides Function RunDlg ( _
    DlgDS As DialogWindow, _
    PreviewDP As DP _
) As Integer
Visual C++
public:
virtual int RunDlg(
    DialogWindow^ DlgDS,
    DP^ PreviewDP
) override

Parameters

DlgDS
Type: ElGUI..::..DialogWindow

[Missing <param name="DlgDS"/> documentation for "M:ElGUI.CDefault_DlgDP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

PreviewDP
Type: ElGUI..::..DP

[Missing <param name="PreviewDP"/> documentation for "M:ElGUI.CDefault_DlgDP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CDefault_DlgDP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

See Also

CDefault_DlgDP Class
RunDlg Overload
ElGUI Namespace


ComboBox Class

[image]

4 of William Foster's Class Libraries
ComboBox Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ComboBox"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ComboBox : ListControl
Visual Basic
Public Class ComboBox _
    Inherits ListControl
Visual C++
public ref class ComboBox : public ListControl

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..Resource_Control
ElGUI..::..Data_Resource_Control
ElGUI..::..TextData_Resource_Control
ElGUI..::..ListControl
ElGUI..::..ComboBox

See Also

ComboBox Members
ElGUI Namespace


ComboBox Members

[image] [image]

4 of William Foster's Class Libraries
ComboBox Members
ComboBox Class Constructors Methods Fields Properties See Also Send Feedback

The ComboBox type exposes the following members.

Constructors

 | Name | Description
Public method | ComboBox | Initializes a new instance of the ComboBox class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendItem | (Overrides ListControl..::..AppendItem(STRING).)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Public method | Empty | (Overrides ListControl..::..Empty()()()().)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SelectItem | (Overrides ListControl..::..SelectItem(Int32).)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from ListControl.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ComboBox Class
ElGUI Namespace


ComboBox Constructor

[image]

4 of William Foster's Class Libraries
ComboBox Constructor
ComboBox Class See Also Send Feedback
Initializes a new instance of the ComboBox class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ComboBox(
    GUI gui,
    Window Parent,
    uint nCols,
    Resource_ID resourceID
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    Parent As Window, _
    nCols As UInteger, _
    resourceID As Resource_ID _
)
Visual C++
public:
ComboBox(
    GUI^ gui,
    Window^ Parent,
    unsigned int nCols,
    Resource_ID resourceID
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.ComboBox.#ctor(ElGUI.GUI,ElGUI.Window,System.UInt32,ElGUI.Resource_ID)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.ComboBox.#ctor(ElGUI.GUI,ElGUI.Window,System.UInt32,ElGUI.Resource_ID)"]

nCols
Type: System..::..UInt32

[Missing <param name="nCols"/> documentation for "M:ElGUI.ComboBox.#ctor(ElGUI.GUI,ElGUI.Window,System.UInt32,ElGUI.Resource_ID)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.ComboBox.#ctor(ElGUI.GUI,ElGUI.Window,System.UInt32,ElGUI.Resource_ID)"]

See Also

ComboBox Class
ElGUI Namespace


ComboBox Fields

[image] [image]

4 of William Foster's Class Libraries
ComboBox Fields
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

ComboBox Class
ElGUI Namespace


ComboBox Methods

[image] [image]

4 of William Foster's Class Libraries
ComboBox Methods
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendItem | (Overrides ListControl..::..AppendItem(STRING).)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Public method | Empty | (Overrides ListControl..::..Empty()()()().)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SelectItem | (Overrides ListControl..::..SelectItem(Int32).)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from ListControl.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

ComboBox Class
ElGUI Namespace


AppendItem Method

[image]

4 of William Foster's Class Libraries
ComboBox..::..AppendItem Method
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ComboBox.AppendItem(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void AppendItem(
    STRING csItem
)
Visual Basic
Public Overrides Sub AppendItem ( _
    csItem As STRING _
)
Visual C++
public:
virtual void AppendItem(
    STRING^ csItem
) override

Parameters

csItem
Type: STRING

[Missing <param name="csItem"/> documentation for "M:ElGUI.ComboBox.AppendItem(El.STRING)"]

See Also

ComboBox Class
ElGUI Namespace


Empty Method

[image]

4 of William Foster's Class Libraries
ComboBox..::..Empty Method
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ComboBox.Empty"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void Empty()
Visual Basic
Public Overrides Sub Empty
Visual C++
public:
virtual void Empty() override

See Also

ComboBox Class
ElGUI Namespace


GetText Method

[image] [image]

4 of William Foster's Class Libraries
ComboBox..::..GetText Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)

See Also

ComboBox Class
ComboBox Members
ElGUI Namespace


SelectItem Method

[image]

4 of William Foster's Class Libraries
ComboBox..::..SelectItem Method
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ComboBox.SelectItem(System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void SelectItem(
    int itemno
)
Visual Basic
Public Overrides Sub SelectItem ( _
    itemno As Integer _
)
Visual C++
public:
virtual void SelectItem(
    int itemno
) override

Parameters

itemno
Type: System..::..Int32

[Missing <param name="itemno"/> documentation for "M:ElGUI.ComboBox.SelectItem(System.Int32)"]

See Also

ComboBox Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
ComboBox..::..SetColor Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

ComboBox Class
ComboBox Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
ComboBox..::..SetDefaultCursor Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

ComboBox Class
ComboBox Members
ElGUI Namespace


ComboBox Properties

[image] [image]

4 of William Foster's Class Libraries
ComboBox Properties
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ComboBox Class
ElGUI Namespace


CSys_ButtonControl Class

[image]

4 of William Foster's Class Libraries
CSys_ButtonControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_ButtonControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_ButtonControl : Button,
    ISysWin
Visual Basic
Public Class CSys_ButtonControl _
    Inherits Button _
    Implements ISysWin
Visual C++
public ref class CSys_ButtonControl : public Button,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls.Primitives..::..ButtonBase
System.Windows.Controls..::..Button
ElGUI..::..CSys_ButtonControl

See Also

CSys_ButtonControl Members
ElGUI Namespace


CSys_ButtonControl Members

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl Members
CSys_ButtonControl Class Constructors Methods Properties Events See Also Send Feedback

The CSys_ButtonControl type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_ButtonControl | Initializes a new instance of the CSys_ButtonControl class

Methods

 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a Button is clicked. (Inherited from Button.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates an appropriate ButtonAutomationPeer for this control as part of the WPF infrastructure. (Inherited from Button.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetIcon |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCancel | Gets or sets a value that indicates whether a Button is a Cancel button. A user can activate the Cancel button by pressing the ESC key. (Inherited from Button.)
Public property | IsDefault | Gets or sets a value that indicates whether a Button is the default button. A user invokes the default button by pressing the ENTER key. (Inherited from Button.)
Public property | IsDefaulted | Gets a value that indicates whether a Button is the button that is activated when a user presses ENTER. (Inherited from Button.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_ButtonControl Class
ElGUI Namespace


CSys_ButtonControl Constructor

[image]

4 of William Foster's Class Libraries
CSys_ButtonControl Constructor
CSys_ButtonControl Class See Also Send Feedback
Initializes a new instance of the CSys_ButtonControl class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_ButtonControl(
    string csText,
    Resource_ID resourceID,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    csText As String, _
    resourceID As Resource_ID, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_ButtonControl(
    String^ csText,
    Resource_ID resourceID,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

csText
Type: System..::..String

[Missing <param name="csText"/> documentation for "M:ElGUI.CSys_ButtonControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.CSys_ButtonControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_ButtonControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_ButtonControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_ButtonControl Class
ElGUI Namespace


CSys_ButtonControl Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl Methods
CSys_ButtonControl Class See Also Send Feedback

The CSys_ButtonControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a Button is clicked. (Inherited from Button.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates an appropriate ButtonAutomationPeer for this control as part of the WPF infrastructure. (Inherited from Button.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetIcon |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_ButtonControl Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl..::..AddHandler Method
CSys_ButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_ButtonControl Class
CSys_ButtonControl Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl..::..ApplyAnimationClock Method
CSys_ButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_ButtonControl Class
CSys_ButtonControl Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl..::..BeginAnimation Method
CSys_ButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_ButtonControl Class
CSys_ButtonControl Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl..::..BeginStoryboard Method
CSys_ButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_ButtonControl Class
CSys_ButtonControl Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl..::..BringIntoView Method
CSys_ButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_ButtonControl Class
CSys_ButtonControl Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl..::..ClearValue Method
CSys_ButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_ButtonControl Class
CSys_ButtonControl Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl..::..HitTestCore Method
CSys_ButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_ButtonControl Class
CSys_ButtonControl Members
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl..::..SetBinding Method
CSys_ButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_ButtonControl Class
CSys_ButtonControl Members
ElGUI Namespace


SetIcon Method

[image]

4 of William Foster's Class Libraries
CSys_ButtonControl..::..SetIcon Method
CSys_ButtonControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_ButtonControl.SetIcon(El.Filename)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetIcon(
    Filename fn
)
Visual Basic
Public Sub SetIcon ( _
    fn As Filename _
)
Visual C++
public:
void SetIcon(
    Filename^ fn
)

Parameters

fn
Type: Filename

[Missing <param name="fn"/> documentation for "M:ElGUI.CSys_ButtonControl.SetIcon(El.Filename)"]

See Also

CSys_ButtonControl Class
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl..::..SetValue Method
CSys_ButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_ButtonControl Class
CSys_ButtonControl Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl..::..TransformToAncestor Method
CSys_ButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_ButtonControl Class
CSys_ButtonControl Members
ElGUI Namespace


CSys_ButtonControl Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl Properties
CSys_ButtonControl Class See Also Send Feedback

The CSys_ButtonControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCancel | Gets or sets a value that indicates whether a Button is a Cancel button. A user can activate the Cancel button by pressing the ESC key. (Inherited from Button.)
Public property | IsDefault | Gets or sets a value that indicates whether a Button is the default button. A user invokes the default button by pressing the ENTER key. (Inherited from Button.)
Public property | IsDefaulted | Gets a value that indicates whether a Button is the button that is activated when a user presses ENTER. (Inherited from Button.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_ButtonControl Class
ElGUI Namespace


CSys_ButtonControl Events

[image] [image]

4 of William Foster's Class Libraries
CSys_ButtonControl Events
CSys_ButtonControl Class See Also Send Feedback

The CSys_ButtonControl type exposes the following members.

Events

 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_ButtonControl Class
ElGUI Namespace


CSys_CheckBoxControl Class

[image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_CheckBoxControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_CheckBoxControl : CheckBox,
    ISysWin
Visual Basic
Public Class CSys_CheckBoxControl _
    Inherits CheckBox _
    Implements ISysWin
Visual C++
public ref class CSys_CheckBoxControl : public CheckBox,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls.Primitives..::..ButtonBase
System.Windows.Controls.Primitives..::..ToggleButton
System.Windows.Controls..::..CheckBox
ElGUI..::..CSys_CheckBoxControl

See Also

CSys_CheckBoxControl Members
ElGUI Namespace


CSys_CheckBoxControl Members

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl Members
CSys_CheckBoxControl Class Constructors Methods Properties Events See Also Send Feedback

The CSys_CheckBoxControl type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_CheckBoxControl | Initializes a new instance of the CSys_CheckBoxControl class

Methods

 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Called when the access key for a CheckBox is invoked. (Inherited from CheckBox.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChecked | Called when a ToggleButton raises a Checked event. (Inherited from ToggleButton.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a control is clicked by the mouse or the keyboard. (Inherited from ToggleButton.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates an AutomationPeer for the CheckBox. (Inherited from CheckBox.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnIndeterminate | Called when a ToggleButton raises an Indeterminate event. (Inherited from ToggleButton.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Responds to a CheckBox KeyDown event. (Inherited from CheckBox.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToggle | Called by the OnClick()()()() method to implement toggle behavior. (Inherited from ToggleButton.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnchecked | Called when a ToggleButton raises an Unchecked event. (Inherited from ToggleButton.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a ToggleButton object. (Inherited from ToggleButton.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsChecked | Gets or sets whether the ToggleButton is checked. (Inherited from ToggleButton.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsThreeState | Determines whether the control supports two or three states. (Inherited from ToggleButton.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | Checked | Occurs when a ToggleButton is checked. (Inherited from ToggleButton.)
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Indeterminate | Occurs when the state of a ToggleButton is neither on nor off. (Inherited from ToggleButton.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unchecked | Occurs when a ToggleButton is unchecked. (Inherited from ToggleButton.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_CheckBoxControl Class
ElGUI Namespace


CSys_CheckBoxControl Constructor

[image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl Constructor
CSys_CheckBoxControl Class See Also Send Feedback
Initializes a new instance of the CSys_CheckBoxControl class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_CheckBoxControl(
    string csText,
    Resource_ID resourceID,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    csText As String, _
    resourceID As Resource_ID, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_CheckBoxControl(
    String^ csText,
    Resource_ID resourceID,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

csText
Type: System..::..String

[Missing <param name="csText"/> documentation for "M:ElGUI.CSys_CheckBoxControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.CSys_CheckBoxControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_CheckBoxControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_CheckBoxControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_CheckBoxControl Class
ElGUI Namespace


CSys_CheckBoxControl Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl Methods
CSys_CheckBoxControl Class See Also Send Feedback

The CSys_CheckBoxControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Called when the access key for a CheckBox is invoked. (Inherited from CheckBox.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChecked | Called when a ToggleButton raises a Checked event. (Inherited from ToggleButton.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a control is clicked by the mouse or the keyboard. (Inherited from ToggleButton.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates an AutomationPeer for the CheckBox. (Inherited from CheckBox.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnIndeterminate | Called when a ToggleButton raises an Indeterminate event. (Inherited from ToggleButton.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Responds to a CheckBox KeyDown event. (Inherited from CheckBox.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToggle | Called by the OnClick()()()() method to implement toggle behavior. (Inherited from ToggleButton.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnchecked | Called when a ToggleButton raises an Unchecked event. (Inherited from ToggleButton.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a ToggleButton object. (Inherited from ToggleButton.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_CheckBoxControl Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl..::..AddHandler Method
CSys_CheckBoxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_CheckBoxControl Class
CSys_CheckBoxControl Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl..::..ApplyAnimationClock Method
CSys_CheckBoxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_CheckBoxControl Class
CSys_CheckBoxControl Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl..::..BeginAnimation Method
CSys_CheckBoxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_CheckBoxControl Class
CSys_CheckBoxControl Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl..::..BeginStoryboard Method
CSys_CheckBoxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_CheckBoxControl Class
CSys_CheckBoxControl Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl..::..BringIntoView Method
CSys_CheckBoxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_CheckBoxControl Class
CSys_CheckBoxControl Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl..::..ClearValue Method
CSys_CheckBoxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_CheckBoxControl Class
CSys_CheckBoxControl Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl..::..HitTestCore Method
CSys_CheckBoxControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_CheckBoxControl Class
CSys_CheckBoxControl Members
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl..::..SetBinding Method
CSys_CheckBoxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_CheckBoxControl Class
CSys_CheckBoxControl Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl..::..SetValue Method
CSys_CheckBoxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_CheckBoxControl Class
CSys_CheckBoxControl Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl..::..TransformToAncestor Method
CSys_CheckBoxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_CheckBoxControl Class
CSys_CheckBoxControl Members
ElGUI Namespace


CSys_CheckBoxControl Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl Properties
CSys_CheckBoxControl Class See Also Send Feedback

The CSys_CheckBoxControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsChecked | Gets or sets whether the ToggleButton is checked. (Inherited from ToggleButton.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsThreeState | Determines whether the control supports two or three states. (Inherited from ToggleButton.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_CheckBoxControl Class
ElGUI Namespace


CSys_CheckBoxControl Events

[image] [image]

4 of William Foster's Class Libraries
CSys_CheckBoxControl Events
CSys_CheckBoxControl Class See Also Send Feedback

The CSys_CheckBoxControl type exposes the following members.

Events

 | Name | Description
Public event | Checked | Occurs when a ToggleButton is checked. (Inherited from ToggleButton.)
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Indeterminate | Occurs when the state of a ToggleButton is neither on nor off. (Inherited from ToggleButton.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unchecked | Occurs when a ToggleButton is unchecked. (Inherited from ToggleButton.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_CheckBoxControl Class
ElGUI Namespace


CSys_ChildWindow Class

[image]

4 of William Foster's Class Libraries
CSys_ChildWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_ChildWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_ChildWindow : DockableContent,
    ISysWin
Visual Basic
Public Class CSys_ChildWindow _
    Inherits DockableContent _
    Implements ISysWin
Visual C++
public ref class CSys_ChildWindow : public DockableContent,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
ManagedContent
DockableContent
ElGUI..::..CSys_ChildWindow

See Also

CSys_ChildWindow Members
ElGUI Namespace


CSys_ChildWindow Members

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow Members
CSys_ChildWindow Class Constructors Methods Properties Events See Also Send Feedback

The CSys_ChildWindow type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_ChildWindow | Initializes a new instance of the CSys_ChildWindow class

Methods

 | Name | Description
Public method | Activate | (Inherited from DockableContent.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Protected method | CanExecuteCommand | (Inherited from DockableContent.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close()()()() | (Inherited from DockableContent.)
Public method | Close(Boolean) | (Inherited from DockableContent.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Protected method | FocusContent | (Inherited from ManagedContent.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetParentManager | (Inherited from ManagedContent.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | (Inherited from DockableContent.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from ManagedContent.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | (Inherited from ManagedContent.)
Protected method | OnClosing | (Inherited from ManagedContent.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentLoaded | (Inherited from DockableContent.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContentUnloaded | (Inherited from DockableContent.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragMouseDown | (Inherited from ManagedContent.)
Protected method | OnDragMouseLeave | (Inherited from ManagedContent.)
Protected method | OnDragMouseMove | (Inherited from DockableContent.)
Protected method | OnDragMouseUp | (Inherited from ManagedContent.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragStart | (Inherited from DockableContent.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnFloatingWindowSizeChanged | (Inherited from ManagedContent.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | (Inherited from ManagedContent.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | (Inherited from DockableContent.)
Protected method | OnIsActiveContentChanged | (Inherited from ManagedContent.)
Protected method | OnIsActiveDocumentChanged | (Inherited from ManagedContent.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | (Inherited from ManagedContent.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | (Inherited from ManagedContent.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManagerChanged | (Inherited from ManagedContent.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from ManagedContent.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStateChanged | (Inherited from DockableContent.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from DockableContent.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Protected method | RaisePropertyChanged | (Inherited from ManagedContent.)
Protected method | RaiseStateChangedEvent | (Inherited from DockableContent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetIsMouseDownFlag | (Inherited from ManagedContent.)
Public method | ResetSavedStateAndPosition | (Inherited from DockableContent.)
Public method | RestoreLayout | (Inherited from DockableContent.)
Public method | SaveLayout | (Inherited from DockableContent.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show()()()() | (Inherited from DockableContent.)
Public method | Show(DockingManager) | (Inherited from DockableContent.)
Public method | Show(AnchorStyle) | (Inherited from DockableContent.)
Public method | Show(DockingManager, AnchorStyle) | (Inherited from DockableContent.)
Public method | ShowAsDocument()()()() | (Inherited from DockableContent.)
Public method | ShowAsDocument(DockingManager) | (Inherited from DockableContent.)
Public method | ShowAsFloatingWindow(Boolean) | (Inherited from DockableContent.)
Public method | ShowAsFloatingWindow(DockingManager, Boolean) | (Inherited from DockableContent.)
Public method | ToggleAutoHide | (Inherited from DockableContent.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContainerPane | (Inherited from ManagedContent.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultElement | (Inherited from ManagedContent.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockableStyle | (Inherited from DockableContent.)
Protected property | DragEnabledArea | (Inherited from ManagedContent.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FloatingWindowSize | (Inherited from ManagedContent.)
Public property | FloatingWindowSizeToContent | (Inherited from DockableContent.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | FlyoutWindowSize | (Inherited from DockableContent.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HideOnClose | (Inherited from DockableContent.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | (Inherited from ManagedContent.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActiveContent | (Inherited from ManagedContent.)
Public property | IsActiveDocument | (Inherited from ManagedContent.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCloseable | (Inherited from ManagedContent.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsLocked | (Inherited from ManagedContent.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Protected property | IsMouseDown | (Inherited from ManagedContent.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Manager | (Inherited from ManagedContent.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Protected property | StartDragPoint | (Inherited from ManagedContent.)
Public property | State | (Inherited from DockableContent.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | (Inherited from ManagedContent.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | Closed | (Inherited from ManagedContent.)
Public event | Closing | (Inherited from ManagedContent.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsActiveContentChanged | (Inherited from ManagedContent.)
Public event | IsActiveDocumentChanged | (Inherited from ManagedContent.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | (Inherited from ManagedContent.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | (Inherited from DockableContent.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_ChildWindow Class
ElGUI Namespace


CSys_ChildWindow Constructor

[image]

4 of William Foster's Class Libraries
CSys_ChildWindow Constructor
CSys_ChildWindow Class See Also Send Feedback
Initializes a new instance of the CSys_ChildWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_ChildWindow(
    string csTitle,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    csTitle As String, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_ChildWindow(
    String^ csTitle,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

csTitle
Type: System..::..String

[Missing <param name="csTitle"/> documentation for "M:ElGUI.CSys_ChildWindow.#ctor(System.String,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_ChildWindow.#ctor(System.String,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_ChildWindow.#ctor(System.String,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_ChildWindow Class
ElGUI Namespace


CSys_ChildWindow Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow Methods
CSys_ChildWindow Class See Also Send Feedback

The CSys_ChildWindow type exposes the following members.

Methods

 | Name | Description
Public method | Activate | (Inherited from DockableContent.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Protected method | CanExecuteCommand | (Inherited from DockableContent.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close()()()() | (Inherited from DockableContent.)
Public method | Close(Boolean) | (Inherited from DockableContent.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Protected method | FocusContent | (Inherited from ManagedContent.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetParentManager | (Inherited from ManagedContent.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | (Inherited from DockableContent.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from ManagedContent.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | (Inherited from ManagedContent.)
Protected method | OnClosing | (Inherited from ManagedContent.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentLoaded | (Inherited from DockableContent.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContentUnloaded | (Inherited from DockableContent.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragMouseDown | (Inherited from ManagedContent.)
Protected method | OnDragMouseLeave | (Inherited from ManagedContent.)
Protected method | OnDragMouseMove | (Inherited from DockableContent.)
Protected method | OnDragMouseUp | (Inherited from ManagedContent.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragStart | (Inherited from DockableContent.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnFloatingWindowSizeChanged | (Inherited from ManagedContent.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | (Inherited from ManagedContent.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | (Inherited from DockableContent.)
Protected method | OnIsActiveContentChanged | (Inherited from ManagedContent.)
Protected method | OnIsActiveDocumentChanged | (Inherited from ManagedContent.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | (Inherited from ManagedContent.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | (Inherited from ManagedContent.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManagerChanged | (Inherited from ManagedContent.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from ManagedContent.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStateChanged | (Inherited from DockableContent.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from DockableContent.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Protected method | RaisePropertyChanged | (Inherited from ManagedContent.)
Protected method | RaiseStateChangedEvent | (Inherited from DockableContent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetIsMouseDownFlag | (Inherited from ManagedContent.)
Public method | ResetSavedStateAndPosition | (Inherited from DockableContent.)
Public method | RestoreLayout | (Inherited from DockableContent.)
Public method | SaveLayout | (Inherited from DockableContent.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show()()()() | (Inherited from DockableContent.)
Public method | Show(DockingManager) | (Inherited from DockableContent.)
Public method | Show(AnchorStyle) | (Inherited from DockableContent.)
Public method | Show(DockingManager, AnchorStyle) | (Inherited from DockableContent.)
Public method | ShowAsDocument()()()() | (Inherited from DockableContent.)
Public method | ShowAsDocument(DockingManager) | (Inherited from DockableContent.)
Public method | ShowAsFloatingWindow(Boolean) | (Inherited from DockableContent.)
Public method | ShowAsFloatingWindow(DockingManager, Boolean) | (Inherited from DockableContent.)
Public method | ToggleAutoHide | (Inherited from DockableContent.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_ChildWindow Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..AddHandler Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..ApplyAnimationClock Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..BeginAnimation Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..BeginStoryboard Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..BringIntoView Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..ClearValue Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


Close Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..Close Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Close()()()() | (Inherited from DockableContent.)
Public method | Close(Boolean) | (Inherited from DockableContent.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..HitTestCore Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..SetBinding Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..SetValue Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


Show Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..Show Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Show()()()() | (Inherited from DockableContent.)
Public method | Show(DockingManager) | (Inherited from DockableContent.)
Public method | Show(AnchorStyle) | (Inherited from DockableContent.)
Public method | Show(DockingManager, AnchorStyle) | (Inherited from DockableContent.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


ShowAsDocument Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..ShowAsDocument Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowAsDocument()()()() | (Inherited from DockableContent.)
Public method | ShowAsDocument(DockingManager) | (Inherited from DockableContent.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


ShowAsFloatingWindow Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..ShowAsFloatingWindow Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowAsFloatingWindow(Boolean) | (Inherited from DockableContent.)
Public method | ShowAsFloatingWindow(DockingManager, Boolean) | (Inherited from DockableContent.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow..::..TransformToAncestor Method
CSys_ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_ChildWindow Class
CSys_ChildWindow Members
ElGUI Namespace


CSys_ChildWindow Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow Properties
CSys_ChildWindow Class See Also Send Feedback

The CSys_ChildWindow type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContainerPane | (Inherited from ManagedContent.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultElement | (Inherited from ManagedContent.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DockableStyle | (Inherited from DockableContent.)
Protected property | DragEnabledArea | (Inherited from ManagedContent.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FloatingWindowSize | (Inherited from ManagedContent.)
Public property | FloatingWindowSizeToContent | (Inherited from DockableContent.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | FlyoutWindowSize | (Inherited from DockableContent.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HideOnClose | (Inherited from DockableContent.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | (Inherited from ManagedContent.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActiveContent | (Inherited from ManagedContent.)
Public property | IsActiveDocument | (Inherited from ManagedContent.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCloseable | (Inherited from ManagedContent.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsLocked | (Inherited from ManagedContent.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Protected property | IsMouseDown | (Inherited from ManagedContent.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Manager | (Inherited from ManagedContent.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Protected property | StartDragPoint | (Inherited from ManagedContent.)
Public property | State | (Inherited from DockableContent.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | (Inherited from ManagedContent.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_ChildWindow Class
ElGUI Namespace


CSys_ChildWindow Events

[image] [image]

4 of William Foster's Class Libraries
CSys_ChildWindow Events
CSys_ChildWindow Class See Also Send Feedback

The CSys_ChildWindow type exposes the following members.

Events

 | Name | Description
Public event | Closed | (Inherited from ManagedContent.)
Public event | Closing | (Inherited from ManagedContent.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsActiveContentChanged | (Inherited from ManagedContent.)
Public event | IsActiveDocumentChanged | (Inherited from ManagedContent.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | (Inherited from ManagedContent.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | (Inherited from DockableContent.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_ChildWindow Class
ElGUI Namespace


CSys_ComboControl Class

[image]

4 of William Foster's Class Libraries
CSys_ComboControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_ComboControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_ComboControl : ComboBox,
    ISysWin
Visual Basic
Public Class CSys_ComboControl _
    Inherits ComboBox _
    Implements ISysWin
Visual C++
public ref class CSys_ComboControl : public ComboBox,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls.Primitives..::..Selector
System.Windows.Controls..::..ComboBox
ElGUI..::..CSys_ComboControl

See Also

CSys_ComboControl Members
ElGUI Namespace


CSys_ComboControl Members

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl Members
CSys_ComboControl Class Constructors Methods Properties Events See Also Send Feedback

The CSys_ComboControl type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_ComboControl | Initializes a new instance of the CSys_ComboControl class

Methods

 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from ComboBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ComboBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Called when ApplyTemplate()()()() is called. (Inherited from ComboBox.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ComboBoxAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ComboBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDropDownClosed | Reports when a combo box's popup closes. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Reports when a combo box's popup opens. (Inherited from ComboBox.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ComboBox.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ComboBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when a KeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Called to report that the left mouse button was released. (Inherited from ComboBox.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when a PreviewKeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Responds to a ComboBox selection change by raising a SelectionChanged event. (Inherited from ComboBox.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ComboBox.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a combo box supports scrolling. (Inherited from ComboBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a combo box is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the ComboBox. (Inherited from ComboBox.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the combo box are selectable but not editable. (Inherited from ComboBox.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionBoxHighlighted | Gets whether the SelectionBoxItem is highlighted. (Inherited from ComboBox.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight | Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item that is displayed in the selection box. (Inherited from ComboBox.)
Public property | SelectionBoxItemStringFormat | Gets a composite string that specifies how to format the selected item in the selection box if it is displayed as a string. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the item template of the selection box content. (Inherited from ComboBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | StaysOpenOnEdit | Gets or sets whether a ComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. (Inherited from ComboBox.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text of the currently selected item. (Inherited from ComboBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropDownClosed | Occurs when the drop-down list of the combo box closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down list of the combo box opens. (Inherited from ComboBox.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_ComboControl Class
ElGUI Namespace


CSys_ComboControl Constructor

[image]

4 of William Foster's Class Libraries
CSys_ComboControl Constructor
CSys_ComboControl Class See Also Send Feedback
Initializes a new instance of the CSys_ComboControl class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_ComboControl(
    uint nCols,
    Resource_ID resourceID,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    nCols As UInteger, _
    resourceID As Resource_ID, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_ComboControl(
    unsigned int nCols,
    Resource_ID resourceID,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

nCols
Type: System..::..UInt32

[Missing <param name="nCols"/> documentation for "M:ElGUI.CSys_ComboControl.#ctor(System.UInt32,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.CSys_ComboControl.#ctor(System.UInt32,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_ComboControl.#ctor(System.UInt32,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_ComboControl.#ctor(System.UInt32,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_ComboControl Class
ElGUI Namespace


CSys_ComboControl Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl Methods
CSys_ComboControl Class See Also Send Feedback

The CSys_ComboControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from ComboBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ComboBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Called when ApplyTemplate()()()() is called. (Inherited from ComboBox.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ComboBoxAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ComboBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDropDownClosed | Reports when a combo box's popup closes. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Reports when a combo box's popup opens. (Inherited from ComboBox.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ComboBox.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ComboBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when a KeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Called to report that the left mouse button was released. (Inherited from ComboBox.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when a PreviewKeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Responds to a ComboBox selection change by raising a SelectionChanged event. (Inherited from ComboBox.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ComboBox.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_ComboControl Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl..::..AddHandler Method
CSys_ComboControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_ComboControl Class
CSys_ComboControl Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl..::..ApplyAnimationClock Method
CSys_ComboControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_ComboControl Class
CSys_ComboControl Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl..::..BeginAnimation Method
CSys_ComboControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_ComboControl Class
CSys_ComboControl Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl..::..BeginStoryboard Method
CSys_ComboControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_ComboControl Class
CSys_ComboControl Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl..::..BringIntoView Method
CSys_ComboControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_ComboControl Class
CSys_ComboControl Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl..::..ClearValue Method
CSys_ComboControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_ComboControl Class
CSys_ComboControl Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl..::..HitTestCore Method
CSys_ComboControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_ComboControl Class
CSys_ComboControl Members
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl..::..SetBinding Method
CSys_ComboControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_ComboControl Class
CSys_ComboControl Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl..::..SetValue Method
CSys_ComboControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_ComboControl Class
CSys_ComboControl Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl..::..TransformToAncestor Method
CSys_ComboControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_ComboControl Class
CSys_ComboControl Members
ElGUI Namespace


CSys_ComboControl Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl Properties
CSys_ComboControl Class See Also Send Feedback

The CSys_ComboControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a combo box supports scrolling. (Inherited from ComboBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a combo box is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the ComboBox. (Inherited from ComboBox.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the combo box are selectable but not editable. (Inherited from ComboBox.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionBoxHighlighted | Gets whether the SelectionBoxItem is highlighted. (Inherited from ComboBox.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight | Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item that is displayed in the selection box. (Inherited from ComboBox.)
Public property | SelectionBoxItemStringFormat | Gets a composite string that specifies how to format the selected item in the selection box if it is displayed as a string. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the item template of the selection box content. (Inherited from ComboBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | StaysOpenOnEdit | Gets or sets whether a ComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. (Inherited from ComboBox.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text of the currently selected item. (Inherited from ComboBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_ComboControl Class
ElGUI Namespace


CSys_ComboControl Events

[image] [image]

4 of William Foster's Class Libraries
CSys_ComboControl Events
CSys_ComboControl Class See Also Send Feedback

The CSys_ComboControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropDownClosed | Occurs when the drop-down list of the combo box closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down list of the combo box opens. (Inherited from ComboBox.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_ComboControl Class
ElGUI Namespace


CSys_ControlWindow Class

[image]

4 of William Foster's Class Libraries
CSys_ControlWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_ControlWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_ControlWindow : Control,
    ISysWin
Visual Basic
Public Class CSys_ControlWindow _
    Inherits Control _
    Implements ISysWin
Visual C++
public ref class CSys_ControlWindow : public Control,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
ElGUI..::..CSys_ControlWindow

See Also

CSys_ControlWindow Members
ElGUI Namespace


CSys_ControlWindow Members

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow Members
CSys_ControlWindow Class Constructors Methods Fields Properties Events See Also Send Feedback

The CSys_ControlWindow type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_ControlWindow | Initializes a new instance of the CSys_ControlWindow class

Methods

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDC |
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayer |
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMessage |
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Resize |
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | SwitchSwitcher |
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Fields

Name | Description
sys_colorspace |

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_ControlWindow Class
ElGUI Namespace


CSys_ControlWindow Constructor

[image]

4 of William Foster's Class Libraries
CSys_ControlWindow Constructor
CSys_ControlWindow Class See Also Send Feedback
Initializes a new instance of the CSys_ControlWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_ControlWindow(
    UILayerWindow Layer
)
Visual Basic
Public Sub New ( _
    Layer As UILayerWindow _
)
Visual C++
public:
CSys_ControlWindow(
    UILayerWindow^ Layer
)

Parameters

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_ControlWindow.#ctor(ElGUI.UILayerWindow)"]

See Also

CSys_ControlWindow Class
ElGUI Namespace


CSys_ControlWindow Fields

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow Fields
CSys_ControlWindow Class See Also Send Feedback

The CSys_ControlWindow type exposes the following members.

Fields

Name | Description
sys_colorspace |

See Also

CSys_ControlWindow Class
ElGUI Namespace


sys_colorspace Field

[image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..sys_colorspace Field
CSys_ControlWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.CSys_ControlWindow.sys_colorspace"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ColorSpace sys_colorspace
Visual Basic
Public Shared sys_colorspace As ColorSpace
Visual C++
public:
static ColorSpace^ sys_colorspace

See Also

CSys_ControlWindow Class
ElGUI Namespace


CSys_ControlWindow Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow Methods
CSys_ControlWindow Class See Also Send Feedback

The CSys_ControlWindow type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | CreateDC |
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayer |
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMessage |
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Resize |
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | SwitchSwitcher |
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_ControlWindow Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..AddHandler Method
CSys_ControlWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_ControlWindow Class
CSys_ControlWindow Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..ApplyAnimationClock Method
CSys_ControlWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_ControlWindow Class
CSys_ControlWindow Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..BeginAnimation Method
CSys_ControlWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_ControlWindow Class
CSys_ControlWindow Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..BeginStoryboard Method
CSys_ControlWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_ControlWindow Class
CSys_ControlWindow Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..BringIntoView Method
CSys_ControlWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_ControlWindow Class
CSys_ControlWindow Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..ClearValue Method
CSys_ControlWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_ControlWindow Class
CSys_ControlWindow Members
ElGUI Namespace


CreateDC Method

[image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..CreateDC Method
CSys_ControlWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_ControlWindow.CreateDC(El.Rect2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CreateDC(
    Rect2dU rect2d
)
Visual Basic
Public Function CreateDC ( _
    rect2d As Rect2dU _
) As Boolean
Visual C++
public:
bool CreateDC(
    Rect2dU^ rect2d
)

Parameters

rect2d
Type: Rect2dU

[Missing <param name="rect2d"/> documentation for "M:ElGUI.CSys_ControlWindow.CreateDC(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CSys_ControlWindow.CreateDC(El.Rect2dU)"]

See Also

CSys_ControlWindow Class
ElGUI Namespace


GetLayer Method

[image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..GetLayer Method
CSys_ControlWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_ControlWindow.GetLayer"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected UILayerWindow GetLayer()
Visual Basic
Protected Function GetLayer As UILayerWindow
Visual C++
protected:
UILayerWindow^ GetLayer()

Return Value

[Missing <returns> documentation for "M:ElGUI.CSys_ControlWindow.GetLayer"]

See Also

CSys_ControlWindow Class
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..HitTestCore Method
CSys_ControlWindow Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_ControlWindow Class
CSys_ControlWindow Members
ElGUI Namespace


OnMessage Method

[image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..OnMessage Method
CSys_ControlWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_ControlWindow.OnMessage(ElGUI.Message)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int OnMessage(
    Message msg
)
Visual Basic
Protected Function OnMessage ( _
    msg As Message _
) As Integer
Visual C++
protected:
int OnMessage(
    Message^ msg
)

Parameters

msg
Type: ElGUI..::..Message

[Missing <param name="msg"/> documentation for "M:ElGUI.CSys_ControlWindow.OnMessage(ElGUI.Message)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CSys_ControlWindow.OnMessage(ElGUI.Message)"]

See Also

CSys_ControlWindow Class
ElGUI Namespace


Resize Method

[image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..Resize Method
CSys_ControlWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_ControlWindow.Resize(System.Int32,System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual void Resize(
    int w,
    int h
)
Visual Basic
Public Overridable Sub Resize ( _
    w As Integer, _
    h As Integer _
)
Visual C++
public:
virtual void Resize(
    int w,
    int h
)

Parameters

w
Type: System..::..Int32

[Missing <param name="w"/> documentation for "M:ElGUI.CSys_ControlWindow.Resize(System.Int32,System.Int32)"]

h
Type: System..::..Int32

[Missing <param name="h"/> documentation for "M:ElGUI.CSys_ControlWindow.Resize(System.Int32,System.Int32)"]

See Also

CSys_ControlWindow Class
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..SetBinding Method
CSys_ControlWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_ControlWindow Class
CSys_ControlWindow Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..SetValue Method
CSys_ControlWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_ControlWindow Class
CSys_ControlWindow Members
ElGUI Namespace


SwitchSwitcher Method

[image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..SwitchSwitcher Method
CSys_ControlWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_ControlWindow.SwitchSwitcher(System.UInt32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SwitchSwitcher(
    uint nPane
)
Visual Basic
Public Sub SwitchSwitcher ( _
    nPane As UInteger _
)
Visual C++
public:
void SwitchSwitcher(
    unsigned int nPane
)

Parameters

nPane
Type: System..::..UInt32

[Missing <param name="nPane"/> documentation for "M:ElGUI.CSys_ControlWindow.SwitchSwitcher(System.UInt32)"]

See Also

CSys_ControlWindow Class
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow..::..TransformToAncestor Method
CSys_ControlWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_ControlWindow Class
CSys_ControlWindow Members
ElGUI Namespace


CSys_ControlWindow Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow Properties
CSys_ControlWindow Class See Also Send Feedback

The CSys_ControlWindow type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_ControlWindow Class
ElGUI Namespace


CSys_ControlWindow Events

[image] [image]

4 of William Foster's Class Libraries
CSys_ControlWindow Events
CSys_ControlWindow Class See Also Send Feedback

The CSys_ControlWindow type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_ControlWindow Class
ElGUI Namespace


CSys_DialogWindow Class

[image]

4 of William Foster's Class Libraries
CSys_DialogWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_DialogWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_DialogWindow : Window,
    ISysWin
Visual Basic
Public Class CSys_DialogWindow _
    Inherits Window _
    Implements ISysWin
Visual C++
public ref class CSys_DialogWindow : public Window,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows..::..Window
ElGUI..::..CSys_DialogWindow

See Also

CSys_DialogWindow Members
ElGUI Namespace


CSys_DialogWindow Members

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow Members
CSys_DialogWindow Class Constructors Methods Properties Events See Also Send Feedback

The CSys_DialogWindow type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_DialogWindow | Initializes a new instance of the CSys_DialogWindow class

Methods

 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddSpacer |
Public method | AddSwitcher |
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | Execute |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MakeNormal |
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog()()()() method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)

Events

 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close()()()() is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_DialogWindow Class
ElGUI Namespace


CSys_DialogWindow Constructor

[image]

4 of William Foster's Class Libraries
CSys_DialogWindow Constructor
CSys_DialogWindow Class See Also Send Feedback
Initializes a new instance of the CSys_DialogWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_DialogWindow(
    string csText,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    csText As String, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_DialogWindow(
    String^ csText,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

csText
Type: System..::..String

[Missing <param name="csText"/> documentation for "M:ElGUI.CSys_DialogWindow.#ctor(System.String,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_DialogWindow.#ctor(System.String,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_DialogWindow.#ctor(System.String,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_DialogWindow Class
ElGUI Namespace


CSys_DialogWindow Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow Methods
CSys_DialogWindow Class See Also Send Feedback

The CSys_DialogWindow type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddSpacer |
Public method | AddSwitcher |
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | Execute |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | MakeNormal |
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_DialogWindow Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..AddHandler Method
CSys_DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_DialogWindow Class
CSys_DialogWindow Members
ElGUI Namespace


AddSpacer Method

[image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..AddSpacer Method
CSys_DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_DialogWindow.AddSpacer(System.UInt32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddSpacer(
    uint nCount
)
Visual Basic
Public Sub AddSpacer ( _
    nCount As UInteger _
)
Visual C++
public:
void AddSpacer(
    unsigned int nCount
)

Parameters

nCount
Type: System..::..UInt32

[Missing <param name="nCount"/> documentation for "M:ElGUI.CSys_DialogWindow.AddSpacer(System.UInt32)"]

See Also

CSys_DialogWindow Class
ElGUI Namespace


AddSwitcher Method

[image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..AddSwitcher Method
CSys_DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_DialogWindow.AddSwitcher(ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddSwitcher(
    Resource_ID rID
)
Visual Basic
Public Sub AddSwitcher ( _
    rID As Resource_ID _
)
Visual C++
public:
void AddSwitcher(
    Resource_ID rID
)

Parameters

rID
Type: ElGUI..::..Resource_ID

[Missing <param name="rID"/> documentation for "M:ElGUI.CSys_DialogWindow.AddSwitcher(ElGUI.Resource_ID)"]

See Also

CSys_DialogWindow Class
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..ApplyAnimationClock Method
CSys_DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_DialogWindow Class
CSys_DialogWindow Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..BeginAnimation Method
CSys_DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_DialogWindow Class
CSys_DialogWindow Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..BeginStoryboard Method
CSys_DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_DialogWindow Class
CSys_DialogWindow Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..BringIntoView Method
CSys_DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_DialogWindow Class
CSys_DialogWindow Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..ClearValue Method
CSys_DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_DialogWindow Class
CSys_DialogWindow Members
ElGUI Namespace


Execute Method

[image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..Execute Method
CSys_DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_DialogWindow.Execute"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Execute()
Visual Basic
Public Function Execute As Integer
Visual C++
public:
int Execute()

Return Value

[Missing <returns> documentation for "M:ElGUI.CSys_DialogWindow.Execute"]

See Also

CSys_DialogWindow Class
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..HitTestCore Method
CSys_DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_DialogWindow Class
CSys_DialogWindow Members
ElGUI Namespace


MakeNormal Method

[image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..MakeNormal Method
CSys_DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_DialogWindow.MakeNormal"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void MakeNormal()
Visual Basic
Public Sub MakeNormal
Visual C++
public:
void MakeNormal()

See Also

CSys_DialogWindow Class
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..SetBinding Method
CSys_DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_DialogWindow Class
CSys_DialogWindow Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..SetValue Method
CSys_DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_DialogWindow Class
CSys_DialogWindow Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow..::..TransformToAncestor Method
CSys_DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_DialogWindow Class
CSys_DialogWindow Members
ElGUI Namespace


CSys_DialogWindow Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow Properties
CSys_DialogWindow Class See Also Send Feedback

The CSys_DialogWindow type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog()()()() method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)

See Also

CSys_DialogWindow Class
ElGUI Namespace


CSys_DialogWindow Events

[image] [image]

4 of William Foster's Class Libraries
CSys_DialogWindow Events
CSys_DialogWindow Class See Also Send Feedback

The CSys_DialogWindow type exposes the following members.

Events

 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close()()()() is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_DialogWindow Class
ElGUI Namespace


CSys_LabelControl Class

[image]

4 of William Foster's Class Libraries
CSys_LabelControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_LabelControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_LabelControl : Label,
    ISysWin
Visual Basic
Public Class CSys_LabelControl _
    Inherits Label _
    Implements ISysWin
Visual C++
public ref class CSys_LabelControl : public Label,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls..::..Label
ElGUI..::..CSys_LabelControl

See Also

CSys_LabelControl Members
ElGUI Namespace


CSys_LabelControl Members

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl Members
CSys_LabelControl Class Constructors Methods Properties Events See Also Send Feedback

The CSys_LabelControl type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_LabelControl | Initializes a new instance of the CSys_LabelControl class

Methods

 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate LabelAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from Label.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Target | Gets or sets the element that receives focus when the user presses the label's access key. (Inherited from Label.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_LabelControl Class
ElGUI Namespace


CSys_LabelControl Constructor

[image]

4 of William Foster's Class Libraries
CSys_LabelControl Constructor
CSys_LabelControl Class See Also Send Feedback
Initializes a new instance of the CSys_LabelControl class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_LabelControl(
    string csText,
    Resource_ID resourceID,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    csText As String, _
    resourceID As Resource_ID, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_LabelControl(
    String^ csText,
    Resource_ID resourceID,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

csText
Type: System..::..String

[Missing <param name="csText"/> documentation for "M:ElGUI.CSys_LabelControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.CSys_LabelControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_LabelControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_LabelControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_LabelControl Class
ElGUI Namespace


CSys_LabelControl Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl Methods
CSys_LabelControl Class See Also Send Feedback

The CSys_LabelControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate LabelAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from Label.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_LabelControl Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl..::..AddHandler Method
CSys_LabelControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_LabelControl Class
CSys_LabelControl Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl..::..ApplyAnimationClock Method
CSys_LabelControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_LabelControl Class
CSys_LabelControl Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl..::..BeginAnimation Method
CSys_LabelControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_LabelControl Class
CSys_LabelControl Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl..::..BeginStoryboard Method
CSys_LabelControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_LabelControl Class
CSys_LabelControl Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl..::..BringIntoView Method
CSys_LabelControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_LabelControl Class
CSys_LabelControl Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl..::..ClearValue Method
CSys_LabelControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_LabelControl Class
CSys_LabelControl Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl..::..HitTestCore Method
CSys_LabelControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_LabelControl Class
CSys_LabelControl Members
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl..::..SetBinding Method
CSys_LabelControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_LabelControl Class
CSys_LabelControl Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl..::..SetValue Method
CSys_LabelControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_LabelControl Class
CSys_LabelControl Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl..::..TransformToAncestor Method
CSys_LabelControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_LabelControl Class
CSys_LabelControl Members
ElGUI Namespace


CSys_LabelControl Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl Properties
CSys_LabelControl Class See Also Send Feedback

The CSys_LabelControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Target | Gets or sets the element that receives focus when the user presses the label's access key. (Inherited from Label.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_LabelControl Class
ElGUI Namespace


CSys_LabelControl Events

[image] [image]

4 of William Foster's Class Libraries
CSys_LabelControl Events
CSys_LabelControl Class See Also Send Feedback

The CSys_LabelControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_LabelControl Class
ElGUI Namespace


CSys_ListboxControl Class

[image]

4 of William Foster's Class Libraries
CSys_ListboxControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_ListboxControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_ListboxControl : ListBox,
    ISysWin
Visual Basic
Public Class CSys_ListboxControl _
    Inherits ListBox _
    Implements ISysWin
Visual C++
public ref class CSys_ListboxControl : public ListBox,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls.Primitives..::..Selector
System.Windows.Controls..::..ListBox
ElGUI..::..CSys_ListboxControl

See Also

CSys_ListboxControl Members
ElGUI Namespace


CSys_ListboxControl Members

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl Members
CSys_ListboxControl Class Constructors Methods Properties Events See Also Send Feedback

The CSys_ListboxControl type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_ListboxControl | Initializes a new instance of the CSys_ListboxControl class

Methods

 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display a specified item. (Inherited from ListBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_ListboxControl Class
ElGUI Namespace


CSys_ListboxControl Constructor

[image]

4 of William Foster's Class Libraries
CSys_ListboxControl Constructor
CSys_ListboxControl Class See Also Send Feedback
Initializes a new instance of the CSys_ListboxControl class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_ListboxControl(
    Resource_ID resourceID,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    resourceID As Resource_ID, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_ListboxControl(
    Resource_ID resourceID,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.CSys_ListboxControl.#ctor(ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_ListboxControl.#ctor(ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_ListboxControl.#ctor(ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_ListboxControl Class
ElGUI Namespace


CSys_ListboxControl Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl Methods
CSys_ListboxControl Class See Also Send Feedback

The CSys_ListboxControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display a specified item. (Inherited from ListBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_ListboxControl Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl..::..AddHandler Method
CSys_ListboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_ListboxControl Class
CSys_ListboxControl Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl..::..ApplyAnimationClock Method
CSys_ListboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_ListboxControl Class
CSys_ListboxControl Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl..::..BeginAnimation Method
CSys_ListboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_ListboxControl Class
CSys_ListboxControl Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl..::..BeginStoryboard Method
CSys_ListboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_ListboxControl Class
CSys_ListboxControl Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl..::..BringIntoView Method
CSys_ListboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_ListboxControl Class
CSys_ListboxControl Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl..::..ClearValue Method
CSys_ListboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_ListboxControl Class
CSys_ListboxControl Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl..::..HitTestCore Method
CSys_ListboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_ListboxControl Class
CSys_ListboxControl Members
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl..::..SetBinding Method
CSys_ListboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_ListboxControl Class
CSys_ListboxControl Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl..::..SetValue Method
CSys_ListboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_ListboxControl Class
CSys_ListboxControl Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl..::..TransformToAncestor Method
CSys_ListboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_ListboxControl Class
CSys_ListboxControl Members
ElGUI Namespace


CSys_ListboxControl Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl Properties
CSys_ListboxControl Class See Also Send Feedback

The CSys_ListboxControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_ListboxControl Class
ElGUI Namespace


CSys_ListboxControl Events

[image] [image]

4 of William Foster's Class Libraries
CSys_ListboxControl Events
CSys_ListboxControl Class See Also Send Feedback

The CSys_ListboxControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_ListboxControl Class
ElGUI Namespace


CSys_ListControl Class

[image]

4 of William Foster's Class Libraries
CSys_ListControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_ListControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_ListControl : ListView,
    ISysWin
Visual Basic
Public Class CSys_ListControl _
    Inherits ListView _
    Implements ISysWin
Visual C++
public ref class CSys_ListControl : public ListView,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls.Primitives..::..Selector
System.Windows.Controls..::..ListBox
System.Windows.Controls..::..ListView
ElGUI..::..CSys_ListControl

See Also

CSys_ListControl Members
ElGUI Namespace


CSys_ListControl Members

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl Members
CSys_ListControl Class Constructors Methods Properties Events See Also Send Feedback

The CSys_ListControl type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_ListControl | Initializes a new instance of the CSys_ListControl class

Methods

 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes all templates, styles, and bindings for the object that is displayed as a ListViewItem. (Inherited from ListView.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates and returns a new ListViewItem container. (Inherited from ListView.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines whether an object is a ListViewItem. (Inherited from ListView.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Defines an AutomationPeer for the ListView control. (Inherited from ListView.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Responds to an OnItemsChanged(NotifyCollectionChangedEventArgs). (Inherited from ListView.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Sets the styles, templates, and bindings for a ListViewItem. (Inherited from ListView.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | View | Gets or sets an object that defines how the data is styled and organized in a ListView control. (Inherited from ListView.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_ListControl Class
ElGUI Namespace


CSys_ListControl Constructor

[image]

4 of William Foster's Class Libraries
CSys_ListControl Constructor
CSys_ListControl Class See Also Send Feedback
Initializes a new instance of the CSys_ListControl class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_ListControl(
    Resource_ID resourceID,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    resourceID As Resource_ID, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_ListControl(
    Resource_ID resourceID,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.CSys_ListControl.#ctor(ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_ListControl.#ctor(ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_ListControl.#ctor(ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_ListControl Class
ElGUI Namespace


CSys_ListControl Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl Methods
CSys_ListControl Class See Also Send Feedback

The CSys_ListControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes all templates, styles, and bindings for the object that is displayed as a ListViewItem. (Inherited from ListView.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates and returns a new ListViewItem container. (Inherited from ListView.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines whether an object is a ListViewItem. (Inherited from ListView.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Defines an AutomationPeer for the ListView control. (Inherited from ListView.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Responds to an OnItemsChanged(NotifyCollectionChangedEventArgs). (Inherited from ListView.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Sets the styles, templates, and bindings for a ListViewItem. (Inherited from ListView.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_ListControl Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl..::..AddHandler Method
CSys_ListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_ListControl Class
CSys_ListControl Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl..::..ApplyAnimationClock Method
CSys_ListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_ListControl Class
CSys_ListControl Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl..::..BeginAnimation Method
CSys_ListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_ListControl Class
CSys_ListControl Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl..::..BeginStoryboard Method
CSys_ListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_ListControl Class
CSys_ListControl Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl..::..BringIntoView Method
CSys_ListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_ListControl Class
CSys_ListControl Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl..::..ClearValue Method
CSys_ListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_ListControl Class
CSys_ListControl Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl..::..HitTestCore Method
CSys_ListControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_ListControl Class
CSys_ListControl Members
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl..::..SetBinding Method
CSys_ListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_ListControl Class
CSys_ListControl Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl..::..SetValue Method
CSys_ListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_ListControl Class
CSys_ListControl Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl..::..TransformToAncestor Method
CSys_ListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_ListControl Class
CSys_ListControl Members
ElGUI Namespace


CSys_ListControl Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl Properties
CSys_ListControl Class See Also Send Feedback

The CSys_ListControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | View | Gets or sets an object that defines how the data is styled and organized in a ListView control. (Inherited from ListView.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_ListControl Class
ElGUI Namespace


CSys_ListControl Events

[image] [image]

4 of William Foster's Class Libraries
CSys_ListControl Events
CSys_ListControl Class See Also Send Feedback

The CSys_ListControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_ListControl Class
ElGUI Namespace


CSys_MainWindow Class

[image]

4 of William Foster's Class Libraries
CSys_MainWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_MainWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_MainWindow : Window,
    ISysWin
Visual Basic
Public Class CSys_MainWindow _
    Inherits Window _
    Implements ISysWin
Visual C++
public ref class CSys_MainWindow : public Window,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows..::..Window
ElGUI..::..CSys_MainWindow

See Also

CSys_MainWindow Members
ElGUI Namespace


CSys_MainWindow Members

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow Members
CSys_MainWindow Class Constructors Methods Properties Events See Also Send Feedback

The CSys_MainWindow type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_MainWindow | Initializes a new instance of the CSys_MainWindow class

Methods

 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | (Overrides Window..::..OnSourceInitialized(EventArgs).)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog()()()() method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)

Events

 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close()()()() is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_MainWindow Class
ElGUI Namespace


CSys_MainWindow Constructor

[image]

4 of William Foster's Class Libraries
CSys_MainWindow Constructor
CSys_MainWindow Class See Also Send Feedback
Initializes a new instance of the CSys_MainWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_MainWindow(
    string csTitle,
    UILayerWindow Layer
)
Visual Basic
Public Sub New ( _
    csTitle As String, _
    Layer As UILayerWindow _
)
Visual C++
public:
CSys_MainWindow(
    String^ csTitle,
    UILayerWindow^ Layer
)

Parameters

csTitle
Type: System..::..String

[Missing <param name="csTitle"/> documentation for "M:ElGUI.CSys_MainWindow.#ctor(System.String,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_MainWindow.#ctor(System.String,ElGUI.UILayerWindow)"]

See Also

CSys_MainWindow Class
ElGUI Namespace


CSys_MainWindow Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow Methods
CSys_MainWindow Class See Also Send Feedback

The CSys_MainWindow type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | (Overrides Window..::..OnSourceInitialized(EventArgs).)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_MainWindow Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow..::..AddHandler Method
CSys_MainWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_MainWindow Class
CSys_MainWindow Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow..::..ApplyAnimationClock Method
CSys_MainWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_MainWindow Class
CSys_MainWindow Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow..::..BeginAnimation Method
CSys_MainWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_MainWindow Class
CSys_MainWindow Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow..::..BeginStoryboard Method
CSys_MainWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_MainWindow Class
CSys_MainWindow Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow..::..BringIntoView Method
CSys_MainWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_MainWindow Class
CSys_MainWindow Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow..::..ClearValue Method
CSys_MainWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_MainWindow Class
CSys_MainWindow Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow..::..HitTestCore Method
CSys_MainWindow Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_MainWindow Class
CSys_MainWindow Members
ElGUI Namespace


OnSourceInitialized Method

[image]

4 of William Foster's Class Libraries
CSys_MainWindow..::..OnSourceInitialized Method
CSys_MainWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_MainWindow.OnSourceInitialized(System.EventArgs)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnSourceInitialized(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSourceInitialized ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSourceInitialized(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

[Missing <param name="e"/> documentation for "M:ElGUI.CSys_MainWindow.OnSourceInitialized(System.EventArgs)"]

See Also

CSys_MainWindow Class
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow..::..SetBinding Method
CSys_MainWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_MainWindow Class
CSys_MainWindow Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow..::..SetValue Method
CSys_MainWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_MainWindow Class
CSys_MainWindow Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow..::..TransformToAncestor Method
CSys_MainWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_MainWindow Class
CSys_MainWindow Members
ElGUI Namespace


CSys_MainWindow Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow Properties
CSys_MainWindow Class See Also Send Feedback

The CSys_MainWindow type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog()()()() method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)

See Also

CSys_MainWindow Class
ElGUI Namespace


CSys_MainWindow Events

[image] [image]

4 of William Foster's Class Libraries
CSys_MainWindow Events
CSys_MainWindow Class See Also Send Feedback

The CSys_MainWindow type exposes the following members.

Events

 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close()()()() is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_MainWindow Class
ElGUI Namespace


CSys_RadioButtonControl Class

[image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_RadioButtonControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_RadioButtonControl : RadioButton,
    ISysWin
Visual Basic
Public Class CSys_RadioButtonControl _
    Inherits RadioButton _
    Implements ISysWin
Visual C++
public ref class CSys_RadioButtonControl : public RadioButton,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls.Primitives..::..ButtonBase
System.Windows.Controls.Primitives..::..ToggleButton
System.Windows.Controls..::..RadioButton
ElGUI..::..CSys_RadioButtonControl

See Also

CSys_RadioButtonControl Members
ElGUI Namespace


CSys_RadioButtonControl Members

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl Members
CSys_RadioButtonControl Class Constructors Methods Properties Events See Also Send Feedback

The CSys_RadioButtonControl type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_RadioButtonControl | Initializes a new instance of the CSys_RadioButtonControl class

Methods

 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Called when the AccessKey for a radio button is invoked. (Inherited from RadioButton.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChecked | Called when the IsChecked property becomes true. (Inherited from RadioButton.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a control is clicked by the mouse or the keyboard. (Inherited from ToggleButton.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate RadioButtonAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from RadioButton.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnIndeterminate | Called when a ToggleButton raises an Indeterminate event. (Inherited from ToggleButton.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToggle | Called by the OnClick()()()() method to implement a RadioButton control's toggle behavior. (Inherited from RadioButton.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnchecked | Called when a ToggleButton raises an Unchecked event. (Inherited from ToggleButton.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a ToggleButton object. (Inherited from ToggleButton.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupName | Gets or sets the name that specifies which RadioButton controls are mutually exclusive. (Inherited from RadioButton.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsChecked | Gets or sets whether the ToggleButton is checked. (Inherited from ToggleButton.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsThreeState | Determines whether the control supports two or three states. (Inherited from ToggleButton.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | Checked | Occurs when a ToggleButton is checked. (Inherited from ToggleButton.)
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Indeterminate | Occurs when the state of a ToggleButton is neither on nor off. (Inherited from ToggleButton.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unchecked | Occurs when a ToggleButton is unchecked. (Inherited from ToggleButton.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_RadioButtonControl Class
ElGUI Namespace


CSys_RadioButtonControl Constructor

[image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl Constructor
CSys_RadioButtonControl Class See Also Send Feedback
Initializes a new instance of the CSys_RadioButtonControl class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_RadioButtonControl(
    string csText,
    Resource_ID resourceID,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    csText As String, _
    resourceID As Resource_ID, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_RadioButtonControl(
    String^ csText,
    Resource_ID resourceID,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

csText
Type: System..::..String

[Missing <param name="csText"/> documentation for "M:ElGUI.CSys_RadioButtonControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.CSys_RadioButtonControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_RadioButtonControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_RadioButtonControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_RadioButtonControl Class
ElGUI Namespace


CSys_RadioButtonControl Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl Methods
CSys_RadioButtonControl Class See Also Send Feedback

The CSys_RadioButtonControl type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Called when the AccessKey for a radio button is invoked. (Inherited from RadioButton.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChecked | Called when the IsChecked property becomes true. (Inherited from RadioButton.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a control is clicked by the mouse or the keyboard. (Inherited from ToggleButton.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate RadioButtonAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from RadioButton.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnIndeterminate | Called when a ToggleButton raises an Indeterminate event. (Inherited from ToggleButton.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToggle | Called by the OnClick()()()() method to implement a RadioButton control's toggle behavior. (Inherited from RadioButton.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnchecked | Called when a ToggleButton raises an Unchecked event. (Inherited from ToggleButton.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a ToggleButton object. (Inherited from ToggleButton.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_RadioButtonControl Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl..::..AddHandler Method
CSys_RadioButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_RadioButtonControl Class
CSys_RadioButtonControl Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl..::..ApplyAnimationClock Method
CSys_RadioButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_RadioButtonControl Class
CSys_RadioButtonControl Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl..::..BeginAnimation Method
CSys_RadioButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_RadioButtonControl Class
CSys_RadioButtonControl Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl..::..BeginStoryboard Method
CSys_RadioButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_RadioButtonControl Class
CSys_RadioButtonControl Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl..::..BringIntoView Method
CSys_RadioButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_RadioButtonControl Class
CSys_RadioButtonControl Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl..::..ClearValue Method
CSys_RadioButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_RadioButtonControl Class
CSys_RadioButtonControl Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl..::..HitTestCore Method
CSys_RadioButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_RadioButtonControl Class
CSys_RadioButtonControl Members
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl..::..SetBinding Method
CSys_RadioButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_RadioButtonControl Class
CSys_RadioButtonControl Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl..::..SetValue Method
CSys_RadioButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_RadioButtonControl Class
CSys_RadioButtonControl Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl..::..TransformToAncestor Method
CSys_RadioButtonControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_RadioButtonControl Class
CSys_RadioButtonControl Members
ElGUI Namespace


CSys_RadioButtonControl Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl Properties
CSys_RadioButtonControl Class See Also Send Feedback

The CSys_RadioButtonControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupName | Gets or sets the name that specifies which RadioButton controls are mutually exclusive. (Inherited from RadioButton.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsChecked | Gets or sets whether the ToggleButton is checked. (Inherited from ToggleButton.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsThreeState | Determines whether the control supports two or three states. (Inherited from ToggleButton.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_RadioButtonControl Class
ElGUI Namespace


CSys_RadioButtonControl Events

[image] [image]

4 of William Foster's Class Libraries
CSys_RadioButtonControl Events
CSys_RadioButtonControl Class See Also Send Feedback

The CSys_RadioButtonControl type exposes the following members.

Events

 | Name | Description
Public event | Checked | Occurs when a ToggleButton is checked. (Inherited from ToggleButton.)
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Indeterminate | Occurs when the state of a ToggleButton is neither on nor off. (Inherited from ToggleButton.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unchecked | Occurs when a ToggleButton is unchecked. (Inherited from ToggleButton.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_RadioButtonControl Class
ElGUI Namespace


CSys_SliderControl Class

[image]

4 of William Foster's Class Libraries
CSys_SliderControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_SliderControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_SliderControl : Slider,
    ISysWin
Visual Basic
Public Class CSys_SliderControl _
    Inherits Slider _
    Implements ISysWin
Visual C++
public ref class CSys_SliderControl : public Slider,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls.Primitives..::..RangeBase
System.Windows.Controls..::..Slider
ElGUI..::..CSys_SliderControl

See Also

CSys_SliderControl Members
ElGUI Namespace


CSys_SliderControl Members

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl Members
CSys_SliderControl Class Constructors Methods Properties Events See Also Send Feedback

The CSys_SliderControl type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_SliderControl | Initializes a new instance of the CSys_SliderControl class

Methods

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of a Slider and determines its Size. (Inherited from Slider.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Builds the visual tree for the Slider control. (Inherited from Slider.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates an AutomationPeer for the Slider. (Inherited from Slider.)
Protected method | OnDecreaseLarge | Responds to the DecreaseLarge command. (Inherited from Slider.)
Protected method | OnDecreaseSmall | Responds to a DecreaseSmall command. (Inherited from Slider.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnIncreaseLarge | Responds to an IncreaseLarge command. (Inherited from Slider.)
Protected method | OnIncreaseSmall | Responds to an IncreaseSmall command. (Inherited from Slider.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMaximizeValue | Responds to the MaximizeValue command. (Inherited from Slider.)
Protected method | OnMaximumChanged | Responds to a change in the value of the Maximum property. (Inherited from Slider.)
Protected method | OnMinimizeValue | Responds to a MinimizeValue command. (Inherited from Slider.)
Protected method | OnMinimumChanged | Responds to a change in the value of the Minimum property. (Inherited from Slider.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Provides class handling for the PreviewMouseLeftButtonDown routed event. (Inherited from Slider.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnThumbDragCompleted | Provides class handling for the DragCompleted event that occurs when the user stops dragging the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragDelta | Provides class handling for the DragDelta event that occurs when the user drags the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragStarted | Provides class handling for the DragStarted event that occurs when the user starts to drag the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnValueChanged | Updates the current position of the Slider when the Value property changes. (Inherited from Slider.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetRange |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoToolTipPlacement | Gets or sets whether a tooltip that contains the current value of the Slider displays when the Thumb is pressed. If a tooltip is displayed, this property also specifies the placement of the tooltip. (Inherited from Slider.)
Public property | AutoToolTipPrecision | Gets or sets the number of digits that are displayed to the right side of the decimal point for the Value of the Slider in a tooltip. (Inherited from Slider.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | Delay | Gets or sets the amount of time in milliseconds that a RepeatButton waits, while it is pressed, before a command to move the Thumb executes, such as a DecreaseLarge command. (Inherited from Slider.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | Interval | Gets or sets the amount of time in milliseconds between increase or decrease commands when a user clicks the RepeatButton of a Slider. (Inherited from Slider.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDirectionReversed | Gets or sets the direction of increasing value. (Inherited from Slider.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsMoveToPointEnabled | Gets or sets a value that indicates whether the Thumb of a Slider moves immediately to the location of the mouse click that occurs while the mouse pointer pauses on the Slider track. (Inherited from Slider.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionRangeEnabled | Gets or sets a value that indicates whether the Slider displays a selection range along the Slider. (Inherited from Slider.)
Public property | IsSnapToTickEnabled | Gets or sets a value that indicates whether the Slider automatically moves the Thumb to the closest tick mark. (Inherited from Slider.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of a Slider. (Inherited from Slider.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectionEnd | Gets or sets the largest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SelectionStart | Gets or sets the smallest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | TickFrequency | Gets or sets the interval between tick marks. (Inherited from Slider.)
Public property | TickPlacement | Gets or sets the position of tick marks with respect to the Track of the Slider. (Inherited from Slider.)
Public property | Ticks | Gets or sets the positions of the tick marks to display for a Slider. (Inherited from Slider.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)

See Also

CSys_SliderControl Class
ElGUI Namespace


CSys_SliderControl Constructor

[image]

4 of William Foster's Class Libraries
CSys_SliderControl Constructor
CSys_SliderControl Class See Also Send Feedback
Initializes a new instance of the CSys_SliderControl class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_SliderControl(
    string csText,
    Resource_ID resourceID,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    csText As String, _
    resourceID As Resource_ID, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_SliderControl(
    String^ csText,
    Resource_ID resourceID,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

csText
Type: System..::..String

[Missing <param name="csText"/> documentation for "M:ElGUI.CSys_SliderControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.CSys_SliderControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_SliderControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_SliderControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_SliderControl Class
ElGUI Namespace


CSys_SliderControl Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl Methods
CSys_SliderControl Class See Also Send Feedback

The CSys_SliderControl type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of a Slider and determines its Size. (Inherited from Slider.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Builds the visual tree for the Slider control. (Inherited from Slider.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates an AutomationPeer for the Slider. (Inherited from Slider.)
Protected method | OnDecreaseLarge | Responds to the DecreaseLarge command. (Inherited from Slider.)
Protected method | OnDecreaseSmall | Responds to a DecreaseSmall command. (Inherited from Slider.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnIncreaseLarge | Responds to an IncreaseLarge command. (Inherited from Slider.)
Protected method | OnIncreaseSmall | Responds to an IncreaseSmall command. (Inherited from Slider.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMaximizeValue | Responds to the MaximizeValue command. (Inherited from Slider.)
Protected method | OnMaximumChanged | Responds to a change in the value of the Maximum property. (Inherited from Slider.)
Protected method | OnMinimizeValue | Responds to a MinimizeValue command. (Inherited from Slider.)
Protected method | OnMinimumChanged | Responds to a change in the value of the Minimum property. (Inherited from Slider.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Provides class handling for the PreviewMouseLeftButtonDown routed event. (Inherited from Slider.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnThumbDragCompleted | Provides class handling for the DragCompleted event that occurs when the user stops dragging the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragDelta | Provides class handling for the DragDelta event that occurs when the user drags the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragStarted | Provides class handling for the DragStarted event that occurs when the user starts to drag the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnValueChanged | Updates the current position of the Slider when the Value property changes. (Inherited from Slider.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetRange |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_SliderControl Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl..::..AddHandler Method
CSys_SliderControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_SliderControl Class
CSys_SliderControl Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl..::..ApplyAnimationClock Method
CSys_SliderControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_SliderControl Class
CSys_SliderControl Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl..::..BeginAnimation Method
CSys_SliderControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_SliderControl Class
CSys_SliderControl Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl..::..BeginStoryboard Method
CSys_SliderControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_SliderControl Class
CSys_SliderControl Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl..::..BringIntoView Method
CSys_SliderControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_SliderControl Class
CSys_SliderControl Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl..::..ClearValue Method
CSys_SliderControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_SliderControl Class
CSys_SliderControl Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl..::..HitTestCore Method
CSys_SliderControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_SliderControl Class
CSys_SliderControl Members
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl..::..SetBinding Method
CSys_SliderControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_SliderControl Class
CSys_SliderControl Members
ElGUI Namespace


SetRange Method

[image]

4 of William Foster's Class Libraries
CSys_SliderControl..::..SetRange Method
CSys_SliderControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_SliderControl.SetRange(El.Range2d)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetRange(
    Range2d range
)
Visual Basic
Public Sub SetRange ( _
    range As Range2d _
)
Visual C++
public:
void SetRange(
    Range2d^ range
)

Parameters

range
Type: Range2d

[Missing <param name="range"/> documentation for "M:ElGUI.CSys_SliderControl.SetRange(El.Range2d)"]

See Also

CSys_SliderControl Class
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl..::..SetValue Method
CSys_SliderControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_SliderControl Class
CSys_SliderControl Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl..::..TransformToAncestor Method
CSys_SliderControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_SliderControl Class
CSys_SliderControl Members
ElGUI Namespace


CSys_SliderControl Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl Properties
CSys_SliderControl Class See Also Send Feedback

The CSys_SliderControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoToolTipPlacement | Gets or sets whether a tooltip that contains the current value of the Slider displays when the Thumb is pressed. If a tooltip is displayed, this property also specifies the placement of the tooltip. (Inherited from Slider.)
Public property | AutoToolTipPrecision | Gets or sets the number of digits that are displayed to the right side of the decimal point for the Value of the Slider in a tooltip. (Inherited from Slider.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | Delay | Gets or sets the amount of time in milliseconds that a RepeatButton waits, while it is pressed, before a command to move the Thumb executes, such as a DecreaseLarge command. (Inherited from Slider.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | Interval | Gets or sets the amount of time in milliseconds between increase or decrease commands when a user clicks the RepeatButton of a Slider. (Inherited from Slider.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDirectionReversed | Gets or sets the direction of increasing value. (Inherited from Slider.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsMoveToPointEnabled | Gets or sets a value that indicates whether the Thumb of a Slider moves immediately to the location of the mouse click that occurs while the mouse pointer pauses on the Slider track. (Inherited from Slider.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionRangeEnabled | Gets or sets a value that indicates whether the Slider displays a selection range along the Slider. (Inherited from Slider.)
Public property | IsSnapToTickEnabled | Gets or sets a value that indicates whether the Slider automatically moves the Thumb to the closest tick mark. (Inherited from Slider.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of a Slider. (Inherited from Slider.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectionEnd | Gets or sets the largest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SelectionStart | Gets or sets the smallest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | TickFrequency | Gets or sets the interval between tick marks. (Inherited from Slider.)
Public property | TickPlacement | Gets or sets the position of tick marks with respect to the Track of the Slider. (Inherited from Slider.)
Public property | Ticks | Gets or sets the positions of the tick marks to display for a Slider. (Inherited from Slider.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_SliderControl Class
ElGUI Namespace


CSys_SliderControl Events

[image] [image]

4 of William Foster's Class Libraries
CSys_SliderControl Events
CSys_SliderControl Class See Also Send Feedback

The CSys_SliderControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)

See Also

CSys_SliderControl Class
ElGUI Namespace


CSys_Tab Class

[image]

4 of William Foster's Class Libraries
CSys_Tab Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_Tab"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_Tab : DocumentContent, ISysWin
Visual Basic
Public Class CSys_Tab _
    Inherits DocumentContent _
    Implements ISysWin
Visual C++
public ref class CSys_Tab : public DocumentContent,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
ManagedContent
DocumentContent
ElGUI..::..CSys_Tab

See Also

CSys_Tab Members
ElGUI Namespace


CSys_Tab Members

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab Members
CSys_Tab Class Constructors Methods Properties Events See Also Send Feedback

The CSys_Tab type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_Tab | Initializes a new instance of the CSys_Tab class

Methods

 | Name | Description
Public method | Activate | (Inherited from DocumentContent.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Protected method | CanExecuteCommand | (Inherited from DocumentContent.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | (Inherited from DocumentContent.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Protected method | FocusContent | (Overrides ManagedContentFocusContent()()()().)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetParentManager | (Inherited from ManagedContent.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | (Inherited from DocumentContent.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from DocumentContent.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | (Inherited from ManagedContent.)
Protected method | OnClosing | (Inherited from ManagedContent.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentLoaded | (Inherited from DocumentContent.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContentUnloaded | (Inherited from DocumentContent.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragMouseDown | (Inherited from ManagedContent.)
Protected method | OnDragMouseLeave | (Inherited from DocumentContent.)
Protected method | OnDragMouseMove | (Inherited from DocumentContent.)
Protected method | OnDragMouseUp | (Inherited from ManagedContent.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragStart | (Inherited from DocumentContent.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnFloatingWindowSizeChanged | (Inherited from ManagedContent.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | (Inherited from ManagedContent.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | (Inherited from DocumentContent.)
Protected method | OnIsActiveContentChanged | (Inherited from ManagedContent.)
Protected method | OnIsActiveDocumentChanged | (Inherited from ManagedContent.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | (Inherited from ManagedContent.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | (Inherited from ManagedContent.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManagerChanged | (Inherited from ManagedContent.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from ManagedContent.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from ManagedContent.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Protected method | RaisePropertyChanged | (Inherited from ManagedContent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetIsMouseDownFlag | (Inherited from ManagedContent.)
Public method | RestoreLayout | (Inherited from DocumentContent.)
Public method | SaveLayout | (Inherited from DocumentContent.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show()()()() | (Inherited from DocumentContent.)
Public method | Show(DockingManager) | (Inherited from DocumentContent.)
Public method | Show(Boolean) | (Inherited from DocumentContent.)
Public method | Show(DockingManager, Boolean) | (Inherited from DocumentContent.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContainerPane | (Inherited from ManagedContent.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContentTypeDescription | (Inherited from DocumentContent.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultElement | (Inherited from ManagedContent.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | DragEnabledArea | (Inherited from ManagedContent.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FloatingWindowSize | (Inherited from ManagedContent.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | (Inherited from ManagedContent.)
Public property | InfoTip | (Inherited from DocumentContent.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActiveContent | (Inherited from ManagedContent.)
Public property | IsActiveDocument | (Inherited from ManagedContent.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCloseable | (Inherited from ManagedContent.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFloating | (Inherited from DocumentContent.)
Public property | IsFloatingAllowed | (Inherited from DocumentContent.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsLocked | (Inherited from ManagedContent.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Protected property | IsMouseDown | (Inherited from ManagedContent.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Manager | (Inherited from ManagedContent.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Protected property | StartDragPoint | (Inherited from ManagedContent.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | (Inherited from ManagedContent.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | Closed | (Inherited from ManagedContent.)
Public event | Closing | (Inherited from ManagedContent.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsActiveContentChanged | (Inherited from ManagedContent.)
Public event | IsActiveDocumentChanged | (Inherited from ManagedContent.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | (Inherited from ManagedContent.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_Tab Class
ElGUI Namespace


CSys_Tab Constructor

[image]

4 of William Foster's Class Libraries
CSys_Tab Constructor
CSys_Tab Class See Also Send Feedback
Initializes a new instance of the CSys_Tab class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_Tab(
    string csTitle,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    csTitle As String, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_Tab(
    String^ csTitle,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

csTitle
Type: System..::..String

[Missing <param name="csTitle"/> documentation for "M:ElGUI.CSys_Tab.#ctor(System.String,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_Tab.#ctor(System.String,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_Tab.#ctor(System.String,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_Tab Class
ElGUI Namespace


CSys_Tab Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab Methods
CSys_Tab Class See Also Send Feedback

The CSys_Tab type exposes the following members.

Methods

 | Name | Description
Public method | Activate | (Inherited from DocumentContent.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Protected method | CanExecuteCommand | (Inherited from DocumentContent.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | (Inherited from DocumentContent.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Protected method | FocusContent | (Overrides ManagedContentFocusContent()()()().)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetParentManager | (Inherited from ManagedContent.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | (Inherited from DocumentContent.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from DocumentContent.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | (Inherited from ManagedContent.)
Protected method | OnClosing | (Inherited from ManagedContent.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentLoaded | (Inherited from DocumentContent.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContentUnloaded | (Inherited from DocumentContent.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragMouseDown | (Inherited from ManagedContent.)
Protected method | OnDragMouseLeave | (Inherited from DocumentContent.)
Protected method | OnDragMouseMove | (Inherited from DocumentContent.)
Protected method | OnDragMouseUp | (Inherited from ManagedContent.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragStart | (Inherited from DocumentContent.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnFloatingWindowSizeChanged | (Inherited from ManagedContent.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | (Inherited from ManagedContent.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | (Inherited from DocumentContent.)
Protected method | OnIsActiveContentChanged | (Inherited from ManagedContent.)
Protected method | OnIsActiveDocumentChanged | (Inherited from ManagedContent.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | (Inherited from ManagedContent.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | (Inherited from ManagedContent.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManagerChanged | (Inherited from ManagedContent.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from ManagedContent.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from ManagedContent.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Protected method | RaisePropertyChanged | (Inherited from ManagedContent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | ResetIsMouseDownFlag | (Inherited from ManagedContent.)
Public method | RestoreLayout | (Inherited from DocumentContent.)
Public method | SaveLayout | (Inherited from DocumentContent.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show()()()() | (Inherited from DocumentContent.)
Public method | Show(DockingManager) | (Inherited from DocumentContent.)
Public method | Show(Boolean) | (Inherited from DocumentContent.)
Public method | Show(DockingManager, Boolean) | (Inherited from DocumentContent.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_Tab Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab..::..AddHandler Method
CSys_Tab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_Tab Class
CSys_Tab Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab..::..ApplyAnimationClock Method
CSys_Tab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_Tab Class
CSys_Tab Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab..::..BeginAnimation Method
CSys_Tab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_Tab Class
CSys_Tab Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab..::..BeginStoryboard Method
CSys_Tab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_Tab Class
CSys_Tab Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab..::..BringIntoView Method
CSys_Tab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_Tab Class
CSys_Tab Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab..::..ClearValue Method
CSys_Tab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_Tab Class
CSys_Tab Members
ElGUI Namespace


FocusContent Method

[image]

4 of William Foster's Class Libraries
CSys_Tab..::..FocusContent Method
CSys_Tab Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_Tab.FocusContent"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void FocusContent()
Visual Basic
Protected Overrides Sub FocusContent
Visual C++
protected:
virtual void FocusContent() override

See Also

CSys_Tab Class
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab..::..HitTestCore Method
CSys_Tab Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_Tab Class
CSys_Tab Members
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab..::..SetBinding Method
CSys_Tab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_Tab Class
CSys_Tab Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab..::..SetValue Method
CSys_Tab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_Tab Class
CSys_Tab Members
ElGUI Namespace


Show Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab..::..Show Method
CSys_Tab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Show()()()() | (Inherited from DocumentContent.)
Public method | Show(DockingManager) | (Inherited from DocumentContent.)
Public method | Show(Boolean) | (Inherited from DocumentContent.)
Public method | Show(DockingManager, Boolean) | (Inherited from DocumentContent.)

See Also

CSys_Tab Class
CSys_Tab Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab..::..TransformToAncestor Method
CSys_Tab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_Tab Class
CSys_Tab Members
ElGUI Namespace


CSys_Tab Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab Properties
CSys_Tab Class See Also Send Feedback

The CSys_Tab type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContainerPane | (Inherited from ManagedContent.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContentTypeDescription | (Inherited from DocumentContent.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultElement | (Inherited from ManagedContent.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Protected property | DragEnabledArea | (Inherited from ManagedContent.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FloatingWindowSize | (Inherited from ManagedContent.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | (Inherited from ManagedContent.)
Public property | InfoTip | (Inherited from DocumentContent.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActiveContent | (Inherited from ManagedContent.)
Public property | IsActiveDocument | (Inherited from ManagedContent.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCloseable | (Inherited from ManagedContent.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFloating | (Inherited from DocumentContent.)
Public property | IsFloatingAllowed | (Inherited from DocumentContent.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsLocked | (Inherited from ManagedContent.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Protected property | IsMouseDown | (Inherited from ManagedContent.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Manager | (Inherited from ManagedContent.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Protected property | StartDragPoint | (Inherited from ManagedContent.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | (Inherited from ManagedContent.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_Tab Class
ElGUI Namespace


CSys_Tab Events

[image] [image]

4 of William Foster's Class Libraries
CSys_Tab Events
CSys_Tab Class See Also Send Feedback

The CSys_Tab type exposes the following members.

Events

 | Name | Description
Public event | Closed | (Inherited from ManagedContent.)
Public event | Closing | (Inherited from ManagedContent.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsActiveContentChanged | (Inherited from ManagedContent.)
Public event | IsActiveDocumentChanged | (Inherited from ManagedContent.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | (Inherited from ManagedContent.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_Tab Class
ElGUI Namespace


CSys_TextboxControl Class

[image]

4 of William Foster's Class Libraries
CSys_TextboxControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_TextboxControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_TextboxControl : TextBox,
    ISysWin
Visual Basic
Public Class CSys_TextboxControl _
    Inherits TextBox _
    Implements ISysWin
Visual C++
public ref class CSys_TextboxControl : public TextBox,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls.Primitives..::..TextBoxBase
System.Windows.Controls..::..TextBox
ElGUI..::..CSys_TextboxControl

See Also

CSys_TextboxControl Members
ElGUI Namespace


CSys_TextboxControl Members

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl Members
CSys_TextboxControl Class Constructors Methods Properties Events See Also Send Feedback

The CSys_TextboxControl type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_TextboxControl | Initializes a new instance of the CSys_TextboxControl class

Methods

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Inherited from TextBoxBase.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | RestrainDistance |
Public method | RestrainInteger |
Public method | RestrainNumeric |
Public method | RestrainPassword |
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | SizeTextbox |
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_TextboxControl Class
ElGUI Namespace


CSys_TextboxControl Constructor

[image]

4 of William Foster's Class Libraries
CSys_TextboxControl Constructor
CSys_TextboxControl Class See Also Send Feedback
Initializes a new instance of the CSys_TextboxControl class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_TextboxControl(
    string csText,
    Resource_ID resourceID,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    csText As String, _
    resourceID As Resource_ID, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_TextboxControl(
    String^ csText,
    Resource_ID resourceID,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

csText
Type: System..::..String

[Missing <param name="csText"/> documentation for "M:ElGUI.CSys_TextboxControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.CSys_TextboxControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_TextboxControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_TextboxControl.#ctor(System.String,ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_TextboxControl Class
ElGUI Namespace


CSys_TextboxControl Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl Methods
CSys_TextboxControl Class See Also Send Feedback

The CSys_TextboxControl type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Inherited from TextBoxBase.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | RestrainDistance |
Public method | RestrainInteger |
Public method | RestrainNumeric |
Public method | RestrainPassword |
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | SizeTextbox |
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_TextboxControl Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..AddHandler Method
CSys_TextboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_TextboxControl Class
CSys_TextboxControl Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..ApplyAnimationClock Method
CSys_TextboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_TextboxControl Class
CSys_TextboxControl Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..BeginAnimation Method
CSys_TextboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_TextboxControl Class
CSys_TextboxControl Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..BeginStoryboard Method
CSys_TextboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_TextboxControl Class
CSys_TextboxControl Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..BringIntoView Method
CSys_TextboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_TextboxControl Class
CSys_TextboxControl Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..ClearValue Method
CSys_TextboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_TextboxControl Class
CSys_TextboxControl Members
ElGUI Namespace


GetRectFromCharacterIndex Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..GetRectFromCharacterIndex Method
CSys_TextboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)

See Also

CSys_TextboxControl Class
CSys_TextboxControl Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..HitTestCore Method
CSys_TextboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_TextboxControl Class
CSys_TextboxControl Members
ElGUI Namespace


RestrainDistance Method

[image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..RestrainDistance Method
CSys_TextboxControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_TextboxControl.RestrainDistance"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RestrainDistance()
Visual Basic
Public Sub RestrainDistance
Visual C++
public:
void RestrainDistance()

See Also

CSys_TextboxControl Class
ElGUI Namespace


RestrainInteger Method

[image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..RestrainInteger Method
CSys_TextboxControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_TextboxControl.RestrainInteger"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RestrainInteger()
Visual Basic
Public Sub RestrainInteger
Visual C++
public:
void RestrainInteger()

See Also

CSys_TextboxControl Class
ElGUI Namespace


RestrainNumeric Method

[image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..RestrainNumeric Method
CSys_TextboxControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_TextboxControl.RestrainNumeric"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RestrainNumeric()
Visual Basic
Public Sub RestrainNumeric
Visual C++
public:
void RestrainNumeric()

See Also

CSys_TextboxControl Class
ElGUI Namespace


RestrainPassword Method

[image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..RestrainPassword Method
CSys_TextboxControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_TextboxControl.RestrainPassword"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RestrainPassword()
Visual Basic
Public Sub RestrainPassword
Visual C++
public:
void RestrainPassword()

See Also

CSys_TextboxControl Class
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..SetBinding Method
CSys_TextboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_TextboxControl Class
CSys_TextboxControl Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..SetValue Method
CSys_TextboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_TextboxControl Class
CSys_TextboxControl Members
ElGUI Namespace


SizeTextbox Method

[image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..SizeTextbox Method
CSys_TextboxControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_TextboxControl.SizeTextbox(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SizeTextbox(
    Size2dU size
)
Visual Basic
Public Sub SizeTextbox ( _
    size As Size2dU _
)
Visual C++
public:
void SizeTextbox(
    Size2dU^ size
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElGUI.CSys_TextboxControl.SizeTextbox(El.Size2dU)"]

See Also

CSys_TextboxControl Class
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl..::..TransformToAncestor Method
CSys_TextboxControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_TextboxControl Class
CSys_TextboxControl Members
ElGUI Namespace


CSys_TextboxControl Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl Properties
CSys_TextboxControl Class See Also Send Feedback

The CSys_TextboxControl type exposes the following members.

Properties

 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_TextboxControl Class
ElGUI Namespace


CSys_TextboxControl Events

[image] [image]

4 of William Foster's Class Libraries
CSys_TextboxControl Events
CSys_TextboxControl Class See Also Send Feedback

The CSys_TextboxControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_TextboxControl Class
ElGUI Namespace


CSys_TextControl Class

[image]

4 of William Foster's Class Libraries
CSys_TextControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_TextControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_TextControl : TextBox,
    ISysWin
Visual Basic
Public Class CSys_TextControl _
    Inherits TextBox _
    Implements ISysWin
Visual C++
public ref class CSys_TextControl : public TextBox,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls.Primitives..::..TextBoxBase
System.Windows.Controls..::..TextBox
ElGUI..::..CSys_TextControl

See Also

CSys_TextControl Members
ElGUI Namespace


CSys_TextControl Members

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl Members
CSys_TextControl Class Constructors Methods Properties Events See Also Send Feedback

The CSys_TextControl type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_TextControl | Initializes a new instance of the CSys_TextControl class

Methods

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetTextSizeOnScreen |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | getXYOfPos |
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Inherited from TextBoxBase.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | SizeTextbox |
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_TextControl Class
ElGUI Namespace


CSys_TextControl Constructor

[image]

4 of William Foster's Class Libraries
CSys_TextControl Constructor
CSys_TextControl Class See Also Send Feedback
Initializes a new instance of the CSys_TextControl class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_TextControl(
    Resource_ID resourceID,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    resourceID As Resource_ID, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_TextControl(
    Resource_ID resourceID,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.CSys_TextControl.#ctor(ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_TextControl.#ctor(ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_TextControl.#ctor(ElGUI.Resource_ID,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_TextControl Class
ElGUI Namespace


CSys_TextControl Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl Methods
CSys_TextControl Class See Also Send Feedback

The CSys_TextControl type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetTextSizeOnScreen |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | getXYOfPos |
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Inherited from TextBoxBase.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | SizeTextbox |
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_TextControl Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl..::..AddHandler Method
CSys_TextControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_TextControl Class
CSys_TextControl Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl..::..ApplyAnimationClock Method
CSys_TextControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_TextControl Class
CSys_TextControl Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl..::..BeginAnimation Method
CSys_TextControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_TextControl Class
CSys_TextControl Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl..::..BeginStoryboard Method
CSys_TextControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_TextControl Class
CSys_TextControl Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl..::..BringIntoView Method
CSys_TextControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_TextControl Class
CSys_TextControl Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl..::..ClearValue Method
CSys_TextControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_TextControl Class
CSys_TextControl Members
ElGUI Namespace


GetRectFromCharacterIndex Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl..::..GetRectFromCharacterIndex Method
CSys_TextControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)

See Also

CSys_TextControl Class
CSys_TextControl Members
ElGUI Namespace


GetTextSizeOnScreen Method

[image]

4 of William Foster's Class Libraries
CSys_TextControl..::..GetTextSizeOnScreen Method
CSys_TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_TextControl.GetTextSizeOnScreen(El.Size2dU@,El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void GetTextSizeOnScreen(
    out Size2dU size,
    STRING cs
)
Visual Basic
Public Sub GetTextSizeOnScreen ( _
    <OutAttribute> ByRef size As Size2dU, _
    cs As STRING _
)
Visual C++
public:
void GetTextSizeOnScreen(
    [OutAttribute] Size2dU^% size,
    STRING^ cs
)

Parameters

size
Type: Size2dU%

[Missing <param name="size"/> documentation for "M:ElGUI.CSys_TextControl.GetTextSizeOnScreen(El.Size2dU@,El.STRING)"]

cs
Type: STRING

[Missing <param name="cs"/> documentation for "M:ElGUI.CSys_TextControl.GetTextSizeOnScreen(El.Size2dU@,El.STRING)"]

See Also

CSys_TextControl Class
ElGUI Namespace


getXYOfPos Method

[image]

4 of William Foster's Class Libraries
CSys_TextControl..::..getXYOfPos Method
CSys_TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_TextControl.getXYOfPos(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Size2dU getXYOfPos(
    Size2dU pos
)
Visual Basic
Public Function getXYOfPos ( _
    pos As Size2dU _
) As Size2dU
Visual C++
public:
Size2dU^ getXYOfPos(
    Size2dU^ pos
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElGUI.CSys_TextControl.getXYOfPos(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CSys_TextControl.getXYOfPos(El.Size2dU)"]

See Also

CSys_TextControl Class
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl..::..HitTestCore Method
CSys_TextControl Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_TextControl Class
CSys_TextControl Members
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl..::..SetBinding Method
CSys_TextControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_TextControl Class
CSys_TextControl Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl..::..SetValue Method
CSys_TextControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_TextControl Class
CSys_TextControl Members
ElGUI Namespace


SizeTextbox Method

[image]

4 of William Foster's Class Libraries
CSys_TextControl..::..SizeTextbox Method
CSys_TextControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_TextControl.SizeTextbox(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SizeTextbox(
    Size2dU size
)
Visual Basic
Public Function SizeTextbox ( _
    size As Size2dU _
) As Boolean
Visual C++
public:
bool SizeTextbox(
    Size2dU^ size
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElGUI.CSys_TextControl.SizeTextbox(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CSys_TextControl.SizeTextbox(El.Size2dU)"]

See Also

CSys_TextControl Class
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl..::..TransformToAncestor Method
CSys_TextControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_TextControl Class
CSys_TextControl Members
ElGUI Namespace


CSys_TextControl Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl Properties
CSys_TextControl Class See Also Send Feedback

The CSys_TextControl type exposes the following members.

Properties

 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_TextControl Class
ElGUI Namespace


CSys_TextControl Events

[image] [image]

4 of William Foster's Class Libraries
CSys_TextControl Events
CSys_TextControl Class See Also Send Feedback

The CSys_TextControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_TextControl Class
ElGUI Namespace


CSys_Toolbar Class

[image]

4 of William Foster's Class Libraries
CSys_Toolbar Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_Toolbar"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_Toolbar : ToolBar,
    ISysWin
Visual Basic
Public Class CSys_Toolbar _
    Inherits ToolBar _
    Implements ISysWin
Visual C++
public ref class CSys_Toolbar : public ToolBar,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls..::..HeaderedItemsControl
System.Windows.Controls..::..ToolBar
ElGUI..::..CSys_Toolbar

See Also

CSys_Toolbar Members
ElGUI Namespace


CSys_Toolbar Members

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar Members
CSys_Toolbar Class Constructors Methods Properties Events See Also Send Feedback

The CSys_Toolbar type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_Toolbar | Initializes a new instance of the CSys_Toolbar class

Methods

 | Name | Description
Public method | AddButton |
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Remeasures a ToolBar. (Inherited from ToolBar.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ToolBarAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ToolBar.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl.)
Protected method | OnHeaderStringFormatChanged | Occurs when the HeaderStringFormat property changes. (Inherited from HeaderedItemsControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedItemsControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Called when the Items property changes. (Inherited from ToolBar.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when a key is pressed on an item in the ToolBar. (Inherited from ToolBar.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when the ToolBar loses mouse capture. (Inherited from ToolBar.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ToolBar.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a HeaderedItemsControl object. (Inherited from HeaderedItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | Band | Gets or sets a value that indicates where the toolbar should be located in the ToolBarTray. (Inherited from ToolBar.)
Public property | BandIndex | Gets or sets the band index number that indicates the position of the toolbar on the band. (Inherited from ToolBar.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. (Inherited from HeaderedItemsControl.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HasOverflowItems | Gets a value that indicates whether the toolbar has items that are not visible. (Inherited from ToolBar.)
Public property | Header | Gets or sets the item that labels the control. (Inherited from HeaderedItemsControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedItemsControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. (Inherited from HeaderedItemsControl.)
Public property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. (Inherited from HeaderedItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsOverflowOpen | Gets or sets a value that indicates whether the ToolBar overflow area is currently visible. (Inherited from ToolBar.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the HeaderedItemsControl. (Inherited from HeaderedItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | Orientation | Gets the orientation of the ToolBar. (Inherited from ToolBar.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_Toolbar Class
ElGUI Namespace


CSys_Toolbar Constructor

[image]

4 of William Foster's Class Libraries
CSys_Toolbar Constructor
CSys_Toolbar Class See Also Send Feedback
Initializes a new instance of the CSys_Toolbar class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_Toolbar(
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_Toolbar(
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_Toolbar.#ctor(ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_Toolbar.#ctor(ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_Toolbar Class
ElGUI Namespace


CSys_Toolbar Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar Methods
CSys_Toolbar Class See Also Send Feedback

The CSys_Toolbar type exposes the following members.

Methods

 | Name | Description
Public method | AddButton |
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Remeasures a ToolBar. (Inherited from ToolBar.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ToolBarAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ToolBar.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl.)
Protected method | OnHeaderStringFormatChanged | Occurs when the HeaderStringFormat property changes. (Inherited from HeaderedItemsControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedItemsControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Called when the Items property changes. (Inherited from ToolBar.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when a key is pressed on an item in the ToolBar. (Inherited from ToolBar.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when the ToolBar loses mouse capture. (Inherited from ToolBar.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ToolBar.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a HeaderedItemsControl object. (Inherited from HeaderedItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_Toolbar Class
ElGUI Namespace


AddButton Method

[image]

4 of William Foster's Class Libraries
CSys_Toolbar..::..AddButton Method
CSys_Toolbar Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_Toolbar.AddButton(System.Windows.UIElement)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddButton(
    UIElement elem
)
Visual Basic
Public Sub AddButton ( _
    elem As UIElement _
)
Visual C++
public:
void AddButton(
    UIElement^ elem
)

Parameters

elem
Type: System.Windows..::..UIElement

[Missing <param name="elem"/> documentation for "M:ElGUI.CSys_Toolbar.AddButton(System.Windows.UIElement)"]

See Also

CSys_Toolbar Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar..::..AddHandler Method
CSys_Toolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_Toolbar Class
CSys_Toolbar Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar..::..ApplyAnimationClock Method
CSys_Toolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_Toolbar Class
CSys_Toolbar Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar..::..BeginAnimation Method
CSys_Toolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_Toolbar Class
CSys_Toolbar Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar..::..BeginStoryboard Method
CSys_Toolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_Toolbar Class
CSys_Toolbar Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar..::..BringIntoView Method
CSys_Toolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_Toolbar Class
CSys_Toolbar Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar..::..ClearValue Method
CSys_Toolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_Toolbar Class
CSys_Toolbar Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar..::..HitTestCore Method
CSys_Toolbar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_Toolbar Class
CSys_Toolbar Members
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar..::..SetBinding Method
CSys_Toolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_Toolbar Class
CSys_Toolbar Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar..::..SetValue Method
CSys_Toolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_Toolbar Class
CSys_Toolbar Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar..::..TransformToAncestor Method
CSys_Toolbar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_Toolbar Class
CSys_Toolbar Members
ElGUI Namespace


CSys_Toolbar Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar Properties
CSys_Toolbar Class See Also Send Feedback

The CSys_Toolbar type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | Band | Gets or sets a value that indicates where the toolbar should be located in the ToolBarTray. (Inherited from ToolBar.)
Public property | BandIndex | Gets or sets the band index number that indicates the position of the toolbar on the band. (Inherited from ToolBar.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. (Inherited from HeaderedItemsControl.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | HasOverflowItems | Gets a value that indicates whether the toolbar has items that are not visible. (Inherited from ToolBar.)
Public property | Header | Gets or sets the item that labels the control. (Inherited from HeaderedItemsControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedItemsControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. (Inherited from HeaderedItemsControl.)
Public property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. (Inherited from HeaderedItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsOverflowOpen | Gets or sets a value that indicates whether the ToolBar overflow area is currently visible. (Inherited from ToolBar.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the HeaderedItemsControl. (Inherited from HeaderedItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | Orientation | Gets the orientation of the ToolBar. (Inherited from ToolBar.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

CSys_Toolbar Class
ElGUI Namespace


CSys_Toolbar Events

[image] [image]

4 of William Foster's Class Libraries
CSys_Toolbar Events
CSys_Toolbar Class See Also Send Feedback

The CSys_Toolbar type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_Toolbar Class
ElGUI Namespace


CSys_TopWindow Class

[image]

4 of William Foster's Class Libraries
CSys_TopWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CSys_TopWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CSys_TopWindow : Window,
    ISysWin
Visual Basic
Public Class CSys_TopWindow _
    Inherits Window _
    Implements ISysWin
Visual C++
public ref class CSys_TopWindow : public Window,
    ISysWin

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows..::..Window
ElGUI..::..CSys_TopWindow

See Also

CSys_TopWindow Members
ElGUI Namespace


CSys_TopWindow Members

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow Members
CSys_TopWindow Class Constructors Methods Properties Events See Also Send Feedback

The CSys_TopWindow type exposes the following members.

Constructors

 | Name | Description
Public method | CSys_TopWindow | Initializes a new instance of the CSys_TopWindow class

Methods

 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | (Overrides Window..::..OnSourceInitialized(EventArgs).)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog()()()() method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)

Events

 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close()()()() is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_TopWindow Class
ElGUI Namespace


CSys_TopWindow Constructor

[image]

4 of William Foster's Class Libraries
CSys_TopWindow Constructor
CSys_TopWindow Class See Also Send Feedback
Initializes a new instance of the CSys_TopWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_TopWindow(
    STRING csTitle,
    UILayerWindow Layer,
    UILayerWindow Parent
)
Visual Basic
Public Sub New ( _
    csTitle As STRING, _
    Layer As UILayerWindow, _
    Parent As UILayerWindow _
)
Visual C++
public:
CSys_TopWindow(
    STRING^ csTitle,
    UILayerWindow^ Layer,
    UILayerWindow^ Parent
)

Parameters

csTitle
Type: STRING

[Missing <param name="csTitle"/> documentation for "M:ElGUI.CSys_TopWindow.#ctor(El.STRING,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElGUI.CSys_TopWindow.#ctor(El.STRING,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.CSys_TopWindow.#ctor(El.STRING,ElGUI.UILayerWindow,ElGUI.UILayerWindow)"]

See Also

CSys_TopWindow Class
ElGUI Namespace


CSys_TopWindow Methods

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow Methods
CSys_TopWindow Class See Also Send Feedback

The CSys_TopWindow type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | (Overrides Window..::..OnSourceInitialized(EventArgs).)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

CSys_TopWindow Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow..::..AddHandler Method
CSys_TopWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

CSys_TopWindow Class
CSys_TopWindow Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow..::..ApplyAnimationClock Method
CSys_TopWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_TopWindow Class
CSys_TopWindow Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow..::..BeginAnimation Method
CSys_TopWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

CSys_TopWindow Class
CSys_TopWindow Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow..::..BeginStoryboard Method
CSys_TopWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

CSys_TopWindow Class
CSys_TopWindow Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow..::..BringIntoView Method
CSys_TopWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

CSys_TopWindow Class
CSys_TopWindow Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow..::..ClearValue Method
CSys_TopWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

CSys_TopWindow Class
CSys_TopWindow Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow..::..HitTestCore Method
CSys_TopWindow Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

CSys_TopWindow Class
CSys_TopWindow Members
ElGUI Namespace


OnSourceInitialized Method

[image]

4 of William Foster's Class Libraries
CSys_TopWindow..::..OnSourceInitialized Method
CSys_TopWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CSys_TopWindow.OnSourceInitialized(System.EventArgs)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnSourceInitialized(
    EventArgs e
)
Visual Basic
Protected Overrides Sub OnSourceInitialized ( _
    e As EventArgs _
)
Visual C++
protected:
virtual void OnSourceInitialized(
    EventArgs^ e
) override

Parameters

e
Type: System..::..EventArgs

[Missing <param name="e"/> documentation for "M:ElGUI.CSys_TopWindow.OnSourceInitialized(System.EventArgs)"]

See Also

CSys_TopWindow Class
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow..::..SetBinding Method
CSys_TopWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

CSys_TopWindow Class
CSys_TopWindow Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow..::..SetValue Method
CSys_TopWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

CSys_TopWindow Class
CSys_TopWindow Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow..::..TransformToAncestor Method
CSys_TopWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

CSys_TopWindow Class
CSys_TopWindow Members
ElGUI Namespace


CSys_TopWindow Properties

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow Properties
CSys_TopWindow Class See Also Send Feedback

The CSys_TopWindow type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog()()()() method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)

See Also

CSys_TopWindow Class
ElGUI Namespace


CSys_TopWindow Events

[image] [image]

4 of William Foster's Class Libraries
CSys_TopWindow Events
CSys_TopWindow Class See Also Send Feedback

The CSys_TopWindow type exposes the following members.

Events

 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close()()()() is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CSys_TopWindow Class
ElGUI Namespace


CTerminalWindow Class

[image]

4 of William Foster's Class Libraries
CTerminalWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CTerminalWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CTerminalWindow : ITerminalWindow
Visual Basic
Public Class CTerminalWindow _
    Implements ITerminalWindow
Visual C++
public ref class CTerminalWindow : ITerminalWindow

Inheritance Hierarchy

System..::..Object
ElGUI..::..CTerminalWindow

See Also

CTerminalWindow Members
ElGUI Namespace


CTerminalWindow Members

[image] [image]

4 of William Foster's Class Libraries
CTerminalWindow Members
CTerminalWindow Class Constructors Methods Fields See Also Send Feedback

The CTerminalWindow type exposes the following members.

Constructors

 | Name | Description
Public method | CTerminalWindow | Initializes a new instance of the CTerminalWindow class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnFocusIn |
Public method | OnFocusOut |
Public method | OnKeyDown |
Public method | OnKeyUp |
Public method | OnMessage |
Public method | OnMouseDoubleClick |
Public method | OnMouseDown |
Public method | OnMouseEnter |
Public method | OnMouseLeave |
Public method | OnMouseMove |
Public method | OnMouseUp |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_msg |

See Also

CTerminalWindow Class
ElGUI Namespace


CTerminalWindow Constructor

[image]

4 of William Foster's Class Libraries
CTerminalWindow Constructor
CTerminalWindow Class See Also Send Feedback
Initializes a new instance of the CTerminalWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CTerminalWindow()
Visual Basic
Public Sub New
Visual C++
public:
CTerminalWindow()

See Also

CTerminalWindow Class
ElGUI Namespace


CTerminalWindow Fields

[image] [image]

4 of William Foster's Class Libraries
CTerminalWindow Fields
CTerminalWindow Class See Also Send Feedback

The CTerminalWindow type exposes the following members.

Fields

 | Name | Description
Public field | m_msg |

See Also

CTerminalWindow Class
ElGUI Namespace


m_msg Field

[image]

4 of William Foster's Class Libraries
CTerminalWindow..::..m_msg Field
CTerminalWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.CTerminalWindow.m_msg"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Message m_msg
Visual Basic
Public m_msg As Message
Visual C++
public:
Message^ m_msg

See Also

CTerminalWindow Class
ElGUI Namespace


CTerminalWindow Methods

[image] [image]

4 of William Foster's Class Libraries
CTerminalWindow Methods
CTerminalWindow Class See Also Send Feedback

The CTerminalWindow type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnFocusIn |
Public method | OnFocusOut |
Public method | OnKeyDown |
Public method | OnKeyUp |
Public method | OnMessage |
Public method | OnMouseDoubleClick |
Public method | OnMouseDown |
Public method | OnMouseEnter |
Public method | OnMouseLeave |
Public method | OnMouseMove |
Public method | OnMouseUp |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CTerminalWindow Class
ElGUI Namespace


OnFocusIn Method

[image]

4 of William Foster's Class Libraries
CTerminalWindow..::..OnFocusIn Method
CTerminalWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CTerminalWindow.OnFocusIn"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnFocusIn()
Visual Basic
Public Overridable Function OnFocusIn As Integer
Visual C++
public:
virtual int OnFocusIn()

Return Value

[Missing <returns> documentation for "M:ElGUI.CTerminalWindow.OnFocusIn"]

Implements

ITerminalWindow..::..OnFocusIn()()()()

See Also

CTerminalWindow Class
ElGUI Namespace


OnFocusOut Method

[image]

4 of William Foster's Class Libraries
CTerminalWindow..::..OnFocusOut Method
CTerminalWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CTerminalWindow.OnFocusOut"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnFocusOut()
Visual Basic
Public Overridable Function OnFocusOut As Integer
Visual C++
public:
virtual int OnFocusOut()

Return Value

[Missing <returns> documentation for "M:ElGUI.CTerminalWindow.OnFocusOut"]

Implements

ITerminalWindow..::..OnFocusOut()()()()

See Also

CTerminalWindow Class
ElGUI Namespace


OnKeyDown Method

[image]

4 of William Foster's Class Libraries
CTerminalWindow..::..OnKeyDown Method
CTerminalWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CTerminalWindow.OnKeyDown(System.Char)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnKeyDown(
    char key
)
Visual Basic
Public Overridable Function OnKeyDown ( _
    key As Char _
) As Integer
Visual C++
public:
virtual int OnKeyDown(
    wchar_t key
)

Parameters

key
Type: System..::..Char

[Missing <param name="key"/> documentation for "M:ElGUI.CTerminalWindow.OnKeyDown(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CTerminalWindow.OnKeyDown(System.Char)"]

Implements

ITerminalWindow..::..OnKeyDown(Char)

See Also

CTerminalWindow Class
ElGUI Namespace


OnKeyUp Method

[image]

4 of William Foster's Class Libraries
CTerminalWindow..::..OnKeyUp Method
CTerminalWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CTerminalWindow.OnKeyUp(System.Char)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnKeyUp(
    char key
)
Visual Basic
Public Overridable Function OnKeyUp ( _
    key As Char _
) As Integer
Visual C++
public:
virtual int OnKeyUp(
    wchar_t key
)

Parameters

key
Type: System..::..Char

[Missing <param name="key"/> documentation for "M:ElGUI.CTerminalWindow.OnKeyUp(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CTerminalWindow.OnKeyUp(System.Char)"]

Implements

ITerminalWindow..::..OnKeyUp(Char)

See Also

CTerminalWindow Class
ElGUI Namespace


OnMessage Method

[image]

4 of William Foster's Class Libraries
CTerminalWindow..::..OnMessage Method
CTerminalWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CTerminalWindow.OnMessage(ElGUI.Message)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMessage(
    Message msg
)
Visual Basic
Public Overridable Function OnMessage ( _
    msg As Message _
) As Integer
Visual C++
public:
virtual int OnMessage(
    Message^ msg
)

Parameters

msg
Type: ElGUI..::..Message

[Missing <param name="msg"/> documentation for "M:ElGUI.CTerminalWindow.OnMessage(ElGUI.Message)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CTerminalWindow.OnMessage(ElGUI.Message)"]

Implements

ITerminalWindow..::..OnMessage(Message)

See Also

CTerminalWindow Class
ElGUI Namespace


OnMouseDoubleClick Method

[image]

4 of William Foster's Class Libraries
CTerminalWindow..::..OnMouseDoubleClick Method
CTerminalWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CTerminalWindow.OnMouseDoubleClick(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMouseDoubleClick(
    Size2dU pt
)
Visual Basic
Public Overridable Function OnMouseDoubleClick ( _
    pt As Size2dU _
) As Integer
Visual C++
public:
virtual int OnMouseDoubleClick(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.CTerminalWindow.OnMouseDoubleClick(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CTerminalWindow.OnMouseDoubleClick(El.Size2dU)"]

Implements

ITerminalWindow..::..OnMouseDoubleClick(Size2dU)

See Also

CTerminalWindow Class
ElGUI Namespace


OnMouseDown Method

[image]

4 of William Foster's Class Libraries
CTerminalWindow..::..OnMouseDown Method
CTerminalWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CTerminalWindow.OnMouseDown(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMouseDown(
    Size2dU pt
)
Visual Basic
Public Overridable Function OnMouseDown ( _
    pt As Size2dU _
) As Integer
Visual C++
public:
virtual int OnMouseDown(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.CTerminalWindow.OnMouseDown(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CTerminalWindow.OnMouseDown(El.Size2dU)"]

Implements

ITerminalWindow..::..OnMouseDown(Size2dU)

See Also

CTerminalWindow Class
ElGUI Namespace


OnMouseEnter Method

[image]

4 of William Foster's Class Libraries
CTerminalWindow..::..OnMouseEnter Method
CTerminalWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CTerminalWindow.OnMouseEnter"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMouseEnter()
Visual Basic
Public Overridable Function OnMouseEnter As Integer
Visual C++
public:
virtual int OnMouseEnter()

Return Value

[Missing <returns> documentation for "M:ElGUI.CTerminalWindow.OnMouseEnter"]

Implements

ITerminalWindow..::..OnMouseEnter()()()()

See Also

CTerminalWindow Class
ElGUI Namespace


OnMouseLeave Method

[image]

4 of William Foster's Class Libraries
CTerminalWindow..::..OnMouseLeave Method
CTerminalWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CTerminalWindow.OnMouseLeave"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMouseLeave()
Visual Basic
Public Overridable Function OnMouseLeave As Integer
Visual C++
public:
virtual int OnMouseLeave()

Return Value

[Missing <returns> documentation for "M:ElGUI.CTerminalWindow.OnMouseLeave"]

Implements

ITerminalWindow..::..OnMouseLeave()()()()

See Also

CTerminalWindow Class
ElGUI Namespace


OnMouseMove Method

[image]

4 of William Foster's Class Libraries
CTerminalWindow..::..OnMouseMove Method
CTerminalWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CTerminalWindow.OnMouseMove(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMouseMove(
    Size2dU pt
)
Visual Basic
Public Overridable Function OnMouseMove ( _
    pt As Size2dU _
) As Integer
Visual C++
public:
virtual int OnMouseMove(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.CTerminalWindow.OnMouseMove(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CTerminalWindow.OnMouseMove(El.Size2dU)"]

Implements

ITerminalWindow..::..OnMouseMove(Size2dU)

See Also

CTerminalWindow Class
ElGUI Namespace


OnMouseUp Method

[image]

4 of William Foster's Class Libraries
CTerminalWindow..::..OnMouseUp Method
CTerminalWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CTerminalWindow.OnMouseUp(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMouseUp(
    Size2dU pt
)
Visual Basic
Public Overridable Function OnMouseUp ( _
    pt As Size2dU _
) As Integer
Visual C++
public:
virtual int OnMouseUp(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.CTerminalWindow.OnMouseUp(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CTerminalWindow.OnMouseUp(El.Size2dU)"]

Implements

ITerminalWindow..::..OnMouseUp(Size2dU)

See Also

CTerminalWindow Class
ElGUI Namespace


CursesBox Class

[image]

4 of William Foster's Class Libraries
CursesBox Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CursesBox"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CursesBox : TextData_Resource_Control
Visual Basic
Public Class CursesBox _
    Inherits TextData_Resource_Control
Visual C++
public ref class CursesBox : public TextData_Resource_Control

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..Resource_Control
ElGUI..::..Data_Resource_Control
ElGUI..::..TextData_Resource_Control
ElGUI..::..CursesBox

See Also

CursesBox Members
ElGUI Namespace


CursesBox Members

[image] [image]

4 of William Foster's Class Libraries
CursesBox Members
CursesBox Class Constructors Methods Fields Properties See Also Send Feedback

The CursesBox type exposes the following members.

Constructors

 | Name | Description
Public method | CursesBox | Initializes a new instance of the CursesBox class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

CursesBox Class
ElGUI Namespace


CursesBox Constructor

[image]

4 of William Foster's Class Libraries
CursesBox Constructor
CursesBox Class See Also Send Feedback
Initializes a new instance of the CursesBox class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CursesBox(
    GUI gui,
    Window Parent,
    STRING csText,
    Resource_ID resourceID
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    Parent As Window, _
    csText As STRING, _
    resourceID As Resource_ID _
)
Visual C++
public:
CursesBox(
    GUI^ gui,
    Window^ Parent,
    STRING^ csText,
    Resource_ID resourceID
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.CursesBox.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.CursesBox.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID)"]

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.CursesBox.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.CursesBox.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID)"]

See Also

CursesBox Class
ElGUI Namespace


CursesBox Fields

[image] [image]

4 of William Foster's Class Libraries
CursesBox Fields
CursesBox Class See Also Send Feedback

The CursesBox type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

CursesBox Class
ElGUI Namespace


CursesBox Methods

[image] [image]

4 of William Foster's Class Libraries
CursesBox Methods
CursesBox Class See Also Send Feedback

The CursesBox type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

CursesBox Class
ElGUI Namespace


GetText Method

[image] [image]

4 of William Foster's Class Libraries
CursesBox..::..GetText Method
CursesBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)

See Also

CursesBox Class
CursesBox Members
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
CursesBox..::..SetColor Method
CursesBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

CursesBox Class
CursesBox Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
CursesBox..::..SetDefaultCursor Method
CursesBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

CursesBox Class
CursesBox Members
ElGUI Namespace


CursesBox Properties

[image] [image]

4 of William Foster's Class Libraries
CursesBox Properties
CursesBox Class See Also Send Feedback

The CursesBox type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

CursesBox Class
ElGUI Namespace


CursesWindow Class

[image]

4 of William Foster's Class Libraries
CursesWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CursesWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CursesWindow : Window
Visual Basic
Public Class CursesWindow _
    Inherits Window
Visual C++
public ref class CursesWindow : public Window

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..CursesWindow

See Also

CursesWindow Members
ElGUI Namespace


CursesWindow Members

[image] [image]

4 of William Foster's Class Libraries
CursesWindow Members
CursesWindow Class Constructors Methods Fields Properties See Also Send Feedback

The CursesWindow type exposes the following members.

Constructors

 | Name | Description
Public method | CursesWindow(GUI, Window) | Initializes a new instance of the CursesWindow class
Public method | CursesWindow(GUI, Window, WINDOW_TYPE, Resource_ID) | Initializes a new instance of the CursesWindow class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | bell |
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | clear |
Public method | clr_to_eol |
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Protected method | GetC |
Public method | GetCursorPosition |
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Protected method | getline |
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetScreenPosition()()()() |
Public method | GetScreenPosition(Size2dU) |
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Public method | home |
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | moveto(Size2dU) |
Public method | moveto(Int32, Int32) |
Protected method | OnCreate | (Overrides UILayerWindow..::..OnCreate()()()().)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Overrides Window..::..OnKeyDown(Char).)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Public method | raw |
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Overrides UILayerWindow..::..SetText(String).)
Public method | SetTextDimensions |
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Public method | sizewindow |
Public method | Space |
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | unraw |
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

CursesWindow Class
ElGUI Namespace


CursesWindow Constructor

[image] [image]

4 of William Foster's Class Libraries
CursesWindow Constructor
CursesWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CursesWindow(GUI, Window) | Initializes a new instance of the CursesWindow class
Public method | CursesWindow(GUI, Window, WINDOW_TYPE, Resource_ID) | Initializes a new instance of the CursesWindow class

See Also

CursesWindow Class
CursesWindow Members
ElGUI Namespace


CursesWindow Constructor (GUI, Window)

[image]

4 of William Foster's Class Libraries
CursesWindow Constructor (GUI, Window)
CursesWindow Class See Also Send Feedback
Initializes a new instance of the CursesWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CursesWindow(
    GUI gui,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    Parent As Window _
)
Visual C++
public:
CursesWindow(
    GUI^ gui,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.CursesWindow.#ctor(ElGUI.GUI,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.CursesWindow.#ctor(ElGUI.GUI,ElGUI.Window)"]

See Also

CursesWindow Class
CursesWindow Overload
ElGUI Namespace


CursesWindow Constructor (GUI, Window, WINDOW_TYPE, Resource_ID)

[image]

4 of William Foster's Class Libraries
CursesWindow Constructor (GUI, Window, WINDOW_TYPE, Resource_ID)
CursesWindow Class See Also Send Feedback
Initializes a new instance of the CursesWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CursesWindow(
    GUI gui,
    Window Parent,
    WINDOW_TYPE eWndType,
    Resource_ID resourceID
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    Parent As Window, _
    eWndType As WINDOW_TYPE, _
    resourceID As Resource_ID _
)
Visual C++
public:
CursesWindow(
    GUI^ gui,
    Window^ Parent,
    WINDOW_TYPE eWndType,
    Resource_ID resourceID
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.CursesWindow.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.WINDOW_TYPE,ElGUI.Resource_ID)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.CursesWindow.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.WINDOW_TYPE,ElGUI.Resource_ID)"]

eWndType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eWndType"/> documentation for "M:ElGUI.CursesWindow.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.WINDOW_TYPE,ElGUI.Resource_ID)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.CursesWindow.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.WINDOW_TYPE,ElGUI.Resource_ID)"]

See Also

CursesWindow Class
CursesWindow Overload
ElGUI Namespace


CursesWindow Fields

[image] [image]

4 of William Foster's Class Libraries
CursesWindow Fields
CursesWindow Class See Also Send Feedback

The CursesWindow type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

CursesWindow Class
ElGUI Namespace


CursesWindow Methods

[image] [image]

4 of William Foster's Class Libraries
CursesWindow Methods
CursesWindow Class See Also Send Feedback

The CursesWindow type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | bell |
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | clear |
Public method | clr_to_eol |
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Protected method | GetC |
Public method | GetCursorPosition |
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Protected method | getline |
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetScreenPosition()()()() |
Public method | GetScreenPosition(Size2dU) |
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Public method | home |
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | moveto(Size2dU) |
Public method | moveto(Int32, Int32) |
Protected method | OnCreate | (Overrides UILayerWindow..::..OnCreate()()()().)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Overrides Window..::..OnKeyDown(Char).)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Public method | raw |
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Overrides UILayerWindow..::..SetText(String).)
Public method | SetTextDimensions |
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Public method | sizewindow |
Public method | Space |
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | unraw |
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

CursesWindow Class
ElGUI Namespace


bell Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..bell Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.bell"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool bell()
Visual Basic
Public Overridable Function bell As Boolean
Visual C++
public:
virtual bool bell()

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.bell"]

See Also

CursesWindow Class
ElGUI Namespace


clear Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..clear Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.clear"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool clear()
Visual Basic
Public Overridable Function clear As Boolean
Visual C++
public:
virtual bool clear()

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.clear"]

See Also

CursesWindow Class
ElGUI Namespace


clr_to_eol Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..clr_to_eol Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.clr_to_eol"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool clr_to_eol()
Visual Basic
Public Overridable Function clr_to_eol As Boolean
Visual C++
public:
virtual bool clr_to_eol()

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.clr_to_eol"]

See Also

CursesWindow Class
ElGUI Namespace


GetC Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..GetC Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.GetC"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected char GetC()
Visual Basic
Protected Function GetC As Char
Visual C++
protected:
wchar_t GetC()

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.GetC"]

See Also

CursesWindow Class
ElGUI Namespace


GetCursorPosition Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..GetCursorPosition Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.GetCursorPosition"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Size2dU GetCursorPosition()
Visual Basic
Public Function GetCursorPosition As Size2dU
Visual C++
public:
Size2dU^ GetCursorPosition()

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.GetCursorPosition"]

See Also

CursesWindow Class
ElGUI Namespace


getline Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..getline Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.getline(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int getline(
    STRING cs
)
Visual Basic
Protected Function getline ( _
    cs As STRING _
) As Integer
Visual C++
protected:
int getline(
    STRING^ cs
)

Parameters

cs
Type: STRING

[Missing <param name="cs"/> documentation for "M:ElGUI.CursesWindow.getline(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.getline(El.STRING)"]

See Also

CursesWindow Class
ElGUI Namespace


GetScreenPosition Method

[image] [image]

4 of William Foster's Class Libraries
CursesWindow..::..GetScreenPosition Method
CursesWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetScreenPosition()()()() |
Public method | GetScreenPosition(Size2dU) |

See Also

CursesWindow Class
CursesWindow Members
ElGUI Namespace


GetScreenPosition Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..GetScreenPosition Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.GetScreenPosition"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Size2dU GetScreenPosition()
Visual Basic
Public Function GetScreenPosition As Size2dU
Visual C++
public:
Size2dU^ GetScreenPosition()

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.GetScreenPosition"]

See Also

CursesWindow Class
GetScreenPosition Overload
ElGUI Namespace


GetScreenPosition Method ()

[image]

4 of William Foster's Class Libraries
CursesWindow..::..GetScreenPosition Method ()
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.GetScreenPosition(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Size2dU GetScreenPosition(
    Size2dU textpos
)
Visual Basic
Public Function GetScreenPosition ( _
    textpos As Size2dU _
) As Size2dU
Visual C++
public:
Size2dU^ GetScreenPosition(
    Size2dU^ textpos
)

Parameters

textpos
Type: Size2dU

[Missing <param name="textpos"/> documentation for "M:ElGUI.CursesWindow.GetScreenPosition(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.GetScreenPosition(El.Size2dU)"]

See Also

CursesWindow Class
GetScreenPosition Overload
ElGUI Namespace


home Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..home Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.home"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool home()
Visual Basic
Public Overridable Function home As Boolean
Visual C++
public:
virtual bool home()

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.home"]

See Also

CursesWindow Class
ElGUI Namespace


moveto Method

[image] [image]

4 of William Foster's Class Libraries
CursesWindow..::..moveto Method
CursesWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | moveto(Size2dU) |
Public method | moveto(Int32, Int32) |

See Also

CursesWindow Class
CursesWindow Members
ElGUI Namespace


moveto Method ()

[image]

4 of William Foster's Class Libraries
CursesWindow..::..moveto Method ()
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.moveto(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool moveto(
    Size2dU pt
)
Visual Basic
Public Overridable Function moveto ( _
    pt As Size2dU _
) As Boolean
Visual C++
public:
virtual bool moveto(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.CursesWindow.moveto(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.moveto(El.Size2dU)"]

See Also

CursesWindow Class
moveto Overload
ElGUI Namespace


moveto Method (Int32, Int32)

[image]

4 of William Foster's Class Libraries
CursesWindow..::..moveto Method (Int32, Int32)
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.moveto(System.Int32,System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool moveto(
    int y,
    int x
)
Visual Basic
Public Overridable Function moveto ( _
    y As Integer, _
    x As Integer _
) As Boolean
Visual C++
public:
virtual bool moveto(
    int y,
    int x
)

Parameters

y
Type: System..::..Int32

[Missing <param name="y"/> documentation for "M:ElGUI.CursesWindow.moveto(System.Int32,System.Int32)"]

x
Type: System..::..Int32

[Missing <param name="x"/> documentation for "M:ElGUI.CursesWindow.moveto(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.moveto(System.Int32,System.Int32)"]

See Also

CursesWindow Class
moveto Overload
ElGUI Namespace


OnCreate Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..OnCreate Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.OnCreate"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool OnCreate()
Visual Basic
Protected Overrides Function OnCreate As Boolean
Visual C++
protected:
virtual bool OnCreate() override

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.OnCreate"]

See Also

CursesWindow Class
ElGUI Namespace


OnKeyDown Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..OnKeyDown Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.OnKeyDown(System.Char)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int OnKeyDown(
    char key
)
Visual Basic
Public Overrides Function OnKeyDown ( _
    key As Char _
) As Integer
Visual C++
public:
virtual int OnKeyDown(
    wchar_t key
) override

Parameters

key
Type: System..::..Char

[Missing <param name="key"/> documentation for "M:ElGUI.CursesWindow.OnKeyDown(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.OnKeyDown(System.Char)"]

Implements

ITerminalWindow..::..OnKeyDown(Char)

See Also

CursesWindow Class
ElGUI Namespace


raw Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..raw Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.raw"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void raw()
Visual Basic
Public Sub raw
Visual C++
public:
void raw()

See Also

CursesWindow Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
CursesWindow..::..SetColor Method
CursesWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

CursesWindow Class
CursesWindow Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
CursesWindow..::..SetDefaultCursor Method
CursesWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

CursesWindow Class
CursesWindow Members
ElGUI Namespace


SetText Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..SetText Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.SetText(System.String)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void SetText(
    string s
)
Visual Basic
Public Overrides Sub SetText ( _
    s As String _
)
Visual C++
public:
virtual void SetText(
    String^ s
) override

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:ElGUI.CursesWindow.SetText(System.String)"]

See Also

CursesWindow Class
ElGUI Namespace


SetTextDimensions Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..SetTextDimensions Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.SetTextDimensions(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetTextDimensions(
    Size2dU dim
)
Visual Basic
Public Function SetTextDimensions ( _
    dim As Size2dU _
) As Boolean
Visual C++
public:
bool SetTextDimensions(
    Size2dU^ dim
)

Parameters

dim
Type: Size2dU

[Missing <param name="dim"/> documentation for "M:ElGUI.CursesWindow.SetTextDimensions(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.CursesWindow.SetTextDimensions(El.Size2dU)"]

See Also

CursesWindow Class
ElGUI Namespace


sizewindow Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..sizewindow Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.sizewindow(System.Int32,System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void sizewindow(
    int x,
    int y
)
Visual Basic
Public Sub sizewindow ( _
    x As Integer, _
    y As Integer _
)
Visual C++
public:
void sizewindow(
    int x,
    int y
)

Parameters

x
Type: System..::..Int32

[Missing <param name="x"/> documentation for "M:ElGUI.CursesWindow.sizewindow(System.Int32,System.Int32)"]

y
Type: System..::..Int32

[Missing <param name="y"/> documentation for "M:ElGUI.CursesWindow.sizewindow(System.Int32,System.Int32)"]

See Also

CursesWindow Class
ElGUI Namespace


Space Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..Space Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.Space(System.UInt32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Space(
    uint pels
)
Visual Basic
Public Sub Space ( _
    pels As UInteger _
)
Visual C++
public:
void Space(
    unsigned int pels
)

Parameters

pels
Type: System..::..UInt32

[Missing <param name="pels"/> documentation for "M:ElGUI.CursesWindow.Space(System.UInt32)"]

See Also

CursesWindow Class
ElGUI Namespace


unraw Method

[image]

4 of William Foster's Class Libraries
CursesWindow..::..unraw Method
CursesWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.CursesWindow.unraw"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void unraw()
Visual Basic
Public Sub unraw
Visual C++
public:
void unraw()

See Also

CursesWindow Class
ElGUI Namespace


CursesWindow Properties

[image] [image]

4 of William Foster's Class Libraries
CursesWindow Properties
CursesWindow Class See Also Send Feedback

The CursesWindow type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

CursesWindow Class
ElGUI Namespace


CURSOR Enumeration

[image]

4 of William Foster's Class Libraries
CURSOR Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.CURSOR"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum CURSOR
Visual Basic
Public Enumeration CURSOR
Visual C++
public enum class CURSOR

Members

Member name | Value | Description
CURSOR_ARROW | 1 |
CURSOR_RARROW | 2 |
CURSOR_IBEAM | 3 |
CURSOR_WATCH | 4 |
CURSOR_CROSS | 5 |
CURSOR_UPDOWN | 6 |
CURSOR_LEFTRIGHT | 7 |
CURSOR_MOVE | 8 |

See Also

ElGUI Namespace


Data_Resource_Control Class

[image]

4 of William Foster's Class Libraries
Data_Resource_Control Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Data_Resource_Control"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class Data_Resource_Control : Resource_Control
Visual Basic
Public MustInherit Class Data_Resource_Control _
    Inherits Resource_Control
Visual C++
public ref class Data_Resource_Control abstract : public Resource_Control

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..Resource_Control
ElGUI..::..Data_Resource_Control
ElGUI..::..Slider
ElGUI..::..TextData_Resource_Control

See Also

Data_Resource_Control Members
ElGUI Namespace


Data_Resource_Control Members

[image] [image]

4 of William Foster's Class Libraries
Data_Resource_Control Members
Data_Resource_Control Class Constructors Methods Fields Properties See Also Send Feedback

The Data_Resource_Control type exposes the following members.

Constructors

 | Name | Description
Public method | Data_Resource_Control | Initializes a new instance of the Data_Resource_Control class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value |
Public property | Value_int |
Public property | Value_uint |
Public property | window | (Inherited from UILayerWindow.)

See Also

Data_Resource_Control Class
ElGUI Namespace


Data_Resource_Control Constructor

[image]

4 of William Foster's Class Libraries
Data_Resource_Control Constructor
Data_Resource_Control Class See Also Send Feedback
Initializes a new instance of the Data_Resource_Control class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Data_Resource_Control(
    GUI gui,
    Window Parent,
    STRING csText,
    Resource_ID resourceID,
    WINDOW_TYPE eType
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    Parent As Window, _
    csText As STRING, _
    resourceID As Resource_ID, _
    eType As WINDOW_TYPE _
)
Visual C++
public:
Data_Resource_Control(
    GUI^ gui,
    Window^ Parent,
    STRING^ csText,
    Resource_ID resourceID,
    WINDOW_TYPE eType
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.Data_Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.Data_Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.Data_Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.Data_Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.Data_Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

See Also

Data_Resource_Control Class
ElGUI Namespace


Data_Resource_Control Fields

[image] [image]

4 of William Foster's Class Libraries
Data_Resource_Control Fields
Data_Resource_Control Class See Also Send Feedback

The Data_Resource_Control type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

Data_Resource_Control Class
ElGUI Namespace


Data_Resource_Control Methods

[image] [image]

4 of William Foster's Class Libraries
Data_Resource_Control Methods
Data_Resource_Control Class See Also Send Feedback

The Data_Resource_Control type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

Data_Resource_Control Class
ElGUI Namespace


GetText Method

[image] [image]

4 of William Foster's Class Libraries
Data_Resource_Control..::..GetText Method
Data_Resource_Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)

See Also

Data_Resource_Control Class
Data_Resource_Control Members
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
Data_Resource_Control..::..SetColor Method
Data_Resource_Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

Data_Resource_Control Class
Data_Resource_Control Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
Data_Resource_Control..::..SetDefaultCursor Method
Data_Resource_Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

Data_Resource_Control Class
Data_Resource_Control Members
ElGUI Namespace


Data_Resource_Control Properties

[image] [image]

4 of William Foster's Class Libraries
Data_Resource_Control Properties
Data_Resource_Control Class See Also Send Feedback

The Data_Resource_Control type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value |
Public property | Value_int |
Public property | Value_uint |
Public property | window | (Inherited from UILayerWindow.)

See Also

Data_Resource_Control Class
ElGUI Namespace


Value Property

[image]

4 of William Foster's Class Libraries
Data_Resource_Control..::..Value Property
Data_Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.Data_Resource_Control.Value"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract double Value { get; set; }
Visual Basic
Public MustOverride Property Value As Double
    Get
    Set
Visual C++
public:
virtual property double Value {
    double get () abstract;
    void set (double value) abstract;
}

See Also

Data_Resource_Control Class
ElGUI Namespace


Value_int Property

[image]

4 of William Foster's Class Libraries
Data_Resource_Control..::..Value_int Property
Data_Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.Data_Resource_Control.Value_int"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Value_int { get; set; }
Visual Basic
Public Property Value_int As Integer
    Get
    Set
Visual C++
public:
property int Value_int {
    int get ();
    void set (int value);
}

See Also

Data_Resource_Control Class
ElGUI Namespace


Value_uint Property

[image]

4 of William Foster's Class Libraries
Data_Resource_Control..::..Value_uint Property
Data_Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.Data_Resource_Control.Value_uint"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract uint Value_uint { get; set; }
Visual Basic
Public MustOverride Property Value_uint As UInteger
    Get
    Set
Visual C++
public:
virtual property unsigned int Value_uint {
    unsigned int get () abstract;
    void set (unsigned int value) abstract;
}

See Also

Data_Resource_Control Class
ElGUI Namespace


DataSource Class

[image]

4 of William Foster's Class Libraries
DataSource Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.DataSource"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DataSource
Visual Basic
Public Class DataSource
Visual C++
public ref class DataSource

Inheritance Hierarchy

System..::..Object
ElGUI..::..DataSource

See Also

DataSource Members
ElGUI Namespace


DataSource Members

[image] [image]

4 of William Foster's Class Libraries
DataSource Members
DataSource Class Constructors Methods See Also Send Feedback

The DataSource type exposes the following members.

Constructors

 | Name | Description
Public method | DataSource | Initializes a new instance of the DataSource class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDX |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSource Class
ElGUI Namespace


DataSource Constructor

[image]

4 of William Foster's Class Libraries
DataSource Constructor
DataSource Class See Also Send Feedback
Initializes a new instance of the DataSource class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataSource()
Visual Basic
Public Sub New
Visual C++
public:
DataSource()

See Also

DataSource Class
ElGUI Namespace


DataSource Methods

[image] [image]

4 of William Foster's Class Libraries
DataSource Methods
DataSource Class See Also Send Feedback

The DataSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDX |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSource Class
ElGUI Namespace


GetDX Method

[image]

4 of William Foster's Class Libraries
DataSource..::..GetDX Method
DataSource Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DataSource.GetDX"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DX GetDX()
Visual Basic
Public Function GetDX As DX
Visual C++
public:
DX^ GetDX()

Return Value

[Missing <returns> documentation for "M:ElGUI.DataSource.GetDX"]

See Also

DataSource Class
ElGUI Namespace


SetDX Method

[image]

4 of William Foster's Class Libraries
DataSource..::..SetDX Method
DataSource Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DataSource.SetDX(ElGUI.DX)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetDX(
    DX DX
)
Visual Basic
Public Sub SetDX ( _
    DX As DX _
)
Visual C++
public:
void SetDX(
    DX^ DX
)

Parameters

DX
Type: ElGUI..::..DX

[Missing <param name="DX"/> documentation for "M:ElGUI.DataSource.SetDX(ElGUI.DX)"]

See Also

DataSource Class
ElGUI Namespace


DialogWindow Class

[image]

4 of William Foster's Class Libraries
DialogWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.DialogWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DialogWindow : ResourceWindow
Visual Basic
Public Class DialogWindow _
    Inherits ResourceWindow
Visual C++
public ref class DialogWindow : public ResourceWindow

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..MenuWindow
ElGUI..::..ResourceWindow
ElGUI..::..DialogWindow
ElGUI..::..MessageBox
ElGUI..::..ToolBar
ElOS..::..FileDialog

See Also

DialogWindow Members
ElGUI Namespace


DialogWindow Members

[image] [image]

4 of William Foster's Class Libraries
DialogWindow Members
DialogWindow Class Constructors Methods Fields Properties See Also Send Feedback

The DialogWindow type exposes the following members.

Constructors

 | Name | Description
Public method | DialogWindow(GUI, array<Char>[]()[][], Window) | Initializes a new instance of the DialogWindow class
Public method | DialogWindow(GUI, String, Window, ResourceStore, WINDOW_TYPE) | Initializes a new instance of the DialogWindow class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu | (Inherited from MenuWindow.)
Protected method | AddResourceControl | (Inherited from ResourceWindow.)
Protected method | AddSpacer | (Inherited from ResourceWindow.)
Protected method | AddSwitcher | (Inherited from ResourceWindow.)
Protected method | AddWindow | (Inherited from ResourceWindow.)
Protected method | AddWindows | (Inherited from ResourceWindow.)
Public method | AppendResourceContainer | (Inherited from ResourceWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Protected method | ButtonPress |
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Protected method | CreateEntryList | (Inherited from ResourceWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | execute |
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Protected method | GetDP |
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Protected method | GetRCList | (Inherited from ResourceWindow.)
Protected method | GetResourceContainer | (Inherited from ResourceWindow.)
Public method | GetResourceControlList |
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUI_Text(STRING, Filename%) |
Public method | GetUI_Text(STRING, STRING%) |
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitializeResourceID | (Inherited from ResourceWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Public method | Lookup_Resource_Control(STRING) | (Inherited from ResourceWindow.)
Public method | Lookup_Resource_Control(Resource_ID) | (Inherited from ResourceWindow.)
Public method | LookupResourceEntity | (Inherited from ResourceWindow.)
Public method | LookupResourceName | (Inherited from ResourceWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Overrides UILayerWindow..::..OnCreate()()()().)
Protected method | OnDestroy | (Overrides Window..::..OnDestroy()()()().)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from MenuWindow.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Overrides MenuWindow..::..OnMessage(Message).)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | RecordKeyboardShortcut | (Inherited from MenuWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Public method | SetDP |
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetResourceContainer | (Inherited from ResourceWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetUI_Text |
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDS()()()() |
Protected method | UpdateDS(Resource_Control) | Given a control on a Dialog, Fill it in with the data fom the Dialog's DX
Public method | UpdateDX()()()() |
Protected method | UpdateDX(Button) |
Protected method | UpdateDX(Data_Resource_Control) | Called by DialogWindow.UpdateDX(Resource_Control RC) Given a Data_Resource_Control on a Dialog, read the control and store the information into the Dialog's DX
Protected method | UpdateDX(Resource_Control) | Given a control on a Dialog, read the control and store the information into the Dialog's DX
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName | (Inherited from MenuWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Public field | m_ds |
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_ResourceControl_List | (Inherited from ResourceWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

DialogWindow Class
ElGUI Namespace


DialogWindow Constructor

[image] [image]

4 of William Foster's Class Libraries
DialogWindow Constructor
DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DialogWindow(GUI, array<Char>[]()[][], Window) | Initializes a new instance of the DialogWindow class
Public method | DialogWindow(GUI, String, Window, ResourceStore, WINDOW_TYPE) | Initializes a new instance of the DialogWindow class

See Also

DialogWindow Class
DialogWindow Members
ElGUI Namespace


DialogWindow Constructor (GUI, Char[], Window)

[image]

4 of William Foster's Class Libraries
DialogWindow Constructor (GUI, array<Char>[]()[][], Window)
DialogWindow Class See Also Send Feedback
Initializes a new instance of the DialogWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DialogWindow(
    GUI gui,
    char[] pScript,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    pScript As Char(), _
    Parent As Window _
)
Visual C++
public:
DialogWindow(
    GUI^ gui,
    array<wchar_t>^ pScript,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.DialogWindow.#ctor(ElGUI.GUI,System.Char[],ElGUI.Window)"]

pScript
Type: array< System..::..Char >[]()[][]

[Missing <param name="pScript"/> documentation for "M:ElGUI.DialogWindow.#ctor(ElGUI.GUI,System.Char[],ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.DialogWindow.#ctor(ElGUI.GUI,System.Char[],ElGUI.Window)"]

See Also

DialogWindow Class
DialogWindow Overload
ElGUI Namespace


DialogWindow Constructor (GUI, String, Window, ResourceStore, WINDOW_TYPE)

[image]

4 of William Foster's Class Libraries
DialogWindow Constructor (GUI, String, Window, ResourceStore, WINDOW_TYPE)
DialogWindow Class See Also Send Feedback
Initializes a new instance of the DialogWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DialogWindow(
    GUI gui,
    string ResourceName,
    Window Parent,
    ResourceStore rStore,
    WINDOW_TYPE eType
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    ResourceName As String, _
    Parent As Window, _
    rStore As ResourceStore, _
    eType As WINDOW_TYPE _
)
Visual C++
public:
DialogWindow(
    GUI^ gui,
    String^ ResourceName,
    Window^ Parent,
    ResourceStore^ rStore,
    WINDOW_TYPE eType
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.DialogWindow.#ctor(ElGUI.GUI,System.String,ElGUI.Window,ElGUI.ResourceStore,ElGUI.WINDOW_TYPE)"]

ResourceName
Type: System..::..String

[Missing <param name="ResourceName"/> documentation for "M:ElGUI.DialogWindow.#ctor(ElGUI.GUI,System.String,ElGUI.Window,ElGUI.ResourceStore,ElGUI.WINDOW_TYPE)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.DialogWindow.#ctor(ElGUI.GUI,System.String,ElGUI.Window,ElGUI.ResourceStore,ElGUI.WINDOW_TYPE)"]

rStore
Type: ElGUI..::..ResourceStore

[Missing <param name="rStore"/> documentation for "M:ElGUI.DialogWindow.#ctor(ElGUI.GUI,System.String,ElGUI.Window,ElGUI.ResourceStore,ElGUI.WINDOW_TYPE)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.DialogWindow.#ctor(ElGUI.GUI,System.String,ElGUI.Window,ElGUI.ResourceStore,ElGUI.WINDOW_TYPE)"]

See Also

DialogWindow Class
DialogWindow Overload
ElGUI Namespace


DialogWindow Fields

[image] [image]

4 of William Foster's Class Libraries
DialogWindow Fields
DialogWindow Class See Also Send Feedback

The DialogWindow type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName | (Inherited from MenuWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Public field | m_ds |
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_ResourceControl_List | (Inherited from ResourceWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

DialogWindow Class
ElGUI Namespace


m_ds Field

[image]

4 of William Foster's Class Libraries
DialogWindow..::..m_ds Field
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.DialogWindow.m_ds"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataSource m_ds
Visual Basic
Public m_ds As DataSource
Visual C++
public:
DataSource^ m_ds

See Also

DialogWindow Class
ElGUI Namespace


DialogWindow Methods

[image] [image]

4 of William Foster's Class Libraries
DialogWindow Methods
DialogWindow Class See Also Send Feedback

The DialogWindow type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu | (Inherited from MenuWindow.)
Protected method | AddResourceControl | (Inherited from ResourceWindow.)
Protected method | AddSpacer | (Inherited from ResourceWindow.)
Protected method | AddSwitcher | (Inherited from ResourceWindow.)
Protected method | AddWindow | (Inherited from ResourceWindow.)
Protected method | AddWindows | (Inherited from ResourceWindow.)
Public method | AppendResourceContainer | (Inherited from ResourceWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Protected method | ButtonPress |
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Protected method | CreateEntryList | (Inherited from ResourceWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | execute |
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Protected method | GetDP |
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Protected method | GetRCList | (Inherited from ResourceWindow.)
Protected method | GetResourceContainer | (Inherited from ResourceWindow.)
Public method | GetResourceControlList |
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUI_Text(STRING, Filename%) |
Public method | GetUI_Text(STRING, STRING%) |
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitializeResourceID | (Inherited from ResourceWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Public method | Lookup_Resource_Control(STRING) | (Inherited from ResourceWindow.)
Public method | Lookup_Resource_Control(Resource_ID) | (Inherited from ResourceWindow.)
Public method | LookupResourceEntity | (Inherited from ResourceWindow.)
Public method | LookupResourceName | (Inherited from ResourceWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Overrides UILayerWindow..::..OnCreate()()()().)
Protected method | OnDestroy | (Overrides Window..::..OnDestroy()()()().)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from MenuWindow.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Overrides MenuWindow..::..OnMessage(Message).)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | RecordKeyboardShortcut | (Inherited from MenuWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Public method | SetDP |
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetResourceContainer | (Inherited from ResourceWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetUI_Text |
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDS()()()() |
Protected method | UpdateDS(Resource_Control) | Given a control on a Dialog, Fill it in with the data fom the Dialog's DX
Public method | UpdateDX()()()() |
Protected method | UpdateDX(Button) |
Protected method | UpdateDX(Data_Resource_Control) | Called by DialogWindow.UpdateDX(Resource_Control RC) Given a Data_Resource_Control on a Dialog, read the control and store the information into the Dialog's DX
Protected method | UpdateDX(Resource_Control) | Given a control on a Dialog, read the control and store the information into the Dialog's DX
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

DialogWindow Class
ElGUI Namespace


ButtonPress Method

[image]

4 of William Foster's Class Libraries
DialogWindow..::..ButtonPress Method
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.ButtonPress(ElGUI.Resource_ID,ElGUI.Resource_Control)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual bool ButtonPress(
    Resource_ID rID,
    Resource_Control Rc
)
Visual Basic
Protected Overridable Function ButtonPress ( _
    rID As Resource_ID, _
    Rc As Resource_Control _
) As Boolean
Visual C++
protected:
virtual bool ButtonPress(
    Resource_ID rID,
    Resource_Control^ Rc
)

Parameters

rID
Type: ElGUI..::..Resource_ID

[Missing <param name="rID"/> documentation for "M:ElGUI.DialogWindow.ButtonPress(ElGUI.Resource_ID,ElGUI.Resource_Control)"]

Rc
Type: ElGUI..::..Resource_Control

[Missing <param name="Rc"/> documentation for "M:ElGUI.DialogWindow.ButtonPress(ElGUI.Resource_ID,ElGUI.Resource_Control)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DialogWindow.ButtonPress(ElGUI.Resource_ID,ElGUI.Resource_Control)"]

See Also

DialogWindow Class
ElGUI Namespace


execute Method

[image]

4 of William Foster's Class Libraries
DialogWindow..::..execute Method
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.execute"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int execute()
Visual Basic
Public Overridable Function execute As Integer
Visual C++
public:
virtual int execute()

Return Value

[Missing <returns> documentation for "M:ElGUI.DialogWindow.execute"]

See Also

DialogWindow Class
ElGUI Namespace


GetDP Method

[image]

4 of William Foster's Class Libraries
DialogWindow..::..GetDP Method
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.GetDP"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected DlgDP GetDP()
Visual Basic
Protected Function GetDP As DlgDP
Visual C++
protected:
DlgDP^ GetDP()

Return Value

[Missing <returns> documentation for "M:ElGUI.DialogWindow.GetDP"]

See Also

DialogWindow Class
ElGUI Namespace


GetResourceControlList Method

[image]

4 of William Foster's Class Libraries
DialogWindow..::..GetResourceControlList Method
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.GetResourceControlList"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Array<Resource_Control> GetResourceControlList()
Visual Basic
Public Function GetResourceControlList As Array(Of Resource_Control)
Visual C++
public:
Array<Resource_Control^>^ GetResourceControlList()

Return Value

[Missing <returns> documentation for "M:ElGUI.DialogWindow.GetResourceControlList"]

See Also

DialogWindow Class
ElGUI Namespace


GetUI_Text Method

[image] [image]

4 of William Foster's Class Libraries
DialogWindow..::..GetUI_Text Method
DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUI_Text(STRING, Filename%) |
Public method | GetUI_Text(STRING, STRING%) |

See Also

DialogWindow Class
DialogWindow Members
ElGUI Namespace


GetUI_Text Method (, )

[image]

4 of William Foster's Class Libraries
DialogWindow..::..GetUI_Text Method (, %)
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.GetUI_Text(El.STRING,El.Filename@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GetUI_Text(
    STRING csResourceName,
    out Filename csText
)
Visual Basic
Public Function GetUI_Text ( _
    csResourceName As STRING, _
    <OutAttribute> ByRef csText As Filename _
) As Boolean
Visual C++
public:
bool GetUI_Text(
    STRING^ csResourceName,
    [OutAttribute] Filename^% csText
)

Parameters

csResourceName
Type: STRING

[Missing <param name="csResourceName"/> documentation for "M:ElGUI.DialogWindow.GetUI_Text(El.STRING,El.Filename@)"]

csText
Type: Filename%

[Missing <param name="csText"/> documentation for "M:ElGUI.DialogWindow.GetUI_Text(El.STRING,El.Filename@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DialogWindow.GetUI_Text(El.STRING,El.Filename@)"]

See Also

DialogWindow Class
GetUI_Text Overload
ElGUI Namespace


GetUI_Text Method (, )

[image]

4 of William Foster's Class Libraries
DialogWindow..::..GetUI_Text Method (, %)
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.GetUI_Text(El.STRING,El.STRING@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GetUI_Text(
    STRING csResourceName,
    out STRING csText
)
Visual Basic
Public Function GetUI_Text ( _
    csResourceName As STRING, _
    <OutAttribute> ByRef csText As STRING _
) As Boolean
Visual C++
public:
bool GetUI_Text(
    STRING^ csResourceName,
    [OutAttribute] STRING^% csText
)

Parameters

csResourceName
Type: STRING

[Missing <param name="csResourceName"/> documentation for "M:ElGUI.DialogWindow.GetUI_Text(El.STRING,El.STRING@)"]

csText
Type: STRING%

[Missing <param name="csText"/> documentation for "M:ElGUI.DialogWindow.GetUI_Text(El.STRING,El.STRING@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DialogWindow.GetUI_Text(El.STRING,El.STRING@)"]

See Also

DialogWindow Class
GetUI_Text Overload
ElGUI Namespace


Lookup_Resource_Control Method

[image] [image]

4 of William Foster's Class Libraries
DialogWindow..::..Lookup_Resource_Control Method
DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lookup_Resource_Control(STRING) | (Inherited from ResourceWindow.)
Public method | Lookup_Resource_Control(Resource_ID) | (Inherited from ResourceWindow.)

See Also

DialogWindow Class
DialogWindow Members
ElGUI Namespace


OnCreate Method

[image]

4 of William Foster's Class Libraries
DialogWindow..::..OnCreate Method
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.OnCreate"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool OnCreate()
Visual Basic
Protected Overrides Function OnCreate As Boolean
Visual C++
protected:
virtual bool OnCreate() override

Return Value

[Missing <returns> documentation for "M:ElGUI.DialogWindow.OnCreate"]

See Also

DialogWindow Class
ElGUI Namespace


OnDestroy Method

[image]

4 of William Foster's Class Libraries
DialogWindow..::..OnDestroy Method
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.OnDestroy"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override int OnDestroy()
Visual Basic
Protected Overrides Function OnDestroy As Integer
Visual C++
protected:
virtual int OnDestroy() override

Return Value

[Missing <returns> documentation for "M:ElGUI.DialogWindow.OnDestroy"]

See Also

DialogWindow Class
ElGUI Namespace


OnMessage Method

[image]

4 of William Foster's Class Libraries
DialogWindow..::..OnMessage Method
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.OnMessage(ElGUI.Message)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int OnMessage(
    Message msg
)
Visual Basic
Public Overrides Function OnMessage ( _
    msg As Message _
) As Integer
Visual C++
public:
virtual int OnMessage(
    Message^ msg
) override

Parameters

msg
Type: ElGUI..::..Message

[Missing <param name="msg"/> documentation for "M:ElGUI.DialogWindow.OnMessage(ElGUI.Message)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DialogWindow.OnMessage(ElGUI.Message)"]

Implements

ITerminalWindow..::..OnMessage(Message)

See Also

DialogWindow Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
DialogWindow..::..SetColor Method
DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

DialogWindow Class
DialogWindow Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
DialogWindow..::..SetDefaultCursor Method
DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

DialogWindow Class
DialogWindow Members
ElGUI Namespace


SetDP Method

[image]

4 of William Foster's Class Libraries
DialogWindow..::..SetDP Method
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.SetDP(ElGUI.DlgDP)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetDP(
    DlgDP DP
)
Visual Basic
Public Sub SetDP ( _
    DP As DlgDP _
)
Visual C++
public:
void SetDP(
    DlgDP^ DP
)

Parameters

DP
Type: ElGUI..::..DlgDP

[Missing <param name="DP"/> documentation for "M:ElGUI.DialogWindow.SetDP(ElGUI.DlgDP)"]

See Also

DialogWindow Class
ElGUI Namespace


SetUI_Text Method

[image]

4 of William Foster's Class Libraries
DialogWindow..::..SetUI_Text Method
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.SetUI_Text(El.STRING,El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetUI_Text(
    STRING csResourceName,
    STRING csText
)
Visual Basic
Public Function SetUI_Text ( _
    csResourceName As STRING, _
    csText As STRING _
) As Boolean
Visual C++
public:
bool SetUI_Text(
    STRING^ csResourceName,
    STRING^ csText
)

Parameters

csResourceName
Type: STRING

[Missing <param name="csResourceName"/> documentation for "M:ElGUI.DialogWindow.SetUI_Text(El.STRING,El.STRING)"]

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.DialogWindow.SetUI_Text(El.STRING,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DialogWindow.SetUI_Text(El.STRING,El.STRING)"]

See Also

DialogWindow Class
ElGUI Namespace


UpdateDS Method

[image] [image]

4 of William Foster's Class Libraries
DialogWindow..::..UpdateDS Method
DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateDS()()()() |
Protected method | UpdateDS(Resource_Control) | Given a control on a Dialog, Fill it in with the data fom the Dialog's DX

See Also

DialogWindow Class
DialogWindow Members
ElGUI Namespace


UpdateDS Method

[image]

4 of William Foster's Class Libraries
DialogWindow..::..UpdateDS Method
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.UpdateDS"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void UpdateDS()
Visual Basic
Public Sub UpdateDS
Visual C++
public:
void UpdateDS()

See Also

DialogWindow Class
UpdateDS Overload
ElGUI Namespace


UpdateDS Method (Resource_Control)

[image]

4 of William Foster's Class Libraries
DialogWindow..::..UpdateDS Method (Resource_Control)
DialogWindow Class See Also Send Feedback
Given a control on a Dialog, Fill it in with the data fom the Dialog's DX

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void UpdateDS(
    Resource_Control Rc
)
Visual Basic
Protected Overridable Sub UpdateDS ( _
    Rc As Resource_Control _
)
Visual C++
protected:
virtual void UpdateDS(
    Resource_Control^ Rc
)

Parameters

Rc
Type: ElGUI..::..Resource_Control

[Missing <param name="Rc"/> documentation for "M:ElGUI.DialogWindow.UpdateDS(ElGUI.Resource_Control)"]

See Also

DialogWindow Class
UpdateDS Overload
ElGUI Namespace


UpdateDX Method

[image] [image]

4 of William Foster's Class Libraries
DialogWindow..::..UpdateDX Method
DialogWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateDX()()()() |
Protected method | UpdateDX(Button) |
Protected method | UpdateDX(Data_Resource_Control) | Called by DialogWindow.UpdateDX(Resource_Control RC) Given a Data_Resource_Control on a Dialog, read the control and store the information into the Dialog's DX
Protected method | UpdateDX(Resource_Control) | Given a control on a Dialog, read the control and store the information into the Dialog's DX

See Also

DialogWindow Class
DialogWindow Members
ElGUI Namespace


UpdateDX Method

[image]

4 of William Foster's Class Libraries
DialogWindow..::..UpdateDX Method
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.UpdateDX"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void UpdateDX()
Visual Basic
Public Sub UpdateDX
Visual C++
public:
void UpdateDX()

See Also

DialogWindow Class
UpdateDX Overload
ElGUI Namespace


UpdateDX Method (Button)

[image]

4 of William Foster's Class Libraries
DialogWindow..::..UpdateDX Method (Button)
DialogWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DialogWindow.UpdateDX(ElGUI.Button)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void UpdateDX(
    Button RC
)
Visual Basic
Protected Overridable Sub UpdateDX ( _
    RC As Button _
)
Visual C++
protected:
virtual void UpdateDX(
    Button^ RC
)

Parameters

RC
Type: ElGUI..::..Button

[Missing <param name="RC"/> documentation for "M:ElGUI.DialogWindow.UpdateDX(ElGUI.Button)"]

See Also

DialogWindow Class
UpdateDX Overload
ElGUI Namespace


UpdateDX Method (Data_Resource_Control)

[image]

4 of William Foster's Class Libraries
DialogWindow..::..UpdateDX Method (Data_Resource_Control)
DialogWindow Class See Also Send Feedback
Called by DialogWindow.UpdateDX(Resource_Control RC) Given a Data_Resource_Control on a Dialog, read the control and store the information into the Dialog's DX

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void UpdateDX(
    Data_Resource_Control RC
)
Visual Basic
Protected Overridable Sub UpdateDX ( _
    RC As Data_Resource_Control _
)
Visual C++
protected:
virtual void UpdateDX(
    Data_Resource_Control^ RC
)

Parameters

RC
Type: ElGUI..::..Data_Resource_Control

[Missing <param name="RC"/> documentation for "M:ElGUI.DialogWindow.UpdateDX(ElGUI.Data_Resource_Control)"]

See Also

DialogWindow Class
UpdateDX Overload
ElGUI Namespace


UpdateDX Method (Resource_Control)

[image]

4 of William Foster's Class Libraries
DialogWindow..::..UpdateDX Method (Resource_Control)
DialogWindow Class See Also Send Feedback
Given a control on a Dialog, read the control and store the information into the Dialog's DX

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void UpdateDX(
    Resource_Control RC
)
Visual Basic
Protected Overridable Sub UpdateDX ( _
    RC As Resource_Control _
)
Visual C++
protected:
virtual void UpdateDX(
    Resource_Control^ RC
)

Parameters

RC
Type: ElGUI..::..Resource_Control

[Missing <param name="RC"/> documentation for "M:ElGUI.DialogWindow.UpdateDX(ElGUI.Resource_Control)"]

See Also

DialogWindow Class
UpdateDX Overload
ElGUI Namespace


DialogWindow Properties

[image] [image]

4 of William Foster's Class Libraries
DialogWindow Properties
DialogWindow Class See Also Send Feedback

The DialogWindow type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

DialogWindow Class
ElGUI Namespace


DlgDP Class

[image]

4 of William Foster's Class Libraries
DlgDP Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.DlgDP"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class DlgDP : DP
Visual Basic
Public MustInherit Class DlgDP _
    Inherits DP
Visual C++
public ref class DlgDP abstract : public DP

Inheritance Hierarchy

System..::..Object
ElGUI..::..DP
ElGUI..::..DlgDP
ElGUI..::..CDefault_DlgDP
ElGUI..::..ToolbarDP

See Also

DlgDP Members
ElGUI Namespace


DlgDP Members

[image] [image]

4 of William Foster's Class Libraries
DlgDP Members
DlgDP Class Constructors Methods Fields See Also Send Feedback

The DlgDP type exposes the following members.

Constructors

 | Name | Description
Public method | DlgDP | Initializes a new instance of the DlgDP class

Methods

 | Name | Description
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetGUI |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview | (Inherited from DP.)
Public method | ProcessInput |
Public method | RunDlg(DialogWindow, DP) |
Public method | RunDlg(Window, STRING) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_parent |

See Also

DlgDP Class
ElGUI Namespace


DlgDP Constructor

[image]

4 of William Foster's Class Libraries
DlgDP Constructor
DlgDP Class See Also Send Feedback
Initializes a new instance of the DlgDP class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DlgDP(
    GUI gui,
    DX dx,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    dx As DX, _
    Parent As Window _
)
Visual C++
public:
DlgDP(
    GUI^ gui,
    DX^ dx,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.DlgDP.#ctor(ElGUI.GUI,ElGUI.DX,ElGUI.Window)"]

dx
Type: ElGUI..::..DX

[Missing <param name="dx"/> documentation for "M:ElGUI.DlgDP.#ctor(ElGUI.GUI,ElGUI.DX,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.DlgDP.#ctor(ElGUI.GUI,ElGUI.DX,ElGUI.Window)"]

See Also

DlgDP Class
ElGUI Namespace


DlgDP Fields

[image] [image]

4 of William Foster's Class Libraries
DlgDP Fields
DlgDP Class See Also Send Feedback

The DlgDP type exposes the following members.

Fields

 | Name | Description
Protected field | m_parent |

See Also

DlgDP Class
ElGUI Namespace


m_parent Field

[image]

4 of William Foster's Class Libraries
DlgDP..::..m_parent Field
DlgDP Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.DlgDP.m_parent"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Window m_parent
Visual Basic
Protected m_parent As Window
Visual C++
protected:
Window^ m_parent

See Also

DlgDP Class
ElGUI Namespace


DlgDP Methods

[image] [image]

4 of William Foster's Class Libraries
DlgDP Methods
DlgDP Class See Also Send Feedback

The DlgDP type exposes the following members.

Methods

 | Name | Description
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetGUI |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview | (Inherited from DP.)
Public method | ProcessInput |
Public method | RunDlg(DialogWindow, DP) |
Public method | RunDlg(Window, STRING) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DlgDP Class
ElGUI Namespace


GetGUI Method

[image]

4 of William Foster's Class Libraries
DlgDP..::..GetGUI Method
DlgDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DlgDP.GetGUI"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GUI GetGUI()
Visual Basic
Public Function GetGUI As GUI
Visual C++
public:
GUI^ GetGUI()

Return Value

[Missing <returns> documentation for "M:ElGUI.DlgDP.GetGUI"]

See Also

DlgDP Class
ElGUI Namespace


ProcessInput Method

[image]

4 of William Foster's Class Libraries
DlgDP..::..ProcessInput Method
DlgDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DlgDP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract bool ProcessInput(
    Resource_Control RC,
    DialogWindow DS
)
Visual Basic
Public MustOverride Function ProcessInput ( _
    RC As Resource_Control, _
    DS As DialogWindow _
) As Boolean
Visual C++
public:
virtual bool ProcessInput(
    Resource_Control^ RC,
    DialogWindow^ DS
) abstract

Parameters

RC
Type: ElGUI..::..Resource_Control

[Missing <param name="RC"/> documentation for "M:ElGUI.DlgDP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

DS
Type: ElGUI..::..DialogWindow

[Missing <param name="DS"/> documentation for "M:ElGUI.DlgDP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DlgDP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

See Also

DlgDP Class
ElGUI Namespace


RunDlg Method

[image] [image]

4 of William Foster's Class Libraries
DlgDP..::..RunDlg Method
DlgDP Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RunDlg(DialogWindow, DP) |
Public method | RunDlg(Window, STRING) |

See Also

DlgDP Class
DlgDP Members
ElGUI Namespace


RunDlg Method (DialogWindow, DP)

[image]

4 of William Foster's Class Libraries
DlgDP..::..RunDlg Method (DialogWindow, DP)
DlgDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DlgDP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract int RunDlg(
    DialogWindow dlg,
    DP PreviewDP
)
Visual Basic
Public MustOverride Function RunDlg ( _
    dlg As DialogWindow, _
    PreviewDP As DP _
) As Integer
Visual C++
public:
virtual int RunDlg(
    DialogWindow^ dlg,
    DP^ PreviewDP
) abstract

Parameters

dlg
Type: ElGUI..::..DialogWindow

[Missing <param name="dlg"/> documentation for "M:ElGUI.DlgDP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

PreviewDP
Type: ElGUI..::..DP

[Missing <param name="PreviewDP"/> documentation for "M:ElGUI.DlgDP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DlgDP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

See Also

DlgDP Class
RunDlg Overload
ElGUI Namespace


RunDlg Method (Window, )

[image]

4 of William Foster's Class Libraries
DlgDP..::..RunDlg Method (Window, )
DlgDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DlgDP.RunDlg(ElGUI.Window,El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int RunDlg(
    Window Parent,
    STRING DialogName
)
Visual Basic
Public Function RunDlg ( _
    Parent As Window, _
    DialogName As STRING _
) As Integer
Visual C++
public:
int RunDlg(
    Window^ Parent,
    STRING^ DialogName
)

Parameters

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.DlgDP.RunDlg(ElGUI.Window,El.STRING)"]

DialogName
Type: STRING

[Missing <param name="DialogName"/> documentation for "M:ElGUI.DlgDP.RunDlg(ElGUI.Window,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DlgDP.RunDlg(ElGUI.Window,El.STRING)"]

See Also

DlgDP Class
RunDlg Overload
ElGUI Namespace


DP Class

[image]

4 of William Foster's Class Libraries
DP Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.DP"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class DP
Visual Basic
Public MustInherit Class DP
Visual C++
public ref class DP abstract

Inheritance Hierarchy

System..::..Object
ElGUI..::..DP
ElGUI..::..ActionDP
ElGUI..::..DlgDP
ElImage..::..MagicWandDP

See Also

DP Members
ElGUI Namespace


DP Members

[image] [image]

4 of William Foster's Class Libraries
DP Members
DP Class Constructors Methods See Also Send Feedback

The DP type exposes the following members.

Constructors

 | Name | Description
Public method | DP | Initializes a new instance of the DP class

Methods

 | Name | Description
Public method | CreateDialog |
Public method | DonePreviewing |
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DP Class
ElGUI Namespace


DP Constructor

[image]

4 of William Foster's Class Libraries
DP Constructor
DP Class See Also Send Feedback
Initializes a new instance of the DP class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DP(
    DX dx
)
Visual Basic
Public Sub New ( _
    dx As DX _
)
Visual C++
public:
DP(
    DX^ dx
)

Parameters

dx
Type: ElGUI..::..DX

[Missing <param name="dx"/> documentation for "M:ElGUI.DP.#ctor(ElGUI.DX)"]

See Also

DP Class
ElGUI Namespace


DP Methods

[image] [image]

4 of William Foster's Class Libraries
DP Methods
DP Class See Also Send Feedback

The DP type exposes the following members.

Methods

 | Name | Description
Public method | CreateDialog |
Public method | DonePreviewing |
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DP Class
ElGUI Namespace


CreateDialog Method

[image]

4 of William Foster's Class Libraries
DP..::..CreateDialog Method
DP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DP.CreateDialog(ElGUI.Window,System.Boolean)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual DialogWindow CreateDialog(
    Window Parent,
    bool bPopup
)
Visual Basic
Public Overridable Function CreateDialog ( _
    Parent As Window, _
    bPopup As Boolean _
) As DialogWindow
Visual C++
public:
virtual DialogWindow^ CreateDialog(
    Window^ Parent,
    bool bPopup
)

Parameters

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.DP.CreateDialog(ElGUI.Window,System.Boolean)"]

bPopup
Type: System..::..Boolean

[Missing <param name="bPopup"/> documentation for "M:ElGUI.DP.CreateDialog(ElGUI.Window,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DP.CreateDialog(ElGUI.Window,System.Boolean)"]

See Also

DP Class
ElGUI Namespace


DonePreviewing Method

[image]

4 of William Foster's Class Libraries
DP..::..DonePreviewing Method
DP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DP.DonePreviewing"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual void DonePreviewing()
Visual Basic
Public Overridable Sub DonePreviewing
Visual C++
public:
virtual void DonePreviewing()

See Also

DP Class
ElGUI Namespace


Edit Method

[image]

4 of William Foster's Class Libraries
DP..::..Edit Method
DP Class See Also Send Feedback
Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list.

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Edit(
    Window Parent,
    bool bPopup
)
Visual Basic
Public Function Edit ( _
    Parent As Window, _
    bPopup As Boolean _
) As Integer
Visual C++
public:
int Edit(
    Window^ Parent,
    bool bPopup
)

Parameters

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.DP.Edit(ElGUI.Window,System.Boolean)"]

bPopup
Type: System..::..Boolean

[Missing <param name="bPopup"/> documentation for "M:ElGUI.DP.Edit(ElGUI.Window,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DP.Edit(ElGUI.Window,System.Boolean)"]

See Also

DP Class
ElGUI Namespace


GetDX Method

[image]

4 of William Foster's Class Libraries
DP..::..GetDX Method
DP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DP.GetDX"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DX GetDX()
Visual Basic
Public Function GetDX As DX
Visual C++
public:
DX^ GetDX()

Return Value

[Missing <returns> documentation for "M:ElGUI.DP.GetDX"]

See Also

DP Class
ElGUI Namespace


Preview Method

[image]

4 of William Foster's Class Libraries
DP..::..Preview Method
DP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DP.Preview"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool Preview()
Visual Basic
Public Overridable Function Preview As Boolean
Visual C++
public:
virtual bool Preview()

Return Value

[Missing <returns> documentation for "M:ElGUI.DP.Preview"]

See Also

DP Class
ElGUI Namespace


DX Class

[image]

4 of William Foster's Class Libraries
DX Class
Members See Also Send Feedback
The DX, or DataExchange Class is the baseclass for a set of data This dataset is used by both by various DS (DataSources) and also DP (DataProcessors). The DS interacts to fill in the DX with appropriate parameters, and then the DP acts using the values describes by the DX.

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class DX
Visual Basic
Public MustInherit Class DX
Visual C++
public ref class DX abstract

Inheritance Hierarchy

System..::..Object
ElGUI..::..DX
ElImage..::..ImageActionDX
ElImage..::..MagicWandDX
ElOS..::..FileSelection_DX

See Also

DX Members
ElGUI Namespace


DX Members

[image] [image]

4 of William Foster's Class Libraries
DX Members
DX Class Constructors Methods Fields See Also Send Feedback

The DX type exposes the following members.

Constructors

 | Name | Description
Public method | DX()()()() | Initializes a new instance of the DX class
Public method | DX(array<DXEntry>[]()[][]) | Initializes a new instance of the DX class

Methods

 | Name | Description
Protected method | CreateMatrix |
Public method | CreateTable | Set up the (empty) DX in memory with fields representing values
 | DoubleToString |
Public method | Dup | Make a Seperate and detached, complete Duplicate Copy of this DX
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateResource |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMember |
Public method | GetMemberBool |
Public method | GetSet | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX.
Public method | GetSetCheck | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX.
Public method | GetSetText | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX.
Public method | GetSetUint | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateField | Check the DXEntry list for a resource control with the given name
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegistryLoad | Load up this DX from the default registry entries based apon the DXEntry list.
Public method | RegistrySave | Based apon the DXEntry list, Automatically Save out any important paramenters of this DX to the registry with unique naming
 | StringToDouble |
 | StringTouint |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | uintToString |

Fields

 | Name | Description
Protected field | m_csRegistryName |
Public field | m_dlgdp_classname |
Protected field | m_FieldList |

See Also

DX Class
ElGUI Namespace


DX Constructor

[image] [image]

4 of William Foster's Class Libraries
DX Constructor
DX Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DX()()()() | Initializes a new instance of the DX class
Public method | DX(array<DXEntry>[]()[][]) | Initializes a new instance of the DX class

See Also

DX Class
DX Members
ElGUI Namespace


DX Constructor

[image]

4 of William Foster's Class Libraries
DX Constructor
DX Class See Also Send Feedback
Initializes a new instance of the DX class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DX()
Visual Basic
Public Sub New
Visual C++
public:
DX()

See Also

DX Class
DX Overload
ElGUI Namespace


DX Constructor (DXEntry[])

[image]

4 of William Foster's Class Libraries
DX Constructor (array<DXEntry>[]()[][])
DX Class See Also Send Feedback
Initializes a new instance of the DX class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DX(
    DXEntry[] dxList
)
Visual Basic
Public Sub New ( _
    dxList As DXEntry() _
)
Visual C++
public:
DX(
    array<DXEntry>^ dxList
)

Parameters

dxList
Type: array< ElGUI..::..DXEntry >[]()[][]

[Missing <param name="dxList"/> documentation for "M:ElGUI.DX.#ctor(ElGUI.DXEntry[])"]

See Also

DX Class
DX Overload
ElGUI Namespace


DX Fields

[image] [image]

4 of William Foster's Class Libraries
DX Fields
DX Class See Also Send Feedback

The DX type exposes the following members.

Fields

 | Name | Description
Protected field | m_csRegistryName |
Public field | m_dlgdp_classname |
Protected field | m_FieldList |

See Also

DX Class
ElGUI Namespace


m_csRegistryName Field

[image]

4 of William Foster's Class Libraries
DX..::..m_csRegistryName Field
DX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.DX.m_csRegistryName"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected STRING m_csRegistryName
Visual Basic
Protected m_csRegistryName As STRING
Visual C++
protected:
STRING^ m_csRegistryName

See Also

DX Class
ElGUI Namespace


m_dlgdp_classname Field

[image]

4 of William Foster's Class Libraries
DX..::..m_dlgdp_classname Field
DX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.DX.m_dlgdp_classname"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_dlgdp_classname
Visual Basic
Public m_dlgdp_classname As String
Visual C++
public:
String^ m_dlgdp_classname

See Also

DX Class
ElGUI Namespace


m_FieldList Field

[image]

4 of William Foster's Class Libraries
DX..::..m_FieldList Field
DX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.DX.m_FieldList"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected DXEntry[] m_FieldList
Visual Basic
Protected m_FieldList As DXEntry()
Visual C++
protected:
array<DXEntry>^ m_FieldList

See Also

DX Class
ElGUI Namespace


DX Methods

[image] [image]

4 of William Foster's Class Libraries
DX Methods
DX Class See Also Send Feedback

The DX type exposes the following members.

Methods

 | Name | Description
Protected method | CreateMatrix |
Public method | CreateTable | Set up the (empty) DX in memory with fields representing values
 | DoubleToString |
Public method | Dup | Make a Seperate and detached, complete Duplicate Copy of this DX
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateResource |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMember |
Public method | GetMemberBool |
Public method | GetSet | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX.
Public method | GetSetCheck | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX.
Public method | GetSetText | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX.
Public method | GetSetUint | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateField | Check the DXEntry list for a resource control with the given name
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegistryLoad | Load up this DX from the default registry entries based apon the DXEntry list.
Public method | RegistrySave | Based apon the DXEntry list, Automatically Save out any important paramenters of this DX to the registry with unique naming
 | StringToDouble |
 | StringTouint |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | uintToString |

See Also

DX Class
ElGUI Namespace


CreateMatrix Method

[image]

4 of William Foster's Class Libraries
DX..::..CreateMatrix Method
DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DX.CreateMatrix(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ResourceEntity CreateMatrix(
    Size2dU size
)
Visual Basic
Protected Function CreateMatrix ( _
    size As Size2dU _
) As ResourceEntity
Visual C++
protected:
ResourceEntity^ CreateMatrix(
    Size2dU^ size
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElGUI.DX.CreateMatrix(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.CreateMatrix(El.Size2dU)"]

See Also

DX Class
ElGUI Namespace


CreateTable Method

[image]

4 of William Foster's Class Libraries
DX..::..CreateTable Method
DX Class See Also Send Feedback
Set up the (empty) DX in memory with fields representing values

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool CreateTable(
    DXEntry[] dxList
)
Visual Basic
Public Overridable Function CreateTable ( _
    dxList As DXEntry() _
) As Boolean
Visual C++
public:
virtual bool CreateTable(
    array<DXEntry>^ dxList
)

Parameters

dxList
Type: array< ElGUI..::..DXEntry >[]()[][]

[Missing <param name="dxList"/> documentation for "M:ElGUI.DX.CreateTable(ElGUI.DXEntry[])"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.CreateTable(ElGUI.DXEntry[])"]

See Also

DX Class
ElGUI Namespace


DoubleToString Method

[image]

4 of William Foster's Class Libraries
DX..::..DoubleToString Method
DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DX.DoubleToString(System.Double)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static STRING DoubleToString(
    double d
)
Visual Basic
Public Shared Function DoubleToString ( _
    d As Double _
) As STRING
Visual C++
public:
static STRING^ DoubleToString(
    double d
)

Parameters

d
Type: System..::..Double

[Missing <param name="d"/> documentation for "M:ElGUI.DX.DoubleToString(System.Double)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.DoubleToString(System.Double)"]

See Also

DX Class
ElGUI Namespace


Dup Method

[image]

4 of William Foster's Class Libraries
DX..::..Dup Method
DX Class See Also Send Feedback
Make a Seperate and detached, complete Duplicate Copy of this DX

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract DX Dup()
Visual Basic
Public MustOverride Function Dup As DX
Visual C++
public:
virtual DX^ Dup() abstract

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.Dup"]

See Also

DX Class
ElGUI Namespace


GenerateResource Method

[image]

4 of William Foster's Class Libraries
DX..::..GenerateResource Method
DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DX.GenerateResource"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceContainer GenerateResource()
Visual Basic
Public Function GenerateResource As ResourceContainer
Visual C++
public:
ResourceContainer^ GenerateResource()

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.GenerateResource"]

See Also

DX Class
ElGUI Namespace


GetMember Method

[image]

4 of William Foster's Class Libraries
DX..::..GetMember Method
DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DX.GetMember(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint GetMember(
    STRING sName
)
Visual Basic
Public Function GetMember ( _
    sName As STRING _
) As UInteger
Visual C++
public:
unsigned int GetMember(
    STRING^ sName
)

Parameters

sName
Type: STRING

[Missing <param name="sName"/> documentation for "M:ElGUI.DX.GetMember(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.GetMember(El.STRING)"]

See Also

DX Class
ElGUI Namespace


GetMemberBool Method

[image]

4 of William Foster's Class Libraries
DX..::..GetMemberBool Method
DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DX.GetMemberBool(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GetMemberBool(
    STRING sName
)
Visual Basic
Public Function GetMemberBool ( _
    sName As STRING _
) As Boolean
Visual C++
public:
bool GetMemberBool(
    STRING^ sName
)

Parameters

sName
Type: STRING

[Missing <param name="sName"/> documentation for "M:ElGUI.DX.GetMemberBool(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.GetMemberBool(El.STRING)"]

See Also

DX Class
ElGUI Namespace


GetSet Method

[image]

4 of William Foster's Class Libraries
DX..::..GetSet Method
DX Class See Also Send Feedback
Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX.

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void GetSet(
    STRING csName,
    ref double d,
    bool bSet
)
Visual Basic
Public Sub GetSet ( _
    csName As STRING, _
    ByRef d As Double, _
    bSet As Boolean _
)
Visual C++
public:
void GetSet(
    STRING^ csName,
    double% d,
    bool bSet
)

Parameters

csName
Type: STRING

[Missing <param name="csName"/> documentation for "M:ElGUI.DX.GetSet(El.STRING,System.Double@,System.Boolean)"]

d
Type: System..::..Double %

[Missing <param name="d"/> documentation for "M:ElGUI.DX.GetSet(El.STRING,System.Double@,System.Boolean)"]

bSet
Type: System..::..Boolean

[Missing <param name="bSet"/> documentation for "M:ElGUI.DX.GetSet(El.STRING,System.Double@,System.Boolean)"]

See Also

DX Class
ElGUI Namespace


GetSetCheck Method

[image]

4 of William Foster's Class Libraries
DX..::..GetSetCheck Method
DX Class See Also Send Feedback
Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX.

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void GetSetCheck(
    STRING csName,
    ref bool bCheck,
    bool bSet
)
Visual Basic
Public Sub GetSetCheck ( _
    csName As STRING, _
    ByRef bCheck As Boolean, _
    bSet As Boolean _
)
Visual C++
public:
void GetSetCheck(
    STRING^ csName,
    bool% bCheck,
    bool bSet
)

Parameters

csName
Type: STRING

[Missing <param name="csName"/> documentation for "M:ElGUI.DX.GetSetCheck(El.STRING,System.Boolean@,System.Boolean)"]

bCheck
Type: System..::..Boolean %

[Missing <param name="bCheck"/> documentation for "M:ElGUI.DX.GetSetCheck(El.STRING,System.Boolean@,System.Boolean)"]

bSet
Type: System..::..Boolean

[Missing <param name="bSet"/> documentation for "M:ElGUI.DX.GetSetCheck(El.STRING,System.Boolean@,System.Boolean)"]

See Also

DX Class
ElGUI Namespace


GetSetText Method

[image]

4 of William Foster's Class Libraries
DX..::..GetSetText Method
DX Class See Also Send Feedback
Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX.

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GetSetText(
    STRING csName,
    ref STRING csText,
    bool bSet
)
Visual Basic
Public Function GetSetText ( _
    csName As STRING, _
    ByRef csText As STRING, _
    bSet As Boolean _
) As Boolean
Visual C++
public:
bool GetSetText(
    STRING^ csName,
    STRING^% csText,
    bool bSet
)

Parameters

csName
Type: STRING

[Missing <param name="csName"/> documentation for "M:ElGUI.DX.GetSetText(El.STRING,El.STRING@,System.Boolean)"]

csText
Type: STRING%

[Missing <param name="csText"/> documentation for "M:ElGUI.DX.GetSetText(El.STRING,El.STRING@,System.Boolean)"]

bSet
Type: System..::..Boolean

[Missing <param name="bSet"/> documentation for "M:ElGUI.DX.GetSetText(El.STRING,El.STRING@,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.GetSetText(El.STRING,El.STRING@,System.Boolean)"]

See Also

DX Class
ElGUI Namespace


GetSetUint Method

[image]

4 of William Foster's Class Libraries
DX..::..GetSetUint Method
DX Class See Also Send Feedback
Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX.

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void GetSetUint(
    STRING csName,
    ref uint u,
    bool bSet
)
Visual Basic
Public Sub GetSetUint ( _
    csName As STRING, _
    ByRef u As UInteger, _
    bSet As Boolean _
)
Visual C++
public:
void GetSetUint(
    STRING^ csName,
    unsigned int% u,
    bool bSet
)

Parameters

csName
Type: STRING

[Missing <param name="csName"/> documentation for "M:ElGUI.DX.GetSetUint(El.STRING,System.UInt32@,System.Boolean)"]

u
Type: System..::..UInt32 %

[Missing <param name="u"/> documentation for "M:ElGUI.DX.GetSetUint(El.STRING,System.UInt32@,System.Boolean)"]

bSet
Type: System..::..Boolean

[Missing <param name="bSet"/> documentation for "M:ElGUI.DX.GetSetUint(El.STRING,System.UInt32@,System.Boolean)"]

See Also

DX Class
ElGUI Namespace


LocateField Method

[image]

4 of William Foster's Class Libraries
DX..::..LocateField Method
DX Class See Also Send Feedback
Check the DXEntry list for a resource control with the given name

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int LocateField(
    STRING csName
)
Visual Basic
Public Function LocateField ( _
    csName As STRING _
) As Integer
Visual C++
public:
int LocateField(
    STRING^ csName
)

Parameters

csName
Type: STRING

[Missing <param name="csName"/> documentation for "M:ElGUI.DX.LocateField(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.LocateField(El.STRING)"]

See Also

DX Class
ElGUI Namespace


RegistryLoad Method

[image]

4 of William Foster's Class Libraries
DX..::..RegistryLoad Method
DX Class See Also Send Feedback
Load up this DX from the default registry entries based apon the DXEntry list.

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RegistryLoad(
    string section,
    string subsection
)
Visual Basic
Public Function RegistryLoad ( _
    section As String, _
    subsection As String _
) As Boolean
Visual C++
public:
bool RegistryLoad(
    String^ section,
    String^ subsection
)

Parameters

section
Type: System..::..String

[Missing <param name="section"/> documentation for "M:ElGUI.DX.RegistryLoad(System.String,System.String)"]

subsection
Type: System..::..String

[Missing <param name="subsection"/> documentation for "M:ElGUI.DX.RegistryLoad(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.RegistryLoad(System.String,System.String)"]

See Also

DX Class
ElGUI Namespace


RegistrySave Method

[image]

4 of William Foster's Class Libraries
DX..::..RegistrySave Method
DX Class See Also Send Feedback
Based apon the DXEntry list, Automatically Save out any important paramenters of this DX to the registry with unique naming

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RegistrySave(
    string section,
    string subsection
)
Visual Basic
Public Function RegistrySave ( _
    section As String, _
    subsection As String _
) As Boolean
Visual C++
public:
bool RegistrySave(
    String^ section,
    String^ subsection
)

Parameters

section
Type: System..::..String

[Missing <param name="section"/> documentation for "M:ElGUI.DX.RegistrySave(System.String,System.String)"]

subsection
Type: System..::..String

[Missing <param name="subsection"/> documentation for "M:ElGUI.DX.RegistrySave(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.RegistrySave(System.String,System.String)"]

See Also

DX Class
ElGUI Namespace


StringToDouble Method

[image]

4 of William Foster's Class Libraries
DX..::..StringToDouble Method
DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DX.StringToDouble(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double StringToDouble(
    STRING p_s
)
Visual Basic
Public Shared Function StringToDouble ( _
    p_s As STRING _
) As Double
Visual C++
public:
static double StringToDouble(
    STRING^ p_s
)

Parameters

p_s
Type: STRING

[Missing <param name="p_s"/> documentation for "M:ElGUI.DX.StringToDouble(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.StringToDouble(El.STRING)"]

See Also

DX Class
ElGUI Namespace


StringTouint Method

[image]

4 of William Foster's Class Libraries
DX..::..StringTouint Method
DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DX.StringTouint(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static uint StringTouint(
    STRING p_s
)
Visual Basic
Public Shared Function StringTouint ( _
    p_s As STRING _
) As UInteger
Visual C++
public:
static unsigned int StringTouint(
    STRING^ p_s
)

Parameters

p_s
Type: STRING

[Missing <param name="p_s"/> documentation for "M:ElGUI.DX.StringTouint(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.StringTouint(El.STRING)"]

See Also

DX Class
ElGUI Namespace


uintToString Method

[image]

4 of William Foster's Class Libraries
DX..::..uintToString Method
DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.DX.uintToString(System.UInt32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static STRING uintToString(
    uint u
)
Visual Basic
Public Shared Function uintToString ( _
    u As UInteger _
) As STRING
Visual C++
public:
static STRING^ uintToString(
    unsigned int u
)

Parameters

u
Type: System..::..UInt32

[Missing <param name="u"/> documentation for "M:ElGUI.DX.uintToString(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.DX.uintToString(System.UInt32)"]

See Also

DX Class
ElGUI Namespace


DXEntry Structure

[image]

4 of William Foster's Class Libraries
DXEntry Structure
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.DXEntry"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct DXEntry
Visual Basic
Public Structure DXEntry
Visual C++
public value class DXEntry

See Also

DXEntry Members
ElGUI Namespace


DXEntry Members

[image] [image]

4 of William Foster's Class Libraries
DXEntry Members
DXEntry Structure Constructors Methods Fields See Also Send Feedback

The DXEntry type exposes the following members.

Constructors

 | Name | Description
Public method | DXEntry | Initializes a new instance of the DXEntry class

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | field |
Public field | field_name |
Public field | field_type |
Public field | use_field |

See Also

DXEntry Structure
ElGUI Namespace


DXEntry Constructor

[image]

4 of William Foster's Class Libraries
DXEntry Constructor
DXEntry Structure See Also Send Feedback
Initializes a new instance of the DXEntry class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DXEntry(
    string name,
    EDXFieldType type,
    string bindfield
)
Visual Basic
Public Sub New ( _
    name As String, _
    type As EDXFieldType, _
    bindfield As String _
)
Visual C++
public:
DXEntry(
    String^ name,
    EDXFieldType type,
    String^ bindfield
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ElGUI.DXEntry.#ctor(System.String,ElGUI.EDXFieldType,System.String)"]

type
Type: ElGUI..::..EDXFieldType

[Missing <param name="type"/> documentation for "M:ElGUI.DXEntry.#ctor(System.String,ElGUI.EDXFieldType,System.String)"]

bindfield
Type: System..::..String

[Missing <param name="bindfield"/> documentation for "M:ElGUI.DXEntry.#ctor(System.String,ElGUI.EDXFieldType,System.String)"]

See Also

DXEntry Structure
ElGUI Namespace


DXEntry Fields

[image] [image]

4 of William Foster's Class Libraries
DXEntry Fields
DXEntry Structure See Also Send Feedback

The DXEntry type exposes the following members.

Fields

 | Name | Description
Public field | field |
Public field | field_name |
Public field | field_type |
Public field | use_field |

See Also

DXEntry Structure
ElGUI Namespace


field Field

[image]

4 of William Foster's Class Libraries
DXEntry..::..field Field
DXEntry Structure See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.DXEntry.field"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object field
Visual Basic
Public field As Object
Visual C++
public:
Object^ field

See Also

DXEntry Structure
ElGUI Namespace


field_name Field

[image]

4 of William Foster's Class Libraries
DXEntry..::..field_name Field
DXEntry Structure See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.DXEntry.field_name"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string field_name
Visual Basic
Public field_name As String
Visual C++
public:
String^ field_name

See Also

DXEntry Structure
ElGUI Namespace


field_type Field

[image]

4 of William Foster's Class Libraries
DXEntry..::..field_type Field
DXEntry Structure See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.DXEntry.field_type"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public EDXFieldType field_type
Visual Basic
Public field_type As EDXFieldType
Visual C++
public:
EDXFieldType field_type

See Also

DXEntry Structure
ElGUI Namespace


use_field Field

[image]

4 of William Foster's Class Libraries
DXEntry..::..use_field Field
DXEntry Structure See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.DXEntry.use_field"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string use_field
Visual Basic
Public use_field As String
Visual C++
public:
String^ use_field

See Also

DXEntry Structure
ElGUI Namespace


DXEntry Methods

[image] [image]

4 of William Foster's Class Libraries
DXEntry Methods
DXEntry Structure See Also Send Feedback

The DXEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

DXEntry Structure
ElGUI Namespace


EBFC_GUIRES_ATTRIBUTE_KEY Enumeration

[image]

4 of William Foster's Class Libraries
EBFC_GUIRES_ATTRIBUTE_KEY Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.EBFC_GUIRES_ATTRIBUTE_KEY"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum EBFC_GUIRES_ATTRIBUTE_KEY
Visual Basic
Public Enumeration EBFC_GUIRES_ATTRIBUTE_KEY
Visual C++
public enum class EBFC_GUIRES_ATTRIBUTE_KEY

Members

Member name | Value | Description
HOTKEY | 0 |
ALIGN | 1 |
POSITION | 2 |
SHAPE | 3 |
SIZE | 4 |
RANGE | 5 |
SIZE_IN_CHARACTERS | 6 |
DEFAULT | 7 |
RADIO | 8 |
CHECKBOX | 9 |
ICON | 10 |
GROUP | 11 |
CHECKED | 12 |
NUMERIC | 13 |
INTEGER | 14 |
PASSWORD | 15 |
CURRENCY | 16 |
PERCENT | 17 |
DISTANCE | 18 |
BIND | 19 |

See Also

ElGUI Namespace


EBFC_GUIRES_HANDLER_KEY Enumeration

[image]

4 of William Foster's Class Libraries
EBFC_GUIRES_HANDLER_KEY Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.EBFC_GUIRES_HANDLER_KEY"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum EBFC_GUIRES_HANDLER_KEY
Visual Basic
Public Enumeration EBFC_GUIRES_HANDLER_KEY
Visual C++
public enum class EBFC_GUIRES_HANDLER_KEY

Members

Member name | Value | Description
MOUSEENTER | 0 |
MOUSELEAVE | 1 |
LEFTCLICK | 2 |
RIGHTCLICK | 3 |

See Also

ElGUI Namespace


EBFC_GUIRES_RESOURCE_KEY Enumeration

[image]

4 of William Foster's Class Libraries
EBFC_GUIRES_RESOURCE_KEY Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.EBFC_GUIRES_RESOURCE_KEY"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum EBFC_GUIRES_RESOURCE_KEY
Visual Basic
Public Enumeration EBFC_GUIRES_RESOURCE_KEY
Visual C++
public enum class EBFC_GUIRES_RESOURCE_KEY

Members

Member name | Value | Description
CONTAINER_KEY_WINDOW | 0 |
CONTAINER_KEY_CONTROL | 1 |
CONTAINER_KEY_TOOLBAR | 2 |
CONTAINER_KEY_MENU | 3 |
RESOURCE_KEY_SUBMENU | 4 |
RESOURCE_KEY_MENU_ENTRY | 5 |
RESOURCE_KEY_SEPERATOR | 6 |
CONTAINER_KEY_END | 7 |
RESOURCE_KEY_BUTTON | 8 |
RESOURCE_KEY_LABEL | 9 |
RESOURCE_KEY_TEXTBOX | 10 |
RESOURCE_KEY_CURSESBOX | 11 |
RESOURCE_KEY_LIST | 12 |
RESOURCE_KEY_LISTBOX | 13 |
RESOURCE_KEY_COMBOBOX | 14 |
RESOURCE_KEY_HORIZONTAL_SEPERATOR | 15 |
RESOURCE_KEY_VERTICAL_SEPERATOR | 16 |
RESOURCE_KEY_DROPLIST | 17 |
RESOURCE_KEY_SPACER | 18 |
RESOURCE_KEY_SWITCHER | 19 |
RESOURCE_KEY_MATRIX | 20 |
RESOURCE_KEY_SLIDER | 21 |
RESOURCE_KEY_BITMAP | 22 |

See Also

ElGUI Namespace


EBFC_GUIRES_RESOURCE_SHAPE_KEY Enumeration

[image]

4 of William Foster's Class Libraries
EBFC_GUIRES_RESOURCE_SHAPE_KEY Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.EBFC_GUIRES_RESOURCE_SHAPE_KEY"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum EBFC_GUIRES_RESOURCE_SHAPE_KEY
Visual Basic
Public Enumeration EBFC_GUIRES_RESOURCE_SHAPE_KEY
Visual C++
public enum class EBFC_GUIRES_RESOURCE_SHAPE_KEY

Members

Member name | Value | Description
RECTANGLE | 0 |
BITMAP | 1 |
OVAL | 2 |
POLYGON | 3 |

See Also

ElGUI Namespace


EditInterface Class

[image]

4 of William Foster's Class Libraries
EditInterface Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.EditInterface"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class EditInterface
Visual Basic
Public Class EditInterface
Visual C++
public ref class EditInterface

Inheritance Hierarchy

System..::..Object
ElGUI..::..EditInterface

See Also

EditInterface Members
ElGUI Namespace


EditInterface Members

[image] [image]

4 of William Foster's Class Libraries
EditInterface Members
EditInterface Class Constructors Methods See Also Send Feedback

The EditInterface type exposes the following members.

Constructors

 | Name | Description
Public method | EditInterface | Initializes a new instance of the EditInterface class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnKeyDown |
Protected method | OnKeyUp |
Public method | OnMessage |
Protected method | OnMouseDoubleClick |
Protected method | OnMouseDown |
Protected method | OnMouseEnter |
Protected method | OnMouseLeave |
Protected method | OnMouseMove |
Protected method | OnMouseUp |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EditInterface Class
ElGUI Namespace


EditInterface Constructor

[image]

4 of William Foster's Class Libraries
EditInterface Constructor
EditInterface Class See Also Send Feedback
Initializes a new instance of the EditInterface class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public EditInterface()
Visual Basic
Public Sub New
Visual C++
public:
EditInterface()

See Also

EditInterface Class
ElGUI Namespace


EditInterface Methods

[image] [image]

4 of William Foster's Class Libraries
EditInterface Methods
EditInterface Class See Also Send Feedback

The EditInterface type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnKeyDown |
Protected method | OnKeyUp |
Public method | OnMessage |
Protected method | OnMouseDoubleClick |
Protected method | OnMouseDown |
Protected method | OnMouseEnter |
Protected method | OnMouseLeave |
Protected method | OnMouseMove |
Protected method | OnMouseUp |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EditInterface Class
ElGUI Namespace


OnKeyDown Method

[image]

4 of William Foster's Class Libraries
EditInterface..::..OnKeyDown Method
EditInterface Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.EditInterface.OnKeyDown(System.Char)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual int OnKeyDown(
    char key
)
Visual Basic
Protected Overridable Function OnKeyDown ( _
    key As Char _
) As Integer
Visual C++
protected:
virtual int OnKeyDown(
    wchar_t key
)

Parameters

key
Type: System..::..Char

[Missing <param name="key"/> documentation for "M:ElGUI.EditInterface.OnKeyDown(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.EditInterface.OnKeyDown(System.Char)"]

See Also

EditInterface Class
ElGUI Namespace


OnKeyUp Method

[image]

4 of William Foster's Class Libraries
EditInterface..::..OnKeyUp Method
EditInterface Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.EditInterface.OnKeyUp(System.Char)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual int OnKeyUp(
    char key
)
Visual Basic
Protected Overridable Function OnKeyUp ( _
    key As Char _
) As Integer
Visual C++
protected:
virtual int OnKeyUp(
    wchar_t key
)

Parameters

key
Type: System..::..Char

[Missing <param name="key"/> documentation for "M:ElGUI.EditInterface.OnKeyUp(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.EditInterface.OnKeyUp(System.Char)"]

See Also

EditInterface Class
ElGUI Namespace


OnMessage Method

[image]

4 of William Foster's Class Libraries
EditInterface..::..OnMessage Method
EditInterface Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.EditInterface.OnMessage(ElGUI.Message)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int OnMessage(
    Message msg
)
Visual Basic
Public Function OnMessage ( _
    msg As Message _
) As Integer
Visual C++
public:
int OnMessage(
    Message^ msg
)

Parameters

msg
Type: ElGUI..::..Message

[Missing <param name="msg"/> documentation for "M:ElGUI.EditInterface.OnMessage(ElGUI.Message)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.EditInterface.OnMessage(ElGUI.Message)"]

See Also

EditInterface Class
ElGUI Namespace


OnMouseDoubleClick Method

[image]

4 of William Foster's Class Libraries
EditInterface..::..OnMouseDoubleClick Method
EditInterface Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.EditInterface.OnMouseDoubleClick(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual int OnMouseDoubleClick(
    Size2dU pt
)
Visual Basic
Protected Overridable Function OnMouseDoubleClick ( _
    pt As Size2dU _
) As Integer
Visual C++
protected:
virtual int OnMouseDoubleClick(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.EditInterface.OnMouseDoubleClick(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.EditInterface.OnMouseDoubleClick(El.Size2dU)"]

See Also

EditInterface Class
ElGUI Namespace


OnMouseDown Method

[image]

4 of William Foster's Class Libraries
EditInterface..::..OnMouseDown Method
EditInterface Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.EditInterface.OnMouseDown(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual int OnMouseDown(
    Size2dU pt
)
Visual Basic
Protected Overridable Function OnMouseDown ( _
    pt As Size2dU _
) As Integer
Visual C++
protected:
virtual int OnMouseDown(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.EditInterface.OnMouseDown(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.EditInterface.OnMouseDown(El.Size2dU)"]

See Also

EditInterface Class
ElGUI Namespace


OnMouseEnter Method

[image]

4 of William Foster's Class Libraries
EditInterface..::..OnMouseEnter Method
EditInterface Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.EditInterface.OnMouseEnter"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual int OnMouseEnter()
Visual Basic
Protected Overridable Function OnMouseEnter As Integer
Visual C++
protected:
virtual int OnMouseEnter()

Return Value

[Missing <returns> documentation for "M:ElGUI.EditInterface.OnMouseEnter"]

See Also

EditInterface Class
ElGUI Namespace


OnMouseLeave Method

[image]

4 of William Foster's Class Libraries
EditInterface..::..OnMouseLeave Method
EditInterface Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.EditInterface.OnMouseLeave"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual int OnMouseLeave()
Visual Basic
Protected Overridable Function OnMouseLeave As Integer
Visual C++
protected:
virtual int OnMouseLeave()

Return Value

[Missing <returns> documentation for "M:ElGUI.EditInterface.OnMouseLeave"]

See Also

EditInterface Class
ElGUI Namespace


OnMouseMove Method

[image]

4 of William Foster's Class Libraries
EditInterface..::..OnMouseMove Method
EditInterface Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.EditInterface.OnMouseMove(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual int OnMouseMove(
    Size2dU pt
)
Visual Basic
Protected Overridable Function OnMouseMove ( _
    pt As Size2dU _
) As Integer
Visual C++
protected:
virtual int OnMouseMove(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.EditInterface.OnMouseMove(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.EditInterface.OnMouseMove(El.Size2dU)"]

See Also

EditInterface Class
ElGUI Namespace


OnMouseUp Method

[image]

4 of William Foster's Class Libraries
EditInterface..::..OnMouseUp Method
EditInterface Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.EditInterface.OnMouseUp(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual int OnMouseUp(
    Size2dU pt
)
Visual Basic
Protected Overridable Function OnMouseUp ( _
    pt As Size2dU _
) As Integer
Visual C++
protected:
virtual int OnMouseUp(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.EditInterface.OnMouseUp(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.EditInterface.OnMouseUp(El.Size2dU)"]

See Also

EditInterface Class
ElGUI Namespace


EDXFieldType Enumeration

[image]

4 of William Foster's Class Libraries
EDXFieldType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.EDXFieldType"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum EDXFieldType
Visual Basic
Public Enumeration EDXFieldType
Visual C++
public enum class EDXFieldType

Members

Member name | Value | Description
DX_DISTANCE | 0 |
DX_BUTTONCHECK | 1 |
DX_LISTINDEX | 2 |
DX_INT | 3 |
DX_UINT | 4 |
DX_DOUBLE | 5 |
DX_STRING | 6 |
DX_FILENAME | 7 |
DX_REPEAT_ARRAY | 8 |

See Also

ElGUI Namespace


EKeyCode Enumeration

[image]

4 of William Foster's Class Libraries
EKeyCode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.EKeyCode"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum EKeyCode
Visual Basic
Public Enumeration EKeyCode
Visual C++
public enum class EKeyCode

Members

Member name | Value | Description
rarrow | 65363 |
larrow | 65361 |
uarrow | 65362 |
darrow | 65364 |
helpkey | 65386 |
pageup | 65365 |
pagedown | 65366 |
CRUBOUT | 65288 |
F1 | 65470 |
F2 | 65471 |
F3 | 65472 |
F4 | 65473 |
F5 | 65474 |
F6 | 65475 |
F7 | 65476 |
F8 | 65477 |
F9 | 65478 |
F10 | 65479 |

See Also

ElGUI Namespace


EKeys Enumeration

[image]

4 of William Foster's Class Libraries
EKeys Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.EKeys"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum EKeys
Visual Basic
Public Enumeration EKeys
Visual C++
public enum class EKeys

Members

Member name | Value | Description
START | 0 |
DEFINE | 1 |
END | 2 |
NAME | 3 |

See Also

ElGUI Namespace


GetcWindow Class

[image]

4 of William Foster's Class Libraries
GetcWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.GetcWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetcWindow : Window
Visual Basic
Public Class GetcWindow _
    Inherits Window
Visual C++
public ref class GetcWindow : public Window

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..GetcWindow

See Also

GetcWindow Members
ElGUI Namespace


GetcWindow Members

[image] [image]

4 of William Foster's Class Libraries
GetcWindow Members
GetcWindow Class Constructors Methods Fields Properties See Also Send Feedback

The GetcWindow type exposes the following members.

Constructors

 | Name | Description
Public method | GetcWindow | Initializes a new instance of the GetcWindow class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetC |
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Overrides Window..::..OnKeyDown(Char).)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

GetcWindow Class
ElGUI Namespace


GetcWindow Constructor

[image]

4 of William Foster's Class Libraries
GetcWindow Constructor
GetcWindow Class See Also Send Feedback
Initializes a new instance of the GetcWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetcWindow(
    GUI gui,
    Window parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    parent As Window _
)
Visual C++
public:
GetcWindow(
    GUI^ gui,
    Window^ parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.GetcWindow.#ctor(ElGUI.GUI,ElGUI.Window)"]

parent
Type: ElGUI..::..Window

[Missing <param name="parent"/> documentation for "M:ElGUI.GetcWindow.#ctor(ElGUI.GUI,ElGUI.Window)"]

See Also

GetcWindow Class
ElGUI Namespace


GetcWindow Fields

[image] [image]

4 of William Foster's Class Libraries
GetcWindow Fields
GetcWindow Class See Also Send Feedback

The GetcWindow type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

GetcWindow Class
ElGUI Namespace


GetcWindow Methods

[image] [image]

4 of William Foster's Class Libraries
GetcWindow Methods
GetcWindow Class See Also Send Feedback

The GetcWindow type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetC |
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Overrides Window..::..OnKeyDown(Char).)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

GetcWindow Class
ElGUI Namespace


GetC Method

[image]

4 of William Foster's Class Libraries
GetcWindow..::..GetC Method
GetcWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GetcWindow.GetC"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public char GetC()
Visual Basic
Public Function GetC As Char
Visual C++
public:
wchar_t GetC()

Return Value

[Missing <returns> documentation for "M:ElGUI.GetcWindow.GetC"]

See Also

GetcWindow Class
ElGUI Namespace


OnKeyDown Method

[image]

4 of William Foster's Class Libraries
GetcWindow..::..OnKeyDown Method
GetcWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GetcWindow.OnKeyDown(System.Char)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int OnKeyDown(
    char key
)
Visual Basic
Public Overrides Function OnKeyDown ( _
    key As Char _
) As Integer
Visual C++
public:
virtual int OnKeyDown(
    wchar_t key
) override

Parameters

key
Type: System..::..Char

[Missing <param name="key"/> documentation for "M:ElGUI.GetcWindow.OnKeyDown(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.GetcWindow.OnKeyDown(System.Char)"]

Implements

ITerminalWindow..::..OnKeyDown(Char)

See Also

GetcWindow Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
GetcWindow..::..SetColor Method
GetcWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

GetcWindow Class
GetcWindow Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
GetcWindow..::..SetDefaultCursor Method
GetcWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

GetcWindow Class
GetcWindow Members
ElGUI Namespace


GetcWindow Properties

[image] [image]

4 of William Foster's Class Libraries
GetcWindow Properties
GetcWindow Class See Also Send Feedback

The GetcWindow type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

GetcWindow Class
ElGUI Namespace


GetlineWindow Class

[image]

4 of William Foster's Class Libraries
GetlineWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.GetlineWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetlineWindow : Window
Visual Basic
Public Class GetlineWindow _
    Inherits Window
Visual C++
public ref class GetlineWindow : public Window

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..GetlineWindow

See Also

GetlineWindow Members
ElGUI Namespace


GetlineWindow Members

[image] [image]

4 of William Foster's Class Libraries
GetlineWindow Members
GetlineWindow Class Constructors Methods Fields Properties See Also Send Feedback

The GetlineWindow type exposes the following members.

Constructors

 | Name | Description
Public method | GetlineWindow | Initializes a new instance of the GetlineWindow class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | Getline |
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Overrides UILayerWindow..::..OnCreate()()()().)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Overrides Window..::..OnFocusIn()()()().)
Public method | OnFocusOut | (Overrides Window..::..OnFocusOut()()()().)
Public method | OnKeyDown | (Overrides Window..::..OnKeyDown(Char).)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

GetlineWindow Class
ElGUI Namespace


GetlineWindow Constructor

[image]

4 of William Foster's Class Libraries
GetlineWindow Constructor
GetlineWindow Class See Also Send Feedback
Initializes a new instance of the GetlineWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetlineWindow(
    GUI gui,
    Window parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    parent As Window _
)
Visual C++
public:
GetlineWindow(
    GUI^ gui,
    Window^ parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.GetlineWindow.#ctor(ElGUI.GUI,ElGUI.Window)"]

parent
Type: ElGUI..::..Window

[Missing <param name="parent"/> documentation for "M:ElGUI.GetlineWindow.#ctor(ElGUI.GUI,ElGUI.Window)"]

See Also

GetlineWindow Class
ElGUI Namespace


GetlineWindow Fields

[image] [image]

4 of William Foster's Class Libraries
GetlineWindow Fields
GetlineWindow Class See Also Send Feedback

The GetlineWindow type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

GetlineWindow Class
ElGUI Namespace


GetlineWindow Methods

[image] [image]

4 of William Foster's Class Libraries
GetlineWindow Methods
GetlineWindow Class See Also Send Feedback

The GetlineWindow type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | Getline |
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Overrides UILayerWindow..::..OnCreate()()()().)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Overrides Window..::..OnFocusIn()()()().)
Public method | OnFocusOut | (Overrides Window..::..OnFocusOut()()()().)
Public method | OnKeyDown | (Overrides Window..::..OnKeyDown(Char).)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

GetlineWindow Class
ElGUI Namespace


Getline Method

[image]

4 of William Foster's Class Libraries
GetlineWindow..::..Getline Method
GetlineWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GetlineWindow.Getline(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint Getline(
    STRING cs
)
Visual Basic
Public Function Getline ( _
    cs As STRING _
) As UInteger
Visual C++
public:
unsigned int Getline(
    STRING^ cs
)

Parameters

cs
Type: STRING

[Missing <param name="cs"/> documentation for "M:ElGUI.GetlineWindow.Getline(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.GetlineWindow.Getline(El.STRING)"]

See Also

GetlineWindow Class
ElGUI Namespace


OnCreate Method

[image]

4 of William Foster's Class Libraries
GetlineWindow..::..OnCreate Method
GetlineWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GetlineWindow.OnCreate"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool OnCreate()
Visual Basic
Protected Overrides Function OnCreate As Boolean
Visual C++
protected:
virtual bool OnCreate() override

Return Value

[Missing <returns> documentation for "M:ElGUI.GetlineWindow.OnCreate"]

See Also

GetlineWindow Class
ElGUI Namespace


OnFocusIn Method

[image]

4 of William Foster's Class Libraries
GetlineWindow..::..OnFocusIn Method
GetlineWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GetlineWindow.OnFocusIn"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int OnFocusIn()
Visual Basic
Public Overrides Function OnFocusIn As Integer
Visual C++
public:
virtual int OnFocusIn() override

Return Value

[Missing <returns> documentation for "M:ElGUI.GetlineWindow.OnFocusIn"]

Implements

ITerminalWindow..::..OnFocusIn()()()()

See Also

GetlineWindow Class
ElGUI Namespace


OnFocusOut Method

[image]

4 of William Foster's Class Libraries
GetlineWindow..::..OnFocusOut Method
GetlineWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GetlineWindow.OnFocusOut"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int OnFocusOut()
Visual Basic
Public Overrides Function OnFocusOut As Integer
Visual C++
public:
virtual int OnFocusOut() override

Return Value

[Missing <returns> documentation for "M:ElGUI.GetlineWindow.OnFocusOut"]

Implements

ITerminalWindow..::..OnFocusOut()()()()

See Also

GetlineWindow Class
ElGUI Namespace


OnKeyDown Method

[image]

4 of William Foster's Class Libraries
GetlineWindow..::..OnKeyDown Method
GetlineWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GetlineWindow.OnKeyDown(System.Char)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int OnKeyDown(
    char key
)
Visual Basic
Public Overrides Function OnKeyDown ( _
    key As Char _
) As Integer
Visual C++
public:
virtual int OnKeyDown(
    wchar_t key
) override

Parameters

key
Type: System..::..Char

[Missing <param name="key"/> documentation for "M:ElGUI.GetlineWindow.OnKeyDown(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.GetlineWindow.OnKeyDown(System.Char)"]

Implements

ITerminalWindow..::..OnKeyDown(Char)

See Also

GetlineWindow Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
GetlineWindow..::..SetColor Method
GetlineWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

GetlineWindow Class
GetlineWindow Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
GetlineWindow..::..SetDefaultCursor Method
GetlineWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

GetlineWindow Class
GetlineWindow Members
ElGUI Namespace


GetlineWindow Properties

[image] [image]

4 of William Foster's Class Libraries
GetlineWindow Properties
GetlineWindow Class See Also Send Feedback

The GetlineWindow type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

GetlineWindow Class
ElGUI Namespace


GUI Class

[image]

4 of William Foster's Class Libraries
GUI Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.GUI"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GUI
Visual Basic
Public Class GUI
Visual C++
public ref class GUI

Inheritance Hierarchy

System..::..Object
ElGUI..::..GUI

See Also

GUI Members
ElGUI Namespace


GUI Members

[image] [image]

4 of William Foster's Class Libraries
GUI Members
GUI Class Constructors Methods Fields See Also Send Feedback

The GUI type exposes the following members.

Constructors

 | Name | Description
Public method | GUI(Object) | Initializes a new instance of the GUI class
Public method | GUI(Object, ScriptResource) | Initializes a new instance of the GUI class

Methods

 | Name | Description
Public method | CreateMainWindow |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetApp |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMainWindow |
Public method | GetResourceStore |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadDialog |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewWindow |
Public method | RegisterResourceStore |
Public method | SetMainWindow |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnregisterResourceStore |

Fields

 | Name | Description
Public field | m_MainControl |

See Also

GUI Class
ElGUI Namespace


GUI Constructor

[image] [image]

4 of William Foster's Class Libraries
GUI Constructor
GUI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GUI(Object) | Initializes a new instance of the GUI class
Public method | GUI(Object, ScriptResource) | Initializes a new instance of the GUI class

See Also

GUI Class
GUI Members
ElGUI Namespace


GUI Constructor (Object)

[image]

4 of William Foster's Class Libraries
GUI Constructor (Object)
GUI Class See Also Send Feedback
Initializes a new instance of the GUI class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GUI(
    Object App
)
Visual Basic
Public Sub New ( _
    App As Object _
)
Visual C++
public:
GUI(
    Object^ App
)

Parameters

App
Type: System..::..Object

[Missing <param name="App"/> documentation for "M:ElGUI.GUI.#ctor(System.Object)"]

See Also

GUI Class
GUI Overload
ElGUI Namespace


GUI Constructor (Object, ScriptResource)

[image]

4 of William Foster's Class Libraries
GUI Constructor (Object, ScriptResource)
GUI Class See Also Send Feedback
Initializes a new instance of the GUI class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GUI(
    Object App,
    ScriptResource res
)
Visual Basic
Public Sub New ( _
    App As Object, _
    res As ScriptResource _
)
Visual C++
public:
GUI(
    Object^ App,
    ScriptResource^ res
)

Parameters

App
Type: System..::..Object

[Missing <param name="App"/> documentation for "M:ElGUI.GUI.#ctor(System.Object,ElGUI.ScriptResource)"]

res
Type: ElGUI..::..ScriptResource

[Missing <param name="res"/> documentation for "M:ElGUI.GUI.#ctor(System.Object,ElGUI.ScriptResource)"]

See Also

GUI Class
GUI Overload
ElGUI Namespace


GUI Fields

[image] [image]

4 of William Foster's Class Libraries
GUI Fields
GUI Class See Also Send Feedback

The GUI type exposes the following members.

Fields

 | Name | Description
Public field | m_MainControl |

See Also

GUI Class
ElGUI Namespace


m_MainControl Field

[image]

4 of William Foster's Class Libraries
GUI..::..m_MainControl Field
GUI Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.GUI.m_MainControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UserControl m_MainControl
Visual Basic
Public m_MainControl As UserControl
Visual C++
public:
UserControl^ m_MainControl

See Also

GUI Class
ElGUI Namespace


GUI Methods

[image] [image]

4 of William Foster's Class Libraries
GUI Methods
GUI Class See Also Send Feedback

The GUI type exposes the following members.

Methods

 | Name | Description
Public method | CreateMainWindow |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetApp |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMainWindow |
Public method | GetResourceStore |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadDialog |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewWindow |
Public method | RegisterResourceStore |
Public method | SetMainWindow |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnregisterResourceStore |

See Also

GUI Class
ElGUI Namespace


CreateMainWindow Method

[image]

4 of William Foster's Class Libraries
GUI..::..CreateMainWindow Method
GUI Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GUI.CreateMainWindow(El.Size2dU,El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CreateMainWindow(
    Size2dU size,
    STRING csTitle
)
Visual Basic
Public Function CreateMainWindow ( _
    size As Size2dU, _
    csTitle As STRING _
) As Boolean
Visual C++
public:
bool CreateMainWindow(
    Size2dU^ size,
    STRING^ csTitle
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElGUI.GUI.CreateMainWindow(El.Size2dU,El.STRING)"]

csTitle
Type: STRING

[Missing <param name="csTitle"/> documentation for "M:ElGUI.GUI.CreateMainWindow(El.Size2dU,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.GUI.CreateMainWindow(El.Size2dU,El.STRING)"]

See Also

GUI Class
ElGUI Namespace


GetApp Method

[image]

4 of William Foster's Class Libraries
GUI..::..GetApp Method
GUI Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GUI.GetApp"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object GetApp()
Visual Basic
Public Function GetApp As Object
Visual C++
public:
Object^ GetApp()

Return Value

[Missing <returns> documentation for "M:ElGUI.GUI.GetApp"]

See Also

GUI Class
ElGUI Namespace


GetMainWindow Method

[image]

4 of William Foster's Class Libraries
GUI..::..GetMainWindow Method
GUI Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GUI.GetMainWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MenuWindow GetMainWindow()
Visual Basic
Public Function GetMainWindow As MenuWindow
Visual C++
public:
MenuWindow^ GetMainWindow()

Return Value

[Missing <returns> documentation for "M:ElGUI.GUI.GetMainWindow"]

See Also

GUI Class
ElGUI Namespace


GetResourceStore Method

[image]

4 of William Foster's Class Libraries
GUI..::..GetResourceStore Method
GUI Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GUI.GetResourceStore(System.String)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceStore GetResourceStore(
    string resname
)
Visual Basic
Public Function GetResourceStore ( _
    resname As String _
) As ResourceStore
Visual C++
public:
ResourceStore^ GetResourceStore(
    String^ resname
)

Parameters

resname
Type: System..::..String

[Missing <param name="resname"/> documentation for "M:ElGUI.GUI.GetResourceStore(System.String)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.GUI.GetResourceStore(System.String)"]

See Also

GUI Class
ElGUI Namespace


LoadDialog Method

[image]

4 of William Foster's Class Libraries
GUI..::..LoadDialog Method
GUI Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GUI.LoadDialog(El.STRING,ElGUI.Window)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DialogWindow LoadDialog(
    STRING csIDName,
    Window Parent
)
Visual Basic
Public Function LoadDialog ( _
    csIDName As STRING, _
    Parent As Window _
) As DialogWindow
Visual C++
public:
DialogWindow^ LoadDialog(
    STRING^ csIDName,
    Window^ Parent
)

Parameters

csIDName
Type: STRING

[Missing <param name="csIDName"/> documentation for "M:ElGUI.GUI.LoadDialog(El.STRING,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.GUI.LoadDialog(El.STRING,ElGUI.Window)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.GUI.LoadDialog(El.STRING,ElGUI.Window)"]

See Also

GUI Class
ElGUI Namespace


NewWindow Method

[image]

4 of William Foster's Class Libraries
GUI..::..NewWindow Method
GUI Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GUI.NewWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Window NewWindow()
Visual Basic
Public Function NewWindow As Window
Visual C++
public:
Window^ NewWindow()

Return Value

[Missing <returns> documentation for "M:ElGUI.GUI.NewWindow"]

See Also

GUI Class
ElGUI Namespace


RegisterResourceStore Method

[image]

4 of William Foster's Class Libraries
GUI..::..RegisterResourceStore Method
GUI Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GUI.RegisterResourceStore(ElGUI.ResourceStore)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RegisterResourceStore(
    ResourceStore ResourceStore
)
Visual Basic
Public Function RegisterResourceStore ( _
    ResourceStore As ResourceStore _
) As Boolean
Visual C++
public:
bool RegisterResourceStore(
    ResourceStore^ ResourceStore
)

Parameters

ResourceStore
Type: ElGUI..::..ResourceStore

[Missing <param name="ResourceStore"/> documentation for "M:ElGUI.GUI.RegisterResourceStore(ElGUI.ResourceStore)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.GUI.RegisterResourceStore(ElGUI.ResourceStore)"]

See Also

GUI Class
ElGUI Namespace


SetMainWindow Method

[image]

4 of William Foster's Class Libraries
GUI..::..SetMainWindow Method
GUI Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GUI.SetMainWindow(ElGUI.MenuWindow,System.String)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetMainWindow(
    MenuWindow MainWindow,
    string csMenuName
)
Visual Basic
Public Function SetMainWindow ( _
    MainWindow As MenuWindow, _
    csMenuName As String _
) As Boolean
Visual C++
public:
bool SetMainWindow(
    MenuWindow^ MainWindow,
    String^ csMenuName
)

Parameters

MainWindow
Type: ElGUI..::..MenuWindow

[Missing <param name="MainWindow"/> documentation for "M:ElGUI.GUI.SetMainWindow(ElGUI.MenuWindow,System.String)"]

csMenuName
Type: System..::..String

[Missing <param name="csMenuName"/> documentation for "M:ElGUI.GUI.SetMainWindow(ElGUI.MenuWindow,System.String)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.GUI.SetMainWindow(ElGUI.MenuWindow,System.String)"]

See Also

GUI Class
ElGUI Namespace


UnregisterResourceStore Method

[image]

4 of William Foster's Class Libraries
GUI..::..UnregisterResourceStore Method
GUI Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.GUI.UnregisterResourceStore(ElGUI.ResourceStore)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UnregisterResourceStore(
    ResourceStore ResourceStore
)
Visual Basic
Public Function UnregisterResourceStore ( _
    ResourceStore As ResourceStore _
) As Boolean
Visual C++
public:
bool UnregisterResourceStore(
    ResourceStore^ ResourceStore
)

Parameters

ResourceStore
Type: ElGUI..::..ResourceStore

[Missing <param name="ResourceStore"/> documentation for "M:ElGUI.GUI.UnregisterResourceStore(ElGUI.ResourceStore)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.GUI.UnregisterResourceStore(ElGUI.ResourceStore)"]

See Also

GUI Class
ElGUI Namespace


ITerminalWindow Interface

[image]

4 of William Foster's Class Libraries
ITerminalWindow Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ITerminalWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface ITerminalWindow
Visual Basic
Public Interface ITerminalWindow
Visual C++
public interface class ITerminalWindow

See Also

ITerminalWindow Members
ElGUI Namespace


ITerminalWindow Members

[image] [image]

4 of William Foster's Class Libraries
ITerminalWindow Members
ITerminalWindow Interface Methods See Also Send Feedback

The ITerminalWindow type exposes the following members.

Methods

 | Name | Description
Public method | OnFocusIn |
Public method | OnFocusOut |
Public method | OnKeyDown |
Public method | OnKeyUp |
Public method | OnMessage |
Public method | OnMouseDoubleClick |
Public method | OnMouseDown |
Public method | OnMouseEnter |
Public method | OnMouseLeave |
Public method | OnMouseMove |
Public method | OnMouseUp |

See Also

ITerminalWindow Interface
ElGUI Namespace


ITerminalWindow Methods

[image] [image]

4 of William Foster's Class Libraries
ITerminalWindow Methods
ITerminalWindow Interface See Also Send Feedback

The ITerminalWindow type exposes the following members.

Methods

 | Name | Description
Public method | OnFocusIn |
Public method | OnFocusOut |
Public method | OnKeyDown |
Public method | OnKeyUp |
Public method | OnMessage |
Public method | OnMouseDoubleClick |
Public method | OnMouseDown |
Public method | OnMouseEnter |
Public method | OnMouseLeave |
Public method | OnMouseMove |
Public method | OnMouseUp |

See Also

ITerminalWindow Interface
ElGUI Namespace


OnFocusIn Method

[image]

4 of William Foster's Class Libraries
ITerminalWindow..::..OnFocusIn Method
ITerminalWindow Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ITerminalWindow.OnFocusIn"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int OnFocusIn()
Visual Basic
Function OnFocusIn As Integer
Visual C++
int OnFocusIn()

Return Value

[Missing <returns> documentation for "M:ElGUI.ITerminalWindow.OnFocusIn"]

See Also

ITerminalWindow Interface
ElGUI Namespace


OnFocusOut Method

[image]

4 of William Foster's Class Libraries
ITerminalWindow..::..OnFocusOut Method
ITerminalWindow Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ITerminalWindow.OnFocusOut"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int OnFocusOut()
Visual Basic
Function OnFocusOut As Integer
Visual C++
int OnFocusOut()

Return Value

[Missing <returns> documentation for "M:ElGUI.ITerminalWindow.OnFocusOut"]

See Also

ITerminalWindow Interface
ElGUI Namespace


OnKeyDown Method

[image]

4 of William Foster's Class Libraries
ITerminalWindow..::..OnKeyDown Method
ITerminalWindow Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ITerminalWindow.OnKeyDown(System.Char)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int OnKeyDown(
    char key
)
Visual Basic
Function OnKeyDown ( _
    key As Char _
) As Integer
Visual C++
int OnKeyDown(
    wchar_t key
)

Parameters

key
Type: System..::..Char

[Missing <param name="key"/> documentation for "M:ElGUI.ITerminalWindow.OnKeyDown(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ITerminalWindow.OnKeyDown(System.Char)"]

See Also

ITerminalWindow Interface
ElGUI Namespace


OnKeyUp Method

[image]

4 of William Foster's Class Libraries
ITerminalWindow..::..OnKeyUp Method
ITerminalWindow Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ITerminalWindow.OnKeyUp(System.Char)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int OnKeyUp(
    char key
)
Visual Basic
Function OnKeyUp ( _
    key As Char _
) As Integer
Visual C++
int OnKeyUp(
    wchar_t key
)

Parameters

key
Type: System..::..Char

[Missing <param name="key"/> documentation for "M:ElGUI.ITerminalWindow.OnKeyUp(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ITerminalWindow.OnKeyUp(System.Char)"]

See Also

ITerminalWindow Interface
ElGUI Namespace


OnMessage Method

[image]

4 of William Foster's Class Libraries
ITerminalWindow..::..OnMessage Method
ITerminalWindow Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ITerminalWindow.OnMessage(ElGUI.Message)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int OnMessage(
    Message msg
)
Visual Basic
Function OnMessage ( _
    msg As Message _
) As Integer
Visual C++
int OnMessage(
    Message^ msg
)

Parameters

msg
Type: ElGUI..::..Message

[Missing <param name="msg"/> documentation for "M:ElGUI.ITerminalWindow.OnMessage(ElGUI.Message)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ITerminalWindow.OnMessage(ElGUI.Message)"]

See Also

ITerminalWindow Interface
ElGUI Namespace


OnMouseDoubleClick Method

[image]

4 of William Foster's Class Libraries
ITerminalWindow..::..OnMouseDoubleClick Method
ITerminalWindow Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ITerminalWindow.OnMouseDoubleClick(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int OnMouseDoubleClick(
    Size2dU pt
)
Visual Basic
Function OnMouseDoubleClick ( _
    pt As Size2dU _
) As Integer
Visual C++
int OnMouseDoubleClick(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.ITerminalWindow.OnMouseDoubleClick(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ITerminalWindow.OnMouseDoubleClick(El.Size2dU)"]

See Also

ITerminalWindow Interface
ElGUI Namespace


OnMouseDown Method

[image]

4 of William Foster's Class Libraries
ITerminalWindow..::..OnMouseDown Method
ITerminalWindow Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ITerminalWindow.OnMouseDown(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int OnMouseDown(
    Size2dU pt
)
Visual Basic
Function OnMouseDown ( _
    pt As Size2dU _
) As Integer
Visual C++
int OnMouseDown(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.ITerminalWindow.OnMouseDown(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ITerminalWindow.OnMouseDown(El.Size2dU)"]

See Also

ITerminalWindow Interface
ElGUI Namespace


OnMouseEnter Method

[image]

4 of William Foster's Class Libraries
ITerminalWindow..::..OnMouseEnter Method
ITerminalWindow Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ITerminalWindow.OnMouseEnter"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int OnMouseEnter()
Visual Basic
Function OnMouseEnter As Integer
Visual C++
int OnMouseEnter()

Return Value

[Missing <returns> documentation for "M:ElGUI.ITerminalWindow.OnMouseEnter"]

See Also

ITerminalWindow Interface
ElGUI Namespace


OnMouseLeave Method

[image]

4 of William Foster's Class Libraries
ITerminalWindow..::..OnMouseLeave Method
ITerminalWindow Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ITerminalWindow.OnMouseLeave"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int OnMouseLeave()
Visual Basic
Function OnMouseLeave As Integer
Visual C++
int OnMouseLeave()

Return Value

[Missing <returns> documentation for "M:ElGUI.ITerminalWindow.OnMouseLeave"]

See Also

ITerminalWindow Interface
ElGUI Namespace


OnMouseMove Method

[image]

4 of William Foster's Class Libraries
ITerminalWindow..::..OnMouseMove Method
ITerminalWindow Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ITerminalWindow.OnMouseMove(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int OnMouseMove(
    Size2dU pt
)
Visual Basic
Function OnMouseMove ( _
    pt As Size2dU _
) As Integer
Visual C++
int OnMouseMove(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.ITerminalWindow.OnMouseMove(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ITerminalWindow.OnMouseMove(El.Size2dU)"]

See Also

ITerminalWindow Interface
ElGUI Namespace


OnMouseUp Method

[image]

4 of William Foster's Class Libraries
ITerminalWindow..::..OnMouseUp Method
ITerminalWindow Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ITerminalWindow.OnMouseUp(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int OnMouseUp(
    Size2dU pt
)
Visual Basic
Function OnMouseUp ( _
    pt As Size2dU _
) As Integer
Visual C++
int OnMouseUp(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.ITerminalWindow.OnMouseUp(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ITerminalWindow.OnMouseUp(El.Size2dU)"]

See Also

ITerminalWindow Interface
ElGUI Namespace


Label Class

[image]

4 of William Foster's Class Libraries
Label Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Label"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Label : Resource_Control
Visual Basic
Public Class Label _
    Inherits Resource_Control
Visual C++
public ref class Label : public Resource_Control

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..Resource_Control
ElGUI..::..Label

See Also

Label Members
ElGUI Namespace


Label Members

[image] [image]

4 of William Foster's Class Libraries
Label Members
Label Class Constructors Methods Fields Properties See Also Send Feedback

The Label type exposes the following members.

Constructors

 | Name | Description
Public method | Label | Initializes a new instance of the Label class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

Label Class
ElGUI Namespace


Label Constructor

[image]

4 of William Foster's Class Libraries
Label Constructor
Label Class See Also Send Feedback
Initializes a new instance of the Label class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Label(
    GUI gui,
    Window Parent,
    STRING csText,
    Resource_ID resourceID
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    Parent As Window, _
    csText As STRING, _
    resourceID As Resource_ID _
)
Visual C++
public:
Label(
    GUI^ gui,
    Window^ Parent,
    STRING^ csText,
    Resource_ID resourceID
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.Label.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.Label.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID)"]

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.Label.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.Label.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID)"]

See Also

Label Class
ElGUI Namespace


Label Fields

[image] [image]

4 of William Foster's Class Libraries
Label Fields
Label Class See Also Send Feedback

The Label type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

Label Class
ElGUI Namespace


Label Methods

[image] [image]

4 of William Foster's Class Libraries
Label Methods
Label Class See Also Send Feedback

The Label type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

Label Class
ElGUI Namespace


GetText Method

[image] [image]

4 of William Foster's Class Libraries
Label..::..GetText Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)

See Also

Label Class
Label Members
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
Label..::..SetColor Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

Label Class
Label Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
Label..::..SetDefaultCursor Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

Label Class
Label Members
ElGUI Namespace


Label Properties

[image] [image]

4 of William Foster's Class Libraries
Label Properties
Label Class See Also Send Feedback

The Label type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

Label Class
ElGUI Namespace


ListBox Class

[image]

4 of William Foster's Class Libraries
ListBox Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ListBox"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ListBox : ListControl
Visual Basic
Public Class ListBox _
    Inherits ListControl
Visual C++
public ref class ListBox : public ListControl

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..Resource_Control
ElGUI..::..Data_Resource_Control
ElGUI..::..TextData_Resource_Control
ElGUI..::..ListControl
ElGUI..::..ListBox

See Also

ListBox Members
ElGUI Namespace


ListBox Members

[image] [image]

4 of William Foster's Class Libraries
ListBox Members
ListBox Class Constructors Methods Fields Properties See Also Send Feedback

The ListBox type exposes the following members.

Constructors

 | Name | Description
Public method | ListBox | Initializes a new instance of the ListBox class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendItem | (Overrides ListControl..::..AppendItem(STRING).)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Public method | Empty | (Overrides ListControl..::..Empty()()()().)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SelectItem | (Overrides ListControl..::..SelectItem(Int32).)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetNumVisible |
Public method | SetText | (Inherited from ListControl.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ListBox Class
ElGUI Namespace


ListBox Constructor

[image]

4 of William Foster's Class Libraries
ListBox Constructor
ListBox Class See Also Send Feedback
Initializes a new instance of the ListBox class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ListBox(
    GUI gui,
    Window Parent,
    Resource_ID resourceID
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    Parent As Window, _
    resourceID As Resource_ID _
)
Visual C++
public:
ListBox(
    GUI^ gui,
    Window^ Parent,
    Resource_ID resourceID
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.ListBox.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.Resource_ID)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.ListBox.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.Resource_ID)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.ListBox.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.Resource_ID)"]

See Also

ListBox Class
ElGUI Namespace


ListBox Fields

[image] [image]

4 of William Foster's Class Libraries
ListBox Fields
ListBox Class See Also Send Feedback

The ListBox type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

ListBox Class
ElGUI Namespace


ListBox Methods

[image] [image]

4 of William Foster's Class Libraries
ListBox Methods
ListBox Class See Also Send Feedback

The ListBox type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendItem | (Overrides ListControl..::..AppendItem(STRING).)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Public method | Empty | (Overrides ListControl..::..Empty()()()().)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SelectItem | (Overrides ListControl..::..SelectItem(Int32).)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetNumVisible |
Public method | SetText | (Inherited from ListControl.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

ListBox Class
ElGUI Namespace


AppendItem Method

[image]

4 of William Foster's Class Libraries
ListBox..::..AppendItem Method
ListBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ListBox.AppendItem(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void AppendItem(
    STRING csItem
)
Visual Basic
Public Overrides Sub AppendItem ( _
    csItem As STRING _
)
Visual C++
public:
virtual void AppendItem(
    STRING^ csItem
) override

Parameters

csItem
Type: STRING

[Missing <param name="csItem"/> documentation for "M:ElGUI.ListBox.AppendItem(El.STRING)"]

See Also

ListBox Class
ElGUI Namespace


Empty Method

[image]

4 of William Foster's Class Libraries
ListBox..::..Empty Method
ListBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ListBox.Empty"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void Empty()
Visual Basic
Public Overrides Sub Empty
Visual C++
public:
virtual void Empty() override

See Also

ListBox Class
ElGUI Namespace


GetText Method

[image] [image]

4 of William Foster's Class Libraries
ListBox..::..GetText Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)

See Also

ListBox Class
ListBox Members
ElGUI Namespace


SelectItem Method

[image]

4 of William Foster's Class Libraries
ListBox..::..SelectItem Method
ListBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ListBox.SelectItem(System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void SelectItem(
    int itemno
)
Visual Basic
Public Overrides Sub SelectItem ( _
    itemno As Integer _
)
Visual C++
public:
virtual void SelectItem(
    int itemno
) override

Parameters

itemno
Type: System..::..Int32

[Missing <param name="itemno"/> documentation for "M:ElGUI.ListBox.SelectItem(System.Int32)"]

See Also

ListBox Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
ListBox..::..SetColor Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

ListBox Class
ListBox Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
ListBox..::..SetDefaultCursor Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

ListBox Class
ListBox Members
ElGUI Namespace


SetNumVisible Method

[image]

4 of William Foster's Class Libraries
ListBox..::..SetNumVisible Method
ListBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ListBox.SetNumVisible(System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetNumVisible(
    int n
)
Visual Basic
Public Sub SetNumVisible ( _
    n As Integer _
)
Visual C++
public:
void SetNumVisible(
    int n
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:ElGUI.ListBox.SetNumVisible(System.Int32)"]

See Also

ListBox Class
ElGUI Namespace


ListBox Properties

[image] [image]

4 of William Foster's Class Libraries
ListBox Properties
ListBox Class See Also Send Feedback

The ListBox type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ListBox Class
ElGUI Namespace


ListControl Class

[image]

4 of William Foster's Class Libraries
ListControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ListControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class ListControl : TextData_Resource_Control
Visual Basic
Public MustInherit Class ListControl _
    Inherits TextData_Resource_Control
Visual C++
public ref class ListControl abstract : public TextData_Resource_Control

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..Resource_Control
ElGUI..::..Data_Resource_Control
ElGUI..::..TextData_Resource_Control
ElGUI..::..ListControl
ElGUI..::..ComboBox
ElGUI..::..ListBox
ElGUI..::..ListRC

See Also

ListControl Members
ElGUI Namespace


ListControl Members

[image] [image]

4 of William Foster's Class Libraries
ListControl Members
ListControl Class Constructors Methods Fields Properties See Also Send Feedback

The ListControl type exposes the following members.

Constructors

 | Name | Description
Public method | ListControl | Initializes a new instance of the ListControl class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendItem |
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Public method | Empty |
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SelectItem |
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Overrides Resource_Control..::..SetText(String).)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ListControl Class
ElGUI Namespace


ListControl Constructor

[image]

4 of William Foster's Class Libraries
ListControl Constructor
ListControl Class See Also Send Feedback
Initializes a new instance of the ListControl class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ListControl(
    GUI gui,
    Window Parent,
    Resource_ID resourceID,
    WINDOW_TYPE eType
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    Parent As Window, _
    resourceID As Resource_ID, _
    eType As WINDOW_TYPE _
)
Visual C++
public:
ListControl(
    GUI^ gui,
    Window^ Parent,
    Resource_ID resourceID,
    WINDOW_TYPE eType
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.ListControl.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.ListControl.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.ListControl.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.ListControl.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

See Also

ListControl Class
ElGUI Namespace


ListControl Fields

[image] [image]

4 of William Foster's Class Libraries
ListControl Fields
ListControl Class See Also Send Feedback

The ListControl type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

ListControl Class
ElGUI Namespace


ListControl Methods

[image] [image]

4 of William Foster's Class Libraries
ListControl Methods
ListControl Class See Also Send Feedback

The ListControl type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendItem |
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Public method | Empty |
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SelectItem |
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Overrides Resource_Control..::..SetText(String).)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

ListControl Class
ElGUI Namespace


AppendItem Method

[image]

4 of William Foster's Class Libraries
ListControl..::..AppendItem Method
ListControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ListControl.AppendItem(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void AppendItem(
    STRING csItem
)
Visual Basic
Public MustOverride Sub AppendItem ( _
    csItem As STRING _
)
Visual C++
public:
virtual void AppendItem(
    STRING^ csItem
) abstract

Parameters

csItem
Type: STRING

[Missing <param name="csItem"/> documentation for "M:ElGUI.ListControl.AppendItem(El.STRING)"]

See Also

ListControl Class
ElGUI Namespace


Empty Method

[image]

4 of William Foster's Class Libraries
ListControl..::..Empty Method
ListControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ListControl.Empty"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void Empty()
Visual Basic
Public MustOverride Sub Empty
Visual C++
public:
virtual void Empty() abstract

See Also

ListControl Class
ElGUI Namespace


GetText Method

[image] [image]

4 of William Foster's Class Libraries
ListControl..::..GetText Method
ListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)

See Also

ListControl Class
ListControl Members
ElGUI Namespace


SelectItem Method

[image]

4 of William Foster's Class Libraries
ListControl..::..SelectItem Method
ListControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ListControl.SelectItem(System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void SelectItem(
    int itemno
)
Visual Basic
Public MustOverride Sub SelectItem ( _
    itemno As Integer _
)
Visual C++
public:
virtual void SelectItem(
    int itemno
) abstract

Parameters

itemno
Type: System..::..Int32

[Missing <param name="itemno"/> documentation for "M:ElGUI.ListControl.SelectItem(System.Int32)"]

See Also

ListControl Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
ListControl..::..SetColor Method
ListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

ListControl Class
ListControl Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
ListControl..::..SetDefaultCursor Method
ListControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

ListControl Class
ListControl Members
ElGUI Namespace


SetText Method

[image]

4 of William Foster's Class Libraries
ListControl..::..SetText Method
ListControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ListControl.SetText(System.String)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void SetText(
    string csText
)
Visual Basic
Public Overrides Sub SetText ( _
    csText As String _
)
Visual C++
public:
virtual void SetText(
    String^ csText
) override

Parameters

csText
Type: System..::..String

[Missing <param name="csText"/> documentation for "M:ElGUI.ListControl.SetText(System.String)"]

See Also

ListControl Class
ElGUI Namespace


ListControl Properties

[image] [image]

4 of William Foster's Class Libraries
ListControl Properties
ListControl Class See Also Send Feedback

The ListControl type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ListControl Class
ElGUI Namespace


ListRC Class

[image]

4 of William Foster's Class Libraries
ListRC Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ListRC"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ListRC : ListControl
Visual Basic
Public Class ListRC _
    Inherits ListControl
Visual C++
public ref class ListRC : public ListControl

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..Resource_Control
ElGUI..::..Data_Resource_Control
ElGUI..::..TextData_Resource_Control
ElGUI..::..ListControl
ElGUI..::..ListRC

See Also

ListRC Members
ElGUI Namespace


ListRC Members

[image] [image]

4 of William Foster's Class Libraries
ListRC Members
ListRC Class Constructors Methods Fields Properties See Also Send Feedback

The ListRC type exposes the following members.

Constructors

 | Name | Description
Public method | ListRC | Initializes a new instance of the ListRC class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendItem | (Overrides ListControl..::..AppendItem(STRING).)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Public method | Empty | (Overrides ListControl..::..Empty()()()().)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SelectItem | (Overrides ListControl..::..SelectItem(Int32).)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetNumCols |
Public method | SetNumVisible |
Public method | SetText | (Inherited from ListControl.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ListRC Class
ElGUI Namespace


ListRC Constructor

[image]

4 of William Foster's Class Libraries
ListRC Constructor
ListRC Class See Also Send Feedback
Initializes a new instance of the ListRC class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ListRC(
    GUI gui,
    Window Parent,
    Resource_ID resourceID
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    Parent As Window, _
    resourceID As Resource_ID _
)
Visual C++
public:
ListRC(
    GUI^ gui,
    Window^ Parent,
    Resource_ID resourceID
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.ListRC.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.Resource_ID)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.ListRC.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.Resource_ID)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.ListRC.#ctor(ElGUI.GUI,ElGUI.Window,ElGUI.Resource_ID)"]

See Also

ListRC Class
ElGUI Namespace


ListRC Fields

[image] [image]

4 of William Foster's Class Libraries
ListRC Fields
ListRC Class See Also Send Feedback

The ListRC type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

ListRC Class
ElGUI Namespace


ListRC Methods

[image] [image]

4 of William Foster's Class Libraries
ListRC Methods
ListRC Class See Also Send Feedback

The ListRC type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendItem | (Overrides ListControl..::..AppendItem(STRING).)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Public method | Empty | (Overrides ListControl..::..Empty()()()().)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SelectItem | (Overrides ListControl..::..SelectItem(Int32).)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetNumCols |
Public method | SetNumVisible |
Public method | SetText | (Inherited from ListControl.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

ListRC Class
ElGUI Namespace


AppendItem Method

[image]

4 of William Foster's Class Libraries
ListRC..::..AppendItem Method
ListRC Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ListRC.AppendItem(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void AppendItem(
    STRING csItem
)
Visual Basic
Public Overrides Sub AppendItem ( _
    csItem As STRING _
)
Visual C++
public:
virtual void AppendItem(
    STRING^ csItem
) override

Parameters

csItem
Type: STRING

[Missing <param name="csItem"/> documentation for "M:ElGUI.ListRC.AppendItem(El.STRING)"]

See Also

ListRC Class
ElGUI Namespace


Empty Method

[image]

4 of William Foster's Class Libraries
ListRC..::..Empty Method
ListRC Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ListRC.Empty"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void Empty()
Visual Basic
Public Overrides Sub Empty
Visual C++
public:
virtual void Empty() override

See Also

ListRC Class
ElGUI Namespace


GetText Method

[image] [image]

4 of William Foster's Class Libraries
ListRC..::..GetText Method
ListRC Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)

See Also

ListRC Class
ListRC Members
ElGUI Namespace


SelectItem Method

[image]

4 of William Foster's Class Libraries
ListRC..::..SelectItem Method
ListRC Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ListRC.SelectItem(System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void SelectItem(
    int itemno
)
Visual Basic
Public Overrides Sub SelectItem ( _
    itemno As Integer _
)
Visual C++
public:
virtual void SelectItem(
    int itemno
) override

Parameters

itemno
Type: System..::..Int32

[Missing <param name="itemno"/> documentation for "M:ElGUI.ListRC.SelectItem(System.Int32)"]

See Also

ListRC Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
ListRC..::..SetColor Method
ListRC Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

ListRC Class
ListRC Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
ListRC..::..SetDefaultCursor Method
ListRC Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

ListRC Class
ListRC Members
ElGUI Namespace


SetNumCols Method

[image]

4 of William Foster's Class Libraries
ListRC..::..SetNumCols Method
ListRC Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ListRC.SetNumCols(System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetNumCols(
    int n
)
Visual Basic
Public Sub SetNumCols ( _
    n As Integer _
)
Visual C++
public:
void SetNumCols(
    int n
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:ElGUI.ListRC.SetNumCols(System.Int32)"]

See Also

ListRC Class
ElGUI Namespace


SetNumVisible Method

[image]

4 of William Foster's Class Libraries
ListRC..::..SetNumVisible Method
ListRC Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ListRC.SetNumVisible(System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetNumVisible(
    int n
)
Visual Basic
Public Sub SetNumVisible ( _
    n As Integer _
)
Visual C++
public:
void SetNumVisible(
    int n
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:ElGUI.ListRC.SetNumVisible(System.Int32)"]

See Also

ListRC Class
ElGUI Namespace


ListRC Properties

[image] [image]

4 of William Foster's Class Libraries
ListRC Properties
ListRC Class See Also Send Feedback

The ListRC type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ListRC Class
ElGUI Namespace


MarchingAnts Class

[image]

4 of William Foster's Class Libraries
MarchingAnts Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.MarchingAnts"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class MarchingAnts : MarchingAnts_Rectangle
Visual Basic
Public Class MarchingAnts _
    Inherits MarchingAnts_Rectangle
Visual C++
public ref class MarchingAnts : public MarchingAnts_Rectangle

Inheritance Hierarchy

System..::..Object
ElGUI..::..MarchingAnts_Rectangle
ElGUI..::..MarchingAnts

See Also

MarchingAnts Members
ElGUI Namespace


MarchingAnts Members

[image] [image]

4 of William Foster's Class Libraries
MarchingAnts Members
MarchingAnts Class Constructors Methods Fields See Also Send Feedback

The MarchingAnts type exposes the following members.

Constructors

 | Name | Description
Public method | MarchingAnts | Initializes a new instance of the MarchingAnts class

Methods

 | Name | Description
Public method | Dispose | (Inherited from MarchingAnts_Rectangle.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | (Overrides MarchingAnts_Rectangle..::..Erase()()()().)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindOutline | Given an Alpha channel, define m_outline: another alpha with just the edges set to various values from 1 to MAX_ANT
Protected method | ForceRedraw | (Inherited from MarchingAnts_Rectangle.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | March | (Overrides MarchingAnts_Rectangle..::..March()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | (Overrides MarchingAnts_Rectangle..::..Move(Size2dU).)
Public method | Pause | (Inherited from MarchingAnts_Rectangle.)
Public method | Resume | (Inherited from MarchingAnts_Rectangle.)
Public method | Set_Rectangle | (Inherited from MarchingAnts_Rectangle.)
Protected method | SetupTimer | (Inherited from MarchingAnts_Rectangle.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_Wnd | (Inherited from MarchingAnts_Rectangle.)

See Also

MarchingAnts Class
ElGUI Namespace


MarchingAnts Constructor

[image]

4 of William Foster's Class Libraries
MarchingAnts Constructor
MarchingAnts Class See Also Send Feedback
Initializes a new instance of the MarchingAnts class

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public MarchingAnts(
    ImageWindow Wnd,
    Bitmap_Alpha Alpha
)
Visual Basic
Public Sub New ( _
    Wnd As ImageWindow, _
    Alpha As Bitmap_Alpha _
)
Visual C++
public:
MarchingAnts(
    ImageWindow^ Wnd,
    Bitmap_Alpha^ Alpha
)

Parameters

Wnd
Type: ElImage..::..ImageWindow

[Missing <param name="Wnd"/> documentation for "M:ElGUI.MarchingAnts.#ctor(ElImage.ImageWindow,ElImage.Bitmap_Alpha)"]

Alpha
Type: ElImage..::..Bitmap_Alpha

[Missing <param name="Alpha"/> documentation for "M:ElGUI.MarchingAnts.#ctor(ElImage.ImageWindow,ElImage.Bitmap_Alpha)"]

See Also

MarchingAnts Class
ElGUI Namespace


MarchingAnts Fields

[image] [image]

4 of William Foster's Class Libraries
MarchingAnts Fields
MarchingAnts Class See Also Send Feedback

The MarchingAnts type exposes the following members.

Fields

 | Name | Description
Protected field | m_Wnd | (Inherited from MarchingAnts_Rectangle.)

See Also

MarchingAnts Class
ElGUI Namespace


MarchingAnts Methods

[image] [image]

4 of William Foster's Class Libraries
MarchingAnts Methods
MarchingAnts Class See Also Send Feedback

The MarchingAnts type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from MarchingAnts_Rectangle.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | (Overrides MarchingAnts_Rectangle..::..Erase()()()().)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindOutline | Given an Alpha channel, define m_outline: another alpha with just the edges set to various values from 1 to MAX_ANT
Protected method | ForceRedraw | (Inherited from MarchingAnts_Rectangle.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | March | (Overrides MarchingAnts_Rectangle..::..March()()()().)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | (Overrides MarchingAnts_Rectangle..::..Move(Size2dU).)
Public method | Pause | (Inherited from MarchingAnts_Rectangle.)
Public method | Resume | (Inherited from MarchingAnts_Rectangle.)
Public method | Set_Rectangle | (Inherited from MarchingAnts_Rectangle.)
Protected method | SetupTimer | (Inherited from MarchingAnts_Rectangle.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MarchingAnts Class
ElGUI Namespace


Erase Method

[image]

4 of William Foster's Class Libraries
MarchingAnts..::..Erase Method
MarchingAnts Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MarchingAnts.Erase"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override void Erase()
Visual Basic
Public Overrides Sub Erase
Visual C++
public:
virtual void Erase() override

See Also

MarchingAnts Class
ElGUI Namespace


FindOutline Method

[image]

4 of William Foster's Class Libraries
MarchingAnts..::..FindOutline Method
MarchingAnts Class See Also Send Feedback
Given an Alpha channel, define m_outline: another alpha with just the edges set to various values from 1 to MAX_ANT

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected bool FindOutline(
    Bitmap_Alpha Alpha
)
Visual Basic
Protected Function FindOutline ( _
    Alpha As Bitmap_Alpha _
) As Boolean
Visual C++
protected:
bool FindOutline(
    Bitmap_Alpha^ Alpha
)

Parameters

Alpha
Type: ElImage..::..Bitmap_Alpha

[Missing <param name="Alpha"/> documentation for "M:ElGUI.MarchingAnts.FindOutline(ElImage.Bitmap_Alpha)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.MarchingAnts.FindOutline(ElImage.Bitmap_Alpha)"]

See Also

MarchingAnts Class
ElGUI Namespace


March Method

[image]

4 of William Foster's Class Libraries
MarchingAnts..::..March Method
MarchingAnts Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MarchingAnts.March"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override void March()
Visual Basic
Public Overrides Sub March
Visual C++
public:
virtual void March() override

See Also

MarchingAnts Class
ElGUI Namespace


Move Method

[image]

4 of William Foster's Class Libraries
MarchingAnts..::..Move Method
MarchingAnts Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MarchingAnts.Move(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override void Move(
    Size2dU offset
)
Visual Basic
Public Overrides Sub Move ( _
    offset As Size2dU _
)
Visual C++
public:
virtual void Move(
    Size2dU^ offset
) override

Parameters

offset
Type: Size2dU

[Missing <param name="offset"/> documentation for "M:ElGUI.MarchingAnts.Move(El.Size2dU)"]

See Also

MarchingAnts Class
ElGUI Namespace


MarchingAnts_Rectangle Class

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.MarchingAnts_Rectangle"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class MarchingAnts_Rectangle : IDisposable
Visual Basic
Public Class MarchingAnts_Rectangle _
    Implements IDisposable
Visual C++
public ref class MarchingAnts_Rectangle : IDisposable

Inheritance Hierarchy

System..::..Object
ElGUI..::..MarchingAnts_Rectangle
ElGUI..::..MarchingAnts

See Also

MarchingAnts_Rectangle Members
ElGUI Namespace


MarchingAnts_Rectangle Members

[image] [image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle Members
MarchingAnts_Rectangle Class Constructors Methods Fields See Also Send Feedback

The MarchingAnts_Rectangle type exposes the following members.

Constructors

 | Name | Description
Public method | MarchingAnts_Rectangle(ImageWindow) | Initializes a new instance of the MarchingAnts_Rectangle class
Public method | MarchingAnts_Rectangle(ImageWindow, Rect2dU) | Initializes a new instance of the MarchingAnts_Rectangle class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MarchingAnts_Rectangle
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | ForceRedraw |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | March |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move |
Public method | Pause |
Public method | Resume |
Public method | Set_Rectangle |
Protected method | SetupTimer |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
 | AntMap |
Protected field | m_Wnd |
 | MAX_ANT |

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


MarchingAnts_Rectangle Constructor

[image] [image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle Constructor
MarchingAnts_Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MarchingAnts_Rectangle(ImageWindow) | Initializes a new instance of the MarchingAnts_Rectangle class
Public method | MarchingAnts_Rectangle(ImageWindow, Rect2dU) | Initializes a new instance of the MarchingAnts_Rectangle class

See Also

MarchingAnts_Rectangle Class
MarchingAnts_Rectangle Members
ElGUI Namespace


MarchingAnts_Rectangle Constructor (ImageWindow)

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle Constructor (ImageWindow)
MarchingAnts_Rectangle Class See Also Send Feedback
Initializes a new instance of the MarchingAnts_Rectangle class

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public MarchingAnts_Rectangle(
    ImageWindow Wnd
)
Visual Basic
Public Sub New ( _
    Wnd As ImageWindow _
)
Visual C++
public:
MarchingAnts_Rectangle(
    ImageWindow^ Wnd
)

Parameters

Wnd
Type: ElImage..::..ImageWindow

[Missing <param name="Wnd"/> documentation for "M:ElGUI.MarchingAnts_Rectangle.#ctor(ElImage.ImageWindow)"]

See Also

MarchingAnts_Rectangle Class
MarchingAnts_Rectangle Overload
ElGUI Namespace


MarchingAnts_Rectangle Constructor (ImageWindow, )

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle Constructor (ImageWindow, )
MarchingAnts_Rectangle Class See Also Send Feedback
Initializes a new instance of the MarchingAnts_Rectangle class

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public MarchingAnts_Rectangle(
    ImageWindow Wnd,
    Rect2dU rect
)
Visual Basic
Public Sub New ( _
    Wnd As ImageWindow, _
    rect As Rect2dU _
)
Visual C++
public:
MarchingAnts_Rectangle(
    ImageWindow^ Wnd,
    Rect2dU^ rect
)

Parameters

Wnd
Type: ElImage..::..ImageWindow

[Missing <param name="Wnd"/> documentation for "M:ElGUI.MarchingAnts_Rectangle.#ctor(ElImage.ImageWindow,El.Rect2dU)"]

rect
Type: Rect2dU

[Missing <param name="rect"/> documentation for "M:ElGUI.MarchingAnts_Rectangle.#ctor(ElImage.ImageWindow,El.Rect2dU)"]

See Also

MarchingAnts_Rectangle Class
MarchingAnts_Rectangle Overload
ElGUI Namespace


MarchingAnts_Rectangle Fields

[image] [image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle Fields
MarchingAnts_Rectangle Class See Also Send Feedback

The MarchingAnts_Rectangle type exposes the following members.

Fields

 | Name | Description
 | AntMap |
Protected field | m_Wnd |
 | MAX_ANT |

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


AntMap Field

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle..::..AntMap Field
MarchingAnts_Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.MarchingAnts_Rectangle.AntMap"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected static byte[] AntMap
Visual Basic
Protected Shared AntMap As Byte()
Visual C++
protected:
static array<unsigned char>^ AntMap

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


m_Wnd Field

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle..::..m_Wnd Field
MarchingAnts_Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.MarchingAnts_Rectangle.m_Wnd"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected ImageWindow m_Wnd
Visual Basic
Protected m_Wnd As ImageWindow
Visual C++
protected:
ImageWindow^ m_Wnd

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


MAX_ANT Field

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle..::..MAX_ANT Field
MarchingAnts_Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.MarchingAnts_Rectangle.MAX_ANT"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected const byte MAX_ANT
Visual Basic
Protected Const MAX_ANT As Byte
Visual C++
protected:
literal unsigned char MAX_ANT

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


MarchingAnts_Rectangle Methods

[image] [image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle Methods
MarchingAnts_Rectangle Class See Also Send Feedback

The MarchingAnts_Rectangle type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | ForceRedraw |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | March |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move |
Public method | Pause |
Public method | Resume |
Public method | Set_Rectangle |
Protected method | SetupTimer |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


Dispose Method

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle..::..Dispose Method
MarchingAnts_Rectangle Class See Also Send Feedback
Releases all resources used by the MarchingAnts_Rectangle

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


Erase Method

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle..::..Erase Method
MarchingAnts_Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MarchingAnts_Rectangle.Erase"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual void Erase()
Visual Basic
Public Overridable Sub Erase
Visual C++
public:
virtual void Erase()

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


ForceRedraw Method

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle..::..ForceRedraw Method
MarchingAnts_Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MarchingAnts_Rectangle.ForceRedraw"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected virtual void ForceRedraw()
Visual Basic
Protected Overridable Sub ForceRedraw
Visual C++
protected:
virtual void ForceRedraw()

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


March Method

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle..::..March Method
MarchingAnts_Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MarchingAnts_Rectangle.March"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual void March()
Visual Basic
Public Overridable Sub March
Visual C++
public:
virtual void March()

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


Move Method

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle..::..Move Method
MarchingAnts_Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MarchingAnts_Rectangle.Move(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual void Move(
    Size2dU offset
)
Visual Basic
Public Overridable Sub Move ( _
    offset As Size2dU _
)
Visual C++
public:
virtual void Move(
    Size2dU^ offset
)

Parameters

offset
Type: Size2dU

[Missing <param name="offset"/> documentation for "M:ElGUI.MarchingAnts_Rectangle.Move(El.Size2dU)"]

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


Pause Method

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle..::..Pause Method
MarchingAnts_Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MarchingAnts_Rectangle.Pause"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Pause()
Visual Basic
Public Sub Pause
Visual C++
public:
void Pause()

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


Resume Method

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle..::..Resume Method
MarchingAnts_Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MarchingAnts_Rectangle.Resume"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Resume()
Visual Basic
Public Sub Resume
Visual C++
public:
void Resume()

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


Set_Rectangle Method

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle..::..Set_Rectangle Method
MarchingAnts_Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MarchingAnts_Rectangle.Set_Rectangle(El.Rect2dU)"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Set_Rectangle(
    Rect2dU rect
)
Visual Basic
Public Sub Set_Rectangle ( _
    rect As Rect2dU _
)
Visual C++
public:
void Set_Rectangle(
    Rect2dU^ rect
)

Parameters

rect
Type: Rect2dU

[Missing <param name="rect"/> documentation for "M:ElGUI.MarchingAnts_Rectangle.Set_Rectangle(El.Rect2dU)"]

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


SetupTimer Method

[image]

4 of William Foster's Class Libraries
MarchingAnts_Rectangle..::..SetupTimer Method
MarchingAnts_Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MarchingAnts_Rectangle.SetupTimer"]

Namespace: ElGUI
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected void SetupTimer()
Visual Basic
Protected Sub SetupTimer
Visual C++
protected:
void SetupTimer()

See Also

MarchingAnts_Rectangle Class
ElGUI Namespace


Menu Class

[image]

4 of William Foster's Class Libraries
Menu Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Menu"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Menu
Visual Basic
Public Class Menu
Visual C++
public ref class Menu

Inheritance Hierarchy

System..::..Object
ElGUI..::..Menu

See Also

Menu Members
ElGUI Namespace


Menu Members

[image] [image]

4 of William Foster's Class Libraries
Menu Members
Menu Class Constructors Methods See Also Send Feedback

The Menu type exposes the following members.

Constructors

 | Name | Description
Public method | Menu | Initializes a new instance of the Menu class

Methods

 | Name | Description
Public method | AddEntry |
Public method | EndSubmenu |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartSubmenu |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Menu Class
ElGUI Namespace


Menu Constructor

[image]

4 of William Foster's Class Libraries
Menu Constructor
Menu Class See Also Send Feedback
Initializes a new instance of the Menu class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Menu(
    MenuWindow win
)
Visual Basic
Public Sub New ( _
    win As MenuWindow _
)
Visual C++
public:
Menu(
    MenuWindow^ win
)

Parameters

win
Type: ElGUI..::..MenuWindow

[Missing <param name="win"/> documentation for "M:ElGUI.Menu.#ctor(ElGUI.MenuWindow)"]

See Also

Menu Class
ElGUI Namespace


Menu Methods

[image] [image]

4 of William Foster's Class Libraries
Menu Methods
Menu Class See Also Send Feedback

The Menu type exposes the following members.

Methods

 | Name | Description
Public method | AddEntry |
Public method | EndSubmenu |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartSubmenu |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Menu Class
ElGUI Namespace


AddEntry Method

[image]

4 of William Foster's Class Libraries
Menu..::..AddEntry Method
Menu Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Menu.AddEntry(El.STRING,ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AddEntry(
    STRING csText,
    Resource_ID id
)
Visual Basic
Public Function AddEntry ( _
    csText As STRING, _
    id As Resource_ID _
) As Boolean
Visual C++
public:
bool AddEntry(
    STRING^ csText,
    Resource_ID id
)

Parameters

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.Menu.AddEntry(El.STRING,ElGUI.Resource_ID)"]

id
Type: ElGUI..::..Resource_ID

[Missing <param name="id"/> documentation for "M:ElGUI.Menu.AddEntry(El.STRING,ElGUI.Resource_ID)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Menu.AddEntry(El.STRING,ElGUI.Resource_ID)"]

See Also

Menu Class
ElGUI Namespace


EndSubmenu Method

[image]

4 of William Foster's Class Libraries
Menu..::..EndSubmenu Method
Menu Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Menu.EndSubmenu"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void EndSubmenu()
Visual Basic
Public Sub EndSubmenu
Visual C++
public:
void EndSubmenu()

See Also

Menu Class
ElGUI Namespace


StartSubmenu Method

[image]

4 of William Foster's Class Libraries
Menu..::..StartSubmenu Method
Menu Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Menu.StartSubmenu(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool StartSubmenu(
    STRING csText
)
Visual Basic
Public Function StartSubmenu ( _
    csText As STRING _
) As Boolean
Visual C++
public:
bool StartSubmenu(
    STRING^ csText
)

Parameters

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.Menu.StartSubmenu(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Menu.StartSubmenu(El.STRING)"]

See Also

Menu Class
ElGUI Namespace


MenuEntry Class

[image]

4 of William Foster's Class Libraries
MenuEntry Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.MenuEntry"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MenuEntry : MenuItem
Visual Basic
Public Class MenuEntry _
    Inherits MenuItem
Visual C++
public ref class MenuEntry : public MenuItem

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls..::..HeaderedItemsControl
System.Windows.Controls..::..MenuItem
ElGUI..::..MenuEntry

See Also

MenuEntry Members
ElGUI Namespace


MenuEntry Members

[image] [image]

4 of William Foster's Class Libraries
MenuEntry Members
MenuEntry Class Constructors Methods Properties Events See Also Send Feedback

The MenuEntry type exposes the following members.

Constructors

 | Name | Description
Public method | MenuEntry | Initializes a new instance of the MenuEntry class

Methods

 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display a specified item. (Inherited from MenuItem.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from MenuItem.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is invoked. (Inherited from MenuItem.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Called when the template's tree is generated. (Inherited from MenuItem.)
Protected method | OnChecked | Called when the IsChecked property becomes true. (Inherited from MenuItem.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a MenuItem is clicked and raises a Click event. (Inherited from MenuItem.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate MenuItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from MenuItem.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Announces that the keyboard is focused on this element. (Inherited from MenuItem.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl.)
Protected method | OnHeaderStringFormatChanged | Occurs when the HeaderStringFormat property changes. (Inherited from HeaderedItemsControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedItemsControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedItemsControl.)
Protected method | OnInitialized | Called when the IsInitialized property is set to true and raises an Initialized event. (Inherited from MenuItem.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the focus is no longer on or within a MenuItem. (Inherited from MenuItem.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Called when the Items property changes. (Inherited from MenuItem.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from MenuItem.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Called whenever the mouse enters a MenuItem. (Inherited from MenuItem.)
Protected method | OnMouseLeave | Called whenever the mouse leaves a MenuItem. (Inherited from MenuItem.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed. (Inherited from MenuItem.)
Protected method | OnMouseLeftButtonUp | Called when the left mouse button is released. (Inherited from MenuItem.)
Protected method | OnMouseMove | Called when the mouse is moved over a menu item. (Inherited from MenuItem.)
Protected method | OnMouseRightButtonDown | Called when the right mouse button is pressed. (Inherited from MenuItem.)
Protected method | OnMouseRightButtonUp | Called when the right mouse button is released. (Inherited from MenuItem.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnSubmenuClosed | Called when the submenu of a MenuItem is closed. (Inherited from MenuItem.)
Protected method | OnSubmenuOpened | Called when the submenu of a MenuItem is opened. (Inherited from MenuItem.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnchecked | Called when the IsChecked property becomes false. (Inherited from MenuItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual MenuItem changes. (Inherited from MenuItem.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from MenuItem.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Used to determine whether to apply a style to the item container. (Inherited from MenuItem.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a HeaderedItemsControl object. (Inherited from HeaderedItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | Command | Gets or sets the command associated with the menu item. (Inherited from MenuItem.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property of a MenuItem. (Inherited from MenuItem.)
Public property | CommandTarget | Gets or sets the target element on which to raise the specified command. (Inherited from MenuItem.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets whether the control supports scrolling. (Inherited from MenuItem.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. (Inherited from HeaderedItemsControl.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Header | Gets or sets the item that labels the control. (Inherited from HeaderedItemsControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedItemsControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. (Inherited from HeaderedItemsControl.)
Public property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. (Inherited from HeaderedItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the icon that appears in a MenuItem. (Inherited from MenuItem.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputGestureText | Sets the text describing an input gesture that will call the command tied to the specified item. (Inherited from MenuItem.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCheckable | Gets a value that indicates whether a MenuItem can be checked. (Inherited from MenuItem.)
Public property | IsChecked | Gets or sets a value that indicates whether the MenuItem is checked. (Inherited from MenuItem.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that indicates whether the IsEnabled property is true for the current menu item. (Inherited from MenuItem.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHighlighted | Gets a value that indicates whether a MenuItem is highlighted. (Inherited from MenuItem.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a MenuItem is pressed. (Inherited from MenuItem.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsSubmenuOpen | Gets or sets a value that indicates whether the submenu of the MenuItem is open. (Inherited from MenuItem.)
Public property | IsSuspendingPopupAnimation | Gets whether a menu suspends animations on its Popup control. (Inherited from MenuItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the HeaderedItemsControl. (Inherited from HeaderedItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Role | Gets a value that indicates the role of a MenuItem. (Inherited from MenuItem.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | StaysOpenOnClick | Gets or sets a value that indicates that the submenu in which this MenuItem is located should not close when this item is clicked. (Inherited from MenuItem.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | Checked | Occurs when a menu item is checked. (Inherited from MenuItem.)
Public event | Click | Occurs when a MenuItem is clicked. (Inherited from MenuItem.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | SubmenuClosed | Occurs when the state of the IsSubmenuOpen property changes to false. (Inherited from MenuItem.)
Public event | SubmenuOpened | Occurs when the state of the IsSubmenuOpen property changes to true. (Inherited from MenuItem.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unchecked | Occurs when a MenuItem is unchecked. (Inherited from MenuItem.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

MenuEntry Class
ElGUI Namespace


MenuEntry Constructor

[image]

4 of William Foster's Class Libraries
MenuEntry Constructor
MenuEntry Class See Also Send Feedback
Initializes a new instance of the MenuEntry class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MenuEntry(
    MenuWindow target,
    STRING csText,
    Resource_ID id
)
Visual Basic
Public Sub New ( _
    target As MenuWindow, _
    csText As STRING, _
    id As Resource_ID _
)
Visual C++
public:
MenuEntry(
    MenuWindow^ target,
    STRING^ csText,
    Resource_ID id
)

Parameters

target
Type: ElGUI..::..MenuWindow

[Missing <param name="target"/> documentation for "M:ElGUI.MenuEntry.#ctor(ElGUI.MenuWindow,El.STRING,ElGUI.Resource_ID)"]

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.MenuEntry.#ctor(ElGUI.MenuWindow,El.STRING,ElGUI.Resource_ID)"]

id
Type: ElGUI..::..Resource_ID

[Missing <param name="id"/> documentation for "M:ElGUI.MenuEntry.#ctor(ElGUI.MenuWindow,El.STRING,ElGUI.Resource_ID)"]

See Also

MenuEntry Class
ElGUI Namespace


MenuEntry Methods

[image] [image]

4 of William Foster's Class Libraries
MenuEntry Methods
MenuEntry Class See Also Send Feedback

The MenuEntry type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display a specified item. (Inherited from MenuItem.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from MenuItem.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is invoked. (Inherited from MenuItem.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Called when the template's tree is generated. (Inherited from MenuItem.)
Protected method | OnChecked | Called when the IsChecked property becomes true. (Inherited from MenuItem.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a MenuItem is clicked and raises a Click event. (Inherited from MenuItem.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate MenuItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from MenuItem.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Announces that the keyboard is focused on this element. (Inherited from MenuItem.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedItemsControl changes. (Inherited from HeaderedItemsControl.)
Protected method | OnHeaderStringFormatChanged | Occurs when the HeaderStringFormat property changes. (Inherited from HeaderedItemsControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedItemsControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedItemsControl.)
Protected method | OnInitialized | Called when the IsInitialized property is set to true and raises an Initialized event. (Inherited from MenuItem.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the focus is no longer on or within a MenuItem. (Inherited from MenuItem.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Called when the Items property changes. (Inherited from MenuItem.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from MenuItem.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture . (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Called whenever the mouse enters a MenuItem. (Inherited from MenuItem.)
Protected method | OnMouseLeave | Called whenever the mouse leaves a MenuItem. (Inherited from MenuItem.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed. (Inherited from MenuItem.)
Protected method | OnMouseLeftButtonUp | Called when the left mouse button is released. (Inherited from MenuItem.)
Protected method | OnMouseMove | Called when the mouse is moved over a menu item. (Inherited from MenuItem.)
Protected method | OnMouseRightButtonDown | Called when the right mouse button is pressed. (Inherited from MenuItem.)
Protected method | OnMouseRightButtonUp | Called when the right mouse button is released. (Inherited from MenuItem.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnSubmenuClosed | Called when the submenu of a MenuItem is closed. (Inherited from MenuItem.)
Protected method | OnSubmenuOpened | Called when the submenu of a MenuItem is opened. (Inherited from MenuItem.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnchecked | Called when the IsChecked property becomes false. (Inherited from MenuItem.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the visual MenuItem changes. (Inherited from MenuItem.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from MenuItem.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Used to determine whether to apply a style to the item container. (Inherited from MenuItem.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a HeaderedItemsControl object. (Inherited from HeaderedItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

MenuEntry Class
ElGUI Namespace


AddHandler Method

[image] [image]

4 of William Foster's Class Libraries
MenuEntry..::..AddHandler Method
MenuEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

MenuEntry Class
MenuEntry Members
ElGUI Namespace


ApplyAnimationClock Method

[image] [image]

4 of William Foster's Class Libraries
MenuEntry..::..ApplyAnimationClock Method
MenuEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

MenuEntry Class
MenuEntry Members
ElGUI Namespace


BeginAnimation Method

[image] [image]

4 of William Foster's Class Libraries
MenuEntry..::..BeginAnimation Method
MenuEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

MenuEntry Class
MenuEntry Members
ElGUI Namespace


BeginStoryboard Method

[image] [image]

4 of William Foster's Class Libraries
MenuEntry..::..BeginStoryboard Method
MenuEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

MenuEntry Class
MenuEntry Members
ElGUI Namespace


BringIntoView Method

[image] [image]

4 of William Foster's Class Libraries
MenuEntry..::..BringIntoView Method
MenuEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

MenuEntry Class
MenuEntry Members
ElGUI Namespace


ClearValue Method

[image] [image]

4 of William Foster's Class Libraries
MenuEntry..::..ClearValue Method
MenuEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

MenuEntry Class
MenuEntry Members
ElGUI Namespace


HitTestCore Method

[image] [image]

4 of William Foster's Class Libraries
MenuEntry..::..HitTestCore Method
MenuEntry Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

MenuEntry Class
MenuEntry Members
ElGUI Namespace


SetBinding Method

[image] [image]

4 of William Foster's Class Libraries
MenuEntry..::..SetBinding Method
MenuEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

MenuEntry Class
MenuEntry Members
ElGUI Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
MenuEntry..::..SetValue Method
MenuEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

MenuEntry Class
MenuEntry Members
ElGUI Namespace


TransformToAncestor Method

[image] [image]

4 of William Foster's Class Libraries
MenuEntry..::..TransformToAncestor Method
MenuEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

MenuEntry Class
MenuEntry Members
ElGUI Namespace


MenuEntry Properties

[image] [image]

4 of William Foster's Class Libraries
MenuEntry Properties
MenuEntry Class See Also Send Feedback

The MenuEntry type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | Command | Gets or sets the command associated with the menu item. (Inherited from MenuItem.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property of a MenuItem. (Inherited from MenuItem.)
Public property | CommandTarget | Gets or sets the target element on which to raise the specified command. (Inherited from MenuItem.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets whether the control supports scrolling. (Inherited from MenuItem.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasHeader | Gets a value that indicates whether this HeaderedItemsControl has a header. (Inherited from HeaderedItemsControl.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Header | Gets or sets the item that labels the control. (Inherited from HeaderedItemsControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedItemsControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the contents of the control's header. (Inherited from HeaderedItemsControl.)
Public property | HeaderTemplateSelector | Gets or sets the object that provides custom selection logic for a template used to display the header of each item. (Inherited from HeaderedItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the icon that appears in a MenuItem. (Inherited from MenuItem.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputGestureText | Sets the text describing an input gesture that will call the command tied to the specified item. (Inherited from MenuItem.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCheckable | Gets a value that indicates whether a MenuItem can be checked. (Inherited from MenuItem.)
Public property | IsChecked | Gets or sets a value that indicates whether the MenuItem is checked. (Inherited from MenuItem.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that indicates whether the IsEnabled property is true for the current menu item. (Inherited from MenuItem.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHighlighted | Gets a value that indicates whether a MenuItem is highlighted. (Inherited from MenuItem.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a MenuItem is pressed. (Inherited from MenuItem.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsSubmenuOpen | Gets or sets a value that indicates whether the submenu of the MenuItem is open. (Inherited from MenuItem.)
Public property | IsSuspendingPopupAnimation | Gets whether a menu suspends animations on its Popup control. (Inherited from MenuItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the HeaderedItemsControl. (Inherited from HeaderedItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Role | Gets a value that indicates the role of a MenuItem. (Inherited from MenuItem.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | StaysOpenOnClick | Gets or sets a value that indicates that the submenu in which this MenuItem is located should not close when this item is clicked. (Inherited from MenuItem.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

MenuEntry Class
ElGUI Namespace


MenuEntry Events

[image] [image]

4 of William Foster's Class Libraries
MenuEntry Events
MenuEntry Class See Also Send Feedback

The MenuEntry type exposes the following members.

Events

 | Name | Description
Public event | Checked | Occurs when a menu item is checked. (Inherited from MenuItem.)
Public event | Click | Occurs when a MenuItem is clicked. (Inherited from MenuItem.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | SubmenuClosed | Occurs when the state of the IsSubmenuOpen property changes to false. (Inherited from MenuItem.)
Public event | SubmenuOpened | Occurs when the state of the IsSubmenuOpen property changes to true. (Inherited from MenuItem.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unchecked | Occurs when a MenuItem is unchecked. (Inherited from MenuItem.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

MenuEntry Class
ElGUI Namespace


MenuWindow Class

[image]

4 of William Foster's Class Libraries
MenuWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.MenuWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MenuWindow : Window
Visual Basic
Public Class MenuWindow _
    Inherits Window
Visual C++
public ref class MenuWindow : public Window

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..MenuWindow
ElGUI..::..ResourceWindow
ElImage..::..ImageWindow

See Also

MenuWindow Members
ElGUI Namespace


MenuWindow Members

[image] [image]

4 of William Foster's Class Libraries
MenuWindow Members
MenuWindow Class Constructors Methods Fields Properties See Also Send Feedback

The MenuWindow type exposes the following members.

Constructors

 | Name | Description
Public method | MenuWindow(GUI, String, WINDOW_TYPE, Window) | Initializes a new instance of the MenuWindow class
Public method | MenuWindow(GUI, STRING, array<Char>[]()[][], WINDOW_TYPE, Window) | Initializes a new instance of the MenuWindow class
Public method | MenuWindow(GUI, STRING, WINDOW_TYPE, Window, Resource_ID, ResourceStore) | Initializes a new instance of the MenuWindow class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu |
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Overrides Window..::..OnKeyDown(Char).)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Overrides Window..::..OnMessage(Message).)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | RecordKeyboardShortcut |
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName |
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

MenuWindow Class
ElGUI Namespace


MenuWindow Constructor

[image] [image]

4 of William Foster's Class Libraries
MenuWindow Constructor
MenuWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MenuWindow(GUI, String, WINDOW_TYPE, Window) | Initializes a new instance of the MenuWindow class
Public method | MenuWindow(GUI, STRING, array<Char>[]()[][], WINDOW_TYPE, Window) | Initializes a new instance of the MenuWindow class
Public method | MenuWindow(GUI, STRING, WINDOW_TYPE, Window, Resource_ID, ResourceStore) | Initializes a new instance of the MenuWindow class

See Also

MenuWindow Class
MenuWindow Members
ElGUI Namespace


MenuWindow Constructor (GUI, String, WINDOW_TYPE, Window)

[image]

4 of William Foster's Class Libraries
MenuWindow Constructor (GUI, String, WINDOW_TYPE, Window)
MenuWindow Class See Also Send Feedback
Initializes a new instance of the MenuWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MenuWindow(
    GUI gui,
    string csTitle,
    WINDOW_TYPE eType,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    csTitle As String, _
    eType As WINDOW_TYPE, _
    Parent As Window _
)
Visual C++
public:
MenuWindow(
    GUI^ gui,
    String^ csTitle,
    WINDOW_TYPE eType,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,System.String,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

csTitle
Type: System..::..String

[Missing <param name="csTitle"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,System.String,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,System.String,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,System.String,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

See Also

MenuWindow Class
MenuWindow Overload
ElGUI Namespace


MenuWindow Constructor (GUI, , Char[], WINDOW_TYPE, Window)

[image]

4 of William Foster's Class Libraries
MenuWindow Constructor (GUI, , array<Char>[]()[][], WINDOW_TYPE, Window)
MenuWindow Class See Also Send Feedback
Initializes a new instance of the MenuWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MenuWindow(
    GUI gui,
    STRING csTitle,
    char[] pMemScript,
    WINDOW_TYPE eType,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    csTitle As STRING, _
    pMemScript As Char(), _
    eType As WINDOW_TYPE, _
    Parent As Window _
)
Visual C++
public:
MenuWindow(
    GUI^ gui,
    STRING^ csTitle,
    array<wchar_t>^ pMemScript,
    WINDOW_TYPE eType,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,El.STRING,System.Char[],ElGUI.WINDOW_TYPE,ElGUI.Window)"]

csTitle
Type: STRING

[Missing <param name="csTitle"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,El.STRING,System.Char[],ElGUI.WINDOW_TYPE,ElGUI.Window)"]

pMemScript
Type: array< System..::..Char >[]()[][]

[Missing <param name="pMemScript"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,El.STRING,System.Char[],ElGUI.WINDOW_TYPE,ElGUI.Window)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,El.STRING,System.Char[],ElGUI.WINDOW_TYPE,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,El.STRING,System.Char[],ElGUI.WINDOW_TYPE,ElGUI.Window)"]

See Also

MenuWindow Class
MenuWindow Overload
ElGUI Namespace


MenuWindow Constructor (GUI, , WINDOW_TYPE, Window, Resource_ID, ResourceStore)

[image]

4 of William Foster's Class Libraries
MenuWindow Constructor (GUI, , WINDOW_TYPE, Window, Resource_ID, ResourceStore)
MenuWindow Class See Also Send Feedback
Initializes a new instance of the MenuWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MenuWindow(
    GUI gui,
    STRING csTitle,
    WINDOW_TYPE eType,
    Window Parent,
    Resource_ID resourceID,
    ResourceStore ResourceStore
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    csTitle As STRING, _
    eType As WINDOW_TYPE, _
    Parent As Window, _
    resourceID As Resource_ID, _
    ResourceStore As ResourceStore _
)
Visual C++
public:
MenuWindow(
    GUI^ gui,
    STRING^ csTitle,
    WINDOW_TYPE eType,
    Window^ Parent,
    Resource_ID resourceID,
    ResourceStore^ ResourceStore
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID,ElGUI.ResourceStore)"]

csTitle
Type: STRING

[Missing <param name="csTitle"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID,ElGUI.ResourceStore)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID,ElGUI.ResourceStore)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID,ElGUI.ResourceStore)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID,ElGUI.ResourceStore)"]

ResourceStore
Type: ElGUI..::..ResourceStore

[Missing <param name="ResourceStore"/> documentation for "M:ElGUI.MenuWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID,ElGUI.ResourceStore)"]

See Also

MenuWindow Class
MenuWindow Overload
ElGUI Namespace


MenuWindow Fields

[image] [image]

4 of William Foster's Class Libraries
MenuWindow Fields
MenuWindow Class See Also Send Feedback

The MenuWindow type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName |
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

MenuWindow Class
ElGUI Namespace


m_csRegistryName Field

[image]

4 of William Foster's Class Libraries
MenuWindow..::..m_csRegistryName Field
MenuWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.MenuWindow.m_csRegistryName"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_csRegistryName
Visual Basic
Public m_csRegistryName As String
Visual C++
public:
String^ m_csRegistryName

See Also

MenuWindow Class
ElGUI Namespace


MenuWindow Methods

[image] [image]

4 of William Foster's Class Libraries
MenuWindow Methods
MenuWindow Class See Also Send Feedback

The MenuWindow type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu |
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Overrides Window..::..OnKeyDown(Char).)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Overrides Window..::..OnMessage(Message).)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | RecordKeyboardShortcut |
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

MenuWindow Class
ElGUI Namespace


AddMenu Method

[image]

4 of William Foster's Class Libraries
MenuWindow..::..AddMenu Method
MenuWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MenuWindow.AddMenu(ElGUI.ResourceContainer)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AddMenu(
    ResourceContainer RC
)
Visual Basic
Public Function AddMenu ( _
    RC As ResourceContainer _
) As Boolean
Visual C++
public:
bool AddMenu(
    ResourceContainer^ RC
)

Parameters

RC
Type: ElGUI..::..ResourceContainer

[Missing <param name="RC"/> documentation for "M:ElGUI.MenuWindow.AddMenu(ElGUI.ResourceContainer)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.MenuWindow.AddMenu(ElGUI.ResourceContainer)"]

See Also

MenuWindow Class
ElGUI Namespace


OnKeyDown Method

[image]

4 of William Foster's Class Libraries
MenuWindow..::..OnKeyDown Method
MenuWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MenuWindow.OnKeyDown(System.Char)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int OnKeyDown(
    char key
)
Visual Basic
Public Overrides Function OnKeyDown ( _
    key As Char _
) As Integer
Visual C++
public:
virtual int OnKeyDown(
    wchar_t key
) override

Parameters

key
Type: System..::..Char

[Missing <param name="key"/> documentation for "M:ElGUI.MenuWindow.OnKeyDown(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.MenuWindow.OnKeyDown(System.Char)"]

Implements

ITerminalWindow..::..OnKeyDown(Char)

See Also

MenuWindow Class
ElGUI Namespace


OnMessage Method

[image]

4 of William Foster's Class Libraries
MenuWindow..::..OnMessage Method
MenuWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MenuWindow.OnMessage(ElGUI.Message)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int OnMessage(
    Message msg
)
Visual Basic
Public Overrides Function OnMessage ( _
    msg As Message _
) As Integer
Visual C++
public:
virtual int OnMessage(
    Message^ msg
) override

Parameters

msg
Type: ElGUI..::..Message

[Missing <param name="msg"/> documentation for "M:ElGUI.MenuWindow.OnMessage(ElGUI.Message)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.MenuWindow.OnMessage(ElGUI.Message)"]

Implements

ITerminalWindow..::..OnMessage(Message)

See Also

MenuWindow Class
ElGUI Namespace


RecordKeyboardShortcut Method

[image]

4 of William Foster's Class Libraries
MenuWindow..::..RecordKeyboardShortcut Method
MenuWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MenuWindow.RecordKeyboardShortcut(El.STRING,ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void RecordKeyboardShortcut(
    STRING csText,
    Resource_ID id
)
Visual Basic
Protected Sub RecordKeyboardShortcut ( _
    csText As STRING, _
    id As Resource_ID _
)
Visual C++
protected:
void RecordKeyboardShortcut(
    STRING^ csText,
    Resource_ID id
)

Parameters

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.MenuWindow.RecordKeyboardShortcut(El.STRING,ElGUI.Resource_ID)"]

id
Type: ElGUI..::..Resource_ID

[Missing <param name="id"/> documentation for "M:ElGUI.MenuWindow.RecordKeyboardShortcut(El.STRING,ElGUI.Resource_ID)"]

See Also

MenuWindow Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
MenuWindow..::..SetColor Method
MenuWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

MenuWindow Class
MenuWindow Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
MenuWindow..::..SetDefaultCursor Method
MenuWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

MenuWindow Class
MenuWindow Members
ElGUI Namespace


MenuWindow Properties

[image] [image]

4 of William Foster's Class Libraries
MenuWindow Properties
MenuWindow Class See Also Send Feedback

The MenuWindow type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

MenuWindow Class
ElGUI Namespace


Message Class

[image]

4 of William Foster's Class Libraries
Message Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Message"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Message
Visual Basic
Public Class Message
Visual C++
public ref class Message

Inheritance Hierarchy

System..::..Object
ElGUI..::..Message

See Also

Message Members
ElGUI Namespace


Message Members

[image] [image]

4 of William Foster's Class Libraries
Message Members
Message Class Constructors Methods Fields See Also Send Feedback

The Message type exposes the following members.

Constructors

 | Name | Description
Public method | Message | Initializes a new instance of the Message class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetID |
Public method | GetParameter |
Public method | GetParameter2 |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXY |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetSource |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
MESSAGE_NOT_PROCESSED |
MESSAGE_PROCESSED |
MK_ALT |
MK_CONTROL |
MK_LBUTTON |
MK_MBUTTON |
MK_RBUTTON |
MK_SHIFT |

See Also

Message Class
ElGUI Namespace


Message Constructor

[image]

4 of William Foster's Class Libraries
Message Constructor
Message Class See Also Send Feedback
Initializes a new instance of the Message class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Message(
    Message..::..EMessage_ID ID,
    Object parameter1,
    Object parameter2
)
Visual Basic
Public Sub New ( _
    ID As Message..::..EMessage_ID, _
    parameter1 As Object, _
    parameter2 As Object _
)
Visual C++
public:
Message(
    Message..::..EMessage_ID ID,
    Object^ parameter1,
    Object^ parameter2
)

Parameters

ID
Type: ElGUI..::..Message..::..EMessage_ID

[Missing <param name="ID"/> documentation for "M:ElGUI.Message.#ctor(ElGUI.Message.EMessage_ID,System.Object,System.Object)"]

parameter1
Type: System..::..Object

[Missing <param name="parameter1"/> documentation for "M:ElGUI.Message.#ctor(ElGUI.Message.EMessage_ID,System.Object,System.Object)"]

parameter2
Type: System..::..Object

[Missing <param name="parameter2"/> documentation for "M:ElGUI.Message.#ctor(ElGUI.Message.EMessage_ID,System.Object,System.Object)"]

See Also

Message Class
ElGUI Namespace


Message Fields

[image] [image]

4 of William Foster's Class Libraries
Message Fields
Message Class See Also Send Feedback

The Message type exposes the following members.

Fields

Name | Description
MESSAGE_NOT_PROCESSED |
MESSAGE_PROCESSED |
MK_ALT |
MK_CONTROL |
MK_LBUTTON |
MK_MBUTTON |
MK_RBUTTON |
MK_SHIFT |

See Also

Message Class
ElGUI Namespace


MESSAGE_NOT_PROCESSED Field

[image]

4 of William Foster's Class Libraries
Message..::..MESSAGE_NOT_PROCESSED Field
Message Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.Message.MESSAGE_NOT_PROCESSED"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const int MESSAGE_NOT_PROCESSED
Visual Basic
Public Const MESSAGE_NOT_PROCESSED As Integer
Visual C++
public:
literal int MESSAGE_NOT_PROCESSED

See Also

Message Class
ElGUI Namespace


MESSAGE_PROCESSED Field

[image]

4 of William Foster's Class Libraries
Message..::..MESSAGE_PROCESSED Field
Message Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.Message.MESSAGE_PROCESSED"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const int MESSAGE_PROCESSED
Visual Basic
Public Const MESSAGE_PROCESSED As Integer
Visual C++
public:
literal int MESSAGE_PROCESSED

See Also

Message Class
ElGUI Namespace


MK_ALT Field

[image]

4 of William Foster's Class Libraries
Message..::..MK_ALT Field
Message Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.Message.MK_ALT"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const ushort MK_ALT
Visual Basic
Public Const MK_ALT As UShort
Visual C++
public:
literal unsigned short MK_ALT

See Also

Message Class
ElGUI Namespace


MK_CONTROL Field

[image]

4 of William Foster's Class Libraries
Message..::..MK_CONTROL Field
Message Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.Message.MK_CONTROL"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const ushort MK_CONTROL
Visual Basic
Public Const MK_CONTROL As UShort
Visual C++
public:
literal unsigned short MK_CONTROL

See Also

Message Class
ElGUI Namespace


MK_LBUTTON Field

[image]

4 of William Foster's Class Libraries
Message..::..MK_LBUTTON Field
Message Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.Message.MK_LBUTTON"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const ushort MK_LBUTTON
Visual Basic
Public Const MK_LBUTTON As UShort
Visual C++
public:
literal unsigned short MK_LBUTTON

See Also

Message Class
ElGUI Namespace


MK_MBUTTON Field

[image]

4 of William Foster's Class Libraries
Message..::..MK_MBUTTON Field
Message Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.Message.MK_MBUTTON"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const ushort MK_MBUTTON
Visual Basic
Public Const MK_MBUTTON As UShort
Visual C++
public:
literal unsigned short MK_MBUTTON

See Also

Message Class
ElGUI Namespace


MK_RBUTTON Field

[image]

4 of William Foster's Class Libraries
Message..::..MK_RBUTTON Field
Message Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.Message.MK_RBUTTON"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const ushort MK_RBUTTON
Visual Basic
Public Const MK_RBUTTON As UShort
Visual C++
public:
literal unsigned short MK_RBUTTON

See Also

Message Class
ElGUI Namespace


MK_SHIFT Field

[image]

4 of William Foster's Class Libraries
Message..::..MK_SHIFT Field
Message Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.Message.MK_SHIFT"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const ushort MK_SHIFT
Visual Basic
Public Const MK_SHIFT As UShort
Visual C++
public:
literal unsigned short MK_SHIFT

See Also

Message Class
ElGUI Namespace


Message Methods

[image] [image]

4 of William Foster's Class Libraries
Message Methods
Message Class See Also Send Feedback

The Message type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetID |
Public method | GetParameter |
Public method | GetParameter2 |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXY |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetSource |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Message Class
ElGUI Namespace


GetID Method

[image]

4 of William Foster's Class Libraries
Message..::..GetID Method
Message Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Message.GetID"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Message..::..EMessage_ID GetID()
Visual Basic
Public Function GetID As Message..::..EMessage_ID
Visual C++
public:
Message..::..EMessage_ID GetID()

Return Value

[Missing <returns> documentation for "M:ElGUI.Message.GetID"]

See Also

Message Class
ElGUI Namespace


GetParameter Method

[image]

4 of William Foster's Class Libraries
Message..::..GetParameter Method
Message Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Message.GetParameter"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object GetParameter()
Visual Basic
Public Function GetParameter As Object
Visual C++
public:
Object^ GetParameter()

Return Value

[Missing <returns> documentation for "M:ElGUI.Message.GetParameter"]

See Also

Message Class
ElGUI Namespace


GetParameter2 Method

[image]

4 of William Foster's Class Libraries
Message..::..GetParameter2 Method
Message Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Message.GetParameter2"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object GetParameter2()
Visual Basic
Public Function GetParameter2 As Object
Visual C++
public:
Object^ GetParameter2()

Return Value

[Missing <returns> documentation for "M:ElGUI.Message.GetParameter2"]

See Also

Message Class
ElGUI Namespace


GetXY Method

[image]

4 of William Foster's Class Libraries
Message..::..GetXY Method
Message Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Message.GetXY"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Size2dU GetXY()
Visual Basic
Public Function GetXY As Size2dU
Visual C++
public:
Size2dU^ GetXY()

Return Value

[Missing <returns> documentation for "M:ElGUI.Message.GetXY"]

See Also

Message Class
ElGUI Namespace


Set Method

[image]

4 of William Foster's Class Libraries
Message..::..Set Method
Message Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Message.Set(ElGUI.Message.EMessage_ID,System.Object)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    Message..::..EMessage_ID ID,
    Object parameter1
)
Visual Basic
Public Sub Set ( _
    ID As Message..::..EMessage_ID, _
    parameter1 As Object _
)
Visual C++
public:
void Set(
    Message..::..EMessage_ID ID,
    Object^ parameter1
)

Parameters

ID
Type: ElGUI..::..Message..::..EMessage_ID

[Missing <param name="ID"/> documentation for "M:ElGUI.Message.Set(ElGUI.Message.EMessage_ID,System.Object)"]

parameter1
Type: System..::..Object

[Missing <param name="parameter1"/> documentation for "M:ElGUI.Message.Set(ElGUI.Message.EMessage_ID,System.Object)"]

See Also

Message Class
ElGUI Namespace


SetSource Method

[image]

4 of William Foster's Class Libraries
Message..::..SetSource Method
Message Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Message.SetSource(System.IntPtr)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetSource(
    IntPtr hwnd
)
Visual Basic
Public Sub SetSource ( _
    hwnd As IntPtr _
)
Visual C++
public:
void SetSource(
    IntPtr hwnd
)

Parameters

hwnd
Type: System..::..IntPtr

[Missing <param name="hwnd"/> documentation for "M:ElGUI.Message.SetSource(System.IntPtr)"]

See Also

Message Class
ElGUI Namespace


Message.EMessage_ID Enumeration

[image]

4 of William Foster's Class Libraries
Message..::..EMessage_ID Enumeration
Message Class See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Message.EMessage_ID"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum EMessage_ID
Visual Basic
Public Enumeration EMessage_ID
Visual C++
public enum class EMessage_ID

Members

Member name | Value | Description
NO_OP | 0 |
KEYPRESS | 4097 |
KEYRELEASE | 4096 |
MOUSEMOVE | 4098 |
MOUSEUP | 4099 |
MOUSEDOWN | 4100 |
MOUSEDOUBLECLICK | 4101 |
MOUSEENTER | 4102 |
MOUSELEAVE | 4103 |
FOCUSIN | 4104 |
FOCUSOUT | 4105 |
DESTROY | 4106 |
REDRAW | 4128 |
RESIZE | 4129 |
BUTTONPRESS | 4130 |
CHILD_EXIT | 4131 |

See Also

ElGUI Namespace


MessageBox Class

[image]

4 of William Foster's Class Libraries
MessageBox Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.MessageBox"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MessageBox : DialogWindow
Visual Basic
Public Class MessageBox _
    Inherits DialogWindow
Visual C++
public ref class MessageBox : public DialogWindow

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..MenuWindow
ElGUI..::..ResourceWindow
ElGUI..::..DialogWindow
ElGUI..::..MessageBox

See Also

MessageBox Members
ElGUI Namespace


MessageBox Members

[image] [image]

4 of William Foster's Class Libraries
MessageBox Members
MessageBox Class Constructors Methods Fields Properties See Also Send Feedback

The MessageBox type exposes the following members.

Constructors

 | Name | Description
Public method | MessageBox | Initializes a new instance of the MessageBox class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu | (Inherited from MenuWindow.)
Protected method | AddResourceControl | (Inherited from ResourceWindow.)
Protected method | AddSpacer | (Inherited from ResourceWindow.)
Protected method | AddSwitcher | (Inherited from ResourceWindow.)
Protected method | AddWindow | (Inherited from ResourceWindow.)
Protected method | AddWindows | (Inherited from ResourceWindow.)
Public method | Alert |
Public method | AppendResourceContainer | (Inherited from ResourceWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Protected method | ButtonPress | (Inherited from DialogWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Protected method | CreateEntryList | (Inherited from ResourceWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | execute | (Inherited from DialogWindow.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Protected method | GetDP | (Inherited from DialogWindow.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Protected method | GetRCList | (Inherited from ResourceWindow.)
Protected method | GetResourceContainer | (Inherited from ResourceWindow.)
Public method | GetResourceControlList | (Inherited from DialogWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUI_Text(STRING, Filename%) | (Inherited from DialogWindow.)
Public method | GetUI_Text(STRING, STRING%) | (Inherited from DialogWindow.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitializeResourceID | (Inherited from ResourceWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Public method | Lookup_Resource_Control(STRING) | (Inherited from ResourceWindow.)
Public method | Lookup_Resource_Control(Resource_ID) | (Inherited from ResourceWindow.)
Public method | LookupResourceEntity | (Inherited from ResourceWindow.)
Public method | LookupResourceName | (Inherited from ResourceWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from DialogWindow.)
Protected method | OnDestroy | (Inherited from DialogWindow.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from MenuWindow.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from DialogWindow.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | RecordKeyboardShortcut | (Inherited from MenuWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Public method | SetDP | (Inherited from DialogWindow.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetResourceContainer | (Inherited from ResourceWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetUI_Text | (Inherited from DialogWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDS()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDS(Resource_Control) | Given a control on a Dialog, Fill it in with the data fom the Dialog's DX (Inherited from DialogWindow.)
Public method | UpdateDX()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDX(Button) | (Inherited from DialogWindow.)
Protected method | UpdateDX(Data_Resource_Control) | Called by DialogWindow.UpdateDX(Resource_Control RC) Given a Data_Resource_Control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)
Protected method | UpdateDX(Resource_Control) | Given a control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName | (Inherited from MenuWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Public field | m_ds | (Inherited from DialogWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_ResourceControl_List | (Inherited from ResourceWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

MessageBox Class
ElGUI Namespace


MessageBox Constructor

[image]

4 of William Foster's Class Libraries
MessageBox Constructor
MessageBox Class See Also Send Feedback
Initializes a new instance of the MessageBox class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MessageBox(
    GUI gui,
    STRING str_Message,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    str_Message As STRING, _
    Parent As Window _
)
Visual C++
public:
MessageBox(
    GUI^ gui,
    STRING^ str_Message,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.MessageBox.#ctor(ElGUI.GUI,El.STRING,ElGUI.Window)"]

str_Message
Type: STRING

[Missing <param name="str_Message"/> documentation for "M:ElGUI.MessageBox.#ctor(ElGUI.GUI,El.STRING,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.MessageBox.#ctor(ElGUI.GUI,El.STRING,ElGUI.Window)"]

See Also

MessageBox Class
ElGUI Namespace


MessageBox Fields

[image] [image]

4 of William Foster's Class Libraries
MessageBox Fields
MessageBox Class See Also Send Feedback

The MessageBox type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName | (Inherited from MenuWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Public field | m_ds | (Inherited from DialogWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_ResourceControl_List | (Inherited from ResourceWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

MessageBox Class
ElGUI Namespace


MessageBox Methods

[image] [image]

4 of William Foster's Class Libraries
MessageBox Methods
MessageBox Class See Also Send Feedback

The MessageBox type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu | (Inherited from MenuWindow.)
Protected method | AddResourceControl | (Inherited from ResourceWindow.)
Protected method | AddSpacer | (Inherited from ResourceWindow.)
Protected method | AddSwitcher | (Inherited from ResourceWindow.)
Protected method | AddWindow | (Inherited from ResourceWindow.)
Protected method | AddWindows | (Inherited from ResourceWindow.)
Public method | Alert |
Public method | AppendResourceContainer | (Inherited from ResourceWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Protected method | ButtonPress | (Inherited from DialogWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Protected method | CreateEntryList | (Inherited from ResourceWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | execute | (Inherited from DialogWindow.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Protected method | GetDP | (Inherited from DialogWindow.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Protected method | GetRCList | (Inherited from ResourceWindow.)
Protected method | GetResourceContainer | (Inherited from ResourceWindow.)
Public method | GetResourceControlList | (Inherited from DialogWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUI_Text(STRING, Filename%) | (Inherited from DialogWindow.)
Public method | GetUI_Text(STRING, STRING%) | (Inherited from DialogWindow.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitializeResourceID | (Inherited from ResourceWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Public method | Lookup_Resource_Control(STRING) | (Inherited from ResourceWindow.)
Public method | Lookup_Resource_Control(Resource_ID) | (Inherited from ResourceWindow.)
Public method | LookupResourceEntity | (Inherited from ResourceWindow.)
Public method | LookupResourceName | (Inherited from ResourceWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from DialogWindow.)
Protected method | OnDestroy | (Inherited from DialogWindow.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from MenuWindow.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from DialogWindow.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | RecordKeyboardShortcut | (Inherited from MenuWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Public method | SetDP | (Inherited from DialogWindow.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetResourceContainer | (Inherited from ResourceWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetUI_Text | (Inherited from DialogWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDS()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDS(Resource_Control) | Given a control on a Dialog, Fill it in with the data fom the Dialog's DX (Inherited from DialogWindow.)
Public method | UpdateDX()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDX(Button) | (Inherited from DialogWindow.)
Protected method | UpdateDX(Data_Resource_Control) | Called by DialogWindow.UpdateDX(Resource_Control RC) Given a Data_Resource_Control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)
Protected method | UpdateDX(Resource_Control) | Given a control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

MessageBox Class
ElGUI Namespace


Alert Method

[image]

4 of William Foster's Class Libraries
MessageBox..::..Alert Method
MessageBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.MessageBox.Alert"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Alert()
Visual Basic
Public Function Alert As Integer
Visual C++
public:
int Alert()

Return Value

[Missing <returns> documentation for "M:ElGUI.MessageBox.Alert"]

See Also

MessageBox Class
ElGUI Namespace


GetUI_Text Method

[image] [image]

4 of William Foster's Class Libraries
MessageBox..::..GetUI_Text Method
MessageBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUI_Text(STRING, Filename%) | (Inherited from DialogWindow.)
Public method | GetUI_Text(STRING, STRING%) | (Inherited from DialogWindow.)

See Also

MessageBox Class
MessageBox Members
ElGUI Namespace


Lookup_Resource_Control Method

[image] [image]

4 of William Foster's Class Libraries
MessageBox..::..Lookup_Resource_Control Method
MessageBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lookup_Resource_Control(STRING) | (Inherited from ResourceWindow.)
Public method | Lookup_Resource_Control(Resource_ID) | (Inherited from ResourceWindow.)

See Also

MessageBox Class
MessageBox Members
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
MessageBox..::..SetColor Method
MessageBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

MessageBox Class
MessageBox Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
MessageBox..::..SetDefaultCursor Method
MessageBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

MessageBox Class
MessageBox Members
ElGUI Namespace


UpdateDS Method

[image] [image]

4 of William Foster's Class Libraries
MessageBox..::..UpdateDS Method
MessageBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateDS()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDS(Resource_Control) | Given a control on a Dialog, Fill it in with the data fom the Dialog's DX (Inherited from DialogWindow.)

See Also

MessageBox Class
MessageBox Members
ElGUI Namespace


UpdateDX Method

[image] [image]

4 of William Foster's Class Libraries
MessageBox..::..UpdateDX Method
MessageBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateDX()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDX(Button) | (Inherited from DialogWindow.)
Protected method | UpdateDX(Data_Resource_Control) | Called by DialogWindow.UpdateDX(Resource_Control RC) Given a Data_Resource_Control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)
Protected method | UpdateDX(Resource_Control) | Given a control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)

See Also

MessageBox Class
MessageBox Members
ElGUI Namespace


MessageBox Properties

[image] [image]

4 of William Foster's Class Libraries
MessageBox Properties
MessageBox Class See Also Send Feedback

The MessageBox type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

MessageBox Class
ElGUI Namespace


ProgressControl Class

[image]

4 of William Foster's Class Libraries
ProgressControl Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ProgressControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ProgressControl : TextData_Resource_Control
Visual Basic
Public Class ProgressControl _
    Inherits TextData_Resource_Control
Visual C++
public ref class ProgressControl : public TextData_Resource_Control

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..Resource_Control
ElGUI..::..Data_Resource_Control
ElGUI..::..TextData_Resource_Control
ElGUI..::..ProgressControl

See Also

ProgressControl Members
ElGUI Namespace


ProgressControl Members

[image] [image]

4 of William Foster's Class Libraries
ProgressControl Members
ProgressControl Class Constructors Methods Fields Properties See Also Send Feedback

The ProgressControl type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressControl(GUI, STRING, WINDOW_TYPE, Window) | Initializes a new instance of the ProgressControl class
Public method | ProgressControl(GUI, STRING, WINDOW_TYPE, Window, Resource_ID) | Initializes a new instance of the ProgressControl class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Overrides UILayerWindow..::..OnCreate()()()().)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Overrides Window..::..OnPaint(Rect2dU).)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetPercentageCompleted |
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ProgressControl Class
ElGUI Namespace


ProgressControl Constructor

[image] [image]

4 of William Foster's Class Libraries
ProgressControl Constructor
ProgressControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProgressControl(GUI, STRING, WINDOW_TYPE, Window) | Initializes a new instance of the ProgressControl class
Public method | ProgressControl(GUI, STRING, WINDOW_TYPE, Window, Resource_ID) | Initializes a new instance of the ProgressControl class

See Also

ProgressControl Class
ProgressControl Members
ElGUI Namespace


ProgressControl Constructor (GUI, , WINDOW_TYPE, Window)

[image]

4 of William Foster's Class Libraries
ProgressControl Constructor (GUI, , WINDOW_TYPE, Window)
ProgressControl Class See Also Send Feedback
Initializes a new instance of the ProgressControl class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ProgressControl(
    GUI gui,
    STRING csTitle,
    WINDOW_TYPE eType,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    csTitle As STRING, _
    eType As WINDOW_TYPE, _
    Parent As Window _
)
Visual C++
public:
ProgressControl(
    GUI^ gui,
    STRING^ csTitle,
    WINDOW_TYPE eType,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.ProgressControl.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

csTitle
Type: STRING

[Missing <param name="csTitle"/> documentation for "M:ElGUI.ProgressControl.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.ProgressControl.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.ProgressControl.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

See Also

ProgressControl Class
ProgressControl Overload
ElGUI Namespace


ProgressControl Constructor (GUI, , WINDOW_TYPE, Window, Resource_ID)

[image]

4 of William Foster's Class Libraries
ProgressControl Constructor (GUI, , WINDOW_TYPE, Window, Resource_ID)
ProgressControl Class See Also Send Feedback
Initializes a new instance of the ProgressControl class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ProgressControl(
    GUI gui,
    STRING csTitle,
    WINDOW_TYPE eType,
    Window Parent,
    Resource_ID resourceID
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    csTitle As STRING, _
    eType As WINDOW_TYPE, _
    Parent As Window, _
    resourceID As Resource_ID _
)
Visual C++
public:
ProgressControl(
    GUI^ gui,
    STRING^ csTitle,
    WINDOW_TYPE eType,
    Window^ Parent,
    Resource_ID resourceID
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.ProgressControl.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID)"]

csTitle
Type: STRING

[Missing <param name="csTitle"/> documentation for "M:ElGUI.ProgressControl.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.ProgressControl.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.ProgressControl.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.ProgressControl.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID)"]

See Also

ProgressControl Class
ProgressControl Overload
ElGUI Namespace


ProgressControl Fields

[image] [image]

4 of William Foster's Class Libraries
ProgressControl Fields
ProgressControl Class See Also Send Feedback

The ProgressControl type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

ProgressControl Class
ElGUI Namespace


ProgressControl Methods

[image] [image]

4 of William Foster's Class Libraries
ProgressControl Methods
ProgressControl Class See Also Send Feedback

The ProgressControl type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Overrides UILayerWindow..::..OnCreate()()()().)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Overrides Window..::..OnPaint(Rect2dU).)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetPercentageCompleted |
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

ProgressControl Class
ElGUI Namespace


GetText Method

[image] [image]

4 of William Foster's Class Libraries
ProgressControl..::..GetText Method
ProgressControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)

See Also

ProgressControl Class
ProgressControl Members
ElGUI Namespace


OnCreate Method

[image]

4 of William Foster's Class Libraries
ProgressControl..::..OnCreate Method
ProgressControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ProgressControl.OnCreate"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool OnCreate()
Visual Basic
Protected Overrides Function OnCreate As Boolean
Visual C++
protected:
virtual bool OnCreate() override

Return Value

[Missing <returns> documentation for "M:ElGUI.ProgressControl.OnCreate"]

See Also

ProgressControl Class
ElGUI Namespace


OnPaint Method

[image]

4 of William Foster's Class Libraries
ProgressControl..::..OnPaint Method
ProgressControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ProgressControl.OnPaint(El.Rect2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override int OnPaint(
    Rect2dU rect2d
)
Visual Basic
Protected Overrides Function OnPaint ( _
    rect2d As Rect2dU _
) As Integer
Visual C++
protected:
virtual int OnPaint(
    Rect2dU^ rect2d
) override

Parameters

rect2d
Type: Rect2dU

[Missing <param name="rect2d"/> documentation for "M:ElGUI.ProgressControl.OnPaint(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ProgressControl.OnPaint(El.Rect2dU)"]

See Also

ProgressControl Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
ProgressControl..::..SetColor Method
ProgressControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

ProgressControl Class
ProgressControl Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
ProgressControl..::..SetDefaultCursor Method
ProgressControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

ProgressControl Class
ProgressControl Members
ElGUI Namespace


SetPercentageCompleted Method

[image]

4 of William Foster's Class Libraries
ProgressControl..::..SetPercentageCompleted Method
ProgressControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ProgressControl.SetPercentageCompleted(System.Double)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool SetPercentageCompleted(
    double d
)
Visual Basic
Public Overridable Function SetPercentageCompleted ( _
    d As Double _
) As Boolean
Visual C++
public:
virtual bool SetPercentageCompleted(
    double d
)

Parameters

d
Type: System..::..Double

[Missing <param name="d"/> documentation for "M:ElGUI.ProgressControl.SetPercentageCompleted(System.Double)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ProgressControl.SetPercentageCompleted(System.Double)"]

See Also

ProgressControl Class
ElGUI Namespace


ProgressControl Properties

[image] [image]

4 of William Foster's Class Libraries
ProgressControl Properties
ProgressControl Class See Also Send Feedback

The ProgressControl type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ProgressControl Class
ElGUI Namespace


ProgressMeter Class

[image]

4 of William Foster's Class Libraries
ProgressMeter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ProgressMeter"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ProgressMeter
Visual Basic
Public Class ProgressMeter
Visual C++
public ref class ProgressMeter

Inheritance Hierarchy

System..::..Object
ElGUI..::..ProgressMeter

See Also

ProgressMeter Members
ElGUI Namespace


ProgressMeter Members

[image] [image]

4 of William Foster's Class Libraries
ProgressMeter Members
ProgressMeter Class Constructors Methods See Also Send Feedback

The ProgressMeter type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressMeter | Initializes a new instance of the ProgressMeter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPercentageCompleted |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProgressMeter Class
ElGUI Namespace


ProgressMeter Constructor

[image]

4 of William Foster's Class Libraries
ProgressMeter Constructor
ProgressMeter Class See Also Send Feedback
Initializes a new instance of the ProgressMeter class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ProgressMeter()
Visual Basic
Public Sub New
Visual C++
public:
ProgressMeter()

See Also

ProgressMeter Class
ElGUI Namespace


ProgressMeter Methods

[image] [image]

4 of William Foster's Class Libraries
ProgressMeter Methods
ProgressMeter Class See Also Send Feedback

The ProgressMeter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetPercentageCompleted |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProgressMeter Class
ElGUI Namespace


SetPercentageCompleted Method

[image]

4 of William Foster's Class Libraries
ProgressMeter..::..SetPercentageCompleted Method
ProgressMeter Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ProgressMeter.SetPercentageCompleted(System.Double)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool SetPercentageCompleted(
    double d
)
Visual Basic
Public Overridable Function SetPercentageCompleted ( _
    d As Double _
) As Boolean
Visual C++
public:
virtual bool SetPercentageCompleted(
    double d
)

Parameters

d
Type: System..::..Double

[Missing <param name="d"/> documentation for "M:ElGUI.ProgressMeter.SetPercentageCompleted(System.Double)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ProgressMeter.SetPercentageCompleted(System.Double)"]

See Also

ProgressMeter Class
ElGUI Namespace


Registry Class

[image]

4 of William Foster's Class Libraries
Registry Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Registry"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Registry
Visual Basic
Public Class Registry
Visual C++
public ref class Registry

Inheritance Hierarchy

System..::..Object
ElGUI..::..Registry

See Also

Registry Members
ElGUI Namespace


Registry Members

[image] [image]

4 of William Foster's Class Libraries
Registry Members
Registry Class Constructors Methods See Also Send Feedback

The Registry type exposes the following members.

Constructors

 | Name | Description
Public method | Registry | Initializes a new instance of the Registry class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUINT |
Public method | GetValue |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetString |
Public method | SetUINT |
Public method | SetValue |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Registry Class
ElGUI Namespace


Registry Constructor

[image]

4 of William Foster's Class Libraries
Registry Constructor
Registry Class See Also Send Feedback
Initializes a new instance of the Registry class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Registry(
    string section
)
Visual Basic
Public Sub New ( _
    section As String _
)
Visual C++
public:
Registry(
    String^ section
)

Parameters

section
Type: System..::..String

[Missing <param name="section"/> documentation for "M:ElGUI.Registry.#ctor(System.String)"]

See Also

Registry Class
ElGUI Namespace


Registry Methods

[image] [image]

4 of William Foster's Class Libraries
Registry Methods
Registry Class See Also Send Feedback

The Registry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUINT |
Public method | GetValue |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetString |
Public method | SetUINT |
Public method | SetValue |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Registry Class
ElGUI Namespace


GetString Method

[image]

4 of William Foster's Class Libraries
Registry..::..GetString Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Registry.GetString(System.String,System.String@,System.String)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GetString(
    string key,
    out string rval,
    string defaultValue
)
Visual Basic
Public Function GetString ( _
    key As String, _
    <OutAttribute> ByRef rval As String, _
    defaultValue As String _
) As Boolean
Visual C++
public:
bool GetString(
    String^ key,
    [OutAttribute] String^% rval,
    String^ defaultValue
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:ElGUI.Registry.GetString(System.String,System.String@,System.String)"]

rval
Type: System..::..String %

[Missing <param name="rval"/> documentation for "M:ElGUI.Registry.GetString(System.String,System.String@,System.String)"]

defaultValue
Type: System..::..String

[Missing <param name="defaultValue"/> documentation for "M:ElGUI.Registry.GetString(System.String,System.String@,System.String)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Registry.GetString(System.String,System.String@,System.String)"]

See Also

Registry Class
ElGUI Namespace


GetUINT Method

[image]

4 of William Foster's Class Libraries
Registry..::..GetUINT Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Registry.GetUINT(System.String,System.UInt32@,System.UInt32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GetUINT(
    string key,
    out uint rU,
    uint defaultU
)
Visual Basic
Public Function GetUINT ( _
    key As String, _
    <OutAttribute> ByRef rU As UInteger, _
    defaultU As UInteger _
) As Boolean
Visual C++
public:
bool GetUINT(
    String^ key,
    [OutAttribute] unsigned int% rU,
    unsigned int defaultU
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:ElGUI.Registry.GetUINT(System.String,System.UInt32@,System.UInt32)"]

rU
Type: System..::..UInt32 %

[Missing <param name="rU"/> documentation for "M:ElGUI.Registry.GetUINT(System.String,System.UInt32@,System.UInt32)"]

defaultU
Type: System..::..UInt32

[Missing <param name="defaultU"/> documentation for "M:ElGUI.Registry.GetUINT(System.String,System.UInt32@,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Registry.GetUINT(System.String,System.UInt32@,System.UInt32)"]

See Also

Registry Class
ElGUI Namespace


GetValue Method

[image]

4 of William Foster's Class Libraries
Registry..::..GetValue Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Registry.GetValue(System.String,El.Value@,El.Value)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GetValue(
    string key,
    out Value rValue,
    Value defaultValue
)
Visual Basic
Public Function GetValue ( _
    key As String, _
    <OutAttribute> ByRef rValue As Value, _
    defaultValue As Value _
) As Boolean
Visual C++
public:
bool GetValue(
    String^ key,
    [OutAttribute] Value^% rValue,
    Value^ defaultValue
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:ElGUI.Registry.GetValue(System.String,El.Value@,El.Value)"]

rValue
Type: Value%

[Missing <param name="rValue"/> documentation for "M:ElGUI.Registry.GetValue(System.String,El.Value@,El.Value)"]

defaultValue
Type: Value

[Missing <param name="defaultValue"/> documentation for "M:ElGUI.Registry.GetValue(System.String,El.Value@,El.Value)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Registry.GetValue(System.String,El.Value@,El.Value)"]

See Also

Registry Class
ElGUI Namespace


SetString Method

[image]

4 of William Foster's Class Libraries
Registry..::..SetString Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Registry.SetString(System.String,System.String)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetString(
    string key,
    string value
)
Visual Basic
Public Function SetString ( _
    key As String, _
    value As String _
) As Boolean
Visual C++
public:
bool SetString(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:ElGUI.Registry.SetString(System.String,System.String)"]

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:ElGUI.Registry.SetString(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Registry.SetString(System.String,System.String)"]

See Also

Registry Class
ElGUI Namespace


SetUINT Method

[image]

4 of William Foster's Class Libraries
Registry..::..SetUINT Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Registry.SetUINT(System.String,System.UInt32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetUINT(
    string key,
    uint U
)
Visual Basic
Public Function SetUINT ( _
    key As String, _
    U As UInteger _
) As Boolean
Visual C++
public:
bool SetUINT(
    String^ key,
    unsigned int U
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:ElGUI.Registry.SetUINT(System.String,System.UInt32)"]

U
Type: System..::..UInt32

[Missing <param name="U"/> documentation for "M:ElGUI.Registry.SetUINT(System.String,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Registry.SetUINT(System.String,System.UInt32)"]

See Also

Registry Class
ElGUI Namespace


SetValue Method

[image]

4 of William Foster's Class Libraries
Registry..::..SetValue Method
Registry Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Registry.SetValue(System.String,El.Value)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetValue(
    string key,
    Value value
)
Visual Basic
Public Function SetValue ( _
    key As String, _
    value As Value _
) As Boolean
Visual C++
public:
bool SetValue(
    String^ key,
    Value^ value
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:ElGUI.Registry.SetValue(System.String,El.Value)"]

value
Type: Value

[Missing <param name="value"/> documentation for "M:ElGUI.Registry.SetValue(System.String,El.Value)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Registry.SetValue(System.String,El.Value)"]

See Also

Registry Class
ElGUI Namespace


Resource_Control Class

[image]

4 of William Foster's Class Libraries
Resource_Control Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Resource_Control"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Resource_Control : Window
Visual Basic
Public Class Resource_Control _
    Inherits Window
Visual C++
public ref class Resource_Control : public Window

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..Resource_Control
ElGUI..::..Button
ElGUI..::..Data_Resource_Control
ElGUI..::..Label

See Also

Resource_Control Members
ElGUI Namespace


Resource_Control Members

[image] [image]

4 of William Foster's Class Libraries
Resource_Control Members
Resource_Control Class Constructors Methods Fields Properties See Also Send Feedback

The Resource_Control type exposes the following members.

Constructors

 | Name | Description
Public method | Resource_Control | Initializes a new instance of the Resource_Control class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() |
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
 | MatrixIndexOfResource_ID |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NormalizeResource_ID | The resource-id stores duplicates of itself with different bits in the upper register. Normalize it to identify it, get the matrixindex to know which one was selected.
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Overrides Window..::..OnMouseDown(Size2dU).)
Public method | OnMouseEnter | (Overrides Window..::..OnMouseEnter()()()().)
Public method | OnMouseLeave | (Overrides Window..::..OnMouseLeave()()()().)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent |
Protected method | ProcessHandlers |
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set |
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Overrides UILayerWindow..::..SetText(String).)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers |
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

Resource_Control Class
ElGUI Namespace


Resource_Control Constructor

[image]

4 of William Foster's Class Libraries
Resource_Control Constructor
Resource_Control Class See Also Send Feedback
Initializes a new instance of the Resource_Control class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Resource_Control(
    GUI Gui,
    Window Parent,
    STRING csText,
    Resource_ID resourceID,
    WINDOW_TYPE eType
)
Visual Basic
Public Sub New ( _
    Gui As GUI, _
    Parent As Window, _
    csText As STRING, _
    resourceID As Resource_ID, _
    eType As WINDOW_TYPE _
)
Visual C++
public:
Resource_Control(
    GUI^ Gui,
    Window^ Parent,
    STRING^ csText,
    Resource_ID resourceID,
    WINDOW_TYPE eType
)

Parameters

Gui
Type: ElGUI..::..GUI

[Missing <param name="Gui"/> documentation for "M:ElGUI.Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

See Also

Resource_Control Class
ElGUI Namespace


Resource_Control Fields

[image] [image]

4 of William Foster's Class Libraries
Resource_Control Fields
Resource_Control Class See Also Send Feedback

The Resource_Control type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

Resource_Control Class
ElGUI Namespace


Resource_Control Methods

[image] [image]

4 of William Foster's Class Libraries
Resource_Control Methods
Resource_Control Class See Also Send Feedback

The Resource_Control type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() |
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
 | MatrixIndexOfResource_ID |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NormalizeResource_ID | The resource-id stores duplicates of itself with different bits in the upper register. Normalize it to identify it, get the matrixindex to know which one was selected.
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Overrides Window..::..OnMouseDown(Size2dU).)
Public method | OnMouseEnter | (Overrides Window..::..OnMouseEnter()()()().)
Public method | OnMouseLeave | (Overrides Window..::..OnMouseLeave()()()().)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent |
Protected method | ProcessHandlers |
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set |
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Overrides UILayerWindow..::..SetText(String).)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers |
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

Resource_Control Class
ElGUI Namespace


GetText Method

[image] [image]

4 of William Foster's Class Libraries
Resource_Control..::..GetText Method
Resource_Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetText()()()() |
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)

See Also

Resource_Control Class
Resource_Control Members
ElGUI Namespace


GetText Method

[image]

4 of William Foster's Class Libraries
Resource_Control..::..GetText Method
Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Resource_Control.GetText"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING GetText()
Visual Basic
Public Function GetText As STRING
Visual C++
public:
STRING^ GetText()

Return Value

[Missing <returns> documentation for "M:ElGUI.Resource_Control.GetText"]

See Also

Resource_Control Class
GetText Overload
ElGUI Namespace


MatrixIndexOfResource_ID Method

[image]

4 of William Foster's Class Libraries
Resource_Control..::..MatrixIndexOfResource_ID Method
Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Resource_Control.MatrixIndexOfResource_ID(ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int MatrixIndexOfResource_ID(
    Resource_ID id
)
Visual Basic
Public Shared Function MatrixIndexOfResource_ID ( _
    id As Resource_ID _
) As Integer
Visual C++
public:
static int MatrixIndexOfResource_ID(
    Resource_ID id
)

Parameters

id
Type: ElGUI..::..Resource_ID

[Missing <param name="id"/> documentation for "M:ElGUI.Resource_Control.MatrixIndexOfResource_ID(ElGUI.Resource_ID)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Resource_Control.MatrixIndexOfResource_ID(ElGUI.Resource_ID)"]

See Also

Resource_Control Class
ElGUI Namespace


NormalizeResource_ID Method

[image]

4 of William Foster's Class Libraries
Resource_Control..::..NormalizeResource_ID Method
Resource_Control Class See Also Send Feedback
The resource-id stores duplicates of itself with different bits in the upper register. Normalize it to identify it, get the matrixindex to know which one was selected.

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Resource_ID NormalizeResource_ID(
    Resource_ID id
)
Visual Basic
Public Shared Function NormalizeResource_ID ( _
    id As Resource_ID _
) As Resource_ID
Visual C++
public:
static Resource_ID NormalizeResource_ID(
    Resource_ID id
)

Parameters

id
Type: ElGUI..::..Resource_ID

[Missing <param name="id"/> documentation for "M:ElGUI.Resource_Control.NormalizeResource_ID(ElGUI.Resource_ID)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Resource_Control.NormalizeResource_ID(ElGUI.Resource_ID)"]

See Also

Resource_Control Class
ElGUI Namespace


OnMouseDown Method

[image]

4 of William Foster's Class Libraries
Resource_Control..::..OnMouseDown Method
Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Resource_Control.OnMouseDown(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int OnMouseDown(
    Size2dU pt
)
Visual Basic
Public Overrides Function OnMouseDown ( _
    pt As Size2dU _
) As Integer
Visual C++
public:
virtual int OnMouseDown(
    Size2dU^ pt
) override

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.Resource_Control.OnMouseDown(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Resource_Control.OnMouseDown(El.Size2dU)"]

Implements

ITerminalWindow..::..OnMouseDown(Size2dU)

See Also

Resource_Control Class
ElGUI Namespace


OnMouseEnter Method

[image]

4 of William Foster's Class Libraries
Resource_Control..::..OnMouseEnter Method
Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Resource_Control.OnMouseEnter"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int OnMouseEnter()
Visual Basic
Public Overrides Function OnMouseEnter As Integer
Visual C++
public:
virtual int OnMouseEnter() override

Return Value

[Missing <returns> documentation for "M:ElGUI.Resource_Control.OnMouseEnter"]

Implements

ITerminalWindow..::..OnMouseEnter()()()()

See Also

Resource_Control Class
ElGUI Namespace


OnMouseLeave Method

[image]

4 of William Foster's Class Libraries
Resource_Control..::..OnMouseLeave Method
Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Resource_Control.OnMouseLeave"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int OnMouseLeave()
Visual Basic
Public Overrides Function OnMouseLeave As Integer
Visual C++
public:
virtual int OnMouseLeave() override

Return Value

[Missing <returns> documentation for "M:ElGUI.Resource_Control.OnMouseLeave"]

Implements

ITerminalWindow..::..OnMouseLeave()()()()

See Also

Resource_Control Class
ElGUI Namespace


ProcessEvent Method

[image]

4 of William Foster's Class Libraries
Resource_Control..::..ProcessEvent Method
Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Resource_Control.ProcessEvent(ElGUI.ResourceEvent)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void ProcessEvent(
    ResourceEvent rEV
)
Visual Basic
Protected Sub ProcessEvent ( _
    rEV As ResourceEvent _
)
Visual C++
protected:
void ProcessEvent(
    ResourceEvent^ rEV
)

Parameters

rEV
Type: ElGUI..::..ResourceEvent

[Missing <param name="rEV"/> documentation for "M:ElGUI.Resource_Control.ProcessEvent(ElGUI.ResourceEvent)"]

See Also

Resource_Control Class
ElGUI Namespace


ProcessHandlers Method

[image]

4 of William Foster's Class Libraries
Resource_Control..::..ProcessHandlers Method
Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Resource_Control.ProcessHandlers(ElGUI.EBFC_GUIRES_HANDLER_KEY)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void ProcessHandlers(
    EBFC_GUIRES_HANDLER_KEY eHandlerKey
)
Visual Basic
Protected Sub ProcessHandlers ( _
    eHandlerKey As EBFC_GUIRES_HANDLER_KEY _
)
Visual C++
protected:
void ProcessHandlers(
    EBFC_GUIRES_HANDLER_KEY eHandlerKey
)

Parameters

eHandlerKey
Type: ElGUI..::..EBFC_GUIRES_HANDLER_KEY

[Missing <param name="eHandlerKey"/> documentation for "M:ElGUI.Resource_Control.ProcessHandlers(ElGUI.EBFC_GUIRES_HANDLER_KEY)"]

See Also

Resource_Control Class
ElGUI Namespace


Set Method

[image]

4 of William Foster's Class Libraries
Resource_Control..::..Set Method
Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Resource_Control.Set(System.Object)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual void Set(
    Object val
)
Visual Basic
Public Overridable Sub Set ( _
    val As Object _
)
Visual C++
public:
virtual void Set(
    Object^ val
)

Parameters

val
Type: System..::..Object

[Missing <param name="val"/> documentation for "M:ElGUI.Resource_Control.Set(System.Object)"]

See Also

Resource_Control Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
Resource_Control..::..SetColor Method
Resource_Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

Resource_Control Class
Resource_Control Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
Resource_Control..::..SetDefaultCursor Method
Resource_Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

Resource_Control Class
Resource_Control Members
ElGUI Namespace


SetText Method

[image]

4 of William Foster's Class Libraries
Resource_Control..::..SetText Method
Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Resource_Control.SetText(System.String)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void SetText(
    string csText
)
Visual Basic
Public Overrides Sub SetText ( _
    csText As String _
)
Visual C++
public:
virtual void SetText(
    String^ csText
) override

Parameters

csText
Type: System..::..String

[Missing <param name="csText"/> documentation for "M:ElGUI.Resource_Control.SetText(System.String)"]

See Also

Resource_Control Class
ElGUI Namespace


UpdateHandlers Method

[image]

4 of William Foster's Class Libraries
Resource_Control..::..UpdateHandlers Method
Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Resource_Control.UpdateHandlers(ElGUI.ResourceEntity)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void UpdateHandlers(
    ResourceEntity ResEntity
)
Visual Basic
Public Sub UpdateHandlers ( _
    ResEntity As ResourceEntity _
)
Visual C++
public:
void UpdateHandlers(
    ResourceEntity^ ResEntity
)

Parameters

ResEntity
Type: ElGUI..::..ResourceEntity

[Missing <param name="ResEntity"/> documentation for "M:ElGUI.Resource_Control.UpdateHandlers(ElGUI.ResourceEntity)"]

See Also

Resource_Control Class
ElGUI Namespace


Resource_Control Properties

[image] [image]

4 of William Foster's Class Libraries
Resource_Control Properties
Resource_Control Class See Also Send Feedback

The Resource_Control type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

Resource_Control Class
ElGUI Namespace


Resource_ID Enumeration

[image]

4 of William Foster's Class Libraries
Resource_ID Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Resource_ID"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Resource_ID
Visual Basic
Public Enumeration Resource_ID
Visual C++
public enum class Resource_ID

See Also

ElGUI Namespace


ResourceAttributes Class

[image]

4 of William Foster's Class Libraries
ResourceAttributes Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ResourceAttributes"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ResourceAttributes
Visual Basic
Public Class ResourceAttributes
Visual C++
public ref class ResourceAttributes

Inheritance Hierarchy

System..::..Object
ElGUI..::..ResourceAttributes
ElGUI..::..ResourceEntity

See Also

ResourceAttributes Members
ElGUI Namespace


ResourceAttributes Members

[image] [image]

4 of William Foster's Class Libraries
ResourceAttributes Members
ResourceAttributes Class Constructors Methods Fields Properties See Also Send Feedback

The ResourceAttributes type exposes the following members.

Constructors

 | Name | Description
Public method | ResourceAttributes | Initializes a new instance of the ResourceAttributes class

Methods

 | Name | Description
Protected method | ConvertAttributeKeyToFlag |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeFlags |
Public method | GetGroup |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHotkey |
Public method | GetName |
Public method | GetPosition |
Public method | GetSize |
Public method | GetText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAttribute |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttribute |
Public method | SetAttributeFlags |
Public method | SetGroup |
Public method | SetHotkey |
Public method | SetName |
Public method | SetShape |
Public method | SetSize |
Public method | SetText |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnsetAttribute |
Public method | UnsetAttributeFlags |

Fields

 | Name | Description
Protected field | m_attribute_flags |
Protected field | m_cHotkey |
Public field | m_cs_bindfieldReflect |
Public field | m_cs_bindto |
Public field | m_cs_group |
Public field | m_cs_name |
Public field | m_cs_text |
Public field | m_horz_align |
Public field | m_position |
Protected field | m_range |
Protected field | m_shape |
Protected field | m_size |
Public field | m_vert_align |

Properties

 | Name | Description
Public property | Range |

See Also

ResourceAttributes Class
ElGUI Namespace


ResourceAttributes Constructor

[image]

4 of William Foster's Class Libraries
ResourceAttributes Constructor
ResourceAttributes Class See Also Send Feedback
Initializes a new instance of the ResourceAttributes class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceAttributes()
Visual Basic
Public Sub New
Visual C++
public:
ResourceAttributes()

See Also

ResourceAttributes Class
ElGUI Namespace


ResourceAttributes Fields

[image] [image]

4 of William Foster's Class Libraries
ResourceAttributes Fields
ResourceAttributes Class See Also Send Feedback

The ResourceAttributes type exposes the following members.

Fields

 | Name | Description
Protected field | m_attribute_flags |
Protected field | m_cHotkey |
Public field | m_cs_bindfieldReflect |
Public field | m_cs_bindto |
Public field | m_cs_group |
Public field | m_cs_name |
Public field | m_cs_text |
Public field | m_horz_align |
Public field | m_position |
Protected field | m_range |
Protected field | m_shape |
Protected field | m_size |
Public field | m_vert_align |

See Also

ResourceAttributes Class
ElGUI Namespace


m_attribute_flags Field

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..m_attribute_flags Field
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceAttributes.m_attribute_flags"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ulong m_attribute_flags
Visual Basic
Protected m_attribute_flags As ULong
Visual C++
protected:
unsigned long long m_attribute_flags

See Also

ResourceAttributes Class
ElGUI Namespace


m_cHotkey Field

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..m_cHotkey Field
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceAttributes.m_cHotkey"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected char m_cHotkey
Visual Basic
Protected m_cHotkey As Char
Visual C++
protected:
wchar_t m_cHotkey

See Also

ResourceAttributes Class
ElGUI Namespace


m_cs_bindfieldReflect Field

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..m_cs_bindfieldReflect Field
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceAttributes.m_cs_bindfieldReflect"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_cs_bindfieldReflect
Visual Basic
Public m_cs_bindfieldReflect As String
Visual C++
public:
String^ m_cs_bindfieldReflect

See Also

ResourceAttributes Class
ElGUI Namespace


m_cs_bindto Field

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..m_cs_bindto Field
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceAttributes.m_cs_bindto"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_cs_bindto
Visual Basic
Public m_cs_bindto As String
Visual C++
public:
String^ m_cs_bindto

See Also

ResourceAttributes Class
ElGUI Namespace


m_cs_group Field

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..m_cs_group Field
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceAttributes.m_cs_group"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING m_cs_group
Visual Basic
Public m_cs_group As STRING
Visual C++
public:
STRING^ m_cs_group

See Also

ResourceAttributes Class
ElGUI Namespace


m_cs_name Field

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..m_cs_name Field
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceAttributes.m_cs_name"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING m_cs_name
Visual Basic
Public m_cs_name As STRING
Visual C++
public:
STRING^ m_cs_name

See Also

ResourceAttributes Class
ElGUI Namespace


m_cs_text Field

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..m_cs_text Field
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceAttributes.m_cs_text"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING m_cs_text
Visual Basic
Public m_cs_text As STRING
Visual C++
public:
STRING^ m_cs_text

See Also

ResourceAttributes Class
ElGUI Namespace


m_horz_align Field

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..m_horz_align Field
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceAttributes.m_horz_align"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ALIGNMENT_KEY m_horz_align
Visual Basic
Public m_horz_align As ALIGNMENT_KEY
Visual C++
public:
ALIGNMENT_KEY m_horz_align

See Also

ResourceAttributes Class
ElGUI Namespace


m_position Field

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..m_position Field
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceAttributes.m_position"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Size2dU m_position
Visual Basic
Public m_position As Size2dU
Visual C++
public:
Size2dU^ m_position

See Also

ResourceAttributes Class
ElGUI Namespace


m_range Field

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..m_range Field
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceAttributes.m_range"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Range2d m_range
Visual Basic
Protected m_range As Range2d
Visual C++
protected:
Range2d^ m_range

See Also

ResourceAttributes Class
ElGUI Namespace


m_shape Field

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..m_shape Field
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceAttributes.m_shape"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Shape2d m_shape
Visual Basic
Protected m_shape As Shape2d
Visual C++
protected:
Shape2d^ m_shape

See Also

ResourceAttributes Class
ElGUI Namespace


m_size Field

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..m_size Field
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceAttributes.m_size"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Size2dU m_size
Visual Basic
Protected m_size As Size2dU
Visual C++
protected:
Size2dU^ m_size

See Also

ResourceAttributes Class
ElGUI Namespace


m_vert_align Field

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..m_vert_align Field
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceAttributes.m_vert_align"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ALIGNMENT_KEY m_vert_align
Visual Basic
Public m_vert_align As ALIGNMENT_KEY
Visual C++
public:
ALIGNMENT_KEY m_vert_align

See Also

ResourceAttributes Class
ElGUI Namespace


ResourceAttributes Methods

[image] [image]

4 of William Foster's Class Libraries
ResourceAttributes Methods
ResourceAttributes Class See Also Send Feedback

The ResourceAttributes type exposes the following members.

Methods

 | Name | Description
Protected method | ConvertAttributeKeyToFlag |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeFlags |
Public method | GetGroup |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHotkey |
Public method | GetName |
Public method | GetPosition |
Public method | GetSize |
Public method | GetText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAttribute |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttribute |
Public method | SetAttributeFlags |
Public method | SetGroup |
Public method | SetHotkey |
Public method | SetName |
Public method | SetShape |
Public method | SetSize |
Public method | SetText |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnsetAttribute |
Public method | UnsetAttributeFlags |

See Also

ResourceAttributes Class
ElGUI Namespace


ConvertAttributeKeyToFlag Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..ConvertAttributeKeyToFlag Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.ConvertAttributeKeyToFlag(ElGUI.EBFC_GUIRES_ATTRIBUTE_KEY)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected uint ConvertAttributeKeyToFlag(
    EBFC_GUIRES_ATTRIBUTE_KEY eKey
)
Visual Basic
Protected Function ConvertAttributeKeyToFlag ( _
    eKey As EBFC_GUIRES_ATTRIBUTE_KEY _
) As UInteger
Visual C++
protected:
unsigned int ConvertAttributeKeyToFlag(
    EBFC_GUIRES_ATTRIBUTE_KEY eKey
)

Parameters

eKey
Type: ElGUI..::..EBFC_GUIRES_ATTRIBUTE_KEY

[Missing <param name="eKey"/> documentation for "M:ElGUI.ResourceAttributes.ConvertAttributeKeyToFlag(ElGUI.EBFC_GUIRES_ATTRIBUTE_KEY)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceAttributes.ConvertAttributeKeyToFlag(ElGUI.EBFC_GUIRES_ATTRIBUTE_KEY)"]

See Also

ResourceAttributes Class
ElGUI Namespace


GetAttributeFlags Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..GetAttributeFlags Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.GetAttributeFlags"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ulong GetAttributeFlags()
Visual Basic
Public Function GetAttributeFlags As ULong
Visual C++
public:
unsigned long long GetAttributeFlags()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceAttributes.GetAttributeFlags"]

See Also

ResourceAttributes Class
ElGUI Namespace


GetGroup Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..GetGroup Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.GetGroup"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING GetGroup()
Visual Basic
Public Function GetGroup As STRING
Visual C++
public:
STRING^ GetGroup()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceAttributes.GetGroup"]

See Also

ResourceAttributes Class
ElGUI Namespace


GetHotkey Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..GetHotkey Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.GetHotkey(System.Char@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GetHotkey(
    out char cHot
)
Visual Basic
Public Function GetHotkey ( _
    <OutAttribute> ByRef cHot As Char _
) As Boolean
Visual C++
public:
bool GetHotkey(
    [OutAttribute] wchar_t% cHot
)

Parameters

cHot
Type: System..::..Char %

[Missing <param name="cHot"/> documentation for "M:ElGUI.ResourceAttributes.GetHotkey(System.Char@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceAttributes.GetHotkey(System.Char@)"]

See Also

ResourceAttributes Class
ElGUI Namespace


GetName Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..GetName Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.GetName(El.STRING@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void GetName(
    out STRING csName
)
Visual Basic
Public Sub GetName ( _
    <OutAttribute> ByRef csName As STRING _
)
Visual C++
public:
void GetName(
    [OutAttribute] STRING^% csName
)

Parameters

csName
Type: STRING%

[Missing <param name="csName"/> documentation for "M:ElGUI.ResourceAttributes.GetName(El.STRING@)"]

See Also

ResourceAttributes Class
ElGUI Namespace


GetPosition Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..GetPosition Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.GetPosition"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Size2dU GetPosition()
Visual Basic
Public Function GetPosition As Size2dU
Visual C++
public:
Size2dU^ GetPosition()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceAttributes.GetPosition"]

See Also

ResourceAttributes Class
ElGUI Namespace


GetSize Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..GetSize Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.GetSize"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Size2dU GetSize()
Visual Basic
Public Function GetSize As Size2dU
Visual C++
public:
Size2dU^ GetSize()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceAttributes.GetSize"]

See Also

ResourceAttributes Class
ElGUI Namespace


GetText Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..GetText Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.GetText(El.STRING@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void GetText(
    out STRING csText
)
Visual Basic
Public Sub GetText ( _
    <OutAttribute> ByRef csText As STRING _
)
Visual C++
public:
void GetText(
    [OutAttribute] STRING^% csText
)

Parameters

csText
Type: STRING%

[Missing <param name="csText"/> documentation for "M:ElGUI.ResourceAttributes.GetText(El.STRING@)"]

See Also

ResourceAttributes Class
ElGUI Namespace


HasAttribute Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..HasAttribute Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.HasAttribute(ElGUI.EBFC_GUIRES_ATTRIBUTE_KEY)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool HasAttribute(
    EBFC_GUIRES_ATTRIBUTE_KEY eKey
)
Visual Basic
Public Function HasAttribute ( _
    eKey As EBFC_GUIRES_ATTRIBUTE_KEY _
) As Boolean
Visual C++
public:
bool HasAttribute(
    EBFC_GUIRES_ATTRIBUTE_KEY eKey
)

Parameters

eKey
Type: ElGUI..::..EBFC_GUIRES_ATTRIBUTE_KEY

[Missing <param name="eKey"/> documentation for "M:ElGUI.ResourceAttributes.HasAttribute(ElGUI.EBFC_GUIRES_ATTRIBUTE_KEY)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceAttributes.HasAttribute(ElGUI.EBFC_GUIRES_ATTRIBUTE_KEY)"]

See Also

ResourceAttributes Class
ElGUI Namespace


SetAttribute Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..SetAttribute Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.SetAttribute(ElGUI.EBFC_GUIRES_ATTRIBUTE_KEY)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetAttribute(
    EBFC_GUIRES_ATTRIBUTE_KEY eKey
)
Visual Basic
Public Sub SetAttribute ( _
    eKey As EBFC_GUIRES_ATTRIBUTE_KEY _
)
Visual C++
public:
void SetAttribute(
    EBFC_GUIRES_ATTRIBUTE_KEY eKey
)

Parameters

eKey
Type: ElGUI..::..EBFC_GUIRES_ATTRIBUTE_KEY

[Missing <param name="eKey"/> documentation for "M:ElGUI.ResourceAttributes.SetAttribute(ElGUI.EBFC_GUIRES_ATTRIBUTE_KEY)"]

See Also

ResourceAttributes Class
ElGUI Namespace


SetAttributeFlags Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..SetAttributeFlags Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.SetAttributeFlags(System.UInt64)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetAttributeFlags(
    ulong flags
)
Visual Basic
Public Sub SetAttributeFlags ( _
    flags As ULong _
)
Visual C++
public:
void SetAttributeFlags(
    unsigned long long flags
)

Parameters

flags
Type: System..::..UInt64

[Missing <param name="flags"/> documentation for "M:ElGUI.ResourceAttributes.SetAttributeFlags(System.UInt64)"]

See Also

ResourceAttributes Class
ElGUI Namespace


SetGroup Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..SetGroup Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.SetGroup(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetGroup(
    STRING csGroup
)
Visual Basic
Public Sub SetGroup ( _
    csGroup As STRING _
)
Visual C++
public:
void SetGroup(
    STRING^ csGroup
)

Parameters

csGroup
Type: STRING

[Missing <param name="csGroup"/> documentation for "M:ElGUI.ResourceAttributes.SetGroup(El.STRING)"]

See Also

ResourceAttributes Class
ElGUI Namespace


SetHotkey Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..SetHotkey Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.SetHotkey(System.Char)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetHotkey(
    char cHot
)
Visual Basic
Public Sub SetHotkey ( _
    cHot As Char _
)
Visual C++
public:
void SetHotkey(
    wchar_t cHot
)

Parameters

cHot
Type: System..::..Char

[Missing <param name="cHot"/> documentation for "M:ElGUI.ResourceAttributes.SetHotkey(System.Char)"]

See Also

ResourceAttributes Class
ElGUI Namespace


SetName Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..SetName Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.SetName(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetName(
    STRING csName
)
Visual Basic
Public Sub SetName ( _
    csName As STRING _
)
Visual C++
public:
void SetName(
    STRING^ csName
)

Parameters

csName
Type: STRING

[Missing <param name="csName"/> documentation for "M:ElGUI.ResourceAttributes.SetName(El.STRING)"]

See Also

ResourceAttributes Class
ElGUI Namespace


SetShape Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..SetShape Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.SetShape(ElVector.Shape2d)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetShape(
    Shape2d shape
)
Visual Basic
Public Function SetShape ( _
    shape As Shape2d _
) As Boolean
Visual C++
public:
bool SetShape(
    Shape2d^ shape
)

Parameters

shape
Type: Shape2d

[Missing <param name="shape"/> documentation for "M:ElGUI.ResourceAttributes.SetShape(ElVector.Shape2d)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceAttributes.SetShape(ElVector.Shape2d)"]

See Also

ResourceAttributes Class
ElGUI Namespace


SetSize Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..SetSize Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.SetSize(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetSize(
    Size2dU size
)
Visual Basic
Public Sub SetSize ( _
    size As Size2dU _
)
Visual C++
public:
void SetSize(
    Size2dU^ size
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElGUI.ResourceAttributes.SetSize(El.Size2dU)"]

See Also

ResourceAttributes Class
ElGUI Namespace


SetText Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..SetText Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.SetText(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetText(
    STRING csText
)
Visual Basic
Public Sub SetText ( _
    csText As STRING _
)
Visual C++
public:
void SetText(
    STRING^ csText
)

Parameters

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.ResourceAttributes.SetText(El.STRING)"]

See Also

ResourceAttributes Class
ElGUI Namespace


UnsetAttribute Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..UnsetAttribute Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.UnsetAttribute(ElGUI.EBFC_GUIRES_ATTRIBUTE_KEY)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void UnsetAttribute(
    EBFC_GUIRES_ATTRIBUTE_KEY eKey
)
Visual Basic
Public Sub UnsetAttribute ( _
    eKey As EBFC_GUIRES_ATTRIBUTE_KEY _
)
Visual C++
public:
void UnsetAttribute(
    EBFC_GUIRES_ATTRIBUTE_KEY eKey
)

Parameters

eKey
Type: ElGUI..::..EBFC_GUIRES_ATTRIBUTE_KEY

[Missing <param name="eKey"/> documentation for "M:ElGUI.ResourceAttributes.UnsetAttribute(ElGUI.EBFC_GUIRES_ATTRIBUTE_KEY)"]

See Also

ResourceAttributes Class
ElGUI Namespace


UnsetAttributeFlags Method

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..UnsetAttributeFlags Method
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceAttributes.UnsetAttributeFlags(System.UInt64)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void UnsetAttributeFlags(
    ulong flags
)
Visual Basic
Public Sub UnsetAttributeFlags ( _
    flags As ULong _
)
Visual C++
public:
void UnsetAttributeFlags(
    unsigned long long flags
)

Parameters

flags
Type: System..::..UInt64

[Missing <param name="flags"/> documentation for "M:ElGUI.ResourceAttributes.UnsetAttributeFlags(System.UInt64)"]

See Also

ResourceAttributes Class
ElGUI Namespace


ResourceAttributes Properties

[image] [image]

4 of William Foster's Class Libraries
ResourceAttributes Properties
ResourceAttributes Class See Also Send Feedback

The ResourceAttributes type exposes the following members.

Properties

 | Name | Description
Public property | Range |

See Also

ResourceAttributes Class
ElGUI Namespace


Range Property

[image]

4 of William Foster's Class Libraries
ResourceAttributes..::..Range Property
ResourceAttributes Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.ResourceAttributes.Range"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Range2d Range { get; set; }
Visual Basic
Public Property Range As Range2d
    Get
    Set
Visual C++
public:
property Range2d^ Range {
    Range2d^ get ();
    void set (Range2d^ value);
}

See Also

ResourceAttributes Class
ElGUI Namespace


ResourceContainer Class

[image]

4 of William Foster's Class Libraries
ResourceContainer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ResourceContainer"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ResourceContainer : ResourceEntity
Visual Basic
Public Class ResourceContainer _
    Inherits ResourceEntity
Visual C++
public ref class ResourceContainer : public ResourceEntity

Inheritance Hierarchy

System..::..Object
ElGUI..::..ResourceAttributes
ElGUI..::..ResourceEntity
ElGUI..::..ResourceContainer

See Also

ResourceContainer Members
ElGUI Namespace


ResourceContainer Members

[image] [image]

4 of William Foster's Class Libraries
ResourceContainer Members
ResourceContainer Class Constructors Methods Fields Properties See Also Send Feedback

The ResourceContainer type exposes the following members.

Constructors

 | Name | Description
Public method | ResourceContainer | Initializes a new instance of the ResourceContainer class

Methods

 | Name | Description
Public method | AddHandler | (Inherited from ResourceEntity.)
Public method | AddResourceContainer |
Public method | AddResourceEntity |
Protected method | ConvertAttributeKeyToFlag | (Inherited from ResourceAttributes.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeFlags | (Inherited from ResourceAttributes.)
Public method | GetEntityList |
Public method | GetGroup | (Inherited from ResourceAttributes.)
Public method | GetHandlerList | (Inherited from ResourceEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHotkey | (Inherited from ResourceAttributes.)
Public method | GetName | (Inherited from ResourceAttributes.)
Public method | GetPosition | (Inherited from ResourceAttributes.)
Public method | GetResourceID | (Inherited from ResourceEntity.)
Public method | GetResourceType | (Inherited from ResourceEntity.)
Public method | GetSize | (Inherited from ResourceAttributes.)
Public method | GetText | (Inherited from ResourceAttributes.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAttribute | (Inherited from ResourceAttributes.)
Public method | HasHandlers | (Inherited from ResourceEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttribute | (Inherited from ResourceAttributes.)
Public method | SetAttributeFlags | (Inherited from ResourceAttributes.)
Public method | SetGroup | (Inherited from ResourceAttributes.)
Public method | SetHotkey | (Inherited from ResourceAttributes.)
Public method | SetName | (Inherited from ResourceAttributes.)
Public method | SetParent | (Inherited from ResourceEntity.)
Public method | SetShape | (Inherited from ResourceAttributes.)
Public method | SetSize | (Inherited from ResourceAttributes.)
Public method | SetText | (Inherited from ResourceAttributes.)
Public method | SetType | (Inherited from ResourceEntity.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnsetAttribute | (Inherited from ResourceAttributes.)
Public method | UnsetAttributeFlags | (Inherited from ResourceAttributes.)

Fields

 | Name | Description
Protected field | m_attribute_flags | (Inherited from ResourceAttributes.)
Protected field | m_cHotkey | (Inherited from ResourceAttributes.)
Public field | m_cs_bindfieldReflect | (Inherited from ResourceAttributes.)
Public field | m_cs_bindto | (Inherited from ResourceAttributes.)
Public field | m_cs_group | (Inherited from ResourceAttributes.)
Public field | m_cs_name | (Inherited from ResourceAttributes.)
Public field | m_cs_text | (Inherited from ResourceAttributes.)
Public field | m_horz_align | (Inherited from ResourceAttributes.)
Public field | m_Parent_ID | (Inherited from ResourceEntity.)
Public field | m_position | (Inherited from ResourceAttributes.)
Protected field | m_range | (Inherited from ResourceAttributes.)
Public field | m_Resource_ID | (Inherited from ResourceEntity.)
Protected field | m_ResourceHandlerList | (Inherited from ResourceEntity.)
Protected field | m_ResourceType | (Inherited from ResourceEntity.)
Protected field | m_shape | (Inherited from ResourceAttributes.)
Protected field | m_size | (Inherited from ResourceAttributes.)
Public field | m_vert_align | (Inherited from ResourceAttributes.)

Properties

 | Name | Description
Public property | Range | (Inherited from ResourceAttributes.)

See Also

ResourceContainer Class
ElGUI Namespace


ResourceContainer Constructor

[image]

4 of William Foster's Class Libraries
ResourceContainer Constructor
ResourceContainer Class See Also Send Feedback
Initializes a new instance of the ResourceContainer class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceContainer(
    Resource_ID ID
)
Visual Basic
Public Sub New ( _
    ID As Resource_ID _
)
Visual C++
public:
ResourceContainer(
    Resource_ID ID
)

Parameters

ID
Type: ElGUI..::..Resource_ID

[Missing <param name="ID"/> documentation for "M:ElGUI.ResourceContainer.#ctor(ElGUI.Resource_ID)"]

See Also

ResourceContainer Class
ElGUI Namespace


ResourceContainer Fields

[image] [image]

4 of William Foster's Class Libraries
ResourceContainer Fields
ResourceContainer Class See Also Send Feedback

The ResourceContainer type exposes the following members.

Fields

 | Name | Description
Protected field | m_attribute_flags | (Inherited from ResourceAttributes.)
Protected field | m_cHotkey | (Inherited from ResourceAttributes.)
Public field | m_cs_bindfieldReflect | (Inherited from ResourceAttributes.)
Public field | m_cs_bindto | (Inherited from ResourceAttributes.)
Public field | m_cs_group | (Inherited from ResourceAttributes.)
Public field | m_cs_name | (Inherited from ResourceAttributes.)
Public field | m_cs_text | (Inherited from ResourceAttributes.)
Public field | m_horz_align | (Inherited from ResourceAttributes.)
Public field | m_Parent_ID | (Inherited from ResourceEntity.)
Public field | m_position | (Inherited from ResourceAttributes.)
Protected field | m_range | (Inherited from ResourceAttributes.)
Public field | m_Resource_ID | (Inherited from ResourceEntity.)
Protected field | m_ResourceHandlerList | (Inherited from ResourceEntity.)
Protected field | m_ResourceType | (Inherited from ResourceEntity.)
Protected field | m_shape | (Inherited from ResourceAttributes.)
Protected field | m_size | (Inherited from ResourceAttributes.)
Public field | m_vert_align | (Inherited from ResourceAttributes.)

See Also

ResourceContainer Class
ElGUI Namespace


ResourceContainer Methods

[image] [image]

4 of William Foster's Class Libraries
ResourceContainer Methods
ResourceContainer Class See Also Send Feedback

The ResourceContainer type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | (Inherited from ResourceEntity.)
Public method | AddResourceContainer |
Public method | AddResourceEntity |
Protected method | ConvertAttributeKeyToFlag | (Inherited from ResourceAttributes.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeFlags | (Inherited from ResourceAttributes.)
Public method | GetEntityList |
Public method | GetGroup | (Inherited from ResourceAttributes.)
Public method | GetHandlerList | (Inherited from ResourceEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHotkey | (Inherited from ResourceAttributes.)
Public method | GetName | (Inherited from ResourceAttributes.)
Public method | GetPosition | (Inherited from ResourceAttributes.)
Public method | GetResourceID | (Inherited from ResourceEntity.)
Public method | GetResourceType | (Inherited from ResourceEntity.)
Public method | GetSize | (Inherited from ResourceAttributes.)
Public method | GetText | (Inherited from ResourceAttributes.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAttribute | (Inherited from ResourceAttributes.)
Public method | HasHandlers | (Inherited from ResourceEntity.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttribute | (Inherited from ResourceAttributes.)
Public method | SetAttributeFlags | (Inherited from ResourceAttributes.)
Public method | SetGroup | (Inherited from ResourceAttributes.)
Public method | SetHotkey | (Inherited from ResourceAttributes.)
Public method | SetName | (Inherited from ResourceAttributes.)
Public method | SetParent | (Inherited from ResourceEntity.)
Public method | SetShape | (Inherited from ResourceAttributes.)
Public method | SetSize | (Inherited from ResourceAttributes.)
Public method | SetText | (Inherited from ResourceAttributes.)
Public method | SetType | (Inherited from ResourceEntity.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnsetAttribute | (Inherited from ResourceAttributes.)
Public method | UnsetAttributeFlags | (Inherited from ResourceAttributes.)

See Also

ResourceContainer Class
ElGUI Namespace


AddResourceContainer Method

[image]

4 of William Foster's Class Libraries
ResourceContainer..::..AddResourceContainer Method
ResourceContainer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceContainer.AddResourceContainer(ElGUI.ResourceContainer)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AddResourceContainer(
    ResourceContainer rc
)
Visual Basic
Public Function AddResourceContainer ( _
    rc As ResourceContainer _
) As Boolean
Visual C++
public:
bool AddResourceContainer(
    ResourceContainer^ rc
)

Parameters

rc
Type: ElGUI..::..ResourceContainer

[Missing <param name="rc"/> documentation for "M:ElGUI.ResourceContainer.AddResourceContainer(ElGUI.ResourceContainer)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceContainer.AddResourceContainer(ElGUI.ResourceContainer)"]

See Also

ResourceContainer Class
ElGUI Namespace


AddResourceEntity Method

[image]

4 of William Foster's Class Libraries
ResourceContainer..::..AddResourceEntity Method
ResourceContainer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceContainer.AddResourceEntity(ElGUI.ResourceEntity)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AddResourceEntity(
    ResourceEntity resourceEntity
)
Visual Basic
Public Function AddResourceEntity ( _
    resourceEntity As ResourceEntity _
) As Boolean
Visual C++
public:
bool AddResourceEntity(
    ResourceEntity^ resourceEntity
)

Parameters

resourceEntity
Type: ElGUI..::..ResourceEntity

[Missing <param name="resourceEntity"/> documentation for "M:ElGUI.ResourceContainer.AddResourceEntity(ElGUI.ResourceEntity)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceContainer.AddResourceEntity(ElGUI.ResourceEntity)"]

See Also

ResourceContainer Class
ElGUI Namespace


GetEntityList Method

[image]

4 of William Foster's Class Libraries
ResourceContainer..::..GetEntityList Method
ResourceContainer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceContainer.GetEntityList"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Array<ResourceEntity> GetEntityList()
Visual Basic
Public Function GetEntityList As Array(Of ResourceEntity)
Visual C++
public:
Array<ResourceEntity^>^ GetEntityList()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceContainer.GetEntityList"]

See Also

ResourceContainer Class
ElGUI Namespace


ResourceContainer Properties

[image] [image]

4 of William Foster's Class Libraries
ResourceContainer Properties
ResourceContainer Class See Also Send Feedback

The ResourceContainer type exposes the following members.

Properties

 | Name | Description
Public property | Range | (Inherited from ResourceAttributes.)

See Also

ResourceContainer Class
ElGUI Namespace


ResourceEntity Class

[image]

4 of William Foster's Class Libraries
ResourceEntity Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ResourceEntity"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ResourceEntity : ResourceAttributes
Visual Basic
Public Class ResourceEntity _
    Inherits ResourceAttributes
Visual C++
public ref class ResourceEntity : public ResourceAttributes

Inheritance Hierarchy

System..::..Object
ElGUI..::..ResourceAttributes
ElGUI..::..ResourceEntity
ElGUI..::..ResourceContainer

See Also

ResourceEntity Members
ElGUI Namespace


ResourceEntity Members

[image] [image]

4 of William Foster's Class Libraries
ResourceEntity Members
ResourceEntity Class Constructors Methods Fields Properties See Also Send Feedback

The ResourceEntity type exposes the following members.

Constructors

 | Name | Description
Public method | ResourceEntity | Initializes a new instance of the ResourceEntity class

Methods

 | Name | Description
Public method | AddHandler |
Protected method | ConvertAttributeKeyToFlag | (Inherited from ResourceAttributes.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeFlags | (Inherited from ResourceAttributes.)
Public method | GetGroup | (Inherited from ResourceAttributes.)
Public method | GetHandlerList |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHotkey | (Inherited from ResourceAttributes.)
Public method | GetName | (Inherited from ResourceAttributes.)
Public method | GetPosition | (Inherited from ResourceAttributes.)
Public method | GetResourceID |
Public method | GetResourceType |
Public method | GetSize | (Inherited from ResourceAttributes.)
Public method | GetText | (Inherited from ResourceAttributes.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAttribute | (Inherited from ResourceAttributes.)
Public method | HasHandlers |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttribute | (Inherited from ResourceAttributes.)
Public method | SetAttributeFlags | (Inherited from ResourceAttributes.)
Public method | SetGroup | (Inherited from ResourceAttributes.)
Public method | SetHotkey | (Inherited from ResourceAttributes.)
Public method | SetName | (Inherited from ResourceAttributes.)
Public method | SetParent |
Public method | SetShape | (Inherited from ResourceAttributes.)
Public method | SetSize | (Inherited from ResourceAttributes.)
Public method | SetText | (Inherited from ResourceAttributes.)
Public method | SetType |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnsetAttribute | (Inherited from ResourceAttributes.)
Public method | UnsetAttributeFlags | (Inherited from ResourceAttributes.)

Fields

 | Name | Description
Protected field | m_attribute_flags | (Inherited from ResourceAttributes.)
Protected field | m_cHotkey | (Inherited from ResourceAttributes.)
Public field | m_cs_bindfieldReflect | (Inherited from ResourceAttributes.)
Public field | m_cs_bindto | (Inherited from ResourceAttributes.)
Public field | m_cs_group | (Inherited from ResourceAttributes.)
Public field | m_cs_name | (Inherited from ResourceAttributes.)
Public field | m_cs_text | (Inherited from ResourceAttributes.)
Public field | m_horz_align | (Inherited from ResourceAttributes.)
Public field | m_Parent_ID |
Public field | m_position | (Inherited from ResourceAttributes.)
Protected field | m_range | (Inherited from ResourceAttributes.)
Public field | m_Resource_ID |
Protected field | m_ResourceHandlerList |
Protected field | m_ResourceType |
Protected field | m_shape | (Inherited from ResourceAttributes.)
Protected field | m_size | (Inherited from ResourceAttributes.)
Public field | m_vert_align | (Inherited from ResourceAttributes.)

Properties

 | Name | Description
Public property | Range | (Inherited from ResourceAttributes.)

See Also

ResourceEntity Class
ElGUI Namespace


ResourceEntity Constructor

[image]

4 of William Foster's Class Libraries
ResourceEntity Constructor
ResourceEntity Class See Also Send Feedback
Initializes a new instance of the ResourceEntity class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceEntity(
    Resource_ID ID
)
Visual Basic
Public Sub New ( _
    ID As Resource_ID _
)
Visual C++
public:
ResourceEntity(
    Resource_ID ID
)

Parameters

ID
Type: ElGUI..::..Resource_ID

[Missing <param name="ID"/> documentation for "M:ElGUI.ResourceEntity.#ctor(ElGUI.Resource_ID)"]

See Also

ResourceEntity Class
ElGUI Namespace


ResourceEntity Fields

[image] [image]

4 of William Foster's Class Libraries
ResourceEntity Fields
ResourceEntity Class See Also Send Feedback

The ResourceEntity type exposes the following members.

Fields

 | Name | Description
Protected field | m_attribute_flags | (Inherited from ResourceAttributes.)
Protected field | m_cHotkey | (Inherited from ResourceAttributes.)
Public field | m_cs_bindfieldReflect | (Inherited from ResourceAttributes.)
Public field | m_cs_bindto | (Inherited from ResourceAttributes.)
Public field | m_cs_group | (Inherited from ResourceAttributes.)
Public field | m_cs_name | (Inherited from ResourceAttributes.)
Public field | m_cs_text | (Inherited from ResourceAttributes.)
Public field | m_horz_align | (Inherited from ResourceAttributes.)
Public field | m_Parent_ID |
Public field | m_position | (Inherited from ResourceAttributes.)
Protected field | m_range | (Inherited from ResourceAttributes.)
Public field | m_Resource_ID |
Protected field | m_ResourceHandlerList |
Protected field | m_ResourceType |
Protected field | m_shape | (Inherited from ResourceAttributes.)
Protected field | m_size | (Inherited from ResourceAttributes.)
Public field | m_vert_align | (Inherited from ResourceAttributes.)

See Also

ResourceEntity Class
ElGUI Namespace


m_Parent_ID Field

[image]

4 of William Foster's Class Libraries
ResourceEntity..::..m_Parent_ID Field
ResourceEntity Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceEntity.m_Parent_ID"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Resource_ID m_Parent_ID
Visual Basic
Public m_Parent_ID As Resource_ID
Visual C++
public:
Resource_ID m_Parent_ID

See Also

ResourceEntity Class
ElGUI Namespace


m_Resource_ID Field

[image]

4 of William Foster's Class Libraries
ResourceEntity..::..m_Resource_ID Field
ResourceEntity Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceEntity.m_Resource_ID"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Resource_ID m_Resource_ID
Visual Basic
Public m_Resource_ID As Resource_ID
Visual C++
public:
Resource_ID m_Resource_ID

See Also

ResourceEntity Class
ElGUI Namespace


m_ResourceHandlerList Field

[image]

4 of William Foster's Class Libraries
ResourceEntity..::..m_ResourceHandlerList Field
ResourceEntity Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceEntity.m_ResourceHandlerList"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Array<ResourceHandler> m_ResourceHandlerList
Visual Basic
Protected m_ResourceHandlerList As Array(Of ResourceHandler)
Visual C++
protected:
Array<ResourceHandler^>^ m_ResourceHandlerList

See Also

ResourceEntity Class
ElGUI Namespace


m_ResourceType Field

[image]

4 of William Foster's Class Libraries
ResourceEntity..::..m_ResourceType Field
ResourceEntity Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceEntity.m_ResourceType"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected EBFC_GUIRES_RESOURCE_KEY m_ResourceType
Visual Basic
Protected m_ResourceType As EBFC_GUIRES_RESOURCE_KEY
Visual C++
protected:
EBFC_GUIRES_RESOURCE_KEY m_ResourceType

See Also

ResourceEntity Class
ElGUI Namespace


ResourceEntity Methods

[image] [image]

4 of William Foster's Class Libraries
ResourceEntity Methods
ResourceEntity Class See Also Send Feedback

The ResourceEntity type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler |
Protected method | ConvertAttributeKeyToFlag | (Inherited from ResourceAttributes.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeFlags | (Inherited from ResourceAttributes.)
Public method | GetGroup | (Inherited from ResourceAttributes.)
Public method | GetHandlerList |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHotkey | (Inherited from ResourceAttributes.)
Public method | GetName | (Inherited from ResourceAttributes.)
Public method | GetPosition | (Inherited from ResourceAttributes.)
Public method | GetResourceID |
Public method | GetResourceType |
Public method | GetSize | (Inherited from ResourceAttributes.)
Public method | GetText | (Inherited from ResourceAttributes.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasAttribute | (Inherited from ResourceAttributes.)
Public method | HasHandlers |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAttribute | (Inherited from ResourceAttributes.)
Public method | SetAttributeFlags | (Inherited from ResourceAttributes.)
Public method | SetGroup | (Inherited from ResourceAttributes.)
Public method | SetHotkey | (Inherited from ResourceAttributes.)
Public method | SetName | (Inherited from ResourceAttributes.)
Public method | SetParent |
Public method | SetShape | (Inherited from ResourceAttributes.)
Public method | SetSize | (Inherited from ResourceAttributes.)
Public method | SetText | (Inherited from ResourceAttributes.)
Public method | SetType |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnsetAttribute | (Inherited from ResourceAttributes.)
Public method | UnsetAttributeFlags | (Inherited from ResourceAttributes.)

See Also

ResourceEntity Class
ElGUI Namespace


AddHandler Method

[image]

4 of William Foster's Class Libraries
ResourceEntity..::..AddHandler Method
ResourceEntity Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceEntity.AddHandler(ElGUI.ResourceHandler)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddHandler(
    ResourceHandler rh
)
Visual Basic
Public Sub AddHandler ( _
    rh As ResourceHandler _
)
Visual C++
public:
void AddHandler(
    ResourceHandler^ rh
)

Parameters

rh
Type: ElGUI..::..ResourceHandler

[Missing <param name="rh"/> documentation for "M:ElGUI.ResourceEntity.AddHandler(ElGUI.ResourceHandler)"]

See Also

ResourceEntity Class
ElGUI Namespace


GetHandlerList Method

[image]

4 of William Foster's Class Libraries
ResourceEntity..::..GetHandlerList Method
ResourceEntity Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceEntity.GetHandlerList"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Array<ResourceHandler> GetHandlerList()
Visual Basic
Public Function GetHandlerList As Array(Of ResourceHandler)
Visual C++
public:
Array<ResourceHandler^>^ GetHandlerList()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceEntity.GetHandlerList"]

See Also

ResourceEntity Class
ElGUI Namespace


GetResourceID Method

[image]

4 of William Foster's Class Libraries
ResourceEntity..::..GetResourceID Method
ResourceEntity Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceEntity.GetResourceID"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Resource_ID GetResourceID()
Visual Basic
Public Function GetResourceID As Resource_ID
Visual C++
public:
Resource_ID GetResourceID()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceEntity.GetResourceID"]

See Also

ResourceEntity Class
ElGUI Namespace


GetResourceType Method

[image]

4 of William Foster's Class Libraries
ResourceEntity..::..GetResourceType Method
ResourceEntity Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceEntity.GetResourceType"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public EBFC_GUIRES_RESOURCE_KEY GetResourceType()
Visual Basic
Public Function GetResourceType As EBFC_GUIRES_RESOURCE_KEY
Visual C++
public:
EBFC_GUIRES_RESOURCE_KEY GetResourceType()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceEntity.GetResourceType"]

See Also

ResourceEntity Class
ElGUI Namespace


HasHandlers Method

[image]

4 of William Foster's Class Libraries
ResourceEntity..::..HasHandlers Method
ResourceEntity Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceEntity.HasHandlers"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool HasHandlers()
Visual Basic
Public Function HasHandlers As Boolean
Visual C++
public:
bool HasHandlers()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceEntity.HasHandlers"]

See Also

ResourceEntity Class
ElGUI Namespace


SetParent Method

[image]

4 of William Foster's Class Libraries
ResourceEntity..::..SetParent Method
ResourceEntity Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceEntity.SetParent(ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetParent(
    Resource_ID parentID
)
Visual Basic
Public Sub SetParent ( _
    parentID As Resource_ID _
)
Visual C++
public:
void SetParent(
    Resource_ID parentID
)

Parameters

parentID
Type: ElGUI..::..Resource_ID

[Missing <param name="parentID"/> documentation for "M:ElGUI.ResourceEntity.SetParent(ElGUI.Resource_ID)"]

See Also

ResourceEntity Class
ElGUI Namespace


SetType Method

[image]

4 of William Foster's Class Libraries
ResourceEntity..::..SetType Method
ResourceEntity Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceEntity.SetType(ElGUI.EBFC_GUIRES_RESOURCE_KEY)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetType(
    EBFC_GUIRES_RESOURCE_KEY eKey
)
Visual Basic
Public Sub SetType ( _
    eKey As EBFC_GUIRES_RESOURCE_KEY _
)
Visual C++
public:
void SetType(
    EBFC_GUIRES_RESOURCE_KEY eKey
)

Parameters

eKey
Type: ElGUI..::..EBFC_GUIRES_RESOURCE_KEY

[Missing <param name="eKey"/> documentation for "M:ElGUI.ResourceEntity.SetType(ElGUI.EBFC_GUIRES_RESOURCE_KEY)"]

See Also

ResourceEntity Class
ElGUI Namespace


ResourceEntity Properties

[image] [image]

4 of William Foster's Class Libraries
ResourceEntity Properties
ResourceEntity Class See Also Send Feedback

The ResourceEntity type exposes the following members.

Properties

 | Name | Description
Public property | Range | (Inherited from ResourceAttributes.)

See Also

ResourceEntity Class
ElGUI Namespace


ResourceEvent Class

[image]

4 of William Foster's Class Libraries
ResourceEvent Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ResourceEvent"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ResourceEvent
Visual Basic
Public Class ResourceEvent
Visual C++
public ref class ResourceEvent

Inheritance Hierarchy

System..::..Object
ElGUI..::..ResourceEvent
ElGUI..::..ResourceHandler

See Also

ResourceEvent Members
ElGUI Namespace


ResourceEvent Members

[image] [image]

4 of William Foster's Class Libraries
ResourceEvent Members
ResourceEvent Class Constructors Methods See Also Send Feedback

The ResourceEvent type exposes the following members.

Constructors

 | Name | Description
Public method | ResourceEvent | Initializes a new instance of the ResourceEvent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEvent |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameter |
Public method | GetTarget |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessPhrase |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResourceEvent Class
ElGUI Namespace


ResourceEvent Constructor

[image]

4 of William Foster's Class Libraries
ResourceEvent Constructor
ResourceEvent Class See Also Send Feedback
Initializes a new instance of the ResourceEvent class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceEvent(
    ResourceEvent..::..EVENT eEvent,
    STRING csPhrase
)
Visual Basic
Public Sub New ( _
    eEvent As ResourceEvent..::..EVENT, _
    csPhrase As STRING _
)
Visual C++
public:
ResourceEvent(
    ResourceEvent..::..EVENT eEvent,
    STRING^ csPhrase
)

Parameters

eEvent
Type: ElGUI..::..ResourceEvent..::..EVENT

[Missing <param name="eEvent"/> documentation for "M:ElGUI.ResourceEvent.#ctor(ElGUI.ResourceEvent.EVENT,El.STRING)"]

csPhrase
Type: STRING

[Missing <param name="csPhrase"/> documentation for "M:ElGUI.ResourceEvent.#ctor(ElGUI.ResourceEvent.EVENT,El.STRING)"]

See Also

ResourceEvent Class
ElGUI Namespace


ResourceEvent Methods

[image] [image]

4 of William Foster's Class Libraries
ResourceEvent Methods
ResourceEvent Class See Also Send Feedback

The ResourceEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEvent |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameter |
Public method | GetTarget |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessPhrase |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResourceEvent Class
ElGUI Namespace


GetEvent Method

[image]

4 of William Foster's Class Libraries
ResourceEvent..::..GetEvent Method
ResourceEvent Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceEvent.GetEvent"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceEvent..::..EVENT GetEvent()
Visual Basic
Public Function GetEvent As ResourceEvent..::..EVENT
Visual C++
public:
ResourceEvent..::..EVENT GetEvent()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceEvent.GetEvent"]

See Also

ResourceEvent Class
ElGUI Namespace


GetParameter Method

[image]

4 of William Foster's Class Libraries
ResourceEvent..::..GetParameter Method
ResourceEvent Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceEvent.GetParameter"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint GetParameter()
Visual Basic
Public Function GetParameter As UInteger
Visual C++
public:
unsigned int GetParameter()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceEvent.GetParameter"]

See Also

ResourceEvent Class
ElGUI Namespace


GetTarget Method

[image]

4 of William Foster's Class Libraries
ResourceEvent..::..GetTarget Method
ResourceEvent Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceEvent.GetTarget"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Resource_ID GetTarget()
Visual Basic
Public Function GetTarget As Resource_ID
Visual C++
public:
Resource_ID GetTarget()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceEvent.GetTarget"]

See Also

ResourceEvent Class
ElGUI Namespace


ProcessPhrase Method

[image]

4 of William Foster's Class Libraries
ResourceEvent..::..ProcessPhrase Method
ResourceEvent Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceEvent.ProcessPhrase(ElGUI.ResourceStore)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ProcessPhrase(
    ResourceStore RStore
)
Visual Basic
Public Function ProcessPhrase ( _
    RStore As ResourceStore _
) As Boolean
Visual C++
public:
bool ProcessPhrase(
    ResourceStore^ RStore
)

Parameters

RStore
Type: ElGUI..::..ResourceStore

[Missing <param name="RStore"/> documentation for "M:ElGUI.ResourceEvent.ProcessPhrase(ElGUI.ResourceStore)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceEvent.ProcessPhrase(ElGUI.ResourceStore)"]

See Also

ResourceEvent Class
ElGUI Namespace


ResourceEvent.EVENT Enumeration

[image]

4 of William Foster's Class Libraries
ResourceEvent..::..EVENT Enumeration
ResourceEvent Class See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ResourceEvent.EVENT"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum EVENT
Visual Basic
Public Enumeration EVENT
Visual C++
public enum class EVENT

Members

Member name | Value | Description
EVENT_SWITCH | 0 |
EVENT_ENDMODAL | 1 |

See Also

ElGUI Namespace


ResourceHandler Class

[image]

4 of William Foster's Class Libraries
ResourceHandler Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ResourceHandler"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ResourceHandler : ResourceEvent
Visual Basic
Public Class ResourceHandler _
    Inherits ResourceEvent
Visual C++
public ref class ResourceHandler : public ResourceEvent

Inheritance Hierarchy

System..::..Object
ElGUI..::..ResourceEvent
ElGUI..::..ResourceHandler

See Also

ResourceHandler Members
ElGUI Namespace


ResourceHandler Members

[image] [image]

4 of William Foster's Class Libraries
ResourceHandler Members
ResourceHandler Class Constructors Methods See Also Send Feedback

The ResourceHandler type exposes the following members.

Constructors

 | Name | Description
Public method | ResourceHandler | Initializes a new instance of the ResourceHandler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEvent | (Inherited from ResourceEvent.)
Public method | GetHandlerKey |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameter | (Inherited from ResourceEvent.)
Public method | GetTarget | (Inherited from ResourceEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessPhrase | (Inherited from ResourceEvent.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResourceHandler Class
ElGUI Namespace


ResourceHandler Constructor

[image]

4 of William Foster's Class Libraries
ResourceHandler Constructor
ResourceHandler Class See Also Send Feedback
Initializes a new instance of the ResourceHandler class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceHandler(
    EBFC_GUIRES_HANDLER_KEY eKey,
    ResourceEvent..::..EVENT eEvent,
    STRING csPhrase
)
Visual Basic
Public Sub New ( _
    eKey As EBFC_GUIRES_HANDLER_KEY, _
    eEvent As ResourceEvent..::..EVENT, _
    csPhrase As STRING _
)
Visual C++
public:
ResourceHandler(
    EBFC_GUIRES_HANDLER_KEY eKey,
    ResourceEvent..::..EVENT eEvent,
    STRING^ csPhrase
)

Parameters

eKey
Type: ElGUI..::..EBFC_GUIRES_HANDLER_KEY

[Missing <param name="eKey"/> documentation for "M:ElGUI.ResourceHandler.#ctor(ElGUI.EBFC_GUIRES_HANDLER_KEY,ElGUI.ResourceEvent.EVENT,El.STRING)"]

eEvent
Type: ElGUI..::..ResourceEvent..::..EVENT

[Missing <param name="eEvent"/> documentation for "M:ElGUI.ResourceHandler.#ctor(ElGUI.EBFC_GUIRES_HANDLER_KEY,ElGUI.ResourceEvent.EVENT,El.STRING)"]

csPhrase
Type: STRING

[Missing <param name="csPhrase"/> documentation for "M:ElGUI.ResourceHandler.#ctor(ElGUI.EBFC_GUIRES_HANDLER_KEY,ElGUI.ResourceEvent.EVENT,El.STRING)"]

See Also

ResourceHandler Class
ElGUI Namespace


ResourceHandler Methods

[image] [image]

4 of William Foster's Class Libraries
ResourceHandler Methods
ResourceHandler Class See Also Send Feedback

The ResourceHandler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEvent | (Inherited from ResourceEvent.)
Public method | GetHandlerKey |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameter | (Inherited from ResourceEvent.)
Public method | GetTarget | (Inherited from ResourceEvent.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessPhrase | (Inherited from ResourceEvent.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResourceHandler Class
ElGUI Namespace


GetHandlerKey Method

[image]

4 of William Foster's Class Libraries
ResourceHandler..::..GetHandlerKey Method
ResourceHandler Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceHandler.GetHandlerKey"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public EBFC_GUIRES_HANDLER_KEY GetHandlerKey()
Visual Basic
Public Function GetHandlerKey As EBFC_GUIRES_HANDLER_KEY
Visual C++
public:
EBFC_GUIRES_HANDLER_KEY GetHandlerKey()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceHandler.GetHandlerKey"]

See Also

ResourceHandler Class
ElGUI Namespace


ResourceStore Class

[image]

4 of William Foster's Class Libraries
ResourceStore Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ResourceStore"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ResourceStore
Visual Basic
Public Class ResourceStore
Visual C++
public ref class ResourceStore

Inheritance Hierarchy

System..::..Object
ElGUI..::..ResourceStore

See Also

ResourceStore Members
ElGUI Namespace


ResourceStore Members

[image] [image]

4 of William Foster's Class Libraries
ResourceStore Members
ResourceStore Class Constructors Methods Fields See Also Send Feedback

The ResourceStore type exposes the following members.

Constructors

 | Name | Description
Public method | ResourceStore | Initializes a new instance of the ResourceStore class

Methods

 | Name | Description
Public method | AddResourceContainer |
Public method | AddResourceEntity |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadString(STRING, STRING%) |
Public method | LoadString(Resource_ID, STRING%) |
Public method | LookupResourceContainer |
Public method | LookupResourceEntity(STRING, Resource_ID) |
 | LookupResourceEntity(STRING, Array<(Of <<'(ResourceEntity>)>>), Resource_ID) |
Public method | LookupResourceID |
Public method | LookupResourceName(STRING%, Resource_ID, Resource_ID) |
 | LookupResourceName(STRING%, Array<(Of <<'(ResourceEntity>)>>), Resource_ID, Resource_ID) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PostLoad |
Public method | SetName |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_resourceContainerList |

See Also

ResourceStore Class
ElGUI Namespace


ResourceStore Constructor

[image]

4 of William Foster's Class Libraries
ResourceStore Constructor
ResourceStore Class See Also Send Feedback
Initializes a new instance of the ResourceStore class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceStore()
Visual Basic
Public Sub New
Visual C++
public:
ResourceStore()

See Also

ResourceStore Class
ElGUI Namespace


ResourceStore Fields

[image] [image]

4 of William Foster's Class Libraries
ResourceStore Fields
ResourceStore Class See Also Send Feedback

The ResourceStore type exposes the following members.

Fields

 | Name | Description
Public field | m_resourceContainerList |

See Also

ResourceStore Class
ElGUI Namespace


m_resourceContainerList Field

[image]

4 of William Foster's Class Libraries
ResourceStore..::..m_resourceContainerList Field
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceStore.m_resourceContainerList"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Array<ResourceContainer> m_resourceContainerList
Visual Basic
Public m_resourceContainerList As Array(Of ResourceContainer)
Visual C++
public:
Array<ResourceContainer^>^ m_resourceContainerList

See Also

ResourceStore Class
ElGUI Namespace


ResourceStore Methods

[image] [image]

4 of William Foster's Class Libraries
ResourceStore Methods
ResourceStore Class See Also Send Feedback

The ResourceStore type exposes the following members.

Methods

 | Name | Description
Public method | AddResourceContainer |
Public method | AddResourceEntity |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadString(STRING, STRING%) |
Public method | LoadString(Resource_ID, STRING%) |
Public method | LookupResourceContainer |
Public method | LookupResourceEntity(STRING, Resource_ID) |
 | LookupResourceEntity(STRING, Array<(Of <<'(ResourceEntity>)>>), Resource_ID) |
Public method | LookupResourceID |
Public method | LookupResourceName(STRING%, Resource_ID, Resource_ID) |
 | LookupResourceName(STRING%, Array<(Of <<'(ResourceEntity>)>>), Resource_ID, Resource_ID) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PostLoad |
Public method | SetName |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResourceStore Class
ElGUI Namespace


AddResourceContainer Method

[image]

4 of William Foster's Class Libraries
ResourceStore..::..AddResourceContainer Method
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceStore.AddResourceContainer(ElGUI.ResourceContainer)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AddResourceContainer(
    ResourceContainer resourceContainer
)
Visual Basic
Public Function AddResourceContainer ( _
    resourceContainer As ResourceContainer _
) As Boolean
Visual C++
public:
bool AddResourceContainer(
    ResourceContainer^ resourceContainer
)

Parameters

resourceContainer
Type: ElGUI..::..ResourceContainer

[Missing <param name="resourceContainer"/> documentation for "M:ElGUI.ResourceStore.AddResourceContainer(ElGUI.ResourceContainer)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceStore.AddResourceContainer(ElGUI.ResourceContainer)"]

See Also

ResourceStore Class
ElGUI Namespace


AddResourceEntity Method

[image]

4 of William Foster's Class Libraries
ResourceStore..::..AddResourceEntity Method
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceStore.AddResourceEntity(ElGUI.ResourceEntity)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AddResourceEntity(
    ResourceEntity resourceEntity
)
Visual Basic
Public Function AddResourceEntity ( _
    resourceEntity As ResourceEntity _
) As Boolean
Visual C++
public:
bool AddResourceEntity(
    ResourceEntity^ resourceEntity
)

Parameters

resourceEntity
Type: ElGUI..::..ResourceEntity

[Missing <param name="resourceEntity"/> documentation for "M:ElGUI.ResourceStore.AddResourceEntity(ElGUI.ResourceEntity)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceStore.AddResourceEntity(ElGUI.ResourceEntity)"]

See Also

ResourceStore Class
ElGUI Namespace


GetName Method

[image]

4 of William Foster's Class Libraries
ResourceStore..::..GetName Method
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceStore.GetName(El.STRING@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void GetName(
    out STRING cs
)
Visual Basic
Public Sub GetName ( _
    <OutAttribute> ByRef cs As STRING _
)
Visual C++
public:
void GetName(
    [OutAttribute] STRING^% cs
)

Parameters

cs
Type: STRING%

[Missing <param name="cs"/> documentation for "M:ElGUI.ResourceStore.GetName(El.STRING@)"]

See Also

ResourceStore Class
ElGUI Namespace


LoadString Method

[image] [image]

4 of William Foster's Class Libraries
ResourceStore..::..LoadString Method
ResourceStore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadString(STRING, STRING%) |
Public method | LoadString(Resource_ID, STRING%) |

See Also

ResourceStore Class
ResourceStore Members
ElGUI Namespace


LoadString Method (, )

[image]

4 of William Foster's Class Libraries
ResourceStore..::..LoadString Method (, %)
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceStore.LoadString(El.STRING,El.STRING@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LoadString(
    STRING csIDName,
    out STRING destString
)
Visual Basic
Public Function LoadString ( _
    csIDName As STRING, _
    <OutAttribute> ByRef destString As STRING _
) As Boolean
Visual C++
public:
bool LoadString(
    STRING^ csIDName,
    [OutAttribute] STRING^% destString
)

Parameters

csIDName
Type: STRING

[Missing <param name="csIDName"/> documentation for "M:ElGUI.ResourceStore.LoadString(El.STRING,El.STRING@)"]

destString
Type: STRING%

[Missing <param name="destString"/> documentation for "M:ElGUI.ResourceStore.LoadString(El.STRING,El.STRING@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceStore.LoadString(El.STRING,El.STRING@)"]

See Also

ResourceStore Class
LoadString Overload
ElGUI Namespace


LoadString Method (Resource_ID, )

[image]

4 of William Foster's Class Libraries
ResourceStore..::..LoadString Method (Resource_ID, %)
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceStore.LoadString(ElGUI.Resource_ID,El.STRING@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LoadString(
    Resource_ID resourceID,
    out STRING destString
)
Visual Basic
Public Function LoadString ( _
    resourceID As Resource_ID, _
    <OutAttribute> ByRef destString As STRING _
) As Boolean
Visual C++
public:
bool LoadString(
    Resource_ID resourceID,
    [OutAttribute] STRING^% destString
)

Parameters

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.ResourceStore.LoadString(ElGUI.Resource_ID,El.STRING@)"]

destString
Type: STRING%

[Missing <param name="destString"/> documentation for "M:ElGUI.ResourceStore.LoadString(ElGUI.Resource_ID,El.STRING@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceStore.LoadString(ElGUI.Resource_ID,El.STRING@)"]

See Also

ResourceStore Class
LoadString Overload
ElGUI Namespace


LookupResourceContainer Method

[image]

4 of William Foster's Class Libraries
ResourceStore..::..LookupResourceContainer Method
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceStore.LookupResourceContainer(ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceContainer LookupResourceContainer(
    Resource_ID resourceID
)
Visual Basic
Public Function LookupResourceContainer ( _
    resourceID As Resource_ID _
) As ResourceContainer
Visual C++
public:
ResourceContainer^ LookupResourceContainer(
    Resource_ID resourceID
)

Parameters

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.ResourceStore.LookupResourceContainer(ElGUI.Resource_ID)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceStore.LookupResourceContainer(ElGUI.Resource_ID)"]

See Also

ResourceStore Class
ElGUI Namespace


LookupResourceEntity Method

[image] [image]

4 of William Foster's Class Libraries
ResourceStore..::..LookupResourceEntity Method
ResourceStore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LookupResourceEntity(STRING, Resource_ID) |
 | LookupResourceEntity(STRING, Array<(Of <<'(ResourceEntity>)>>), Resource_ID) |

See Also

ResourceStore Class
ResourceStore Members
ElGUI Namespace


LookupResourceEntity Method (, Resource_ID)

[image]

4 of William Foster's Class Libraries
ResourceStore..::..LookupResourceEntity Method (, Resource_ID)
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceStore.LookupResourceEntity(El.STRING,ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceEntity LookupResourceEntity(
    STRING csIDName,
    Resource_ID parentID
)
Visual Basic
Public Function LookupResourceEntity ( _
    csIDName As STRING, _
    parentID As Resource_ID _
) As ResourceEntity
Visual C++
public:
ResourceEntity^ LookupResourceEntity(
    STRING^ csIDName,
    Resource_ID parentID
)

Parameters

csIDName
Type: STRING

[Missing <param name="csIDName"/> documentation for "M:ElGUI.ResourceStore.LookupResourceEntity(El.STRING,ElGUI.Resource_ID)"]

parentID
Type: ElGUI..::..Resource_ID

[Missing <param name="parentID"/> documentation for "M:ElGUI.ResourceStore.LookupResourceEntity(El.STRING,ElGUI.Resource_ID)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceStore.LookupResourceEntity(El.STRING,ElGUI.Resource_ID)"]

See Also

ResourceStore Class
LookupResourceEntity Overload
ElGUI Namespace


LookupResourceEntity Method (, (ResourceEntity), Resource_ID)

[image]

4 of William Foster's Class Libraries
ResourceStore..::..LookupResourceEntity Method (, <(Of <(<'ResourceEntity>)>)>, Resource_ID)
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceStore.LookupResourceEntity(El.STRING,El.Array{ElGUI.ResourceEntity},ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ResourceEntity LookupResourceEntity(
    STRING csIDName,
    Array<ResourceEntity> EntityArray,
    Resource_ID parentID
)
Visual Basic
Public Shared Function LookupResourceEntity ( _
    csIDName As STRING, _
    EntityArray As Array(Of ResourceEntity), _
    parentID As Resource_ID _
) As ResourceEntity
Visual C++
public:
static ResourceEntity^ LookupResourceEntity(
    STRING^ csIDName,
    Array<ResourceEntity^>^ EntityArray,
    Resource_ID parentID
)

Parameters

csIDName
Type: STRING

[Missing <param name="csIDName"/> documentation for "M:ElGUI.ResourceStore.LookupResourceEntity(El.STRING,El.Array{ElGUI.ResourceEntity},ElGUI.Resource_ID)"]

EntityArray
Type: Array<(Of <(<' ResourceEntity >)>)>

[Missing <param name="EntityArray"/> documentation for "M:ElGUI.ResourceStore.LookupResourceEntity(El.STRING,El.Array{ElGUI.ResourceEntity},ElGUI.Resource_ID)"]

parentID
Type: ElGUI..::..Resource_ID

[Missing <param name="parentID"/> documentation for "M:ElGUI.ResourceStore.LookupResourceEntity(El.STRING,El.Array{ElGUI.ResourceEntity},ElGUI.Resource_ID)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceStore.LookupResourceEntity(El.STRING,El.Array{ElGUI.ResourceEntity},ElGUI.Resource_ID)"]

See Also

ResourceStore Class
LookupResourceEntity Overload
ElGUI Namespace


LookupResourceID Method

[image]

4 of William Foster's Class Libraries
ResourceStore..::..LookupResourceID Method
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceStore.LookupResourceID(El.STRING,ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Resource_ID LookupResourceID(
    STRING csIDName,
    Resource_ID parentID
)
Visual Basic
Public Function LookupResourceID ( _
    csIDName As STRING, _
    parentID As Resource_ID _
) As Resource_ID
Visual C++
public:
Resource_ID LookupResourceID(
    STRING^ csIDName,
    Resource_ID parentID
)

Parameters

csIDName
Type: STRING

[Missing <param name="csIDName"/> documentation for "M:ElGUI.ResourceStore.LookupResourceID(El.STRING,ElGUI.Resource_ID)"]

parentID
Type: ElGUI..::..Resource_ID

[Missing <param name="parentID"/> documentation for "M:ElGUI.ResourceStore.LookupResourceID(El.STRING,ElGUI.Resource_ID)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceStore.LookupResourceID(El.STRING,ElGUI.Resource_ID)"]

See Also

ResourceStore Class
ElGUI Namespace


LookupResourceName Method

[image] [image]

4 of William Foster's Class Libraries
ResourceStore..::..LookupResourceName Method
ResourceStore Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LookupResourceName(STRING%, Resource_ID, Resource_ID) |
 | LookupResourceName(STRING%, Array<(Of <<'(ResourceEntity>)>>), Resource_ID, Resource_ID) |

See Also

ResourceStore Class
ResourceStore Members
ElGUI Namespace


LookupResourceName Method (, Resource_ID, Resource_ID)

[image]

4 of William Foster's Class Libraries
ResourceStore..::..LookupResourceName Method (%, Resource_ID, Resource_ID)
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceStore.LookupResourceName(El.STRING@,ElGUI.Resource_ID,ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LookupResourceName(
    out STRING csIDName,
    Resource_ID rID,
    Resource_ID parentID
)
Visual Basic
Public Function LookupResourceName ( _
    <OutAttribute> ByRef csIDName As STRING, _
    rID As Resource_ID, _
    parentID As Resource_ID _
) As Boolean
Visual C++
public:
bool LookupResourceName(
    [OutAttribute] STRING^% csIDName,
    Resource_ID rID,
    Resource_ID parentID
)

Parameters

csIDName
Type: STRING%

[Missing <param name="csIDName"/> documentation for "M:ElGUI.ResourceStore.LookupResourceName(El.STRING@,ElGUI.Resource_ID,ElGUI.Resource_ID)"]

rID
Type: ElGUI..::..Resource_ID

[Missing <param name="rID"/> documentation for "M:ElGUI.ResourceStore.LookupResourceName(El.STRING@,ElGUI.Resource_ID,ElGUI.Resource_ID)"]

parentID
Type: ElGUI..::..Resource_ID

[Missing <param name="parentID"/> documentation for "M:ElGUI.ResourceStore.LookupResourceName(El.STRING@,ElGUI.Resource_ID,ElGUI.Resource_ID)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceStore.LookupResourceName(El.STRING@,ElGUI.Resource_ID,ElGUI.Resource_ID)"]

See Also

ResourceStore Class
LookupResourceName Overload
ElGUI Namespace


LookupResourceName Method (, (ResourceEntity), Resource_ID, Resource_ID)

[image]

4 of William Foster's Class Libraries
ResourceStore..::..LookupResourceName Method (%, <(Of <(<'ResourceEntity>)>)>, Resource_ID, Resource_ID)
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceStore.LookupResourceName(El.STRING@,El.Array{ElGUI.ResourceEntity},ElGUI.Resource_ID,ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool LookupResourceName(
    out STRING csIDName,
    Array<ResourceEntity> EntityArray,
    Resource_ID rID,
    Resource_ID parentID
)
Visual Basic
Public Shared Function LookupResourceName ( _
    <OutAttribute> ByRef csIDName As STRING, _
    EntityArray As Array(Of ResourceEntity), _
    rID As Resource_ID, _
    parentID As Resource_ID _
) As Boolean
Visual C++
public:
static bool LookupResourceName(
    [OutAttribute] STRING^% csIDName,
    Array<ResourceEntity^>^ EntityArray,
    Resource_ID rID,
    Resource_ID parentID
)

Parameters

csIDName
Type: STRING%

[Missing <param name="csIDName"/> documentation for "M:ElGUI.ResourceStore.LookupResourceName(El.STRING@,El.Array{ElGUI.ResourceEntity},ElGUI.Resource_ID,ElGUI.Resource_ID)"]

EntityArray
Type: Array<(Of <(<' ResourceEntity >)>)>

[Missing <param name="EntityArray"/> documentation for "M:ElGUI.ResourceStore.LookupResourceName(El.STRING@,El.Array{ElGUI.ResourceEntity},ElGUI.Resource_ID,ElGUI.Resource_ID)"]

rID
Type: ElGUI..::..Resource_ID

[Missing <param name="rID"/> documentation for "M:ElGUI.ResourceStore.LookupResourceName(El.STRING@,El.Array{ElGUI.ResourceEntity},ElGUI.Resource_ID,ElGUI.Resource_ID)"]

parentID
Type: ElGUI..::..Resource_ID

[Missing <param name="parentID"/> documentation for "M:ElGUI.ResourceStore.LookupResourceName(El.STRING@,El.Array{ElGUI.ResourceEntity},ElGUI.Resource_ID,ElGUI.Resource_ID)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceStore.LookupResourceName(El.STRING@,El.Array{ElGUI.ResourceEntity},ElGUI.Resource_ID,ElGUI.Resource_ID)"]

See Also

ResourceStore Class
LookupResourceName Overload
ElGUI Namespace


PostLoad Method

[image]

4 of William Foster's Class Libraries
ResourceStore..::..PostLoad Method
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceStore.PostLoad"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void PostLoad()
Visual Basic
Public Sub PostLoad
Visual C++
public:
void PostLoad()

See Also

ResourceStore Class
ElGUI Namespace


SetName Method

[image]

4 of William Foster's Class Libraries
ResourceStore..::..SetName Method
ResourceStore Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceStore.SetName(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetName(
    STRING cs
)
Visual Basic
Public Sub SetName ( _
    cs As STRING _
)
Visual C++
public:
void SetName(
    STRING^ cs
)

Parameters

cs
Type: STRING

[Missing <param name="cs"/> documentation for "M:ElGUI.ResourceStore.SetName(El.STRING)"]

See Also

ResourceStore Class
ElGUI Namespace


ResourceWindow Class

[image]

4 of William Foster's Class Libraries
ResourceWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ResourceWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ResourceWindow : MenuWindow
Visual Basic
Public Class ResourceWindow _
    Inherits MenuWindow
Visual C++
public ref class ResourceWindow : public MenuWindow

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..MenuWindow
ElGUI..::..ResourceWindow
ElGUI..::..DialogWindow

See Also

ResourceWindow Members
ElGUI Namespace


ResourceWindow Members

[image] [image]

4 of William Foster's Class Libraries
ResourceWindow Members
ResourceWindow Class Constructors Methods Fields Properties See Also Send Feedback

The ResourceWindow type exposes the following members.

Constructors

 | Name | Description
Public method | ResourceWindow(GUI, array<Char>[]()[][], Window) | Initializes a new instance of the ResourceWindow class
Public method | ResourceWindow(GUI, String, Window) | Initializes a new instance of the ResourceWindow class
Public method | ResourceWindow(GUI, STRING, WINDOW_TYPE, Window) | Initializes a new instance of the ResourceWindow class
Public method | ResourceWindow(GUI, STRING, WINDOW_TYPE, Window, ResourceStore) | Initializes a new instance of the ResourceWindow class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu | (Inherited from MenuWindow.)
Protected method | AddResourceControl |
Protected method | AddSpacer |
Protected method | AddSwitcher |
Protected method | AddWindow |
Protected method | AddWindows |
Public method | AppendResourceContainer |
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Protected method | CreateEntryList |
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Protected method | GetRCList |
Protected method | GetResourceContainer |
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitializeResourceID |
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Public method | Lookup_Resource_Control(STRING) |
Public method | Lookup_Resource_Control(Resource_ID) |
Public method | LookupResourceEntity |
Public method | LookupResourceName |
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from MenuWindow.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from MenuWindow.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | RecordKeyboardShortcut | (Inherited from MenuWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetResourceContainer |
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName | (Inherited from MenuWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_ResourceControl_List |
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ResourceWindow Class
ElGUI Namespace


ResourceWindow Constructor

[image] [image]

4 of William Foster's Class Libraries
ResourceWindow Constructor
ResourceWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResourceWindow(GUI, array<Char>[]()[][], Window) | Initializes a new instance of the ResourceWindow class
Public method | ResourceWindow(GUI, String, Window) | Initializes a new instance of the ResourceWindow class
Public method | ResourceWindow(GUI, STRING, WINDOW_TYPE, Window) | Initializes a new instance of the ResourceWindow class
Public method | ResourceWindow(GUI, STRING, WINDOW_TYPE, Window, ResourceStore) | Initializes a new instance of the ResourceWindow class

See Also

ResourceWindow Class
ResourceWindow Members
ElGUI Namespace


ResourceWindow Constructor (GUI, Char[], Window)

[image]

4 of William Foster's Class Libraries
ResourceWindow Constructor (GUI, array<Char>[]()[][], Window)
ResourceWindow Class See Also Send Feedback
Initializes a new instance of the ResourceWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceWindow(
    GUI gui,
    char[] pMemScript,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    pMemScript As Char(), _
    Parent As Window _
)
Visual C++
public:
ResourceWindow(
    GUI^ gui,
    array<wchar_t>^ pMemScript,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,System.Char[],ElGUI.Window)"]

pMemScript
Type: array< System..::..Char >[]()[][]

[Missing <param name="pMemScript"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,System.Char[],ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,System.Char[],ElGUI.Window)"]

See Also

ResourceWindow Class
ResourceWindow Overload
ElGUI Namespace


ResourceWindow Constructor (GUI, String, Window)

[image]

4 of William Foster's Class Libraries
ResourceWindow Constructor (GUI, String, Window)
ResourceWindow Class See Also Send Feedback
Initializes a new instance of the ResourceWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceWindow(
    GUI gui,
    string csTitle,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    csTitle As String, _
    Parent As Window _
)
Visual C++
public:
ResourceWindow(
    GUI^ gui,
    String^ csTitle,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,System.String,ElGUI.Window)"]

csTitle
Type: System..::..String

[Missing <param name="csTitle"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,System.String,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,System.String,ElGUI.Window)"]

See Also

ResourceWindow Class
ResourceWindow Overload
ElGUI Namespace


ResourceWindow Constructor (GUI, , WINDOW_TYPE, Window)

[image]

4 of William Foster's Class Libraries
ResourceWindow Constructor (GUI, , WINDOW_TYPE, Window)
ResourceWindow Class See Also Send Feedback
Initializes a new instance of the ResourceWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceWindow(
    GUI gui,
    STRING ResourceName,
    WINDOW_TYPE eType,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    ResourceName As STRING, _
    eType As WINDOW_TYPE, _
    Parent As Window _
)
Visual C++
public:
ResourceWindow(
    GUI^ gui,
    STRING^ ResourceName,
    WINDOW_TYPE eType,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

ResourceName
Type: STRING

[Missing <param name="ResourceName"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

See Also

ResourceWindow Class
ResourceWindow Overload
ElGUI Namespace


ResourceWindow Constructor (GUI, , WINDOW_TYPE, Window, ResourceStore)

[image]

4 of William Foster's Class Libraries
ResourceWindow Constructor (GUI, , WINDOW_TYPE, Window, ResourceStore)
ResourceWindow Class See Also Send Feedback
Initializes a new instance of the ResourceWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceWindow(
    GUI gui,
    STRING ResourceName,
    WINDOW_TYPE eType,
    Window Parent,
    ResourceStore rStore
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    ResourceName As STRING, _
    eType As WINDOW_TYPE, _
    Parent As Window, _
    rStore As ResourceStore _
)
Visual C++
public:
ResourceWindow(
    GUI^ gui,
    STRING^ ResourceName,
    WINDOW_TYPE eType,
    Window^ Parent,
    ResourceStore^ rStore
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.ResourceStore)"]

ResourceName
Type: STRING

[Missing <param name="ResourceName"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.ResourceStore)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.ResourceStore)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.ResourceStore)"]

rStore
Type: ElGUI..::..ResourceStore

[Missing <param name="rStore"/> documentation for "M:ElGUI.ResourceWindow.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.ResourceStore)"]

See Also

ResourceWindow Class
ResourceWindow Overload
ElGUI Namespace


ResourceWindow Fields

[image] [image]

4 of William Foster's Class Libraries
ResourceWindow Fields
ResourceWindow Class See Also Send Feedback

The ResourceWindow type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName | (Inherited from MenuWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_ResourceControl_List |
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

ResourceWindow Class
ElGUI Namespace


m_ResourceControl_List Field

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..m_ResourceControl_List Field
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ResourceWindow.m_ResourceControl_List"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Array<Resource_Control> m_ResourceControl_List
Visual Basic
Protected m_ResourceControl_List As Array(Of Resource_Control)
Visual C++
protected:
Array<Resource_Control^>^ m_ResourceControl_List

See Also

ResourceWindow Class
ElGUI Namespace


ResourceWindow Methods

[image] [image]

4 of William Foster's Class Libraries
ResourceWindow Methods
ResourceWindow Class See Also Send Feedback

The ResourceWindow type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu | (Inherited from MenuWindow.)
Protected method | AddResourceControl |
Protected method | AddSpacer |
Protected method | AddSwitcher |
Protected method | AddWindow |
Protected method | AddWindows |
Public method | AppendResourceContainer |
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Protected method | CreateEntryList |
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Protected method | GetRCList |
Protected method | GetResourceContainer |
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitializeResourceID |
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Public method | Lookup_Resource_Control(STRING) |
Public method | Lookup_Resource_Control(Resource_ID) |
Public method | LookupResourceEntity |
Public method | LookupResourceName |
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from MenuWindow.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from MenuWindow.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | RecordKeyboardShortcut | (Inherited from MenuWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetResourceContainer |
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

ResourceWindow Class
ElGUI Namespace


AddResourceControl Method

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..AddResourceControl Method
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.AddResourceControl(ElGUI.Resource_Control)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void AddResourceControl(
    Resource_Control Rc
)
Visual Basic
Protected Sub AddResourceControl ( _
    Rc As Resource_Control _
)
Visual C++
protected:
void AddResourceControl(
    Resource_Control^ Rc
)

Parameters

Rc
Type: ElGUI..::..Resource_Control

[Missing <param name="Rc"/> documentation for "M:ElGUI.ResourceWindow.AddResourceControl(ElGUI.Resource_Control)"]

See Also

ResourceWindow Class
ElGUI Namespace


AddSpacer Method

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..AddSpacer Method
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.AddSpacer(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void AddSpacer(
    Size2dU size
)
Visual Basic
Protected Sub AddSpacer ( _
    size As Size2dU _
)
Visual C++
protected:
void AddSpacer(
    Size2dU^ size
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElGUI.ResourceWindow.AddSpacer(El.Size2dU)"]

See Also

ResourceWindow Class
ElGUI Namespace


AddSwitcher Method

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..AddSwitcher Method
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.AddSwitcher(ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void AddSwitcher(
    Resource_ID rID
)
Visual Basic
Protected Sub AddSwitcher ( _
    rID As Resource_ID _
)
Visual C++
protected:
void AddSwitcher(
    Resource_ID rID
)

Parameters

rID
Type: ElGUI..::..Resource_ID

[Missing <param name="rID"/> documentation for "M:ElGUI.ResourceWindow.AddSwitcher(ElGUI.Resource_ID)"]

See Also

ResourceWindow Class
ElGUI Namespace


AddWindow Method

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..AddWindow Method
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.AddWindow(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool AddWindow(
    STRING csNext
)
Visual Basic
Protected Function AddWindow ( _
    csNext As STRING _
) As Boolean
Visual C++
protected:
bool AddWindow(
    STRING^ csNext
)

Parameters

csNext
Type: STRING

[Missing <param name="csNext"/> documentation for "M:ElGUI.ResourceWindow.AddWindow(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceWindow.AddWindow(El.STRING)"]

See Also

ResourceWindow Class
ElGUI Namespace


AddWindows Method

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..AddWindows Method
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.AddWindows(ElGUI.ResourceEntity)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool AddWindows(
    ResourceEntity ResEntity
)
Visual Basic
Protected Function AddWindows ( _
    ResEntity As ResourceEntity _
) As Boolean
Visual C++
protected:
bool AddWindows(
    ResourceEntity^ ResEntity
)

Parameters

ResEntity
Type: ElGUI..::..ResourceEntity

[Missing <param name="ResEntity"/> documentation for "M:ElGUI.ResourceWindow.AddWindows(ElGUI.ResourceEntity)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceWindow.AddWindows(ElGUI.ResourceEntity)"]

See Also

ResourceWindow Class
ElGUI Namespace


AppendResourceContainer Method

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..AppendResourceContainer Method
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.AppendResourceContainer(ElGUI.ResourceContainer)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AppendResourceContainer(
    ResourceContainer RC
)
Visual Basic
Public Sub AppendResourceContainer ( _
    RC As ResourceContainer _
)
Visual C++
public:
void AppendResourceContainer(
    ResourceContainer^ RC
)

Parameters

RC
Type: ElGUI..::..ResourceContainer

[Missing <param name="RC"/> documentation for "M:ElGUI.ResourceWindow.AppendResourceContainer(ElGUI.ResourceContainer)"]

See Also

ResourceWindow Class
ElGUI Namespace


CreateEntryList Method

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..CreateEntryList Method
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.CreateEntryList(El.Array{ElGUI.ResourceEntity})"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool CreateEntryList(
    Array<ResourceEntity> ResEntityList
)
Visual Basic
Protected Function CreateEntryList ( _
    ResEntityList As Array(Of ResourceEntity) _
) As Boolean
Visual C++
protected:
bool CreateEntryList(
    Array<ResourceEntity^>^ ResEntityList
)

Parameters

ResEntityList
Type: Array<(Of <(<' ResourceEntity >)>)>

[Missing <param name="ResEntityList"/> documentation for "M:ElGUI.ResourceWindow.CreateEntryList(El.Array{ElGUI.ResourceEntity})"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceWindow.CreateEntryList(El.Array{ElGUI.ResourceEntity})"]

See Also

ResourceWindow Class
ElGUI Namespace


GetRCList Method

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..GetRCList Method
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.GetRCList"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Array<ResourceContainer> GetRCList()
Visual Basic
Protected Function GetRCList As Array(Of ResourceContainer)
Visual C++
protected:
Array<ResourceContainer^>^ GetRCList()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceWindow.GetRCList"]

See Also

ResourceWindow Class
ElGUI Namespace


GetResourceContainer Method

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..GetResourceContainer Method
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.GetResourceContainer"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ResourceContainer GetResourceContainer()
Visual Basic
Protected Function GetResourceContainer As ResourceContainer
Visual C++
protected:
ResourceContainer^ GetResourceContainer()

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceWindow.GetResourceContainer"]

See Also

ResourceWindow Class
ElGUI Namespace


InitializeResourceID Method

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..InitializeResourceID Method
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.InitializeResourceID"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void InitializeResourceID()
Visual Basic
Protected Sub InitializeResourceID
Visual C++
protected:
void InitializeResourceID()

See Also

ResourceWindow Class
ElGUI Namespace


Lookup_Resource_Control Method

[image] [image]

4 of William Foster's Class Libraries
ResourceWindow..::..Lookup_Resource_Control Method
ResourceWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lookup_Resource_Control(STRING) |
Public method | Lookup_Resource_Control(Resource_ID) |

See Also

ResourceWindow Class
ResourceWindow Members
ElGUI Namespace


Lookup_Resource_Control Method ()

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..Lookup_Resource_Control Method ()
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.Lookup_Resource_Control(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Resource_Control Lookup_Resource_Control(
    STRING csName
)
Visual Basic
Public Function Lookup_Resource_Control ( _
    csName As STRING _
) As Resource_Control
Visual C++
public:
Resource_Control^ Lookup_Resource_Control(
    STRING^ csName
)

Parameters

csName
Type: STRING

[Missing <param name="csName"/> documentation for "M:ElGUI.ResourceWindow.Lookup_Resource_Control(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceWindow.Lookup_Resource_Control(El.STRING)"]

See Also

ResourceWindow Class
Lookup_Resource_Control Overload
ElGUI Namespace


Lookup_Resource_Control Method (Resource_ID)

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..Lookup_Resource_Control Method (Resource_ID)
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.Lookup_Resource_Control(ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Resource_Control Lookup_Resource_Control(
    Resource_ID rID
)
Visual Basic
Public Function Lookup_Resource_Control ( _
    rID As Resource_ID _
) As Resource_Control
Visual C++
public:
Resource_Control^ Lookup_Resource_Control(
    Resource_ID rID
)

Parameters

rID
Type: ElGUI..::..Resource_ID

[Missing <param name="rID"/> documentation for "M:ElGUI.ResourceWindow.Lookup_Resource_Control(ElGUI.Resource_ID)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceWindow.Lookup_Resource_Control(ElGUI.Resource_ID)"]

See Also

ResourceWindow Class
Lookup_Resource_Control Overload
ElGUI Namespace


LookupResourceEntity Method

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..LookupResourceEntity Method
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.LookupResourceEntity(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceEntity LookupResourceEntity(
    STRING csName
)
Visual Basic
Public Function LookupResourceEntity ( _
    csName As STRING _
) As ResourceEntity
Visual C++
public:
ResourceEntity^ LookupResourceEntity(
    STRING^ csName
)

Parameters

csName
Type: STRING

[Missing <param name="csName"/> documentation for "M:ElGUI.ResourceWindow.LookupResourceEntity(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceWindow.LookupResourceEntity(El.STRING)"]

See Also

ResourceWindow Class
ElGUI Namespace


LookupResourceName Method

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..LookupResourceName Method
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.LookupResourceName(El.STRING@,ElGUI.Resource_ID)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LookupResourceName(
    out STRING csIDName,
    Resource_ID rID
)
Visual Basic
Public Function LookupResourceName ( _
    <OutAttribute> ByRef csIDName As STRING, _
    rID As Resource_ID _
) As Boolean
Visual C++
public:
bool LookupResourceName(
    [OutAttribute] STRING^% csIDName,
    Resource_ID rID
)

Parameters

csIDName
Type: STRING%

[Missing <param name="csIDName"/> documentation for "M:ElGUI.ResourceWindow.LookupResourceName(El.STRING@,ElGUI.Resource_ID)"]

rID
Type: ElGUI..::..Resource_ID

[Missing <param name="rID"/> documentation for "M:ElGUI.ResourceWindow.LookupResourceName(El.STRING@,ElGUI.Resource_ID)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ResourceWindow.LookupResourceName(El.STRING@,ElGUI.Resource_ID)"]

See Also

ResourceWindow Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
ResourceWindow..::..SetColor Method
ResourceWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

ResourceWindow Class
ResourceWindow Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
ResourceWindow..::..SetDefaultCursor Method
ResourceWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

ResourceWindow Class
ResourceWindow Members
ElGUI Namespace


SetResourceContainer Method

[image]

4 of William Foster's Class Libraries
ResourceWindow..::..SetResourceContainer Method
ResourceWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ResourceWindow.SetResourceContainer(ElGUI.ResourceContainer)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetResourceContainer(
    ResourceContainer RC
)
Visual Basic
Public Sub SetResourceContainer ( _
    RC As ResourceContainer _
)
Visual C++
public:
void SetResourceContainer(
    ResourceContainer^ RC
)

Parameters

RC
Type: ElGUI..::..ResourceContainer

[Missing <param name="RC"/> documentation for "M:ElGUI.ResourceWindow.SetResourceContainer(ElGUI.ResourceContainer)"]

See Also

ResourceWindow Class
ElGUI Namespace


ResourceWindow Properties

[image] [image]

4 of William Foster's Class Libraries
ResourceWindow Properties
ResourceWindow Class See Also Send Feedback

The ResourceWindow type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ResourceWindow Class
ElGUI Namespace


ScriptResource Class

[image]

4 of William Foster's Class Libraries
ScriptResource Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ScriptResource"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ScriptResource : Script_XML
Visual Basic
Public Class ScriptResource _
    Inherits Script_XML
Visual C++
public ref class ScriptResource : public Script_XML

Inheritance Hierarchy

System..::..Object
Stream
ElScript..::..Script_Text
ElScript..::..Script
ElScript..::..Script_XML
ElGUI..::..ScriptResource

See Also

ScriptResource Members
ElGUI Namespace


ScriptResource Members

[image] [image]

4 of William Foster's Class Libraries
ScriptResource Members
ScriptResource Class Constructors Methods Fields Properties See Also Send Feedback

The ScriptResource type exposes the following members.

Constructors

 | Name | Description
Public method | ScriptResource | Initializes a new instance of the ScriptResource class

Methods

 | Name | Description
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Inherited from Script.)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML | (Inherited from Script_XML.)
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Public method | LoadResources |
Protected method | LoadResourcesInternal |
Public method | LoadString |
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Protected method | PickupAttributes |
Protected method | PickupHandlers |
Protected method | PickupName |
Protected method | PickupText |
Public method | Read | (Inherited from Stream.)
Public method | Read_ResourceShape |
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext | (Inherited from Script_XML.)
Public method | ReadNextResourceContainer |
Public method | ReadNextResourceEntity |
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Public method | ReadToTagEnd | (Inherited from Script_XML.)
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Inherited from Script_XML.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetFolder |
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment | (Inherited from Script.)
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField | (Inherited from Script_XML.)
Public method | WriteAnXMLTag | (Inherited from Script_XML.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

Fields

 | Name | Description
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)
 | Res_KeyWords |

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

ScriptResource Class
ElGUI Namespace


ScriptResource Constructor

[image]

4 of William Foster's Class Libraries
ScriptResource Constructor
ScriptResource Class See Also Send Feedback
Initializes a new instance of the ScriptResource class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScriptResource(
    Stream resourceStream
)
Visual Basic
Public Sub New ( _
    resourceStream As Stream _
)
Visual C++
public:
ScriptResource(
    Stream^ resourceStream
)

Parameters

resourceStream
Type: Stream

[Missing <param name="resourceStream"/> documentation for "M:ElGUI.ScriptResource.#ctor(El.Stream)"]

See Also

ScriptResource Class
ElGUI Namespace


ScriptResource Fields

[image] [image]

4 of William Foster's Class Libraries
ScriptResource Fields
ScriptResource Class See Also Send Feedback

The ScriptResource type exposes the following members.

Fields

 | Name | Description
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)
 | Res_KeyWords |

See Also

ScriptResource Class
ElGUI Namespace


Res_KeyWords Field

[image]

4 of William Foster's Class Libraries
ScriptResource..::..Res_KeyWords Field
ScriptResource Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ScriptResource.Res_KeyWords"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string[] Res_KeyWords
Visual Basic
Public Shared Res_KeyWords As String()
Visual C++
public:
static array<String^>^ Res_KeyWords

See Also

ScriptResource Class
ElGUI Namespace


ScriptResource Methods

[image] [image]

4 of William Foster's Class Libraries
ScriptResource Methods
ScriptResource Class See Also Send Feedback

The ScriptResource type exposes the following members.

Methods

 | Name | Description
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Inherited from Script.)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML | (Inherited from Script_XML.)
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Public method | LoadResources |
Protected method | LoadResourcesInternal |
Public method | LoadString |
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Protected method | PickupAttributes |
Protected method | PickupHandlers |
Protected method | PickupName |
Protected method | PickupText |
Public method | Read | (Inherited from Stream.)
Public method | Read_ResourceShape |
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext | (Inherited from Script_XML.)
Public method | ReadNextResourceContainer |
Public method | ReadNextResourceEntity |
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Public method | ReadToTagEnd | (Inherited from Script_XML.)
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Inherited from Script_XML.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetFolder |
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment | (Inherited from Script.)
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField | (Inherited from Script_XML.)
Public method | WriteAnXMLTag | (Inherited from Script_XML.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

ScriptResource Class
ElGUI Namespace


AttachFile Method

[image] [image]

4 of William Foster's Class Libraries
ScriptResource..::..AttachFile Method
ScriptResource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)

See Also

ScriptResource Class
ScriptResource Members
ElGUI Namespace


AttachMemory Method

[image] [image]

4 of William Foster's Class Libraries
ScriptResource..::..AttachMemory Method
ScriptResource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)

See Also

ScriptResource Class
ScriptResource Members
ElGUI Namespace


LoadResources Method

[image]

4 of William Foster's Class Libraries
ScriptResource..::..LoadResources Method
ScriptResource Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ScriptResource.LoadResources"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceStore LoadResources()
Visual Basic
Public Function LoadResources As ResourceStore
Visual C++
public:
ResourceStore^ LoadResources()

Return Value

[Missing <returns> documentation for "M:ElGUI.ScriptResource.LoadResources"]

See Also

ScriptResource Class
ElGUI Namespace


LoadResourcesInternal Method

[image]

4 of William Foster's Class Libraries
ScriptResource..::..LoadResourcesInternal Method
ScriptResource Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ScriptResource.LoadResourcesInternal(ElGUI.ResourceStore@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool LoadResourcesInternal(
    ref ResourceStore Res
)
Visual Basic
Protected Function LoadResourcesInternal ( _
    ByRef Res As ResourceStore _
) As Boolean
Visual C++
protected:
bool LoadResourcesInternal(
    ResourceStore^% Res
)

Parameters

Res
Type: ElGUI..::..ResourceStore %

[Missing <param name="Res"/> documentation for "M:ElGUI.ScriptResource.LoadResourcesInternal(ElGUI.ResourceStore@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ScriptResource.LoadResourcesInternal(ElGUI.ResourceStore@)"]

See Also

ScriptResource Class
ElGUI Namespace


LoadString Method

[image]

4 of William Foster's Class Libraries
ScriptResource..::..LoadString Method
ScriptResource Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ScriptResource.LoadString(ElGUI.Resource_ID,El.STRING@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LoadString(
    Resource_ID resourceID,
    out STRING destString
)
Visual Basic
Public Function LoadString ( _
    resourceID As Resource_ID, _
    <OutAttribute> ByRef destString As STRING _
) As Boolean
Visual C++
public:
bool LoadString(
    Resource_ID resourceID,
    [OutAttribute] STRING^% destString
)

Parameters

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.ScriptResource.LoadString(ElGUI.Resource_ID,El.STRING@)"]

destString
Type: STRING%

[Missing <param name="destString"/> documentation for "M:ElGUI.ScriptResource.LoadString(ElGUI.Resource_ID,El.STRING@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ScriptResource.LoadString(ElGUI.Resource_ID,El.STRING@)"]

See Also

ScriptResource Class
ElGUI Namespace


NextChar Method

[image] [image]

4 of William Foster's Class Libraries
ScriptResource..::..NextChar Method
ScriptResource Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)

See Also

ScriptResource Class
ScriptResource Members
ElGUI Namespace


PickupAttributes Method

[image]

4 of William Foster's Class Libraries
ScriptResource..::..PickupAttributes Method
ScriptResource Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ScriptResource.PickupAttributes(ElGUI.ResourceEntity@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool PickupAttributes(
    ref ResourceEntity resourceEntity
)
Visual Basic
Protected Function PickupAttributes ( _
    ByRef resourceEntity As ResourceEntity _
) As Boolean
Visual C++
protected:
bool PickupAttributes(
    ResourceEntity^% resourceEntity
)

Parameters

resourceEntity
Type: ElGUI..::..ResourceEntity %

[Missing <param name="resourceEntity"/> documentation for "M:ElGUI.ScriptResource.PickupAttributes(ElGUI.ResourceEntity@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ScriptResource.PickupAttributes(ElGUI.ResourceEntity@)"]

See Also

ScriptResource Class
ElGUI Namespace


PickupHandlers Method

[image]

4 of William Foster's Class Libraries
ScriptResource..::..PickupHandlers Method
ScriptResource Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ScriptResource.PickupHandlers(ElGUI.ResourceEntity@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool PickupHandlers(
    ref ResourceEntity resourceEntity
)
Visual Basic
Protected Function PickupHandlers ( _
    ByRef resourceEntity As ResourceEntity _
) As Boolean
Visual C++
protected:
bool PickupHandlers(
    ResourceEntity^% resourceEntity
)

Parameters

resourceEntity
Type: ElGUI..::..ResourceEntity %

[Missing <param name="resourceEntity"/> documentation for "M:ElGUI.ScriptResource.PickupHandlers(ElGUI.ResourceEntity@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ScriptResource.PickupHandlers(ElGUI.ResourceEntity@)"]

See Also

ScriptResource Class
ElGUI Namespace


PickupName Method

[image]

4 of William Foster's Class Libraries
ScriptResource..::..PickupName Method
ScriptResource Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ScriptResource.PickupName(ElGUI.ResourceEntity@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool PickupName(
    ref ResourceEntity resourceEntity
)
Visual Basic
Protected Function PickupName ( _
    ByRef resourceEntity As ResourceEntity _
) As Boolean
Visual C++
protected:
bool PickupName(
    ResourceEntity^% resourceEntity
)

Parameters

resourceEntity
Type: ElGUI..::..ResourceEntity %

[Missing <param name="resourceEntity"/> documentation for "M:ElGUI.ScriptResource.PickupName(ElGUI.ResourceEntity@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ScriptResource.PickupName(ElGUI.ResourceEntity@)"]

See Also

ScriptResource Class
ElGUI Namespace


PickupText Method

[image]

4 of William Foster's Class Libraries
ScriptResource..::..PickupText Method
ScriptResource Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ScriptResource.PickupText(ElGUI.ResourceEntity@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool PickupText(
    ref ResourceEntity resourceEntity
)
Visual Basic
Protected Function PickupText ( _
    ByRef resourceEntity As ResourceEntity _
) As Boolean
Visual C++
protected:
bool PickupText(
    ResourceEntity^% resourceEntity
)

Parameters

resourceEntity
Type: ElGUI..::..ResourceEntity %

[Missing <param name="resourceEntity"/> documentation for "M:ElGUI.ScriptResource.PickupText(ElGUI.ResourceEntity@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ScriptResource.PickupText(ElGUI.ResourceEntity@)"]

See Also

ScriptResource Class
ElGUI Namespace


Read_ResourceShape Method

[image]

4 of William Foster's Class Libraries
ScriptResource..::..Read_ResourceShape Method
ScriptResource Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ScriptResource.Read_ResourceShape(ElGUI.ResourceEntity@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Read_ResourceShape(
    ref ResourceEntity resourceEntity
)
Visual Basic
Public Function Read_ResourceShape ( _
    ByRef resourceEntity As ResourceEntity _
) As Boolean
Visual C++
public:
bool Read_ResourceShape(
    ResourceEntity^% resourceEntity
)

Parameters

resourceEntity
Type: ElGUI..::..ResourceEntity %

[Missing <param name="resourceEntity"/> documentation for "M:ElGUI.ScriptResource.Read_ResourceShape(ElGUI.ResourceEntity@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ScriptResource.Read_ResourceShape(ElGUI.ResourceEntity@)"]

See Also

ScriptResource Class
ElGUI Namespace


ReadLine Method

[image] [image]

4 of William Foster's Class Libraries
ScriptResource..::..ReadLine Method
ScriptResource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)

See Also

ScriptResource Class
ScriptResource Members
ElGUI Namespace


ReadNextResourceContainer Method

[image]

4 of William Foster's Class Libraries
ScriptResource..::..ReadNextResourceContainer Method
ScriptResource Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ScriptResource.ReadNextResourceContainer(ElGUI.ResourceContainer@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadNextResourceContainer(
    ref ResourceContainer resourceContainer
)
Visual Basic
Public Function ReadNextResourceContainer ( _
    ByRef resourceContainer As ResourceContainer _
) As Boolean
Visual C++
public:
bool ReadNextResourceContainer(
    ResourceContainer^% resourceContainer
)

Parameters

resourceContainer
Type: ElGUI..::..ResourceContainer %

[Missing <param name="resourceContainer"/> documentation for "M:ElGUI.ScriptResource.ReadNextResourceContainer(ElGUI.ResourceContainer@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ScriptResource.ReadNextResourceContainer(ElGUI.ResourceContainer@)"]

See Also

ScriptResource Class
ElGUI Namespace


ReadNextResourceEntity Method

[image]

4 of William Foster's Class Libraries
ScriptResource..::..ReadNextResourceEntity Method
ScriptResource Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ScriptResource.ReadNextResourceEntity"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResourceEntity ReadNextResourceEntity()
Visual Basic
Public Function ReadNextResourceEntity As ResourceEntity
Visual C++
public:
ResourceEntity^ ReadNextResourceEntity()

Return Value

[Missing <returns> documentation for "M:ElGUI.ScriptResource.ReadNextResourceEntity"]

See Also

ScriptResource Class
ElGUI Namespace


ReadScript_ArgumentList_2dPair Method

[image] [image]

4 of William Foster's Class Libraries
ScriptResource..::..ReadScript_ArgumentList_2dPair Method
ScriptResource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)

See Also

ScriptResource Class
ScriptResource Members
ElGUI Namespace


Seek Method

[image] [image]

4 of William Foster's Class Libraries
ScriptResource..::..Seek Method
ScriptResource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)

See Also

ScriptResource Class
ScriptResource Members
ElGUI Namespace


SetFolder Method

[image]

4 of William Foster's Class Libraries
ScriptResource..::..SetFolder Method
ScriptResource Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ScriptResource.SetFolder(El.Filename)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetFolder(
    Filename folder
)
Visual Basic
Public Sub SetFolder ( _
    folder As Filename _
)
Visual C++
public:
void SetFolder(
    Filename^ folder
)

Parameters

folder
Type: Filename

[Missing <param name="folder"/> documentation for "M:ElGUI.ScriptResource.SetFolder(El.Filename)"]

See Also

ScriptResource Class
ElGUI Namespace


Write Method

[image] [image]

4 of William Foster's Class Libraries
ScriptResource..::..Write Method
ScriptResource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

ScriptResource Class
ScriptResource Members
ElGUI Namespace


WriteLine Method

[image] [image]

4 of William Foster's Class Libraries
ScriptResource..::..WriteLine Method
ScriptResource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

ScriptResource Class
ScriptResource Members
ElGUI Namespace


ScriptResource Properties

[image] [image]

4 of William Foster's Class Libraries
ScriptResource Properties
ScriptResource Class See Also Send Feedback

The ScriptResource type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

ScriptResource Class
ElGUI Namespace


Slider Class

[image]

4 of William Foster's Class Libraries
Slider Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Slider"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Slider : Data_Resource_Control
Visual Basic
Public Class Slider _
    Inherits Data_Resource_Control
Visual C++
public ref class Slider : public Data_Resource_Control

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..Resource_Control
ElGUI..::..Data_Resource_Control
ElGUI..::..Slider

See Also

Slider Members
ElGUI Namespace


Slider Members

[image] [image]

4 of William Foster's Class Libraries
Slider Members
Slider Class Constructors Methods Fields Properties See Also Send Feedback

The Slider type exposes the following members.

Constructors

 | Name | Description
Public method | Slider | Initializes a new instance of the Slider class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Overrides Resource_Control..::..Set(Object).)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetRange |
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Overrides Data_Resource_Control..::..Value.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Overrides Data_Resource_Control..::..Value_uint.)
Public property | window | (Inherited from UILayerWindow.)

See Also

Slider Class
ElGUI Namespace


Slider Constructor

[image]

4 of William Foster's Class Libraries
Slider Constructor
Slider Class See Also Send Feedback
Initializes a new instance of the Slider class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Slider(
    GUI gui,
    Window Parent,
    STRING csText,
    Resource_ID resourceID,
    Size2dU size
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    Parent As Window, _
    csText As STRING, _
    resourceID As Resource_ID, _
    size As Size2dU _
)
Visual C++
public:
Slider(
    GUI^ gui,
    Window^ Parent,
    STRING^ csText,
    Resource_ID resourceID,
    Size2dU^ size
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.Slider.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,El.Size2dU)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.Slider.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,El.Size2dU)"]

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.Slider.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,El.Size2dU)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.Slider.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,El.Size2dU)"]

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElGUI.Slider.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,El.Size2dU)"]

See Also

Slider Class
ElGUI Namespace


Slider Fields

[image] [image]

4 of William Foster's Class Libraries
Slider Fields
Slider Class See Also Send Feedback

The Slider type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

Slider Class
ElGUI Namespace


Slider Methods

[image] [image]

4 of William Foster's Class Libraries
Slider Methods
Slider Class See Also Send Feedback

The Slider type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Overrides Resource_Control..::..Set(Object).)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetRange |
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

Slider Class
ElGUI Namespace


GetText Method

[image] [image]

4 of William Foster's Class Libraries
Slider..::..GetText Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)

See Also

Slider Class
Slider Members
ElGUI Namespace


Set Method

[image]

4 of William Foster's Class Libraries
Slider..::..Set Method
Slider Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Slider.Set(System.Object)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void Set(
    Object val
)
Visual Basic
Public Overrides Sub Set ( _
    val As Object _
)
Visual C++
public:
virtual void Set(
    Object^ val
) override

Parameters

val
Type: System..::..Object

[Missing <param name="val"/> documentation for "M:ElGUI.Slider.Set(System.Object)"]

See Also

Slider Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
Slider..::..SetColor Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

Slider Class
Slider Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
Slider..::..SetDefaultCursor Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

Slider Class
Slider Members
ElGUI Namespace


SetRange Method

[image]

4 of William Foster's Class Libraries
Slider..::..SetRange Method
Slider Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Slider.SetRange(El.Range2d,System.Boolean)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetRange(
    Range2d range,
    bool bLoggy
)
Visual Basic
Public Sub SetRange ( _
    range As Range2d, _
    bLoggy As Boolean _
)
Visual C++
public:
void SetRange(
    Range2d^ range,
    bool bLoggy
)

Parameters

range
Type: Range2d

[Missing <param name="range"/> documentation for "M:ElGUI.Slider.SetRange(El.Range2d,System.Boolean)"]

bLoggy
Type: System..::..Boolean

[Missing <param name="bLoggy"/> documentation for "M:ElGUI.Slider.SetRange(El.Range2d,System.Boolean)"]

See Also

Slider Class
ElGUI Namespace


Slider Properties

[image] [image]

4 of William Foster's Class Libraries
Slider Properties
Slider Class See Also Send Feedback

The Slider type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Overrides Data_Resource_Control..::..Value.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Overrides Data_Resource_Control..::..Value_uint.)
Public property | window | (Inherited from UILayerWindow.)

See Also

Slider Class
ElGUI Namespace


Value Property

[image]

4 of William Foster's Class Libraries
Slider..::..Value Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.Slider.Value"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override double Value { get; set; }
Visual Basic
Public Overrides Property Value As Double
    Get
    Set
Visual C++
public:
virtual property double Value {
    double get () override;
    void set (double value) override;
}

See Also

Slider Class
ElGUI Namespace


Value_uint Property

[image]

4 of William Foster's Class Libraries
Slider..::..Value_uint Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.Slider.Value_uint"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override uint Value_uint { get; set; }
Visual Basic
Public Overrides Property Value_uint As UInteger
    Get
    Set
Visual C++
public:
virtual property unsigned int Value_uint {
    unsigned int get () override;
    void set (unsigned int value) override;
}

See Also

Slider Class
ElGUI Namespace


TextBox Class

[image]

4 of William Foster's Class Libraries
TextBox Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.TextBox"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TextBox : TextData_Resource_Control
Visual Basic
Public Class TextBox _
    Inherits TextData_Resource_Control
Visual C++
public ref class TextBox : public TextData_Resource_Control

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..Resource_Control
ElGUI..::..Data_Resource_Control
ElGUI..::..TextData_Resource_Control
ElGUI..::..TextBox

See Also

TextBox Members
ElGUI Namespace


TextBox Members

[image] [image]

4 of William Foster's Class Libraries
TextBox Members
TextBox Class Constructors Methods Fields Properties See Also Send Feedback

The TextBox type exposes the following members.

Constructors

 | Name | Description
Public method | TextBox | Initializes a new instance of the TextBox class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetAttribute |
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

TextBox Class
ElGUI Namespace


TextBox Constructor

[image]

4 of William Foster's Class Libraries
TextBox Constructor
TextBox Class See Also Send Feedback
Initializes a new instance of the TextBox class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TextBox(
    GUI gui,
    Window Parent,
    STRING csText,
    Resource_ID resourceID
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    Parent As Window, _
    csText As STRING, _
    resourceID As Resource_ID _
)
Visual C++
public:
TextBox(
    GUI^ gui,
    Window^ Parent,
    STRING^ csText,
    Resource_ID resourceID
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.TextBox.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.TextBox.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID)"]

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.TextBox.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.TextBox.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID)"]

See Also

TextBox Class
ElGUI Namespace


TextBox Fields

[image] [image]

4 of William Foster's Class Libraries
TextBox Fields
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

TextBox Class
ElGUI Namespace


TextBox Methods

[image] [image]

4 of William Foster's Class Libraries
TextBox Methods
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetAttribute |
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

TextBox Class
ElGUI Namespace


GetText Method

[image] [image]

4 of William Foster's Class Libraries
TextBox..::..GetText Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)

See Also

TextBox Class
TextBox Members
ElGUI Namespace


SetAttribute Method

[image]

4 of William Foster's Class Libraries
TextBox..::..SetAttribute Method
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.TextBox.SetAttribute(ElGUI.EBFC_GUIRES_ATTRIBUTE_KEY)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetAttribute(
    EBFC_GUIRES_ATTRIBUTE_KEY attribute
)
Visual Basic
Public Sub SetAttribute ( _
    attribute As EBFC_GUIRES_ATTRIBUTE_KEY _
)
Visual C++
public:
void SetAttribute(
    EBFC_GUIRES_ATTRIBUTE_KEY attribute
)

Parameters

attribute
Type: ElGUI..::..EBFC_GUIRES_ATTRIBUTE_KEY

[Missing <param name="attribute"/> documentation for "M:ElGUI.TextBox.SetAttribute(ElGUI.EBFC_GUIRES_ATTRIBUTE_KEY)"]

See Also

TextBox Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
TextBox..::..SetColor Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

TextBox Class
TextBox Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
TextBox..::..SetDefaultCursor Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

TextBox Class
TextBox Members
ElGUI Namespace


TextBox Properties

[image] [image]

4 of William Foster's Class Libraries
TextBox Properties
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Inherited from TextData_Resource_Control.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Inherited from TextData_Resource_Control.)
Public property | window | (Inherited from UILayerWindow.)

See Also

TextBox Class
ElGUI Namespace


TextData_Resource_Control Class

[image]

4 of William Foster's Class Libraries
TextData_Resource_Control Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.TextData_Resource_Control"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TextData_Resource_Control : Data_Resource_Control
Visual Basic
Public Class TextData_Resource_Control _
    Inherits Data_Resource_Control
Visual C++
public ref class TextData_Resource_Control : public Data_Resource_Control

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..Resource_Control
ElGUI..::..Data_Resource_Control
ElGUI..::..TextData_Resource_Control
ElGUI..::..CursesBox
ElGUI..::..ListControl
ElGUI..::..ProgressControl
ElGUI..::..TextBox

See Also

TextData_Resource_Control Members
ElGUI Namespace


TextData_Resource_Control Members

[image] [image]

4 of William Foster's Class Libraries
TextData_Resource_Control Members
TextData_Resource_Control Class Constructors Methods Fields Properties See Also Send Feedback

The TextData_Resource_Control type exposes the following members.

Constructors

 | Name | Description
Public method | TextData_Resource_Control | Initializes a new instance of the TextData_Resource_Control class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Overrides Data_Resource_Control..::..Value.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Overrides Data_Resource_Control..::..Value_uint.)
Public property | window | (Inherited from UILayerWindow.)

See Also

TextData_Resource_Control Class
ElGUI Namespace


TextData_Resource_Control Constructor

[image]

4 of William Foster's Class Libraries
TextData_Resource_Control Constructor
TextData_Resource_Control Class See Also Send Feedback
Initializes a new instance of the TextData_Resource_Control class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TextData_Resource_Control(
    GUI gui,
    Window Parent,
    STRING csText,
    Resource_ID resourceID,
    WINDOW_TYPE eType
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    Parent As Window, _
    csText As STRING, _
    resourceID As Resource_ID, _
    eType As WINDOW_TYPE _
)
Visual C++
public:
TextData_Resource_Control(
    GUI^ gui,
    Window^ Parent,
    STRING^ csText,
    Resource_ID resourceID,
    WINDOW_TYPE eType
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.TextData_Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.TextData_Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

csText
Type: STRING

[Missing <param name="csText"/> documentation for "M:ElGUI.TextData_Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.TextData_Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.TextData_Resource_Control.#ctor(ElGUI.GUI,ElGUI.Window,El.STRING,ElGUI.Resource_ID,ElGUI.WINDOW_TYPE)"]

See Also

TextData_Resource_Control Class
ElGUI Namespace


TextData_Resource_Control Fields

[image] [image]

4 of William Foster's Class Libraries
TextData_Resource_Control Fields
TextData_Resource_Control Class See Also Send Feedback

The TextData_Resource_Control type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

TextData_Resource_Control Class
ElGUI Namespace


TextData_Resource_Control Methods

[image] [image]

4 of William Foster's Class Libraries
TextData_Resource_Control Methods
TextData_Resource_Control Class See Also Send Feedback

The TextData_Resource_Control type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from Window.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from Window.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Resource_Control.)
Public method | OnMouseEnter | (Inherited from Resource_Control.)
Public method | OnMouseLeave | (Inherited from Resource_Control.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ProcessEvent | (Inherited from Resource_Control.)
Protected method | ProcessHandlers | (Inherited from Resource_Control.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | Set | (Inherited from Resource_Control.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from Resource_Control.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHandlers | (Inherited from Resource_Control.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

TextData_Resource_Control Class
ElGUI Namespace


GetText Method

[image] [image]

4 of William Foster's Class Libraries
TextData_Resource_Control..::..GetText Method
TextData_Resource_Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetText()()()() | (Inherited from Resource_Control.)
Public method | GetText(STRING%) | (Inherited from UILayerWindow.)

See Also

TextData_Resource_Control Class
TextData_Resource_Control Members
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
TextData_Resource_Control..::..SetColor Method
TextData_Resource_Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

TextData_Resource_Control Class
TextData_Resource_Control Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
TextData_Resource_Control..::..SetDefaultCursor Method
TextData_Resource_Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

TextData_Resource_Control Class
TextData_Resource_Control Members
ElGUI Namespace


TextData_Resource_Control Properties

[image] [image]

4 of William Foster's Class Libraries
TextData_Resource_Control Properties
TextData_Resource_Control Class See Also Send Feedback

The TextData_Resource_Control type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | Value | (Overrides Data_Resource_Control..::..Value.)
Public property | Value_int | (Inherited from Data_Resource_Control.)
Public property | Value_uint | (Overrides Data_Resource_Control..::..Value_uint.)
Public property | window | (Inherited from UILayerWindow.)

See Also

TextData_Resource_Control Class
ElGUI Namespace


Value Property

[image]

4 of William Foster's Class Libraries
TextData_Resource_Control..::..Value Property
TextData_Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.TextData_Resource_Control.Value"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override double Value { get; set; }
Visual Basic
Public Overrides Property Value As Double
    Get
    Set
Visual C++
public:
virtual property double Value {
    double get () override;
    void set (double value) override;
}

See Also

TextData_Resource_Control Class
ElGUI Namespace


Value_uint Property

[image]

4 of William Foster's Class Libraries
TextData_Resource_Control..::..Value_uint Property
TextData_Resource_Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.TextData_Resource_Control.Value_uint"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override uint Value_uint { get; set; }
Visual Basic
Public Overrides Property Value_uint As UInteger
    Get
    Set
Visual C++
public:
virtual property unsigned int Value_uint {
    unsigned int get () override;
    void set (unsigned int value) override;
}

See Also

TextData_Resource_Control Class
ElGUI Namespace


ToolBar Class

[image]

4 of William Foster's Class Libraries
ToolBar Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.ToolBar"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ToolBar : DialogWindow
Visual Basic
Public Class ToolBar _
    Inherits DialogWindow
Visual C++
public ref class ToolBar : public DialogWindow

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..MenuWindow
ElGUI..::..ResourceWindow
ElGUI..::..DialogWindow
ElGUI..::..ToolBar

See Also

ToolBar Members
ElGUI Namespace


ToolBar Members

[image] [image]

4 of William Foster's Class Libraries
ToolBar Members
ToolBar Class Constructors Methods Fields Properties See Also Send Feedback

The ToolBar type exposes the following members.

Constructors

 | Name | Description
Public method | ToolBar(GUI, STRING, Window) | Initializes a new instance of the ToolBar class
Public method | ToolBar(GUI, STRING, Window, ResourceStore) | Initializes a new instance of the ToolBar class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu | (Inherited from MenuWindow.)
Protected method | AddResourceControl | (Inherited from ResourceWindow.)
Protected method | AddSpacer | (Inherited from ResourceWindow.)
Protected method | AddSwitcher | (Inherited from ResourceWindow.)
Protected method | AddWindow | (Inherited from ResourceWindow.)
Protected method | AddWindows | (Inherited from ResourceWindow.)
Public method | AppendResourceContainer | (Inherited from ResourceWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Protected method | ButtonPress | (Inherited from DialogWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Protected method | CreateEntryList | (Inherited from ResourceWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | execute | (Inherited from DialogWindow.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Protected method | GetDP | (Inherited from DialogWindow.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Protected method | GetRCList | (Inherited from ResourceWindow.)
Protected method | GetResourceContainer | (Inherited from ResourceWindow.)
Public method | GetResourceControlList | (Inherited from DialogWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUI_Text(STRING, Filename%) | (Inherited from DialogWindow.)
Public method | GetUI_Text(STRING, STRING%) | (Inherited from DialogWindow.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitializeResourceID | (Inherited from ResourceWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Public method | Lookup_Resource_Control(STRING) | (Inherited from ResourceWindow.)
Public method | Lookup_Resource_Control(Resource_ID) | (Inherited from ResourceWindow.)
Public method | LookupResourceEntity | (Inherited from ResourceWindow.)
Public method | LookupResourceName | (Inherited from ResourceWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Overrides DialogWindow..::..OnCreate()()()().)
Protected method | OnDestroy | (Inherited from DialogWindow.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from MenuWindow.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from DialogWindow.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | RecordKeyboardShortcut | (Inherited from MenuWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Public method | SetDP | (Inherited from DialogWindow.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetResourceContainer | (Inherited from ResourceWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetUI_Text | (Inherited from DialogWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDS()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDS(Resource_Control) | Given a control on a Dialog, Fill it in with the data fom the Dialog's DX (Inherited from DialogWindow.)
Public method | UpdateDX()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDX(Button) | (Inherited from DialogWindow.)
Protected method | UpdateDX(Data_Resource_Control) | Called by DialogWindow.UpdateDX(Resource_Control RC) Given a Data_Resource_Control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)
Protected method | UpdateDX(Resource_Control) | Given a control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName | (Inherited from MenuWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Public field | m_ds | (Inherited from DialogWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_ResourceControl_List | (Inherited from ResourceWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ToolBar Class
ElGUI Namespace


ToolBar Constructor

[image] [image]

4 of William Foster's Class Libraries
ToolBar Constructor
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToolBar(GUI, STRING, Window) | Initializes a new instance of the ToolBar class
Public method | ToolBar(GUI, STRING, Window, ResourceStore) | Initializes a new instance of the ToolBar class

See Also

ToolBar Class
ToolBar Members
ElGUI Namespace


ToolBar Constructor (GUI, , Window)

[image]

4 of William Foster's Class Libraries
ToolBar Constructor (GUI, , Window)
ToolBar Class See Also Send Feedback
Initializes a new instance of the ToolBar class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ToolBar(
    GUI gui,
    STRING ResourceName,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    ResourceName As STRING, _
    Parent As Window _
)
Visual C++
public:
ToolBar(
    GUI^ gui,
    STRING^ ResourceName,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.ToolBar.#ctor(ElGUI.GUI,El.STRING,ElGUI.Window)"]

ResourceName
Type: STRING

[Missing <param name="ResourceName"/> documentation for "M:ElGUI.ToolBar.#ctor(ElGUI.GUI,El.STRING,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.ToolBar.#ctor(ElGUI.GUI,El.STRING,ElGUI.Window)"]

See Also

ToolBar Class
ToolBar Overload
ElGUI Namespace


ToolBar Constructor (GUI, , Window, ResourceStore)

[image]

4 of William Foster's Class Libraries
ToolBar Constructor (GUI, , Window, ResourceStore)
ToolBar Class See Also Send Feedback
Initializes a new instance of the ToolBar class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ToolBar(
    GUI gui,
    STRING ResourceName,
    Window Parent,
    ResourceStore ReStore
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    ResourceName As STRING, _
    Parent As Window, _
    ReStore As ResourceStore _
)
Visual C++
public:
ToolBar(
    GUI^ gui,
    STRING^ ResourceName,
    Window^ Parent,
    ResourceStore^ ReStore
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.ToolBar.#ctor(ElGUI.GUI,El.STRING,ElGUI.Window,ElGUI.ResourceStore)"]

ResourceName
Type: STRING

[Missing <param name="ResourceName"/> documentation for "M:ElGUI.ToolBar.#ctor(ElGUI.GUI,El.STRING,ElGUI.Window,ElGUI.ResourceStore)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.ToolBar.#ctor(ElGUI.GUI,El.STRING,ElGUI.Window,ElGUI.ResourceStore)"]

ReStore
Type: ElGUI..::..ResourceStore

[Missing <param name="ReStore"/> documentation for "M:ElGUI.ToolBar.#ctor(ElGUI.GUI,El.STRING,ElGUI.Window,ElGUI.ResourceStore)"]

See Also

ToolBar Class
ToolBar Overload
ElGUI Namespace


ToolBar Fields

[image] [image]

4 of William Foster's Class Libraries
ToolBar Fields
ToolBar Class See Also Send Feedback

The ToolBar type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName | (Inherited from MenuWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Public field | m_ds | (Inherited from DialogWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_ResourceControl_List | (Inherited from ResourceWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

ToolBar Class
ElGUI Namespace


ToolBar Methods

[image] [image]

4 of William Foster's Class Libraries
ToolBar Methods
ToolBar Class See Also Send Feedback

The ToolBar type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu | (Inherited from MenuWindow.)
Protected method | AddResourceControl | (Inherited from ResourceWindow.)
Protected method | AddSpacer | (Inherited from ResourceWindow.)
Protected method | AddSwitcher | (Inherited from ResourceWindow.)
Protected method | AddWindow | (Inherited from ResourceWindow.)
Protected method | AddWindows | (Inherited from ResourceWindow.)
Public method | AppendResourceContainer | (Inherited from ResourceWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Protected method | ButtonPress | (Inherited from DialogWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Protected method | CreateEntryList | (Inherited from ResourceWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | execute | (Inherited from DialogWindow.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Protected method | GetDP | (Inherited from DialogWindow.)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Protected method | GetRCList | (Inherited from ResourceWindow.)
Protected method | GetResourceContainer | (Inherited from ResourceWindow.)
Public method | GetResourceControlList | (Inherited from DialogWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUI_Text(STRING, Filename%) | (Inherited from DialogWindow.)
Public method | GetUI_Text(STRING, STRING%) | (Inherited from DialogWindow.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitializeResourceID | (Inherited from ResourceWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Public method | Lookup_Resource_Control(STRING) | (Inherited from ResourceWindow.)
Public method | Lookup_Resource_Control(Resource_ID) | (Inherited from ResourceWindow.)
Public method | LookupResourceEntity | (Inherited from ResourceWindow.)
Public method | LookupResourceName | (Inherited from ResourceWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Overrides DialogWindow..::..OnCreate()()()().)
Protected method | OnDestroy | (Inherited from DialogWindow.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from MenuWindow.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from DialogWindow.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | RecordKeyboardShortcut | (Inherited from MenuWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Public method | SetDP | (Inherited from DialogWindow.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetResourceContainer | (Inherited from ResourceWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetUI_Text | (Inherited from DialogWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDS()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDS(Resource_Control) | Given a control on a Dialog, Fill it in with the data fom the Dialog's DX (Inherited from DialogWindow.)
Public method | UpdateDX()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDX(Button) | (Inherited from DialogWindow.)
Protected method | UpdateDX(Data_Resource_Control) | Called by DialogWindow.UpdateDX(Resource_Control RC) Given a Data_Resource_Control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)
Protected method | UpdateDX(Resource_Control) | Given a control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

ToolBar Class
ElGUI Namespace


GetUI_Text Method

[image] [image]

4 of William Foster's Class Libraries
ToolBar..::..GetUI_Text Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUI_Text(STRING, Filename%) | (Inherited from DialogWindow.)
Public method | GetUI_Text(STRING, STRING%) | (Inherited from DialogWindow.)

See Also

ToolBar Class
ToolBar Members
ElGUI Namespace


Lookup_Resource_Control Method

[image] [image]

4 of William Foster's Class Libraries
ToolBar..::..Lookup_Resource_Control Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lookup_Resource_Control(STRING) | (Inherited from ResourceWindow.)
Public method | Lookup_Resource_Control(Resource_ID) | (Inherited from ResourceWindow.)

See Also

ToolBar Class
ToolBar Members
ElGUI Namespace


OnCreate Method

[image]

4 of William Foster's Class Libraries
ToolBar..::..OnCreate Method
ToolBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ToolBar.OnCreate"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool OnCreate()
Visual Basic
Protected Overrides Function OnCreate As Boolean
Visual C++
protected:
virtual bool OnCreate() override

Return Value

[Missing <returns> documentation for "M:ElGUI.ToolBar.OnCreate"]

See Also

ToolBar Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
ToolBar..::..SetColor Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

ToolBar Class
ToolBar Members
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
ToolBar..::..SetDefaultCursor Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

ToolBar Class
ToolBar Members
ElGUI Namespace


UpdateDS Method

[image] [image]

4 of William Foster's Class Libraries
ToolBar..::..UpdateDS Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateDS()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDS(Resource_Control) | Given a control on a Dialog, Fill it in with the data fom the Dialog's DX (Inherited from DialogWindow.)

See Also

ToolBar Class
ToolBar Members
ElGUI Namespace


UpdateDX Method

[image] [image]

4 of William Foster's Class Libraries
ToolBar..::..UpdateDX Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateDX()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDX(Button) | (Inherited from DialogWindow.)
Protected method | UpdateDX(Data_Resource_Control) | Called by DialogWindow.UpdateDX(Resource_Control RC) Given a Data_Resource_Control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)
Protected method | UpdateDX(Resource_Control) | Given a control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)

See Also

ToolBar Class
ToolBar Members
ElGUI Namespace


ToolBar Properties

[image] [image]

4 of William Foster's Class Libraries
ToolBar Properties
ToolBar Class See Also Send Feedback

The ToolBar type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ToolBar Class
ElGUI Namespace


ToolbarDP Class

[image]

4 of William Foster's Class Libraries
ToolbarDP Class
Members See Also Send Feedback
This simple DlgDP just stores the last selected button information. It is the responsibility of the application to read this data when (before) it uses the tool. Derive from this DP to make one that will feed your windows with the result.

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ToolbarDP : DlgDP
Visual Basic
Public Class ToolbarDP _
    Inherits DlgDP
Visual C++
public ref class ToolbarDP : public DlgDP

Inheritance Hierarchy

System..::..Object
ElGUI..::..DP
ElGUI..::..DlgDP
ElGUI..::..ToolbarDP

See Also

ToolbarDP Members
ElGUI Namespace


ToolbarDP Members

[image] [image]

4 of William Foster's Class Libraries
ToolbarDP Members
ToolbarDP Class Constructors Methods Fields See Also Send Feedback

The ToolbarDP type exposes the following members.

Constructors

 | Name | Description
Public method | ToolbarDP | Initializes a new instance of the ToolbarDP class

Methods

 | Name | Description
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetGUI | (Inherited from DlgDP.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview | (Inherited from DP.)
Public method | ProcessInput | (Overrides DlgDP..::..ProcessInput(Resource_Control, DialogWindow).)
Public method | RunDlg(DialogWindow, DP) | (Overrides DlgDP..::..RunDlg(DialogWindow, DP).)
Public method | RunDlg(Window, STRING) | (Inherited from DlgDP.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_csName |
Protected field | m_parent | (Inherited from DlgDP.)
Public field | m_rId |

See Also

ToolbarDP Class
ElGUI Namespace


ToolbarDP Constructor

[image]

4 of William Foster's Class Libraries
ToolbarDP Constructor
ToolbarDP Class See Also Send Feedback
Initializes a new instance of the ToolbarDP class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ToolbarDP(
    GUI gui
)
Visual Basic
Public Sub New ( _
    gui As GUI _
)
Visual C++
public:
ToolbarDP(
    GUI^ gui
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.ToolbarDP.#ctor(ElGUI.GUI)"]

See Also

ToolbarDP Class
ElGUI Namespace


ToolbarDP Fields

[image] [image]

4 of William Foster's Class Libraries
ToolbarDP Fields
ToolbarDP Class See Also Send Feedback

The ToolbarDP type exposes the following members.

Fields

 | Name | Description
Public field | m_csName |
Protected field | m_parent | (Inherited from DlgDP.)
Public field | m_rId |

See Also

ToolbarDP Class
ElGUI Namespace


m_csName Field

[image]

4 of William Foster's Class Libraries
ToolbarDP..::..m_csName Field
ToolbarDP Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ToolbarDP.m_csName"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING m_csName
Visual Basic
Public m_csName As STRING
Visual C++
public:
STRING^ m_csName

See Also

ToolbarDP Class
ElGUI Namespace


m_rId Field

[image]

4 of William Foster's Class Libraries
ToolbarDP..::..m_rId Field
ToolbarDP Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.ToolbarDP.m_rId"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Resource_ID m_rId
Visual Basic
Public m_rId As Resource_ID
Visual C++
public:
Resource_ID m_rId

See Also

ToolbarDP Class
ElGUI Namespace


ToolbarDP Methods

[image] [image]

4 of William Foster's Class Libraries
ToolbarDP Methods
ToolbarDP Class See Also Send Feedback

The ToolbarDP type exposes the following members.

Methods

 | Name | Description
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetGUI | (Inherited from DlgDP.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview | (Inherited from DP.)
Public method | ProcessInput | (Overrides DlgDP..::..ProcessInput(Resource_Control, DialogWindow).)
Public method | RunDlg(DialogWindow, DP) | (Overrides DlgDP..::..RunDlg(DialogWindow, DP).)
Public method | RunDlg(Window, STRING) | (Inherited from DlgDP.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ToolbarDP Class
ElGUI Namespace


ProcessInput Method

[image]

4 of William Foster's Class Libraries
ToolbarDP..::..ProcessInput Method
ToolbarDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ToolbarDP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool ProcessInput(
    Resource_Control Ctrl,
    DialogWindow DS
)
Visual Basic
Public Overrides Function ProcessInput ( _
    Ctrl As Resource_Control, _
    DS As DialogWindow _
) As Boolean
Visual C++
public:
virtual bool ProcessInput(
    Resource_Control^ Ctrl,
    DialogWindow^ DS
) override

Parameters

Ctrl
Type: ElGUI..::..Resource_Control

[Missing <param name="Ctrl"/> documentation for "M:ElGUI.ToolbarDP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

DS
Type: ElGUI..::..DialogWindow

[Missing <param name="DS"/> documentation for "M:ElGUI.ToolbarDP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ToolbarDP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

See Also

ToolbarDP Class
ElGUI Namespace


RunDlg Method

[image] [image]

4 of William Foster's Class Libraries
ToolbarDP..::..RunDlg Method
ToolbarDP Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RunDlg(DialogWindow, DP) | (Overrides DlgDP..::..RunDlg(DialogWindow, DP).)
Public method | RunDlg(Window, STRING) | (Inherited from DlgDP.)

See Also

ToolbarDP Class
ToolbarDP Members
ElGUI Namespace


RunDlg Method (DialogWindow, DP)

[image]

4 of William Foster's Class Libraries
ToolbarDP..::..RunDlg Method (DialogWindow, DP)
ToolbarDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.ToolbarDP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int RunDlg(
    DialogWindow dlg,
    DP PreviewDP
)
Visual Basic
Public Overrides Function RunDlg ( _
    dlg As DialogWindow, _
    PreviewDP As DP _
) As Integer
Visual C++
public:
virtual int RunDlg(
    DialogWindow^ dlg,
    DP^ PreviewDP
) override

Parameters

dlg
Type: ElGUI..::..DialogWindow

[Missing <param name="dlg"/> documentation for "M:ElGUI.ToolbarDP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

PreviewDP
Type: ElGUI..::..DP

[Missing <param name="PreviewDP"/> documentation for "M:ElGUI.ToolbarDP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.ToolbarDP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

See Also

ToolbarDP Class
RunDlg Overload
ElGUI Namespace


UILayerWindow Class

[image]

4 of William Foster's Class Libraries
UILayerWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.UILayerWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UILayerWindow
Visual Basic
Public Class UILayerWindow
Visual C++
public ref class UILayerWindow

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window

See Also

UILayerWindow Members
ElGUI Namespace


UILayerWindow Members

[image] [image]

4 of William Foster's Class Libraries
UILayerWindow Members
UILayerWindow Class Constructors Methods Fields Properties See Also Send Feedback

The UILayerWindow type exposes the following members.

Constructors

 | Name | Description
Public method | UILayerWindow | Initializes a new instance of the UILayerWindow class

Methods

 | Name | Description
Public method | AddControl |
Protected method | AddMatrix |
Public method | AppendText |
Public method | ChangeFocus |
Public method | Create |
Public method | CreateDC |
Public method | Dirty |
Public method | DoCreate |
Public method | DoModal |
Public method | DrawBitmap |
Public method | DrawEllipse |
Public method | DrawLine |
Public method | DrawPixel |
Public method | DrawRectangle |
Protected method | EndFrame |
Protected method | EndModal |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse |
Public method | FillRectangle |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetGUI |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex |
Public method | GetParent |
Public method | GetSizeOnScreen |
Public method | GetText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUpdateRect |
Public method | GetWindowType |
Public method | GetXYOfPos |
Public method | Hide |
Protected method | InitContent |
Public method | InitDocker |
Protected method | InitDockMan |
Public method | InitDocPane |
Protected method | InitWindowContent |
Public method | IsChildWindow |
Public method | IsControl |
Public method | IsElement |
Public method | IsMDIContainer |
Public method | IsTab |
Public method | IsWindow |
Public method | LayerSetFont |
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate |
Public method | OnMessage |
Protected method | OnRedraw |
Protected method | OnResize |
Protected method | PointFromScreen |
Public method | ReleaseDC |
Public method | ReplaceText |
Public method | RestrainDistance |
Public method | RestrainInteger |
Public method | RestrainNumeric |
Public method | RestrainPassword |
Public method | SelectAll |
Public method | SetAddtoTab |
Public method | SetColor |
Public method | SetData |
Public method | SetDefaultCursor(CURSOR) |
Public method | SetDefaultCursor(Image) |
Public method | SetDialogResult |
Protected method | SetEditable |
Protected method | SetFocus |
Public method | SetIndex |
Public method | SetText |
Public method | SetTextEditable |
Public method | SetTitle |
Public method | SetWindowDefault |
Public method | SetWindowFocus |
Public method | SetWindowPosition |
Public method | SetWindowSize |
Public method | Show |
Public method | SizeTextbox |
Public method | SizeToContent |
Protected method | Stop |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc |

Fields

 | Name | Description
Protected field | m_addgrid |
Protected field | m_brush |
Protected field | m_col |
Protected field | m_dockman |
Protected field | m_dockPane |
Protected field | m_documentPane |
Protected field | m_eWndType |
Protected field | m_graph |
Protected field | m_GUI |
Protected field | m_Panel |
Protected field | m_Parent |
Protected field | m_pen |
Protected field | m_resPanel |
Protected field | m_row |
Protected field | m_size |
Protected field | m_SysObject |

Properties

 | Name | Description
Public property | childitem |
Public property | control |
Public property | element |
Public property | tabitem |
Public property | toolbar |
Public property | window |

See Also

UILayerWindow Class
ElGUI Namespace


UILayerWindow Constructor

[image]

4 of William Foster's Class Libraries
UILayerWindow Constructor
UILayerWindow Class See Also Send Feedback
Initializes a new instance of the UILayerWindow class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UILayerWindow(
    GUI gui,
    string csTitle,
    WINDOW_TYPE eType,
    UILayerWindow Parent,
    Resource_ID resourceID
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    csTitle As String, _
    eType As WINDOW_TYPE, _
    Parent As UILayerWindow, _
    resourceID As Resource_ID _
)
Visual C++
public:
UILayerWindow(
    GUI^ gui,
    String^ csTitle,
    WINDOW_TYPE eType,
    UILayerWindow^ Parent,
    Resource_ID resourceID
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.UILayerWindow.#ctor(ElGUI.GUI,System.String,ElGUI.WINDOW_TYPE,ElGUI.UILayerWindow,ElGUI.Resource_ID)"]

csTitle
Type: System..::..String

[Missing <param name="csTitle"/> documentation for "M:ElGUI.UILayerWindow.#ctor(ElGUI.GUI,System.String,ElGUI.WINDOW_TYPE,ElGUI.UILayerWindow,ElGUI.Resource_ID)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.UILayerWindow.#ctor(ElGUI.GUI,System.String,ElGUI.WINDOW_TYPE,ElGUI.UILayerWindow,ElGUI.Resource_ID)"]

Parent
Type: ElGUI..::..UILayerWindow

[Missing <param name="Parent"/> documentation for "M:ElGUI.UILayerWindow.#ctor(ElGUI.GUI,System.String,ElGUI.WINDOW_TYPE,ElGUI.UILayerWindow,ElGUI.Resource_ID)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.UILayerWindow.#ctor(ElGUI.GUI,System.String,ElGUI.WINDOW_TYPE,ElGUI.UILayerWindow,ElGUI.Resource_ID)"]

See Also

UILayerWindow Class
ElGUI Namespace


UILayerWindow Fields

[image] [image]

4 of William Foster's Class Libraries
UILayerWindow Fields
UILayerWindow Class See Also Send Feedback

The UILayerWindow type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid |
Protected field | m_brush |
Protected field | m_col |
Protected field | m_dockman |
Protected field | m_dockPane |
Protected field | m_documentPane |
Protected field | m_eWndType |
Protected field | m_graph |
Protected field | m_GUI |
Protected field | m_Panel |
Protected field | m_Parent |
Protected field | m_pen |
Protected field | m_resPanel |
Protected field | m_row |
Protected field | m_size |
Protected field | m_SysObject |

See Also

UILayerWindow Class
ElGUI Namespace


m_addgrid Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_addgrid Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_addgrid"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Grid m_addgrid
Visual Basic
Protected m_addgrid As Grid
Visual C++
protected:
Grid^ m_addgrid

See Also

UILayerWindow Class
ElGUI Namespace


m_brush Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_brush Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_brush"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Brush m_brush
Visual Basic
Protected m_brush As Brush
Visual C++
protected:
Brush^ m_brush

See Also

UILayerWindow Class
ElGUI Namespace


m_col Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_col Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_col"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int m_col
Visual Basic
Protected m_col As Integer
Visual C++
protected:
int m_col

See Also

UILayerWindow Class
ElGUI Namespace


m_dockman Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_dockman Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_dockman"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected DockingManager m_dockman
Visual Basic
Protected m_dockman As DockingManager
Visual C++
protected:
DockingManager^ m_dockman

See Also

UILayerWindow Class
ElGUI Namespace


m_dockPane Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_dockPane Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_dockPane"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected DockablePane m_dockPane
Visual Basic
Protected m_dockPane As DockablePane
Visual C++
protected:
DockablePane^ m_dockPane

See Also

UILayerWindow Class
ElGUI Namespace


m_documentPane Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_documentPane Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_documentPane"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected DocumentPane m_documentPane
Visual Basic
Protected m_documentPane As DocumentPane
Visual C++
protected:
DocumentPane^ m_documentPane

See Also

UILayerWindow Class
ElGUI Namespace


m_eWndType Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_eWndType Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_eWndType"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected WINDOW_TYPE m_eWndType
Visual Basic
Protected m_eWndType As WINDOW_TYPE
Visual C++
protected:
WINDOW_TYPE m_eWndType

See Also

UILayerWindow Class
ElGUI Namespace


m_graph Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_graph Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_graph"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Graphics m_graph
Visual Basic
Protected m_graph As Graphics
Visual C++
protected:
Graphics^ m_graph

See Also

UILayerWindow Class
ElGUI Namespace


m_GUI Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_GUI Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_GUI"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected GUI m_GUI
Visual Basic
Protected m_GUI As GUI
Visual C++
protected:
GUI^ m_GUI

See Also

UILayerWindow Class
ElGUI Namespace


m_Panel Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_Panel Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_Panel"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected StackPanel m_Panel
Visual Basic
Protected m_Panel As StackPanel
Visual C++
protected:
StackPanel^ m_Panel

See Also

UILayerWindow Class
ElGUI Namespace


m_Parent Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_Parent Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_Parent"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected UILayerWindow m_Parent
Visual Basic
Protected m_Parent As UILayerWindow
Visual C++
protected:
UILayerWindow^ m_Parent

See Also

UILayerWindow Class
ElGUI Namespace


m_pen Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_pen Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_pen"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Pen m_pen
Visual Basic
Protected m_pen As Pen
Visual C++
protected:
Pen^ m_pen

See Also

UILayerWindow Class
ElGUI Namespace


m_resPanel Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_resPanel Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_resPanel"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ResizingPanel m_resPanel
Visual Basic
Protected m_resPanel As ResizingPanel
Visual C++
protected:
ResizingPanel^ m_resPanel

See Also

UILayerWindow Class
ElGUI Namespace


m_row Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_row Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_row"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int m_row
Visual Basic
Protected m_row As Integer
Visual C++
protected:
int m_row

See Also

UILayerWindow Class
ElGUI Namespace


m_size Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_size Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_size"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Size2dU m_size
Visual Basic
Protected m_size As Size2dU
Visual C++
protected:
Size2dU^ m_size

See Also

UILayerWindow Class
ElGUI Namespace


m_SysObject Field

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..m_SysObject Field
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.UILayerWindow.m_SysObject"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Object m_SysObject
Visual Basic
Protected m_SysObject As Object
Visual C++
protected:
Object^ m_SysObject

See Also

UILayerWindow Class
ElGUI Namespace


UILayerWindow Methods

[image] [image]

4 of William Foster's Class Libraries
UILayerWindow Methods
UILayerWindow Class See Also Send Feedback

The UILayerWindow type exposes the following members.

Methods

 | Name | Description
Public method | AddControl |
Protected method | AddMatrix |
Public method | AppendText |
Public method | ChangeFocus |
Public method | Create |
Public method | CreateDC |
Public method | Dirty |
Public method | DoCreate |
Public method | DoModal |
Public method | DrawBitmap |
Public method | DrawEllipse |
Public method | DrawLine |
Public method | DrawPixel |
Public method | DrawRectangle |
Protected method | EndFrame |
Protected method | EndModal |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse |
Public method | FillRectangle |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetGUI |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex |
Public method | GetParent |
Public method | GetSizeOnScreen |
Public method | GetText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUpdateRect |
Public method | GetWindowType |
Public method | GetXYOfPos |
Public method | Hide |
Protected method | InitContent |
Public method | InitDocker |
Protected method | InitDockMan |
Public method | InitDocPane |
Protected method | InitWindowContent |
Public method | IsChildWindow |
Public method | IsControl |
Public method | IsElement |
Public method | IsMDIContainer |
Public method | IsTab |
Public method | IsWindow |
Public method | LayerSetFont |
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate |
Public method | OnMessage |
Protected method | OnRedraw |
Protected method | OnResize |
Protected method | PointFromScreen |
Public method | ReleaseDC |
Public method | ReplaceText |
Public method | RestrainDistance |
Public method | RestrainInteger |
Public method | RestrainNumeric |
Public method | RestrainPassword |
Public method | SelectAll |
Public method | SetAddtoTab |
Public method | SetColor |
Public method | SetData |
Public method | SetDefaultCursor(CURSOR) |
Public method | SetDefaultCursor(Image) |
Public method | SetDialogResult |
Protected method | SetEditable |
Protected method | SetFocus |
Public method | SetIndex |
Public method | SetText |
Public method | SetTextEditable |
Public method | SetTitle |
Public method | SetWindowDefault |
Public method | SetWindowFocus |
Public method | SetWindowPosition |
Public method | SetWindowSize |
Public method | Show |
Public method | SizeTextbox |
Public method | SizeToContent |
Protected method | Stop |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc |

See Also

UILayerWindow Class
ElGUI Namespace


AddControl Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..AddControl Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.AddControl(System.Windows.UIElement)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddControl(
    UIElement elem
)
Visual Basic
Public Sub AddControl ( _
    elem As UIElement _
)
Visual C++
public:
void AddControl(
    UIElement^ elem
)

Parameters

elem
Type: System.Windows..::..UIElement

[Missing <param name="elem"/> documentation for "M:ElGUI.UILayerWindow.AddControl(System.Windows.UIElement)"]

See Also

UILayerWindow Class
ElGUI Namespace


AddMatrix Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..AddMatrix Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.AddMatrix(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void AddMatrix(
    Size2dU size
)
Visual Basic
Protected Sub AddMatrix ( _
    size As Size2dU _
)
Visual C++
protected:
void AddMatrix(
    Size2dU^ size
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElGUI.UILayerWindow.AddMatrix(El.Size2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


AppendText Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..AppendText Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.AppendText(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AppendText(
    STRING cs
)
Visual Basic
Public Sub AppendText ( _
    cs As STRING _
)
Visual C++
public:
void AppendText(
    STRING^ cs
)

Parameters

cs
Type: STRING

[Missing <param name="cs"/> documentation for "M:ElGUI.UILayerWindow.AppendText(El.STRING)"]

See Also

UILayerWindow Class
ElGUI Namespace


ChangeFocus Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..ChangeFocus Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.ChangeFocus(ElGUI.UILayerWindow)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ChangeFocus(
    UILayerWindow Child
)
Visual Basic
Public Sub ChangeFocus ( _
    Child As UILayerWindow _
)
Visual C++
public:
void ChangeFocus(
    UILayerWindow^ Child
)

Parameters

Child
Type: ElGUI..::..UILayerWindow

[Missing <param name="Child"/> documentation for "M:ElGUI.UILayerWindow.ChangeFocus(ElGUI.UILayerWindow)"]

See Also

UILayerWindow Class
ElGUI Namespace


Create Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..Create Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.Create"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Create()
Visual Basic
Public Function Create As Boolean
Visual C++
public:
bool Create()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.Create"]

See Also

UILayerWindow Class
ElGUI Namespace


CreateDC Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..CreateDC Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.CreateDC(El.Rect2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CreateDC(
    Rect2dU rect2d
)
Visual Basic
Public Function CreateDC ( _
    rect2d As Rect2dU _
) As Boolean
Visual C++
public:
bool CreateDC(
    Rect2dU^ rect2d
)

Parameters

rect2d
Type: Rect2dU

[Missing <param name="rect2d"/> documentation for "M:ElGUI.UILayerWindow.CreateDC(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.CreateDC(El.Rect2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


Dirty Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..Dirty Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.Dirty"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual void Dirty()
Visual Basic
Public Overridable Sub Dirty
Visual C++
public:
virtual void Dirty()

See Also

UILayerWindow Class
ElGUI Namespace


DoCreate Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..DoCreate Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.DoCreate"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void DoCreate()
Visual Basic
Public Sub DoCreate
Visual C++
public:
void DoCreate()

See Also

UILayerWindow Class
ElGUI Namespace


DoModal Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..DoModal Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.DoModal"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int DoModal()
Visual Basic
Public Overridable Function DoModal As Integer
Visual C++
public:
virtual int DoModal()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.DoModal"]

See Also

UILayerWindow Class
ElGUI Namespace


DrawBitmap Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..DrawBitmap Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.DrawBitmap(ElImage.Bitmap,El.Rect2dU,El.Size2dU,System.Double)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void DrawBitmap(
    Bitmap bmp,
    Rect2dU dest_rect,
    Size2dU source_origin,
    double zoom
)
Visual Basic
Public Sub DrawBitmap ( _
    bmp As Bitmap, _
    dest_rect As Rect2dU, _
    source_origin As Size2dU, _
    zoom As Double _
)
Visual C++
public:
void DrawBitmap(
    Bitmap^ bmp,
    Rect2dU^ dest_rect,
    Size2dU^ source_origin,
    double zoom
)

Parameters

bmp
Type: ElImage..::..Bitmap

[Missing <param name="bmp"/> documentation for "M:ElGUI.UILayerWindow.DrawBitmap(ElImage.Bitmap,El.Rect2dU,El.Size2dU,System.Double)"]

dest_rect
Type: Rect2dU

[Missing <param name="dest_rect"/> documentation for "M:ElGUI.UILayerWindow.DrawBitmap(ElImage.Bitmap,El.Rect2dU,El.Size2dU,System.Double)"]

source_origin
Type: Size2dU

[Missing <param name="source_origin"/> documentation for "M:ElGUI.UILayerWindow.DrawBitmap(ElImage.Bitmap,El.Rect2dU,El.Size2dU,System.Double)"]

zoom
Type: System..::..Double

[Missing <param name="zoom"/> documentation for "M:ElGUI.UILayerWindow.DrawBitmap(ElImage.Bitmap,El.Rect2dU,El.Size2dU,System.Double)"]

See Also

UILayerWindow Class
ElGUI Namespace


DrawEllipse Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..DrawEllipse Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.DrawEllipse(El.Rect2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void DrawEllipse(
    Rect2dU rect2d
)
Visual Basic
Public Sub DrawEllipse ( _
    rect2d As Rect2dU _
)
Visual C++
public:
void DrawEllipse(
    Rect2dU^ rect2d
)

Parameters

rect2d
Type: Rect2dU

[Missing <param name="rect2d"/> documentation for "M:ElGUI.UILayerWindow.DrawEllipse(El.Rect2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


DrawLine Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..DrawLine Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.DrawLine(El.Size2dU,El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void DrawLine(
    Size2dU pt1,
    Size2dU pt2
)
Visual Basic
Public Sub DrawLine ( _
    pt1 As Size2dU, _
    pt2 As Size2dU _
)
Visual C++
public:
void DrawLine(
    Size2dU^ pt1,
    Size2dU^ pt2
)

Parameters

pt1
Type: Size2dU

[Missing <param name="pt1"/> documentation for "M:ElGUI.UILayerWindow.DrawLine(El.Size2dU,El.Size2dU)"]

pt2
Type: Size2dU

[Missing <param name="pt2"/> documentation for "M:ElGUI.UILayerWindow.DrawLine(El.Size2dU,El.Size2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


DrawPixel Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..DrawPixel Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.DrawPixel(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void DrawPixel(
    Size2dU pt
)
Visual Basic
Public Sub DrawPixel ( _
    pt As Size2dU _
)
Visual C++
public:
void DrawPixel(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.UILayerWindow.DrawPixel(El.Size2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


DrawRectangle Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..DrawRectangle Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.DrawRectangle(El.Rect2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void DrawRectangle(
    Rect2dU rect2d
)
Visual Basic
Public Sub DrawRectangle ( _
    rect2d As Rect2dU _
)
Visual C++
public:
void DrawRectangle(
    Rect2dU^ rect2d
)

Parameters

rect2d
Type: Rect2dU

[Missing <param name="rect2d"/> documentation for "M:ElGUI.UILayerWindow.DrawRectangle(El.Rect2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


EndFrame Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..EndFrame Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.EndFrame"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void EndFrame()
Visual Basic
Protected Sub EndFrame
Visual C++
protected:
void EndFrame()

See Also

UILayerWindow Class
ElGUI Namespace


EndModal Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..EndModal Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.EndModal(System.Int32,System.String)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void EndModal(
    int i_exitvalue,
    string csText
)
Visual Basic
Protected Overridable Sub EndModal ( _
    i_exitvalue As Integer, _
    csText As String _
)
Visual C++
protected:
virtual void EndModal(
    int i_exitvalue,
    String^ csText
)

Parameters

i_exitvalue
Type: System..::..Int32

[Missing <param name="i_exitvalue"/> documentation for "M:ElGUI.UILayerWindow.EndModal(System.Int32,System.String)"]

csText
Type: System..::..String

[Missing <param name="csText"/> documentation for "M:ElGUI.UILayerWindow.EndModal(System.Int32,System.String)"]

See Also

UILayerWindow Class
ElGUI Namespace


FillEllipse Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..FillEllipse Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.FillEllipse(El.Rect2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void FillEllipse(
    Rect2dU rect2d
)
Visual Basic
Public Sub FillEllipse ( _
    rect2d As Rect2dU _
)
Visual C++
public:
void FillEllipse(
    Rect2dU^ rect2d
)

Parameters

rect2d
Type: Rect2dU

[Missing <param name="rect2d"/> documentation for "M:ElGUI.UILayerWindow.FillEllipse(El.Rect2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


FillRectangle Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..FillRectangle Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.FillRectangle(El.Rect2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void FillRectangle(
    Rect2dU rect2d
)
Visual Basic
Public Sub FillRectangle ( _
    rect2d As Rect2dU _
)
Visual C++
public:
void FillRectangle(
    Rect2dU^ rect2d
)

Parameters

rect2d
Type: Rect2dU

[Missing <param name="rect2d"/> documentation for "M:ElGUI.UILayerWindow.FillRectangle(El.Rect2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


GetGUI Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..GetGUI Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.GetGUI"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GUI GetGUI()
Visual Basic
Public Function GetGUI As GUI
Visual C++
public:
GUI^ GetGUI()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.GetGUI"]

See Also

UILayerWindow Class
ElGUI Namespace


GetIndex Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..GetIndex Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.GetIndex"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint GetIndex()
Visual Basic
Public Function GetIndex As UInteger
Visual C++
public:
unsigned int GetIndex()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.GetIndex"]

See Also

UILayerWindow Class
ElGUI Namespace


GetParent Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..GetParent Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.GetParent"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UILayerWindow GetParent()
Visual Basic
Public Function GetParent As UILayerWindow
Visual C++
public:
UILayerWindow^ GetParent()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.GetParent"]

See Also

UILayerWindow Class
ElGUI Namespace


GetSizeOnScreen Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..GetSizeOnScreen Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.GetSizeOnScreen(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Size2dU GetSizeOnScreen(
    STRING cs
)
Visual Basic
Public Function GetSizeOnScreen ( _
    cs As STRING _
) As Size2dU
Visual C++
public:
Size2dU^ GetSizeOnScreen(
    STRING^ cs
)

Parameters

cs
Type: STRING

[Missing <param name="cs"/> documentation for "M:ElGUI.UILayerWindow.GetSizeOnScreen(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.GetSizeOnScreen(El.STRING)"]

See Also

UILayerWindow Class
ElGUI Namespace


GetText Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..GetText Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.GetText(El.STRING@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint GetText(
    out STRING cs
)
Visual Basic
Public Function GetText ( _
    <OutAttribute> ByRef cs As STRING _
) As UInteger
Visual C++
public:
unsigned int GetText(
    [OutAttribute] STRING^% cs
)

Parameters

cs
Type: STRING%

[Missing <param name="cs"/> documentation for "M:ElGUI.UILayerWindow.GetText(El.STRING@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.GetText(El.STRING@)"]

See Also

UILayerWindow Class
ElGUI Namespace


GetUpdateRect Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..GetUpdateRect Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.GetUpdateRect(System.Int32,System.Drawing.Rectangle@,System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static int GetUpdateRect(
    int hwnd,
    ref Rectangle lpRect,
    int bErase
)
Visual Basic
Public Shared Function GetUpdateRect ( _
    hwnd As Integer, _
    ByRef lpRect As Rectangle, _
    bErase As Integer _
) As Integer
Visual C++
public:
static int GetUpdateRect(
    int hwnd,
    Rectangle% lpRect,
    int bErase
)

Parameters

hwnd
Type: System..::..Int32

[Missing <param name="hwnd"/> documentation for "M:ElGUI.UILayerWindow.GetUpdateRect(System.Int32,System.Drawing.Rectangle@,System.Int32)"]

lpRect
Type: System.Drawing..::..Rectangle %

[Missing <param name="lpRect"/> documentation for "M:ElGUI.UILayerWindow.GetUpdateRect(System.Int32,System.Drawing.Rectangle@,System.Int32)"]

bErase
Type: System..::..Int32

[Missing <param name="bErase"/> documentation for "M:ElGUI.UILayerWindow.GetUpdateRect(System.Int32,System.Drawing.Rectangle@,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.GetUpdateRect(System.Int32,System.Drawing.Rectangle@,System.Int32)"]

See Also

UILayerWindow Class
ElGUI Namespace


GetWindowType Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..GetWindowType Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.GetWindowType"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WINDOW_TYPE GetWindowType()
Visual Basic
Public Function GetWindowType As WINDOW_TYPE
Visual C++
public:
WINDOW_TYPE GetWindowType()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.GetWindowType"]

See Also

UILayerWindow Class
ElGUI Namespace


GetXYOfPos Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..GetXYOfPos Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.GetXYOfPos(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Size2dU GetXYOfPos(
    Size2dU pos
)
Visual Basic
Public Function GetXYOfPos ( _
    pos As Size2dU _
) As Size2dU
Visual C++
public:
Size2dU^ GetXYOfPos(
    Size2dU^ pos
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElGUI.UILayerWindow.GetXYOfPos(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.GetXYOfPos(El.Size2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


Hide Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..Hide Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.Hide"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Hide()
Visual Basic
Public Sub Hide
Visual C++
public:
void Hide()

See Also

UILayerWindow Class
ElGUI Namespace


InitContent Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..InitContent Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.InitContent"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void InitContent()
Visual Basic
Protected Sub InitContent
Visual C++
protected:
void InitContent()

See Also

UILayerWindow Class
ElGUI Namespace


InitDocker Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..InitDocker Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.InitDocker(System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void InitDocker(
    int width
)
Visual Basic
Public Sub InitDocker ( _
    width As Integer _
)
Visual C++
public:
void InitDocker(
    int width
)

Parameters

width
Type: System..::..Int32

[Missing <param name="width"/> documentation for "M:ElGUI.UILayerWindow.InitDocker(System.Int32)"]

See Also

UILayerWindow Class
ElGUI Namespace


InitDockMan Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..InitDockMan Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.InitDockMan"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void InitDockMan()
Visual Basic
Protected Sub InitDockMan
Visual C++
protected:
void InitDockMan()

See Also

UILayerWindow Class
ElGUI Namespace


InitDocPane Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..InitDocPane Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.InitDocPane(System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void InitDocPane(
    int width
)
Visual Basic
Public Sub InitDocPane ( _
    width As Integer _
)
Visual C++
public:
void InitDocPane(
    int width
)

Parameters

width
Type: System..::..Int32

[Missing <param name="width"/> documentation for "M:ElGUI.UILayerWindow.InitDocPane(System.Int32)"]

See Also

UILayerWindow Class
ElGUI Namespace


InitWindowContent Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..InitWindowContent Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.InitWindowContent"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void InitWindowContent()
Visual Basic
Protected Sub InitWindowContent
Visual C++
protected:
void InitWindowContent()

See Also

UILayerWindow Class
ElGUI Namespace


IsChildWindow Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..IsChildWindow Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.IsChildWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsChildWindow()
Visual Basic
Public Function IsChildWindow As Boolean
Visual C++
public:
bool IsChildWindow()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.IsChildWindow"]

See Also

UILayerWindow Class
ElGUI Namespace


IsControl Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..IsControl Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.IsControl"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsControl()
Visual Basic
Public Function IsControl As Boolean
Visual C++
public:
bool IsControl()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.IsControl"]

See Also

UILayerWindow Class
ElGUI Namespace


IsElement Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..IsElement Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.IsElement"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsElement()
Visual Basic
Public Function IsElement As Boolean
Visual C++
public:
bool IsElement()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.IsElement"]

See Also

UILayerWindow Class
ElGUI Namespace


IsMDIContainer Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..IsMDIContainer Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.IsMDIContainer"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsMDIContainer()
Visual Basic
Public Function IsMDIContainer As Boolean
Visual C++
public:
bool IsMDIContainer()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.IsMDIContainer"]

See Also

UILayerWindow Class
ElGUI Namespace


IsTab Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..IsTab Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.IsTab"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsTab()
Visual Basic
Public Function IsTab As Boolean
Visual C++
public:
bool IsTab()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.IsTab"]

See Also

UILayerWindow Class
ElGUI Namespace


IsWindow Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..IsWindow Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.IsWindow"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsWindow()
Visual Basic
Public Function IsWindow As Boolean
Visual C++
public:
bool IsWindow()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.IsWindow"]

See Also

UILayerWindow Class
ElGUI Namespace


LayerSetFont Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..LayerSetFont Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.LayerSetFont(El.STRING,System.Double)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LayerSetFont(
    STRING fontname,
    double d_pointSize
)
Visual Basic
Public Function LayerSetFont ( _
    fontname As STRING, _
    d_pointSize As Double _
) As Boolean
Visual C++
public:
bool LayerSetFont(
    STRING^ fontname,
    double d_pointSize
)

Parameters

fontname
Type: STRING

[Missing <param name="fontname"/> documentation for "M:ElGUI.UILayerWindow.LayerSetFont(El.STRING,System.Double)"]

d_pointSize
Type: System..::..Double

[Missing <param name="d_pointSize"/> documentation for "M:ElGUI.UILayerWindow.LayerSetFont(El.STRING,System.Double)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.LayerSetFont(El.STRING,System.Double)"]

See Also

UILayerWindow Class
ElGUI Namespace


MakeSysObject Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..MakeSysObject Method
UILayerWindow Class See Also Send Feedback
Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void MakeSysObject(
    string csTitle,
    Resource_ID resourceID
)
Visual Basic
Protected Overridable Sub MakeSysObject ( _
    csTitle As String, _
    resourceID As Resource_ID _
)
Visual C++
protected:
virtual void MakeSysObject(
    String^ csTitle,
    Resource_ID resourceID
)

Parameters

csTitle
Type: System..::..String

[Missing <param name="csTitle"/> documentation for "M:ElGUI.UILayerWindow.MakeSysObject(System.String,ElGUI.Resource_ID)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.UILayerWindow.MakeSysObject(System.String,ElGUI.Resource_ID)"]

See Also

UILayerWindow Class
ElGUI Namespace


OnCreate Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..OnCreate Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.OnCreate"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual bool OnCreate()
Visual Basic
Protected Overridable Function OnCreate As Boolean
Visual C++
protected:
virtual bool OnCreate()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.OnCreate"]

See Also

UILayerWindow Class
ElGUI Namespace


OnMessage Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..OnMessage Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.OnMessage(ElGUI.Message)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMessage(
    Message msg
)
Visual Basic
Public Overridable Function OnMessage ( _
    msg As Message _
) As Integer
Visual C++
public:
virtual int OnMessage(
    Message^ msg
)

Parameters

msg
Type: ElGUI..::..Message

[Missing <param name="msg"/> documentation for "M:ElGUI.UILayerWindow.OnMessage(ElGUI.Message)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.OnMessage(ElGUI.Message)"]

See Also

UILayerWindow Class
ElGUI Namespace


OnRedraw Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..OnRedraw Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.OnRedraw(ElVector.Shape2d)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual bool OnRedraw(
    Shape2d shapeDraw
)
Visual Basic
Protected Overridable Function OnRedraw ( _
    shapeDraw As Shape2d _
) As Boolean
Visual C++
protected:
virtual bool OnRedraw(
    Shape2d^ shapeDraw
)

Parameters

shapeDraw
Type: Shape2d

[Missing <param name="shapeDraw"/> documentation for "M:ElGUI.UILayerWindow.OnRedraw(ElVector.Shape2d)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.OnRedraw(ElVector.Shape2d)"]

See Also

UILayerWindow Class
ElGUI Namespace


OnResize Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..OnResize Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.OnResize(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual int OnResize(
    Size2dU size
)
Visual Basic
Protected Overridable Function OnResize ( _
    size As Size2dU _
) As Integer
Visual C++
protected:
virtual int OnResize(
    Size2dU^ size
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElGUI.UILayerWindow.OnResize(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.OnResize(El.Size2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


PointFromScreen Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..PointFromScreen Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.PointFromScreen(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Size2dU PointFromScreen(
    Size2dU pos
)
Visual Basic
Protected Function PointFromScreen ( _
    pos As Size2dU _
) As Size2dU
Visual C++
protected:
Size2dU^ PointFromScreen(
    Size2dU^ pos
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElGUI.UILayerWindow.PointFromScreen(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.PointFromScreen(El.Size2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


ReleaseDC Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..ReleaseDC Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.ReleaseDC"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ReleaseDC()
Visual Basic
Public Sub ReleaseDC
Visual C++
public:
void ReleaseDC()

See Also

UILayerWindow Class
ElGUI Namespace


ReplaceText Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..ReplaceText Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.ReplaceText(System.UInt32,System.UInt32,System.String)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ReplaceText(
    uint pos,
    uint dlength,
    string s
)
Visual Basic
Public Sub ReplaceText ( _
    pos As UInteger, _
    dlength As UInteger, _
    s As String _
)
Visual C++
public:
void ReplaceText(
    unsigned int pos,
    unsigned int dlength,
    String^ s
)

Parameters

pos
Type: System..::..UInt32

[Missing <param name="pos"/> documentation for "M:ElGUI.UILayerWindow.ReplaceText(System.UInt32,System.UInt32,System.String)"]

dlength
Type: System..::..UInt32

[Missing <param name="dlength"/> documentation for "M:ElGUI.UILayerWindow.ReplaceText(System.UInt32,System.UInt32,System.String)"]

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:ElGUI.UILayerWindow.ReplaceText(System.UInt32,System.UInt32,System.String)"]

See Also

UILayerWindow Class
ElGUI Namespace


RestrainDistance Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..RestrainDistance Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.RestrainDistance"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RestrainDistance()
Visual Basic
Public Sub RestrainDistance
Visual C++
public:
void RestrainDistance()

See Also

UILayerWindow Class
ElGUI Namespace


RestrainInteger Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..RestrainInteger Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.RestrainInteger"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RestrainInteger()
Visual Basic
Public Sub RestrainInteger
Visual C++
public:
void RestrainInteger()

See Also

UILayerWindow Class
ElGUI Namespace


RestrainNumeric Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..RestrainNumeric Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.RestrainNumeric"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RestrainNumeric()
Visual Basic
Public Sub RestrainNumeric
Visual C++
public:
void RestrainNumeric()

See Also

UILayerWindow Class
ElGUI Namespace


RestrainPassword Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..RestrainPassword Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.RestrainPassword"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RestrainPassword()
Visual Basic
Public Sub RestrainPassword
Visual C++
public:
void RestrainPassword()

See Also

UILayerWindow Class
ElGUI Namespace


SelectAll Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SelectAll Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SelectAll"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SelectAll()
Visual Basic
Public Sub SelectAll
Visual C++
public:
void SelectAll()

See Also

UILayerWindow Class
ElGUI Namespace


SetAddtoTab Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetAddtoTab Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetAddtoTab(System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetAddtoTab(
    int tabNo
)
Visual Basic
Public Sub SetAddtoTab ( _
    tabNo As Integer _
)
Visual C++
public:
void SetAddtoTab(
    int tabNo
)

Parameters

tabNo
Type: System..::..Int32

[Missing <param name="tabNo"/> documentation for "M:ElGUI.UILayerWindow.SetAddtoTab(System.Int32)"]

See Also

UILayerWindow Class
ElGUI Namespace


SetColor Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetColor Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetColor(System.UInt32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetColor(
    uint color
)
Visual Basic
Public Sub SetColor ( _
    color As UInteger _
)
Visual C++
public:
void SetColor(
    unsigned int color
)

Parameters

color
Type: System..::..UInt32

[Missing <param name="color"/> documentation for "M:ElGUI.UILayerWindow.SetColor(System.UInt32)"]

See Also

UILayerWindow Class
ElGUI Namespace


SetData Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetData Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetData(System.Windows.Media.Geometry)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetData(
    Geometry geom
)
Visual Basic
Public Sub SetData ( _
    geom As Geometry _
)
Visual C++
public:
void SetData(
    Geometry^ geom
)

Parameters

geom
Type: System.Windows.Media..::..Geometry

[Missing <param name="geom"/> documentation for "M:ElGUI.UILayerWindow.SetData(System.Windows.Media.Geometry)"]

See Also

UILayerWindow Class
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetDefaultCursor Method
UILayerWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) |
Public method | SetDefaultCursor(Image) |

See Also

UILayerWindow Class
UILayerWindow Members
ElGUI Namespace


SetDefaultCursor Method (CURSOR)

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetDefaultCursor Method (CURSOR)
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetDefaultCursor(ElGUI.CURSOR)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CURSOR SetDefaultCursor(
    CURSOR eCur
)
Visual Basic
Public Function SetDefaultCursor ( _
    eCur As CURSOR _
) As CURSOR
Visual C++
public:
CURSOR SetDefaultCursor(
    CURSOR eCur
)

Parameters

eCur
Type: ElGUI..::..CURSOR

[Missing <param name="eCur"/> documentation for "M:ElGUI.UILayerWindow.SetDefaultCursor(ElGUI.CURSOR)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.SetDefaultCursor(ElGUI.CURSOR)"]

See Also

UILayerWindow Class
SetDefaultCursor Overload
ElGUI Namespace


SetDefaultCursor Method (Image)

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetDefaultCursor Method (Image)
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetDefaultCursor(ElImage.Image)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetDefaultCursor(
    Image img
)
Visual Basic
Public Sub SetDefaultCursor ( _
    img As Image _
)
Visual C++
public:
void SetDefaultCursor(
    Image^ img
)

Parameters

img
Type: ElImage..::..Image

[Missing <param name="img"/> documentation for "M:ElGUI.UILayerWindow.SetDefaultCursor(ElImage.Image)"]

See Also

UILayerWindow Class
SetDefaultCursor Overload
ElGUI Namespace


SetDialogResult Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetDialogResult Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetDialogResult(System.Boolean)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetDialogResult(
    bool bResult
)
Visual Basic
Public Sub SetDialogResult ( _
    bResult As Boolean _
)
Visual C++
public:
void SetDialogResult(
    bool bResult
)

Parameters

bResult
Type: System..::..Boolean

[Missing <param name="bResult"/> documentation for "M:ElGUI.UILayerWindow.SetDialogResult(System.Boolean)"]

See Also

UILayerWindow Class
ElGUI Namespace


SetEditable Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetEditable Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetEditable(System.Boolean)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void SetEditable(
    bool bEditable
)
Visual Basic
Protected Sub SetEditable ( _
    bEditable As Boolean _
)
Visual C++
protected:
void SetEditable(
    bool bEditable
)

Parameters

bEditable
Type: System..::..Boolean

[Missing <param name="bEditable"/> documentation for "M:ElGUI.UILayerWindow.SetEditable(System.Boolean)"]

See Also

UILayerWindow Class
ElGUI Namespace


SetFocus Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetFocus Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetFocus"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void SetFocus()
Visual Basic
Protected Sub SetFocus
Visual C++
protected:
void SetFocus()

See Also

UILayerWindow Class
ElGUI Namespace


SetIndex Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetIndex Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetIndex(System.UInt32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetIndex(
    uint uIndex
)
Visual Basic
Public Sub SetIndex ( _
    uIndex As UInteger _
)
Visual C++
public:
void SetIndex(
    unsigned int uIndex
)

Parameters

uIndex
Type: System..::..UInt32

[Missing <param name="uIndex"/> documentation for "M:ElGUI.UILayerWindow.SetIndex(System.UInt32)"]

See Also

UILayerWindow Class
ElGUI Namespace


SetText Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetText Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetText(System.String)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual void SetText(
    string cs
)
Visual Basic
Public Overridable Sub SetText ( _
    cs As String _
)
Visual C++
public:
virtual void SetText(
    String^ cs
)

Parameters

cs
Type: System..::..String

[Missing <param name="cs"/> documentation for "M:ElGUI.UILayerWindow.SetText(System.String)"]

See Also

UILayerWindow Class
ElGUI Namespace


SetTextEditable Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetTextEditable Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetTextEditable(System.Boolean)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetTextEditable(
    bool bEditable
)
Visual Basic
Public Sub SetTextEditable ( _
    bEditable As Boolean _
)
Visual C++
public:
void SetTextEditable(
    bool bEditable
)

Parameters

bEditable
Type: System..::..Boolean

[Missing <param name="bEditable"/> documentation for "M:ElGUI.UILayerWindow.SetTextEditable(System.Boolean)"]

See Also

UILayerWindow Class
ElGUI Namespace


SetTitle Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetTitle Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetTitle(El.STRING)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetTitle(
    STRING cs
)
Visual Basic
Public Sub SetTitle ( _
    cs As STRING _
)
Visual C++
public:
void SetTitle(
    STRING^ cs
)

Parameters

cs
Type: STRING

[Missing <param name="cs"/> documentation for "M:ElGUI.UILayerWindow.SetTitle(El.STRING)"]

See Also

UILayerWindow Class
ElGUI Namespace


SetWindowDefault Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetWindowDefault Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetWindowDefault"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetWindowDefault()
Visual Basic
Public Sub SetWindowDefault
Visual C++
public:
void SetWindowDefault()

See Also

UILayerWindow Class
ElGUI Namespace


SetWindowFocus Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetWindowFocus Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetWindowFocus"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetWindowFocus()
Visual Basic
Public Sub SetWindowFocus
Visual C++
public:
void SetWindowFocus()

See Also

UILayerWindow Class
ElGUI Namespace


SetWindowPosition Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetWindowPosition Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetWindowPosition(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetWindowPosition(
    Size2dU pos
)
Visual Basic
Public Sub SetWindowPosition ( _
    pos As Size2dU _
)
Visual C++
public:
void SetWindowPosition(
    Size2dU^ pos
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElGUI.UILayerWindow.SetWindowPosition(El.Size2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


SetWindowSize Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SetWindowSize Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SetWindowSize(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetWindowSize(
    Size2dU size
)
Visual Basic
Public Sub SetWindowSize ( _
    size As Size2dU _
)
Visual C++
public:
void SetWindowSize(
    Size2dU^ size
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElGUI.UILayerWindow.SetWindowSize(El.Size2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


Show Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..Show Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.Show"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Show()
Visual Basic
Public Function Show As Boolean
Visual C++
public:
bool Show()

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.Show"]

See Also

UILayerWindow Class
ElGUI Namespace


SizeTextbox Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SizeTextbox Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SizeTextbox(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SizeTextbox(
    Size2dU size
)
Visual Basic
Public Function SizeTextbox ( _
    size As Size2dU _
) As Boolean
Visual C++
public:
bool SizeTextbox(
    Size2dU^ size
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElGUI.UILayerWindow.SizeTextbox(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.SizeTextbox(El.Size2dU)"]

See Also

UILayerWindow Class
ElGUI Namespace


SizeToContent Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..SizeToContent Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.SizeToContent"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SizeToContent()
Visual Basic
Public Sub SizeToContent
Visual C++
public:
void SizeToContent()

See Also

UILayerWindow Class
ElGUI Namespace


Stop Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..Stop Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.Stop(System.Int32)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void Stop(
    int i_exitvalue
)
Visual Basic
Protected Overridable Sub Stop ( _
    i_exitvalue As Integer _
)
Visual C++
protected:
virtual void Stop(
    int i_exitvalue
)

Parameters

i_exitvalue
Type: System..::..Int32

[Missing <param name="i_exitvalue"/> documentation for "M:ElGUI.UILayerWindow.Stop(System.Int32)"]

See Also

UILayerWindow Class
ElGUI Namespace


WndProc Method

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..WndProc Method
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.UILayerWindow.WndProc(System.IntPtr,System.Int32,System.IntPtr,System.IntPtr,System.Boolean@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr WndProc(
    IntPtr hwnd,
    int msg,
    IntPtr wParam,
    IntPtr lParam,
    ref bool handled
)
Visual Basic
Public Function WndProc ( _
    hwnd As IntPtr, _
    msg As Integer, _
    wParam As IntPtr, _
    lParam As IntPtr, _
    ByRef handled As Boolean _
) As IntPtr
Visual C++
public:
IntPtr WndProc(
    IntPtr hwnd,
    int msg,
    IntPtr wParam,
    IntPtr lParam,
    bool% handled
)

Parameters

hwnd
Type: System..::..IntPtr

[Missing <param name="hwnd"/> documentation for "M:ElGUI.UILayerWindow.WndProc(System.IntPtr,System.Int32,System.IntPtr,System.IntPtr,System.Boolean@)"]

msg
Type: System..::..Int32

[Missing <param name="msg"/> documentation for "M:ElGUI.UILayerWindow.WndProc(System.IntPtr,System.Int32,System.IntPtr,System.IntPtr,System.Boolean@)"]

wParam
Type: System..::..IntPtr

[Missing <param name="wParam"/> documentation for "M:ElGUI.UILayerWindow.WndProc(System.IntPtr,System.Int32,System.IntPtr,System.IntPtr,System.Boolean@)"]

lParam
Type: System..::..IntPtr

[Missing <param name="lParam"/> documentation for "M:ElGUI.UILayerWindow.WndProc(System.IntPtr,System.Int32,System.IntPtr,System.IntPtr,System.Boolean@)"]

handled
Type: System..::..Boolean %

[Missing <param name="handled"/> documentation for "M:ElGUI.UILayerWindow.WndProc(System.IntPtr,System.Int32,System.IntPtr,System.IntPtr,System.Boolean@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.UILayerWindow.WndProc(System.IntPtr,System.Int32,System.IntPtr,System.IntPtr,System.Boolean@)"]

See Also

UILayerWindow Class
ElGUI Namespace


UILayerWindow Properties

[image] [image]

4 of William Foster's Class Libraries
UILayerWindow Properties
UILayerWindow Class See Also Send Feedback

The UILayerWindow type exposes the following members.

Properties

 | Name | Description
Public property | childitem |
Public property | control |
Public property | element |
Public property | tabitem |
Public property | toolbar |
Public property | window |

See Also

UILayerWindow Class
ElGUI Namespace


childitem Property

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..childitem Property
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.UILayerWindow.childitem"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DockableContent childitem { get; }
Visual Basic
Public ReadOnly Property childitem As DockableContent
    Get
Visual C++
public:
property DockableContent^ childitem {
    DockableContent^ get ();
}

See Also

UILayerWindow Class
ElGUI Namespace


control Property

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..control Property
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.UILayerWindow.control"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Control control { get; }
Visual Basic
Public ReadOnly Property control As Control
    Get
Visual C++
public:
property Control^ control {
    Control^ get ();
}

See Also

UILayerWindow Class
ElGUI Namespace


element Property

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..element Property
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.UILayerWindow.element"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FrameworkElement element { get; }
Visual Basic
Public ReadOnly Property element As FrameworkElement
    Get
Visual C++
public:
property FrameworkElement^ element {
    FrameworkElement^ get ();
}

See Also

UILayerWindow Class
ElGUI Namespace


tabitem Property

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..tabitem Property
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.UILayerWindow.tabitem"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DocumentContent tabitem { get; }
Visual Basic
Public ReadOnly Property tabitem As DocumentContent
    Get
Visual C++
public:
property DocumentContent^ tabitem {
    DocumentContent^ get ();
}

See Also

UILayerWindow Class
ElGUI Namespace


toolbar Property

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..toolbar Property
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.UILayerWindow.toolbar"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CSys_Toolbar toolbar { get; }
Visual Basic
Public ReadOnly Property toolbar As CSys_Toolbar
    Get
Visual C++
public:
property CSys_Toolbar^ toolbar {
    CSys_Toolbar^ get ();
}

See Also

UILayerWindow Class
ElGUI Namespace


window Property

[image]

4 of William Foster's Class Libraries
UILayerWindow..::..window Property
UILayerWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ElGUI.UILayerWindow.window"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Window window { get; }
Visual Basic
Public ReadOnly Property window As Window
    Get
Visual C++
public:
property Window^ window {
    Window^ get ();
}

See Also

UILayerWindow Class
ElGUI Namespace


Window Class

[image]

4 of William Foster's Class Libraries
Window Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.Window"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Window : UILayerWindow, ITerminalWindow
Visual Basic
Public Class Window _
    Inherits UILayerWindow _
    Implements ITerminalWindow
Visual C++
public ref class Window : public UILayerWindow,
    ITerminalWindow

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..CursesWindow
ElGUI..::..GetcWindow
ElGUI..::..GetlineWindow
ElGUI..::..MenuWindow
ElGUI..::..Resource_Control

See Also

Window Members
ElGUI Namespace


Window Members

[image] [image]

4 of William Foster's Class Libraries
Window Members
Window Class Constructors Methods Fields Properties See Also Send Feedback

The Window type exposes the following members.

Constructors

 | Name | Description
Public method | Window(GUI, String, WINDOW_TYPE, Window) | Initializes a new instance of the Window class
Public method | Window(GUI, STRING, array<Char>[]()[][], WINDOW_TYPE, Window) | Initializes a new instance of the Window class
Public method | Window(GUI, STRING, WINDOW_TYPE, Window, Resource_ID, ResourceStore) | Initializes a new instance of the Window class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape |
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID |
Public method | GetResourceStore |
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline |
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty |
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible |
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy |
Public method | OnFocusIn |
Public method | OnFocusOut |
Public method | OnKeyDown |
Public method | OnKeyUp |
Public method | OnMessage | (Overrides UILayerWindow..::..OnMessage(Message).)
Public method | OnMouseDoubleClick |
Public method | OnMouseDown |
Public method | OnMouseEnter |
Public method | OnMouseLeave |
Public method | OnMouseMove |
Public method | OnMouseUp |
Protected method | OnPaint |
Protected method | OnRedraw | (Overrides UILayerWindow..::..OnRedraw(Shape2d).)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ReflectInternalImage |
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal |
Protected method | RenderOutline |
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize |
Public method | SetClean |
Public method | SetClip |
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) |
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty |
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible |
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline |
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg |
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

Window Class
ElGUI Namespace


Window Constructor

[image] [image]

4 of William Foster's Class Libraries
Window Constructor
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Window(GUI, String, WINDOW_TYPE, Window) | Initializes a new instance of the Window class
Public method | Window(GUI, STRING, array<Char>[]()[][], WINDOW_TYPE, Window) | Initializes a new instance of the Window class
Public method | Window(GUI, STRING, WINDOW_TYPE, Window, Resource_ID, ResourceStore) | Initializes a new instance of the Window class

See Also

Window Class
Window Members
ElGUI Namespace


Window Constructor (GUI, String, WINDOW_TYPE, Window)

[image]

4 of William Foster's Class Libraries
Window Constructor (GUI, String, WINDOW_TYPE, Window)
Window Class See Also Send Feedback
Initializes a new instance of the Window class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Window(
    GUI gui,
    string csTitle,
    WINDOW_TYPE eType,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    csTitle As String, _
    eType As WINDOW_TYPE, _
    Parent As Window _
)
Visual C++
public:
Window(
    GUI^ gui,
    String^ csTitle,
    WINDOW_TYPE eType,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,System.String,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

csTitle
Type: System..::..String

[Missing <param name="csTitle"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,System.String,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,System.String,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,System.String,ElGUI.WINDOW_TYPE,ElGUI.Window)"]

See Also

Window Class
Window Overload
ElGUI Namespace


Window Constructor (GUI, , Char[], WINDOW_TYPE, Window)

[image]

4 of William Foster's Class Libraries
Window Constructor (GUI, , array<Char>[]()[][], WINDOW_TYPE, Window)
Window Class See Also Send Feedback
Initializes a new instance of the Window class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Window(
    GUI gui,
    STRING csTitle,
    char[] MemScript,
    WINDOW_TYPE eType,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    csTitle As STRING, _
    MemScript As Char(), _
    eType As WINDOW_TYPE, _
    Parent As Window _
)
Visual C++
public:
Window(
    GUI^ gui,
    STRING^ csTitle,
    array<wchar_t>^ MemScript,
    WINDOW_TYPE eType,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,El.STRING,System.Char[],ElGUI.WINDOW_TYPE,ElGUI.Window)"]

csTitle
Type: STRING

[Missing <param name="csTitle"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,El.STRING,System.Char[],ElGUI.WINDOW_TYPE,ElGUI.Window)"]

MemScript
Type: array< System..::..Char >[]()[][]

[Missing <param name="MemScript"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,El.STRING,System.Char[],ElGUI.WINDOW_TYPE,ElGUI.Window)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,El.STRING,System.Char[],ElGUI.WINDOW_TYPE,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,El.STRING,System.Char[],ElGUI.WINDOW_TYPE,ElGUI.Window)"]

See Also

Window Class
Window Overload
ElGUI Namespace


Window Constructor (GUI, , WINDOW_TYPE, Window, Resource_ID, ResourceStore)

[image]

4 of William Foster's Class Libraries
Window Constructor (GUI, , WINDOW_TYPE, Window, Resource_ID, ResourceStore)
Window Class See Also Send Feedback
Initializes a new instance of the Window class

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Window(
    GUI gui,
    STRING csTitle,
    WINDOW_TYPE eType,
    Window Parent,
    Resource_ID resourceID,
    ResourceStore ResourceStore
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    csTitle As STRING, _
    eType As WINDOW_TYPE, _
    Parent As Window, _
    resourceID As Resource_ID, _
    ResourceStore As ResourceStore _
)
Visual C++
public:
Window(
    GUI^ gui,
    STRING^ csTitle,
    WINDOW_TYPE eType,
    Window^ Parent,
    Resource_ID resourceID,
    ResourceStore^ ResourceStore
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID,ElGUI.ResourceStore)"]

csTitle
Type: STRING

[Missing <param name="csTitle"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID,ElGUI.ResourceStore)"]

eType
Type: ElGUI..::..WINDOW_TYPE

[Missing <param name="eType"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID,ElGUI.ResourceStore)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID,ElGUI.ResourceStore)"]

resourceID
Type: ElGUI..::..Resource_ID

[Missing <param name="resourceID"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID,ElGUI.ResourceStore)"]

ResourceStore
Type: ElGUI..::..ResourceStore

[Missing <param name="ResourceStore"/> documentation for "M:ElGUI.Window.#ctor(ElGUI.GUI,El.STRING,ElGUI.WINDOW_TYPE,ElGUI.Window,ElGUI.Resource_ID,ElGUI.ResourceStore)"]

See Also

Window Class
Window Overload
ElGUI Namespace


Window Fields

[image] [image]

4 of William Foster's Class Libraries
Window Fields
Window Class See Also Send Feedback

The Window type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg |
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

Window Class
ElGUI Namespace


m_msg Field

[image]

4 of William Foster's Class Libraries
Window..::..m_msg Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ElGUI.Window.m_msg"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Message m_msg
Visual Basic
Public m_msg As Message
Visual C++
public:
Message^ m_msg

See Also

Window Class
ElGUI Namespace


Window Methods

[image] [image]

4 of William Foster's Class Libraries
Window Methods
Window Class See Also Send Feedback

The Window type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape |
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID |
Public method | GetResourceStore |
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline |
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty |
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible |
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy |
Public method | OnFocusIn |
Public method | OnFocusOut |
Public method | OnKeyDown |
Public method | OnKeyUp |
Public method | OnMessage | (Overrides UILayerWindow..::..OnMessage(Message).)
Public method | OnMouseDoubleClick |
Public method | OnMouseDown |
Public method | OnMouseEnter |
Public method | OnMouseLeave |
Public method | OnMouseMove |
Public method | OnMouseUp |
Protected method | OnPaint |
Protected method | OnRedraw | (Overrides UILayerWindow..::..OnRedraw(Shape2d).)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | ReflectInternalImage |
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal |
Protected method | RenderOutline |
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize |
Public method | SetClean |
Public method | SetClip |
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) |
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty |
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible |
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline |
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

Window Class
ElGUI Namespace


Finalize Method

[image]

4 of William Foster's Class Libraries
Window..::..Finalize Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.Finalize"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Window Class
ElGUI Namespace


GetOutlineShape Method

[image]

4 of William Foster's Class Libraries
Window..::..GetOutlineShape Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.GetOutlineShape(ElVector.Shape2d@)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GetOutlineShape(
    out Shape2d shape
)
Visual Basic
Public Function GetOutlineShape ( _
    <OutAttribute> ByRef shape As Shape2d _
) As Boolean
Visual C++
public:
bool GetOutlineShape(
    [OutAttribute] Shape2d^% shape
)

Parameters

shape
Type: Shape2d%

[Missing <param name="shape"/> documentation for "M:ElGUI.Window.GetOutlineShape(ElVector.Shape2d@)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.GetOutlineShape(ElVector.Shape2d@)"]

See Also

Window Class
ElGUI Namespace


GetResourceID Method

[image]

4 of William Foster's Class Libraries
Window..::..GetResourceID Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.GetResourceID"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Resource_ID GetResourceID()
Visual Basic
Public Function GetResourceID As Resource_ID
Visual C++
public:
Resource_ID GetResourceID()

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.GetResourceID"]

See Also

Window Class
ElGUI Namespace


GetResourceStore Method

[image]

4 of William Foster's Class Libraries
Window..::..GetResourceStore Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.GetResourceStore"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual ResourceStore GetResourceStore()
Visual Basic
Public Overridable Function GetResourceStore As ResourceStore
Visual C++
public:
virtual ResourceStore^ GetResourceStore()

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.GetResourceStore"]

See Also

Window Class
ElGUI Namespace


GetWindowOutline Method

[image]

4 of William Foster's Class Libraries
Window..::..GetWindowOutline Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.GetWindowOutline(ElVector.Shape2d)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GetWindowOutline(
    Shape2d shape_outline
)
Visual Basic
Public Function GetWindowOutline ( _
    shape_outline As Shape2d _
) As Boolean
Visual C++
public:
bool GetWindowOutline(
    Shape2d^ shape_outline
)

Parameters

shape_outline
Type: Shape2d

[Missing <param name="shape_outline"/> documentation for "M:ElGUI.Window.GetWindowOutline(ElVector.Shape2d)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.GetWindowOutline(ElVector.Shape2d)"]

See Also

Window Class
ElGUI Namespace


IsDirty Method

[image]

4 of William Foster's Class Libraries
Window..::..IsDirty Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.IsDirty"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsDirty()
Visual Basic
Public Function IsDirty As Boolean
Visual C++
public:
bool IsDirty()

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.IsDirty"]

See Also

Window Class
ElGUI Namespace


IsVisible Method

[image]

4 of William Foster's Class Libraries
Window..::..IsVisible Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.IsVisible"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsVisible()
Visual Basic
Public Function IsVisible As Boolean
Visual C++
public:
bool IsVisible()

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.IsVisible"]

See Also

Window Class
ElGUI Namespace


OnDestroy Method

[image]

4 of William Foster's Class Libraries
Window..::..OnDestroy Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnDestroy"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual int OnDestroy()
Visual Basic
Protected Overridable Function OnDestroy As Integer
Visual C++
protected:
virtual int OnDestroy()

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnDestroy"]

See Also

Window Class
ElGUI Namespace


OnFocusIn Method

[image]

4 of William Foster's Class Libraries
Window..::..OnFocusIn Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnFocusIn"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnFocusIn()
Visual Basic
Public Overridable Function OnFocusIn As Integer
Visual C++
public:
virtual int OnFocusIn()

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnFocusIn"]

Implements

ITerminalWindow..::..OnFocusIn()()()()

See Also

Window Class
ElGUI Namespace


OnFocusOut Method

[image]

4 of William Foster's Class Libraries
Window..::..OnFocusOut Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnFocusOut"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnFocusOut()
Visual Basic
Public Overridable Function OnFocusOut As Integer
Visual C++
public:
virtual int OnFocusOut()

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnFocusOut"]

Implements

ITerminalWindow..::..OnFocusOut()()()()

See Also

Window Class
ElGUI Namespace


OnKeyDown Method

[image]

4 of William Foster's Class Libraries
Window..::..OnKeyDown Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnKeyDown(System.Char)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnKeyDown(
    char key
)
Visual Basic
Public Overridable Function OnKeyDown ( _
    key As Char _
) As Integer
Visual C++
public:
virtual int OnKeyDown(
    wchar_t key
)

Parameters

key
Type: System..::..Char

[Missing <param name="key"/> documentation for "M:ElGUI.Window.OnKeyDown(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnKeyDown(System.Char)"]

Implements

ITerminalWindow..::..OnKeyDown(Char)

See Also

Window Class
ElGUI Namespace


OnKeyUp Method

[image]

4 of William Foster's Class Libraries
Window..::..OnKeyUp Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnKeyUp(System.Char)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnKeyUp(
    char key
)
Visual Basic
Public Overridable Function OnKeyUp ( _
    key As Char _
) As Integer
Visual C++
public:
virtual int OnKeyUp(
    wchar_t key
)

Parameters

key
Type: System..::..Char

[Missing <param name="key"/> documentation for "M:ElGUI.Window.OnKeyUp(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnKeyUp(System.Char)"]

Implements

ITerminalWindow..::..OnKeyUp(Char)

See Also

Window Class
ElGUI Namespace


OnMessage Method

[image]

4 of William Foster's Class Libraries
Window..::..OnMessage Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnMessage(ElGUI.Message)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int OnMessage(
    Message msg
)
Visual Basic
Public Overrides Function OnMessage ( _
    msg As Message _
) As Integer
Visual C++
public:
virtual int OnMessage(
    Message^ msg
) override

Parameters

msg
Type: ElGUI..::..Message

[Missing <param name="msg"/> documentation for "M:ElGUI.Window.OnMessage(ElGUI.Message)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnMessage(ElGUI.Message)"]

Implements

ITerminalWindow..::..OnMessage(Message)

See Also

Window Class
ElGUI Namespace


OnMouseDoubleClick Method

[image]

4 of William Foster's Class Libraries
Window..::..OnMouseDoubleClick Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnMouseDoubleClick(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMouseDoubleClick(
    Size2dU pt
)
Visual Basic
Public Overridable Function OnMouseDoubleClick ( _
    pt As Size2dU _
) As Integer
Visual C++
public:
virtual int OnMouseDoubleClick(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.Window.OnMouseDoubleClick(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnMouseDoubleClick(El.Size2dU)"]

Implements

ITerminalWindow..::..OnMouseDoubleClick(Size2dU)

See Also

Window Class
ElGUI Namespace


OnMouseDown Method

[image]

4 of William Foster's Class Libraries
Window..::..OnMouseDown Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnMouseDown(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMouseDown(
    Size2dU pt
)
Visual Basic
Public Overridable Function OnMouseDown ( _
    pt As Size2dU _
) As Integer
Visual C++
public:
virtual int OnMouseDown(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.Window.OnMouseDown(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnMouseDown(El.Size2dU)"]

Implements

ITerminalWindow..::..OnMouseDown(Size2dU)

See Also

Window Class
ElGUI Namespace


OnMouseEnter Method

[image]

4 of William Foster's Class Libraries
Window..::..OnMouseEnter Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnMouseEnter"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMouseEnter()
Visual Basic
Public Overridable Function OnMouseEnter As Integer
Visual C++
public:
virtual int OnMouseEnter()

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnMouseEnter"]

Implements

ITerminalWindow..::..OnMouseEnter()()()()

See Also

Window Class
ElGUI Namespace


OnMouseLeave Method

[image]

4 of William Foster's Class Libraries
Window..::..OnMouseLeave Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnMouseLeave"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMouseLeave()
Visual Basic
Public Overridable Function OnMouseLeave As Integer
Visual C++
public:
virtual int OnMouseLeave()

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnMouseLeave"]

Implements

ITerminalWindow..::..OnMouseLeave()()()()

See Also

Window Class
ElGUI Namespace


OnMouseMove Method

[image]

4 of William Foster's Class Libraries
Window..::..OnMouseMove Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnMouseMove(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMouseMove(
    Size2dU pt
)
Visual Basic
Public Overridable Function OnMouseMove ( _
    pt As Size2dU _
) As Integer
Visual C++
public:
virtual int OnMouseMove(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.Window.OnMouseMove(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnMouseMove(El.Size2dU)"]

Implements

ITerminalWindow..::..OnMouseMove(Size2dU)

See Also

Window Class
ElGUI Namespace


OnMouseUp Method

[image]

4 of William Foster's Class Libraries
Window..::..OnMouseUp Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnMouseUp(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual int OnMouseUp(
    Size2dU pt
)
Visual Basic
Public Overridable Function OnMouseUp ( _
    pt As Size2dU _
) As Integer
Visual C++
public:
virtual int OnMouseUp(
    Size2dU^ pt
)

Parameters

pt
Type: Size2dU

[Missing <param name="pt"/> documentation for "M:ElGUI.Window.OnMouseUp(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnMouseUp(El.Size2dU)"]

Implements

ITerminalWindow..::..OnMouseUp(Size2dU)

See Also

Window Class
ElGUI Namespace


OnPaint Method

[image]

4 of William Foster's Class Libraries
Window..::..OnPaint Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnPaint(El.Rect2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual int OnPaint(
    Rect2dU rect2d
)
Visual Basic
Protected Overridable Function OnPaint ( _
    rect2d As Rect2dU _
) As Integer
Visual C++
protected:
virtual int OnPaint(
    Rect2dU^ rect2d
)

Parameters

rect2d
Type: Rect2dU

[Missing <param name="rect2d"/> documentation for "M:ElGUI.Window.OnPaint(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnPaint(El.Rect2dU)"]

See Also

Window Class
ElGUI Namespace


OnRedraw Method

[image]

4 of William Foster's Class Libraries
Window..::..OnRedraw Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.OnRedraw(ElVector.Shape2d)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool OnRedraw(
    Shape2d shapeDraw
)
Visual Basic
Protected Overrides Function OnRedraw ( _
    shapeDraw As Shape2d _
) As Boolean
Visual C++
protected:
virtual bool OnRedraw(
    Shape2d^ shapeDraw
) override

Parameters

shapeDraw
Type: Shape2d

[Missing <param name="shapeDraw"/> documentation for "M:ElGUI.Window.OnRedraw(ElVector.Shape2d)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.OnRedraw(ElVector.Shape2d)"]

See Also

Window Class
ElGUI Namespace


ReflectInternalImage Method

[image]

4 of William Foster's Class Libraries
Window..::..ReflectInternalImage Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.ReflectInternalImage(ElVector.Shape2d)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool ReflectInternalImage(
    Shape2d shapeDraw
)
Visual Basic
Protected Function ReflectInternalImage ( _
    shapeDraw As Shape2d _
) As Boolean
Visual C++
protected:
bool ReflectInternalImage(
    Shape2d^ shapeDraw
)

Parameters

shapeDraw
Type: Shape2d

[Missing <param name="shapeDraw"/> documentation for "M:ElGUI.Window.ReflectInternalImage(ElVector.Shape2d)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.ReflectInternalImage(ElVector.Shape2d)"]

See Also

Window Class
ElGUI Namespace


RenderInternal Method

[image]

4 of William Foster's Class Libraries
Window..::..RenderInternal Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.RenderInternal"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool RenderInternal()
Visual Basic
Protected Function RenderInternal As Boolean
Visual C++
protected:
bool RenderInternal()

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.RenderInternal"]

See Also

Window Class
ElGUI Namespace


RenderOutline Method

[image]

4 of William Foster's Class Libraries
Window..::..RenderOutline Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.RenderOutline(ElVector.Shape2d)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void RenderOutline(
    Shape2d shapeDraw
)
Visual Basic
Protected Sub RenderOutline ( _
    shapeDraw As Shape2d _
)
Visual C++
protected:
void RenderOutline(
    Shape2d^ shapeDraw
)

Parameters

shapeDraw
Type: Shape2d

[Missing <param name="shapeDraw"/> documentation for "M:ElGUI.Window.RenderOutline(ElVector.Shape2d)"]

See Also

Window Class
ElGUI Namespace


SetCanvasSize Method

[image]

4 of William Foster's Class Libraries
Window..::..SetCanvasSize Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.SetCanvasSize(El.Size2dU)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetCanvasSize(
    Size2dU size
)
Visual Basic
Public Sub SetCanvasSize ( _
    size As Size2dU _
)
Visual C++
public:
void SetCanvasSize(
    Size2dU^ size
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElGUI.Window.SetCanvasSize(El.Size2dU)"]

See Also

Window Class
ElGUI Namespace


SetClean Method

[image]

4 of William Foster's Class Libraries
Window..::..SetClean Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.SetClean"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetClean()
Visual Basic
Public Sub SetClean
Visual C++
public:
void SetClean()

See Also

Window Class
ElGUI Namespace


SetClip Method

[image]

4 of William Foster's Class Libraries
Window..::..SetClip Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.SetClip(ElVector.Shape2d)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetClip(
    Shape2d shapeClip
)
Visual Basic
Public Sub SetClip ( _
    shapeClip As Shape2d _
)
Visual C++
public:
void SetClip(
    Shape2d^ shapeClip
)

Parameters

shapeClip
Type: Shape2d

[Missing <param name="shapeClip"/> documentation for "M:ElGUI.Window.SetClip(ElVector.Shape2d)"]

See Also

Window Class
ElGUI Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
Window..::..SetColor Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) |

See Also

Window Class
Window Members
ElGUI Namespace


SetColor Method (Color)

[image]

4 of William Foster's Class Libraries
Window..::..SetColor Method (Color)
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.SetColor(ElImage.Color)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetColor(
    Color color
)
Visual Basic
Public Sub SetColor ( _
    color As Color _
)
Visual C++
public:
void SetColor(
    Color^ color
)

Parameters

color
Type: ElImage..::..Color

[Missing <param name="color"/> documentation for "M:ElGUI.Window.SetColor(ElImage.Color)"]

See Also

Window Class
SetColor Overload
ElGUI Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
Window..::..SetDefaultCursor Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

Window Class
Window Members
ElGUI Namespace


SetDirty Method

[image]

4 of William Foster's Class Libraries
Window..::..SetDirty Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.SetDirty"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetDirty()
Visual Basic
Public Sub SetDirty
Visual C++
public:
void SetDirty()

See Also

Window Class
ElGUI Namespace


SetVisible Method

[image]

4 of William Foster's Class Libraries
Window..::..SetVisible Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.SetVisible(System.Boolean)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetVisible(
    bool bOn
)
Visual Basic
Public Sub SetVisible ( _
    bOn As Boolean _
)
Visual C++
public:
void SetVisible(
    bool bOn
)

Parameters

bOn
Type: System..::..Boolean

[Missing <param name="bOn"/> documentation for "M:ElGUI.Window.SetVisible(System.Boolean)"]

See Also

Window Class
ElGUI Namespace


SetWindowOutline Method

[image]

4 of William Foster's Class Libraries
Window..::..SetWindowOutline Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ElGUI.Window.SetWindowOutline(ElVector.Shape2d)"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetWindowOutline(
    Shape2d shape_outline
)
Visual Basic
Public Function SetWindowOutline ( _
    shape_outline As Shape2d _
) As Boolean
Visual C++
public:
bool SetWindowOutline(
    Shape2d^ shape_outline
)

Parameters

shape_outline
Type: Shape2d

[Missing <param name="shape_outline"/> documentation for "M:ElGUI.Window.SetWindowOutline(ElVector.Shape2d)"]

Return Value

[Missing <returns> documentation for "M:ElGUI.Window.SetWindowOutline(ElVector.Shape2d)"]

See Also

Window Class
ElGUI Namespace


Window Properties

[image] [image]

4 of William Foster's Class Libraries
Window Properties
Window Class See Also Send Feedback

The Window type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

Window Class
ElGUI Namespace


WINDOW_TYPE Enumeration

[image]

4 of William Foster's Class Libraries
WINDOW_TYPE Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElGUI.WINDOW_TYPE"]

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum WINDOW_TYPE
Visual Basic
Public Enumeration WINDOW_TYPE
Visual C++
public enum class WINDOW_TYPE

Members

Member name | Value | Description
WND_MAIN | 0 |
WND_TOP | 1 |
WND_CHILD | 2 |
WND_TAB | 3 |
WND_CURSES | 4 |
WND_3D | 5 |
WND_DIALOG | 6 |
WND_BUTTON | 7 |
WND_CHECKBOX | 8 |
WND_RADIOBUTTON | 9 |
WND_TEXTBOX | 10 |
WND_LABEL | 11 |
WND_LIST | 12 |
WND_LISTBOX | 13 |
WND_COMBO | 14 |
WND_TOOLBAR | 15 |
WND_GL | 16 |
WND_SLIDER | 17 |
WND_PATH | 18 |

See Also

ElGUI Namespace


WM Enumeration

[image]

4 of William Foster's Class Libraries
WM Enumeration
See Also Send Feedback
Windows Messages Defined in winuser.h from Windows SDK v6.1 Documentation pulled from MSDN.

Namespace: ElGUI
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum WM
Visual Basic
Public Enumeration WM
Visual C++
public enum class WM

Members

Member name | Value | Description
NULL | 0 | The WM_NULL message performs no operation. An application sends the WM_NULL message if it wants to post a message that the recipient window will ignore.
CREATE | 1 | The WM_CREATE message is sent when an application requests that a window be created by calling the CreateWindowEx or CreateWindow function. (The message is sent before the function returns.) The window procedure of the new window receives this message after the window is created, but before the window becomes visible.
DESTROY | 2 | The WM_DESTROY message is sent when a window is being destroyed. It is sent to the window procedure of the window being destroyed after the window is removed from the screen. This message is sent first to the window being destroyed and then to the child windows (if any) as they are destroyed. During the processing of the message, it can be assumed that all child windows still exist. ///
MOVE | 3 | The WM_MOVE message is sent after a window has been moved.
SIZE | 5 | The WM_SIZE message is sent to a window after its size has changed.
ACTIVATE | 6 | The WM_ACTIVATE message is sent to both the window being activated and the window being deactivated. If the windows use the same input queue, the message is sent synchronously, first to the window procedure of the top-level window being deactivated, then to the window procedure of the top-level window being activated. If the windows use different input queues, the message is sent asynchronously, so the window is activated immediately.
SETFOCUS | 7 | The WM_SETFOCUS message is sent to a window after it has gained the keyboard focus.
KILLFOCUS | 8 | The WM_KILLFOCUS message is sent to a window immediately before it loses the keyboard focus.
ENABLE | 10 | The WM_ENABLE message is sent when an application changes the enabled state of a window. It is sent to the window whose enabled state is changing. This message is sent before the EnableWindow function returns, but after the enabled state (WS_DISABLED style bit) of the window has changed.
SETREDRAW | 11 | An application sends the WM_SETREDRAW message to a window to allow changes in that window to be redrawn or to prevent changes in that window from being redrawn.
SETTEXT | 12 | An application sends a WM_SETTEXT message to set the text of a window.
GETTEXT | 13 | An application sends a WM_GETTEXT message to copy the text that corresponds to a window into a buffer provided by the caller.
GETTEXTLENGTH | 14 | An application sends a WM_GETTEXTLENGTH message to determine the length, in characters, of the text associated with a window.
PAINT | 15 | The WM_PAINT message is sent when the system or another application makes a request to paint a portion of an application's window. The message is sent when the UpdateWindow or RedrawWindow function is called, or by the DispatchMessage function when the application obtains a WM_PAINT message by using the GetMessage or PeekMessage function.
CLOSE | 16 | The WM_CLOSE message is sent as a signal that a window or an application should terminate.
QUERYENDSESSION | 17 | The WM_QUERYENDSESSION message is sent when the user chooses to end the session or when an application calls one of the system shutdown functions. If any application returns zero, the session is not ended. The system stops sending WM_QUERYENDSESSION messages as soon as one application returns zero. After processing this message, the system sends the WM_ENDSESSION message with the wParam parameter set to the results of the WM_QUERYENDSESSION message.
QUERYOPEN | 19 | The WM_QUERYOPEN message is sent to an icon when the user requests that the window be restored to its previous size and position.
ENDSESSION | 22 | The WM_ENDSESSION message is sent to an application after the system processes the results of the WM_QUERYENDSESSION message. The WM_ENDSESSION message informs the application whether the session is ending.
QUIT | 18 | The WM_QUIT message indicates a request to terminate an application and is generated when the application calls the PostQuitMessage function. It causes the GetMessage function to return zero.
ERASEBKGND | 20 | The WM_ERASEBKGND message is sent when the window background must be erased (for example, when a window is resized). The message is sent to prepare an invalidated portion of a window for painting.
SYSCOLORCHANGE | 21 | This message is sent to all top-level windows when a change is made to a system color setting.
SHOWWINDOW | 24 | The WM_SHOWWINDOW message is sent to a window when the window is about to be hidden or shown.
WININICHANGE | 26 | An application sends the WM_WININICHANGE message to all top-level windows after making a change to the WIN.INI file. The SystemParametersInfo function sends this message after an application uses the function to change a setting in WIN.INI. Note The WM_WININICHANGE message is provided only for compatibility with earlier versions of the system. Applications should use the WM_SETTINGCHANGE message.
SETTINGCHANGE | 26 | An application sends the WM_WININICHANGE message to all top-level windows after making a change to the WIN.INI file. The SystemParametersInfo function sends this message after an application uses the function to change a setting in WIN.INI. Note The WM_WININICHANGE message is provided only for compatibility with earlier versions of the system. Applications should use the WM_SETTINGCHANGE message.
DEVMODECHANGE | 27 | The WM_DEVMODECHANGE message is sent to all top-level windows whenever the user changes device-mode settings.
ACTIVATEAPP | 28 | The WM_ACTIVATEAPP message is sent when a window belonging to a different application than the active window is about to be activated. The message is sent to the application whose window is being activated and to the application whose window is being deactivated.
FONTCHANGE | 29 | An application sends the WM_FONTCHANGE message to all top-level windows in the system after changing the pool of font resources.
TIMECHANGE | 30 | A message that is sent whenever there is a change in the system time.
CANCELMODE | 31 | The WM_CANCELMODE message is sent to cancel certain modes, such as mouse capture. For example, the system sends this message to the active window when a dialog box or message box is displayed. Certain functions also send this message explicitly to the specified window regardless of whether it is the active window. For example, the EnableWindow function sends this message when disabling the specified window.
SETCURSOR | 32 | The WM_SETCURSOR message is sent to a window if the mouse causes the cursor to move within a window and mouse input is not captured.
MOUSEACTIVATE | 33 | The WM_MOUSEACTIVATE message is sent when the cursor is in an inactive window and the user presses a mouse button. The parent window receives this message only if the child window passes it to the DefWindowProc function.
CHILDACTIVATE | 34 | The WM_CHILDACTIVATE message is sent to a child window when the user clicks the window's title bar or when the window is activated, moved, or sized.
QUEUESYNC | 35 | The WM_QUEUESYNC message is sent by a computer-based training (CBT) application to separate user-input messages from other messages sent through the WH_JOURNALPLAYBACK Hook procedure.
GETMINMAXINFO | 36 | The WM_GETMINMAXINFO message is sent to a window when the size or position of the window is about to change. An application can use this message to override the window's default maximized size and position, or its default minimum or maximum tracking size.
PAINTICON | 38 | Windows NT 3.51 and earlier: The WM_PAINTICON message is sent to a minimized window when the icon is to be painted. This message is not sent by newer versions of Microsoft Windows, except in unusual circumstances explained in the Remarks.
ICONERASEBKGND | 39 | Windows NT 3.51 and earlier: The WM_ICONERASEBKGND message is sent to a minimized window when the background of the icon must be filled before painting the icon. A window receives this message only if a class icon is defined for the window; otherwise, WM_ERASEBKGND is sent. This message is not sent by newer versions of Windows.
NEXTDLGCTL | 40 | The WM_NEXTDLGCTL message is sent to a dialog box procedure to set the keyboard focus to a different control in the dialog box.
SPOOLERSTATUS | 42 | The WM_SPOOLERSTATUS message is sent from Print Manager whenever a job is added to or removed from the Print Manager queue.
DRAWITEM | 43 | The WM_DRAWITEM message is sent to the parent window of an owner-drawn button, combo box, list box, or menu when a visual aspect of the button, combo box, list box, or menu has changed.
MEASUREITEM | 44 | The WM_MEASUREITEM message is sent to the owner window of a combo box, list box, list view control, or menu item when the control or menu is created.
DELETEITEM | 45 | Sent to the owner of a list box or combo box when the list box or combo box is destroyed or when items are removed by the LB_DELETESTRING, LB_RESETCONTENT, CB_DELETESTRING, or CB_RESETCONTENT message. The system sends a WM_DELETEITEM message for each deleted item. The system sends the WM_DELETEITEM message for any deleted list box or combo box item with nonzero item data.
VKEYTOITEM | 46 | Sent by a list box with the LBS_WANTKEYBOARDINPUT style to its owner in response to a WM_KEYDOWN message.
CHARTOITEM | 47 | Sent by a list box with the LBS_WANTKEYBOARDINPUT style to its owner in response to a WM_CHAR message.
SETFONT | 48 | An application sends a WM_SETFONT message to specify the font that a control is to use when drawing text.
GETFONT | 49 | An application sends a WM_GETFONT message to a control to retrieve the font with which the control is currently drawing its text.
SETHOTKEY | 50 | An application sends a WM_SETHOTKEY message to a window to associate a hot key with the window. When the user presses the hot key, the system activates the window.
GETHOTKEY | 51 | An application sends a WM_GETHOTKEY message to determine the hot key associated with a window.
QUERYDRAGICON | 55 | The WM_QUERYDRAGICON message is sent to a minimized (iconic) window. The window is about to be dragged by the user but does not have an icon defined for its class. An application can return a handle to an icon or cursor. The system displays this cursor or icon while the user drags the icon.
COMPAREITEM | 57 | The system sends the WM_COMPAREITEM message to determine the relative position of a new item in the sorted list of an owner-drawn combo box or list box. Whenever the application adds a new item, the system sends this message to the owner of a combo box or list box created with the CBS_SORT or LBS_SORT style.
GETOBJECT | 61 | Active Accessibility sends the WM_GETOBJECT message to obtain information about an accessible object contained in a server application. Applications never send this message directly. It is sent only by Active Accessibility in response to calls to AccessibleObjectFromPoint, AccessibleObjectFromEvent, or AccessibleObjectFromWindow. However, server applications handle this message.
COMPACTING | 65 | The WM_COMPACTING message is sent to all top-level windows when the system detects more than 12.5 percent of system time over a 30- to 60-second interval is being spent compacting memory. This indicates that system memory is low.
COMMNOTIFY | 68 | WM_COMMNOTIFY is Obsolete for Win32-Based Applications
WINDOWPOSCHANGING | 70 | The WM_WINDOWPOSCHANGING message is sent to a window whose size, position, or place in the Z order is about to change as a result of a call to the SetWindowPos function or another window-management function.
WINDOWPOSCHANGED | 71 | The WM_WINDOWPOSCHANGED message is sent to a window whose size, position, or place in the Z order has changed as a result of a call to the SetWindowPos function or another window-management function.
POWER | 72 | Notifies applications that the system, typically a battery-powered personal computer, is about to enter a suspended mode. Use: POWERBROADCAST
COPYDATA | 74 | An application sends the WM_COPYDATA message to pass data to another application.
CANCELJOURNAL | 75 | The WM_CANCELJOURNAL message is posted to an application when a user cancels the application's journaling activities. The message is posted with a NULL window handle.
NOTIFY | 78 | Sent by a common control to its parent window when an event has occurred or the control requires some information.
INPUTLANGCHANGEREQUEST | 80 | The WM_INPUTLANGCHANGEREQUEST message is posted to the window with the focus when the user chooses a new input language, either with the hotkey (specified in the Keyboard control panel application) or from the indicator on the system taskbar. An application can accept the change by passing the message to the DefWindowProc function or reject the change (and prevent it from taking place) by returning immediately.
INPUTLANGCHANGE | 81 | The WM_INPUTLANGCHANGE message is sent to the topmost affected window after an application's input language has been changed. You should make any application-specific settings and pass the message to the DefWindowProc function, which passes the message to all first-level child windows. These child windows can pass the message to DefWindowProc to have it pass the message to their child windows, and so on.
TCARD | 82 | Sent to an application that has initiated a training card with Microsoft Windows Help. The message informs the application when the user clicks an authorable button. An application initiates a training card by specifying the HELP_TCARD command in a call to the WinHelp function.
HELP | 83 | Indicates that the user pressed the F1 key. If a menu is active when F1 is pressed, WM_HELP is sent to the window associated with the menu; otherwise, WM_HELP is sent to the window that has the keyboard focus. If no window has the keyboard focus, WM_HELP is sent to the currently active window.
USERCHANGED | 84 | The WM_USERCHANGED message is sent to all windows after the user has logged on or off. When the user logs on or off, the system updates the user-specific settings. The system sends this message immediately after updating the settings.
NOTIFYFORMAT | 85 | Determines if a window accepts ANSI or Unicode structures in the WM_NOTIFY notification message. WM_NOTIFYFORMAT messages are sent from a common control to its parent window and from the parent window to the common control.
CONTEXTMENU | 123 | The WM_CONTEXTMENU message notifies a window that the user clicked the right mouse button (right-clicked) in the window.
STYLECHANGING | 124 | The WM_STYLECHANGING message is sent to a window when the SetWindowLong function is about to change one or more of the window's styles.
STYLECHANGED | 125 | The WM_STYLECHANGED message is sent to a window after the SetWindowLong function has changed one or more of the window's styles
DISPLAYCHANGE | 126 | The WM_DISPLAYCHANGE message is sent to all windows when the display resolution has changed.
GETICON | 127 | The WM_GETICON message is sent to a window to retrieve a handle to the large or small icon associated with a window. The system displays the large icon in the ALT+TAB dialog, and the small icon in the window caption.
SETICON | 128 | An application sends the WM_SETICON message to associate a new large or small icon with a window. The system displays the large icon in the ALT+TAB dialog box, and the small icon in the window caption.
NCCREATE | 129 | The WM_NCCREATE message is sent prior to the WM_CREATE message when a window is first created.
NCDESTROY | 130 | The WM_NCDESTROY message informs a window that its nonclient area is being destroyed. The DestroyWindow function sends the WM_NCDESTROY message to the window following the WM_DESTROY message. WM_DESTROY is used to free the allocated memory object associated with the window. The WM_NCDESTROY message is sent after the child windows have been destroyed. In contrast, WM_DESTROY is sent before the child windows are destroyed.
NCCALCSIZE | 131 | The WM_NCCALCSIZE message is sent when the size and position of a window's client area must be calculated. By processing this message, an application can control the content of the window's client area when the size or position of the window changes.
NCHITTEST | 132 | The WM_NCHITTEST message is sent to a window when the cursor moves, or when a mouse button is pressed or released. If the mouse is not captured, the message is sent to the window beneath the cursor. Otherwise, the message is sent to the window that has captured the mouse.
NCPAINT | 133 | The WM_NCPAINT message is sent to a window when its frame must be painted.
NCACTIVATE | 134 | The WM_NCACTIVATE message is sent to a window when its nonclient area needs to be changed to indicate an active or inactive state.
GETDLGCODE | 135 | The WM_GETDLGCODE message is sent to the window procedure associated with a control. By default, the system handles all keyboard input to the control; the system interprets certain types of keyboard input as dialog box navigation keys. To override this default behavior, the control can respond to the WM_GETDLGCODE message to indicate the types of input it wants to process itself.
SYNCPAINT | 136 | The WM_SYNCPAINT message is used to synchronize painting while avoiding linking independent GUI threads.
NCMOUSEMOVE | 160 | The WM_NCMOUSEMOVE message is posted to a window when the cursor is moved within the nonclient area of the window. This message is posted to the window that contains the cursor. If a window has captured the mouse, this message is not posted.
NCLBUTTONDOWN | 161 | The WM_NCLBUTTONDOWN message is posted when the user presses the left mouse button while the cursor is within the nonclient area of a window. This message is posted to the window that contains the cursor. If a window has captured the mouse, this message is not posted.
NCLBUTTONUP | 162 | The WM_NCLBUTTONUP message is posted when the user releases the left mouse button while the cursor is within the nonclient area of a window. This message is posted to the window that contains the cursor. If a window has captured the mouse, this message is not posted.
NCLBUTTONDBLCLK | 163 | The WM_NCLBUTTONDBLCLK message is posted when the user double-clicks the left mouse button while the cursor is within the nonclient area of a window. This message is posted to the window that contains the cursor. If a window has captured the mouse, this message is not posted.
NCRBUTTONDOWN | 164 | The WM_NCRBUTTONDOWN message is posted when the user presses the right mouse button while the cursor is within the nonclient area of a window. This message is posted to the window that contains the cursor. If a window has captured the mouse, this message is not posted.
NCRBUTTONUP | 165 | The WM_NCRBUTTONUP message is posted when the user releases the right mouse button while the cursor is within the nonclient area of a window. This message is posted to the window that contains the cursor. If a window has captured the mouse, this message is not posted.
NCRBUTTONDBLCLK | 166 | The WM_NCRBUTTONDBLCLK message is posted when the user double-clicks the right mouse button while the cursor is within the nonclient area of a window. This message is posted to the window that contains the cursor. If a window has captured the mouse, this message is not posted.
NCMBUTTONDOWN | 167 | The WM_NCMBUTTONDOWN message is posted when the user presses the middle mouse button while the cursor is within the nonclient area of a window. This message is posted to the window that contains the cursor. If a window has captured the mouse, this message is not posted.
NCMBUTTONUP | 168 | The WM_NCMBUTTONUP message is posted when the user releases the middle mouse button while the cursor is within the nonclient area of a window. This message is posted to the window that contains the cursor. If a window has captured the mouse, this message is not posted.
NCMBUTTONDBLCLK | 169 | The WM_NCMBUTTONDBLCLK message is posted when the user double-clicks the middle mouse button while the cursor is within the nonclient area of a window. This message is posted to the window that contains the cursor. If a window has captured the mouse, this message is not posted.
NCXBUTTONDOWN | 171 | The WM_NCXBUTTONDOWN message is posted when the user presses the first or second X button while the cursor is in the nonclient area of a window. This message is posted to the window that contains the cursor. If a window has captured the mouse, this message is not posted.
NCXBUTTONUP | 172 | The WM_NCXBUTTONUP message is posted when the user releases the first or second X button while the cursor is in the nonclient area of a window. This message is posted to the window that contains the cursor. If a window has captured the mouse, this message is not posted.
NCXBUTTONDBLCLK | 173 | The WM_NCXBUTTONDBLCLK message is posted when the user double-clicks the first or second X button while the cursor is in the nonclient area of a window. This message is posted to the window that contains the cursor. If a window has captured the mouse, this message is not posted.
INPUT_DEVICE_CHANGE | 254 | The WM_INPUT_DEVICE_CHANGE message is sent to the window that registered to receive raw input. A window receives this message through its WindowProc function.
INPUT | 255 | The WM_INPUT message is sent to the window that is getting raw input.
KEYFIRST | 256 | This message filters for keyboard messages.
KEYDOWN | 256 | The WM_KEYDOWN message is posted to the window with the keyboard focus when a nonsystem key is pressed. A nonsystem key is a key that is pressed when the ALT key is not pressed.
KEYUP | 257 | The WM_KEYUP message is posted to the window with the keyboard focus when a nonsystem key is released. A nonsystem key is a key that is pressed when the ALT key is not pressed, or a keyboard key that is pressed when a window has the keyboard focus.
CHAR | 258 | The WM_CHAR message is posted to the window with the keyboard focus when a WM_KEYDOWN message is translated by the TranslateMessage function. The WM_CHAR message contains the character code of the key that was pressed.
DEADCHAR | 259 | The WM_DEADCHAR message is posted to the window with the keyboard focus when a WM_KEYUP message is translated by the TranslateMessage function. WM_DEADCHAR specifies a character code generated by a dead key. A dead key is a key that generates a character, such as the umlaut (double-dot), that is combined with another character to form a composite character. For example, the umlaut-O character (Ö) is generated by typing the dead key for the umlaut character, and then typing the O key.
SYSKEYDOWN | 260 | The WM_SYSKEYDOWN message is posted to the window with the keyboard focus when the user presses the F10 key (which activates the menu bar) or holds down the ALT key and then presses another key. It also occurs when no window currently has the keyboard focus; in this case, the WM_SYSKEYDOWN message is sent to the active window. The window that receives the message can distinguish between these two contexts by checking the context code in the lParam parameter.
SYSKEYUP | 261 | The WM_SYSKEYUP message is posted to the window with the keyboard focus when the user releases a key that was pressed while the ALT key was held down. It also occurs when no window currently has the keyboard focus; in this case, the WM_SYSKEYUP message is sent to the active window. The window that receives the message can distinguish between these two contexts by checking the context code in the lParam parameter.
SYSCHAR | 262 | The WM_SYSCHAR message is posted to the window with the keyboard focus when a WM_SYSKEYDOWN message is translated by the TranslateMessage function. It specifies the character code of a system character key — that is, a character key that is pressed while the ALT key is down.
SYSDEADCHAR | 263 | The WM_SYSDEADCHAR message is sent to the window with the keyboard focus when a WM_SYSKEYDOWN message is translated by the TranslateMessage function. WM_SYSDEADCHAR specifies the character code of a system dead key — that is, a dead key that is pressed while holding down the ALT key.
UNICHAR | 265 | The WM_UNICHAR message is posted to the window with the keyboard focus when a WM_KEYDOWN message is translated by the TranslateMessage function. The WM_UNICHAR message contains the character code of the key that was pressed. The WM_UNICHAR message is equivalent to WM_CHAR, but it uses Unicode Transformation Format (UTF)-32, whereas WM_CHAR uses UTF-16. It is designed to send or post Unicode characters to ANSI windows and it can can handle Unicode Supplementary Plane characters.
KEYLAST | 265 | This message filters for keyboard messages.
IME_STARTCOMPOSITION | 269 | Sent immediately before the IME generates the composition string as a result of a keystroke. A window receives this message through its WindowProc function.
IME_ENDCOMPOSITION | 270 | Sent to an application when the IME ends composition. A window receives this message through its WindowProc function.
IME_COMPOSITION | 271 | Sent to an application when the IME changes composition status as a result of a keystroke. A window receives this message through its WindowProc function.
IME_KEYLAST | 271 |
INITDIALOG | 272 | The WM_INITDIALOG message is sent to the dialog box procedure immediately before a dialog box is displayed. Dialog box procedures typically use this message to initialize controls and carry out any other initialization tasks that affect the appearance of the dialog box.
COMMAND | 273 | The WM_COMMAND message is sent when the user selects a command item from a menu, when a control sends a notification message to its parent window, or when an accelerator keystroke is translated.
SYSCOMMAND | 274 | A window receives this message when the user chooses a command from the Window menu, clicks the maximize button, minimize button, restore button, close button, or moves the form. You can stop the form from moving by filtering this out.
TIMER | 275 | The WM_TIMER message is posted to the installing thread's message queue when a timer expires. The message is posted by the GetMessage or PeekMessage function.
HSCROLL | 276 | The WM_HSCROLL message is sent to a window when a scroll event occurs in the window's standard horizontal scroll bar. This message is also sent to the owner of a horizontal scroll bar control when a scroll event occurs in the control.
VSCROLL | 277 | The WM_VSCROLL message is sent to a window when a scroll event occurs in the window's standard vertical scroll bar. This message is also sent to the owner of a vertical scroll bar control when a scroll event occurs in the control.
INITMENU | 278 | The WM_INITMENU message is sent when a menu is about to become active. It occurs when the user clicks an item on the menu bar or presses a menu key. This allows the application to modify the menu before it is displayed.
INITMENUPOPUP | 279 | The WM_INITMENUPOPUP message is sent when a drop-down menu or submenu is about to become active. This allows an application to modify the menu before it is displayed, without changing the entire menu.
MENUSELECT | 287 | The WM_MENUSELECT message is sent to a menu's owner window when the user selects a menu item.
MENUCHAR | 288 | The WM_MENUCHAR message is sent when a menu is active and the user presses a key that does not correspond to any mnemonic or accelerator key. This message is sent to the window that owns the menu.
ENTERIDLE | 289 | The WM_ENTERIDLE message is sent to the owner window of a modal dialog box or menu that is entering an idle state. A modal dialog box or menu enters an idle state when no messages are waiting in its queue after it has processed one or more previous messages.
MENURBUTTONUP | 290 | The WM_MENURBUTTONUP message is sent when the user releases the right mouse button while the cursor is on a menu item.
MENUDRAG | 291 | The WM_MENUDRAG message is sent to the owner of a drag-and-drop menu when the user drags a menu item.
MENUGETOBJECT | 292 | The WM_MENUGETOBJECT message is sent to the owner of a drag-and-drop menu when the mouse cursor enters a menu item or moves from the center of the item to the top or bottom of the item.
UNINITMENUPOPUP | 293 | The WM_UNINITMENUPOPUP message is sent when a drop-down menu or submenu has been destroyed.
MENUCOMMAND | 294 | The WM_MENUCOMMAND message is sent when the user makes a selection from a menu.
CHANGEUISTATE | 295 | An application sends the WM_CHANGEUISTATE message to indicate that the user interface (UI) state should be changed.
UPDATEUISTATE | 296 | An application sends the WM_UPDATEUISTATE message to change the user interface (UI) state for the specified window and all its child windows.
QUERYUISTATE | 297 | An application sends the WM_QUERYUISTATE message to retrieve the user interface (UI) state for a window.
CTLCOLORMSGBOX | 306 | The WM_CTLCOLORMSGBOX message is sent to the owner window of a message box before Windows draws the message box. By responding to this message, the owner window can set the text and background colors of the message box by using the given display device context handle.
CTLCOLOREDIT | 307 | An edit control that is not read-only or disabled sends the WM_CTLCOLOREDIT message to its parent window when the control is about to be drawn. By responding to this message, the parent window can use the specified device context handle to set the text and background colors of the edit control.
CTLCOLORLISTBOX | 308 | Sent to the parent window of a list box before the system draws the list box. By responding to this message, the parent window can set the text and background colors of the list box by using the specified display device context handle.
CTLCOLORBTN | 309 | The WM_CTLCOLORBTN message is sent to the parent window of a button before drawing the button. The parent window can change the button's text and background colors. However, only owner-drawn buttons respond to the parent window processing this message.
CTLCOLORDLG | 310 | The WM_CTLCOLORDLG message is sent to a dialog box before the system draws the dialog box. By responding to this message, the dialog box can set its text and background colors using the specified display device context handle.
CTLCOLORSCROLLBAR | 311 | The WM_CTLCOLORSCROLLBAR message is sent to the parent window of a scroll bar control when the control is about to be drawn. By responding to this message, the parent window can use the display context handle to set the background color of the scroll bar control.
CTLCOLORSTATIC | 312 | A static control, or an edit control that is read-only or disabled, sends the WM_CTLCOLORSTATIC message to its parent window when the control is about to be drawn. By responding to this message, the parent window can use the specified device context handle to set the text and background colors of the static control.
MOUSEFIRST | 512 | Use WM_MOUSEFIRST to specify the first mouse message. Use the PeekMessage() Function.
MOUSEMOVE | 512 | The WM_MOUSEMOVE message is posted to a window when the cursor moves. If the mouse is not captured, the message is posted to the window that contains the cursor. Otherwise, the message is posted to the window that has captured the mouse.
LBUTTONDOWN | 513 | The WM_LBUTTONDOWN message is posted when the user presses the left mouse button while the cursor is in the client area of a window. If the mouse is not captured, the message is posted to the window beneath the cursor. Otherwise, the message is posted to the window that has captured the mouse.
LBUTTONUP | 514 | The WM_LBUTTONUP message is posted when the user releases the left mouse button while the cursor is in the client area of a window. If the mouse is not captured, the message is posted to the window beneath the cursor. Otherwise, the message is posted to the window that has captured the mouse.
LBUTTONDBLCLK | 515 | The WM_LBUTTONDBLCLK message is posted when the user double-clicks the left mouse button while the cursor is in the client area of a window. If the mouse is not captured, the message is posted to the window beneath the cursor. Otherwise, the message is posted to the window that has captured the mouse.
RBUTTONDOWN | 516 | The WM_RBUTTONDOWN message is posted when the user presses the right mouse button while the cursor is in the client area of a window. If the mouse is not captured, the message is posted to the window beneath the cursor. Otherwise, the message is posted to the window that has captured the mouse.
RBUTTONUP | 517 | The WM_RBUTTONUP message is posted when the user releases the right mouse button while the cursor is in the client area of a window. If the mouse is not captured, the message is posted to the window beneath the cursor. Otherwise, the message is posted to the window that has captured the mouse.
RBUTTONDBLCLK | 518 | The WM_RBUTTONDBLCLK message is posted when the user double-clicks the right mouse button while the cursor is in the client area of a window. If the mouse is not captured, the message is posted to the window beneath the cursor. Otherwise, the message is posted to the window that has captured the mouse.
MBUTTONDOWN | 519 | The WM_MBUTTONDOWN message is posted when the user presses the middle mouse button while the cursor is in the client area of a window. If the mouse is not captured, the message is posted to the window beneath the cursor. Otherwise, the message is posted to the window that has captured the mouse.
MBUTTONUP | 520 | The WM_MBUTTONUP message is posted when the user releases the middle mouse button while the cursor is in the client area of a window. If the mouse is not captured, the message is posted to the window beneath the cursor. Otherwise, the message is posted to the window that has captured the mouse.
MBUTTONDBLCLK | 521 | The WM_MBUTTONDBLCLK message is posted when the user double-clicks the middle mouse button while the cursor is in the client area of a window. If the mouse is not captured, the message is posted to the window beneath the cursor. Otherwise, the message is posted to the window that has captured the mouse.
MOUSEWHEEL | 522 | The WM_MOUSEWHEEL message is sent to the focus window when the mouse wheel is rotated. The DefWindowProc function propagates the message to the window's parent. There should be no internal forwarding of the message, since DefWindowProc propagates it up the parent chain until it finds a window that processes it.
XBUTTONDOWN | 523 | The WM_XBUTTONDOWN message is posted when the user presses the first or second X button while the cursor is in the client area of a window. If the mouse is not captured, the message is posted to the window beneath the cursor. Otherwise, the message is posted to the window that has captured the mouse.
XBUTTONUP | 524 | The WM_XBUTTONUP message is posted when the user releases the first or second X button while the cursor is in the client area of a window. If the mouse is not captured, the message is posted to the window beneath the cursor. Otherwise, the message is posted to the window that has captured the mouse.
XBUTTONDBLCLK | 525 | The WM_XBUTTONDBLCLK message is posted when the user double-clicks the first or second X button while the cursor is in the client area of a window. If the mouse is not captured, the message is posted to the window beneath the cursor. Otherwise, the message is posted to the window that has captured the mouse.
MOUSEHWHEEL | 526 | The WM_MOUSEHWHEEL message is sent to the focus window when the mouse's horizontal scroll wheel is tilted or rotated. The DefWindowProc function propagates the message to the window's parent. There should be no internal forwarding of the message, since DefWindowProc propagates it up the parent chain until it finds a window that processes it.
MOUSELAST | 526 | Use WM_MOUSELAST to specify the last mouse message. Used with PeekMessage() Function.
PARENTNOTIFY | 528 | The WM_PARENTNOTIFY message is sent to the parent of a child window when the child window is created or destroyed, or when the user clicks a mouse button while the cursor is over the child window. When the child window is being created, the system sends WM_PARENTNOTIFY just before the CreateWindow or CreateWindowEx function that creates the window returns. When the child window is being destroyed, the system sends the message before any processing to destroy the window takes place.
ENTERMENULOOP | 529 | The WM_ENTERMENULOOP message informs an application's main window procedure that a menu modal loop has been entered.
EXITMENULOOP | 530 | The WM_EXITMENULOOP message informs an application's main window procedure that a menu modal loop has been exited.
NEXTMENU | 531 | The WM_NEXTMENU message is sent to an application when the right or left arrow key is used to switch between the menu bar and the system menu.
SIZING | 532 | The WM_SIZING message is sent to a window that the user is resizing. By processing this message, an application can monitor the size and position of the drag rectangle and, if needed, change its size or position.
CAPTURECHANGED | 533 | The WM_CAPTURECHANGED message is sent to the window that is losing the mouse capture.
MOVING | 534 | The WM_MOVING message is sent to a window that the user is moving. By processing this message, an application can monitor the position of the drag rectangle and, if needed, change its position.
POWERBROADCAST | 536 | Notifies applications that a power-management event has occurred.
DEVICECHANGE | 537 | Notifies an application of a change to the hardware configuration of a device or the computer.
MDICREATE | 544 | An application sends the WM_MDICREATE message to a multiple-document interface (MDI) client window to create an MDI child window.
MDIDESTROY | 545 | An application sends the WM_MDIDESTROY message to a multiple-document interface (MDI) client window to close an MDI child window.
MDIACTIVATE | 546 | An application sends the WM_MDIACTIVATE message to a multiple-document interface (MDI) client window to instruct the client window to activate a different MDI child window.
MDIRESTORE | 547 | An application sends the WM_MDIRESTORE message to a multiple-document interface (MDI) client window to restore an MDI child window from maximized or minimized size.
MDINEXT | 548 | An application sends the WM_MDINEXT message to a multiple-document interface (MDI) client window to activate the next or previous child window.
MDIMAXIMIZE | 549 | An application sends the WM_MDIMAXIMIZE message to a multiple-document interface (MDI) client window to maximize an MDI child window. The system resizes the child window to make its client area fill the client window. The system places the child window's window menu icon in the rightmost position of the frame window's menu bar, and places the child window's restore icon in the leftmost position. The system also appends the title bar text of the child window to that of the frame window.
MDITILE | 550 | An application sends the WM_MDITILE message to a multiple-document interface (MDI) client window to arrange all of its MDI child windows in a tile format.
MDICASCADE | 551 | An application sends the WM_MDICASCADE message to a multiple-document interface (MDI) client window to arrange all its child windows in a cascade format.
MDIICONARRANGE | 552 | An application sends the WM_MDIICONARRANGE message to a multiple-document interface (MDI) client window to arrange all minimized MDI child windows. It does not affect child windows that are not minimized.
MDIGETACTIVE | 553 | An application sends the WM_MDIGETACTIVE message to a multiple-document interface (MDI) client window to retrieve the handle to the active MDI child window.
MDISETMENU | 560 | An application sends the WM_MDISETMENU message to a multiple-document interface (MDI) client window to replace the entire menu of an MDI frame window, to replace the window menu of the frame window, or both.
ENTERSIZEMOVE | 561 | The WM_ENTERSIZEMOVE message is sent one time to a window after it enters the moving or sizing modal loop. The window enters the moving or sizing modal loop when the user clicks the window's title bar or sizing border, or when the window passes the WM_SYSCOMMAND message to the DefWindowProc function and the wParam parameter of the message specifies the SC_MOVE or SC_SIZE value. The operation is complete when DefWindowProc returns. The system sends the WM_ENTERSIZEMOVE message regardless of whether the dragging of full windows is enabled.
EXITSIZEMOVE | 562 | The WM_EXITSIZEMOVE message is sent one time to a window, after it has exited the moving or sizing modal loop. The window enters the moving or sizing modal loop when the user clicks the window's title bar or sizing border, or when the window passes the WM_SYSCOMMAND message to the DefWindowProc function and the wParam parameter of the message specifies the SC_MOVE or SC_SIZE value. The operation is complete when DefWindowProc returns.
DROPFILES | 563 | Sent when the user drops a file on the window of an application that has registered itself as a recipient of dropped files.
MDIREFRESHMENU | 564 | An application sends the WM_MDIREFRESHMENU message to a multiple-document interface (MDI) client window to refresh the window menu of the MDI frame window.
IME_SETCONTEXT | 641 | Sent to an application when a window is activated. A window receives this message through its WindowProc function.
IME_NOTIFY | 642 | Sent to an application to notify it of changes to the IME window. A window receives this message through its WindowProc function.
IME_CONTROL | 643 | Sent by an application to direct the IME window to carry out the requested command. The application uses this message to control the IME window that it has created. To send this message, the application calls the SendMessage function with the following parameters.
IME_COMPOSITIONFULL | 644 | Sent to an application when the IME window finds no space to extend the area for the composition window. A window receives this message through its WindowProc function.
IME_SELECT | 645 | Sent to an application when the operating system is about to change the current IME. A window receives this message through its WindowProc function.
IME_CHAR | 646 | Sent to an application when the IME gets a character of the conversion result. A window receives this message through its WindowProc function.
IME_REQUEST | 648 | Sent to an application to provide commands and request information. A window receives this message through its WindowProc function.
IME_KEYDOWN | 656 | Sent to an application by the IME to notify the application of a key press and to keep message order. A window receives this message through its WindowProc function.
IME_KEYUP | 657 | Sent to an application by the IME to notify the application of a key release and to keep message order. A window receives this message through its WindowProc function.
MOUSEHOVER | 673 | The WM_MOUSEHOVER message is posted to a window when the cursor hovers over the client area of the window for the period of time specified in a prior call to TrackMouseEvent.
MOUSELEAVE | 675 | The WM_MOUSELEAVE message is posted to a window when the cursor leaves the client area of the window specified in a prior call to TrackMouseEvent.
NCMOUSEHOVER | 672 | The WM_NCMOUSEHOVER message is posted to a window when the cursor hovers over the nonclient area of the window for the period of time specified in a prior call to TrackMouseEvent.
NCMOUSELEAVE | 674 | The WM_NCMOUSELEAVE message is posted to a window when the cursor leaves the nonclient area of the window specified in a prior call to TrackMouseEvent.
WTSSESSION_CHANGE | 689 | The WM_WTSSESSION_CHANGE message notifies applications of changes in session state.
TABLET_FIRST | 704 |
TABLET_LAST | 735 |
CUT | 768 | An application sends a WM_CUT message to an edit control or combo box to delete (cut) the current selection, if any, in the edit control and copy the deleted text to the clipboard in CF_TEXT format.
COPY | 769 | An application sends the WM_COPY message to an edit control or combo box to copy the current selection to the clipboard in CF_TEXT format.
PASTE | 770 | An application sends a WM_PASTE message to an edit control or combo box to copy the current content of the clipboard to the edit control at the current caret position. Data is inserted only if the clipboard contains data in CF_TEXT format.
CLEAR | 771 | An application sends a WM_CLEAR message to an edit control or combo box to delete (clear) the current selection, if any, from the edit control.
UNDO | 772 | An application sends a WM_UNDO message to an edit control to undo the last operation. When this message is sent to an edit control, the previously deleted text is restored or the previously added text is deleted.
RENDERFORMAT | 773 | The WM_RENDERFORMAT message is sent to the clipboard owner if it has delayed rendering a specific clipboard format and if an application has requested data in that format. The clipboard owner must render data in the specified format and place it on the clipboard by calling the SetClipboardData function.
RENDERALLFORMATS | 774 | The WM_RENDERALLFORMATS message is sent to the clipboard owner before it is destroyed, if the clipboard owner has delayed rendering one or more clipboard formats. For the content of the clipboard to remain available to other applications, the clipboard owner must render data in all the formats it is capable of generating, and place the data on the clipboard by calling the SetClipboardData function.
DESTROYCLIPBOARD | 775 | The WM_DESTROYCLIPBOARD message is sent to the clipboard owner when a call to the EmptyClipboard function empties the clipboard.
DRAWCLIPBOARD | 776 | The WM_DRAWCLIPBOARD message is sent to the first window in the clipboard viewer chain when the content of the clipboard changes. This enables a clipboard viewer window to display the new content of the clipboard.
PAINTCLIPBOARD | 777 | The WM_PAINTCLIPBOARD message is sent to the clipboard owner by a clipboard viewer window when the clipboard contains data in the CF_OWNERDISPLAY format and the clipboard viewer's client area needs repainting.
VSCROLLCLIPBOARD | 778 | The WM_VSCROLLCLIPBOARD message is sent to the clipboard owner by a clipboard viewer window when the clipboard contains data in the CF_OWNERDISPLAY format and an event occurs in the clipboard viewer's vertical scroll bar. The owner should scroll the clipboard image and update the scroll bar values.
SIZECLIPBOARD | 779 | The WM_SIZECLIPBOARD message is sent to the clipboard owner by a clipboard viewer window when the clipboard contains data in the CF_OWNERDISPLAY format and the clipboard viewer's client area has changed size.
ASKCBFORMATNAME | 780 | The WM_ASKCBFORMATNAME message is sent to the clipboard owner by a clipboard viewer window to request the name of a CF_OWNERDISPLAY clipboard format.
CHANGECBCHAIN | 781 | The WM_CHANGECBCHAIN message is sent to the first window in the clipboard viewer chain when a window is being removed from the chain.
HSCROLLCLIPBOARD | 782 | The WM_HSCROLLCLIPBOARD message is sent to the clipboard owner by a clipboard viewer window. This occurs when the clipboard contains data in the CF_OWNERDISPLAY format and an event occurs in the clipboard viewer's horizontal scroll bar. The owner should scroll the clipboard image and update the scroll bar values.
QUERYNEWPALETTE | 783 | This message informs a window that it is about to receive the keyboard focus, giving the window the opportunity to realize its logical palette when it receives the focus.
PALETTEISCHANGING | 784 | The WM_PALETTEISCHANGING message informs applications that an application is going to realize its logical palette.
PALETTECHANGED | 785 | This message is sent by the OS to all top-level and overlapped windows after the window with the keyboard focus realizes its logical palette. This message enables windows that do not have the keyboard focus to realize their logical palettes and update their client areas.
HOTKEY | 786 | The WM_HOTKEY message is posted when the user presses a hot key registered by the RegisterHotKey function. The message is placed at the top of the message queue associated with the thread that registered the hot key.
PRINT | 791 | The WM_PRINT message is sent to a window to request that it draw itself in the specified device context, most commonly in a printer device context.
PRINTCLIENT | 792 | The WM_PRINTCLIENT message is sent to a window to request that it draw its client area in the specified device context, most commonly in a printer device context.
APPCOMMAND | 793 | The WM_APPCOMMAND message notifies a window that the user generated an application command event, for example, by clicking an application command button using the mouse or typing an application command key on the keyboard.
THEMECHANGED | 794 | The WM_THEMECHANGED message is broadcast to every window following a theme change event. Examples of theme change events are the activation of a theme, the deactivation of a theme, or a transition from one theme to another.
CLIPBOARDUPDATE | 797 | Sent when the contents of the clipboard have changed.
DWMCOMPOSITIONCHANGED | 798 | The system will send a window the WM_DWMCOMPOSITIONCHANGED message to indicate that the availability of desktop composition has changed.
DWMNCRENDERINGCHANGED | 799 | WM_DWMNCRENDERINGCHANGED is called when the non-client area rendering status of a window has changed. Only windows that have set the flag DWM_BLURBEHIND.fTransitionOnMaximized to true will get this message.
DWMCOLORIZATIONCOLORCHANGED | 800 | Sent to all top-level windows when the colorization color has changed.
DWMWINDOWMAXIMIZEDCHANGE | 801 | WM_DWMWINDOWMAXIMIZEDCHANGE will let you know when a DWM composed window is maximized. You also have to register for this message as well. You'd have other windowd go opaque when this message is sent.
GETTITLEBARINFOEX | 831 | Sent to request extended title bar information. A window receives this message through its WindowProc function.
HANDHELDFIRST | 856 |
HANDHELDLAST | 863 |
AFXFIRST | 864 |
AFXLAST | 895 |
PENWINFIRST | 896 |
PENWINLAST | 911 |
APP | 32768 | The WM_APP constant is used by applications to help define private messages, usually of the form WM_APP+X, where X is an integer value.
USER | 1024 | The WM_USER constant is used by applications to help define private messages for use by private window classes, usually of the form WM_USER+X, where X is an integer value.
CPL_LAUNCH | 5120 | An application sends the WM_CPL_LAUNCH message to Windows Control Panel to request that a Control Panel application be started.
CPL_LAUNCHED | 5121 | The WM_CPL_LAUNCHED message is sent when a Control Panel application, started by the WM_CPL_LAUNCH message, has closed. The WM_CPL_LAUNCHED message is sent to the window identified by the wParam parameter of the WM_CPL_LAUNCH message that started the application.
SYSTIMER | 280 | WM_SYSTIMER is a well-known yet still undocumented message. Windows uses WM_SYSTIMER for internal actions like scrolling.

See Also

ElGUI Namespace


ElImage Namespace

[image]

4 of William Foster's Class Libraries
ElImage Namespace
Send Feedback

[Missing <summary> documentation for "N:ElImage"]

Classes

 | Class | Description
Public class | Bitmap |
Public class | Bitmap_Alpha |
Public class | BitmapPipe |
Public class | Brightness_Histogram |
Public class | CLabRgb |
Public class | Color |
Public class | ColorMatrix3 |
Public class | ColorSpace |
Public class | ColorVector3 |
Public class | CXyzRgb |
Public class | ElImageActionDP |
Public class | Histogram |
Public class | HSL_Histogram |
Public class | Image |
Public class | Image_2dArrayPixel |
Public class | Image_Basic |
Public class | Image_Buffer |
Public class | Image_Chunker |
Public class | Image_Format |
Public class | Image_Format_SysImage |
Public class | Image_Info |
Public class | Image_Segment |
Public class | Image_Store |
Public class | ImageActionDP |
Public class | ImageActionDX |
Public class | ImageEdit |
Public class | ImageFormat_ClassFactory |
Public class | ImageWindow |
Public class | Layer |
Public class | MagicWandDP |
Public class | MagicWandDX |
Public class | Page |
Public class | Palette |
Public class | PaletteComparer |
Public class | PaletteCounter |
Public class | PixelBuffer |
Public class | Pixels |
Public class | Resolution |
Public class | Scaled_Bitmap_Alpha |
Public class | ScriptImage |
Public class | Spline | Describes a Spline in 2d space
Public class | Thing2d |
Public class | WBbmpExtention |

Structures

 | Structure | Description
Public structure | PixelData |

Interfaces

 | Interface | Description
Public interface | Image_Effect |

Enumerations

 | Enumeration | Description
Public enumeration | ColorSpace..::..El_ColorFamily |
Public enumeration | ColorSpace..::..El_ColorSpace |
Public enumeration | EImageActions |
Public enumeration | El_Color |
Public enumeration | ESelectMode |


Bitmap Class

[image]

4 of William Foster's Class Libraries
Bitmap Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Bitmap"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Bitmap : Thing2d
Visual Basic
Public Class Bitmap _
    Inherits Thing2d
Visual C++
public ref class Bitmap : public Thing2d

Inheritance Hierarchy

System..::..Object
ElImage..::..Thing2d
ElImage..::..Bitmap
ElImage..::..Bitmap_Alpha

See Also

Bitmap Members
ElImage Namespace


Bitmap Members

[image] [image]

4 of William Foster's Class Libraries
Bitmap Members
Bitmap Class Constructors Methods Fields Properties See Also Send Feedback

The Bitmap type exposes the following members.

Constructors

 | Name | Description
Public method | Bitmap()()()() | Initializes a new instance of the Bitmap class
Public method | Bitmap(BitmapSource) | Initializes a new instance of the Bitmap class
Public method | Bitmap(Bitmap) | Initializes a new instance of the Bitmap class
Public method | Bitmap(Size2dU, ColorSpace, Color) | Initializes a new instance of the Bitmap class

Methods

 | Name | Description
Public method | Allocate |
 | CalculateEffectiveBits |
Public method | crop |
Public method | Dup | (Overrides Thing2d..::..Dup()()()().)
Public method | DupAlpha |
Public method | DupAsAlpha |
Public method | Enlarge |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractBitmap |
Public method | FillRectangle |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlpha | (Overrides Thing2d..::..GetAlpha()()()().)
Public method | GetColorSpace()()()() |
Public method | GetColorSpace(ColorSpace%) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayer | (Inherited from Thing2d.)
Public method | GetName | (Inherited from Thing2d.)
Public method | GetPitch |
Public method | GetPosition | (Inherited from Thing2d.)
Public method | GetRect | (Inherited from Thing2d.)
Public method | GetRectangle |
Public method | GetResolution |
Public method | GetScanline |
Public method | GetSize | (Inherited from Thing2d.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetZoomedRectangle |
Public method | GetZoomedScanline |
Public method | GetZoomedScanlines |
Public method | IntersectsPoint | (Inherited from Thing2d.)
Public method | IsCompressed |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeBitmap |
Public method | Name | (Inherited from Thing2d.)
Public method | PickupSelection |
Public method | ReferencePixels |
Public method | Release |
Public method | Replace |
Public method | Set(Bitmap) |
Public method | Set(Bitmap) |
Public method | Set(Thing2d) | (Inherited from Thing2d.)
Public method | SetAlpha |
Public method | SetBits |
Public method | SetLayer | (Inherited from Thing2d.)
Public method | SetPosition | (Overrides Thing2d..::..SetPosition(Size2dU).)
Public method | SetScanlines |
Public method | SetWindow | (Inherited from Thing2d.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_Alpha |
Protected field | m_colorSpace |
Protected field | m_Layer | (Inherited from Thing2d.)
Protected field | m_Name | (Inherited from Thing2d.)
Protected field | m_pixelArray2d |
Public field | m_rectSize | (Inherited from Thing2d.)
Protected field | m_resolutionX |
Protected field | m_resolutionY |

Properties

 | Name | Description
Public property | Item |
Public property | size | (Inherited from Thing2d.)

See Also

Bitmap Class
ElImage Namespace


Bitmap Constructor

[image] [image]

4 of William Foster's Class Libraries
Bitmap Constructor
Bitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Bitmap()()()() | Initializes a new instance of the Bitmap class
Public method | Bitmap(BitmapSource) | Initializes a new instance of the Bitmap class
Public method | Bitmap(Bitmap) | Initializes a new instance of the Bitmap class
Public method | Bitmap(Size2dU, ColorSpace, Color) | Initializes a new instance of the Bitmap class

See Also

Bitmap Class
Bitmap Members
ElImage Namespace


Bitmap Constructor

[image]

4 of William Foster's Class Libraries
Bitmap Constructor
Bitmap Class See Also Send Feedback
Initializes a new instance of the Bitmap class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap()
Visual Basic
Public Sub New
Visual C++
public:
Bitmap()

See Also

Bitmap Class
Bitmap Overload
ElImage Namespace


Bitmap Constructor (BitmapSource)

[image]

4 of William Foster's Class Libraries
Bitmap Constructor (BitmapSource)
Bitmap Class See Also Send Feedback
Initializes a new instance of the Bitmap class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap(
    BitmapSource bitsource
)
Visual Basic
Public Sub New ( _
    bitsource As BitmapSource _
)
Visual C++
public:
Bitmap(
    BitmapSource^ bitsource
)

Parameters

bitsource
Type: System.Windows.Media.Imaging..::..BitmapSource

[Missing <param name="bitsource"/> documentation for "M:ElImage.Bitmap.#ctor(System.Windows.Media.Imaging.BitmapSource)"]

See Also

Bitmap Class
Bitmap Overload
ElImage Namespace


Bitmap Constructor (Bitmap)

[image]

4 of William Foster's Class Libraries
Bitmap Constructor (Bitmap)
Bitmap Class See Also Send Feedback
Initializes a new instance of the Bitmap class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap(
    Bitmap duper
)
Visual Basic
Public Sub New ( _
    duper As Bitmap _
)
Visual C++
public:
Bitmap(
    Bitmap^ duper
)

Parameters

duper
Type: ElImage..::..Bitmap

[Missing <param name="duper"/> documentation for "M:ElImage.Bitmap.#ctor(ElImage.Bitmap)"]

See Also

Bitmap Class
Bitmap Overload
ElImage Namespace


Bitmap Constructor (, ColorSpace, Color)

[image]

4 of William Foster's Class Libraries
Bitmap Constructor (, ColorSpace, Color)
Bitmap Class See Also Send Feedback
Initializes a new instance of the Bitmap class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap(
    Size2dU size,
    ColorSpace colorSpace,
    Color BackgroundColor
)
Visual Basic
Public Sub New ( _
    size As Size2dU, _
    colorSpace As ColorSpace, _
    BackgroundColor As Color _
)
Visual C++
public:
Bitmap(
    Size2dU^ size,
    ColorSpace^ colorSpace,
    Color^ BackgroundColor
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElImage.Bitmap.#ctor(El.Size2dU,ElImage.ColorSpace,ElImage.Color)"]

colorSpace
Type: ElImage..::..ColorSpace

[Missing <param name="colorSpace"/> documentation for "M:ElImage.Bitmap.#ctor(El.Size2dU,ElImage.ColorSpace,ElImage.Color)"]

BackgroundColor
Type: ElImage..::..Color

[Missing <param name="BackgroundColor"/> documentation for "M:ElImage.Bitmap.#ctor(El.Size2dU,ElImage.ColorSpace,ElImage.Color)"]

See Also

Bitmap Class
Bitmap Overload
ElImage Namespace


Bitmap Fields

[image] [image]

4 of William Foster's Class Libraries
Bitmap Fields
Bitmap Class See Also Send Feedback

The Bitmap type exposes the following members.

Fields

 | Name | Description
Protected field | m_Alpha |
Protected field | m_colorSpace |
Protected field | m_Layer | (Inherited from Thing2d.)
Protected field | m_Name | (Inherited from Thing2d.)
Protected field | m_pixelArray2d |
Public field | m_rectSize | (Inherited from Thing2d.)
Protected field | m_resolutionX |
Protected field | m_resolutionY |

See Also

Bitmap Class
ElImage Namespace


m_Alpha Field

[image]

4 of William Foster's Class Libraries
Bitmap..::..m_Alpha Field
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Bitmap.m_Alpha"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected Bitmap_Alpha m_Alpha
Visual Basic
Protected m_Alpha As Bitmap_Alpha
Visual C++
protected:
Bitmap_Alpha^ m_Alpha

See Also

Bitmap Class
ElImage Namespace


m_colorSpace Field

[image]

4 of William Foster's Class Libraries
Bitmap..::..m_colorSpace Field
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Bitmap.m_colorSpace"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected ColorSpace m_colorSpace
Visual Basic
Protected m_colorSpace As ColorSpace
Visual C++
protected:
ColorSpace^ m_colorSpace

See Also

Bitmap Class
ElImage Namespace


m_pixelArray2d Field

[image]

4 of William Foster's Class Libraries
Bitmap..::..m_pixelArray2d Field
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Bitmap.m_pixelArray2d"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected Image_2dArrayPixel m_pixelArray2d
Visual Basic
Protected m_pixelArray2d As Image_2dArrayPixel
Visual C++
protected:
Image_2dArrayPixel^ m_pixelArray2d

See Also

Bitmap Class
ElImage Namespace


m_resolutionX Field

[image]

4 of William Foster's Class Libraries
Bitmap..::..m_resolutionX Field
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Bitmap.m_resolutionX"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected Resolution m_resolutionX
Visual Basic
Protected m_resolutionX As Resolution
Visual C++
protected:
Resolution^ m_resolutionX

See Also

Bitmap Class
ElImage Namespace


m_resolutionY Field

[image]

4 of William Foster's Class Libraries
Bitmap..::..m_resolutionY Field
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Bitmap.m_resolutionY"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected Resolution m_resolutionY
Visual Basic
Protected m_resolutionY As Resolution
Visual C++
protected:
Resolution^ m_resolutionY

See Also

Bitmap Class
ElImage Namespace


Bitmap Methods

[image] [image]

4 of William Foster's Class Libraries
Bitmap Methods
Bitmap Class See Also Send Feedback

The Bitmap type exposes the following members.

Methods

 | Name | Description
Public method | Allocate |
 | CalculateEffectiveBits |
Public method | crop |
Public method | Dup | (Overrides Thing2d..::..Dup()()()().)
Public method | DupAlpha |
Public method | DupAsAlpha |
Public method | Enlarge |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractBitmap |
Public method | FillRectangle |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlpha | (Overrides Thing2d..::..GetAlpha()()()().)
Public method | GetColorSpace()()()() |
Public method | GetColorSpace(ColorSpace%) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayer | (Inherited from Thing2d.)
Public method | GetName | (Inherited from Thing2d.)
Public method | GetPitch |
Public method | GetPosition | (Inherited from Thing2d.)
Public method | GetRect | (Inherited from Thing2d.)
Public method | GetRectangle |
Public method | GetResolution |
Public method | GetScanline |
Public method | GetSize | (Inherited from Thing2d.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetZoomedRectangle |
Public method | GetZoomedScanline |
Public method | GetZoomedScanlines |
Public method | IntersectsPoint | (Inherited from Thing2d.)
Public method | IsCompressed |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeBitmap |
Public method | Name | (Inherited from Thing2d.)
Public method | PickupSelection |
Public method | ReferencePixels |
Public method | Release |
Public method | Replace |
Public method | Set(Bitmap) |
Public method | Set(Bitmap) |
Public method | Set(Thing2d) | (Inherited from Thing2d.)
Public method | SetAlpha |
Public method | SetBits |
Public method | SetLayer | (Inherited from Thing2d.)
Public method | SetPosition | (Overrides Thing2d..::..SetPosition(Size2dU).)
Public method | SetScanlines |
Public method | SetWindow | (Inherited from Thing2d.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Bitmap Class
ElImage Namespace


Allocate Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..Allocate Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.Allocate(ElImage.ColorSpace,El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Allocate(
    ColorSpace colorSpace,
    Size2dU size
)
Visual Basic
Public Function Allocate ( _
    colorSpace As ColorSpace, _
    size As Size2dU _
) As Boolean
Visual C++
public:
bool Allocate(
    ColorSpace^ colorSpace,
    Size2dU^ size
)

Parameters

colorSpace
Type: ElImage..::..ColorSpace

[Missing <param name="colorSpace"/> documentation for "M:ElImage.Bitmap.Allocate(ElImage.ColorSpace,El.Size2dU)"]

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElImage.Bitmap.Allocate(ElImage.ColorSpace,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.Allocate(ElImage.ColorSpace,El.Size2dU)"]

See Also

Bitmap Class
ElImage Namespace


CalculateEffectiveBits Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..CalculateEffectiveBits Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.CalculateEffectiveBits(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static uint CalculateEffectiveBits(
    uint u_bitsPerPixel
)
Visual Basic
Public Shared Function CalculateEffectiveBits ( _
    u_bitsPerPixel As UInteger _
) As UInteger
Visual C++
public:
static unsigned int CalculateEffectiveBits(
    unsigned int u_bitsPerPixel
)

Parameters

u_bitsPerPixel
Type: System..::..UInt32

[Missing <param name="u_bitsPerPixel"/> documentation for "M:ElImage.Bitmap.CalculateEffectiveBits(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.CalculateEffectiveBits(System.UInt32)"]

See Also

Bitmap Class
ElImage Namespace


crop Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..crop Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.crop(El.Rect2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual bool crop(
    Rect2dU chunk
)
Visual Basic
Public Overridable Function crop ( _
    chunk As Rect2dU _
) As Boolean
Visual C++
public:
virtual bool crop(
    Rect2dU^ chunk
)

Parameters

chunk
Type: Rect2dU

[Missing <param name="chunk"/> documentation for "M:ElImage.Bitmap.crop(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.crop(El.Rect2dU)"]

See Also

Bitmap Class
ElImage Namespace


Dup Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..Dup Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.Dup"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override Thing2d Dup()
Visual Basic
Public Overrides Function Dup As Thing2d
Visual C++
public:
virtual Thing2d^ Dup() override

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.Dup"]

See Also

Bitmap Class
ElImage Namespace


DupAlpha Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..DupAlpha Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.DupAlpha(ElImage.Bitmap_Alpha)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void DupAlpha(
    Bitmap_Alpha Alpha
)
Visual Basic
Public Sub DupAlpha ( _
    Alpha As Bitmap_Alpha _
)
Visual C++
public:
void DupAlpha(
    Bitmap_Alpha^ Alpha
)

Parameters

Alpha
Type: ElImage..::..Bitmap_Alpha

[Missing <param name="Alpha"/> documentation for "M:ElImage.Bitmap.DupAlpha(ElImage.Bitmap_Alpha)"]

See Also

Bitmap Class
ElImage Namespace


DupAsAlpha Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..DupAsAlpha Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.DupAsAlpha"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap_Alpha DupAsAlpha()
Visual Basic
Public Function DupAsAlpha As Bitmap_Alpha
Visual C++
public:
Bitmap_Alpha^ DupAsAlpha()

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.DupAsAlpha"]

See Also

Bitmap Class
ElImage Namespace


Enlarge Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..Enlarge Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.Enlarge(El.Rect2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Enlarge(
    Rect2dU rect
)
Visual Basic
Public Function Enlarge ( _
    rect As Rect2dU _
) As Boolean
Visual C++
public:
bool Enlarge(
    Rect2dU^ rect
)

Parameters

rect
Type: Rect2dU

[Missing <param name="rect"/> documentation for "M:ElImage.Bitmap.Enlarge(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.Enlarge(El.Rect2dU)"]

See Also

Bitmap Class
ElImage Namespace


ExtractBitmap Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..ExtractBitmap Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.ExtractBitmap(El.Rect2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap ExtractBitmap(
    Rect2dU SourceRect
)
Visual Basic
Public Function ExtractBitmap ( _
    SourceRect As Rect2dU _
) As Bitmap
Visual C++
public:
Bitmap^ ExtractBitmap(
    Rect2dU^ SourceRect
)

Parameters

SourceRect
Type: Rect2dU

[Missing <param name="SourceRect"/> documentation for "M:ElImage.Bitmap.ExtractBitmap(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.ExtractBitmap(El.Rect2dU)"]

See Also

Bitmap Class
ElImage Namespace


FillRectangle Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..FillRectangle Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.FillRectangle(ElImage.Color,El.Rect2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool FillRectangle(
    Color col,
    Rect2dU r
)
Visual Basic
Public Function FillRectangle ( _
    col As Color, _
    r As Rect2dU _
) As Boolean
Visual C++
public:
bool FillRectangle(
    Color^ col,
    Rect2dU^ r
)

Parameters

col
Type: ElImage..::..Color

[Missing <param name="col"/> documentation for "M:ElImage.Bitmap.FillRectangle(ElImage.Color,El.Rect2dU)"]

r
Type: Rect2dU

[Missing <param name="r"/> documentation for "M:ElImage.Bitmap.FillRectangle(ElImage.Color,El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.FillRectangle(ElImage.Color,El.Rect2dU)"]

See Also

Bitmap Class
ElImage Namespace


GetAlpha Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..GetAlpha Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.GetAlpha"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override Bitmap_Alpha GetAlpha()
Visual Basic
Public Overrides Function GetAlpha As Bitmap_Alpha
Visual C++
public:
virtual Bitmap_Alpha^ GetAlpha() override

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.GetAlpha"]

See Also

Bitmap Class
ElImage Namespace


GetColorSpace Method

[image] [image]

4 of William Foster's Class Libraries
Bitmap..::..GetColorSpace Method
Bitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetColorSpace()()()() |
Public method | GetColorSpace(ColorSpace%) |

See Also

Bitmap Class
Bitmap Members
ElImage Namespace


GetColorSpace Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..GetColorSpace Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.GetColorSpace"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ColorSpace GetColorSpace()
Visual Basic
Public Function GetColorSpace As ColorSpace
Visual C++
public:
ColorSpace^ GetColorSpace()

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.GetColorSpace"]

See Also

Bitmap Class
GetColorSpace Overload
ElImage Namespace


GetColorSpace Method (ColorSpace)

[image]

4 of William Foster's Class Libraries
Bitmap..::..GetColorSpace Method (ColorSpace%)
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.GetColorSpace(ElImage.ColorSpace@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void GetColorSpace(
    out ColorSpace colorSpace
)
Visual Basic
Public Sub GetColorSpace ( _
    <OutAttribute> ByRef colorSpace As ColorSpace _
)
Visual C++
public:
void GetColorSpace(
    [OutAttribute] ColorSpace^% colorSpace
)

Parameters

colorSpace
Type: ElImage..::..ColorSpace %

[Missing <param name="colorSpace"/> documentation for "M:ElImage.Bitmap.GetColorSpace(ElImage.ColorSpace@)"]

See Also

Bitmap Class
GetColorSpace Overload
ElImage Namespace


GetPitch Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..GetPitch Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.GetPitch"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint GetPitch()
Visual Basic
Public Function GetPitch As UInteger
Visual C++
public:
unsigned int GetPitch()

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.GetPitch"]

See Also

Bitmap Class
ElImage Namespace


GetRectangle Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..GetRectangle Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.GetRectangle(System.Byte[],El.Size2dU,El.Size2dU,ElImage.ColorSpace)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool GetRectangle(
    byte[] destPixels,
    Size2dU Size,
    Size2dU Origin,
    ColorSpace destCSpace
)
Visual Basic
Public Function GetRectangle ( _
    destPixels As Byte(), _
    Size As Size2dU, _
    Origin As Size2dU, _
    destCSpace As ColorSpace _
) As Boolean
Visual C++
public:
bool GetRectangle(
    array<unsigned char>^ destPixels,
    Size2dU^ Size,
    Size2dU^ Origin,
    ColorSpace^ destCSpace
)

Parameters

destPixels
Type: array< System..::..Byte >[]()[][]

[Missing <param name="destPixels"/> documentation for "M:ElImage.Bitmap.GetRectangle(System.Byte[],El.Size2dU,El.Size2dU,ElImage.ColorSpace)"]

Size
Type: Size2dU

[Missing <param name="Size"/> documentation for "M:ElImage.Bitmap.GetRectangle(System.Byte[],El.Size2dU,El.Size2dU,ElImage.ColorSpace)"]

Origin
Type: Size2dU

[Missing <param name="Origin"/> documentation for "M:ElImage.Bitmap.GetRectangle(System.Byte[],El.Size2dU,El.Size2dU,ElImage.ColorSpace)"]

destCSpace
Type: ElImage..::..ColorSpace

[Missing <param name="destCSpace"/> documentation for "M:ElImage.Bitmap.GetRectangle(System.Byte[],El.Size2dU,El.Size2dU,ElImage.ColorSpace)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.GetRectangle(System.Byte[],El.Size2dU,El.Size2dU,ElImage.ColorSpace)"]

See Also

Bitmap Class
ElImage Namespace


GetResolution Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..GetResolution Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.GetResolution(ElImage.Resolution,ElImage.Resolution)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void GetResolution(
    Resolution resolutionX,
    Resolution resolutionY
)
Visual Basic
Public Sub GetResolution ( _
    resolutionX As Resolution, _
    resolutionY As Resolution _
)
Visual C++
public:
void GetResolution(
    Resolution^ resolutionX,
    Resolution^ resolutionY
)

Parameters

resolutionX
Type: ElImage..::..Resolution

[Missing <param name="resolutionX"/> documentation for "M:ElImage.Bitmap.GetResolution(ElImage.Resolution,ElImage.Resolution)"]

resolutionY
Type: ElImage..::..Resolution

[Missing <param name="resolutionY"/> documentation for "M:ElImage.Bitmap.GetResolution(ElImage.Resolution,ElImage.Resolution)"]

See Also

Bitmap Class
ElImage Namespace


GetScanline Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..GetScanline Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.GetScanline(System.Byte[],System.Int32,System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool GetScanline(
    byte[] pixelData,
    int dOffset,
    uint u_x,
    uint u_y,
    uint ww,
    ColorSpace cspace
)
Visual Basic
Public Function GetScanline ( _
    pixelData As Byte(), _
    dOffset As Integer, _
    u_x As UInteger, _
    u_y As UInteger, _
    ww As UInteger, _
    cspace As ColorSpace _
) As Boolean
Visual C++
public:
bool GetScanline(
    array<unsigned char>^ pixelData,
    int dOffset,
    unsigned int u_x,
    unsigned int u_y,
    unsigned int ww,
    ColorSpace^ cspace
)

Parameters

pixelData
Type: array< System..::..Byte >[]()[][]

[Missing <param name="pixelData"/> documentation for "M:ElImage.Bitmap.GetScanline(System.Byte[],System.Int32,System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace)"]

dOffset
Type: System..::..Int32

[Missing <param name="dOffset"/> documentation for "M:ElImage.Bitmap.GetScanline(System.Byte[],System.Int32,System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace)"]

u_x
Type: System..::..UInt32

[Missing <param name="u_x"/> documentation for "M:ElImage.Bitmap.GetScanline(System.Byte[],System.Int32,System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace)"]

u_y
Type: System..::..UInt32

[Missing <param name="u_y"/> documentation for "M:ElImage.Bitmap.GetScanline(System.Byte[],System.Int32,System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace)"]

ww
Type: System..::..UInt32

[Missing <param name="ww"/> documentation for "M:ElImage.Bitmap.GetScanline(System.Byte[],System.Int32,System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace)"]

cspace
Type: ElImage..::..ColorSpace

[Missing <param name="cspace"/> documentation for "M:ElImage.Bitmap.GetScanline(System.Byte[],System.Int32,System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.GetScanline(System.Byte[],System.Int32,System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace)"]

See Also

Bitmap Class
ElImage Namespace


GetZoomedRectangle Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..GetZoomedRectangle Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.GetZoomedRectangle(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool GetZoomedRectangle(
    byte[] destPixels,
    Size2dU destSize,
    Size2dU sourceOrigin,
    double zoom,
    ColorSpace destCSpace
)
Visual Basic
Public Function GetZoomedRectangle ( _
    destPixels As Byte(), _
    destSize As Size2dU, _
    sourceOrigin As Size2dU, _
    zoom As Double, _
    destCSpace As ColorSpace _
) As Boolean
Visual C++
public:
bool GetZoomedRectangle(
    array<unsigned char>^ destPixels,
    Size2dU^ destSize,
    Size2dU^ sourceOrigin,
    double zoom,
    ColorSpace^ destCSpace
)

Parameters

destPixels
Type: array< System..::..Byte >[]()[][]

[Missing <param name="destPixels"/> documentation for "M:ElImage.Bitmap.GetZoomedRectangle(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

destSize
Type: Size2dU

[Missing <param name="destSize"/> documentation for "M:ElImage.Bitmap.GetZoomedRectangle(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

sourceOrigin
Type: Size2dU

[Missing <param name="sourceOrigin"/> documentation for "M:ElImage.Bitmap.GetZoomedRectangle(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

zoom
Type: System..::..Double

[Missing <param name="zoom"/> documentation for "M:ElImage.Bitmap.GetZoomedRectangle(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

destCSpace
Type: ElImage..::..ColorSpace

[Missing <param name="destCSpace"/> documentation for "M:ElImage.Bitmap.GetZoomedRectangle(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.GetZoomedRectangle(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

See Also

Bitmap Class
ElImage Namespace


GetZoomedScanline Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..GetZoomedScanline Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.GetZoomedScanline(System.Byte[],System.Int32,El.Size2dU,System.UInt32,System.Double,ElImage.ColorSpace)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool GetZoomedScanline(
    byte[] destPixels,
    int doffset,
    Size2dU source_pos,
    uint dest_ww,
    double zoom,
    ColorSpace cspace
)
Visual Basic
Public Function GetZoomedScanline ( _
    destPixels As Byte(), _
    doffset As Integer, _
    source_pos As Size2dU, _
    dest_ww As UInteger, _
    zoom As Double, _
    cspace As ColorSpace _
) As Boolean
Visual C++
public:
bool GetZoomedScanline(
    array<unsigned char>^ destPixels,
    int doffset,
    Size2dU^ source_pos,
    unsigned int dest_ww,
    double zoom,
    ColorSpace^ cspace
)

Parameters

destPixels
Type: array< System..::..Byte >[]()[][]

[Missing <param name="destPixels"/> documentation for "M:ElImage.Bitmap.GetZoomedScanline(System.Byte[],System.Int32,El.Size2dU,System.UInt32,System.Double,ElImage.ColorSpace)"]

doffset
Type: System..::..Int32

[Missing <param name="doffset"/> documentation for "M:ElImage.Bitmap.GetZoomedScanline(System.Byte[],System.Int32,El.Size2dU,System.UInt32,System.Double,ElImage.ColorSpace)"]

source_pos
Type: Size2dU

[Missing <param name="source_pos"/> documentation for "M:ElImage.Bitmap.GetZoomedScanline(System.Byte[],System.Int32,El.Size2dU,System.UInt32,System.Double,ElImage.ColorSpace)"]

dest_ww
Type: System..::..UInt32

[Missing <param name="dest_ww"/> documentation for "M:ElImage.Bitmap.GetZoomedScanline(System.Byte[],System.Int32,El.Size2dU,System.UInt32,System.Double,ElImage.ColorSpace)"]

zoom
Type: System..::..Double

[Missing <param name="zoom"/> documentation for "M:ElImage.Bitmap.GetZoomedScanline(System.Byte[],System.Int32,El.Size2dU,System.UInt32,System.Double,ElImage.ColorSpace)"]

cspace
Type: ElImage..::..ColorSpace

[Missing <param name="cspace"/> documentation for "M:ElImage.Bitmap.GetZoomedScanline(System.Byte[],System.Int32,El.Size2dU,System.UInt32,System.Double,ElImage.ColorSpace)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.GetZoomedScanline(System.Byte[],System.Int32,El.Size2dU,System.UInt32,System.Double,ElImage.ColorSpace)"]

See Also

Bitmap Class
ElImage Namespace


GetZoomedScanlines Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..GetZoomedScanlines Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.GetZoomedScanlines(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool GetZoomedScanlines(
    byte[] destPixels,
    Size2dU source_pos,
    Size2dU dest_size,
    double zoom,
    ColorSpace cspace
)
Visual Basic
Public Function GetZoomedScanlines ( _
    destPixels As Byte(), _
    source_pos As Size2dU, _
    dest_size As Size2dU, _
    zoom As Double, _
    cspace As ColorSpace _
) As Boolean
Visual C++
public:
bool GetZoomedScanlines(
    array<unsigned char>^ destPixels,
    Size2dU^ source_pos,
    Size2dU^ dest_size,
    double zoom,
    ColorSpace^ cspace
)

Parameters

destPixels
Type: array< System..::..Byte >[]()[][]

[Missing <param name="destPixels"/> documentation for "M:ElImage.Bitmap.GetZoomedScanlines(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

source_pos
Type: Size2dU

[Missing <param name="source_pos"/> documentation for "M:ElImage.Bitmap.GetZoomedScanlines(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

dest_size
Type: Size2dU

[Missing <param name="dest_size"/> documentation for "M:ElImage.Bitmap.GetZoomedScanlines(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

zoom
Type: System..::..Double

[Missing <param name="zoom"/> documentation for "M:ElImage.Bitmap.GetZoomedScanlines(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

cspace
Type: ElImage..::..ColorSpace

[Missing <param name="cspace"/> documentation for "M:ElImage.Bitmap.GetZoomedScanlines(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.GetZoomedScanlines(System.Byte[],El.Size2dU,El.Size2dU,System.Double,ElImage.ColorSpace)"]

See Also

Bitmap Class
ElImage Namespace


IsCompressed Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..IsCompressed Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.IsCompressed"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool IsCompressed()
Visual Basic
Public Function IsCompressed As Boolean
Visual C++
public:
bool IsCompressed()

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.IsCompressed"]

See Also

Bitmap Class
ElImage Namespace


MergeBitmap Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..MergeBitmap Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.MergeBitmap(ElImage.Bitmap)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void MergeBitmap(
    Bitmap merge
)
Visual Basic
Public Sub MergeBitmap ( _
    merge As Bitmap _
)
Visual C++
public:
void MergeBitmap(
    Bitmap^ merge
)

Parameters

merge
Type: ElImage..::..Bitmap

[Missing <param name="merge"/> documentation for "M:ElImage.Bitmap.MergeBitmap(ElImage.Bitmap)"]

See Also

Bitmap Class
ElImage Namespace


PickupSelection Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..PickupSelection Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.PickupSelection(ElImage.Bitmap_Alpha,ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap PickupSelection(
    Bitmap_Alpha Alpha,
    Color BackgroundColor
)
Visual Basic
Public Function PickupSelection ( _
    Alpha As Bitmap_Alpha, _
    BackgroundColor As Color _
) As Bitmap
Visual C++
public:
Bitmap^ PickupSelection(
    Bitmap_Alpha^ Alpha,
    Color^ BackgroundColor
)

Parameters

Alpha
Type: ElImage..::..Bitmap_Alpha

[Missing <param name="Alpha"/> documentation for "M:ElImage.Bitmap.PickupSelection(ElImage.Bitmap_Alpha,ElImage.Color)"]

BackgroundColor
Type: ElImage..::..Color

[Missing <param name="BackgroundColor"/> documentation for "M:ElImage.Bitmap.PickupSelection(ElImage.Bitmap_Alpha,ElImage.Color)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.PickupSelection(ElImage.Bitmap_Alpha,ElImage.Color)"]

See Also

Bitmap Class
ElImage Namespace


ReferencePixels Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..ReferencePixels Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.ReferencePixels(El.Size2dU,System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Pixels ReferencePixels(
    Size2dU pos,
    uint u_getPixelCount
)
Visual Basic
Public Function ReferencePixels ( _
    pos As Size2dU, _
    u_getPixelCount As UInteger _
) As Pixels
Visual C++
public:
Pixels^ ReferencePixels(
    Size2dU^ pos,
    unsigned int u_getPixelCount
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.Bitmap.ReferencePixels(El.Size2dU,System.UInt32)"]

u_getPixelCount
Type: System..::..UInt32

[Missing <param name="u_getPixelCount"/> documentation for "M:ElImage.Bitmap.ReferencePixels(El.Size2dU,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.ReferencePixels(El.Size2dU,System.UInt32)"]

See Also

Bitmap Class
ElImage Namespace


Release Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..Release Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.Release"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Release()
Visual Basic
Public Function Release As Boolean
Visual C++
public:
bool Release()

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.Release"]

See Also

Bitmap Class
ElImage Namespace


Replace Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..Replace Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.Replace(ElImage.Bitmap)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Replace(
    Bitmap Bmp
)
Visual Basic
Public Function Replace ( _
    Bmp As Bitmap _
) As Boolean
Visual C++
public:
bool Replace(
    Bitmap^ Bmp
)

Parameters

Bmp
Type: ElImage..::..Bitmap

[Missing <param name="Bmp"/> documentation for "M:ElImage.Bitmap.Replace(ElImage.Bitmap)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.Replace(ElImage.Bitmap)"]

See Also

Bitmap Class
ElImage Namespace


Set Method

[image] [image]

4 of William Foster's Class Libraries
Bitmap..::..Set Method
Bitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Bitmap) |
Public method | Set(Bitmap) |
Public method | Set(Thing2d) | (Inherited from Thing2d.)

See Also

Bitmap Class
Bitmap Members
ElImage Namespace


Set Method (Bitmap)

[image]

4 of William Foster's Class Libraries
Bitmap..::..Set Method (Bitmap)
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.Set(System.Drawing.Bitmap)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Set(
    Bitmap sysbmp
)
Visual Basic
Public Sub Set ( _
    sysbmp As Bitmap _
)
Visual C++
public:
void Set(
    Bitmap^ sysbmp
)

Parameters

sysbmp
Type: System.Drawing..::..Bitmap

[Missing <param name="sysbmp"/> documentation for "M:ElImage.Bitmap.Set(System.Drawing.Bitmap)"]

See Also

Bitmap Class
Set Overload
ElImage Namespace


Set Method (Bitmap)

[image]

4 of William Foster's Class Libraries
Bitmap..::..Set Method (Bitmap)
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.Set(ElImage.Bitmap)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Set(
    Bitmap bmp
)
Visual Basic
Public Sub Set ( _
    bmp As Bitmap _
)
Visual C++
public:
void Set(
    Bitmap^ bmp
)

Parameters

bmp
Type: ElImage..::..Bitmap

[Missing <param name="bmp"/> documentation for "M:ElImage.Bitmap.Set(ElImage.Bitmap)"]

See Also

Bitmap Class
Set Overload
ElImage Namespace


SetAlpha Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..SetAlpha Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.SetAlpha(ElImage.Bitmap_Alpha)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetAlpha(
    Bitmap_Alpha Alpha
)
Visual Basic
Public Sub SetAlpha ( _
    Alpha As Bitmap_Alpha _
)
Visual C++
public:
void SetAlpha(
    Bitmap_Alpha^ Alpha
)

Parameters

Alpha
Type: ElImage..::..Bitmap_Alpha

[Missing <param name="Alpha"/> documentation for "M:ElImage.Bitmap.SetAlpha(ElImage.Bitmap_Alpha)"]

See Also

Bitmap Class
ElImage Namespace


SetBits Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..SetBits Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.SetBits(System.Array,System.Int32,El.Size2dU,El.Size2dU,System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool SetBits(
    Array srcBits,
    int src_offset,
    Size2dU dstPos,
    Size2dU dstSize,
    uint u_pitch
)
Visual Basic
Public Function SetBits ( _
    srcBits As Array, _
    src_offset As Integer, _
    dstPos As Size2dU, _
    dstSize As Size2dU, _
    u_pitch As UInteger _
) As Boolean
Visual C++
public:
bool SetBits(
    Array^ srcBits,
    int src_offset,
    Size2dU^ dstPos,
    Size2dU^ dstSize,
    unsigned int u_pitch
)

Parameters

srcBits
Type: System..::..Array

[Missing <param name="srcBits"/> documentation for "M:ElImage.Bitmap.SetBits(System.Array,System.Int32,El.Size2dU,El.Size2dU,System.UInt32)"]

src_offset
Type: System..::..Int32

[Missing <param name="src_offset"/> documentation for "M:ElImage.Bitmap.SetBits(System.Array,System.Int32,El.Size2dU,El.Size2dU,System.UInt32)"]

dstPos
Type: Size2dU

[Missing <param name="dstPos"/> documentation for "M:ElImage.Bitmap.SetBits(System.Array,System.Int32,El.Size2dU,El.Size2dU,System.UInt32)"]

dstSize
Type: Size2dU

[Missing <param name="dstSize"/> documentation for "M:ElImage.Bitmap.SetBits(System.Array,System.Int32,El.Size2dU,El.Size2dU,System.UInt32)"]

u_pitch
Type: System..::..UInt32

[Missing <param name="u_pitch"/> documentation for "M:ElImage.Bitmap.SetBits(System.Array,System.Int32,El.Size2dU,El.Size2dU,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.SetBits(System.Array,System.Int32,El.Size2dU,El.Size2dU,System.UInt32)"]

See Also

Bitmap Class
ElImage Namespace


SetPosition Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..SetPosition Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.SetPosition(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override void SetPosition(
    Size2dU pos
)
Visual Basic
Public Overrides Sub SetPosition ( _
    pos As Size2dU _
)
Visual C++
public:
virtual void SetPosition(
    Size2dU^ pos
) override

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.Bitmap.SetPosition(El.Size2dU)"]

See Also

Bitmap Class
ElImage Namespace


SetScanlines Method

[image]

4 of William Foster's Class Libraries
Bitmap..::..SetScanlines Method
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap.SetScanlines(System.Byte[],System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace,System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool SetScanlines(
    byte[] pixelData,
    uint u_x,
    uint u_y,
    uint ww,
    ColorSpace cspace,
    uint u_nLines
)
Visual Basic
Public Function SetScanlines ( _
    pixelData As Byte(), _
    u_x As UInteger, _
    u_y As UInteger, _
    ww As UInteger, _
    cspace As ColorSpace, _
    u_nLines As UInteger _
) As Boolean
Visual C++
public:
bool SetScanlines(
    array<unsigned char>^ pixelData,
    unsigned int u_x,
    unsigned int u_y,
    unsigned int ww,
    ColorSpace^ cspace,
    unsigned int u_nLines
)

Parameters

pixelData
Type: array< System..::..Byte >[]()[][]

[Missing <param name="pixelData"/> documentation for "M:ElImage.Bitmap.SetScanlines(System.Byte[],System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace,System.UInt32)"]

u_x
Type: System..::..UInt32

[Missing <param name="u_x"/> documentation for "M:ElImage.Bitmap.SetScanlines(System.Byte[],System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace,System.UInt32)"]

u_y
Type: System..::..UInt32

[Missing <param name="u_y"/> documentation for "M:ElImage.Bitmap.SetScanlines(System.Byte[],System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace,System.UInt32)"]

ww
Type: System..::..UInt32

[Missing <param name="ww"/> documentation for "M:ElImage.Bitmap.SetScanlines(System.Byte[],System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace,System.UInt32)"]

cspace
Type: ElImage..::..ColorSpace

[Missing <param name="cspace"/> documentation for "M:ElImage.Bitmap.SetScanlines(System.Byte[],System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace,System.UInt32)"]

u_nLines
Type: System..::..UInt32

[Missing <param name="u_nLines"/> documentation for "M:ElImage.Bitmap.SetScanlines(System.Byte[],System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap.SetScanlines(System.Byte[],System.UInt32,System.UInt32,System.UInt32,ElImage.ColorSpace,System.UInt32)"]

See Also

Bitmap Class
ElImage Namespace


Bitmap Properties

[image] [image]

4 of William Foster's Class Libraries
Bitmap Properties
Bitmap Class See Also Send Feedback

The Bitmap type exposes the following members.

Properties

 | Name | Description
Public property | Item |
Public property | size | (Inherited from Thing2d.)

See Also

Bitmap Class
ElImage Namespace


Item Property

[image]

4 of William Foster's Class Libraries
Bitmap..::..Item Property
Bitmap Class See Also Send Feedback

[Missing <summary> documentation for "P:ElImage.Bitmap.Item(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Color this[
    Size2dU pos
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    pos As Size2dU _
) As Color
    Get
Visual C++
public:
property Color^ default[Size2dU^ pos] {
    Color^ get (Size2dU^ pos);
}

Parameters

pos
Type: Size2dU

See Also

Bitmap Class
ElImage Namespace


Bitmap_Alpha Class

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Bitmap_Alpha"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Bitmap_Alpha : Bitmap
Visual Basic
Public Class Bitmap_Alpha _
    Inherits Bitmap
Visual C++
public ref class Bitmap_Alpha : public Bitmap

Inheritance Hierarchy

System..::..Object
ElImage..::..Thing2d
ElImage..::..Bitmap
ElImage..::..Bitmap_Alpha

See Also

Bitmap_Alpha Members
ElImage Namespace


Bitmap_Alpha Members

[image] [image]

4 of William Foster's Class Libraries
Bitmap_Alpha Members
Bitmap_Alpha Class Constructors Methods Fields Properties See Also Send Feedback

The Bitmap_Alpha type exposes the following members.

Constructors

 | Name | Description
Public method | Bitmap_Alpha()()()() | Initializes a new instance of the Bitmap_Alpha class
Public method | Bitmap_Alpha(Size2dU) | Initializes a new instance of the Bitmap_Alpha class

Methods

 | Name | Description
Public method | AdjacentOff |
Public method | AdjacentOn |
Public method | Allocate | (Inherited from Bitmap.)
Public method | BitwiseOR | OR's the bits of the given alpha into this one. bmpAlpha may be a smaller bitmap with it's position set
Public method | crop | (Inherited from Bitmap.)
Public method | Dup |
Public method | DupAlpha | (Inherited from Bitmap.)
Public method | DupAsAlpha | (Inherited from Bitmap.)
Public method | Edge |
Public method | Enlarge | (Inherited from Bitmap.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractBitmap |
Public method | FillRectangle | (Inherited from Bitmap.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlpha | (Inherited from Bitmap.)
Public method | GetArray |
Public method | GetColorSpace()()()() | (Inherited from Bitmap.)
Public method | GetColorSpace(ColorSpace%) | (Inherited from Bitmap.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayer | (Inherited from Thing2d.)
Public method | GetName | (Inherited from Thing2d.)
Public method | GetPitch | (Inherited from Bitmap.)
Public method | GetPosition | (Inherited from Thing2d.)
Public method | GetRect | (Inherited from Thing2d.)
Public method | GetRectangle | (Inherited from Bitmap.)
Public method | GetResolution | (Inherited from Bitmap.)
Public method | GetScanline | (Inherited from Bitmap.)
Public method | GetSize | (Inherited from Thing2d.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetZoomedRectangle | (Inherited from Bitmap.)
Public method | GetZoomedScanline | (Inherited from Bitmap.)
Public method | GetZoomedScanlines | (Inherited from Bitmap.)
Public method | IntersectsPoint | (Inherited from Thing2d.)
Public method | Invert | Set all data within this Alpha to 255-data
Protected method | IsBlankLine |
Public method | IsCompressed | (Inherited from Bitmap.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeBitmap | (Inherited from Bitmap.)
Public method | Name | (Inherited from Thing2d.)
Public method | PickupSelection | (Inherited from Bitmap.)
Protected method | RangeOfZeros |
Public method | ReferencePixels | (Inherited from Bitmap.)
Public method | Release | (Inherited from Bitmap.)
Public method | Replace | (Inherited from Bitmap.)
Public method | Set(Bitmap) | (Inherited from Bitmap.)
Public method | Set(Bitmap) | (Inherited from Bitmap.)
Public method | Set(Thing2d) | (Inherited from Thing2d.)
Public method | Set(Size2dU, Byte) |
Public method | SetAlpha | (Inherited from Bitmap.)
Public method | SetBits | (Inherited from Bitmap.)
Public method | SetLayer | (Inherited from Thing2d.)
Public method | SetPosition | (Inherited from Bitmap.)
Public method | SetScanlines | (Inherited from Bitmap.)
Public method | SetWindow | (Inherited from Thing2d.)
Public method | Shrink |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_Alpha | (Inherited from Bitmap.)
Protected field | m_colorSpace | (Inherited from Bitmap.)
Protected field | m_Layer | (Inherited from Thing2d.)
Protected field | m_Name | (Inherited from Thing2d.)
Protected field | m_pixelArray2d | (Inherited from Bitmap.)
Public field | m_rectSize | (Inherited from Thing2d.)
Protected field | m_resolutionX | (Inherited from Bitmap.)
Protected field | m_resolutionY | (Inherited from Bitmap.)

Properties

 | Name | Description
Public property | Item |
Public property | size | (Inherited from Thing2d.)

See Also

Bitmap_Alpha Class
ElImage Namespace


Bitmap_Alpha Constructor

[image] [image]

4 of William Foster's Class Libraries
Bitmap_Alpha Constructor
Bitmap_Alpha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Bitmap_Alpha()()()() | Initializes a new instance of the Bitmap_Alpha class
Public method | Bitmap_Alpha(Size2dU) | Initializes a new instance of the Bitmap_Alpha class

See Also

Bitmap_Alpha Class
Bitmap_Alpha Members
ElImage Namespace


Bitmap_Alpha Constructor

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha Constructor
Bitmap_Alpha Class See Also Send Feedback
Initializes a new instance of the Bitmap_Alpha class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap_Alpha()
Visual Basic
Public Sub New
Visual C++
public:
Bitmap_Alpha()

See Also

Bitmap_Alpha Class
Bitmap_Alpha Overload
ElImage Namespace


Bitmap_Alpha Constructor ()

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha Constructor ()
Bitmap_Alpha Class See Also Send Feedback
Initializes a new instance of the Bitmap_Alpha class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap_Alpha(
    Size2dU size
)
Visual Basic
Public Sub New ( _
    size As Size2dU _
)
Visual C++
public:
Bitmap_Alpha(
    Size2dU^ size
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElImage.Bitmap_Alpha.#ctor(El.Size2dU)"]

See Also

Bitmap_Alpha Class
Bitmap_Alpha Overload
ElImage Namespace


Bitmap_Alpha Fields

[image] [image]

4 of William Foster's Class Libraries
Bitmap_Alpha Fields
Bitmap_Alpha Class See Also Send Feedback

The Bitmap_Alpha type exposes the following members.

Fields

 | Name | Description
Protected field | m_Alpha | (Inherited from Bitmap.)
Protected field | m_colorSpace | (Inherited from Bitmap.)
Protected field | m_Layer | (Inherited from Thing2d.)
Protected field | m_Name | (Inherited from Thing2d.)
Protected field | m_pixelArray2d | (Inherited from Bitmap.)
Public field | m_rectSize | (Inherited from Thing2d.)
Protected field | m_resolutionX | (Inherited from Bitmap.)
Protected field | m_resolutionY | (Inherited from Bitmap.)

See Also

Bitmap_Alpha Class
ElImage Namespace


Bitmap_Alpha Methods

[image] [image]

4 of William Foster's Class Libraries
Bitmap_Alpha Methods
Bitmap_Alpha Class See Also Send Feedback

The Bitmap_Alpha type exposes the following members.

Methods

 | Name | Description
Public method | AdjacentOff |
Public method | AdjacentOn |
Public method | Allocate | (Inherited from Bitmap.)
Public method | BitwiseOR | OR's the bits of the given alpha into this one. bmpAlpha may be a smaller bitmap with it's position set
Public method | crop | (Inherited from Bitmap.)
Public method | Dup |
Public method | DupAlpha | (Inherited from Bitmap.)
Public method | DupAsAlpha | (Inherited from Bitmap.)
Public method | Edge |
Public method | Enlarge | (Inherited from Bitmap.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractBitmap |
Public method | FillRectangle | (Inherited from Bitmap.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlpha | (Inherited from Bitmap.)
Public method | GetArray |
Public method | GetColorSpace()()()() | (Inherited from Bitmap.)
Public method | GetColorSpace(ColorSpace%) | (Inherited from Bitmap.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayer | (Inherited from Thing2d.)
Public method | GetName | (Inherited from Thing2d.)
Public method | GetPitch | (Inherited from Bitmap.)
Public method | GetPosition | (Inherited from Thing2d.)
Public method | GetRect | (Inherited from Thing2d.)
Public method | GetRectangle | (Inherited from Bitmap.)
Public method | GetResolution | (Inherited from Bitmap.)
Public method | GetScanline | (Inherited from Bitmap.)
Public method | GetSize | (Inherited from Thing2d.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetZoomedRectangle | (Inherited from Bitmap.)
Public method | GetZoomedScanline | (Inherited from Bitmap.)
Public method | GetZoomedScanlines | (Inherited from Bitmap.)
Public method | IntersectsPoint | (Inherited from Thing2d.)
Public method | Invert | Set all data within this Alpha to 255-data
Protected method | IsBlankLine |
Public method | IsCompressed | (Inherited from Bitmap.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeBitmap | (Inherited from Bitmap.)
Public method | Name | (Inherited from Thing2d.)
Public method | PickupSelection | (Inherited from Bitmap.)
Protected method | RangeOfZeros |
Public method | ReferencePixels | (Inherited from Bitmap.)
Public method | Release | (Inherited from Bitmap.)
Public method | Replace | (Inherited from Bitmap.)
Public method | Set(Bitmap) | (Inherited from Bitmap.)
Public method | Set(Bitmap) | (Inherited from Bitmap.)
Public method | Set(Thing2d) | (Inherited from Thing2d.)
Public method | Set(Size2dU, Byte) |
Public method | SetAlpha | (Inherited from Bitmap.)
Public method | SetBits | (Inherited from Bitmap.)
Public method | SetLayer | (Inherited from Thing2d.)
Public method | SetPosition | (Inherited from Bitmap.)
Public method | SetScanlines | (Inherited from Bitmap.)
Public method | SetWindow | (Inherited from Thing2d.)
Public method | Shrink |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Bitmap_Alpha Class
ElImage Namespace


AdjacentOff Method

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..AdjacentOff Method
Bitmap_Alpha Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap_Alpha.AdjacentOff(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte AdjacentOff(
    Size2dU pos
)
Visual Basic
Public Function AdjacentOff ( _
    pos As Size2dU _
) As Byte
Visual C++
public:
unsigned char AdjacentOff(
    Size2dU^ pos
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.Bitmap_Alpha.AdjacentOff(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap_Alpha.AdjacentOff(El.Size2dU)"]

See Also

Bitmap_Alpha Class
ElImage Namespace


AdjacentOn Method

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..AdjacentOn Method
Bitmap_Alpha Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap_Alpha.AdjacentOn(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte AdjacentOn(
    Size2dU pos
)
Visual Basic
Public Function AdjacentOn ( _
    pos As Size2dU _
) As Byte
Visual C++
public:
unsigned char AdjacentOn(
    Size2dU^ pos
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.Bitmap_Alpha.AdjacentOn(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap_Alpha.AdjacentOn(El.Size2dU)"]

See Also

Bitmap_Alpha Class
ElImage Namespace


BitwiseOR Method

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..BitwiseOR Method
Bitmap_Alpha Class See Also Send Feedback
OR's the bits of the given alpha into this one. bmpAlpha may be a smaller bitmap with it's position set

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void BitwiseOR(
    Bitmap_Alpha bmpAlpha
)
Visual Basic
Public Sub BitwiseOR ( _
    bmpAlpha As Bitmap_Alpha _
)
Visual C++
public:
void BitwiseOR(
    Bitmap_Alpha^ bmpAlpha
)

Parameters

bmpAlpha
Type: ElImage..::..Bitmap_Alpha

[Missing <param name="bmpAlpha"/> documentation for "M:ElImage.Bitmap_Alpha.BitwiseOR(ElImage.Bitmap_Alpha)"]

See Also

Bitmap_Alpha Class
ElImage Namespace


Dup Method

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..Dup Method
Bitmap_Alpha Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap_Alpha.Dup"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap_Alpha Dup()
Visual Basic
Public Function Dup As Bitmap_Alpha
Visual C++
public:
Bitmap_Alpha^ Dup()

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap_Alpha.Dup"]

See Also

Bitmap_Alpha Class
ElImage Namespace


Edge Method

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..Edge Method
Bitmap_Alpha Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap_Alpha.Edge(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte Edge(
    Size2dU pos
)
Visual Basic
Public Function Edge ( _
    pos As Size2dU _
) As Byte
Visual C++
public:
unsigned char Edge(
    Size2dU^ pos
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.Bitmap_Alpha.Edge(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap_Alpha.Edge(El.Size2dU)"]

See Also

Bitmap_Alpha Class
ElImage Namespace


ExtractBitmap Method

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..ExtractBitmap Method
Bitmap_Alpha Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap_Alpha.ExtractBitmap(El.Rect2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap_Alpha ExtractBitmap(
    Rect2dU SourceRect
)
Visual Basic
Public Function ExtractBitmap ( _
    SourceRect As Rect2dU _
) As Bitmap_Alpha
Visual C++
public:
Bitmap_Alpha^ ExtractBitmap(
    Rect2dU^ SourceRect
)

Parameters

SourceRect
Type: Rect2dU

[Missing <param name="SourceRect"/> documentation for "M:ElImage.Bitmap_Alpha.ExtractBitmap(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap_Alpha.ExtractBitmap(El.Rect2dU)"]

See Also

Bitmap_Alpha Class
ElImage Namespace


GetArray Method

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..GetArray Method
Bitmap_Alpha Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap_Alpha.GetArray(El.Size2dU,System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ArraySegment<byte> GetArray(
    Size2dU pos,
    uint count
)
Visual Basic
Public Function GetArray ( _
    pos As Size2dU, _
    count As UInteger _
) As ArraySegment(Of Byte)
Visual C++
public:
ArraySegment<unsigned char> GetArray(
    Size2dU^ pos,
    unsigned int count
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.Bitmap_Alpha.GetArray(El.Size2dU,System.UInt32)"]

count
Type: System..::..UInt32

[Missing <param name="count"/> documentation for "M:ElImage.Bitmap_Alpha.GetArray(El.Size2dU,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap_Alpha.GetArray(El.Size2dU,System.UInt32)"]

See Also

Bitmap_Alpha Class
ElImage Namespace


GetColorSpace Method

[image] [image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..GetColorSpace Method
Bitmap_Alpha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetColorSpace()()()() | (Inherited from Bitmap.)
Public method | GetColorSpace(ColorSpace%) | (Inherited from Bitmap.)

See Also

Bitmap_Alpha Class
Bitmap_Alpha Members
ElImage Namespace


Invert Method

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..Invert Method
Bitmap_Alpha Class See Also Send Feedback
Set all data within this Alpha to 255-data

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Invert()
Visual Basic
Public Sub Invert
Visual C++
public:
void Invert()

See Also

Bitmap_Alpha Class
ElImage Namespace


IsBlankLine Method

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..IsBlankLine Method
Bitmap_Alpha Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap_Alpha.IsBlankLine(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected bool IsBlankLine(
    uint line
)
Visual Basic
Protected Function IsBlankLine ( _
    line As UInteger _
) As Boolean
Visual C++
protected:
bool IsBlankLine(
    unsigned int line
)

Parameters

line
Type: System..::..UInt32

[Missing <param name="line"/> documentation for "M:ElImage.Bitmap_Alpha.IsBlankLine(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap_Alpha.IsBlankLine(System.UInt32)"]

See Also

Bitmap_Alpha Class
ElImage Namespace


RangeOfZeros Method

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..RangeOfZeros Method
Bitmap_Alpha Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap_Alpha.RangeOfZeros(System.UInt32,System.Int32@,System.Int32@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected bool RangeOfZeros(
    uint line,
    out int l,
    out int r
)
Visual Basic
Protected Function RangeOfZeros ( _
    line As UInteger, _
    <OutAttribute> ByRef l As Integer, _
    <OutAttribute> ByRef r As Integer _
) As Boolean
Visual C++
protected:
bool RangeOfZeros(
    unsigned int line,
    [OutAttribute] int% l,
    [OutAttribute] int% r
)

Parameters

line
Type: System..::..UInt32

[Missing <param name="line"/> documentation for "M:ElImage.Bitmap_Alpha.RangeOfZeros(System.UInt32,System.Int32@,System.Int32@)"]

l
Type: System..::..Int32 %

[Missing <param name="l"/> documentation for "M:ElImage.Bitmap_Alpha.RangeOfZeros(System.UInt32,System.Int32@,System.Int32@)"]

r
Type: System..::..Int32 %

[Missing <param name="r"/> documentation for "M:ElImage.Bitmap_Alpha.RangeOfZeros(System.UInt32,System.Int32@,System.Int32@)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap_Alpha.RangeOfZeros(System.UInt32,System.Int32@,System.Int32@)"]

See Also

Bitmap_Alpha Class
ElImage Namespace


Set Method

[image] [image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..Set Method
Bitmap_Alpha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Bitmap) | (Inherited from Bitmap.)
Public method | Set(Bitmap) | (Inherited from Bitmap.)
Public method | Set(Thing2d) | (Inherited from Thing2d.)
Public method | Set(Size2dU, Byte) |

See Also

Bitmap_Alpha Class
Bitmap_Alpha Members
ElImage Namespace


Set Method (, Byte)

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..Set Method (, Byte)
Bitmap_Alpha Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap_Alpha.Set(El.Size2dU,System.Byte)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Set(
    Size2dU pos,
    byte value
)
Visual Basic
Public Sub Set ( _
    pos As Size2dU, _
    value As Byte _
)
Visual C++
public:
void Set(
    Size2dU^ pos,
    unsigned char value
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.Bitmap_Alpha.Set(El.Size2dU,System.Byte)"]

value
Type: System..::..Byte

[Missing <param name="value"/> documentation for "M:ElImage.Bitmap_Alpha.Set(El.Size2dU,System.Byte)"]

See Also

Bitmap_Alpha Class
Set Overload
ElImage Namespace


Shrink Method

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..Shrink Method
Bitmap_Alpha Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Bitmap_Alpha.Shrink"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Shrink()
Visual Basic
Public Function Shrink As Boolean
Visual C++
public:
bool Shrink()

Return Value

[Missing <returns> documentation for "M:ElImage.Bitmap_Alpha.Shrink"]

See Also

Bitmap_Alpha Class
ElImage Namespace


Bitmap_Alpha Properties

[image] [image]

4 of William Foster's Class Libraries
Bitmap_Alpha Properties
Bitmap_Alpha Class See Also Send Feedback

The Bitmap_Alpha type exposes the following members.

Properties

 | Name | Description
Public property | Item |
Public property | size | (Inherited from Thing2d.)

See Also

Bitmap_Alpha Class
ElImage Namespace


Item Property

[image]

4 of William Foster's Class Libraries
Bitmap_Alpha..::..Item Property
Bitmap_Alpha Class See Also Send Feedback

[Missing <summary> documentation for "P:ElImage.Bitmap_Alpha.Item(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte this[
    Size2dU pos
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    pos As Size2dU _
) As Byte
    Get
Visual C++
public:
property unsigned char default[Size2dU^ pos] {
    unsigned char get (Size2dU^ pos);
}

Parameters

pos
Type: Size2dU

See Also

Bitmap_Alpha Class
ElImage Namespace


BitmapPipe Class

[image]

4 of William Foster's Class Libraries
BitmapPipe Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.BitmapPipe"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class BitmapPipe
Visual Basic
Public Class BitmapPipe
Visual C++
public ref class BitmapPipe

Inheritance Hierarchy

System..::..Object
ElImage..::..BitmapPipe

See Also

BitmapPipe Members
ElImage Namespace


BitmapPipe Members

[image] [image]

4 of William Foster's Class Libraries
BitmapPipe Members
BitmapPipe Class Constructors Methods See Also Send Feedback

The BitmapPipe type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapPipe(Bitmap) | Initializes a new instance of the BitmapPipe class
Public method | BitmapPipe(Bitmap, Rect2dU, ColorSpace) | Initializes a new instance of the BitmapPipe class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Iterate()()()() |
Public method | Iterate(PixelBuffer%) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetColorSpace |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BitmapPipe Class
ElImage Namespace


BitmapPipe Constructor

[image] [image]

4 of William Foster's Class Libraries
BitmapPipe Constructor
BitmapPipe Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BitmapPipe(Bitmap) | Initializes a new instance of the BitmapPipe class
Public method | BitmapPipe(Bitmap, Rect2dU, ColorSpace) | Initializes a new instance of the BitmapPipe class

See Also

BitmapPipe Class
BitmapPipe Members
ElImage Namespace


BitmapPipe Constructor (Bitmap)

[image]

4 of William Foster's Class Libraries
BitmapPipe Constructor (Bitmap)
BitmapPipe Class See Also Send Feedback
Initializes a new instance of the BitmapPipe class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public BitmapPipe(
    Bitmap Bmp
)
Visual Basic
Public Sub New ( _
    Bmp As Bitmap _
)
Visual C++
public:
BitmapPipe(
    Bitmap^ Bmp
)

Parameters

Bmp
Type: ElImage..::..Bitmap

[Missing <param name="Bmp"/> documentation for "M:ElImage.BitmapPipe.#ctor(ElImage.Bitmap)"]

See Also

BitmapPipe Class
BitmapPipe Overload
ElImage Namespace


BitmapPipe Constructor (Bitmap, , ColorSpace)

[image]

4 of William Foster's Class Libraries
BitmapPipe Constructor (Bitmap, , ColorSpace)
BitmapPipe Class See Also Send Feedback
Initializes a new instance of the BitmapPipe class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public BitmapPipe(
    Bitmap Bmp,
    Rect2dU Rect,
    ColorSpace cspace
)
Visual Basic
Public Sub New ( _
    Bmp As Bitmap, _
    Rect As Rect2dU, _
    cspace As ColorSpace _
)
Visual C++
public:
BitmapPipe(
    Bitmap^ Bmp,
    Rect2dU^ Rect,
    ColorSpace^ cspace
)

Parameters

Bmp
Type: ElImage..::..Bitmap

[Missing <param name="Bmp"/> documentation for "M:ElImage.BitmapPipe.#ctor(ElImage.Bitmap,El.Rect2dU,ElImage.ColorSpace)"]

Rect
Type: Rect2dU

[Missing <param name="Rect"/> documentation for "M:ElImage.BitmapPipe.#ctor(ElImage.Bitmap,El.Rect2dU,ElImage.ColorSpace)"]

cspace
Type: ElImage..::..ColorSpace

[Missing <param name="cspace"/> documentation for "M:ElImage.BitmapPipe.#ctor(ElImage.Bitmap,El.Rect2dU,ElImage.ColorSpace)"]

See Also

BitmapPipe Class
BitmapPipe Overload
ElImage Namespace


BitmapPipe Methods

[image] [image]

4 of William Foster's Class Libraries
BitmapPipe Methods
BitmapPipe Class See Also Send Feedback

The BitmapPipe type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Iterate()()()() |
Public method | Iterate(PixelBuffer%) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetColorSpace |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BitmapPipe Class
ElImage Namespace


GetSize Method

[image]

4 of William Foster's Class Libraries
BitmapPipe..::..GetSize Method
BitmapPipe Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.BitmapPipe.GetSize"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Size2dU GetSize()
Visual Basic
Public Function GetSize As Size2dU
Visual C++
public:
Size2dU^ GetSize()

Return Value

[Missing <returns> documentation for "M:ElImage.BitmapPipe.GetSize"]

See Also

BitmapPipe Class
ElImage Namespace


Iterate Method

[image] [image]

4 of William Foster's Class Libraries
BitmapPipe..::..Iterate Method
BitmapPipe Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Iterate()()()() |
Public method | Iterate(PixelBuffer%) |

See Also

BitmapPipe Class
BitmapPipe Members
ElImage Namespace


Iterate Method

[image]

4 of William Foster's Class Libraries
BitmapPipe..::..Iterate Method
BitmapPipe Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.BitmapPipe.Iterate"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public PixelBuffer Iterate()
Visual Basic
Public Function Iterate As PixelBuffer
Visual C++
public:
PixelBuffer^ Iterate()

Return Value

[Missing <returns> documentation for "M:ElImage.BitmapPipe.Iterate"]

See Also

BitmapPipe Class
Iterate Overload
ElImage Namespace


Iterate Method (PixelBuffer)

[image]

4 of William Foster's Class Libraries
BitmapPipe..::..Iterate Method (PixelBuffer%)
BitmapPipe Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.BitmapPipe.Iterate(ElImage.PixelBuffer@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Iterate(
    out PixelBuffer pxlbuf
)
Visual Basic
Public Function Iterate ( _
    <OutAttribute> ByRef pxlbuf As PixelBuffer _
) As Boolean
Visual C++
public:
bool Iterate(
    [OutAttribute] PixelBuffer^% pxlbuf
)

Parameters

pxlbuf
Type: ElImage..::..PixelBuffer %

[Missing <param name="pxlbuf"/> documentation for "M:ElImage.BitmapPipe.Iterate(ElImage.PixelBuffer@)"]

Return Value

[Missing <returns> documentation for "M:ElImage.BitmapPipe.Iterate(ElImage.PixelBuffer@)"]

See Also

BitmapPipe Class
Iterate Overload
ElImage Namespace


SetColorSpace Method

[image]

4 of William Foster's Class Libraries
BitmapPipe..::..SetColorSpace Method
BitmapPipe Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.BitmapPipe.SetColorSpace(ElImage.ColorSpace)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetColorSpace(
    ColorSpace cspace
)
Visual Basic
Public Sub SetColorSpace ( _
    cspace As ColorSpace _
)
Visual C++
public:
void SetColorSpace(
    ColorSpace^ cspace
)

Parameters

cspace
Type: ElImage..::..ColorSpace

[Missing <param name="cspace"/> documentation for "M:ElImage.BitmapPipe.SetColorSpace(ElImage.ColorSpace)"]

See Also

BitmapPipe Class
ElImage Namespace


Brightness_Histogram Class

[image]

4 of William Foster's Class Libraries
Brightness_Histogram Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Brightness_Histogram"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Brightness_Histogram : Histogram
Visual Basic
Public Class Brightness_Histogram _
    Inherits Histogram
Visual C++
public ref class Brightness_Histogram : public Histogram

Inheritance Hierarchy

System..::..Object
ElImage..::..Histogram
ElImage..::..Brightness_Histogram

See Also

Brightness_Histogram Members
ElImage Namespace


Brightness_Histogram Members

[image] [image]

4 of William Foster's Class Libraries
Brightness_Histogram Members
Brightness_Histogram Class Constructors Methods Fields See Also Send Feedback

The Brightness_Histogram type exposes the following members.

Constructors

 | Name | Description
Public method | Brightness_Histogram | Initializes a new instance of the Brightness_Histogram class

Methods

 | Name | Description
Public method | Average | Find the midpoint of the curve, or brightness of the average pixel (Inherited from Histogram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run_Histogram | (Overrides Histogram..::..Run_Histogram(Rect2dU).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ZeroMap | (Inherited from Histogram.)

Fields

 | Name | Description
Protected field | m_b_beenRun | (Inherited from Histogram.)
Protected field | m_Bmp | (Inherited from Histogram.)
Public field | m_full_rect | (Inherited from Histogram.)
Public field | m_Map | (Inherited from Histogram.)

See Also

Brightness_Histogram Class
ElImage Namespace


Brightness_Histogram Constructor

[image]

4 of William Foster's Class Libraries
Brightness_Histogram Constructor
Brightness_Histogram Class See Also Send Feedback
Initializes a new instance of the Brightness_Histogram class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Brightness_Histogram(
    Bitmap Bmp
)
Visual Basic
Public Sub New ( _
    Bmp As Bitmap _
)
Visual C++
public:
Brightness_Histogram(
    Bitmap^ Bmp
)

Parameters

Bmp
Type: ElImage..::..Bitmap

[Missing <param name="Bmp"/> documentation for "M:ElImage.Brightness_Histogram.#ctor(ElImage.Bitmap)"]

See Also

Brightness_Histogram Class
ElImage Namespace


Brightness_Histogram Fields

[image] [image]

4 of William Foster's Class Libraries
Brightness_Histogram Fields
Brightness_Histogram Class See Also Send Feedback

The Brightness_Histogram type exposes the following members.

Fields

 | Name | Description
Protected field | m_b_beenRun | (Inherited from Histogram.)
Protected field | m_Bmp | (Inherited from Histogram.)
Public field | m_full_rect | (Inherited from Histogram.)
Public field | m_Map | (Inherited from Histogram.)

See Also

Brightness_Histogram Class
ElImage Namespace


Brightness_Histogram Methods

[image] [image]

4 of William Foster's Class Libraries
Brightness_Histogram Methods
Brightness_Histogram Class See Also Send Feedback

The Brightness_Histogram type exposes the following members.

Methods

 | Name | Description
Public method | Average | Find the midpoint of the curve, or brightness of the average pixel (Inherited from Histogram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run_Histogram | (Overrides Histogram..::..Run_Histogram(Rect2dU).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ZeroMap | (Inherited from Histogram.)

See Also

Brightness_Histogram Class
ElImage Namespace


Run_Histogram Method

[image]

4 of William Foster's Class Libraries
Brightness_Histogram..::..Run_Histogram Method
Brightness_Histogram Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Brightness_Histogram.Run_Histogram(El.Rect2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override void Run_Histogram(
    Rect2dU rect
)
Visual Basic
Public Overrides Sub Run_Histogram ( _
    rect As Rect2dU _
)
Visual C++
public:
virtual void Run_Histogram(
    Rect2dU^ rect
) override

Parameters

rect
Type: Rect2dU

[Missing <param name="rect"/> documentation for "M:ElImage.Brightness_Histogram.Run_Histogram(El.Rect2dU)"]

See Also

Brightness_Histogram Class
ElImage Namespace


CLabRgb Class

[image]

4 of William Foster's Class Libraries
CLabRgb Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.CLabRgb"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class CLabRgb
Visual Basic
Public Class CLabRgb
Visual C++
public ref class CLabRgb

Inheritance Hierarchy

System..::..Object
ElImage..::..CLabRgb

See Also

CLabRgb Members
ElImage Namespace


CLabRgb Members

[image] [image]

4 of William Foster's Class Libraries
CLabRgb Members
CLabRgb Class Constructors Methods See Also Send Feedback

The CLabRgb type exposes the following members.

Constructors

 | Name | Description
Public method | CLabRgb | Initializes a new instance of the CLabRgb class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LabToRgb |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RgbToLab |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CLabRgb Class
ElImage Namespace


CLabRgb Constructor

[image]

4 of William Foster's Class Libraries
CLabRgb Constructor
CLabRgb Class See Also Send Feedback
Initializes a new instance of the CLabRgb class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public CLabRgb()
Visual Basic
Public Sub New
Visual C++
public:
CLabRgb()

See Also

CLabRgb Class
ElImage Namespace


CLabRgb Methods

[image] [image]

4 of William Foster's Class Libraries
CLabRgb Methods
CLabRgb Class See Also Send Feedback

The CLabRgb type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LabToRgb |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RgbToLab |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CLabRgb Class
ElImage Namespace


LabToRgb Method

[image]

4 of William Foster's Class Libraries
CLabRgb..::..LabToRgb Method
CLabRgb Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.CLabRgb.LabToRgb(ElImage.ColorVector3,ElImage.ColorVector3@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void LabToRgb(
    ColorVector3 Lab,
    out ColorVector3 Rgb_Result
)
Visual Basic
Public Sub LabToRgb ( _
    Lab As ColorVector3, _
    <OutAttribute> ByRef Rgb_Result As ColorVector3 _
)
Visual C++
public:
void LabToRgb(
    ColorVector3^ Lab,
    [OutAttribute] ColorVector3^% Rgb_Result
)

Parameters

Lab
Type: ElImage..::..ColorVector3

[Missing <param name="Lab"/> documentation for "M:ElImage.CLabRgb.LabToRgb(ElImage.ColorVector3,ElImage.ColorVector3@)"]

Rgb_Result
Type: ElImage..::..ColorVector3 %

[Missing <param name="Rgb_Result"/> documentation for "M:ElImage.CLabRgb.LabToRgb(ElImage.ColorVector3,ElImage.ColorVector3@)"]

See Also

CLabRgb Class
ElImage Namespace


RgbToLab Method

[image]

4 of William Foster's Class Libraries
CLabRgb..::..RgbToLab Method
CLabRgb Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.CLabRgb.RgbToLab(ElImage.ColorVector3,ElImage.ColorVector3@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void RgbToLab(
    ColorVector3 Rgb,
    out ColorVector3 Lab_result
)
Visual Basic
Public Sub RgbToLab ( _
    Rgb As ColorVector3, _
    <OutAttribute> ByRef Lab_result As ColorVector3 _
)
Visual C++
public:
void RgbToLab(
    ColorVector3^ Rgb,
    [OutAttribute] ColorVector3^% Lab_result
)

Parameters

Rgb
Type: ElImage..::..ColorVector3

[Missing <param name="Rgb"/> documentation for "M:ElImage.CLabRgb.RgbToLab(ElImage.ColorVector3,ElImage.ColorVector3@)"]

Lab_result
Type: ElImage..::..ColorVector3 %

[Missing <param name="Lab_result"/> documentation for "M:ElImage.CLabRgb.RgbToLab(ElImage.ColorVector3,ElImage.ColorVector3@)"]

See Also

CLabRgb Class
ElImage Namespace


Color Class

[image]

4 of William Foster's Class Libraries
Color Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Color"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Color
Visual Basic
Public Class Color
Visual C++
public ref class Color

Inheritance Hierarchy

System..::..Object
ElImage..::..Color

See Also

Color Members
ElImage Namespace


Color Members

[image] [image]

4 of William Foster's Class Libraries
Color Members
Color Class Constructors Methods Operators Fields See Also Send Feedback

The Color type exposes the following members.

Constructors

 | Name | Description
Public method | Color()()()() | Initializes a new instance of the Color class
Public method | Color(El_Color) | Initializes a new instance of the Color class

Methods

 | Name | Description
Public method | AdjustBrightness(Int32) | Adjust the brightness of a color
Public method | AdjustBrightness(Single) |
Public method | AdjustLog |
Public method | Closeness |
Public method | CopyRGB |
Public method | CopyRGBA |
 | DELTA |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAs12BitRGB |
Public method | GetAs16BitRGB |
Public method | GetAs24BitRGB |
Public method | GetBrightness |
Public method | GetGrey |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LABtoRGB |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RGBtoHSL |
Public method | RGBtoLAB |
Public method | Set |
Public method | Set16bitRGB |
Public method | SetGrey |
Public method | SetHSL |
Public method | SetLAB()()()() |
Public method | SetLAB(Double, Double, Double) |
Public method | SetRGB()()()() |
Public method | SetRGB(UInt32, UInt32, UInt32) |
Public method | SetRGBA(UInt32) |
Public method | SetRGBA(UInt32, UInt32, UInt32, UInt32) |
Public method | SplitHSL |
Public method | SplitLAB |
Public method | SplitRGB |
Public method | SplitRGBA |
Public method | TakeDelta |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality |
ImplicitWideningImplicitImplicitImplicit(Color to Color) |
Inequality |

Fields

 | Name | Description
Public field | m_RGBA |

See Also

Color Class
ElImage Namespace


Color Constructor

[image] [image]

4 of William Foster's Class Libraries
Color Constructor
Color Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Color()()()() | Initializes a new instance of the Color class
Public method | Color(El_Color) | Initializes a new instance of the Color class

See Also

Color Class
Color Members
ElImage Namespace


Color Constructor

[image]

4 of William Foster's Class Libraries
Color Constructor
Color Class See Also Send Feedback
Initializes a new instance of the Color class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Color()
Visual Basic
Public Sub New
Visual C++
public:
Color()

See Also

Color Class
Color Overload
ElImage Namespace


Color Constructor (El_Color)

[image]

4 of William Foster's Class Libraries
Color Constructor (El_Color)
Color Class See Also Send Feedback
Initializes a new instance of the Color class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Color(
    El_Color eCol
)
Visual Basic
Public Sub New ( _
    eCol As El_Color _
)
Visual C++
public:
Color(
    El_Color eCol
)

Parameters

eCol
Type: ElImage..::..El_Color

[Missing <param name="eCol"/> documentation for "M:ElImage.Color.#ctor(ElImage.El_Color)"]

See Also

Color Class
Color Overload
ElImage Namespace


Color Fields

[image] [image]

4 of William Foster's Class Libraries
Color Fields
Color Class See Also Send Feedback

The Color type exposes the following members.

Fields

 | Name | Description
Public field | m_RGBA |

See Also

Color Class
ElImage Namespace


m_RGBA Field

[image]

4 of William Foster's Class Libraries
Color..::..m_RGBA Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Color.m_RGBA"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public PixelData m_RGBA
Visual Basic
Public m_RGBA As PixelData
Visual C++
public:
PixelData m_RGBA

See Also

Color Class
ElImage Namespace


Color Methods

[image] [image]

4 of William Foster's Class Libraries
Color Methods
Color Class See Also Send Feedback

The Color type exposes the following members.

Methods

 | Name | Description
Public method | AdjustBrightness(Int32) | Adjust the brightness of a color
Public method | AdjustBrightness(Single) |
Public method | AdjustLog |
Public method | Closeness |
Public method | CopyRGB |
Public method | CopyRGBA |
 | DELTA |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAs12BitRGB |
Public method | GetAs16BitRGB |
Public method | GetAs24BitRGB |
Public method | GetBrightness |
Public method | GetGrey |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LABtoRGB |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RGBtoHSL |
Public method | RGBtoLAB |
Public method | Set |
Public method | Set16bitRGB |
Public method | SetGrey |
Public method | SetHSL |
Public method | SetLAB()()()() |
Public method | SetLAB(Double, Double, Double) |
Public method | SetRGB()()()() |
Public method | SetRGB(UInt32, UInt32, UInt32) |
Public method | SetRGBA(UInt32) |
Public method | SetRGBA(UInt32, UInt32, UInt32, UInt32) |
Public method | SplitHSL |
Public method | SplitLAB |
Public method | SplitRGB |
Public method | SplitRGBA |
Public method | TakeDelta |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Color Class
ElImage Namespace


AdjustBrightness Method

[image] [image]

4 of William Foster's Class Libraries
Color..::..AdjustBrightness Method
Color Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AdjustBrightness(Int32) | Adjust the brightness of a color
Public method | AdjustBrightness(Single) |

See Also

Color Class
Color Members
ElImage Namespace


AdjustBrightness Method (Int32)

[image]

4 of William Foster's Class Libraries
Color..::..AdjustBrightness Method (Int32)
Color Class See Also Send Feedback
Adjust the brightness of a color

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void AdjustBrightness(
    int adjust
)
Visual Basic
Public Sub AdjustBrightness ( _
    adjust As Integer _
)
Visual C++
public:
void AdjustBrightness(
    int adjust
)

Parameters

adjust
Type: System..::..Int32

[Missing <param name="adjust"/> documentation for "M:ElImage.Color.AdjustBrightness(System.Int32)"]

See Also

Color Class
AdjustBrightness Overload
ElImage Namespace


AdjustBrightness Method (Single)

[image]

4 of William Foster's Class Libraries
Color..::..AdjustBrightness Method (Single)
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.AdjustBrightness(System.Single)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void AdjustBrightness(
    float adj
)
Visual Basic
Public Sub AdjustBrightness ( _
    adj As Single _
)
Visual C++
public:
void AdjustBrightness(
    float adj
)

Parameters

adj
Type: System..::..Single

[Missing <param name="adj"/> documentation for "M:ElImage.Color.AdjustBrightness(System.Single)"]

See Also

Color Class
AdjustBrightness Overload
ElImage Namespace


AdjustLog Method

[image]

4 of William Foster's Class Libraries
Color..::..AdjustLog Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.AdjustLog"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void AdjustLog()
Visual Basic
Public Sub AdjustLog
Visual C++
public:
void AdjustLog()

See Also

Color Class
ElImage Namespace


Closeness Method

[image]

4 of William Foster's Class Libraries
Color..::..Closeness Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.Closeness(ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint Closeness(
    Color c
)
Visual Basic
Public Function Closeness ( _
    c As Color _
) As UInteger
Visual C++
public:
unsigned int Closeness(
    Color^ c
)

Parameters

c
Type: ElImage..::..Color

[Missing <param name="c"/> documentation for "M:ElImage.Color.Closeness(ElImage.Color)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Color.Closeness(ElImage.Color)"]

See Also

Color Class
ElImage Namespace


CopyRGB Method

[image]

4 of William Foster's Class Libraries
Color..::..CopyRGB Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.CopyRGB(System.Byte[])"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void CopyRGB(
    byte[] srcptr
)
Visual Basic
Public Sub CopyRGB ( _
    srcptr As Byte() _
)
Visual C++
public:
void CopyRGB(
    array<unsigned char>^ srcptr
)

Parameters

srcptr
Type: array< System..::..Byte >[]()[][]

[Missing <param name="srcptr"/> documentation for "M:ElImage.Color.CopyRGB(System.Byte[])"]

See Also

Color Class
ElImage Namespace


CopyRGBA Method

[image]

4 of William Foster's Class Libraries
Color..::..CopyRGBA Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.CopyRGBA(System.Byte[])"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void CopyRGBA(
    byte[] srcptr
)
Visual Basic
Public Sub CopyRGBA ( _
    srcptr As Byte() _
)
Visual C++
public:
void CopyRGBA(
    array<unsigned char>^ srcptr
)

Parameters

srcptr
Type: array< System..::..Byte >[]()[][]

[Missing <param name="srcptr"/> documentation for "M:ElImage.Color.CopyRGBA(System.Byte[])"]

See Also

Color Class
ElImage Namespace


DELTA Method

[image]

4 of William Foster's Class Libraries
Color..::..DELTA Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.DELTA(System.Byte,System.Byte)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static uint DELTA(
    byte a,
    byte b
)
Visual Basic
Public Shared Function DELTA ( _
    a As Byte, _
    b As Byte _
) As UInteger
Visual C++
public:
static unsigned int DELTA(
    unsigned char a,
    unsigned char b
)

Parameters

a
Type: System..::..Byte

[Missing <param name="a"/> documentation for "M:ElImage.Color.DELTA(System.Byte,System.Byte)"]

b
Type: System..::..Byte

[Missing <param name="b"/> documentation for "M:ElImage.Color.DELTA(System.Byte,System.Byte)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Color.DELTA(System.Byte,System.Byte)"]

See Also

Color Class
ElImage Namespace


GetAs12BitRGB Method

[image]

4 of William Foster's Class Libraries
Color..::..GetAs12BitRGB Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.GetAs12BitRGB"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public int GetAs12BitRGB()
Visual Basic
Public Function GetAs12BitRGB As Integer
Visual C++
public:
int GetAs12BitRGB()

Return Value

[Missing <returns> documentation for "M:ElImage.Color.GetAs12BitRGB"]

See Also

Color Class
ElImage Namespace


GetAs16BitRGB Method

[image]

4 of William Foster's Class Libraries
Color..::..GetAs16BitRGB Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.GetAs16BitRGB"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ushort GetAs16BitRGB()
Visual Basic
Public Function GetAs16BitRGB As UShort
Visual C++
public:
unsigned short GetAs16BitRGB()

Return Value

[Missing <returns> documentation for "M:ElImage.Color.GetAs16BitRGB"]

See Also

Color Class
ElImage Namespace


GetAs24BitRGB Method

[image]

4 of William Foster's Class Libraries
Color..::..GetAs24BitRGB Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.GetAs24BitRGB"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint GetAs24BitRGB()
Visual Basic
Public Function GetAs24BitRGB As UInteger
Visual C++
public:
unsigned int GetAs24BitRGB()

Return Value

[Missing <returns> documentation for "M:ElImage.Color.GetAs24BitRGB"]

See Also

Color Class
ElImage Namespace


GetBrightness Method

[image]

4 of William Foster's Class Libraries
Color..::..GetBrightness Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.GetBrightness"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte GetBrightness()
Visual Basic
Public Function GetBrightness As Byte
Visual C++
public:
unsigned char GetBrightness()

Return Value

[Missing <returns> documentation for "M:ElImage.Color.GetBrightness"]

See Also

Color Class
ElImage Namespace


GetGrey Method

[image]

4 of William Foster's Class Libraries
Color..::..GetGrey Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.GetGrey"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte GetGrey()
Visual Basic
Public Function GetGrey As Byte
Visual C++
public:
unsigned char GetGrey()

Return Value

[Missing <returns> documentation for "M:ElImage.Color.GetGrey"]

See Also

Color Class
ElImage Namespace


LABtoRGB Method

[image]

4 of William Foster's Class Libraries
Color..::..LABtoRGB Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.LABtoRGB(ElImage.ColorVector3,System.Byte@,System.Byte@,System.Byte@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void LABtoRGB(
    ColorVector3 lab,
    out byte r,
    out byte g,
    out byte b
)
Visual Basic
Public Sub LABtoRGB ( _
    lab As ColorVector3, _
    <OutAttribute> ByRef r As Byte, _
    <OutAttribute> ByRef g As Byte, _
    <OutAttribute> ByRef b As Byte _
)
Visual C++
public:
void LABtoRGB(
    ColorVector3^ lab,
    [OutAttribute] unsigned char% r,
    [OutAttribute] unsigned char% g,
    [OutAttribute] unsigned char% b
)

Parameters

lab
Type: ElImage..::..ColorVector3

[Missing <param name="lab"/> documentation for "M:ElImage.Color.LABtoRGB(ElImage.ColorVector3,System.Byte@,System.Byte@,System.Byte@)"]

r
Type: System..::..Byte %

[Missing <param name="r"/> documentation for "M:ElImage.Color.LABtoRGB(ElImage.ColorVector3,System.Byte@,System.Byte@,System.Byte@)"]

g
Type: System..::..Byte %

[Missing <param name="g"/> documentation for "M:ElImage.Color.LABtoRGB(ElImage.ColorVector3,System.Byte@,System.Byte@,System.Byte@)"]

b
Type: System..::..Byte %

[Missing <param name="b"/> documentation for "M:ElImage.Color.LABtoRGB(ElImage.ColorVector3,System.Byte@,System.Byte@,System.Byte@)"]

See Also

Color Class
ElImage Namespace


RGBtoHSL Method

[image]

4 of William Foster's Class Libraries
Color..::..RGBtoHSL Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.RGBtoHSL(System.Byte,System.Byte,System.Byte,System.UInt32@,System.UInt32@,System.UInt32@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void RGBtoHSL(
    byte bR,
    byte bG,
    byte bB,
    out uint H,
    out uint S,
    out uint L
)
Visual Basic
Public Sub RGBtoHSL ( _
    bR As Byte, _
    bG As Byte, _
    bB As Byte, _
    <OutAttribute> ByRef H As UInteger, _
    <OutAttribute> ByRef S As UInteger, _
    <OutAttribute> ByRef L As UInteger _
)
Visual C++
public:
void RGBtoHSL(
    unsigned char bR,
    unsigned char bG,
    unsigned char bB,
    [OutAttribute] unsigned int% H,
    [OutAttribute] unsigned int% S,
    [OutAttribute] unsigned int% L
)

Parameters

bR
Type: System..::..Byte

[Missing <param name="bR"/> documentation for "M:ElImage.Color.RGBtoHSL(System.Byte,System.Byte,System.Byte,System.UInt32@,System.UInt32@,System.UInt32@)"]

bG
Type: System..::..Byte

[Missing <param name="bG"/> documentation for "M:ElImage.Color.RGBtoHSL(System.Byte,System.Byte,System.Byte,System.UInt32@,System.UInt32@,System.UInt32@)"]

bB
Type: System..::..Byte

[Missing <param name="bB"/> documentation for "M:ElImage.Color.RGBtoHSL(System.Byte,System.Byte,System.Byte,System.UInt32@,System.UInt32@,System.UInt32@)"]

H
Type: System..::..UInt32 %

[Missing <param name="H"/> documentation for "M:ElImage.Color.RGBtoHSL(System.Byte,System.Byte,System.Byte,System.UInt32@,System.UInt32@,System.UInt32@)"]

S
Type: System..::..UInt32 %

[Missing <param name="S"/> documentation for "M:ElImage.Color.RGBtoHSL(System.Byte,System.Byte,System.Byte,System.UInt32@,System.UInt32@,System.UInt32@)"]

L
Type: System..::..UInt32 %

[Missing <param name="L"/> documentation for "M:ElImage.Color.RGBtoHSL(System.Byte,System.Byte,System.Byte,System.UInt32@,System.UInt32@,System.UInt32@)"]

See Also

Color Class
ElImage Namespace


RGBtoLAB Method

[image]

4 of William Foster's Class Libraries
Color..::..RGBtoLAB Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.RGBtoLAB(System.Byte,System.Byte,System.Byte,ElImage.ColorVector3@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void RGBtoLAB(
    byte r,
    byte g,
    byte b,
    out ColorVector3 lab
)
Visual Basic
Public Sub RGBtoLAB ( _
    r As Byte, _
    g As Byte, _
    b As Byte, _
    <OutAttribute> ByRef lab As ColorVector3 _
)
Visual C++
public:
void RGBtoLAB(
    unsigned char r,
    unsigned char g,
    unsigned char b,
    [OutAttribute] ColorVector3^% lab
)

Parameters

r
Type: System..::..Byte

[Missing <param name="r"/> documentation for "M:ElImage.Color.RGBtoLAB(System.Byte,System.Byte,System.Byte,ElImage.ColorVector3@)"]

g
Type: System..::..Byte

[Missing <param name="g"/> documentation for "M:ElImage.Color.RGBtoLAB(System.Byte,System.Byte,System.Byte,ElImage.ColorVector3@)"]

b
Type: System..::..Byte

[Missing <param name="b"/> documentation for "M:ElImage.Color.RGBtoLAB(System.Byte,System.Byte,System.Byte,ElImage.ColorVector3@)"]

lab
Type: ElImage..::..ColorVector3 %

[Missing <param name="lab"/> documentation for "M:ElImage.Color.RGBtoLAB(System.Byte,System.Byte,System.Byte,ElImage.ColorVector3@)"]

See Also

Color Class
ElImage Namespace


Set Method

[image]

4 of William Foster's Class Libraries
Color..::..Set Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.Set(ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Set(
    Color c
)
Visual Basic
Public Sub Set ( _
    c As Color _
)
Visual C++
public:
void Set(
    Color^ c
)

Parameters

c
Type: ElImage..::..Color

[Missing <param name="c"/> documentation for "M:ElImage.Color.Set(ElImage.Color)"]

See Also

Color Class
ElImage Namespace


Set16bitRGB Method

[image]

4 of William Foster's Class Libraries
Color..::..Set16bitRGB Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.Set16bitRGB(System.UInt16)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Set16bitRGB(
    ushort us
)
Visual Basic
Public Sub Set16bitRGB ( _
    us As UShort _
)
Visual C++
public:
void Set16bitRGB(
    unsigned short us
)

Parameters

us
Type: System..::..UInt16

[Missing <param name="us"/> documentation for "M:ElImage.Color.Set16bitRGB(System.UInt16)"]

See Also

Color Class
ElImage Namespace


SetGrey Method

[image]

4 of William Foster's Class Libraries
Color..::..SetGrey Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.SetGrey(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetGrey(
    uint g
)
Visual Basic
Public Sub SetGrey ( _
    g As UInteger _
)
Visual C++
public:
void SetGrey(
    unsigned int g
)

Parameters

g
Type: System..::..UInt32

[Missing <param name="g"/> documentation for "M:ElImage.Color.SetGrey(System.UInt32)"]

See Also

Color Class
ElImage Namespace


SetHSL Method

[image]

4 of William Foster's Class Libraries
Color..::..SetHSL Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.SetHSL(System.UInt32,System.UInt32,System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetHSL(
    uint Hue,
    uint Saturation,
    uint Lightness
)
Visual Basic
Public Sub SetHSL ( _
    Hue As UInteger, _
    Saturation As UInteger, _
    Lightness As UInteger _
)
Visual C++
public:
void SetHSL(
    unsigned int Hue,
    unsigned int Saturation,
    unsigned int Lightness
)

Parameters

Hue
Type: System..::..UInt32

[Missing <param name="Hue"/> documentation for "M:ElImage.Color.SetHSL(System.UInt32,System.UInt32,System.UInt32)"]

Saturation
Type: System..::..UInt32

[Missing <param name="Saturation"/> documentation for "M:ElImage.Color.SetHSL(System.UInt32,System.UInt32,System.UInt32)"]

Lightness
Type: System..::..UInt32

[Missing <param name="Lightness"/> documentation for "M:ElImage.Color.SetHSL(System.UInt32,System.UInt32,System.UInt32)"]

See Also

Color Class
ElImage Namespace


SetLAB Method

[image] [image]

4 of William Foster's Class Libraries
Color..::..SetLAB Method
Color Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetLAB()()()() |
Public method | SetLAB(Double, Double, Double) |

See Also

Color Class
Color Members
ElImage Namespace


SetLAB Method

[image]

4 of William Foster's Class Libraries
Color..::..SetLAB Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.SetLAB"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool SetLAB()
Visual Basic
Public Function SetLAB As Boolean
Visual C++
public:
bool SetLAB()

Return Value

[Missing <returns> documentation for "M:ElImage.Color.SetLAB"]

See Also

Color Class
SetLAB Overload
ElImage Namespace


SetLAB Method (Double, Double, Double)

[image]

4 of William Foster's Class Libraries
Color..::..SetLAB Method (Double, Double, Double)
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.SetLAB(System.Double,System.Double,System.Double)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetLAB(
    double L,
    double A,
    double B
)
Visual Basic
Public Sub SetLAB ( _
    L As Double, _
    A As Double, _
    B As Double _
)
Visual C++
public:
void SetLAB(
    double L,
    double A,
    double B
)

Parameters

L
Type: System..::..Double

[Missing <param name="L"/> documentation for "M:ElImage.Color.SetLAB(System.Double,System.Double,System.Double)"]

A
Type: System..::..Double

[Missing <param name="A"/> documentation for "M:ElImage.Color.SetLAB(System.Double,System.Double,System.Double)"]

B
Type: System..::..Double

[Missing <param name="B"/> documentation for "M:ElImage.Color.SetLAB(System.Double,System.Double,System.Double)"]

See Also

Color Class
SetLAB Overload
ElImage Namespace


SetRGB Method

[image] [image]

4 of William Foster's Class Libraries
Color..::..SetRGB Method
Color Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetRGB()()()() |
Public method | SetRGB(UInt32, UInt32, UInt32) |

See Also

Color Class
Color Members
ElImage Namespace


SetRGB Method

[image]

4 of William Foster's Class Libraries
Color..::..SetRGB Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.SetRGB"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool SetRGB()
Visual Basic
Public Function SetRGB As Boolean
Visual C++
public:
bool SetRGB()

Return Value

[Missing <returns> documentation for "M:ElImage.Color.SetRGB"]

See Also

Color Class
SetRGB Overload
ElImage Namespace


SetRGB Method (UInt32, UInt32, UInt32)

[image]

4 of William Foster's Class Libraries
Color..::..SetRGB Method (UInt32, UInt32, UInt32)
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.SetRGB(System.UInt32,System.UInt32,System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetRGB(
    uint r,
    uint g,
    uint b
)
Visual Basic
Public Sub SetRGB ( _
    r As UInteger, _
    g As UInteger, _
    b As UInteger _
)
Visual C++
public:
void SetRGB(
    unsigned int r,
    unsigned int g,
    unsigned int b
)

Parameters

r
Type: System..::..UInt32

[Missing <param name="r"/> documentation for "M:ElImage.Color.SetRGB(System.UInt32,System.UInt32,System.UInt32)"]

g
Type: System..::..UInt32

[Missing <param name="g"/> documentation for "M:ElImage.Color.SetRGB(System.UInt32,System.UInt32,System.UInt32)"]

b
Type: System..::..UInt32

[Missing <param name="b"/> documentation for "M:ElImage.Color.SetRGB(System.UInt32,System.UInt32,System.UInt32)"]

See Also

Color Class
SetRGB Overload
ElImage Namespace


SetRGBA Method

[image] [image]

4 of William Foster's Class Libraries
Color..::..SetRGBA Method
Color Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetRGBA(UInt32) |
Public method | SetRGBA(UInt32, UInt32, UInt32, UInt32) |

See Also

Color Class
Color Members
ElImage Namespace


SetRGBA Method (UInt32)

[image]

4 of William Foster's Class Libraries
Color..::..SetRGBA Method (UInt32)
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.SetRGBA(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetRGBA(
    uint rgba
)
Visual Basic
Public Sub SetRGBA ( _
    rgba As UInteger _
)
Visual C++
public:
void SetRGBA(
    unsigned int rgba
)

Parameters

rgba
Type: System..::..UInt32

[Missing <param name="rgba"/> documentation for "M:ElImage.Color.SetRGBA(System.UInt32)"]

See Also

Color Class
SetRGBA Overload
ElImage Namespace


SetRGBA Method (UInt32, UInt32, UInt32, UInt32)

[image]

4 of William Foster's Class Libraries
Color..::..SetRGBA Method (UInt32, UInt32, UInt32, UInt32)
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.SetRGBA(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetRGBA(
    uint r,
    uint g,
    uint b,
    uint a
)
Visual Basic
Public Sub SetRGBA ( _
    r As UInteger, _
    g As UInteger, _
    b As UInteger, _
    a As UInteger _
)
Visual C++
public:
void SetRGBA(
    unsigned int r,
    unsigned int g,
    unsigned int b,
    unsigned int a
)

Parameters

r
Type: System..::..UInt32

[Missing <param name="r"/> documentation for "M:ElImage.Color.SetRGBA(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

g
Type: System..::..UInt32

[Missing <param name="g"/> documentation for "M:ElImage.Color.SetRGBA(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

b
Type: System..::..UInt32

[Missing <param name="b"/> documentation for "M:ElImage.Color.SetRGBA(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

a
Type: System..::..UInt32

[Missing <param name="a"/> documentation for "M:ElImage.Color.SetRGBA(System.UInt32,System.UInt32,System.UInt32,System.UInt32)"]

See Also

Color Class
SetRGBA Overload
ElImage Namespace


SplitHSL Method

[image]

4 of William Foster's Class Libraries
Color..::..SplitHSL Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.SplitHSL(System.UInt32@,System.UInt32@,System.UInt32@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SplitHSL(
    out uint H,
    out uint S,
    out uint L
)
Visual Basic
Public Sub SplitHSL ( _
    <OutAttribute> ByRef H As UInteger, _
    <OutAttribute> ByRef S As UInteger, _
    <OutAttribute> ByRef L As UInteger _
)
Visual C++
public:
void SplitHSL(
    [OutAttribute] unsigned int% H,
    [OutAttribute] unsigned int% S,
    [OutAttribute] unsigned int% L
)

Parameters

H
Type: System..::..UInt32 %

[Missing <param name="H"/> documentation for "M:ElImage.Color.SplitHSL(System.UInt32@,System.UInt32@,System.UInt32@)"]

S
Type: System..::..UInt32 %

[Missing <param name="S"/> documentation for "M:ElImage.Color.SplitHSL(System.UInt32@,System.UInt32@,System.UInt32@)"]

L
Type: System..::..UInt32 %

[Missing <param name="L"/> documentation for "M:ElImage.Color.SplitHSL(System.UInt32@,System.UInt32@,System.UInt32@)"]

See Also

Color Class
ElImage Namespace


SplitLAB Method

[image]

4 of William Foster's Class Libraries
Color..::..SplitLAB Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.SplitLAB(System.Double@,System.Double@,System.Double@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SplitLAB(
    out double L,
    out double A,
    out double B
)
Visual Basic
Public Sub SplitLAB ( _
    <OutAttribute> ByRef L As Double, _
    <OutAttribute> ByRef A As Double, _
    <OutAttribute> ByRef B As Double _
)
Visual C++
public:
void SplitLAB(
    [OutAttribute] double% L,
    [OutAttribute] double% A,
    [OutAttribute] double% B
)

Parameters

L
Type: System..::..Double %

[Missing <param name="L"/> documentation for "M:ElImage.Color.SplitLAB(System.Double@,System.Double@,System.Double@)"]

A
Type: System..::..Double %

[Missing <param name="A"/> documentation for "M:ElImage.Color.SplitLAB(System.Double@,System.Double@,System.Double@)"]

B
Type: System..::..Double %

[Missing <param name="B"/> documentation for "M:ElImage.Color.SplitLAB(System.Double@,System.Double@,System.Double@)"]

See Also

Color Class
ElImage Namespace


SplitRGB Method

[image]

4 of William Foster's Class Libraries
Color..::..SplitRGB Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.SplitRGB(System.UInt32@,System.UInt32@,System.UInt32@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SplitRGB(
    out uint r,
    out uint g,
    out uint b
)
Visual Basic
Public Sub SplitRGB ( _
    <OutAttribute> ByRef r As UInteger, _
    <OutAttribute> ByRef g As UInteger, _
    <OutAttribute> ByRef b As UInteger _
)
Visual C++
public:
void SplitRGB(
    [OutAttribute] unsigned int% r,
    [OutAttribute] unsigned int% g,
    [OutAttribute] unsigned int% b
)

Parameters

r
Type: System..::..UInt32 %

[Missing <param name="r"/> documentation for "M:ElImage.Color.SplitRGB(System.UInt32@,System.UInt32@,System.UInt32@)"]

g
Type: System..::..UInt32 %

[Missing <param name="g"/> documentation for "M:ElImage.Color.SplitRGB(System.UInt32@,System.UInt32@,System.UInt32@)"]

b
Type: System..::..UInt32 %

[Missing <param name="b"/> documentation for "M:ElImage.Color.SplitRGB(System.UInt32@,System.UInt32@,System.UInt32@)"]

See Also

Color Class
ElImage Namespace


SplitRGBA Method

[image]

4 of William Foster's Class Libraries
Color..::..SplitRGBA Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.SplitRGBA(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SplitRGBA(
    out uint r,
    out uint g,
    out uint b,
    out uint a
)
Visual Basic
Public Sub SplitRGBA ( _
    <OutAttribute> ByRef r As UInteger, _
    <OutAttribute> ByRef g As UInteger, _
    <OutAttribute> ByRef b As UInteger, _
    <OutAttribute> ByRef a As UInteger _
)
Visual C++
public:
void SplitRGBA(
    [OutAttribute] unsigned int% r,
    [OutAttribute] unsigned int% g,
    [OutAttribute] unsigned int% b,
    [OutAttribute] unsigned int% a
)

Parameters

r
Type: System..::..UInt32 %

[Missing <param name="r"/> documentation for "M:ElImage.Color.SplitRGBA(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

g
Type: System..::..UInt32 %

[Missing <param name="g"/> documentation for "M:ElImage.Color.SplitRGBA(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

b
Type: System..::..UInt32 %

[Missing <param name="b"/> documentation for "M:ElImage.Color.SplitRGBA(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

a
Type: System..::..UInt32 %

[Missing <param name="a"/> documentation for "M:ElImage.Color.SplitRGBA(System.UInt32@,System.UInt32@,System.UInt32@,System.UInt32@)"]

See Also

Color Class
ElImage Namespace


TakeDelta Method

[image]

4 of William Foster's Class Libraries
Color..::..TakeDelta Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.TakeDelta(ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void TakeDelta(
    Color c
)
Visual Basic
Public Sub TakeDelta ( _
    c As Color _
)
Visual C++
public:
void TakeDelta(
    Color^ c
)

Parameters

c
Type: ElImage..::..Color

[Missing <param name="c"/> documentation for "M:ElImage.Color.TakeDelta(ElImage.Color)"]

See Also

Color Class
ElImage Namespace


Color Operators and Type Conversions

[image] [image]

4 of William Foster's Class Libraries
Color Operators and Type Conversions
Color Class See Also Send Feedback

The Color type exposes the following members.

Operators

Name | Description
Equality |
ImplicitWideningImplicitImplicitImplicit(Color to Color) |
Inequality |

See Also

Color Class
ElImage Namespace


Equality Operator

[image]

4 of William Foster's Class Libraries
Color..::..Equality Operator
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.op_Equality(ElImage.Color,ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static bool operator ==(
    Color c1,
    Color c2
)
Visual Basic
Public Shared Operator = ( _
    c1 As Color, _
    c2 As Color _
) As Boolean
Visual C++
public:
static bool operator ==(
    Color^ c1,
    Color^ c2
)

Parameters

c1
Type: ElImage..::..Color

[Missing <param name="c1"/> documentation for "M:ElImage.Color.op_Equality(ElImage.Color,ElImage.Color)"]

c2
Type: ElImage..::..Color

[Missing <param name="c2"/> documentation for "M:ElImage.Color.op_Equality(ElImage.Color,ElImage.Color)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Color.op_Equality(ElImage.Color,ElImage.Color)"]

See Also

Color Class
ElImage Namespace


Implicit Conversion (Color to Color)

[image]

4 of William Foster's Class Libraries
Color ImplicitWideningImplicitImplicitImplicit Conversion (Color to Color)
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.op_Implicit(ElImage.Color)~System.Drawing.Color"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static implicit operator Color (
    Color c
)
Visual Basic
Public Shared Widening Operator CType ( _
    c As Color _
) As Color
Visual C++
static implicit operator Color (
    Color^ c
)

Parameters

c
Type: ElImage..::..Color

[Missing <param name="c"/> documentation for "M:ElImage.Color.op_Implicit(ElImage.Color)~System.Drawing.Color"]

Return Value

[Missing <returns> documentation for "M:ElImage.Color.op_Implicit(ElImage.Color)~System.Drawing.Color"]

See Also

Color Class
ElImage Namespace


Inequality Operator

[image]

4 of William Foster's Class Libraries
Color..::..Inequality Operator
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Color.op_Inequality(ElImage.Color,ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static bool operator !=(
    Color c1,
    Color c2
)
Visual Basic
Public Shared Operator <> ( _
    c1 As Color, _
    c2 As Color _
) As Boolean
Visual C++
public:
static bool operator !=(
    Color^ c1,
    Color^ c2
)

Parameters

c1
Type: ElImage..::..Color

[Missing <param name="c1"/> documentation for "M:ElImage.Color.op_Inequality(ElImage.Color,ElImage.Color)"]

c2
Type: ElImage..::..Color

[Missing <param name="c2"/> documentation for "M:ElImage.Color.op_Inequality(ElImage.Color,ElImage.Color)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Color.op_Inequality(ElImage.Color,ElImage.Color)"]

See Also

Color Class
ElImage Namespace


ColorMatrix3 Class

[image]

4 of William Foster's Class Libraries
ColorMatrix3 Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.ColorMatrix3"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class ColorMatrix3
Visual Basic
Public Class ColorMatrix3
Visual C++
public ref class ColorMatrix3

Inheritance Hierarchy

System..::..Object
ElImage..::..ColorMatrix3

See Also

ColorMatrix3 Members
ElImage Namespace


ColorMatrix3 Members

[image] [image]

4 of William Foster's Class Libraries
ColorMatrix3 Members
ColorMatrix3 Class Constructors Methods Fields See Also Send Feedback

The ColorMatrix3 type exposes the following members.

Constructors

 | Name | Description
Public method | ColorMatrix3()()()() | Initializes a new instance of the ColorMatrix3 class
Public method | ColorMatrix3(Double, Double, Double, Double, Double, Double, Double, Double, Double) | Initializes a new instance of the ColorMatrix3 class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | member |

See Also

ColorMatrix3 Class
ElImage Namespace


ColorMatrix3 Constructor

[image] [image]

4 of William Foster's Class Libraries
ColorMatrix3 Constructor
ColorMatrix3 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ColorMatrix3()()()() | Initializes a new instance of the ColorMatrix3 class
Public method | ColorMatrix3(Double, Double, Double, Double, Double, Double, Double, Double, Double) | Initializes a new instance of the ColorMatrix3 class

See Also

ColorMatrix3 Class
ColorMatrix3 Members
ElImage Namespace


ColorMatrix3 Constructor

[image]

4 of William Foster's Class Libraries
ColorMatrix3 Constructor
ColorMatrix3 Class See Also Send Feedback
Initializes a new instance of the ColorMatrix3 class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ColorMatrix3()
Visual Basic
Public Sub New
Visual C++
public:
ColorMatrix3()

See Also

ColorMatrix3 Class
ColorMatrix3 Overload
ElImage Namespace


ColorMatrix3 Constructor (Double, Double, Double, Double, Double, Double, Double, Double, Double)

[image]

4 of William Foster's Class Libraries
ColorMatrix3 Constructor (Double, Double, Double, Double, Double, Double, Double, Double, Double)
ColorMatrix3 Class See Also Send Feedback
Initializes a new instance of the ColorMatrix3 class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ColorMatrix3(
    double a,
    double b,
    double c,
    double d,
    double e,
    double f,
    double g,
    double h,
    double i
)
Visual Basic
Public Sub New ( _
    a As Double, _
    b As Double, _
    c As Double, _
    d As Double, _
    e As Double, _
    f As Double, _
    g As Double, _
    h As Double, _
    i As Double _
)
Visual C++
public:
ColorMatrix3(
    double a,
    double b,
    double c,
    double d,
    double e,
    double f,
    double g,
    double h,
    double i
)

Parameters

a
Type: System..::..Double

[Missing <param name="a"/> documentation for "M:ElImage.ColorMatrix3.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

b
Type: System..::..Double

[Missing <param name="b"/> documentation for "M:ElImage.ColorMatrix3.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

c
Type: System..::..Double

[Missing <param name="c"/> documentation for "M:ElImage.ColorMatrix3.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

d
Type: System..::..Double

[Missing <param name="d"/> documentation for "M:ElImage.ColorMatrix3.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

e
Type: System..::..Double

[Missing <param name="e"/> documentation for "M:ElImage.ColorMatrix3.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

f
Type: System..::..Double

[Missing <param name="f"/> documentation for "M:ElImage.ColorMatrix3.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

g
Type: System..::..Double

[Missing <param name="g"/> documentation for "M:ElImage.ColorMatrix3.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

h
Type: System..::..Double

[Missing <param name="h"/> documentation for "M:ElImage.ColorMatrix3.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

i
Type: System..::..Double

[Missing <param name="i"/> documentation for "M:ElImage.ColorMatrix3.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

See Also

ColorMatrix3 Class
ColorMatrix3 Overload
ElImage Namespace


ColorMatrix3 Fields

[image] [image]

4 of William Foster's Class Libraries
ColorMatrix3 Fields
ColorMatrix3 Class See Also Send Feedback

The ColorMatrix3 type exposes the following members.

Fields

 | Name | Description
Public field | member |

See Also

ColorMatrix3 Class
ElImage Namespace


member Field

[image]

4 of William Foster's Class Libraries
ColorMatrix3..::..member Field
ColorMatrix3 Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.ColorMatrix3.member"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public double[,] member
Visual Basic
Public member As Double(,)
Visual C++
public:
array<double,2>^ member

See Also

ColorMatrix3 Class
ElImage Namespace


ColorMatrix3 Methods

[image] [image]

4 of William Foster's Class Libraries
ColorMatrix3 Methods
ColorMatrix3 Class See Also Send Feedback

The ColorMatrix3 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorMatrix3 Class
ElImage Namespace


ColorSpace Class

[image]

4 of William Foster's Class Libraries
ColorSpace Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.ColorSpace"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class ColorSpace
Visual Basic
Public Class ColorSpace
Visual C++
public ref class ColorSpace

Inheritance Hierarchy

System..::..Object
ElImage..::..ColorSpace

See Also

ColorSpace Members
ElImage Namespace


ColorSpace Members

[image] [image]

4 of William Foster's Class Libraries
ColorSpace Members
ColorSpace Class Constructors Methods Operators Fields See Also Send Feedback

The ColorSpace type exposes the following members.

Constructors

 | Name | Description
Public method | ColorSpace()()()() | Initializes a new instance of the ColorSpace class
Public method | ColorSpace(PixelFormat) | Initializes a new instance of the ColorSpace class
Public method | ColorSpace(ColorSpace) | Initializes a new instance of the ColorSpace class
Public method | ColorSpace(ColorSpace..::..El_ColorSpace) | Initializes a new instance of the ColorSpace class

Methods

 | Name | Description
Public method | BytesRequiredToStore |
Protected method | CalculateBitsPerPixel |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBitsPerPixel |
Public method | GetColorSpace |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPixelFormat |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetColorSpace |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality |
Inequality |

Fields

 | Name | Description
Public field | m_palette |

See Also

ColorSpace Class
ElImage Namespace


ColorSpace Constructor

[image] [image]

4 of William Foster's Class Libraries
ColorSpace Constructor
ColorSpace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ColorSpace()()()() | Initializes a new instance of the ColorSpace class
Public method | ColorSpace(PixelFormat) | Initializes a new instance of the ColorSpace class
Public method | ColorSpace(ColorSpace) | Initializes a new instance of the ColorSpace class
Public method | ColorSpace(ColorSpace..::..El_ColorSpace) | Initializes a new instance of the ColorSpace class

See Also

ColorSpace Class
ColorSpace Members
ElImage Namespace


ColorSpace Constructor

[image]

4 of William Foster's Class Libraries
ColorSpace Constructor
ColorSpace Class See Also Send Feedback
Initializes a new instance of the ColorSpace class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ColorSpace()
Visual Basic
Public Sub New
Visual C++
public:
ColorSpace()

See Also

ColorSpace Class
ColorSpace Overload
ElImage Namespace


ColorSpace Constructor (PixelFormat)

[image]

4 of William Foster's Class Libraries
ColorSpace Constructor (PixelFormat)
ColorSpace Class See Also Send Feedback
Initializes a new instance of the ColorSpace class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ColorSpace(
    PixelFormat pxlfmt
)
Visual Basic
Public Sub New ( _
    pxlfmt As PixelFormat _
)
Visual C++
public:
ColorSpace(
    PixelFormat pxlfmt
)

Parameters

pxlfmt
Type: System.Drawing.Imaging..::..PixelFormat

[Missing <param name="pxlfmt"/> documentation for "M:ElImage.ColorSpace.#ctor(System.Drawing.Imaging.PixelFormat)"]

See Also

ColorSpace Class
ColorSpace Overload
ElImage Namespace


ColorSpace Constructor (ColorSpace)

[image]

4 of William Foster's Class Libraries
ColorSpace Constructor (ColorSpace)
ColorSpace Class See Also Send Feedback
Initializes a new instance of the ColorSpace class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ColorSpace(
    ColorSpace spc
)
Visual Basic
Public Sub New ( _
    spc As ColorSpace _
)
Visual C++
public:
ColorSpace(
    ColorSpace^ spc
)

Parameters

spc
Type: ElImage..::..ColorSpace

[Missing <param name="spc"/> documentation for "M:ElImage.ColorSpace.#ctor(ElImage.ColorSpace)"]

See Also

ColorSpace Class
ColorSpace Overload
ElImage Namespace


ColorSpace Constructor (ColorSpace.El_ColorSpace)

[image]

4 of William Foster's Class Libraries
ColorSpace Constructor (ColorSpace..::..El_ColorSpace)
ColorSpace Class See Also Send Feedback
Initializes a new instance of the ColorSpace class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ColorSpace(
    ColorSpace..::..El_ColorSpace eSpace
)
Visual Basic
Public Sub New ( _
    eSpace As ColorSpace..::..El_ColorSpace _
)
Visual C++
public:
ColorSpace(
    ColorSpace..::..El_ColorSpace eSpace
)

Parameters

eSpace
Type: ElImage..::..ColorSpace..::..El_ColorSpace

[Missing <param name="eSpace"/> documentation for "M:ElImage.ColorSpace.#ctor(ElImage.ColorSpace.El_ColorSpace)"]

See Also

ColorSpace Class
ColorSpace Overload
ElImage Namespace


ColorSpace Fields

[image] [image]

4 of William Foster's Class Libraries
ColorSpace Fields
ColorSpace Class See Also Send Feedback

The ColorSpace type exposes the following members.

Fields

 | Name | Description
Public field | m_palette |

See Also

ColorSpace Class
ElImage Namespace


m_palette Field

[image]

4 of William Foster's Class Libraries
ColorSpace..::..m_palette Field
ColorSpace Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.ColorSpace.m_palette"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Palette m_palette
Visual Basic
Public m_palette As Palette
Visual C++
public:
Palette^ m_palette

See Also

ColorSpace Class
ElImage Namespace


ColorSpace Methods

[image] [image]

4 of William Foster's Class Libraries
ColorSpace Methods
ColorSpace Class See Also Send Feedback

The ColorSpace type exposes the following members.

Methods

 | Name | Description
Public method | BytesRequiredToStore |
Protected method | CalculateBitsPerPixel |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBitsPerPixel |
Public method | GetColorSpace |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPixelFormat |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetColorSpace |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorSpace Class
ElImage Namespace


BytesRequiredToStore Method

[image]

4 of William Foster's Class Libraries
ColorSpace..::..BytesRequiredToStore Method
ColorSpace Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ColorSpace.BytesRequiredToStore(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint BytesRequiredToStore(
    uint u_pixelCount
)
Visual Basic
Public Function BytesRequiredToStore ( _
    u_pixelCount As UInteger _
) As UInteger
Visual C++
public:
unsigned int BytesRequiredToStore(
    unsigned int u_pixelCount
)

Parameters

u_pixelCount
Type: System..::..UInt32

[Missing <param name="u_pixelCount"/> documentation for "M:ElImage.ColorSpace.BytesRequiredToStore(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ColorSpace.BytesRequiredToStore(System.UInt32)"]

See Also

ColorSpace Class
ElImage Namespace


CalculateBitsPerPixel Method

[image]

4 of William Foster's Class Libraries
ColorSpace..::..CalculateBitsPerPixel Method
ColorSpace Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ColorSpace.CalculateBitsPerPixel"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected void CalculateBitsPerPixel()
Visual Basic
Protected Sub CalculateBitsPerPixel
Visual C++
protected:
void CalculateBitsPerPixel()

See Also

ColorSpace Class
ElImage Namespace


GetBitsPerPixel Method

[image]

4 of William Foster's Class Libraries
ColorSpace..::..GetBitsPerPixel Method
ColorSpace Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ColorSpace.GetBitsPerPixel"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte GetBitsPerPixel()
Visual Basic
Public Function GetBitsPerPixel As Byte
Visual C++
public:
unsigned char GetBitsPerPixel()

Return Value

[Missing <returns> documentation for "M:ElImage.ColorSpace.GetBitsPerPixel"]

See Also

ColorSpace Class
ElImage Namespace


GetColorSpace Method

[image]

4 of William Foster's Class Libraries
ColorSpace..::..GetColorSpace Method
ColorSpace Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ColorSpace.GetColorSpace"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ColorSpace..::..El_ColorSpace GetColorSpace()
Visual Basic
Public Function GetColorSpace As ColorSpace..::..El_ColorSpace
Visual C++
public:
ColorSpace..::..El_ColorSpace GetColorSpace()

Return Value

[Missing <returns> documentation for "M:ElImage.ColorSpace.GetColorSpace"]

See Also

ColorSpace Class
ElImage Namespace


GetPixelFormat Method

[image]

4 of William Foster's Class Libraries
ColorSpace..::..GetPixelFormat Method
ColorSpace Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ColorSpace.GetPixelFormat"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public PixelFormat GetPixelFormat()
Visual Basic
Public Function GetPixelFormat As PixelFormat
Visual C++
public:
PixelFormat GetPixelFormat()

Return Value

[Missing <returns> documentation for "M:ElImage.ColorSpace.GetPixelFormat"]

See Also

ColorSpace Class
ElImage Namespace


Set Method

[image]

4 of William Foster's Class Libraries
ColorSpace..::..Set Method
ColorSpace Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ColorSpace.Set(ElImage.ColorSpace)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Set(
    ColorSpace colorSpace
)
Visual Basic
Public Sub Set ( _
    colorSpace As ColorSpace _
)
Visual C++
public:
void Set(
    ColorSpace^ colorSpace
)

Parameters

colorSpace
Type: ElImage..::..ColorSpace

[Missing <param name="colorSpace"/> documentation for "M:ElImage.ColorSpace.Set(ElImage.ColorSpace)"]

See Also

ColorSpace Class
ElImage Namespace


SetColorSpace Method

[image]

4 of William Foster's Class Libraries
ColorSpace..::..SetColorSpace Method
ColorSpace Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ColorSpace.SetColorSpace(ElImage.ColorSpace.El_ColorSpace)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetColorSpace(
    ColorSpace..::..El_ColorSpace eSpace
)
Visual Basic
Public Sub SetColorSpace ( _
    eSpace As ColorSpace..::..El_ColorSpace _
)
Visual C++
public:
void SetColorSpace(
    ColorSpace..::..El_ColorSpace eSpace
)

Parameters

eSpace
Type: ElImage..::..ColorSpace..::..El_ColorSpace

[Missing <param name="eSpace"/> documentation for "M:ElImage.ColorSpace.SetColorSpace(ElImage.ColorSpace.El_ColorSpace)"]

See Also

ColorSpace Class
ElImage Namespace


ColorSpace Operators

[image] [image]

4 of William Foster's Class Libraries
ColorSpace Operators
ColorSpace Class See Also Send Feedback

The ColorSpace type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ColorSpace Class
ElImage Namespace


Equality Operator

[image]

4 of William Foster's Class Libraries
ColorSpace..::..Equality Operator
ColorSpace Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ColorSpace.op_Equality(ElImage.ColorSpace,ElImage.ColorSpace)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static bool operator ==(
    ColorSpace cs1,
    ColorSpace cs2
)
Visual Basic
Public Shared Operator = ( _
    cs1 As ColorSpace, _
    cs2 As ColorSpace _
) As Boolean
Visual C++
public:
static bool operator ==(
    ColorSpace^ cs1,
    ColorSpace^ cs2
)

Parameters

cs1
Type: ElImage..::..ColorSpace

[Missing <param name="cs1"/> documentation for "M:ElImage.ColorSpace.op_Equality(ElImage.ColorSpace,ElImage.ColorSpace)"]

cs2
Type: ElImage..::..ColorSpace

[Missing <param name="cs2"/> documentation for "M:ElImage.ColorSpace.op_Equality(ElImage.ColorSpace,ElImage.ColorSpace)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ColorSpace.op_Equality(ElImage.ColorSpace,ElImage.ColorSpace)"]

See Also

ColorSpace Class
ElImage Namespace


Inequality Operator

[image]

4 of William Foster's Class Libraries
ColorSpace..::..Inequality Operator
ColorSpace Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ColorSpace.op_Inequality(ElImage.ColorSpace,ElImage.ColorSpace)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static bool operator !=(
    ColorSpace cs1,
    ColorSpace cs2
)
Visual Basic
Public Shared Operator <> ( _
    cs1 As ColorSpace, _
    cs2 As ColorSpace _
) As Boolean
Visual C++
public:
static bool operator !=(
    ColorSpace^ cs1,
    ColorSpace^ cs2
)

Parameters

cs1
Type: ElImage..::..ColorSpace

[Missing <param name="cs1"/> documentation for "M:ElImage.ColorSpace.op_Inequality(ElImage.ColorSpace,ElImage.ColorSpace)"]

cs2
Type: ElImage..::..ColorSpace

[Missing <param name="cs2"/> documentation for "M:ElImage.ColorSpace.op_Inequality(ElImage.ColorSpace,ElImage.ColorSpace)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ColorSpace.op_Inequality(ElImage.ColorSpace,ElImage.ColorSpace)"]

See Also

ColorSpace Class
ElImage Namespace


ColorSpace.El_ColorFamily Enumeration

[image]

4 of William Foster's Class Libraries
ColorSpace..::..El_ColorFamily Enumeration
ColorSpace Class See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.ColorSpace.El_ColorFamily"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public enum El_ColorFamily
Visual Basic
Public Enumeration El_ColorFamily
Visual C++
public enum class El_ColorFamily

Members

Member name | Value | Description
COLORFAMILY_RGB | 0 |
COLORFAMILY_FSL | 1 |
COLORFAMILY_CMYK | 2 |
COLORFAMILY_GRAY | 3 |
COLORFAMILY_HSL | 4 |
COLORFAMILY_LAB | 5 |
COLORFAMILY_MONOCHROME | 6 |
COLORFAMILY_PANTONE | 7 |
COLORFAMILY_OPACITY | 8 |
COLORFAMILY_UNKNOWN | 9 |

See Also

ElImage Namespace


ColorSpace.El_ColorSpace Enumeration

[image]

4 of William Foster's Class Libraries
ColorSpace..::..El_ColorSpace Enumeration
ColorSpace Class See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.ColorSpace.El_ColorSpace"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public enum El_ColorSpace
Visual Basic
Public Enumeration El_ColorSpace
Visual C++
public enum class El_ColorSpace

Members

Member name | Value | Description
COLORSPACE_RGB | 0 |
COLORSPACE_RGBA | 1 |
COLORSPACE_RGB16 | 2 |
COLORSPACE_FSL | 3 |
COLORSPACE_CMYK | 4 |
COLORSPACE_GRAY | 5 |
COLORSPACE_HSL | 6 |
COLORSPACE_LAB | 7 |
COLORSPACE_MONOCHROME | 8 |
COLORSPACE_INDEXED | 9 |
COLORSPACE_PANTONE | 10 |
COLORSPACE_OPACITY | 11 |
COLORSPACE_UNKNOWN | 12 |
COLORSPACE_BGRA | 13 |
COLORSPACE_BGR | 14 |

See Also

ElImage Namespace


ColorVector3 Class

[image]

4 of William Foster's Class Libraries
ColorVector3 Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.ColorVector3"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class ColorVector3
Visual Basic
Public Class ColorVector3
Visual C++
public ref class ColorVector3

Inheritance Hierarchy

System..::..Object
ElImage..::..ColorVector3

See Also

ColorVector3 Members
ElImage Namespace


ColorVector3 Members

[image] [image]

4 of William Foster's Class Libraries
ColorVector3 Members
ColorVector3 Class Constructors Methods Fields See Also Send Feedback

The ColorVector3 type exposes the following members.

Constructors

 | Name | Description
Public method | ColorVector3()()()() | Initializes a new instance of the ColorVector3 class
Public method | ColorVector3(Double, Double, Double) | Initializes a new instance of the ColorVector3 class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | coordinate |

See Also

ColorVector3 Class
ElImage Namespace


ColorVector3 Constructor

[image] [image]

4 of William Foster's Class Libraries
ColorVector3 Constructor
ColorVector3 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ColorVector3()()()() | Initializes a new instance of the ColorVector3 class
Public method | ColorVector3(Double, Double, Double) | Initializes a new instance of the ColorVector3 class

See Also

ColorVector3 Class
ColorVector3 Members
ElImage Namespace


ColorVector3 Constructor

[image]

4 of William Foster's Class Libraries
ColorVector3 Constructor
ColorVector3 Class See Also Send Feedback
Initializes a new instance of the ColorVector3 class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ColorVector3()
Visual Basic
Public Sub New
Visual C++
public:
ColorVector3()

See Also

ColorVector3 Class
ColorVector3 Overload
ElImage Namespace


ColorVector3 Constructor (Double, Double, Double)

[image]

4 of William Foster's Class Libraries
ColorVector3 Constructor (Double, Double, Double)
ColorVector3 Class See Also Send Feedback
Initializes a new instance of the ColorVector3 class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ColorVector3(
    double x,
    double y,
    double z
)
Visual Basic
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double _
)
Visual C++
public:
ColorVector3(
    double x,
    double y,
    double z
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ElImage.ColorVector3.#ctor(System.Double,System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ElImage.ColorVector3.#ctor(System.Double,System.Double,System.Double)"]

z
Type: System..::..Double

[Missing <param name="z"/> documentation for "M:ElImage.ColorVector3.#ctor(System.Double,System.Double,System.Double)"]

See Also

ColorVector3 Class
ColorVector3 Overload
ElImage Namespace


ColorVector3 Fields

[image] [image]

4 of William Foster's Class Libraries
ColorVector3 Fields
ColorVector3 Class See Also Send Feedback

The ColorVector3 type exposes the following members.

Fields

 | Name | Description
Public field | coordinate |

See Also

ColorVector3 Class
ElImage Namespace


coordinate Field

[image]

4 of William Foster's Class Libraries
ColorVector3..::..coordinate Field
ColorVector3 Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.ColorVector3.coordinate"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public double[] coordinate
Visual Basic
Public coordinate As Double()
Visual C++
public:
array<double>^ coordinate

See Also

ColorVector3 Class
ElImage Namespace


ColorVector3 Methods

[image] [image]

4 of William Foster's Class Libraries
ColorVector3 Methods
ColorVector3 Class See Also Send Feedback

The ColorVector3 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorVector3 Class
ElImage Namespace


CXyzRgb Class

[image]

4 of William Foster's Class Libraries
CXyzRgb Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.CXyzRgb"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class CXyzRgb
Visual Basic
Public Class CXyzRgb
Visual C++
public ref class CXyzRgb

Inheritance Hierarchy

System..::..Object
ElImage..::..CXyzRgb

See Also

CXyzRgb Members
ElImage Namespace


CXyzRgb Members

[image] [image]

4 of William Foster's Class Libraries
CXyzRgb Members
CXyzRgb Class Constructors Methods See Also Send Feedback

The CXyzRgb type exposes the following members.

Constructors

 | Name | Description
Public method | CXyzRgb | Initializes a new instance of the CXyzRgb class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LabToXyz |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RgbToXyz |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | XyzToLab |
Public method | XyzToRgb |

See Also

CXyzRgb Class
ElImage Namespace


CXyzRgb Constructor

[image]

4 of William Foster's Class Libraries
CXyzRgb Constructor
CXyzRgb Class See Also Send Feedback
Initializes a new instance of the CXyzRgb class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public CXyzRgb()
Visual Basic
Public Sub New
Visual C++
public:
CXyzRgb()

See Also

CXyzRgb Class
ElImage Namespace


CXyzRgb Methods

[image] [image]

4 of William Foster's Class Libraries
CXyzRgb Methods
CXyzRgb Class See Also Send Feedback

The CXyzRgb type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LabToXyz |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RgbToXyz |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | XyzToLab |
Public method | XyzToRgb |

See Also

CXyzRgb Class
ElImage Namespace


LabToXyz Method

[image]

4 of William Foster's Class Libraries
CXyzRgb..::..LabToXyz Method
CXyzRgb Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.CXyzRgb.LabToXyz(ElImage.ColorVector3,ElImage.ColorVector3@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void LabToXyz(
    ColorVector3 Lab,
    out ColorVector3 Result
)
Visual Basic
Public Sub LabToXyz ( _
    Lab As ColorVector3, _
    <OutAttribute> ByRef Result As ColorVector3 _
)
Visual C++
public:
void LabToXyz(
    ColorVector3^ Lab,
    [OutAttribute] ColorVector3^% Result
)

Parameters

Lab
Type: ElImage..::..ColorVector3

[Missing <param name="Lab"/> documentation for "M:ElImage.CXyzRgb.LabToXyz(ElImage.ColorVector3,ElImage.ColorVector3@)"]

Result
Type: ElImage..::..ColorVector3 %

[Missing <param name="Result"/> documentation for "M:ElImage.CXyzRgb.LabToXyz(ElImage.ColorVector3,ElImage.ColorVector3@)"]

See Also

CXyzRgb Class
ElImage Namespace


RgbToXyz Method

[image]

4 of William Foster's Class Libraries
CXyzRgb..::..RgbToXyz Method
CXyzRgb Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.CXyzRgb.RgbToXyz(ElImage.ColorVector3,ElImage.ColorVector3@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void RgbToXyz(
    ColorVector3 Rgb,
    out ColorVector3 Result
)
Visual Basic
Public Sub RgbToXyz ( _
    Rgb As ColorVector3, _
    <OutAttribute> ByRef Result As ColorVector3 _
)
Visual C++
public:
void RgbToXyz(
    ColorVector3^ Rgb,
    [OutAttribute] ColorVector3^% Result
)

Parameters

Rgb
Type: ElImage..::..ColorVector3

[Missing <param name="Rgb"/> documentation for "M:ElImage.CXyzRgb.RgbToXyz(ElImage.ColorVector3,ElImage.ColorVector3@)"]

Result
Type: ElImage..::..ColorVector3 %

[Missing <param name="Result"/> documentation for "M:ElImage.CXyzRgb.RgbToXyz(ElImage.ColorVector3,ElImage.ColorVector3@)"]

See Also

CXyzRgb Class
ElImage Namespace


XyzToLab Method

[image]

4 of William Foster's Class Libraries
CXyzRgb..::..XyzToLab Method
CXyzRgb Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.CXyzRgb.XyzToLab(ElImage.ColorVector3,ElImage.ColorVector3@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void XyzToLab(
    ColorVector3 Xyz,
    out ColorVector3 Result
)
Visual Basic
Public Sub XyzToLab ( _
    Xyz As ColorVector3, _
    <OutAttribute> ByRef Result As ColorVector3 _
)
Visual C++
public:
void XyzToLab(
    ColorVector3^ Xyz,
    [OutAttribute] ColorVector3^% Result
)

Parameters

Xyz
Type: ElImage..::..ColorVector3

[Missing <param name="Xyz"/> documentation for "M:ElImage.CXyzRgb.XyzToLab(ElImage.ColorVector3,ElImage.ColorVector3@)"]

Result
Type: ElImage..::..ColorVector3 %

[Missing <param name="Result"/> documentation for "M:ElImage.CXyzRgb.XyzToLab(ElImage.ColorVector3,ElImage.ColorVector3@)"]

See Also

CXyzRgb Class
ElImage Namespace


XyzToRgb Method

[image]

4 of William Foster's Class Libraries
CXyzRgb..::..XyzToRgb Method
CXyzRgb Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.CXyzRgb.XyzToRgb(ElImage.ColorVector3,ElImage.ColorVector3@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void XyzToRgb(
    ColorVector3 Xyz,
    out ColorVector3 Result
)
Visual Basic
Public Sub XyzToRgb ( _
    Xyz As ColorVector3, _
    <OutAttribute> ByRef Result As ColorVector3 _
)
Visual C++
public:
void XyzToRgb(
    ColorVector3^ Xyz,
    [OutAttribute] ColorVector3^% Result
)

Parameters

Xyz
Type: ElImage..::..ColorVector3

[Missing <param name="Xyz"/> documentation for "M:ElImage.CXyzRgb.XyzToRgb(ElImage.ColorVector3,ElImage.ColorVector3@)"]

Result
Type: ElImage..::..ColorVector3 %

[Missing <param name="Result"/> documentation for "M:ElImage.CXyzRgb.XyzToRgb(ElImage.ColorVector3,ElImage.ColorVector3@)"]

See Also

CXyzRgb Class
ElImage Namespace


EImageActions Enumeration

[image]

4 of William Foster's Class Libraries
EImageActions Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.EImageActions"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public enum EImageActions
Visual Basic
Public Enumeration EImageActions
Visual C++
public enum class EImageActions

Members

Member name | Value | Description
DESKEW | 0 |
PAINT_BUCKET | 1 |
BRIGHTNESS | 2 |
SEGMENT | 3 |

See Also

ElImage Namespace


El_Color Enumeration

[image]

4 of William Foster's Class Libraries
El_Color Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.El_Color"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public enum El_Color
Visual Basic
Public Enumeration El_Color
Visual C++
public enum class El_Color

Members

Member name | Value | Description
WHITE | 0 |
BLACK | 1 |
RED | 2 |
GREEN | 3 |
BLUE | 4 |
CYAN | 5 |
MAGENTA | 6 |
YELLOW | 7 |
GREY | 8 |
LIGHT_GREY | 9 |
DARK_GREY | 10 |

See Also

ElImage Namespace


ElImageActionDP Class

[image]

4 of William Foster's Class Libraries
ElImageActionDP Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.ElImageActionDP"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class ElImageActionDP : ImageActionDP
Visual Basic
Public Class ElImageActionDP _
    Inherits ImageActionDP
Visual C++
public ref class ElImageActionDP : public ImageActionDP

Inheritance Hierarchy

System..::..Object
ElGUI..::..DP
ElGUI..::..ActionDP
ElImage..::..ImageActionDP
ElImage..::..ElImageActionDP

See Also

ElImageActionDP Members
ElImage Namespace


ElImageActionDP Members

[image] [image]

4 of William Foster's Class Libraries
ElImageActionDP Members
ElImageActionDP Class Constructors Methods Fields Properties See Also Send Feedback

The ElImageActionDP type exposes the following members.

Constructors

 | Name | Description
Public method | ElImageActionDP | Initializes a new instance of the ElImageActionDP class

Methods

 | Name | Description
Public method | ApplyAction | (Inherited from ActionDP.)
Public method | CombineAction | (Inherited from ActionDP.)
Public method | CompletedAction | (Inherited from ImageActionDP.)
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Dup | (Overrides ActionDP..::..Dup()()()().)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | EditDX | Override this to edit the action parameters via a dialog before processing starts on a new action. (Inherited from ImageActionDP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformAction | (Overrides ActionDP..::..PerformAction(Boolean%).)
Public method | Prepare | (Overrides ImageActionDP..::..Prepare(ImageWindow).)
Public method | Preview | (Inherited from DP.)
Public method | PreviewAction | (Inherited from ActionDP.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UndoAction | (Inherited from ActionDP.)

Fields

 | Name | Description
Public field | m_combinable | (Inherited from ActionDP.)
Public field | m_eact |
Public field | m_name | (Inherited from ActionDP.)
Public field | m_undoable | (Inherited from ActionDP.)
Protected field | m_wnd | (Inherited from ImageActionDP.)

Properties

 | Name | Description
Public property | Name | (Overrides ActionDP..::..Name.)

See Also

ElImageActionDP Class
ElImage Namespace


ElImageActionDP Constructor

[image]

4 of William Foster's Class Libraries
ElImageActionDP Constructor
ElImageActionDP Class See Also Send Feedback
Initializes a new instance of the ElImageActionDP class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ElImageActionDP(
    EImageActions eact,
    ImageActionDX dx
)
Visual Basic
Public Sub New ( _
    eact As EImageActions, _
    dx As ImageActionDX _
)
Visual C++
public:
ElImageActionDP(
    EImageActions eact,
    ImageActionDX^ dx
)

Parameters

eact
Type: ElImage..::..EImageActions

[Missing <param name="eact"/> documentation for "M:ElImage.ElImageActionDP.#ctor(ElImage.EImageActions,ElImage.ImageActionDX)"]

dx
Type: ElImage..::..ImageActionDX

[Missing <param name="dx"/> documentation for "M:ElImage.ElImageActionDP.#ctor(ElImage.EImageActions,ElImage.ImageActionDX)"]

See Also

ElImageActionDP Class
ElImage Namespace


ElImageActionDP Fields

[image] [image]

4 of William Foster's Class Libraries
ElImageActionDP Fields
ElImageActionDP Class See Also Send Feedback

The ElImageActionDP type exposes the following members.

Fields

 | Name | Description
Public field | m_combinable | (Inherited from ActionDP.)
Public field | m_eact |
Public field | m_name | (Inherited from ActionDP.)
Public field | m_undoable | (Inherited from ActionDP.)
Protected field | m_wnd | (Inherited from ImageActionDP.)

See Also

ElImageActionDP Class
ElImage Namespace


m_eact Field

[image]

4 of William Foster's Class Libraries
ElImageActionDP..::..m_eact Field
ElImageActionDP Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.ElImageActionDP.m_eact"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public EImageActions m_eact
Visual Basic
Public m_eact As EImageActions
Visual C++
public:
EImageActions m_eact

See Also

ElImageActionDP Class
ElImage Namespace


ElImageActionDP Methods

[image] [image]

4 of William Foster's Class Libraries
ElImageActionDP Methods
ElImageActionDP Class See Also Send Feedback

The ElImageActionDP type exposes the following members.

Methods

 | Name | Description
Public method | ApplyAction | (Inherited from ActionDP.)
Public method | CombineAction | (Inherited from ActionDP.)
Public method | CompletedAction | (Inherited from ImageActionDP.)
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Dup | (Overrides ActionDP..::..Dup()()()().)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | EditDX | Override this to edit the action parameters via a dialog before processing starts on a new action. (Inherited from ImageActionDP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformAction | (Overrides ActionDP..::..PerformAction(Boolean%).)
Public method | Prepare | (Overrides ImageActionDP..::..Prepare(ImageWindow).)
Public method | Preview | (Inherited from DP.)
Public method | PreviewAction | (Inherited from ActionDP.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UndoAction | (Inherited from ActionDP.)

See Also

ElImageActionDP Class
ElImage Namespace


Dup Method

[image]

4 of William Foster's Class Libraries
ElImageActionDP..::..Dup Method
ElImageActionDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ElImageActionDP.Dup"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override ActionDP Dup()
Visual Basic
Public Overrides Function Dup As ActionDP
Visual C++
public:
virtual ActionDP^ Dup() override

Return Value

[Missing <returns> documentation for "M:ElImage.ElImageActionDP.Dup"]

See Also

ElImageActionDP Class
ElImage Namespace


PerformAction Method

[image]

4 of William Foster's Class Libraries
ElImageActionDP..::..PerformAction Method
ElImageActionDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ElImageActionDP.PerformAction(System.Boolean@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override bool PerformAction(
    out bool bActionTaken
)
Visual Basic
Public Overrides Function PerformAction ( _
    <OutAttribute> ByRef bActionTaken As Boolean _
) As Boolean
Visual C++
public:
virtual bool PerformAction(
    [OutAttribute] bool% bActionTaken
) override

Parameters

bActionTaken
Type: System..::..Boolean %

[Missing <param name="bActionTaken"/> documentation for "M:ElImage.ElImageActionDP.PerformAction(System.Boolean@)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ElImageActionDP.PerformAction(System.Boolean@)"]

See Also

ElImageActionDP Class
ElImage Namespace


Prepare Method

[image]

4 of William Foster's Class Libraries
ElImageActionDP..::..Prepare Method
ElImageActionDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ElImageActionDP.Prepare(ElImage.ImageWindow)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override bool Prepare(
    ImageWindow wnd
)
Visual Basic
Public Overrides Function Prepare ( _
    wnd As ImageWindow _
) As Boolean
Visual C++
public:
virtual bool Prepare(
    ImageWindow^ wnd
) override

Parameters

wnd
Type: ElImage..::..ImageWindow

[Missing <param name="wnd"/> documentation for "M:ElImage.ElImageActionDP.Prepare(ElImage.ImageWindow)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ElImageActionDP.Prepare(ElImage.ImageWindow)"]

See Also

ElImageActionDP Class
ElImage Namespace


ElImageActionDP Properties

[image] [image]

4 of William Foster's Class Libraries
ElImageActionDP Properties
ElImageActionDP Class See Also Send Feedback

The ElImageActionDP type exposes the following members.

Properties

 | Name | Description
Public property | Name | (Overrides ActionDP..::..Name.)

See Also

ElImageActionDP Class
ElImage Namespace


Name Property

[image]

4 of William Foster's Class Libraries
ElImageActionDP..::..Name Property
ElImageActionDP Class See Also Send Feedback

[Missing <summary> documentation for "P:ElImage.ElImageActionDP.Name"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

See Also

ElImageActionDP Class
ElImage Namespace


ESelectMode Enumeration

[image]

4 of William Foster's Class Libraries
ESelectMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.ESelectMode"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public enum ESelectMode
Visual Basic
Public Enumeration ESelectMode
Visual C++
public enum class ESelectMode

Members

Member name | Value | Description
NEW | 0 |
ADD | 1 |
SUBTRACT | 2 |

See Also

ElImage Namespace


Histogram Class

[image]

4 of William Foster's Class Libraries
Histogram Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Histogram"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Histogram
Visual Basic
Public Class Histogram
Visual C++
public ref class Histogram

Inheritance Hierarchy

System..::..Object
ElImage..::..Histogram
ElImage..::..Brightness_Histogram
ElImage..::..HSL_Histogram

See Also

Histogram Members
ElImage Namespace


Histogram Members

[image] [image]

4 of William Foster's Class Libraries
Histogram Members
Histogram Class Constructors Methods Fields See Also Send Feedback

The Histogram type exposes the following members.

Constructors

 | Name | Description
Public method | Histogram | Initializes a new instance of the Histogram class

Methods

 | Name | Description
Public method | Average | Find the midpoint of the curve, or brightness of the average pixel
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run_Histogram |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ZeroMap |

Fields

 | Name | Description
Protected field | m_b_beenRun |
Protected field | m_Bmp |
Public field | m_full_rect |
Public field | m_Map |

See Also

Histogram Class
ElImage Namespace


Histogram Constructor

[image]

4 of William Foster's Class Libraries
Histogram Constructor
Histogram Class See Also Send Feedback
Initializes a new instance of the Histogram class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Histogram(
    Bitmap Bmp
)
Visual Basic
Public Sub New ( _
    Bmp As Bitmap _
)
Visual C++
public:
Histogram(
    Bitmap^ Bmp
)

Parameters

Bmp
Type: ElImage..::..Bitmap

[Missing <param name="Bmp"/> documentation for "M:ElImage.Histogram.#ctor(ElImage.Bitmap)"]

See Also

Histogram Class
ElImage Namespace


Histogram Fields

[image] [image]

4 of William Foster's Class Libraries
Histogram Fields
Histogram Class See Also Send Feedback

The Histogram type exposes the following members.

Fields

 | Name | Description
Protected field | m_b_beenRun |
Protected field | m_Bmp |
Public field | m_full_rect |
Public field | m_Map |

See Also

Histogram Class
ElImage Namespace


m_b_beenRun Field

[image]

4 of William Foster's Class Libraries
Histogram..::..m_b_beenRun Field
Histogram Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Histogram.m_b_beenRun"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected bool m_b_beenRun
Visual Basic
Protected m_b_beenRun As Boolean
Visual C++
protected:
bool m_b_beenRun

See Also

Histogram Class
ElImage Namespace


m_Bmp Field

[image]

4 of William Foster's Class Libraries
Histogram..::..m_Bmp Field
Histogram Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Histogram.m_Bmp"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected Bitmap m_Bmp
Visual Basic
Protected m_Bmp As Bitmap
Visual C++
protected:
Bitmap^ m_Bmp

See Also

Histogram Class
ElImage Namespace


m_full_rect Field

[image]

4 of William Foster's Class Libraries
Histogram..::..m_full_rect Field
Histogram Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Histogram.m_full_rect"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Rect2dU m_full_rect
Visual Basic
Public m_full_rect As Rect2dU
Visual C++
public:
Rect2dU^ m_full_rect

See Also

Histogram Class
ElImage Namespace


m_Map Field

[image]

4 of William Foster's Class Libraries
Histogram..::..m_Map Field
Histogram Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Histogram.m_Map"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint[] m_Map
Visual Basic
Public m_Map As UInteger()
Visual C++
public:
array<unsigned int>^ m_Map

See Also

Histogram Class
ElImage Namespace


Histogram Methods

[image] [image]

4 of William Foster's Class Libraries
Histogram Methods
Histogram Class See Also Send Feedback

The Histogram type exposes the following members.

Methods

 | Name | Description
Public method | Average | Find the midpoint of the curve, or brightness of the average pixel
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run_Histogram |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ZeroMap |

See Also

Histogram Class
ElImage Namespace


Average Method

[image]

4 of William Foster's Class Libraries
Histogram..::..Average Method
Histogram Class See Also Send Feedback
Find the midpoint of the curve, or brightness of the average pixel

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte Average()
Visual Basic
Public Function Average As Byte
Visual C++
public:
unsigned char Average()

Return Value

[Missing <returns> documentation for "M:ElImage.Histogram.Average"]

See Also

Histogram Class
ElImage Namespace


Run_Histogram Method

[image]

4 of William Foster's Class Libraries
Histogram..::..Run_Histogram Method
Histogram Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Histogram.Run_Histogram(El.Rect2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual void Run_Histogram(
    Rect2dU Rect
)
Visual Basic
Public Overridable Sub Run_Histogram ( _
    Rect As Rect2dU _
)
Visual C++
public:
virtual void Run_Histogram(
    Rect2dU^ Rect
)

Parameters

Rect
Type: Rect2dU

[Missing <param name="Rect"/> documentation for "M:ElImage.Histogram.Run_Histogram(El.Rect2dU)"]

See Also

Histogram Class
ElImage Namespace


ZeroMap Method

[image]

4 of William Foster's Class Libraries
Histogram..::..ZeroMap Method
Histogram Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Histogram.ZeroMap"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected void ZeroMap()
Visual Basic
Protected Sub ZeroMap
Visual C++
protected:
void ZeroMap()

See Also

Histogram Class
ElImage Namespace


HSL_Histogram Class

[image]

4 of William Foster's Class Libraries
HSL_Histogram Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.HSL_Histogram"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class HSL_Histogram : Histogram
Visual Basic
Public Class HSL_Histogram _
    Inherits Histogram
Visual C++
public ref class HSL_Histogram : public Histogram

Inheritance Hierarchy

System..::..Object
ElImage..::..Histogram
ElImage..::..HSL_Histogram

See Also

HSL_Histogram Members
ElImage Namespace


HSL_Histogram Members

[image] [image]

4 of William Foster's Class Libraries
HSL_Histogram Members
HSL_Histogram Class Constructors Methods Fields See Also Send Feedback

The HSL_Histogram type exposes the following members.

Constructors

 | Name | Description
Public method | HSL_Histogram | Initializes a new instance of the HSL_Histogram class

Methods

 | Name | Description
Public method | Average | Find the midpoint of the curve, or brightness of the average pixel (Inherited from Histogram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run_Histogram | (Overrides Histogram..::..Run_Histogram(Rect2dU).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ZeroMap | (Inherited from Histogram.)
Protected method | ZeroMaps |

Fields

 | Name | Description
Protected field | m_b_beenRun | (Inherited from Histogram.)
Protected field | m_Bmp | (Inherited from Histogram.)
Public field | m_full_rect | (Inherited from Histogram.)
Public field | m_Map | (Inherited from Histogram.)

See Also

HSL_Histogram Class
ElImage Namespace


HSL_Histogram Constructor

[image]

4 of William Foster's Class Libraries
HSL_Histogram Constructor
HSL_Histogram Class See Also Send Feedback
Initializes a new instance of the HSL_Histogram class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public HSL_Histogram(
    Bitmap Bmp
)
Visual Basic
Public Sub New ( _
    Bmp As Bitmap _
)
Visual C++
public:
HSL_Histogram(
    Bitmap^ Bmp
)

Parameters

Bmp
Type: ElImage..::..Bitmap

[Missing <param name="Bmp"/> documentation for "M:ElImage.HSL_Histogram.#ctor(ElImage.Bitmap)"]

See Also

HSL_Histogram Class
ElImage Namespace


HSL_Histogram Fields

[image] [image]

4 of William Foster's Class Libraries
HSL_Histogram Fields
HSL_Histogram Class See Also Send Feedback

The HSL_Histogram type exposes the following members.

Fields

 | Name | Description
Protected field | m_b_beenRun | (Inherited from Histogram.)
Protected field | m_Bmp | (Inherited from Histogram.)
Public field | m_full_rect | (Inherited from Histogram.)
Public field | m_Map | (Inherited from Histogram.)

See Also

HSL_Histogram Class
ElImage Namespace


HSL_Histogram Methods

[image] [image]

4 of William Foster's Class Libraries
HSL_Histogram Methods
HSL_Histogram Class See Also Send Feedback

The HSL_Histogram type exposes the following members.

Methods

 | Name | Description
Public method | Average | Find the midpoint of the curve, or brightness of the average pixel (Inherited from Histogram.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run_Histogram | (Overrides Histogram..::..Run_Histogram(Rect2dU).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ZeroMap | (Inherited from Histogram.)
Protected method | ZeroMaps |

See Also

HSL_Histogram Class
ElImage Namespace


Run_Histogram Method

[image]

4 of William Foster's Class Libraries
HSL_Histogram..::..Run_Histogram Method
HSL_Histogram Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.HSL_Histogram.Run_Histogram(El.Rect2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override void Run_Histogram(
    Rect2dU rect
)
Visual Basic
Public Overrides Sub Run_Histogram ( _
    rect As Rect2dU _
)
Visual C++
public:
virtual void Run_Histogram(
    Rect2dU^ rect
) override

Parameters

rect
Type: Rect2dU

[Missing <param name="rect"/> documentation for "M:ElImage.HSL_Histogram.Run_Histogram(El.Rect2dU)"]

See Also

HSL_Histogram Class
ElImage Namespace


ZeroMaps Method

[image]

4 of William Foster's Class Libraries
HSL_Histogram..::..ZeroMaps Method
HSL_Histogram Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.HSL_Histogram.ZeroMaps"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected void ZeroMaps()
Visual Basic
Protected Sub ZeroMaps
Visual C++
protected:
void ZeroMaps()

See Also

HSL_Histogram Class
ElImage Namespace


Image Class

[image]

4 of William Foster's Class Libraries
Image Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Image"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Image : Image_Basic
Visual Basic
Public Class Image _
    Inherits Image_Basic
Visual C++
public ref class Image : public Image_Basic

Inheritance Hierarchy

System..::..Object
ElImage..::..Image_Store
ElImage..::..Image_Basic
ElImage..::..Image

See Also

Image Members
ElImage Namespace


Image Members

[image] [image]

4 of William Foster's Class Libraries
Image Members
Image Class Constructors Methods Fields Properties See Also Send Feedback

The Image type exposes the following members.

Constructors

 | Name | Description
Public method | Image()()()() | Initializes a new instance of the Image class
Public method | Image(Stream) | Initializes a new instance of the Image class
Public method | Image(Image) | Initializes a new instance of the Image class

Methods

 | Name | Description
Public method | AddPage | (Inherited from Image_Store.)
Public method | AttachBitmap | (Inherited from Image_Store.)
Public method | AttachStream | (Inherited from Image_Store.)
Public method | ConstructBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) | (Inherited from Image_Store.)
Public method | ConstructBuffer(Image_Segment, ScriptImage) | (Inherited from Image_Store.)
Public method | CreateEmptyBuffer | (Inherited from Image_Basic.)
Public method | Effect |
Public method | Empty | (Inherited from Image_Store.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBuffer |
Public method | GetCachedBuffer | (Inherited from Image_Store.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageSize | (Inherited from Image_Store.)
Public method | GetInfo_Native | (Inherited from Image_Basic.)
Public method | GetInfo_Transformed |
Public method | GetLayer()()()() | (Inherited from Image_Store.)
Public method | GetLayer(UInt32) | (Inherited from Image_Store.)
Public method | GetLayerNumber | (Inherited from Image_Store.)
Public method | GetPage()()()() | (Inherited from Image_Store.)
Public method | GetPage(UInt32) | (Inherited from Image_Store.)
Public method | GetPageNumber | (Inherited from Image_Store.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsModified | (Inherited from Image_Store.)
Public method | Load | (Inherited from Image_Store.)
Public method | LoadSegmentBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) | (Inherited from Image_Store.)
Public method | LoadSegmentBuffer(Image_Segment, ScriptImage) | (Inherited from Image_Store.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSelection | (Inherited from Image_Basic.)
Public method | PreviousSelection | (Inherited from Image_Basic.)
Protected method | ReverseTransformSegment |
Public method | Save(Image_Buffer) | (Inherited from Image_Store.)
Public method | Save(Image_Segment) |
Public method | SetBitmap | (Inherited from Image_Store.)
Public method | SetLayerNumber | (Inherited from Image_Store.)
Public method | SetModified | (Inherited from Image_Store.)
Public method | SetNative | (Inherited from Image_Store.)
Public method | SetNativeColorspace | (Inherited from Image_Basic.)
Public method | SetPageNumber | (Inherited from Image_Store.)
Protected method | SetSegmentToEntireImage(Image_Segment) |
Public method | SetSegmentToEntireImage(Image_Segment%) | (Inherited from Image_Basic.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformColorspace |
Protected method | TransformInfo |

Fields

 | Name | Description
Protected field | m_b_modified | (Inherited from Image_Store.)
Protected field | m_Image_Format | (Inherited from Image_Store.)
Protected field | m_InfoNative | (Inherited from Image_Store.)
Protected field | m_Pages | (Inherited from Image_Store.)

Properties

 | Name | Description
Public property | stream | (Inherited from Image_Store.)

See Also

Image Class
ElImage Namespace


Image Constructor

[image] [image]

4 of William Foster's Class Libraries
Image Constructor
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Image()()()() | Initializes a new instance of the Image class
Public method | Image(Stream) | Initializes a new instance of the Image class
Public method | Image(Image) | Initializes a new instance of the Image class

See Also

Image Class
Image Members
ElImage Namespace


Image Constructor

[image]

4 of William Foster's Class Libraries
Image Constructor
Image Class See Also Send Feedback
Initializes a new instance of the Image class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image()
Visual Basic
Public Sub New
Visual C++
public:
Image()

See Also

Image Class
Image Overload
ElImage Namespace


Image Constructor ()

[image]

4 of William Foster's Class Libraries
Image Constructor ()
Image Class See Also Send Feedback
Initializes a new instance of the Image class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image(
    Stream stream
)
Visual Basic
Public Sub New ( _
    stream As Stream _
)
Visual C++
public:
Image(
    Stream^ stream
)

Parameters

stream
Type: Stream

[Missing <param name="stream"/> documentation for "M:ElImage.Image.#ctor(El.Stream)"]

See Also

Image Class
Image Overload
ElImage Namespace


Image Constructor (Image)

[image]

4 of William Foster's Class Libraries
Image Constructor (Image)
Image Class See Also Send Feedback
Initializes a new instance of the Image class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image(
    Image img
)
Visual Basic
Public Sub New ( _
    img As Image _
)
Visual C++
public:
Image(
    Image^ img
)

Parameters

img
Type: ElImage..::..Image

[Missing <param name="img"/> documentation for "M:ElImage.Image.#ctor(ElImage.Image)"]

See Also

Image Class
Image Overload
ElImage Namespace


Image Fields

[image] [image]

4 of William Foster's Class Libraries
Image Fields
Image Class See Also Send Feedback

The Image type exposes the following members.

Fields

 | Name | Description
Protected field | m_b_modified | (Inherited from Image_Store.)
Protected field | m_Image_Format | (Inherited from Image_Store.)
Protected field | m_InfoNative | (Inherited from Image_Store.)
Protected field | m_Pages | (Inherited from Image_Store.)

See Also

Image Class
ElImage Namespace


Image Methods

[image] [image]

4 of William Foster's Class Libraries
Image Methods
Image Class See Also Send Feedback

The Image type exposes the following members.

Methods

 | Name | Description
Public method | AddPage | (Inherited from Image_Store.)
Public method | AttachBitmap | (Inherited from Image_Store.)
Public method | AttachStream | (Inherited from Image_Store.)
Public method | ConstructBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) | (Inherited from Image_Store.)
Public method | ConstructBuffer(Image_Segment, ScriptImage) | (Inherited from Image_Store.)
Public method | CreateEmptyBuffer | (Inherited from Image_Basic.)
Public method | Effect |
Public method | Empty | (Inherited from Image_Store.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBuffer |
Public method | GetCachedBuffer | (Inherited from Image_Store.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageSize | (Inherited from Image_Store.)
Public method | GetInfo_Native | (Inherited from Image_Basic.)
Public method | GetInfo_Transformed |
Public method | GetLayer()()()() | (Inherited from Image_Store.)
Public method | GetLayer(UInt32) | (Inherited from Image_Store.)
Public method | GetLayerNumber | (Inherited from Image_Store.)
Public method | GetPage()()()() | (Inherited from Image_Store.)
Public method | GetPage(UInt32) | (Inherited from Image_Store.)
Public method | GetPageNumber | (Inherited from Image_Store.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsModified | (Inherited from Image_Store.)
Public method | Load | (Inherited from Image_Store.)
Public method | LoadSegmentBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) | (Inherited from Image_Store.)
Public method | LoadSegmentBuffer(Image_Segment, ScriptImage) | (Inherited from Image_Store.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSelection | (Inherited from Image_Basic.)
Public method | PreviousSelection | (Inherited from Image_Basic.)
Protected method | ReverseTransformSegment |
Public method | Save(Image_Buffer) | (Inherited from Image_Store.)
Public method | Save(Image_Segment) |
Public method | SetBitmap | (Inherited from Image_Store.)
Public method | SetLayerNumber | (Inherited from Image_Store.)
Public method | SetModified | (Inherited from Image_Store.)
Public method | SetNative | (Inherited from Image_Store.)
Public method | SetNativeColorspace | (Inherited from Image_Basic.)
Public method | SetPageNumber | (Inherited from Image_Store.)
Protected method | SetSegmentToEntireImage(Image_Segment) |
Public method | SetSegmentToEntireImage(Image_Segment%) | (Inherited from Image_Basic.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformColorspace |
Protected method | TransformInfo |

See Also

Image Class
ElImage Namespace


ConstructBuffer Method

[image] [image]

4 of William Foster's Class Libraries
Image..::..ConstructBuffer Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConstructBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) | (Inherited from Image_Store.)
Public method | ConstructBuffer(Image_Segment, ScriptImage) | (Inherited from Image_Store.)

See Also

Image Class
Image Members
ElImage Namespace


Effect Method

[image]

4 of William Foster's Class Libraries
Image..::..Effect Method
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image.Effect(ElImage.Image_Segment,ElImage.Image_Effect)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Effect(
    Image_Segment segment,
    Image_Effect Effect
)
Visual Basic
Public Function Effect ( _
    segment As Image_Segment, _
    Effect As Image_Effect _
) As Boolean
Visual C++
public:
bool Effect(
    Image_Segment^ segment,
    Image_Effect^ Effect
)

Parameters

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Image.Effect(ElImage.Image_Segment,ElImage.Image_Effect)"]

Effect
Type: ElImage..::..Image_Effect

[Missing <param name="Effect"/> documentation for "M:ElImage.Image.Effect(ElImage.Image_Segment,ElImage.Image_Effect)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image.Effect(ElImage.Image_Segment,ElImage.Image_Effect)"]

See Also

Image Class
ElImage Namespace


GetBuffer Method

[image]

4 of William Foster's Class Libraries
Image..::..GetBuffer Method
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image.GetBuffer(ElImage.Image_Segment)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual Image_Buffer GetBuffer(
    Image_Segment segment
)
Visual Basic
Public Overridable Function GetBuffer ( _
    segment As Image_Segment _
) As Image_Buffer
Visual C++
public:
virtual Image_Buffer^ GetBuffer(
    Image_Segment^ segment
)

Parameters

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Image.GetBuffer(ElImage.Image_Segment)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image.GetBuffer(ElImage.Image_Segment)"]

See Also

Image Class
ElImage Namespace


GetInfo_Transformed Method

[image]

4 of William Foster's Class Libraries
Image..::..GetInfo_Transformed Method
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image.GetInfo_Transformed"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Info GetInfo_Transformed()
Visual Basic
Public Function GetInfo_Transformed As Image_Info
Visual C++
public:
Image_Info^ GetInfo_Transformed()

Return Value

[Missing <returns> documentation for "M:ElImage.Image.GetInfo_Transformed"]

See Also

Image Class
ElImage Namespace


GetLayer Method

[image] [image]

4 of William Foster's Class Libraries
Image..::..GetLayer Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLayer()()()() | (Inherited from Image_Store.)
Public method | GetLayer(UInt32) | (Inherited from Image_Store.)

See Also

Image Class
Image Members
ElImage Namespace


GetPage Method

[image] [image]

4 of William Foster's Class Libraries
Image..::..GetPage Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPage()()()() | (Inherited from Image_Store.)
Public method | GetPage(UInt32) | (Inherited from Image_Store.)

See Also

Image Class
Image Members
ElImage Namespace


LoadSegmentBuffer Method

[image] [image]

4 of William Foster's Class Libraries
Image..::..LoadSegmentBuffer Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadSegmentBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) | (Inherited from Image_Store.)
Public method | LoadSegmentBuffer(Image_Segment, ScriptImage) | (Inherited from Image_Store.)

See Also

Image Class
Image Members
ElImage Namespace


ReverseTransformSegment Method

[image]

4 of William Foster's Class Libraries
Image..::..ReverseTransformSegment Method
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image.ReverseTransformSegment(ElImage.Image_Segment,ElImage.Image_Segment@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected bool ReverseTransformSegment(
    Image_Segment SegNative,
    out Image_Segment SegReverseTransformed
)
Visual Basic
Protected Function ReverseTransformSegment ( _
    SegNative As Image_Segment, _
    <OutAttribute> ByRef SegReverseTransformed As Image_Segment _
) As Boolean
Visual C++
protected:
bool ReverseTransformSegment(
    Image_Segment^ SegNative,
    [OutAttribute] Image_Segment^% SegReverseTransformed
)

Parameters

SegNative
Type: ElImage..::..Image_Segment

[Missing <param name="SegNative"/> documentation for "M:ElImage.Image.ReverseTransformSegment(ElImage.Image_Segment,ElImage.Image_Segment@)"]

SegReverseTransformed
Type: ElImage..::..Image_Segment %

[Missing <param name="SegReverseTransformed"/> documentation for "M:ElImage.Image.ReverseTransformSegment(ElImage.Image_Segment,ElImage.Image_Segment@)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image.ReverseTransformSegment(ElImage.Image_Segment,ElImage.Image_Segment@)"]

See Also

Image Class
ElImage Namespace


Save Method

[image] [image]

4 of William Foster's Class Libraries
Image..::..Save Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Save(Image_Buffer) | (Inherited from Image_Store.)
Public method | Save(Image_Segment) |

See Also

Image Class
Image Members
ElImage Namespace


Save Method (Image_Segment)

[image]

4 of William Foster's Class Libraries
Image..::..Save Method (Image_Segment)
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image.Save(ElImage.Image_Segment)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Save(
    Image_Segment segment
)
Visual Basic
Public Function Save ( _
    segment As Image_Segment _
) As Boolean
Visual C++
public:
bool Save(
    Image_Segment^ segment
)

Parameters

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Image.Save(ElImage.Image_Segment)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image.Save(ElImage.Image_Segment)"]

See Also

Image Class
Save Overload
ElImage Namespace


SetSegmentToEntireImage Method

[image] [image]

4 of William Foster's Class Libraries
Image..::..SetSegmentToEntireImage Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | SetSegmentToEntireImage(Image_Segment) |
Public method | SetSegmentToEntireImage(Image_Segment%) | (Inherited from Image_Basic.)

See Also

Image Class
Image Members
ElImage Namespace


SetSegmentToEntireImage Method (Image_Segment)

[image]

4 of William Foster's Class Libraries
Image..::..SetSegmentToEntireImage Method (Image_Segment)
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image.SetSegmentToEntireImage(ElImage.Image_Segment)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected virtual void SetSegmentToEntireImage(
    Image_Segment seg
)
Visual Basic
Protected Overridable Sub SetSegmentToEntireImage ( _
    seg As Image_Segment _
)
Visual C++
protected:
virtual void SetSegmentToEntireImage(
    Image_Segment^ seg
)

Parameters

seg
Type: ElImage..::..Image_Segment

[Missing <param name="seg"/> documentation for "M:ElImage.Image.SetSegmentToEntireImage(ElImage.Image_Segment)"]

See Also

Image Class
SetSegmentToEntireImage Overload
ElImage Namespace


TransformColorspace Method

[image]

4 of William Foster's Class Libraries
Image..::..TransformColorspace Method
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image.TransformColorspace(ElImage.ColorSpace)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void TransformColorspace(
    ColorSpace space
)
Visual Basic
Public Sub TransformColorspace ( _
    space As ColorSpace _
)
Visual C++
public:
void TransformColorspace(
    ColorSpace^ space
)

Parameters

space
Type: ElImage..::..ColorSpace

[Missing <param name="space"/> documentation for "M:ElImage.Image.TransformColorspace(ElImage.ColorSpace)"]

See Also

Image Class
ElImage Namespace


TransformInfo Method

[image]

4 of William Foster's Class Libraries
Image..::..TransformInfo Method
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image.TransformInfo(ElImage.Image_Info,ElImage.Image_Info@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected Image_Info TransformInfo(
    Image_Info InfoNative,
    out Image_Info InfoTransformed
)
Visual Basic
Protected Function TransformInfo ( _
    InfoNative As Image_Info, _
    <OutAttribute> ByRef InfoTransformed As Image_Info _
) As Image_Info
Visual C++
protected:
Image_Info^ TransformInfo(
    Image_Info^ InfoNative,
    [OutAttribute] Image_Info^% InfoTransformed
)

Parameters

InfoNative
Type: ElImage..::..Image_Info

[Missing <param name="InfoNative"/> documentation for "M:ElImage.Image.TransformInfo(ElImage.Image_Info,ElImage.Image_Info@)"]

InfoTransformed
Type: ElImage..::..Image_Info %

[Missing <param name="InfoTransformed"/> documentation for "M:ElImage.Image.TransformInfo(ElImage.Image_Info,ElImage.Image_Info@)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image.TransformInfo(ElImage.Image_Info,ElImage.Image_Info@)"]

See Also

Image Class
ElImage Namespace


Image Properties

[image] [image]

4 of William Foster's Class Libraries
Image Properties
Image Class See Also Send Feedback

The Image type exposes the following members.

Properties

 | Name | Description
Public property | stream | (Inherited from Image_Store.)

See Also

Image Class
ElImage Namespace


Image_2dArrayPixel Class

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Image_2dArrayPixel"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Image_2dArrayPixel
Visual Basic
Public Class Image_2dArrayPixel
Visual C++
public ref class Image_2dArrayPixel

Inheritance Hierarchy

System..::..Object
ElImage..::..Image_2dArrayPixel

See Also

Image_2dArrayPixel Members
ElImage Namespace


Image_2dArrayPixel Members

[image] [image]

4 of William Foster's Class Libraries
Image_2dArrayPixel Members
Image_2dArrayPixel Class Constructors Methods See Also Send Feedback

The Image_2dArrayPixel type exposes the following members.

Constructors

 | Name | Description
Public method | Image_2dArrayPixel(ColorSpace) | Initializes a new instance of the Image_2dArrayPixel class
Public method | Image_2dArrayPixel(Size2dU, ColorSpace, Allocation) | Initializes a new instance of the Image_2dArrayPixel class

Methods

 | Name | Description
Public method | Allocate |
Public method | BytesRequiredToStore |
Public method | crop |
Public method | Dup |
Public method | Enlarge |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllocation |
Public method | GetArray |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffset |
Public method | GetPixels |
Public method | GetSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetSize |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Image_2dArrayPixel Class
ElImage Namespace


Image_2dArrayPixel Constructor

[image] [image]

4 of William Foster's Class Libraries
Image_2dArrayPixel Constructor
Image_2dArrayPixel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Image_2dArrayPixel(ColorSpace) | Initializes a new instance of the Image_2dArrayPixel class
Public method | Image_2dArrayPixel(Size2dU, ColorSpace, Allocation) | Initializes a new instance of the Image_2dArrayPixel class

See Also

Image_2dArrayPixel Class
Image_2dArrayPixel Members
ElImage Namespace


Image_2dArrayPixel Constructor (ColorSpace)

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel Constructor (ColorSpace)
Image_2dArrayPixel Class See Also Send Feedback
Initializes a new instance of the Image_2dArrayPixel class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_2dArrayPixel(
    ColorSpace colorSpace
)
Visual Basic
Public Sub New ( _
    colorSpace As ColorSpace _
)
Visual C++
public:
Image_2dArrayPixel(
    ColorSpace^ colorSpace
)

Parameters

colorSpace
Type: ElImage..::..ColorSpace

[Missing <param name="colorSpace"/> documentation for "M:ElImage.Image_2dArrayPixel.#ctor(ElImage.ColorSpace)"]

See Also

Image_2dArrayPixel Class
Image_2dArrayPixel Overload
ElImage Namespace


Image_2dArrayPixel Constructor (, ColorSpace, )

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel Constructor (, ColorSpace, )
Image_2dArrayPixel Class See Also Send Feedback
Initializes a new instance of the Image_2dArrayPixel class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_2dArrayPixel(
    Size2dU size2d,
    ColorSpace colorSpace,
    Allocation DupAllocation
)
Visual Basic
Public Sub New ( _
    size2d As Size2dU, _
    colorSpace As ColorSpace, _
    DupAllocation As Allocation _
)
Visual C++
public:
Image_2dArrayPixel(
    Size2dU^ size2d,
    ColorSpace^ colorSpace,
    Allocation^ DupAllocation
)

Parameters

size2d
Type: Size2dU

[Missing <param name="size2d"/> documentation for "M:ElImage.Image_2dArrayPixel.#ctor(El.Size2dU,ElImage.ColorSpace,El.Allocation)"]

colorSpace
Type: ElImage..::..ColorSpace

[Missing <param name="colorSpace"/> documentation for "M:ElImage.Image_2dArrayPixel.#ctor(El.Size2dU,ElImage.ColorSpace,El.Allocation)"]

DupAllocation
Type: Allocation

[Missing <param name="DupAllocation"/> documentation for "M:ElImage.Image_2dArrayPixel.#ctor(El.Size2dU,ElImage.ColorSpace,El.Allocation)"]

See Also

Image_2dArrayPixel Class
Image_2dArrayPixel Overload
ElImage Namespace


Image_2dArrayPixel Methods

[image] [image]

4 of William Foster's Class Libraries
Image_2dArrayPixel Methods
Image_2dArrayPixel Class See Also Send Feedback

The Image_2dArrayPixel type exposes the following members.

Methods

 | Name | Description
Public method | Allocate |
Public method | BytesRequiredToStore |
Public method | crop |
Public method | Dup |
Public method | Enlarge |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllocation |
Public method | GetArray |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffset |
Public method | GetPixels |
Public method | GetSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetSize |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Image_2dArrayPixel Class
ElImage Namespace


Allocate Method

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel..::..Allocate Method
Image_2dArrayPixel Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_2dArrayPixel.Allocate"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Allocate()
Visual Basic
Public Sub Allocate
Visual C++
public:
void Allocate()

See Also

Image_2dArrayPixel Class
ElImage Namespace


BytesRequiredToStore Method

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel..::..BytesRequiredToStore Method
Image_2dArrayPixel Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_2dArrayPixel.BytesRequiredToStore(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint BytesRequiredToStore(
    uint u_pixelCount
)
Visual Basic
Public Function BytesRequiredToStore ( _
    u_pixelCount As UInteger _
) As UInteger
Visual C++
public:
unsigned int BytesRequiredToStore(
    unsigned int u_pixelCount
)

Parameters

u_pixelCount
Type: System..::..UInt32

[Missing <param name="u_pixelCount"/> documentation for "M:ElImage.Image_2dArrayPixel.BytesRequiredToStore(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_2dArrayPixel.BytesRequiredToStore(System.UInt32)"]

See Also

Image_2dArrayPixel Class
ElImage Namespace


crop Method

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel..::..crop Method
Image_2dArrayPixel Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_2dArrayPixel.crop(El.Rect2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool crop(
    Rect2dU chunk
)
Visual Basic
Public Function crop ( _
    chunk As Rect2dU _
) As Boolean
Visual C++
public:
bool crop(
    Rect2dU^ chunk
)

Parameters

chunk
Type: Rect2dU

[Missing <param name="chunk"/> documentation for "M:ElImage.Image_2dArrayPixel.crop(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_2dArrayPixel.crop(El.Rect2dU)"]

See Also

Image_2dArrayPixel Class
ElImage Namespace


Dup Method

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel..::..Dup Method
Image_2dArrayPixel Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_2dArrayPixel.Dup"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_2dArrayPixel Dup()
Visual Basic
Public Function Dup As Image_2dArrayPixel
Visual C++
public:
Image_2dArrayPixel^ Dup()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_2dArrayPixel.Dup"]

See Also

Image_2dArrayPixel Class
ElImage Namespace


Enlarge Method

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel..::..Enlarge Method
Image_2dArrayPixel Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_2dArrayPixel.Enlarge(El.Size2dU,El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Enlarge(
    Size2dU size,
    Size2dU newOffset
)
Visual Basic
Public Function Enlarge ( _
    size As Size2dU, _
    newOffset As Size2dU _
) As Boolean
Visual C++
public:
bool Enlarge(
    Size2dU^ size,
    Size2dU^ newOffset
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElImage.Image_2dArrayPixel.Enlarge(El.Size2dU,El.Size2dU)"]

newOffset
Type: Size2dU

[Missing <param name="newOffset"/> documentation for "M:ElImage.Image_2dArrayPixel.Enlarge(El.Size2dU,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_2dArrayPixel.Enlarge(El.Size2dU,El.Size2dU)"]

See Also

Image_2dArrayPixel Class
ElImage Namespace


GetAllocation Method

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel..::..GetAllocation Method
Image_2dArrayPixel Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_2dArrayPixel.GetAllocation"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Allocation GetAllocation()
Visual Basic
Public Function GetAllocation As Allocation
Visual C++
public:
Allocation^ GetAllocation()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_2dArrayPixel.GetAllocation"]

See Also

Image_2dArrayPixel Class
ElImage Namespace


GetArray Method

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel..::..GetArray Method
Image_2dArrayPixel Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_2dArrayPixel.GetArray(El.Size2dU,System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ArraySegment<byte> GetArray(
    Size2dU pos,
    uint count
)
Visual Basic
Public Function GetArray ( _
    pos As Size2dU, _
    count As UInteger _
) As ArraySegment(Of Byte)
Visual C++
public:
ArraySegment<unsigned char> GetArray(
    Size2dU^ pos,
    unsigned int count
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.Image_2dArrayPixel.GetArray(El.Size2dU,System.UInt32)"]

count
Type: System..::..UInt32

[Missing <param name="count"/> documentation for "M:ElImage.Image_2dArrayPixel.GetArray(El.Size2dU,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_2dArrayPixel.GetArray(El.Size2dU,System.UInt32)"]

See Also

Image_2dArrayPixel Class
ElImage Namespace


GetOffset Method

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel..::..GetOffset Method
Image_2dArrayPixel Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_2dArrayPixel.GetOffset(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public int GetOffset(
    Size2dU pos
)
Visual Basic
Public Function GetOffset ( _
    pos As Size2dU _
) As Integer
Visual C++
public:
int GetOffset(
    Size2dU^ pos
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.Image_2dArrayPixel.GetOffset(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_2dArrayPixel.GetOffset(El.Size2dU)"]

See Also

Image_2dArrayPixel Class
ElImage Namespace


GetPixels Method

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel..::..GetPixels Method
Image_2dArrayPixel Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_2dArrayPixel.GetPixels(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Pixels GetPixels(
    Size2dU pos
)
Visual Basic
Public Function GetPixels ( _
    pos As Size2dU _
) As Pixels
Visual C++
public:
Pixels^ GetPixels(
    Size2dU^ pos
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.Image_2dArrayPixel.GetPixels(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_2dArrayPixel.GetPixels(El.Size2dU)"]

See Also

Image_2dArrayPixel Class
ElImage Namespace


GetSize Method

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel..::..GetSize Method
Image_2dArrayPixel Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_2dArrayPixel.GetSize"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Size2dU GetSize()
Visual Basic
Public Function GetSize As Size2dU
Visual C++
public:
Size2dU^ GetSize()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_2dArrayPixel.GetSize"]

See Also

Image_2dArrayPixel Class
ElImage Namespace


SetSize Method

[image]

4 of William Foster's Class Libraries
Image_2dArrayPixel..::..SetSize Method
Image_2dArrayPixel Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_2dArrayPixel.SetSize(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetSize(
    Size2dU size2d
)
Visual Basic
Public Sub SetSize ( _
    size2d As Size2dU _
)
Visual C++
public:
void SetSize(
    Size2dU^ size2d
)

Parameters

size2d
Type: Size2dU

[Missing <param name="size2d"/> documentation for "M:ElImage.Image_2dArrayPixel.SetSize(El.Size2dU)"]

See Also

Image_2dArrayPixel Class
ElImage Namespace


Image_Basic Class

[image]

4 of William Foster's Class Libraries
Image_Basic Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Image_Basic"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Image_Basic : Image_Store
Visual Basic
Public Class Image_Basic _
    Inherits Image_Store
Visual C++
public ref class Image_Basic : public Image_Store

Inheritance Hierarchy

System..::..Object
ElImage..::..Image_Store
ElImage..::..Image_Basic
ElImage..::..Image

See Also

Image_Basic Members
ElImage Namespace


Image_Basic Members

[image] [image]

4 of William Foster's Class Libraries
Image_Basic Members
Image_Basic Class Constructors Methods Fields Properties See Also Send Feedback

The Image_Basic type exposes the following members.

Constructors

 | Name | Description
Public method | Image_Basic()()()() | Initializes a new instance of the Image_Basic class
Public method | Image_Basic(Stream) | Initializes a new instance of the Image_Basic class
Public method | Image_Basic(Image_Basic) | Initializes a new instance of the Image_Basic class

Methods

 | Name | Description
Public method | AddPage | (Inherited from Image_Store.)
Public method | AttachBitmap | (Inherited from Image_Store.)
Public method | AttachStream | (Inherited from Image_Store.)
Public method | ConstructBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) | (Inherited from Image_Store.)
Public method | ConstructBuffer(Image_Segment, ScriptImage) | (Inherited from Image_Store.)
Public method | CreateEmptyBuffer |
Public method | Empty | (Inherited from Image_Store.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedBuffer | (Inherited from Image_Store.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageSize | (Inherited from Image_Store.)
Public method | GetInfo_Native |
Public method | GetLayer()()()() | (Inherited from Image_Store.)
Public method | GetLayer(UInt32) | (Inherited from Image_Store.)
Public method | GetLayerNumber | (Inherited from Image_Store.)
Public method | GetPage()()()() | (Inherited from Image_Store.)
Public method | GetPage(UInt32) | (Inherited from Image_Store.)
Public method | GetPageNumber | (Inherited from Image_Store.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsModified | (Inherited from Image_Store.)
Public method | Load | (Inherited from Image_Store.)
Public method | LoadSegmentBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) | (Inherited from Image_Store.)
Public method | LoadSegmentBuffer(Image_Segment, ScriptImage) | (Inherited from Image_Store.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSelection |
Public method | PreviousSelection |
Public method | Save | (Inherited from Image_Store.)
Public method | SetBitmap | (Inherited from Image_Store.)
Public method | SetLayerNumber | (Inherited from Image_Store.)
Public method | SetModified | (Inherited from Image_Store.)
Public method | SetNative | (Inherited from Image_Store.)
Public method | SetNativeColorspace |
Public method | SetPageNumber | (Inherited from Image_Store.)
Public method | SetSegmentToEntireImage |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_b_modified | (Inherited from Image_Store.)
Protected field | m_Image_Format | (Inherited from Image_Store.)
Protected field | m_InfoNative | (Inherited from Image_Store.)
Protected field | m_Pages | (Inherited from Image_Store.)

Properties

 | Name | Description
Public property | stream | (Inherited from Image_Store.)

See Also

Image_Basic Class
ElImage Namespace


Image_Basic Constructor

[image] [image]

4 of William Foster's Class Libraries
Image_Basic Constructor
Image_Basic Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Image_Basic()()()() | Initializes a new instance of the Image_Basic class
Public method | Image_Basic(Stream) | Initializes a new instance of the Image_Basic class
Public method | Image_Basic(Image_Basic) | Initializes a new instance of the Image_Basic class

See Also

Image_Basic Class
Image_Basic Members
ElImage Namespace


Image_Basic Constructor

[image]

4 of William Foster's Class Libraries
Image_Basic Constructor
Image_Basic Class See Also Send Feedback
Initializes a new instance of the Image_Basic class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Basic()
Visual Basic
Public Sub New
Visual C++
public:
Image_Basic()

See Also

Image_Basic Class
Image_Basic Overload
ElImage Namespace


Image_Basic Constructor ()

[image]

4 of William Foster's Class Libraries
Image_Basic Constructor ()
Image_Basic Class See Also Send Feedback
Initializes a new instance of the Image_Basic class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Basic(
    Stream stream
)
Visual Basic
Public Sub New ( _
    stream As Stream _
)
Visual C++
public:
Image_Basic(
    Stream^ stream
)

Parameters

stream
Type: Stream

[Missing <param name="stream"/> documentation for "M:ElImage.Image_Basic.#ctor(El.Stream)"]

See Also

Image_Basic Class
Image_Basic Overload
ElImage Namespace


Image_Basic Constructor (Image_Basic)

[image]

4 of William Foster's Class Libraries
Image_Basic Constructor (Image_Basic)
Image_Basic Class See Also Send Feedback
Initializes a new instance of the Image_Basic class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Basic(
    Image_Basic basic
)
Visual Basic
Public Sub New ( _
    basic As Image_Basic _
)
Visual C++
public:
Image_Basic(
    Image_Basic^ basic
)

Parameters

basic
Type: ElImage..::..Image_Basic

[Missing <param name="basic"/> documentation for "M:ElImage.Image_Basic.#ctor(ElImage.Image_Basic)"]

See Also

Image_Basic Class
Image_Basic Overload
ElImage Namespace


Image_Basic Fields

[image] [image]

4 of William Foster's Class Libraries
Image_Basic Fields
Image_Basic Class See Also Send Feedback

The Image_Basic type exposes the following members.

Fields

 | Name | Description
Protected field | m_b_modified | (Inherited from Image_Store.)
Protected field | m_Image_Format | (Inherited from Image_Store.)
Protected field | m_InfoNative | (Inherited from Image_Store.)
Protected field | m_Pages | (Inherited from Image_Store.)

See Also

Image_Basic Class
ElImage Namespace


Image_Basic Methods

[image] [image]

4 of William Foster's Class Libraries
Image_Basic Methods
Image_Basic Class See Also Send Feedback

The Image_Basic type exposes the following members.

Methods

 | Name | Description
Public method | AddPage | (Inherited from Image_Store.)
Public method | AttachBitmap | (Inherited from Image_Store.)
Public method | AttachStream | (Inherited from Image_Store.)
Public method | ConstructBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) | (Inherited from Image_Store.)
Public method | ConstructBuffer(Image_Segment, ScriptImage) | (Inherited from Image_Store.)
Public method | CreateEmptyBuffer |
Public method | Empty | (Inherited from Image_Store.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedBuffer | (Inherited from Image_Store.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageSize | (Inherited from Image_Store.)
Public method | GetInfo_Native |
Public method | GetLayer()()()() | (Inherited from Image_Store.)
Public method | GetLayer(UInt32) | (Inherited from Image_Store.)
Public method | GetLayerNumber | (Inherited from Image_Store.)
Public method | GetPage()()()() | (Inherited from Image_Store.)
Public method | GetPage(UInt32) | (Inherited from Image_Store.)
Public method | GetPageNumber | (Inherited from Image_Store.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsModified | (Inherited from Image_Store.)
Public method | Load | (Inherited from Image_Store.)
Public method | LoadSegmentBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) | (Inherited from Image_Store.)
Public method | LoadSegmentBuffer(Image_Segment, ScriptImage) | (Inherited from Image_Store.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSelection |
Public method | PreviousSelection |
Public method | Save | (Inherited from Image_Store.)
Public method | SetBitmap | (Inherited from Image_Store.)
Public method | SetLayerNumber | (Inherited from Image_Store.)
Public method | SetModified | (Inherited from Image_Store.)
Public method | SetNative | (Inherited from Image_Store.)
Public method | SetNativeColorspace |
Public method | SetPageNumber | (Inherited from Image_Store.)
Public method | SetSegmentToEntireImage |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Image_Basic Class
ElImage Namespace


ConstructBuffer Method

[image] [image]

4 of William Foster's Class Libraries
Image_Basic..::..ConstructBuffer Method
Image_Basic Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConstructBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) | (Inherited from Image_Store.)
Public method | ConstructBuffer(Image_Segment, ScriptImage) | (Inherited from Image_Store.)

See Also

Image_Basic Class
Image_Basic Members
ElImage Namespace


CreateEmptyBuffer Method

[image]

4 of William Foster's Class Libraries
Image_Basic..::..CreateEmptyBuffer Method
Image_Basic Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Basic.CreateEmptyBuffer(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool CreateEmptyBuffer(
    Size2dU size
)
Visual Basic
Public Function CreateEmptyBuffer ( _
    size As Size2dU _
) As Boolean
Visual C++
public:
bool CreateEmptyBuffer(
    Size2dU^ size
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElImage.Image_Basic.CreateEmptyBuffer(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Basic.CreateEmptyBuffer(El.Size2dU)"]

See Also

Image_Basic Class
ElImage Namespace


GetInfo_Native Method

[image]

4 of William Foster's Class Libraries
Image_Basic..::..GetInfo_Native Method
Image_Basic Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Basic.GetInfo_Native"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Info GetInfo_Native()
Visual Basic
Public Function GetInfo_Native As Image_Info
Visual C++
public:
Image_Info^ GetInfo_Native()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Basic.GetInfo_Native"]

See Also

Image_Basic Class
ElImage Namespace


GetLayer Method

[image] [image]

4 of William Foster's Class Libraries
Image_Basic..::..GetLayer Method
Image_Basic Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLayer()()()() | (Inherited from Image_Store.)
Public method | GetLayer(UInt32) | (Inherited from Image_Store.)

See Also

Image_Basic Class
Image_Basic Members
ElImage Namespace


GetPage Method

[image] [image]

4 of William Foster's Class Libraries
Image_Basic..::..GetPage Method
Image_Basic Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPage()()()() | (Inherited from Image_Store.)
Public method | GetPage(UInt32) | (Inherited from Image_Store.)

See Also

Image_Basic Class
Image_Basic Members
ElImage Namespace


LoadSegmentBuffer Method

[image] [image]

4 of William Foster's Class Libraries
Image_Basic..::..LoadSegmentBuffer Method
Image_Basic Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadSegmentBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) | (Inherited from Image_Store.)
Public method | LoadSegmentBuffer(Image_Segment, ScriptImage) | (Inherited from Image_Store.)

See Also

Image_Basic Class
Image_Basic Members
ElImage Namespace


NextSelection Method

[image]

4 of William Foster's Class Libraries
Image_Basic..::..NextSelection Method
Image_Basic Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Basic.NextSelection"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual bool NextSelection()
Visual Basic
Public Overridable Function NextSelection As Boolean
Visual C++
public:
virtual bool NextSelection()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Basic.NextSelection"]

See Also

Image_Basic Class
ElImage Namespace


PreviousSelection Method

[image]

4 of William Foster's Class Libraries
Image_Basic..::..PreviousSelection Method
Image_Basic Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Basic.PreviousSelection"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual bool PreviousSelection()
Visual Basic
Public Overridable Function PreviousSelection As Boolean
Visual C++
public:
virtual bool PreviousSelection()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Basic.PreviousSelection"]

See Also

Image_Basic Class
ElImage Namespace


SetNativeColorspace Method

[image]

4 of William Foster's Class Libraries
Image_Basic..::..SetNativeColorspace Method
Image_Basic Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Basic.SetNativeColorspace(ElImage.ColorSpace)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetNativeColorspace(
    ColorSpace cspace
)
Visual Basic
Public Sub SetNativeColorspace ( _
    cspace As ColorSpace _
)
Visual C++
public:
void SetNativeColorspace(
    ColorSpace^ cspace
)

Parameters

cspace
Type: ElImage..::..ColorSpace

[Missing <param name="cspace"/> documentation for "M:ElImage.Image_Basic.SetNativeColorspace(ElImage.ColorSpace)"]

See Also

Image_Basic Class
ElImage Namespace


SetSegmentToEntireImage Method

[image]

4 of William Foster's Class Libraries
Image_Basic..::..SetSegmentToEntireImage Method
Image_Basic Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Basic.SetSegmentToEntireImage(ElImage.Image_Segment@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual void SetSegmentToEntireImage(
    out Image_Segment seg
)
Visual Basic
Public Overridable Sub SetSegmentToEntireImage ( _
    <OutAttribute> ByRef seg As Image_Segment _
)
Visual C++
public:
virtual void SetSegmentToEntireImage(
    [OutAttribute] Image_Segment^% seg
)

Parameters

seg
Type: ElImage..::..Image_Segment %

[Missing <param name="seg"/> documentation for "M:ElImage.Image_Basic.SetSegmentToEntireImage(ElImage.Image_Segment@)"]

See Also

Image_Basic Class
ElImage Namespace


Image_Basic Properties

[image] [image]

4 of William Foster's Class Libraries
Image_Basic Properties
Image_Basic Class See Also Send Feedback

The Image_Basic type exposes the following members.

Properties

 | Name | Description
Public property | stream | (Inherited from Image_Store.)

See Also

Image_Basic Class
ElImage Namespace


Image_Buffer Class

[image]

4 of William Foster's Class Libraries
Image_Buffer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Image_Buffer"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Image_Buffer
Visual Basic
Public Class Image_Buffer
Visual C++
public ref class Image_Buffer

Inheritance Hierarchy

System..::..Object
ElImage..::..Image_Buffer

See Also

Image_Buffer Members
ElImage Namespace


Image_Buffer Members

[image] [image]

4 of William Foster's Class Libraries
Image_Buffer Members
Image_Buffer Class Constructors Methods Fields See Also Send Feedback

The Image_Buffer type exposes the following members.

Constructors

 | Name | Description
Public method | Image_Buffer(Image_Buffer) | Initializes a new instance of the Image_Buffer class
Public method | Image_Buffer(Image_Info) | Initializes a new instance of the Image_Buffer class

Methods

 | Name | Description
Protected method | AddLayeredBitmap |
Public method | AllocateRectangle |
Public method | ApplyEffects |
Public method | ConstructBuffer |
Public method | EmptyLayer |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBitmap |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSegment |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadBuffer |
Public method | LookupBitmap |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBitmap |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TranslateSegment_To_PixelRectangle |

Fields

Name | Description
ALL_LAYERS |

See Also

Image_Buffer Class
ElImage Namespace


Image_Buffer Constructor

[image] [image]

4 of William Foster's Class Libraries
Image_Buffer Constructor
Image_Buffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Image_Buffer(Image_Buffer) | Initializes a new instance of the Image_Buffer class
Public method | Image_Buffer(Image_Info) | Initializes a new instance of the Image_Buffer class

See Also

Image_Buffer Class
Image_Buffer Members
ElImage Namespace


Image_Buffer Constructor (Image_Buffer)

[image]

4 of William Foster's Class Libraries
Image_Buffer Constructor (Image_Buffer)
Image_Buffer Class See Also Send Feedback
Initializes a new instance of the Image_Buffer class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Buffer(
    Image_Buffer duper
)
Visual Basic
Public Sub New ( _
    duper As Image_Buffer _
)
Visual C++
public:
Image_Buffer(
    Image_Buffer^ duper
)

Parameters

duper
Type: ElImage..::..Image_Buffer

[Missing <param name="duper"/> documentation for "M:ElImage.Image_Buffer.#ctor(ElImage.Image_Buffer)"]

See Also

Image_Buffer Class
Image_Buffer Overload
ElImage Namespace


Image_Buffer Constructor (Image_Info)

[image]

4 of William Foster's Class Libraries
Image_Buffer Constructor (Image_Info)
Image_Buffer Class See Also Send Feedback
Initializes a new instance of the Image_Buffer class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Buffer(
    Image_Info imageInfo
)
Visual Basic
Public Sub New ( _
    imageInfo As Image_Info _
)
Visual C++
public:
Image_Buffer(
    Image_Info^ imageInfo
)

Parameters

imageInfo
Type: ElImage..::..Image_Info

[Missing <param name="imageInfo"/> documentation for "M:ElImage.Image_Buffer.#ctor(ElImage.Image_Info)"]

See Also

Image_Buffer Class
Image_Buffer Overload
ElImage Namespace


Image_Buffer Fields

[image] [image]

4 of William Foster's Class Libraries
Image_Buffer Fields
Image_Buffer Class See Also Send Feedback

The Image_Buffer type exposes the following members.

Fields

Name | Description
ALL_LAYERS |

See Also

Image_Buffer Class
ElImage Namespace


ALL_LAYERS Field

[image]

4 of William Foster's Class Libraries
Image_Buffer..::..ALL_LAYERS Field
Image_Buffer Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Image_Buffer.ALL_LAYERS"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public const uint ALL_LAYERS
Visual Basic
Public Const ALL_LAYERS As UInteger
Visual C++
public:
literal unsigned int ALL_LAYERS

See Also

Image_Buffer Class
ElImage Namespace


Image_Buffer Methods

[image] [image]

4 of William Foster's Class Libraries
Image_Buffer Methods
Image_Buffer Class See Also Send Feedback

The Image_Buffer type exposes the following members.

Methods

 | Name | Description
Protected method | AddLayeredBitmap |
Public method | AllocateRectangle |
Public method | ApplyEffects |
Public method | ConstructBuffer |
Public method | EmptyLayer |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBitmap |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSegment |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadBuffer |
Public method | LookupBitmap |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetBitmap |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TranslateSegment_To_PixelRectangle |

See Also

Image_Buffer Class
ElImage Namespace


AddLayeredBitmap Method

[image]

4 of William Foster's Class Libraries
Image_Buffer..::..AddLayeredBitmap Method
Image_Buffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Buffer.AddLayeredBitmap"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected Bitmap AddLayeredBitmap()
Visual Basic
Protected Function AddLayeredBitmap As Bitmap
Visual C++
protected:
Bitmap^ AddLayeredBitmap()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Buffer.AddLayeredBitmap"]

See Also

Image_Buffer Class
ElImage Namespace


AllocateRectangle Method

[image]

4 of William Foster's Class Libraries
Image_Buffer..::..AllocateRectangle Method
Image_Buffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Buffer.AllocateRectangle(El.Rect2dU,System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap AllocateRectangle(
    Rect2dU rect,
    uint uLayer
)
Visual Basic
Public Function AllocateRectangle ( _
    rect As Rect2dU, _
    uLayer As UInteger _
) As Bitmap
Visual C++
public:
Bitmap^ AllocateRectangle(
    Rect2dU^ rect,
    unsigned int uLayer
)

Parameters

rect
Type: Rect2dU

[Missing <param name="rect"/> documentation for "M:ElImage.Image_Buffer.AllocateRectangle(El.Rect2dU,System.UInt32)"]

uLayer
Type: System..::..UInt32

[Missing <param name="uLayer"/> documentation for "M:ElImage.Image_Buffer.AllocateRectangle(El.Rect2dU,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Buffer.AllocateRectangle(El.Rect2dU,System.UInt32)"]

See Also

Image_Buffer Class
ElImage Namespace


ApplyEffects Method

[image]

4 of William Foster's Class Libraries
Image_Buffer..::..ApplyEffects Method
Image_Buffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Buffer.ApplyEffects(El.Array{ElImage.Image_Effect})"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool ApplyEffects(
    Array<Image_Effect> effects
)
Visual Basic
Public Function ApplyEffects ( _
    effects As Array(Of Image_Effect) _
) As Boolean
Visual C++
public:
bool ApplyEffects(
    Array<Image_Effect^>^ effects
)

Parameters

effects
Type: Array<(Of <(<' Image_Effect >)>)>

[Missing <param name="effects"/> documentation for "M:ElImage.Image_Buffer.ApplyEffects(El.Array{ElImage.Image_Effect})"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Buffer.ApplyEffects(El.Array{ElImage.Image_Effect})"]

See Also

Image_Buffer Class
ElImage Namespace


ConstructBuffer Method

[image]

4 of William Foster's Class Libraries
Image_Buffer..::..ConstructBuffer Method
Image_Buffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Buffer.ConstructBuffer(ElImage.Image_Segment)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Buffer ConstructBuffer(
    Image_Segment segment
)
Visual Basic
Public Function ConstructBuffer ( _
    segment As Image_Segment _
) As Image_Buffer
Visual C++
public:
Image_Buffer^ ConstructBuffer(
    Image_Segment^ segment
)

Parameters

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Image_Buffer.ConstructBuffer(ElImage.Image_Segment)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Buffer.ConstructBuffer(ElImage.Image_Segment)"]

See Also

Image_Buffer Class
ElImage Namespace


EmptyLayer Method

[image]

4 of William Foster's Class Libraries
Image_Buffer..::..EmptyLayer Method
Image_Buffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Buffer.EmptyLayer(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint EmptyLayer(
    uint uLayer
)
Visual Basic
Public Function EmptyLayer ( _
    uLayer As UInteger _
) As UInteger
Visual C++
public:
unsigned int EmptyLayer(
    unsigned int uLayer
)

Parameters

uLayer
Type: System..::..UInt32

[Missing <param name="uLayer"/> documentation for "M:ElImage.Image_Buffer.EmptyLayer(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Buffer.EmptyLayer(System.UInt32)"]

See Also

Image_Buffer Class
ElImage Namespace


GetBitmap Method

[image]

4 of William Foster's Class Libraries
Image_Buffer..::..GetBitmap Method
Image_Buffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Buffer.GetBitmap(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap GetBitmap(
    uint uLayer
)
Visual Basic
Public Function GetBitmap ( _
    uLayer As UInteger _
) As Bitmap
Visual C++
public:
Bitmap^ GetBitmap(
    unsigned int uLayer
)

Parameters

uLayer
Type: System..::..UInt32

[Missing <param name="uLayer"/> documentation for "M:ElImage.Image_Buffer.GetBitmap(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Buffer.GetBitmap(System.UInt32)"]

See Also

Image_Buffer Class
ElImage Namespace


GetSegment Method

[image]

4 of William Foster's Class Libraries
Image_Buffer..::..GetSegment Method
Image_Buffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Buffer.GetSegment"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Segment GetSegment()
Visual Basic
Public Function GetSegment As Image_Segment
Visual C++
public:
Image_Segment^ GetSegment()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Buffer.GetSegment"]

See Also

Image_Buffer Class
ElImage Namespace


LoadBuffer Method

[image]

4 of William Foster's Class Libraries
Image_Buffer..::..LoadBuffer Method
Image_Buffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Buffer.LoadBuffer(ElImage.Image_Store,ElImage.Image_Format,ElImage.Image_Segment)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool LoadBuffer(
    Image_Store store,
    Image_Format Loader,
    Image_Segment segment
)
Visual Basic
Public Function LoadBuffer ( _
    store As Image_Store, _
    Loader As Image_Format, _
    segment As Image_Segment _
) As Boolean
Visual C++
public:
bool LoadBuffer(
    Image_Store^ store,
    Image_Format^ Loader,
    Image_Segment^ segment
)

Parameters

store
Type: ElImage..::..Image_Store

[Missing <param name="store"/> documentation for "M:ElImage.Image_Buffer.LoadBuffer(ElImage.Image_Store,ElImage.Image_Format,ElImage.Image_Segment)"]

Loader
Type: ElImage..::..Image_Format

[Missing <param name="Loader"/> documentation for "M:ElImage.Image_Buffer.LoadBuffer(ElImage.Image_Store,ElImage.Image_Format,ElImage.Image_Segment)"]

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Image_Buffer.LoadBuffer(ElImage.Image_Store,ElImage.Image_Format,ElImage.Image_Segment)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Buffer.LoadBuffer(ElImage.Image_Store,ElImage.Image_Format,ElImage.Image_Segment)"]

See Also

Image_Buffer Class
ElImage Namespace


LookupBitmap Method

[image]

4 of William Foster's Class Libraries
Image_Buffer..::..LookupBitmap Method
Image_Buffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Buffer.LookupBitmap(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public int LookupBitmap(
    uint uLayer
)
Visual Basic
Public Function LookupBitmap ( _
    uLayer As UInteger _
) As Integer
Visual C++
public:
int LookupBitmap(
    unsigned int uLayer
)

Parameters

uLayer
Type: System..::..UInt32

[Missing <param name="uLayer"/> documentation for "M:ElImage.Image_Buffer.LookupBitmap(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Buffer.LookupBitmap(System.UInt32)"]

See Also

Image_Buffer Class
ElImage Namespace


SetBitmap Method

[image]

4 of William Foster's Class Libraries
Image_Buffer..::..SetBitmap Method
Image_Buffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Buffer.SetBitmap(ElImage.Bitmap,ElImage.Image_Segment)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetBitmap(
    Bitmap Bmp,
    Image_Segment segment
)
Visual Basic
Public Sub SetBitmap ( _
    Bmp As Bitmap, _
    segment As Image_Segment _
)
Visual C++
public:
void SetBitmap(
    Bitmap^ Bmp,
    Image_Segment^ segment
)

Parameters

Bmp
Type: ElImage..::..Bitmap

[Missing <param name="Bmp"/> documentation for "M:ElImage.Image_Buffer.SetBitmap(ElImage.Bitmap,ElImage.Image_Segment)"]

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Image_Buffer.SetBitmap(ElImage.Bitmap,ElImage.Image_Segment)"]

See Also

Image_Buffer Class
ElImage Namespace


TranslateSegment_To_PixelRectangle Method

[image]

4 of William Foster's Class Libraries
Image_Buffer..::..TranslateSegment_To_PixelRectangle Method
Image_Buffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Buffer.TranslateSegment_To_PixelRectangle(ElImage.Image_Store,ElImage.Image_Segment,El.Rect2dU@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected bool TranslateSegment_To_PixelRectangle(
    Image_Store store,
    Image_Segment segment,
    out Rect2dU rect
)
Visual Basic
Protected Function TranslateSegment_To_PixelRectangle ( _
    store As Image_Store, _
    segment As Image_Segment, _
    <OutAttribute> ByRef rect As Rect2dU _
) As Boolean
Visual C++
protected:
bool TranslateSegment_To_PixelRectangle(
    Image_Store^ store,
    Image_Segment^ segment,
    [OutAttribute] Rect2dU^% rect
)

Parameters

store
Type: ElImage..::..Image_Store

[Missing <param name="store"/> documentation for "M:ElImage.Image_Buffer.TranslateSegment_To_PixelRectangle(ElImage.Image_Store,ElImage.Image_Segment,El.Rect2dU@)"]

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Image_Buffer.TranslateSegment_To_PixelRectangle(ElImage.Image_Store,ElImage.Image_Segment,El.Rect2dU@)"]

rect
Type: Rect2dU%

[Missing <param name="rect"/> documentation for "M:ElImage.Image_Buffer.TranslateSegment_To_PixelRectangle(ElImage.Image_Store,ElImage.Image_Segment,El.Rect2dU@)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Buffer.TranslateSegment_To_PixelRectangle(ElImage.Image_Store,ElImage.Image_Segment,El.Rect2dU@)"]

See Also

Image_Buffer Class
ElImage Namespace


Image_Chunker Class

[image]

4 of William Foster's Class Libraries
Image_Chunker Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Image_Chunker"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Image_Chunker
Visual Basic
Public Class Image_Chunker
Visual C++
public ref class Image_Chunker

Inheritance Hierarchy

System..::..Object
ElImage..::..Image_Chunker

See Also

Image_Chunker Members
ElImage Namespace


Image_Chunker Members

[image] [image]

4 of William Foster's Class Libraries
Image_Chunker Members
Image_Chunker Class Constructors Methods See Also Send Feedback

The Image_Chunker type exposes the following members.

Constructors

 | Name | Description
Public method | Image_Chunker | Initializes a new instance of the Image_Chunker class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IterateNextChunk |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetChunkSize |
Public method | StartIteratingChunks |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Image_Chunker Class
ElImage Namespace


Image_Chunker Constructor

[image]

4 of William Foster's Class Libraries
Image_Chunker Constructor
Image_Chunker Class See Also Send Feedback
Initializes a new instance of the Image_Chunker class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Chunker(
    Image_Buffer imageBuffer,
    bool b_EdgeChunksLarger
)
Visual Basic
Public Sub New ( _
    imageBuffer As Image_Buffer, _
    b_EdgeChunksLarger As Boolean _
)
Visual C++
public:
Image_Chunker(
    Image_Buffer^ imageBuffer,
    bool b_EdgeChunksLarger
)

Parameters

imageBuffer
Type: ElImage..::..Image_Buffer

[Missing <param name="imageBuffer"/> documentation for "M:ElImage.Image_Chunker.#ctor(ElImage.Image_Buffer,System.Boolean)"]

b_EdgeChunksLarger
Type: System..::..Boolean

[Missing <param name="b_EdgeChunksLarger"/> documentation for "M:ElImage.Image_Chunker.#ctor(ElImage.Image_Buffer,System.Boolean)"]

See Also

Image_Chunker Class
ElImage Namespace


Image_Chunker Methods

[image] [image]

4 of William Foster's Class Libraries
Image_Chunker Methods
Image_Chunker Class See Also Send Feedback

The Image_Chunker type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IterateNextChunk |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetChunkSize |
Public method | StartIteratingChunks |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Image_Chunker Class
ElImage Namespace


IterateNextChunk Method

[image]

4 of William Foster's Class Libraries
Image_Chunker..::..IterateNextChunk Method
Image_Chunker Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Chunker.IterateNextChunk(El.Rect2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint IterateNextChunk(
    Rect2dU NextRect
)
Visual Basic
Public Function IterateNextChunk ( _
    NextRect As Rect2dU _
) As UInteger
Visual C++
public:
unsigned int IterateNextChunk(
    Rect2dU^ NextRect
)

Parameters

NextRect
Type: Rect2dU

[Missing <param name="NextRect"/> documentation for "M:ElImage.Image_Chunker.IterateNextChunk(El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Chunker.IterateNextChunk(El.Rect2dU)"]

See Also

Image_Chunker Class
ElImage Namespace


Set Method

[image]

4 of William Foster's Class Libraries
Image_Chunker..::..Set Method
Image_Chunker Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Chunker.Set(ElImage.Image_Buffer)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Set(
    Image_Buffer imageBuffer
)
Visual Basic
Public Function Set ( _
    imageBuffer As Image_Buffer _
) As Boolean
Visual C++
public:
bool Set(
    Image_Buffer^ imageBuffer
)

Parameters

imageBuffer
Type: ElImage..::..Image_Buffer

[Missing <param name="imageBuffer"/> documentation for "M:ElImage.Image_Chunker.Set(ElImage.Image_Buffer)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Chunker.Set(ElImage.Image_Buffer)"]

See Also

Image_Chunker Class
ElImage Namespace


SetChunkSize Method

[image]

4 of William Foster's Class Libraries
Image_Chunker..::..SetChunkSize Method
Image_Chunker Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Chunker.SetChunkSize(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Size2dU SetChunkSize(
    Size2dU region
)
Visual Basic
Public Function SetChunkSize ( _
    region As Size2dU _
) As Size2dU
Visual C++
public:
Size2dU^ SetChunkSize(
    Size2dU^ region
)

Parameters

region
Type: Size2dU

[Missing <param name="region"/> documentation for "M:ElImage.Image_Chunker.SetChunkSize(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Chunker.SetChunkSize(El.Size2dU)"]

See Also

Image_Chunker Class
ElImage Namespace


StartIteratingChunks Method

[image]

4 of William Foster's Class Libraries
Image_Chunker..::..StartIteratingChunks Method
Image_Chunker Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Chunker.StartIteratingChunks"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool StartIteratingChunks()
Visual Basic
Public Function StartIteratingChunks As Boolean
Visual C++
public:
bool StartIteratingChunks()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Chunker.StartIteratingChunks"]

See Also

Image_Chunker Class
ElImage Namespace


Image_Effect Interface

[image]

4 of William Foster's Class Libraries
Image_Effect Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Image_Effect"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public interface Image_Effect
Visual Basic
Public Interface Image_Effect
Visual C++
public interface class Image_Effect

See Also

Image_Effect Members
ElImage Namespace


Image_Effect Members

[image] [image]

4 of William Foster's Class Libraries
Image_Effect Members
Image_Effect Interface Methods See Also Send Feedback

The Image_Effect type exposes the following members.

Methods

 | Name | Description
Public method | ApplyToBuffer |

See Also

Image_Effect Interface
ElImage Namespace


Image_Effect Methods

[image] [image]

4 of William Foster's Class Libraries
Image_Effect Methods
Image_Effect Interface See Also Send Feedback

The Image_Effect type exposes the following members.

Methods

 | Name | Description
Public method | ApplyToBuffer |

See Also

Image_Effect Interface
ElImage Namespace


ApplyToBuffer Method

[image]

4 of William Foster's Class Libraries
Image_Effect..::..ApplyToBuffer Method
Image_Effect Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Effect.ApplyToBuffer(ElImage.Image_Buffer)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
bool ApplyToBuffer(
    Image_Buffer buffer
)
Visual Basic
Function ApplyToBuffer ( _
    buffer As Image_Buffer _
) As Boolean
Visual C++
bool ApplyToBuffer(
    Image_Buffer^ buffer
)

Parameters

buffer
Type: ElImage..::..Image_Buffer

[Missing <param name="buffer"/> documentation for "M:ElImage.Image_Effect.ApplyToBuffer(ElImage.Image_Buffer)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Effect.ApplyToBuffer(ElImage.Image_Buffer)"]

See Also

Image_Effect Interface
ElImage Namespace


Image_Format Class

[image]

4 of William Foster's Class Libraries
Image_Format Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Image_Format"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public abstract class Image_Format : Stream
Visual Basic
Public MustInherit Class Image_Format _
    Inherits Stream
Visual C++
public ref class Image_Format abstract : public Stream

Inheritance Hierarchy

System..::..Object
Stream
ElImage..::..Image_Format
ElImage..::..Image_Format_SysImage

See Also

Image_Format Members
ElImage Namespace


Image_Format Members

[image] [image]

4 of William Foster's Class Libraries
Image_Format Members
Image_Format Class Constructors Methods Fields Properties See Also Send Feedback

The Image_Format type exposes the following members.

Constructors

 | Name | Description
Public method | Image_Format | Initializes a new instance of the Image_Format class

Methods

 | Name | Description
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | Close | (Inherited from Stream.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Stream.)
Public method | Flush | (Inherited from Stream.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttached | (Inherited from Stream.)
Public method | LoadHeader |
Public method | LoadRectangle |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttach | (Inherited from Stream.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | Rewind | (Inherited from Stream.)
Public method | SaveBitmap |
Public method | SaveBuffer |
Public method | SavePage |
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Stream.)
Public method | Set | (Inherited from Stream.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | Tell | (Inherited from Stream.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write(STRING) | (Inherited from Stream.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

Fields

 | Name | Description
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Image_Format Class
ElImage Namespace


Image_Format Constructor

[image]

4 of William Foster's Class Libraries
Image_Format Constructor
Image_Format Class See Also Send Feedback
Initializes a new instance of the Image_Format class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Format(
    Stream Stream
)
Visual Basic
Public Sub New ( _
    Stream As Stream _
)
Visual C++
public:
Image_Format(
    Stream^ Stream
)

Parameters

Stream
Type: Stream

[Missing <param name="Stream"/> documentation for "M:ElImage.Image_Format.#ctor(El.Stream)"]

See Also

Image_Format Class
ElImage Namespace


Image_Format Fields

[image] [image]

4 of William Foster's Class Libraries
Image_Format Fields
Image_Format Class See Also Send Feedback

The Image_Format type exposes the following members.

Fields

 | Name | Description
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)

See Also

Image_Format Class
ElImage Namespace


Image_Format Methods

[image] [image]

4 of William Foster's Class Libraries
Image_Format Methods
Image_Format Class See Also Send Feedback

The Image_Format type exposes the following members.

Methods

 | Name | Description
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | Close | (Inherited from Stream.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Stream.)
Public method | Flush | (Inherited from Stream.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttached | (Inherited from Stream.)
Public method | LoadHeader |
Public method | LoadRectangle |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttach | (Inherited from Stream.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | Rewind | (Inherited from Stream.)
Public method | SaveBitmap |
Public method | SaveBuffer |
Public method | SavePage |
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Stream.)
Public method | Set | (Inherited from Stream.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | Tell | (Inherited from Stream.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write(STRING) | (Inherited from Stream.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

Image_Format Class
ElImage Namespace


AttachFile Method

[image] [image]

4 of William Foster's Class Libraries
Image_Format..::..AttachFile Method
Image_Format Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)

See Also

Image_Format Class
Image_Format Members
ElImage Namespace


AttachMemory Method

[image] [image]

4 of William Foster's Class Libraries
Image_Format..::..AttachMemory Method
Image_Format Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)

See Also

Image_Format Class
Image_Format Members
ElImage Namespace


LoadHeader Method

[image]

4 of William Foster's Class Libraries
Image_Format..::..LoadHeader Method
Image_Format Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Format.LoadHeader(ElImage.Image_Info@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public abstract bool LoadHeader(
    out Image_Info info
)
Visual Basic
Public MustOverride Function LoadHeader ( _
    <OutAttribute> ByRef info As Image_Info _
) As Boolean
Visual C++
public:
virtual bool LoadHeader(
    [OutAttribute] Image_Info^% info
) abstract

Parameters

info
Type: ElImage..::..Image_Info %

[Missing <param name="info"/> documentation for "M:ElImage.Image_Format.LoadHeader(ElImage.Image_Info@)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Format.LoadHeader(ElImage.Image_Info@)"]

See Also

Image_Format Class
ElImage Namespace


LoadRectangle Method

[image]

4 of William Foster's Class Libraries
Image_Format..::..LoadRectangle Method
Image_Format Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Format.LoadRectangle(El.Rect2dU,ElImage.Bitmap@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public abstract bool LoadRectangle(
    Rect2dU rect2d_Load,
    out Bitmap bfc_bitmap
)
Visual Basic
Public MustOverride Function LoadRectangle ( _
    rect2d_Load As Rect2dU, _
    <OutAttribute> ByRef bfc_bitmap As Bitmap _
) As Boolean
Visual C++
public:
virtual bool LoadRectangle(
    Rect2dU^ rect2d_Load,
    [OutAttribute] Bitmap^% bfc_bitmap
) abstract

Parameters

rect2d_Load
Type: Rect2dU

[Missing <param name="rect2d_Load"/> documentation for "M:ElImage.Image_Format.LoadRectangle(El.Rect2dU,ElImage.Bitmap@)"]

bfc_bitmap
Type: ElImage..::..Bitmap %

[Missing <param name="bfc_bitmap"/> documentation for "M:ElImage.Image_Format.LoadRectangle(El.Rect2dU,ElImage.Bitmap@)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Format.LoadRectangle(El.Rect2dU,ElImage.Bitmap@)"]

See Also

Image_Format Class
ElImage Namespace


SaveBitmap Method

[image]

4 of William Foster's Class Libraries
Image_Format..::..SaveBitmap Method
Image_Format Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Format.SaveBitmap(ElImage.Bitmap)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public abstract bool SaveBitmap(
    Bitmap bmp
)
Visual Basic
Public MustOverride Function SaveBitmap ( _
    bmp As Bitmap _
) As Boolean
Visual C++
public:
virtual bool SaveBitmap(
    Bitmap^ bmp
) abstract

Parameters

bmp
Type: ElImage..::..Bitmap

[Missing <param name="bmp"/> documentation for "M:ElImage.Image_Format.SaveBitmap(ElImage.Bitmap)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Format.SaveBitmap(ElImage.Bitmap)"]

See Also

Image_Format Class
ElImage Namespace


SaveBuffer Method

[image]

4 of William Foster's Class Libraries
Image_Format..::..SaveBuffer Method
Image_Format Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Format.SaveBuffer(ElImage.Image_Buffer)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool SaveBuffer(
    Image_Buffer buffer
)
Visual Basic
Public Function SaveBuffer ( _
    buffer As Image_Buffer _
) As Boolean
Visual C++
public:
bool SaveBuffer(
    Image_Buffer^ buffer
)

Parameters

buffer
Type: ElImage..::..Image_Buffer

[Missing <param name="buffer"/> documentation for "M:ElImage.Image_Format.SaveBuffer(ElImage.Image_Buffer)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Format.SaveBuffer(ElImage.Image_Buffer)"]

See Also

Image_Format Class
ElImage Namespace


SavePage Method

[image]

4 of William Foster's Class Libraries
Image_Format..::..SavePage Method
Image_Format Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Format.SavePage(System.Int32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual bool SavePage(
    int pageno
)
Visual Basic
Public Overridable Function SavePage ( _
    pageno As Integer _
) As Boolean
Visual C++
public:
virtual bool SavePage(
    int pageno
)

Parameters

pageno
Type: System..::..Int32

[Missing <param name="pageno"/> documentation for "M:ElImage.Image_Format.SavePage(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Format.SavePage(System.Int32)"]

See Also

Image_Format Class
ElImage Namespace


Seek Method

[image] [image]

4 of William Foster's Class Libraries
Image_Format..::..Seek Method
Image_Format Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Stream.)

See Also

Image_Format Class
Image_Format Members
ElImage Namespace


Write Method

[image] [image]

4 of William Foster's Class Libraries
Image_Format..::..Write Method
Image_Format Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(STRING) | (Inherited from Stream.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

Image_Format Class
Image_Format Members
ElImage Namespace


Image_Format Properties

[image] [image]

4 of William Foster's Class Libraries
Image_Format Properties
Image_Format Class See Also Send Feedback

The Image_Format type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Image_Format Class
ElImage Namespace


Image_Format_SysImage Class

[image]

4 of William Foster's Class Libraries
Image_Format_SysImage Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Image_Format_SysImage"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Image_Format_SysImage : Image_Format
Visual Basic
Public Class Image_Format_SysImage _
    Inherits Image_Format
Visual C++
public ref class Image_Format_SysImage : public Image_Format

Inheritance Hierarchy

System..::..Object
Stream
ElImage..::..Image_Format
ElImage..::..Image_Format_SysImage

See Also

Image_Format_SysImage Members
ElImage Namespace


Image_Format_SysImage Members

[image] [image]

4 of William Foster's Class Libraries
Image_Format_SysImage Members
Image_Format_SysImage Class Constructors Methods Fields Properties See Also Send Feedback

The Image_Format_SysImage type exposes the following members.

Constructors

 | Name | Description
Public method | Image_Format_SysImage | Initializes a new instance of the Image_Format_SysImage class

Methods

 | Name | Description
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | Close | (Inherited from Stream.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Stream.)
Public method | Flush | (Inherited from Stream.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttached | (Inherited from Stream.)
Public method | LoadHeader | (Overrides Image_Format..::..LoadHeader(Image_Info%).)
Public method | LoadRectangle | (Overrides Image_Format..::..LoadRectangle(Rect2dU, Bitmap%).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttach | (Inherited from Stream.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | Rewind | (Inherited from Stream.)
Public method | SaveBitmap | (Overrides Image_Format..::..SaveBitmap(Bitmap).)
Public method | SaveBuffer | (Inherited from Image_Format.)
Public method | SavePage | (Inherited from Image_Format.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Stream.)
Public method | Set | (Inherited from Stream.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | Tell | (Inherited from Stream.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write(STRING) | (Inherited from Stream.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

Fields

 | Name | Description
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Image_Format_SysImage Class
ElImage Namespace


Image_Format_SysImage Constructor

[image]

4 of William Foster's Class Libraries
Image_Format_SysImage Constructor
Image_Format_SysImage Class See Also Send Feedback
Initializes a new instance of the Image_Format_SysImage class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Format_SysImage(
    Stream stream
)
Visual Basic
Public Sub New ( _
    stream As Stream _
)
Visual C++
public:
Image_Format_SysImage(
    Stream^ stream
)

Parameters

stream
Type: Stream

[Missing <param name="stream"/> documentation for "M:ElImage.Image_Format_SysImage.#ctor(El.Stream)"]

See Also

Image_Format_SysImage Class
ElImage Namespace


Image_Format_SysImage Fields

[image] [image]

4 of William Foster's Class Libraries
Image_Format_SysImage Fields
Image_Format_SysImage Class See Also Send Feedback

The Image_Format_SysImage type exposes the following members.

Fields

 | Name | Description
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)

See Also

Image_Format_SysImage Class
ElImage Namespace


Image_Format_SysImage Methods

[image] [image]

4 of William Foster's Class Libraries
Image_Format_SysImage Methods
Image_Format_SysImage Class See Also Send Feedback

The Image_Format_SysImage type exposes the following members.

Methods

 | Name | Description
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | Close | (Inherited from Stream.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Stream.)
Public method | Flush | (Inherited from Stream.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttached | (Inherited from Stream.)
Public method | LoadHeader | (Overrides Image_Format..::..LoadHeader(Image_Info%).)
Public method | LoadRectangle | (Overrides Image_Format..::..LoadRectangle(Rect2dU, Bitmap%).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttach | (Inherited from Stream.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | Rewind | (Inherited from Stream.)
Public method | SaveBitmap | (Overrides Image_Format..::..SaveBitmap(Bitmap).)
Public method | SaveBuffer | (Inherited from Image_Format.)
Public method | SavePage | (Inherited from Image_Format.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Stream.)
Public method | Set | (Inherited from Stream.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | Tell | (Inherited from Stream.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write(STRING) | (Inherited from Stream.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

Image_Format_SysImage Class
ElImage Namespace


AttachFile Method

[image] [image]

4 of William Foster's Class Libraries
Image_Format_SysImage..::..AttachFile Method
Image_Format_SysImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)

See Also

Image_Format_SysImage Class
Image_Format_SysImage Members
ElImage Namespace


AttachMemory Method

[image] [image]

4 of William Foster's Class Libraries
Image_Format_SysImage..::..AttachMemory Method
Image_Format_SysImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)

See Also

Image_Format_SysImage Class
Image_Format_SysImage Members
ElImage Namespace


LoadHeader Method

[image]

4 of William Foster's Class Libraries
Image_Format_SysImage..::..LoadHeader Method
Image_Format_SysImage Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Format_SysImage.LoadHeader(ElImage.Image_Info@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override bool LoadHeader(
    out Image_Info info
)
Visual Basic
Public Overrides Function LoadHeader ( _
    <OutAttribute> ByRef info As Image_Info _
) As Boolean
Visual C++
public:
virtual bool LoadHeader(
    [OutAttribute] Image_Info^% info
) override

Parameters

info
Type: ElImage..::..Image_Info %

[Missing <param name="info"/> documentation for "M:ElImage.Image_Format_SysImage.LoadHeader(ElImage.Image_Info@)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Format_SysImage.LoadHeader(ElImage.Image_Info@)"]

See Also

Image_Format_SysImage Class
ElImage Namespace


LoadRectangle Method

[image]

4 of William Foster's Class Libraries
Image_Format_SysImage..::..LoadRectangle Method
Image_Format_SysImage Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Format_SysImage.LoadRectangle(El.Rect2dU,ElImage.Bitmap@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override bool LoadRectangle(
    Rect2dU rect2d_Load,
    out Bitmap bfc_bitmap
)
Visual Basic
Public Overrides Function LoadRectangle ( _
    rect2d_Load As Rect2dU, _
    <OutAttribute> ByRef bfc_bitmap As Bitmap _
) As Boolean
Visual C++
public:
virtual bool LoadRectangle(
    Rect2dU^ rect2d_Load,
    [OutAttribute] Bitmap^% bfc_bitmap
) override

Parameters

rect2d_Load
Type: Rect2dU

[Missing <param name="rect2d_Load"/> documentation for "M:ElImage.Image_Format_SysImage.LoadRectangle(El.Rect2dU,ElImage.Bitmap@)"]

bfc_bitmap
Type: ElImage..::..Bitmap %

[Missing <param name="bfc_bitmap"/> documentation for "M:ElImage.Image_Format_SysImage.LoadRectangle(El.Rect2dU,ElImage.Bitmap@)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Format_SysImage.LoadRectangle(El.Rect2dU,ElImage.Bitmap@)"]

See Also

Image_Format_SysImage Class
ElImage Namespace


SaveBitmap Method

[image]

4 of William Foster's Class Libraries
Image_Format_SysImage..::..SaveBitmap Method
Image_Format_SysImage Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Format_SysImage.SaveBitmap(ElImage.Bitmap)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override bool SaveBitmap(
    Bitmap bmp
)
Visual Basic
Public Overrides Function SaveBitmap ( _
    bmp As Bitmap _
) As Boolean
Visual C++
public:
virtual bool SaveBitmap(
    Bitmap^ bmp
) override

Parameters

bmp
Type: ElImage..::..Bitmap

[Missing <param name="bmp"/> documentation for "M:ElImage.Image_Format_SysImage.SaveBitmap(ElImage.Bitmap)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Format_SysImage.SaveBitmap(ElImage.Bitmap)"]

See Also

Image_Format_SysImage Class
ElImage Namespace


Seek Method

[image] [image]

4 of William Foster's Class Libraries
Image_Format_SysImage..::..Seek Method
Image_Format_SysImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Stream.)

See Also

Image_Format_SysImage Class
Image_Format_SysImage Members
ElImage Namespace


Write Method

[image] [image]

4 of William Foster's Class Libraries
Image_Format_SysImage..::..Write Method
Image_Format_SysImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(STRING) | (Inherited from Stream.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

Image_Format_SysImage Class
Image_Format_SysImage Members
ElImage Namespace


Image_Format_SysImage Properties

[image] [image]

4 of William Foster's Class Libraries
Image_Format_SysImage Properties
Image_Format_SysImage Class See Also Send Feedback

The Image_Format_SysImage type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Image_Format_SysImage Class
ElImage Namespace


Image_Info Class

[image]

4 of William Foster's Class Libraries
Image_Info Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Image_Info"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Image_Info
Visual Basic
Public Class Image_Info
Visual C++
public ref class Image_Info

Inheritance Hierarchy

System..::..Object
ElImage..::..Image_Info

See Also

Image_Info Members
ElImage Namespace


Image_Info Members

[image] [image]

4 of William Foster's Class Libraries
Image_Info Members
Image_Info Class Constructors Methods Fields See Also Send Feedback

The Image_Info type exposes the following members.

Constructors

 | Name | Description
Public method | Image_Info()()()() | Initializes a new instance of the Image_Info class
Public method | Image_Info(Image_Info) | Initializes a new instance of the Image_Info class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetColorSpace |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResolution |
Public method | GetSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetColorSpace |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_colorSpace |
Public field | m_resolution |
Public field | m_size |

See Also

Image_Info Class
ElImage Namespace


Image_Info Constructor

[image] [image]

4 of William Foster's Class Libraries
Image_Info Constructor
Image_Info Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Image_Info()()()() | Initializes a new instance of the Image_Info class
Public method | Image_Info(Image_Info) | Initializes a new instance of the Image_Info class

See Also

Image_Info Class
Image_Info Members
ElImage Namespace


Image_Info Constructor

[image]

4 of William Foster's Class Libraries
Image_Info Constructor
Image_Info Class See Also Send Feedback
Initializes a new instance of the Image_Info class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Info()
Visual Basic
Public Sub New
Visual C++
public:
Image_Info()

See Also

Image_Info Class
Image_Info Overload
ElImage Namespace


Image_Info Constructor (Image_Info)

[image]

4 of William Foster's Class Libraries
Image_Info Constructor (Image_Info)
Image_Info Class See Also Send Feedback
Initializes a new instance of the Image_Info class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Info(
    Image_Info duper
)
Visual Basic
Public Sub New ( _
    duper As Image_Info _
)
Visual C++
public:
Image_Info(
    Image_Info^ duper
)

Parameters

duper
Type: ElImage..::..Image_Info

[Missing <param name="duper"/> documentation for "M:ElImage.Image_Info.#ctor(ElImage.Image_Info)"]

See Also

Image_Info Class
Image_Info Overload
ElImage Namespace


Image_Info Fields

[image] [image]

4 of William Foster's Class Libraries
Image_Info Fields
Image_Info Class See Also Send Feedback

The Image_Info type exposes the following members.

Fields

 | Name | Description
Public field | m_colorSpace |
Public field | m_resolution |
Public field | m_size |

See Also

Image_Info Class
ElImage Namespace


m_colorSpace Field

[image]

4 of William Foster's Class Libraries
Image_Info..::..m_colorSpace Field
Image_Info Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Image_Info.m_colorSpace"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ColorSpace m_colorSpace
Visual Basic
Public m_colorSpace As ColorSpace
Visual C++
public:
ColorSpace^ m_colorSpace

See Also

Image_Info Class
ElImage Namespace


m_resolution Field

[image]

4 of William Foster's Class Libraries
Image_Info..::..m_resolution Field
Image_Info Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Image_Info.m_resolution"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Resolution m_resolution
Visual Basic
Public m_resolution As Resolution
Visual C++
public:
Resolution^ m_resolution

See Also

Image_Info Class
ElImage Namespace


m_size Field

[image]

4 of William Foster's Class Libraries
Image_Info..::..m_size Field
Image_Info Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Image_Info.m_size"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Size2dU m_size
Visual Basic
Public m_size As Size2dU
Visual C++
public:
Size2dU^ m_size

See Also

Image_Info Class
ElImage Namespace


Image_Info Methods

[image] [image]

4 of William Foster's Class Libraries
Image_Info Methods
Image_Info Class See Also Send Feedback

The Image_Info type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetColorSpace |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResolution |
Public method | GetSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetColorSpace |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Image_Info Class
ElImage Namespace


GetColorSpace Method

[image]

4 of William Foster's Class Libraries
Image_Info..::..GetColorSpace Method
Image_Info Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Info.GetColorSpace"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ColorSpace GetColorSpace()
Visual Basic
Public Function GetColorSpace As ColorSpace
Visual C++
public:
ColorSpace^ GetColorSpace()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Info.GetColorSpace"]

See Also

Image_Info Class
ElImage Namespace


GetResolution Method

[image]

4 of William Foster's Class Libraries
Image_Info..::..GetResolution Method
Image_Info Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Info.GetResolution"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Resolution GetResolution()
Visual Basic
Public Function GetResolution As Resolution
Visual C++
public:
Resolution^ GetResolution()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Info.GetResolution"]

See Also

Image_Info Class
ElImage Namespace


GetSize Method

[image]

4 of William Foster's Class Libraries
Image_Info..::..GetSize Method
Image_Info Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Info.GetSize"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Size2dU GetSize()
Visual Basic
Public Function GetSize As Size2dU
Visual C++
public:
Size2dU^ GetSize()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Info.GetSize"]

See Also

Image_Info Class
ElImage Namespace


SetColorSpace Method

[image]

4 of William Foster's Class Libraries
Image_Info..::..SetColorSpace Method
Image_Info Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Info.SetColorSpace(ElImage.ColorSpace)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetColorSpace(
    ColorSpace cspc
)
Visual Basic
Public Sub SetColorSpace ( _
    cspc As ColorSpace _
)
Visual C++
public:
void SetColorSpace(
    ColorSpace^ cspc
)

Parameters

cspc
Type: ElImage..::..ColorSpace

[Missing <param name="cspc"/> documentation for "M:ElImage.Image_Info.SetColorSpace(ElImage.ColorSpace)"]

See Also

Image_Info Class
ElImage Namespace


Image_Segment Class

[image]

4 of William Foster's Class Libraries
Image_Segment Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Image_Segment"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Image_Segment
Visual Basic
Public Class Image_Segment
Visual C++
public ref class Image_Segment

Inheritance Hierarchy

System..::..Object
ElImage..::..Image_Segment

See Also

Image_Segment Members
ElImage Namespace


Image_Segment Members

[image] [image]

4 of William Foster's Class Libraries
Image_Segment Members
Image_Segment Class Constructors Methods Operators See Also Send Feedback

The Image_Segment type exposes the following members.

Constructors

 | Name | Description
Public method | Image_Segment()()()() | Initializes a new instance of the Image_Segment class
Public method | Image_Segment(Image_Segment) | Initializes a new instance of the Image_Segment class

Methods

 | Name | Description
Public method | EncapsulatesSegment |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResolution |
Public method | GetScale |
Public method | GetSourceRectangle |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetScale |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality |
Inequality |

See Also

Image_Segment Class
ElImage Namespace


Image_Segment Constructor

[image] [image]

4 of William Foster's Class Libraries
Image_Segment Constructor
Image_Segment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Image_Segment()()()() | Initializes a new instance of the Image_Segment class
Public method | Image_Segment(Image_Segment) | Initializes a new instance of the Image_Segment class

See Also

Image_Segment Class
Image_Segment Members
ElImage Namespace


Image_Segment Constructor

[image]

4 of William Foster's Class Libraries
Image_Segment Constructor
Image_Segment Class See Also Send Feedback
Initializes a new instance of the Image_Segment class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Segment()
Visual Basic
Public Sub New
Visual C++
public:
Image_Segment()

See Also

Image_Segment Class
Image_Segment Overload
ElImage Namespace


Image_Segment Constructor (Image_Segment)

[image]

4 of William Foster's Class Libraries
Image_Segment Constructor (Image_Segment)
Image_Segment Class See Also Send Feedback
Initializes a new instance of the Image_Segment class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Segment(
    Image_Segment seg
)
Visual Basic
Public Sub New ( _
    seg As Image_Segment _
)
Visual C++
public:
Image_Segment(
    Image_Segment^ seg
)

Parameters

seg
Type: ElImage..::..Image_Segment

[Missing <param name="seg"/> documentation for "M:ElImage.Image_Segment.#ctor(ElImage.Image_Segment)"]

See Also

Image_Segment Class
Image_Segment Overload
ElImage Namespace


Image_Segment Methods

[image] [image]

4 of William Foster's Class Libraries
Image_Segment Methods
Image_Segment Class See Also Send Feedback

The Image_Segment type exposes the following members.

Methods

 | Name | Description
Public method | EncapsulatesSegment |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResolution |
Public method | GetScale |
Public method | GetSourceRectangle |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetScale |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Image_Segment Class
ElImage Namespace


EncapsulatesSegment Method

[image]

4 of William Foster's Class Libraries
Image_Segment..::..EncapsulatesSegment Method
Image_Segment Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Segment.EncapsulatesSegment(ElImage.Image_Segment)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool EncapsulatesSegment(
    Image_Segment seg
)
Visual Basic
Public Function EncapsulatesSegment ( _
    seg As Image_Segment _
) As Boolean
Visual C++
public:
bool EncapsulatesSegment(
    Image_Segment^ seg
)

Parameters

seg
Type: ElImage..::..Image_Segment

[Missing <param name="seg"/> documentation for "M:ElImage.Image_Segment.EncapsulatesSegment(ElImage.Image_Segment)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Segment.EncapsulatesSegment(ElImage.Image_Segment)"]

See Also

Image_Segment Class
ElImage Namespace


GetResolution Method

[image]

4 of William Foster's Class Libraries
Image_Segment..::..GetResolution Method
Image_Segment Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Segment.GetResolution"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Resolution GetResolution()
Visual Basic
Public Function GetResolution As Resolution
Visual C++
public:
Resolution^ GetResolution()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Segment.GetResolution"]

See Also

Image_Segment Class
ElImage Namespace


GetScale Method

[image]

4 of William Foster's Class Libraries
Image_Segment..::..GetScale Method
Image_Segment Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Segment.GetScale"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Size2d GetScale()
Visual Basic
Public Function GetScale As Size2d
Visual C++
public:
Size2d^ GetScale()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Segment.GetScale"]

See Also

Image_Segment Class
ElImage Namespace


GetSourceRectangle Method

[image]

4 of William Foster's Class Libraries
Image_Segment..::..GetSourceRectangle Method
Image_Segment Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Segment.GetSourceRectangle"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Rect2d GetSourceRectangle()
Visual Basic
Public Function GetSourceRectangle As Rect2d
Visual C++
public:
Rect2d^ GetSourceRectangle()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Segment.GetSourceRectangle"]

See Also

Image_Segment Class
ElImage Namespace


Set Method

[image]

4 of William Foster's Class Libraries
Image_Segment..::..Set Method
Image_Segment Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Segment.Set(ElImage.Image_Segment)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Set(
    Image_Segment seg
)
Visual Basic
Public Sub Set ( _
    seg As Image_Segment _
)
Visual C++
public:
void Set(
    Image_Segment^ seg
)

Parameters

seg
Type: ElImage..::..Image_Segment

[Missing <param name="seg"/> documentation for "M:ElImage.Image_Segment.Set(ElImage.Image_Segment)"]

See Also

Image_Segment Class
ElImage Namespace


SetScale Method

[image]

4 of William Foster's Class Libraries
Image_Segment..::..SetScale Method
Image_Segment Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Segment.SetScale(El.Size2d)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetScale(
    Size2d scale
)
Visual Basic
Public Sub SetScale ( _
    scale As Size2d _
)
Visual C++
public:
void SetScale(
    Size2d^ scale
)

Parameters

scale
Type: Size2d

[Missing <param name="scale"/> documentation for "M:ElImage.Image_Segment.SetScale(El.Size2d)"]

See Also

Image_Segment Class
ElImage Namespace


Image_Segment Operators

[image] [image]

4 of William Foster's Class Libraries
Image_Segment Operators
Image_Segment Class See Also Send Feedback

The Image_Segment type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Image_Segment Class
ElImage Namespace


Equality Operator

[image]

4 of William Foster's Class Libraries
Image_Segment..::..Equality Operator
Image_Segment Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Segment.op_Equality(ElImage.Image_Segment,ElImage.Image_Segment)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static bool operator ==(
    Image_Segment seg1,
    Image_Segment seg2
)
Visual Basic
Public Shared Operator = ( _
    seg1 As Image_Segment, _
    seg2 As Image_Segment _
) As Boolean
Visual C++
public:
static bool operator ==(
    Image_Segment^ seg1,
    Image_Segment^ seg2
)

Parameters

seg1
Type: ElImage..::..Image_Segment

[Missing <param name="seg1"/> documentation for "M:ElImage.Image_Segment.op_Equality(ElImage.Image_Segment,ElImage.Image_Segment)"]

seg2
Type: ElImage..::..Image_Segment

[Missing <param name="seg2"/> documentation for "M:ElImage.Image_Segment.op_Equality(ElImage.Image_Segment,ElImage.Image_Segment)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Segment.op_Equality(ElImage.Image_Segment,ElImage.Image_Segment)"]

See Also

Image_Segment Class
ElImage Namespace


Inequality Operator

[image]

4 of William Foster's Class Libraries
Image_Segment..::..Inequality Operator
Image_Segment Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Segment.op_Inequality(ElImage.Image_Segment,ElImage.Image_Segment)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static bool operator !=(
    Image_Segment seg1,
    Image_Segment seg2
)
Visual Basic
Public Shared Operator <> ( _
    seg1 As Image_Segment, _
    seg2 As Image_Segment _
) As Boolean
Visual C++
public:
static bool operator !=(
    Image_Segment^ seg1,
    Image_Segment^ seg2
)

Parameters

seg1
Type: ElImage..::..Image_Segment

[Missing <param name="seg1"/> documentation for "M:ElImage.Image_Segment.op_Inequality(ElImage.Image_Segment,ElImage.Image_Segment)"]

seg2
Type: ElImage..::..Image_Segment

[Missing <param name="seg2"/> documentation for "M:ElImage.Image_Segment.op_Inequality(ElImage.Image_Segment,ElImage.Image_Segment)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Segment.op_Inequality(ElImage.Image_Segment,ElImage.Image_Segment)"]

See Also

Image_Segment Class
ElImage Namespace


Image_Store Class

[image]

4 of William Foster's Class Libraries
Image_Store Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Image_Store"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Image_Store
Visual Basic
Public Class Image_Store
Visual C++
public ref class Image_Store

Inheritance Hierarchy

System..::..Object
ElImage..::..Image_Store
ElImage..::..Image_Basic

See Also

Image_Store Members
ElImage Namespace


Image_Store Members

[image] [image]

4 of William Foster's Class Libraries
Image_Store Members
Image_Store Class Constructors Methods Fields Properties See Also Send Feedback

The Image_Store type exposes the following members.

Constructors

 | Name | Description
Public method | Image_Store()()()() | Initializes a new instance of the Image_Store class
Public method | Image_Store(Stream) | Initializes a new instance of the Image_Store class
Public method | Image_Store(Image_Store) | Initializes a new instance of the Image_Store class

Methods

 | Name | Description
Public method | AddPage |
Public method | AttachBitmap |
Public method | AttachStream |
Public method | ConstructBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) |
Public method | ConstructBuffer(Image_Segment, ScriptImage) |
Public method | Empty |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedBuffer |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageSize |
Public method | GetLayer()()()() |
Public method | GetLayer(UInt32) |
Public method | GetLayerNumber |
Public method | GetPage()()()() |
Public method | GetPage(UInt32) |
Public method | GetPageNumber |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsModified |
Public method | Load |
Public method | LoadSegmentBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) |
Public method | LoadSegmentBuffer(Image_Segment, ScriptImage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save |
Public method | SetBitmap |
Public method | SetLayerNumber |
Public method | SetModified |
Public method | SetNative |
Public method | SetPageNumber |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_b_modified |
Protected field | m_Image_Format |
Protected field | m_InfoNative |
Protected field | m_Pages |

Properties

 | Name | Description
Public property | stream |

See Also

Image_Store Class
ElImage Namespace


Image_Store Constructor

[image] [image]

4 of William Foster's Class Libraries
Image_Store Constructor
Image_Store Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Image_Store()()()() | Initializes a new instance of the Image_Store class
Public method | Image_Store(Stream) | Initializes a new instance of the Image_Store class
Public method | Image_Store(Image_Store) | Initializes a new instance of the Image_Store class

See Also

Image_Store Class
Image_Store Members
ElImage Namespace


Image_Store Constructor

[image]

4 of William Foster's Class Libraries
Image_Store Constructor
Image_Store Class See Also Send Feedback
Initializes a new instance of the Image_Store class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Store()
Visual Basic
Public Sub New
Visual C++
public:
Image_Store()

See Also

Image_Store Class
Image_Store Overload
ElImage Namespace


Image_Store Constructor ()

[image]

4 of William Foster's Class Libraries
Image_Store Constructor ()
Image_Store Class See Also Send Feedback
Initializes a new instance of the Image_Store class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Store(
    Stream stream
)
Visual Basic
Public Sub New ( _
    stream As Stream _
)
Visual C++
public:
Image_Store(
    Stream^ stream
)

Parameters

stream
Type: Stream

[Missing <param name="stream"/> documentation for "M:ElImage.Image_Store.#ctor(El.Stream)"]

See Also

Image_Store Class
Image_Store Overload
ElImage Namespace


Image_Store Constructor (Image_Store)

[image]

4 of William Foster's Class Libraries
Image_Store Constructor (Image_Store)
Image_Store Class See Also Send Feedback
Initializes a new instance of the Image_Store class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Store(
    Image_Store duper
)
Visual Basic
Public Sub New ( _
    duper As Image_Store _
)
Visual C++
public:
Image_Store(
    Image_Store^ duper
)

Parameters

duper
Type: ElImage..::..Image_Store

[Missing <param name="duper"/> documentation for "M:ElImage.Image_Store.#ctor(ElImage.Image_Store)"]

See Also

Image_Store Class
Image_Store Overload
ElImage Namespace


Image_Store Fields

[image] [image]

4 of William Foster's Class Libraries
Image_Store Fields
Image_Store Class See Also Send Feedback

The Image_Store type exposes the following members.

Fields

 | Name | Description
Protected field | m_b_modified |
Protected field | m_Image_Format |
Protected field | m_InfoNative |
Protected field | m_Pages |

See Also

Image_Store Class
ElImage Namespace


m_b_modified Field

[image]

4 of William Foster's Class Libraries
Image_Store..::..m_b_modified Field
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Image_Store.m_b_modified"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected bool m_b_modified
Visual Basic
Protected m_b_modified As Boolean
Visual C++
protected:
bool m_b_modified

See Also

Image_Store Class
ElImage Namespace


m_Image_Format Field

[image]

4 of William Foster's Class Libraries
Image_Store..::..m_Image_Format Field
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Image_Store.m_Image_Format"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected Image_Format m_Image_Format
Visual Basic
Protected m_Image_Format As Image_Format
Visual C++
protected:
Image_Format^ m_Image_Format

See Also

Image_Store Class
ElImage Namespace


m_InfoNative Field

[image]

4 of William Foster's Class Libraries
Image_Store..::..m_InfoNative Field
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Image_Store.m_InfoNative"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected Image_Info m_InfoNative
Visual Basic
Protected m_InfoNative As Image_Info
Visual C++
protected:
Image_Info^ m_InfoNative

See Also

Image_Store Class
ElImage Namespace


m_Pages Field

[image]

4 of William Foster's Class Libraries
Image_Store..::..m_Pages Field
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Image_Store.m_Pages"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected Array<Page> m_Pages
Visual Basic
Protected m_Pages As Array(Of Page)
Visual C++
protected:
Array<Page^>^ m_Pages

See Also

Image_Store Class
ElImage Namespace


Image_Store Methods

[image] [image]

4 of William Foster's Class Libraries
Image_Store Methods
Image_Store Class See Also Send Feedback

The Image_Store type exposes the following members.

Methods

 | Name | Description
Public method | AddPage |
Public method | AttachBitmap |
Public method | AttachStream |
Public method | ConstructBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) |
Public method | ConstructBuffer(Image_Segment, ScriptImage) |
Public method | Empty |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCachedBuffer |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageSize |
Public method | GetLayer()()()() |
Public method | GetLayer(UInt32) |
Public method | GetLayerNumber |
Public method | GetPage()()()() |
Public method | GetPage(UInt32) |
Public method | GetPageNumber |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsModified |
Public method | Load |
Public method | LoadSegmentBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) |
Public method | LoadSegmentBuffer(Image_Segment, ScriptImage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save |
Public method | SetBitmap |
Public method | SetLayerNumber |
Public method | SetModified |
Public method | SetNative |
Public method | SetPageNumber |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Image_Store Class
ElImage Namespace


AddPage Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..AddPage Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.AddPage"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void AddPage()
Visual Basic
Public Sub AddPage
Visual C++
public:
void AddPage()

See Also

Image_Store Class
ElImage Namespace


AttachBitmap Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..AttachBitmap Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.AttachBitmap(ElImage.Bitmap)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool AttachBitmap(
    Bitmap bmp
)
Visual Basic
Public Function AttachBitmap ( _
    bmp As Bitmap _
) As Boolean
Visual C++
public:
bool AttachBitmap(
    Bitmap^ bmp
)

Parameters

bmp
Type: ElImage..::..Bitmap

[Missing <param name="bmp"/> documentation for "M:ElImage.Image_Store.AttachBitmap(ElImage.Bitmap)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.AttachBitmap(ElImage.Bitmap)"]

See Also

Image_Store Class
ElImage Namespace


AttachStream Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..AttachStream Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.AttachStream(El.Stream)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual bool AttachStream(
    Stream stream
)
Visual Basic
Public Overridable Function AttachStream ( _
    stream As Stream _
) As Boolean
Visual C++
public:
virtual bool AttachStream(
    Stream^ stream
)

Parameters

stream
Type: Stream

[Missing <param name="stream"/> documentation for "M:ElImage.Image_Store.AttachStream(El.Stream)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.AttachStream(El.Stream)"]

See Also

Image_Store Class
ElImage Namespace


ConstructBuffer Method

[image] [image]

4 of William Foster's Class Libraries
Image_Store..::..ConstructBuffer Method
Image_Store Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConstructBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) |
Public method | ConstructBuffer(Image_Segment, ScriptImage) |

See Also

Image_Store Class
Image_Store Members
ElImage Namespace


ConstructBuffer Method (Image_Segment, (Image_Effect))

[image]

4 of William Foster's Class Libraries
Image_Store..::..ConstructBuffer Method (Image_Segment, <(Of <(<'Image_Effect>)>)>)
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.ConstructBuffer(ElImage.Image_Segment,El.Array{ElImage.Image_Effect})"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Buffer ConstructBuffer(
    Image_Segment segment,
    Array<Image_Effect> effects
)
Visual Basic
Public Function ConstructBuffer ( _
    segment As Image_Segment, _
    effects As Array(Of Image_Effect) _
) As Image_Buffer
Visual C++
public:
Image_Buffer^ ConstructBuffer(
    Image_Segment^ segment,
    Array<Image_Effect^>^ effects
)

Parameters

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Image_Store.ConstructBuffer(ElImage.Image_Segment,El.Array{ElImage.Image_Effect})"]

effects
Type: Array<(Of <(<' Image_Effect >)>)>

[Missing <param name="effects"/> documentation for "M:ElImage.Image_Store.ConstructBuffer(ElImage.Image_Segment,El.Array{ElImage.Image_Effect})"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.ConstructBuffer(ElImage.Image_Segment,El.Array{ElImage.Image_Effect})"]

See Also

Image_Store Class
ConstructBuffer Overload
ElImage Namespace


ConstructBuffer Method (Image_Segment, ScriptImage)

[image]

4 of William Foster's Class Libraries
Image_Store..::..ConstructBuffer Method (Image_Segment, ScriptImage)
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.ConstructBuffer(ElImage.Image_Segment,ElImage.ScriptImage)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Buffer ConstructBuffer(
    Image_Segment segment,
    ScriptImage Script
)
Visual Basic
Public Function ConstructBuffer ( _
    segment As Image_Segment, _
    Script As ScriptImage _
) As Image_Buffer
Visual C++
public:
Image_Buffer^ ConstructBuffer(
    Image_Segment^ segment,
    ScriptImage^ Script
)

Parameters

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Image_Store.ConstructBuffer(ElImage.Image_Segment,ElImage.ScriptImage)"]

Script
Type: ElImage..::..ScriptImage

[Missing <param name="Script"/> documentation for "M:ElImage.Image_Store.ConstructBuffer(ElImage.Image_Segment,ElImage.ScriptImage)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.ConstructBuffer(ElImage.Image_Segment,ElImage.ScriptImage)"]

See Also

Image_Store Class
ConstructBuffer Overload
ElImage Namespace


Empty Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..Empty Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.Empty"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Empty()
Visual Basic
Public Sub Empty
Visual C++
public:
void Empty()

See Also

Image_Store Class
ElImage Namespace


GetCachedBuffer Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..GetCachedBuffer Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.GetCachedBuffer(ElImage.Image_Segment)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Buffer GetCachedBuffer(
    Image_Segment segment
)
Visual Basic
Public Function GetCachedBuffer ( _
    segment As Image_Segment _
) As Image_Buffer
Visual C++
public:
Image_Buffer^ GetCachedBuffer(
    Image_Segment^ segment
)

Parameters

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Image_Store.GetCachedBuffer(ElImage.Image_Segment)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.GetCachedBuffer(ElImage.Image_Segment)"]

See Also

Image_Store Class
ElImage Namespace


GetImageSize Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..GetImageSize Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.GetImageSize"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Size2dU GetImageSize()
Visual Basic
Public Function GetImageSize As Size2dU
Visual C++
public:
Size2dU^ GetImageSize()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.GetImageSize"]

See Also

Image_Store Class
ElImage Namespace


GetLayer Method

[image] [image]

4 of William Foster's Class Libraries
Image_Store..::..GetLayer Method
Image_Store Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLayer()()()() |
Public method | GetLayer(UInt32) |

See Also

Image_Store Class
Image_Store Members
ElImage Namespace


GetLayer Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..GetLayer Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.GetLayer"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Layer GetLayer()
Visual Basic
Public Function GetLayer As Layer
Visual C++
public:
Layer^ GetLayer()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.GetLayer"]

See Also

Image_Store Class
GetLayer Overload
ElImage Namespace


GetLayer Method (UInt32)

[image]

4 of William Foster's Class Libraries
Image_Store..::..GetLayer Method (UInt32)
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.GetLayer(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Layer GetLayer(
    uint uLayerNo
)
Visual Basic
Public Function GetLayer ( _
    uLayerNo As UInteger _
) As Layer
Visual C++
public:
Layer^ GetLayer(
    unsigned int uLayerNo
)

Parameters

uLayerNo
Type: System..::..UInt32

[Missing <param name="uLayerNo"/> documentation for "M:ElImage.Image_Store.GetLayer(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.GetLayer(System.UInt32)"]

See Also

Image_Store Class
GetLayer Overload
ElImage Namespace


GetLayerNumber Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..GetLayerNumber Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.GetLayerNumber"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint GetLayerNumber()
Visual Basic
Public Function GetLayerNumber As UInteger
Visual C++
public:
unsigned int GetLayerNumber()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.GetLayerNumber"]

See Also

Image_Store Class
ElImage Namespace


GetPage Method

[image] [image]

4 of William Foster's Class Libraries
Image_Store..::..GetPage Method
Image_Store Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPage()()()() |
Public method | GetPage(UInt32) |

See Also

Image_Store Class
Image_Store Members
ElImage Namespace


GetPage Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..GetPage Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.GetPage"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Page GetPage()
Visual Basic
Public Function GetPage As Page
Visual C++
public:
Page^ GetPage()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.GetPage"]

See Also

Image_Store Class
GetPage Overload
ElImage Namespace


GetPage Method (UInt32)

[image]

4 of William Foster's Class Libraries
Image_Store..::..GetPage Method (UInt32)
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.GetPage(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Page GetPage(
    uint uPage
)
Visual Basic
Public Function GetPage ( _
    uPage As UInteger _
) As Page
Visual C++
public:
Page^ GetPage(
    unsigned int uPage
)

Parameters

uPage
Type: System..::..UInt32

[Missing <param name="uPage"/> documentation for "M:ElImage.Image_Store.GetPage(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.GetPage(System.UInt32)"]

See Also

Image_Store Class
GetPage Overload
ElImage Namespace


GetPageNumber Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..GetPageNumber Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.GetPageNumber"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint GetPageNumber()
Visual Basic
Public Function GetPageNumber As UInteger
Visual C++
public:
unsigned int GetPageNumber()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.GetPageNumber"]

See Also

Image_Store Class
ElImage Namespace


IsModified Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..IsModified Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.IsModified"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool IsModified()
Visual Basic
Public Function IsModified As Boolean
Visual C++
public:
bool IsModified()

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.IsModified"]

See Also

Image_Store Class
ElImage Namespace


Load Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..Load Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.Load(ElImage.Image_Segment)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Buffer Load(
    Image_Segment segment
)
Visual Basic
Public Function Load ( _
    segment As Image_Segment _
) As Image_Buffer
Visual C++
public:
Image_Buffer^ Load(
    Image_Segment^ segment
)

Parameters

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Image_Store.Load(ElImage.Image_Segment)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.Load(ElImage.Image_Segment)"]

See Also

Image_Store Class
ElImage Namespace


LoadSegmentBuffer Method

[image] [image]

4 of William Foster's Class Libraries
Image_Store..::..LoadSegmentBuffer Method
Image_Store Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadSegmentBuffer(Image_Segment, Array<(Of <<'(Image_Effect>)>>)) |
Public method | LoadSegmentBuffer(Image_Segment, ScriptImage) |

See Also

Image_Store Class
Image_Store Members
ElImage Namespace


LoadSegmentBuffer Method (Image_Segment, (Image_Effect))

[image]

4 of William Foster's Class Libraries
Image_Store..::..LoadSegmentBuffer Method (Image_Segment, <(Of <(<'Image_Effect>)>)>)
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.LoadSegmentBuffer(ElImage.Image_Segment,El.Array{ElImage.Image_Effect})"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool LoadSegmentBuffer(
    Image_Segment segment,
    Array<Image_Effect> effects
)
Visual Basic
Public Function LoadSegmentBuffer ( _
    segment As Image_Segment, _
    effects As Array(Of Image_Effect) _
) As Boolean
Visual C++
public:
bool LoadSegmentBuffer(
    Image_Segment^ segment,
    Array<Image_Effect^>^ effects
)

Parameters

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Image_Store.LoadSegmentBuffer(ElImage.Image_Segment,El.Array{ElImage.Image_Effect})"]

effects
Type: Array<(Of <(<' Image_Effect >)>)>

[Missing <param name="effects"/> documentation for "M:ElImage.Image_Store.LoadSegmentBuffer(ElImage.Image_Segment,El.Array{ElImage.Image_Effect})"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.LoadSegmentBuffer(ElImage.Image_Segment,El.Array{ElImage.Image_Effect})"]

See Also

Image_Store Class
LoadSegmentBuffer Overload
ElImage Namespace


LoadSegmentBuffer Method (Image_Segment, ScriptImage)

[image]

4 of William Foster's Class Libraries
Image_Store..::..LoadSegmentBuffer Method (Image_Segment, ScriptImage)
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.LoadSegmentBuffer(ElImage.Image_Segment,ElImage.ScriptImage)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool LoadSegmentBuffer(
    Image_Segment segment,
    ScriptImage Script
)
Visual Basic
Public Function LoadSegmentBuffer ( _
    segment As Image_Segment, _
    Script As ScriptImage _
) As Boolean
Visual C++
public:
bool LoadSegmentBuffer(
    Image_Segment^ segment,
    ScriptImage^ Script
)

Parameters

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Image_Store.LoadSegmentBuffer(ElImage.Image_Segment,ElImage.ScriptImage)"]

Script
Type: ElImage..::..ScriptImage

[Missing <param name="Script"/> documentation for "M:ElImage.Image_Store.LoadSegmentBuffer(ElImage.Image_Segment,ElImage.ScriptImage)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.LoadSegmentBuffer(ElImage.Image_Segment,ElImage.ScriptImage)"]

See Also

Image_Store Class
LoadSegmentBuffer Overload
ElImage Namespace


Save Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..Save Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.Save(ElImage.Image_Buffer)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Save(
    Image_Buffer buffer
)
Visual Basic
Public Function Save ( _
    buffer As Image_Buffer _
) As Boolean
Visual C++
public:
bool Save(
    Image_Buffer^ buffer
)

Parameters

buffer
Type: ElImage..::..Image_Buffer

[Missing <param name="buffer"/> documentation for "M:ElImage.Image_Store.Save(ElImage.Image_Buffer)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.Save(ElImage.Image_Buffer)"]

See Also

Image_Store Class
ElImage Namespace


SetBitmap Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..SetBitmap Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.SetBitmap(ElImage.Bitmap)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool SetBitmap(
    Bitmap bmp
)
Visual Basic
Public Function SetBitmap ( _
    bmp As Bitmap _
) As Boolean
Visual C++
public:
bool SetBitmap(
    Bitmap^ bmp
)

Parameters

bmp
Type: ElImage..::..Bitmap

[Missing <param name="bmp"/> documentation for "M:ElImage.Image_Store.SetBitmap(ElImage.Bitmap)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Image_Store.SetBitmap(ElImage.Bitmap)"]

See Also

Image_Store Class
ElImage Namespace


SetLayerNumber Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..SetLayerNumber Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.SetLayerNumber(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetLayerNumber(
    uint layerNo
)
Visual Basic
Public Sub SetLayerNumber ( _
    layerNo As UInteger _
)
Visual C++
public:
void SetLayerNumber(
    unsigned int layerNo
)

Parameters

layerNo
Type: System..::..UInt32

[Missing <param name="layerNo"/> documentation for "M:ElImage.Image_Store.SetLayerNumber(System.UInt32)"]

See Also

Image_Store Class
ElImage Namespace


SetModified Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..SetModified Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.SetModified(System.Boolean)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetModified(
    bool bMod
)
Visual Basic
Public Sub SetModified ( _
    bMod As Boolean _
)
Visual C++
public:
void SetModified(
    bool bMod
)

Parameters

bMod
Type: System..::..Boolean

[Missing <param name="bMod"/> documentation for "M:ElImage.Image_Store.SetModified(System.Boolean)"]

See Also

Image_Store Class
ElImage Namespace


SetNative Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..SetNative Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.SetNative(ElImage.Bitmap)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetNative(
    Bitmap bmp
)
Visual Basic
Public Sub SetNative ( _
    bmp As Bitmap _
)
Visual C++
public:
void SetNative(
    Bitmap^ bmp
)

Parameters

bmp
Type: ElImage..::..Bitmap

[Missing <param name="bmp"/> documentation for "M:ElImage.Image_Store.SetNative(ElImage.Bitmap)"]

See Also

Image_Store Class
ElImage Namespace


SetPageNumber Method

[image]

4 of William Foster's Class Libraries
Image_Store..::..SetPageNumber Method
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Image_Store.SetPageNumber(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetPageNumber(
    uint page
)
Visual Basic
Public Sub SetPageNumber ( _
    page As UInteger _
)
Visual C++
public:
void SetPageNumber(
    unsigned int page
)

Parameters

page
Type: System..::..UInt32

[Missing <param name="page"/> documentation for "M:ElImage.Image_Store.SetPageNumber(System.UInt32)"]

See Also

Image_Store Class
ElImage Namespace


Image_Store Properties

[image] [image]

4 of William Foster's Class Libraries
Image_Store Properties
Image_Store Class See Also Send Feedback

The Image_Store type exposes the following members.

Properties

 | Name | Description
Public property | stream |

See Also

Image_Store Class
ElImage Namespace


stream Property

[image]

4 of William Foster's Class Libraries
Image_Store..::..stream Property
Image_Store Class See Also Send Feedback

[Missing <summary> documentation for "P:ElImage.Image_Store.stream"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Stream stream { get; }
Visual Basic
Public ReadOnly Property stream As Stream
    Get
Visual C++
public:
property Stream^ stream {
    Stream^ get ();
}

See Also

Image_Store Class
ElImage Namespace


ImageActionDP Class

[image]

4 of William Foster's Class Libraries
ImageActionDP Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.ImageActionDP"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public abstract class ImageActionDP : ActionDP
Visual Basic
Public MustInherit Class ImageActionDP _
    Inherits ActionDP
Visual C++
public ref class ImageActionDP abstract : public ActionDP

Inheritance Hierarchy

System..::..Object
ElGUI..::..DP
ElGUI..::..ActionDP
ElImage..::..ImageActionDP
ElImage..::..ElImageActionDP

See Also

ImageActionDP Members
ElImage Namespace


ImageActionDP Members

[image] [image]

4 of William Foster's Class Libraries
ImageActionDP Members
ImageActionDP Class Constructors Methods Fields Properties See Also Send Feedback

The ImageActionDP type exposes the following members.

Constructors

 | Name | Description
Public method | ImageActionDP | Initializes a new instance of the ImageActionDP class

Methods

 | Name | Description
Public method | ApplyAction | (Inherited from ActionDP.)
Public method | CombineAction | (Inherited from ActionDP.)
Public method | CompletedAction | (Overrides ActionDP..::..CompletedAction(Boolean).)
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Dup | (Inherited from ActionDP.)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | EditDX | Override this to edit the action parameters via a dialog before processing starts on a new action.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformAction | (Inherited from ActionDP.)
Public method | Prepare |
Public method | Preview | (Inherited from DP.)
Public method | PreviewAction | (Inherited from ActionDP.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UndoAction | (Inherited from ActionDP.)

Fields

 | Name | Description
Public field | m_combinable | (Inherited from ActionDP.)
Public field | m_name | (Inherited from ActionDP.)
Public field | m_undoable | (Inherited from ActionDP.)
Protected field | m_wnd |

Properties

 | Name | Description
Public property | Name | (Inherited from ActionDP.)

See Also

ImageActionDP Class
ElImage Namespace


ImageActionDP Constructor

[image]

4 of William Foster's Class Libraries
ImageActionDP Constructor
ImageActionDP Class See Also Send Feedback
Initializes a new instance of the ImageActionDP class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ImageActionDP(
    string name,
    DX dx
)
Visual Basic
Public Sub New ( _
    name As String, _
    dx As DX _
)
Visual C++
public:
ImageActionDP(
    String^ name,
    DX^ dx
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ElImage.ImageActionDP.#ctor(System.String,ElGUI.DX)"]

dx
Type: ElGUI..::..DX

[Missing <param name="dx"/> documentation for "M:ElImage.ImageActionDP.#ctor(System.String,ElGUI.DX)"]

See Also

ImageActionDP Class
ElImage Namespace


ImageActionDP Fields

[image] [image]

4 of William Foster's Class Libraries
ImageActionDP Fields
ImageActionDP Class See Also Send Feedback

The ImageActionDP type exposes the following members.

Fields

 | Name | Description
Public field | m_combinable | (Inherited from ActionDP.)
Public field | m_name | (Inherited from ActionDP.)
Public field | m_undoable | (Inherited from ActionDP.)
Protected field | m_wnd |

See Also

ImageActionDP Class
ElImage Namespace


m_wnd Field

[image]

4 of William Foster's Class Libraries
ImageActionDP..::..m_wnd Field
ImageActionDP Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.ImageActionDP.m_wnd"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected ImageWindow m_wnd
Visual Basic
Protected m_wnd As ImageWindow
Visual C++
protected:
ImageWindow^ m_wnd

See Also

ImageActionDP Class
ElImage Namespace


ImageActionDP Methods

[image] [image]

4 of William Foster's Class Libraries
ImageActionDP Methods
ImageActionDP Class See Also Send Feedback

The ImageActionDP type exposes the following members.

Methods

 | Name | Description
Public method | ApplyAction | (Inherited from ActionDP.)
Public method | CombineAction | (Inherited from ActionDP.)
Public method | CompletedAction | (Overrides ActionDP..::..CompletedAction(Boolean).)
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Dup | (Inherited from ActionDP.)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | EditDX | Override this to edit the action parameters via a dialog before processing starts on a new action.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformAction | (Inherited from ActionDP.)
Public method | Prepare |
Public method | Preview | (Inherited from DP.)
Public method | PreviewAction | (Inherited from ActionDP.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UndoAction | (Inherited from ActionDP.)

See Also

ImageActionDP Class
ElImage Namespace


CompletedAction Method

[image]

4 of William Foster's Class Libraries
ImageActionDP..::..CompletedAction Method
ImageActionDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageActionDP.CompletedAction(System.Boolean)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override void CompletedAction(
    bool bActionTaken
)
Visual Basic
Public Overrides Sub CompletedAction ( _
    bActionTaken As Boolean _
)
Visual C++
public:
virtual void CompletedAction(
    bool bActionTaken
) override

Parameters

bActionTaken
Type: System..::..Boolean

[Missing <param name="bActionTaken"/> documentation for "M:ElImage.ImageActionDP.CompletedAction(System.Boolean)"]

See Also

ImageActionDP Class
ElImage Namespace


EditDX Method

[image]

4 of William Foster's Class Libraries
ImageActionDP..::..EditDX Method
ImageActionDP Class See Also Send Feedback
Override this to edit the action parameters via a dialog before processing starts on a new action.

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual bool EditDX()
Visual Basic
Public Overridable Function EditDX As Boolean
Visual C++
public:
virtual bool EditDX()

Return Value

returns false to abort the action

See Also

ImageActionDP Class
ElImage Namespace


Prepare Method

[image]

4 of William Foster's Class Libraries
ImageActionDP..::..Prepare Method
ImageActionDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageActionDP.Prepare(ElImage.ImageWindow)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual bool Prepare(
    ImageWindow wnd
)
Visual Basic
Public Overridable Function Prepare ( _
    wnd As ImageWindow _
) As Boolean
Visual C++
public:
virtual bool Prepare(
    ImageWindow^ wnd
)

Parameters

wnd
Type: ElImage..::..ImageWindow

[Missing <param name="wnd"/> documentation for "M:ElImage.ImageActionDP.Prepare(ElImage.ImageWindow)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ImageActionDP.Prepare(ElImage.ImageWindow)"]

See Also

ImageActionDP Class
ElImage Namespace


ImageActionDP Properties

[image] [image]

4 of William Foster's Class Libraries
ImageActionDP Properties
ImageActionDP Class See Also Send Feedback

The ImageActionDP type exposes the following members.

Properties

 | Name | Description
Public property | Name | (Inherited from ActionDP.)

See Also

ImageActionDP Class
ElImage Namespace


ImageActionDX Class

[image]

4 of William Foster's Class Libraries
ImageActionDX Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.ImageActionDX"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class ImageActionDX : DX
Visual Basic
Public Class ImageActionDX _
    Inherits DX
Visual C++
public ref class ImageActionDX : public DX

Inheritance Hierarchy

System..::..Object
ElGUI..::..DX
ElImage..::..ImageActionDX

See Also

ImageActionDX Members
ElImage Namespace


ImageActionDX Members

[image] [image]

4 of William Foster's Class Libraries
ImageActionDX Members
ImageActionDX Class Constructors Methods Fields See Also Send Feedback

The ImageActionDX type exposes the following members.

Constructors

 | Name | Description
Public method | ImageActionDX | Initializes a new instance of the ImageActionDX class

Methods

 | Name | Description
Protected method | CreateMatrix | (Inherited from DX.)
Public method | CreateTable | Set up the (empty) DX in memory with fields representing values (Inherited from DX.)
Public method | Dup | (Overrides DX..::..Dup()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateResource | (Inherited from DX.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMember | (Inherited from DX.)
Public method | GetMemberBool | (Inherited from DX.)
Public method | GetSet | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetCheck | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetText | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetUint | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateField | Check the DXEntry list for a resource control with the given name (Inherited from DX.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegistryLoad | Load up this DX from the default registry entries based apon the DXEntry list. (Inherited from DX.)
Public method | RegistrySave | Based apon the DXEntry list, Automatically Save out any important paramenters of this DX to the registry with unique naming (Inherited from DX.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_Bmp |
Protected field | m_csRegistryName | (Inherited from DX.)
Public field | m_dlgdp_classname | (Inherited from DX.)
Protected field | m_FieldList | (Inherited from DX.)

See Also

ImageActionDX Class
ElImage Namespace


ImageActionDX Constructor

[image]

4 of William Foster's Class Libraries
ImageActionDX Constructor
ImageActionDX Class See Also Send Feedback
Initializes a new instance of the ImageActionDX class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ImageActionDX()
Visual Basic
Public Sub New
Visual C++
public:
ImageActionDX()

See Also

ImageActionDX Class
ElImage Namespace


ImageActionDX Fields

[image] [image]

4 of William Foster's Class Libraries
ImageActionDX Fields
ImageActionDX Class See Also Send Feedback

The ImageActionDX type exposes the following members.

Fields

 | Name | Description
Public field | m_Bmp |
Protected field | m_csRegistryName | (Inherited from DX.)
Public field | m_dlgdp_classname | (Inherited from DX.)
Protected field | m_FieldList | (Inherited from DX.)

See Also

ImageActionDX Class
ElImage Namespace


m_Bmp Field

[image]

4 of William Foster's Class Libraries
ImageActionDX..::..m_Bmp Field
ImageActionDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.ImageActionDX.m_Bmp"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap m_Bmp
Visual Basic
Public m_Bmp As Bitmap
Visual C++
public:
Bitmap^ m_Bmp

See Also

ImageActionDX Class
ElImage Namespace


ImageActionDX Methods

[image] [image]

4 of William Foster's Class Libraries
ImageActionDX Methods
ImageActionDX Class See Also Send Feedback

The ImageActionDX type exposes the following members.

Methods

 | Name | Description
Protected method | CreateMatrix | (Inherited from DX.)
Public method | CreateTable | Set up the (empty) DX in memory with fields representing values (Inherited from DX.)
Public method | Dup | (Overrides DX..::..Dup()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateResource | (Inherited from DX.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMember | (Inherited from DX.)
Public method | GetMemberBool | (Inherited from DX.)
Public method | GetSet | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetCheck | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetText | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetUint | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateField | Check the DXEntry list for a resource control with the given name (Inherited from DX.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegistryLoad | Load up this DX from the default registry entries based apon the DXEntry list. (Inherited from DX.)
Public method | RegistrySave | Based apon the DXEntry list, Automatically Save out any important paramenters of this DX to the registry with unique naming (Inherited from DX.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageActionDX Class
ElImage Namespace


Dup Method

[image]

4 of William Foster's Class Libraries
ImageActionDX..::..Dup Method
ImageActionDX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageActionDX.Dup"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override DX Dup()
Visual Basic
Public Overrides Function Dup As DX
Visual C++
public:
virtual DX^ Dup() override

Return Value

[Missing <returns> documentation for "M:ElImage.ImageActionDX.Dup"]

See Also

ImageActionDX Class
ElImage Namespace


ImageEdit Class

[image]

4 of William Foster's Class Libraries
ImageEdit Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.ImageEdit"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class ImageEdit
Visual Basic
Public Class ImageEdit
Visual C++
public ref class ImageEdit

Inheritance Hierarchy

System..::..Object
ElImage..::..ImageEdit

See Also

ImageEdit Members
ElImage Namespace


ImageEdit Members

[image] [image]

4 of William Foster's Class Libraries
ImageEdit Members
ImageEdit Class Constructors Methods Fields See Also Send Feedback

The ImageEdit type exposes the following members.

Constructors

 | Name | Description
Public method | ImageEdit | Initializes a new instance of the ImageEdit class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_image |

See Also

ImageEdit Class
ElImage Namespace


ImageEdit Constructor

[image]

4 of William Foster's Class Libraries
ImageEdit Constructor
ImageEdit Class See Also Send Feedback
Initializes a new instance of the ImageEdit class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ImageEdit(
    UILayerWindow Layer
)
Visual Basic
Public Sub New ( _
    Layer As UILayerWindow _
)
Visual C++
public:
ImageEdit(
    UILayerWindow^ Layer
)

Parameters

Layer
Type: ElGUI..::..UILayerWindow

[Missing <param name="Layer"/> documentation for "M:ElImage.ImageEdit.#ctor(ElGUI.UILayerWindow)"]

See Also

ImageEdit Class
ElImage Namespace


ImageEdit Fields

[image] [image]

4 of William Foster's Class Libraries
ImageEdit Fields
ImageEdit Class See Also Send Feedback

The ImageEdit type exposes the following members.

Fields

 | Name | Description
Public field | m_image |

See Also

ImageEdit Class
ElImage Namespace


m_image Field

[image]

4 of William Foster's Class Libraries
ImageEdit..::..m_image Field
ImageEdit Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.ImageEdit.m_image"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image m_image
Visual Basic
Public m_image As Image
Visual C++
public:
Image^ m_image

See Also

ImageEdit Class
ElImage Namespace


ImageEdit Methods

[image] [image]

4 of William Foster's Class Libraries
ImageEdit Methods
ImageEdit Class See Also Send Feedback

The ImageEdit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageEdit Class
ElImage Namespace


ImageFormat_ClassFactory Class

[image]

4 of William Foster's Class Libraries
ImageFormat_ClassFactory Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.ImageFormat_ClassFactory"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static class ImageFormat_ClassFactory
Visual Basic
Public NotInheritable Class ImageFormat_ClassFactory
Visual C++
public ref class ImageFormat_ClassFactory abstract sealed

Inheritance Hierarchy

System..::..Object
ElImage..::..ImageFormat_ClassFactory

See Also

ImageFormat_ClassFactory Members
ElImage Namespace


ImageFormat_ClassFactory Members

[image] [image]

4 of William Foster's Class Libraries
ImageFormat_ClassFactory Members
ImageFormat_ClassFactory Class Methods See Also Send Feedback

The ImageFormat_ClassFactory type exposes the following members.

Methods

Name | Description
Manufacture |

See Also

ImageFormat_ClassFactory Class
ElImage Namespace


ImageFormat_ClassFactory Methods

[image] [image]

4 of William Foster's Class Libraries
ImageFormat_ClassFactory Methods
ImageFormat_ClassFactory Class See Also Send Feedback

The ImageFormat_ClassFactory type exposes the following members.

Methods

Name | Description
Manufacture |

See Also

ImageFormat_ClassFactory Class
ElImage Namespace


Manufacture Method

[image]

4 of William Foster's Class Libraries
ImageFormat_ClassFactory..::..Manufacture Method
ImageFormat_ClassFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageFormat_ClassFactory.Manufacture(El.Stream)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static Image_Format Manufacture(
    Stream stream
)
Visual Basic
Public Shared Function Manufacture ( _
    stream As Stream _
) As Image_Format
Visual C++
public:
static Image_Format^ Manufacture(
    Stream^ stream
)

Parameters

stream
Type: Stream

[Missing <param name="stream"/> documentation for "M:ElImage.ImageFormat_ClassFactory.Manufacture(El.Stream)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ImageFormat_ClassFactory.Manufacture(El.Stream)"]

See Also

ImageFormat_ClassFactory Class
ElImage Namespace


ImageWindow Class

[image]

4 of William Foster's Class Libraries
ImageWindow Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.ImageWindow"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class ImageWindow : MenuWindow
Visual Basic
Public Class ImageWindow _
    Inherits MenuWindow
Visual C++
public ref class ImageWindow : public MenuWindow

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..MenuWindow
ElImage..::..ImageWindow

See Also

ImageWindow Members
ElImage Namespace


ImageWindow Members

[image] [image]

4 of William Foster's Class Libraries
ImageWindow Members
ImageWindow Class Constructors Methods Fields Properties See Also Send Feedback

The ImageWindow type exposes the following members.

Constructors

 | Name | Description
Public method | ImageWindow | Initializes a new instance of the ImageWindow class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu | (Inherited from MenuWindow.)
Public method | AddSelection |
Public method | AnythingSelected |
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | ColorUnderPoint |
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | DeleteSelection |
Public method | DeSelect |
Public method | Dirty | (Overrides UILayerWindow..::..Dirty()()()().)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetBitmap |
Public method | GetCurrentBitmap |
Public method | GetCurrentLayer |
Public method | GetCurrentSelection | Returns a Thing2d that is the Thing representation of the current selection.
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImage |
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOrigin |
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSelectionBitmap |
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetThing |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetWritableBitmap |
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | GetZoom |
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | InvalidateMix |
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Public method | LayerUnderPoint |
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveSelection |
Public method | NextSelection |
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Overrides Window..::..OnFocusIn()()()().)
Public method | OnFocusOut | (Overrides Window..::..OnFocusOut()()()().)
Public method | OnKeyDown | (Inherited from MenuWindow.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from MenuWindow.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Overrides UILayerWindow..::..OnResize(Size2dU).)
Public method | OptimizeLook |
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Public method | PreviousSelection |
Protected method | RecordKeyboardShortcut | (Inherited from MenuWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | RegisterOperation |
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Public method | RenderBitmap |
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceSelection |
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | Save |
Public method | ScreenToImage |
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SelectAlpha | Pick up an area described by Alpha from the background. Add or Subtract based on parameters
Public method | SelectionUnderPoint |
Public method | SelectLayer |
Public method | SelectRectangle |
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetImage |
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateMarchingAnts |
Public method | UpdateReflectedImage |
Protected method | WithinImage | Checks a screen click position to make sure we are within the actual image, and not it's scrollbars or beyond it's limits
Public method | WndProc | (Inherited from UILayerWindow.)
Public method | ZoomIn |
Public method | ZoomOut |

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName | (Inherited from MenuWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Protected field | m_Image |
Public field | m_img |
Public field | m_marching_ants |
Public field | m_msg | (Inherited from Window.)
Protected field | m_origin |
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)
Protected field | m_zoom |

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ImageWindow Class
ElImage Namespace


ImageWindow Constructor

[image]

4 of William Foster's Class Libraries
ImageWindow Constructor
ImageWindow Class See Also Send Feedback
Initializes a new instance of the ImageWindow class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ImageWindow(
    GUI gui,
    string csTitle,
    Image Image,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    csTitle As String, _
    Image As Image, _
    Parent As Window _
)
Visual C++
public:
ImageWindow(
    GUI^ gui,
    String^ csTitle,
    Image^ Image,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElImage.ImageWindow.#ctor(ElGUI.GUI,System.String,ElImage.Image,ElGUI.Window)"]

csTitle
Type: System..::..String

[Missing <param name="csTitle"/> documentation for "M:ElImage.ImageWindow.#ctor(ElGUI.GUI,System.String,ElImage.Image,ElGUI.Window)"]

Image
Type: ElImage..::..Image

[Missing <param name="Image"/> documentation for "M:ElImage.ImageWindow.#ctor(ElGUI.GUI,System.String,ElImage.Image,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElImage.ImageWindow.#ctor(ElGUI.GUI,System.String,ElImage.Image,ElGUI.Window)"]

See Also

ImageWindow Class
ElImage Namespace


ImageWindow Fields

[image] [image]

4 of William Foster's Class Libraries
ImageWindow Fields
ImageWindow Class See Also Send Feedback

The ImageWindow type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName | (Inherited from MenuWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Protected field | m_Image |
Public field | m_img |
Public field | m_marching_ants |
Public field | m_msg | (Inherited from Window.)
Protected field | m_origin |
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)
Protected field | m_zoom |

See Also

ImageWindow Class
ElImage Namespace


m_Image Field

[image]

4 of William Foster's Class Libraries
ImageWindow..::..m_Image Field
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.ImageWindow.m_Image"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected Image m_Image
Visual Basic
Protected m_Image As Image
Visual C++
protected:
Image^ m_Image

See Also

ImageWindow Class
ElImage Namespace


m_img Field

[image]

4 of William Foster's Class Libraries
ImageWindow..::..m_img Field
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.ImageWindow.m_img"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ImageEdit m_img
Visual Basic
Public m_img As ImageEdit
Visual C++
public:
ImageEdit^ m_img

See Also

ImageWindow Class
ElImage Namespace


m_marching_ants Field

[image]

4 of William Foster's Class Libraries
ImageWindow..::..m_marching_ants Field
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.ImageWindow.m_marching_ants"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public MarchingAnts_Rectangle m_marching_ants
Visual Basic
Public m_marching_ants As MarchingAnts_Rectangle
Visual C++
public:
MarchingAnts_Rectangle^ m_marching_ants

See Also

ImageWindow Class
ElImage Namespace


m_origin Field

[image]

4 of William Foster's Class Libraries
ImageWindow..::..m_origin Field
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.ImageWindow.m_origin"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected Size2dU m_origin
Visual Basic
Protected m_origin As Size2dU
Visual C++
protected:
Size2dU^ m_origin

See Also

ImageWindow Class
ElImage Namespace


m_zoom Field

[image]

4 of William Foster's Class Libraries
ImageWindow..::..m_zoom Field
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.ImageWindow.m_zoom"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected double m_zoom
Visual Basic
Protected m_zoom As Double
Visual C++
protected:
double m_zoom

See Also

ImageWindow Class
ElImage Namespace


ImageWindow Methods

[image] [image]

4 of William Foster's Class Libraries
ImageWindow Methods
ImageWindow Class See Also Send Feedback

The ImageWindow type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu | (Inherited from MenuWindow.)
Public method | AddSelection |
Public method | AnythingSelected |
Public method | AppendText | (Inherited from UILayerWindow.)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | ColorUnderPoint |
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Public method | DeleteSelection |
Public method | DeSelect |
Public method | Dirty | (Overrides UILayerWindow..::..Dirty()()()().)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Public method | GetBitmap |
Public method | GetCurrentBitmap |
Public method | GetCurrentLayer |
Public method | GetCurrentSelection | Returns a Thing2d that is the Thing representation of the current selection.
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImage |
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOrigin |
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSelectionBitmap |
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetThing |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetWritableBitmap |
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | GetZoom |
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | InvalidateMix |
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Public method | LayerUnderPoint |
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveSelection |
Public method | NextSelection |
Protected method | OnCreate | (Inherited from UILayerWindow.)
Protected method | OnDestroy | (Inherited from Window.)
Public method | OnFocusIn | (Overrides Window..::..OnFocusIn()()()().)
Public method | OnFocusOut | (Overrides Window..::..OnFocusOut()()()().)
Public method | OnKeyDown | (Inherited from MenuWindow.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Inherited from MenuWindow.)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Overrides UILayerWindow..::..OnResize(Size2dU).)
Public method | OptimizeLook |
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Public method | PreviousSelection |
Protected method | RecordKeyboardShortcut | (Inherited from MenuWindow.)
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | RegisterOperation |
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Public method | RenderBitmap |
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceSelection |
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | Save |
Public method | ScreenToImage |
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SelectAlpha | Pick up an area described by Alpha from the background. Add or Subtract based on parameters
Public method | SelectionUnderPoint |
Public method | SelectLayer |
Public method | SelectRectangle |
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetImage |
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateMarchingAnts |
Public method | UpdateReflectedImage |
Protected method | WithinImage | Checks a screen click position to make sure we are within the actual image, and not it's scrollbars or beyond it's limits
Public method | WndProc | (Inherited from UILayerWindow.)
Public method | ZoomIn |
Public method | ZoomOut |

See Also

ImageWindow Class
ElImage Namespace


AddSelection Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..AddSelection Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.AddSelection(ElImage.Thing2d)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void AddSelection(
    Thing2d Sel
)
Visual Basic
Public Sub AddSelection ( _
    Sel As Thing2d _
)
Visual C++
public:
void AddSelection(
    Thing2d^ Sel
)

Parameters

Sel
Type: ElImage..::..Thing2d

[Missing <param name="Sel"/> documentation for "M:ElImage.ImageWindow.AddSelection(ElImage.Thing2d)"]

See Also

ImageWindow Class
ElImage Namespace


AnythingSelected Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..AnythingSelected Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.AnythingSelected"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool AnythingSelected()
Visual Basic
Public Function AnythingSelected As Boolean
Visual C++
public:
bool AnythingSelected()

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.AnythingSelected"]

See Also

ImageWindow Class
ElImage Namespace


ColorUnderPoint Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..ColorUnderPoint Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.ColorUnderPoint(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Color ColorUnderPoint(
    Size2dU pointScreen
)
Visual Basic
Public Function ColorUnderPoint ( _
    pointScreen As Size2dU _
) As Color
Visual C++
public:
Color^ ColorUnderPoint(
    Size2dU^ pointScreen
)

Parameters

pointScreen
Type: Size2dU

[Missing <param name="pointScreen"/> documentation for "M:ElImage.ImageWindow.ColorUnderPoint(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.ColorUnderPoint(El.Size2dU)"]

See Also

ImageWindow Class
ElImage Namespace


DeleteSelection Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..DeleteSelection Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.DeleteSelection"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void DeleteSelection()
Visual Basic
Public Sub DeleteSelection
Visual C++
public:
void DeleteSelection()

See Also

ImageWindow Class
ElImage Namespace


DeSelect Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..DeSelect Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.DeSelect"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual bool DeSelect()
Visual Basic
Public Overridable Function DeSelect As Boolean
Visual C++
public:
virtual bool DeSelect()

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.DeSelect"]

See Also

ImageWindow Class
ElImage Namespace


Dirty Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..Dirty Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.Dirty"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override void Dirty()
Visual Basic
Public Overrides Sub Dirty
Visual C++
public:
virtual void Dirty() override

See Also

ImageWindow Class
ElImage Namespace


GetBitmap Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..GetBitmap Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.GetBitmap(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap GetBitmap(
    uint uLayer
)
Visual Basic
Public Function GetBitmap ( _
    uLayer As UInteger _
) As Bitmap
Visual C++
public:
Bitmap^ GetBitmap(
    unsigned int uLayer
)

Parameters

uLayer
Type: System..::..UInt32

[Missing <param name="uLayer"/> documentation for "M:ElImage.ImageWindow.GetBitmap(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.GetBitmap(System.UInt32)"]

See Also

ImageWindow Class
ElImage Namespace


GetCurrentBitmap Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..GetCurrentBitmap Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.GetCurrentBitmap"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap GetCurrentBitmap()
Visual Basic
Public Function GetCurrentBitmap As Bitmap
Visual C++
public:
Bitmap^ GetCurrentBitmap()

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.GetCurrentBitmap"]

See Also

ImageWindow Class
ElImage Namespace


GetCurrentLayer Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..GetCurrentLayer Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.GetCurrentLayer"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint GetCurrentLayer()
Visual Basic
Public Function GetCurrentLayer As UInteger
Visual C++
public:
unsigned int GetCurrentLayer()

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.GetCurrentLayer"]

See Also

ImageWindow Class
ElImage Namespace


GetCurrentSelection Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..GetCurrentSelection Method
ImageWindow Class See Also Send Feedback
Returns a Thing2d that is the Thing representation of the current selection.

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Thing2d GetCurrentSelection()
Visual Basic
Public Function GetCurrentSelection As Thing2d
Visual C++
public:
Thing2d^ GetCurrentSelection()

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.GetCurrentSelection"]

See Also

ImageWindow Class
ElImage Namespace


GetImage Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..GetImage Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.GetImage"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image GetImage()
Visual Basic
Public Function GetImage As Image
Visual C++
public:
Image^ GetImage()

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.GetImage"]

See Also

ImageWindow Class
ElImage Namespace


GetOrigin Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..GetOrigin Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.GetOrigin"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Size2dU GetOrigin()
Visual Basic
Public Function GetOrigin As Size2dU
Visual C++
public:
Size2dU^ GetOrigin()

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.GetOrigin"]

See Also

ImageWindow Class
ElImage Namespace


GetSelectionBitmap Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..GetSelectionBitmap Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.GetSelectionBitmap"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap GetSelectionBitmap()
Visual Basic
Public Function GetSelectionBitmap As Bitmap
Visual C++
public:
Bitmap^ GetSelectionBitmap()

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.GetSelectionBitmap"]

See Also

ImageWindow Class
ElImage Namespace


GetThing Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..GetThing Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.GetThing(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Thing2d GetThing(
    uint uLayerNo
)
Visual Basic
Public Function GetThing ( _
    uLayerNo As UInteger _
) As Thing2d
Visual C++
public:
Thing2d^ GetThing(
    unsigned int uLayerNo
)

Parameters

uLayerNo
Type: System..::..UInt32

[Missing <param name="uLayerNo"/> documentation for "M:ElImage.ImageWindow.GetThing(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.GetThing(System.UInt32)"]

See Also

ImageWindow Class
ElImage Namespace


GetWritableBitmap Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..GetWritableBitmap Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.GetWritableBitmap"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public WriteableBitmap GetWritableBitmap()
Visual Basic
Public Function GetWritableBitmap As WriteableBitmap
Visual C++
public:
WriteableBitmap^ GetWritableBitmap()

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.GetWritableBitmap"]

See Also

ImageWindow Class
ElImage Namespace


GetZoom Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..GetZoom Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.GetZoom"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public double GetZoom()
Visual Basic
Public Function GetZoom As Double
Visual C++
public:
double GetZoom()

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.GetZoom"]

See Also

ImageWindow Class
ElImage Namespace


InvalidateMix Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..InvalidateMix Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.InvalidateMix"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void InvalidateMix()
Visual Basic
Public Sub InvalidateMix
Visual C++
public:
void InvalidateMix()

See Also

ImageWindow Class
ElImage Namespace


LayerUnderPoint Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..LayerUnderPoint Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.LayerUnderPoint(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint LayerUnderPoint(
    Size2dU pointScreen
)
Visual Basic
Public Function LayerUnderPoint ( _
    pointScreen As Size2dU _
) As UInteger
Visual C++
public:
unsigned int LayerUnderPoint(
    Size2dU^ pointScreen
)

Parameters

pointScreen
Type: Size2dU

[Missing <param name="pointScreen"/> documentation for "M:ElImage.ImageWindow.LayerUnderPoint(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.LayerUnderPoint(El.Size2dU)"]

See Also

ImageWindow Class
ElImage Namespace


MoveSelection Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..MoveSelection Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.MoveSelection(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void MoveSelection(
    Size2dU delta
)
Visual Basic
Public Sub MoveSelection ( _
    delta As Size2dU _
)
Visual C++
public:
void MoveSelection(
    Size2dU^ delta
)

Parameters

delta
Type: Size2dU

[Missing <param name="delta"/> documentation for "M:ElImage.ImageWindow.MoveSelection(El.Size2dU)"]

See Also

ImageWindow Class
ElImage Namespace


NextSelection Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..NextSelection Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.NextSelection"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool NextSelection()
Visual Basic
Public Function NextSelection As Boolean
Visual C++
public:
bool NextSelection()

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.NextSelection"]

See Also

ImageWindow Class
ElImage Namespace


OnFocusIn Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..OnFocusIn Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.OnFocusIn"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override int OnFocusIn()
Visual Basic
Public Overrides Function OnFocusIn As Integer
Visual C++
public:
virtual int OnFocusIn() override

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.OnFocusIn"]

Implements

ITerminalWindow..::..OnFocusIn()()()()

See Also

ImageWindow Class
ElImage Namespace


OnFocusOut Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..OnFocusOut Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.OnFocusOut"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override int OnFocusOut()
Visual Basic
Public Overrides Function OnFocusOut As Integer
Visual C++
public:
virtual int OnFocusOut() override

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.OnFocusOut"]

Implements

ITerminalWindow..::..OnFocusOut()()()()

See Also

ImageWindow Class
ElImage Namespace


OnResize Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..OnResize Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.OnResize(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected override int OnResize(
    Size2dU size
)
Visual Basic
Protected Overrides Function OnResize ( _
    size As Size2dU _
) As Integer
Visual C++
protected:
virtual int OnResize(
    Size2dU^ size
) override

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElImage.ImageWindow.OnResize(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.OnResize(El.Size2dU)"]

See Also

ImageWindow Class
ElImage Namespace


OptimizeLook Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..OptimizeLook Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.OptimizeLook"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void OptimizeLook()
Visual Basic
Public Sub OptimizeLook
Visual C++
public:
void OptimizeLook()

See Also

ImageWindow Class
ElImage Namespace


PreviousSelection Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..PreviousSelection Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.PreviousSelection"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool PreviousSelection()
Visual Basic
Public Function PreviousSelection As Boolean
Visual C++
public:
bool PreviousSelection()

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.PreviousSelection"]

See Also

ImageWindow Class
ElImage Namespace


RegisterOperation Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..RegisterOperation Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.RegisterOperation(El.STRING)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool RegisterOperation(
    STRING csOperation
)
Visual Basic
Public Function RegisterOperation ( _
    csOperation As STRING _
) As Boolean
Visual C++
public:
bool RegisterOperation(
    STRING^ csOperation
)

Parameters

csOperation
Type: STRING

[Missing <param name="csOperation"/> documentation for "M:ElImage.ImageWindow.RegisterOperation(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.RegisterOperation(El.STRING)"]

See Also

ImageWindow Class
ElImage Namespace


RenderBitmap Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..RenderBitmap Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.RenderBitmap(ElImage.Bitmap,El.Rect2dU,El.Size2dU,System.Double)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void RenderBitmap(
    Bitmap bmp,
    Rect2dU dest_rect,
    Size2dU source_origin,
    double zoom
)
Visual Basic
Public Sub RenderBitmap ( _
    bmp As Bitmap, _
    dest_rect As Rect2dU, _
    source_origin As Size2dU, _
    zoom As Double _
)
Visual C++
public:
void RenderBitmap(
    Bitmap^ bmp,
    Rect2dU^ dest_rect,
    Size2dU^ source_origin,
    double zoom
)

Parameters

bmp
Type: ElImage..::..Bitmap

[Missing <param name="bmp"/> documentation for "M:ElImage.ImageWindow.RenderBitmap(ElImage.Bitmap,El.Rect2dU,El.Size2dU,System.Double)"]

dest_rect
Type: Rect2dU

[Missing <param name="dest_rect"/> documentation for "M:ElImage.ImageWindow.RenderBitmap(ElImage.Bitmap,El.Rect2dU,El.Size2dU,System.Double)"]

source_origin
Type: Size2dU

[Missing <param name="source_origin"/> documentation for "M:ElImage.ImageWindow.RenderBitmap(ElImage.Bitmap,El.Rect2dU,El.Size2dU,System.Double)"]

zoom
Type: System..::..Double

[Missing <param name="zoom"/> documentation for "M:ElImage.ImageWindow.RenderBitmap(ElImage.Bitmap,El.Rect2dU,El.Size2dU,System.Double)"]

See Also

ImageWindow Class
ElImage Namespace


ReplaceSelection Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..ReplaceSelection Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.ReplaceSelection(ElImage.Bitmap)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void ReplaceSelection(
    Bitmap Bmp
)
Visual Basic
Public Sub ReplaceSelection ( _
    Bmp As Bitmap _
)
Visual C++
public:
void ReplaceSelection(
    Bitmap^ Bmp
)

Parameters

Bmp
Type: ElImage..::..Bitmap

[Missing <param name="Bmp"/> documentation for "M:ElImage.ImageWindow.ReplaceSelection(ElImage.Bitmap)"]

See Also

ImageWindow Class
ElImage Namespace


Save Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..Save Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.Save(El.Stream)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Save(
    Stream stream
)
Visual Basic
Public Function Save ( _
    stream As Stream _
) As Boolean
Visual C++
public:
bool Save(
    Stream^ stream
)

Parameters

stream
Type: Stream

[Missing <param name="stream"/> documentation for "M:ElImage.ImageWindow.Save(El.Stream)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.Save(El.Stream)"]

See Also

ImageWindow Class
ElImage Namespace


ScreenToImage Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..ScreenToImage Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.ScreenToImage(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Size2dU ScreenToImage(
    Size2dU pointScreen
)
Visual Basic
Public Function ScreenToImage ( _
    pointScreen As Size2dU _
) As Size2dU
Visual C++
public:
Size2dU^ ScreenToImage(
    Size2dU^ pointScreen
)

Parameters

pointScreen
Type: Size2dU

[Missing <param name="pointScreen"/> documentation for "M:ElImage.ImageWindow.ScreenToImage(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.ScreenToImage(El.Size2dU)"]

See Also

ImageWindow Class
ElImage Namespace


SelectAlpha Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..SelectAlpha Method
ImageWindow Class See Also Send Feedback
Pick up an area described by Alpha from the background. Add or Subtract based on parameters

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SelectAlpha(
    Bitmap_Alpha Alpha,
    bool bAdd,
    bool bSubtract
)
Visual Basic
Public Sub SelectAlpha ( _
    Alpha As Bitmap_Alpha, _
    bAdd As Boolean, _
    bSubtract As Boolean _
)
Visual C++
public:
void SelectAlpha(
    Bitmap_Alpha^ Alpha,
    bool bAdd,
    bool bSubtract
)

Parameters

Alpha
Type: ElImage..::..Bitmap_Alpha

[Missing <param name="Alpha"/> documentation for "M:ElImage.ImageWindow.SelectAlpha(ElImage.Bitmap_Alpha,System.Boolean,System.Boolean)"]

bAdd
Type: System..::..Boolean
Add to exisiting selection?
bSubtract
Type: System..::..Boolean
Subtract from existing selection?

See Also

ImageWindow Class
ElImage Namespace


SelectionUnderPoint Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..SelectionUnderPoint Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.SelectionUnderPoint(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool SelectionUnderPoint(
    Size2dU pointScreen
)
Visual Basic
Public Function SelectionUnderPoint ( _
    pointScreen As Size2dU _
) As Boolean
Visual C++
public:
bool SelectionUnderPoint(
    Size2dU^ pointScreen
)

Parameters

pointScreen
Type: Size2dU

[Missing <param name="pointScreen"/> documentation for "M:ElImage.ImageWindow.SelectionUnderPoint(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.SelectionUnderPoint(El.Size2dU)"]

See Also

ImageWindow Class
ElImage Namespace


SelectLayer Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..SelectLayer Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.SelectLayer(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SelectLayer(
    uint uLayer
)
Visual Basic
Public Sub SelectLayer ( _
    uLayer As UInteger _
)
Visual C++
public:
void SelectLayer(
    unsigned int uLayer
)

Parameters

uLayer
Type: System..::..UInt32

[Missing <param name="uLayer"/> documentation for "M:ElImage.ImageWindow.SelectLayer(System.UInt32)"]

See Also

ImageWindow Class
ElImage Namespace


SelectRectangle Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..SelectRectangle Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.SelectRectangle(El.Rect2dU,System.Boolean,System.Boolean)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SelectRectangle(
    Rect2dU rect,
    bool bAdd,
    bool bSubtract
)
Visual Basic
Public Sub SelectRectangle ( _
    rect As Rect2dU, _
    bAdd As Boolean, _
    bSubtract As Boolean _
)
Visual C++
public:
void SelectRectangle(
    Rect2dU^ rect,
    bool bAdd,
    bool bSubtract
)

Parameters

rect
Type: Rect2dU

[Missing <param name="rect"/> documentation for "M:ElImage.ImageWindow.SelectRectangle(El.Rect2dU,System.Boolean,System.Boolean)"]

bAdd
Type: System..::..Boolean

[Missing <param name="bAdd"/> documentation for "M:ElImage.ImageWindow.SelectRectangle(El.Rect2dU,System.Boolean,System.Boolean)"]

bSubtract
Type: System..::..Boolean

[Missing <param name="bSubtract"/> documentation for "M:ElImage.ImageWindow.SelectRectangle(El.Rect2dU,System.Boolean,System.Boolean)"]

See Also

ImageWindow Class
ElImage Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
ImageWindow..::..SetColor Method
ImageWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

ImageWindow Class
ImageWindow Members
ElImage Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
ImageWindow..::..SetDefaultCursor Method
ImageWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

ImageWindow Class
ImageWindow Members
ElImage Namespace


SetImage Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..SetImage Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.SetImage(ElImage.Image)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual void SetImage(
    Image Image
)
Visual Basic
Public Overridable Sub SetImage ( _
    Image As Image _
)
Visual C++
public:
virtual void SetImage(
    Image^ Image
)

Parameters

Image
Type: ElImage..::..Image

[Missing <param name="Image"/> documentation for "M:ElImage.ImageWindow.SetImage(ElImage.Image)"]

See Also

ImageWindow Class
ElImage Namespace


UpdateMarchingAnts Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..UpdateMarchingAnts Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.UpdateMarchingAnts"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void UpdateMarchingAnts()
Visual Basic
Public Sub UpdateMarchingAnts
Visual C++
public:
void UpdateMarchingAnts()

See Also

ImageWindow Class
ElImage Namespace


UpdateReflectedImage Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..UpdateReflectedImage Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.UpdateReflectedImage"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void UpdateReflectedImage()
Visual Basic
Public Sub UpdateReflectedImage
Visual C++
public:
void UpdateReflectedImage()

See Also

ImageWindow Class
ElImage Namespace


WithinImage Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..WithinImage Method
ImageWindow Class See Also Send Feedback
Checks a screen click position to make sure we are within the actual image, and not it's scrollbars or beyond it's limits

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected bool WithinImage(
    Size2dU pos
)
Visual Basic
Protected Function WithinImage ( _
    pos As Size2dU _
) As Boolean
Visual C++
protected:
bool WithinImage(
    Size2dU^ pos
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.ImageWindow.WithinImage(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ImageWindow.WithinImage(El.Size2dU)"]

See Also

ImageWindow Class
ElImage Namespace


ZoomIn Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..ZoomIn Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.ZoomIn"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void ZoomIn()
Visual Basic
Public Sub ZoomIn
Visual C++
public:
void ZoomIn()

See Also

ImageWindow Class
ElImage Namespace


ZoomOut Method

[image]

4 of William Foster's Class Libraries
ImageWindow..::..ZoomOut Method
ImageWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ImageWindow.ZoomOut"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void ZoomOut()
Visual Basic
Public Sub ZoomOut
Visual C++
public:
void ZoomOut()

See Also

ImageWindow Class
ElImage Namespace


ImageWindow Properties

[image] [image]

4 of William Foster's Class Libraries
ImageWindow Properties
ImageWindow Class See Also Send Feedback

The ImageWindow type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

ImageWindow Class
ElImage Namespace


Layer Class

[image]

4 of William Foster's Class Libraries
Layer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Layer"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Layer
Visual Basic
Public Class Layer
Visual C++
public ref class Layer

Inheritance Hierarchy

System..::..Object
ElImage..::..Layer

See Also

Layer Members
ElImage Namespace


Layer Members

[image] [image]

4 of William Foster's Class Libraries
Layer Members
Layer Class Constructors Methods Fields See Also Send Feedback

The Layer type exposes the following members.

Constructors

 | Name | Description
Public method | Layer(Layer) | Initializes a new instance of the Layer class
Public method | Layer(UInt32, STRING) | Initializes a new instance of the Layer class

Methods

 | Name | Description
Public method | ClearContent |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageSize |
Public method | GetName |
Public method | GetNumber |
Public method | GetTag |
Public method | GetThing |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserDatafield |
Public method | IsBitmap |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetContent |
Public method | SetImageSize |
Public method | SetName |
Public method | SetNumber |
Public method | SetTag |
Public method | SetUserDatafield |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_Content |
Protected field | m_csName |
Protected field | m_Number |

See Also

Layer Class
ElImage Namespace


Layer Constructor

[image] [image]

4 of William Foster's Class Libraries
Layer Constructor
Layer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Layer(Layer) | Initializes a new instance of the Layer class
Public method | Layer(UInt32, STRING) | Initializes a new instance of the Layer class

See Also

Layer Class
Layer Members
ElImage Namespace


Layer Constructor (Layer)

[image]

4 of William Foster's Class Libraries
Layer Constructor (Layer)
Layer Class See Also Send Feedback
Initializes a new instance of the Layer class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Layer(
    Layer duper
)
Visual Basic
Public Sub New ( _
    duper As Layer _
)
Visual C++
public:
Layer(
    Layer^ duper
)

Parameters

duper
Type: ElImage..::..Layer

[Missing <param name="duper"/> documentation for "M:ElImage.Layer.#ctor(ElImage.Layer)"]

See Also

Layer Class
Layer Overload
ElImage Namespace


Layer Constructor (UInt32, )

[image]

4 of William Foster's Class Libraries
Layer Constructor (UInt32, )
Layer Class See Also Send Feedback
Initializes a new instance of the Layer class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Layer(
    uint number,
    STRING name
)
Visual Basic
Public Sub New ( _
    number As UInteger, _
    name As STRING _
)
Visual C++
public:
Layer(
    unsigned int number,
    STRING^ name
)

Parameters

number
Type: System..::..UInt32

[Missing <param name="number"/> documentation for "M:ElImage.Layer.#ctor(System.UInt32,El.STRING)"]

name
Type: STRING

[Missing <param name="name"/> documentation for "M:ElImage.Layer.#ctor(System.UInt32,El.STRING)"]

See Also

Layer Class
Layer Overload
ElImage Namespace


Layer Fields

[image] [image]

4 of William Foster's Class Libraries
Layer Fields
Layer Class See Also Send Feedback

The Layer type exposes the following members.

Fields

 | Name | Description
Protected field | m_Content |
Protected field | m_csName |
Protected field | m_Number |

See Also

Layer Class
ElImage Namespace


m_Content Field

[image]

4 of William Foster's Class Libraries
Layer..::..m_Content Field
Layer Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Layer.m_Content"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected Thing2d m_Content
Visual Basic
Protected m_Content As Thing2d
Visual C++
protected:
Thing2d^ m_Content

See Also

Layer Class
ElImage Namespace


m_csName Field

[image]

4 of William Foster's Class Libraries
Layer..::..m_csName Field
Layer Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Layer.m_csName"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected STRING m_csName
Visual Basic
Protected m_csName As STRING
Visual C++
protected:
STRING^ m_csName

See Also

Layer Class
ElImage Namespace


m_Number Field

[image]

4 of William Foster's Class Libraries
Layer..::..m_Number Field
Layer Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Layer.m_Number"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected uint m_Number
Visual Basic
Protected m_Number As UInteger
Visual C++
protected:
unsigned int m_Number

See Also

Layer Class
ElImage Namespace


Layer Methods

[image] [image]

4 of William Foster's Class Libraries
Layer Methods
Layer Class See Also Send Feedback

The Layer type exposes the following members.

Methods

 | Name | Description
Public method | ClearContent |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageSize |
Public method | GetName |
Public method | GetNumber |
Public method | GetTag |
Public method | GetThing |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserDatafield |
Public method | IsBitmap |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetContent |
Public method | SetImageSize |
Public method | SetName |
Public method | SetNumber |
Public method | SetTag |
Public method | SetUserDatafield |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Layer Class
ElImage Namespace


ClearContent Method

[image]

4 of William Foster's Class Libraries
Layer..::..ClearContent Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.ClearContent"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void ClearContent()
Visual Basic
Public Sub ClearContent
Visual C++
public:
void ClearContent()

See Also

Layer Class
ElImage Namespace


GetImageSize Method

[image]

4 of William Foster's Class Libraries
Layer..::..GetImageSize Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.GetImageSize"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Size2dU GetImageSize()
Visual Basic
Public Function GetImageSize As Size2dU
Visual C++
public:
Size2dU^ GetImageSize()

Return Value

[Missing <returns> documentation for "M:ElImage.Layer.GetImageSize"]

See Also

Layer Class
ElImage Namespace


GetName Method

[image]

4 of William Foster's Class Libraries
Layer..::..GetName Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.GetName"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public STRING GetName()
Visual Basic
Public Function GetName As STRING
Visual C++
public:
STRING^ GetName()

Return Value

[Missing <returns> documentation for "M:ElImage.Layer.GetName"]

See Also

Layer Class
ElImage Namespace


GetNumber Method

[image]

4 of William Foster's Class Libraries
Layer..::..GetNumber Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.GetNumber"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint GetNumber()
Visual Basic
Public Function GetNumber As UInteger
Visual C++
public:
unsigned int GetNumber()

Return Value

[Missing <returns> documentation for "M:ElImage.Layer.GetNumber"]

See Also

Layer Class
ElImage Namespace


GetTag Method

[image]

4 of William Foster's Class Libraries
Layer..::..GetTag Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.GetTag(El.STRING,El.STRING)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool GetTag(
    STRING tag,
    STRING data
)
Visual Basic
Public Function GetTag ( _
    tag As STRING, _
    data As STRING _
) As Boolean
Visual C++
public:
bool GetTag(
    STRING^ tag,
    STRING^ data
)

Parameters

tag
Type: STRING

[Missing <param name="tag"/> documentation for "M:ElImage.Layer.GetTag(El.STRING,El.STRING)"]

data
Type: STRING

[Missing <param name="data"/> documentation for "M:ElImage.Layer.GetTag(El.STRING,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Layer.GetTag(El.STRING,El.STRING)"]

See Also

Layer Class
ElImage Namespace


GetThing Method

[image]

4 of William Foster's Class Libraries
Layer..::..GetThing Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.GetThing"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Thing2d GetThing()
Visual Basic
Public Function GetThing As Thing2d
Visual C++
public:
Thing2d^ GetThing()

Return Value

[Missing <returns> documentation for "M:ElImage.Layer.GetThing"]

See Also

Layer Class
ElImage Namespace


GetUserDatafield Method

[image]

4 of William Foster's Class Libraries
Layer..::..GetUserDatafield Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.GetUserDatafield"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Allocation GetUserDatafield()
Visual Basic
Public Function GetUserDatafield As Allocation
Visual C++
public:
Allocation^ GetUserDatafield()

Return Value

[Missing <returns> documentation for "M:ElImage.Layer.GetUserDatafield"]

See Also

Layer Class
ElImage Namespace


IsBitmap Method

[image]

4 of William Foster's Class Libraries
Layer..::..IsBitmap Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.IsBitmap"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool IsBitmap()
Visual Basic
Public Function IsBitmap As Boolean
Visual C++
public:
bool IsBitmap()

Return Value

[Missing <returns> documentation for "M:ElImage.Layer.IsBitmap"]

See Also

Layer Class
ElImage Namespace


SetContent Method

[image]

4 of William Foster's Class Libraries
Layer..::..SetContent Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.SetContent(ElImage.Thing2d)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetContent(
    Thing2d content
)
Visual Basic
Public Sub SetContent ( _
    content As Thing2d _
)
Visual C++
public:
void SetContent(
    Thing2d^ content
)

Parameters

content
Type: ElImage..::..Thing2d

[Missing <param name="content"/> documentation for "M:ElImage.Layer.SetContent(ElImage.Thing2d)"]

See Also

Layer Class
ElImage Namespace


SetImageSize Method

[image]

4 of William Foster's Class Libraries
Layer..::..SetImageSize Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.SetImageSize(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetImageSize(
    Size2dU size
)
Visual Basic
Public Sub SetImageSize ( _
    size As Size2dU _
)
Visual C++
public:
void SetImageSize(
    Size2dU^ size
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElImage.Layer.SetImageSize(El.Size2dU)"]

See Also

Layer Class
ElImage Namespace


SetName Method

[image]

4 of William Foster's Class Libraries
Layer..::..SetName Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.SetName(El.STRING)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetName(
    STRING csName
)
Visual Basic
Public Sub SetName ( _
    csName As STRING _
)
Visual C++
public:
void SetName(
    STRING^ csName
)

Parameters

csName
Type: STRING

[Missing <param name="csName"/> documentation for "M:ElImage.Layer.SetName(El.STRING)"]

See Also

Layer Class
ElImage Namespace


SetNumber Method

[image]

4 of William Foster's Class Libraries
Layer..::..SetNumber Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.SetNumber(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetNumber(
    uint number
)
Visual Basic
Public Sub SetNumber ( _
    number As UInteger _
)
Visual C++
public:
void SetNumber(
    unsigned int number
)

Parameters

number
Type: System..::..UInt32

[Missing <param name="number"/> documentation for "M:ElImage.Layer.SetNumber(System.UInt32)"]

See Also

Layer Class
ElImage Namespace


SetTag Method

[image]

4 of William Foster's Class Libraries
Layer..::..SetTag Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.SetTag(El.STRING,El.STRING)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool SetTag(
    STRING tag,
    STRING data
)
Visual Basic
Public Function SetTag ( _
    tag As STRING, _
    data As STRING _
) As Boolean
Visual C++
public:
bool SetTag(
    STRING^ tag,
    STRING^ data
)

Parameters

tag
Type: STRING

[Missing <param name="tag"/> documentation for "M:ElImage.Layer.SetTag(El.STRING,El.STRING)"]

data
Type: STRING

[Missing <param name="data"/> documentation for "M:ElImage.Layer.SetTag(El.STRING,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Layer.SetTag(El.STRING,El.STRING)"]

See Also

Layer Class
ElImage Namespace


SetUserDatafield Method

[image]

4 of William Foster's Class Libraries
Layer..::..SetUserDatafield Method
Layer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Layer.SetUserDatafield(El.Allocation)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool SetUserDatafield(
    Allocation data
)
Visual Basic
Public Function SetUserDatafield ( _
    data As Allocation _
) As Boolean
Visual C++
public:
bool SetUserDatafield(
    Allocation^ data
)

Parameters

data
Type: Allocation

[Missing <param name="data"/> documentation for "M:ElImage.Layer.SetUserDatafield(El.Allocation)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Layer.SetUserDatafield(El.Allocation)"]

See Also

Layer Class
ElImage Namespace


MagicWandDP Class

[image]

4 of William Foster's Class Libraries
MagicWandDP Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.MagicWandDP"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class MagicWandDP : DP
Visual Basic
Public Class MagicWandDP _
    Inherits DP
Visual C++
public ref class MagicWandDP : public DP

Inheritance Hierarchy

System..::..Object
ElGUI..::..DP
ElImage..::..MagicWandDP

See Also

MagicWandDP Members
ElImage Namespace


MagicWandDP Members

[image] [image]

4 of William Foster's Class Libraries
MagicWandDP Members
MagicWandDP Class Constructors Methods See Also Send Feedback

The MagicWandDP type exposes the following members.

Constructors

 | Name | Description
Public method | MagicWandDP | Initializes a new instance of the MagicWandDP class

Methods

 | Name | Description
Public method | ClickAndObtainAlpha |
Public method | ClickAndObtainBitmap |
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview | (Inherited from DP.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MagicWandDP Class
ElImage Namespace


MagicWandDP Constructor

[image]

4 of William Foster's Class Libraries
MagicWandDP Constructor
MagicWandDP Class See Also Send Feedback
Initializes a new instance of the MagicWandDP class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public MagicWandDP(
    MagicWandDX Dx
)
Visual Basic
Public Sub New ( _
    Dx As MagicWandDX _
)
Visual C++
public:
MagicWandDP(
    MagicWandDX^ Dx
)

Parameters

Dx
Type: ElImage..::..MagicWandDX

[Missing <param name="Dx"/> documentation for "M:ElImage.MagicWandDP.#ctor(ElImage.MagicWandDX)"]

See Also

MagicWandDP Class
ElImage Namespace


MagicWandDP Methods

[image] [image]

4 of William Foster's Class Libraries
MagicWandDP Methods
MagicWandDP Class See Also Send Feedback

The MagicWandDP type exposes the following members.

Methods

 | Name | Description
Public method | ClickAndObtainAlpha |
Public method | ClickAndObtainBitmap |
Public method | CreateDialog | (Inherited from DP.)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview | (Inherited from DP.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MagicWandDP Class
ElImage Namespace


ClickAndObtainAlpha Method

[image]

4 of William Foster's Class Libraries
MagicWandDP..::..ClickAndObtainAlpha Method
MagicWandDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.MagicWandDP.ClickAndObtainAlpha(ElImage.Bitmap,El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap_Alpha ClickAndObtainAlpha(
    Bitmap bmp,
    Size2dU pos
)
Visual Basic
Public Function ClickAndObtainAlpha ( _
    bmp As Bitmap, _
    pos As Size2dU _
) As Bitmap_Alpha
Visual C++
public:
Bitmap_Alpha^ ClickAndObtainAlpha(
    Bitmap^ bmp,
    Size2dU^ pos
)

Parameters

bmp
Type: ElImage..::..Bitmap

[Missing <param name="bmp"/> documentation for "M:ElImage.MagicWandDP.ClickAndObtainAlpha(ElImage.Bitmap,El.Size2dU)"]

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.MagicWandDP.ClickAndObtainAlpha(ElImage.Bitmap,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.MagicWandDP.ClickAndObtainAlpha(ElImage.Bitmap,El.Size2dU)"]

See Also

MagicWandDP Class
ElImage Namespace


ClickAndObtainBitmap Method

[image]

4 of William Foster's Class Libraries
MagicWandDP..::..ClickAndObtainBitmap Method
MagicWandDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.MagicWandDP.ClickAndObtainBitmap(ElImage.Bitmap,El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap ClickAndObtainBitmap(
    Bitmap bmp,
    Size2dU pos
)
Visual Basic
Public Function ClickAndObtainBitmap ( _
    bmp As Bitmap, _
    pos As Size2dU _
) As Bitmap
Visual C++
public:
Bitmap^ ClickAndObtainBitmap(
    Bitmap^ bmp,
    Size2dU^ pos
)

Parameters

bmp
Type: ElImage..::..Bitmap

[Missing <param name="bmp"/> documentation for "M:ElImage.MagicWandDP.ClickAndObtainBitmap(ElImage.Bitmap,El.Size2dU)"]

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.MagicWandDP.ClickAndObtainBitmap(ElImage.Bitmap,El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.MagicWandDP.ClickAndObtainBitmap(ElImage.Bitmap,El.Size2dU)"]

See Also

MagicWandDP Class
ElImage Namespace


GetDX Method

[image]

4 of William Foster's Class Libraries
MagicWandDP..::..GetDX Method
MagicWandDP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.MagicWandDP.GetDX"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public MagicWandDX GetDX()
Visual Basic
Public Function GetDX As MagicWandDX
Visual C++
public:
MagicWandDX^ GetDX()

Return Value

[Missing <returns> documentation for "M:ElImage.MagicWandDP.GetDX"]

See Also

MagicWandDP Class
ElImage Namespace


MagicWandDX Class

[image]

4 of William Foster's Class Libraries
MagicWandDX Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.MagicWandDX"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class MagicWandDX : DX
Visual Basic
Public Class MagicWandDX _
    Inherits DX
Visual C++
public ref class MagicWandDX : public DX

Inheritance Hierarchy

System..::..Object
ElGUI..::..DX
ElImage..::..MagicWandDX

See Also

MagicWandDX Members
ElImage Namespace


MagicWandDX Members

[image] [image]

4 of William Foster's Class Libraries
MagicWandDX Members
MagicWandDX Class Constructors Methods Fields See Also Send Feedback

The MagicWandDX type exposes the following members.

Constructors

 | Name | Description
Public method | MagicWandDX | Initializes a new instance of the MagicWandDX class

Methods

 | Name | Description
Public method | ColorMatches |
Protected method | CreateMatrix | (Inherited from DX.)
Public method | CreateTable | Set up the (empty) DX in memory with fields representing values (Inherited from DX.)
 | delta |
Public method | Dup | (Overrides DX..::..Dup()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateResource | (Inherited from DX.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMember | (Inherited from DX.)
Public method | GetMemberBool | (Inherited from DX.)
Public method | GetSet | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetCheck | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetText | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetUint | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateField | Check the DXEntry list for a resource control with the given name (Inherited from DX.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegistryLoad | Load up this DX from the default registry entries based apon the DXEntry list. (Inherited from DX.)
Public method | RegistrySave | Based apon the DXEntry list, Automatically Save out any important paramenters of this DX to the registry with unique naming (Inherited from DX.)
Public method | Seed |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_b_Adaptive |
Public field | m_b_Hue |
Public field | m_b_LABA |
Public field | m_b_LABB |
Public field | m_b_LABL |
Public field | m_b_Lightness |
Public field | m_b_Saturation |
Protected field | m_csRegistryName | (Inherited from DX.)
Public field | m_dlgdp_classname | (Inherited from DX.)
Protected field | m_FieldList | (Inherited from DX.)
Public field | m_horz_permeate |
Public field | m_percent_Adapt |
Public field | m_percent_Hue |
Public field | m_percent_LABA |
Public field | m_percent_LABB |
Public field | m_percent_LABL |
Public field | m_percent_Lightness |
Public field | m_percent_Saturation |
Public field | m_Source_Bitmap |
Public field | m_Source_ClickPos |
Public field | m_Source_mode |
Public field | m_test_LABA |
Public field | m_tuning |
Public field | m_vert_permeate |

See Also

MagicWandDX Class
ElImage Namespace


MagicWandDX Constructor

[image]

4 of William Foster's Class Libraries
MagicWandDX Constructor
MagicWandDX Class See Also Send Feedback
Initializes a new instance of the MagicWandDX class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public MagicWandDX()
Visual Basic
Public Sub New
Visual C++
public:
MagicWandDX()

See Also

MagicWandDX Class
ElImage Namespace


MagicWandDX Fields

[image] [image]

4 of William Foster's Class Libraries
MagicWandDX Fields
MagicWandDX Class See Also Send Feedback

The MagicWandDX type exposes the following members.

Fields

 | Name | Description
Public field | m_b_Adaptive |
Public field | m_b_Hue |
Public field | m_b_LABA |
Public field | m_b_LABB |
Public field | m_b_LABL |
Public field | m_b_Lightness |
Public field | m_b_Saturation |
Protected field | m_csRegistryName | (Inherited from DX.)
Public field | m_dlgdp_classname | (Inherited from DX.)
Protected field | m_FieldList | (Inherited from DX.)
Public field | m_horz_permeate |
Public field | m_percent_Adapt |
Public field | m_percent_Hue |
Public field | m_percent_LABA |
Public field | m_percent_LABB |
Public field | m_percent_LABL |
Public field | m_percent_Lightness |
Public field | m_percent_Saturation |
Public field | m_Source_Bitmap |
Public field | m_Source_ClickPos |
Public field | m_Source_mode |
Public field | m_test_LABA |
Public field | m_tuning |
Public field | m_vert_permeate |

See Also

MagicWandDX Class
ElImage Namespace


m_b_Adaptive Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_b_Adaptive Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_b_Adaptive"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool m_b_Adaptive
Visual Basic
Public m_b_Adaptive As Boolean
Visual C++
public:
bool m_b_Adaptive

See Also

MagicWandDX Class
ElImage Namespace


m_b_Hue Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_b_Hue Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_b_Hue"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool m_b_Hue
Visual Basic
Public m_b_Hue As Boolean
Visual C++
public:
bool m_b_Hue

See Also

MagicWandDX Class
ElImage Namespace


m_b_LABA Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_b_LABA Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_b_LABA"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool m_b_LABA
Visual Basic
Public m_b_LABA As Boolean
Visual C++
public:
bool m_b_LABA

See Also

MagicWandDX Class
ElImage Namespace


m_b_LABB Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_b_LABB Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_b_LABB"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool m_b_LABB
Visual Basic
Public m_b_LABB As Boolean
Visual C++
public:
bool m_b_LABB

See Also

MagicWandDX Class
ElImage Namespace


m_b_LABL Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_b_LABL Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_b_LABL"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool m_b_LABL
Visual Basic
Public m_b_LABL As Boolean
Visual C++
public:
bool m_b_LABL

See Also

MagicWandDX Class
ElImage Namespace


m_b_Lightness Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_b_Lightness Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_b_Lightness"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool m_b_Lightness
Visual Basic
Public m_b_Lightness As Boolean
Visual C++
public:
bool m_b_Lightness

See Also

MagicWandDX Class
ElImage Namespace


m_b_Saturation Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_b_Saturation Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_b_Saturation"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool m_b_Saturation
Visual Basic
Public m_b_Saturation As Boolean
Visual C++
public:
bool m_b_Saturation

See Also

MagicWandDX Class
ElImage Namespace


m_horz_permeate Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_horz_permeate Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_horz_permeate"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint m_horz_permeate
Visual Basic
Public m_horz_permeate As UInteger
Visual C++
public:
unsigned int m_horz_permeate

See Also

MagicWandDX Class
ElImage Namespace


m_percent_Adapt Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_percent_Adapt Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_percent_Adapt"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint m_percent_Adapt
Visual Basic
Public m_percent_Adapt As UInteger
Visual C++
public:
unsigned int m_percent_Adapt

See Also

MagicWandDX Class
ElImage Namespace


m_percent_Hue Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_percent_Hue Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_percent_Hue"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint m_percent_Hue
Visual Basic
Public m_percent_Hue As UInteger
Visual C++
public:
unsigned int m_percent_Hue

See Also

MagicWandDX Class
ElImage Namespace


m_percent_LABA Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_percent_LABA Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_percent_LABA"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint m_percent_LABA
Visual Basic
Public m_percent_LABA As UInteger
Visual C++
public:
unsigned int m_percent_LABA

See Also

MagicWandDX Class
ElImage Namespace


m_percent_LABB Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_percent_LABB Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_percent_LABB"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint m_percent_LABB
Visual Basic
Public m_percent_LABB As UInteger
Visual C++
public:
unsigned int m_percent_LABB

See Also

MagicWandDX Class
ElImage Namespace


m_percent_LABL Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_percent_LABL Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_percent_LABL"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint m_percent_LABL
Visual Basic
Public m_percent_LABL As UInteger
Visual C++
public:
unsigned int m_percent_LABL

See Also

MagicWandDX Class
ElImage Namespace


m_percent_Lightness Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_percent_Lightness Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_percent_Lightness"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint m_percent_Lightness
Visual Basic
Public m_percent_Lightness As UInteger
Visual C++
public:
unsigned int m_percent_Lightness

See Also

MagicWandDX Class
ElImage Namespace


m_percent_Saturation Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_percent_Saturation Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_percent_Saturation"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint m_percent_Saturation
Visual Basic
Public m_percent_Saturation As UInteger
Visual C++
public:
unsigned int m_percent_Saturation

See Also

MagicWandDX Class
ElImage Namespace


m_Source_Bitmap Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_Source_Bitmap Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_Source_Bitmap"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Bitmap m_Source_Bitmap
Visual Basic
Public m_Source_Bitmap As Bitmap
Visual C++
public:
Bitmap^ m_Source_Bitmap

See Also

MagicWandDX Class
ElImage Namespace


m_Source_ClickPos Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_Source_ClickPos Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_Source_ClickPos"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Size2dU m_Source_ClickPos
Visual Basic
Public m_Source_ClickPos As Size2dU
Visual C++
public:
Size2dU^ m_Source_ClickPos

See Also

MagicWandDX Class
ElImage Namespace


m_Source_mode Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_Source_mode Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_Source_mode"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ESelectMode m_Source_mode
Visual Basic
Public m_Source_mode As ESelectMode
Visual C++
public:
ESelectMode m_Source_mode

See Also

MagicWandDX Class
ElImage Namespace


m_test_LABA Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_test_LABA Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_test_LABA"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public double m_test_LABA
Visual Basic
Public m_test_LABA As Double
Visual C++
public:
double m_test_LABA

See Also

MagicWandDX Class
ElImage Namespace


m_tuning Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_tuning Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_tuning"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public double m_tuning
Visual Basic
Public m_tuning As Double
Visual C++
public:
double m_tuning

See Also

MagicWandDX Class
ElImage Namespace


m_vert_permeate Field

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..m_vert_permeate Field
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.MagicWandDX.m_vert_permeate"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint m_vert_permeate
Visual Basic
Public m_vert_permeate As UInteger
Visual C++
public:
unsigned int m_vert_permeate

See Also

MagicWandDX Class
ElImage Namespace


MagicWandDX Methods

[image] [image]

4 of William Foster's Class Libraries
MagicWandDX Methods
MagicWandDX Class See Also Send Feedback

The MagicWandDX type exposes the following members.

Methods

 | Name | Description
Public method | ColorMatches |
Protected method | CreateMatrix | (Inherited from DX.)
Public method | CreateTable | Set up the (empty) DX in memory with fields representing values (Inherited from DX.)
 | delta |
Public method | Dup | (Overrides DX..::..Dup()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateResource | (Inherited from DX.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMember | (Inherited from DX.)
Public method | GetMemberBool | (Inherited from DX.)
Public method | GetSet | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetCheck | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetText | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetUint | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateField | Check the DXEntry list for a resource control with the given name (Inherited from DX.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegistryLoad | Load up this DX from the default registry entries based apon the DXEntry list. (Inherited from DX.)
Public method | RegistrySave | Based apon the DXEntry list, Automatically Save out any important paramenters of this DX to the registry with unique naming (Inherited from DX.)
Public method | Seed |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MagicWandDX Class
ElImage Namespace


ColorMatches Method

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..ColorMatches Method
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.MagicWandDX.ColorMatches(ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool ColorMatches(
    Color c
)
Visual Basic
Public Function ColorMatches ( _
    c As Color _
) As Boolean
Visual C++
public:
bool ColorMatches(
    Color^ c
)

Parameters

c
Type: ElImage..::..Color

[Missing <param name="c"/> documentation for "M:ElImage.MagicWandDX.ColorMatches(ElImage.Color)"]

Return Value

[Missing <returns> documentation for "M:ElImage.MagicWandDX.ColorMatches(ElImage.Color)"]

See Also

MagicWandDX Class
ElImage Namespace


delta Method

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..delta Method
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.MagicWandDX.delta(System.UInt32,System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static uint delta(
    uint a,
    uint b
)
Visual Basic
Public Shared Function delta ( _
    a As UInteger, _
    b As UInteger _
) As UInteger
Visual C++
public:
static unsigned int delta(
    unsigned int a,
    unsigned int b
)

Parameters

a
Type: System..::..UInt32

[Missing <param name="a"/> documentation for "M:ElImage.MagicWandDX.delta(System.UInt32,System.UInt32)"]

b
Type: System..::..UInt32

[Missing <param name="b"/> documentation for "M:ElImage.MagicWandDX.delta(System.UInt32,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.MagicWandDX.delta(System.UInt32,System.UInt32)"]

See Also

MagicWandDX Class
ElImage Namespace


Dup Method

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..Dup Method
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.MagicWandDX.Dup"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override DX Dup()
Visual Basic
Public Overrides Function Dup As DX
Visual C++
public:
virtual DX^ Dup() override

Return Value

[Missing <returns> documentation for "M:ElImage.MagicWandDX.Dup"]

See Also

MagicWandDX Class
ElImage Namespace


Seed Method

[image]

4 of William Foster's Class Libraries
MagicWandDX..::..Seed Method
MagicWandDX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.MagicWandDX.Seed(ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Seed(
    Color c
)
Visual Basic
Public Sub Seed ( _
    c As Color _
)
Visual C++
public:
void Seed(
    Color^ c
)

Parameters

c
Type: ElImage..::..Color

[Missing <param name="c"/> documentation for "M:ElImage.MagicWandDX.Seed(ElImage.Color)"]

See Also

MagicWandDX Class
ElImage Namespace


Page Class

[image]

4 of William Foster's Class Libraries
Page Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Page"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Page
Visual Basic
Public Class Page
Visual C++
public ref class Page

Inheritance Hierarchy

System..::..Object
ElImage..::..Page

See Also

Page Members
ElImage Namespace


Page Members

[image] [image]

4 of William Foster's Class Libraries
Page Members
Page Class Constructors Methods Fields See Also Send Feedback

The Page type exposes the following members.

Constructors

 | Name | Description
Public method | Page()()()() | Initializes a new instance of the Page class
Public method | Page(Page) | Initializes a new instance of the Page class

Methods

 | Name | Description
Public method | AddBuffer |
Public method | AddLayer |
Public method | AvailableLayer |
Public method | DetermineEntireImageSegment |
Public method | Empty |
Public method | EmptyLayer |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayer()()()() |
Public method | GetLayer(UInt32) |
Public method | GetLayerNumber |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateLayer |
Public method | MakeSegmentBeLoadBalanced |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextLayer |
Public method | PreviousLayer |
Public method | SetLayerNumber |
Public method | SetSegmentToEntireImage |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_bufferCache |
Public field | m_entire_segment |

See Also

Page Class
ElImage Namespace


Page Constructor

[image] [image]

4 of William Foster's Class Libraries
Page Constructor
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Page()()()() | Initializes a new instance of the Page class
Public method | Page(Page) | Initializes a new instance of the Page class

See Also

Page Class
Page Members
ElImage Namespace


Page Constructor

[image]

4 of William Foster's Class Libraries
Page Constructor
Page Class See Also Send Feedback
Initializes a new instance of the Page class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Page()
Visual Basic
Public Sub New
Visual C++
public:
Page()

See Also

Page Class
Page Overload
ElImage Namespace


Page Constructor (Page)

[image]

4 of William Foster's Class Libraries
Page Constructor (Page)
Page Class See Also Send Feedback
Initializes a new instance of the Page class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Page(
    Page duper
)
Visual Basic
Public Sub New ( _
    duper As Page _
)
Visual C++
public:
Page(
    Page^ duper
)

Parameters

duper
Type: ElImage..::..Page

[Missing <param name="duper"/> documentation for "M:ElImage.Page.#ctor(ElImage.Page)"]

See Also

Page Class
Page Overload
ElImage Namespace


Page Fields

[image] [image]

4 of William Foster's Class Libraries
Page Fields
Page Class See Also Send Feedback

The Page type exposes the following members.

Fields

 | Name | Description
Public field | m_bufferCache |
Public field | m_entire_segment |

See Also

Page Class
ElImage Namespace


m_bufferCache Field

[image]

4 of William Foster's Class Libraries
Page..::..m_bufferCache Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Page.m_bufferCache"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Array<Image_Buffer> m_bufferCache
Visual Basic
Public m_bufferCache As Array(Of Image_Buffer)
Visual C++
public:
Array<Image_Buffer^>^ m_bufferCache

See Also

Page Class
ElImage Namespace


m_entire_segment Field

[image]

4 of William Foster's Class Libraries
Page..::..m_entire_segment Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Page.m_entire_segment"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Image_Segment m_entire_segment
Visual Basic
Public m_entire_segment As Image_Segment
Visual C++
public:
Image_Segment^ m_entire_segment

See Also

Page Class
ElImage Namespace


Page Methods

[image] [image]

4 of William Foster's Class Libraries
Page Methods
Page Class See Also Send Feedback

The Page type exposes the following members.

Methods

 | Name | Description
Public method | AddBuffer |
Public method | AddLayer |
Public method | AvailableLayer |
Public method | DetermineEntireImageSegment |
Public method | Empty |
Public method | EmptyLayer |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayer()()()() |
Public method | GetLayer(UInt32) |
Public method | GetLayerNumber |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateLayer |
Public method | MakeSegmentBeLoadBalanced |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextLayer |
Public method | PreviousLayer |
Public method | SetLayerNumber |
Public method | SetSegmentToEntireImage |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Page Class
ElImage Namespace


AddBuffer Method

[image]

4 of William Foster's Class Libraries
Page..::..AddBuffer Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.AddBuffer(ElImage.Image_Buffer)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool AddBuffer(
    Image_Buffer buffer
)
Visual Basic
Public Function AddBuffer ( _
    buffer As Image_Buffer _
) As Boolean
Visual C++
public:
bool AddBuffer(
    Image_Buffer^ buffer
)

Parameters

buffer
Type: ElImage..::..Image_Buffer

[Missing <param name="buffer"/> documentation for "M:ElImage.Page.AddBuffer(ElImage.Image_Buffer)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Page.AddBuffer(ElImage.Image_Buffer)"]

See Also

Page Class
ElImage Namespace


AddLayer Method

[image]

4 of William Foster's Class Libraries
Page..::..AddLayer Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.AddLayer"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint AddLayer()
Visual Basic
Public Function AddLayer As UInteger
Visual C++
public:
unsigned int AddLayer()

Return Value

[Missing <returns> documentation for "M:ElImage.Page.AddLayer"]

See Also

Page Class
ElImage Namespace


AvailableLayer Method

[image]

4 of William Foster's Class Libraries
Page..::..AvailableLayer Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.AvailableLayer"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint AvailableLayer()
Visual Basic
Public Function AvailableLayer As UInteger
Visual C++
public:
unsigned int AvailableLayer()

Return Value

[Missing <returns> documentation for "M:ElImage.Page.AvailableLayer"]

See Also

Page Class
ElImage Namespace


DetermineEntireImageSegment Method

[image]

4 of William Foster's Class Libraries
Page..::..DetermineEntireImageSegment Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.DetermineEntireImageSegment"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual bool DetermineEntireImageSegment()
Visual Basic
Public Overridable Function DetermineEntireImageSegment As Boolean
Visual C++
public:
virtual bool DetermineEntireImageSegment()

Return Value

[Missing <returns> documentation for "M:ElImage.Page.DetermineEntireImageSegment"]

See Also

Page Class
ElImage Namespace


Empty Method

[image]

4 of William Foster's Class Libraries
Page..::..Empty Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.Empty"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Empty()
Visual Basic
Public Sub Empty
Visual C++
public:
void Empty()

See Also

Page Class
ElImage Namespace


EmptyLayer Method

[image]

4 of William Foster's Class Libraries
Page..::..EmptyLayer Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.EmptyLayer(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void EmptyLayer(
    uint uLayer
)
Visual Basic
Public Sub EmptyLayer ( _
    uLayer As UInteger _
)
Visual C++
public:
void EmptyLayer(
    unsigned int uLayer
)

Parameters

uLayer
Type: System..::..UInt32

[Missing <param name="uLayer"/> documentation for "M:ElImage.Page.EmptyLayer(System.UInt32)"]

See Also

Page Class
ElImage Namespace


GetLayer Method

[image] [image]

4 of William Foster's Class Libraries
Page..::..GetLayer Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLayer()()()() |
Public method | GetLayer(UInt32) |

See Also

Page Class
Page Members
ElImage Namespace


GetLayer Method

[image]

4 of William Foster's Class Libraries
Page..::..GetLayer Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.GetLayer"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Layer GetLayer()
Visual Basic
Public Function GetLayer As Layer
Visual C++
public:
Layer^ GetLayer()

Return Value

[Missing <returns> documentation for "M:ElImage.Page.GetLayer"]

See Also

Page Class
GetLayer Overload
ElImage Namespace


GetLayer Method (UInt32)

[image]

4 of William Foster's Class Libraries
Page..::..GetLayer Method (UInt32)
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.GetLayer(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Layer GetLayer(
    uint uLayer
)
Visual Basic
Public Function GetLayer ( _
    uLayer As UInteger _
) As Layer
Visual C++
public:
Layer^ GetLayer(
    unsigned int uLayer
)

Parameters

uLayer
Type: System..::..UInt32

[Missing <param name="uLayer"/> documentation for "M:ElImage.Page.GetLayer(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Page.GetLayer(System.UInt32)"]

See Also

Page Class
GetLayer Overload
ElImage Namespace


GetLayerNumber Method

[image]

4 of William Foster's Class Libraries
Page..::..GetLayerNumber Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.GetLayerNumber"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint GetLayerNumber()
Visual Basic
Public Function GetLayerNumber As UInteger
Visual C++
public:
unsigned int GetLayerNumber()

Return Value

[Missing <returns> documentation for "M:ElImage.Page.GetLayerNumber"]

See Also

Page Class
ElImage Namespace


LocateLayer Method

[image]

4 of William Foster's Class Libraries
Page..::..LocateLayer Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.LocateLayer(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Layer LocateLayer(
    uint uLayer
)
Visual Basic
Public Function LocateLayer ( _
    uLayer As UInteger _
) As Layer
Visual C++
public:
Layer^ LocateLayer(
    unsigned int uLayer
)

Parameters

uLayer
Type: System..::..UInt32

[Missing <param name="uLayer"/> documentation for "M:ElImage.Page.LocateLayer(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Page.LocateLayer(System.UInt32)"]

See Also

Page Class
ElImage Namespace


MakeSegmentBeLoadBalanced Method

[image]

4 of William Foster's Class Libraries
Page..::..MakeSegmentBeLoadBalanced Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.MakeSegmentBeLoadBalanced(ElImage.Image_Segment)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool MakeSegmentBeLoadBalanced(
    Image_Segment segment
)
Visual Basic
Public Function MakeSegmentBeLoadBalanced ( _
    segment As Image_Segment _
) As Boolean
Visual C++
public:
bool MakeSegmentBeLoadBalanced(
    Image_Segment^ segment
)

Parameters

segment
Type: ElImage..::..Image_Segment

[Missing <param name="segment"/> documentation for "M:ElImage.Page.MakeSegmentBeLoadBalanced(ElImage.Image_Segment)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Page.MakeSegmentBeLoadBalanced(ElImage.Image_Segment)"]

See Also

Page Class
ElImage Namespace


NextLayer Method

[image]

4 of William Foster's Class Libraries
Page..::..NextLayer Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.NextLayer(System.Int32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public int NextLayer(
    int uReferenceLayer
)
Visual Basic
Public Function NextLayer ( _
    uReferenceLayer As Integer _
) As Integer
Visual C++
public:
int NextLayer(
    int uReferenceLayer
)

Parameters

uReferenceLayer
Type: System..::..Int32

[Missing <param name="uReferenceLayer"/> documentation for "M:ElImage.Page.NextLayer(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Page.NextLayer(System.Int32)"]

See Also

Page Class
ElImage Namespace


PreviousLayer Method

[image]

4 of William Foster's Class Libraries
Page..::..PreviousLayer Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.PreviousLayer(System.Int32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public int PreviousLayer(
    int uReferenceLayer
)
Visual Basic
Public Function PreviousLayer ( _
    uReferenceLayer As Integer _
) As Integer
Visual C++
public:
int PreviousLayer(
    int uReferenceLayer
)

Parameters

uReferenceLayer
Type: System..::..Int32

[Missing <param name="uReferenceLayer"/> documentation for "M:ElImage.Page.PreviousLayer(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Page.PreviousLayer(System.Int32)"]

See Also

Page Class
ElImage Namespace


SetLayerNumber Method

[image]

4 of William Foster's Class Libraries
Page..::..SetLayerNumber Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.SetLayerNumber(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetLayerNumber(
    uint layerNo
)
Visual Basic
Public Sub SetLayerNumber ( _
    layerNo As UInteger _
)
Visual C++
public:
void SetLayerNumber(
    unsigned int layerNo
)

Parameters

layerNo
Type: System..::..UInt32

[Missing <param name="layerNo"/> documentation for "M:ElImage.Page.SetLayerNumber(System.UInt32)"]

See Also

Page Class
ElImage Namespace


SetSegmentToEntireImage Method

[image]

4 of William Foster's Class Libraries
Page..::..SetSegmentToEntireImage Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Page.SetSegmentToEntireImage(ElImage.Image_Segment@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual void SetSegmentToEntireImage(
    out Image_Segment seg
)
Visual Basic
Public Overridable Sub SetSegmentToEntireImage ( _
    <OutAttribute> ByRef seg As Image_Segment _
)
Visual C++
public:
virtual void SetSegmentToEntireImage(
    [OutAttribute] Image_Segment^% seg
)

Parameters

seg
Type: ElImage..::..Image_Segment %

[Missing <param name="seg"/> documentation for "M:ElImage.Page.SetSegmentToEntireImage(ElImage.Image_Segment@)"]

See Also

Page Class
ElImage Namespace


Palette Class

[image]

4 of William Foster's Class Libraries
Palette Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Palette"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Palette
Visual Basic
Public Class Palette
Visual C++
public ref class Palette

Inheritance Hierarchy

System..::..Object
ElImage..::..Palette
ElImage..::..PaletteCounter

See Also

Palette Members
ElImage Namespace


Palette Members

[image] [image]

4 of William Foster's Class Libraries
Palette Members
Palette Class Constructors Methods See Also Send Feedback

The Palette type exposes the following members.

Constructors

 | Name | Description
Public method | Palette()()()() | Initializes a new instance of the Palette class
Public method | Palette(Palette) | Initializes a new instance of the Palette class

Methods

 | Name | Description
Public method | ColorToIndex |
Public method | Dup |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Generate |
Public method | GetColor(UInt32) |
Public method | GetColor(UInt32, Color%) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfColors |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Palette Class
ElImage Namespace


Palette Constructor

[image] [image]

4 of William Foster's Class Libraries
Palette Constructor
Palette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Palette()()()() | Initializes a new instance of the Palette class
Public method | Palette(Palette) | Initializes a new instance of the Palette class

See Also

Palette Class
Palette Members
ElImage Namespace


Palette Constructor

[image]

4 of William Foster's Class Libraries
Palette Constructor
Palette Class See Also Send Feedback
Initializes a new instance of the Palette class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Palette()
Visual Basic
Public Sub New
Visual C++
public:
Palette()

See Also

Palette Class
Palette Overload
ElImage Namespace


Palette Constructor (Palette)

[image]

4 of William Foster's Class Libraries
Palette Constructor (Palette)
Palette Class See Also Send Feedback
Initializes a new instance of the Palette class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Palette(
    Palette paldup
)
Visual Basic
Public Sub New ( _
    paldup As Palette _
)
Visual C++
public:
Palette(
    Palette^ paldup
)

Parameters

paldup
Type: ElImage..::..Palette

[Missing <param name="paldup"/> documentation for "M:ElImage.Palette.#ctor(ElImage.Palette)"]

See Also

Palette Class
Palette Overload
ElImage Namespace


Palette Methods

[image] [image]

4 of William Foster's Class Libraries
Palette Methods
Palette Class See Also Send Feedback

The Palette type exposes the following members.

Methods

 | Name | Description
Public method | ColorToIndex |
Public method | Dup |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Generate |
Public method | GetColor(UInt32) |
Public method | GetColor(UInt32, Color%) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfColors |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Palette Class
ElImage Namespace


ColorToIndex Method

[image]

4 of William Foster's Class Libraries
Palette..::..ColorToIndex Method
Palette Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Palette.ColorToIndex(ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint ColorToIndex(
    Color c
)
Visual Basic
Public Function ColorToIndex ( _
    c As Color _
) As UInteger
Visual C++
public:
unsigned int ColorToIndex(
    Color^ c
)

Parameters

c
Type: ElImage..::..Color

[Missing <param name="c"/> documentation for "M:ElImage.Palette.ColorToIndex(ElImage.Color)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Palette.ColorToIndex(ElImage.Color)"]

See Also

Palette Class
ElImage Namespace


Dup Method

[image]

4 of William Foster's Class Libraries
Palette..::..Dup Method
Palette Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Palette.Dup"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Palette Dup()
Visual Basic
Public Function Dup As Palette
Visual C++
public:
Palette^ Dup()

Return Value

[Missing <returns> documentation for "M:ElImage.Palette.Dup"]

See Also

Palette Class
ElImage Namespace


Generate Method

[image]

4 of William Foster's Class Libraries
Palette..::..Generate Method
Palette Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Palette.Generate(ElImage.Bitmap,System.UInt32,El.Rect2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Generate(
    Bitmap Bmp,
    uint uPalsize,
    Rect2dU Rect
)
Visual Basic
Public Function Generate ( _
    Bmp As Bitmap, _
    uPalsize As UInteger, _
    Rect As Rect2dU _
) As Boolean
Visual C++
public:
bool Generate(
    Bitmap^ Bmp,
    unsigned int uPalsize,
    Rect2dU^ Rect
)

Parameters

Bmp
Type: ElImage..::..Bitmap

[Missing <param name="Bmp"/> documentation for "M:ElImage.Palette.Generate(ElImage.Bitmap,System.UInt32,El.Rect2dU)"]

uPalsize
Type: System..::..UInt32

[Missing <param name="uPalsize"/> documentation for "M:ElImage.Palette.Generate(ElImage.Bitmap,System.UInt32,El.Rect2dU)"]

Rect
Type: Rect2dU

[Missing <param name="Rect"/> documentation for "M:ElImage.Palette.Generate(ElImage.Bitmap,System.UInt32,El.Rect2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Palette.Generate(ElImage.Bitmap,System.UInt32,El.Rect2dU)"]

See Also

Palette Class
ElImage Namespace


GetColor Method

[image] [image]

4 of William Foster's Class Libraries
Palette..::..GetColor Method
Palette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetColor(UInt32) |
Public method | GetColor(UInt32, Color%) |

See Also

Palette Class
Palette Members
ElImage Namespace


GetColor Method (UInt32)

[image]

4 of William Foster's Class Libraries
Palette..::..GetColor Method (UInt32)
Palette Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Palette.GetColor(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Color GetColor(
    uint uIndex
)
Visual Basic
Public Function GetColor ( _
    uIndex As UInteger _
) As Color
Visual C++
public:
Color^ GetColor(
    unsigned int uIndex
)

Parameters

uIndex
Type: System..::..UInt32

[Missing <param name="uIndex"/> documentation for "M:ElImage.Palette.GetColor(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Palette.GetColor(System.UInt32)"]

See Also

Palette Class
GetColor Overload
ElImage Namespace


GetColor Method (UInt32, Color)

[image]

4 of William Foster's Class Libraries
Palette..::..GetColor Method (UInt32, Color%)
Palette Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Palette.GetColor(System.UInt32,ElImage.Color@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void GetColor(
    uint uIndex,
    out Color c
)
Visual Basic
Public Sub GetColor ( _
    uIndex As UInteger, _
    <OutAttribute> ByRef c As Color _
)
Visual C++
public:
void GetColor(
    unsigned int uIndex,
    [OutAttribute] Color^% c
)

Parameters

uIndex
Type: System..::..UInt32

[Missing <param name="uIndex"/> documentation for "M:ElImage.Palette.GetColor(System.UInt32,ElImage.Color@)"]

c
Type: ElImage..::..Color %

[Missing <param name="c"/> documentation for "M:ElImage.Palette.GetColor(System.UInt32,ElImage.Color@)"]

See Also

Palette Class
GetColor Overload
ElImage Namespace


GetNumberOfColors Method

[image]

4 of William Foster's Class Libraries
Palette..::..GetNumberOfColors Method
Palette Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Palette.GetNumberOfColors"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint GetNumberOfColors()
Visual Basic
Public Function GetNumberOfColors As UInteger
Visual C++
public:
unsigned int GetNumberOfColors()

Return Value

[Missing <returns> documentation for "M:ElImage.Palette.GetNumberOfColors"]

See Also

Palette Class
ElImage Namespace


PaletteComparer Class

[image]

4 of William Foster's Class Libraries
PaletteComparer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.PaletteComparer"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class PaletteComparer : IComparer<ushort>
Visual Basic
Public Class PaletteComparer _
    Implements IComparer(Of UShort)
Visual C++
public ref class PaletteComparer : IComparer<unsigned short>

Inheritance Hierarchy

System..::..Object
ElImage..::..PaletteComparer

See Also

PaletteComparer Members
ElImage Namespace


PaletteComparer Members

[image] [image]

4 of William Foster's Class Libraries
PaletteComparer Members
PaletteComparer Class Constructors Methods See Also Send Feedback

The PaletteComparer type exposes the following members.

Constructors

 | Name | Description
Public method | PaletteComparer | Initializes a new instance of the PaletteComparer class

Methods

 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteComparer Class
ElImage Namespace


PaletteComparer Constructor

[image]

4 of William Foster's Class Libraries
PaletteComparer Constructor
PaletteComparer Class See Also Send Feedback
Initializes a new instance of the PaletteComparer class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public PaletteComparer(
    ulong[] occ
)
Visual Basic
Public Sub New ( _
    occ As ULong() _
)
Visual C++
public:
PaletteComparer(
    array<unsigned long long>^ occ
)

Parameters

occ
Type: array< System..::..UInt64 >[]()[][]

[Missing <param name="occ"/> documentation for "M:ElImage.PaletteComparer.#ctor(System.UInt64[])"]

See Also

PaletteComparer Class
ElImage Namespace


PaletteComparer Methods

[image] [image]

4 of William Foster's Class Libraries
PaletteComparer Methods
PaletteComparer Class See Also Send Feedback

The PaletteComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteComparer Class
ElImage Namespace


Compare Method

[image]

4 of William Foster's Class Libraries
PaletteComparer..::..Compare Method
PaletteComparer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.PaletteComparer.Compare(System.UInt16,System.UInt16)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public int Compare(
    ushort arg1,
    ushort arg2
)
Visual Basic
Public Function Compare ( _
    arg1 As UShort, _
    arg2 As UShort _
) As Integer
Visual C++
public:
virtual int Compare(
    unsigned short arg1,
    unsigned short arg2
) sealed

Parameters

arg1
Type: System..::..UInt16

[Missing <param name="arg1"/> documentation for "M:ElImage.PaletteComparer.Compare(System.UInt16,System.UInt16)"]

arg2
Type: System..::..UInt16

[Missing <param name="arg2"/> documentation for "M:ElImage.PaletteComparer.Compare(System.UInt16,System.UInt16)"]

Return Value

[Missing <returns> documentation for "M:ElImage.PaletteComparer.Compare(System.UInt16,System.UInt16)"]

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

PaletteComparer Class
ElImage Namespace


PaletteCounter Class

[image]

4 of William Foster's Class Libraries
PaletteCounter Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.PaletteCounter"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class PaletteCounter : Palette
Visual Basic
Public Class PaletteCounter _
    Inherits Palette
Visual C++
public ref class PaletteCounter : public Palette

Inheritance Hierarchy

System..::..Object
ElImage..::..Palette
ElImage..::..PaletteCounter

See Also

PaletteCounter Members
ElImage Namespace


PaletteCounter Members

[image] [image]

4 of William Foster's Class Libraries
PaletteCounter Members
PaletteCounter Class Constructors Methods See Also Send Feedback

The PaletteCounter type exposes the following members.

Constructors

 | Name | Description
Public method | PaletteCounter | Initializes a new instance of the PaletteCounter class

Methods

 | Name | Description
Public method | ColorToIndex | (Inherited from Palette.)
Public method | Dup | (Inherited from Palette.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Generate | (Inherited from Palette.)
Public method | GetColor(UInt32) | (Inherited from Palette.)
Public method | GetColor(UInt32, Color%) | (Inherited from Palette.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfColors | (Inherited from Palette.)
Public method | GetPrimaryColor |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IncrementSample |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteCounter Class
ElImage Namespace


PaletteCounter Constructor

[image]

4 of William Foster's Class Libraries
PaletteCounter Constructor
PaletteCounter Class See Also Send Feedback
Initializes a new instance of the PaletteCounter class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public PaletteCounter(
    Palette palette
)
Visual Basic
Public Sub New ( _
    palette As Palette _
)
Visual C++
public:
PaletteCounter(
    Palette^ palette
)

Parameters

palette
Type: ElImage..::..Palette

[Missing <param name="palette"/> documentation for "M:ElImage.PaletteCounter.#ctor(ElImage.Palette)"]

See Also

PaletteCounter Class
ElImage Namespace


PaletteCounter Methods

[image] [image]

4 of William Foster's Class Libraries
PaletteCounter Methods
PaletteCounter Class See Also Send Feedback

The PaletteCounter type exposes the following members.

Methods

 | Name | Description
Public method | ColorToIndex | (Inherited from Palette.)
Public method | Dup | (Inherited from Palette.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Generate | (Inherited from Palette.)
Public method | GetColor(UInt32) | (Inherited from Palette.)
Public method | GetColor(UInt32, Color%) | (Inherited from Palette.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfColors | (Inherited from Palette.)
Public method | GetPrimaryColor |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IncrementSample |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaletteCounter Class
ElImage Namespace


GetColor Method

[image] [image]

4 of William Foster's Class Libraries
PaletteCounter..::..GetColor Method
PaletteCounter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetColor(UInt32) | (Inherited from Palette.)
Public method | GetColor(UInt32, Color%) | (Inherited from Palette.)

See Also

PaletteCounter Class
PaletteCounter Members
ElImage Namespace


GetPrimaryColor Method

[image]

4 of William Foster's Class Libraries
PaletteCounter..::..GetPrimaryColor Method
PaletteCounter Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.PaletteCounter.GetPrimaryColor(ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool GetPrimaryColor(
    Color c
)
Visual Basic
Public Function GetPrimaryColor ( _
    c As Color _
) As Boolean
Visual C++
public:
bool GetPrimaryColor(
    Color^ c
)

Parameters

c
Type: ElImage..::..Color

[Missing <param name="c"/> documentation for "M:ElImage.PaletteCounter.GetPrimaryColor(ElImage.Color)"]

Return Value

[Missing <returns> documentation for "M:ElImage.PaletteCounter.GetPrimaryColor(ElImage.Color)"]

See Also

PaletteCounter Class
ElImage Namespace


IncrementSample Method

[image]

4 of William Foster's Class Libraries
PaletteCounter..::..IncrementSample Method
PaletteCounter Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.PaletteCounter.IncrementSample(ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void IncrementSample(
    Color col
)
Visual Basic
Public Sub IncrementSample ( _
    col As Color _
)
Visual C++
public:
void IncrementSample(
    Color^ col
)

Parameters

col
Type: ElImage..::..Color

[Missing <param name="col"/> documentation for "M:ElImage.PaletteCounter.IncrementSample(ElImage.Color)"]

See Also

PaletteCounter Class
ElImage Namespace


PixelBuffer Class

[image]

4 of William Foster's Class Libraries
PixelBuffer Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.PixelBuffer"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class PixelBuffer
Visual Basic
Public Class PixelBuffer
Visual C++
public ref class PixelBuffer

Inheritance Hierarchy

System..::..Object
ElImage..::..PixelBuffer

See Also

PixelBuffer Members
ElImage Namespace


PixelBuffer Members

[image] [image]

4 of William Foster's Class Libraries
PixelBuffer Members
PixelBuffer Class Constructors Methods Fields See Also Send Feedback

The PixelBuffer type exposes the following members.

Constructors

 | Name | Description
Public method | PixelBuffer()()()() | Initializes a new instance of the PixelBuffer class
Public method | PixelBuffer(Pixels, UInt32) | Initializes a new instance of the PixelBuffer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCount |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPtr |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Iterate |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_count |
Public field | m_offset |
Public field | m_Pixels |

See Also

PixelBuffer Class
ElImage Namespace


PixelBuffer Constructor

[image] [image]

4 of William Foster's Class Libraries
PixelBuffer Constructor
PixelBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PixelBuffer()()()() | Initializes a new instance of the PixelBuffer class
Public method | PixelBuffer(Pixels, UInt32) | Initializes a new instance of the PixelBuffer class

See Also

PixelBuffer Class
PixelBuffer Members
ElImage Namespace


PixelBuffer Constructor

[image]

4 of William Foster's Class Libraries
PixelBuffer Constructor
PixelBuffer Class See Also Send Feedback
Initializes a new instance of the PixelBuffer class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public PixelBuffer()
Visual Basic
Public Sub New
Visual C++
public:
PixelBuffer()

See Also

PixelBuffer Class
PixelBuffer Overload
ElImage Namespace


PixelBuffer Constructor (Pixels, UInt32)

[image]

4 of William Foster's Class Libraries
PixelBuffer Constructor (Pixels, UInt32)
PixelBuffer Class See Also Send Feedback
Initializes a new instance of the PixelBuffer class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public PixelBuffer(
    Pixels pixels,
    uint count
)
Visual Basic
Public Sub New ( _
    pixels As Pixels, _
    count As UInteger _
)
Visual C++
public:
PixelBuffer(
    Pixels^ pixels,
    unsigned int count
)

Parameters

pixels
Type: ElImage..::..Pixels

[Missing <param name="pixels"/> documentation for "M:ElImage.PixelBuffer.#ctor(ElImage.Pixels,System.UInt32)"]

count
Type: System..::..UInt32

[Missing <param name="count"/> documentation for "M:ElImage.PixelBuffer.#ctor(ElImage.Pixels,System.UInt32)"]

See Also

PixelBuffer Class
PixelBuffer Overload
ElImage Namespace


PixelBuffer Fields

[image] [image]

4 of William Foster's Class Libraries
PixelBuffer Fields
PixelBuffer Class See Also Send Feedback

The PixelBuffer type exposes the following members.

Fields

 | Name | Description
Public field | m_count |
Public field | m_offset |
Public field | m_Pixels |

See Also

PixelBuffer Class
ElImage Namespace


m_count Field

[image]

4 of William Foster's Class Libraries
PixelBuffer..::..m_count Field
PixelBuffer Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.PixelBuffer.m_count"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint m_count
Visual Basic
Public m_count As UInteger
Visual C++
public:
unsigned int m_count

See Also

PixelBuffer Class
ElImage Namespace


m_offset Field

[image]

4 of William Foster's Class Libraries
PixelBuffer..::..m_offset Field
PixelBuffer Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.PixelBuffer.m_offset"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint m_offset
Visual Basic
Public m_offset As UInteger
Visual C++
public:
unsigned int m_offset

See Also

PixelBuffer Class
ElImage Namespace


m_Pixels Field

[image]

4 of William Foster's Class Libraries
PixelBuffer..::..m_Pixels Field
PixelBuffer Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.PixelBuffer.m_Pixels"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Pixels m_Pixels
Visual Basic
Public m_Pixels As Pixels
Visual C++
public:
Pixels^ m_Pixels

See Also

PixelBuffer Class
ElImage Namespace


PixelBuffer Methods

[image] [image]

4 of William Foster's Class Libraries
PixelBuffer Methods
PixelBuffer Class See Also Send Feedback

The PixelBuffer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCount |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPtr |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Iterate |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PixelBuffer Class
ElImage Namespace


GetCount Method

[image]

4 of William Foster's Class Libraries
PixelBuffer..::..GetCount Method
PixelBuffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.PixelBuffer.GetCount"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint GetCount()
Visual Basic
Public Function GetCount As UInteger
Visual C++
public:
unsigned int GetCount()

Return Value

[Missing <returns> documentation for "M:ElImage.PixelBuffer.GetCount"]

See Also

PixelBuffer Class
ElImage Namespace


GetPtr Method

[image]

4 of William Foster's Class Libraries
PixelBuffer..::..GetPtr Method
PixelBuffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.PixelBuffer.GetPtr"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte[] GetPtr()
Visual Basic
Public Function GetPtr As Byte()
Visual C++
public:
array<unsigned char>^ GetPtr()

Return Value

[Missing <returns> documentation for "M:ElImage.PixelBuffer.GetPtr"]

See Also

PixelBuffer Class
ElImage Namespace


Iterate Method

[image]

4 of William Foster's Class Libraries
PixelBuffer..::..Iterate Method
PixelBuffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.PixelBuffer.Iterate(ElImage.Color@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Iterate(
    out Color c
)
Visual Basic
Public Function Iterate ( _
    <OutAttribute> ByRef c As Color _
) As Boolean
Visual C++
public:
bool Iterate(
    [OutAttribute] Color^% c
)

Parameters

c
Type: ElImage..::..Color %

[Missing <param name="c"/> documentation for "M:ElImage.PixelBuffer.Iterate(ElImage.Color@)"]

Return Value

[Missing <returns> documentation for "M:ElImage.PixelBuffer.Iterate(ElImage.Color@)"]

See Also

PixelBuffer Class
ElImage Namespace


Set Method

[image]

4 of William Foster's Class Libraries
PixelBuffer..::..Set Method
PixelBuffer Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.PixelBuffer.Set(ElImage.Pixels,System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Set(
    Pixels pixels,
    uint count
)
Visual Basic
Public Sub Set ( _
    pixels As Pixels, _
    count As UInteger _
)
Visual C++
public:
void Set(
    Pixels^ pixels,
    unsigned int count
)

Parameters

pixels
Type: ElImage..::..Pixels

[Missing <param name="pixels"/> documentation for "M:ElImage.PixelBuffer.Set(ElImage.Pixels,System.UInt32)"]

count
Type: System..::..UInt32

[Missing <param name="count"/> documentation for "M:ElImage.PixelBuffer.Set(ElImage.Pixels,System.UInt32)"]

See Also

PixelBuffer Class
ElImage Namespace


PixelData Structure

[image]

4 of William Foster's Class Libraries
PixelData Structure
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.PixelData"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public struct PixelData
Visual Basic
Public Structure PixelData
Visual C++
public value class PixelData

See Also

PixelData Members
ElImage Namespace


PixelData Members

[image] [image]

4 of William Foster's Class Libraries
PixelData Members
PixelData Structure Methods Fields See Also Send Feedback

The PixelData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | m_a |
Public field | m_b |
Public field | m_g |
Public field | m_Pxl |
Public field | m_r |

See Also

PixelData Structure
ElImage Namespace


PixelData Fields

[image] [image]

4 of William Foster's Class Libraries
PixelData Fields
PixelData Structure See Also Send Feedback

The PixelData type exposes the following members.

Fields

 | Name | Description
Public field | m_a |
Public field | m_b |
Public field | m_g |
Public field | m_Pxl |
Public field | m_r |

See Also

PixelData Structure
ElImage Namespace


m_a Field

[image]

4 of William Foster's Class Libraries
PixelData..::..m_a Field
PixelData Structure See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.PixelData.m_a"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte m_a
Visual Basic
Public m_a As Byte
Visual C++
public:
unsigned char m_a

See Also

PixelData Structure
ElImage Namespace


m_b Field

[image]

4 of William Foster's Class Libraries
PixelData..::..m_b Field
PixelData Structure See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.PixelData.m_b"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte m_b
Visual Basic
Public m_b As Byte
Visual C++
public:
unsigned char m_b

See Also

PixelData Structure
ElImage Namespace


m_g Field

[image]

4 of William Foster's Class Libraries
PixelData..::..m_g Field
PixelData Structure See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.PixelData.m_g"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte m_g
Visual Basic
Public m_g As Byte
Visual C++
public:
unsigned char m_g

See Also

PixelData Structure
ElImage Namespace


m_Pxl Field

[image]

4 of William Foster's Class Libraries
PixelData..::..m_Pxl Field
PixelData Structure See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.PixelData.m_Pxl"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ulong m_Pxl
Visual Basic
Public m_Pxl As ULong
Visual C++
public:
unsigned long long m_Pxl

See Also

PixelData Structure
ElImage Namespace


m_r Field

[image]

4 of William Foster's Class Libraries
PixelData..::..m_r Field
PixelData Structure See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.PixelData.m_r"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte m_r
Visual Basic
Public m_r As Byte
Visual C++
public:
unsigned char m_r

See Also

PixelData Structure
ElImage Namespace


PixelData Methods

[image] [image]

4 of William Foster's Class Libraries
PixelData Methods
PixelData Structure See Also Send Feedback

The PixelData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

PixelData Structure
ElImage Namespace


Pixels Class

[image]

4 of William Foster's Class Libraries
Pixels Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Pixels"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Pixels
Visual Basic
Public Class Pixels
Visual C++
public ref class Pixels

Inheritance Hierarchy

System..::..Object
ElImage..::..Pixels

See Also

Pixels Members
ElImage Namespace


Pixels Members

[image] [image]

4 of William Foster's Class Libraries
Pixels Members
Pixels Class Constructors Methods Fields Properties See Also Send Feedback

The Pixels type exposes the following members.

Constructors

 | Name | Description
Public method | Pixels()()()() | Initializes a new instance of the Pixels class
Public method | Pixels(Pixels) | Initializes a new instance of the Pixels class
Public method | Pixels(array<Byte>[]()[][], ColorSpace, Int32) | Initializes a new instance of the Pixels class

Methods

 | Name | Description
Protected method | BytesRequiredToStore |
Public method | Decrement |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Fill |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPtr |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment()()()() |
Public method | Increment(Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MixPixel |
Public method | MixPixels |
Public method | Reset |
Public method | Set |
Public method | Sta |
Public method | Stav |
Public method | StavLine |
Public method | StavZoomedLine |
Public method | Store |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransferAv | Copies a single pixel from another Pixels object

Fields

 | Name | Description
Protected field | m_BytesPerPixel |
Protected field | m_colorSpace |
Public field | m_offset |
Protected field | m_ptr |

Properties

 | Name | Description
Public property | color |
Public property | Item |

See Also

Pixels Class
ElImage Namespace


Pixels Constructor

[image] [image]

4 of William Foster's Class Libraries
Pixels Constructor
Pixels Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Pixels()()()() | Initializes a new instance of the Pixels class
Public method | Pixels(Pixels) | Initializes a new instance of the Pixels class
Public method | Pixels(array<Byte>[]()[][], ColorSpace, Int32) | Initializes a new instance of the Pixels class

See Also

Pixels Class
Pixels Members
ElImage Namespace


Pixels Constructor

[image]

4 of William Foster's Class Libraries
Pixels Constructor
Pixels Class See Also Send Feedback
Initializes a new instance of the Pixels class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Pixels()
Visual Basic
Public Sub New
Visual C++
public:
Pixels()

See Also

Pixels Class
Pixels Overload
ElImage Namespace


Pixels Constructor (Pixels)

[image]

4 of William Foster's Class Libraries
Pixels Constructor (Pixels)
Pixels Class See Also Send Feedback
Initializes a new instance of the Pixels class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Pixels(
    Pixels copy
)
Visual Basic
Public Sub New ( _
    copy As Pixels _
)
Visual C++
public:
Pixels(
    Pixels^ copy
)

Parameters

copy
Type: ElImage..::..Pixels

[Missing <param name="copy"/> documentation for "M:ElImage.Pixels.#ctor(ElImage.Pixels)"]

See Also

Pixels Class
Pixels Overload
ElImage Namespace


Pixels Constructor (Byte[], ColorSpace, Int32)

[image]

4 of William Foster's Class Libraries
Pixels Constructor (array<Byte>[]()[][], ColorSpace, Int32)
Pixels Class See Also Send Feedback
Initializes a new instance of the Pixels class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Pixels(
    byte[] ptr,
    ColorSpace colorSpace,
    int offset
)
Visual Basic
Public Sub New ( _
    ptr As Byte(), _
    colorSpace As ColorSpace, _
    offset As Integer _
)
Visual C++
public:
Pixels(
    array<unsigned char>^ ptr,
    ColorSpace^ colorSpace,
    int offset
)

Parameters

ptr
Type: array< System..::..Byte >[]()[][]

[Missing <param name="ptr"/> documentation for "M:ElImage.Pixels.#ctor(System.Byte[],ElImage.ColorSpace,System.Int32)"]

colorSpace
Type: ElImage..::..ColorSpace

[Missing <param name="colorSpace"/> documentation for "M:ElImage.Pixels.#ctor(System.Byte[],ElImage.ColorSpace,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:ElImage.Pixels.#ctor(System.Byte[],ElImage.ColorSpace,System.Int32)"]

See Also

Pixels Class
Pixels Overload
ElImage Namespace


Pixels Fields

[image] [image]

4 of William Foster's Class Libraries
Pixels Fields
Pixels Class See Also Send Feedback

The Pixels type exposes the following members.

Fields

 | Name | Description
Protected field | m_BytesPerPixel |
Protected field | m_colorSpace |
Public field | m_offset |
Protected field | m_ptr |

See Also

Pixels Class
ElImage Namespace


m_BytesPerPixel Field

[image]

4 of William Foster's Class Libraries
Pixels..::..m_BytesPerPixel Field
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Pixels.m_BytesPerPixel"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected int m_BytesPerPixel
Visual Basic
Protected m_BytesPerPixel As Integer
Visual C++
protected:
int m_BytesPerPixel

See Also

Pixels Class
ElImage Namespace


m_colorSpace Field

[image]

4 of William Foster's Class Libraries
Pixels..::..m_colorSpace Field
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Pixels.m_colorSpace"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected ColorSpace m_colorSpace
Visual Basic
Protected m_colorSpace As ColorSpace
Visual C++
protected:
ColorSpace^ m_colorSpace

See Also

Pixels Class
ElImage Namespace


m_offset Field

[image]

4 of William Foster's Class Libraries
Pixels..::..m_offset Field
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Pixels.m_offset"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public int m_offset
Visual Basic
Public m_offset As Integer
Visual C++
public:
int m_offset

See Also

Pixels Class
ElImage Namespace


m_ptr Field

[image]

4 of William Foster's Class Libraries
Pixels..::..m_ptr Field
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Pixels.m_ptr"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected byte[] m_ptr
Visual Basic
Protected m_ptr As Byte()
Visual C++
protected:
array<unsigned char>^ m_ptr

See Also

Pixels Class
ElImage Namespace


Pixels Methods

[image] [image]

4 of William Foster's Class Libraries
Pixels Methods
Pixels Class See Also Send Feedback

The Pixels type exposes the following members.

Methods

 | Name | Description
Protected method | BytesRequiredToStore |
Public method | Decrement |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Fill |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPtr |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment()()()() |
Public method | Increment(Int32) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MixPixel |
Public method | MixPixels |
Public method | Reset |
Public method | Set |
Public method | Sta |
Public method | Stav |
Public method | StavLine |
Public method | StavZoomedLine |
Public method | Store |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransferAv | Copies a single pixel from another Pixels object

See Also

Pixels Class
ElImage Namespace


BytesRequiredToStore Method

[image]

4 of William Foster's Class Libraries
Pixels..::..BytesRequiredToStore Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.BytesRequiredToStore(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected uint BytesRequiredToStore(
    uint u_pixelCount
)
Visual Basic
Protected Function BytesRequiredToStore ( _
    u_pixelCount As UInteger _
) As UInteger
Visual C++
protected:
unsigned int BytesRequiredToStore(
    unsigned int u_pixelCount
)

Parameters

u_pixelCount
Type: System..::..UInt32

[Missing <param name="u_pixelCount"/> documentation for "M:ElImage.Pixels.BytesRequiredToStore(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Pixels.BytesRequiredToStore(System.UInt32)"]

See Also

Pixels Class
ElImage Namespace


Decrement Method

[image]

4 of William Foster's Class Libraries
Pixels..::..Decrement Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.Decrement"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual void Decrement()
Visual Basic
Public Overridable Sub Decrement
Visual C++
public:
virtual void Decrement()

See Also

Pixels Class
ElImage Namespace


Fill Method

[image]

4 of William Foster's Class Libraries
Pixels..::..Fill Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.Fill(ElImage.Color,System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Fill(
    Color color,
    uint ww
)
Visual Basic
Public Sub Fill ( _
    color As Color, _
    ww As UInteger _
)
Visual C++
public:
void Fill(
    Color^ color,
    unsigned int ww
)

Parameters

color
Type: ElImage..::..Color

[Missing <param name="color"/> documentation for "M:ElImage.Pixels.Fill(ElImage.Color,System.UInt32)"]

ww
Type: System..::..UInt32

[Missing <param name="ww"/> documentation for "M:ElImage.Pixels.Fill(ElImage.Color,System.UInt32)"]

See Also

Pixels Class
ElImage Namespace


GetPtr Method

[image]

4 of William Foster's Class Libraries
Pixels..::..GetPtr Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.GetPtr"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte[] GetPtr()
Visual Basic
Public Function GetPtr As Byte()
Visual C++
public:
array<unsigned char>^ GetPtr()

Return Value

[Missing <returns> documentation for "M:ElImage.Pixels.GetPtr"]

See Also

Pixels Class
ElImage Namespace


Increment Method

[image] [image]

4 of William Foster's Class Libraries
Pixels..::..Increment Method
Pixels Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Increment()()()() |
Public method | Increment(Int32) |

See Also

Pixels Class
Pixels Members
ElImage Namespace


Increment Method

[image]

4 of William Foster's Class Libraries
Pixels..::..Increment Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.Increment"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual void Increment()
Visual Basic
Public Overridable Sub Increment
Visual C++
public:
virtual void Increment()

See Also

Pixels Class
Increment Overload
ElImage Namespace


Increment Method (Int32)

[image]

4 of William Foster's Class Libraries
Pixels..::..Increment Method (Int32)
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.Increment(System.Int32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual void Increment(
    int i_inc
)
Visual Basic
Public Overridable Sub Increment ( _
    i_inc As Integer _
)
Visual C++
public:
virtual void Increment(
    int i_inc
)

Parameters

i_inc
Type: System..::..Int32

[Missing <param name="i_inc"/> documentation for "M:ElImage.Pixels.Increment(System.Int32)"]

See Also

Pixels Class
Increment Overload
ElImage Namespace


MixPixel Method

[image]

4 of William Foster's Class Libraries
Pixels..::..MixPixel Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.MixPixel(ElImage.Color,ElImage.Color,System.Byte)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static Color MixPixel(
    Color c1,
    Color c2,
    byte ucAlpha
)
Visual Basic
Public Shared Function MixPixel ( _
    c1 As Color, _
    c2 As Color, _
    ucAlpha As Byte _
) As Color
Visual C++
public:
static Color^ MixPixel(
    Color^ c1,
    Color^ c2,
    unsigned char ucAlpha
)

Parameters

c1
Type: ElImage..::..Color

[Missing <param name="c1"/> documentation for "M:ElImage.Pixels.MixPixel(ElImage.Color,ElImage.Color,System.Byte)"]

c2
Type: ElImage..::..Color

[Missing <param name="c2"/> documentation for "M:ElImage.Pixels.MixPixel(ElImage.Color,ElImage.Color,System.Byte)"]

ucAlpha
Type: System..::..Byte

[Missing <param name="ucAlpha"/> documentation for "M:ElImage.Pixels.MixPixel(ElImage.Color,ElImage.Color,System.Byte)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Pixels.MixPixel(ElImage.Color,ElImage.Color,System.Byte)"]

See Also

Pixels Class
ElImage Namespace


MixPixels Method

[image]

4 of William Foster's Class Libraries
Pixels..::..MixPixels Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.MixPixels(ElImage.Pixels,System.ArraySegment{System.Byte},System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void MixPixels(
    Pixels SourceData,
    ArraySegment<byte> AlphaData,
    uint uPixelCount
)
Visual Basic
Public Sub MixPixels ( _
    SourceData As Pixels, _
    AlphaData As ArraySegment(Of Byte), _
    uPixelCount As UInteger _
)
Visual C++
public:
void MixPixels(
    Pixels^ SourceData,
    ArraySegment<unsigned char> AlphaData,
    unsigned int uPixelCount
)

Parameters

SourceData
Type: ElImage..::..Pixels

[Missing <param name="SourceData"/> documentation for "M:ElImage.Pixels.MixPixels(ElImage.Pixels,System.ArraySegment{System.Byte},System.UInt32)"]

AlphaData
Type: System..::..ArraySegment <(Of <(<' Byte >)>)>

[Missing <param name="AlphaData"/> documentation for "M:ElImage.Pixels.MixPixels(ElImage.Pixels,System.ArraySegment{System.Byte},System.UInt32)"]

uPixelCount
Type: System..::..UInt32

[Missing <param name="uPixelCount"/> documentation for "M:ElImage.Pixels.MixPixels(ElImage.Pixels,System.ArraySegment{System.Byte},System.UInt32)"]

See Also

Pixels Class
ElImage Namespace


Reset Method

[image]

4 of William Foster's Class Libraries
Pixels..::..Reset Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.Reset"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

Pixels Class
ElImage Namespace


Set Method

[image]

4 of William Foster's Class Libraries
Pixels..::..Set Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.Set(ElImage.Pixels)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Set(
    Pixels eq
)
Visual Basic
Public Sub Set ( _
    eq As Pixels _
)
Visual C++
public:
void Set(
    Pixels^ eq
)

Parameters

eq
Type: ElImage..::..Pixels

[Missing <param name="eq"/> documentation for "M:ElImage.Pixels.Set(ElImage.Pixels)"]

See Also

Pixels Class
ElImage Namespace


Sta Method

[image]

4 of William Foster's Class Libraries
Pixels..::..Sta Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.Sta(ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Sta(
    Color color
)
Visual Basic
Public Sub Sta ( _
    color As Color _
)
Visual C++
public:
void Sta(
    Color^ color
)

Parameters

color
Type: ElImage..::..Color

[Missing <param name="color"/> documentation for "M:ElImage.Pixels.Sta(ElImage.Color)"]

See Also

Pixels Class
ElImage Namespace


Stav Method

[image]

4 of William Foster's Class Libraries
Pixels..::..Stav Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.Stav(ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual void Stav(
    Color color
)
Visual Basic
Public Overridable Sub Stav ( _
    color As Color _
)
Visual C++
public:
virtual void Stav(
    Color^ color
)

Parameters

color
Type: ElImage..::..Color

[Missing <param name="color"/> documentation for "M:ElImage.Pixels.Stav(ElImage.Color)"]

See Also

Pixels Class
ElImage Namespace


StavLine Method

[image]

4 of William Foster's Class Libraries
Pixels..::..StavLine Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.StavLine(ElImage.Pixels,System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void StavLine(
    Pixels pelSrc,
    uint ww
)
Visual Basic
Public Sub StavLine ( _
    pelSrc As Pixels, _
    ww As UInteger _
)
Visual C++
public:
void StavLine(
    Pixels^ pelSrc,
    unsigned int ww
)

Parameters

pelSrc
Type: ElImage..::..Pixels

[Missing <param name="pelSrc"/> documentation for "M:ElImage.Pixels.StavLine(ElImage.Pixels,System.UInt32)"]

ww
Type: System..::..UInt32

[Missing <param name="ww"/> documentation for "M:ElImage.Pixels.StavLine(ElImage.Pixels,System.UInt32)"]

See Also

Pixels Class
ElImage Namespace


StavZoomedLine Method

[image]

4 of William Foster's Class Libraries
Pixels..::..StavZoomedLine Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.StavZoomedLine(ElImage.Pixels,System.UInt32,System.Double)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void StavZoomedLine(
    Pixels pelSrc,
    uint dest_ww,
    double zoom
)
Visual Basic
Public Sub StavZoomedLine ( _
    pelSrc As Pixels, _
    dest_ww As UInteger, _
    zoom As Double _
)
Visual C++
public:
void StavZoomedLine(
    Pixels^ pelSrc,
    unsigned int dest_ww,
    double zoom
)

Parameters

pelSrc
Type: ElImage..::..Pixels

[Missing <param name="pelSrc"/> documentation for "M:ElImage.Pixels.StavZoomedLine(ElImage.Pixels,System.UInt32,System.Double)"]

dest_ww
Type: System..::..UInt32

[Missing <param name="dest_ww"/> documentation for "M:ElImage.Pixels.StavZoomedLine(ElImage.Pixels,System.UInt32,System.Double)"]

zoom
Type: System..::..Double

[Missing <param name="zoom"/> documentation for "M:ElImage.Pixels.StavZoomedLine(ElImage.Pixels,System.UInt32,System.Double)"]

See Also

Pixels Class
ElImage Namespace


Store Method

[image]

4 of William Foster's Class Libraries
Pixels..::..Store Method
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Pixels.Store(System.Int32,ElImage.Color)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Store(
    int offset,
    Color color
)
Visual Basic
Public Sub Store ( _
    offset As Integer, _
    color As Color _
)
Visual C++
public:
void Store(
    int offset,
    Color^ color
)

Parameters

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:ElImage.Pixels.Store(System.Int32,ElImage.Color)"]

color
Type: ElImage..::..Color

[Missing <param name="color"/> documentation for "M:ElImage.Pixels.Store(System.Int32,ElImage.Color)"]

See Also

Pixels Class
ElImage Namespace


TransferAv Method

[image]

4 of William Foster's Class Libraries
Pixels..::..TransferAv Method
Pixels Class See Also Send Feedback
Copies a single pixel from another Pixels object

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void TransferAv(
    Pixels src
)
Visual Basic
Public Sub TransferAv ( _
    src As Pixels _
)
Visual C++
public:
void TransferAv(
    Pixels^ src
)

Parameters

src
Type: ElImage..::..Pixels

[Missing <param name="src"/> documentation for "M:ElImage.Pixels.TransferAv(ElImage.Pixels)"]

See Also

Pixels Class
ElImage Namespace


Pixels Properties

[image] [image]

4 of William Foster's Class Libraries
Pixels Properties
Pixels Class See Also Send Feedback

The Pixels type exposes the following members.

Properties

 | Name | Description
Public property | color |
Public property | Item |

See Also

Pixels Class
ElImage Namespace


color Property

[image]

4 of William Foster's Class Libraries
Pixels..::..color Property
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "P:ElImage.Pixels.color"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual Color color { get; }
Visual Basic
Public Overridable ReadOnly Property color As Color
    Get
Visual C++
public:
virtual property Color^ color {
    Color^ get ();
}

See Also

Pixels Class
ElImage Namespace


Item Property

[image]

4 of William Foster's Class Libraries
Pixels..::..Item Property
Pixels Class See Also Send Feedback

[Missing <summary> documentation for "P:ElImage.Pixels.Item(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual Color this[
    uint offset
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    offset As UInteger _
) As Color
    Get
    Set
Visual C++
public:
virtual property Color^ default[unsigned int offset] {
    Color^ get (unsigned int offset);
    void set (unsigned int offset, Color^ value);
}

Parameters

offset
Type: System..::..UInt32

See Also

Pixels Class
ElImage Namespace


Resolution Class

[image]

4 of William Foster's Class Libraries
Resolution Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Resolution"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Resolution
Visual Basic
Public Class Resolution
Visual C++
public ref class Resolution

Inheritance Hierarchy

System..::..Object
ElImage..::..Resolution

See Also

Resolution Members
ElImage Namespace


Resolution Members

[image] [image]

4 of William Foster's Class Libraries
Resolution Members
Resolution Class Constructors Methods Fields See Also Send Feedback

The Resolution type exposes the following members.

Constructors

 | Name | Description
Public method | Resolution()()()() | Initializes a new instance of the Resolution class
Public method | Resolution(Resolution) | Initializes a new instance of the Resolution class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDotsPerInch |
Public method | GetDotsPerMeter |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
 | INCHES_PER_METER |
Public field | m_dotsPerMeter |

See Also

Resolution Class
ElImage Namespace


Resolution Constructor

[image] [image]

4 of William Foster's Class Libraries
Resolution Constructor
Resolution Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Resolution()()()() | Initializes a new instance of the Resolution class
Public method | Resolution(Resolution) | Initializes a new instance of the Resolution class

See Also

Resolution Class
Resolution Members
ElImage Namespace


Resolution Constructor

[image]

4 of William Foster's Class Libraries
Resolution Constructor
Resolution Class See Also Send Feedback
Initializes a new instance of the Resolution class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Resolution()
Visual Basic
Public Sub New
Visual C++
public:
Resolution()

See Also

Resolution Class
Resolution Overload
ElImage Namespace


Resolution Constructor (Resolution)

[image]

4 of William Foster's Class Libraries
Resolution Constructor (Resolution)
Resolution Class See Also Send Feedback
Initializes a new instance of the Resolution class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Resolution(
    Resolution resolution
)
Visual Basic
Public Sub New ( _
    resolution As Resolution _
)
Visual C++
public:
Resolution(
    Resolution^ resolution
)

Parameters

resolution
Type: ElImage..::..Resolution

[Missing <param name="resolution"/> documentation for "M:ElImage.Resolution.#ctor(ElImage.Resolution)"]

See Also

Resolution Class
Resolution Overload
ElImage Namespace


Resolution Fields

[image] [image]

4 of William Foster's Class Libraries
Resolution Fields
Resolution Class See Also Send Feedback

The Resolution type exposes the following members.

Fields

 | Name | Description
 | INCHES_PER_METER |
Public field | m_dotsPerMeter |

See Also

Resolution Class
ElImage Namespace


INCHES_PER_METER Field

[image]

4 of William Foster's Class Libraries
Resolution..::..INCHES_PER_METER Field
Resolution Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Resolution.INCHES_PER_METER"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public const double INCHES_PER_METER
Visual Basic
Public Const INCHES_PER_METER As Double
Visual C++
public:
literal double INCHES_PER_METER

See Also

Resolution Class
ElImage Namespace


m_dotsPerMeter Field

[image]

4 of William Foster's Class Libraries
Resolution..::..m_dotsPerMeter Field
Resolution Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Resolution.m_dotsPerMeter"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Value m_dotsPerMeter
Visual Basic
Public m_dotsPerMeter As Value
Visual C++
public:
Value^ m_dotsPerMeter

See Also

Resolution Class
ElImage Namespace


Resolution Methods

[image] [image]

4 of William Foster's Class Libraries
Resolution Methods
Resolution Class See Also Send Feedback

The Resolution type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDotsPerInch |
Public method | GetDotsPerMeter |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Resolution Class
ElImage Namespace


GetDotsPerInch Method

[image]

4 of William Foster's Class Libraries
Resolution..::..GetDotsPerInch Method
Resolution Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Resolution.GetDotsPerInch"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint GetDotsPerInch()
Visual Basic
Public Function GetDotsPerInch As UInteger
Visual C++
public:
unsigned int GetDotsPerInch()

Return Value

[Missing <returns> documentation for "M:ElImage.Resolution.GetDotsPerInch"]

See Also

Resolution Class
ElImage Namespace


GetDotsPerMeter Method

[image]

4 of William Foster's Class Libraries
Resolution..::..GetDotsPerMeter Method
Resolution Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Resolution.GetDotsPerMeter"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint GetDotsPerMeter()
Visual Basic
Public Function GetDotsPerMeter As UInteger
Visual C++
public:
unsigned int GetDotsPerMeter()

Return Value

[Missing <returns> documentation for "M:ElImage.Resolution.GetDotsPerMeter"]

See Also

Resolution Class
ElImage Namespace


Scaled_Bitmap_Alpha Class

[image]

4 of William Foster's Class Libraries
Scaled_Bitmap_Alpha Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Scaled_Bitmap_Alpha"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Scaled_Bitmap_Alpha
Visual Basic
Public Class Scaled_Bitmap_Alpha
Visual C++
public ref class Scaled_Bitmap_Alpha

Inheritance Hierarchy

System..::..Object
ElImage..::..Scaled_Bitmap_Alpha

See Also

Scaled_Bitmap_Alpha Members
ElImage Namespace


Scaled_Bitmap_Alpha Members

[image] [image]

4 of William Foster's Class Libraries
Scaled_Bitmap_Alpha Members
Scaled_Bitmap_Alpha Class Constructors Methods Properties See Also Send Feedback

The Scaled_Bitmap_Alpha type exposes the following members.

Constructors

 | Name | Description
Public method | Scaled_Bitmap_Alpha | Initializes a new instance of the Scaled_Bitmap_Alpha class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item |

See Also

Scaled_Bitmap_Alpha Class
ElImage Namespace


Scaled_Bitmap_Alpha Constructor

[image]

4 of William Foster's Class Libraries
Scaled_Bitmap_Alpha Constructor
Scaled_Bitmap_Alpha Class See Also Send Feedback
Initializes a new instance of the Scaled_Bitmap_Alpha class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Scaled_Bitmap_Alpha(
    Bitmap_Alpha alph,
    Size2dU scaled_size
)
Visual Basic
Public Sub New ( _
    alph As Bitmap_Alpha, _
    scaled_size As Size2dU _
)
Visual C++
public:
Scaled_Bitmap_Alpha(
    Bitmap_Alpha^ alph,
    Size2dU^ scaled_size
)

Parameters

alph
Type: ElImage..::..Bitmap_Alpha

[Missing <param name="alph"/> documentation for "M:ElImage.Scaled_Bitmap_Alpha.#ctor(ElImage.Bitmap_Alpha,El.Size2dU)"]

scaled_size
Type: Size2dU

[Missing <param name="scaled_size"/> documentation for "M:ElImage.Scaled_Bitmap_Alpha.#ctor(ElImage.Bitmap_Alpha,El.Size2dU)"]

See Also

Scaled_Bitmap_Alpha Class
ElImage Namespace


Scaled_Bitmap_Alpha Methods

[image] [image]

4 of William Foster's Class Libraries
Scaled_Bitmap_Alpha Methods
Scaled_Bitmap_Alpha Class See Also Send Feedback

The Scaled_Bitmap_Alpha type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Scaled_Bitmap_Alpha Class
ElImage Namespace


Scaled_Bitmap_Alpha Properties

[image] [image]

4 of William Foster's Class Libraries
Scaled_Bitmap_Alpha Properties
Scaled_Bitmap_Alpha Class See Also Send Feedback

The Scaled_Bitmap_Alpha type exposes the following members.

Properties

 | Name | Description
Public property | Item |

See Also

Scaled_Bitmap_Alpha Class
ElImage Namespace


Item Property

[image]

4 of William Foster's Class Libraries
Scaled_Bitmap_Alpha..::..Item Property
Scaled_Bitmap_Alpha Class See Also Send Feedback

[Missing <summary> documentation for "P:ElImage.Scaled_Bitmap_Alpha.Item(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public byte this[
    Size2dU pos
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    pos As Size2dU _
) As Byte
    Get
Visual C++
public:
property unsigned char default[Size2dU^ pos] {
    unsigned char get (Size2dU^ pos);
}

Parameters

pos
Type: Size2dU

See Also

Scaled_Bitmap_Alpha Class
ElImage Namespace


ScriptImage Class

[image]

4 of William Foster's Class Libraries
ScriptImage Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.ScriptImage"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class ScriptImage : Script_XML
Visual Basic
Public Class ScriptImage _
    Inherits Script_XML
Visual C++
public ref class ScriptImage : public Script_XML

Inheritance Hierarchy

System..::..Object
Stream
ElScript..::..Script_Text
ElScript..::..Script
ElScript..::..Script_XML
ElImage..::..ScriptImage

See Also

ScriptImage Members
ElImage Namespace


ScriptImage Members

[image] [image]

4 of William Foster's Class Libraries
ScriptImage Members
ScriptImage Class Constructors Methods Fields Properties See Also Send Feedback

The ScriptImage type exposes the following members.

Constructors

 | Name | Description
Public method | ScriptImage | Initializes a new instance of the ScriptImage class

Methods

 | Name | Description
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Inherited from Script.)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML | (Inherited from Script_XML.)
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Public method | Process(Image) |
Public method | Process(Image_Buffer) |
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext | (Inherited from Script_XML.)
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Public method | ReadToTagEnd | (Inherited from Script_XML.)
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Inherited from Script_XML.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment | (Inherited from Script.)
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField | (Inherited from Script_XML.)
Public method | WriteAnXMLTag | (Inherited from Script_XML.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

Fields

 | Name | Description
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

ScriptImage Class
ElImage Namespace


ScriptImage Constructor

[image]

4 of William Foster's Class Libraries
ScriptImage Constructor
ScriptImage Class See Also Send Feedback
Initializes a new instance of the ScriptImage class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public ScriptImage(
    Stream resourceStream
)
Visual Basic
Public Sub New ( _
    resourceStream As Stream _
)
Visual C++
public:
ScriptImage(
    Stream^ resourceStream
)

Parameters

resourceStream
Type: Stream

[Missing <param name="resourceStream"/> documentation for "M:ElImage.ScriptImage.#ctor(El.Stream)"]

See Also

ScriptImage Class
ElImage Namespace


ScriptImage Fields

[image] [image]

4 of William Foster's Class Libraries
ScriptImage Fields
ScriptImage Class See Also Send Feedback

The ScriptImage type exposes the following members.

Fields

 | Name | Description
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)

See Also

ScriptImage Class
ElImage Namespace


ScriptImage Methods

[image] [image]

4 of William Foster's Class Libraries
ScriptImage Methods
ScriptImage Class See Also Send Feedback

The ScriptImage type exposes the following members.

Methods

 | Name | Description
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Inherited from Script.)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML | (Inherited from Script_XML.)
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Public method | Process(Image) |
Public method | Process(Image_Buffer) |
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext | (Inherited from Script_XML.)
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Public method | ReadToTagEnd | (Inherited from Script_XML.)
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Inherited from Script_XML.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment | (Inherited from Script.)
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField | (Inherited from Script_XML.)
Public method | WriteAnXMLTag | (Inherited from Script_XML.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

ScriptImage Class
ElImage Namespace


AttachFile Method

[image] [image]

4 of William Foster's Class Libraries
ScriptImage..::..AttachFile Method
ScriptImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)

See Also

ScriptImage Class
ScriptImage Members
ElImage Namespace


AttachMemory Method

[image] [image]

4 of William Foster's Class Libraries
ScriptImage..::..AttachMemory Method
ScriptImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)

See Also

ScriptImage Class
ScriptImage Members
ElImage Namespace


NextChar Method

[image] [image]

4 of William Foster's Class Libraries
ScriptImage..::..NextChar Method
ScriptImage Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)

See Also

ScriptImage Class
ScriptImage Members
ElImage Namespace


Process Method

[image] [image]

4 of William Foster's Class Libraries
ScriptImage..::..Process Method
ScriptImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Process(Image) |
Public method | Process(Image_Buffer) |

See Also

ScriptImage Class
ScriptImage Members
ElImage Namespace


Process Method (Image)

[image]

4 of William Foster's Class Libraries
ScriptImage..::..Process Method (Image)
ScriptImage Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ScriptImage.Process(ElImage.Image)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Process(
    Image image
)
Visual Basic
Public Function Process ( _
    image As Image _
) As Boolean
Visual C++
public:
bool Process(
    Image^ image
)

Parameters

image
Type: ElImage..::..Image

[Missing <param name="image"/> documentation for "M:ElImage.ScriptImage.Process(ElImage.Image)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ScriptImage.Process(ElImage.Image)"]

See Also

ScriptImage Class
Process Overload
ElImage Namespace


Process Method (Image_Buffer)

[image]

4 of William Foster's Class Libraries
ScriptImage..::..Process Method (Image_Buffer)
ScriptImage Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.ScriptImage.Process(ElImage.Image_Buffer)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public bool Process(
    Image_Buffer buffer
)
Visual Basic
Public Function Process ( _
    buffer As Image_Buffer _
) As Boolean
Visual C++
public:
bool Process(
    Image_Buffer^ buffer
)

Parameters

buffer
Type: ElImage..::..Image_Buffer

[Missing <param name="buffer"/> documentation for "M:ElImage.ScriptImage.Process(ElImage.Image_Buffer)"]

Return Value

[Missing <returns> documentation for "M:ElImage.ScriptImage.Process(ElImage.Image_Buffer)"]

See Also

ScriptImage Class
Process Overload
ElImage Namespace


ReadLine Method

[image] [image]

4 of William Foster's Class Libraries
ScriptImage..::..ReadLine Method
ScriptImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)

See Also

ScriptImage Class
ScriptImage Members
ElImage Namespace


ReadScript_ArgumentList_2dPair Method

[image] [image]

4 of William Foster's Class Libraries
ScriptImage..::..ReadScript_ArgumentList_2dPair Method
ScriptImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)

See Also

ScriptImage Class
ScriptImage Members
ElImage Namespace


Seek Method

[image] [image]

4 of William Foster's Class Libraries
ScriptImage..::..Seek Method
ScriptImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)

See Also

ScriptImage Class
ScriptImage Members
ElImage Namespace


Write Method

[image] [image]

4 of William Foster's Class Libraries
ScriptImage..::..Write Method
ScriptImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

ScriptImage Class
ScriptImage Members
ElImage Namespace


WriteLine Method

[image] [image]

4 of William Foster's Class Libraries
ScriptImage..::..WriteLine Method
ScriptImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

ScriptImage Class
ScriptImage Members
ElImage Namespace


ScriptImage Properties

[image] [image]

4 of William Foster's Class Libraries
ScriptImage Properties
ScriptImage Class See Also Send Feedback

The ScriptImage type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

ScriptImage Class
ElImage Namespace


Spline Class

[image]

4 of William Foster's Class Libraries
Spline Class
Members See Also Send Feedback
Describes a Spline in 2d space

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public class Spline : Thing2d
Visual Basic
Public Class Spline _
    Inherits Thing2d
Visual C++
public ref class Spline : public Thing2d

Inheritance Hierarchy

System..::..Object
ElImage..::..Thing2d
ElImage..::..Spline

See Also

Spline Members
ElImage Namespace


Spline Members

[image] [image]

4 of William Foster's Class Libraries
Spline Members
Spline Class Constructors Methods Fields Properties See Also Send Feedback

The Spline type exposes the following members.

Constructors

 | Name | Description
Public method | Spline()()()() | Initializes a new instance of the Spline class
Public method | Spline(Spline) | Initializes a new instance of the Spline class

Methods

 | Name | Description
Public method | AddControlPoint |
Public method | DeleteControlPoint |
Public method | Dup | (Overrides Thing2d..::..Dup()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControlPoint |
Public method | GetAlpha | (Inherited from Thing2d.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayer | (Inherited from Thing2d.)
Public method | GetName | (Inherited from Thing2d.)
Public method | GetPosition | (Inherited from Thing2d.)
Public method | GetRect | (Inherited from Thing2d.)
Public method | GetSize | (Inherited from Thing2d.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectsPoint | (Inherited from Thing2d.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveControlPoint |
Public method | Name | (Inherited from Thing2d.)
Public method | Set(Spline) |
Public method | Set(Thing2d) | (Inherited from Thing2d.)
Public method | SetLayer | (Inherited from Thing2d.)
Public method | SetPosition | (Inherited from Thing2d.)
Public method | SetWindow | (Inherited from Thing2d.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_Layer | (Inherited from Thing2d.)
Protected field | m_Name | (Inherited from Thing2d.)
Public field | m_rectSize | (Inherited from Thing2d.)

Properties

 | Name | Description
Public property | size | (Inherited from Thing2d.)

See Also

Spline Class
ElImage Namespace


Spline Constructor

[image] [image]

4 of William Foster's Class Libraries
Spline Constructor
Spline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Spline()()()() | Initializes a new instance of the Spline class
Public method | Spline(Spline) | Initializes a new instance of the Spline class

See Also

Spline Class
Spline Members
ElImage Namespace


Spline Constructor

[image]

4 of William Foster's Class Libraries
Spline Constructor
Spline Class See Also Send Feedback
Initializes a new instance of the Spline class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Spline()
Visual Basic
Public Sub New
Visual C++
public:
Spline()

See Also

Spline Class
Spline Overload
ElImage Namespace


Spline Constructor (Spline)

[image]

4 of William Foster's Class Libraries
Spline Constructor (Spline)
Spline Class See Also Send Feedback
Initializes a new instance of the Spline class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Spline(
    Spline duper
)
Visual Basic
Public Sub New ( _
    duper As Spline _
)
Visual C++
public:
Spline(
    Spline^ duper
)

Parameters

duper
Type: ElImage..::..Spline

[Missing <param name="duper"/> documentation for "M:ElImage.Spline.#ctor(ElImage.Spline)"]

See Also

Spline Class
Spline Overload
ElImage Namespace


Spline Fields

[image] [image]

4 of William Foster's Class Libraries
Spline Fields
Spline Class See Also Send Feedback

The Spline type exposes the following members.

Fields

 | Name | Description
Protected field | m_Layer | (Inherited from Thing2d.)
Protected field | m_Name | (Inherited from Thing2d.)
Public field | m_rectSize | (Inherited from Thing2d.)

See Also

Spline Class
ElImage Namespace


Spline Methods

[image] [image]

4 of William Foster's Class Libraries
Spline Methods
Spline Class See Also Send Feedback

The Spline type exposes the following members.

Methods

 | Name | Description
Public method | AddControlPoint |
Public method | DeleteControlPoint |
Public method | Dup | (Overrides Thing2d..::..Dup()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControlPoint |
Public method | GetAlpha | (Inherited from Thing2d.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayer | (Inherited from Thing2d.)
Public method | GetName | (Inherited from Thing2d.)
Public method | GetPosition | (Inherited from Thing2d.)
Public method | GetRect | (Inherited from Thing2d.)
Public method | GetSize | (Inherited from Thing2d.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectsPoint | (Inherited from Thing2d.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveControlPoint |
Public method | Name | (Inherited from Thing2d.)
Public method | Set(Spline) |
Public method | Set(Thing2d) | (Inherited from Thing2d.)
Public method | SetLayer | (Inherited from Thing2d.)
Public method | SetPosition | (Inherited from Thing2d.)
Public method | SetWindow | (Inherited from Thing2d.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Spline Class
ElImage Namespace


AddControlPoint Method

[image]

4 of William Foster's Class Libraries
Spline..::..AddControlPoint Method
Spline Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Spline.AddControlPoint(El.Size2d)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void AddControlPoint(
    Size2d pos
)
Visual Basic
Public Sub AddControlPoint ( _
    pos As Size2d _
)
Visual C++
public:
void AddControlPoint(
    Size2d^ pos
)

Parameters

pos
Type: Size2d

[Missing <param name="pos"/> documentation for "M:ElImage.Spline.AddControlPoint(El.Size2d)"]

See Also

Spline Class
ElImage Namespace


DeleteControlPoint Method

[image]

4 of William Foster's Class Libraries
Spline..::..DeleteControlPoint Method
Spline Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Spline.DeleteControlPoint(System.Int32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void DeleteControlPoint(
    int control
)
Visual Basic
Public Sub DeleteControlPoint ( _
    control As Integer _
)
Visual C++
public:
void DeleteControlPoint(
    int control
)

Parameters

control
Type: System..::..Int32

[Missing <param name="control"/> documentation for "M:ElImage.Spline.DeleteControlPoint(System.Int32)"]

See Also

Spline Class
ElImage Namespace


Dup Method

[image]

4 of William Foster's Class Libraries
Spline..::..Dup Method
Spline Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Spline.Dup"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public override Thing2d Dup()
Visual Basic
Public Overrides Function Dup As Thing2d
Visual C++
public:
virtual Thing2d^ Dup() override

Return Value

[Missing <returns> documentation for "M:ElImage.Spline.Dup"]

See Also

Spline Class
ElImage Namespace


FindControlPoint Method

[image]

4 of William Foster's Class Libraries
Spline..::..FindControlPoint Method
Spline Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Spline.FindControlPoint(El.Size2d)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public int FindControlPoint(
    Size2d pos
)
Visual Basic
Public Function FindControlPoint ( _
    pos As Size2d _
) As Integer
Visual C++
public:
int FindControlPoint(
    Size2d^ pos
)

Parameters

pos
Type: Size2d

[Missing <param name="pos"/> documentation for "M:ElImage.Spline.FindControlPoint(El.Size2d)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Spline.FindControlPoint(El.Size2d)"]

See Also

Spline Class
ElImage Namespace


MoveControlPoint Method

[image]

4 of William Foster's Class Libraries
Spline..::..MoveControlPoint Method
Spline Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Spline.MoveControlPoint(System.Int32,El.Size2d)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void MoveControlPoint(
    int control,
    Size2d delta
)
Visual Basic
Public Sub MoveControlPoint ( _
    control As Integer, _
    delta As Size2d _
)
Visual C++
public:
void MoveControlPoint(
    int control,
    Size2d^ delta
)

Parameters

control
Type: System..::..Int32

[Missing <param name="control"/> documentation for "M:ElImage.Spline.MoveControlPoint(System.Int32,El.Size2d)"]

delta
Type: Size2d

[Missing <param name="delta"/> documentation for "M:ElImage.Spline.MoveControlPoint(System.Int32,El.Size2d)"]

See Also

Spline Class
ElImage Namespace


Set Method

[image] [image]

4 of William Foster's Class Libraries
Spline..::..Set Method
Spline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Spline) |
Public method | Set(Thing2d) | (Inherited from Thing2d.)

See Also

Spline Class
Spline Members
ElImage Namespace


Set Method (Spline)

[image]

4 of William Foster's Class Libraries
Spline..::..Set Method (Spline)
Spline Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Spline.Set(ElImage.Spline)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Set(
    Spline spline_duper
)
Visual Basic
Public Sub Set ( _
    spline_duper As Spline _
)
Visual C++
public:
void Set(
    Spline^ spline_duper
)

Parameters

spline_duper
Type: ElImage..::..Spline

[Missing <param name="spline_duper"/> documentation for "M:ElImage.Spline.Set(ElImage.Spline)"]

See Also

Spline Class
Set Overload
ElImage Namespace


Spline Properties

[image] [image]

4 of William Foster's Class Libraries
Spline Properties
Spline Class See Also Send Feedback

The Spline type exposes the following members.

Properties

 | Name | Description
Public property | size | (Inherited from Thing2d.)

See Also

Spline Class
ElImage Namespace


Thing2d Class

[image]

4 of William Foster's Class Libraries
Thing2d Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.Thing2d"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public abstract class Thing2d
Visual Basic
Public MustInherit Class Thing2d
Visual C++
public ref class Thing2d abstract

Inheritance Hierarchy

System..::..Object
ElImage..::..Thing2d
ElImage..::..Bitmap
ElImage..::..Spline

See Also

Thing2d Members
ElImage Namespace


Thing2d Members

[image] [image]

4 of William Foster's Class Libraries
Thing2d Members
Thing2d Class Constructors Methods Fields Properties See Also Send Feedback

The Thing2d type exposes the following members.

Constructors

 | Name | Description
Public method | Thing2d | Initializes a new instance of the Thing2d class

Methods

 | Name | Description
Public method | Dup |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlpha |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayer |
Public method | GetName |
Public method | GetPosition |
Public method | GetRect |
Public method | GetSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectsPoint |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Name |
Public method | Set |
Public method | SetLayer |
Public method | SetPosition |
Public method | SetWindow |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_Layer |
Protected field | m_Name |
Public field | m_rectSize |

Properties

 | Name | Description
Public property | size |

See Also

Thing2d Class
ElImage Namespace


Thing2d Constructor

[image]

4 of William Foster's Class Libraries
Thing2d Constructor
Thing2d Class See Also Send Feedback
Initializes a new instance of the Thing2d class

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Thing2d()
Visual Basic
Public Sub New
Visual C++
public:
Thing2d()

See Also

Thing2d Class
ElImage Namespace


Thing2d Fields

[image] [image]

4 of William Foster's Class Libraries
Thing2d Fields
Thing2d Class See Also Send Feedback

The Thing2d type exposes the following members.

Fields

 | Name | Description
Protected field | m_Layer |
Protected field | m_Name |
Public field | m_rectSize |

See Also

Thing2d Class
ElImage Namespace


m_Layer Field

[image]

4 of William Foster's Class Libraries
Thing2d..::..m_Layer Field
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Thing2d.m_Layer"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected uint m_Layer
Visual Basic
Protected m_Layer As UInteger
Visual C++
protected:
unsigned int m_Layer

See Also

Thing2d Class
ElImage Namespace


m_Name Field

[image]

4 of William Foster's Class Libraries
Thing2d..::..m_Name Field
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Thing2d.m_Name"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
protected STRING m_Name
Visual Basic
Protected m_Name As STRING
Visual C++
protected:
STRING^ m_Name

See Also

Thing2d Class
ElImage Namespace


m_rectSize Field

[image]

4 of William Foster's Class Libraries
Thing2d..::..m_rectSize Field
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "F:ElImage.Thing2d.m_rectSize"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Rect2dU m_rectSize
Visual Basic
Public m_rectSize As Rect2dU
Visual C++
public:
Rect2dU^ m_rectSize

See Also

Thing2d Class
ElImage Namespace


Thing2d Methods

[image] [image]

4 of William Foster's Class Libraries
Thing2d Methods
Thing2d Class See Also Send Feedback

The Thing2d type exposes the following members.

Methods

 | Name | Description
Public method | Dup |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlpha |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayer |
Public method | GetName |
Public method | GetPosition |
Public method | GetRect |
Public method | GetSize |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectsPoint |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Name |
Public method | Set |
Public method | SetLayer |
Public method | SetPosition |
Public method | SetWindow |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Thing2d Class
ElImage Namespace


Dup Method

[image]

4 of William Foster's Class Libraries
Thing2d..::..Dup Method
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Thing2d.Dup"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public abstract Thing2d Dup()
Visual Basic
Public MustOverride Function Dup As Thing2d
Visual C++
public:
virtual Thing2d^ Dup() abstract

Return Value

[Missing <returns> documentation for "M:ElImage.Thing2d.Dup"]

See Also

Thing2d Class
ElImage Namespace


GetAlpha Method

[image]

4 of William Foster's Class Libraries
Thing2d..::..GetAlpha Method
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Thing2d.GetAlpha"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual Bitmap_Alpha GetAlpha()
Visual Basic
Public Overridable Function GetAlpha As Bitmap_Alpha
Visual C++
public:
virtual Bitmap_Alpha^ GetAlpha()

Return Value

[Missing <returns> documentation for "M:ElImage.Thing2d.GetAlpha"]

See Also

Thing2d Class
ElImage Namespace


GetLayer Method

[image]

4 of William Foster's Class Libraries
Thing2d..::..GetLayer Method
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Thing2d.GetLayer"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public uint GetLayer()
Visual Basic
Public Function GetLayer As UInteger
Visual C++
public:
unsigned int GetLayer()

Return Value

[Missing <returns> documentation for "M:ElImage.Thing2d.GetLayer"]

See Also

Thing2d Class
ElImage Namespace


GetName Method

[image]

4 of William Foster's Class Libraries
Thing2d..::..GetName Method
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Thing2d.GetName"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public STRING GetName()
Visual Basic
Public Function GetName As STRING
Visual C++
public:
STRING^ GetName()

Return Value

[Missing <returns> documentation for "M:ElImage.Thing2d.GetName"]

See Also

Thing2d Class
ElImage Namespace


GetPosition Method

[image]

4 of William Foster's Class Libraries
Thing2d..::..GetPosition Method
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Thing2d.GetPosition(El.Size2dU@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void GetPosition(
    out Size2dU pos
)
Visual Basic
Public Sub GetPosition ( _
    <OutAttribute> ByRef pos As Size2dU _
)
Visual C++
public:
void GetPosition(
    [OutAttribute] Size2dU^% pos
)

Parameters

pos
Type: Size2dU%

[Missing <param name="pos"/> documentation for "M:ElImage.Thing2d.GetPosition(El.Size2dU@)"]

See Also

Thing2d Class
ElImage Namespace


GetRect Method

[image]

4 of William Foster's Class Libraries
Thing2d..::..GetRect Method
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Thing2d.GetRect(El.Rect2dU@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void GetRect(
    out Rect2dU rectU
)
Visual Basic
Public Sub GetRect ( _
    <OutAttribute> ByRef rectU As Rect2dU _
)
Visual C++
public:
void GetRect(
    [OutAttribute] Rect2dU^% rectU
)

Parameters

rectU
Type: Rect2dU%

[Missing <param name="rectU"/> documentation for "M:ElImage.Thing2d.GetRect(El.Rect2dU@)"]

See Also

Thing2d Class
ElImage Namespace


GetSize Method

[image]

4 of William Foster's Class Libraries
Thing2d..::..GetSize Method
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Thing2d.GetSize(El.Size2dU@)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void GetSize(
    out Size2dU size2d
)
Visual Basic
Public Sub GetSize ( _
    <OutAttribute> ByRef size2d As Size2dU _
)
Visual C++
public:
void GetSize(
    [OutAttribute] Size2dU^% size2d
)

Parameters

size2d
Type: Size2dU%

[Missing <param name="size2d"/> documentation for "M:ElImage.Thing2d.GetSize(El.Size2dU@)"]

See Also

Thing2d Class
ElImage Namespace


IntersectsPoint Method

[image]

4 of William Foster's Class Libraries
Thing2d..::..IntersectsPoint Method
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Thing2d.IntersectsPoint(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual bool IntersectsPoint(
    Size2dU pointImage
)
Visual Basic
Public Overridable Function IntersectsPoint ( _
    pointImage As Size2dU _
) As Boolean
Visual C++
public:
virtual bool IntersectsPoint(
    Size2dU^ pointImage
)

Parameters

pointImage
Type: Size2dU

[Missing <param name="pointImage"/> documentation for "M:ElImage.Thing2d.IntersectsPoint(El.Size2dU)"]

Return Value

[Missing <returns> documentation for "M:ElImage.Thing2d.IntersectsPoint(El.Size2dU)"]

See Also

Thing2d Class
ElImage Namespace


Name Method

[image]

4 of William Foster's Class Libraries
Thing2d..::..Name Method
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Thing2d.Name(El.STRING)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Name(
    STRING name
)
Visual Basic
Public Sub Name ( _
    name As STRING _
)
Visual C++
public:
void Name(
    STRING^ name
)

Parameters

name
Type: STRING

[Missing <param name="name"/> documentation for "M:ElImage.Thing2d.Name(El.STRING)"]

See Also

Thing2d Class
ElImage Namespace


Set Method

[image]

4 of William Foster's Class Libraries
Thing2d..::..Set Method
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Thing2d.Set(ElImage.Thing2d)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void Set(
    Thing2d copy
)
Visual Basic
Public Sub Set ( _
    copy As Thing2d _
)
Visual C++
public:
void Set(
    Thing2d^ copy
)

Parameters

copy
Type: ElImage..::..Thing2d

[Missing <param name="copy"/> documentation for "M:ElImage.Thing2d.Set(ElImage.Thing2d)"]

See Also

Thing2d Class
ElImage Namespace


SetLayer Method

[image]

4 of William Foster's Class Libraries
Thing2d..::..SetLayer Method
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Thing2d.SetLayer(System.UInt32)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetLayer(
    uint uLayer
)
Visual Basic
Public Sub SetLayer ( _
    uLayer As UInteger _
)
Visual C++
public:
void SetLayer(
    unsigned int uLayer
)

Parameters

uLayer
Type: System..::..UInt32

[Missing <param name="uLayer"/> documentation for "M:ElImage.Thing2d.SetLayer(System.UInt32)"]

See Also

Thing2d Class
ElImage Namespace


SetPosition Method

[image]

4 of William Foster's Class Libraries
Thing2d..::..SetPosition Method
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Thing2d.SetPosition(El.Size2dU)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public virtual void SetPosition(
    Size2dU pos
)
Visual Basic
Public Overridable Sub SetPosition ( _
    pos As Size2dU _
)
Visual C++
public:
virtual void SetPosition(
    Size2dU^ pos
)

Parameters

pos
Type: Size2dU

[Missing <param name="pos"/> documentation for "M:ElImage.Thing2d.SetPosition(El.Size2dU)"]

See Also

Thing2d Class
ElImage Namespace


SetWindow Method

[image]

4 of William Foster's Class Libraries
Thing2d..::..SetWindow Method
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.Thing2d.SetWindow(ElGUI.UILayerWindow)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public void SetWindow(
    UILayerWindow Laywin
)
Visual Basic
Public Sub SetWindow ( _
    Laywin As UILayerWindow _
)
Visual C++
public:
void SetWindow(
    UILayerWindow^ Laywin
)

Parameters

Laywin
Type: ElGUI..::..UILayerWindow

[Missing <param name="Laywin"/> documentation for "M:ElImage.Thing2d.SetWindow(ElGUI.UILayerWindow)"]

See Also

Thing2d Class
ElImage Namespace


Thing2d Properties

[image] [image]

4 of William Foster's Class Libraries
Thing2d Properties
Thing2d Class See Also Send Feedback

The Thing2d type exposes the following members.

Properties

 | Name | Description
Public property | size |

See Also

Thing2d Class
ElImage Namespace


size Property

[image]

4 of William Foster's Class Libraries
Thing2d..::..size Property
Thing2d Class See Also Send Feedback

[Missing <summary> documentation for "P:ElImage.Thing2d.size"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public Size2dU size { get; }
Visual Basic
Public ReadOnly Property size As Size2dU
    Get
Visual C++
public:
property Size2dU^ size {
    Size2dU^ get ();
}

See Also

Thing2d Class
ElImage Namespace


WBbmpExtention Class

[image]

4 of William Foster's Class Libraries
WBbmpExtention Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElImage.WBbmpExtention"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static class WBbmpExtention
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class WBbmpExtention
Visual C++
[ExtensionAttribute]
public ref class WBbmpExtention abstract sealed

Inheritance Hierarchy

System..::..Object
ElImage..::..WBbmpExtention

See Also

WBbmpExtention Members
ElImage Namespace


WBbmpExtention Members

[image] [image]

4 of William Foster's Class Libraries
WBbmpExtention Members
WBbmpExtention Class Methods See Also Send Feedback

The WBbmpExtention type exposes the following members.

Methods

Name | Description
BytesPerPixel |

See Also

WBbmpExtention Class
ElImage Namespace


WBbmpExtention Methods

[image] [image]

4 of William Foster's Class Libraries
WBbmpExtention Methods
WBbmpExtention Class See Also Send Feedback

The WBbmpExtention type exposes the following members.

Methods

Name | Description
BytesPerPixel |

See Also

WBbmpExtention Class
ElImage Namespace


BytesPerPixel Method

[image]

4 of William Foster's Class Libraries
WBbmpExtention..::..BytesPerPixel Method
WBbmpExtention Class See Also Send Feedback

[Missing <summary> documentation for "M:ElImage.WBbmpExtention.BytesPerPixel(System.Windows.Media.Imaging.WriteableBitmap)"]

Namespace: ElImage
Assembly: ElImage (in ElImage.dll) Version: 0.0.0.0

Syntax

C#
public static int BytesPerPixel(
    this WriteableBitmap bmp
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function BytesPerPixel ( _
    bmp As WriteableBitmap _
) As Integer
Visual C++
[ExtensionAttribute]
public:
static int BytesPerPixel(
    WriteableBitmap^ bmp
)

Parameters

bmp
Type: System.Windows.Media.Imaging..::..WriteableBitmap

[Missing <param name="bmp"/> documentation for "M:ElImage.WBbmpExtention.BytesPerPixel(System.Windows.Media.Imaging.WriteableBitmap)"]

Return Value

[Missing <returns> documentation for "M:ElImage.WBbmpExtention.BytesPerPixel(System.Windows.Media.Imaging.WriteableBitmap)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WriteableBitmap. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

WBbmpExtention Class
ElImage Namespace


ElOS Namespace

[image]

4 of William Foster's Class Libraries
ElOS Namespace
Send Feedback

[Missing <summary> documentation for "N:ElOS"]

Classes

 | Class | Description
Public class | Application |
Public class | FileDialog |
Public class | FileOperation |
Public class | FileOperationClass |
Public class | FileSelection_DP |
Public class | FileSelection_DX |
Public class | FileSelector |
Public class | FilesystemEntry |
Public class | FolderOperation |
Public class | FolderSelector |
Public class | OS_Static |


Application Class

[image]

4 of William Foster's Class Libraries
Application Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElOS.Application"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public class Application : ApplicationBase
Visual Basic
Public Class Application _
    Inherits ApplicationBase
Visual C++
public ref class Application : public ApplicationBase

Inheritance Hierarchy

System..::..Object
ApplicationBase
ElOS..::..Application

See Also

Application Members
ElOS Namespace


Application Members

[image] [image]

4 of William Foster's Class Libraries
Application Members
Application Class Constructors Methods Fields See Also Send Feedback

The Application type exposes the following members.

Constructors

 | Name | Description
Public method | Application | Initializes a new instance of the Application class

Methods

 | Name | Description
Public method | CreateMainWindow |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetCopyrightString |
Public method | GetGUI |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResourceFolder | (Inherited from ApplicationBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | (Inherited from ApplicationBase.)
Public method | InitializeAppLayer |
Protected method | LoadResources(Filename) |
Protected method | LoadResources(String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | On_About |
Public method | SelectInputImageFiles |
Public method | SelectOutputImageFile |
Public method | SetResource |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
 | csImageMask |
 | fsel_imageopen_DX |
 | fsel_imagesave_DX |
Public field | m_Appname |
Protected field | m_args | (Inherited from ApplicationBase.)
Protected field | m_BaseFolder | (Inherited from ApplicationBase.)
Protected field | m_resource_stream |
Protected field | m_ResourceFolder | (Inherited from ApplicationBase.)

See Also

Application Class
ElOS Namespace


Application Constructor

[image]

4 of William Foster's Class Libraries
Application Constructor
Application Class See Also Send Feedback
Initializes a new instance of the Application class

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public Application(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
Application(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ElOS.Application.#ctor(System.String)"]

See Also

Application Class
ElOS Namespace


Application Fields

[image] [image]

4 of William Foster's Class Libraries
Application Fields
Application Class See Also Send Feedback

The Application type exposes the following members.

Fields

 | Name | Description
 | csImageMask |
 | fsel_imageopen_DX |
 | fsel_imagesave_DX |
Public field | m_Appname |
Protected field | m_args | (Inherited from ApplicationBase.)
Protected field | m_BaseFolder | (Inherited from ApplicationBase.)
Protected field | m_resource_stream |
Protected field | m_ResourceFolder | (Inherited from ApplicationBase.)

See Also

Application Class
ElOS Namespace


csImageMask Field

[image]

4 of William Foster's Class Libraries
Application..::..csImageMask Field
Application Class See Also Send Feedback

[Missing <summary> documentation for "F:ElOS.Application.csImageMask"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static STRING csImageMask
Visual Basic
Public Shared csImageMask As STRING
Visual C++
public:
static STRING^ csImageMask

See Also

Application Class
ElOS Namespace


fsel_imageopen_DX Field

[image]

4 of William Foster's Class Libraries
Application..::..fsel_imageopen_DX Field
Application Class See Also Send Feedback

[Missing <summary> documentation for "F:ElOS.Application.fsel_imageopen_DX"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static FileSelection_DX fsel_imageopen_DX
Visual Basic
Public Shared fsel_imageopen_DX As FileSelection_DX
Visual C++
public:
static FileSelection_DX^ fsel_imageopen_DX

See Also

Application Class
ElOS Namespace


fsel_imagesave_DX Field

[image]

4 of William Foster's Class Libraries
Application..::..fsel_imagesave_DX Field
Application Class See Also Send Feedback

[Missing <summary> documentation for "F:ElOS.Application.fsel_imagesave_DX"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static FileSelection_DX fsel_imagesave_DX
Visual Basic
Public Shared fsel_imagesave_DX As FileSelection_DX
Visual C++
public:
static FileSelection_DX^ fsel_imagesave_DX

See Also

Application Class
ElOS Namespace


m_Appname Field

[image]

4 of William Foster's Class Libraries
Application..::..m_Appname Field
Application Class See Also Send Feedback

[Missing <summary> documentation for "F:ElOS.Application.m_Appname"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public string m_Appname
Visual Basic
Public m_Appname As String
Visual C++
public:
String^ m_Appname

See Also

Application Class
ElOS Namespace


m_resource_stream Field

[image]

4 of William Foster's Class Libraries
Application..::..m_resource_stream Field
Application Class See Also Send Feedback

[Missing <summary> documentation for "F:ElOS.Application.m_resource_stream"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected Stream m_resource_stream
Visual Basic
Protected m_resource_stream As Stream
Visual C++
protected:
Stream^ m_resource_stream

See Also

Application Class
ElOS Namespace


Application Methods

[image] [image]

4 of William Foster's Class Libraries
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

 | Name | Description
Public method | CreateMainWindow |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetCopyrightString |
Public method | GetGUI |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResourceFolder | (Inherited from ApplicationBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | (Inherited from ApplicationBase.)
Public method | InitializeAppLayer |
Protected method | LoadResources(Filename) |
Protected method | LoadResources(String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | On_About |
Public method | SelectInputImageFiles |
Public method | SelectOutputImageFile |
Public method | SetResource |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Application Class
ElOS Namespace


CreateMainWindow Method

[image]

4 of William Foster's Class Libraries
Application..::..CreateMainWindow Method
Application Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.Application.CreateMainWindow(El.Size2dU,El.STRING,El.STRING)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public virtual bool CreateMainWindow(
    Size2dU size,
    STRING csTitle,
    STRING csMenuName
)
Visual Basic
Public Overridable Function CreateMainWindow ( _
    size As Size2dU, _
    csTitle As STRING, _
    csMenuName As STRING _
) As Boolean
Visual C++
public:
virtual bool CreateMainWindow(
    Size2dU^ size,
    STRING^ csTitle,
    STRING^ csMenuName
)

Parameters

size
Type: Size2dU

[Missing <param name="size"/> documentation for "M:ElOS.Application.CreateMainWindow(El.Size2dU,El.STRING,El.STRING)"]

csTitle
Type: STRING

[Missing <param name="csTitle"/> documentation for "M:ElOS.Application.CreateMainWindow(El.Size2dU,El.STRING,El.STRING)"]

csMenuName
Type: STRING

[Missing <param name="csMenuName"/> documentation for "M:ElOS.Application.CreateMainWindow(El.Size2dU,El.STRING,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElOS.Application.CreateMainWindow(El.Size2dU,El.STRING,El.STRING)"]

See Also

Application Class
ElOS Namespace


Finalize Method

[image]

4 of William Foster's Class Libraries
Application..::..Finalize Method
Application Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.Application.Finalize"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Application Class
ElOS Namespace


GetCopyrightString Method

[image]

4 of William Foster's Class Libraries
Application..::..GetCopyrightString Method
Application Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.Application.GetCopyrightString(El.STRING)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void GetCopyrightString(
    STRING s
)
Visual Basic
Public Sub GetCopyrightString ( _
    s As STRING _
)
Visual C++
public:
void GetCopyrightString(
    STRING^ s
)

Parameters

s
Type: STRING

[Missing <param name="s"/> documentation for "M:ElOS.Application.GetCopyrightString(El.STRING)"]

See Also

Application Class
ElOS Namespace


GetGUI Method

[image]

4 of William Foster's Class Libraries
Application..::..GetGUI Method
Application Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.Application.GetGUI"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public GUI GetGUI()
Visual Basic
Public Function GetGUI As GUI
Visual C++
public:
GUI^ GetGUI()

Return Value

[Missing <returns> documentation for "M:ElOS.Application.GetGUI"]

See Also

Application Class
ElOS Namespace


InitializeAppLayer Method

[image]

4 of William Foster's Class Libraries
Application..::..InitializeAppLayer Method
Application Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.Application.InitializeAppLayer"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public int InitializeAppLayer()
Visual Basic
Public Function InitializeAppLayer As Integer
Visual C++
public:
int InitializeAppLayer()

Return Value

[Missing <returns> documentation for "M:ElOS.Application.InitializeAppLayer"]

See Also

Application Class
ElOS Namespace


LoadResources Method

[image] [image]

4 of William Foster's Class Libraries
Application..::..LoadResources Method
Application Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | LoadResources(Filename) |
Protected method | LoadResources(String) |

See Also

Application Class
Application Members
ElOS Namespace


LoadResources Method ()

[image]

4 of William Foster's Class Libraries
Application..::..LoadResources Method ()
Application Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.Application.LoadResources(El.Filename)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected bool LoadResources(
    Filename ResourceFilename
)
Visual Basic
Protected Function LoadResources ( _
    ResourceFilename As Filename _
) As Boolean
Visual C++
protected:
bool LoadResources(
    Filename^ ResourceFilename
)

Parameters

ResourceFilename
Type: Filename

[Missing <param name="ResourceFilename"/> documentation for "M:ElOS.Application.LoadResources(El.Filename)"]

Return Value

[Missing <returns> documentation for "M:ElOS.Application.LoadResources(El.Filename)"]

See Also

Application Class
LoadResources Overload
ElOS Namespace


LoadResources Method (String)

[image]

4 of William Foster's Class Libraries
Application..::..LoadResources Method (String)
Application Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.Application.LoadResources(System.String)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected bool LoadResources(
    string resourceInMemory
)
Visual Basic
Protected Function LoadResources ( _
    resourceInMemory As String _
) As Boolean
Visual C++
protected:
bool LoadResources(
    String^ resourceInMemory
)

Parameters

resourceInMemory
Type: System..::..String

[Missing <param name="resourceInMemory"/> documentation for "M:ElOS.Application.LoadResources(System.String)"]

Return Value

[Missing <returns> documentation for "M:ElOS.Application.LoadResources(System.String)"]

See Also

Application Class
LoadResources Overload
ElOS Namespace


On_About Method

[image]

4 of William Foster's Class Libraries
Application..::..On_About Method
Application Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.Application.On_About"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public virtual void On_About()
Visual Basic
Public Overridable Sub On_About
Visual C++
public:
virtual void On_About()

See Also

Application Class
ElOS Namespace


SelectInputImageFiles Method

[image]

4 of William Foster's Class Libraries
Application..::..SelectInputImageFiles Method
Application Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.Application.SelectInputImageFiles(System.String,El.Array{El.Filename}@)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public bool SelectInputImageFiles(
    string RegKey,
    out Array<Filename> Filenames
)
Visual Basic
Public Function SelectInputImageFiles ( _
    RegKey As String, _
    <OutAttribute> ByRef Filenames As Array(Of Filename) _
) As Boolean
Visual C++
public:
bool SelectInputImageFiles(
    String^ RegKey,
    [OutAttribute] Array<Filename^>^% Filenames
)

Parameters

RegKey
Type: System..::..String

[Missing <param name="RegKey"/> documentation for "M:ElOS.Application.SelectInputImageFiles(System.String,El.Array{El.Filename}@)"]

Filenames
Type: Array<(Of <(<'Filename>)>)>%

[Missing <param name="Filenames"/> documentation for "M:ElOS.Application.SelectInputImageFiles(System.String,El.Array{El.Filename}@)"]

Return Value

[Missing <returns> documentation for "M:ElOS.Application.SelectInputImageFiles(System.String,El.Array{El.Filename}@)"]

See Also

Application Class
ElOS Namespace


SelectOutputImageFile Method

[image]

4 of William Foster's Class Libraries
Application..::..SelectOutputImageFile Method
Application Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.Application.SelectOutputImageFile(System.String,El.Array{El.Filename}@)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public bool SelectOutputImageFile(
    string RegKey,
    out Array<Filename> Filenames
)
Visual Basic
Public Function SelectOutputImageFile ( _
    RegKey As String, _
    <OutAttribute> ByRef Filenames As Array(Of Filename) _
) As Boolean
Visual C++
public:
bool SelectOutputImageFile(
    String^ RegKey,
    [OutAttribute] Array<Filename^>^% Filenames
)

Parameters

RegKey
Type: System..::..String

[Missing <param name="RegKey"/> documentation for "M:ElOS.Application.SelectOutputImageFile(System.String,El.Array{El.Filename}@)"]

Filenames
Type: Array<(Of <(<'Filename>)>)>%

[Missing <param name="Filenames"/> documentation for "M:ElOS.Application.SelectOutputImageFile(System.String,El.Array{El.Filename}@)"]

Return Value

[Missing <returns> documentation for "M:ElOS.Application.SelectOutputImageFile(System.String,El.Array{El.Filename}@)"]

See Also

Application Class
ElOS Namespace


SetResource Method

[image]

4 of William Foster's Class Libraries
Application..::..SetResource Method
Application Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.Application.SetResource(ElGUI.ScriptResource)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public bool SetResource(
    ScriptResource res
)
Visual Basic
Public Function SetResource ( _
    res As ScriptResource _
) As Boolean
Visual C++
public:
bool SetResource(
    ScriptResource^ res
)

Parameters

res
Type: ElGUI..::..ScriptResource

[Missing <param name="res"/> documentation for "M:ElOS.Application.SetResource(ElGUI.ScriptResource)"]

Return Value

[Missing <returns> documentation for "M:ElOS.Application.SetResource(ElGUI.ScriptResource)"]

See Also

Application Class
ElOS Namespace


FileDialog Class

[image]

4 of William Foster's Class Libraries
FileDialog Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElOS.FileDialog"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public class FileDialog : DialogWindow
Visual Basic
Public Class FileDialog _
    Inherits DialogWindow
Visual C++
public ref class FileDialog : public DialogWindow

Inheritance Hierarchy

System..::..Object
ElGUI..::..UILayerWindow
ElGUI..::..Window
ElGUI..::..MenuWindow
ElGUI..::..ResourceWindow
ElGUI..::..DialogWindow
ElOS..::..FileDialog

See Also

FileDialog Members
ElOS Namespace


FileDialog Members

[image] [image]

4 of William Foster's Class Libraries
FileDialog Members
FileDialog Class Constructors Methods Fields Properties See Also Send Feedback

The FileDialog type exposes the following members.

Constructors

 | Name | Description
Public method | FileDialog | Initializes a new instance of the FileDialog class

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddFilesOfFolder |
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu | (Inherited from MenuWindow.)
Protected method | AddResourceControl | (Inherited from ResourceWindow.)
Protected method | AddSpacer | (Inherited from ResourceWindow.)
Protected method | AddSwitcher | (Inherited from ResourceWindow.)
Protected method | AddWindow | (Inherited from ResourceWindow.)
Protected method | AddWindows | (Inherited from ResourceWindow.)
Public method | AppendResourceContainer | (Inherited from ResourceWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Protected method | ButtonPress | (Overrides DialogWindow..::..ButtonPress(Resource_ID, Resource_Control).)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Protected method | CreateEntryList | (Inherited from ResourceWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | execute | (Inherited from DialogWindow.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Protected method | GetDP | (Inherited from DialogWindow.)
Protected method | GetDX |
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Protected method | GetRCList | (Inherited from ResourceWindow.)
Protected method | GetResourceContainer | (Inherited from ResourceWindow.)
Public method | GetResourceControlList | (Inherited from DialogWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUI_Text(STRING, Filename%) | (Inherited from DialogWindow.)
Public method | GetUI_Text(STRING, STRING%) | (Inherited from DialogWindow.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitializeResourceID | (Inherited from ResourceWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | LoadCurrentFolder |
Protected method | LoadFolder |
Public method | Lookup_Resource_Control(STRING) | (Inherited from ResourceWindow.)
Public method | Lookup_Resource_Control(Resource_ID) | (Inherited from ResourceWindow.)
Public method | LookupResourceEntity | (Inherited from ResourceWindow.)
Public method | LookupResourceName | (Inherited from ResourceWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Overrides DialogWindow..::..OnCreate()()()().)
Protected method | OnDestroy | (Inherited from DialogWindow.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from MenuWindow.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Overrides DialogWindow..::..OnMessage(Message).)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | RecordKeyboardShortcut | (Inherited from MenuWindow.)
Protected method | RedrawOrganizer |
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Public method | SetDP | (Inherited from DialogWindow.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetResourceContainer | (Inherited from ResourceWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetUI_Text | (Inherited from DialogWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDS()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDS(Resource_Control) | Given a control on a Dialog, Fill it in with the data fom the Dialog's DX (Inherited from DialogWindow.)
Public method | UpdateDX()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDX(Button) | (Inherited from DialogWindow.)
Protected method | UpdateDX(Data_Resource_Control) | Called by DialogWindow.UpdateDX(Resource_Control RC) Given a Data_Resource_Control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)
Protected method | UpdateDX(Resource_Control) | (Overrides DialogWindow..::..UpdateDX(Resource_Control).)
Protected method | UpdateFilename |
Protected method | UpFolder |
Public method | WndProc | (Inherited from UILayerWindow.)

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName | (Inherited from MenuWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Public field | m_ds | (Inherited from DialogWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_ResourceControl_List | (Inherited from ResourceWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

FileDialog Class
ElOS Namespace


FileDialog Constructor

[image]

4 of William Foster's Class Libraries
FileDialog Constructor
FileDialog Class See Also Send Feedback
Initializes a new instance of the FileDialog class

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public FileDialog(
    GUI gui,
    DX dx,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    dx As DX, _
    Parent As Window _
)
Visual C++
public:
FileDialog(
    GUI^ gui,
    DX^ dx,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElOS.FileDialog.#ctor(ElGUI.GUI,ElGUI.DX,ElGUI.Window)"]

dx
Type: ElGUI..::..DX

[Missing <param name="dx"/> documentation for "M:ElOS.FileDialog.#ctor(ElGUI.GUI,ElGUI.DX,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElOS.FileDialog.#ctor(ElGUI.GUI,ElGUI.DX,ElGUI.Window)"]

See Also

FileDialog Class
ElOS Namespace


FileDialog Fields

[image] [image]

4 of William Foster's Class Libraries
FileDialog Fields
FileDialog Class See Also Send Feedback

The FileDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_addgrid | (Inherited from UILayerWindow.)
Protected field | m_brush | (Inherited from UILayerWindow.)
Protected field | m_col | (Inherited from UILayerWindow.)
Public field | m_csRegistryName | (Inherited from MenuWindow.)
Protected field | m_dockman | (Inherited from UILayerWindow.)
Protected field | m_dockPane | (Inherited from UILayerWindow.)
Protected field | m_documentPane | (Inherited from UILayerWindow.)
Public field | m_ds | (Inherited from DialogWindow.)
Protected field | m_eWndType | (Inherited from UILayerWindow.)
Protected field | m_graph | (Inherited from UILayerWindow.)
Protected field | m_GUI | (Inherited from UILayerWindow.)
Public field | m_msg | (Inherited from Window.)
Protected field | m_Panel | (Inherited from UILayerWindow.)
Protected field | m_Parent | (Inherited from UILayerWindow.)
Protected field | m_pen | (Inherited from UILayerWindow.)
Protected field | m_ResourceControl_List | (Inherited from ResourceWindow.)
Protected field | m_resPanel | (Inherited from UILayerWindow.)
Protected field | m_row | (Inherited from UILayerWindow.)
Protected field | m_size | (Inherited from UILayerWindow.)
Protected field | m_SysObject | (Inherited from UILayerWindow.)

See Also

FileDialog Class
ElOS Namespace


FileDialog Methods

[image] [image]

4 of William Foster's Class Libraries
FileDialog Methods
FileDialog Class See Also Send Feedback

The FileDialog type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | (Inherited from UILayerWindow.)
Protected method | AddFilesOfFolder |
Protected method | AddMatrix | (Inherited from UILayerWindow.)
Public method | AddMenu | (Inherited from MenuWindow.)
Protected method | AddResourceControl | (Inherited from ResourceWindow.)
Protected method | AddSpacer | (Inherited from ResourceWindow.)
Protected method | AddSwitcher | (Inherited from ResourceWindow.)
Protected method | AddWindow | (Inherited from ResourceWindow.)
Protected method | AddWindows | (Inherited from ResourceWindow.)
Public method | AppendResourceContainer | (Inherited from ResourceWindow.)
Public method | AppendText | (Inherited from UILayerWindow.)
Protected method | ButtonPress | (Overrides DialogWindow..::..ButtonPress(Resource_ID, Resource_Control).)
Public method | ChangeFocus | (Inherited from UILayerWindow.)
Public method | Create | (Inherited from UILayerWindow.)
Public method | CreateDC | (Inherited from UILayerWindow.)
Protected method | CreateEntryList | (Inherited from ResourceWindow.)
Public method | Dirty | (Inherited from UILayerWindow.)
Public method | DoCreate | (Inherited from UILayerWindow.)
Public method | DoModal | (Inherited from UILayerWindow.)
Public method | DrawBitmap | (Inherited from UILayerWindow.)
Public method | DrawEllipse | (Inherited from UILayerWindow.)
Public method | DrawLine | (Inherited from UILayerWindow.)
Public method | DrawPixel | (Inherited from UILayerWindow.)
Public method | DrawRectangle | (Inherited from UILayerWindow.)
Protected method | EndFrame | (Inherited from UILayerWindow.)
Protected method | EndModal | (Inherited from UILayerWindow.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | execute | (Inherited from DialogWindow.)
Public method | FillEllipse | (Inherited from UILayerWindow.)
Public method | FillRectangle | (Inherited from UILayerWindow.)
Protected method | Finalize | (Inherited from Window.)
Protected method | GetDP | (Inherited from DialogWindow.)
Protected method | GetDX |
Public method | GetGUI | (Inherited from UILayerWindow.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex | (Inherited from UILayerWindow.)
Public method | GetOutlineShape | (Inherited from Window.)
Public method | GetParent | (Inherited from UILayerWindow.)
Protected method | GetRCList | (Inherited from ResourceWindow.)
Protected method | GetResourceContainer | (Inherited from ResourceWindow.)
Public method | GetResourceControlList | (Inherited from DialogWindow.)
Public method | GetResourceID | (Inherited from Window.)
Public method | GetResourceStore | (Inherited from Window.)
Public method | GetSizeOnScreen | (Inherited from UILayerWindow.)
Public method | GetText | (Inherited from UILayerWindow.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUI_Text(STRING, Filename%) | (Inherited from DialogWindow.)
Public method | GetUI_Text(STRING, STRING%) | (Inherited from DialogWindow.)
Public method | GetWindowOutline | (Inherited from Window.)
Public method | GetWindowType | (Inherited from UILayerWindow.)
Public method | GetXYOfPos | (Inherited from UILayerWindow.)
Public method | Hide | (Inherited from UILayerWindow.)
Protected method | InitContent | (Inherited from UILayerWindow.)
Public method | InitDocker | (Inherited from UILayerWindow.)
Protected method | InitDockMan | (Inherited from UILayerWindow.)
Public method | InitDocPane | (Inherited from UILayerWindow.)
Protected method | InitializeResourceID | (Inherited from ResourceWindow.)
Protected method | InitWindowContent | (Inherited from UILayerWindow.)
Public method | IsChildWindow | (Inherited from UILayerWindow.)
Public method | IsControl | (Inherited from UILayerWindow.)
Public method | IsDirty | (Inherited from Window.)
Public method | IsElement | (Inherited from UILayerWindow.)
Public method | IsMDIContainer | (Inherited from UILayerWindow.)
Public method | IsTab | (Inherited from UILayerWindow.)
Public method | IsVisible | (Inherited from Window.)
Public method | IsWindow | (Inherited from UILayerWindow.)
Public method | LayerSetFont | (Inherited from UILayerWindow.)
Protected method | LoadCurrentFolder |
Protected method | LoadFolder |
Public method | Lookup_Resource_Control(STRING) | (Inherited from ResourceWindow.)
Public method | Lookup_Resource_Control(Resource_ID) | (Inherited from ResourceWindow.)
Public method | LookupResourceEntity | (Inherited from ResourceWindow.)
Public method | LookupResourceName | (Inherited from ResourceWindow.)
Protected method | MakeSysObject | Instantiate m_SysObject, which will be a windows control the control or window is either WPF, silverlight, Winforms, depending on which engine is enabled (Inherited from UILayerWindow.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCreate | (Overrides DialogWindow..::..OnCreate()()()().)
Protected method | OnDestroy | (Inherited from DialogWindow.)
Public method | OnFocusIn | (Inherited from Window.)
Public method | OnFocusOut | (Inherited from Window.)
Public method | OnKeyDown | (Inherited from MenuWindow.)
Public method | OnKeyUp | (Inherited from Window.)
Public method | OnMessage | (Overrides DialogWindow..::..OnMessage(Message).)
Public method | OnMouseDoubleClick | (Inherited from Window.)
Public method | OnMouseDown | (Inherited from Window.)
Public method | OnMouseEnter | (Inherited from Window.)
Public method | OnMouseLeave | (Inherited from Window.)
Public method | OnMouseMove | (Inherited from Window.)
Public method | OnMouseUp | (Inherited from Window.)
Protected method | OnPaint | (Inherited from Window.)
Protected method | OnRedraw | (Inherited from Window.)
Protected method | OnResize | (Inherited from UILayerWindow.)
Protected method | PointFromScreen | (Inherited from UILayerWindow.)
Protected method | RecordKeyboardShortcut | (Inherited from MenuWindow.)
Protected method | RedrawOrganizer |
Protected method | ReflectInternalImage | (Inherited from Window.)
Public method | ReleaseDC | (Inherited from UILayerWindow.)
Protected method | RenderInternal | (Inherited from Window.)
Protected method | RenderOutline | (Inherited from Window.)
Public method | ReplaceText | (Inherited from UILayerWindow.)
Public method | RestrainDistance | (Inherited from UILayerWindow.)
Public method | RestrainInteger | (Inherited from UILayerWindow.)
Public method | RestrainNumeric | (Inherited from UILayerWindow.)
Public method | RestrainPassword | (Inherited from UILayerWindow.)
Public method | SelectAll | (Inherited from UILayerWindow.)
Public method | SetAddtoTab | (Inherited from UILayerWindow.)
Public method | SetCanvasSize | (Inherited from Window.)
Public method | SetClean | (Inherited from Window.)
Public method | SetClip | (Inherited from Window.)
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)
Public method | SetData | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)
Public method | SetDialogResult | (Inherited from UILayerWindow.)
Public method | SetDirty | (Inherited from Window.)
Public method | SetDP | (Inherited from DialogWindow.)
Protected method | SetEditable | (Inherited from UILayerWindow.)
Protected method | SetFocus | (Inherited from UILayerWindow.)
Public method | SetIndex | (Inherited from UILayerWindow.)
Public method | SetResourceContainer | (Inherited from ResourceWindow.)
Public method | SetText | (Inherited from UILayerWindow.)
Public method | SetTextEditable | (Inherited from UILayerWindow.)
Public method | SetTitle | (Inherited from UILayerWindow.)
Public method | SetUI_Text | (Inherited from DialogWindow.)
Public method | SetVisible | (Inherited from Window.)
Public method | SetWindowDefault | (Inherited from UILayerWindow.)
Public method | SetWindowFocus | (Inherited from UILayerWindow.)
Public method | SetWindowOutline | (Inherited from Window.)
Public method | SetWindowPosition | (Inherited from UILayerWindow.)
Public method | SetWindowSize | (Inherited from UILayerWindow.)
Public method | Show | (Inherited from UILayerWindow.)
Public method | SizeTextbox | (Inherited from UILayerWindow.)
Public method | SizeToContent | (Inherited from UILayerWindow.)
Protected method | Stop | (Inherited from UILayerWindow.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDS()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDS(Resource_Control) | Given a control on a Dialog, Fill it in with the data fom the Dialog's DX (Inherited from DialogWindow.)
Public method | UpdateDX()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDX(Button) | (Inherited from DialogWindow.)
Protected method | UpdateDX(Data_Resource_Control) | Called by DialogWindow.UpdateDX(Resource_Control RC) Given a Data_Resource_Control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)
Protected method | UpdateDX(Resource_Control) | (Overrides DialogWindow..::..UpdateDX(Resource_Control).)
Protected method | UpdateFilename |
Protected method | UpFolder |
Public method | WndProc | (Inherited from UILayerWindow.)

See Also

FileDialog Class
ElOS Namespace


AddFilesOfFolder Method

[image]

4 of William Foster's Class Libraries
FileDialog..::..AddFilesOfFolder Method
FileDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileDialog.AddFilesOfFolder(El.Filename)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected void AddFilesOfFolder(
    Filename csFolder
)
Visual Basic
Protected Sub AddFilesOfFolder ( _
    csFolder As Filename _
)
Visual C++
protected:
void AddFilesOfFolder(
    Filename^ csFolder
)

Parameters

csFolder
Type: Filename

[Missing <param name="csFolder"/> documentation for "M:ElOS.FileDialog.AddFilesOfFolder(El.Filename)"]

See Also

FileDialog Class
ElOS Namespace


ButtonPress Method

[image]

4 of William Foster's Class Libraries
FileDialog..::..ButtonPress Method
FileDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileDialog.ButtonPress(ElGUI.Resource_ID,ElGUI.Resource_Control)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected override bool ButtonPress(
    Resource_ID rID,
    Resource_Control Rc
)
Visual Basic
Protected Overrides Function ButtonPress ( _
    rID As Resource_ID, _
    Rc As Resource_Control _
) As Boolean
Visual C++
protected:
virtual bool ButtonPress(
    Resource_ID rID,
    Resource_Control^ Rc
) override

Parameters

rID
Type: ElGUI..::..Resource_ID

[Missing <param name="rID"/> documentation for "M:ElOS.FileDialog.ButtonPress(ElGUI.Resource_ID,ElGUI.Resource_Control)"]

Rc
Type: ElGUI..::..Resource_Control

[Missing <param name="Rc"/> documentation for "M:ElOS.FileDialog.ButtonPress(ElGUI.Resource_ID,ElGUI.Resource_Control)"]

Return Value

[Missing <returns> documentation for "M:ElOS.FileDialog.ButtonPress(ElGUI.Resource_ID,ElGUI.Resource_Control)"]

See Also

FileDialog Class
ElOS Namespace


GetDX Method

[image]

4 of William Foster's Class Libraries
FileDialog..::..GetDX Method
FileDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileDialog.GetDX"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected FileSelection_DX GetDX()
Visual Basic
Protected Function GetDX As FileSelection_DX
Visual C++
protected:
FileSelection_DX^ GetDX()

Return Value

[Missing <returns> documentation for "M:ElOS.FileDialog.GetDX"]

See Also

FileDialog Class
ElOS Namespace


GetUI_Text Method

[image] [image]

4 of William Foster's Class Libraries
FileDialog..::..GetUI_Text Method
FileDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUI_Text(STRING, Filename%) | (Inherited from DialogWindow.)
Public method | GetUI_Text(STRING, STRING%) | (Inherited from DialogWindow.)

See Also

FileDialog Class
FileDialog Members
ElOS Namespace


LoadCurrentFolder Method

[image]

4 of William Foster's Class Libraries
FileDialog..::..LoadCurrentFolder Method
FileDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileDialog.LoadCurrentFolder"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected bool LoadCurrentFolder()
Visual Basic
Protected Function LoadCurrentFolder As Boolean
Visual C++
protected:
bool LoadCurrentFolder()

Return Value

[Missing <returns> documentation for "M:ElOS.FileDialog.LoadCurrentFolder"]

See Also

FileDialog Class
ElOS Namespace


LoadFolder Method

[image]

4 of William Foster's Class Libraries
FileDialog..::..LoadFolder Method
FileDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileDialog.LoadFolder(El.Filename)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected bool LoadFolder(
    Filename csFolder
)
Visual Basic
Protected Function LoadFolder ( _
    csFolder As Filename _
) As Boolean
Visual C++
protected:
bool LoadFolder(
    Filename^ csFolder
)

Parameters

csFolder
Type: Filename

[Missing <param name="csFolder"/> documentation for "M:ElOS.FileDialog.LoadFolder(El.Filename)"]

Return Value

[Missing <returns> documentation for "M:ElOS.FileDialog.LoadFolder(El.Filename)"]

See Also

FileDialog Class
ElOS Namespace


Lookup_Resource_Control Method

[image] [image]

4 of William Foster's Class Libraries
FileDialog..::..Lookup_Resource_Control Method
FileDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Lookup_Resource_Control(STRING) | (Inherited from ResourceWindow.)
Public method | Lookup_Resource_Control(Resource_ID) | (Inherited from ResourceWindow.)

See Also

FileDialog Class
FileDialog Members
ElOS Namespace


OnCreate Method

[image]

4 of William Foster's Class Libraries
FileDialog..::..OnCreate Method
FileDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileDialog.OnCreate"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected override bool OnCreate()
Visual Basic
Protected Overrides Function OnCreate As Boolean
Visual C++
protected:
virtual bool OnCreate() override

Return Value

[Missing <returns> documentation for "M:ElOS.FileDialog.OnCreate"]

See Also

FileDialog Class
ElOS Namespace


OnMessage Method

[image]

4 of William Foster's Class Libraries
FileDialog..::..OnMessage Method
FileDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileDialog.OnMessage(ElGUI.Message)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public override int OnMessage(
    Message msg
)
Visual Basic
Public Overrides Function OnMessage ( _
    msg As Message _
) As Integer
Visual C++
public:
virtual int OnMessage(
    Message^ msg
) override

Parameters

msg
Type: ElGUI..::..Message

[Missing <param name="msg"/> documentation for "M:ElOS.FileDialog.OnMessage(ElGUI.Message)"]

Return Value

[Missing <returns> documentation for "M:ElOS.FileDialog.OnMessage(ElGUI.Message)"]

Implements

ITerminalWindow..::..OnMessage(Message)

See Also

FileDialog Class
ElOS Namespace


RedrawOrganizer Method

[image]

4 of William Foster's Class Libraries
FileDialog..::..RedrawOrganizer Method
FileDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileDialog.RedrawOrganizer"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected void RedrawOrganizer()
Visual Basic
Protected Sub RedrawOrganizer
Visual C++
protected:
void RedrawOrganizer()

See Also

FileDialog Class
ElOS Namespace


SetColor Method

[image] [image]

4 of William Foster's Class Libraries
FileDialog..::..SetColor Method
FileDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetColor(UInt32) | (Inherited from UILayerWindow.)
Public method | SetColor(Color) | (Inherited from Window.)

See Also

FileDialog Class
FileDialog Members
ElOS Namespace


SetDefaultCursor Method

[image] [image]

4 of William Foster's Class Libraries
FileDialog..::..SetDefaultCursor Method
FileDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDefaultCursor(CURSOR) | (Inherited from UILayerWindow.)
Public method | SetDefaultCursor(Image) | (Inherited from UILayerWindow.)

See Also

FileDialog Class
FileDialog Members
ElOS Namespace


UpdateDS Method

[image] [image]

4 of William Foster's Class Libraries
FileDialog..::..UpdateDS Method
FileDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateDS()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDS(Resource_Control) | Given a control on a Dialog, Fill it in with the data fom the Dialog's DX (Inherited from DialogWindow.)

See Also

FileDialog Class
FileDialog Members
ElOS Namespace


UpdateDX Method

[image] [image]

4 of William Foster's Class Libraries
FileDialog..::..UpdateDX Method
FileDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateDX()()()() | (Inherited from DialogWindow.)
Protected method | UpdateDX(Button) | (Inherited from DialogWindow.)
Protected method | UpdateDX(Data_Resource_Control) | Called by DialogWindow.UpdateDX(Resource_Control RC) Given a Data_Resource_Control on a Dialog, read the control and store the information into the Dialog's DX (Inherited from DialogWindow.)
Protected method | UpdateDX(Resource_Control) | (Overrides DialogWindow..::..UpdateDX(Resource_Control).)

See Also

FileDialog Class
FileDialog Members
ElOS Namespace


UpdateDX Method (Resource_Control)

[image]

4 of William Foster's Class Libraries
FileDialog..::..UpdateDX Method (Resource_Control)
FileDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileDialog.UpdateDX(ElGUI.Resource_Control)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected override void UpdateDX(
    Resource_Control Txtbox
)
Visual Basic
Protected Overrides Sub UpdateDX ( _
    Txtbox As Resource_Control _
)
Visual C++
protected:
virtual void UpdateDX(
    Resource_Control^ Txtbox
) override

Parameters

Txtbox
Type: ElGUI..::..Resource_Control

[Missing <param name="Txtbox"/> documentation for "M:ElOS.FileDialog.UpdateDX(ElGUI.Resource_Control)"]

See Also

FileDialog Class
UpdateDX Overload
ElOS Namespace


UpdateFilename Method

[image]

4 of William Foster's Class Libraries
FileDialog..::..UpdateFilename Method
FileDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileDialog.UpdateFilename"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected bool UpdateFilename()
Visual Basic
Protected Function UpdateFilename As Boolean
Visual C++
protected:
bool UpdateFilename()

Return Value

[Missing <returns> documentation for "M:ElOS.FileDialog.UpdateFilename"]

See Also

FileDialog Class
ElOS Namespace


UpFolder Method

[image]

4 of William Foster's Class Libraries
FileDialog..::..UpFolder Method
FileDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileDialog.UpFolder"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected void UpFolder()
Visual Basic
Protected Sub UpFolder
Visual C++
protected:
void UpFolder()

See Also

FileDialog Class
ElOS Namespace


FileDialog Properties

[image] [image]

4 of William Foster's Class Libraries
FileDialog Properties
FileDialog Class See Also Send Feedback

The FileDialog type exposes the following members.

Properties

 | Name | Description
Public property | childitem | (Inherited from UILayerWindow.)
Public property | control | (Inherited from UILayerWindow.)
Public property | element | (Inherited from UILayerWindow.)
Public property | tabitem | (Inherited from UILayerWindow.)
Public property | toolbar | (Inherited from UILayerWindow.)
Public property | window | (Inherited from UILayerWindow.)

See Also

FileDialog Class
ElOS Namespace


FileOperation Class

[image]

4 of William Foster's Class Libraries
FileOperation Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElOS.FileOperation"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public class FileOperation
Visual Basic
Public Class FileOperation
Visual C++
public ref class FileOperation

Inheritance Hierarchy

System..::..Object
ElOS..::..FileOperation

See Also

FileOperation Members
ElOS Namespace


FileOperation Members

[image] [image]

4 of William Foster's Class Libraries
FileOperation Members
FileOperation Class Constructors Methods Fields See Also Send Feedback

The FileOperation type exposes the following members.

Constructors

 | Name | Description
Public method | FileOperation | Initializes a new instance of the FileOperation class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Operate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ALL_WILD |

See Also

FileOperation Class
ElOS Namespace


FileOperation Constructor

[image]

4 of William Foster's Class Libraries
FileOperation Constructor
FileOperation Class See Also Send Feedback
Initializes a new instance of the FileOperation class

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public FileOperation(
    Filename cs_TargetFilespec,
    bool b_recurse_subfolders
)
Visual Basic
Public Sub New ( _
    cs_TargetFilespec As Filename, _
    b_recurse_subfolders As Boolean _
)
Visual C++
public:
FileOperation(
    Filename^ cs_TargetFilespec,
    bool b_recurse_subfolders
)

Parameters

cs_TargetFilespec
Type: Filename

[Missing <param name="cs_TargetFilespec"/> documentation for "M:ElOS.FileOperation.#ctor(El.Filename,System.Boolean)"]

b_recurse_subfolders
Type: System..::..Boolean

[Missing <param name="b_recurse_subfolders"/> documentation for "M:ElOS.FileOperation.#ctor(El.Filename,System.Boolean)"]

See Also

FileOperation Class
ElOS Namespace


FileOperation Fields

[image] [image]

4 of William Foster's Class Libraries
FileOperation Fields
FileOperation Class See Also Send Feedback

The FileOperation type exposes the following members.

Fields

Name | Description
ALL_WILD |

See Also

FileOperation Class
ElOS Namespace


ALL_WILD Field

[image]

4 of William Foster's Class Libraries
FileOperation..::..ALL_WILD Field
FileOperation Class See Also Send Feedback

[Missing <summary> documentation for "F:ElOS.FileOperation.ALL_WILD"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static string ALL_WILD
Visual Basic
Public Shared ALL_WILD As String
Visual C++
public:
static String^ ALL_WILD

See Also

FileOperation Class
ElOS Namespace


FileOperation Methods

[image] [image]

4 of William Foster's Class Libraries
FileOperation Methods
FileOperation Class See Also Send Feedback

The FileOperation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Operate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileOperation Class
ElOS Namespace


Operate Method

[image]

4 of William Foster's Class Libraries
FileOperation..::..Operate Method
FileOperation Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileOperation.Operate(ElOS.FileOperationClass)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public bool Operate(
    FileOperationClass opclass
)
Visual Basic
Public Function Operate ( _
    opclass As FileOperationClass _
) As Boolean
Visual C++
public:
bool Operate(
    FileOperationClass^ opclass
)

Parameters

opclass
Type: ElOS..::..FileOperationClass

[Missing <param name="opclass"/> documentation for "M:ElOS.FileOperation.Operate(ElOS.FileOperationClass)"]

Return Value

[Missing <returns> documentation for "M:ElOS.FileOperation.Operate(ElOS.FileOperationClass)"]

See Also

FileOperation Class
ElOS Namespace


FileOperationClass Class

[image]

4 of William Foster's Class Libraries
FileOperationClass Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElOS.FileOperationClass"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public abstract class FileOperationClass
Visual Basic
Public MustInherit Class FileOperationClass
Visual C++
public ref class FileOperationClass abstract

Inheritance Hierarchy

System..::..Object
ElOS..::..FileOperationClass

See Also

FileOperationClass Members
ElOS Namespace


FileOperationClass Members

[image] [image]

4 of William Foster's Class Libraries
FileOperationClass Members
FileOperationClass Class Constructors Methods See Also Send Feedback

The FileOperationClass type exposes the following members.

Constructors

 | Name | Description
Protected method | FileOperationClass | Initializes a new instance of the FileOperationClass class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Operate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileOperationClass Class
ElOS Namespace


FileOperationClass Constructor

[image]

4 of William Foster's Class Libraries
FileOperationClass Constructor
FileOperationClass Class See Also Send Feedback
Initializes a new instance of the FileOperationClass class

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected FileOperationClass()
Visual Basic
Protected Sub New
Visual C++
protected:
FileOperationClass()

See Also

FileOperationClass Class
ElOS Namespace


FileOperationClass Methods

[image] [image]

4 of William Foster's Class Libraries
FileOperationClass Methods
FileOperationClass Class See Also Send Feedback

The FileOperationClass type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Operate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileOperationClass Class
ElOS Namespace


Operate Method

[image]

4 of William Foster's Class Libraries
FileOperationClass..::..Operate Method
FileOperationClass Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileOperationClass.Operate(El.Filename)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public abstract int Operate(
    Filename fname
)
Visual Basic
Public MustOverride Function Operate ( _
    fname As Filename _
) As Integer
Visual C++
public:
virtual int Operate(
    Filename^ fname
) abstract

Parameters

fname
Type: Filename

[Missing <param name="fname"/> documentation for "M:ElOS.FileOperationClass.Operate(El.Filename)"]

Return Value

[Missing <returns> documentation for "M:ElOS.FileOperationClass.Operate(El.Filename)"]

See Also

FileOperationClass Class
ElOS Namespace


FileSelection_DP Class

[image]

4 of William Foster's Class Libraries
FileSelection_DP Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElOS.FileSelection_DP"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public class FileSelection_DP : CDefault_DlgDP
Visual Basic
Public Class FileSelection_DP _
    Inherits CDefault_DlgDP
Visual C++
public ref class FileSelection_DP : public CDefault_DlgDP

Inheritance Hierarchy

System..::..Object
ElGUI..::..DP
ElGUI..::..DlgDP
ElGUI..::..CDefault_DlgDP
ElOS..::..FileSelection_DP

See Also

FileSelection_DP Members
ElOS Namespace


FileSelection_DP Members

[image] [image]

4 of William Foster's Class Libraries
FileSelection_DP Members
FileSelection_DP Class Constructors Methods Fields See Also Send Feedback

The FileSelection_DP type exposes the following members.

Constructors

 | Name | Description
Public method | FileSelection_DP | Initializes a new instance of the FileSelection_DP class

Methods

 | Name | Description
Public method | CreateDialog | (Overrides DP..::..CreateDialog(Window, Boolean).)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetGUI | (Inherited from DlgDP.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadMemoryResource | (Inherited from CDefault_DlgDP.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview | (Inherited from CDefault_DlgDP.)
Public method | ProcessInput | (Overrides CDefault_DlgDP..::..ProcessInput(Resource_Control, DialogWindow).)
Public method | RunDlg(DialogWindow, DP) | (Overrides CDefault_DlgDP..::..RunDlg(DialogWindow, DP).)
Public method | RunDlg(Window, STRING) | (Inherited from DlgDP.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_parent | (Inherited from DlgDP.)

See Also

FileSelection_DP Class
ElOS Namespace


FileSelection_DP Constructor

[image]

4 of William Foster's Class Libraries
FileSelection_DP Constructor
FileSelection_DP Class See Also Send Feedback
Initializes a new instance of the FileSelection_DP class

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public FileSelection_DP(
    GUI gui,
    FileSelection_DX DX,
    Window Parent
)
Visual Basic
Public Sub New ( _
    gui As GUI, _
    DX As FileSelection_DX, _
    Parent As Window _
)
Visual C++
public:
FileSelection_DP(
    GUI^ gui,
    FileSelection_DX^ DX,
    Window^ Parent
)

Parameters

gui
Type: ElGUI..::..GUI

[Missing <param name="gui"/> documentation for "M:ElOS.FileSelection_DP.#ctor(ElGUI.GUI,ElOS.FileSelection_DX,ElGUI.Window)"]

DX
Type: ElOS..::..FileSelection_DX

[Missing <param name="DX"/> documentation for "M:ElOS.FileSelection_DP.#ctor(ElGUI.GUI,ElOS.FileSelection_DX,ElGUI.Window)"]

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElOS.FileSelection_DP.#ctor(ElGUI.GUI,ElOS.FileSelection_DX,ElGUI.Window)"]

See Also

FileSelection_DP Class
ElOS Namespace


FileSelection_DP Fields

[image] [image]

4 of William Foster's Class Libraries
FileSelection_DP Fields
FileSelection_DP Class See Also Send Feedback

The FileSelection_DP type exposes the following members.

Fields

 | Name | Description
Protected field | m_parent | (Inherited from DlgDP.)

See Also

FileSelection_DP Class
ElOS Namespace


FileSelection_DP Methods

[image] [image]

4 of William Foster's Class Libraries
FileSelection_DP Methods
FileSelection_DP Class See Also Send Feedback

The FileSelection_DP type exposes the following members.

Methods

 | Name | Description
Public method | CreateDialog | (Overrides DP..::..CreateDialog(Window, Boolean).)
Public method | DonePreviewing | (Inherited from DP.)
Public method | Edit | Pull up a dialog for this dx. If a DlgDP is named, instantiate one of it, else generate one from the field list. (Inherited from DP.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDX | (Inherited from DP.)
Public method | GetGUI | (Inherited from DlgDP.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadMemoryResource | (Inherited from CDefault_DlgDP.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Preview | (Inherited from CDefault_DlgDP.)
Public method | ProcessInput | (Overrides CDefault_DlgDP..::..ProcessInput(Resource_Control, DialogWindow).)
Public method | RunDlg(DialogWindow, DP) | (Overrides CDefault_DlgDP..::..RunDlg(DialogWindow, DP).)
Public method | RunDlg(Window, STRING) | (Inherited from DlgDP.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileSelection_DP Class
ElOS Namespace


CreateDialog Method

[image]

4 of William Foster's Class Libraries
FileSelection_DP..::..CreateDialog Method
FileSelection_DP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelection_DP.CreateDialog(ElGUI.Window,System.Boolean)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public override DialogWindow CreateDialog(
    Window Parent,
    bool bPopup
)
Visual Basic
Public Overrides Function CreateDialog ( _
    Parent As Window, _
    bPopup As Boolean _
) As DialogWindow
Visual C++
public:
virtual DialogWindow^ CreateDialog(
    Window^ Parent,
    bool bPopup
) override

Parameters

Parent
Type: ElGUI..::..Window

[Missing <param name="Parent"/> documentation for "M:ElOS.FileSelection_DP.CreateDialog(ElGUI.Window,System.Boolean)"]

bPopup
Type: System..::..Boolean

[Missing <param name="bPopup"/> documentation for "M:ElOS.FileSelection_DP.CreateDialog(ElGUI.Window,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ElOS.FileSelection_DP.CreateDialog(ElGUI.Window,System.Boolean)"]

See Also

FileSelection_DP Class
ElOS Namespace


ProcessInput Method

[image]

4 of William Foster's Class Libraries
FileSelection_DP..::..ProcessInput Method
FileSelection_DP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelection_DP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public override bool ProcessInput(
    Resource_Control Ctrl,
    DialogWindow DS
)
Visual Basic
Public Overrides Function ProcessInput ( _
    Ctrl As Resource_Control, _
    DS As DialogWindow _
) As Boolean
Visual C++
public:
virtual bool ProcessInput(
    Resource_Control^ Ctrl,
    DialogWindow^ DS
) override

Parameters

Ctrl
Type: ElGUI..::..Resource_Control

[Missing <param name="Ctrl"/> documentation for "M:ElOS.FileSelection_DP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

DS
Type: ElGUI..::..DialogWindow

[Missing <param name="DS"/> documentation for "M:ElOS.FileSelection_DP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

Return Value

[Missing <returns> documentation for "M:ElOS.FileSelection_DP.ProcessInput(ElGUI.Resource_Control,ElGUI.DialogWindow)"]

See Also

FileSelection_DP Class
ElOS Namespace


RunDlg Method

[image] [image]

4 of William Foster's Class Libraries
FileSelection_DP..::..RunDlg Method
FileSelection_DP Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RunDlg(DialogWindow, DP) | (Overrides CDefault_DlgDP..::..RunDlg(DialogWindow, DP).)
Public method | RunDlg(Window, STRING) | (Inherited from DlgDP.)

See Also

FileSelection_DP Class
FileSelection_DP Members
ElOS Namespace


RunDlg Method (DialogWindow, DP)

[image]

4 of William Foster's Class Libraries
FileSelection_DP..::..RunDlg Method (DialogWindow, DP)
FileSelection_DP Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelection_DP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public override int RunDlg(
    DialogWindow DS,
    DP PreviewDP
)
Visual Basic
Public Overrides Function RunDlg ( _
    DS As DialogWindow, _
    PreviewDP As DP _
) As Integer
Visual C++
public:
virtual int RunDlg(
    DialogWindow^ DS,
    DP^ PreviewDP
) override

Parameters

DS
Type: ElGUI..::..DialogWindow

[Missing <param name="DS"/> documentation for "M:ElOS.FileSelection_DP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

PreviewDP
Type: ElGUI..::..DP

[Missing <param name="PreviewDP"/> documentation for "M:ElOS.FileSelection_DP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

Return Value

[Missing <returns> documentation for "M:ElOS.FileSelection_DP.RunDlg(ElGUI.DialogWindow,ElGUI.DP)"]

See Also

FileSelection_DP Class
RunDlg Overload
ElOS Namespace


FileSelection_DX Class

[image]

4 of William Foster's Class Libraries
FileSelection_DX Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElOS.FileSelection_DX"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public class FileSelection_DX : DX
Visual Basic
Public Class FileSelection_DX _
    Inherits DX
Visual C++
public ref class FileSelection_DX : public DX

Inheritance Hierarchy

System..::..Object
ElGUI..::..DX
ElOS..::..FileSelection_DX

See Also

FileSelection_DX Members
ElOS Namespace


FileSelection_DX Members

[image] [image]

4 of William Foster's Class Libraries
FileSelection_DX Members
FileSelection_DX Class Constructors Methods Fields See Also Send Feedback

The FileSelection_DX type exposes the following members.

Constructors

 | Name | Description
Public method | FileSelection_DX | Initializes a new instance of the FileSelection_DX class

Methods

 | Name | Description
Public method | AddFilename |
Protected method | CreateMatrix | (Inherited from DX.)
Public method | CreateTable | Set up the (empty) DX in memory with fields representing values (Inherited from DX.)
Public method | Dup | (Overrides DX..::..Dup()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateResource | (Inherited from DX.)
Public method | GetFilemask |
Public method | GetFilenames |
Public method | GetFilesystemEntries |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMember | (Inherited from DX.)
Public method | GetMemberBool | (Inherited from DX.)
Public method | GetSet | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetCheck | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetText | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetUint | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetStartFolder |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateField | Check the DXEntry list for a resource control with the given name (Inherited from DX.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegistryLoad | Load up this DX from the default registry entries based apon the DXEntry list. (Inherited from DX.)
Public method | RegistrySave | Based apon the DXEntry list, Automatically Save out any important paramenters of this DX to the registry with unique naming (Inherited from DX.)
Public method | SetFilemask |
Public method | SetFilesystemEntries |
Public method | SetStartFolder |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_csRegistryName | (Inherited from DX.)
Public field | m_dlgdp_classname | (Inherited from DX.)
Protected field | m_FieldList | (Inherited from DX.)

See Also

FileSelection_DX Class
ElOS Namespace


FileSelection_DX Constructor

[image]

4 of William Foster's Class Libraries
FileSelection_DX Constructor
FileSelection_DX Class See Also Send Feedback
Initializes a new instance of the FileSelection_DX class

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public FileSelection_DX(
    bool b_open,
    bool b_multiple_selections,
    bool b_select_folder,
    STRING ExtentionList,
    Filename StartFolder
)
Visual Basic
Public Sub New ( _
    b_open As Boolean, _
    b_multiple_selections As Boolean, _
    b_select_folder As Boolean, _
    ExtentionList As STRING, _
    StartFolder As Filename _
)
Visual C++
public:
FileSelection_DX(
    bool b_open,
    bool b_multiple_selections,
    bool b_select_folder,
    STRING^ ExtentionList,
    Filename^ StartFolder
)

Parameters

b_open
Type: System..::..Boolean

[Missing <param name="b_open"/> documentation for "M:ElOS.FileSelection_DX.#ctor(System.Boolean,System.Boolean,System.Boolean,El.STRING,El.Filename)"]

b_multiple_selections
Type: System..::..Boolean

[Missing <param name="b_multiple_selections"/> documentation for "M:ElOS.FileSelection_DX.#ctor(System.Boolean,System.Boolean,System.Boolean,El.STRING,El.Filename)"]

b_select_folder
Type: System..::..Boolean

[Missing <param name="b_select_folder"/> documentation for "M:ElOS.FileSelection_DX.#ctor(System.Boolean,System.Boolean,System.Boolean,El.STRING,El.Filename)"]

ExtentionList
Type: STRING

[Missing <param name="ExtentionList"/> documentation for "M:ElOS.FileSelection_DX.#ctor(System.Boolean,System.Boolean,System.Boolean,El.STRING,El.Filename)"]

StartFolder
Type: Filename

[Missing <param name="StartFolder"/> documentation for "M:ElOS.FileSelection_DX.#ctor(System.Boolean,System.Boolean,System.Boolean,El.STRING,El.Filename)"]

See Also

FileSelection_DX Class
ElOS Namespace


FileSelection_DX Fields

[image] [image]

4 of William Foster's Class Libraries
FileSelection_DX Fields
FileSelection_DX Class See Also Send Feedback

The FileSelection_DX type exposes the following members.

Fields

 | Name | Description
Protected field | m_csRegistryName | (Inherited from DX.)
Public field | m_dlgdp_classname | (Inherited from DX.)
Protected field | m_FieldList | (Inherited from DX.)

See Also

FileSelection_DX Class
ElOS Namespace


FileSelection_DX Methods

[image] [image]

4 of William Foster's Class Libraries
FileSelection_DX Methods
FileSelection_DX Class See Also Send Feedback

The FileSelection_DX type exposes the following members.

Methods

 | Name | Description
Public method | AddFilename |
Protected method | CreateMatrix | (Inherited from DX.)
Public method | CreateTable | Set up the (empty) DX in memory with fields representing values (Inherited from DX.)
Public method | Dup | (Overrides DX..::..Dup()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateResource | (Inherited from DX.)
Public method | GetFilemask |
Public method | GetFilenames |
Public method | GetFilesystemEntries |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMember | (Inherited from DX.)
Public method | GetMemberBool | (Inherited from DX.)
Public method | GetSet | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetCheck | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetText | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetSetUint | Given the name of the resource control, either Set the appropriate field in the DX or obtain it from the DX. (Inherited from DX.)
Public method | GetStartFolder |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateField | Check the DXEntry list for a resource control with the given name (Inherited from DX.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RegistryLoad | Load up this DX from the default registry entries based apon the DXEntry list. (Inherited from DX.)
Public method | RegistrySave | Based apon the DXEntry list, Automatically Save out any important paramenters of this DX to the registry with unique naming (Inherited from DX.)
Public method | SetFilemask |
Public method | SetFilesystemEntries |
Public method | SetStartFolder |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileSelection_DX Class
ElOS Namespace


AddFilename Method

[image]

4 of William Foster's Class Libraries
FileSelection_DX..::..AddFilename Method
FileSelection_DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelection_DX.AddFilename(El.Filename,System.Int32)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void AddFilename(
    Filename fname,
    int i_organizer_offset
)
Visual Basic
Public Sub AddFilename ( _
    fname As Filename, _
    i_organizer_offset As Integer _
)
Visual C++
public:
void AddFilename(
    Filename^ fname,
    int i_organizer_offset
)

Parameters

fname
Type: Filename

[Missing <param name="fname"/> documentation for "M:ElOS.FileSelection_DX.AddFilename(El.Filename,System.Int32)"]

i_organizer_offset
Type: System..::..Int32

[Missing <param name="i_organizer_offset"/> documentation for "M:ElOS.FileSelection_DX.AddFilename(El.Filename,System.Int32)"]

See Also

FileSelection_DX Class
ElOS Namespace


Dup Method

[image]

4 of William Foster's Class Libraries
FileSelection_DX..::..Dup Method
FileSelection_DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelection_DX.Dup"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public override DX Dup()
Visual Basic
Public Overrides Function Dup As DX
Visual C++
public:
virtual DX^ Dup() override

Return Value

[Missing <returns> documentation for "M:ElOS.FileSelection_DX.Dup"]

See Also

FileSelection_DX Class
ElOS Namespace


GetFilemask Method

[image]

4 of William Foster's Class Libraries
FileSelection_DX..::..GetFilemask Method
FileSelection_DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelection_DX.GetFilemask(El.STRING@)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void GetFilemask(
    out STRING Mask
)
Visual Basic
Public Sub GetFilemask ( _
    <OutAttribute> ByRef Mask As STRING _
)
Visual C++
public:
void GetFilemask(
    [OutAttribute] STRING^% Mask
)

Parameters

Mask
Type: STRING%

[Missing <param name="Mask"/> documentation for "M:ElOS.FileSelection_DX.GetFilemask(El.STRING@)"]

See Also

FileSelection_DX Class
ElOS Namespace


GetFilenames Method

[image]

4 of William Foster's Class Libraries
FileSelection_DX..::..GetFilenames Method
FileSelection_DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelection_DX.GetFilenames(El.Array{El.Filename}@)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void GetFilenames(
    out Array<Filename> Filenames
)
Visual Basic
Public Sub GetFilenames ( _
    <OutAttribute> ByRef Filenames As Array(Of Filename) _
)
Visual C++
public:
void GetFilenames(
    [OutAttribute] Array<Filename^>^% Filenames
)

Parameters

Filenames
Type: Array<(Of <(<'Filename>)>)>%

[Missing <param name="Filenames"/> documentation for "M:ElOS.FileSelection_DX.GetFilenames(El.Array{El.Filename}@)"]

See Also

FileSelection_DX Class
ElOS Namespace


GetFilesystemEntries Method

[image]

4 of William Foster's Class Libraries
FileSelection_DX..::..GetFilesystemEntries Method
FileSelection_DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelection_DX.GetFilesystemEntries(El.Array{ElOS.FilesystemEntry})"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void GetFilesystemEntries(
    Array<FilesystemEntry> Files
)
Visual Basic
Public Sub GetFilesystemEntries ( _
    Files As Array(Of FilesystemEntry) _
)
Visual C++
public:
void GetFilesystemEntries(
    Array<FilesystemEntry^>^ Files
)

Parameters

Files
Type: Array<(Of <(<' FilesystemEntry >)>)>

[Missing <param name="Files"/> documentation for "M:ElOS.FileSelection_DX.GetFilesystemEntries(El.Array{ElOS.FilesystemEntry})"]

See Also

FileSelection_DX Class
ElOS Namespace


GetStartFolder Method

[image]

4 of William Foster's Class Libraries
FileSelection_DX..::..GetStartFolder Method
FileSelection_DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelection_DX.GetStartFolder(El.Filename@)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void GetStartFolder(
    out Filename StartFolder
)
Visual Basic
Public Sub GetStartFolder ( _
    <OutAttribute> ByRef StartFolder As Filename _
)
Visual C++
public:
void GetStartFolder(
    [OutAttribute] Filename^% StartFolder
)

Parameters

StartFolder
Type: Filename%

[Missing <param name="StartFolder"/> documentation for "M:ElOS.FileSelection_DX.GetStartFolder(El.Filename@)"]

See Also

FileSelection_DX Class
ElOS Namespace


SetFilemask Method

[image]

4 of William Foster's Class Libraries
FileSelection_DX..::..SetFilemask Method
FileSelection_DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelection_DX.SetFilemask(System.String)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void SetFilemask(
    string Mask
)
Visual Basic
Public Sub SetFilemask ( _
    Mask As String _
)
Visual C++
public:
void SetFilemask(
    String^ Mask
)

Parameters

Mask
Type: System..::..String

[Missing <param name="Mask"/> documentation for "M:ElOS.FileSelection_DX.SetFilemask(System.String)"]

See Also

FileSelection_DX Class
ElOS Namespace


SetFilesystemEntries Method

[image]

4 of William Foster's Class Libraries
FileSelection_DX..::..SetFilesystemEntries Method
FileSelection_DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelection_DX.SetFilesystemEntries(El.Array{ElOS.FilesystemEntry})"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void SetFilesystemEntries(
    Array<FilesystemEntry> Files
)
Visual Basic
Public Sub SetFilesystemEntries ( _
    Files As Array(Of FilesystemEntry) _
)
Visual C++
public:
void SetFilesystemEntries(
    Array<FilesystemEntry^>^ Files
)

Parameters

Files
Type: Array<(Of <(<' FilesystemEntry >)>)>

[Missing <param name="Files"/> documentation for "M:ElOS.FileSelection_DX.SetFilesystemEntries(El.Array{ElOS.FilesystemEntry})"]

See Also

FileSelection_DX Class
ElOS Namespace


SetStartFolder Method

[image]

4 of William Foster's Class Libraries
FileSelection_DX..::..SetStartFolder Method
FileSelection_DX Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelection_DX.SetStartFolder(El.Filename)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void SetStartFolder(
    Filename StartFolder
)
Visual Basic
Public Sub SetStartFolder ( _
    StartFolder As Filename _
)
Visual C++
public:
void SetStartFolder(
    Filename^ StartFolder
)

Parameters

StartFolder
Type: Filename

[Missing <param name="StartFolder"/> documentation for "M:ElOS.FileSelection_DX.SetStartFolder(El.Filename)"]

See Also

FileSelection_DX Class
ElOS Namespace


FileSelector Class

[image]

4 of William Foster's Class Libraries
FileSelector Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElOS.FileSelector"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public class FileSelector
Visual Basic
Public Class FileSelector
Visual C++
public ref class FileSelector

Inheritance Hierarchy

System..::..Object
ElOS..::..FileSelector
ElOS..::..FolderSelector

See Also

FileSelector Members
ElOS Namespace


FileSelector Members

[image] [image]

4 of William Foster's Class Libraries
FileSelector Members
FileSelector Class Constructors Methods Fields See Also Send Feedback

The FileSelector type exposes the following members.

Constructors

 | Name | Description
Public method | FileSelector | Initializes a new instance of the FileSelector class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Release |
Public method | StartIteration()()()() |
Public method | StartIteration(Filename) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_b_first |
Protected field | m_files |
Protected field | m_fn_filespec |
Protected field | m_index |

See Also

FileSelector Class
ElOS Namespace


FileSelector Constructor

[image]

4 of William Foster's Class Libraries
FileSelector Constructor
FileSelector Class See Also Send Feedback
Initializes a new instance of the FileSelector class

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public FileSelector(
    Filename fn_filespec
)
Visual Basic
Public Sub New ( _
    fn_filespec As Filename _
)
Visual C++
public:
FileSelector(
    Filename^ fn_filespec
)

Parameters

fn_filespec
Type: Filename

[Missing <param name="fn_filespec"/> documentation for "M:ElOS.FileSelector.#ctor(El.Filename)"]

See Also

FileSelector Class
ElOS Namespace


FileSelector Fields

[image] [image]

4 of William Foster's Class Libraries
FileSelector Fields
FileSelector Class See Also Send Feedback

The FileSelector type exposes the following members.

Fields

 | Name | Description
Protected field | m_b_first |
Protected field | m_files |
Protected field | m_fn_filespec |
Protected field | m_index |

See Also

FileSelector Class
ElOS Namespace


m_b_first Field

[image]

4 of William Foster's Class Libraries
FileSelector..::..m_b_first Field
FileSelector Class See Also Send Feedback

[Missing <summary> documentation for "F:ElOS.FileSelector.m_b_first"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected bool m_b_first
Visual Basic
Protected m_b_first As Boolean
Visual C++
protected:
bool m_b_first

See Also

FileSelector Class
ElOS Namespace


m_files Field

[image]

4 of William Foster's Class Libraries
FileSelector..::..m_files Field
FileSelector Class See Also Send Feedback

[Missing <summary> documentation for "F:ElOS.FileSelector.m_files"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected string[] m_files
Visual Basic
Protected m_files As String()
Visual C++
protected:
array<String^>^ m_files

See Also

FileSelector Class
ElOS Namespace


m_fn_filespec Field

[image]

4 of William Foster's Class Libraries
FileSelector..::..m_fn_filespec Field
FileSelector Class See Also Send Feedback

[Missing <summary> documentation for "F:ElOS.FileSelector.m_fn_filespec"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected Filename m_fn_filespec
Visual Basic
Protected m_fn_filespec As Filename
Visual C++
protected:
Filename^ m_fn_filespec

See Also

FileSelector Class
ElOS Namespace


m_index Field

[image]

4 of William Foster's Class Libraries
FileSelector..::..m_index Field
FileSelector Class See Also Send Feedback

[Missing <summary> documentation for "F:ElOS.FileSelector.m_index"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected int m_index
Visual Basic
Protected m_index As Integer
Visual C++
protected:
int m_index

See Also

FileSelector Class
ElOS Namespace


FileSelector Methods

[image] [image]

4 of William Foster's Class Libraries
FileSelector Methods
FileSelector Class See Also Send Feedback

The FileSelector type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Release |
Public method | StartIteration()()()() |
Public method | StartIteration(Filename) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileSelector Class
ElOS Namespace


Finalize Method

[image]

4 of William Foster's Class Libraries
FileSelector..::..Finalize Method
FileSelector Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelector.Finalize"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

FileSelector Class
ElOS Namespace


GetNext Method

[image]

4 of William Foster's Class Libraries
FileSelector..::..GetNext Method
FileSelector Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelector.GetNext(El.Filename@)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public bool GetNext(
    out Filename fspec
)
Visual Basic
Public Function GetNext ( _
    <OutAttribute> ByRef fspec As Filename _
) As Boolean
Visual C++
public:
bool GetNext(
    [OutAttribute] Filename^% fspec
)

Parameters

fspec
Type: Filename%

[Missing <param name="fspec"/> documentation for "M:ElOS.FileSelector.GetNext(El.Filename@)"]

Return Value

[Missing <returns> documentation for "M:ElOS.FileSelector.GetNext(El.Filename@)"]

See Also

FileSelector Class
ElOS Namespace


Release Method

[image]

4 of William Foster's Class Libraries
FileSelector..::..Release Method
FileSelector Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelector.Release"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void Release()
Visual Basic
Public Sub Release
Visual C++
public:
void Release()

See Also

FileSelector Class
ElOS Namespace


StartIteration Method

[image] [image]

4 of William Foster's Class Libraries
FileSelector..::..StartIteration Method
FileSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartIteration()()()() |
Public method | StartIteration(Filename) |

See Also

FileSelector Class
FileSelector Members
ElOS Namespace


StartIteration Method

[image]

4 of William Foster's Class Libraries
FileSelector..::..StartIteration Method
FileSelector Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelector.StartIteration"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public bool StartIteration()
Visual Basic
Public Function StartIteration As Boolean
Visual C++
public:
bool StartIteration()

Return Value

[Missing <returns> documentation for "M:ElOS.FileSelector.StartIteration"]

See Also

FileSelector Class
StartIteration Overload
ElOS Namespace


StartIteration Method ()

[image]

4 of William Foster's Class Libraries
FileSelector..::..StartIteration Method ()
FileSelector Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FileSelector.StartIteration(El.Filename)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public bool StartIteration(
    Filename fn_filespec
)
Visual Basic
Public Function StartIteration ( _
    fn_filespec As Filename _
) As Boolean
Visual C++
public:
bool StartIteration(
    Filename^ fn_filespec
)

Parameters

fn_filespec
Type: Filename

[Missing <param name="fn_filespec"/> documentation for "M:ElOS.FileSelector.StartIteration(El.Filename)"]

Return Value

[Missing <returns> documentation for "M:ElOS.FileSelector.StartIteration(El.Filename)"]

See Also

FileSelector Class
StartIteration Overload
ElOS Namespace


FilesystemEntry Class

[image]

4 of William Foster's Class Libraries
FilesystemEntry Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElOS.FilesystemEntry"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public class FilesystemEntry : Filename
Visual Basic
Public Class FilesystemEntry _
    Inherits Filename
Visual C++
public ref class FilesystemEntry : public Filename

Inheritance Hierarchy

System..::..Object
STRING
Filename
ElOS..::..FilesystemEntry

See Also

FilesystemEntry Members
ElOS Namespace


FilesystemEntry Members

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry Members
FilesystemEntry Class Constructors Methods Fields Properties See Also Send Feedback

The FilesystemEntry type exposes the following members.

Constructors

 | Name | Description
Public method | FilesystemEntry()()()() | Initializes a new instance of the FilesystemEntry class
Public method | FilesystemEntry(STRING) | Initializes a new instance of the FilesystemEntry class
Public method | FilesystemEntry(STRING, Filename) | Initializes a new instance of the FilesystemEntry class

Methods

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | DeleteFilespec | (Inherited from Filename.)
Public method | Empty | (Inherited from STRING.)
Public method | EnsureTrailingSlash | (Inherited from Filename.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | (Inherited from Filename.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)
Public method | FindOneOf | (Inherited from STRING.)
Public method | FormatV | (Inherited from STRING.)
Public method | GetAsString | (Inherited from STRING.)
Public method | GetAt | (Inherited from STRING.)
Public method | GetBytePtr | (Inherited from STRING.)
Public method | GetComponents | (Inherited from Filename.)
Public method | GetEnumerator | (Inherited from STRING.)
Public method | GetExtension | (Inherited from Filename.)
Public method | GetFolder |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | (Inherited from STRING.)
Public method | GetLengthBytes | (Inherited from STRING.)
Public method | GetName | (Inherited from Filename.)
Public method | GetNameExtension | (Inherited from Filename.)
Public method | GetNextSubdir | (Inherited from Filename.)
Public method | GetPath | (Inherited from Filename.)
Public method | GetPtr | (Inherited from STRING.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAt | (Inherited from STRING.)
Public method | IsEmpty | (Inherited from STRING.)
Public method | Left | (Inherited from STRING.)
Public method | LeftEquals | (Inherited from STRING.)
Public method | LeftFrom | (Inherited from STRING.)
Public method | MatchesWildcard | (Inherited from Filename.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid | (Inherited from STRING.)
Public method | ParseLines | (Inherited from STRING.)
Public method | PrependPath | (Inherited from Filename.)
Public method | RemoveAt | (Inherited from STRING.)
Public method | RemoveQuotes | (Inherited from STRING.)
Public method | RemoveTrailingSlash | (Inherited from Filename.)
Public method | RemoveWhitespace | (Inherited from STRING.)
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)
Public method | ReverseFind | (Inherited from STRING.)
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)
Public method | RightFrom | (Inherited from STRING.)
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)
Public method | SetAt | (Inherited from STRING.)
Public method | SetComponents | (Inherited from Filename.)
Public method | SetExtention | (Inherited from Filename.)
Public method | SetLength | (Inherited from STRING.)
Public method | SetName | (Inherited from Filename.)
Public method | SetPath | (Inherited from Filename.)
Public method | SpanExcluding | (Inherited from STRING.)
Public method | Substitute | (Inherited from STRING.)
Public method | Terminate | (Inherited from STRING.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase | (Inherited from STRING.)
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)
Public method | UnLink | (Inherited from Filename.)
Public method | Update |

Fields

 | Name | Description
Protected field | m_cs | (Inherited from STRING.)

Properties

 | Name | Description
Public property | Item(UInt32) | (Inherited from STRING.)
Public property | Item(Int32) | (Inherited from STRING.)
Public property | Length | (Inherited from STRING.)

See Also

FilesystemEntry Class
ElOS Namespace


FilesystemEntry Constructor

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry Constructor
FilesystemEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FilesystemEntry()()()() | Initializes a new instance of the FilesystemEntry class
Public method | FilesystemEntry(STRING) | Initializes a new instance of the FilesystemEntry class
Public method | FilesystemEntry(STRING, Filename) | Initializes a new instance of the FilesystemEntry class

See Also

FilesystemEntry Class
FilesystemEntry Members
ElOS Namespace


FilesystemEntry Constructor

[image]

4 of William Foster's Class Libraries
FilesystemEntry Constructor
FilesystemEntry Class See Also Send Feedback
Initializes a new instance of the FilesystemEntry class

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public FilesystemEntry()
Visual Basic
Public Sub New
Visual C++
public:
FilesystemEntry()

See Also

FilesystemEntry Class
FilesystemEntry Overload
ElOS Namespace


FilesystemEntry Constructor ()

[image]

4 of William Foster's Class Libraries
FilesystemEntry Constructor ()
FilesystemEntry Class See Also Send Feedback
Initializes a new instance of the FilesystemEntry class

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public FilesystemEntry(
    STRING srcString
)
Visual Basic
Public Sub New ( _
    srcString As STRING _
)
Visual C++
public:
FilesystemEntry(
    STRING^ srcString
)

Parameters

srcString
Type: STRING

[Missing <param name="srcString"/> documentation for "M:ElOS.FilesystemEntry.#ctor(El.STRING)"]

See Also

FilesystemEntry Class
FilesystemEntry Overload
ElOS Namespace


FilesystemEntry Constructor (, )

[image]

4 of William Foster's Class Libraries
FilesystemEntry Constructor (, )
FilesystemEntry Class See Also Send Feedback
Initializes a new instance of the FilesystemEntry class

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public FilesystemEntry(
    STRING srcString,
    Filename csFolder
)
Visual Basic
Public Sub New ( _
    srcString As STRING, _
    csFolder As Filename _
)
Visual C++
public:
FilesystemEntry(
    STRING^ srcString,
    Filename^ csFolder
)

Parameters

srcString
Type: STRING

[Missing <param name="srcString"/> documentation for "M:ElOS.FilesystemEntry.#ctor(El.STRING,El.Filename)"]

csFolder
Type: Filename

[Missing <param name="csFolder"/> documentation for "M:ElOS.FilesystemEntry.#ctor(El.STRING,El.Filename)"]

See Also

FilesystemEntry Class
FilesystemEntry Overload
ElOS Namespace


FilesystemEntry Fields

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry Fields
FilesystemEntry Class See Also Send Feedback

The FilesystemEntry type exposes the following members.

Fields

 | Name | Description
Protected field | m_cs | (Inherited from STRING.)

See Also

FilesystemEntry Class
ElOS Namespace


FilesystemEntry Methods

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry Methods
FilesystemEntry Class See Also Send Feedback

The FilesystemEntry type exposes the following members.

Methods

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | DeleteFilespec | (Inherited from Filename.)
Public method | Empty | (Inherited from STRING.)
Public method | EnsureTrailingSlash | (Inherited from Filename.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | (Inherited from Filename.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)
Public method | FindOneOf | (Inherited from STRING.)
Public method | FormatV | (Inherited from STRING.)
Public method | GetAsString | (Inherited from STRING.)
Public method | GetAt | (Inherited from STRING.)
Public method | GetBytePtr | (Inherited from STRING.)
Public method | GetComponents | (Inherited from Filename.)
Public method | GetEnumerator | (Inherited from STRING.)
Public method | GetExtension | (Inherited from Filename.)
Public method | GetFolder |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | (Inherited from STRING.)
Public method | GetLengthBytes | (Inherited from STRING.)
Public method | GetName | (Inherited from Filename.)
Public method | GetNameExtension | (Inherited from Filename.)
Public method | GetNextSubdir | (Inherited from Filename.)
Public method | GetPath | (Inherited from Filename.)
Public method | GetPtr | (Inherited from STRING.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAt | (Inherited from STRING.)
Public method | IsEmpty | (Inherited from STRING.)
Public method | Left | (Inherited from STRING.)
Public method | LeftEquals | (Inherited from STRING.)
Public method | LeftFrom | (Inherited from STRING.)
Public method | MatchesWildcard | (Inherited from Filename.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid | (Inherited from STRING.)
Public method | ParseLines | (Inherited from STRING.)
Public method | PrependPath | (Inherited from Filename.)
Public method | RemoveAt | (Inherited from STRING.)
Public method | RemoveQuotes | (Inherited from STRING.)
Public method | RemoveTrailingSlash | (Inherited from Filename.)
Public method | RemoveWhitespace | (Inherited from STRING.)
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)
Public method | ReverseFind | (Inherited from STRING.)
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)
Public method | RightFrom | (Inherited from STRING.)
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)
Public method | SetAt | (Inherited from STRING.)
Public method | SetComponents | (Inherited from Filename.)
Public method | SetExtention | (Inherited from Filename.)
Public method | SetLength | (Inherited from STRING.)
Public method | SetName | (Inherited from Filename.)
Public method | SetPath | (Inherited from Filename.)
Public method | SpanExcluding | (Inherited from STRING.)
Public method | Substitute | (Inherited from STRING.)
Public method | Terminate | (Inherited from STRING.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase | (Inherited from STRING.)
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)
Public method | UnLink | (Inherited from Filename.)
Public method | Update |

See Also

FilesystemEntry Class
ElOS Namespace


Append Method

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry..::..Append Method
FilesystemEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)

See Also

FilesystemEntry Class
FilesystemEntry Members
ElOS Namespace


Compare Method

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry..::..Compare Method
FilesystemEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)

See Also

FilesystemEntry Class
FilesystemEntry Members
ElOS Namespace


CompareNoCase Method

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry..::..CompareNoCase Method
FilesystemEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)

See Also

FilesystemEntry Class
FilesystemEntry Members
ElOS Namespace


Find Method

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry..::..Find Method
FilesystemEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)

See Also

FilesystemEntry Class
FilesystemEntry Members
ElOS Namespace


GetFolder Method

[image]

4 of William Foster's Class Libraries
FilesystemEntry..::..GetFolder Method
FilesystemEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FilesystemEntry.GetFolder"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public Filename GetFolder()
Visual Basic
Public Function GetFolder As Filename
Visual C++
public:
Filename^ GetFolder()

Return Value

[Missing <returns> documentation for "M:ElOS.FilesystemEntry.GetFolder"]

See Also

FilesystemEntry Class
ElOS Namespace


Replace Method

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry..::..Replace Method
FilesystemEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)

See Also

FilesystemEntry Class
FilesystemEntry Members
ElOS Namespace


Right Method

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry..::..Right Method
FilesystemEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)

See Also

FilesystemEntry Class
FilesystemEntry Members
ElOS Namespace


Set Method

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry..::..Set Method
FilesystemEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)

See Also

FilesystemEntry Class
FilesystemEntry Members
ElOS Namespace


Trim Method

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry..::..Trim Method
FilesystemEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)

See Also

FilesystemEntry Class
FilesystemEntry Members
ElOS Namespace


TrimLeft Method

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry..::..TrimLeft Method
FilesystemEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)

See Also

FilesystemEntry Class
FilesystemEntry Members
ElOS Namespace


TrimRight Method

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry..::..TrimRight Method
FilesystemEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

See Also

FilesystemEntry Class
FilesystemEntry Members
ElOS Namespace


Update Method

[image]

4 of William Foster's Class Libraries
FilesystemEntry..::..Update Method
FilesystemEntry Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FilesystemEntry.Update"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public bool Update()
Visual Basic
Public Function Update As Boolean
Visual C++
public:
bool Update()

Return Value

[Missing <returns> documentation for "M:ElOS.FilesystemEntry.Update"]

See Also

FilesystemEntry Class
ElOS Namespace


FilesystemEntry Properties

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry Properties
FilesystemEntry Class See Also Send Feedback

The FilesystemEntry type exposes the following members.

Properties

 | Name | Description
Public property | Item(UInt32) | (Inherited from STRING.)
Public property | Item(Int32) | (Inherited from STRING.)
Public property | Length | (Inherited from STRING.)

See Also

FilesystemEntry Class
ElOS Namespace


Item Property

[image] [image]

4 of William Foster's Class Libraries
FilesystemEntry..::..Item Property
FilesystemEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item(UInt32) | (Inherited from STRING.)
Public property | Item(Int32) | (Inherited from STRING.)

See Also

FilesystemEntry Class
FilesystemEntry Members
ElOS Namespace


FolderOperation Class

[image]

4 of William Foster's Class Libraries
FolderOperation Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElOS.FolderOperation"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public class FolderOperation
Visual Basic
Public Class FolderOperation
Visual C++
public ref class FolderOperation

Inheritance Hierarchy

System..::..Object
ElOS..::..FolderOperation

See Also

FolderOperation Members
ElOS Namespace


FolderOperation Members

[image] [image]

4 of William Foster's Class Libraries
FolderOperation Members
FolderOperation Class Constructors Methods See Also Send Feedback

The FolderOperation type exposes the following members.

Constructors

 | Name | Description
Public method | FolderOperation(Boolean) | Initializes a new instance of the FolderOperation class
Public method | FolderOperation(Filename, Boolean) | Initializes a new instance of the FolderOperation class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Operate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FolderOperation Class
ElOS Namespace


FolderOperation Constructor

[image] [image]

4 of William Foster's Class Libraries
FolderOperation Constructor
FolderOperation Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FolderOperation(Boolean) | Initializes a new instance of the FolderOperation class
Public method | FolderOperation(Filename, Boolean) | Initializes a new instance of the FolderOperation class

See Also

FolderOperation Class
FolderOperation Members
ElOS Namespace


FolderOperation Constructor (Boolean)

[image]

4 of William Foster's Class Libraries
FolderOperation Constructor (Boolean)
FolderOperation Class See Also Send Feedback
Initializes a new instance of the FolderOperation class

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public FolderOperation(
    bool b_recurse_subfolders
)
Visual Basic
Public Sub New ( _
    b_recurse_subfolders As Boolean _
)
Visual C++
public:
FolderOperation(
    bool b_recurse_subfolders
)

Parameters

b_recurse_subfolders
Type: System..::..Boolean

[Missing <param name="b_recurse_subfolders"/> documentation for "M:ElOS.FolderOperation.#ctor(System.Boolean)"]

See Also

FolderOperation Class
FolderOperation Overload
ElOS Namespace


FolderOperation Constructor (, Boolean)

[image]

4 of William Foster's Class Libraries
FolderOperation Constructor (, Boolean)
FolderOperation Class See Also Send Feedback
Initializes a new instance of the FolderOperation class

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public FolderOperation(
    Filename cs_TargetFolder,
    bool b_recurse_subfolders
)
Visual Basic
Public Sub New ( _
    cs_TargetFolder As Filename, _
    b_recurse_subfolders As Boolean _
)
Visual C++
public:
FolderOperation(
    Filename^ cs_TargetFolder,
    bool b_recurse_subfolders
)

Parameters

cs_TargetFolder
Type: Filename

[Missing <param name="cs_TargetFolder"/> documentation for "M:ElOS.FolderOperation.#ctor(El.Filename,System.Boolean)"]

b_recurse_subfolders
Type: System..::..Boolean

[Missing <param name="b_recurse_subfolders"/> documentation for "M:ElOS.FolderOperation.#ctor(El.Filename,System.Boolean)"]

See Also

FolderOperation Class
FolderOperation Overload
ElOS Namespace


FolderOperation Methods

[image] [image]

4 of William Foster's Class Libraries
FolderOperation Methods
FolderOperation Class See Also Send Feedback

The FolderOperation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Operate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FolderOperation Class
ElOS Namespace


Operate Method

[image]

4 of William Foster's Class Libraries
FolderOperation..::..Operate Method
FolderOperation Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FolderOperation.Operate(ElOS.FileOperationClass)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public int Operate(
    FileOperationClass opclass
)
Visual Basic
Public Function Operate ( _
    opclass As FileOperationClass _
) As Integer
Visual C++
public:
int Operate(
    FileOperationClass^ opclass
)

Parameters

opclass
Type: ElOS..::..FileOperationClass

[Missing <param name="opclass"/> documentation for "M:ElOS.FolderOperation.Operate(ElOS.FileOperationClass)"]

Return Value

[Missing <returns> documentation for "M:ElOS.FolderOperation.Operate(ElOS.FileOperationClass)"]

See Also

FolderOperation Class
ElOS Namespace


FolderSelector Class

[image]

4 of William Foster's Class Libraries
FolderSelector Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElOS.FolderSelector"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public class FolderSelector : FileSelector
Visual Basic
Public Class FolderSelector _
    Inherits FileSelector
Visual C++
public ref class FolderSelector : public FileSelector

Inheritance Hierarchy

System..::..Object
ElOS..::..FileSelector
ElOS..::..FolderSelector

See Also

FolderSelector Members
ElOS Namespace


FolderSelector Members

[image] [image]

4 of William Foster's Class Libraries
FolderSelector Members
FolderSelector Class Constructors Methods Fields See Also Send Feedback

The FolderSelector type exposes the following members.

Constructors

 | Name | Description
Public method | FolderSelector | Initializes a new instance of the FolderSelector class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from FileSelector.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Release | (Inherited from FileSelector.)
Public method | StartIteration()()()() | (Inherited from FileSelector.)
Public method | StartIteration(Filename) | (Inherited from FileSelector.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_b_first | (Inherited from FileSelector.)
Protected field | m_files | (Inherited from FileSelector.)
Protected field | m_fn_filespec | (Inherited from FileSelector.)
Protected field | m_index | (Inherited from FileSelector.)

See Also

FolderSelector Class
ElOS Namespace


FolderSelector Constructor

[image]

4 of William Foster's Class Libraries
FolderSelector Constructor
FolderSelector Class See Also Send Feedback
Initializes a new instance of the FolderSelector class

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public FolderSelector(
    Filename fn_filespec
)
Visual Basic
Public Sub New ( _
    fn_filespec As Filename _
)
Visual C++
public:
FolderSelector(
    Filename^ fn_filespec
)

Parameters

fn_filespec
Type: Filename

[Missing <param name="fn_filespec"/> documentation for "M:ElOS.FolderSelector.#ctor(El.Filename)"]

See Also

FolderSelector Class
ElOS Namespace


FolderSelector Fields

[image] [image]

4 of William Foster's Class Libraries
FolderSelector Fields
FolderSelector Class See Also Send Feedback

The FolderSelector type exposes the following members.

Fields

 | Name | Description
Protected field | m_b_first | (Inherited from FileSelector.)
Protected field | m_files | (Inherited from FileSelector.)
Protected field | m_fn_filespec | (Inherited from FileSelector.)
Protected field | m_index | (Inherited from FileSelector.)

See Also

FolderSelector Class
ElOS Namespace


FolderSelector Methods

[image] [image]

4 of William Foster's Class Libraries
FolderSelector Methods
FolderSelector Class See Also Send Feedback

The FolderSelector type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from FileSelector.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Release | (Inherited from FileSelector.)
Public method | StartIteration()()()() | (Inherited from FileSelector.)
Public method | StartIteration(Filename) | (Inherited from FileSelector.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FolderSelector Class
ElOS Namespace


GetNext Method

[image]

4 of William Foster's Class Libraries
FolderSelector..::..GetNext Method
FolderSelector Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.FolderSelector.GetNext(El.Filename@)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public virtual bool GetNext(
    out Filename fspec
)
Visual Basic
Public Overridable Function GetNext ( _
    <OutAttribute> ByRef fspec As Filename _
) As Boolean
Visual C++
public:
virtual bool GetNext(
    [OutAttribute] Filename^% fspec
)

Parameters

fspec
Type: Filename%

[Missing <param name="fspec"/> documentation for "M:ElOS.FolderSelector.GetNext(El.Filename@)"]

Return Value

[Missing <returns> documentation for "M:ElOS.FolderSelector.GetNext(El.Filename@)"]

See Also

FolderSelector Class
ElOS Namespace


StartIteration Method

[image] [image]

4 of William Foster's Class Libraries
FolderSelector..::..StartIteration Method
FolderSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartIteration()()()() | (Inherited from FileSelector.)
Public method | StartIteration(Filename) | (Inherited from FileSelector.)

See Also

FolderSelector Class
FolderSelector Members
ElOS Namespace


OS_Static Class

[image]

4 of William Foster's Class Libraries
OS_Static Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElOS.OS_Static"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static class OS_Static
Visual Basic
Public NotInheritable Class OS_Static
Visual C++
public ref class OS_Static abstract sealed

Inheritance Hierarchy

System..::..Object
ElOS..::..OS_Static

See Also

OS_Static Members
ElOS Namespace


OS_Static Members

[image] [image]

4 of William Foster's Class Libraries
OS_Static Members
OS_Static Class Methods See Also Send Feedback

The OS_Static type exposes the following members.

Methods

Name | Description
CreateDirectory |
EL_TRACE |
ForceDirectory |
GetCreditsString |
GetCurrentPath |
GetFileAttributes |
MakePathAbsolute |
PExec |
SetCurrentPath |
SysCommand |

See Also

OS_Static Class
ElOS Namespace


OS_Static Methods

[image] [image]

4 of William Foster's Class Libraries
OS_Static Methods
OS_Static Class See Also Send Feedback

The OS_Static type exposes the following members.

Methods

Name | Description
CreateDirectory |
EL_TRACE |
ForceDirectory |
GetCreditsString |
GetCurrentPath |
GetFileAttributes |
MakePathAbsolute |
PExec |
SetCurrentPath |
SysCommand |

See Also

OS_Static Class
ElOS Namespace


CreateDirectory Method

[image]

4 of William Foster's Class Libraries
OS_Static..::..CreateDirectory Method
OS_Static Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.OS_Static.CreateDirectory(El.Filename)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static bool CreateDirectory(
    Filename dir
)
Visual Basic
Public Shared Function CreateDirectory ( _
    dir As Filename _
) As Boolean
Visual C++
public:
static bool CreateDirectory(
    Filename^ dir
)

Parameters

dir
Type: Filename

[Missing <param name="dir"/> documentation for "M:ElOS.OS_Static.CreateDirectory(El.Filename)"]

Return Value

[Missing <returns> documentation for "M:ElOS.OS_Static.CreateDirectory(El.Filename)"]

See Also

OS_Static Class
ElOS Namespace


EL_TRACE Method

[image]

4 of William Foster's Class Libraries
OS_Static..::..EL_TRACE Method
OS_Static Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.OS_Static.EL_TRACE(System.String,System.Object[])"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static void EL_TRACE(
    string lpszFormat,
    params Object[] argList
)
Visual Basic
Public Shared Sub EL_TRACE ( _
    lpszFormat As String, _
    ParamArray argList As Object() _
)
Visual C++
public:
static void EL_TRACE(
    String^ lpszFormat,
    ... array<Object^>^ argList
)

Parameters

lpszFormat
Type: System..::..String

[Missing <param name="lpszFormat"/> documentation for "M:ElOS.OS_Static.EL_TRACE(System.String,System.Object[])"]

argList
Type: array< System..::..Object >[]()[][]

[Missing <param name="argList"/> documentation for "M:ElOS.OS_Static.EL_TRACE(System.String,System.Object[])"]

See Also

OS_Static Class
ElOS Namespace


ForceDirectory Method

[image]

4 of William Foster's Class Libraries
OS_Static..::..ForceDirectory Method
OS_Static Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.OS_Static.ForceDirectory(El.Filename)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static bool ForceDirectory(
    Filename force
)
Visual Basic
Public Shared Function ForceDirectory ( _
    force As Filename _
) As Boolean
Visual C++
public:
static bool ForceDirectory(
    Filename^ force
)

Parameters

force
Type: Filename

[Missing <param name="force"/> documentation for "M:ElOS.OS_Static.ForceDirectory(El.Filename)"]

Return Value

[Missing <returns> documentation for "M:ElOS.OS_Static.ForceDirectory(El.Filename)"]

See Also

OS_Static Class
ElOS Namespace


GetCreditsString Method

[image]

4 of William Foster's Class Libraries
OS_Static..::..GetCreditsString Method
OS_Static Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.OS_Static.GetCreditsString(El.STRING@)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static void GetCreditsString(
    out STRING sCredits
)
Visual Basic
Public Shared Sub GetCreditsString ( _
    <OutAttribute> ByRef sCredits As STRING _
)
Visual C++
public:
static void GetCreditsString(
    [OutAttribute] STRING^% sCredits
)

Parameters

sCredits
Type: STRING%

[Missing <param name="sCredits"/> documentation for "M:ElOS.OS_Static.GetCreditsString(El.STRING@)"]

See Also

OS_Static Class
ElOS Namespace


GetCurrentPath Method

[image]

4 of William Foster's Class Libraries
OS_Static..::..GetCurrentPath Method
OS_Static Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.OS_Static.GetCurrentPath(El.Filename@)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static bool GetCurrentPath(
    out Filename getcwd
)
Visual Basic
Public Shared Function GetCurrentPath ( _
    <OutAttribute> ByRef getcwd As Filename _
) As Boolean
Visual C++
public:
static bool GetCurrentPath(
    [OutAttribute] Filename^% getcwd
)

Parameters

getcwd
Type: Filename%

[Missing <param name="getcwd"/> documentation for "M:ElOS.OS_Static.GetCurrentPath(El.Filename@)"]

Return Value

[Missing <returns> documentation for "M:ElOS.OS_Static.GetCurrentPath(El.Filename@)"]

See Also

OS_Static Class
ElOS Namespace


GetFileAttributes Method

[image]

4 of William Foster's Class Libraries
OS_Static..::..GetFileAttributes Method
OS_Static Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.OS_Static.GetFileAttributes(El.Filename,System.IO.FileAttributes@)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static bool GetFileAttributes(
    Filename fName,
    out FileAttributes attributes
)
Visual Basic
Public Shared Function GetFileAttributes ( _
    fName As Filename, _
    <OutAttribute> ByRef attributes As FileAttributes _
) As Boolean
Visual C++
public:
static bool GetFileAttributes(
    Filename^ fName,
    [OutAttribute] FileAttributes% attributes
)

Parameters

fName
Type: Filename

[Missing <param name="fName"/> documentation for "M:ElOS.OS_Static.GetFileAttributes(El.Filename,System.IO.FileAttributes@)"]

attributes
Type: System.IO..::..FileAttributes %

[Missing <param name="attributes"/> documentation for "M:ElOS.OS_Static.GetFileAttributes(El.Filename,System.IO.FileAttributes@)"]

Return Value

[Missing <returns> documentation for "M:ElOS.OS_Static.GetFileAttributes(El.Filename,System.IO.FileAttributes@)"]

See Also

OS_Static Class
ElOS Namespace


MakePathAbsolute Method

[image]

4 of William Foster's Class Libraries
OS_Static..::..MakePathAbsolute Method
OS_Static Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.OS_Static.MakePathAbsolute(El.Filename)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static void MakePathAbsolute(
    Filename foldername
)
Visual Basic
Public Shared Sub MakePathAbsolute ( _
    foldername As Filename _
)
Visual C++
public:
static void MakePathAbsolute(
    Filename^ foldername
)

Parameters

foldername
Type: Filename

[Missing <param name="foldername"/> documentation for "M:ElOS.OS_Static.MakePathAbsolute(El.Filename)"]

See Also

OS_Static Class
ElOS Namespace


PExec Method

[image]

4 of William Foster's Class Libraries
OS_Static..::..PExec Method
OS_Static Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.OS_Static.PExec(System.String,System.String@)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static bool PExec(
    string cmd,
    out string strOutput
)
Visual Basic
Public Shared Function PExec ( _
    cmd As String, _
    <OutAttribute> ByRef strOutput As String _
) As Boolean
Visual C++
public:
static bool PExec(
    String^ cmd,
    [OutAttribute] String^% strOutput
)

Parameters

cmd
Type: System..::..String

[Missing <param name="cmd"/> documentation for "M:ElOS.OS_Static.PExec(System.String,System.String@)"]

strOutput
Type: System..::..String %

[Missing <param name="strOutput"/> documentation for "M:ElOS.OS_Static.PExec(System.String,System.String@)"]

Return Value

[Missing <returns> documentation for "M:ElOS.OS_Static.PExec(System.String,System.String@)"]

See Also

OS_Static Class
ElOS Namespace


SetCurrentPath Method

[image]

4 of William Foster's Class Libraries
OS_Static..::..SetCurrentPath Method
OS_Static Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.OS_Static.SetCurrentPath(El.Filename)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static bool SetCurrentPath(
    Filename cwd
)
Visual Basic
Public Shared Function SetCurrentPath ( _
    cwd As Filename _
) As Boolean
Visual C++
public:
static bool SetCurrentPath(
    Filename^ cwd
)

Parameters

cwd
Type: Filename

[Missing <param name="cwd"/> documentation for "M:ElOS.OS_Static.SetCurrentPath(El.Filename)"]

Return Value

[Missing <returns> documentation for "M:ElOS.OS_Static.SetCurrentPath(El.Filename)"]

See Also

OS_Static Class
ElOS Namespace


SysCommand Method

[image]

4 of William Foster's Class Libraries
OS_Static..::..SysCommand Method
OS_Static Class See Also Send Feedback

[Missing <summary> documentation for "M:ElOS.OS_Static.SysCommand(El.STRING)"]

Namespace: ElOS
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static bool SysCommand(
    STRING sCommand
)
Visual Basic
Public Shared Function SysCommand ( _
    sCommand As STRING _
) As Boolean
Visual C++
public:
static bool SysCommand(
    STRING^ sCommand
)

Parameters

sCommand
Type: STRING

[Missing <param name="sCommand"/> documentation for "M:ElOS.OS_Static.SysCommand(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElOS.OS_Static.SysCommand(El.STRING)"]

See Also

OS_Static Class
ElOS Namespace


ElScript Namespace

[image]

4 of William Foster's Class Libraries
ElScript Namespace
Send Feedback

[Missing <summary> documentation for "N:ElScript"]

Classes

 | Class | Description
Public class | C_Define |
Public class | CEquat |
Public class | CPlusPlus_Argument |
Public class | CPlusPlus_ClassDefinition |
Public class | CPlusPlus_FunctionDefinition |
Public class | CPlusPlus_FunctionName |
Public class | CPlusPlus_VariableDefinition |
Public class | ParseIncludes |
Public class | Phrase |
Public class | Program |
Public class | Script |
Public class | Script_C |
Public class | Script_CPlusPlus |
Public class | Script_Program |
Public class | Script_Source |
Public class | Script_Text |
Public class | Script_XML |
Public class | Variable |

Interfaces

 | Interface | Description
Public interface | IEquat_User |
Public interface | IPhrase_Reader |

Enumerations

 | Enumeration | Description
Public enumeration | CEquat..::..EType |
Public enumeration | E_CPLUSPLUS_SCOPE |
Public enumeration | Script..::..SYNTAX_ERROR_TYPE |
Protected enumeration | Script_C..::..E_C_IFDEF |
Public enumeration | Script_XML..::..EBFCScript_XMLMark |
Public enumeration | Variable..::..EVariableType |


C_Define Class

[image]

4 of William Foster's Class Libraries
C_Define Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.C_Define"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class C_Define
Visual Basic
Public Class C_Define
Visual C++
public ref class C_Define

Inheritance Hierarchy

System..::..Object
ElScript..::..C_Define

See Also

C_Define Members
ElScript Namespace


C_Define Members

[image] [image]

4 of William Foster's Class Libraries
C_Define Members
C_Define Class Constructors Methods Fields See Also Send Feedback

The C_Define type exposes the following members.

Constructors

 | Name | Description
Public method | C_Define | Initializes a new instance of the C_Define class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetArgumentString |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_cs_args |
Public field | m_cs_defname |
Public field | m_cs_substitute |

See Also

C_Define Class
ElScript Namespace


C_Define Constructor

[image]

4 of William Foster's Class Libraries
C_Define Constructor
C_Define Class See Also Send Feedback
Initializes a new instance of the C_Define class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public C_Define(
    STRING tag,
    STRING value
)
Visual Basic
Public Sub New ( _
    tag As STRING, _
    value As STRING _
)
Visual C++
public:
C_Define(
    STRING^ tag,
    STRING^ value
)

Parameters

tag
Type: STRING

[Missing <param name="tag"/> documentation for "M:ElScript.C_Define.#ctor(El.STRING,El.STRING)"]

value
Type: STRING

[Missing <param name="value"/> documentation for "M:ElScript.C_Define.#ctor(El.STRING,El.STRING)"]

See Also

C_Define Class
ElScript Namespace


C_Define Fields

[image] [image]

4 of William Foster's Class Libraries
C_Define Fields
C_Define Class See Also Send Feedback

The C_Define type exposes the following members.

Fields

 | Name | Description
Public field | m_cs_args |
Public field | m_cs_defname |
Public field | m_cs_substitute |

See Also

C_Define Class
ElScript Namespace


m_cs_args Field

[image]

4 of William Foster's Class Libraries
C_Define..::..m_cs_args Field
C_Define Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.C_Define.m_cs_args"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING m_cs_args
Visual Basic
Public m_cs_args As STRING
Visual C++
public:
STRING^ m_cs_args

See Also

C_Define Class
ElScript Namespace


m_cs_defname Field

[image]

4 of William Foster's Class Libraries
C_Define..::..m_cs_defname Field
C_Define Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.C_Define.m_cs_defname"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING m_cs_defname
Visual Basic
Public m_cs_defname As STRING
Visual C++
public:
STRING^ m_cs_defname

See Also

C_Define Class
ElScript Namespace


m_cs_substitute Field

[image]

4 of William Foster's Class Libraries
C_Define..::..m_cs_substitute Field
C_Define Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.C_Define.m_cs_substitute"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING m_cs_substitute
Visual Basic
Public m_cs_substitute As STRING
Visual C++
public:
STRING^ m_cs_substitute

See Also

C_Define Class
ElScript Namespace


C_Define Methods

[image] [image]

4 of William Foster's Class Libraries
C_Define Methods
C_Define Class See Also Send Feedback

The C_Define type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetArgumentString |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C_Define Class
ElScript Namespace


SetArgumentString Method

[image]

4 of William Foster's Class Libraries
C_Define..::..SetArgumentString Method
C_Define Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.C_Define.SetArgumentString(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetArgumentString(
    STRING cs_args
)
Visual Basic
Public Sub SetArgumentString ( _
    cs_args As STRING _
)
Visual C++
public:
void SetArgumentString(
    STRING^ cs_args
)

Parameters

cs_args
Type: STRING

[Missing <param name="cs_args"/> documentation for "M:ElScript.C_Define.SetArgumentString(El.STRING)"]

See Also

C_Define Class
ElScript Namespace


CEquat Class

[image]

4 of William Foster's Class Libraries
CEquat Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.CEquat"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CEquat
Visual Basic
Public Class CEquat
Visual C++
public ref class CEquat

Inheritance Hierarchy

System..::..Object
ElScript..::..CEquat

See Also

CEquat Members
ElScript Namespace


CEquat Members

[image] [image]

4 of William Foster's Class Libraries
CEquat Members
CEquat Class Constructors Methods See Also Send Feedback

The CEquat type exposes the following members.

Constructors

 | Name | Description
Public method | CEquat(IEquat_User) | Initializes a new instance of the CEquat class
Public method | CEquat(IEquat_User, STRING) | Initializes a new instance of the CEquat class

Methods

 | Name | Description
Public method | Calculate |
 | constant |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | equat |
Public method | equat_legalized |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | findclose |
Protected method | findopen |
Protected method | gaval |
Public method | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | is_digit |
Public method | Legalize_Equation |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | myatof |
Protected method | myfunct |
Protected method | oper |
Protected method | power |
Public method | Set |
Public method | Set_Legalized |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | type |
Protected method | varval |

See Also

CEquat Class
ElScript Namespace


CEquat Constructor

[image] [image]

4 of William Foster's Class Libraries
CEquat Constructor
CEquat Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CEquat(IEquat_User) | Initializes a new instance of the CEquat class
Public method | CEquat(IEquat_User, STRING) | Initializes a new instance of the CEquat class

See Also

CEquat Class
CEquat Members
ElScript Namespace


CEquat Constructor (IEquat_User)

[image]

4 of William Foster's Class Libraries
CEquat Constructor (IEquat_User)
CEquat Class See Also Send Feedback
Initializes a new instance of the CEquat class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CEquat(
    IEquat_User eqnUser
)
Visual Basic
Public Sub New ( _
    eqnUser As IEquat_User _
)
Visual C++
public:
CEquat(
    IEquat_User^ eqnUser
)

Parameters

eqnUser
Type: ElScript..::..IEquat_User

[Missing <param name="eqnUser"/> documentation for "M:ElScript.CEquat.#ctor(ElScript.IEquat_User)"]

See Also

CEquat Class
CEquat Overload
ElScript Namespace


CEquat Constructor (IEquat_User, )

[image]

4 of William Foster's Class Libraries
CEquat Constructor (IEquat_User, )
CEquat Class See Also Send Feedback
Initializes a new instance of the CEquat class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CEquat(
    IEquat_User eqnUser,
    STRING str_equation
)
Visual Basic
Public Sub New ( _
    eqnUser As IEquat_User, _
    str_equation As STRING _
)
Visual C++
public:
CEquat(
    IEquat_User^ eqnUser,
    STRING^ str_equation
)

Parameters

eqnUser
Type: ElScript..::..IEquat_User

[Missing <param name="eqnUser"/> documentation for "M:ElScript.CEquat.#ctor(ElScript.IEquat_User,El.STRING)"]

str_equation
Type: STRING

[Missing <param name="str_equation"/> documentation for "M:ElScript.CEquat.#ctor(ElScript.IEquat_User,El.STRING)"]

See Also

CEquat Class
CEquat Overload
ElScript Namespace


CEquat Methods

[image] [image]

4 of William Foster's Class Libraries
CEquat Methods
CEquat Class See Also Send Feedback

The CEquat type exposes the following members.

Methods

 | Name | Description
Public method | Calculate |
 | constant |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | equat |
Public method | equat_legalized |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | findclose |
Protected method | findopen |
Protected method | gaval |
Public method | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | is_digit |
Public method | Legalize_Equation |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | myatof |
Protected method | myfunct |
Protected method | oper |
Protected method | power |
Public method | Set |
Public method | Set_Legalized |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | type |
Protected method | varval |

See Also

CEquat Class
ElScript Namespace


Calculate Method

[image]

4 of William Foster's Class Libraries
CEquat..::..Calculate Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.Calculate"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Calculate()
Visual Basic
Public Function Calculate As Double
Visual C++
public:
double Calculate()

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.Calculate"]

See Also

CEquat Class
ElScript Namespace


constant Method

[image]

4 of William Foster's Class Libraries
CEquat..::..constant Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.constant(System.Char)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double constant(
    char c
)
Visual Basic
Public Shared Function constant ( _
    c As Char _
) As Double
Visual C++
public:
static double constant(
    wchar_t c
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:ElScript.CEquat.constant(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.constant(System.Char)"]

See Also

CEquat Class
ElScript Namespace


equat Method

[image]

4 of William Foster's Class Libraries
CEquat..::..equat Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.equat(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double equat(
    STRING cs_eqn
)
Visual Basic
Public Function equat ( _
    cs_eqn As STRING _
) As Double
Visual C++
public:
double equat(
    STRING^ cs_eqn
)

Parameters

cs_eqn
Type: STRING

[Missing <param name="cs_eqn"/> documentation for "M:ElScript.CEquat.equat(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.equat(El.STRING)"]

See Also

CEquat Class
ElScript Namespace


equat_legalized Method

[image]

4 of William Foster's Class Libraries
CEquat..::..equat_legalized Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.equat_legalized(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double equat_legalized(
    STRING cs_eqn
)
Visual Basic
Public Function equat_legalized ( _
    cs_eqn As STRING _
) As Double
Visual C++
public:
double equat_legalized(
    STRING^ cs_eqn
)

Parameters

cs_eqn
Type: STRING

[Missing <param name="cs_eqn"/> documentation for "M:ElScript.CEquat.equat_legalized(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.equat_legalized(El.STRING)"]

See Also

CEquat Class
ElScript Namespace


findclose Method

[image]

4 of William Foster's Class Libraries
CEquat..::..findclose Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.findclose(System.Char[],System.Int32)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int findclose(
    char[] e,
    int c
)
Visual Basic
Protected Function findclose ( _
    e As Char(), _
    c As Integer _
) As Integer
Visual C++
protected:
int findclose(
    array<wchar_t>^ e,
    int c
)

Parameters

e
Type: array< System..::..Char >[]()[][]

[Missing <param name="e"/> documentation for "M:ElScript.CEquat.findclose(System.Char[],System.Int32)"]

c
Type: System..::..Int32

[Missing <param name="c"/> documentation for "M:ElScript.CEquat.findclose(System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.findclose(System.Char[],System.Int32)"]

See Also

CEquat Class
ElScript Namespace


findopen Method

[image]

4 of William Foster's Class Libraries
CEquat..::..findopen Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.findopen(System.Char[],System.Int32)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int findopen(
    char[] e,
    int c
)
Visual Basic
Protected Function findopen ( _
    e As Char(), _
    c As Integer _
) As Integer
Visual C++
protected:
int findopen(
    array<wchar_t>^ e,
    int c
)

Parameters

e
Type: array< System..::..Char >[]()[][]

[Missing <param name="e"/> documentation for "M:ElScript.CEquat.findopen(System.Char[],System.Int32)"]

c
Type: System..::..Int32

[Missing <param name="c"/> documentation for "M:ElScript.CEquat.findopen(System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.findopen(System.Char[],System.Int32)"]

See Also

CEquat Class
ElScript Namespace


gaval Method

[image]

4 of William Foster's Class Libraries
CEquat..::..gaval Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.gaval(System.Char[],System.Int32)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected double gaval(
    char[] e,
    int i
)
Visual Basic
Protected Function gaval ( _
    e As Char(), _
    i As Integer _
) As Double
Visual C++
protected:
double gaval(
    array<wchar_t>^ e,
    int i
)

Parameters

e
Type: array< System..::..Char >[]()[][]

[Missing <param name="e"/> documentation for "M:ElScript.CEquat.gaval(System.Char[],System.Int32)"]

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:ElScript.CEquat.gaval(System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.gaval(System.Char[],System.Int32)"]

See Also

CEquat Class
ElScript Namespace


Get Method

[image]

4 of William Foster's Class Libraries
CEquat..::..Get Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.Get(El.STRING@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Get(
    out STRING csEqn
)
Visual Basic
Public Sub Get ( _
    <OutAttribute> ByRef csEqn As STRING _
)
Visual C++
public:
void Get(
    [OutAttribute] STRING^% csEqn
)

Parameters

csEqn
Type: STRING%

[Missing <param name="csEqn"/> documentation for "M:ElScript.CEquat.Get(El.STRING@)"]

See Also

CEquat Class
ElScript Namespace


is_digit Method

[image]

4 of William Foster's Class Libraries
CEquat..::..is_digit Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.is_digit(System.Int32)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool is_digit(
    int c
)
Visual Basic
Public Shared Function is_digit ( _
    c As Integer _
) As Boolean
Visual C++
public:
static bool is_digit(
    int c
)

Parameters

c
Type: System..::..Int32

[Missing <param name="c"/> documentation for "M:ElScript.CEquat.is_digit(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.is_digit(System.Int32)"]

See Also

CEquat Class
ElScript Namespace


Legalize_Equation Method

[image]

4 of William Foster's Class Libraries
CEquat..::..Legalize_Equation Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.Legalize_Equation(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Legalize_Equation(
    STRING cs_eqn
)
Visual Basic
Public Function Legalize_Equation ( _
    cs_eqn As STRING _
) As Boolean
Visual C++
public:
bool Legalize_Equation(
    STRING^ cs_eqn
)

Parameters

cs_eqn
Type: STRING

[Missing <param name="cs_eqn"/> documentation for "M:ElScript.CEquat.Legalize_Equation(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.Legalize_Equation(El.STRING)"]

See Also

CEquat Class
ElScript Namespace


myatof Method

[image]

4 of William Foster's Class Libraries
CEquat..::..myatof Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.myatof(System.Char[],System.Int32)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected double myatof(
    char[] a,
    int index
)
Visual Basic
Protected Function myatof ( _
    a As Char(), _
    index As Integer _
) As Double
Visual C++
protected:
double myatof(
    array<wchar_t>^ a,
    int index
)

Parameters

a
Type: array< System..::..Char >[]()[][]

[Missing <param name="a"/> documentation for "M:ElScript.CEquat.myatof(System.Char[],System.Int32)"]

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:ElScript.CEquat.myatof(System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.myatof(System.Char[],System.Int32)"]

See Also

CEquat Class
ElScript Namespace


myfunct Method

[image]

4 of William Foster's Class Libraries
CEquat..::..myfunct Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.myfunct(System.Char[],System.Int32)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected double myfunct(
    char[] e,
    int i
)
Visual Basic
Protected Function myfunct ( _
    e As Char(), _
    i As Integer _
) As Double
Visual C++
protected:
double myfunct(
    array<wchar_t>^ e,
    int i
)

Parameters

e
Type: array< System..::..Char >[]()[][]

[Missing <param name="e"/> documentation for "M:ElScript.CEquat.myfunct(System.Char[],System.Int32)"]

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:ElScript.CEquat.myfunct(System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.myfunct(System.Char[],System.Int32)"]

See Also

CEquat Class
ElScript Namespace


oper Method

[image]

4 of William Foster's Class Libraries
CEquat..::..oper Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.oper(System.Double,System.Double,System.Char)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected double oper(
    double n,
    double d,
    char o
)
Visual Basic
Protected Function oper ( _
    n As Double, _
    d As Double, _
    o As Char _
) As Double
Visual C++
protected:
double oper(
    double n,
    double d,
    wchar_t o
)

Parameters

n
Type: System..::..Double

[Missing <param name="n"/> documentation for "M:ElScript.CEquat.oper(System.Double,System.Double,System.Char)"]

d
Type: System..::..Double

[Missing <param name="d"/> documentation for "M:ElScript.CEquat.oper(System.Double,System.Double,System.Char)"]

o
Type: System..::..Char

[Missing <param name="o"/> documentation for "M:ElScript.CEquat.oper(System.Double,System.Double,System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.oper(System.Double,System.Double,System.Char)"]

See Also

CEquat Class
ElScript Namespace


power Method

[image]

4 of William Foster's Class Libraries
CEquat..::..power Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.power(System.Double,System.Double)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected double power(
    double x,
    double y
)
Visual Basic
Protected Function power ( _
    x As Double, _
    y As Double _
) As Double
Visual C++
protected:
double power(
    double x,
    double y
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ElScript.CEquat.power(System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ElScript.CEquat.power(System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.power(System.Double,System.Double)"]

See Also

CEquat Class
ElScript Namespace


Set Method

[image]

4 of William Foster's Class Libraries
CEquat..::..Set Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.Set(ElScript.IEquat_User,El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    IEquat_User eqnUser,
    STRING str_equation
)
Visual Basic
Public Sub Set ( _
    eqnUser As IEquat_User, _
    str_equation As STRING _
)
Visual C++
public:
void Set(
    IEquat_User^ eqnUser,
    STRING^ str_equation
)

Parameters

eqnUser
Type: ElScript..::..IEquat_User

[Missing <param name="eqnUser"/> documentation for "M:ElScript.CEquat.Set(ElScript.IEquat_User,El.STRING)"]

str_equation
Type: STRING

[Missing <param name="str_equation"/> documentation for "M:ElScript.CEquat.Set(ElScript.IEquat_User,El.STRING)"]

See Also

CEquat Class
ElScript Namespace


Set_Legalized Method

[image]

4 of William Foster's Class Libraries
CEquat..::..Set_Legalized Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.Set_Legalized(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set_Legalized(
    STRING str_equation
)
Visual Basic
Public Sub Set_Legalized ( _
    str_equation As STRING _
)
Visual C++
public:
void Set_Legalized(
    STRING^ str_equation
)

Parameters

str_equation
Type: STRING

[Missing <param name="str_equation"/> documentation for "M:ElScript.CEquat.Set_Legalized(El.STRING)"]

See Also

CEquat Class
ElScript Namespace


type Method

[image]

4 of William Foster's Class Libraries
CEquat..::..type Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.type(System.Char)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static CEquat..::..EType type(
    char c
)
Visual Basic
Public Shared Function type ( _
    c As Char _
) As CEquat..::..EType
Visual C++
public:
static CEquat..::..EType type(
    wchar_t c
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:ElScript.CEquat.type(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.type(System.Char)"]

See Also

CEquat Class
ElScript Namespace


varval Method

[image]

4 of William Foster's Class Libraries
CEquat..::..varval Method
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CEquat.varval(System.Char[],System.Int32)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected double varval(
    char[] e,
    int c
)
Visual Basic
Protected Function varval ( _
    e As Char(), _
    c As Integer _
) As Double
Visual C++
protected:
double varval(
    array<wchar_t>^ e,
    int c
)

Parameters

e
Type: array< System..::..Char >[]()[][]

[Missing <param name="e"/> documentation for "M:ElScript.CEquat.varval(System.Char[],System.Int32)"]

c
Type: System..::..Int32

[Missing <param name="c"/> documentation for "M:ElScript.CEquat.varval(System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CEquat.varval(System.Char[],System.Int32)"]

See Also

CEquat Class
ElScript Namespace


CEquat.EType Enumeration

[image]

4 of William Foster's Class Libraries
CEquat..::..EType Enumeration
CEquat Class See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.CEquat.EType"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum EType
Visual Basic
Public Enumeration EType
Visual C++
public enum class EType

Members

Member name | Value | Description
LETTER | 0 |
DIGIT | 1 |
SPACE | 2 |
OPERATOR | 3 |

See Also

ElScript Namespace


CPlusPlus_Argument Class

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.CPlusPlus_Argument"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CPlusPlus_Argument
Visual Basic
Public Class CPlusPlus_Argument
Visual C++
public ref class CPlusPlus_Argument

Inheritance Hierarchy

System..::..Object
ElScript..::..CPlusPlus_Argument
ElScript..::..CPlusPlus_VariableDefinition

See Also

CPlusPlus_Argument Members
ElScript Namespace


CPlusPlus_Argument Members

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_Argument Members
CPlusPlus_Argument Class Constructors Methods Operators Fields See Also Send Feedback

The CPlusPlus_Argument type exposes the following members.

Constructors

 | Name | Description
Public method | CPlusPlus_Argument()()()() | Initializes a new instance of the CPlusPlus_Argument class
Public method | CPlusPlus_Argument(STRING) | Initializes a new instance of the CPlusPlus_Argument class

Methods

 | Name | Description
Protected method | Empty |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetFromString |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality |
Inequality |

Fields

 | Name | Description
Public field | m_b_const |
Public field | m_b_pointer |
Public field | m_b_reference |
Public field | m_b_volatile |
Public field | m_cs_ArgumentName |
Public field | m_cs_DefaultValue |
Public field | m_cs_Type |

See Also

CPlusPlus_Argument Class
ElScript Namespace


CPlusPlus_Argument Constructor

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_Argument Constructor
CPlusPlus_Argument Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CPlusPlus_Argument()()()() | Initializes a new instance of the CPlusPlus_Argument class
Public method | CPlusPlus_Argument(STRING) | Initializes a new instance of the CPlusPlus_Argument class

See Also

CPlusPlus_Argument Class
CPlusPlus_Argument Members
ElScript Namespace


CPlusPlus_Argument Constructor

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument Constructor
CPlusPlus_Argument Class See Also Send Feedback
Initializes a new instance of the CPlusPlus_Argument class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CPlusPlus_Argument()
Visual Basic
Public Sub New
Visual C++
public:
CPlusPlus_Argument()

See Also

CPlusPlus_Argument Class
CPlusPlus_Argument Overload
ElScript Namespace


CPlusPlus_Argument Constructor ()

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument Constructor ()
CPlusPlus_Argument Class See Also Send Feedback
Initializes a new instance of the CPlusPlus_Argument class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CPlusPlus_Argument(
    STRING argdesc
)
Visual Basic
Public Sub New ( _
    argdesc As STRING _
)
Visual C++
public:
CPlusPlus_Argument(
    STRING^ argdesc
)

Parameters

argdesc
Type: STRING

[Missing <param name="argdesc"/> documentation for "M:ElScript.CPlusPlus_Argument.#ctor(El.STRING)"]

See Also

CPlusPlus_Argument Class
CPlusPlus_Argument Overload
ElScript Namespace


CPlusPlus_Argument Fields

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_Argument Fields
CPlusPlus_Argument Class See Also Send Feedback

The CPlusPlus_Argument type exposes the following members.

Fields

 | Name | Description
Public field | m_b_const |
Public field | m_b_pointer |
Public field | m_b_reference |
Public field | m_b_volatile |
Public field | m_cs_ArgumentName |
Public field | m_cs_DefaultValue |
Public field | m_cs_Type |

See Also

CPlusPlus_Argument Class
ElScript Namespace


m_b_const Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument..::..m_b_const Field
CPlusPlus_Argument Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_Argument.m_b_const"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool m_b_const
Visual Basic
Public m_b_const As Boolean
Visual C++
public:
bool m_b_const

See Also

CPlusPlus_Argument Class
ElScript Namespace


m_b_pointer Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument..::..m_b_pointer Field
CPlusPlus_Argument Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_Argument.m_b_pointer"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool m_b_pointer
Visual Basic
Public m_b_pointer As Boolean
Visual C++
public:
bool m_b_pointer

See Also

CPlusPlus_Argument Class
ElScript Namespace


m_b_reference Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument..::..m_b_reference Field
CPlusPlus_Argument Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_Argument.m_b_reference"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool m_b_reference
Visual Basic
Public m_b_reference As Boolean
Visual C++
public:
bool m_b_reference

See Also

CPlusPlus_Argument Class
ElScript Namespace


m_b_volatile Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument..::..m_b_volatile Field
CPlusPlus_Argument Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_Argument.m_b_volatile"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool m_b_volatile
Visual Basic
Public m_b_volatile As Boolean
Visual C++
public:
bool m_b_volatile

See Also

CPlusPlus_Argument Class
ElScript Namespace


m_cs_ArgumentName Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument..::..m_cs_ArgumentName Field
CPlusPlus_Argument Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_Argument.m_cs_ArgumentName"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_cs_ArgumentName
Visual Basic
Public m_cs_ArgumentName As String
Visual C++
public:
String^ m_cs_ArgumentName

See Also

CPlusPlus_Argument Class
ElScript Namespace


m_cs_DefaultValue Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument..::..m_cs_DefaultValue Field
CPlusPlus_Argument Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_Argument.m_cs_DefaultValue"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_cs_DefaultValue
Visual Basic
Public m_cs_DefaultValue As String
Visual C++
public:
String^ m_cs_DefaultValue

See Also

CPlusPlus_Argument Class
ElScript Namespace


m_cs_Type Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument..::..m_cs_Type Field
CPlusPlus_Argument Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_Argument.m_cs_Type"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CPlusPlus_FunctionName m_cs_Type
Visual Basic
Public m_cs_Type As CPlusPlus_FunctionName
Visual C++
public:
CPlusPlus_FunctionName^ m_cs_Type

See Also

CPlusPlus_Argument Class
ElScript Namespace


CPlusPlus_Argument Methods

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_Argument Methods
CPlusPlus_Argument Class See Also Send Feedback

The CPlusPlus_Argument type exposes the following members.

Methods

 | Name | Description
Protected method | Empty |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetFromString |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CPlusPlus_Argument Class
ElScript Namespace


Empty Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument..::..Empty Method
CPlusPlus_Argument Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_Argument.Empty"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void Empty()
Visual Basic
Protected Sub Empty
Visual C++
protected:
void Empty()

See Also

CPlusPlus_Argument Class
ElScript Namespace


Set Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument..::..Set Method
CPlusPlus_Argument Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_Argument.Set(ElScript.CPlusPlus_Argument)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    CPlusPlus_Argument copy
)
Visual Basic
Public Sub Set ( _
    copy As CPlusPlus_Argument _
)
Visual C++
public:
void Set(
    CPlusPlus_Argument^ copy
)

Parameters

copy
Type: ElScript..::..CPlusPlus_Argument

[Missing <param name="copy"/> documentation for "M:ElScript.CPlusPlus_Argument.Set(ElScript.CPlusPlus_Argument)"]

See Also

CPlusPlus_Argument Class
ElScript Namespace


SetFromString Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument..::..SetFromString Method
CPlusPlus_Argument Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_Argument.SetFromString(System.String)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetFromString(
    string argdesc
)
Visual Basic
Public Function SetFromString ( _
    argdesc As String _
) As Boolean
Visual C++
public:
bool SetFromString(
    String^ argdesc
)

Parameters

argdesc
Type: System..::..String

[Missing <param name="argdesc"/> documentation for "M:ElScript.CPlusPlus_Argument.SetFromString(System.String)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_Argument.SetFromString(System.String)"]

See Also

CPlusPlus_Argument Class
ElScript Namespace


CPlusPlus_Argument Operators

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_Argument Operators
CPlusPlus_Argument Class See Also Send Feedback

The CPlusPlus_Argument type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

CPlusPlus_Argument Class
ElScript Namespace


Equality Operator

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument..::..Equality Operator
CPlusPlus_Argument Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_Argument.op_Equality(ElScript.CPlusPlus_Argument,ElScript.CPlusPlus_Argument)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator ==(
    CPlusPlus_Argument one,
    CPlusPlus_Argument other
)
Visual Basic
Public Shared Operator = ( _
    one As CPlusPlus_Argument, _
    other As CPlusPlus_Argument _
) As Boolean
Visual C++
public:
static bool operator ==(
    CPlusPlus_Argument^ one,
    CPlusPlus_Argument^ other
)

Parameters

one
Type: ElScript..::..CPlusPlus_Argument

[Missing <param name="one"/> documentation for "M:ElScript.CPlusPlus_Argument.op_Equality(ElScript.CPlusPlus_Argument,ElScript.CPlusPlus_Argument)"]

other
Type: ElScript..::..CPlusPlus_Argument

[Missing <param name="other"/> documentation for "M:ElScript.CPlusPlus_Argument.op_Equality(ElScript.CPlusPlus_Argument,ElScript.CPlusPlus_Argument)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_Argument.op_Equality(ElScript.CPlusPlus_Argument,ElScript.CPlusPlus_Argument)"]

See Also

CPlusPlus_Argument Class
ElScript Namespace


Inequality Operator

[image]

4 of William Foster's Class Libraries
CPlusPlus_Argument..::..Inequality Operator
CPlusPlus_Argument Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_Argument.op_Inequality(ElScript.CPlusPlus_Argument,ElScript.CPlusPlus_Argument)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator !=(
    CPlusPlus_Argument one,
    CPlusPlus_Argument other
)
Visual Basic
Public Shared Operator <> ( _
    one As CPlusPlus_Argument, _
    other As CPlusPlus_Argument _
) As Boolean
Visual C++
public:
static bool operator !=(
    CPlusPlus_Argument^ one,
    CPlusPlus_Argument^ other
)

Parameters

one
Type: ElScript..::..CPlusPlus_Argument

[Missing <param name="one"/> documentation for "M:ElScript.CPlusPlus_Argument.op_Inequality(ElScript.CPlusPlus_Argument,ElScript.CPlusPlus_Argument)"]

other
Type: ElScript..::..CPlusPlus_Argument

[Missing <param name="other"/> documentation for "M:ElScript.CPlusPlus_Argument.op_Inequality(ElScript.CPlusPlus_Argument,ElScript.CPlusPlus_Argument)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_Argument.op_Inequality(ElScript.CPlusPlus_Argument,ElScript.CPlusPlus_Argument)"]

See Also

CPlusPlus_Argument Class
ElScript Namespace


CPlusPlus_ClassDefinition Class

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.CPlusPlus_ClassDefinition"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CPlusPlus_ClassDefinition
Visual Basic
Public Class CPlusPlus_ClassDefinition
Visual C++
public ref class CPlusPlus_ClassDefinition

Inheritance Hierarchy

System..::..Object
ElScript..::..CPlusPlus_ClassDefinition

See Also

CPlusPlus_ClassDefinition Members
ElScript Namespace


CPlusPlus_ClassDefinition Members

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition Members
CPlusPlus_ClassDefinition Class Constructors Methods Fields See Also Send Feedback

The CPlusPlus_ClassDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | CPlusPlus_ClassDefinition()()()() | Initializes a new instance of the CPlusPlus_ClassDefinition class
Public method | CPlusPlus_ClassDefinition(CPlusPlus_ClassDefinition) | Initializes a new instance of the CPlusPlus_ClassDefinition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | FunctionExists |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetFromClassDef |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
 | csCPP_Deliminators |
Public field | m_b_ExportMe |
Public field | m_cs_ClassName |
Public field | m_cs_comments |
Public field | m_cs_Data |
Public field | m_cs_NameSpace |
Public field | m_cs_parentclasses |
Public field | m_CurrentScope |
Public field | m_functions |
Public field | m_vars |

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


CPlusPlus_ClassDefinition Constructor

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition Constructor
CPlusPlus_ClassDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CPlusPlus_ClassDefinition()()()() | Initializes a new instance of the CPlusPlus_ClassDefinition class
Public method | CPlusPlus_ClassDefinition(CPlusPlus_ClassDefinition) | Initializes a new instance of the CPlusPlus_ClassDefinition class

See Also

CPlusPlus_ClassDefinition Class
CPlusPlus_ClassDefinition Members
ElScript Namespace


CPlusPlus_ClassDefinition Constructor

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition Constructor
CPlusPlus_ClassDefinition Class See Also Send Feedback
Initializes a new instance of the CPlusPlus_ClassDefinition class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CPlusPlus_ClassDefinition()
Visual Basic
Public Sub New
Visual C++
public:
CPlusPlus_ClassDefinition()

See Also

CPlusPlus_ClassDefinition Class
CPlusPlus_ClassDefinition Overload
ElScript Namespace


CPlusPlus_ClassDefinition Constructor (CPlusPlus_ClassDefinition)

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition Constructor (CPlusPlus_ClassDefinition)
CPlusPlus_ClassDefinition Class See Also Send Feedback
Initializes a new instance of the CPlusPlus_ClassDefinition class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CPlusPlus_ClassDefinition(
    CPlusPlus_ClassDefinition _class
)
Visual Basic
Public Sub New ( _
    _class As CPlusPlus_ClassDefinition _
)
Visual C++
public:
CPlusPlus_ClassDefinition(
    CPlusPlus_ClassDefinition^ _class
)

Parameters

_class
Type: ElScript..::..CPlusPlus_ClassDefinition

[Missing <param name="_class"/> documentation for "M:ElScript.CPlusPlus_ClassDefinition.#ctor(ElScript.CPlusPlus_ClassDefinition)"]

See Also

CPlusPlus_ClassDefinition Class
CPlusPlus_ClassDefinition Overload
ElScript Namespace


CPlusPlus_ClassDefinition Fields

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition Fields
CPlusPlus_ClassDefinition Class See Also Send Feedback

The CPlusPlus_ClassDefinition type exposes the following members.

Fields

 | Name | Description
 | csCPP_Deliminators |
Public field | m_b_ExportMe |
Public field | m_cs_ClassName |
Public field | m_cs_comments |
Public field | m_cs_Data |
Public field | m_cs_NameSpace |
Public field | m_cs_parentclasses |
Public field | m_CurrentScope |
Public field | m_functions |
Public field | m_vars |

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


csCPP_Deliminators Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..csCPP_Deliminators Field
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_ClassDefinition.csCPP_Deliminators"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static STRING csCPP_Deliminators
Visual Basic
Public Shared csCPP_Deliminators As STRING
Visual C++
public:
static STRING^ csCPP_Deliminators

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


m_b_ExportMe Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..m_b_ExportMe Field
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_ClassDefinition.m_b_ExportMe"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool m_b_ExportMe
Visual Basic
Public m_b_ExportMe As Boolean
Visual C++
public:
bool m_b_ExportMe

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


m_cs_ClassName Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..m_cs_ClassName Field
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_ClassDefinition.m_cs_ClassName"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_cs_ClassName
Visual Basic
Public m_cs_ClassName As String
Visual C++
public:
String^ m_cs_ClassName

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


m_cs_comments Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..m_cs_comments Field
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_ClassDefinition.m_cs_comments"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING m_cs_comments
Visual Basic
Public m_cs_comments As STRING
Visual C++
public:
STRING^ m_cs_comments

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


m_cs_Data Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..m_cs_Data Field
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_ClassDefinition.m_cs_Data"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING m_cs_Data
Visual Basic
Public m_cs_Data As STRING
Visual C++
public:
STRING^ m_cs_Data

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


m_cs_NameSpace Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..m_cs_NameSpace Field
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_ClassDefinition.m_cs_NameSpace"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING m_cs_NameSpace
Visual Basic
Public m_cs_NameSpace As STRING
Visual C++
public:
STRING^ m_cs_NameSpace

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


m_cs_parentclasses Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..m_cs_parentclasses Field
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_ClassDefinition.m_cs_parentclasses"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING m_cs_parentclasses
Visual Basic
Public m_cs_parentclasses As STRING
Visual C++
public:
STRING^ m_cs_parentclasses

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


m_CurrentScope Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..m_CurrentScope Field
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_ClassDefinition.m_CurrentScope"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public E_CPLUSPLUS_SCOPE m_CurrentScope
Visual Basic
Public m_CurrentScope As E_CPLUSPLUS_SCOPE
Visual C++
public:
E_CPLUSPLUS_SCOPE m_CurrentScope

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


m_functions Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..m_functions Field
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_ClassDefinition.m_functions"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Array<CPlusPlus_FunctionDefinition> m_functions
Visual Basic
Public m_functions As Array(Of CPlusPlus_FunctionDefinition)
Visual C++
public:
Array<CPlusPlus_FunctionDefinition^>^ m_functions

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


m_vars Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..m_vars Field
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_ClassDefinition.m_vars"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Array<CPlusPlus_VariableDefinition> m_vars
Visual Basic
Public m_vars As Array(Of CPlusPlus_VariableDefinition)
Visual C++
public:
Array<CPlusPlus_VariableDefinition^>^ m_vars

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


CPlusPlus_ClassDefinition Methods

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition Methods
CPlusPlus_ClassDefinition Class See Also Send Feedback

The CPlusPlus_ClassDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | FunctionExists |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set |
Public method | SetFromClassDef |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


Finalize Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..Finalize Method
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_ClassDefinition.Finalize"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


FunctionExists Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..FunctionExists Method
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_ClassDefinition.FunctionExists(ElScript.CPlusPlus_FunctionDefinition)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CPlusPlus_FunctionDefinition FunctionExists(
    CPlusPlus_FunctionDefinition fdef
)
Visual Basic
Public Function FunctionExists ( _
    fdef As CPlusPlus_FunctionDefinition _
) As CPlusPlus_FunctionDefinition
Visual C++
public:
CPlusPlus_FunctionDefinition^ FunctionExists(
    CPlusPlus_FunctionDefinition^ fdef
)

Parameters

fdef
Type: ElScript..::..CPlusPlus_FunctionDefinition

[Missing <param name="fdef"/> documentation for "M:ElScript.CPlusPlus_ClassDefinition.FunctionExists(ElScript.CPlusPlus_FunctionDefinition)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_ClassDefinition.FunctionExists(ElScript.CPlusPlus_FunctionDefinition)"]

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


Set Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..Set Method
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_ClassDefinition.Set(ElScript.CPlusPlus_ClassDefinition)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    CPlusPlus_ClassDefinition copy
)
Visual Basic
Public Sub Set ( _
    copy As CPlusPlus_ClassDefinition _
)
Visual C++
public:
void Set(
    CPlusPlus_ClassDefinition^ copy
)

Parameters

copy
Type: ElScript..::..CPlusPlus_ClassDefinition

[Missing <param name="copy"/> documentation for "M:ElScript.CPlusPlus_ClassDefinition.Set(ElScript.CPlusPlus_ClassDefinition)"]

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


SetFromClassDef Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_ClassDefinition..::..SetFromClassDef Method
CPlusPlus_ClassDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_ClassDefinition.SetFromClassDef(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetFromClassDef(
    STRING ClassDef
)
Visual Basic
Public Sub SetFromClassDef ( _
    ClassDef As STRING _
)
Visual C++
public:
void SetFromClassDef(
    STRING^ ClassDef
)

Parameters

ClassDef
Type: STRING

[Missing <param name="ClassDef"/> documentation for "M:ElScript.CPlusPlus_ClassDefinition.SetFromClassDef(El.STRING)"]

See Also

CPlusPlus_ClassDefinition Class
ElScript Namespace


CPlusPlus_FunctionDefinition Class

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.CPlusPlus_FunctionDefinition"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CPlusPlus_FunctionDefinition
Visual Basic
Public Class CPlusPlus_FunctionDefinition
Visual C++
public ref class CPlusPlus_FunctionDefinition

Inheritance Hierarchy

System..::..Object
ElScript..::..CPlusPlus_FunctionDefinition

See Also

CPlusPlus_FunctionDefinition Members
ElScript Namespace


CPlusPlus_FunctionDefinition Members

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition Members
CPlusPlus_FunctionDefinition Class Constructors Methods Operators Fields See Also Send Feedback

The CPlusPlus_FunctionDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | CPlusPlus_FunctionDefinition()()()() | Initializes a new instance of the CPlusPlus_FunctionDefinition class
Public method | CPlusPlus_FunctionDefinition(CPlusPlus_FunctionDefinition) | Initializes a new instance of the CPlusPlus_FunctionDefinition class

Methods

 | Name | Description
 | ArgArraysEqual |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsNativeVartype |
Public method | MakeArgumentList |
Public method | MakeArgumentList_Sharp |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge |
Public method | Set |
Public method | SetArgumentsFromString |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValidateSelf |

Operators

Name | Description
Equality |
Inequality |

Fields

 | Name | Description
Public field | m_b_const |
Public field | m_b_friend |
Public field | m_b_operator |
Public field | m_b_static |
Public field | m_b_virtual |
Public field | m_cs_code |
Public field | m_cs_comments |
Public field | m_cs_FunctionName |
Public field | m_cs_parameters |
Public field | m_cs_ParentClass |
Public field | m_cs_ReturnType |
Public field | m_e_scope |
Public field | m_Parameters |

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


CPlusPlus_FunctionDefinition Constructor

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition Constructor
CPlusPlus_FunctionDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CPlusPlus_FunctionDefinition()()()() | Initializes a new instance of the CPlusPlus_FunctionDefinition class
Public method | CPlusPlus_FunctionDefinition(CPlusPlus_FunctionDefinition) | Initializes a new instance of the CPlusPlus_FunctionDefinition class

See Also

CPlusPlus_FunctionDefinition Class
CPlusPlus_FunctionDefinition Members
ElScript Namespace


CPlusPlus_FunctionDefinition Constructor

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition Constructor
CPlusPlus_FunctionDefinition Class See Also Send Feedback
Initializes a new instance of the CPlusPlus_FunctionDefinition class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CPlusPlus_FunctionDefinition()
Visual Basic
Public Sub New
Visual C++
public:
CPlusPlus_FunctionDefinition()

See Also

CPlusPlus_FunctionDefinition Class
CPlusPlus_FunctionDefinition Overload
ElScript Namespace


CPlusPlus_FunctionDefinition Constructor (CPlusPlus_FunctionDefinition)

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition Constructor (CPlusPlus_FunctionDefinition)
CPlusPlus_FunctionDefinition Class See Also Send Feedback
Initializes a new instance of the CPlusPlus_FunctionDefinition class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CPlusPlus_FunctionDefinition(
    CPlusPlus_FunctionDefinition copy
)
Visual Basic
Public Sub New ( _
    copy As CPlusPlus_FunctionDefinition _
)
Visual C++
public:
CPlusPlus_FunctionDefinition(
    CPlusPlus_FunctionDefinition^ copy
)

Parameters

copy
Type: ElScript..::..CPlusPlus_FunctionDefinition

[Missing <param name="copy"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.#ctor(ElScript.CPlusPlus_FunctionDefinition)"]

See Also

CPlusPlus_FunctionDefinition Class
CPlusPlus_FunctionDefinition Overload
ElScript Namespace


CPlusPlus_FunctionDefinition Fields

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition Fields
CPlusPlus_FunctionDefinition Class See Also Send Feedback

The CPlusPlus_FunctionDefinition type exposes the following members.

Fields

 | Name | Description
Public field | m_b_const |
Public field | m_b_friend |
Public field | m_b_operator |
Public field | m_b_static |
Public field | m_b_virtual |
Public field | m_cs_code |
Public field | m_cs_comments |
Public field | m_cs_FunctionName |
Public field | m_cs_parameters |
Public field | m_cs_ParentClass |
Public field | m_cs_ReturnType |
Public field | m_e_scope |
Public field | m_Parameters |

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


m_b_const Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..m_b_const Field
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_FunctionDefinition.m_b_const"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool m_b_const
Visual Basic
Public m_b_const As Boolean
Visual C++
public:
bool m_b_const

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


m_b_friend Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..m_b_friend Field
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_FunctionDefinition.m_b_friend"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool m_b_friend
Visual Basic
Public m_b_friend As Boolean
Visual C++
public:
bool m_b_friend

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


m_b_operator Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..m_b_operator Field
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_FunctionDefinition.m_b_operator"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool m_b_operator
Visual Basic
Public m_b_operator As Boolean
Visual C++
public:
bool m_b_operator

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


m_b_static Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..m_b_static Field
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_FunctionDefinition.m_b_static"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool m_b_static
Visual Basic
Public m_b_static As Boolean
Visual C++
public:
bool m_b_static

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


m_b_virtual Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..m_b_virtual Field
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_FunctionDefinition.m_b_virtual"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool m_b_virtual
Visual Basic
Public m_b_virtual As Boolean
Visual C++
public:
bool m_b_virtual

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


m_cs_code Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..m_cs_code Field
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_FunctionDefinition.m_cs_code"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_cs_code
Visual Basic
Public m_cs_code As String
Visual C++
public:
String^ m_cs_code

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


m_cs_comments Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..m_cs_comments Field
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_FunctionDefinition.m_cs_comments"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_cs_comments
Visual Basic
Public m_cs_comments As String
Visual C++
public:
String^ m_cs_comments

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


m_cs_FunctionName Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..m_cs_FunctionName Field
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_FunctionDefinition.m_cs_FunctionName"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_cs_FunctionName
Visual Basic
Public m_cs_FunctionName As String
Visual C++
public:
String^ m_cs_FunctionName

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


m_cs_parameters Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..m_cs_parameters Field
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_FunctionDefinition.m_cs_parameters"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_cs_parameters
Visual Basic
Public m_cs_parameters As String
Visual C++
public:
String^ m_cs_parameters

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


m_cs_ParentClass Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..m_cs_ParentClass Field
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_FunctionDefinition.m_cs_ParentClass"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_cs_ParentClass
Visual Basic
Public m_cs_ParentClass As String
Visual C++
public:
String^ m_cs_ParentClass

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


m_cs_ReturnType Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..m_cs_ReturnType Field
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_FunctionDefinition.m_cs_ReturnType"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string m_cs_ReturnType
Visual Basic
Public m_cs_ReturnType As String
Visual C++
public:
String^ m_cs_ReturnType

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


m_e_scope Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..m_e_scope Field
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_FunctionDefinition.m_e_scope"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public E_CPLUSPLUS_SCOPE m_e_scope
Visual Basic
Public m_e_scope As E_CPLUSPLUS_SCOPE
Visual C++
public:
E_CPLUSPLUS_SCOPE m_e_scope

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


m_Parameters Field

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..m_Parameters Field
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.CPlusPlus_FunctionDefinition.m_Parameters"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Array<CPlusPlus_Argument> m_Parameters
Visual Basic
Public m_Parameters As Array(Of CPlusPlus_Argument)
Visual C++
public:
Array<CPlusPlus_Argument^>^ m_Parameters

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


CPlusPlus_FunctionDefinition Methods

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition Methods
CPlusPlus_FunctionDefinition Class See Also Send Feedback

The CPlusPlus_FunctionDefinition type exposes the following members.

Methods

 | Name | Description
 | ArgArraysEqual |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsNativeVartype |
Public method | MakeArgumentList |
Public method | MakeArgumentList_Sharp |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge |
Public method | Set |
Public method | SetArgumentsFromString |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValidateSelf |

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


ArgArraysEqual Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..ArgArraysEqual Method
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.ArgArraysEqual(El.Array{ElScript.CPlusPlus_Argument},El.Array{ElScript.CPlusPlus_Argument})"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool ArgArraysEqual(
    Array<CPlusPlus_Argument> args1,
    Array<CPlusPlus_Argument> args2
)
Visual Basic
Public Shared Function ArgArraysEqual ( _
    args1 As Array(Of CPlusPlus_Argument), _
    args2 As Array(Of CPlusPlus_Argument) _
) As Boolean
Visual C++
public:
static bool ArgArraysEqual(
    Array<CPlusPlus_Argument^>^ args1,
    Array<CPlusPlus_Argument^>^ args2
)

Parameters

args1
Type: Array<(Of <(<' CPlusPlus_Argument >)>)>

[Missing <param name="args1"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.ArgArraysEqual(El.Array{ElScript.CPlusPlus_Argument},El.Array{ElScript.CPlusPlus_Argument})"]

args2
Type: Array<(Of <(<' CPlusPlus_Argument >)>)>

[Missing <param name="args2"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.ArgArraysEqual(El.Array{ElScript.CPlusPlus_Argument},El.Array{ElScript.CPlusPlus_Argument})"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.ArgArraysEqual(El.Array{ElScript.CPlusPlus_Argument},El.Array{ElScript.CPlusPlus_Argument})"]

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


IsNativeVartype Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..IsNativeVartype Method
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.IsNativeVartype(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsNativeVartype(
    STRING csType
)
Visual Basic
Public Function IsNativeVartype ( _
    csType As STRING _
) As Boolean
Visual C++
public:
bool IsNativeVartype(
    STRING^ csType
)

Parameters

csType
Type: STRING

[Missing <param name="csType"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.IsNativeVartype(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.IsNativeVartype(El.STRING)"]

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


MakeArgumentList Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..MakeArgumentList Method
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.MakeArgumentList(El.STRING,System.Boolean)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool MakeArgumentList(
    STRING sTxt,
    bool bWithTypes
)
Visual Basic
Public Function MakeArgumentList ( _
    sTxt As STRING, _
    bWithTypes As Boolean _
) As Boolean
Visual C++
public:
bool MakeArgumentList(
    STRING^ sTxt,
    bool bWithTypes
)

Parameters

sTxt
Type: STRING

[Missing <param name="sTxt"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.MakeArgumentList(El.STRING,System.Boolean)"]

bWithTypes
Type: System..::..Boolean

[Missing <param name="bWithTypes"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.MakeArgumentList(El.STRING,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.MakeArgumentList(El.STRING,System.Boolean)"]

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


MakeArgumentList_Sharp Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..MakeArgumentList_Sharp Method
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.MakeArgumentList_Sharp(El.STRING,System.Boolean)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool MakeArgumentList_Sharp(
    STRING sTxt,
    bool bWithTypes
)
Visual Basic
Public Function MakeArgumentList_Sharp ( _
    sTxt As STRING, _
    bWithTypes As Boolean _
) As Boolean
Visual C++
public:
bool MakeArgumentList_Sharp(
    STRING^ sTxt,
    bool bWithTypes
)

Parameters

sTxt
Type: STRING

[Missing <param name="sTxt"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.MakeArgumentList_Sharp(El.STRING,System.Boolean)"]

bWithTypes
Type: System..::..Boolean

[Missing <param name="bWithTypes"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.MakeArgumentList_Sharp(El.STRING,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.MakeArgumentList_Sharp(El.STRING,System.Boolean)"]

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


Merge Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..Merge Method
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.Merge(ElScript.CPlusPlus_FunctionDefinition)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Merge(
    CPlusPlus_FunctionDefinition other
)
Visual Basic
Public Function Merge ( _
    other As CPlusPlus_FunctionDefinition _
) As Boolean
Visual C++
public:
bool Merge(
    CPlusPlus_FunctionDefinition^ other
)

Parameters

other
Type: ElScript..::..CPlusPlus_FunctionDefinition

[Missing <param name="other"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.Merge(ElScript.CPlusPlus_FunctionDefinition)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.Merge(ElScript.CPlusPlus_FunctionDefinition)"]

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


Set Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..Set Method
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.Set(ElScript.CPlusPlus_FunctionDefinition)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    CPlusPlus_FunctionDefinition copy
)
Visual Basic
Public Sub Set ( _
    copy As CPlusPlus_FunctionDefinition _
)
Visual C++
public:
void Set(
    CPlusPlus_FunctionDefinition^ copy
)

Parameters

copy
Type: ElScript..::..CPlusPlus_FunctionDefinition

[Missing <param name="copy"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.Set(ElScript.CPlusPlus_FunctionDefinition)"]

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


SetArgumentsFromString Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..SetArgumentsFromString Method
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.SetArgumentsFromString(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetArgumentsFromString(
    STRING sArgs
)
Visual Basic
Public Sub SetArgumentsFromString ( _
    sArgs As STRING _
)
Visual C++
public:
void SetArgumentsFromString(
    STRING^ sArgs
)

Parameters

sArgs
Type: STRING

[Missing <param name="sArgs"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.SetArgumentsFromString(El.STRING)"]

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


ValidateSelf Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..ValidateSelf Method
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.ValidateSelf"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ValidateSelf()
Visual Basic
Public Function ValidateSelf As Boolean
Visual C++
public:
bool ValidateSelf()

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.ValidateSelf"]

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


CPlusPlus_FunctionDefinition Operators

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition Operators
CPlusPlus_FunctionDefinition Class See Also Send Feedback

The CPlusPlus_FunctionDefinition type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


Equality Operator

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..Equality Operator
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.op_Equality(ElScript.CPlusPlus_FunctionDefinition,ElScript.CPlusPlus_FunctionDefinition)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator ==(
    CPlusPlus_FunctionDefinition one,
    CPlusPlus_FunctionDefinition other
)
Visual Basic
Public Shared Operator = ( _
    one As CPlusPlus_FunctionDefinition, _
    other As CPlusPlus_FunctionDefinition _
) As Boolean
Visual C++
public:
static bool operator ==(
    CPlusPlus_FunctionDefinition^ one,
    CPlusPlus_FunctionDefinition^ other
)

Parameters

one
Type: ElScript..::..CPlusPlus_FunctionDefinition

[Missing <param name="one"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.op_Equality(ElScript.CPlusPlus_FunctionDefinition,ElScript.CPlusPlus_FunctionDefinition)"]

other
Type: ElScript..::..CPlusPlus_FunctionDefinition

[Missing <param name="other"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.op_Equality(ElScript.CPlusPlus_FunctionDefinition,ElScript.CPlusPlus_FunctionDefinition)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.op_Equality(ElScript.CPlusPlus_FunctionDefinition,ElScript.CPlusPlus_FunctionDefinition)"]

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


Inequality Operator

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionDefinition..::..Inequality Operator
CPlusPlus_FunctionDefinition Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.op_Inequality(ElScript.CPlusPlus_FunctionDefinition,ElScript.CPlusPlus_FunctionDefinition)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator !=(
    CPlusPlus_FunctionDefinition one,
    CPlusPlus_FunctionDefinition other
)
Visual Basic
Public Shared Operator <> ( _
    one As CPlusPlus_FunctionDefinition, _
    other As CPlusPlus_FunctionDefinition _
) As Boolean
Visual C++
public:
static bool operator !=(
    CPlusPlus_FunctionDefinition^ one,
    CPlusPlus_FunctionDefinition^ other
)

Parameters

one
Type: ElScript..::..CPlusPlus_FunctionDefinition

[Missing <param name="one"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.op_Inequality(ElScript.CPlusPlus_FunctionDefinition,ElScript.CPlusPlus_FunctionDefinition)"]

other
Type: ElScript..::..CPlusPlus_FunctionDefinition

[Missing <param name="other"/> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.op_Inequality(ElScript.CPlusPlus_FunctionDefinition,ElScript.CPlusPlus_FunctionDefinition)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_FunctionDefinition.op_Inequality(ElScript.CPlusPlus_FunctionDefinition,ElScript.CPlusPlus_FunctionDefinition)"]

See Also

CPlusPlus_FunctionDefinition Class
ElScript Namespace


CPlusPlus_FunctionName Class

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.CPlusPlus_FunctionName"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CPlusPlus_FunctionName : STRING
Visual Basic
Public Class CPlusPlus_FunctionName _
    Inherits STRING
Visual C++
public ref class CPlusPlus_FunctionName : public STRING

Inheritance Hierarchy

System..::..Object
STRING
ElScript..::..CPlusPlus_FunctionName

See Also

CPlusPlus_FunctionName Members
ElScript Namespace


CPlusPlus_FunctionName Members

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName Members
CPlusPlus_FunctionName Class Constructors Methods Operators Fields Properties See Also Send Feedback

The CPlusPlus_FunctionName type exposes the following members.

Constructors

 | Name | Description
Public method | CPlusPlus_FunctionName()()()() | Initializes a new instance of the CPlusPlus_FunctionName class
Public method | CPlusPlus_FunctionName(STRING) | Initializes a new instance of the CPlusPlus_FunctionName class

Methods

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Empty | (Inherited from STRING.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)
Public method | FindOneOf | (Inherited from STRING.)
Public method | FormatV | (Inherited from STRING.)
Public method | GetAsString | (Inherited from STRING.)
Public method | GetAt | (Inherited from STRING.)
Public method | GetBytePtr | (Inherited from STRING.)
Public method | GetEnumerator | (Inherited from STRING.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | (Inherited from STRING.)
Public method | GetLengthBytes | (Inherited from STRING.)
Protected method | GetName |
Public method | GetPtr | (Inherited from STRING.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAt | (Inherited from STRING.)
Public method | IsEmpty | (Inherited from STRING.)
Public method | Left | (Inherited from STRING.)
Public method | LeftEquals | (Inherited from STRING.)
Public method | LeftFrom | (Inherited from STRING.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid | (Inherited from STRING.)
Public method | ParseLines | (Inherited from STRING.)
Public method | RemoveAt | (Inherited from STRING.)
Public method | RemoveQuotes | (Inherited from STRING.)
Public method | RemoveWhitespace | (Inherited from STRING.)
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)
Public method | ReverseFind | (Inherited from STRING.)
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)
Public method | RightFrom | (Inherited from STRING.)
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)
Public method | SetAt | (Inherited from STRING.)
Public method | SetLength | (Inherited from STRING.)
Public method | SpanExcluding | (Inherited from STRING.)
Public method | Substitute | (Inherited from STRING.)
Public method | Terminate | (Inherited from STRING.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase | (Inherited from STRING.)
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

Operators

Name | Description
Equality |
Inequality |

Fields

 | Name | Description
Protected field | m_cs | (Inherited from STRING.)

Properties

 | Name | Description
Public property | Item(UInt32) | (Inherited from STRING.)
Public property | Item(Int32) | (Inherited from STRING.)
Public property | Length | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
ElScript Namespace


CPlusPlus_FunctionName Constructor

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName Constructor
CPlusPlus_FunctionName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CPlusPlus_FunctionName()()()() | Initializes a new instance of the CPlusPlus_FunctionName class
Public method | CPlusPlus_FunctionName(STRING) | Initializes a new instance of the CPlusPlus_FunctionName class

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Members
ElScript Namespace


CPlusPlus_FunctionName Constructor

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName Constructor
CPlusPlus_FunctionName Class See Also Send Feedback
Initializes a new instance of the CPlusPlus_FunctionName class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CPlusPlus_FunctionName()
Visual Basic
Public Sub New
Visual C++
public:
CPlusPlus_FunctionName()

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Overload
ElScript Namespace


CPlusPlus_FunctionName Constructor ()

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName Constructor ()
CPlusPlus_FunctionName Class See Also Send Feedback
Initializes a new instance of the CPlusPlus_FunctionName class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CPlusPlus_FunctionName(
    STRING name
)
Visual Basic
Public Sub New ( _
    name As STRING _
)
Visual C++
public:
CPlusPlus_FunctionName(
    STRING^ name
)

Parameters

name
Type: STRING

[Missing <param name="name"/> documentation for "M:ElScript.CPlusPlus_FunctionName.#ctor(El.STRING)"]

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Overload
ElScript Namespace


CPlusPlus_FunctionName Fields

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName Fields
CPlusPlus_FunctionName Class See Also Send Feedback

The CPlusPlus_FunctionName type exposes the following members.

Fields

 | Name | Description
Protected field | m_cs | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
ElScript Namespace


CPlusPlus_FunctionName Methods

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName Methods
CPlusPlus_FunctionName Class See Also Send Feedback

The CPlusPlus_FunctionName type exposes the following members.

Methods

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Empty | (Inherited from STRING.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)
Public method | FindOneOf | (Inherited from STRING.)
Public method | FormatV | (Inherited from STRING.)
Public method | GetAsString | (Inherited from STRING.)
Public method | GetAt | (Inherited from STRING.)
Public method | GetBytePtr | (Inherited from STRING.)
Public method | GetEnumerator | (Inherited from STRING.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | (Inherited from STRING.)
Public method | GetLengthBytes | (Inherited from STRING.)
Protected method | GetName |
Public method | GetPtr | (Inherited from STRING.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertAt | (Inherited from STRING.)
Public method | IsEmpty | (Inherited from STRING.)
Public method | Left | (Inherited from STRING.)
Public method | LeftEquals | (Inherited from STRING.)
Public method | LeftFrom | (Inherited from STRING.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid | (Inherited from STRING.)
Public method | ParseLines | (Inherited from STRING.)
Public method | RemoveAt | (Inherited from STRING.)
Public method | RemoveQuotes | (Inherited from STRING.)
Public method | RemoveWhitespace | (Inherited from STRING.)
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)
Public method | ReverseFind | (Inherited from STRING.)
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)
Public method | RightFrom | (Inherited from STRING.)
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)
Public method | SetAt | (Inherited from STRING.)
Public method | SetLength | (Inherited from STRING.)
Public method | SpanExcluding | (Inherited from STRING.)
Public method | Substitute | (Inherited from STRING.)
Public method | Terminate | (Inherited from STRING.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase | (Inherited from STRING.)
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
ElScript Namespace


Append Method

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..Append Method
CPlusPlus_FunctionName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Members
ElScript Namespace


Compare Method

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..Compare Method
CPlusPlus_FunctionName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Members
ElScript Namespace


CompareNoCase Method

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..CompareNoCase Method
CPlusPlus_FunctionName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Members
ElScript Namespace


Find Method

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..Find Method
CPlusPlus_FunctionName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Members
ElScript Namespace


GetName Method

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..GetName Method
CPlusPlus_FunctionName Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_FunctionName.GetName(El.STRING@,System.UInt32)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool GetName(
    out STRING csName,
    uint uIndex
)
Visual Basic
Protected Function GetName ( _
    <OutAttribute> ByRef csName As STRING, _
    uIndex As UInteger _
) As Boolean
Visual C++
protected:
bool GetName(
    [OutAttribute] STRING^% csName,
    unsigned int uIndex
)

Parameters

csName
Type: STRING%

[Missing <param name="csName"/> documentation for "M:ElScript.CPlusPlus_FunctionName.GetName(El.STRING@,System.UInt32)"]

uIndex
Type: System..::..UInt32

[Missing <param name="uIndex"/> documentation for "M:ElScript.CPlusPlus_FunctionName.GetName(El.STRING@,System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_FunctionName.GetName(El.STRING@,System.UInt32)"]

See Also

CPlusPlus_FunctionName Class
ElScript Namespace


Replace Method

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..Replace Method
CPlusPlus_FunctionName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Members
ElScript Namespace


Right Method

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..Right Method
CPlusPlus_FunctionName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Members
ElScript Namespace


Set Method

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..Set Method
CPlusPlus_FunctionName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Members
ElScript Namespace


Trim Method

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..Trim Method
CPlusPlus_FunctionName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Members
ElScript Namespace


TrimLeft Method

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..TrimLeft Method
CPlusPlus_FunctionName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Members
ElScript Namespace


TrimRight Method

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..TrimRight Method
CPlusPlus_FunctionName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Members
ElScript Namespace


CPlusPlus_FunctionName Operators

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName Operators
CPlusPlus_FunctionName Class See Also Send Feedback

The CPlusPlus_FunctionName type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

CPlusPlus_FunctionName Class
ElScript Namespace


Equality Operator

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..Equality Operator
CPlusPlus_FunctionName Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_FunctionName.op_Equality(ElScript.CPlusPlus_FunctionName,ElScript.CPlusPlus_FunctionName)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator ==(
    CPlusPlus_FunctionName one,
    CPlusPlus_FunctionName other
)
Visual Basic
Public Shared Operator = ( _
    one As CPlusPlus_FunctionName, _
    other As CPlusPlus_FunctionName _
) As Boolean
Visual C++
public:
static bool operator ==(
    CPlusPlus_FunctionName^ one,
    CPlusPlus_FunctionName^ other
)

Parameters

one
Type: ElScript..::..CPlusPlus_FunctionName

[Missing <param name="one"/> documentation for "M:ElScript.CPlusPlus_FunctionName.op_Equality(ElScript.CPlusPlus_FunctionName,ElScript.CPlusPlus_FunctionName)"]

other
Type: ElScript..::..CPlusPlus_FunctionName

[Missing <param name="other"/> documentation for "M:ElScript.CPlusPlus_FunctionName.op_Equality(ElScript.CPlusPlus_FunctionName,ElScript.CPlusPlus_FunctionName)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_FunctionName.op_Equality(ElScript.CPlusPlus_FunctionName,ElScript.CPlusPlus_FunctionName)"]

See Also

CPlusPlus_FunctionName Class
ElScript Namespace


Inequality Operator

[image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..Inequality Operator
CPlusPlus_FunctionName Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.CPlusPlus_FunctionName.op_Inequality(ElScript.CPlusPlus_FunctionName,ElScript.CPlusPlus_FunctionName)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator !=(
    CPlusPlus_FunctionName one,
    CPlusPlus_FunctionName other
)
Visual Basic
Public Shared Operator <> ( _
    one As CPlusPlus_FunctionName, _
    other As CPlusPlus_FunctionName _
) As Boolean
Visual C++
public:
static bool operator !=(
    CPlusPlus_FunctionName^ one,
    CPlusPlus_FunctionName^ other
)

Parameters

one
Type: ElScript..::..CPlusPlus_FunctionName

[Missing <param name="one"/> documentation for "M:ElScript.CPlusPlus_FunctionName.op_Inequality(ElScript.CPlusPlus_FunctionName,ElScript.CPlusPlus_FunctionName)"]

other
Type: ElScript..::..CPlusPlus_FunctionName

[Missing <param name="other"/> documentation for "M:ElScript.CPlusPlus_FunctionName.op_Inequality(ElScript.CPlusPlus_FunctionName,ElScript.CPlusPlus_FunctionName)"]

Return Value

[Missing <returns> documentation for "M:ElScript.CPlusPlus_FunctionName.op_Inequality(ElScript.CPlusPlus_FunctionName,ElScript.CPlusPlus_FunctionName)"]

See Also

CPlusPlus_FunctionName Class
ElScript Namespace


CPlusPlus_FunctionName Properties

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName Properties
CPlusPlus_FunctionName Class See Also Send Feedback

The CPlusPlus_FunctionName type exposes the following members.

Properties

 | Name | Description
Public property | Item(UInt32) | (Inherited from STRING.)
Public property | Item(Int32) | (Inherited from STRING.)
Public property | Length | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
ElScript Namespace


Item Property

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_FunctionName..::..Item Property
CPlusPlus_FunctionName Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item(UInt32) | (Inherited from STRING.)
Public property | Item(Int32) | (Inherited from STRING.)

See Also

CPlusPlus_FunctionName Class
CPlusPlus_FunctionName Members
ElScript Namespace


CPlusPlus_VariableDefinition Class

[image]

4 of William Foster's Class Libraries
CPlusPlus_VariableDefinition Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.CPlusPlus_VariableDefinition"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CPlusPlus_VariableDefinition : CPlusPlus_Argument
Visual Basic
Public Class CPlusPlus_VariableDefinition _
    Inherits CPlusPlus_Argument
Visual C++
public ref class CPlusPlus_VariableDefinition : public CPlusPlus_Argument

Inheritance Hierarchy

System..::..Object
ElScript..::..CPlusPlus_Argument
ElScript..::..CPlusPlus_VariableDefinition

See Also

CPlusPlus_VariableDefinition Members
ElScript Namespace


CPlusPlus_VariableDefinition Members

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_VariableDefinition Members
CPlusPlus_VariableDefinition Class Constructors Methods Fields See Also Send Feedback

The CPlusPlus_VariableDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | CPlusPlus_VariableDefinition | Initializes a new instance of the CPlusPlus_VariableDefinition class

Methods

 | Name | Description
Protected method | Empty | (Inherited from CPlusPlus_Argument.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set | (Inherited from CPlusPlus_Argument.)
Public method | SetFromString | (Inherited from CPlusPlus_Argument.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_b_const | (Inherited from CPlusPlus_Argument.)
Public field | m_b_pointer | (Inherited from CPlusPlus_Argument.)
Public field | m_b_reference | (Inherited from CPlusPlus_Argument.)
Public field | m_b_volatile | (Inherited from CPlusPlus_Argument.)
Public field | m_cs_ArgumentName | (Inherited from CPlusPlus_Argument.)
Public field | m_cs_DefaultValue | (Inherited from CPlusPlus_Argument.)
Public field | m_cs_Type | (Inherited from CPlusPlus_Argument.)

See Also

CPlusPlus_VariableDefinition Class
ElScript Namespace


CPlusPlus_VariableDefinition Constructor

[image]

4 of William Foster's Class Libraries
CPlusPlus_VariableDefinition Constructor
CPlusPlus_VariableDefinition Class See Also Send Feedback
Initializes a new instance of the CPlusPlus_VariableDefinition class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CPlusPlus_VariableDefinition()
Visual Basic
Public Sub New
Visual C++
public:
CPlusPlus_VariableDefinition()

See Also

CPlusPlus_VariableDefinition Class
ElScript Namespace


CPlusPlus_VariableDefinition Fields

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_VariableDefinition Fields
CPlusPlus_VariableDefinition Class See Also Send Feedback

The CPlusPlus_VariableDefinition type exposes the following members.

Fields

 | Name | Description
Public field | m_b_const | (Inherited from CPlusPlus_Argument.)
Public field | m_b_pointer | (Inherited from CPlusPlus_Argument.)
Public field | m_b_reference | (Inherited from CPlusPlus_Argument.)
Public field | m_b_volatile | (Inherited from CPlusPlus_Argument.)
Public field | m_cs_ArgumentName | (Inherited from CPlusPlus_Argument.)
Public field | m_cs_DefaultValue | (Inherited from CPlusPlus_Argument.)
Public field | m_cs_Type | (Inherited from CPlusPlus_Argument.)

See Also

CPlusPlus_VariableDefinition Class
ElScript Namespace


CPlusPlus_VariableDefinition Methods

[image] [image]

4 of William Foster's Class Libraries
CPlusPlus_VariableDefinition Methods
CPlusPlus_VariableDefinition Class See Also Send Feedback

The CPlusPlus_VariableDefinition type exposes the following members.

Methods

 | Name | Description
Protected method | Empty | (Inherited from CPlusPlus_Argument.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set | (Inherited from CPlusPlus_Argument.)
Public method | SetFromString | (Inherited from CPlusPlus_Argument.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CPlusPlus_VariableDefinition Class
ElScript Namespace


E_CPLUSPLUS_SCOPE Enumeration

[image]

4 of William Foster's Class Libraries
E_CPLUSPLUS_SCOPE Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.E_CPLUSPLUS_SCOPE"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum E_CPLUSPLUS_SCOPE
Visual Basic
Public Enumeration E_CPLUSPLUS_SCOPE
Visual C++
public enum class E_CPLUSPLUS_SCOPE

Members

Member name | Value | Description
E_CPPS_PRIVATE | 0 |
E_CPPS_PROTECTED | 1 |
E_CPPS_PUBLIC | 2 |

See Also

ElScript Namespace


IEquat_User Interface

[image]

4 of William Foster's Class Libraries
IEquat_User Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.IEquat_User"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IEquat_User
Visual Basic
Public Interface IEquat_User
Visual C++
public interface class IEquat_User

See Also

IEquat_User Members
ElScript Namespace


IEquat_User Members

[image] [image]

4 of William Foster's Class Libraries
IEquat_User Members
IEquat_User Interface Methods See Also Send Feedback

The IEquat_User type exposes the following members.

Methods

 | Name | Description
Public method | isvar |
Public method | myfunct |

See Also

IEquat_User Interface
ElScript Namespace


IEquat_User Methods

[image] [image]

4 of William Foster's Class Libraries
IEquat_User Methods
IEquat_User Interface See Also Send Feedback

The IEquat_User type exposes the following members.

Methods

 | Name | Description
Public method | isvar |
Public method | myfunct |

See Also

IEquat_User Interface
ElScript Namespace


isvar Method

[image]

4 of William Foster's Class Libraries
IEquat_User..::..isvar Method
IEquat_User Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.IEquat_User.isvar(System.Char[],System.Int32)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
double isvar(
    char[] e,
    int c
)
Visual Basic
Function isvar ( _
    e As Char(), _
    c As Integer _
) As Double
Visual C++
double isvar(
    array<wchar_t>^ e,
    int c
)

Parameters

e
Type: array< System..::..Char >[]()[][]

[Missing <param name="e"/> documentation for "M:ElScript.IEquat_User.isvar(System.Char[],System.Int32)"]

c
Type: System..::..Int32

[Missing <param name="c"/> documentation for "M:ElScript.IEquat_User.isvar(System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElScript.IEquat_User.isvar(System.Char[],System.Int32)"]

See Also

IEquat_User Interface
ElScript Namespace


myfunct Method

[image]

4 of William Foster's Class Libraries
IEquat_User..::..myfunct Method
IEquat_User Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.IEquat_User.myfunct(El.STRING,System.Char[],System.Int32)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
double myfunct(
    STRING func_name,
    char[] e,
    int i
)
Visual Basic
Function myfunct ( _
    func_name As STRING, _
    e As Char(), _
    i As Integer _
) As Double
Visual C++
double myfunct(
    STRING^ func_name,
    array<wchar_t>^ e,
    int i
)

Parameters

func_name
Type: STRING

[Missing <param name="func_name"/> documentation for "M:ElScript.IEquat_User.myfunct(El.STRING,System.Char[],System.Int32)"]

e
Type: array< System..::..Char >[]()[][]

[Missing <param name="e"/> documentation for "M:ElScript.IEquat_User.myfunct(El.STRING,System.Char[],System.Int32)"]

i
Type: System..::..Int32

[Missing <param name="i"/> documentation for "M:ElScript.IEquat_User.myfunct(El.STRING,System.Char[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElScript.IEquat_User.myfunct(El.STRING,System.Char[],System.Int32)"]

See Also

IEquat_User Interface
ElScript Namespace


IPhrase_Reader Interface

[image]

4 of William Foster's Class Libraries
IPhrase_Reader Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.IPhrase_Reader"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IPhrase_Reader
Visual Basic
Public Interface IPhrase_Reader
Visual C++
public interface class IPhrase_Reader

See Also

IPhrase_Reader Members
ElScript Namespace


IPhrase_Reader Members

[image] [image]

4 of William Foster's Class Libraries
IPhrase_Reader Members
IPhrase_Reader Interface Methods See Also Send Feedback

The IPhrase_Reader type exposes the following members.

Methods

 | Name | Description
Public method | BufferNextLine |

See Also

IPhrase_Reader Interface
ElScript Namespace


IPhrase_Reader Methods

[image] [image]

4 of William Foster's Class Libraries
IPhrase_Reader Methods
IPhrase_Reader Interface See Also Send Feedback

The IPhrase_Reader type exposes the following members.

Methods

 | Name | Description
Public method | BufferNextLine |

See Also

IPhrase_Reader Interface
ElScript Namespace


BufferNextLine Method

[image]

4 of William Foster's Class Libraries
IPhrase_Reader..::..BufferNextLine Method
IPhrase_Reader Interface See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.IPhrase_Reader.BufferNextLine"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
bool BufferNextLine()
Visual Basic
Function BufferNextLine As Boolean
Visual C++
bool BufferNextLine()

Return Value

[Missing <returns> documentation for "M:ElScript.IPhrase_Reader.BufferNextLine"]

See Also

IPhrase_Reader Interface
ElScript Namespace


ParseIncludes Class

[image]

4 of William Foster's Class Libraries
ParseIncludes Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.ParseIncludes"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ParseIncludes
Visual Basic
Public Class ParseIncludes
Visual C++
public ref class ParseIncludes

Inheritance Hierarchy

System..::..Object
ElScript..::..ParseIncludes

See Also

ParseIncludes Members
ElScript Namespace


ParseIncludes Members

[image] [image]

4 of William Foster's Class Libraries
ParseIncludes Members
ParseIncludes Class Constructors Methods See Also Send Feedback

The ParseIncludes type exposes the following members.

Constructors

 | Name | Description
Public method | ParseIncludes()()()() | Initializes a new instance of the ParseIncludes class
Public method | ParseIncludes(STRING, STRING) | Initializes a new instance of the ParseIncludes class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateFile |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseIncludes Class
ElScript Namespace


ParseIncludes Constructor

[image] [image]

4 of William Foster's Class Libraries
ParseIncludes Constructor
ParseIncludes Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParseIncludes()()()() | Initializes a new instance of the ParseIncludes class
Public method | ParseIncludes(STRING, STRING) | Initializes a new instance of the ParseIncludes class

See Also

ParseIncludes Class
ParseIncludes Members
ElScript Namespace


ParseIncludes Constructor

[image]

4 of William Foster's Class Libraries
ParseIncludes Constructor
ParseIncludes Class See Also Send Feedback
Initializes a new instance of the ParseIncludes class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ParseIncludes()
Visual Basic
Public Sub New
Visual C++
public:
ParseIncludes()

See Also

ParseIncludes Class
ParseIncludes Overload
ElScript Namespace


ParseIncludes Constructor (, )

[image]

4 of William Foster's Class Libraries
ParseIncludes Constructor (, )
ParseIncludes Class See Also Send Feedback
Initializes a new instance of the ParseIncludes class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ParseIncludes(
    STRING includePath,
    STRING csSkipIncludes
)
Visual Basic
Public Sub New ( _
    includePath As STRING, _
    csSkipIncludes As STRING _
)
Visual C++
public:
ParseIncludes(
    STRING^ includePath,
    STRING^ csSkipIncludes
)

Parameters

includePath
Type: STRING

[Missing <param name="includePath"/> documentation for "M:ElScript.ParseIncludes.#ctor(El.STRING,El.STRING)"]

csSkipIncludes
Type: STRING

[Missing <param name="csSkipIncludes"/> documentation for "M:ElScript.ParseIncludes.#ctor(El.STRING,El.STRING)"]

See Also

ParseIncludes Class
ParseIncludes Overload
ElScript Namespace


ParseIncludes Methods

[image] [image]

4 of William Foster's Class Libraries
ParseIncludes Methods
ParseIncludes Class See Also Send Feedback

The ParseIncludes type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateFile |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParseIncludes Class
ElScript Namespace


LocateFile Method

[image]

4 of William Foster's Class Libraries
ParseIncludes..::..LocateFile Method
ParseIncludes Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.ParseIncludes.LocateFile(El.Filename,El.Filename@,El.Filename)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int LocateFile(
    Filename fnLocate,
    out Filename out_fullPath,
    Filename curdir
)
Visual Basic
Public Function LocateFile ( _
    fnLocate As Filename, _
    <OutAttribute> ByRef out_fullPath As Filename, _
    curdir As Filename _
) As Integer
Visual C++
public:
int LocateFile(
    Filename^ fnLocate,
    [OutAttribute] Filename^% out_fullPath,
    Filename^ curdir
)

Parameters

fnLocate
Type: Filename

[Missing <param name="fnLocate"/> documentation for "M:ElScript.ParseIncludes.LocateFile(El.Filename,El.Filename@,El.Filename)"]

out_fullPath
Type: Filename%

[Missing <param name="out_fullPath"/> documentation for "M:ElScript.ParseIncludes.LocateFile(El.Filename,El.Filename@,El.Filename)"]

curdir
Type: Filename

[Missing <param name="curdir"/> documentation for "M:ElScript.ParseIncludes.LocateFile(El.Filename,El.Filename@,El.Filename)"]

Return Value

[Missing <returns> documentation for "M:ElScript.ParseIncludes.LocateFile(El.Filename,El.Filename@,El.Filename)"]

See Also

ParseIncludes Class
ElScript Namespace


Phrase Class

[image]

4 of William Foster's Class Libraries
Phrase Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Phrase"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Phrase : StringBuffer
Visual Basic
Public Class Phrase _
    Inherits StringBuffer
Visual C++
public ref class Phrase : public StringBuffer

Inheritance Hierarchy

System..::..Object
STRING
StringBuffer
ElScript..::..Phrase

See Also

Phrase Members
ElScript Namespace


Phrase Members

[image] [image]

4 of William Foster's Class Libraries
Phrase Members
Phrase Class Constructors Methods Fields Properties See Also Send Feedback

The Phrase type exposes the following members.

Constructors

 | Name | Description
Public method | Phrase()()()() | Initializes a new instance of the Phrase class
Public method | Phrase(STRING) | Initializes a new instance of the Phrase class
Public method | Phrase(IPhrase_Reader) | Initializes a new instance of the Phrase class
Public method | Phrase(Phrase) | Initializes a new instance of the Phrase class

Methods

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)
Protected method | Changed |
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Empty | (Overrides STRINGEmpty()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)
Public method | FindOneOf | (Inherited from STRING.)
Public method | FormatV | (Inherited from STRING.)
Public method | GetAsString | (Inherited from STRING.)
Public method | GetAt | (Inherited from STRING.)
Public method | GetBytePtr | (Inherited from STRING.)
Public method | GetDefaultDeliminators |
Public method | GetEnumerator | (Inherited from STRING.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex |
Public method | GetLength | (Inherited from STRING.)
Public method | GetLengthBytes | (Inherited from STRING.)
Public method | GetPtr | (Inherited from STRING.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment_BufPtr |
Public method | InsertAt | (Inherited from STRING.)
 | InterpretCharacter |
Public method | IsEmpty | (Inherited from STRING.)
Public method | IsEOL |
Public method | isletter |
Public method | Left | (Inherited from STRING.)
Public method | LeftEquals | (Inherited from STRING.)
Public method | LeftFrom | (Inherited from STRING.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid | (Inherited from STRING.)
Public method | More |
Protected method | NextIsDeliminator |
Public method | ParseLines | (Inherited from STRING.)
Public method | ReadAheadScriptCharacter |
Public method | ReadAheadScriptWord(String%) |
Public method | ReadAheadScriptWord(String%, Char) |
Public method | ReadAheadScriptWord(String%, String) |
Public method | ReadScriptLetters |
Public method | ReadScriptWord(String%) |
Public method | ReadScriptWord(String%, Char) |
Public method | ReadScriptWord(String%, String) |
Protected method | ReadScriptWordInternal |
Protected method | ReadScriptWordInternal_Internal |
Public method | Remainder |
Public method | RemoveAt | (Inherited from STRING.)
Public method | RemoveQuotes | (Inherited from STRING.)
Public method | RemoveWhitespace | (Inherited from STRING.)
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)
Public method | Reset |
Public method | ReverseFind | (Inherited from STRING.)
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)
Public method | RightFrom | (Inherited from STRING.)
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)
Public method | Set(STRING) |
Public method | SetAt | (Inherited from STRING.)
Public method | SetDeliminators |
Public method | SetLength | (Inherited from STRING.)
Public method | SkipDeliminator |
Public method | SkipDeliminators |
Public method | SkipScriptCharacter |
Public method | SkipScriptWord()()()() |
Public method | SkipScriptWord(Char) |
Public method | SkipScriptWord(String) |
Public method | SkipToDeliminator |
Public method | SkipToNonLetter |
Public method | SkipWhiteSpace |
Public method | SpanExcluding | (Inherited from STRING.)
Public method | Substitute | (Inherited from STRING.)
Public method | Terminate | (Inherited from STRING.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase | (Inherited from STRING.)
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

Fields

 | Name | Description
Protected field | m_bEOL |
Protected field | m_cs | (Inherited from STRING.)
Protected field | m_csDeliminators |
Public field | m_DelimTriggerChar |
Protected field | m_iCurrentIndex |
Protected field | m_Reader |

Properties

 | Name | Description
Public property | Item(UInt32) | (Inherited from STRING.)
Public property | Item(Int32) | (Inherited from STRING.)
Public property | Length | (Inherited from STRING.)

See Also

Phrase Class
ElScript Namespace


Phrase Constructor

[image] [image]

4 of William Foster's Class Libraries
Phrase Constructor
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Phrase()()()() | Initializes a new instance of the Phrase class
Public method | Phrase(STRING) | Initializes a new instance of the Phrase class
Public method | Phrase(IPhrase_Reader) | Initializes a new instance of the Phrase class
Public method | Phrase(Phrase) | Initializes a new instance of the Phrase class

See Also

Phrase Class
Phrase Members
ElScript Namespace


Phrase Constructor

[image]

4 of William Foster's Class Libraries
Phrase Constructor
Phrase Class See Also Send Feedback
Initializes a new instance of the Phrase class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Phrase()
Visual Basic
Public Sub New
Visual C++
public:
Phrase()

See Also

Phrase Class
Phrase Overload
ElScript Namespace


Phrase Constructor ()

[image]

4 of William Foster's Class Libraries
Phrase Constructor ()
Phrase Class See Also Send Feedback
Initializes a new instance of the Phrase class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Phrase(
    STRING cs
)
Visual Basic
Public Sub New ( _
    cs As STRING _
)
Visual C++
public:
Phrase(
    STRING^ cs
)

Parameters

cs
Type: STRING

[Missing <param name="cs"/> documentation for "M:ElScript.Phrase.#ctor(El.STRING)"]

See Also

Phrase Class
Phrase Overload
ElScript Namespace


Phrase Constructor (IPhrase_Reader)

[image]

4 of William Foster's Class Libraries
Phrase Constructor (IPhrase_Reader)
Phrase Class See Also Send Feedback
Initializes a new instance of the Phrase class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Phrase(
    IPhrase_Reader reader
)
Visual Basic
Public Sub New ( _
    reader As IPhrase_Reader _
)
Visual C++
public:
Phrase(
    IPhrase_Reader^ reader
)

Parameters

reader
Type: ElScript..::..IPhrase_Reader

[Missing <param name="reader"/> documentation for "M:ElScript.Phrase.#ctor(ElScript.IPhrase_Reader)"]

See Also

Phrase Class
Phrase Overload
ElScript Namespace


Phrase Constructor (Phrase)

[image]

4 of William Foster's Class Libraries
Phrase Constructor (Phrase)
Phrase Class See Also Send Feedback
Initializes a new instance of the Phrase class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Phrase(
    Phrase ph
)
Visual Basic
Public Sub New ( _
    ph As Phrase _
)
Visual C++
public:
Phrase(
    Phrase^ ph
)

Parameters

ph
Type: ElScript..::..Phrase

[Missing <param name="ph"/> documentation for "M:ElScript.Phrase.#ctor(ElScript.Phrase)"]

See Also

Phrase Class
Phrase Overload
ElScript Namespace


Phrase Fields

[image] [image]

4 of William Foster's Class Libraries
Phrase Fields
Phrase Class See Also Send Feedback

The Phrase type exposes the following members.

Fields

 | Name | Description
Protected field | m_bEOL |
Protected field | m_cs | (Inherited from STRING.)
Protected field | m_csDeliminators |
Public field | m_DelimTriggerChar |
Protected field | m_iCurrentIndex |
Protected field | m_Reader |

See Also

Phrase Class
ElScript Namespace


m_bEOL Field

[image]

4 of William Foster's Class Libraries
Phrase..::..m_bEOL Field
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Phrase.m_bEOL"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool m_bEOL
Visual Basic
Protected m_bEOL As Boolean
Visual C++
protected:
bool m_bEOL

See Also

Phrase Class
ElScript Namespace


m_csDeliminators Field

[image]

4 of William Foster's Class Libraries
Phrase..::..m_csDeliminators Field
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Phrase.m_csDeliminators"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected STRING m_csDeliminators
Visual Basic
Protected m_csDeliminators As STRING
Visual C++
protected:
STRING^ m_csDeliminators

See Also

Phrase Class
ElScript Namespace


m_DelimTriggerChar Field

[image]

4 of William Foster's Class Libraries
Phrase..::..m_DelimTriggerChar Field
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Phrase.m_DelimTriggerChar"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public char m_DelimTriggerChar
Visual Basic
Public m_DelimTriggerChar As Char
Visual C++
public:
wchar_t m_DelimTriggerChar

See Also

Phrase Class
ElScript Namespace


m_iCurrentIndex Field

[image]

4 of William Foster's Class Libraries
Phrase..::..m_iCurrentIndex Field
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Phrase.m_iCurrentIndex"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int m_iCurrentIndex
Visual Basic
Protected m_iCurrentIndex As Integer
Visual C++
protected:
int m_iCurrentIndex

See Also

Phrase Class
ElScript Namespace


m_Reader Field

[image]

4 of William Foster's Class Libraries
Phrase..::..m_Reader Field
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Phrase.m_Reader"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected IPhrase_Reader m_Reader
Visual Basic
Protected m_Reader As IPhrase_Reader
Visual C++
protected:
IPhrase_Reader^ m_Reader

See Also

Phrase Class
ElScript Namespace


Phrase Methods

[image] [image]

4 of William Foster's Class Libraries
Phrase Methods
Phrase Class See Also Send Feedback

The Phrase type exposes the following members.

Methods

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)
Protected method | Changed |
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Empty | (Overrides STRINGEmpty()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)
Public method | FindOneOf | (Inherited from STRING.)
Public method | FormatV | (Inherited from STRING.)
Public method | GetAsString | (Inherited from STRING.)
Public method | GetAt | (Inherited from STRING.)
Public method | GetBytePtr | (Inherited from STRING.)
Public method | GetDefaultDeliminators |
Public method | GetEnumerator | (Inherited from STRING.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndex |
Public method | GetLength | (Inherited from STRING.)
Public method | GetLengthBytes | (Inherited from STRING.)
Public method | GetPtr | (Inherited from STRING.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment_BufPtr |
Public method | InsertAt | (Inherited from STRING.)
 | InterpretCharacter |
Public method | IsEmpty | (Inherited from STRING.)
Public method | IsEOL |
Public method | isletter |
Public method | Left | (Inherited from STRING.)
Public method | LeftEquals | (Inherited from STRING.)
Public method | LeftFrom | (Inherited from STRING.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mid | (Inherited from STRING.)
Public method | More |
Protected method | NextIsDeliminator |
Public method | ParseLines | (Inherited from STRING.)
Public method | ReadAheadScriptCharacter |
Public method | ReadAheadScriptWord(String%) |
Public method | ReadAheadScriptWord(String%, Char) |
Public method | ReadAheadScriptWord(String%, String) |
Public method | ReadScriptLetters |
Public method | ReadScriptWord(String%) |
Public method | ReadScriptWord(String%, Char) |
Public method | ReadScriptWord(String%, String) |
Protected method | ReadScriptWordInternal |
Protected method | ReadScriptWordInternal_Internal |
Public method | Remainder |
Public method | RemoveAt | (Inherited from STRING.)
Public method | RemoveQuotes | (Inherited from STRING.)
Public method | RemoveWhitespace | (Inherited from STRING.)
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)
Public method | Reset |
Public method | ReverseFind | (Inherited from STRING.)
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)
Public method | RightFrom | (Inherited from STRING.)
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)
Public method | Set(STRING) |
Public method | SetAt | (Inherited from STRING.)
Public method | SetDeliminators |
Public method | SetLength | (Inherited from STRING.)
Public method | SkipDeliminator |
Public method | SkipDeliminators |
Public method | SkipScriptCharacter |
Public method | SkipScriptWord()()()() |
Public method | SkipScriptWord(Char) |
Public method | SkipScriptWord(String) |
Public method | SkipToDeliminator |
Public method | SkipToNonLetter |
Public method | SkipWhiteSpace |
Public method | SpanExcluding | (Inherited from STRING.)
Public method | Substitute | (Inherited from STRING.)
Public method | Terminate | (Inherited from STRING.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUpperCase | (Inherited from STRING.)
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

See Also

Phrase Class
ElScript Namespace


Append Method

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..Append Method
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Append(Char) | (Inherited from STRING.)
Public method | Append(String) | (Inherited from STRING.)

See Also

Phrase Class
Phrase Members
ElScript Namespace


Changed Method

[image]

4 of William Foster's Class Libraries
Phrase..::..Changed Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.Changed"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void Changed()
Visual Basic
Protected Sub Changed
Visual C++
protected:
void Changed()

See Also

Phrase Class
ElScript Namespace


Compare Method

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..Compare Method
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Compare(STRING) | (Inherited from STRING.)
Public method | Compare(array<Char>[]()[][], UInt32) | (Inherited from STRING.)
Public method | Compare(STRING, Boolean) | (Inherited from STRING.)

See Also

Phrase Class
Phrase Members
ElScript Namespace


CompareNoCase Method

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..CompareNoCase Method
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareNoCase(STRING) | (Inherited from STRING.)
Public method | CompareNoCase(array<Char>[]()[][], UInt32) | (Inherited from STRING.)

See Also

Phrase Class
Phrase Members
ElScript Namespace


Empty Method

[image]

4 of William Foster's Class Libraries
Phrase..::..Empty Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.Empty"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void Empty()
Visual Basic
Public Overrides Sub Empty
Visual C++
public:
virtual void Empty() override

See Also

Phrase Class
ElScript Namespace


Find Method

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..Find Method
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Find(Char) | (Inherited from STRING.)
Public method | Find(Char, UInt32) | (Inherited from STRING.)
Public method | Find(STRING, UInt32) | (Inherited from STRING.)
Public method | Find(Char, UInt32, Boolean) | (Inherited from STRING.)
Public method | Find(STRING, UInt32, Boolean, Boolean) | (Inherited from STRING.)

See Also

Phrase Class
Phrase Members
ElScript Namespace


GetDefaultDeliminators Method

[image]

4 of William Foster's Class Libraries
Phrase..::..GetDefaultDeliminators Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.GetDefaultDeliminators"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string GetDefaultDeliminators()
Visual Basic
Public Function GetDefaultDeliminators As String
Visual C++
public:
String^ GetDefaultDeliminators()

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.GetDefaultDeliminators"]

See Also

Phrase Class
ElScript Namespace


GetIndex Method

[image]

4 of William Foster's Class Libraries
Phrase..::..GetIndex Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.GetIndex"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int GetIndex()
Visual Basic
Public Function GetIndex As Integer
Visual C++
public:
int GetIndex()

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.GetIndex"]

See Also

Phrase Class
ElScript Namespace


Increment_BufPtr Method

[image]

4 of William Foster's Class Libraries
Phrase..::..Increment_BufPtr Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.Increment_BufPtr"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Increment_BufPtr()
Visual Basic
Public Sub Increment_BufPtr
Visual C++
public:
void Increment_BufPtr()

See Also

Phrase Class
ElScript Namespace


InterpretCharacter Method

[image]

4 of William Foster's Class Libraries
Phrase..::..InterpretCharacter Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.InterpretCharacter(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static char InterpretCharacter(
    STRING csCharRep
)
Visual Basic
Public Shared Function InterpretCharacter ( _
    csCharRep As STRING _
) As Char
Visual C++
public:
static wchar_t InterpretCharacter(
    STRING^ csCharRep
)

Parameters

csCharRep
Type: STRING

[Missing <param name="csCharRep"/> documentation for "M:ElScript.Phrase.InterpretCharacter(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.InterpretCharacter(El.STRING)"]

See Also

Phrase Class
ElScript Namespace


IsEOL Method

[image]

4 of William Foster's Class Libraries
Phrase..::..IsEOL Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.IsEOL"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsEOL()
Visual Basic
Public Function IsEOL As Boolean
Visual C++
public:
bool IsEOL()

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.IsEOL"]

See Also

Phrase Class
ElScript Namespace


isletter Method

[image]

4 of William Foster's Class Libraries
Phrase..::..isletter Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.isletter(System.Char)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool isletter(
    char c
)
Visual Basic
Public Function isletter ( _
    c As Char _
) As Boolean
Visual C++
public:
bool isletter(
    wchar_t c
)

Parameters

c
Type: System..::..Char

[Missing <param name="c"/> documentation for "M:ElScript.Phrase.isletter(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.isletter(System.Char)"]

See Also

Phrase Class
ElScript Namespace


More Method

[image]

4 of William Foster's Class Libraries
Phrase..::..More Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.More"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool More()
Visual Basic
Public Function More As Boolean
Visual C++
public:
bool More()

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.More"]

See Also

Phrase Class
ElScript Namespace


NextIsDeliminator Method

[image]

4 of William Foster's Class Libraries
Phrase..::..NextIsDeliminator Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.NextIsDeliminator(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool NextIsDeliminator(
    STRING csDeliminators
)
Visual Basic
Protected Function NextIsDeliminator ( _
    csDeliminators As STRING _
) As Boolean
Visual C++
protected:
bool NextIsDeliminator(
    STRING^ csDeliminators
)

Parameters

csDeliminators
Type: STRING

[Missing <param name="csDeliminators"/> documentation for "M:ElScript.Phrase.NextIsDeliminator(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.NextIsDeliminator(El.STRING)"]

See Also

Phrase Class
ElScript Namespace


ReadAheadScriptCharacter Method

[image]

4 of William Foster's Class Libraries
Phrase..::..ReadAheadScriptCharacter Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.ReadAheadScriptCharacter(System.Char@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadAheadScriptCharacter(
    out char c
)
Visual Basic
Public Function ReadAheadScriptCharacter ( _
    <OutAttribute> ByRef c As Char _
) As Boolean
Visual C++
public:
bool ReadAheadScriptCharacter(
    [OutAttribute] wchar_t% c
)

Parameters

c
Type: System..::..Char %

[Missing <param name="c"/> documentation for "M:ElScript.Phrase.ReadAheadScriptCharacter(System.Char@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.ReadAheadScriptCharacter(System.Char@)"]

See Also

Phrase Class
ElScript Namespace


ReadAheadScriptWord Method

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..ReadAheadScriptWord Method
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadAheadScriptWord(String%) |
Public method | ReadAheadScriptWord(String%, Char) |
Public method | ReadAheadScriptWord(String%, String) |

See Also

Phrase Class
Phrase Members
ElScript Namespace


ReadAheadScriptWord Method (String)

[image]

4 of William Foster's Class Libraries
Phrase..::..ReadAheadScriptWord Method (String%)
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.ReadAheadScriptWord(System.String@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadAheadScriptWord(
    out string s
)
Visual Basic
Public Function ReadAheadScriptWord ( _
    <OutAttribute> ByRef s As String _
) As Boolean
Visual C++
public:
bool ReadAheadScriptWord(
    [OutAttribute] String^% s
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Phrase.ReadAheadScriptWord(System.String@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.ReadAheadScriptWord(System.String@)"]

See Also

Phrase Class
ReadAheadScriptWord Overload
ElScript Namespace


ReadAheadScriptWord Method (String, Char)

[image]

4 of William Foster's Class Libraries
Phrase..::..ReadAheadScriptWord Method (String%, Char)
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.ReadAheadScriptWord(System.String@,System.Char)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadAheadScriptWord(
    out string s,
    char cDeliminator
)
Visual Basic
Public Function ReadAheadScriptWord ( _
    <OutAttribute> ByRef s As String, _
    cDeliminator As Char _
) As Boolean
Visual C++
public:
bool ReadAheadScriptWord(
    [OutAttribute] String^% s,
    wchar_t cDeliminator
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Phrase.ReadAheadScriptWord(System.String@,System.Char)"]

cDeliminator
Type: System..::..Char

[Missing <param name="cDeliminator"/> documentation for "M:ElScript.Phrase.ReadAheadScriptWord(System.String@,System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.ReadAheadScriptWord(System.String@,System.Char)"]

See Also

Phrase Class
ReadAheadScriptWord Overload
ElScript Namespace


ReadAheadScriptWord Method (String, String)

[image]

4 of William Foster's Class Libraries
Phrase..::..ReadAheadScriptWord Method (String%, String)
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.ReadAheadScriptWord(System.String@,System.String)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadAheadScriptWord(
    out string s,
    string csDeliminators
)
Visual Basic
Public Function ReadAheadScriptWord ( _
    <OutAttribute> ByRef s As String, _
    csDeliminators As String _
) As Boolean
Visual C++
public:
bool ReadAheadScriptWord(
    [OutAttribute] String^% s,
    String^ csDeliminators
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Phrase.ReadAheadScriptWord(System.String@,System.String)"]

csDeliminators
Type: System..::..String

[Missing <param name="csDeliminators"/> documentation for "M:ElScript.Phrase.ReadAheadScriptWord(System.String@,System.String)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.ReadAheadScriptWord(System.String@,System.String)"]

See Also

Phrase Class
ReadAheadScriptWord Overload
ElScript Namespace


ReadScriptLetters Method

[image]

4 of William Foster's Class Libraries
Phrase..::..ReadScriptLetters Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.ReadScriptLetters(System.String@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScriptLetters(
    out string s
)
Visual Basic
Public Function ReadScriptLetters ( _
    <OutAttribute> ByRef s As String _
) As Boolean
Visual C++
public:
bool ReadScriptLetters(
    [OutAttribute] String^% s
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Phrase.ReadScriptLetters(System.String@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.ReadScriptLetters(System.String@)"]

See Also

Phrase Class
ElScript Namespace


ReadScriptWord Method

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..ReadScriptWord Method
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadScriptWord(String%) |
Public method | ReadScriptWord(String%, Char) |
Public method | ReadScriptWord(String%, String) |

See Also

Phrase Class
Phrase Members
ElScript Namespace


ReadScriptWord Method (String)

[image]

4 of William Foster's Class Libraries
Phrase..::..ReadScriptWord Method (String%)
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.ReadScriptWord(System.String@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScriptWord(
    out string s
)
Visual Basic
Public Function ReadScriptWord ( _
    <OutAttribute> ByRef s As String _
) As Boolean
Visual C++
public:
bool ReadScriptWord(
    [OutAttribute] String^% s
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Phrase.ReadScriptWord(System.String@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.ReadScriptWord(System.String@)"]

See Also

Phrase Class
ReadScriptWord Overload
ElScript Namespace


ReadScriptWord Method (String, Char)

[image]

4 of William Foster's Class Libraries
Phrase..::..ReadScriptWord Method (String%, Char)
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.ReadScriptWord(System.String@,System.Char)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScriptWord(
    out string s,
    char cDeliminator
)
Visual Basic
Public Function ReadScriptWord ( _
    <OutAttribute> ByRef s As String, _
    cDeliminator As Char _
) As Boolean
Visual C++
public:
bool ReadScriptWord(
    [OutAttribute] String^% s,
    wchar_t cDeliminator
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Phrase.ReadScriptWord(System.String@,System.Char)"]

cDeliminator
Type: System..::..Char

[Missing <param name="cDeliminator"/> documentation for "M:ElScript.Phrase.ReadScriptWord(System.String@,System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.ReadScriptWord(System.String@,System.Char)"]

See Also

Phrase Class
ReadScriptWord Overload
ElScript Namespace


ReadScriptWord Method (String, String)

[image]

4 of William Foster's Class Libraries
Phrase..::..ReadScriptWord Method (String%, String)
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.ReadScriptWord(System.String@,System.String)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScriptWord(
    out string s,
    string csDeliminators
)
Visual Basic
Public Function ReadScriptWord ( _
    <OutAttribute> ByRef s As String, _
    csDeliminators As String _
) As Boolean
Visual C++
public:
bool ReadScriptWord(
    [OutAttribute] String^% s,
    String^ csDeliminators
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Phrase.ReadScriptWord(System.String@,System.String)"]

csDeliminators
Type: System..::..String

[Missing <param name="csDeliminators"/> documentation for "M:ElScript.Phrase.ReadScriptWord(System.String@,System.String)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.ReadScriptWord(System.String@,System.String)"]

See Also

Phrase Class
ReadScriptWord Overload
ElScript Namespace


ReadScriptWordInternal Method

[image]

4 of William Foster's Class Libraries
Phrase..::..ReadScriptWordInternal Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.ReadScriptWordInternal(System.String@,System.String,System.Boolean)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool ReadScriptWordInternal(
    out string sOut,
    string csDeliminators,
    bool bReadAhead
)
Visual Basic
Protected Function ReadScriptWordInternal ( _
    <OutAttribute> ByRef sOut As String, _
    csDeliminators As String, _
    bReadAhead As Boolean _
) As Boolean
Visual C++
protected:
bool ReadScriptWordInternal(
    [OutAttribute] String^% sOut,
    String^ csDeliminators,
    bool bReadAhead
)

Parameters

sOut
Type: System..::..String %

[Missing <param name="sOut"/> documentation for "M:ElScript.Phrase.ReadScriptWordInternal(System.String@,System.String,System.Boolean)"]

csDeliminators
Type: System..::..String

[Missing <param name="csDeliminators"/> documentation for "M:ElScript.Phrase.ReadScriptWordInternal(System.String@,System.String,System.Boolean)"]

bReadAhead
Type: System..::..Boolean

[Missing <param name="bReadAhead"/> documentation for "M:ElScript.Phrase.ReadScriptWordInternal(System.String@,System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.ReadScriptWordInternal(System.String@,System.String,System.Boolean)"]

See Also

Phrase Class
ElScript Namespace


ReadScriptWordInternal_Internal Method

[image]

4 of William Foster's Class Libraries
Phrase..::..ReadScriptWordInternal_Internal Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.ReadScriptWordInternal_Internal(System.String@,System.String,System.Boolean)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool ReadScriptWordInternal_Internal(
    out string sOut,
    string csDeliminators,
    bool bReadAhead
)
Visual Basic
Protected Function ReadScriptWordInternal_Internal ( _
    <OutAttribute> ByRef sOut As String, _
    csDeliminators As String, _
    bReadAhead As Boolean _
) As Boolean
Visual C++
protected:
bool ReadScriptWordInternal_Internal(
    [OutAttribute] String^% sOut,
    String^ csDeliminators,
    bool bReadAhead
)

Parameters

sOut
Type: System..::..String %

[Missing <param name="sOut"/> documentation for "M:ElScript.Phrase.ReadScriptWordInternal_Internal(System.String@,System.String,System.Boolean)"]

csDeliminators
Type: System..::..String

[Missing <param name="csDeliminators"/> documentation for "M:ElScript.Phrase.ReadScriptWordInternal_Internal(System.String@,System.String,System.Boolean)"]

bReadAhead
Type: System..::..Boolean

[Missing <param name="bReadAhead"/> documentation for "M:ElScript.Phrase.ReadScriptWordInternal_Internal(System.String@,System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.ReadScriptWordInternal_Internal(System.String@,System.String,System.Boolean)"]

See Also

Phrase Class
ElScript Namespace


Remainder Method

[image]

4 of William Foster's Class Libraries
Phrase..::..Remainder Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.Remainder"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public STRING Remainder()
Visual Basic
Public Function Remainder As STRING
Visual C++
public:
STRING^ Remainder()

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.Remainder"]

See Also

Phrase Class
ElScript Namespace


Replace Method

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..Replace Method
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Replace(STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, STRING, STRING) | (Inherited from STRING.)
Public method | Replace(UInt32, UInt32, STRING) | (Inherited from STRING.)

See Also

Phrase Class
Phrase Members
ElScript Namespace


Reset Method

[image]

4 of William Foster's Class Libraries
Phrase..::..Reset Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.Reset"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

Phrase Class
ElScript Namespace


Right Method

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..Right Method
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Right()()()() | (Inherited from STRING.)
Public method | Right(UInt32) | (Inherited from STRING.)

See Also

Phrase Class
Phrase Members
ElScript Namespace


Set Method

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..Set Method
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(array<Byte>[]()[][]) | (Inherited from STRING.)
Public method | Set(String) | (Inherited from STRING.)
Public method | Set(STRING) |

See Also

Phrase Class
Phrase Members
ElScript Namespace


Set Method ()

[image]

4 of William Foster's Class Libraries
Phrase..::..Set Method ()
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.Set(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    STRING cs
)
Visual Basic
Public Sub Set ( _
    cs As STRING _
)
Visual C++
public:
void Set(
    STRING^ cs
)

Parameters

cs
Type: STRING

[Missing <param name="cs"/> documentation for "M:ElScript.Phrase.Set(El.STRING)"]

See Also

Phrase Class
Set Overload
ElScript Namespace


SetDeliminators Method

[image]

4 of William Foster's Class Libraries
Phrase..::..SetDeliminators Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.SetDeliminators(System.String)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetDeliminators(
    string csDeliminators
)
Visual Basic
Public Sub SetDeliminators ( _
    csDeliminators As String _
)
Visual C++
public:
void SetDeliminators(
    String^ csDeliminators
)

Parameters

csDeliminators
Type: System..::..String

[Missing <param name="csDeliminators"/> documentation for "M:ElScript.Phrase.SetDeliminators(System.String)"]

See Also

Phrase Class
ElScript Namespace


SkipDeliminator Method

[image]

4 of William Foster's Class Libraries
Phrase..::..SkipDeliminator Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.SkipDeliminator(System.Char)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SkipDeliminator(
    char cDelim
)
Visual Basic
Public Function SkipDeliminator ( _
    cDelim As Char _
) As Boolean
Visual C++
public:
bool SkipDeliminator(
    wchar_t cDelim
)

Parameters

cDelim
Type: System..::..Char

[Missing <param name="cDelim"/> documentation for "M:ElScript.Phrase.SkipDeliminator(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.SkipDeliminator(System.Char)"]

See Also

Phrase Class
ElScript Namespace


SkipDeliminators Method

[image]

4 of William Foster's Class Libraries
Phrase..::..SkipDeliminators Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.SkipDeliminators(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SkipDeliminators(
    STRING csDeliminators
)
Visual Basic
Public Sub SkipDeliminators ( _
    csDeliminators As STRING _
)
Visual C++
public:
void SkipDeliminators(
    STRING^ csDeliminators
)

Parameters

csDeliminators
Type: STRING

[Missing <param name="csDeliminators"/> documentation for "M:ElScript.Phrase.SkipDeliminators(El.STRING)"]

See Also

Phrase Class
ElScript Namespace


SkipScriptCharacter Method

[image]

4 of William Foster's Class Libraries
Phrase..::..SkipScriptCharacter Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.SkipScriptCharacter"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SkipScriptCharacter()
Visual Basic
Public Function SkipScriptCharacter As Boolean
Visual C++
public:
bool SkipScriptCharacter()

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.SkipScriptCharacter"]

See Also

Phrase Class
ElScript Namespace


SkipScriptWord Method

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..SkipScriptWord Method
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SkipScriptWord()()()() |
Public method | SkipScriptWord(Char) |
Public method | SkipScriptWord(String) |

See Also

Phrase Class
Phrase Members
ElScript Namespace


SkipScriptWord Method

[image]

4 of William Foster's Class Libraries
Phrase..::..SkipScriptWord Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.SkipScriptWord"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SkipScriptWord()
Visual Basic
Public Function SkipScriptWord As Boolean
Visual C++
public:
bool SkipScriptWord()

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.SkipScriptWord"]

See Also

Phrase Class
SkipScriptWord Overload
ElScript Namespace


SkipScriptWord Method (Char)

[image]

4 of William Foster's Class Libraries
Phrase..::..SkipScriptWord Method (Char)
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.SkipScriptWord(System.Char)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SkipScriptWord(
    char cDeliminator
)
Visual Basic
Public Function SkipScriptWord ( _
    cDeliminator As Char _
) As Boolean
Visual C++
public:
bool SkipScriptWord(
    wchar_t cDeliminator
)

Parameters

cDeliminator
Type: System..::..Char

[Missing <param name="cDeliminator"/> documentation for "M:ElScript.Phrase.SkipScriptWord(System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.SkipScriptWord(System.Char)"]

See Also

Phrase Class
SkipScriptWord Overload
ElScript Namespace


SkipScriptWord Method (String)

[image]

4 of William Foster's Class Libraries
Phrase..::..SkipScriptWord Method (String)
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.SkipScriptWord(System.String)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SkipScriptWord(
    string csDeliminators
)
Visual Basic
Public Function SkipScriptWord ( _
    csDeliminators As String _
) As Boolean
Visual C++
public:
bool SkipScriptWord(
    String^ csDeliminators
)

Parameters

csDeliminators
Type: System..::..String

[Missing <param name="csDeliminators"/> documentation for "M:ElScript.Phrase.SkipScriptWord(System.String)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Phrase.SkipScriptWord(System.String)"]

See Also

Phrase Class
SkipScriptWord Overload
ElScript Namespace


SkipToDeliminator Method

[image]

4 of William Foster's Class Libraries
Phrase..::..SkipToDeliminator Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.SkipToDeliminator(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SkipToDeliminator(
    STRING csDeliminators
)
Visual Basic
Public Sub SkipToDeliminator ( _
    csDeliminators As STRING _
)
Visual C++
public:
void SkipToDeliminator(
    STRING^ csDeliminators
)

Parameters

csDeliminators
Type: STRING

[Missing <param name="csDeliminators"/> documentation for "M:ElScript.Phrase.SkipToDeliminator(El.STRING)"]

See Also

Phrase Class
ElScript Namespace


SkipToNonLetter Method

[image]

4 of William Foster's Class Libraries
Phrase..::..SkipToNonLetter Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.SkipToNonLetter"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SkipToNonLetter()
Visual Basic
Public Sub SkipToNonLetter
Visual C++
public:
void SkipToNonLetter()

See Also

Phrase Class
ElScript Namespace


SkipWhiteSpace Method

[image]

4 of William Foster's Class Libraries
Phrase..::..SkipWhiteSpace Method
Phrase Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Phrase.SkipWhiteSpace"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SkipWhiteSpace()
Visual Basic
Public Sub SkipWhiteSpace
Visual C++
public:
void SkipWhiteSpace()

See Also

Phrase Class
ElScript Namespace


Trim Method

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..Trim Method
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Trim()()()() | (Inherited from STRING.)
Public method | Trim(UInt32, UInt32) | (Inherited from STRING.)

See Also

Phrase Class
Phrase Members
ElScript Namespace


TrimLeft Method

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..TrimLeft Method
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimLeft()()()() | (Inherited from STRING.)
Public method | TrimLeft(UInt32) | (Inherited from STRING.)
Public method | TrimLeft(STRING) | (Inherited from STRING.)

See Also

Phrase Class
Phrase Members
ElScript Namespace


TrimRight Method

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..TrimRight Method
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrimRight()()()() | (Inherited from STRING.)
Public method | TrimRight(UInt32) | (Inherited from STRING.)

See Also

Phrase Class
Phrase Members
ElScript Namespace


Phrase Properties

[image] [image]

4 of William Foster's Class Libraries
Phrase Properties
Phrase Class See Also Send Feedback

The Phrase type exposes the following members.

Properties

 | Name | Description
Public property | Item(UInt32) | (Inherited from STRING.)
Public property | Item(Int32) | (Inherited from STRING.)
Public property | Length | (Inherited from STRING.)

See Also

Phrase Class
ElScript Namespace


Item Property

[image] [image]

4 of William Foster's Class Libraries
Phrase..::..Item Property
Phrase Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item(UInt32) | (Inherited from STRING.)
Public property | Item(Int32) | (Inherited from STRING.)

See Also

Phrase Class
Phrase Members
ElScript Namespace


Program Class

[image]

4 of William Foster's Class Libraries
Program Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Program"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Program
Visual Basic
Public Class Program
Visual C++
public ref class Program

Inheritance Hierarchy

System..::..Object
ElScript..::..Program

See Also

Program Members
ElScript Namespace


Program Members

[image] [image]

4 of William Foster's Class Libraries
Program Members
Program Class Constructors Methods See Also Send Feedback

The Program type exposes the following members.

Constructors

 | Name | Description
Public method | Program | Initializes a new instance of the Program class

Methods

 | Name | Description
Public method | Assign_Variable |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate_Statement |
Public method | Evaluate_Variable |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Program Class
ElScript Namespace


Program Constructor

[image]

4 of William Foster's Class Libraries
Program Constructor
Program Class See Also Send Feedback
Initializes a new instance of the Program class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Program()
Visual Basic
Public Sub New
Visual C++
public:
Program()

See Also

Program Class
ElScript Namespace


Program Methods

[image] [image]

4 of William Foster's Class Libraries
Program Methods
Program Class See Also Send Feedback

The Program type exposes the following members.

Methods

 | Name | Description
Public method | Assign_Variable |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate_Statement |
Public method | Evaluate_Variable |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Program Class
ElScript Namespace


Assign_Variable Method

[image]

4 of William Foster's Class Libraries
Program..::..Assign_Variable Method
Program Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Program.Assign_Variable(ElScript.Variable,El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Assign_Variable(
    Variable varSrc,
    STRING varName
)
Visual Basic
Public Function Assign_Variable ( _
    varSrc As Variable, _
    varName As STRING _
) As Boolean
Visual C++
public:
bool Assign_Variable(
    Variable^ varSrc,
    STRING^ varName
)

Parameters

varSrc
Type: ElScript..::..Variable

[Missing <param name="varSrc"/> documentation for "M:ElScript.Program.Assign_Variable(ElScript.Variable,El.STRING)"]

varName
Type: STRING

[Missing <param name="varName"/> documentation for "M:ElScript.Program.Assign_Variable(ElScript.Variable,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Program.Assign_Variable(ElScript.Variable,El.STRING)"]

See Also

Program Class
ElScript Namespace


Evaluate_Statement Method

[image]

4 of William Foster's Class Libraries
Program..::..Evaluate_Statement Method
Program Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Program.Evaluate_Statement(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Evaluate_Statement(
    STRING cs
)
Visual Basic
Public Function Evaluate_Statement ( _
    cs As STRING _
) As Boolean
Visual C++
public:
bool Evaluate_Statement(
    STRING^ cs
)

Parameters

cs
Type: STRING

[Missing <param name="cs"/> documentation for "M:ElScript.Program.Evaluate_Statement(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Program.Evaluate_Statement(El.STRING)"]

See Also

Program Class
ElScript Namespace


Evaluate_Variable Method

[image]

4 of William Foster's Class Libraries
Program..::..Evaluate_Variable Method
Program Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Program.Evaluate_Variable(ElScript.Variable@,El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Evaluate_Variable(
    out Variable varDest,
    STRING varName
)
Visual Basic
Public Function Evaluate_Variable ( _
    <OutAttribute> ByRef varDest As Variable, _
    varName As STRING _
) As Boolean
Visual C++
public:
bool Evaluate_Variable(
    [OutAttribute] Variable^% varDest,
    STRING^ varName
)

Parameters

varDest
Type: ElScript..::..Variable %

[Missing <param name="varDest"/> documentation for "M:ElScript.Program.Evaluate_Variable(ElScript.Variable@,El.STRING)"]

varName
Type: STRING

[Missing <param name="varName"/> documentation for "M:ElScript.Program.Evaluate_Variable(ElScript.Variable@,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Program.Evaluate_Variable(ElScript.Variable@,El.STRING)"]

See Also

Program Class
ElScript Namespace


Run Method

[image]

4 of William Foster's Class Libraries
Program..::..Run Method
Program Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Program.Run"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Run()
Visual Basic
Public Function Run As Boolean
Visual C++
public:
bool Run()

Return Value

[Missing <returns> documentation for "M:ElScript.Program.Run"]

See Also

Program Class
ElScript Namespace


Script Class

[image]

4 of William Foster's Class Libraries
Script Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Script"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Script : Script_Text, IPhrase_Reader
Visual Basic
Public Class Script _
    Inherits Script_Text _
    Implements IPhrase_Reader
Visual C++
public ref class Script : public Script_Text,
    IPhrase_Reader

Inheritance Hierarchy

System..::..Object
Stream
ElScript..::..Script_Text
ElScript..::..Script
ElScript..::..Script_XML

See Also

Script Members
ElScript Namespace


Script Members

[image] [image]

4 of William Foster's Class Libraries
Script Members
Script Class Constructors Methods Fields Properties See Also Send Feedback

The Script type exposes the following members.

Constructors

 | Name | Description
Public method | Script()()()() | Initializes a new instance of the Script class
Public method | Script(Stream) | Initializes a new instance of the Script class
Public method | Script(Filename, Boolean) | Initializes a new instance of the Script class

Methods

 | Name | Description
Public method | AppendScript |
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL |
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine |
Protected method | BufferScript |
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor |
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Protected method | Emit |
Public method | Empty |
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache |
Protected method | GetErrorCount |
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount |
Public method | IsAttached | (Inherited from Stream.)
Protected method | LocateMidlineComment |
Public method | MatchScriptKey |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition |
Protected method | NextChar()()()() |
Protected method | NextChar(Int32) |
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character |
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadScript_ArgumentList |
Public method | ReadScript_ArgumentList_2dPair(Size2d%) |
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) |
Public method | ReadScript_BetweenDeliminators |
Public method | ReadScript_Character |
Public method | ReadScriptLine |
Public method | ReadScriptLine_skipcomments |
Public method | ReadScriptPhrase |
Public method | ReadScriptString |
Public method | ReadScriptWord |
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments |
Public method | Reset |
Public method | Rewind | (Overrides Script_Text..::..Rewind()()()().)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator |
Public method | SetSkipComments |
Public method | SetSkipLinefeeds |
Public method | SetSkipWhitespace |
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors |
Protected method | Skip_Bufferchar |
Protected method | SkippingLinefeeds | (Overrides Script_Text..::..SkippingLinefeeds()()()().)
Public method | SkipScript_Character |
Public method | SkipScriptLine |
Public method | SkipScriptWord |
Public method | SyntaxError |
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey |
Public method | TestScriptKey |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment |
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

Fields

 | Name | Description
Protected field | m_bOkAddComments |
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments |
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase |
Protected field | m_saMidlineCommentChars |
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)
 | SCRIPT_KEY_NONE |

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script Class
ElScript Namespace


Script Constructor

[image] [image]

4 of William Foster's Class Libraries
Script Constructor
Script Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Script()()()() | Initializes a new instance of the Script class
Public method | Script(Stream) | Initializes a new instance of the Script class
Public method | Script(Filename, Boolean) | Initializes a new instance of the Script class

See Also

Script Class
Script Members
ElScript Namespace


Script Constructor

[image]

4 of William Foster's Class Libraries
Script Constructor
Script Class See Also Send Feedback
Initializes a new instance of the Script class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script()
Visual Basic
Public Sub New
Visual C++
public:
Script()

See Also

Script Class
Script Overload
ElScript Namespace


Script Constructor ()

[image]

4 of William Foster's Class Libraries
Script Constructor ()
Script Class See Also Send Feedback
Initializes a new instance of the Script class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script(
    Stream bfc_stream
)
Visual Basic
Public Sub New ( _
    bfc_stream As Stream _
)
Visual C++
public:
Script(
    Stream^ bfc_stream
)

Parameters

bfc_stream
Type: Stream

[Missing <param name="bfc_stream"/> documentation for "M:ElScript.Script.#ctor(El.Stream)"]

See Also

Script Class
Script Overload
ElScript Namespace


Script Constructor (, Boolean)

[image]

4 of William Foster's Class Libraries
Script Constructor (, Boolean)
Script Class See Also Send Feedback
Initializes a new instance of the Script class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script(
    Filename bfc_filename,
    bool b_ReadOnly
)
Visual Basic
Public Sub New ( _
    bfc_filename As Filename, _
    b_ReadOnly As Boolean _
)
Visual C++
public:
Script(
    Filename^ bfc_filename,
    bool b_ReadOnly
)

Parameters

bfc_filename
Type: Filename

[Missing <param name="bfc_filename"/> documentation for "M:ElScript.Script.#ctor(El.Filename,System.Boolean)"]

b_ReadOnly
Type: System..::..Boolean

[Missing <param name="b_ReadOnly"/> documentation for "M:ElScript.Script.#ctor(El.Filename,System.Boolean)"]

See Also

Script Class
Script Overload
ElScript Namespace


Script Fields

[image] [image]

4 of William Foster's Class Libraries
Script Fields
Script Class See Also Send Feedback

The Script type exposes the following members.

Fields

 | Name | Description
Protected field | m_bOkAddComments |
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments |
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase |
Protected field | m_saMidlineCommentChars |
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)
 | SCRIPT_KEY_NONE |

See Also

Script Class
ElScript Namespace


m_bOkAddComments Field

[image]

4 of William Foster's Class Libraries
Script..::..m_bOkAddComments Field
Script Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script.m_bOkAddComments"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool m_bOkAddComments
Visual Basic
Protected m_bOkAddComments As Boolean
Visual C++
protected:
bool m_bOkAddComments

See Also

Script Class
ElScript Namespace


m_bSkippingComments Field

[image]

4 of William Foster's Class Libraries
Script..::..m_bSkippingComments Field
Script Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script.m_bSkippingComments"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool m_bSkippingComments
Visual Basic
Protected m_bSkippingComments As Boolean
Visual C++
protected:
bool m_bSkippingComments

See Also

Script Class
ElScript Namespace


m_phrase Field

[image]

4 of William Foster's Class Libraries
Script..::..m_phrase Field
Script Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script.m_phrase"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Phrase m_phrase
Visual Basic
Protected m_phrase As Phrase
Visual C++
protected:
Phrase^ m_phrase

See Also

Script Class
ElScript Namespace


m_saMidlineCommentChars Field

[image]

4 of William Foster's Class Libraries
Script..::..m_saMidlineCommentChars Field
Script Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script.m_saMidlineCommentChars"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ArrayList m_saMidlineCommentChars
Visual Basic
Protected m_saMidlineCommentChars As ArrayList
Visual C++
protected:
ArrayList^ m_saMidlineCommentChars

See Also

Script Class
ElScript Namespace


SCRIPT_KEY_NONE Field

[image]

4 of William Foster's Class Libraries
Script..::..SCRIPT_KEY_NONE Field
Script Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script.SCRIPT_KEY_NONE"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const int SCRIPT_KEY_NONE
Visual Basic
Public Const SCRIPT_KEY_NONE As Integer
Visual C++
public:
literal int SCRIPT_KEY_NONE

See Also

Script Class
ElScript Namespace


Script Methods

[image] [image]

4 of William Foster's Class Libraries
Script Methods
Script Class See Also Send Feedback

The Script type exposes the following members.

Methods

 | Name | Description
Public method | AppendScript |
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL |
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine |
Protected method | BufferScript |
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor |
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Protected method | Emit |
Public method | Empty |
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache |
Protected method | GetErrorCount |
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount |
Public method | IsAttached | (Inherited from Stream.)
Protected method | LocateMidlineComment |
Public method | MatchScriptKey |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition |
Protected method | NextChar()()()() |
Protected method | NextChar(Int32) |
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character |
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadScript_ArgumentList |
Public method | ReadScript_ArgumentList_2dPair(Size2d%) |
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) |
Public method | ReadScript_BetweenDeliminators |
Public method | ReadScript_Character |
Public method | ReadScriptLine |
Public method | ReadScriptLine_skipcomments |
Public method | ReadScriptPhrase |
Public method | ReadScriptString |
Public method | ReadScriptWord |
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments |
Public method | Reset |
Public method | Rewind | (Overrides Script_Text..::..Rewind()()()().)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator |
Public method | SetSkipComments |
Public method | SetSkipLinefeeds |
Public method | SetSkipWhitespace |
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors |
Protected method | Skip_Bufferchar |
Protected method | SkippingLinefeeds | (Overrides Script_Text..::..SkippingLinefeeds()()()().)
Public method | SkipScript_Character |
Public method | SkipScriptLine |
Public method | SkipScriptWord |
Public method | SyntaxError |
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey |
Public method | TestScriptKey |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment |
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

Script Class
ElScript Namespace


AppendScript Method

[image]

4 of William Foster's Class Libraries
Script..::..AppendScript Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.AppendScript(ElScript.Script)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AppendScript(
    Script src
)
Visual Basic
Public Sub AppendScript ( _
    src As Script _
)
Visual C++
public:
void AppendScript(
    Script^ src
)

Parameters

src
Type: ElScript..::..Script

[Missing <param name="src"/> documentation for "M:ElScript.Script.AppendScript(ElScript.Script)"]

See Also

Script Class
ElScript Namespace


AtEOL Method

[image]

4 of William Foster's Class Libraries
Script..::..AtEOL Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.AtEOL"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AtEOL()
Visual Basic
Public Function AtEOL As Boolean
Visual C++
public:
bool AtEOL()

Return Value

[Missing <returns> documentation for "M:ElScript.Script.AtEOL"]

See Also

Script Class
ElScript Namespace


AttachFile Method

[image] [image]

4 of William Foster's Class Libraries
Script..::..AttachFile Method
Script Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)

See Also

Script Class
Script Members
ElScript Namespace


AttachMemory Method

[image] [image]

4 of William Foster's Class Libraries
Script..::..AttachMemory Method
Script Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)

See Also

Script Class
Script Members
ElScript Namespace


BufferNextLine Method

[image]

4 of William Foster's Class Libraries
Script..::..BufferNextLine Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.BufferNextLine"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool BufferNextLine()
Visual Basic
Public Overridable Function BufferNextLine As Boolean
Visual C++
public:
virtual bool BufferNextLine()

Return Value

[Missing <returns> documentation for "M:ElScript.Script.BufferNextLine"]

Implements

IPhrase_Reader..::..BufferNextLine()()()()

See Also

Script Class
ElScript Namespace


BufferScript Method

[image]

4 of William Foster's Class Libraries
Script..::..BufferScript Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.BufferScript"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool BufferScript()
Visual Basic
Protected Function BufferScript As Boolean
Visual C++
protected:
bool BufferScript()

Return Value

[Missing <returns> documentation for "M:ElScript.Script.BufferScript"]

See Also

Script Class
ElScript Namespace


Constructor Method

[image]

4 of William Foster's Class Libraries
Script..::..Constructor Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.Constructor"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Constructor()
Visual Basic
Public Sub Constructor
Visual C++
public:
void Constructor()

See Also

Script Class
ElScript Namespace


Emit Method

[image]

4 of William Foster's Class Libraries
Script..::..Emit Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.Emit(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void Emit(
    STRING txt
)
Visual Basic
Protected Sub Emit ( _
    txt As STRING _
)
Visual C++
protected:
void Emit(
    STRING^ txt
)

Parameters

txt
Type: STRING

[Missing <param name="txt"/> documentation for "M:ElScript.Script.Emit(El.STRING)"]

See Also

Script Class
ElScript Namespace


Empty Method

[image]

4 of William Foster's Class Libraries
Script..::..Empty Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.Empty"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Empty()
Visual Basic
Public Sub Empty
Visual C++
public:
void Empty()

See Also

Script Class
ElScript Namespace


GetCommentCache Method

[image]

4 of William Foster's Class Libraries
Script..::..GetCommentCache Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.GetCommentCache(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool GetCommentCache(
    STRING comment
)
Visual Basic
Public Function GetCommentCache ( _
    comment As STRING _
) As Boolean
Visual C++
public:
bool GetCommentCache(
    STRING^ comment
)

Parameters

comment
Type: STRING

[Missing <param name="comment"/> documentation for "M:ElScript.Script.GetCommentCache(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.GetCommentCache(El.STRING)"]

See Also

Script Class
ElScript Namespace


GetErrorCount Method

[image]

4 of William Foster's Class Libraries
Script..::..GetErrorCount Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.GetErrorCount"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int GetErrorCount()
Visual Basic
Protected Function GetErrorCount As Integer
Visual C++
protected:
int GetErrorCount()

Return Value

[Missing <returns> documentation for "M:ElScript.Script.GetErrorCount"]

See Also

Script Class
ElScript Namespace


GetWarningCount Method

[image]

4 of William Foster's Class Libraries
Script..::..GetWarningCount Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.GetWarningCount"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int GetWarningCount()
Visual Basic
Protected Function GetWarningCount As Integer
Visual C++
protected:
int GetWarningCount()

Return Value

[Missing <returns> documentation for "M:ElScript.Script.GetWarningCount"]

See Also

Script Class
ElScript Namespace


LocateMidlineComment Method

[image]

4 of William Foster's Class Libraries
Script..::..LocateMidlineComment Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.LocateMidlineComment(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int LocateMidlineComment(
    STRING s
)
Visual Basic
Protected Function LocateMidlineComment ( _
    s As STRING _
) As Integer
Visual C++
protected:
int LocateMidlineComment(
    STRING^ s
)

Parameters

s
Type: STRING

[Missing <param name="s"/> documentation for "M:ElScript.Script.LocateMidlineComment(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.LocateMidlineComment(El.STRING)"]

See Also

Script Class
ElScript Namespace


MatchScriptKey Method

[image]

4 of William Foster's Class Libraries
Script..::..MatchScriptKey Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.MatchScriptKey(System.String[],System.Int32@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool MatchScriptKey(
    string[] WordList,
    out int iKey
)
Visual Basic
Public Function MatchScriptKey ( _
    WordList As String(), _
    <OutAttribute> ByRef iKey As Integer _
) As Boolean
Visual C++
public:
bool MatchScriptKey(
    array<String^>^ WordList,
    [OutAttribute] int% iKey
)

Parameters

WordList
Type: array< System..::..String >[]()[][]

[Missing <param name="WordList"/> documentation for "M:ElScript.Script.MatchScriptKey(System.String[],System.Int32@)"]

iKey
Type: System..::..Int32 %

[Missing <param name="iKey"/> documentation for "M:ElScript.Script.MatchScriptKey(System.String[],System.Int32@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.MatchScriptKey(System.String[],System.Int32@)"]

See Also

Script Class
ElScript Namespace


newposition Method

[image]

4 of William Foster's Class Libraries
Script..::..newposition Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.newposition"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void newposition()
Visual Basic
Protected Sub newposition
Visual C++
protected:
void newposition()

See Also

Script Class
ElScript Namespace


NextChar Method

[image] [image]

4 of William Foster's Class Libraries
Script..::..NextChar Method
Script Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | NextChar()()()() |
Protected method | NextChar(Int32) |

See Also

Script Class
Script Members
ElScript Namespace


NextChar Method

[image]

4 of William Foster's Class Libraries
Script..::..NextChar Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.NextChar"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected char NextChar()
Visual Basic
Protected Function NextChar As Char
Visual C++
protected:
wchar_t NextChar()

Return Value

[Missing <returns> documentation for "M:ElScript.Script.NextChar"]

See Also

Script Class
NextChar Overload
ElScript Namespace


NextChar Method (Int32)

[image]

4 of William Foster's Class Libraries
Script..::..NextChar Method (Int32)
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.NextChar(System.Int32)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected char NextChar(
    int offset
)
Visual Basic
Protected Function NextChar ( _
    offset As Integer _
) As Char
Visual C++
protected:
wchar_t NextChar(
    int offset
)

Parameters

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:ElScript.Script.NextChar(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.NextChar(System.Int32)"]

See Also

Script Class
NextChar Overload
ElScript Namespace


ReadAheadScript_Character Method

[image]

4 of William Foster's Class Libraries
Script..::..ReadAheadScript_Character Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.ReadAheadScript_Character(System.Char@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadAheadScript_Character(
    out char c
)
Visual Basic
Public Function ReadAheadScript_Character ( _
    <OutAttribute> ByRef c As Char _
) As Boolean
Visual C++
public:
bool ReadAheadScript_Character(
    [OutAttribute] wchar_t% c
)

Parameters

c
Type: System..::..Char %

[Missing <param name="c"/> documentation for "M:ElScript.Script.ReadAheadScript_Character(System.Char@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.ReadAheadScript_Character(System.Char@)"]

See Also

Script Class
ElScript Namespace


ReadLine Method

[image] [image]

4 of William Foster's Class Libraries
Script..::..ReadLine Method
Script Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)

See Also

Script Class
Script Members
ElScript Namespace


ReadScript_ArgumentList Method

[image]

4 of William Foster's Class Libraries
Script..::..ReadScript_ArgumentList Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.ReadScript_ArgumentList(System.String@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScript_ArgumentList(
    out string s
)
Visual Basic
Public Function ReadScript_ArgumentList ( _
    <OutAttribute> ByRef s As String _
) As Boolean
Visual C++
public:
bool ReadScript_ArgumentList(
    [OutAttribute] String^% s
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Script.ReadScript_ArgumentList(System.String@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.ReadScript_ArgumentList(System.String@)"]

See Also

Script Class
ElScript Namespace


ReadScript_ArgumentList_2dPair Method

[image] [image]

4 of William Foster's Class Libraries
Script..::..ReadScript_ArgumentList_2dPair Method
Script Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadScript_ArgumentList_2dPair(Size2d%) |
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) |

See Also

Script Class
Script Members
ElScript Namespace


ReadScript_ArgumentList_2dPair Method ()

[image]

4 of William Foster's Class Libraries
Script..::..ReadScript_ArgumentList_2dPair Method (%)
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.ReadScript_ArgumentList_2dPair(El.Size2d@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScript_ArgumentList_2dPair(
    out Size2d pair
)
Visual Basic
Public Function ReadScript_ArgumentList_2dPair ( _
    <OutAttribute> ByRef pair As Size2d _
) As Boolean
Visual C++
public:
bool ReadScript_ArgumentList_2dPair(
    [OutAttribute] Size2d^% pair
)

Parameters

pair
Type: Size2d%

[Missing <param name="pair"/> documentation for "M:ElScript.Script.ReadScript_ArgumentList_2dPair(El.Size2d@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.ReadScript_ArgumentList_2dPair(El.Size2d@)"]

See Also

Script Class
ReadScript_ArgumentList_2dPair Overload
ElScript Namespace


ReadScript_ArgumentList_2dPair Method ()

[image]

4 of William Foster's Class Libraries
Script..::..ReadScript_ArgumentList_2dPair Method (%)
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.ReadScript_ArgumentList_2dPair(El.Size2dU@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScript_ArgumentList_2dPair(
    out Size2dU pair
)
Visual Basic
Public Function ReadScript_ArgumentList_2dPair ( _
    <OutAttribute> ByRef pair As Size2dU _
) As Boolean
Visual C++
public:
bool ReadScript_ArgumentList_2dPair(
    [OutAttribute] Size2dU^% pair
)

Parameters

pair
Type: Size2dU%

[Missing <param name="pair"/> documentation for "M:ElScript.Script.ReadScript_ArgumentList_2dPair(El.Size2dU@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.ReadScript_ArgumentList_2dPair(El.Size2dU@)"]

See Also

Script Class
ReadScript_ArgumentList_2dPair Overload
ElScript Namespace


ReadScript_BetweenDeliminators Method

[image]

4 of William Foster's Class Libraries
Script..::..ReadScript_BetweenDeliminators Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.ReadScript_BetweenDeliminators(System.Boolean,System.String@,System.Char,System.Char)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScript_BetweenDeliminators(
    bool bNest,
    out string s,
    char cBegin_deliminator,
    char cEnd_deliminator
)
Visual Basic
Public Function ReadScript_BetweenDeliminators ( _
    bNest As Boolean, _
    <OutAttribute> ByRef s As String, _
    cBegin_deliminator As Char, _
    cEnd_deliminator As Char _
) As Boolean
Visual C++
public:
bool ReadScript_BetweenDeliminators(
    bool bNest,
    [OutAttribute] String^% s,
    wchar_t cBegin_deliminator,
    wchar_t cEnd_deliminator
)

Parameters

bNest
Type: System..::..Boolean

[Missing <param name="bNest"/> documentation for "M:ElScript.Script.ReadScript_BetweenDeliminators(System.Boolean,System.String@,System.Char,System.Char)"]

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Script.ReadScript_BetweenDeliminators(System.Boolean,System.String@,System.Char,System.Char)"]

cBegin_deliminator
Type: System..::..Char

[Missing <param name="cBegin_deliminator"/> documentation for "M:ElScript.Script.ReadScript_BetweenDeliminators(System.Boolean,System.String@,System.Char,System.Char)"]

cEnd_deliminator
Type: System..::..Char

[Missing <param name="cEnd_deliminator"/> documentation for "M:ElScript.Script.ReadScript_BetweenDeliminators(System.Boolean,System.String@,System.Char,System.Char)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.ReadScript_BetweenDeliminators(System.Boolean,System.String@,System.Char,System.Char)"]

See Also

Script Class
ElScript Namespace


ReadScript_Character Method

[image]

4 of William Foster's Class Libraries
Script..::..ReadScript_Character Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.ReadScript_Character(System.Char@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScript_Character(
    out char c
)
Visual Basic
Public Function ReadScript_Character ( _
    <OutAttribute> ByRef c As Char _
) As Boolean
Visual C++
public:
bool ReadScript_Character(
    [OutAttribute] wchar_t% c
)

Parameters

c
Type: System..::..Char %

[Missing <param name="c"/> documentation for "M:ElScript.Script.ReadScript_Character(System.Char@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.ReadScript_Character(System.Char@)"]

See Also

Script Class
ElScript Namespace


ReadScriptLine Method

[image]

4 of William Foster's Class Libraries
Script..::..ReadScriptLine Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.ReadScriptLine(System.String@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScriptLine(
    out string s
)
Visual Basic
Public Function ReadScriptLine ( _
    <OutAttribute> ByRef s As String _
) As Boolean
Visual C++
public:
bool ReadScriptLine(
    [OutAttribute] String^% s
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Script.ReadScriptLine(System.String@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.ReadScriptLine(System.String@)"]

See Also

Script Class
ElScript Namespace


ReadScriptLine_skipcomments Method

[image]

4 of William Foster's Class Libraries
Script..::..ReadScriptLine_skipcomments Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.ReadScriptLine_skipcomments(El.STRING@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScriptLine_skipcomments(
    out STRING s
)
Visual Basic
Public Function ReadScriptLine_skipcomments ( _
    <OutAttribute> ByRef s As STRING _
) As Boolean
Visual C++
public:
bool ReadScriptLine_skipcomments(
    [OutAttribute] STRING^% s
)

Parameters

s
Type: STRING%

[Missing <param name="s"/> documentation for "M:ElScript.Script.ReadScriptLine_skipcomments(El.STRING@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.ReadScriptLine_skipcomments(El.STRING@)"]

See Also

Script Class
ElScript Namespace


ReadScriptPhrase Method

[image]

4 of William Foster's Class Libraries
Script..::..ReadScriptPhrase Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.ReadScriptPhrase(System.String)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScriptPhrase(
    string s
)
Visual Basic
Public Function ReadScriptPhrase ( _
    s As String _
) As Boolean
Visual C++
public:
bool ReadScriptPhrase(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:ElScript.Script.ReadScriptPhrase(System.String)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.ReadScriptPhrase(System.String)"]

See Also

Script Class
ElScript Namespace


ReadScriptString Method

[image]

4 of William Foster's Class Libraries
Script..::..ReadScriptString Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.ReadScriptString(System.String@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScriptString(
    out string s
)
Visual Basic
Public Function ReadScriptString ( _
    <OutAttribute> ByRef s As String _
) As Boolean
Visual C++
public:
bool ReadScriptString(
    [OutAttribute] String^% s
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Script.ReadScriptString(System.String@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.ReadScriptString(System.String@)"]

See Also

Script Class
ElScript Namespace


ReadScriptWord Method

[image]

4 of William Foster's Class Libraries
Script..::..ReadScriptWord Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.ReadScriptWord(System.String@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadScriptWord(
    out string s
)
Visual Basic
Public Function ReadScriptWord ( _
    <OutAttribute> ByRef s As String _
) As Boolean
Visual C++
public:
bool ReadScriptWord(
    [OutAttribute] String^% s
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Script.ReadScriptWord(System.String@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.ReadScriptWord(System.String@)"]

See Also

Script Class
ElScript Namespace


RemoveEnclosedComments Method

[image]

4 of William Foster's Class Libraries
Script..::..RemoveEnclosedComments Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.RemoveEnclosedComments(System.String@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RemoveEnclosedComments(
    ref string s
)
Visual Basic
Public Sub RemoveEnclosedComments ( _
    ByRef s As String _
)
Visual C++
public:
void RemoveEnclosedComments(
    String^% s
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Script.RemoveEnclosedComments(System.String@)"]

See Also

Script Class
ElScript Namespace


Reset Method

[image]

4 of William Foster's Class Libraries
Script..::..Reset Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.Reset"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

Script Class
ElScript Namespace


Rewind Method

[image]

4 of William Foster's Class Libraries
Script..::..Rewind Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.Rewind"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool Rewind()
Visual Basic
Public Overrides Function Rewind As Boolean
Visual C++
public:
virtual bool Rewind() override

Return Value

[Missing <returns> documentation for "M:ElScript.Script.Rewind"]

See Also

Script Class
ElScript Namespace


Seek Method

[image] [image]

4 of William Foster's Class Libraries
Script..::..Seek Method
Script Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)

See Also

Script Class
Script Members
ElScript Namespace


SetMidlineCommentIndicator Method

[image]

4 of William Foster's Class Libraries
Script..::..SetMidlineCommentIndicator Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.SetMidlineCommentIndicator(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetMidlineCommentIndicator(
    STRING csCommentChars
)
Visual Basic
Public Sub SetMidlineCommentIndicator ( _
    csCommentChars As STRING _
)
Visual C++
public:
void SetMidlineCommentIndicator(
    STRING^ csCommentChars
)

Parameters

csCommentChars
Type: STRING

[Missing <param name="csCommentChars"/> documentation for "M:ElScript.Script.SetMidlineCommentIndicator(El.STRING)"]

See Also

Script Class
ElScript Namespace


SetSkipComments Method

[image]

4 of William Foster's Class Libraries
Script..::..SetSkipComments Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.SetSkipComments(System.Boolean)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetSkipComments(
    bool bOn
)
Visual Basic
Public Function SetSkipComments ( _
    bOn As Boolean _
) As Boolean
Visual C++
public:
bool SetSkipComments(
    bool bOn
)

Parameters

bOn
Type: System..::..Boolean

[Missing <param name="bOn"/> documentation for "M:ElScript.Script.SetSkipComments(System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.SetSkipComments(System.Boolean)"]

See Also

Script Class
ElScript Namespace


SetSkipLinefeeds Method

[image]

4 of William Foster's Class Libraries
Script..::..SetSkipLinefeeds Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.SetSkipLinefeeds(System.Boolean)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetSkipLinefeeds(
    bool bOn
)
Visual Basic
Public Function SetSkipLinefeeds ( _
    bOn As Boolean _
) As Boolean
Visual C++
public:
bool SetSkipLinefeeds(
    bool bOn
)

Parameters

bOn
Type: System..::..Boolean

[Missing <param name="bOn"/> documentation for "M:ElScript.Script.SetSkipLinefeeds(System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.SetSkipLinefeeds(System.Boolean)"]

See Also

Script Class
ElScript Namespace


SetSkipWhitespace Method

[image]

4 of William Foster's Class Libraries
Script..::..SetSkipWhitespace Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.SetSkipWhitespace(System.Boolean)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetSkipWhitespace(
    bool bOn
)
Visual Basic
Public Function SetSkipWhitespace ( _
    bOn As Boolean _
) As Boolean
Visual C++
public:
bool SetSkipWhitespace(
    bool bOn
)

Parameters

bOn
Type: System..::..Boolean

[Missing <param name="bOn"/> documentation for "M:ElScript.Script.SetSkipWhitespace(System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.SetSkipWhitespace(System.Boolean)"]

See Also

Script Class
ElScript Namespace


ShowErrors Method

[image]

4 of William Foster's Class Libraries
Script..::..ShowErrors Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.ShowErrors(System.Boolean,System.Boolean)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ShowErrors(
    bool bErrors,
    bool bWarnings
)
Visual Basic
Public Sub ShowErrors ( _
    bErrors As Boolean, _
    bWarnings As Boolean _
)
Visual C++
public:
void ShowErrors(
    bool bErrors,
    bool bWarnings
)

Parameters

bErrors
Type: System..::..Boolean

[Missing <param name="bErrors"/> documentation for "M:ElScript.Script.ShowErrors(System.Boolean,System.Boolean)"]

bWarnings
Type: System..::..Boolean

[Missing <param name="bWarnings"/> documentation for "M:ElScript.Script.ShowErrors(System.Boolean,System.Boolean)"]

See Also

Script Class
ElScript Namespace


Skip_Bufferchar Method

[image]

4 of William Foster's Class Libraries
Script..::..Skip_Bufferchar Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.Skip_Bufferchar"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void Skip_Bufferchar()
Visual Basic
Protected Sub Skip_Bufferchar
Visual C++
protected:
void Skip_Bufferchar()

See Also

Script Class
ElScript Namespace


SkippingLinefeeds Method

[image]

4 of William Foster's Class Libraries
Script..::..SkippingLinefeeds Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.SkippingLinefeeds"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool SkippingLinefeeds()
Visual Basic
Protected Overrides Function SkippingLinefeeds As Boolean
Visual C++
protected:
virtual bool SkippingLinefeeds() override

Return Value

[Missing <returns> documentation for "M:ElScript.Script.SkippingLinefeeds"]

See Also

Script Class
ElScript Namespace


SkipScript_Character Method

[image]

4 of William Foster's Class Libraries
Script..::..SkipScript_Character Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.SkipScript_Character"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SkipScript_Character()
Visual Basic
Public Function SkipScript_Character As Boolean
Visual C++
public:
bool SkipScript_Character()

Return Value

[Missing <returns> documentation for "M:ElScript.Script.SkipScript_Character"]

See Also

Script Class
ElScript Namespace


SkipScriptLine Method

[image]

4 of William Foster's Class Libraries
Script..::..SkipScriptLine Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.SkipScriptLine"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SkipScriptLine()
Visual Basic
Public Function SkipScriptLine As Boolean
Visual C++
public:
bool SkipScriptLine()

Return Value

[Missing <returns> documentation for "M:ElScript.Script.SkipScriptLine"]

See Also

Script Class
ElScript Namespace


SkipScriptWord Method

[image]

4 of William Foster's Class Libraries
Script..::..SkipScriptWord Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.SkipScriptWord"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SkipScriptWord()
Visual Basic
Public Function SkipScriptWord As Boolean
Visual C++
public:
bool SkipScriptWord()

Return Value

[Missing <returns> documentation for "M:ElScript.Script.SkipScriptWord"]

See Also

Script Class
ElScript Namespace


SyntaxError Method

[image]

4 of William Foster's Class Libraries
Script..::..SyntaxError Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.SyntaxError(ElScript.Script.SYNTAX_ERROR_TYPE,System.String)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SyntaxError(
    Script..::..SYNTAX_ERROR_TYPE type,
    string errstr
)
Visual Basic
Public Sub SyntaxError ( _
    type As Script..::..SYNTAX_ERROR_TYPE, _
    errstr As String _
)
Visual C++
public:
void SyntaxError(
    Script..::..SYNTAX_ERROR_TYPE type,
    String^ errstr
)

Parameters

type
Type: ElScript..::..Script..::..SYNTAX_ERROR_TYPE

[Missing <param name="type"/> documentation for "M:ElScript.Script.SyntaxError(ElScript.Script.SYNTAX_ERROR_TYPE,System.String)"]

errstr
Type: System..::..String

[Missing <param name="errstr"/> documentation for "M:ElScript.Script.SyntaxError(ElScript.Script.SYNTAX_ERROR_TYPE,System.String)"]

See Also

Script Class
ElScript Namespace


TestKey Method

[image]

4 of William Foster's Class Libraries
Script..::..TestKey Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.TestKey(System.String,System.String[])"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int TestKey(
    string csWord,
    string[] WordList
)
Visual Basic
Public Function TestKey ( _
    csWord As String, _
    WordList As String() _
) As Integer
Visual C++
public:
int TestKey(
    String^ csWord,
    array<String^>^ WordList
)

Parameters

csWord
Type: System..::..String

[Missing <param name="csWord"/> documentation for "M:ElScript.Script.TestKey(System.String,System.String[])"]

WordList
Type: array< System..::..String >[]()[][]

[Missing <param name="WordList"/> documentation for "M:ElScript.Script.TestKey(System.String,System.String[])"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.TestKey(System.String,System.String[])"]

See Also

Script Class
ElScript Namespace


TestScriptKey Method

[image]

4 of William Foster's Class Libraries
Script..::..TestScriptKey Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.TestScriptKey(System.String[])"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int TestScriptKey(
    string[] WordList
)
Visual Basic
Public Function TestScriptKey ( _
    WordList As String() _
) As Integer
Visual C++
public:
int TestScriptKey(
    array<String^>^ WordList
)

Parameters

WordList
Type: array< System..::..String >[]()[][]

[Missing <param name="WordList"/> documentation for "M:ElScript.Script.TestScriptKey(System.String[])"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script.TestScriptKey(System.String[])"]

See Also

Script Class
ElScript Namespace


WithinComment Method

[image]

4 of William Foster's Class Libraries
Script..::..WithinComment Method
Script Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script.WithinComment"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WithinComment()
Visual Basic
Public Function WithinComment As Boolean
Visual C++
public:
bool WithinComment()

Return Value

[Missing <returns> documentation for "M:ElScript.Script.WithinComment"]

See Also

Script Class
ElScript Namespace


Write Method

[image] [image]

4 of William Foster's Class Libraries
Script..::..Write Method
Script Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

Script Class
Script Members
ElScript Namespace


WriteLine Method

[image] [image]

4 of William Foster's Class Libraries
Script..::..WriteLine Method
Script Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

Script Class
Script Members
ElScript Namespace


Script Properties

[image] [image]

4 of William Foster's Class Libraries
Script Properties
Script Class See Also Send Feedback

The Script type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script Class
ElScript Namespace


Script.SYNTAX_ERROR_TYPE Enumeration

[image]

4 of William Foster's Class Libraries
Script..::..SYNTAX_ERROR_TYPE Enumeration
Script Class See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Script.SYNTAX_ERROR_TYPE"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum SYNTAX_ERROR_TYPE
Visual Basic
Public Enumeration SYNTAX_ERROR_TYPE
Visual C++
public enum class SYNTAX_ERROR_TYPE

Members

Member name | Value | Description
SYNTAX_WARNING | 0 |
SYNTAX_ERROR | 1 |
CONSTRUCTION_ERROR | 2 |

See Also

ElScript Namespace


Script_C Class

[image]

4 of William Foster's Class Libraries
Script_C Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Script_C"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Script_C : Script_Source
Visual Basic
Public Class Script_C _
    Inherits Script_Source
Visual C++
public ref class Script_C : public Script_Source

Inheritance Hierarchy

System..::..Object
Stream
ElScript..::..Script_Text
ElScript..::..Script
ElScript..::..Script_XML
ElScript..::..Script_Source
ElScript..::..Script_C
ElScript..::..Script_CPlusPlus

See Also

Script_C Members
ElScript Namespace


Script_C Members

[image] [image]

4 of William Foster's Class Libraries
Script_C Members
Script_C Class Constructors Methods Fields Properties See Also Send Feedback

The Script_C type exposes the following members.

Constructors

 | Name | Description
Public method | Script_C(Stream) | Initializes a new instance of the Script_C class
Public method | Script_C(Stream, STRING, STRING, STRING) | Initializes a new instance of the Script_C class

Methods

 | Name | Description
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Overrides Script..::..BufferNextLine()()()().)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML | (Inherited from Script_XML.)
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Protected method | PopSource |
Public method | ProcessDirective |
Public method | PushSource(Filename) |
Protected method | PushSource(StreamSource) |
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadAheadScript_Character_NoDefines |
Public method | ReadBetweenBrackets |
Protected method | ReadIfdefDirective |
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext | (Inherited from Script_XML.)
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Protected method | ReadSourceLine |
Public method | ReadToTagEnd | (Inherited from Script_XML.)
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Inherited from Script_XML.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | skipping_code |
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkippingStrings | (Inherited from Script_Source.)
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment | (Inherited from Script.)
Protected method | WithinInclude |
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField | (Inherited from Script_XML.)
Public method | WriteAnXMLTag | (Inherited from Script_XML.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

Fields

 | Name | Description
Protected field | m_b_skipping_strings | (Inherited from Script_Source.)
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_cs_LastComment |
Protected field | m_cs_pwdWorkingFrom |
Protected field | m_csa_scannedincludes |
Protected field | m_defines |
Protected field | m_ifdef_depth |
Protected field | m_ifdef_on_depth |
Protected field | m_LinenumberStack |
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_pi |
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_StreamStack |
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script_C Class
ElScript Namespace


Script_C Constructor

[image] [image]

4 of William Foster's Class Libraries
Script_C Constructor
Script_C Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Script_C(Stream) | Initializes a new instance of the Script_C class
Public method | Script_C(Stream, STRING, STRING, STRING) | Initializes a new instance of the Script_C class

See Also

Script_C Class
Script_C Members
ElScript Namespace


Script_C Constructor ()

[image]

4 of William Foster's Class Libraries
Script_C Constructor ()
Script_C Class See Also Send Feedback
Initializes a new instance of the Script_C class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script_C(
    Stream bfc_stream
)
Visual Basic
Public Sub New ( _
    bfc_stream As Stream _
)
Visual C++
public:
Script_C(
    Stream^ bfc_stream
)

Parameters

bfc_stream
Type: Stream

[Missing <param name="bfc_stream"/> documentation for "M:ElScript.Script_C.#ctor(El.Stream)"]

See Also

Script_C Class
Script_C Overload
ElScript Namespace


Script_C Constructor (, , , )

[image]

4 of William Foster's Class Libraries
Script_C Constructor (, , , )
Script_C Class See Also Send Feedback
Initializes a new instance of the Script_C class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script_C(
    Stream bfc_stream,
    STRING csIncludePaths,
    STRING csSkipIncludes,
    STRING csDefines
)
Visual Basic
Public Sub New ( _
    bfc_stream As Stream, _
    csIncludePaths As STRING, _
    csSkipIncludes As STRING, _
    csDefines As STRING _
)
Visual C++
public:
Script_C(
    Stream^ bfc_stream,
    STRING^ csIncludePaths,
    STRING^ csSkipIncludes,
    STRING^ csDefines
)

Parameters

bfc_stream
Type: Stream

[Missing <param name="bfc_stream"/> documentation for "M:ElScript.Script_C.#ctor(El.Stream,El.STRING,El.STRING,El.STRING)"]

csIncludePaths
Type: STRING

[Missing <param name="csIncludePaths"/> documentation for "M:ElScript.Script_C.#ctor(El.Stream,El.STRING,El.STRING,El.STRING)"]

csSkipIncludes
Type: STRING

[Missing <param name="csSkipIncludes"/> documentation for "M:ElScript.Script_C.#ctor(El.Stream,El.STRING,El.STRING,El.STRING)"]

csDefines
Type: STRING

[Missing <param name="csDefines"/> documentation for "M:ElScript.Script_C.#ctor(El.Stream,El.STRING,El.STRING,El.STRING)"]

See Also

Script_C Class
Script_C Overload
ElScript Namespace


Script_C Fields

[image] [image]

4 of William Foster's Class Libraries
Script_C Fields
Script_C Class See Also Send Feedback

The Script_C type exposes the following members.

Fields

 | Name | Description
Protected field | m_b_skipping_strings | (Inherited from Script_Source.)
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_cs_LastComment |
Protected field | m_cs_pwdWorkingFrom |
Protected field | m_csa_scannedincludes |
Protected field | m_defines |
Protected field | m_ifdef_depth |
Protected field | m_ifdef_on_depth |
Protected field | m_LinenumberStack |
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_pi |
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_StreamStack |
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)

See Also

Script_C Class
ElScript Namespace


m_cs_LastComment Field

[image]

4 of William Foster's Class Libraries
Script_C..::..m_cs_LastComment Field
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script_C.m_cs_LastComment"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected STRING m_cs_LastComment
Visual Basic
Protected m_cs_LastComment As STRING
Visual C++
protected:
STRING^ m_cs_LastComment

See Also

Script_C Class
ElScript Namespace


m_cs_pwdWorkingFrom Field

[image]

4 of William Foster's Class Libraries
Script_C..::..m_cs_pwdWorkingFrom Field
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script_C.m_cs_pwdWorkingFrom"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Filename m_cs_pwdWorkingFrom
Visual Basic
Protected m_cs_pwdWorkingFrom As Filename
Visual C++
protected:
Filename^ m_cs_pwdWorkingFrom

See Also

Script_C Class
ElScript Namespace


m_csa_scannedincludes Field

[image]

4 of William Foster's Class Libraries
Script_C..::..m_csa_scannedincludes Field
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script_C.m_csa_scannedincludes"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Array<STRING> m_csa_scannedincludes
Visual Basic
Protected m_csa_scannedincludes As Array(Of STRING)
Visual C++
protected:
Array<STRING^>^ m_csa_scannedincludes

See Also

Script_C Class
ElScript Namespace


m_defines Field

[image]

4 of William Foster's Class Libraries
Script_C..::..m_defines Field
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script_C.m_defines"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Array<C_Define> m_defines
Visual Basic
Protected m_defines As Array(Of C_Define)
Visual C++
protected:
Array<C_Define^>^ m_defines

See Also

Script_C Class
ElScript Namespace


m_ifdef_depth Field

[image]

4 of William Foster's Class Libraries
Script_C..::..m_ifdef_depth Field
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script_C.m_ifdef_depth"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected uint m_ifdef_depth
Visual Basic
Protected m_ifdef_depth As UInteger
Visual C++
protected:
unsigned int m_ifdef_depth

See Also

Script_C Class
ElScript Namespace


m_ifdef_on_depth Field

[image]

4 of William Foster's Class Libraries
Script_C..::..m_ifdef_on_depth Field
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script_C.m_ifdef_on_depth"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected uint m_ifdef_on_depth
Visual Basic
Protected m_ifdef_on_depth As UInteger
Visual C++
protected:
unsigned int m_ifdef_on_depth

See Also

Script_C Class
ElScript Namespace


m_LinenumberStack Field

[image]

4 of William Foster's Class Libraries
Script_C..::..m_LinenumberStack Field
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script_C.m_LinenumberStack"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Array<uint> m_LinenumberStack
Visual Basic
Protected m_LinenumberStack As Array(Of UInteger)
Visual C++
protected:
Array<unsigned int>^ m_LinenumberStack

See Also

Script_C Class
ElScript Namespace


m_pi Field

[image]

4 of William Foster's Class Libraries
Script_C..::..m_pi Field
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script_C.m_pi"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ParseIncludes m_pi
Visual Basic
Protected m_pi As ParseIncludes
Visual C++
protected:
ParseIncludes^ m_pi

See Also

Script_C Class
ElScript Namespace


m_StreamStack Field

[image]

4 of William Foster's Class Libraries
Script_C..::..m_StreamStack Field
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script_C.m_StreamStack"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Array<StreamSource> m_StreamStack
Visual Basic
Protected m_StreamStack As Array(Of StreamSource)
Visual C++
protected:
Array<StreamSource^>^ m_StreamStack

See Also

Script_C Class
ElScript Namespace


Script_C Methods

[image] [image]

4 of William Foster's Class Libraries
Script_C Methods
Script_C Class See Also Send Feedback

The Script_C type exposes the following members.

Methods

 | Name | Description
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Overrides Script..::..BufferNextLine()()()().)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML | (Inherited from Script_XML.)
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Protected method | PopSource |
Public method | ProcessDirective |
Public method | PushSource(Filename) |
Protected method | PushSource(StreamSource) |
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadAheadScript_Character_NoDefines |
Public method | ReadBetweenBrackets |
Protected method | ReadIfdefDirective |
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext | (Inherited from Script_XML.)
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Protected method | ReadSourceLine |
Public method | ReadToTagEnd | (Inherited from Script_XML.)
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Inherited from Script_XML.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | skipping_code |
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkippingStrings | (Inherited from Script_Source.)
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment | (Inherited from Script.)
Protected method | WithinInclude |
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField | (Inherited from Script_XML.)
Public method | WriteAnXMLTag | (Inherited from Script_XML.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

Script_C Class
ElScript Namespace


AttachFile Method

[image] [image]

4 of William Foster's Class Libraries
Script_C..::..AttachFile Method
Script_C Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)

See Also

Script_C Class
Script_C Members
ElScript Namespace


AttachMemory Method

[image] [image]

4 of William Foster's Class Libraries
Script_C..::..AttachMemory Method
Script_C Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)

See Also

Script_C Class
Script_C Members
ElScript Namespace


BufferNextLine Method

[image]

4 of William Foster's Class Libraries
Script_C..::..BufferNextLine Method
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_C.BufferNextLine"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool BufferNextLine()
Visual Basic
Public Overrides Function BufferNextLine As Boolean
Visual C++
public:
virtual bool BufferNextLine() override

Return Value

[Missing <returns> documentation for "M:ElScript.Script_C.BufferNextLine"]

Implements

IPhrase_Reader..::..BufferNextLine()()()()

See Also

Script_C Class
ElScript Namespace


NextChar Method

[image] [image]

4 of William Foster's Class Libraries
Script_C..::..NextChar Method
Script_C Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)

See Also

Script_C Class
Script_C Members
ElScript Namespace


PopSource Method

[image]

4 of William Foster's Class Libraries
Script_C..::..PopSource Method
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_C.PopSource"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool PopSource()
Visual Basic
Protected Function PopSource As Boolean
Visual C++
protected:
bool PopSource()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_C.PopSource"]

See Also

Script_C Class
ElScript Namespace


ProcessDirective Method

[image]

4 of William Foster's Class Libraries
Script_C..::..ProcessDirective Method
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_C.ProcessDirective"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ProcessDirective()
Visual Basic
Public Function ProcessDirective As Boolean
Visual C++
public:
bool ProcessDirective()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_C.ProcessDirective"]

See Also

Script_C Class
ElScript Namespace


PushSource Method

[image] [image]

4 of William Foster's Class Libraries
Script_C..::..PushSource Method
Script_C Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PushSource(Filename) |
Protected method | PushSource(StreamSource) |

See Also

Script_C Class
Script_C Members
ElScript Namespace


PushSource Method ()

[image]

4 of William Foster's Class Libraries
Script_C..::..PushSource Method ()
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_C.PushSource(El.Filename)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool PushSource(
    Filename sl
)
Visual Basic
Public Function PushSource ( _
    sl As Filename _
) As Boolean
Visual C++
public:
bool PushSource(
    Filename^ sl
)

Parameters

sl
Type: Filename

[Missing <param name="sl"/> documentation for "M:ElScript.Script_C.PushSource(El.Filename)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_C.PushSource(El.Filename)"]

See Also

Script_C Class
PushSource Overload
ElScript Namespace


PushSource Method ()

[image]

4 of William Foster's Class Libraries
Script_C..::..PushSource Method ()
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_C.PushSource(El.StreamSource)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void PushSource(
    StreamSource _stream
)
Visual Basic
Protected Sub PushSource ( _
    _stream As StreamSource _
)
Visual C++
protected:
void PushSource(
    StreamSource^ _stream
)

Parameters

_stream
Type: StreamSource

[Missing <param name="_stream"/> documentation for "M:ElScript.Script_C.PushSource(El.StreamSource)"]

See Also

Script_C Class
PushSource Overload
ElScript Namespace


ReadAheadScript_Character_NoDefines Method

[image]

4 of William Foster's Class Libraries
Script_C..::..ReadAheadScript_Character_NoDefines Method
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_C.ReadAheadScript_Character_NoDefines(System.Char@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadAheadScript_Character_NoDefines(
    out char c
)
Visual Basic
Public Function ReadAheadScript_Character_NoDefines ( _
    <OutAttribute> ByRef c As Char _
) As Boolean
Visual C++
public:
bool ReadAheadScript_Character_NoDefines(
    [OutAttribute] wchar_t% c
)

Parameters

c
Type: System..::..Char %

[Missing <param name="c"/> documentation for "M:ElScript.Script_C.ReadAheadScript_Character_NoDefines(System.Char@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_C.ReadAheadScript_Character_NoDefines(System.Char@)"]

See Also

Script_C Class
ElScript Namespace


ReadBetweenBrackets Method

[image]

4 of William Foster's Class Libraries
Script_C..::..ReadBetweenBrackets Method
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_C.ReadBetweenBrackets(System.String@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadBetweenBrackets(
    out string s
)
Visual Basic
Public Function ReadBetweenBrackets ( _
    <OutAttribute> ByRef s As String _
) As Boolean
Visual C++
public:
bool ReadBetweenBrackets(
    [OutAttribute] String^% s
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Script_C.ReadBetweenBrackets(System.String@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_C.ReadBetweenBrackets(System.String@)"]

See Also

Script_C Class
ElScript Namespace


ReadIfdefDirective Method

[image]

4 of William Foster's Class Libraries
Script_C..::..ReadIfdefDirective Method
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_C.ReadIfdefDirective(ElScript.Script_C.E_C_IFDEF)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool ReadIfdefDirective(
    Script_C..::..E_C_IFDEF eif
)
Visual Basic
Protected Function ReadIfdefDirective ( _
    eif As Script_C..::..E_C_IFDEF _
) As Boolean
Visual C++
protected:
bool ReadIfdefDirective(
    Script_C..::..E_C_IFDEF eif
)

Parameters

eif
Type: ElScript..::..Script_C..::..E_C_IFDEF

[Missing <param name="eif"/> documentation for "M:ElScript.Script_C.ReadIfdefDirective(ElScript.Script_C.E_C_IFDEF)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_C.ReadIfdefDirective(ElScript.Script_C.E_C_IFDEF)"]

See Also

Script_C Class
ElScript Namespace


ReadLine Method

[image] [image]

4 of William Foster's Class Libraries
Script_C..::..ReadLine Method
Script_C Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)

See Also

Script_C Class
Script_C Members
ElScript Namespace


ReadScript_ArgumentList_2dPair Method

[image] [image]

4 of William Foster's Class Libraries
Script_C..::..ReadScript_ArgumentList_2dPair Method
Script_C Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)

See Also

Script_C Class
Script_C Members
ElScript Namespace


ReadSourceLine Method

[image]

4 of William Foster's Class Libraries
Script_C..::..ReadSourceLine Method
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_C.ReadSourceLine(El.STRING@,System.Char@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool ReadSourceLine(
    out STRING s,
    out char finalc
)
Visual Basic
Protected Function ReadSourceLine ( _
    <OutAttribute> ByRef s As STRING, _
    <OutAttribute> ByRef finalc As Char _
) As Boolean
Visual C++
protected:
bool ReadSourceLine(
    [OutAttribute] STRING^% s,
    [OutAttribute] wchar_t% finalc
)

Parameters

s
Type: STRING%

[Missing <param name="s"/> documentation for "M:ElScript.Script_C.ReadSourceLine(El.STRING@,System.Char@)"]

finalc
Type: System..::..Char %

[Missing <param name="finalc"/> documentation for "M:ElScript.Script_C.ReadSourceLine(El.STRING@,System.Char@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_C.ReadSourceLine(El.STRING@,System.Char@)"]

See Also

Script_C Class
ElScript Namespace


Seek Method

[image] [image]

4 of William Foster's Class Libraries
Script_C..::..Seek Method
Script_C Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)

See Also

Script_C Class
Script_C Members
ElScript Namespace


skipping_code Method

[image]

4 of William Foster's Class Libraries
Script_C..::..skipping_code Method
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_C.skipping_code"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool skipping_code()
Visual Basic
Protected Function skipping_code As Boolean
Visual C++
protected:
bool skipping_code()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_C.skipping_code"]

See Also

Script_C Class
ElScript Namespace


WithinInclude Method

[image]

4 of William Foster's Class Libraries
Script_C..::..WithinInclude Method
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_C.WithinInclude"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool WithinInclude()
Visual Basic
Protected Function WithinInclude As Boolean
Visual C++
protected:
bool WithinInclude()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_C.WithinInclude"]

See Also

Script_C Class
ElScript Namespace


Write Method

[image] [image]

4 of William Foster's Class Libraries
Script_C..::..Write Method
Script_C Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

Script_C Class
Script_C Members
ElScript Namespace


WriteLine Method

[image] [image]

4 of William Foster's Class Libraries
Script_C..::..WriteLine Method
Script_C Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

Script_C Class
Script_C Members
ElScript Namespace


Script_C Properties

[image] [image]

4 of William Foster's Class Libraries
Script_C Properties
Script_C Class See Also Send Feedback

The Script_C type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script_C Class
ElScript Namespace


Script_C.E_C_IFDEF Enumeration

[image]

4 of William Foster's Class Libraries
Script_C..::..E_C_IFDEF Enumeration
Script_C Class See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Script_C.E_C_IFDEF"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected enum E_C_IFDEF
Visual Basic
Protected Enumeration E_C_IFDEF
Visual C++
protected enum class E_C_IFDEF

Members

Member name | Value | Description
E_IFDEF_IF | 0 |
E_IFDEF_IFDEF | 1 |
E_IFDEF_IFNDEF | 2 |
E_IFDEF_ELSE | 3 |
E_IFDEF_ENDIF | 4 |

See Also

ElScript Namespace


Script_CPlusPlus Class

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Script_CPlusPlus"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Script_CPlusPlus : Script_C
Visual Basic
Public Class Script_CPlusPlus _
    Inherits Script_C
Visual C++
public ref class Script_CPlusPlus : public Script_C

Inheritance Hierarchy

System..::..Object
Stream
ElScript..::..Script_Text
ElScript..::..Script
ElScript..::..Script_XML
ElScript..::..Script_Source
ElScript..::..Script_C
ElScript..::..Script_CPlusPlus

See Also

Script_CPlusPlus Members
ElScript Namespace


Script_CPlusPlus Members

[image] [image]

4 of William Foster's Class Libraries
Script_CPlusPlus Members
Script_CPlusPlus Class Constructors Methods Fields Properties See Also Send Feedback

The Script_CPlusPlus type exposes the following members.

Constructors

 | Name | Description
Public method | Script_CPlusPlus | Initializes a new instance of the Script_CPlusPlus class

Methods

 | Name | Description
Protected method | AddClass |
Protected method | AddFunction |
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Inherited from Script_C.)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML | (Inherited from Script_XML.)
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Public method | LoadSources_Local |
Protected method | LocateClass |
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OkToDeclare |
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Protected method | PopClass |
Protected method | PopNameSpace |
Protected method | PopSource | (Inherited from Script_C.)
Protected method | Process_Class_Declaration |
Protected method | Process_Function_Declaration |
Public method | ProcessDirective | (Inherited from Script_C.)
Protected method | ProcessNext |
Protected method | PushClass |
Protected method | PushNameSpace |
Public method | PushSource(Filename) | (Inherited from Script_C.)
Protected method | PushSource(StreamSource) | (Inherited from Script_C.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadAheadScript_Character_NoDefines | (Inherited from Script_C.)
Public method | ReadBetweenBrackets | (Inherited from Script_C.)
Protected method | ReadIfdefDirective | (Inherited from Script_C.)
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext | (Inherited from Script_XML.)
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Protected method | ReadSourceLine | (Inherited from Script_C.)
Public method | ReadToTagEnd | (Inherited from Script_XML.)
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Inherited from Script_XML.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | SkipIncludedClassdefs |
Protected method | skipping_code | (Inherited from Script_C.)
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkippingStrings | (Inherited from Script_Source.)
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | WithinClassdef |
Public method | WithinComment | (Inherited from Script.)
Protected method | WithinInclude | (Inherited from Script_C.)
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField | (Inherited from Script_XML.)
Public method | WriteAnXMLTag | (Inherited from Script_XML.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

Fields

 | Name | Description
Protected field | m_b_skipping_strings | (Inherited from Script_Source.)
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_cs_LastComment | (Inherited from Script_C.)
Protected field | m_cs_pwdWorkingFrom | (Inherited from Script_C.)
Protected field | m_csa_scannedincludes | (Inherited from Script_C.)
Protected field | m_defines | (Inherited from Script_C.)
Protected field | m_ifdef_depth | (Inherited from Script_C.)
Protected field | m_ifdef_on_depth | (Inherited from Script_C.)
Protected field | m_LinenumberStack | (Inherited from Script_C.)
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_pi | (Inherited from Script_C.)
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_StreamStack | (Inherited from Script_C.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script_CPlusPlus Class
ElScript Namespace


Script_CPlusPlus Constructor

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus Constructor
Script_CPlusPlus Class See Also Send Feedback
Initializes a new instance of the Script_CPlusPlus class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script_CPlusPlus(
    Stream bfc_stream,
    STRING csIncludePaths,
    STRING csSkipIncludes,
    STRING csDefines
)
Visual Basic
Public Sub New ( _
    bfc_stream As Stream, _
    csIncludePaths As STRING, _
    csSkipIncludes As STRING, _
    csDefines As STRING _
)
Visual C++
public:
Script_CPlusPlus(
    Stream^ bfc_stream,
    STRING^ csIncludePaths,
    STRING^ csSkipIncludes,
    STRING^ csDefines
)

Parameters

bfc_stream
Type: Stream

[Missing <param name="bfc_stream"/> documentation for "M:ElScript.Script_CPlusPlus.#ctor(El.Stream,El.STRING,El.STRING,El.STRING)"]

csIncludePaths
Type: STRING

[Missing <param name="csIncludePaths"/> documentation for "M:ElScript.Script_CPlusPlus.#ctor(El.Stream,El.STRING,El.STRING,El.STRING)"]

csSkipIncludes
Type: STRING

[Missing <param name="csSkipIncludes"/> documentation for "M:ElScript.Script_CPlusPlus.#ctor(El.Stream,El.STRING,El.STRING,El.STRING)"]

csDefines
Type: STRING

[Missing <param name="csDefines"/> documentation for "M:ElScript.Script_CPlusPlus.#ctor(El.Stream,El.STRING,El.STRING,El.STRING)"]

See Also

Script_CPlusPlus Class
ElScript Namespace


Script_CPlusPlus Fields

[image] [image]

4 of William Foster's Class Libraries
Script_CPlusPlus Fields
Script_CPlusPlus Class See Also Send Feedback

The Script_CPlusPlus type exposes the following members.

Fields

 | Name | Description
Protected field | m_b_skipping_strings | (Inherited from Script_Source.)
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_cs_LastComment | (Inherited from Script_C.)
Protected field | m_cs_pwdWorkingFrom | (Inherited from Script_C.)
Protected field | m_csa_scannedincludes | (Inherited from Script_C.)
Protected field | m_defines | (Inherited from Script_C.)
Protected field | m_ifdef_depth | (Inherited from Script_C.)
Protected field | m_ifdef_on_depth | (Inherited from Script_C.)
Protected field | m_LinenumberStack | (Inherited from Script_C.)
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_pi | (Inherited from Script_C.)
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_StreamStack | (Inherited from Script_C.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)

See Also

Script_CPlusPlus Class
ElScript Namespace


Script_CPlusPlus Methods

[image] [image]

4 of William Foster's Class Libraries
Script_CPlusPlus Methods
Script_CPlusPlus Class See Also Send Feedback

The Script_CPlusPlus type exposes the following members.

Methods

 | Name | Description
Protected method | AddClass |
Protected method | AddFunction |
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Inherited from Script_C.)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML | (Inherited from Script_XML.)
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Public method | LoadSources_Local |
Protected method | LocateClass |
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OkToDeclare |
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Protected method | PopClass |
Protected method | PopNameSpace |
Protected method | PopSource | (Inherited from Script_C.)
Protected method | Process_Class_Declaration |
Protected method | Process_Function_Declaration |
Public method | ProcessDirective | (Inherited from Script_C.)
Protected method | ProcessNext |
Protected method | PushClass |
Protected method | PushNameSpace |
Public method | PushSource(Filename) | (Inherited from Script_C.)
Protected method | PushSource(StreamSource) | (Inherited from Script_C.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadAheadScript_Character_NoDefines | (Inherited from Script_C.)
Public method | ReadBetweenBrackets | (Inherited from Script_C.)
Protected method | ReadIfdefDirective | (Inherited from Script_C.)
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext | (Inherited from Script_XML.)
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Protected method | ReadSourceLine | (Inherited from Script_C.)
Public method | ReadToTagEnd | (Inherited from Script_XML.)
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Inherited from Script_XML.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | SkipIncludedClassdefs |
Protected method | skipping_code | (Inherited from Script_C.)
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkippingStrings | (Inherited from Script_Source.)
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | WithinClassdef |
Public method | WithinComment | (Inherited from Script.)
Protected method | WithinInclude | (Inherited from Script_C.)
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField | (Inherited from Script_XML.)
Public method | WriteAnXMLTag | (Inherited from Script_XML.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

Script_CPlusPlus Class
ElScript Namespace


AddClass Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..AddClass Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.AddClass(System.String,System.Boolean)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected CPlusPlus_ClassDefinition AddClass(
    string csClassDef,
    bool bNameOnly
)
Visual Basic
Protected Function AddClass ( _
    csClassDef As String, _
    bNameOnly As Boolean _
) As CPlusPlus_ClassDefinition
Visual C++
protected:
CPlusPlus_ClassDefinition^ AddClass(
    String^ csClassDef,
    bool bNameOnly
)

Parameters

csClassDef
Type: System..::..String

[Missing <param name="csClassDef"/> documentation for "M:ElScript.Script_CPlusPlus.AddClass(System.String,System.Boolean)"]

bNameOnly
Type: System..::..Boolean

[Missing <param name="bNameOnly"/> documentation for "M:ElScript.Script_CPlusPlus.AddClass(System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_CPlusPlus.AddClass(System.String,System.Boolean)"]

See Also

Script_CPlusPlus Class
ElScript Namespace


AddFunction Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..AddFunction Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.AddFunction(ElScript.CPlusPlus_FunctionDefinition)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool AddFunction(
    CPlusPlus_FunctionDefinition fdef
)
Visual Basic
Protected Function AddFunction ( _
    fdef As CPlusPlus_FunctionDefinition _
) As Boolean
Visual C++
protected:
bool AddFunction(
    CPlusPlus_FunctionDefinition^ fdef
)

Parameters

fdef
Type: ElScript..::..CPlusPlus_FunctionDefinition

[Missing <param name="fdef"/> documentation for "M:ElScript.Script_CPlusPlus.AddFunction(ElScript.CPlusPlus_FunctionDefinition)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_CPlusPlus.AddFunction(ElScript.CPlusPlus_FunctionDefinition)"]

See Also

Script_CPlusPlus Class
ElScript Namespace


AttachFile Method

[image] [image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..AttachFile Method
Script_CPlusPlus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)

See Also

Script_CPlusPlus Class
Script_CPlusPlus Members
ElScript Namespace


AttachMemory Method

[image] [image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..AttachMemory Method
Script_CPlusPlus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)

See Also

Script_CPlusPlus Class
Script_CPlusPlus Members
ElScript Namespace


LoadSources_Local Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..LoadSources_Local Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.LoadSources_Local"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LoadSources_Local()
Visual Basic
Public Function LoadSources_Local As Boolean
Visual C++
public:
bool LoadSources_Local()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_CPlusPlus.LoadSources_Local"]

See Also

Script_CPlusPlus Class
ElScript Namespace


LocateClass Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..LocateClass Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.LocateClass(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected CPlusPlus_ClassDefinition LocateClass(
    STRING ClassName
)
Visual Basic
Protected Function LocateClass ( _
    ClassName As STRING _
) As CPlusPlus_ClassDefinition
Visual C++
protected:
CPlusPlus_ClassDefinition^ LocateClass(
    STRING^ ClassName
)

Parameters

ClassName
Type: STRING

[Missing <param name="ClassName"/> documentation for "M:ElScript.Script_CPlusPlus.LocateClass(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_CPlusPlus.LocateClass(El.STRING)"]

See Also

Script_CPlusPlus Class
ElScript Namespace


NextChar Method

[image] [image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..NextChar Method
Script_CPlusPlus Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)

See Also

Script_CPlusPlus Class
Script_CPlusPlus Members
ElScript Namespace


OkToDeclare Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..OkToDeclare Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.OkToDeclare"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool OkToDeclare()
Visual Basic
Protected Function OkToDeclare As Boolean
Visual C++
protected:
bool OkToDeclare()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_CPlusPlus.OkToDeclare"]

See Also

Script_CPlusPlus Class
ElScript Namespace


PopClass Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..PopClass Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.PopClass"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void PopClass()
Visual Basic
Protected Sub PopClass
Visual C++
protected:
void PopClass()

See Also

Script_CPlusPlus Class
ElScript Namespace


PopNameSpace Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..PopNameSpace Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.PopNameSpace"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void PopNameSpace()
Visual Basic
Protected Sub PopNameSpace
Visual C++
protected:
void PopNameSpace()

See Also

Script_CPlusPlus Class
ElScript Namespace


Process_Class_Declaration Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..Process_Class_Declaration Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.Process_Class_Declaration(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool Process_Class_Declaration(
    STRING s
)
Visual Basic
Protected Function Process_Class_Declaration ( _
    s As STRING _
) As Boolean
Visual C++
protected:
bool Process_Class_Declaration(
    STRING^ s
)

Parameters

s
Type: STRING

[Missing <param name="s"/> documentation for "M:ElScript.Script_CPlusPlus.Process_Class_Declaration(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_CPlusPlus.Process_Class_Declaration(El.STRING)"]

See Also

Script_CPlusPlus Class
ElScript Namespace


Process_Function_Declaration Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..Process_Function_Declaration Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.Process_Function_Declaration(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool Process_Function_Declaration(
    STRING sline
)
Visual Basic
Protected Function Process_Function_Declaration ( _
    sline As STRING _
) As Boolean
Visual C++
protected:
bool Process_Function_Declaration(
    STRING^ sline
)

Parameters

sline
Type: STRING

[Missing <param name="sline"/> documentation for "M:ElScript.Script_CPlusPlus.Process_Function_Declaration(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_CPlusPlus.Process_Function_Declaration(El.STRING)"]

See Also

Script_CPlusPlus Class
ElScript Namespace


ProcessNext Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..ProcessNext Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.ProcessNext"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool ProcessNext()
Visual Basic
Protected Function ProcessNext As Boolean
Visual C++
protected:
bool ProcessNext()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_CPlusPlus.ProcessNext"]

See Also

Script_CPlusPlus Class
ElScript Namespace


PushClass Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..PushClass Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.PushClass(ElScript.CPlusPlus_ClassDefinition)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void PushClass(
    CPlusPlus_ClassDefinition cl
)
Visual Basic
Protected Sub PushClass ( _
    cl As CPlusPlus_ClassDefinition _
)
Visual C++
protected:
void PushClass(
    CPlusPlus_ClassDefinition^ cl
)

Parameters

cl
Type: ElScript..::..CPlusPlus_ClassDefinition

[Missing <param name="cl"/> documentation for "M:ElScript.Script_CPlusPlus.PushClass(ElScript.CPlusPlus_ClassDefinition)"]

See Also

Script_CPlusPlus Class
ElScript Namespace


PushNameSpace Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..PushNameSpace Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.PushNameSpace(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void PushNameSpace(
    STRING s
)
Visual Basic
Protected Sub PushNameSpace ( _
    s As STRING _
)
Visual C++
protected:
void PushNameSpace(
    STRING^ s
)

Parameters

s
Type: STRING

[Missing <param name="s"/> documentation for "M:ElScript.Script_CPlusPlus.PushNameSpace(El.STRING)"]

See Also

Script_CPlusPlus Class
ElScript Namespace


PushSource Method

[image] [image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..PushSource Method
Script_CPlusPlus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PushSource(Filename) | (Inherited from Script_C.)
Protected method | PushSource(StreamSource) | (Inherited from Script_C.)

See Also

Script_CPlusPlus Class
Script_CPlusPlus Members
ElScript Namespace


ReadLine Method

[image] [image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..ReadLine Method
Script_CPlusPlus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)

See Also

Script_CPlusPlus Class
Script_CPlusPlus Members
ElScript Namespace


ReadScript_ArgumentList_2dPair Method

[image] [image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..ReadScript_ArgumentList_2dPair Method
Script_CPlusPlus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)

See Also

Script_CPlusPlus Class
Script_CPlusPlus Members
ElScript Namespace


Seek Method

[image] [image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..Seek Method
Script_CPlusPlus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)

See Also

Script_CPlusPlus Class
Script_CPlusPlus Members
ElScript Namespace


SkipIncludedClassdefs Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..SkipIncludedClassdefs Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.SkipIncludedClassdefs(System.Boolean)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void SkipIncludedClassdefs(
    bool bOn
)
Visual Basic
Protected Sub SkipIncludedClassdefs ( _
    bOn As Boolean _
)
Visual C++
protected:
void SkipIncludedClassdefs(
    bool bOn
)

Parameters

bOn
Type: System..::..Boolean

[Missing <param name="bOn"/> documentation for "M:ElScript.Script_CPlusPlus.SkipIncludedClassdefs(System.Boolean)"]

See Also

Script_CPlusPlus Class
ElScript Namespace


WithinClassdef Method

[image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..WithinClassdef Method
Script_CPlusPlus Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_CPlusPlus.WithinClassdef"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool WithinClassdef()
Visual Basic
Protected Function WithinClassdef As Boolean
Visual C++
protected:
bool WithinClassdef()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_CPlusPlus.WithinClassdef"]

See Also

Script_CPlusPlus Class
ElScript Namespace


Write Method

[image] [image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..Write Method
Script_CPlusPlus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

Script_CPlusPlus Class
Script_CPlusPlus Members
ElScript Namespace


WriteLine Method

[image] [image]

4 of William Foster's Class Libraries
Script_CPlusPlus..::..WriteLine Method
Script_CPlusPlus Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

Script_CPlusPlus Class
Script_CPlusPlus Members
ElScript Namespace


Script_CPlusPlus Properties

[image] [image]

4 of William Foster's Class Libraries
Script_CPlusPlus Properties
Script_CPlusPlus Class See Also Send Feedback

The Script_CPlusPlus type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script_CPlusPlus Class
ElScript Namespace


Script_Program Class

[image]

4 of William Foster's Class Libraries
Script_Program Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Script_Program"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Script_Program : Script_Source
Visual Basic
Public Class Script_Program _
    Inherits Script_Source
Visual C++
public ref class Script_Program : public Script_Source

Inheritance Hierarchy

System..::..Object
Stream
ElScript..::..Script_Text
ElScript..::..Script
ElScript..::..Script_XML
ElScript..::..Script_Source
ElScript..::..Script_Program

See Also

Script_Program Members
ElScript Namespace


Script_Program Members

[image] [image]

4 of William Foster's Class Libraries
Script_Program Members
Script_Program Class Constructors Methods Fields Properties See Also Send Feedback

The Script_Program type exposes the following members.

Constructors

 | Name | Description
Public method | Script_Program | Initializes a new instance of the Script_Program class

Methods

 | Name | Description
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | Assign_Variable |
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Inherited from Script.)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Protected method | Compile |
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML | (Inherited from Script_XML.)
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Script_Text..::..Finalize()()()().)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Protected method | GetNextStatement |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext | (Inherited from Script_XML.)
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Public method | ReadToTagEnd | (Inherited from Script_XML.)
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Inherited from Script_XML.)
Public method | Run |
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkippingStrings | (Inherited from Script_Source.)
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment | (Inherited from Script.)
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField | (Inherited from Script_XML.)
Public method | WriteAnXMLTag | (Inherited from Script_XML.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

Fields

 | Name | Description
Protected field | m_b_skipping_strings | (Inherited from Script_Source.)
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script_Program Class
ElScript Namespace


Script_Program Constructor

[image]

4 of William Foster's Class Libraries
Script_Program Constructor
Script_Program Class See Also Send Feedback
Initializes a new instance of the Script_Program class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script_Program(
    Stream bfc_stream
)
Visual Basic
Public Sub New ( _
    bfc_stream As Stream _
)
Visual C++
public:
Script_Program(
    Stream^ bfc_stream
)

Parameters

bfc_stream
Type: Stream

[Missing <param name="bfc_stream"/> documentation for "M:ElScript.Script_Program.#ctor(El.Stream)"]

See Also

Script_Program Class
ElScript Namespace


Script_Program Fields

[image] [image]

4 of William Foster's Class Libraries
Script_Program Fields
Script_Program Class See Also Send Feedback

The Script_Program type exposes the following members.

Fields

 | Name | Description
Protected field | m_b_skipping_strings | (Inherited from Script_Source.)
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)

See Also

Script_Program Class
ElScript Namespace


Script_Program Methods

[image] [image]

4 of William Foster's Class Libraries
Script_Program Methods
Script_Program Class See Also Send Feedback

The Script_Program type exposes the following members.

Methods

 | Name | Description
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | Assign_Variable |
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Inherited from Script.)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Protected method | Compile |
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML | (Inherited from Script_XML.)
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Script_Text..::..Finalize()()()().)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Protected method | GetNextStatement |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext | (Inherited from Script_XML.)
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Public method | ReadToTagEnd | (Inherited from Script_XML.)
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Inherited from Script_XML.)
Public method | Run |
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkippingStrings | (Inherited from Script_Source.)
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment | (Inherited from Script.)
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField | (Inherited from Script_XML.)
Public method | WriteAnXMLTag | (Inherited from Script_XML.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

Script_Program Class
ElScript Namespace


Assign_Variable Method

[image]

4 of William Foster's Class Libraries
Script_Program..::..Assign_Variable Method
Script_Program Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Program.Assign_Variable"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Assign_Variable()
Visual Basic
Public Function Assign_Variable As Boolean
Visual C++
public:
bool Assign_Variable()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Program.Assign_Variable"]

See Also

Script_Program Class
ElScript Namespace


AttachFile Method

[image] [image]

4 of William Foster's Class Libraries
Script_Program..::..AttachFile Method
Script_Program Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)

See Also

Script_Program Class
Script_Program Members
ElScript Namespace


AttachMemory Method

[image] [image]

4 of William Foster's Class Libraries
Script_Program..::..AttachMemory Method
Script_Program Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)

See Also

Script_Program Class
Script_Program Members
ElScript Namespace


Compile Method

[image]

4 of William Foster's Class Libraries
Script_Program..::..Compile Method
Script_Program Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Program.Compile"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool Compile()
Visual Basic
Protected Function Compile As Boolean
Visual C++
protected:
bool Compile()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Program.Compile"]

See Also

Script_Program Class
ElScript Namespace


Finalize Method

[image]

4 of William Foster's Class Libraries
Script_Program..::..Finalize Method
Script_Program Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Program.Finalize"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Script_Program Class
ElScript Namespace


GetNextStatement Method

[image]

4 of William Foster's Class Libraries
Script_Program..::..GetNextStatement Method
Script_Program Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Program.GetNextStatement(El.STRING@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool GetNextStatement(
    out STRING cs
)
Visual Basic
Protected Function GetNextStatement ( _
    <OutAttribute> ByRef cs As STRING _
) As Boolean
Visual C++
protected:
bool GetNextStatement(
    [OutAttribute] STRING^% cs
)

Parameters

cs
Type: STRING%

[Missing <param name="cs"/> documentation for "M:ElScript.Script_Program.GetNextStatement(El.STRING@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Program.GetNextStatement(El.STRING@)"]

See Also

Script_Program Class
ElScript Namespace


NextChar Method

[image] [image]

4 of William Foster's Class Libraries
Script_Program..::..NextChar Method
Script_Program Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)

See Also

Script_Program Class
Script_Program Members
ElScript Namespace


ReadLine Method

[image] [image]

4 of William Foster's Class Libraries
Script_Program..::..ReadLine Method
Script_Program Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)

See Also

Script_Program Class
Script_Program Members
ElScript Namespace


ReadScript_ArgumentList_2dPair Method

[image] [image]

4 of William Foster's Class Libraries
Script_Program..::..ReadScript_ArgumentList_2dPair Method
Script_Program Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)

See Also

Script_Program Class
Script_Program Members
ElScript Namespace


Run Method

[image]

4 of William Foster's Class Libraries
Script_Program..::..Run Method
Script_Program Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Program.Run"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Run()
Visual Basic
Public Function Run As Boolean
Visual C++
public:
bool Run()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Program.Run"]

See Also

Script_Program Class
ElScript Namespace


Seek Method

[image] [image]

4 of William Foster's Class Libraries
Script_Program..::..Seek Method
Script_Program Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)

See Also

Script_Program Class
Script_Program Members
ElScript Namespace


Write Method

[image] [image]

4 of William Foster's Class Libraries
Script_Program..::..Write Method
Script_Program Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

Script_Program Class
Script_Program Members
ElScript Namespace


WriteLine Method

[image] [image]

4 of William Foster's Class Libraries
Script_Program..::..WriteLine Method
Script_Program Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

Script_Program Class
Script_Program Members
ElScript Namespace


Script_Program Properties

[image] [image]

4 of William Foster's Class Libraries
Script_Program Properties
Script_Program Class See Also Send Feedback

The Script_Program type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script_Program Class
ElScript Namespace


Script_Source Class

[image]

4 of William Foster's Class Libraries
Script_Source Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Script_Source"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Script_Source : Script_XML
Visual Basic
Public Class Script_Source _
    Inherits Script_XML
Visual C++
public ref class Script_Source : public Script_XML

Inheritance Hierarchy

System..::..Object
Stream
ElScript..::..Script_Text
ElScript..::..Script
ElScript..::..Script_XML
ElScript..::..Script_Source
ElScript..::..Script_C
ElScript..::..Script_Program

See Also

Script_Source Members
ElScript Namespace


Script_Source Members

[image] [image]

4 of William Foster's Class Libraries
Script_Source Members
Script_Source Class Constructors Methods Fields Properties See Also Send Feedback

The Script_Source type exposes the following members.

Constructors

 | Name | Description
Public method | Script_Source | Initializes a new instance of the Script_Source class

Methods

 | Name | Description
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Inherited from Script.)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML | (Inherited from Script_XML.)
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext | (Inherited from Script_XML.)
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Public method | ReadToTagEnd | (Inherited from Script_XML.)
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Inherited from Script_XML.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkippingStrings |
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment | (Inherited from Script.)
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField | (Inherited from Script_XML.)
Public method | WriteAnXMLTag | (Inherited from Script_XML.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

Fields

 | Name | Description
Protected field | m_b_skipping_strings |
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script_Source Class
ElScript Namespace


Script_Source Constructor

[image]

4 of William Foster's Class Libraries
Script_Source Constructor
Script_Source Class See Also Send Feedback
Initializes a new instance of the Script_Source class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script_Source(
    Stream bfc_stream
)
Visual Basic
Public Sub New ( _
    bfc_stream As Stream _
)
Visual C++
public:
Script_Source(
    Stream^ bfc_stream
)

Parameters

bfc_stream
Type: Stream

[Missing <param name="bfc_stream"/> documentation for "M:ElScript.Script_Source.#ctor(El.Stream)"]

See Also

Script_Source Class
ElScript Namespace


Script_Source Fields

[image] [image]

4 of William Foster's Class Libraries
Script_Source Fields
Script_Source Class See Also Send Feedback

The Script_Source type exposes the following members.

Fields

 | Name | Description
Protected field | m_b_skipping_strings |
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)

See Also

Script_Source Class
ElScript Namespace


m_b_skipping_strings Field

[image]

4 of William Foster's Class Libraries
Script_Source..::..m_b_skipping_strings Field
Script_Source Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script_Source.m_b_skipping_strings"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool m_b_skipping_strings
Visual Basic
Protected m_b_skipping_strings As Boolean
Visual C++
protected:
bool m_b_skipping_strings

See Also

Script_Source Class
ElScript Namespace


Script_Source Methods

[image] [image]

4 of William Foster's Class Libraries
Script_Source Methods
Script_Source Class See Also Send Feedback

The Script_Source type exposes the following members.

Methods

 | Name | Description
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Inherited from Script.)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML | (Inherited from Script_XML.)
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext | (Inherited from Script_XML.)
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Public method | ReadToTagEnd | (Inherited from Script_XML.)
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Inherited from Script_XML.)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkippingStrings |
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment | (Inherited from Script.)
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField | (Inherited from Script_XML.)
Public method | WriteAnXMLTag | (Inherited from Script_XML.)
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

Script_Source Class
ElScript Namespace


AttachFile Method

[image] [image]

4 of William Foster's Class Libraries
Script_Source..::..AttachFile Method
Script_Source Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)

See Also

Script_Source Class
Script_Source Members
ElScript Namespace


AttachMemory Method

[image] [image]

4 of William Foster's Class Libraries
Script_Source..::..AttachMemory Method
Script_Source Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)

See Also

Script_Source Class
Script_Source Members
ElScript Namespace


NextChar Method

[image] [image]

4 of William Foster's Class Libraries
Script_Source..::..NextChar Method
Script_Source Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)

See Also

Script_Source Class
Script_Source Members
ElScript Namespace


ReadLine Method

[image] [image]

4 of William Foster's Class Libraries
Script_Source..::..ReadLine Method
Script_Source Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)

See Also

Script_Source Class
Script_Source Members
ElScript Namespace


ReadScript_ArgumentList_2dPair Method

[image] [image]

4 of William Foster's Class Libraries
Script_Source..::..ReadScript_ArgumentList_2dPair Method
Script_Source Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)

See Also

Script_Source Class
Script_Source Members
ElScript Namespace


Seek Method

[image] [image]

4 of William Foster's Class Libraries
Script_Source..::..Seek Method
Script_Source Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)

See Also

Script_Source Class
Script_Source Members
ElScript Namespace


SkippingStrings Method

[image]

4 of William Foster's Class Libraries
Script_Source..::..SkippingStrings Method
Script_Source Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Source.SkippingStrings(System.Boolean)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SkippingStrings(
    bool bOn
)
Visual Basic
Public Sub SkippingStrings ( _
    bOn As Boolean _
)
Visual C++
public:
void SkippingStrings(
    bool bOn
)

Parameters

bOn
Type: System..::..Boolean

[Missing <param name="bOn"/> documentation for "M:ElScript.Script_Source.SkippingStrings(System.Boolean)"]

See Also

Script_Source Class
ElScript Namespace


Write Method

[image] [image]

4 of William Foster's Class Libraries
Script_Source..::..Write Method
Script_Source Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

Script_Source Class
Script_Source Members
ElScript Namespace


WriteLine Method

[image] [image]

4 of William Foster's Class Libraries
Script_Source..::..WriteLine Method
Script_Source Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

Script_Source Class
Script_Source Members
ElScript Namespace


Script_Source Properties

[image] [image]

4 of William Foster's Class Libraries
Script_Source Properties
Script_Source Class See Also Send Feedback

The Script_Source type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script_Source Class
ElScript Namespace


Script_Text Class

[image]

4 of William Foster's Class Libraries
Script_Text Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Script_Text"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Script_Text : Stream
Visual Basic
Public Class Script_Text _
    Inherits Stream
Visual C++
public ref class Script_Text : public Stream

Inheritance Hierarchy

System..::..Object
Stream
ElScript..::..Script_Text
ElScript..::..Script

See Also

Script_Text Members
ElScript Namespace


Script_Text Members

[image] [image]

4 of William Foster's Class Libraries
Script_Text Members
Script_Text Class Constructors Methods Fields Properties See Also Send Feedback

The Script_Text type exposes the following members.

Constructors

 | Name | Description
Public method | Script_Text()()()() | Initializes a new instance of the Script_Text class
Public method | Script_Text(Stream) | Initializes a new instance of the Script_Text class
Public method | Script_Text(Script_Text) | Initializes a new instance of the Script_Text class
Public method | Script_Text(Filename, Boolean) | Initializes a new instance of the Script_Text class

Methods

 | Name | Description
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution |
Public method | AppendToFile | (Inherited from Stream.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Protected method | ClearBuffer |
Public method | Close | (Inherited from Stream.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Protected method | EmptyBuffer |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides StreamFinalize()()()().)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter |
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttach | (Overrides StreamOnAttach()()()().)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadLine(STRING%) |
Public method | ReadLine(String%) |
Public method | RefillBuffer |
Public method | Rewind | (Overrides StreamRewind()()()().)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Overrides StreamSeek(UInt32, UInt64, UInt64%).)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter |
Public method | SetMaxLineLength |
Public method | SetThreaded | (Inherited from Stream.)
Protected method | SkippingLinefeeds |
Public method | Tell | (Overrides StreamTell()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write(STRING) | (Overrides StreamWrite(STRING).)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified |
Public method | WriteLine(STRING) |
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) |
Public method | WriteLine(String, array<Object>[]()[][]) |

Fields

 | Name | Description
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_MaxLineLength |
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber |

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script_Text Class
ElScript Namespace


Script_Text Constructor

[image] [image]

4 of William Foster's Class Libraries
Script_Text Constructor
Script_Text Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Script_Text()()()() | Initializes a new instance of the Script_Text class
Public method | Script_Text(Stream) | Initializes a new instance of the Script_Text class
Public method | Script_Text(Script_Text) | Initializes a new instance of the Script_Text class
Public method | Script_Text(Filename, Boolean) | Initializes a new instance of the Script_Text class

See Also

Script_Text Class
Script_Text Members
ElScript Namespace


Script_Text Constructor

[image]

4 of William Foster's Class Libraries
Script_Text Constructor
Script_Text Class See Also Send Feedback
Initializes a new instance of the Script_Text class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script_Text()
Visual Basic
Public Sub New
Visual C++
public:
Script_Text()

See Also

Script_Text Class
Script_Text Overload
ElScript Namespace


Script_Text Constructor ()

[image]

4 of William Foster's Class Libraries
Script_Text Constructor ()
Script_Text Class See Also Send Feedback
Initializes a new instance of the Script_Text class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script_Text(
    Stream bfc_stream
)
Visual Basic
Public Sub New ( _
    bfc_stream As Stream _
)
Visual C++
public:
Script_Text(
    Stream^ bfc_stream
)

Parameters

bfc_stream
Type: Stream

[Missing <param name="bfc_stream"/> documentation for "M:ElScript.Script_Text.#ctor(El.Stream)"]

See Also

Script_Text Class
Script_Text Overload
ElScript Namespace


Script_Text Constructor (Script_Text)

[image]

4 of William Foster's Class Libraries
Script_Text Constructor (Script_Text)
Script_Text Class See Also Send Feedback
Initializes a new instance of the Script_Text class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script_Text(
    Script_Text bfc_text_stream
)
Visual Basic
Public Sub New ( _
    bfc_text_stream As Script_Text _
)
Visual C++
public:
Script_Text(
    Script_Text^ bfc_text_stream
)

Parameters

bfc_text_stream
Type: ElScript..::..Script_Text

[Missing <param name="bfc_text_stream"/> documentation for "M:ElScript.Script_Text.#ctor(ElScript.Script_Text)"]

See Also

Script_Text Class
Script_Text Overload
ElScript Namespace


Script_Text Constructor (, Boolean)

[image]

4 of William Foster's Class Libraries
Script_Text Constructor (, Boolean)
Script_Text Class See Also Send Feedback
Initializes a new instance of the Script_Text class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script_Text(
    Filename bfc_filename,
    bool b_ReadOnly
)
Visual Basic
Public Sub New ( _
    bfc_filename As Filename, _
    b_ReadOnly As Boolean _
)
Visual C++
public:
Script_Text(
    Filename^ bfc_filename,
    bool b_ReadOnly
)

Parameters

bfc_filename
Type: Filename

[Missing <param name="bfc_filename"/> documentation for "M:ElScript.Script_Text.#ctor(El.Filename,System.Boolean)"]

b_ReadOnly
Type: System..::..Boolean

[Missing <param name="b_ReadOnly"/> documentation for "M:ElScript.Script_Text.#ctor(El.Filename,System.Boolean)"]

See Also

Script_Text Class
Script_Text Overload
ElScript Namespace


Script_Text Fields

[image] [image]

4 of William Foster's Class Libraries
Script_Text Fields
Script_Text Class See Also Send Feedback

The Script_Text type exposes the following members.

Fields

 | Name | Description
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_MaxLineLength |
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber |

See Also

Script_Text Class
ElScript Namespace


m_MaxLineLength Field

[image]

4 of William Foster's Class Libraries
Script_Text..::..m_MaxLineLength Field
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script_Text.m_MaxLineLength"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected uint m_MaxLineLength
Visual Basic
Protected m_MaxLineLength As UInteger
Visual C++
protected:
unsigned int m_MaxLineLength

See Also

Script_Text Class
ElScript Namespace


m_uLineNumber Field

[image]

4 of William Foster's Class Libraries
Script_Text..::..m_uLineNumber Field
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "F:ElScript.Script_Text.m_uLineNumber"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected uint m_uLineNumber
Visual Basic
Protected m_uLineNumber As UInteger
Visual C++
protected:
unsigned int m_uLineNumber

See Also

Script_Text Class
ElScript Namespace


Script_Text Methods

[image] [image]

4 of William Foster's Class Libraries
Script_Text Methods
Script_Text Class See Also Send Feedback

The Script_Text type exposes the following members.

Methods

 | Name | Description
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution |
Public method | AppendToFile | (Inherited from Stream.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Protected method | ClearBuffer |
Public method | Close | (Inherited from Stream.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Protected method | EmptyBuffer |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides StreamFinalize()()()().)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter |
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttach | (Overrides StreamOnAttach()()()().)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadLine(STRING%) |
Public method | ReadLine(String%) |
Public method | RefillBuffer |
Public method | Rewind | (Overrides StreamRewind()()()().)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Overrides StreamSeek(UInt32, UInt64, UInt64%).)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter |
Public method | SetMaxLineLength |
Public method | SetThreaded | (Inherited from Stream.)
Protected method | SkippingLinefeeds |
Public method | Tell | (Overrides StreamTell()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write(STRING) | (Overrides StreamWrite(STRING).)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified |
Public method | WriteLine(STRING) |
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) |
Public method | WriteLine(String, array<Object>[]()[][]) |

See Also

Script_Text Class
ElScript Namespace


AppendStreamWithSubstitution Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..AppendStreamWithSubstitution Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.AppendStreamWithSubstitution(ElScript.Script_Text,El.STRING[],El.STRING[])"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AppendStreamWithSubstitution(
    Script_Text stream,
    STRING[] substitute_array,
    STRING[] replace_array
)
Visual Basic
Public Function AppendStreamWithSubstitution ( _
    stream As Script_Text, _
    substitute_array As STRING(), _
    replace_array As STRING() _
) As Boolean
Visual C++
public:
bool AppendStreamWithSubstitution(
    Script_Text^ stream,
    array<STRING^>^ substitute_array,
    array<STRING^>^ replace_array
)

Parameters

stream
Type: ElScript..::..Script_Text

[Missing <param name="stream"/> documentation for "M:ElScript.Script_Text.AppendStreamWithSubstitution(ElScript.Script_Text,El.STRING[],El.STRING[])"]

substitute_array
Type: array<STRING>[]()[][]

[Missing <param name="substitute_array"/> documentation for "M:ElScript.Script_Text.AppendStreamWithSubstitution(ElScript.Script_Text,El.STRING[],El.STRING[])"]

replace_array
Type: array<STRING>[]()[][]

[Missing <param name="replace_array"/> documentation for "M:ElScript.Script_Text.AppendStreamWithSubstitution(ElScript.Script_Text,El.STRING[],El.STRING[])"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.AppendStreamWithSubstitution(ElScript.Script_Text,El.STRING[],El.STRING[])"]

See Also

Script_Text Class
ElScript Namespace


AttachFile Method

[image] [image]

4 of William Foster's Class Libraries
Script_Text..::..AttachFile Method
Script_Text Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)

See Also

Script_Text Class
Script_Text Members
ElScript Namespace


AttachMemory Method

[image] [image]

4 of William Foster's Class Libraries
Script_Text..::..AttachMemory Method
Script_Text Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)

See Also

Script_Text Class
Script_Text Members
ElScript Namespace


ClearBuffer Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..ClearBuffer Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.ClearBuffer"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool ClearBuffer()
Visual Basic
Protected Function ClearBuffer As Boolean
Visual C++
protected:
bool ClearBuffer()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.ClearBuffer"]

See Also

Script_Text Class
ElScript Namespace


EmptyBuffer Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..EmptyBuffer Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.EmptyBuffer"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void EmptyBuffer()
Visual Basic
Protected Sub EmptyBuffer
Visual C++
protected:
void EmptyBuffer()

See Also

Script_Text Class
ElScript Namespace


Finalize Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..Finalize Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.Finalize"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Script_Text Class
ElScript Namespace


GetBytesPerCharacter Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..GetBytesPerCharacter Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.GetBytesPerCharacter"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint GetBytesPerCharacter()
Visual Basic
Public Function GetBytesPerCharacter As UInteger
Visual C++
public:
unsigned int GetBytesPerCharacter()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.GetBytesPerCharacter"]

See Also

Script_Text Class
ElScript Namespace


GetLineNumber Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..GetLineNumber Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.GetLineNumber"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint GetLineNumber()
Visual Basic
Public Function GetLineNumber As UInteger
Visual C++
public:
unsigned int GetLineNumber()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.GetLineNumber"]

See Also

Script_Text Class
ElScript Namespace


OnAttach Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..OnAttach Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.OnAttach"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool OnAttach()
Visual Basic
Protected Overrides Function OnAttach As Boolean
Visual C++
protected:
virtual bool OnAttach() override

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.OnAttach"]

See Also

Script_Text Class
ElScript Namespace


ReadLine Method

[image] [image]

4 of William Foster's Class Libraries
Script_Text..::..ReadLine Method
Script_Text Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadLine(STRING%) |
Public method | ReadLine(String%) |

See Also

Script_Text Class
Script_Text Members
ElScript Namespace


ReadLine Method ()

[image]

4 of William Foster's Class Libraries
Script_Text..::..ReadLine Method (%)
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.ReadLine(El.STRING@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadLine(
    out STRING s
)
Visual Basic
Public Function ReadLine ( _
    <OutAttribute> ByRef s As STRING _
) As Boolean
Visual C++
public:
bool ReadLine(
    [OutAttribute] STRING^% s
)

Parameters

s
Type: STRING%

[Missing <param name="s"/> documentation for "M:ElScript.Script_Text.ReadLine(El.STRING@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.ReadLine(El.STRING@)"]

See Also

Script_Text Class
ReadLine Overload
ElScript Namespace


ReadLine Method (String)

[image]

4 of William Foster's Class Libraries
Script_Text..::..ReadLine Method (String%)
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.ReadLine(System.String@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadLine(
    out string s
)
Visual Basic
Public Function ReadLine ( _
    <OutAttribute> ByRef s As String _
) As Boolean
Visual C++
public:
bool ReadLine(
    [OutAttribute] String^% s
)

Parameters

s
Type: System..::..String %

[Missing <param name="s"/> documentation for "M:ElScript.Script_Text.ReadLine(System.String@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.ReadLine(System.String@)"]

See Also

Script_Text Class
ReadLine Overload
ElScript Namespace


RefillBuffer Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..RefillBuffer Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.RefillBuffer"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RefillBuffer()
Visual Basic
Public Function RefillBuffer As Boolean
Visual C++
public:
bool RefillBuffer()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.RefillBuffer"]

See Also

Script_Text Class
ElScript Namespace


Rewind Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..Rewind Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.Rewind"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool Rewind()
Visual Basic
Public Overrides Function Rewind As Boolean
Visual C++
public:
virtual bool Rewind() override

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.Rewind"]

See Also

Script_Text Class
ElScript Namespace


Seek Method

[image] [image]

4 of William Foster's Class Libraries
Script_Text..::..Seek Method
Script_Text Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Overrides StreamSeek(UInt32, UInt64, UInt64%).)

See Also

Script_Text Class
Script_Text Members
ElScript Namespace


Seek Method (UInt32, UInt64, UInt64)

[image]

4 of William Foster's Class Libraries
Script_Text..::..Seek Method (UInt32, UInt64, UInt64%)
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.Seek(System.UInt32,System.UInt64,System.UInt64@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool Seek(
    uint n64Offset,
    ulong ulOrigin,
    out ulong un64NewPosition
)
Visual Basic
Public Overrides Function Seek ( _
    n64Offset As UInteger, _
    ulOrigin As ULong, _
    <OutAttribute> ByRef un64NewPosition As ULong _
) As Boolean
Visual C++
public:
virtual bool Seek(
    unsigned int n64Offset,
    unsigned long long ulOrigin,
    [OutAttribute] unsigned long long% un64NewPosition
) override

Parameters

n64Offset
Type: System..::..UInt32

[Missing <param name="n64Offset"/> documentation for "M:ElScript.Script_Text.Seek(System.UInt32,System.UInt64,System.UInt64@)"]

ulOrigin
Type: System..::..UInt64

[Missing <param name="ulOrigin"/> documentation for "M:ElScript.Script_Text.Seek(System.UInt32,System.UInt64,System.UInt64@)"]

un64NewPosition
Type: System..::..UInt64 %

[Missing <param name="un64NewPosition"/> documentation for "M:ElScript.Script_Text.Seek(System.UInt32,System.UInt64,System.UInt64@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.Seek(System.UInt32,System.UInt64,System.UInt64@)"]

See Also

Script_Text Class
Seek Overload
ElScript Namespace


SetBytesPerCharacter Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..SetBytesPerCharacter Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.SetBytesPerCharacter(System.UInt32)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetBytesPerCharacter(
    uint u_BytesPerCharacter
)
Visual Basic
Public Sub SetBytesPerCharacter ( _
    u_BytesPerCharacter As UInteger _
)
Visual C++
public:
void SetBytesPerCharacter(
    unsigned int u_BytesPerCharacter
)

Parameters

u_BytesPerCharacter
Type: System..::..UInt32

[Missing <param name="u_BytesPerCharacter"/> documentation for "M:ElScript.Script_Text.SetBytesPerCharacter(System.UInt32)"]

See Also

Script_Text Class
ElScript Namespace


SetMaxLineLength Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..SetMaxLineLength Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.SetMaxLineLength(System.UInt32)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetMaxLineLength(
    uint maxlen
)
Visual Basic
Public Sub SetMaxLineLength ( _
    maxlen As UInteger _
)
Visual C++
public:
void SetMaxLineLength(
    unsigned int maxlen
)

Parameters

maxlen
Type: System..::..UInt32

[Missing <param name="maxlen"/> documentation for "M:ElScript.Script_Text.SetMaxLineLength(System.UInt32)"]

See Also

Script_Text Class
ElScript Namespace


SkippingLinefeeds Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..SkippingLinefeeds Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.SkippingLinefeeds"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual bool SkippingLinefeeds()
Visual Basic
Protected Overridable Function SkippingLinefeeds As Boolean
Visual C++
protected:
virtual bool SkippingLinefeeds()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.SkippingLinefeeds"]

See Also

Script_Text Class
ElScript Namespace


Tell Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..Tell Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.Tell"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override uint Tell()
Visual Basic
Public Overrides Function Tell As UInteger
Visual C++
public:
virtual unsigned int Tell() override

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.Tell"]

See Also

Script_Text Class
ElScript Namespace


Write Method

[image] [image]

4 of William Foster's Class Libraries
Script_Text..::..Write Method
Script_Text Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(STRING) | (Overrides StreamWrite(STRING).)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

Script_Text Class
Script_Text Members
ElScript Namespace


Write Method ()

[image]

4 of William Foster's Class Libraries
Script_Text..::..Write Method ()
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.Write(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool Write(
    STRING cs
)
Visual Basic
Public Overrides Function Write ( _
    cs As STRING _
) As Boolean
Visual C++
public:
virtual bool Write(
    STRING^ cs
) override

Parameters

cs
Type: STRING

[Missing <param name="cs"/> documentation for "M:ElScript.Script_Text.Write(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.Write(El.STRING)"]

See Also

Script_Text Class
Write Overload
ElScript Namespace


Write_Tabbified Method

[image]

4 of William Foster's Class Libraries
Script_Text..::..Write_Tabbified Method
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.Write_Tabbified(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Write_Tabbified(
    STRING text
)
Visual Basic
Public Function Write_Tabbified ( _
    text As STRING _
) As Boolean
Visual C++
public:
bool Write_Tabbified(
    STRING^ text
)

Parameters

text
Type: STRING

[Missing <param name="text"/> documentation for "M:ElScript.Script_Text.Write_Tabbified(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.Write_Tabbified(El.STRING)"]

See Also

Script_Text Class
ElScript Namespace


WriteLine Method

[image] [image]

4 of William Foster's Class Libraries
Script_Text..::..WriteLine Method
Script_Text Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteLine(STRING) |
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) |
Public method | WriteLine(String, array<Object>[]()[][]) |

See Also

Script_Text Class
Script_Text Members
ElScript Namespace


WriteLine Method ()

[image]

4 of William Foster's Class Libraries
Script_Text..::..WriteLine Method ()
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.WriteLine(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WriteLine(
    STRING cs
)
Visual Basic
Public Function WriteLine ( _
    cs As STRING _
) As Boolean
Visual C++
public:
bool WriteLine(
    STRING^ cs
)

Parameters

cs
Type: STRING

[Missing <param name="cs"/> documentation for "M:ElScript.Script_Text.WriteLine(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.WriteLine(El.STRING)"]

See Also

Script_Text Class
WriteLine Overload
ElScript Namespace


WriteLine Method (Char[], Object[])

[image]

4 of William Foster's Class Libraries
Script_Text..::..WriteLine Method (array<Char>[]()[][], array<Object>[]()[][])
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.WriteLine(System.Char[],System.Object[])"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WriteLine(
    char[] lpszFormat,
    params Object[] argList
)
Visual Basic
Public Function WriteLine ( _
    lpszFormat As Char(), _
    ParamArray argList As Object() _
) As Boolean
Visual C++
public:
bool WriteLine(
    array<wchar_t>^ lpszFormat,
    ... array<Object^>^ argList
)

Parameters

lpszFormat
Type: array< System..::..Char >[]()[][]

[Missing <param name="lpszFormat"/> documentation for "M:ElScript.Script_Text.WriteLine(System.Char[],System.Object[])"]

argList
Type: array< System..::..Object >[]()[][]

[Missing <param name="argList"/> documentation for "M:ElScript.Script_Text.WriteLine(System.Char[],System.Object[])"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.WriteLine(System.Char[],System.Object[])"]

See Also

Script_Text Class
WriteLine Overload
ElScript Namespace


WriteLine Method (String, Object[])

[image]

4 of William Foster's Class Libraries
Script_Text..::..WriteLine Method (String, array<Object>[]()[][])
Script_Text Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_Text.WriteLine(System.String,System.Object[])"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WriteLine(
    string szFormat,
    params Object[] argList
)
Visual Basic
Public Function WriteLine ( _
    szFormat As String, _
    ParamArray argList As Object() _
) As Boolean
Visual C++
public:
bool WriteLine(
    String^ szFormat,
    ... array<Object^>^ argList
)

Parameters

szFormat
Type: System..::..String

[Missing <param name="szFormat"/> documentation for "M:ElScript.Script_Text.WriteLine(System.String,System.Object[])"]

argList
Type: array< System..::..Object >[]()[][]

[Missing <param name="argList"/> documentation for "M:ElScript.Script_Text.WriteLine(System.String,System.Object[])"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_Text.WriteLine(System.String,System.Object[])"]

See Also

Script_Text Class
WriteLine Overload
ElScript Namespace


Script_Text Properties

[image] [image]

4 of William Foster's Class Libraries
Script_Text Properties
Script_Text Class See Also Send Feedback

The Script_Text type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script_Text Class
ElScript Namespace


Script_XML Class

[image]

4 of William Foster's Class Libraries
Script_XML Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Script_XML"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Script_XML : Script
Visual Basic
Public Class Script_XML _
    Inherits Script
Visual C++
public ref class Script_XML : public Script

Inheritance Hierarchy

System..::..Object
Stream
ElScript..::..Script_Text
ElScript..::..Script
ElScript..::..Script_XML
ElGUI..::..ScriptResource
ElImage..::..ScriptImage
ElScript..::..Script_Source

See Also

Script_XML Members
ElScript Namespace


Script_XML Members

[image] [image]

4 of William Foster's Class Libraries
Script_XML Members
Script_XML Class Constructors Methods Fields Properties See Also Send Feedback

The Script_XML type exposes the following members.

Constructors

 | Name | Description
Public method | Script_XML | Initializes a new instance of the Script_XML class

Methods

 | Name | Description
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Inherited from Script.)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML |
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext |
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Public method | ReadToTagEnd |
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Overrides Script..::..Rewind()()()().)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment | (Inherited from Script.)
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField |
Public method | WriteAnXMLTag |
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

Fields

 | Name | Description
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script_XML Class
ElScript Namespace


Script_XML Constructor

[image]

4 of William Foster's Class Libraries
Script_XML Constructor
Script_XML Class See Also Send Feedback
Initializes a new instance of the Script_XML class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script_XML(
    Stream bfc_stream
)
Visual Basic
Public Sub New ( _
    bfc_stream As Stream _
)
Visual C++
public:
Script_XML(
    Stream^ bfc_stream
)

Parameters

bfc_stream
Type: Stream

[Missing <param name="bfc_stream"/> documentation for "M:ElScript.Script_XML.#ctor(El.Stream)"]

See Also

Script_XML Class
ElScript Namespace


Script_XML Fields

[image] [image]

4 of William Foster's Class Libraries
Script_XML Fields
Script_XML Class See Also Send Feedback

The Script_XML type exposes the following members.

Fields

 | Name | Description
Protected field | m_bOkAddComments | (Inherited from Script.)
Public field | m_bReadOnly | (Inherited from Stream.)
Protected field | m_bSkippingComments | (Inherited from Script.)
Protected field | m_MaxLineLength | (Inherited from Script_Text.)
Protected field | m_phrase | (Inherited from Script.)
Protected field | m_saMidlineCommentChars | (Inherited from Script.)
Protected field | m_source | (Inherited from Stream.)
Protected field | m_ThreadInfo | (Inherited from Stream.)
Protected field | m_uLineNumber | (Inherited from Script_Text.)

See Also

Script_XML Class
ElScript Namespace


Script_XML Methods

[image] [image]

4 of William Foster's Class Libraries
Script_XML Methods
Script_XML Class See Also Send Feedback

The Script_XML type exposes the following members.

Methods

 | Name | Description
Public method | AppendScript | (Inherited from Script.)
Public method | AppendStream | (Inherited from Stream.)
Public method | AppendStreamWithSubstitution | (Inherited from Script_Text.)
Public method | AppendToFile | (Inherited from Stream.)
Public method | AtEOL | (Inherited from Script.)
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachStream | (Inherited from Stream.)
Public method | BufferNextLine | (Inherited from Script.)
Protected method | BufferScript | (Inherited from Script.)
Protected method | ClearBuffer | (Inherited from Script_Text.)
Public method | Close | (Inherited from Stream.)
Public method | Constructor | (Inherited from Script.)
Public method | CreateFile | (Inherited from Stream.)
Public method | Detach | (Inherited from Stream.)
Public method | DumpXML |
Protected method | Emit | (Inherited from Script.)
Public method | Empty | (Inherited from Script.)
Protected method | EmptyBuffer | (Inherited from Script_Text.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from Script_Text.)
Public method | Flush | (Inherited from Stream.)
Public method | GetBytesPerCharacter | (Inherited from Script_Text.)
Public method | GetCommentCache | (Inherited from Script.)
Protected method | GetErrorCount | (Inherited from Script.)
Public method | GetFilename | (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineNumber | (Inherited from Script_Text.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetWarningCount | (Inherited from Script.)
Public method | IsAttached | (Inherited from Stream.)
Protected method | LocateMidlineComment | (Inherited from Script.)
Public method | MatchScriptKey | (Inherited from Script.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | newposition | (Inherited from Script.)
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)
Protected method | OnAttach | (Inherited from Script_Text.)
Public method | Open | (Inherited from Stream.)
Public method | Read | (Inherited from Stream.)
Public method | ReadAhead | (Inherited from Stream.)
Public method | ReadAheadScript_Character | (Inherited from Script.)
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)
Public method | ReadNext |
Public method | ReadScript_ArgumentList | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)
Public method | ReadScript_BetweenDeliminators | (Inherited from Script.)
Public method | ReadScript_Character | (Inherited from Script.)
Public method | ReadScriptLine | (Inherited from Script.)
Public method | ReadScriptLine_skipcomments | (Inherited from Script.)
Public method | ReadScriptPhrase | (Inherited from Script.)
Public method | ReadScriptString | (Inherited from Script.)
Public method | ReadScriptWord | (Inherited from Script.)
Public method | ReadToTagEnd |
Public method | RefillBuffer | (Inherited from Script_Text.)
Public method | RemoveEnclosedComments | (Inherited from Script.)
Public method | Reset | (Inherited from Script.)
Public method | Rewind | (Overrides Script..::..Rewind()()()().)
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)
Public method | Set | (Inherited from Stream.)
Public method | SetBytesPerCharacter | (Inherited from Script_Text.)
Public method | SetMaxLineLength | (Inherited from Script_Text.)
Public method | SetMidlineCommentIndicator | (Inherited from Script.)
Public method | SetSkipComments | (Inherited from Script.)
Public method | SetSkipLinefeeds | (Inherited from Script.)
Public method | SetSkipWhitespace | (Inherited from Script.)
Public method | SetThreaded | (Inherited from Stream.)
Public method | ShowErrors | (Inherited from Script.)
Protected method | Skip_Bufferchar | (Inherited from Script.)
Protected method | SkippingLinefeeds | (Inherited from Script.)
Public method | SkipScript_Character | (Inherited from Script.)
Public method | SkipScriptLine | (Inherited from Script.)
Public method | SkipScriptWord | (Inherited from Script.)
Public method | SyntaxError | (Inherited from Script.)
Public method | Tell | (Inherited from Script_Text.)
Public method | TestKey | (Inherited from Script.)
Public method | TestScriptKey | (Inherited from Script.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WithinComment | (Inherited from Script.)
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)
Public method | Write_Tabbified | (Inherited from Script_Text.)
Public method | WriteAField |
Public method | WriteAnXMLTag |
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

Script_XML Class
ElScript Namespace


AttachFile Method

[image] [image]

4 of William Foster's Class Libraries
Script_XML..::..AttachFile Method
Script_XML Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachFile(Filename, Boolean) | (Inherited from Stream.)
Public method | AttachFile(Filename, EAccessMode) | (Inherited from Stream.)

See Also

Script_XML Class
Script_XML Members
ElScript Namespace


AttachMemory Method

[image] [image]

4 of William Foster's Class Libraries
Script_XML..::..AttachMemory Method
Script_XML Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AttachMemory(array<Char>[]()[][], UInt64) | (Inherited from Stream.)
Public method | AttachMemory(array<Byte>[]()[][], UInt64) | (Inherited from Stream.)

See Also

Script_XML Class
Script_XML Members
ElScript Namespace


DumpXML Method

[image]

4 of William Foster's Class Libraries
Script_XML..::..DumpXML Method
Script_XML Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_XML.DumpXML"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool DumpXML()
Visual Basic
Public Function DumpXML As Boolean
Visual C++
public:
bool DumpXML()

Return Value

[Missing <returns> documentation for "M:ElScript.Script_XML.DumpXML"]

See Also

Script_XML Class
ElScript Namespace


NextChar Method

[image] [image]

4 of William Foster's Class Libraries
Script_XML..::..NextChar Method
Script_XML Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | NextChar()()()() | (Inherited from Script.)
Protected method | NextChar(Int32) | (Inherited from Script.)

See Also

Script_XML Class
Script_XML Members
ElScript Namespace


ReadLine Method

[image] [image]

4 of William Foster's Class Libraries
Script_XML..::..ReadLine Method
Script_XML Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadLine(STRING%) | (Inherited from Script_Text.)
Public method | ReadLine(String%) | (Inherited from Script_Text.)

See Also

Script_XML Class
Script_XML Members
ElScript Namespace


ReadNext Method

[image]

4 of William Foster's Class Libraries
Script_XML..::..ReadNext Method
Script_XML Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_XML.ReadNext(El.STRING@)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Script_XML..::..EBFCScript_XMLMark ReadNext(
    out STRING s
)
Visual Basic
Public Function ReadNext ( _
    <OutAttribute> ByRef s As STRING _
) As Script_XML..::..EBFCScript_XMLMark
Visual C++
public:
Script_XML..::..EBFCScript_XMLMark ReadNext(
    [OutAttribute] STRING^% s
)

Parameters

s
Type: STRING%

[Missing <param name="s"/> documentation for "M:ElScript.Script_XML.ReadNext(El.STRING@)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_XML.ReadNext(El.STRING@)"]

See Also

Script_XML Class
ElScript Namespace


ReadScript_ArgumentList_2dPair Method

[image] [image]

4 of William Foster's Class Libraries
Script_XML..::..ReadScript_ArgumentList_2dPair Method
Script_XML Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadScript_ArgumentList_2dPair(Size2d%) | (Inherited from Script.)
Public method | ReadScript_ArgumentList_2dPair(Size2dU%) | (Inherited from Script.)

See Also

Script_XML Class
Script_XML Members
ElScript Namespace


ReadToTagEnd Method

[image]

4 of William Foster's Class Libraries
Script_XML..::..ReadToTagEnd Method
Script_XML Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_XML.ReadToTagEnd(El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadToTagEnd(
    STRING s_tag
)
Visual Basic
Public Function ReadToTagEnd ( _
    s_tag As STRING _
) As Boolean
Visual C++
public:
bool ReadToTagEnd(
    STRING^ s_tag
)

Parameters

s_tag
Type: STRING

[Missing <param name="s_tag"/> documentation for "M:ElScript.Script_XML.ReadToTagEnd(El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_XML.ReadToTagEnd(El.STRING)"]

See Also

Script_XML Class
ElScript Namespace


Rewind Method

[image]

4 of William Foster's Class Libraries
Script_XML..::..Rewind Method
Script_XML Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_XML.Rewind"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool Rewind()
Visual Basic
Public Overrides Function Rewind As Boolean
Visual C++
public:
virtual bool Rewind() override

Return Value

[Missing <returns> documentation for "M:ElScript.Script_XML.Rewind"]

See Also

Script_XML Class
ElScript Namespace


Seek Method

[image] [image]

4 of William Foster's Class Libraries
Script_XML..::..Seek Method
Script_XML Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Seek(UInt32, UInt64) | (Inherited from Stream.)
Public method | Seek(UInt32, UInt64, UInt64%) | (Inherited from Script_Text.)

See Also

Script_XML Class
Script_XML Members
ElScript Namespace


Write Method

[image] [image]

4 of William Foster's Class Libraries
Script_XML..::..Write Method
Script_XML Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(STRING) | (Inherited from Script_Text.)
Public method | Write(MemPtr, UInt32, UInt32%) | (Inherited from Stream.)

See Also

Script_XML Class
Script_XML Members
ElScript Namespace


WriteAField Method

[image]

4 of William Foster's Class Libraries
Script_XML..::..WriteAField Method
Script_XML Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_XML.WriteAField(ElData.Archive_Field,ElData.Archive_Field_Header)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WriteAField(
    Archive_Field ArchiveField,
    Archive_Field_Header ArchiveFieldHeader
)
Visual Basic
Public Function WriteAField ( _
    ArchiveField As Archive_Field, _
    ArchiveFieldHeader As Archive_Field_Header _
) As Boolean
Visual C++
public:
bool WriteAField(
    Archive_Field^ ArchiveField,
    Archive_Field_Header^ ArchiveFieldHeader
)

Parameters

ArchiveField
Type: Archive_Field

[Missing <param name="ArchiveField"/> documentation for "M:ElScript.Script_XML.WriteAField(ElData.Archive_Field,ElData.Archive_Field_Header)"]

ArchiveFieldHeader
Type: Archive_Field_Header

[Missing <param name="ArchiveFieldHeader"/> documentation for "M:ElScript.Script_XML.WriteAField(ElData.Archive_Field,ElData.Archive_Field_Header)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_XML.WriteAField(ElData.Archive_Field,ElData.Archive_Field_Header)"]

See Also

Script_XML Class
ElScript Namespace


WriteAnXMLTag Method

[image]

4 of William Foster's Class Libraries
Script_XML..::..WriteAnXMLTag Method
Script_XML Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Script_XML.WriteAnXMLTag(El.STRING,El.STRING)"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WriteAnXMLTag(
    STRING cs_FieldName,
    STRING cs_FieldData
)
Visual Basic
Public Function WriteAnXMLTag ( _
    cs_FieldName As STRING, _
    cs_FieldData As STRING _
) As Boolean
Visual C++
public:
bool WriteAnXMLTag(
    STRING^ cs_FieldName,
    STRING^ cs_FieldData
)

Parameters

cs_FieldName
Type: STRING

[Missing <param name="cs_FieldName"/> documentation for "M:ElScript.Script_XML.WriteAnXMLTag(El.STRING,El.STRING)"]

cs_FieldData
Type: STRING

[Missing <param name="cs_FieldData"/> documentation for "M:ElScript.Script_XML.WriteAnXMLTag(El.STRING,El.STRING)"]

Return Value

[Missing <returns> documentation for "M:ElScript.Script_XML.WriteAnXMLTag(El.STRING,El.STRING)"]

See Also

Script_XML Class
ElScript Namespace


WriteLine Method

[image] [image]

4 of William Foster's Class Libraries
Script_XML..::..WriteLine Method
Script_XML Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteLine(STRING) | (Inherited from Script_Text.)
Public method | WriteLine(array<Char>[]()[][], array<Object>[]()[][]) | (Inherited from Script_Text.)
Public method | WriteLine(String, array<Object>[]()[][]) | (Inherited from Script_Text.)

See Also

Script_XML Class
Script_XML Members
ElScript Namespace


Script_XML Properties

[image] [image]

4 of William Foster's Class Libraries
Script_XML Properties
Script_XML Class See Also Send Feedback

The Script_XML type exposes the following members.

Properties

 | Name | Description
Public property | SysStream | (Inherited from Stream.)

See Also

Script_XML Class
ElScript Namespace


Script_XML.EBFCScript_XMLMark Enumeration

[image]

4 of William Foster's Class Libraries
Script_XML..::..EBFCScript_XMLMark Enumeration
Script_XML Class See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Script_XML.EBFCScript_XMLMark"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum EBFCScript_XMLMark
Visual Basic
Public Enumeration EBFCScript_XMLMark
Visual C++
public enum class EBFCScript_XMLMark

Members

Member name | Value | Description
TAG_START | 0 |
ATTRIBUTE | 1 |
VALUE | 2 |
TAG_END | 3 |
EOF | 4 |

See Also

ElScript Namespace


Variable Class

[image]

4 of William Foster's Class Libraries
Variable Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Variable"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Variable : Value
Visual Basic
Public Class Variable _
    Inherits Value
Visual C++
public ref class Variable : public Value

Inheritance Hierarchy

System..::..Object
Value
ElScript..::..Variable

See Also

Variable Members
ElScript Namespace


Variable Members

[image] [image]

4 of William Foster's Class Libraries
Variable Members
Variable Class Constructors Methods Fields See Also Send Feedback

The Variable type exposes the following members.

Constructors

 | Name | Description
Public method | Variable | Initializes a new instance of the Variable class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue_double | (Inherited from Value.)
Public method | GetValue_int | (Inherited from Value.)
Public method | GetValue_uint | (Inherited from Value.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToString | (Inherited from Value.)
Public method | SetFromString | (Inherited from Value.)
Public method | SetValue(Double) | (Inherited from Value.)
Public method | SetValue(Int32) | (Inherited from Value.)
Public method | SetValue(UInt32) | (Inherited from Value.)
Public method | SetValue(Value) | (Inherited from Value.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | m_d_value | (Inherited from Value.)

See Also

Variable Class
ElScript Namespace


Variable Constructor

[image]

4 of William Foster's Class Libraries
Variable Constructor
Variable Class See Also Send Feedback
Initializes a new instance of the Variable class

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Variable()
Visual Basic
Public Sub New
Visual C++
public:
Variable()

See Also

Variable Class
ElScript Namespace


Variable Fields

[image] [image]

4 of William Foster's Class Libraries
Variable Fields
Variable Class See Also Send Feedback

The Variable type exposes the following members.

Fields

 | Name | Description
Public field | m_d_value | (Inherited from Value.)

See Also

Variable Class
ElScript Namespace


Variable Methods

[image] [image]

4 of William Foster's Class Libraries
Variable Methods
Variable Class See Also Send Feedback

The Variable type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue_double | (Inherited from Value.)
Public method | GetValue_int | (Inherited from Value.)
Public method | GetValue_uint | (Inherited from Value.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToString | (Inherited from Value.)
Public method | SetFromString | (Inherited from Value.)
Public method | SetValue(Double) | (Inherited from Value.)
Public method | SetValue(Int32) | (Inherited from Value.)
Public method | SetValue(UInt32) | (Inherited from Value.)
Public method | SetValue(Value) | (Inherited from Value.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Variable Class
ElScript Namespace


Finalize Method

[image]

4 of William Foster's Class Libraries
Variable..::..Finalize Method
Variable Class See Also Send Feedback

[Missing <summary> documentation for "M:ElScript.Variable.Finalize"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Variable Class
ElScript Namespace


SetValue Method

[image] [image]

4 of William Foster's Class Libraries
Variable..::..SetValue Method
Variable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(Double) | (Inherited from Value.)
Public method | SetValue(Int32) | (Inherited from Value.)
Public method | SetValue(UInt32) | (Inherited from Value.)
Public method | SetValue(Value) | (Inherited from Value.)

See Also

Variable Class
Variable Members
ElScript Namespace


Variable.EVariableType Enumeration

[image]

4 of William Foster's Class Libraries
Variable..::..EVariableType Enumeration
Variable Class See Also Send Feedback

[Missing <summary> documentation for "T:ElScript.Variable.EVariableType"]

Namespace: ElScript
Assembly: ElScript (in ElScript.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum EVariableType
Visual Basic
Public Enumeration EVariableType
Visual C++
public enum class EVariableType

Members

Member name | Value | Description
VAR_STRING | 0 |
VAR_VALUE | 1 |

See Also

ElScript Namespace


PublicDomain Namespace

[image]

4 of William Foster's Class Libraries
PublicDomain Namespace
Send Feedback

[Missing <summary> documentation for "N:PublicDomain"]

Classes

 | Class | Description
Public class | ProcessHelper | Obsolete. Wrapper around the Process class to add some convenience methods but most importantly deal with the complex nature of getting both StandardOutput and StandardError streams concurrently (this must be done with callbacks). See http://msdn2.microsoft.com/en-us/library/system.diagnostics.process.standarderror.aspx


ProcessHelper Class

[image]

4 of William Foster's Class Libraries
ProcessHelper Class
Members See Also Send Feedback
Wrapper around the Process class to add some convenience methods but most importantly deal with the complex nature of getting both StandardOutput and StandardError streams concurrently (this must be done with callbacks). See http://msdn2.microsoft.com/en-us/library/system.diagnostics.process.standarderror.aspx

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
[ObsoleteAttribute("Use IronProcess Instead")]
public class ProcessHelper
Visual Basic
<ObsoleteAttribute("Use IronProcess Instead")> _
Public Class ProcessHelper
Visual C++
[ObsoleteAttribute(L"Use IronProcess Instead")]
public ref class ProcessHelper

Inheritance Hierarchy

System..::..Object
PublicDomain..::..ProcessHelper

See Also

ProcessHelper Members
PublicDomain Namespace


ProcessHelper Members

[image] [image]

4 of William Foster's Class Libraries
ProcessHelper Members
ProcessHelper Class Constructors Methods Properties See Also Send Feedback

The ProcessHelper type exposes the following members.

Constructors

 | Name | Description
Public method | ProcessHelper()()()() | Initializes a new instance of the ProcessHelper class.
Public method | ProcessHelper(Boolean) | Initializes a new instance of the ProcessHelper class.

Methods

 | Name | Description
Public method | AddArguments | Adds the arguments.
Public method | CheckForError()()()() | Checks for error.
Public method | CheckForError(Boolean) | Checks for error.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified STR.
Protected method | process_ErrorDataReceived | Handles the ErrorDataReceived event of the process control.
Protected method | process_OutputDataReceived | Handles the OutputDataReceived event of the process control.
Public method | SetArguments | Sets the arguments.
 | SplitOn | Splits str based on the index. The first element is the left portion, and the second element is the right portion. The character at index index is either included at the end of the left portion, or at the beginning of the right portion, depending on isIndexInFirstPortion The return result is never null, and the elements are never null, so one of the elements may be an empty string.
Public method | Start()()()() | Starts this instance.
Public method | Start(Boolean) | Starts the process, begins asynchronous reads on both standard output and standard error.
Public method | StartAndWaitForExit()()()() | Starts with a timeout of [!:GlobalConstants.DefaultExecuteSmallProcessTimeout] milliseconds and does not throw an exception when it sees an error, but returns the standard error and output.
Public method | StartAndWaitForExit(Boolean) | Starts the process, begins asynchronous reads on both standard output and standard error, and waits for the process to exit. The return code of the process is returned.
Public method | StartAndWaitForExit(Int32) | Starts the and wait for exit.
Public method | StartAndWaitForExit(Int32, Boolean) | Starts the process, begins asynchronous reads on both standard output and standard error, and waits for the process to exit. The return code of the process is returned.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Arguments | Gets or sets the arguments.
Public property | Error | Gets or sets the error.
Public property | ExitCode | Gets the exit code.
Public property | FileName | Gets or sets the name of the file.
Public property | Out | Gets or sets the out.
Public property | Process | Gets or sets the process.
Public property | StandardError | Gets the standard error.
Public property | StandardOutput | Gets the standard output.
Public property | StartInfo | Gets the start info.

See Also

ProcessHelper Class
PublicDomain Namespace


ProcessHelper Constructor

[image] [image]

4 of William Foster's Class Libraries
ProcessHelper Constructor
ProcessHelper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProcessHelper()()()() | Initializes a new instance of the ProcessHelper class.
Public method | ProcessHelper(Boolean) | Initializes a new instance of the ProcessHelper class.

See Also

ProcessHelper Class
ProcessHelper Members
PublicDomain Namespace


ProcessHelper Constructor

[image]

4 of William Foster's Class Libraries
ProcessHelper Constructor
ProcessHelper Class See Also Send Feedback
Initializes a new instance of the ProcessHelper class.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public ProcessHelper()
Visual Basic
Public Sub New
Visual C++
public:
ProcessHelper()

See Also

ProcessHelper Class
ProcessHelper Overload
PublicDomain Namespace


ProcessHelper Constructor (Boolean)

[image]

4 of William Foster's Class Libraries
ProcessHelper Constructor (Boolean)
ProcessHelper Class See Also Send Feedback
Initializes a new instance of the ProcessHelper class.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public ProcessHelper(
    bool sendStreamsToStrings
)
Visual Basic
Public Sub New ( _
    sendStreamsToStrings As Boolean _
)
Visual C++
public:
ProcessHelper(
    bool sendStreamsToStrings
)

Parameters

sendStreamsToStrings
Type: System..::..Boolean
if set to true [send streams to strings].

See Also

ProcessHelper Class
ProcessHelper Overload
PublicDomain Namespace


ProcessHelper Methods

[image] [image]

4 of William Foster's Class Libraries
ProcessHelper Methods
ProcessHelper Class See Also Send Feedback

The ProcessHelper type exposes the following members.

Methods

 | Name | Description
Public method | AddArguments | Adds the arguments.
Public method | CheckForError()()()() | Checks for error.
Public method | CheckForError(Boolean) | Checks for error.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Parses the specified STR.
Protected method | process_ErrorDataReceived | Handles the ErrorDataReceived event of the process control.
Protected method | process_OutputDataReceived | Handles the OutputDataReceived event of the process control.
Public method | SetArguments | Sets the arguments.
 | SplitOn | Splits str based on the index. The first element is the left portion, and the second element is the right portion. The character at index index is either included at the end of the left portion, or at the beginning of the right portion, depending on isIndexInFirstPortion The return result is never null, and the elements are never null, so one of the elements may be an empty string.
Public method | Start()()()() | Starts this instance.
Public method | Start(Boolean) | Starts the process, begins asynchronous reads on both standard output and standard error.
Public method | StartAndWaitForExit()()()() | Starts with a timeout of [!:GlobalConstants.DefaultExecuteSmallProcessTimeout] milliseconds and does not throw an exception when it sees an error, but returns the standard error and output.
Public method | StartAndWaitForExit(Boolean) | Starts the process, begins asynchronous reads on both standard output and standard error, and waits for the process to exit. The return code of the process is returned.
Public method | StartAndWaitForExit(Int32) | Starts the and wait for exit.
Public method | StartAndWaitForExit(Int32, Boolean) | Starts the process, begins asynchronous reads on both standard output and standard error, and waits for the process to exit. The return code of the process is returned.
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ProcessHelper Class
PublicDomain Namespace


AddArguments Method

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..AddArguments Method
ProcessHelper Class See Also Send Feedback
Adds the arguments.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void AddArguments(
    params string[] args
)
Visual Basic
Public Sub AddArguments ( _
    ParamArray args As String() _
)
Visual C++
public:
void AddArguments(
    ... array<String^>^ args
)

Parameters

args
Type: array< System..::..String >[]()[][]
The args.

See Also

ProcessHelper Class
PublicDomain Namespace


CheckForError Method

[image] [image]

4 of William Foster's Class Libraries
ProcessHelper..::..CheckForError Method
ProcessHelper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CheckForError()()()() | Checks for error.
Public method | CheckForError(Boolean) | Checks for error.

See Also

ProcessHelper Class
ProcessHelper Members
PublicDomain Namespace


CheckForError Method

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..CheckForError Method
ProcessHelper Class See Also Send Feedback
Checks for error.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public string CheckForError()
Visual Basic
Public Function CheckForError As String
Visual C++
public:
String^ CheckForError()

Return Value

[Missing <returns> documentation for "M:PublicDomain.ProcessHelper.CheckForError"]

See Also

ProcessHelper Class
CheckForError Overload
PublicDomain Namespace


CheckForError Method (Boolean)

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..CheckForError Method (Boolean)
ProcessHelper Class See Also Send Feedback
Checks for error.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public string CheckForError(
    bool throwOnError
)
Visual Basic
Public Function CheckForError ( _
    throwOnError As Boolean _
) As String
Visual C++
public:
String^ CheckForError(
    bool throwOnError
)

Parameters

throwOnError
Type: System..::..Boolean
if set to true [throw on error].

Return Value

[Missing <returns> documentation for "M:PublicDomain.ProcessHelper.CheckForError(System.Boolean)"]

See Also

ProcessHelper Class
CheckForError Overload
PublicDomain Namespace


Parse Method

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..Parse Method
ProcessHelper Class See Also Send Feedback
Parses the specified STR.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static ProcessHelper Parse(
    string str
)
Visual Basic
Public Shared Function Parse ( _
    str As String _
) As ProcessHelper
Visual C++
public:
static ProcessHelper^ Parse(
    String^ str
)

Parameters

str
Type: System..::..String
The STR.

Return Value

[Missing <returns> documentation for "M:PublicDomain.ProcessHelper.Parse(System.String)"]

See Also

ProcessHelper Class
PublicDomain Namespace


process_ErrorDataReceived Method

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..process_ErrorDataReceived Method
ProcessHelper Class See Also Send Feedback
Handles the ErrorDataReceived event of the process control.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected virtual void process_ErrorDataReceived(
    Object sender,
    DataReceivedEventArgs e
)
Visual Basic
Protected Overridable Sub process_ErrorDataReceived ( _
    sender As Object, _
    e As DataReceivedEventArgs _
)
Visual C++
protected:
virtual void process_ErrorDataReceived(
    Object^ sender,
    DataReceivedEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: System.Diagnostics..::..DataReceivedEventArgs
The DataReceivedEventArgs instance containing the event data.

See Also

ProcessHelper Class
PublicDomain Namespace


process_OutputDataReceived Method

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..process_OutputDataReceived Method
ProcessHelper Class See Also Send Feedback
Handles the OutputDataReceived event of the process control.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
protected virtual void process_OutputDataReceived(
    Object sender,
    DataReceivedEventArgs e
)
Visual Basic
Protected Overridable Sub process_OutputDataReceived ( _
    sender As Object, _
    e As DataReceivedEventArgs _
)
Visual C++
protected:
virtual void process_OutputDataReceived(
    Object^ sender,
    DataReceivedEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: System.Diagnostics..::..DataReceivedEventArgs
The DataReceivedEventArgs instance containing the event data.

See Also

ProcessHelper Class
PublicDomain Namespace


SetArguments Method

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..SetArguments Method
ProcessHelper Class See Also Send Feedback
Sets the arguments.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void SetArguments(
    params string[] args
)
Visual Basic
Public Sub SetArguments ( _
    ParamArray args As String() _
)
Visual C++
public:
void SetArguments(
    ... array<String^>^ args
)

Parameters

args
Type: array< System..::..String >[]()[][]
The args.

See Also

ProcessHelper Class
PublicDomain Namespace


SplitOn Method

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..SplitOn Method
ProcessHelper Class See Also Send Feedback
Splits str based on the index. The first element is the left portion, and the second element is the right portion. The character at index index is either included at the end of the left portion, or at the beginning of the right portion, depending on isIndexInFirstPortion The return result is never null, and the elements are never null, so one of the elements may be an empty string.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public static string[] SplitOn(
    string str,
    int index,
    bool isIndexInFirstPortion
)
Visual Basic
Public Shared Function SplitOn ( _
    str As String, _
    index As Integer, _
    isIndexInFirstPortion As Boolean _
) As String()
Visual C++
public:
static array<String^>^ SplitOn(
    String^ str,
    int index,
    bool isIndexInFirstPortion
)

Parameters

str
Type: System..::..String
The STR.
index
Type: System..::..Int32
The index.
isIndexInFirstPortion
Type: System..::..Boolean
if set to true [is index in first portion].

Return Value

[Missing <returns> documentation for "M:PublicDomain.ProcessHelper.SplitOn(System.String,System.Int32,System.Boolean)"]

See Also

ProcessHelper Class
PublicDomain Namespace


Start Method

[image] [image]

4 of William Foster's Class Libraries
ProcessHelper..::..Start Method
ProcessHelper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Start()()()() | Starts this instance.
Public method | Start(Boolean) | Starts the process, begins asynchronous reads on both standard output and standard error.

See Also

ProcessHelper Class
ProcessHelper Members
PublicDomain Namespace


Start Method

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..Start Method
ProcessHelper Class See Also Send Feedback
Starts this instance.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void Start()
Visual Basic
Public Sub Start
Visual C++
public:
void Start()

See Also

ProcessHelper Class
Start Overload
PublicDomain Namespace


Start Method (Boolean)

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..Start Method (Boolean)
ProcessHelper Class See Also Send Feedback
Starts the process, begins asynchronous reads on both standard output and standard error.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public void Start(
    bool useRedirect
)
Visual Basic
Public Sub Start ( _
    useRedirect As Boolean _
)
Visual C++
public:
void Start(
    bool useRedirect
)

Parameters

useRedirect
Type: System..::..Boolean
if set to true [use redirect].

See Also

ProcessHelper Class
Start Overload
PublicDomain Namespace


StartAndWaitForExit Method

[image] [image]

4 of William Foster's Class Libraries
ProcessHelper..::..StartAndWaitForExit Method
ProcessHelper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartAndWaitForExit()()()() | Starts with a timeout of [!:GlobalConstants.DefaultExecuteSmallProcessTimeout] milliseconds and does not throw an exception when it sees an error, but returns the standard error and output.
Public method | StartAndWaitForExit(Boolean) | Starts the process, begins asynchronous reads on both standard output and standard error, and waits for the process to exit. The return code of the process is returned.
Public method | StartAndWaitForExit(Int32) | Starts the and wait for exit.
Public method | StartAndWaitForExit(Int32, Boolean) | Starts the process, begins asynchronous reads on both standard output and standard error, and waits for the process to exit. The return code of the process is returned.

See Also

ProcessHelper Class
ProcessHelper Members
PublicDomain Namespace


StartAndWaitForExit Method

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..StartAndWaitForExit Method
ProcessHelper Class See Also Send Feedback
Starts with a timeout of [!:GlobalConstants.DefaultExecuteSmallProcessTimeout] milliseconds and does not throw an exception when it sees an error, but returns the standard error and output.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public int StartAndWaitForExit()
Visual Basic
Public Function StartAndWaitForExit As Integer
Visual C++
public:
int StartAndWaitForExit()

Return Value

[Missing <returns> documentation for "M:PublicDomain.ProcessHelper.StartAndWaitForExit"]

See Also

ProcessHelper Class
StartAndWaitForExit Overload
PublicDomain Namespace


StartAndWaitForExit Method (Boolean)

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..StartAndWaitForExit Method (Boolean)
ProcessHelper Class See Also Send Feedback
Starts the process, begins asynchronous reads on both standard output and standard error, and waits for the process to exit. The return code of the process is returned.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public int StartAndWaitForExit(
    bool throwOnError
)
Visual Basic
Public Function StartAndWaitForExit ( _
    throwOnError As Boolean _
) As Integer
Visual C++
public:
int StartAndWaitForExit(
    bool throwOnError
)

Parameters

throwOnError
Type: System..::..Boolean
if set to true [throw on error].

Return Value

Return code of completed process

See Also

ProcessHelper Class
StartAndWaitForExit Overload
PublicDomain Namespace


StartAndWaitForExit Method (Int32)

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..StartAndWaitForExit Method (Int32)
ProcessHelper Class See Also Send Feedback
Starts the and wait for exit.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public int StartAndWaitForExit(
    int timeoutMs
)
Visual Basic
Public Function StartAndWaitForExit ( _
    timeoutMs As Integer _
) As Integer
Visual C++
public:
int StartAndWaitForExit(
    int timeoutMs
)

Parameters

timeoutMs
Type: System..::..Int32
The timeout ms.

Return Value

[Missing <returns> documentation for "M:PublicDomain.ProcessHelper.StartAndWaitForExit(System.Int32)"]

See Also

ProcessHelper Class
StartAndWaitForExit Overload
PublicDomain Namespace


StartAndWaitForExit Method (Int32, Boolean)

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..StartAndWaitForExit Method (Int32, Boolean)
ProcessHelper Class See Also Send Feedback
Starts the process, begins asynchronous reads on both standard output and standard error, and waits for the process to exit. The return code of the process is returned.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public int StartAndWaitForExit(
    int timeoutMs,
    bool throwOnError
)
Visual Basic
Public Function StartAndWaitForExit ( _
    timeoutMs As Integer, _
    throwOnError As Boolean _
) As Integer
Visual C++
public:
int StartAndWaitForExit(
    int timeoutMs,
    bool throwOnError
)

Parameters

timeoutMs
Type: System..::..Int32
The timeout ms.
throwOnError
Type: System..::..Boolean
if set to true [throw on error].

Return Value

Return code of completed process

See Also

ProcessHelper Class
StartAndWaitForExit Overload
PublicDomain Namespace


ToString Method

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..ToString Method
ProcessHelper Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents the current Object.

See Also

ProcessHelper Class
PublicDomain Namespace


ProcessHelper Properties

[image] [image]

4 of William Foster's Class Libraries
ProcessHelper Properties
ProcessHelper Class See Also Send Feedback

The ProcessHelper type exposes the following members.

Properties

 | Name | Description
Public property | Arguments | Gets or sets the arguments.
Public property | Error | Gets or sets the error.
Public property | ExitCode | Gets the exit code.
Public property | FileName | Gets or sets the name of the file.
Public property | Out | Gets or sets the out.
Public property | Process | Gets or sets the process.
Public property | StandardError | Gets the standard error.
Public property | StandardOutput | Gets the standard output.
Public property | StartInfo | Gets the start info.

See Also

ProcessHelper Class
PublicDomain Namespace


Arguments Property

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..Arguments Property
ProcessHelper Class See Also Send Feedback
Gets or sets the arguments.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public string Arguments { get; set; }
Visual Basic
Public Property Arguments As String
    Get
    Set
Visual C++
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}

Field Value

The arguments.

See Also

ProcessHelper Class
PublicDomain Namespace


Error Property

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..Error Property
ProcessHelper Class See Also Send Feedback
Gets or sets the error.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public TextWriter Error { get; set; }
Visual Basic
Public Property Error As TextWriter
    Get
    Set
Visual C++
public:
property TextWriter^ Error {
    TextWriter^ get ();
    void set (TextWriter^ value);
}

Field Value

The error.

See Also

ProcessHelper Class
PublicDomain Namespace


ExitCode Property

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..ExitCode Property
ProcessHelper Class See Also Send Feedback
Gets the exit code.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public int ExitCode { get; }
Visual Basic
Public ReadOnly Property ExitCode As Integer
    Get
Visual C++
public:
property int ExitCode {
    int get ();
}

Field Value

The exit code.

See Also

ProcessHelper Class
PublicDomain Namespace


FileName Property

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..FileName Property
ProcessHelper Class See Also Send Feedback
Gets or sets the name of the file.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public string FileName { get; set; }
Visual Basic
Public Property FileName As String
    Get
    Set
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the file.

See Also

ProcessHelper Class
PublicDomain Namespace


Out Property

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..Out Property
ProcessHelper Class See Also Send Feedback
Gets or sets the out.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public TextWriter Out { get; set; }
Visual Basic
Public Property Out As TextWriter
    Get
    Set
Visual C++
public:
property TextWriter^ Out {
    TextWriter^ get ();
    void set (TextWriter^ value);
}

Field Value

The out.

See Also

ProcessHelper Class
PublicDomain Namespace


Process Property

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..Process Property
ProcessHelper Class See Also Send Feedback
Gets or sets the process.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public Process Process { get; set; }
Visual Basic
Public Property Process As Process
    Get
    Set
Visual C++
public:
property Process^ Process {
    Process^ get ();
    void set (Process^ value);
}

Field Value

The process.

See Also

ProcessHelper Class
PublicDomain Namespace


StandardError Property

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..StandardError Property
ProcessHelper Class See Also Send Feedback
Gets the standard error.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public string StandardError { get; }
Visual Basic
Public ReadOnly Property StandardError As String
    Get
Visual C++
public:
property String^ StandardError {
    String^ get ();
}

Field Value

The standard error.

See Also

ProcessHelper Class
PublicDomain Namespace


StandardOutput Property

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..StandardOutput Property
ProcessHelper Class See Also Send Feedback
Gets the standard output.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public string StandardOutput { get; }
Visual Basic
Public ReadOnly Property StandardOutput As String
    Get
Visual C++
public:
property String^ StandardOutput {
    String^ get ();
}

Field Value

The standard output.

See Also

ProcessHelper Class
PublicDomain Namespace


StartInfo Property

[image]

4 of William Foster's Class Libraries
ProcessHelper..::..StartInfo Property
ProcessHelper Class See Also Send Feedback
Gets the start info.

Namespace: PublicDomain
Assembly: ElOS (in ElOS.dll) Version: 0.0.0.0

Syntax

C#
public ProcessStartInfo StartInfo { get; }
Visual Basic
Public ReadOnly Property StartInfo As ProcessStartInfo
    Get
Visual C++
public:
property ProcessStartInfo^ StartInfo {
    ProcessStartInfo^ get ();
}

Field Value

The start info.

See Also

ProcessHelper Class
PublicDomain Namespace


Utility.ModifyRegistry Namespace

[image]

4 of William Foster's Class Libraries
Utility.ModifyRegistry Namespace
Send Feedback

[Missing <summary> documentation for "N:Utility.ModifyRegistry"]

Classes

 | Class | Description
Public class | ModifyRegistry | An useful class to read/write/delete/count registry keys


ModifyRegistry Class

[image]

4 of William Foster's Class Libraries
ModifyRegistry Class
Members See Also Send Feedback
An useful class to read/write/delete/count registry keys

Namespace: Utility.ModifyRegistry
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ModifyRegistry
Visual Basic
Public Class ModifyRegistry
Visual C++
public ref class ModifyRegistry

Inheritance Hierarchy

System..::..Object
Utility.ModifyRegistry..::..ModifyRegistry

See Also

ModifyRegistry Members
Utility.ModifyRegistry Namespace


ModifyRegistry Members

[image] [image]

4 of William Foster's Class Libraries
ModifyRegistry Members
ModifyRegistry Class Constructors Methods Properties See Also Send Feedback

The ModifyRegistry type exposes the following members.

Constructors

 | Name | Description
Public method | ModifyRegistry | Initializes a new instance of the ModifyRegistry class

Methods

 | Name | Description
Public method | DeleteKey | To delete a registry key. input: KeyName (string) output: true or false
Public method | DeleteSubKeyTree | To delete a sub key and any child. input: void output: true or false
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | To read a registry key. input: KeyName (string) output: value (string)
Public method | SubKeyCount | Retrive the count of subkeys at the current key. input: void output: number of subkeys
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValueCount | Retrive the count of values in the key. input: void output: number of keys
Public method | Write | To write into a registry key. input: KeyName (string) , Value (object) output: true or false

Properties

 | Name | Description
Public property | BaseRegistryKey | A property to set the BaseRegistryKey value. (default = Registry.LocalMachine)
Public property | ShowError | A property to show or hide error messages (default = false)
Public property | SubKey | A property to set the SubKey value (default = "SOFTWARE\\" + Application.ProductName.ToUpper())

See Also

ModifyRegistry Class
Utility.ModifyRegistry Namespace


ModifyRegistry Constructor

[image]

4 of William Foster's Class Libraries
ModifyRegistry Constructor
ModifyRegistry Class See Also Send Feedback
Initializes a new instance of the ModifyRegistry class

Namespace: Utility.ModifyRegistry
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ModifyRegistry()
Visual Basic
Public Sub New
Visual C++
public:
ModifyRegistry()

See Also

ModifyRegistry Class
Utility.ModifyRegistry Namespace


ModifyRegistry Methods

[image] [image]

4 of William Foster's Class Libraries
ModifyRegistry Methods
ModifyRegistry Class See Also Send Feedback

The ModifyRegistry type exposes the following members.

Methods

 | Name | Description
Public method | DeleteKey | To delete a registry key. input: KeyName (string) output: true or false
Public method | DeleteSubKeyTree | To delete a sub key and any child. input: void output: true or false
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | To read a registry key. input: KeyName (string) output: value (string)
Public method | SubKeyCount | Retrive the count of subkeys at the current key. input: void output: number of subkeys
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValueCount | Retrive the count of values in the key. input: void output: number of keys
Public method | Write | To write into a registry key. input: KeyName (string) , Value (object) output: true or false

See Also

ModifyRegistry Class
Utility.ModifyRegistry Namespace


DeleteKey Method

[image]

4 of William Foster's Class Libraries
ModifyRegistry..::..DeleteKey Method
ModifyRegistry Class See Also Send Feedback
To delete a registry key. input: KeyName (string) output: true or false

Namespace: Utility.ModifyRegistry
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool DeleteKey(
    string KeyName
)
Visual Basic
Public Function DeleteKey ( _
    KeyName As String _
) As Boolean
Visual C++
public:
bool DeleteKey(
    String^ KeyName
)

Parameters

KeyName
Type: System..::..String

[Missing <param name="KeyName"/> documentation for "M:Utility.ModifyRegistry.ModifyRegistry.DeleteKey(System.String)"]

Return Value

[Missing <returns> documentation for "M:Utility.ModifyRegistry.ModifyRegistry.DeleteKey(System.String)"]

See Also

ModifyRegistry Class
Utility.ModifyRegistry Namespace


DeleteSubKeyTree Method

[image]

4 of William Foster's Class Libraries
ModifyRegistry..::..DeleteSubKeyTree Method
ModifyRegistry Class See Also Send Feedback
To delete a sub key and any child. input: void output: true or false

Namespace: Utility.ModifyRegistry
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool DeleteSubKeyTree()
Visual Basic
Public Function DeleteSubKeyTree As Boolean
Visual C++
public:
bool DeleteSubKeyTree()

Return Value

[Missing <returns> documentation for "M:Utility.ModifyRegistry.ModifyRegistry.DeleteSubKeyTree"]

See Also

ModifyRegistry Class
Utility.ModifyRegistry Namespace


Read Method

[image]

4 of William Foster's Class Libraries
ModifyRegistry..::..Read Method
ModifyRegistry Class See Also Send Feedback
To read a registry key. input: KeyName (string) output: value (string)

Namespace: Utility.ModifyRegistry
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Read(
    string KeyName
)
Visual Basic
Public Function Read ( _
    KeyName As String _
) As String
Visual C++
public:
String^ Read(
    String^ KeyName
)

Parameters

KeyName
Type: System..::..String

[Missing <param name="KeyName"/> documentation for "M:Utility.ModifyRegistry.ModifyRegistry.Read(System.String)"]

Return Value

[Missing <returns> documentation for "M:Utility.ModifyRegistry.ModifyRegistry.Read(System.String)"]

See Also

ModifyRegistry Class
Utility.ModifyRegistry Namespace


SubKeyCount Method

[image]

4 of William Foster's Class Libraries
ModifyRegistry..::..SubKeyCount Method
ModifyRegistry Class See Also Send Feedback
Retrive the count of subkeys at the current key. input: void output: number of subkeys

Namespace: Utility.ModifyRegistry
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int SubKeyCount()
Visual Basic
Public Function SubKeyCount As Integer
Visual C++
public:
int SubKeyCount()

Return Value

[Missing <returns> documentation for "M:Utility.ModifyRegistry.ModifyRegistry.SubKeyCount"]

See Also

ModifyRegistry Class
Utility.ModifyRegistry Namespace


ValueCount Method

[image]

4 of William Foster's Class Libraries
ModifyRegistry..::..ValueCount Method
ModifyRegistry Class See Also Send Feedback
Retrive the count of values in the key. input: void output: number of keys

Namespace: Utility.ModifyRegistry
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int ValueCount()
Visual Basic
Public Function ValueCount As Integer
Visual C++
public:
int ValueCount()

Return Value

[Missing <returns> documentation for "M:Utility.ModifyRegistry.ModifyRegistry.ValueCount"]

See Also

ModifyRegistry Class
Utility.ModifyRegistry Namespace


Write Method

[image]

4 of William Foster's Class Libraries
ModifyRegistry..::..Write Method
ModifyRegistry Class See Also Send Feedback
To write into a registry key. input: KeyName (string) , Value (object) output: true or false

Namespace: Utility.ModifyRegistry
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Write(
    string KeyName,
    Object Value
)
Visual Basic
Public Function Write ( _
    KeyName As String, _
    Value As Object _
) As Boolean
Visual C++
public:
bool Write(
    String^ KeyName,
    Object^ Value
)

Parameters

KeyName
Type: System..::..String

[Missing <param name="KeyName"/> documentation for "M:Utility.ModifyRegistry.ModifyRegistry.Write(System.String,System.Object)"]

Value
Type: System..::..Object

[Missing <param name="Value"/> documentation for "M:Utility.ModifyRegistry.ModifyRegistry.Write(System.String,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Utility.ModifyRegistry.ModifyRegistry.Write(System.String,System.Object)"]

See Also

ModifyRegistry Class
Utility.ModifyRegistry Namespace


ModifyRegistry Properties

[image] [image]

4 of William Foster's Class Libraries
ModifyRegistry Properties
ModifyRegistry Class See Also Send Feedback

The ModifyRegistry type exposes the following members.

Properties

 | Name | Description
Public property | BaseRegistryKey | A property to set the BaseRegistryKey value. (default = Registry.LocalMachine)
Public property | ShowError | A property to show or hide error messages (default = false)
Public property | SubKey | A property to set the SubKey value (default = "SOFTWARE\\" + Application.ProductName.ToUpper())

See Also

ModifyRegistry Class
Utility.ModifyRegistry Namespace


BaseRegistryKey Property

[image]

4 of William Foster's Class Libraries
ModifyRegistry..::..BaseRegistryKey Property
ModifyRegistry Class See Also Send Feedback
A property to set the BaseRegistryKey value. (default = Registry.LocalMachine)

Namespace: Utility.ModifyRegistry
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RegistryKey BaseRegistryKey { get; set; }
Visual Basic
Public Property BaseRegistryKey As RegistryKey
    Get
    Set
Visual C++
public:
property RegistryKey^ BaseRegistryKey {
    RegistryKey^ get ();
    void set (RegistryKey^ value);
}

See Also

ModifyRegistry Class
Utility.ModifyRegistry Namespace


ShowError Property

[image]

4 of William Foster's Class Libraries
ModifyRegistry..::..ShowError Property
ModifyRegistry Class See Also Send Feedback
A property to show or hide error messages (default = false)

Namespace: Utility.ModifyRegistry
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShowError { get; set; }
Visual Basic
Public Property ShowError As Boolean
    Get
    Set
Visual C++
public:
property bool ShowError {
    bool get ();
    void set (bool value);
}

See Also

ModifyRegistry Class
Utility.ModifyRegistry Namespace


SubKey Property

[image]

4 of William Foster's Class Libraries
ModifyRegistry..::..SubKey Property
ModifyRegistry Class See Also Send Feedback
A property to set the SubKey value (default = "SOFTWARE\\" + Application.ProductName.ToUpper())

Namespace: Utility.ModifyRegistry
Assembly: ElGUI (in ElGUI.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string SubKey { get; set; }
Visual Basic
Public Property SubKey As String
    Get
    Set
Visual C++
public:
property String^ SubKey {
    String^ get ();
    void set (String^ value);
}

See Also

ModifyRegistry Class
Utility.ModifyRegistry Namespace