ElRender Namespace

[image]

A Sandcastle Documented Class Library
ElRender Namespace
Send Feedback

[Missing <summary> documentation for "N:ElRender"]

Classes

 | Class | Description
Public class | Point3d |
Public class | Renderable |


Point3d Class

[image]

A Sandcastle Documented Class Library
Point3d Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElRender.Point3d"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Point3d
Visual Basic
Public Class Point3d
Visual C++
public ref class Point3d

Inheritance Hierarchy

System..::..Object
ElRender..::..Point3d

See Also

Point3d Members
ElRender Namespace


Point3d Members

[image] [image]

A Sandcastle Documented Class Library
Point3d Members
Point3d Class Constructors Methods Fields See Also Send Feedback

The Point3d type exposes the following members.

Constructors

 | Name | Description
Public method | Point3d()()()() | Initializes a new instance of the Point3d class
Public method | Point3d(Point3d%) | Initializes a new instance of the Point3d class
Public method | Point3d(Double, Double, Double) | Initializes a new instance of the Point3d class
Public method | Point3d(Single, Single, Single) | Initializes a new instance of the Point3d class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Offset |
Public method | Set(Double, Double, Double) |
Public method | Set(Single, Single, Single) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | x |
Public field | y |
Public field | z |

See Also

Point3d Class
ElRender Namespace


Point3d Constructor

[image] [image]

A Sandcastle Documented Class Library
Point3d Constructor
Point3d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Point3d()()()() | Initializes a new instance of the Point3d class
Public method | Point3d(Point3d%) | Initializes a new instance of the Point3d class
Public method | Point3d(Double, Double, Double) | Initializes a new instance of the Point3d class
Public method | Point3d(Single, Single, Single) | Initializes a new instance of the Point3d class

See Also

Point3d Class
Point3d Members
ElRender Namespace


Point3d Constructor

[image]

A Sandcastle Documented Class Library
Point3d Constructor
Point3d Class See Also Send Feedback
Initializes a new instance of the Point3d class

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point3d()
Visual Basic
Public Sub New
Visual C++
public:
Point3d()

See Also

Point3d Class
Point3d Overload
ElRender Namespace


Point3d Constructor (Point3d)

[image]

A Sandcastle Documented Class Library
Point3d Constructor (Point3d%)
Point3d Class See Also Send Feedback
Initializes a new instance of the Point3d class

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point3d(
    ref Point3d ptref
)
Visual Basic
Public Sub New ( _
    ByRef ptref As Point3d _
)
Visual C++
public:
Point3d(
    Point3d^% ptref
)

Parameters

ptref
Type: ElRender..::..Point3d %

[Missing <param name="ptref"/> documentation for "M:ElRender.Point3d.#ctor(ElRender.Point3d@)"]

See Also

Point3d Class
Point3d Overload
ElRender Namespace


Point3d Constructor (Double, Double, Double)

[image]

A Sandcastle Documented Class Library
Point3d Constructor (Double, Double, Double)
Point3d Class See Also Send Feedback
Initializes a new instance of the Point3d class

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point3d(
    double xf,
    double yf,
    double zf
)
Visual Basic
Public Sub New ( _
    xf As Double, _
    yf As Double, _
    zf As Double _
)
Visual C++
public:
Point3d(
    double xf,
    double yf,
    double zf
)

Parameters

xf
Type: System..::..Double

[Missing <param name="xf"/> documentation for "M:ElRender.Point3d.#ctor(System.Double,System.Double,System.Double)"]

yf
Type: System..::..Double

[Missing <param name="yf"/> documentation for "M:ElRender.Point3d.#ctor(System.Double,System.Double,System.Double)"]

zf
Type: System..::..Double

[Missing <param name="zf"/> documentation for "M:ElRender.Point3d.#ctor(System.Double,System.Double,System.Double)"]

See Also

Point3d Class
Point3d Overload
ElRender Namespace


Point3d Constructor (Single, Single, Single)

[image]

A Sandcastle Documented Class Library
Point3d Constructor (Single, Single, Single)
Point3d Class See Also Send Feedback
Initializes a new instance of the Point3d class

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point3d(
    float xf,
    float yf,
    float zf
)
Visual Basic
Public Sub New ( _
    xf As Single, _
    yf As Single, _
    zf As Single _
)
Visual C++
public:
Point3d(
    float xf,
    float yf,
    float zf
)

Parameters

xf
Type: System..::..Single

[Missing <param name="xf"/> documentation for "M:ElRender.Point3d.#ctor(System.Single,System.Single,System.Single)"]

yf
Type: System..::..Single

[Missing <param name="yf"/> documentation for "M:ElRender.Point3d.#ctor(System.Single,System.Single,System.Single)"]

zf
Type: System..::..Single

[Missing <param name="zf"/> documentation for "M:ElRender.Point3d.#ctor(System.Single,System.Single,System.Single)"]

See Also

Point3d Class
Point3d Overload
ElRender Namespace


Point3d Fields

[image] [image]

A Sandcastle Documented Class Library
Point3d Fields
Point3d Class See Also Send Feedback

The Point3d type exposes the following members.

Fields

 | Name | Description
Public field | x |
Public field | y |
Public field | z |

See Also

Point3d Class
ElRender Namespace


x Field

[image]

A Sandcastle Documented Class Library
Point3d..::..x Field
Point3d Class See Also Send Feedback

[Missing <summary> documentation for "F:ElRender.Point3d.x"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double x
Visual Basic
Public x As Double
Visual C++
public:
double x

See Also

Point3d Class
ElRender Namespace


y Field

[image]

A Sandcastle Documented Class Library
Point3d..::..y Field
Point3d Class See Also Send Feedback

[Missing <summary> documentation for "F:ElRender.Point3d.y"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double y
Visual Basic
Public y As Double
Visual C++
public:
double y

See Also

Point3d Class
ElRender Namespace


z Field

[image]

A Sandcastle Documented Class Library
Point3d..::..z Field
Point3d Class See Also Send Feedback

[Missing <summary> documentation for "F:ElRender.Point3d.z"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double z
Visual Basic
Public z As Double
Visual C++
public:
double z

See Also

Point3d Class
ElRender Namespace


Point3d Methods

[image] [image]

A Sandcastle Documented Class Library
Point3d Methods
Point3d Class See Also Send Feedback

The Point3d type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Offset |
Public method | Set(Double, Double, Double) |
Public method | Set(Single, Single, Single) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Point3d Class
ElRender Namespace


Offset Method

[image]

A Sandcastle Documented Class Library
Point3d..::..Offset Method
Point3d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElRender.Point3d.Offset(System.Double,System.Double,System.Double)"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Offset(
    double xf,
    double yf,
    double zf
)
Visual Basic
Public Sub Offset ( _
    xf As Double, _
    yf As Double, _
    zf As Double _
)
Visual C++
public:
void Offset(
    double xf,
    double yf,
    double zf
)

Parameters

xf
Type: System..::..Double

[Missing <param name="xf"/> documentation for "M:ElRender.Point3d.Offset(System.Double,System.Double,System.Double)"]

yf
Type: System..::..Double

[Missing <param name="yf"/> documentation for "M:ElRender.Point3d.Offset(System.Double,System.Double,System.Double)"]

zf
Type: System..::..Double

[Missing <param name="zf"/> documentation for "M:ElRender.Point3d.Offset(System.Double,System.Double,System.Double)"]

See Also

Point3d Class
ElRender Namespace


Set Method

[image] [image]

A Sandcastle Documented Class Library
Point3d..::..Set Method
Point3d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(Double, Double, Double) |
Public method | Set(Single, Single, Single) |

See Also

Point3d Class
Point3d Members
ElRender Namespace


Set Method (Double, Double, Double)

[image]

A Sandcastle Documented Class Library
Point3d..::..Set Method (Double, Double, Double)
Point3d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElRender.Point3d.Set(System.Double,System.Double,System.Double)"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    double xf,
    double yf,
    double zf
)
Visual Basic
Public Sub Set ( _
    xf As Double, _
    yf As Double, _
    zf As Double _
)
Visual C++
public:
void Set(
    double xf,
    double yf,
    double zf
)

Parameters

xf
Type: System..::..Double

[Missing <param name="xf"/> documentation for "M:ElRender.Point3d.Set(System.Double,System.Double,System.Double)"]

yf
Type: System..::..Double

[Missing <param name="yf"/> documentation for "M:ElRender.Point3d.Set(System.Double,System.Double,System.Double)"]

zf
Type: System..::..Double

[Missing <param name="zf"/> documentation for "M:ElRender.Point3d.Set(System.Double,System.Double,System.Double)"]

See Also

Point3d Class
Set Overload
ElRender Namespace


Set Method (Single, Single, Single)

[image]

A Sandcastle Documented Class Library
Point3d..::..Set Method (Single, Single, Single)
Point3d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElRender.Point3d.Set(System.Single,System.Single,System.Single)"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    float xf,
    float yf,
    float zf
)
Visual Basic
Public Sub Set ( _
    xf As Single, _
    yf As Single, _
    zf As Single _
)
Visual C++
public:
void Set(
    float xf,
    float yf,
    float zf
)

Parameters

xf
Type: System..::..Single

[Missing <param name="xf"/> documentation for "M:ElRender.Point3d.Set(System.Single,System.Single,System.Single)"]

yf
Type: System..::..Single

[Missing <param name="yf"/> documentation for "M:ElRender.Point3d.Set(System.Single,System.Single,System.Single)"]

zf
Type: System..::..Single

[Missing <param name="zf"/> documentation for "M:ElRender.Point3d.Set(System.Single,System.Single,System.Single)"]

See Also

Point3d Class
Set Overload
ElRender Namespace


Renderable Class

[image]

A Sandcastle Documented Class Library
Renderable Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElRender.Renderable"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Renderable : SimpleRenderable
Visual Basic
Public Class Renderable _
    Inherits SimpleRenderable
Visual C++
public ref class Renderable : public SimpleRenderable

Inheritance Hierarchy

System..::..Object
ShadowCaster
MovableObject
SimpleRenderable
ElRender..::..Renderable

See Also

Renderable Members
ElRender Namespace


Renderable Members

[image] [image]

A Sandcastle Documented Class Library
Renderable Members
Renderable Class Constructors Methods Fields Properties Events See Also Send Feedback

The Renderable type exposes the following members.

Constructors

 | Name | Description
Public method | Renderable | Initializes a new instance of the Renderable class

Methods

 | Name | Description
Public method | AddQueryFlags | (Inherited from MovableObject.)
Public method | AddVisibilityFlags | (Inherited from MovableObject.)
Public method | CreateAnimableValue | (Inherited from MovableObject.)
Public method | DetachFromParent | (Inherited from MovableObject.)
Protected method | dispose | (Inherited from SimpleRenderable.)
Public method | Dispose | (Inherited from SimpleRenderable.)
Protected method | DumpPolygon |
Protected method | DumpPolygonInvertZ |
Protected method | DumpQuads |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtrudeBounds | (Inherited from ShadowCaster.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateShadowVolume | (Inherited from ShadowCaster.)
Public method | GetCustomParameter | (Inherited from SimpleRenderable.)
Public method | GetDarkCapBounds | (Inherited from MovableObject.)
Public method | GetEdgeList()()()() | (Inherited from ShadowCaster.)
Public method | GetEdgeList(Int32) | (Inherited from MovableObject.)
Protected method | GetExtrusionDistance | (Inherited from ShadowCaster.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastShadowVolumeRenderableEnumerator | (Inherited from MovableObject.)
Public method | GetLightCapBounds | (Inherited from MovableObject.)
Public method | GetPointExtrusionDistance | (Inherited from MovableObject.)
Public method | GetShadowVolumeRenderableEnumerator(ShadowTechnique, Light, HardwareIndexBuffer, Single, Boolean) | (Inherited from ShadowCaster.)
Public method | GetShadowVolumeRenderableEnumerator(ShadowTechnique, Light, HardwareIndexBuffer, Boolean, Single, Int32) | (Inherited from MovableObject.)
Public method | GetSquaredViewDepth | (Overrides SimpleRenderableGetSquaredViewDepth(Camera).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorldBoundingBox()()()() | (Inherited from ShadowCaster.)
Public method | GetWorldBoundingBox(Boolean) | (Inherited from MovableObject.)
Public method | GetWorldBoundingSphere()()()() | (Inherited from MovableObject.)
Public method | GetWorldBoundingSphere(Boolean) | (Inherited from MovableObject.)
Public method | GetWorldTransforms | (Inherited from SimpleRenderable.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyCurrentCamera | (Inherited from SimpleRenderable.)
Public method | QueryLights | (Inherited from MovableObject.)
Public method | RemoveQueryFlags | (Inherited from MovableObject.)
Public method | RemoveVisibilityFlags | (Inherited from MovableObject.)
Public method | SetCustomParameter | (Inherited from SimpleRenderable.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateCustomGpuParameter | (Inherited from SimpleRenderable.)
Protected method | UpdateEdgeListLightFacing | (Inherited from ShadowCaster.)
Public method | UpdateRenderQueue | (Inherited from SimpleRenderable.)

Fields

 | Name | Description
Protected field | beyondFarDistance | (Inherited from MovableObject.)
Protected field | box | (Inherited from SimpleRenderable.)
Protected field | camera | (Inherited from SimpleRenderable.)
Protected field | castShadows | (Inherited from MovableObject.)
Protected field | color |
Protected field | customParams | (Inherited from SimpleRenderable.)
Protected field | debugDisplay | (Inherited from MovableObject.)
Protected field | defaultQueryFlags | (Inherited from MovableObject.)
Protected field | dummyLightList | (Inherited from SimpleRenderable.)
Protected field | dummyList | (Inherited from MovableObject.)
Protected field | indexData | (Inherited from SimpleRenderable.)
Protected field | isVisible | (Inherited from MovableObject.)
Protected field | lightList | (Inherited from MovableObject.)
Protected field | lightListUpdated | (Inherited from MovableObject.)
Public field | m_location |
Protected field | material | (Inherited from SimpleRenderable.)
Protected field | materialName | (Inherited from SimpleRenderable.)
Public field | mo |
Protected field | name | (Inherited from MovableObject.)
Protected field | parentIsTagPoint | (Inherited from MovableObject.)
Protected field | parentNode | (Inherited from MovableObject.)
Protected field | queryFlags | (Inherited from MovableObject.)
Protected field | renderingDisabled | (Inherited from MovableObject.)
Protected field | renderOperation | (Inherited from SimpleRenderable.)
Protected field | renderQueueID | (Inherited from MovableObject.)
Protected field | renderQueueIDSet | (Inherited from MovableObject.)
Protected field | sceneMgr | (Inherited from SimpleRenderable.)
Protected field | squaredUpperDistance | (Inherited from MovableObject.)
Protected field | upperDistance | (Inherited from MovableObject.)
Protected field | userData | (Inherited from MovableObject.)
Protected field | vertexData | (Inherited from SimpleRenderable.)
Protected field | visibilityFlags | (Inherited from MovableObject.)
Protected field | worldAABB | (Inherited from MovableObject.)
Protected field | worldBoundingSphere | (Inherited from MovableObject.)
Protected field | worldDarkCapBounds | (Inherited from MovableObject.)
Protected field | worldTransform | (Inherited from SimpleRenderable.)

Properties

 | Name | Description
Public property | AnimableValueNames | (Inherited from MovableObject.)
Public property | BoundingBox | (Inherited from SimpleRenderable.)
Public property | BoundingRadius | (Overrides MovableObjectBoundingRadius()()()().)
Public property | CastShadows | (Inherited from MovableObject.)
Public property | CastsShadows | (Inherited from SimpleRenderable.)
Public property | Creator | (Inherited from MovableObject.)
Public property | DebugDisplayEnabled | (Inherited from MovableObject.)
Public property | DefaultQueryFlags | (Inherited from MovableObject.)
Public property | IsAttached | Obsolete. (Inherited from MovableObject.)
Protected property | isDisposed | (Inherited from SimpleRenderable.)
Public property | IsInScene | (Inherited from MovableObject.)
Public property | IsVisible | (Inherited from MovableObject.)
Public property | Lights | (Inherited from SimpleRenderable.)
Public property | Manager | (Inherited from MovableObject.)
Public property | Material | (Inherited from SimpleRenderable.)
Public property | MovableType | (Inherited from MovableObject.)
Public property | Name | (Inherited from MovableObject.)
Public property | NormalizeNormals | (Inherited from SimpleRenderable.)
Public property | NumWorldTransforms | (Inherited from SimpleRenderable.)
Public property | ParentNode | (Inherited from MovableObject.)
Public property | ParentNodeFullTransform | (Inherited from MovableObject.)
Public property | ParentSceneNode | (Inherited from MovableObject.)
Public property | PolygonModeOverrideable | (Inherited from SimpleRenderable.)
Public property | QueryFlags | (Inherited from MovableObject.)
Public property | RenderingDistance | (Inherited from MovableObject.)
Public property | RenderOperation | (Inherited from SimpleRenderable.)
Public property | RenderQueueGroup | (Inherited from MovableObject.)
Public property | ShowBoundingBox | (Inherited from MovableObject.)
Public property | Technique | (Inherited from SimpleRenderable.)
Public property | TypeFlags | (Inherited from MovableObject.)
Public property | UseIdentityProjection | (Inherited from SimpleRenderable.)
Public property | UseIdentityView | (Inherited from SimpleRenderable.)
Public property | UserData | (Inherited from MovableObject.)
Public property | VisibilityFlags | (Inherited from MovableObject.)
Public property | WorldOrientation | (Inherited from SimpleRenderable.)
Public property | WorldPosition | (Inherited from SimpleRenderable.)

Events

 | Name | Description
Public event | ObjectAttached | (Inherited from MovableObject.)
Public event | ObjectDestroyed | (Inherited from MovableObject.)
Public event | ObjectDetached | (Inherited from MovableObject.)
Public event | ObjectMoved | (Inherited from MovableObject.)
Public event | ObjectQueryLights | (Inherited from MovableObject.)
Public event | ObjectRenamed | (Inherited from MovableObject.)
Public event | ObjectRendering | (Inherited from MovableObject.)

See Also

Renderable Class
ElRender Namespace


Renderable Constructor

[image]

A Sandcastle Documented Class Library
Renderable Constructor
Renderable Class See Also Send Feedback
Initializes a new instance of the Renderable class

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Renderable()
Visual Basic
Public Sub New
Visual C++
public:
Renderable()

See Also

Renderable Class
ElRender Namespace


Renderable Fields

[image] [image]

A Sandcastle Documented Class Library
Renderable Fields
Renderable Class See Also Send Feedback

The Renderable type exposes the following members.

Fields

 | Name | Description
Protected field | beyondFarDistance | (Inherited from MovableObject.)
Protected field | box | (Inherited from SimpleRenderable.)
Protected field | camera | (Inherited from SimpleRenderable.)
Protected field | castShadows | (Inherited from MovableObject.)
Protected field | color |
Protected field | customParams | (Inherited from SimpleRenderable.)
Protected field | debugDisplay | (Inherited from MovableObject.)
Protected field | defaultQueryFlags | (Inherited from MovableObject.)
Protected field | dummyLightList | (Inherited from SimpleRenderable.)
Protected field | dummyList | (Inherited from MovableObject.)
Protected field | indexData | (Inherited from SimpleRenderable.)
Protected field | isVisible | (Inherited from MovableObject.)
Protected field | lightList | (Inherited from MovableObject.)
Protected field | lightListUpdated | (Inherited from MovableObject.)
Public field | m_location |
Protected field | material | (Inherited from SimpleRenderable.)
Protected field | materialName | (Inherited from SimpleRenderable.)
Public field | mo |
Protected field | name | (Inherited from MovableObject.)
Protected field | parentIsTagPoint | (Inherited from MovableObject.)
Protected field | parentNode | (Inherited from MovableObject.)
Protected field | queryFlags | (Inherited from MovableObject.)
Protected field | renderingDisabled | (Inherited from MovableObject.)
Protected field | renderOperation | (Inherited from SimpleRenderable.)
Protected field | renderQueueID | (Inherited from MovableObject.)
Protected field | renderQueueIDSet | (Inherited from MovableObject.)
Protected field | sceneMgr | (Inherited from SimpleRenderable.)
Protected field | squaredUpperDistance | (Inherited from MovableObject.)
Protected field | upperDistance | (Inherited from MovableObject.)
Protected field | userData | (Inherited from MovableObject.)
Protected field | vertexData | (Inherited from SimpleRenderable.)
Protected field | visibilityFlags | (Inherited from MovableObject.)
Protected field | worldAABB | (Inherited from MovableObject.)
Protected field | worldBoundingSphere | (Inherited from MovableObject.)
Protected field | worldDarkCapBounds | (Inherited from MovableObject.)
Protected field | worldTransform | (Inherited from SimpleRenderable.)

See Also

Renderable Class
ElRender Namespace


color Field

[image]

A Sandcastle Documented Class Library
Renderable..::..color Field
Renderable Class See Also Send Feedback

[Missing <summary> documentation for "F:ElRender.Renderable.color"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ColorEx color
Visual Basic
Protected color As ColorEx
Visual C++
protected:
ColorEx color

See Also

Renderable Class
ElRender Namespace


m_location Field

[image]

A Sandcastle Documented Class Library
Renderable..::..m_location Field
Renderable Class See Also Send Feedback

[Missing <summary> documentation for "F:ElRender.Renderable.m_location"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point3d m_location
Visual Basic
Public m_location As Point3d
Visual C++
public:
Point3d^ m_location

See Also

Renderable Class
ElRender Namespace


mo Field

[image]

A Sandcastle Documented Class Library
Renderable..::..mo Field
Renderable Class See Also Send Feedback

[Missing <summary> documentation for "F:ElRender.Renderable.mo"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ManualObject mo
Visual Basic
Public mo As ManualObject
Visual C++
public:
ManualObject^ mo

See Also

Renderable Class
ElRender Namespace


Renderable Methods

[image] [image]

A Sandcastle Documented Class Library
Renderable Methods
Renderable Class See Also Send Feedback

The Renderable type exposes the following members.

Methods

 | Name | Description
Public method | AddQueryFlags | (Inherited from MovableObject.)
Public method | AddVisibilityFlags | (Inherited from MovableObject.)
Public method | CreateAnimableValue | (Inherited from MovableObject.)
Public method | DetachFromParent | (Inherited from MovableObject.)
Protected method | dispose | (Inherited from SimpleRenderable.)
Public method | Dispose | (Inherited from SimpleRenderable.)
Protected method | DumpPolygon |
Protected method | DumpPolygonInvertZ |
Protected method | DumpQuads |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExtrudeBounds | (Inherited from ShadowCaster.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateShadowVolume | (Inherited from ShadowCaster.)
Public method | GetCustomParameter | (Inherited from SimpleRenderable.)
Public method | GetDarkCapBounds | (Inherited from MovableObject.)
Public method | GetEdgeList()()()() | (Inherited from ShadowCaster.)
Public method | GetEdgeList(Int32) | (Inherited from MovableObject.)
Protected method | GetExtrusionDistance | (Inherited from ShadowCaster.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastShadowVolumeRenderableEnumerator | (Inherited from MovableObject.)
Public method | GetLightCapBounds | (Inherited from MovableObject.)
Public method | GetPointExtrusionDistance | (Inherited from MovableObject.)
Public method | GetShadowVolumeRenderableEnumerator(ShadowTechnique, Light, HardwareIndexBuffer, Single, Boolean) | (Inherited from ShadowCaster.)
Public method | GetShadowVolumeRenderableEnumerator(ShadowTechnique, Light, HardwareIndexBuffer, Boolean, Single, Int32) | (Inherited from MovableObject.)
Public method | GetSquaredViewDepth | (Overrides SimpleRenderableGetSquaredViewDepth(Camera).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorldBoundingBox()()()() | (Inherited from ShadowCaster.)
Public method | GetWorldBoundingBox(Boolean) | (Inherited from MovableObject.)
Public method | GetWorldBoundingSphere()()()() | (Inherited from MovableObject.)
Public method | GetWorldBoundingSphere(Boolean) | (Inherited from MovableObject.)
Public method | GetWorldTransforms | (Inherited from SimpleRenderable.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyCurrentCamera | (Inherited from SimpleRenderable.)
Public method | QueryLights | (Inherited from MovableObject.)
Public method | RemoveQueryFlags | (Inherited from MovableObject.)
Public method | RemoveVisibilityFlags | (Inherited from MovableObject.)
Public method | SetCustomParameter | (Inherited from SimpleRenderable.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateCustomGpuParameter | (Inherited from SimpleRenderable.)
Protected method | UpdateEdgeListLightFacing | (Inherited from ShadowCaster.)
Public method | UpdateRenderQueue | (Inherited from SimpleRenderable.)

See Also

Renderable Class
ElRender Namespace


DumpPolygon Method

[image]

A Sandcastle Documented Class Library
Renderable..::..DumpPolygon Method
Renderable Class See Also Send Feedback

[Missing <summary> documentation for "M:ElRender.Renderable.DumpPolygon(ElRender.Point3d[])"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void DumpPolygon(
    Point3d[] points
)
Visual Basic
Protected Sub DumpPolygon ( _
    points As Point3d() _
)
Visual C++
protected:
void DumpPolygon(
    array<Point3d^>^ points
)

Parameters

points
Type: array< ElRender..::..Point3d >[]()[][]

[Missing <param name="points"/> documentation for "M:ElRender.Renderable.DumpPolygon(ElRender.Point3d[])"]

See Also

Renderable Class
ElRender Namespace


DumpPolygonInvertZ Method

[image]

A Sandcastle Documented Class Library
Renderable..::..DumpPolygonInvertZ Method
Renderable Class See Also Send Feedback

[Missing <summary> documentation for "M:ElRender.Renderable.DumpPolygonInvertZ(ElRender.Point3d[])"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void DumpPolygonInvertZ(
    Point3d[] points
)
Visual Basic
Protected Sub DumpPolygonInvertZ ( _
    points As Point3d() _
)
Visual C++
protected:
void DumpPolygonInvertZ(
    array<Point3d^>^ points
)

Parameters

points
Type: array< ElRender..::..Point3d >[]()[][]

[Missing <param name="points"/> documentation for "M:ElRender.Renderable.DumpPolygonInvertZ(ElRender.Point3d[])"]

See Also

Renderable Class
ElRender Namespace


DumpQuads Method

[image]

A Sandcastle Documented Class Library
Renderable..::..DumpQuads Method
Renderable Class See Also Send Feedback

[Missing <summary> documentation for "M:ElRender.Renderable.DumpQuads"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void DumpQuads()
Visual Basic
Protected Sub DumpQuads
Visual C++
protected:
void DumpQuads()

See Also

Renderable Class
ElRender Namespace


GetEdgeList Method

[image] [image]

A Sandcastle Documented Class Library
Renderable..::..GetEdgeList Method
Renderable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEdgeList()()()() | (Inherited from ShadowCaster.)
Public method | GetEdgeList(Int32) | (Inherited from MovableObject.)

See Also

Renderable Class
Renderable Members
ElRender Namespace


GetShadowVolumeRenderableEnumerator Method

[image] [image]

A Sandcastle Documented Class Library
Renderable..::..GetShadowVolumeRenderableEnumerator Method
Renderable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetShadowVolumeRenderableEnumerator(ShadowTechnique, Light, HardwareIndexBuffer, Single, Boolean) | (Inherited from ShadowCaster.)
Public method | GetShadowVolumeRenderableEnumerator(ShadowTechnique, Light, HardwareIndexBuffer, Boolean, Single, Int32) | (Inherited from MovableObject.)

See Also

Renderable Class
Renderable Members
ElRender Namespace


GetSquaredViewDepth Method

[image]

A Sandcastle Documented Class Library
Renderable..::..GetSquaredViewDepth Method
Renderable Class See Also Send Feedback

[Missing <summary> documentation for "M:ElRender.Renderable.GetSquaredViewDepth(Axiom.Core.Camera)"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override float GetSquaredViewDepth(
    Camera camera
)
Visual Basic
Public Overrides Function GetSquaredViewDepth ( _
    camera As Camera _
) As Single
Visual C++
public:
virtual float GetSquaredViewDepth(
    Camera^ camera
) override

Parameters

camera
Type: Camera

[Missing <param name="camera"/> documentation for "M:ElRender.Renderable.GetSquaredViewDepth(Axiom.Core.Camera)"]

Return Value

[Missing <returns> documentation for "M:ElRender.Renderable.GetSquaredViewDepth(Axiom.Core.Camera)"]

Implements

IRenderableGetSquaredViewDepth(Camera)

See Also

Renderable Class
ElRender Namespace


GetWorldBoundingBox Method

[image] [image]

A Sandcastle Documented Class Library
Renderable..::..GetWorldBoundingBox Method
Renderable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWorldBoundingBox()()()() | (Inherited from ShadowCaster.)
Public method | GetWorldBoundingBox(Boolean) | (Inherited from MovableObject.)

See Also

Renderable Class
Renderable Members
ElRender Namespace


GetWorldBoundingSphere Method

[image] [image]

A Sandcastle Documented Class Library
Renderable..::..GetWorldBoundingSphere Method
Renderable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWorldBoundingSphere()()()() | (Inherited from MovableObject.)
Public method | GetWorldBoundingSphere(Boolean) | (Inherited from MovableObject.)

See Also

Renderable Class
Renderable Members
ElRender Namespace


Renderable Properties

[image] [image]

A Sandcastle Documented Class Library
Renderable Properties
Renderable Class See Also Send Feedback

The Renderable type exposes the following members.

Properties

 | Name | Description
Public property | AnimableValueNames | (Inherited from MovableObject.)
Public property | BoundingBox | (Inherited from SimpleRenderable.)
Public property | BoundingRadius | (Overrides MovableObjectBoundingRadius()()()().)
Public property | CastShadows | (Inherited from MovableObject.)
Public property | CastsShadows | (Inherited from SimpleRenderable.)
Public property | Creator | (Inherited from MovableObject.)
Public property | DebugDisplayEnabled | (Inherited from MovableObject.)
Public property | DefaultQueryFlags | (Inherited from MovableObject.)
Public property | IsAttached | Obsolete. (Inherited from MovableObject.)
Protected property | isDisposed | (Inherited from SimpleRenderable.)
Public property | IsInScene | (Inherited from MovableObject.)
Public property | IsVisible | (Inherited from MovableObject.)
Public property | Lights | (Inherited from SimpleRenderable.)
Public property | Manager | (Inherited from MovableObject.)
Public property | Material | (Inherited from SimpleRenderable.)
Public property | MovableType | (Inherited from MovableObject.)
Public property | Name | (Inherited from MovableObject.)
Public property | NormalizeNormals | (Inherited from SimpleRenderable.)
Public property | NumWorldTransforms | (Inherited from SimpleRenderable.)
Public property | ParentNode | (Inherited from MovableObject.)
Public property | ParentNodeFullTransform | (Inherited from MovableObject.)
Public property | ParentSceneNode | (Inherited from MovableObject.)
Public property | PolygonModeOverrideable | (Inherited from SimpleRenderable.)
Public property | QueryFlags | (Inherited from MovableObject.)
Public property | RenderingDistance | (Inherited from MovableObject.)
Public property | RenderOperation | (Inherited from SimpleRenderable.)
Public property | RenderQueueGroup | (Inherited from MovableObject.)
Public property | ShowBoundingBox | (Inherited from MovableObject.)
Public property | Technique | (Inherited from SimpleRenderable.)
Public property | TypeFlags | (Inherited from MovableObject.)
Public property | UseIdentityProjection | (Inherited from SimpleRenderable.)
Public property | UseIdentityView | (Inherited from SimpleRenderable.)
Public property | UserData | (Inherited from MovableObject.)
Public property | VisibilityFlags | (Inherited from MovableObject.)
Public property | WorldOrientation | (Inherited from SimpleRenderable.)
Public property | WorldPosition | (Inherited from SimpleRenderable.)

See Also

Renderable Class
ElRender Namespace


BoundingRadius Property

[image]

A Sandcastle Documented Class Library
Renderable..::..BoundingRadius Property
Renderable Class See Also Send Feedback

[Missing <summary> documentation for "P:ElRender.Renderable.BoundingRadius"]

Namespace: ElRender
Assembly: ElRender (in ElRender.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override float BoundingRadius { get; }
Visual Basic
Public Overrides ReadOnly Property BoundingRadius As Single
    Get
Visual C++
public:
virtual property float BoundingRadius {
    float get () override;
}

See Also

Renderable Class
ElRender Namespace


Renderable Events

[image] [image]

A Sandcastle Documented Class Library
Renderable Events
Renderable Class See Also Send Feedback

The Renderable type exposes the following members.

Events

 | Name | Description
Public event | ObjectAttached | (Inherited from MovableObject.)
Public event | ObjectDestroyed | (Inherited from MovableObject.)
Public event | ObjectDetached | (Inherited from MovableObject.)
Public event | ObjectMoved | (Inherited from MovableObject.)
Public event | ObjectQueryLights | (Inherited from MovableObject.)
Public event | ObjectRenamed | (Inherited from MovableObject.)
Public event | ObjectRendering | (Inherited from MovableObject.)

See Also

Renderable Class
ElRender Namespace


ElVector Namespace

[image]

A Sandcastle Documented Class Library
ElVector Namespace
Send Feedback

[Missing <summary> documentation for "N:ElVector"]

Classes

 | Class | Description
Public class | Shape2d |
Public class | Shape2d_Bezier |
Public class | Shape2d_BezierSegment |
Public class | Shape2d_Rect |
Public class | Shape3d |
Public class | Shape3d_Box |
Public class | SpaceVector |

Enumerations

 | Enumeration | Description
Public enumeration | E3dShapeType |
Public enumeration | EShapeType2d |


E3dShapeType Enumeration

[image]

A Sandcastle Documented Class Library
E3dShapeType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElVector.E3dShapeType"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public enum E3dShapeType
Visual Basic
Public Enumeration E3dShapeType
Visual C++
public enum class E3dShapeType

Members

Member name | Value | Description
SHAPE3D_UNINITIALIZED | 0 |
SHAPE3D_3D_CUBE | 1 |
SHAPE3D_3D_SPHERE | 2 |
SHAPE3D_3D_VERTICES | 3 |
SHAPE3D_3D_SHAPED_EDGES | 4 |
SHAPE3D_3D_ALPHA_FUNCTION | 5 |

See Also

ElVector Namespace


EShapeType2d Enumeration

[image]

A Sandcastle Documented Class Library
EShapeType2d Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:ElVector.EShapeType2d"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public enum EShapeType2d
Visual Basic
Public Enumeration EShapeType2d
Visual C++
public enum class EShapeType2d

Members

Member name | Value | Description
SHAPE_UNINITIALIZED | 0 |
SHAPE_2D_LINE | 1 |
SHAPE_2D_POLYGON | 2 |
SHAPE_2D_BEZIER | 3 |
SHAPE_2D_TEXT | 4 |
SHAPE_2D_OVAL | 5 |
SHAPE_2D_CURVE | 6 |

See Also


Shape2d Class

[image]

A Sandcastle Documented Class Library
Shape2d Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElVector.Shape2d"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public abstract class Shape2d
Visual Basic
Public MustInherit Class Shape2d
Visual C++
public ref class Shape2d abstract

Inheritance Hierarchy

System..::..Object
ElVector..::..Shape2d
ElVector..::..Shape2d_Bezier
ElVector..::..Shape2d_Rect

See Also

Shape2d Members


Shape2d Members

[image] [image]

A Sandcastle Documented Class Library
Shape2d Members
Shape2d Class Constructors Methods Fields See Also Send Feedback

The Shape2d type exposes the following members.

Constructors

 | Name | Description
Public method | Shape2d | Initializes a new instance of the Shape2d class

Methods

 | Name | Description
Public method | Calculate_EncompassingRetangle |
Public method | Dup |
Public method | EncompassingRectanglesIntersect |
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Shape2d) |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEncompassingRetangle |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShapeType |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectsRectangle |
Public method | LimitTo |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToAlphaBitmap |
Public method | SetDirty |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_2dPosition |
Protected field | m_AlphaBitmap |
Protected field | m_EncompassingRetangle |
Protected field | m_Limiting2dShape |
Protected field | m_shapeType |

See Also

Shape2d Class


Shape2d Constructor

[image]

A Sandcastle Documented Class Library
Shape2d Constructor
Shape2d Class See Also Send Feedback
Initializes a new instance of the Shape2d class

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public Shape2d()
Visual Basic
Public Sub New
Visual C++
public:
Shape2d()

See Also

Shape2d Class


Shape2d Fields

[image] [image]

A Sandcastle Documented Class Library
Shape2d Fields
Shape2d Class See Also Send Feedback

The Shape2d type exposes the following members.

Fields

 | Name | Description
Protected field | m_2dPosition |
Protected field | m_AlphaBitmap |
Protected field | m_EncompassingRetangle |
Protected field | m_Limiting2dShape |
Protected field | m_shapeType |

See Also

Shape2d Class


m_2dPosition Field

[image]

A Sandcastle Documented Class Library
Shape2d..::..m_2dPosition Field
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "F:ElVector.Shape2d.m_2dPosition"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
protected Size2d m_2dPosition
Visual Basic
Protected m_2dPosition As Size2d
Visual C++
protected:
Size2d^ m_2dPosition

See Also

Shape2d Class


m_AlphaBitmap Field

[image]

A Sandcastle Documented Class Library
Shape2d..::..m_AlphaBitmap Field
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "F:ElVector.Shape2d.m_AlphaBitmap"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
protected Bitmap_Alpha m_AlphaBitmap
Visual Basic
Protected m_AlphaBitmap As Bitmap_Alpha
Visual C++
protected:
Bitmap_Alpha^ m_AlphaBitmap

See Also

Shape2d Class


m_EncompassingRetangle Field

[image]

A Sandcastle Documented Class Library
Shape2d..::..m_EncompassingRetangle Field
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "F:ElVector.Shape2d.m_EncompassingRetangle"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
protected Shape2d_Rect m_EncompassingRetangle
Visual Basic
Protected m_EncompassingRetangle As Shape2d_Rect
Visual C++
protected:
Shape2d_Rect^ m_EncompassingRetangle

See Also

Shape2d Class


m_Limiting2dShape Field

[image]

A Sandcastle Documented Class Library
Shape2d..::..m_Limiting2dShape Field
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "F:ElVector.Shape2d.m_Limiting2dShape"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
protected Shape2d m_Limiting2dShape
Visual Basic
Protected m_Limiting2dShape As Shape2d
Visual C++
protected:
Shape2d^ m_Limiting2dShape

See Also

Shape2d Class


m_shapeType Field

[image]

A Sandcastle Documented Class Library
Shape2d..::..m_shapeType Field
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "F:ElVector.Shape2d.m_shapeType"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
protected EShapeType2d m_shapeType
Visual Basic
Protected m_shapeType As EShapeType2d
Visual C++
protected:
EShapeType2d m_shapeType

See Also

Shape2d Class


Shape2d Methods

[image] [image]

A Sandcastle Documented Class Library
Shape2d Methods
Shape2d Class See Also Send Feedback

The Shape2d type exposes the following members.

Methods

 | Name | Description
Public method | Calculate_EncompassingRetangle |
Public method | Dup |
Public method | EncompassingRectanglesIntersect |
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Shape2d) |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEncompassingRetangle |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShapeType |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectsRectangle |
Public method | LimitTo |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToAlphaBitmap |
Public method | SetDirty |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Shape2d Class


Calculate_EncompassingRetangle Method

[image]

A Sandcastle Documented Class Library
Shape2d..::..Calculate_EncompassingRetangle Method
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d.Calculate_EncompassingRetangle"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public abstract Shape2d_Rect Calculate_EncompassingRetangle()
Visual Basic
Public MustOverride Function Calculate_EncompassingRetangle As Shape2d_Rect
Visual C++
public:
virtual Shape2d_Rect^ Calculate_EncompassingRetangle() abstract

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d.Calculate_EncompassingRetangle"]

See Also

Shape2d Class


Dup Method

[image]

A Sandcastle Documented Class Library
Shape2d..::..Dup Method
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d.Dup"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public abstract Shape2d Dup()
Visual Basic
Public MustOverride Function Dup As Shape2d
Visual C++
public:
virtual Shape2d^ Dup() abstract

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d.Dup"]

See Also

Shape2d Class


EncompassingRectanglesIntersect Method

[image]

A Sandcastle Documented Class Library
Shape2d..::..EncompassingRectanglesIntersect Method
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d.EncompassingRectanglesIntersect(ElVector.Shape2d)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public bool EncompassingRectanglesIntersect(
    Shape2d Shape2d
)
Visual Basic
Public Function EncompassingRectanglesIntersect ( _
    Shape2d As Shape2d _
) As Boolean
Visual C++
public:
bool EncompassingRectanglesIntersect(
    Shape2d^ Shape2d
)

Parameters

Shape2d
Type: ElVector..::..Shape2d

[Missing <param name="Shape2d"/> documentation for "M:ElVector.Shape2d.EncompassingRectanglesIntersect(ElVector.Shape2d)"]

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d.EncompassingRectanglesIntersect(ElVector.Shape2d)"]

See Also

Shape2d Class


Equals Method

[image] [image]

A Sandcastle Documented Class Library
Shape2d..::..Equals Method
Shape2d Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Shape2d) |

See Also

Shape2d Class
Shape2d Members


Equals Method (Shape2d)

[image]

A Sandcastle Documented Class Library
Shape2d..::..Equals Method (Shape2d)
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d.Equals(ElVector.Shape2d)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public void Equals(
    Shape2d other_2dShape
)
Visual Basic
Public Sub Equals ( _
    other_2dShape As Shape2d _
)
Visual C++
public:
void Equals(
    Shape2d^ other_2dShape
)

Parameters

other_2dShape
Type: ElVector..::..Shape2d

[Missing <param name="other_2dShape"/> documentation for "M:ElVector.Shape2d.Equals(ElVector.Shape2d)"]

See Also

Shape2d Class
Equals Overload


GetEncompassingRetangle Method

[image]

A Sandcastle Documented Class Library
Shape2d..::..GetEncompassingRetangle Method
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d.GetEncompassingRetangle(ElVector.Shape2d_Rect@)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public bool GetEncompassingRetangle(
    out Shape2d_Rect rectangle
)
Visual Basic
Public Function GetEncompassingRetangle ( _
    <OutAttribute> ByRef rectangle As Shape2d_Rect _
) As Boolean
Visual C++
public:
bool GetEncompassingRetangle(
    [OutAttribute] Shape2d_Rect^% rectangle
)

Parameters

rectangle
Type: ElVector..::..Shape2d_Rect %

[Missing <param name="rectangle"/> documentation for "M:ElVector.Shape2d.GetEncompassingRetangle(ElVector.Shape2d_Rect@)"]

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d.GetEncompassingRetangle(ElVector.Shape2d_Rect@)"]

See Also

Shape2d Class


GetShapeType Method

[image]

A Sandcastle Documented Class Library
Shape2d..::..GetShapeType Method
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d.GetShapeType"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public EShapeType2d GetShapeType()
Visual Basic
Public Function GetShapeType As EShapeType2d
Visual C++
public:
EShapeType2d GetShapeType()

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d.GetShapeType"]

See Also

Shape2d Class


IntersectsRectangle Method

[image]

A Sandcastle Documented Class Library
Shape2d..::..IntersectsRectangle Method
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d.IntersectsRectangle(ElVector.Shape2d_Rect)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public abstract bool IntersectsRectangle(
    Shape2d_Rect Rect2d
)
Visual Basic
Public MustOverride Function IntersectsRectangle ( _
    Rect2d As Shape2d_Rect _
) As Boolean
Visual C++
public:
virtual bool IntersectsRectangle(
    Shape2d_Rect^ Rect2d
) abstract

Parameters

Rect2d
Type: ElVector..::..Shape2d_Rect

[Missing <param name="Rect2d"/> documentation for "M:ElVector.Shape2d.IntersectsRectangle(ElVector.Shape2d_Rect)"]

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d.IntersectsRectangle(ElVector.Shape2d_Rect)"]

See Also

Shape2d Class


LimitTo Method

[image]

A Sandcastle Documented Class Library
Shape2d..::..LimitTo Method
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d.LimitTo(ElVector.Shape2d)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public bool LimitTo(
    Shape2d shapeLimit
)
Visual Basic
Public Function LimitTo ( _
    shapeLimit As Shape2d _
) As Boolean
Visual C++
public:
bool LimitTo(
    Shape2d^ shapeLimit
)

Parameters

shapeLimit
Type: ElVector..::..Shape2d

[Missing <param name="shapeLimit"/> documentation for "M:ElVector.Shape2d.LimitTo(ElVector.Shape2d)"]

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d.LimitTo(ElVector.Shape2d)"]

See Also

Shape2d Class


RenderToAlphaBitmap Method

[image]

A Sandcastle Documented Class Library
Shape2d..::..RenderToAlphaBitmap Method
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d.RenderToAlphaBitmap(El.Rect2d,ElImage.Bitmap_Alpha)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public abstract bool RenderToAlphaBitmap(
    Rect2d sourceRect,
    Bitmap_Alpha destAlphaBitmap
)
Visual Basic
Public MustOverride Function RenderToAlphaBitmap ( _
    sourceRect As Rect2d, _
    destAlphaBitmap As Bitmap_Alpha _
) As Boolean
Visual C++
public:
virtual bool RenderToAlphaBitmap(
    Rect2d^ sourceRect,
    Bitmap_Alpha^ destAlphaBitmap
) abstract

Parameters

sourceRect
Type: Rect2d

[Missing <param name="sourceRect"/> documentation for "M:ElVector.Shape2d.RenderToAlphaBitmap(El.Rect2d,ElImage.Bitmap_Alpha)"]

destAlphaBitmap
Type: Bitmap_Alpha

[Missing <param name="destAlphaBitmap"/> documentation for "M:ElVector.Shape2d.RenderToAlphaBitmap(El.Rect2d,ElImage.Bitmap_Alpha)"]

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d.RenderToAlphaBitmap(El.Rect2d,ElImage.Bitmap_Alpha)"]

See Also

Shape2d Class


SetDirty Method

[image]

A Sandcastle Documented Class Library
Shape2d..::..SetDirty Method
Shape2d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d.SetDirty"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public void SetDirty()
Visual Basic
Public Sub SetDirty
Visual C++
public:
void SetDirty()

See Also

Shape2d Class


Shape2d_Bezier Class

[image]

A Sandcastle Documented Class Library
Shape2d_Bezier Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElVector.Shape2d_Bezier"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public class Shape2d_Bezier : Shape2d
Visual Basic
Public Class Shape2d_Bezier _
    Inherits Shape2d
Visual C++
public ref class Shape2d_Bezier : public Shape2d

Inheritance Hierarchy

System..::..Object
ElVector..::..Shape2d
ElVector..::..Shape2d_Bezier

See Also

Shape2d_Bezier Members


Shape2d_Bezier Members

[image] [image]

A Sandcastle Documented Class Library
Shape2d_Bezier Members
Shape2d_Bezier Class Constructors Methods Fields See Also Send Feedback

The Shape2d_Bezier type exposes the following members.

Constructors

 | Name | Description
Public method | Shape2d_Bezier()()()() | Initializes a new instance of the Shape2d_Bezier class
Public method | Shape2d_Bezier(Shape2d_Bezier) | Initializes a new instance of the Shape2d_Bezier class

Methods

 | Name | Description
Public method | Calculate_EncompassingRetangle | (Overrides Shape2d..::..Calculate_EncompassingRetangle()()()().)
Public method | Dup | (Overrides Shape2d..::..Dup()()()().)
Public method | EncompassingRectanglesIntersect | (Inherited from Shape2d.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Shape2d) | (Inherited from Shape2d.)
Public method | Equals(Shape2d_Bezier) |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEncompassingRetangle | (Inherited from Shape2d.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShapeType | (Inherited from Shape2d.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects |
Public method | IntersectsRectangle | (Overrides Shape2d..::..IntersectsRectangle(Shape2d_Rect).)
Public method | LimitTo | (Inherited from Shape2d.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToAlphaBitmap | (Overrides Shape2d..::..RenderToAlphaBitmap(Rect2d, Bitmap_Alpha).)
Public method | SetDirty | (Inherited from Shape2d.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_2dPosition | (Inherited from Shape2d.)
Protected field | m_AlphaBitmap | (Inherited from Shape2d.)
Protected field | m_EncompassingRetangle | (Inherited from Shape2d.)
Protected field | m_Limiting2dShape | (Inherited from Shape2d.)
Protected field | m_shapeType | (Inherited from Shape2d.)

See Also

Shape2d_Bezier Class


Shape2d_Bezier Constructor

[image] [image]

A Sandcastle Documented Class Library
Shape2d_Bezier Constructor
Shape2d_Bezier Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Shape2d_Bezier()()()() | Initializes a new instance of the Shape2d_Bezier class
Public method | Shape2d_Bezier(Shape2d_Bezier) | Initializes a new instance of the Shape2d_Bezier class

See Also

Shape2d_Bezier Class
Shape2d_Bezier Members


Shape2d_Bezier Constructor

[image]

A Sandcastle Documented Class Library
Shape2d_Bezier Constructor
Shape2d_Bezier Class See Also Send Feedback
Initializes a new instance of the Shape2d_Bezier class

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public Shape2d_Bezier()
Visual Basic
Public Sub New
Visual C++
public:
Shape2d_Bezier()

See Also

Shape2d_Bezier Class
Shape2d_Bezier Overload


Shape2d_Bezier Constructor (Shape2d_Bezier)

[image]

A Sandcastle Documented Class Library
Shape2d_Bezier Constructor (Shape2d_Bezier)
Shape2d_Bezier Class See Also Send Feedback
Initializes a new instance of the Shape2d_Bezier class

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public Shape2d_Bezier(
    Shape2d_Bezier bezier
)
Visual Basic
Public Sub New ( _
    bezier As Shape2d_Bezier _
)
Visual C++
public:
Shape2d_Bezier(
    Shape2d_Bezier^ bezier
)

Parameters

bezier
Type: ElVector..::..Shape2d_Bezier

[Missing <param name="bezier"/> documentation for "M:ElVector.Shape2d_Bezier.#ctor(ElVector.Shape2d_Bezier)"]

See Also

Shape2d_Bezier Class
Shape2d_Bezier Overload


Shape2d_Bezier Fields

[image] [image]

A Sandcastle Documented Class Library
Shape2d_Bezier Fields
Shape2d_Bezier Class See Also Send Feedback

The Shape2d_Bezier type exposes the following members.

Fields

 | Name | Description
Protected field | m_2dPosition | (Inherited from Shape2d.)
Protected field | m_AlphaBitmap | (Inherited from Shape2d.)
Protected field | m_EncompassingRetangle | (Inherited from Shape2d.)
Protected field | m_Limiting2dShape | (Inherited from Shape2d.)
Protected field | m_shapeType | (Inherited from Shape2d.)

See Also

Shape2d_Bezier Class


Shape2d_Bezier Methods

[image] [image]

A Sandcastle Documented Class Library
Shape2d_Bezier Methods
Shape2d_Bezier Class See Also Send Feedback

The Shape2d_Bezier type exposes the following members.

Methods

 | Name | Description
Public method | Calculate_EncompassingRetangle | (Overrides Shape2d..::..Calculate_EncompassingRetangle()()()().)
Public method | Dup | (Overrides Shape2d..::..Dup()()()().)
Public method | EncompassingRectanglesIntersect | (Inherited from Shape2d.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Shape2d) | (Inherited from Shape2d.)
Public method | Equals(Shape2d_Bezier) |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEncompassingRetangle | (Inherited from Shape2d.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShapeType | (Inherited from Shape2d.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects |
Public method | IntersectsRectangle | (Overrides Shape2d..::..IntersectsRectangle(Shape2d_Rect).)
Public method | LimitTo | (Inherited from Shape2d.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToAlphaBitmap | (Overrides Shape2d..::..RenderToAlphaBitmap(Rect2d, Bitmap_Alpha).)
Public method | SetDirty | (Inherited from Shape2d.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Shape2d_Bezier Class


Calculate_EncompassingRetangle Method

[image]

A Sandcastle Documented Class Library
Shape2d_Bezier..::..Calculate_EncompassingRetangle Method
Shape2d_Bezier Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d_Bezier.Calculate_EncompassingRetangle"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public override Shape2d_Rect Calculate_EncompassingRetangle()
Visual Basic
Public Overrides Function Calculate_EncompassingRetangle As Shape2d_Rect
Visual C++
public:
virtual Shape2d_Rect^ Calculate_EncompassingRetangle() override

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d_Bezier.Calculate_EncompassingRetangle"]

See Also

Shape2d_Bezier Class


Dup Method

[image]

A Sandcastle Documented Class Library
Shape2d_Bezier..::..Dup Method
Shape2d_Bezier Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d_Bezier.Dup"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public override Shape2d Dup()
Visual Basic
Public Overrides Function Dup As Shape2d
Visual C++
public:
virtual Shape2d^ Dup() override

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d_Bezier.Dup"]

See Also

Shape2d_Bezier Class


Equals Method

[image] [image]

A Sandcastle Documented Class Library
Shape2d_Bezier..::..Equals Method
Shape2d_Bezier Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Shape2d) | (Inherited from Shape2d.)
Public method | Equals(Shape2d_Bezier) |

See Also

Shape2d_Bezier Class
Shape2d_Bezier Members


Equals Method (Shape2d_Bezier)

[image]

A Sandcastle Documented Class Library
Shape2d_Bezier..::..Equals Method (Shape2d_Bezier)
Shape2d_Bezier Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d_Bezier.Equals(ElVector.Shape2d_Bezier)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public void Equals(
    Shape2d_Bezier Other_2dBezier
)
Visual Basic
Public Sub Equals ( _
    Other_2dBezier As Shape2d_Bezier _
)
Visual C++
public:
void Equals(
    Shape2d_Bezier^ Other_2dBezier
)

Parameters

Other_2dBezier
Type: ElVector..::..Shape2d_Bezier

[Missing <param name="Other_2dBezier"/> documentation for "M:ElVector.Shape2d_Bezier.Equals(ElVector.Shape2d_Bezier)"]

See Also

Shape2d_Bezier Class
Equals Overload


Intersects Method

[image]

A Sandcastle Documented Class Library
Shape2d_Bezier..::..Intersects Method
Shape2d_Bezier Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d_Bezier.Intersects(ElVector.Shape2d)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public bool Intersects(
    Shape2d Shape2d
)
Visual Basic
Public Function Intersects ( _
    Shape2d As Shape2d _
) As Boolean
Visual C++
public:
bool Intersects(
    Shape2d^ Shape2d
)

Parameters

Shape2d
Type: ElVector..::..Shape2d

[Missing <param name="Shape2d"/> documentation for "M:ElVector.Shape2d_Bezier.Intersects(ElVector.Shape2d)"]

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d_Bezier.Intersects(ElVector.Shape2d)"]

See Also

Shape2d_Bezier Class


IntersectsRectangle Method

[image]

A Sandcastle Documented Class Library
Shape2d_Bezier..::..IntersectsRectangle Method
Shape2d_Bezier Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d_Bezier.IntersectsRectangle(ElVector.Shape2d_Rect)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public override bool IntersectsRectangle(
    Shape2d_Rect Rect2d
)
Visual Basic
Public Overrides Function IntersectsRectangle ( _
    Rect2d As Shape2d_Rect _
) As Boolean
Visual C++
public:
virtual bool IntersectsRectangle(
    Shape2d_Rect^ Rect2d
) override

Parameters

Rect2d
Type: ElVector..::..Shape2d_Rect

[Missing <param name="Rect2d"/> documentation for "M:ElVector.Shape2d_Bezier.IntersectsRectangle(ElVector.Shape2d_Rect)"]

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d_Bezier.IntersectsRectangle(ElVector.Shape2d_Rect)"]

See Also

Shape2d_Bezier Class


RenderToAlphaBitmap Method

[image]

A Sandcastle Documented Class Library
Shape2d_Bezier..::..RenderToAlphaBitmap Method
Shape2d_Bezier Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d_Bezier.RenderToAlphaBitmap(El.Rect2d,ElImage.Bitmap_Alpha)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public override bool RenderToAlphaBitmap(
    Rect2d sourceRect,
    Bitmap_Alpha destAlphaBitmap
)
Visual Basic
Public Overrides Function RenderToAlphaBitmap ( _
    sourceRect As Rect2d, _
    destAlphaBitmap As Bitmap_Alpha _
) As Boolean
Visual C++
public:
virtual bool RenderToAlphaBitmap(
    Rect2d^ sourceRect,
    Bitmap_Alpha^ destAlphaBitmap
) override

Parameters

sourceRect
Type: Rect2d

[Missing <param name="sourceRect"/> documentation for "M:ElVector.Shape2d_Bezier.RenderToAlphaBitmap(El.Rect2d,ElImage.Bitmap_Alpha)"]

destAlphaBitmap
Type: Bitmap_Alpha

[Missing <param name="destAlphaBitmap"/> documentation for "M:ElVector.Shape2d_Bezier.RenderToAlphaBitmap(El.Rect2d,ElImage.Bitmap_Alpha)"]

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d_Bezier.RenderToAlphaBitmap(El.Rect2d,ElImage.Bitmap_Alpha)"]

See Also

Shape2d_Bezier Class


Shape2d_BezierSegment Class

[image]

A Sandcastle Documented Class Library
Shape2d_BezierSegment Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElVector.Shape2d_BezierSegment"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public class Shape2d_BezierSegment
Visual Basic
Public Class Shape2d_BezierSegment
Visual C++
public ref class Shape2d_BezierSegment

Inheritance Hierarchy

System..::..Object
ElVector..::..Shape2d_BezierSegment

See Also

Shape2d_BezierSegment Members


Shape2d_BezierSegment Members

[image] [image]

A Sandcastle Documented Class Library
Shape2d_BezierSegment Members
Shape2d_BezierSegment Class Constructors Methods See Also Send Feedback

The Shape2d_BezierSegment type exposes the following members.

Constructors

 | Name | Description
Public method | Shape2d_BezierSegment | Initializes a new instance of the Shape2d_BezierSegment class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Shape2d_BezierSegment Class


Shape2d_BezierSegment Constructor

[image]

A Sandcastle Documented Class Library
Shape2d_BezierSegment Constructor
Shape2d_BezierSegment Class See Also Send Feedback
Initializes a new instance of the Shape2d_BezierSegment class

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public Shape2d_BezierSegment()
Visual Basic
Public Sub New
Visual C++
public:
Shape2d_BezierSegment()

See Also

Shape2d_BezierSegment Class


Shape2d_BezierSegment Methods

[image] [image]

A Sandcastle Documented Class Library
Shape2d_BezierSegment Methods
Shape2d_BezierSegment Class See Also Send Feedback

The Shape2d_BezierSegment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Shape2d_BezierSegment Class


Shape2d_Rect Class

[image]

A Sandcastle Documented Class Library
Shape2d_Rect Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElVector.Shape2d_Rect"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public class Shape2d_Rect : Shape2d
Visual Basic
Public Class Shape2d_Rect _
    Inherits Shape2d
Visual C++
public ref class Shape2d_Rect : public Shape2d

Inheritance Hierarchy

System..::..Object
ElVector..::..Shape2d
ElVector..::..Shape2d_Rect

See Also

Shape2d_Rect Members


Shape2d_Rect Members

[image] [image]

A Sandcastle Documented Class Library
Shape2d_Rect Members
Shape2d_Rect Class Constructors Methods Fields See Also Send Feedback

The Shape2d_Rect type exposes the following members.

Constructors

 | Name | Description
Public method | Shape2d_Rect()()()() | Initializes a new instance of the Shape2d_Rect class
Public method | Shape2d_Rect(Rect2d) | Initializes a new instance of the Shape2d_Rect class
Public method | Shape2d_Rect(Shape2d_Rect) | Initializes a new instance of the Shape2d_Rect class

Methods

 | Name | Description
Public method | Calculate_EncompassingRetangle | (Overrides Shape2d..::..Calculate_EncompassingRetangle()()()().)
Public method | Dup | (Overrides Shape2d..::..Dup()()()().)
Public method | EncompassingRectanglesIntersect | (Inherited from Shape2d.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Shape2d) | (Inherited from Shape2d.)
Public method | Equals(Shape2d_Rect) |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEncompassingRetangle | (Inherited from Shape2d.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShapeType | (Inherited from Shape2d.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects |
Public method | IntersectsRectangle | (Overrides Shape2d..::..IntersectsRectangle(Shape2d_Rect).)
Public method | LimitTo | (Inherited from Shape2d.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToAlphaBitmap | (Overrides Shape2d..::..RenderToAlphaBitmap(Rect2d, Bitmap_Alpha).)
Public method | SetDirty | (Inherited from Shape2d.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_2dPosition | (Inherited from Shape2d.)
Protected field | m_AlphaBitmap | (Inherited from Shape2d.)
Protected field | m_EncompassingRetangle | (Inherited from Shape2d.)
Protected field | m_Limiting2dShape | (Inherited from Shape2d.)
Protected field | m_shapeType | (Inherited from Shape2d.)

See Also

Shape2d_Rect Class


Shape2d_Rect Constructor

[image] [image]

A Sandcastle Documented Class Library
Shape2d_Rect Constructor
Shape2d_Rect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Shape2d_Rect()()()() | Initializes a new instance of the Shape2d_Rect class
Public method | Shape2d_Rect(Rect2d) | Initializes a new instance of the Shape2d_Rect class
Public method | Shape2d_Rect(Shape2d_Rect) | Initializes a new instance of the Shape2d_Rect class

See Also

Shape2d_Rect Class
Shape2d_Rect Members


Shape2d_Rect Constructor

[image]

A Sandcastle Documented Class Library
Shape2d_Rect Constructor
Shape2d_Rect Class See Also Send Feedback
Initializes a new instance of the Shape2d_Rect class

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public Shape2d_Rect()
Visual Basic
Public Sub New
Visual C++
public:
Shape2d_Rect()

See Also

Shape2d_Rect Class
Shape2d_Rect Overload


Shape2d_Rect Constructor ()

[image]

A Sandcastle Documented Class Library
Shape2d_Rect Constructor ()
Shape2d_Rect Class See Also Send Feedback
Initializes a new instance of the Shape2d_Rect class

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public Shape2d_Rect(
    Rect2d rectangle
)
Visual Basic
Public Sub New ( _
    rectangle As Rect2d _
)
Visual C++
public:
Shape2d_Rect(
    Rect2d^ rectangle
)

Parameters

rectangle
Type: Rect2d

[Missing <param name="rectangle"/> documentation for "M:ElVector.Shape2d_Rect.#ctor(El.Rect2d)"]

See Also

Shape2d_Rect Class
Shape2d_Rect Overload


Shape2d_Rect Constructor (Shape2d_Rect)

[image]

A Sandcastle Documented Class Library
Shape2d_Rect Constructor (Shape2d_Rect)
Shape2d_Rect Class See Also Send Feedback
Initializes a new instance of the Shape2d_Rect class

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public Shape2d_Rect(
    Shape2d_Rect duper
)
Visual Basic
Public Sub New ( _
    duper As Shape2d_Rect _
)
Visual C++
public:
Shape2d_Rect(
    Shape2d_Rect^ duper
)

Parameters

duper
Type: ElVector..::..Shape2d_Rect

[Missing <param name="duper"/> documentation for "M:ElVector.Shape2d_Rect.#ctor(ElVector.Shape2d_Rect)"]

See Also

Shape2d_Rect Class
Shape2d_Rect Overload


Shape2d_Rect Fields

[image] [image]

A Sandcastle Documented Class Library
Shape2d_Rect Fields
Shape2d_Rect Class See Also Send Feedback

The Shape2d_Rect type exposes the following members.

Fields

 | Name | Description
Protected field | m_2dPosition | (Inherited from Shape2d.)
Protected field | m_AlphaBitmap | (Inherited from Shape2d.)
Protected field | m_EncompassingRetangle | (Inherited from Shape2d.)
Protected field | m_Limiting2dShape | (Inherited from Shape2d.)
Protected field | m_shapeType | (Inherited from Shape2d.)

See Also

Shape2d_Rect Class


Shape2d_Rect Methods

[image] [image]

A Sandcastle Documented Class Library
Shape2d_Rect Methods
Shape2d_Rect Class See Also Send Feedback

The Shape2d_Rect type exposes the following members.

Methods

 | Name | Description
Public method | Calculate_EncompassingRetangle | (Overrides Shape2d..::..Calculate_EncompassingRetangle()()()().)
Public method | Dup | (Overrides Shape2d..::..Dup()()()().)
Public method | EncompassingRectanglesIntersect | (Inherited from Shape2d.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Shape2d) | (Inherited from Shape2d.)
Public method | Equals(Shape2d_Rect) |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEncompassingRetangle | (Inherited from Shape2d.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShapeType | (Inherited from Shape2d.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects |
Public method | IntersectsRectangle | (Overrides Shape2d..::..IntersectsRectangle(Shape2d_Rect).)
Public method | LimitTo | (Inherited from Shape2d.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RenderToAlphaBitmap | (Overrides Shape2d..::..RenderToAlphaBitmap(Rect2d, Bitmap_Alpha).)
Public method | SetDirty | (Inherited from Shape2d.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Shape2d_Rect Class


Calculate_EncompassingRetangle Method

[image]

A Sandcastle Documented Class Library
Shape2d_Rect..::..Calculate_EncompassingRetangle Method
Shape2d_Rect Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d_Rect.Calculate_EncompassingRetangle"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public override Shape2d_Rect Calculate_EncompassingRetangle()
Visual Basic
Public Overrides Function Calculate_EncompassingRetangle As Shape2d_Rect
Visual C++
public:
virtual Shape2d_Rect^ Calculate_EncompassingRetangle() override

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d_Rect.Calculate_EncompassingRetangle"]

See Also

Shape2d_Rect Class


Dup Method

[image]

A Sandcastle Documented Class Library
Shape2d_Rect..::..Dup Method
Shape2d_Rect Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d_Rect.Dup"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public override Shape2d Dup()
Visual Basic
Public Overrides Function Dup As Shape2d
Visual C++
public:
virtual Shape2d^ Dup() override

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d_Rect.Dup"]

See Also

Shape2d_Rect Class


Equals Method

[image] [image]

A Sandcastle Documented Class Library
Shape2d_Rect..::..Equals Method
Shape2d_Rect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(Shape2d) | (Inherited from Shape2d.)
Public method | Equals(Shape2d_Rect) |

See Also

Shape2d_Rect Class
Shape2d_Rect Members


Equals Method (Shape2d_Rect)

[image]

A Sandcastle Documented Class Library
Shape2d_Rect..::..Equals Method (Shape2d_Rect)
Shape2d_Rect Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d_Rect.Equals(ElVector.Shape2d_Rect)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public void Equals(
    Shape2d_Rect Other_2dRect
)
Visual Basic
Public Sub Equals ( _
    Other_2dRect As Shape2d_Rect _
)
Visual C++
public:
void Equals(
    Shape2d_Rect^ Other_2dRect
)

Parameters

Other_2dRect
Type: ElVector..::..Shape2d_Rect

[Missing <param name="Other_2dRect"/> documentation for "M:ElVector.Shape2d_Rect.Equals(ElVector.Shape2d_Rect)"]

See Also

Shape2d_Rect Class
Equals Overload


Intersects Method

[image]

A Sandcastle Documented Class Library
Shape2d_Rect..::..Intersects Method
Shape2d_Rect Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d_Rect.Intersects(ElVector.Shape2d)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public bool Intersects(
    Shape2d Shape2d
)
Visual Basic
Public Function Intersects ( _
    Shape2d As Shape2d _
) As Boolean
Visual C++
public:
bool Intersects(
    Shape2d^ Shape2d
)

Parameters

Shape2d
Type: ElVector..::..Shape2d

[Missing <param name="Shape2d"/> documentation for "M:ElVector.Shape2d_Rect.Intersects(ElVector.Shape2d)"]

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d_Rect.Intersects(ElVector.Shape2d)"]

See Also

Shape2d_Rect Class


IntersectsRectangle Method

[image]

A Sandcastle Documented Class Library
Shape2d_Rect..::..IntersectsRectangle Method
Shape2d_Rect Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d_Rect.IntersectsRectangle(ElVector.Shape2d_Rect)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public override bool IntersectsRectangle(
    Shape2d_Rect Rect2d
)
Visual Basic
Public Overrides Function IntersectsRectangle ( _
    Rect2d As Shape2d_Rect _
) As Boolean
Visual C++
public:
virtual bool IntersectsRectangle(
    Shape2d_Rect^ Rect2d
) override

Parameters

Rect2d
Type: ElVector..::..Shape2d_Rect

[Missing <param name="Rect2d"/> documentation for "M:ElVector.Shape2d_Rect.IntersectsRectangle(ElVector.Shape2d_Rect)"]

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d_Rect.IntersectsRectangle(ElVector.Shape2d_Rect)"]

See Also

Shape2d_Rect Class


RenderToAlphaBitmap Method

[image]

A Sandcastle Documented Class Library
Shape2d_Rect..::..RenderToAlphaBitmap Method
Shape2d_Rect Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape2d_Rect.RenderToAlphaBitmap(El.Rect2d,ElImage.Bitmap_Alpha)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public override bool RenderToAlphaBitmap(
    Rect2d sourceRect,
    Bitmap_Alpha destAlphaBitmap
)
Visual Basic
Public Overrides Function RenderToAlphaBitmap ( _
    sourceRect As Rect2d, _
    destAlphaBitmap As Bitmap_Alpha _
) As Boolean
Visual C++
public:
virtual bool RenderToAlphaBitmap(
    Rect2d^ sourceRect,
    Bitmap_Alpha^ destAlphaBitmap
) override

Parameters

sourceRect
Type: Rect2d

[Missing <param name="sourceRect"/> documentation for "M:ElVector.Shape2d_Rect.RenderToAlphaBitmap(El.Rect2d,ElImage.Bitmap_Alpha)"]

destAlphaBitmap
Type: Bitmap_Alpha

[Missing <param name="destAlphaBitmap"/> documentation for "M:ElVector.Shape2d_Rect.RenderToAlphaBitmap(El.Rect2d,ElImage.Bitmap_Alpha)"]

Return Value

[Missing <returns> documentation for "M:ElVector.Shape2d_Rect.RenderToAlphaBitmap(El.Rect2d,ElImage.Bitmap_Alpha)"]

See Also

Shape2d_Rect Class


Shape3d Class

[image]

A Sandcastle Documented Class Library
Shape3d Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElVector.Shape3d"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public class Shape3d
Visual Basic
Public Class Shape3d
Visual C++
public ref class Shape3d

Inheritance Hierarchy

System..::..Object
ElVector..::..Shape3d
ElVector..::..Shape3d_Box

See Also

Shape3d Members


Shape3d Members

[image] [image]

A Sandcastle Documented Class Library
Shape3d Members
Shape3d Class Constructors Methods Fields See Also Send Feedback

The Shape3d type exposes the following members.

Constructors

 | Name | Description
Public method | Shape3d | Initializes a new instance of the Shape3d class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShapeType |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_shapeType |

See Also

Shape3d Class


Shape3d Constructor

[image]

A Sandcastle Documented Class Library
Shape3d Constructor
Shape3d Class See Also Send Feedback
Initializes a new instance of the Shape3d class

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public Shape3d()
Visual Basic
Public Sub New
Visual C++
public:
Shape3d()

See Also

Shape3d Class


Shape3d Fields

[image] [image]

A Sandcastle Documented Class Library
Shape3d Fields
Shape3d Class See Also Send Feedback

The Shape3d type exposes the following members.

Fields

 | Name | Description
Protected field | m_shapeType |

See Also

Shape3d Class


m_shapeType Field

[image]

A Sandcastle Documented Class Library
Shape3d..::..m_shapeType Field
Shape3d Class See Also Send Feedback

[Missing <summary> documentation for "F:ElVector.Shape3d.m_shapeType"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
protected E3dShapeType m_shapeType
Visual Basic
Protected m_shapeType As E3dShapeType
Visual C++
protected:
E3dShapeType m_shapeType

See Also

Shape3d Class


Shape3d Methods

[image] [image]

A Sandcastle Documented Class Library
Shape3d Methods
Shape3d Class See Also Send Feedback

The Shape3d type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShapeType |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Shape3d Class


GetShapeType Method

[image]

A Sandcastle Documented Class Library
Shape3d..::..GetShapeType Method
Shape3d Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.Shape3d.GetShapeType"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public E3dShapeType GetShapeType()
Visual Basic
Public Function GetShapeType As E3dShapeType
Visual C++
public:
E3dShapeType GetShapeType()

Return Value

[Missing <returns> documentation for "M:ElVector.Shape3d.GetShapeType"]

See Also

Shape3d Class


Shape3d_Box Class

[image]

A Sandcastle Documented Class Library
Shape3d_Box Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElVector.Shape3d_Box"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public class Shape3d_Box : Shape3d
Visual Basic
Public Class Shape3d_Box _
    Inherits Shape3d
Visual C++
public ref class Shape3d_Box : public Shape3d

Inheritance Hierarchy

System..::..Object
ElVector..::..Shape3d
ElVector..::..Shape3d_Box

See Also

Shape3d_Box Members


Shape3d_Box Members

[image] [image]

A Sandcastle Documented Class Library
Shape3d_Box Members
Shape3d_Box Class Constructors Methods Fields See Also Send Feedback

The Shape3d_Box type exposes the following members.

Constructors

 | Name | Description
Public method | Shape3d_Box | Initializes a new instance of the Shape3d_Box class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShapeType | (Inherited from Shape3d.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | m_shapeType | (Inherited from Shape3d.)

See Also

Shape3d_Box Class


Shape3d_Box Constructor

[image]

A Sandcastle Documented Class Library
Shape3d_Box Constructor
Shape3d_Box Class See Also Send Feedback
Initializes a new instance of the Shape3d_Box class

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public Shape3d_Box()
Visual Basic
Public Sub New
Visual C++
public:
Shape3d_Box()

See Also

Shape3d_Box Class


Shape3d_Box Fields

[image] [image]

A Sandcastle Documented Class Library
Shape3d_Box Fields
Shape3d_Box Class See Also Send Feedback

The Shape3d_Box type exposes the following members.

Fields

 | Name | Description
Protected field | m_shapeType | (Inherited from Shape3d.)

See Also

Shape3d_Box Class


Shape3d_Box Methods

[image] [image]

A Sandcastle Documented Class Library
Shape3d_Box Methods
Shape3d_Box Class See Also Send Feedback

The Shape3d_Box type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShapeType | (Inherited from Shape3d.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Shape3d_Box Class


SpaceVector Class

[image]

A Sandcastle Documented Class Library
SpaceVector Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ElVector.SpaceVector"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public class SpaceVector
Visual Basic
Public Class SpaceVector
Visual C++
public ref class SpaceVector

Inheritance Hierarchy

System..::..Object
ElVector..::..SpaceVector

See Also

SpaceVector Members


SpaceVector Members

[image] [image]

A Sandcastle Documented Class Library
SpaceVector Members
SpaceVector Class Constructors Methods See Also Send Feedback

The SpaceVector type exposes the following members.

Constructors

 | Name | Description
Public method | SpaceVector()()()() | Initializes a new instance of the SpaceVector class
Public method | SpaceVector(Value, Value, Value, Value, Value, Value) | Initializes a new instance of the SpaceVector class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set(SpaceVector) |
Public method | Set(Position3d, Position3d) |
Public method | Set(Value, Value, Value, Value, Value, Value) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceVector Class


SpaceVector Constructor

[image] [image]

A Sandcastle Documented Class Library
SpaceVector Constructor
SpaceVector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SpaceVector()()()() | Initializes a new instance of the SpaceVector class
Public method | SpaceVector(Value, Value, Value, Value, Value, Value) | Initializes a new instance of the SpaceVector class

See Also

SpaceVector Class
SpaceVector Members


SpaceVector Constructor

[image]

A Sandcastle Documented Class Library
SpaceVector Constructor
SpaceVector Class See Also Send Feedback
Initializes a new instance of the SpaceVector class

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public SpaceVector()
Visual Basic
Public Sub New
Visual C++
public:
SpaceVector()

See Also

SpaceVector Class
SpaceVector Overload


SpaceVector Constructor (, , , , , )

[image]

A Sandcastle Documented Class Library
SpaceVector Constructor (, , , , , )
SpaceVector Class See Also Send Feedback
Initializes a new instance of the SpaceVector class

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public SpaceVector(
    Value X,
    Value Y,
    Value Z,
    Value dx,
    Value dy,
    Value dz
)
Visual Basic
Public Sub New ( _
    X As Value, _
    Y As Value, _
    Z As Value, _
    dx As Value, _
    dy As Value, _
    dz As Value _
)
Visual C++
public:
SpaceVector(
    Value^ X,
    Value^ Y,
    Value^ Z,
    Value^ dx,
    Value^ dy,
    Value^ dz
)

Parameters

X
Type: Value

[Missing <param name="X"/> documentation for "M:ElVector.SpaceVector.#ctor(El.Value,El.Value,El.Value,El.Value,El.Value,El.Value)"]

Y
Type: Value

[Missing <param name="Y"/> documentation for "M:ElVector.SpaceVector.#ctor(El.Value,El.Value,El.Value,El.Value,El.Value,El.Value)"]

Z
Type: Value

[Missing <param name="Z"/> documentation for "M:ElVector.SpaceVector.#ctor(El.Value,El.Value,El.Value,El.Value,El.Value,El.Value)"]

dx
Type: Value

[Missing <param name="dx"/> documentation for "M:ElVector.SpaceVector.#ctor(El.Value,El.Value,El.Value,El.Value,El.Value,El.Value)"]

dy
Type: Value

[Missing <param name="dy"/> documentation for "M:ElVector.SpaceVector.#ctor(El.Value,El.Value,El.Value,El.Value,El.Value,El.Value)"]

dz
Type: Value

[Missing <param name="dz"/> documentation for "M:ElVector.SpaceVector.#ctor(El.Value,El.Value,El.Value,El.Value,El.Value,El.Value)"]

See Also

SpaceVector Class
SpaceVector Overload


SpaceVector Methods

[image] [image]

A Sandcastle Documented Class Library
SpaceVector Methods
SpaceVector Class See Also Send Feedback

The SpaceVector type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set(SpaceVector) |
Public method | Set(Position3d, Position3d) |
Public method | Set(Value, Value, Value, Value, Value, Value) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceVector Class


Get Method

[image]

A Sandcastle Documented Class Library
SpaceVector..::..Get Method
SpaceVector Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.SpaceVector.Get(El.Position3d@,El.Position3d@)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public void Get(
    out Position3d position,
    out Position3d direction
)
Visual Basic
Public Sub Get ( _
    <OutAttribute> ByRef position As Position3d, _
    <OutAttribute> ByRef direction As Position3d _
)
Visual C++
public:
void Get(
    [OutAttribute] Position3d^% position,
    [OutAttribute] Position3d^% direction
)

Parameters

position
Type: Position3d%

[Missing <param name="position"/> documentation for "M:ElVector.SpaceVector.Get(El.Position3d@,El.Position3d@)"]

direction
Type: Position3d%

[Missing <param name="direction"/> documentation for "M:ElVector.SpaceVector.Get(El.Position3d@,El.Position3d@)"]

See Also

SpaceVector Class


Set Method

[image] [image]

A Sandcastle Documented Class Library
SpaceVector..::..Set Method
SpaceVector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(SpaceVector) |
Public method | Set(Position3d, Position3d) |
Public method | Set(Value, Value, Value, Value, Value, Value) |

See Also

SpaceVector Class
SpaceVector Members


Set Method (SpaceVector)

[image]

A Sandcastle Documented Class Library
SpaceVector..::..Set Method (SpaceVector)
SpaceVector Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.SpaceVector.Set(ElVector.SpaceVector)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public void Set(
    SpaceVector vector
)
Visual Basic
Public Sub Set ( _
    vector As SpaceVector _
)
Visual C++
public:
void Set(
    SpaceVector^ vector
)

Parameters

vector
Type: ElVector..::..SpaceVector

[Missing <param name="vector"/> documentation for "M:ElVector.SpaceVector.Set(ElVector.SpaceVector)"]

See Also

SpaceVector Class
Set Overload


Set Method (, )

[image]

A Sandcastle Documented Class Library
SpaceVector..::..Set Method (, )
SpaceVector Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.SpaceVector.Set(El.Position3d,El.Position3d)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public void Set(
    Position3d position,
    Position3d direction
)
Visual Basic
Public Sub Set ( _
    position As Position3d, _
    direction As Position3d _
)
Visual C++
public:
void Set(
    Position3d^ position,
    Position3d^ direction
)

Parameters

position
Type: Position3d

[Missing <param name="position"/> documentation for "M:ElVector.SpaceVector.Set(El.Position3d,El.Position3d)"]

direction
Type: Position3d

[Missing <param name="direction"/> documentation for "M:ElVector.SpaceVector.Set(El.Position3d,El.Position3d)"]

See Also

SpaceVector Class
Set Overload


Set Method (, , , , , )

[image]

A Sandcastle Documented Class Library
SpaceVector..::..Set Method (, , , , , )
SpaceVector Class See Also Send Feedback

[Missing <summary> documentation for "M:ElVector.SpaceVector.Set(El.Value,El.Value,El.Value,El.Value,El.Value,El.Value)"]

Namespace: ElVector
Assembly: ElVector (in ElVector.dll) Version: 0.0.0.0

Syntax

C#
public void Set(
    Value X,
    Value Y,
    Value Z,
    Value dx,
    Value dy,
    Value dz
)
Visual Basic
Public Sub Set ( _
    X As Value, _
    Y As Value, _
    Z As Value, _
    dx As Value, _
    dy As Value, _
    dz As Value _
)
Visual C++
public:
void Set(
    Value^ X,
    Value^ Y,
    Value^ Z,
    Value^ dx,
    Value^ dy,
    Value^ dz
)

Parameters

X
Type: Value

[Missing <param name="X"/> documentation for "M:ElVector.SpaceVector.Set(El.Value,El.Value,El.Value,El.Value,El.Value,El.Value)"]

Y
Type: Value

[Missing <param name="Y"/> documentation for "M:ElVector.SpaceVector.Set(El.Value,El.Value,El.Value,El.Value,El.Value,El.Value)"]

Z
Type: Value

[Missing <param name="Z"/> documentation for "M:ElVector.SpaceVector.Set(El.Value,El.Value,El.Value,El.Value,El.Value,El.Value)"]

dx
Type: Value

[Missing <param name="dx"/> documentation for "M:ElVector.SpaceVector.Set(El.Value,El.Value,El.Value,El.Value,El.Value,El.Value)"]

dy
Type: Value

[Missing <param name="dy"/> documentation for "M:ElVector.SpaceVector.Set(El.Value,El.Value,El.Value,El.Value,El.Value,El.Value)"]

dz
Type: Value

[Missing <param name="dz"/> documentation for "M:ElVector.SpaceVector.Set(El.Value,El.Value,El.Value,El.Value,El.Value,El.Value)"]

See Also

SpaceVector Class
Set Overload